9fans - fans of the OS Plan 9 from Bell Labs
 help / color / mirror / Atom feed
* [9fans] Raspberry Pi400 Ethernet
       [not found] <601087538.1280146.1622224718850.ref@mail.yahoo.com>
@ 2021-05-28 17:58 ` Brian L. Stuart
  2021-05-28 18:05   ` Skip Tavakkolian
  0 siblings, 1 reply; 11+ messages in thread
From: Brian L. Stuart @ 2021-05-28 17:58 UTC (permalink / raw)
  To: 9fans

So I picked up a pi400 and everything seems happy
except the Ethernet.  I'm using Richard's latest 9pi.img
from 9p.io.  At least, I'm pretty sure it's the latest; it
does include the /dev/serial driver.  The network switch
is showing the hardware to be happy and I'm using a
cable that has been working with a Pi3, but ipconf
times out with a "no success with DHCP" error.  Anyone
have any wisdom that I'm overlooking?

Also, Richard, I'm going to send you a bug fix for devspi
soon.  I discovered that attempting to acces spictl is
broken.

BLS

------------------------------------------
9fans: 9fans
Permalink: https://9fans.topicbox.com/groups/9fans/T8d2c30e280421e20-M1cdfe9038b2b15321b2eff4d
Delivery options: https://9fans.topicbox.com/groups/9fans/subscription

^ permalink raw reply	[flat|nested] 11+ messages in thread

* Re: [9fans] Raspberry Pi400 Ethernet
  2021-05-28 17:58 ` [9fans] Raspberry Pi400 Ethernet Brian L. Stuart
@ 2021-05-28 18:05   ` Skip Tavakkolian
  2021-05-28 18:10     ` Skip Tavakkolian
  0 siblings, 1 reply; 11+ messages in thread
From: Skip Tavakkolian @ 2021-05-28 18:05 UTC (permalink / raw)
  To: 9fans

This might be helpful:

https://docs.google.com/document/d/1hgcsAgk_FJRYW5r7LVeY23sTZN_giUit-8ra-dlW9ng/edit?usp=sharing

On Fri, May 28, 2021 at 11:00 AM Brian L. Stuart <blstuart@bellsouth.net> wrote:
> 
> So I picked up a pi400 and everything seems happy
> except the Ethernet.  I'm using Richard's latest 9pi.img
> from 9p.io.  At least, I'm pretty sure it's the latest; it
> does include the /dev/serial driver.  The network switch
> is showing the hardware to be happy and I'm using a
> cable that has been working with a Pi3, but ipconf
> times out with a "no success with DHCP" error.  Anyone
> have any wisdom that I'm overlooking?
> 
> Also, Richard, I'm going to send you a bug fix for devspi
> soon.  I discovered that attempting to acces spictl is
> broken.
> 
> BLS

------------------------------------------
9fans: 9fans
Permalink: https://9fans.topicbox.com/groups/9fans/T8d2c30e280421e20-M3b11f3db55f278d6add071a4
Delivery options: https://9fans.topicbox.com/groups/9fans/subscription

^ permalink raw reply	[flat|nested] 11+ messages in thread

* Re: [9fans] Raspberry Pi400 Ethernet
  2021-05-28 18:05   ` Skip Tavakkolian
@ 2021-05-28 18:10     ` Skip Tavakkolian
  2021-05-28 18:26       ` Richard Miller
  0 siblings, 1 reply; 11+ messages in thread
From: Skip Tavakkolian @ 2021-05-28 18:10 UTC (permalink / raw)
  To: 9fans

Regarding dhcpd, to pxeboot, this diff is needed (also referenced in
the previous doc):
https://gist.github.com/9nut/5a3829356b6d0ce3ae47e2f390df7442

On Fri, May 28, 2021 at 11:05 AM Skip Tavakkolian
<skip.tavakkolian@gmail.com> wrote:
>
> This might be helpful:
>
> https://docs.google.com/document/d/1hgcsAgk_FJRYW5r7LVeY23sTZN_giUit-8ra-dlW9ng/edit?usp=sharing
>
> On Fri, May 28, 2021 at 11:00 AM Brian L. Stuart <blstuart@bellsouth.net> wrote:
> > 
> > So I picked up a pi400 and everything seems happy
> > except the Ethernet.  I'm using Richard's latest 9pi.img
> > from 9p.io.  At least, I'm pretty sure it's the latest; it
> > does include the /dev/serial driver.  The network switch
> > is showing the hardware to be happy and I'm using a
> > cable that has been working with a Pi3, but ipconf
> > times out with a "no success with DHCP" error.  Anyone
> > have any wisdom that I'm overlooking?
> > 
> > Also, Richard, I'm going to send you a bug fix for devspi
> > soon.  I discovered that attempting to acces spictl is
> > broken.
> > 
> > BLS

------------------------------------------
9fans: 9fans
Permalink: https://9fans.topicbox.com/groups/9fans/T8d2c30e280421e20-M397c1b0941f3eca57b1ab1cb
Delivery options: https://9fans.topicbox.com/groups/9fans/subscription

^ permalink raw reply	[flat|nested] 11+ messages in thread

* Re: [9fans] Raspberry Pi400 Ethernet
  2021-05-28 18:10     ` Skip Tavakkolian
@ 2021-05-28 18:26       ` Richard Miller
  2021-05-28 18:39         ` Brian L. Stuart
  2021-05-28 19:11         ` Steve Simon
  0 siblings, 2 replies; 11+ messages in thread
From: Richard Miller @ 2021-05-28 18:26 UTC (permalink / raw)
  To: 9fans

I have no personal experience of the pi400 but I believe the ethernet
hardware is identical to the pi4. Could it be a configuration problem?
Can you run snoopy or equivalent on the network segment and see if the
dhcp requests are being transmitted? And check the dhcp server log to
see if there's a reason for non-response? Also you can try using
ipconfig to set a specific ip address and gateway without using
dhcp, to see if it's a dhcp problem or a more fundamental ethernet problem.


------------------------------------------
9fans: 9fans
Permalink: https://9fans.topicbox.com/groups/9fans/T8d2c30e280421e20-M78ab0f08080650d55630723e
Delivery options: https://9fans.topicbox.com/groups/9fans/subscription

^ permalink raw reply	[flat|nested] 11+ messages in thread

* Re: [9fans] Raspberry Pi400 Ethernet
  2021-05-28 18:26       ` Richard Miller
@ 2021-05-28 18:39         ` Brian L. Stuart
  2021-05-28 18:51           ` Richard Miller
  2021-05-28 19:11         ` Steve Simon
  1 sibling, 1 reply; 11+ messages in thread
From: Brian L. Stuart @ 2021-05-28 18:39 UTC (permalink / raw)
  To: 9fans

I'm inclined to think you're on the right track with
a dhcp problem.  It seems to be working fine if I
set the address manually on the command line.
The really odd part is I just moved the SD card over
from a pi3 that was booting fine with dhcp.  I'll keep
digging.

BLS







On Friday, May 28, 2021, 2:28:16 PM EDT, Richard Miller <9fans@hamnavoe.com> wrote: 





I have no personal experience of the pi400 but I believe the ethernet
hardware is identical to the pi4. Could it be a configuration problem?
Can you run snoopy or equivalent on the network segment and see if the
dhcp requests are being transmitted? And check the dhcp server log to
see if there's a reason for non-response? Also you can try using
ipconfig to set a specific ip address and gateway without using
dhcp, to see if it's a dhcp problem or a more fundamental ethernet problem.


------------------------------------------
9fans: 9fans
Permalink: https://9fans.topicbox.com/groups/9fans/T8d2c30e280421e20-M9351afac61fe9f7850128c94
Delivery options: https://9fans.topicbox.com/groups/9fans/subscription

^ permalink raw reply	[flat|nested] 11+ messages in thread

* Re: [9fans] Raspberry Pi400 Ethernet
  2021-05-28 18:39         ` Brian L. Stuart
@ 2021-05-28 18:51           ` Richard Miller
  2021-05-28 19:11             ` Brian L. Stuart
  0 siblings, 1 reply; 11+ messages in thread
From: Richard Miller @ 2021-05-28 18:51 UTC (permalink / raw)
  To: 9fans

> The really odd part is I just moved the SD card over
> from a pi3 that was booting fine with dhcp.

Does the MAC address in the dhcp request look right?


------------------------------------------
9fans: 9fans
Permalink: https://9fans.topicbox.com/groups/9fans/T8d2c30e280421e20-M9e2789d215c02cc904dee5ca
Delivery options: https://9fans.topicbox.com/groups/9fans/subscription

^ permalink raw reply	[flat|nested] 11+ messages in thread

* Re: [9fans] Raspberry Pi400 Ethernet
  2021-05-28 18:26       ` Richard Miller
  2021-05-28 18:39         ` Brian L. Stuart
@ 2021-05-28 19:11         ` Steve Simon
  2021-05-28 20:50           ` Brian L. Stuart
  1 sibling, 1 reply; 11+ messages in thread
From: Steve Simon @ 2021-05-28 19:11 UTC (permalink / raw)
  To: 9fans

hi Brian,

pi4 ether worked out of the box for me with richards kernel, i am running a kernel from Christmas.

sadly i have had problems with usb3 which is on my todo list - usb2 devices work fine as do usb3 devices in usb2 sockets.

-Steve


------------------------------------------
9fans: 9fans
Permalink: https://9fans.topicbox.com/groups/9fans/T8d2c30e280421e20-Mc55694b340b224d49bb702fd
Delivery options: https://9fans.topicbox.com/groups/9fans/subscription

^ permalink raw reply	[flat|nested] 11+ messages in thread

* Re: [9fans] Raspberry Pi400 Ethernet
  2021-05-28 18:51           ` Richard Miller
@ 2021-05-28 19:11             ` Brian L. Stuart
  2021-05-28 20:09               ` Skip Tavakkolian
  0 siblings, 1 reply; 11+ messages in thread
From: Brian L. Stuart @ 2021-05-28 19:11 UTC (permalink / raw)
  To: 9fans

On Friday, May 28, 2021, 2:52:35 PM EDT, Richard Miller <9fans@hamnavoe.com> wrote: 
>> The really odd part is I just moved the SD card over
>> from a pi3 that was booting fine with dhcp.
>
> Does the MAC address in the dhcp request look right?

It does.  I'm at a loss to explain it, but I ended up rebooting
my auth/dhcp server and now everything is working.

False alarm, I guess.

Thanks,
BLS

------------------------------------------
9fans: 9fans
Permalink: https://9fans.topicbox.com/groups/9fans/T8d2c30e280421e20-M0975e43cb2c172ae2a9dc63c
Delivery options: https://9fans.topicbox.com/groups/9fans/subscription

^ permalink raw reply	[flat|nested] 11+ messages in thread

* Re: [9fans] Raspberry Pi400 Ethernet
  2021-05-28 19:11             ` Brian L. Stuart
@ 2021-05-28 20:09               ` Skip Tavakkolian
  2021-05-28 20:36                 ` Brian L. Stuart
  0 siblings, 1 reply; 11+ messages in thread
From: Skip Tavakkolian @ 2021-05-28 20:09 UTC (permalink / raw)
  To: 9fans

might be this (from the diffs gist i posted earlier):
    case ODtftpserver: /* RPi4s request it for no-SD netbooting
without hardcoding TFTP_IP in EEPROM */

On Fri, May 28, 2021 at 12:13 PM Brian L. Stuart <blstuart@bellsouth.net> wrote:
>
> On Friday, May 28, 2021, 2:52:35 PM EDT, Richard Miller <9fans@hamnavoe.com> wrote:
> >> The really odd part is I just moved the SD card over
> >> from a pi3 that was booting fine with dhcp.
> >
> > Does the MAC address in the dhcp request look right?
> 
> It does.  I'm at a loss to explain it, but I ended up rebooting
> my auth/dhcp server and now everything is working.
> 
> False alarm, I guess.
> 
> Thanks,
> BLS

------------------------------------------
9fans: 9fans
Permalink: https://9fans.topicbox.com/groups/9fans/T8d2c30e280421e20-Mc1f2494243e94a819a45ba37
Delivery options: https://9fans.topicbox.com/groups/9fans/subscription

^ permalink raw reply	[flat|nested] 11+ messages in thread

* Re: [9fans] Raspberry Pi400 Ethernet
  2021-05-28 20:09               ` Skip Tavakkolian
@ 2021-05-28 20:36                 ` Brian L. Stuart
  0 siblings, 0 replies; 11+ messages in thread
From: Brian L. Stuart @ 2021-05-28 20:36 UTC (permalink / raw)
  To: 9fans

I'll check on that.  Though in this case, I was booting
from the SD card and then running ipconfig by hand
to get an address.

BLS







On Friday, May 28, 2021, 4:11:04 PM EDT, Skip Tavakkolian <skip.tavakkolian@gmail.com> wrote: 





might be this (from the diffs gist i posted earlier):
    case ODtftpserver: /* RPi4s request it for no-SD netbooting
without hardcoding TFTP_IP in EEPROM */

On Fri, May 28, 2021 at 12:13 PM Brian L. Stuart <blstuart@bellsouth.net> wrote:
>
> On Friday, May 28, 2021, 2:52:35 PM EDT, Richard Miller <9fans@hamnavoe.com> wrote:
> >> The really odd part is I just moved the SD card over
> >> from a pi3 that was booting fine with dhcp.
> >
> > Does the MAC address in the dhcp request look right?
> 
> It does.  I'm at a loss to explain it, but I ended up rebooting
> my auth/dhcp server and now everything is working.
> 
> False alarm, I guess.
> 
> Thanks,
> BLS



------------------------------------------
9fans: 9fans
Permalink: https://9fans.topicbox.com/groups/9fans/T8d2c30e280421e20-M59de3a6995dc4de76608d14f
Delivery options: https://9fans.topicbox.com/groups/9fans/subscription

^ permalink raw reply	[flat|nested] 11+ messages in thread

* Re: [9fans] Raspberry Pi400 Ethernet
  2021-05-28 19:11         ` Steve Simon
@ 2021-05-28 20:50           ` Brian L. Stuart
  0 siblings, 0 replies; 11+ messages in thread
From: Brian L. Stuart @ 2021-05-28 20:50 UTC (permalink / raw)
  To: 9fans

On Friday, May 28, 2021, 3:12:26 PM EDT, Steve Simon <steve@quintile.net> wrote: 
> sadly i have had problems with usb3 which is on
> my todo list - usb2 devices work fine as do usb3
> devices in usb2 sockets.

I'll definitely keep that in mind.  I haven't been
trying to use any USB3 devices, but who know
what'll happen.

BLS

------------------------------------------
9fans: 9fans
Permalink: https://9fans.topicbox.com/groups/9fans/T8d2c30e280421e20-M3246d8de0bd9d31f1c12bbac
Delivery options: https://9fans.topicbox.com/groups/9fans/subscription

^ permalink raw reply	[flat|nested] 11+ messages in thread

end of thread, other threads:[~2021-05-28 20:50 UTC | newest]

Thread overview: 11+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
     [not found] <601087538.1280146.1622224718850.ref@mail.yahoo.com>
2021-05-28 17:58 ` [9fans] Raspberry Pi400 Ethernet Brian L. Stuart
2021-05-28 18:05   ` Skip Tavakkolian
2021-05-28 18:10     ` Skip Tavakkolian
2021-05-28 18:26       ` Richard Miller
2021-05-28 18:39         ` Brian L. Stuart
2021-05-28 18:51           ` Richard Miller
2021-05-28 19:11             ` Brian L. Stuart
2021-05-28 20:09               ` Skip Tavakkolian
2021-05-28 20:36                 ` Brian L. Stuart
2021-05-28 19:11         ` Steve Simon
2021-05-28 20:50           ` Brian L. Stuart

9fans - fans of the OS Plan 9 from Bell Labs

This inbox may be cloned and mirrored by anyone:

	git clone --mirror http://inbox.vuxu.org/9fans

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V1 9fans 9fans/ http://inbox.vuxu.org/9fans \
		9fans@9fans.net
	public-inbox-index 9fans

Example config snippet for mirrors.
Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.archive.9fans


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git