9front - general discussion about 9front
 help / color / mirror / Atom feed
* [9front] audio stopped working on two *60 series thinkpads
@ 2021-03-19  2:58 sl
  2021-03-19  5:04 ` mike
  0 siblings, 1 reply; 5+ messages in thread
From: sl @ 2021-03-19  2:58 UTC (permalink / raw)
  To: 9front

anyone with a T60 or X60 era machine willing to test?  i'm perfectly
willing to believe my machines are just borked.  however:

the other day i had out my X60t[0].  audio used to work on this
machine.  now it does not.

today i had out my T60p[1].  audio used to work on this machine.  now
it does not.

no idea when the breakage may have occurred.

sl

[0] http://plan9.stanleylieber.com/hardware/thinkpad/x60t/6363-g4u/sysinfo
[1] http://plan9.stanleylieber.com/hardware/thinkpad/t60p/2623-ddu/sysinfo

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [9front] audio stopped working on two *60 series thinkpads
  2021-03-19  2:58 [9front] audio stopped working on two *60 series thinkpads sl
@ 2021-03-19  5:04 ` mike
  2021-03-19  5:11   ` Silas McCroskey
  2021-03-19 16:08   ` sl
  0 siblings, 2 replies; 5+ messages in thread
From: mike @ 2021-03-19  5:04 UTC (permalink / raw)
  To: 9front

Audio works on my T60 (using pin 5): https://mike.eff0ff.net/hardware/t60/9front.sysinfo

> On 03/19/2021 3:58 AM sl@stanleylieber.com wrote:
> 
>  
> anyone with a T60 or X60 era machine willing to test?  i'm perfectly
> willing to believe my machines are just borked.  however:
> 
> the other day i had out my X60t[0].  audio used to work on this
> machine.  now it does not.
> 
> today i had out my T60p[1].  audio used to work on this machine.  now
> it does not.
> 
> no idea when the breakage may have occurred.
> 
> sl
> 
> [0] http://plan9.stanleylieber.com/hardware/thinkpad/x60t/6363-g4u/sysinfo
> [1] http://plan9.stanleylieber.com/hardware/thinkpad/t60p/2623-ddu/sysinfo

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [9front] audio stopped working on two *60 series thinkpads
  2021-03-19  5:04 ` mike
@ 2021-03-19  5:11   ` Silas McCroskey
  2021-03-19 16:10     ` sl
  2021-03-19 16:08   ` sl
  1 sibling, 1 reply; 5+ messages in thread
From: Silas McCroskey @ 2021-03-19  5:11 UTC (permalink / raw)
  To: 9front

I last rebuilt against 9front commit 85479d16418f (2021-01-22) and
audio works on both my x60t and t60p.

I'm 99% sure you know better, but are you sure your sound isn't just
muted via the hardware buttons?

http://sam-d.org/sysinfo/x60t
http://sam-d.org/sysinfo/t60p

- sam-d

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [9front] audio stopped working on two *60 series thinkpads
  2021-03-19  5:04 ` mike
  2021-03-19  5:11   ` Silas McCroskey
@ 2021-03-19 16:08   ` sl
  1 sibling, 0 replies; 5+ messages in thread
From: sl @ 2021-03-19 16:08 UTC (permalink / raw)
  To: 9front

> Audio works on my T60 (using pin 5): https://mike.eff0ff.net/hardware/t60/9front.sysinfo

i had been using pin 7... which is supposed to be the speaker:

pin 5 inout jack+fix ext left lineout green eapd ← aout 3, amix 14
pin 6 out nothing ext front hpout green ← aout 3, amix 14
pin 7 out nothing int special speaker black ← amix 15

i probably misremembered my previously working configuration.

pin 5 makes the speaker work on my T60p.

thanks!

sl

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [9front] audio stopped working on two *60 series thinkpads
  2021-03-19  5:11   ` Silas McCroskey
@ 2021-03-19 16:10     ` sl
  0 siblings, 0 replies; 5+ messages in thread
From: sl @ 2021-03-19 16:10 UTC (permalink / raw)
  To: 9front

> I'm 99% sure you know better, but are you sure your sound isn't just
> muted via the hardware buttons?

that wasn't it.  and i keep track of my working configurations, so i
must have just written "pin 7" in error.  i haven't tested pin 5
against my X60t yet, but it does work on my T60p.

thanks,

sl

^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2021-03-19 16:17 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-03-19  2:58 [9front] audio stopped working on two *60 series thinkpads sl
2021-03-19  5:04 ` mike
2021-03-19  5:11   ` Silas McCroskey
2021-03-19 16:10     ` sl
2021-03-19 16:08   ` sl

9front - general discussion about 9front

This inbox may be cloned and mirrored by anyone:

	git clone --mirror http://inbox.vuxu.org/9front

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V1 9front 9front/ http://inbox.vuxu.org/9front \
		9front@9front.org
	public-inbox-index 9front

Example config snippet for mirrors.
Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.archive.9front


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git