List for cgit developers and users
 help / color / mirror / Atom feed
* cgit dependencies
@ 2020-10-19  3:09 Sukma Wardana
  2020-10-19 12:39 ` Mateja Maric
  2020-10-19 13:14 ` Pedro Lucas Porcellis
  0 siblings, 2 replies; 5+ messages in thread
From: Sukma Wardana @ 2020-10-19  3:09 UTC (permalink / raw)
  To: cgit

Hi,
 
I just installed cgit on my Slackware VPS, everything is work well.
However, I couldn't make the about-formatting.sh and email-gravatar.lua work.
 
So, far I already installed Lua 5.1 & luaossl-20170903, but it's keep give error.
So, do I install the correct version of Lua and lua ossl?
 
For the about-formatting.sh what kind of requirements to enable this feature?
 
I already read the README and cgitrc.5.txt, but can't find the answer for my problem.
 
Please kindly advice how to solve my problem.
 
Cheers,
Sukma Wardana

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: cgit dependencies
  2020-10-19  3:09 cgit dependencies Sukma Wardana
@ 2020-10-19 12:39 ` Mateja Maric
  2020-10-20  3:16   ` Sukma Wardana
  2020-10-19 13:14 ` Pedro Lucas Porcellis
  1 sibling, 1 reply; 5+ messages in thread
From: Mateja Maric @ 2020-10-19 12:39 UTC (permalink / raw)
  To: Sukma Wardana, cgit

Check out comments in 
https://git.zx2c4.com/cgit/tree/filters/about-formatting.sh for 
about-formatting dependencies.
Hope this helps!

On 10/19/20 5:09 AM, Sukma Wardana wrote:
> Hi,
>   
> I just installed cgit on my Slackware VPS, everything is work well.
> However, I couldn't make the about-formatting.sh and email-gravatar.lua work.
>   
> So, far I already installed Lua 5.1 & luaossl-20170903, but it's keep give error.
> So, do I install the correct version of Lua and lua ossl?
>   
> For the about-formatting.sh what kind of requirements to enable this feature?
>   
> I already read the README and cgitrc.5.txt, but can't find the answer for my problem.
>   
> Please kindly advice how to solve my problem.
>   
> Cheers,
> Sukma Wardana

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: cgit dependencies
  2020-10-19  3:09 cgit dependencies Sukma Wardana
  2020-10-19 12:39 ` Mateja Maric
@ 2020-10-19 13:14 ` Pedro Lucas Porcellis
  1 sibling, 0 replies; 5+ messages in thread
From: Pedro Lucas Porcellis @ 2020-10-19 13:14 UTC (permalink / raw)
  To: Sukma Wardana; +Cc: cgit

Hi Sukma,
> For the about-formatting.sh what kind of requirements to enable this
> feature?

I've sent a patch some time ago, improving the documentation on how to
enable this feature, although it was not merged yet, is available here:

https://lists.zx2c4.com/pipermail/cgit/2020-September/004541.html

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: cgit dependencies
  2020-10-19 12:39 ` Mateja Maric
@ 2020-10-20  3:16   ` Sukma Wardana
  2020-10-20 14:35     ` Mateja Maric
  0 siblings, 1 reply; 5+ messages in thread
From: Sukma Wardana @ 2020-10-20  3:16 UTC (permalink / raw)
  To: Mateja Maric; +Cc: cgit

Hi Mateja,
 
Actually, I already saw the comment for about formatting. Just curious the require python version is 2.x or 3.x?
Also what version use for these dependencies:

* markdown-python
* docutils

Cheers,
sukma

Sent: Monday, October 19, 2020 at 7:39 PM
From: "Mateja Maric" <mail@matejamaric.com>
To: "Sukma Wardana" <sukma.wardana@mail.com>, cgit@lists.zx2c4.com
Subject: Re: cgit dependencies
Check out comments in
https://git.zx2c4.com/cgit/tree/filters/about-formatting.sh for
about-formatting dependencies.
Hope this helps!

On 10/19/20 5:09 AM, Sukma Wardana wrote:
> Hi,
>
> I just installed cgit on my Slackware VPS, everything is work well.
> However, I couldn't make the about-formatting.sh and email-gravatar.lua work.
>
> So, far I already installed Lua 5.1 & luaossl-20170903, but it's keep give error.
> So, do I install the correct version of Lua and lua ossl?
>
> For the about-formatting.sh what kind of requirements to enable this feature?
>
> I already read the README and cgitrc.5.txt, but can't find the answer for my problem.
>
> Please kindly advice how to solve my problem.
>
> Cheers,
> Sukma Wardana

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: cgit dependencies
  2020-10-20  3:16   ` Sukma Wardana
@ 2020-10-20 14:35     ` Mateja Maric
  0 siblings, 0 replies; 5+ messages in thread
From: Mateja Maric @ 2020-10-20 14:35 UTC (permalink / raw)
  To: Sukma Wardana; +Cc: cgit

There are versions of those dependencies in both Python 2 and 3 (at 
least there are in Debian repositories).
However you should probably stick to Python 3, since Python 2 is not 
supported anymore.

On 10/20/20 5:16 AM, Sukma Wardana wrote:
> Hi Mateja,
>   
> Actually, I already saw the comment for about formatting. Just curious the require python version is 2.x or 3.x?
> Also what version use for these dependencies:
>
> * markdown-python
> * docutils
>
> Cheers,
> sukma
>
> Sent: Monday, October 19, 2020 at 7:39 PM
> From: "Mateja Maric" <mail@matejamaric.com>
> To: "Sukma Wardana" <sukma.wardana@mail.com>, cgit@lists.zx2c4.com
> Subject: Re: cgit dependencies
> Check out comments in
> https://git.zx2c4.com/cgit/tree/filters/about-formatting.sh for
> about-formatting dependencies.
> Hope this helps!
>
> On 10/19/20 5:09 AM, Sukma Wardana wrote:
>> Hi,
>>
>> I just installed cgit on my Slackware VPS, everything is work well.
>> However, I couldn't make the about-formatting.sh and email-gravatar.lua work.
>>
>> So, far I already installed Lua 5.1 & luaossl-20170903, but it's keep give error.
>> So, do I install the correct version of Lua and lua ossl?
>>
>> For the about-formatting.sh what kind of requirements to enable this feature?
>>
>> I already read the README and cgitrc.5.txt, but can't find the answer for my problem.
>>
>> Please kindly advice how to solve my problem.
>>
>> Cheers,
>> Sukma Wardana

^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2020-10-20 14:36 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-10-19  3:09 cgit dependencies Sukma Wardana
2020-10-19 12:39 ` Mateja Maric
2020-10-20  3:16   ` Sukma Wardana
2020-10-20 14:35     ` Mateja Maric
2020-10-19 13:14 ` Pedro Lucas Porcellis

List for cgit developers and users

This inbox may be cloned and mirrored by anyone:

	git clone --mirror http://inbox.vuxu.org/cgit

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V1 cgit cgit/ http://inbox.vuxu.org/cgit \
		cgit@lists.zx2c4.com
	public-inbox-index cgit

Example config snippet for mirrors.
Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.archive.cgit


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git