List for cgit developers and users
 help / color / mirror / Atom feed
* Incompatibilities with python3-pygments 2.6.1?
@ 2020-07-01 13:51 jean-christophe manciot
  2020-07-01 14:12 ` Christian Hesse
  2020-07-01 15:35 ` Roy Marples
  0 siblings, 2 replies; 6+ messages in thread
From: jean-christophe manciot @ 2020-07-01 13:51 UTC (permalink / raw)
  To: cgit

Hello everyone,

I've built python3-pygments from sources
(https://github.com/pygments/pygments) using the latest stable 2.6.1
tag.
Using it with cgit v1.2.3 and git 2.25.1 leads to blank 'about' pages
whereas everything works fine with 2.3.1+dfsg-1ubuntu2 on Ubuntu
focal.

Any suggestions?

The deb package is available on Ubuntu focal at
https://git.sdxlive.com/PPA/tree/Ubuntu/pool/stable/p/python3-pygments.

Cheers.
-- 
Jean-Christophe

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: Incompatibilities with python3-pygments 2.6.1?
  2020-07-01 13:51 Incompatibilities with python3-pygments 2.6.1? jean-christophe manciot
@ 2020-07-01 14:12 ` Christian Hesse
  2020-07-01 15:26   ` jean-christophe manciot
  2020-07-01 15:35 ` Roy Marples
  1 sibling, 1 reply; 6+ messages in thread
From: Christian Hesse @ 2020-07-01 14:12 UTC (permalink / raw)
  To: jean-christophe manciot; +Cc: cgit

[-- Attachment #1: Type: text/plain, Size: 969 bytes --]

jean-christophe manciot <actionmystique@gmail.com> on Wed, 2020/07/01 15:51:
> Hello everyone,
> 
> I've built python3-pygments from sources
> (https://github.com/pygments/pygments) using the latest stable 2.6.1
> tag.
> Using it with cgit v1.2.3 and git 2.25.1 leads to blank 'about' pages
> whereas everything works fine with 2.3.1+dfsg-1ubuntu2 on Ubuntu
> focal.
> 
> Any suggestions?
> 
> The deb package is available on Ubuntu focal at
> https://git.sdxlive.com/PPA/tree/Ubuntu/pool/stable/p/python3-pygments.
> 
> Cheers.

I use cgit with python-pygments 2.6.1-2 on Arch Linux. Everything works as
expected, so looks like this is not a general issue with python-pygments.

Any error messages in the logs?
-- 
main(a){char*c=/*    Schoene Gruesse                         */"B?IJj;MEH"
"CX:;",b;for(a/*    Best regards             my address:    */=0;b=c[a++];)
putchar(b-1/(/*    Chris            cc -ox -xc - && ./x    */b/42*2-3)*42);}

[-- Attachment #2: OpenPGP digital signature --]
[-- Type: application/pgp-signature, Size: 488 bytes --]

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: Incompatibilities with python3-pygments 2.6.1?
  2020-07-01 14:12 ` Christian Hesse
@ 2020-07-01 15:26   ` jean-christophe manciot
  0 siblings, 0 replies; 6+ messages in thread
From: jean-christophe manciot @ 2020-07-01 15:26 UTC (permalink / raw)
  To: Christian Hesse; +Cc: cgit

Nothing related to this issue appears in uwsgi/nginx logs nor any
other log below /var/log.
Is there a way to log cgit trace?

On Wed, Jul 1, 2020 at 4:12 PM Christian Hesse <list@eworm.de> wrote:
>
> jean-christophe manciot <actionmystique@gmail.com> on Wed, 2020/07/01 15:51:
> > Hello everyone,
> >
> > I've built python3-pygments from sources
> > (https://github.com/pygments/pygments) using the latest stable 2.6.1
> > tag.
> > Using it with cgit v1.2.3 and git 2.25.1 leads to blank 'about' pages
> > whereas everything works fine with 2.3.1+dfsg-1ubuntu2 on Ubuntu
> > focal.
> >
> > Any suggestions?
> >
> > The deb package is available on Ubuntu focal at
> > https://git.sdxlive.com/PPA/tree/Ubuntu/pool/stable/p/python3-pygments.
> >
> > Cheers.
>
> I use cgit with python-pygments 2.6.1-2 on Arch Linux. Everything works as
> expected, so looks like this is not a general issue with python-pygments.
>
> Any error messages in the logs?
> --
> main(a){char*c=/*    Schoene Gruesse                         */"B?IJj;MEH"
> "CX:;",b;for(a/*    Best regards             my address:    */=0;b=c[a++];)
> putchar(b-1/(/*    Chris            cc -ox -xc - && ./x    */b/42*2-3)*42);}



-- 
Jean-Christophe

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: Incompatibilities with python3-pygments 2.6.1?
  2020-07-01 13:51 Incompatibilities with python3-pygments 2.6.1? jean-christophe manciot
  2020-07-01 14:12 ` Christian Hesse
@ 2020-07-01 15:35 ` Roy Marples
  2020-07-01 15:41   ` jean-christophe manciot
  1 sibling, 1 reply; 6+ messages in thread
From: Roy Marples @ 2020-07-01 15:35 UTC (permalink / raw)
  To: jean-christophe manciot, cgit

On 01/07/2020 14:51, jean-christophe manciot wrote:
> Hello everyone,
> 
> I've built python3-pygments from sources
> (https://github.com/pygments/pygments) using the latest stable 2.6.1
> tag.
> Using it with cgit v1.2.3 and git 2.25.1 leads to blank 'about' pages
> whereas everything works fine with 2.3.1+dfsg-1ubuntu2 on Ubuntu
> focal.
> 
> Any suggestions?
> 
> The deb package is available on Ubuntu focal at
> https://git.sdxlive.com/PPA/tree/Ubuntu/pool/stable/p/python3-pygments.

I use the highlight package instead, running cgit under uwsgi fronted by nginx.
When I restart the web server, the highlighted code is blank until I restart the 
uwsgi service. I don't know why this is as there is no reported error, but the 
symtom appears to mirror your own so I thought it was worth mentioning.

Roy

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: Incompatibilities with python3-pygments 2.6.1?
  2020-07-01 15:35 ` Roy Marples
@ 2020-07-01 15:41   ` jean-christophe manciot
  2020-07-03 15:36     ` jean-christophe manciot
  0 siblings, 1 reply; 6+ messages in thread
From: jean-christophe manciot @ 2020-07-01 15:41 UTC (permalink / raw)
  To: Roy Marples; +Cc: cgit

I tried to restart uwsgi then nginx systemd services after
python3-pygments upgrade, but the symptom persists.

On Wed, Jul 1, 2020 at 5:35 PM Roy Marples <roy@marples.name> wrote:
>
> On 01/07/2020 14:51, jean-christophe manciot wrote:
> > Hello everyone,
> >
> > I've built python3-pygments from sources
> > (https://github.com/pygments/pygments) using the latest stable 2.6.1
> > tag.
> > Using it with cgit v1.2.3 and git 2.25.1 leads to blank 'about' pages
> > whereas everything works fine with 2.3.1+dfsg-1ubuntu2 on Ubuntu
> > focal.
> >
> > Any suggestions?
> >
> > The deb package is available on Ubuntu focal at
> > https://git.sdxlive.com/PPA/tree/Ubuntu/pool/stable/p/python3-pygments.
>
> I use the highlight package instead, running cgit under uwsgi fronted by nginx.
> When I restart the web server, the highlighted code is blank until I restart the
> uwsgi service. I don't know why this is as there is no reported error, but the
> symtom appears to mirror your own so I thought it was worth mentioning.
>
> Roy



-- 
Jean-Christophe

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: Incompatibilities with python3-pygments 2.6.1?
  2020-07-01 15:41   ` jean-christophe manciot
@ 2020-07-03 15:36     ` jean-christophe manciot
  0 siblings, 0 replies; 6+ messages in thread
From: jean-christophe manciot @ 2020-07-03 15:36 UTC (permalink / raw)
  To: Roy Marples; +Cc: cgit

It appears it was actually caused by a packaging quirk where a
non-default python lib path was used by default.
I have rebuilt the package and now everything is fine.

On Wed, Jul 1, 2020 at 5:41 PM jean-christophe manciot
<actionmystique@gmail.com> wrote:
>
> I tried to restart uwsgi then nginx systemd services after
> python3-pygments upgrade, but the symptom persists.
>
> On Wed, Jul 1, 2020 at 5:35 PM Roy Marples <roy@marples.name> wrote:
> >
> > On 01/07/2020 14:51, jean-christophe manciot wrote:
> > > Hello everyone,
> > >
> > > I've built python3-pygments from sources
> > > (https://github.com/pygments/pygments) using the latest stable 2.6.1
> > > tag.
> > > Using it with cgit v1.2.3 and git 2.25.1 leads to blank 'about' pages
> > > whereas everything works fine with 2.3.1+dfsg-1ubuntu2 on Ubuntu
> > > focal.
> > >
> > > Any suggestions?
> > >
> > > The deb package is available on Ubuntu focal at
> > > https://git.sdxlive.com/PPA/tree/Ubuntu/pool/stable/p/python3-pygments.
> >
> > I use the highlight package instead, running cgit under uwsgi fronted by nginx.
> > When I restart the web server, the highlighted code is blank until I restart the
> > uwsgi service. I don't know why this is as there is no reported error, but the
> > symtom appears to mirror your own so I thought it was worth mentioning.
> >
> > Roy
>
>
>
> --
> Jean-Christophe



-- 
Jean-Christophe

^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2020-07-03 15:36 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-07-01 13:51 Incompatibilities with python3-pygments 2.6.1? jean-christophe manciot
2020-07-01 14:12 ` Christian Hesse
2020-07-01 15:26   ` jean-christophe manciot
2020-07-01 15:35 ` Roy Marples
2020-07-01 15:41   ` jean-christophe manciot
2020-07-03 15:36     ` jean-christophe manciot

List for cgit developers and users

This inbox may be cloned and mirrored by anyone:

	git clone --mirror http://inbox.vuxu.org/cgit

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V1 cgit cgit/ http://inbox.vuxu.org/cgit \
		cgit@lists.zx2c4.com
	public-inbox-index cgit

Example config snippet for mirrors.
Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.archive.cgit


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git