Unnamed repository; edit this file 'description' to name the repository.
 help / color / Atom feed
* No gnus connection with emacs-27
@ 2020-04-17  5:20 Colin Baxter
  2020-04-17 11:41 ` No gnus connection with emacs-27 SOLVED Colin Baxter
  0 siblings, 1 reply; 2+ messages in thread
From: Colin Baxter @ 2020-04-17  5:20 UTC (permalink / raw)
  To: info-gnus-english

Hello,

I can connect to my news groups using emacs-26.3, no problem, but not
with emacs-27 (or emacs-28). Has something changed?

The relevant (I think!) portion of my ~/.gnus.el is

(setq gnus-select-method
      '(nntp "news.gmane.io"))

Emacs-26.3 accepts this, but emacs-27 gives the error:

Opening nntp server on news...failed: >>> (error news/nntp No address
associated with hostname)

Best wishes,

Colin

Colin Baxter
URL: http://www.Colin-Baxter.com


_______________________________________________
info-gnus-english mailing list
info-gnus-english@gnu.org
https://lists.gnu.org/mailman/listinfo/info-gnus-english

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: No gnus connection with emacs-27 SOLVED
  2020-04-17  5:20 No gnus connection with emacs-27 Colin Baxter
@ 2020-04-17 11:41 ` Colin Baxter
  0 siblings, 0 replies; 2+ messages in thread
From: Colin Baxter @ 2020-04-17 11:41 UTC (permalink / raw)
  To: info-gnus-english

>>>>> "Colin" == Colin Baxter <m43cap@yandex.com> writes:

    Colin> Hello, I can connect to my news groups using emacs-26.3, no
    Colin> problem, but not with emacs-27 (or emacs-28). Has something
    Colin> changed?

    Colin> The relevant (I think!) portion of my ~/.gnus.el is

    Colin> (setq gnus-select-method '(nntp "news.gmane.io"))

    Colin> Emacs-26.3 accepts this, but emacs-27 gives the error:

    Colin> Opening nntp server on news...failed: >>> (error news/nntp No
    Colin> address associated with hostname)

I was launching emacs-27 via the "-q" option and then loading settings
via an elisp config file (don't ask me why!). It seems that emacs-27 had
no way of knowing it had to use ~/.gnus.el when receiving a M-x gnus <RET>
instruction. The solution is therefore to either

M-x load-library <RET> ~/.gnus.el <RET>

prior to launching gnus, or to put

(load-library "~/.gnus.el")

in the original elisp config file.

I hadn't realised before that the "-q" switch is such a killer!

Best wishes,

Colin Baxter
URL: http://www.Colin-Baxter.com
---------------------------------------------------------------------
GnuPG fingerprint: 68A8 799C 0230 16E7 BF68  2A27 BBFA 2492 91F5 41C8
---------------------------------------------------------------------
The sole cause of all human misery is the inability of people to sit
quietly in their rooms.  Blaise Pascal, 1670


_______________________________________________
info-gnus-english mailing list
info-gnus-english@gnu.org
https://lists.gnu.org/mailman/listinfo/info-gnus-english

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, back to index

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-04-17  5:20 No gnus connection with emacs-27 Colin Baxter
2020-04-17 11:41 ` No gnus connection with emacs-27 SOLVED Colin Baxter

Unnamed repository; edit this file 'description' to name the repository.

Archives are clonable: git clone --mirror http://inbox.vuxu.org/info-gnus-english

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.archive.emacs.gnus.user


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git