Announcements and discussions for Gnus, the GNU Emacs Usenet newsreader
 help / color / mirror / Atom feed
* Error message Process nntpd not running
@ 2021-07-20 10:16 Richmond
  2021-07-20 10:57 ` Pankaj Jangid
  0 siblings, 1 reply; 12+ messages in thread
From: Richmond @ 2021-07-20 10:16 UTC (permalink / raw)
  To: info-gnus-english

Since nntp.aioe.org has upgraded its system from debian 8 I have been
getting this error when starting gnus:

>>> (error Process nntpd not running)
nntp (nntp.aioe.org) open error: ‘>>> (error Process nntpd not
running)’.  Continue? (y or n) y

However if I go to the server buffer and open the server it then works ok.

What does this error mean? Is it a timing issue?

I have

(setq
gnus-select-method                                                                                   
\

      '(nntp
"nntp.aioe.org"                                                                               
\

             (nntp-open-connection-function
nntp-open-tls-stream)                                           \

             (nntp-port-number 563)))

(setq nntp-connection-timeout 240)

_______________________________________________
info-gnus-english mailing list
info-gnus-english@gnu.org
https://lists.gnu.org/mailman/listinfo/info-gnus-english

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: Error message Process nntpd not running
  2021-07-20 10:16 Error message Process nntpd not running Richmond
@ 2021-07-20 10:57 ` Pankaj Jangid
  2021-07-20 11:15   ` Richmond
  0 siblings, 1 reply; 12+ messages in thread
From: Pankaj Jangid @ 2021-07-20 10:57 UTC (permalink / raw)
  To: info-gnus-english

Richmond <dnomhcir@gmx.com> writes:

> Since nntp.aioe.org has upgraded its system from debian 8 I have been
> getting this error when starting gnus:
>
>>>> (error Process nntpd not running)
> nntp (nntp.aioe.org) open error: ‘>>> (error Process nntpd not
> running)’.  Continue? (y or n) y

> However if I go to the server buffer and open the server it then works ok.
>
> What does this error mean? Is it a timing issue?

This error should be related to the back-end process. Does the problem
persists even after restarting Emacs? I face this issue with some IMAP
servers but not always. This is could be due to unreliable network. Due
to which the back-end process goes into stale state.


> I have
>
> (setq gnus-select-method
>     '(nntp "nntp.aioe.org"
>         (nntp-open-connection-function nntp-open-tls-stream)
>         (nntp-port-number 563)))
> 
> (setq nntp-connection-timeout 240)


I have just the below setting in my config. And it is working fine.

(setq gnus-select-method '(nntp "nntp.aioe.org")) ; news

Could you please try removing the other params from your configuration
if the previously mentioned restart also doesn’t fix the issue.

I know "restart" is too much for an Emacs user. But I am just trying to
pin-point the cause.


_______________________________________________
info-gnus-english mailing list
info-gnus-english@gnu.org
https://lists.gnu.org/mailman/listinfo/info-gnus-english

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: Error message Process nntpd not running
  2021-07-20 10:57 ` Pankaj Jangid
@ 2021-07-20 11:15   ` Richmond
  2021-07-20 11:26     ` Pankaj Jangid
  0 siblings, 1 reply; 12+ messages in thread
From: Richmond @ 2021-07-20 11:15 UTC (permalink / raw)
  To: info-gnus-english

Pankaj Jangid wrote:
> Richmond <dnomhcir@gmx.com> writes:
>
>> Since nntp.aioe.org has upgraded its system from debian 8 I have been
>> getting this error when starting gnus:
>>
>>>>> (error Process nntpd not running)
>> nntp (nntp.aioe.org) open error: ‘>>> (error Process nntpd not
>> running)’.  Continue? (y or n) y
>> However if I go to the server buffer and open the server it then works ok.
>>
>> What does this error mean? Is it a timing issue?
> This error should be related to the back-end process. Does the problem
> persists even after restarting Emacs? I face this issue with some IMAP
> servers but not always. This is could be due to unreliable network. Due
> to which the back-end process goes into stale state.
The problem occurs every time I start emacs. I start emacs with

emacs -nw -f gnus

>
>> I have
>>
>> (setq gnus-select-method
>>     '(nntp "nntp.aioe.org"
>>         (nntp-open-connection-function nntp-open-tls-stream)
>>         (nntp-port-number 563)))
>>
>> (setq nntp-connection-timeout 240)
>
> I have just the below setting in my config. And it is working fine.
>
> (setq gnus-select-method '(nntp "nntp.aioe.org")) ; news
>
> Could you please try removing the other params from your configuration
> if the previously mentioned restart also doesn’t fix the issue.
This change does fix the issue. However it means not using TLS. I want
to use TLS. I was using TLS before the server was upgraded without any
problems. And I use other servers with TLS without getting this error.


_______________________________________________
info-gnus-english mailing list
info-gnus-english@gnu.org
https://lists.gnu.org/mailman/listinfo/info-gnus-english

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: Error message Process nntpd not running
  2021-07-20 11:15   ` Richmond
@ 2021-07-20 11:26     ` Pankaj Jangid
  2021-07-20 11:31       ` Richmond
  0 siblings, 1 reply; 12+ messages in thread
From: Pankaj Jangid @ 2021-07-20 11:26 UTC (permalink / raw)
  To: info-gnus-english

Richmond <dnomhcir@gmx.com> writes:

>> Could you please try removing the other params from your configuration
>> if the previously mentioned restart also doesn’t fix the issue.
> This change does fix the issue. However it means not using TLS. I want
> to use TLS. I was using TLS before the server was upgraded without any
> problems. And I use other servers with TLS without getting this error.

Then probably wait for a couple of days. The guys at aioi.org must be in
the process of restoring the certificates.

If the issue persists then report it to them that TLS isn’t working.



_______________________________________________
info-gnus-english mailing list
info-gnus-english@gnu.org
https://lists.gnu.org/mailman/listinfo/info-gnus-english

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: Error message Process nntpd not running
  2021-07-20 11:26     ` Pankaj Jangid
@ 2021-07-20 11:31       ` Richmond
  2021-07-20 12:24         ` Pankaj Jangid
  0 siblings, 1 reply; 12+ messages in thread
From: Richmond @ 2021-07-20 11:31 UTC (permalink / raw)
  To: info-gnus-english

Pankaj Jangid wrote:
> Richmond <dnomhcir@gmx.com> writes:
>
>>> Could you please try removing the other params from your configuration
>>> if the previously mentioned restart also doesn’t fix the issue.
>> This change does fix the issue. However it means not using TLS. I want
>> to use TLS. I was using TLS before the server was upgraded without any
>> problems. And I use other servers with TLS without getting this error.
> Then probably wait for a couple of days. The guys at aioi.org must be in
> the process of restoring the certificates.
>
> If the issue persists then report it to them that TLS isn’t working.

I have already reported it to them. They say there is nothing wrong

their end.

Notice this command works and allows interaction with the server:

gnutls-cli nntp.aioe.org:563



_______________________________________________
info-gnus-english mailing list
info-gnus-english@gnu.org
https://lists.gnu.org/mailman/listinfo/info-gnus-english

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: Error message Process nntpd not running
  2021-07-20 11:31       ` Richmond
@ 2021-07-20 12:24         ` Pankaj Jangid
  2021-07-20 12:44           ` Richmond
  0 siblings, 1 reply; 12+ messages in thread
From: Pankaj Jangid @ 2021-07-20 12:24 UTC (permalink / raw)
  To: info-gnus-english

Richmond <dnomhcir@gmx.com> writes:

> I have already reported it to them. They say there is nothing wrong
>
> their end.
>
> Notice this command works and allows interaction with the server:
>
> gnutls-cli nntp.aioe.org:563

Oh yes. I forgot, you had already mentioned that it works fine in the
server buffer.

Then it could be something in your newsrc. I think Lars or Eric would
like to comment here.


_______________________________________________
info-gnus-english mailing list
info-gnus-english@gnu.org
https://lists.gnu.org/mailman/listinfo/info-gnus-english

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: Error message Process nntpd not running
  2021-07-20 12:24         ` Pankaj Jangid
@ 2021-07-20 12:44           ` Richmond
  2021-07-20 13:50             ` Pankaj Jangid
  0 siblings, 1 reply; 12+ messages in thread
From: Richmond @ 2021-07-20 12:44 UTC (permalink / raw)
  To: Pankaj Jangid; +Cc: info-gnus-english

Pankaj Jangid <pankaj@codeisgreat.org> writes:

> Richmond <dnomhcir@gmx.com> writes:
>
>> I have already reported it to them. They say there is nothing wrong
>>
>> their end.
>>
>> Notice this command works and allows interaction with the server:
>>
>> gnutls-cli nntp.aioe.org:563
>
> Oh yes. I forgot, you had already mentioned that it works fine in the
> server buffer.
>
> Then it could be something in your newsrc. I think Lars or Eric would
> like to comment here.

I tried creating a new linux user, and copied the files .gnus and
.gnu-emacs-custom and then ran emacs -nw -f gnus, but still got the same
error.


_______________________________________________
info-gnus-english mailing list
info-gnus-english@gnu.org
https://lists.gnu.org/mailman/listinfo/info-gnus-english

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: Error message Process nntpd not running
  2021-07-20 12:44           ` Richmond
@ 2021-07-20 13:50             ` Pankaj Jangid
  2021-07-20 17:35               ` Richmond
  0 siblings, 1 reply; 12+ messages in thread
From: Pankaj Jangid @ 2021-07-20 13:50 UTC (permalink / raw)
  To: Richmond; +Cc: info-gnus-english

Richmond <dnomhcir@gmx.com> writes:

> I tried creating a new linux user, and copied the files .gnus and
> .gnu-emacs-custom and then ran emacs -nw -f gnus, but still got the
> same error.

Is this emacs-27? I can see that that could be the only difference. I am
using Emacs from the git master (i.e. 28.x).

If you have access to emacs from git master then could you please try
reproducing it?


_______________________________________________
info-gnus-english mailing list
info-gnus-english@gnu.org
https://lists.gnu.org/mailman/listinfo/info-gnus-english

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: Error message Process nntpd not running
  2021-07-20 13:50             ` Pankaj Jangid
@ 2021-07-20 17:35               ` Richmond
  2021-07-20 17:55                 ` Richmond
  2021-07-21  3:19                 ` Pankaj Jangid
  0 siblings, 2 replies; 12+ messages in thread
From: Richmond @ 2021-07-20 17:35 UTC (permalink / raw)
  To: Pankaj Jangid; +Cc: info-gnus-english

Pankaj Jangid <pankaj@codeisgreat.org> writes:

> Richmond <dnomhcir@gmx.com> writes:
>
>> I tried creating a new linux user, and copied the files .gnus and
>> .gnu-emacs-custom and then ran emacs -nw -f gnus, but still got the
>> same error.
>
> Is this emacs-27? I can see that that could be the only difference. I am
> using Emacs from the git master (i.e. 28.x).
>
> If you have access to emacs from git master then could you please try
> reproducing it?

I was using 26.

I have now tried 27.2, and 28.0.50 (and 25) and all produce the same
error.

I think it is odd that I get the error if I start gnus from the command
line, with emacs -nw -f gnus, but if I start emacs first, emacs -nw,
then start gnus from within emacs. I get no error.

So perhaps I just need to delay the start of gnus a little?

_______________________________________________
info-gnus-english mailing list
info-gnus-english@gnu.org
https://lists.gnu.org/mailman/listinfo/info-gnus-english

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: Error message Process nntpd not running
  2021-07-20 17:35               ` Richmond
@ 2021-07-20 17:55                 ` Richmond
  2021-07-20 19:12                   ` Eric Abrahamsen
  2021-07-21  3:19                 ` Pankaj Jangid
  1 sibling, 1 reply; 12+ messages in thread
From: Richmond @ 2021-07-20 17:55 UTC (permalink / raw)
  To: info-gnus-english

Richmond wrote:
> Pankaj Jangid <pankaj@codeisgreat.org> writes:
>
>> Richmond <dnomhcir@gmx.com> writes:
>>
>>> I tried creating a new linux user, and copied the files .gnus and
>>> .gnu-emacs-custom and then ran emacs -nw -f gnus, but still got the
>>> same error.
>> Is this emacs-27? I can see that that could be the only difference. I am
>> using Emacs from the git master (i.e. 28.x).
>>
>> If you have access to emacs from git master then could you please try
>> reproducing it?
> I was using 26.
>
> I have now tried 27.2, and 28.0.50 (and 25) and all produce the same
> error.
>
> I think it is odd that I get the error if I start gnus from the command
> line, with emacs -nw -f gnus, but if I start emacs first, emacs -nw,
> then start gnus from within emacs. I get no error.
>
> So perhaps I just need to delay the start of gnus a little?
>

I placed:

(sit-for 3)

at the end of .emacs which seems to prevent the error, although I should
perhaps place it in a gnus file because I don't want it happening every
time I start emacs.


_______________________________________________
info-gnus-english mailing list
info-gnus-english@gnu.org
https://lists.gnu.org/mailman/listinfo/info-gnus-english

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: Error message Process nntpd not running
  2021-07-20 17:55                 ` Richmond
@ 2021-07-20 19:12                   ` Eric Abrahamsen
  0 siblings, 0 replies; 12+ messages in thread
From: Eric Abrahamsen @ 2021-07-20 19:12 UTC (permalink / raw)
  To: Richmond; +Cc: info-gnus-english

Richmond <dnomhcir@gmx.com> writes:

> Richmond wrote:
>> Pankaj Jangid <pankaj@codeisgreat.org> writes:
>>
>>> Richmond <dnomhcir@gmx.com> writes:
>>>
>>>> I tried creating a new linux user, and copied the files .gnus and
>>>> .gnu-emacs-custom and then ran emacs -nw -f gnus, but still got the
>>>> same error.
>>> Is this emacs-27? I can see that that could be the only difference. I am
>>> using Emacs from the git master (i.e. 28.x).
>>>
>>> If you have access to emacs from git master then could you please try
>>> reproducing it?
>> I was using 26.
>>
>> I have now tried 27.2, and 28.0.50 (and 25) and all produce the same
>> error.
>>
>> I think it is odd that I get the error if I start gnus from the command
>> line, with emacs -nw -f gnus, but if I start emacs first, emacs -nw,
>> then start gnus from within emacs. I get no error.
>>
>> So perhaps I just need to delay the start of gnus a little?
>>
>
> I placed:
>
> (sit-for 3)
>
> at the end of .emacs which seems to prevent the error, although I should
> perhaps place it in a gnus file because I don't want it happening every
> time I start emacs.

That's very weird, but unfortunately I won't be able to help, as I don't
know much about the implementation of the TLS code in Emacs. Lars knows
about that, so hopefully he'll chime in.

_______________________________________________
info-gnus-english mailing list
info-gnus-english@gnu.org
https://lists.gnu.org/mailman/listinfo/info-gnus-english

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: Error message Process nntpd not running
  2021-07-20 17:35               ` Richmond
  2021-07-20 17:55                 ` Richmond
@ 2021-07-21  3:19                 ` Pankaj Jangid
  1 sibling, 0 replies; 12+ messages in thread
From: Pankaj Jangid @ 2021-07-21  3:19 UTC (permalink / raw)
  To: Richmond; +Cc: info-gnus-english

Richmond <dnomhcir@gmx.com> writes:

> I was using 26.
>
> I have now tried 27.2, and 28.0.50 (and 25) and all produce the same
> error.
>
> I think it is odd that I get the error if I start gnus from the command
> line, with emacs -nw -f gnus, but if I start emacs first, emacs -nw,
> then start gnus from within emacs. I get no error.
>
> So perhaps I just need to delay the start of gnus a little?

Yes the TLS library may not be loaded by that time. For the same reason,
it is working in the server buffer later. But I am not the right person
to comment.

_______________________________________________
info-gnus-english mailing list
info-gnus-english@gnu.org
https://lists.gnu.org/mailman/listinfo/info-gnus-english

^ permalink raw reply	[flat|nested] 12+ messages in thread

end of thread, other threads:[~2021-07-21  3:19 UTC | newest]

Thread overview: 12+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-07-20 10:16 Error message Process nntpd not running Richmond
2021-07-20 10:57 ` Pankaj Jangid
2021-07-20 11:15   ` Richmond
2021-07-20 11:26     ` Pankaj Jangid
2021-07-20 11:31       ` Richmond
2021-07-20 12:24         ` Pankaj Jangid
2021-07-20 12:44           ` Richmond
2021-07-20 13:50             ` Pankaj Jangid
2021-07-20 17:35               ` Richmond
2021-07-20 17:55                 ` Richmond
2021-07-20 19:12                   ` Eric Abrahamsen
2021-07-21  3:19                 ` Pankaj Jangid

Announcements and discussions for Gnus, the GNU Emacs Usenet newsreader

This inbox may be cloned and mirrored by anyone:

	git clone --mirror https://inbox.vuxu.org/info-gnus-english

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V1 info-gnus-english info-gnus-english/ https://inbox.vuxu.org/info-gnus-english \
		info-gnus-english@inbox.vuxu.org
	public-inbox-index info-gnus-english

Example config snippet for mirrors.
Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.archive.emacs.gnus.user


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git