From mboxrd@z Thu Jan 1 00:00:00 1970 X-Msuck: nntp://news.gmane.org/gmane.linux.lib.musl.general/5996 Path: news.gmane.org!not-for-mail From: Rich Felker Newsgroups: gmane.linux.lib.musl.general Subject: Re: [PATCH 6/8] add the functions for cnd_t Date: Sat, 30 Aug 2014 20:35:18 -0400 Message-ID: <20140831003517.GO12888@brightrain.aerifal.cx> References: <64bad51d35eea337b8d998a1a2165c5adc440e1d.1409423162.git.Jens.Gustedt@inria.fr> Reply-To: musl@lists.openwall.com NNTP-Posting-Host: plane.gmane.org Mime-Version: 1.0 Content-Type: text/plain; charset=us-ascii X-Trace: ger.gmane.org 1409445337 12940 80.91.229.3 (31 Aug 2014 00:35:37 GMT) X-Complaints-To: usenet@ger.gmane.org NNTP-Posting-Date: Sun, 31 Aug 2014 00:35:37 +0000 (UTC) To: musl@lists.openwall.com Original-X-From: musl-return-6003-gllmg-musl=m.gmane.org@lists.openwall.com Sun Aug 31 02:35:30 2014 Return-path: Envelope-to: gllmg-musl@plane.gmane.org Original-Received: from mother.openwall.net ([195.42.179.200]) by plane.gmane.org with smtp (Exim 4.69) (envelope-from ) id 1XNt7C-00008J-Ky for gllmg-musl@plane.gmane.org; Sun, 31 Aug 2014 02:35:30 +0200 Original-Received: (qmail 19493 invoked by uid 550); 31 Aug 2014 00:35:30 -0000 Mailing-List: contact musl-help@lists.openwall.com; run by ezmlm Precedence: bulk List-Post: List-Help: List-Unsubscribe: List-Subscribe: Original-Received: (qmail 19485 invoked from network); 31 Aug 2014 00:35:29 -0000 Content-Disposition: inline In-Reply-To: <64bad51d35eea337b8d998a1a2165c5adc440e1d.1409423162.git.Jens.Gustedt@inria.fr> User-Agent: Mutt/1.5.21 (2010-09-15) Original-Sender: Rich Felker Xref: news.gmane.org gmane.linux.lib.musl.general:5996 Archived-At: On Sat, Aug 30, 2014 at 08:47:22PM +0200, Jens Gustedt wrote: > diff --git a/src/thread/cnd_destroy.c b/src/thread/cnd_destroy.c > new file mode 100644 > index 0000000..7c24d1a > --- /dev/null > +++ b/src/thread/cnd_destroy.c > @@ -0,0 +1,5 @@ > +#include > + > +void (cnd_destroy)(cnd_t *cnd) { > + /* For private cv this is a no-op */ > +} Is there a reason for the parens around the name? I'm assuming it was related to a macro definition at some point, but we don't have one now and it seems unlikely that it would be desirable to define away the destroy call to a NOP, in case we ever want to switch to an implementation where NOP is not suitable. > diff --git a/src/thread/cnd_init.c b/src/thread/cnd_init.c > new file mode 100644 > index 0000000..c8aaee5 > --- /dev/null > +++ b/src/thread/cnd_init.c > @@ -0,0 +1,9 @@ > +#include > + > +int cnd_init(cnd_t * c) > +{ > + *c = (cnd_t) { > + 0 > + }; > + return thrd_success; > +} Just style, but generally we use {0} or { 0 } all on one line as a zero-initializer. I would refrain from using multi-line unless (1) we're using designated initializers, not just a universal zero initializer, and (2) multi-line is actually needed for clarity or to avoid exceeding 80 columns. > diff --git a/src/thread/cnd_signal.c b/src/thread/cnd_signal.c > new file mode 100644 > index 0000000..143883c > --- /dev/null > +++ b/src/thread/cnd_signal.c > @@ -0,0 +1,9 @@ > +#include > + > +int __private_cond_signal(cnd_t *, int); > + > +int cnd_signal(cnd_t * cnd) { > + /* This internal function never fails. */ > + (void)__private_cond_signal(cnd, 1); Cast-to-void isn't used in musl source except when it's necessary for types (e.g. in ?:). > + return thrd_success; > +} This would be a candidate for "return thrd_success?thrd_success:ret", I think. Rich