Github messages for voidlinux
 help / color / Atom feed
* Re: [PR PATCH] [Updated] [RFC] xfce4-4.14pre1
       [not found] <gh-mailinglist-notifications-41a7ca26-5023-4802-975b-f1789d68868e-void-packages-11932@inbox.vuxu.org>
  2019-07-02 13:05 ` [PR PATCH] [Updated] [RFC] xfce4-4.14pre1 voidlinux-github
@ 2019-07-02 13:05 ` voidlinux-github
  2019-07-02 13:16 ` [PR PATCH] [Updated] [RFC] xfce4-4.14pre2 voidlinux-github
                   ` (4 subsequent siblings)
  6 siblings, 0 replies; 7+ messages in thread
From: voidlinux-github @ 2019-07-02 13:05 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 723 bytes --]

There is an updated pull request by pbui against master on the void-packages repository

https://github.com/pbui/void-packages xfce4-4.14
https://github.com/void-linux/void-packages/pull/11932

[RFC] xfce4-4.14pre1
This updates the core xfce4 packages to 4.14pre1 status as outlined here:

https://wiki.xfce.org/releng/4.14/xfce_4.14pre1

This also includes some revbumps and updates to packages that depend on xfconf (which has a SO bump).

I'm not sure if we want to update all the packages now, wait until 4.14 is released, or update individual packages on a case-by-case basis.  That is what I am marking this with [RFC].

A patch file from https://github.com/void-linux/void-packages/pull/11932.patch is attached

[-- Warning: decoded text below may be mangled --]
[-- Attachment #2: github-pr-xfce4-4.14-11932.patch --]
[-- Type: application/text/x-diff, Size: 37713 bytes --]

From aa66a9411b6d698026033b6427f08b6c954babb3 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:33:32 -0400
Subject: [PATCH 01/29] xfconf: update to 4.13.8.

- Update common/shlibs for libxfconf-0.so.3
- glib-devel needs to be hostmakedepends for cross-compiling
---
 common/shlibs           | 2 +-
 srcpkgs/xfconf/template | 8 ++++----
 2 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index 22c315708e6..f49e5937f7e 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -179,7 +179,7 @@ libnl-genl-3.so.200 libnl3-3.2.1_1
 libnl-cli-3.so.200 libnl3-3.2.1_1
 libreadline.so.8 libreadline8-8.0_1
 libhistory.so.8 libhistory8-8.0_1
-libxfconf-0.so.2 xfconf-4.9.1_1
+libxfconf-0.so.3 xfconf-4.13.7_1
 libxfce4util.so.7 libxfce4util-4.12.1_1
 libxfce4panel-1.0.so.4 xfce4-panel-4.9.2_1
 libxfce4panel-2.0.so.4 xfce4-panel-4.12.0_1
diff --git a/srcpkgs/xfconf/template b/srcpkgs/xfconf/template
index fb150ff36f1..10605f3d8d1 100644
--- a/srcpkgs/xfconf/template
+++ b/srcpkgs/xfconf/template
@@ -1,18 +1,18 @@
 # Template file for 'xfconf'
 pkgname=xfconf
-version=4.12.1
+version=4.13.8
 revision=1
 build_options="perl"
 build_style=gnu-configure
 configure_args="$(vopt_enable perl 'perl-bindings --with-perl-options=INSTALLDIRS=vendor')"
-hostmakedepends="pkg-config intltool"
-makedepends="dbus-glib-devel libxfce4util-devel $(vopt_if perl 'perl-ExtUtils-Depends perl-ExtUtils-PkgConfig perl-Glib')"
+hostmakedepends="pkg-config intltool glib-devel"
+makedepends="libxfce4util-devel $(vopt_if perl 'perl-ExtUtils-Depends perl-ExtUtils-PkgConfig perl-Glib')"
 short_desc="Xfce hierarchical (tree-like) configuration system"
 maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2, LGPL-2.1"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/xfconf/${version%.*}/$pkgname-$version.tar.bz2"
-checksum=35f48564e5694faa54fdc180cd3268e16fc2352946a89a3c2fc12cbe400ada36
+checksum=55e2441c4ff78a7006fabb59647f7bc1f190cbb82327b93ba063ff624a896591
 
 xfconf-devel_package() {
 	depends="dbus-glib-devel ${sourcepkg}>=${version}_${revision}"

From 58902b9f356fb2a2c23323cd62c00eb4ba54ab35 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Tue, 2 Jul 2019 08:51:42 -0400
Subject: [PATCH 02/29] libxfce4util: update to 4.13.4.

Use gir build helper (for cross-compilation)
---
 srcpkgs/libxfce4util/template | 16 ++++++++++++----
 1 file changed, 12 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/libxfce4util/template b/srcpkgs/libxfce4util/template
index 6c2f3cf4a3b..9ebc4f45422 100644
--- a/srcpkgs/libxfce4util/template
+++ b/srcpkgs/libxfce4util/template
@@ -1,8 +1,9 @@
 # Template file for 'libxfce4util'
 pkgname=libxfce4util
-version=4.12.1
-revision=3
+version=4.13.4
+revision=1
 build_style=gnu-configure
+build_helper="gir"
 hostmakedepends="pkg-config intltool"
 makedepends="libglib-devel"
 short_desc="Utility library for the Xfce4 desktop environment"
@@ -10,7 +11,11 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="LGPL-2.0-or-later"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/$pkgname/${version%.*}/$pkgname-$version.tar.bz2"
-checksum=876bdefa2e13cbf68b626b2158892fb93e824e1ef59cf951123a96cefbc8881d
+checksum=57dd4ba226432afdf98cea4700a4679bb1b57ce80713167f99fde50ad87d0863
+
+# Package build options
+build_options="gir"
+build_options_default="gir"
 
 libxfce4util-devel_package() {
 	depends="libglib-devel ${sourcepkg}>=${version}_${revision}"
@@ -19,6 +24,9 @@ libxfce4util-devel_package() {
 		vmove usr/include
 		vmove usr/lib/pkgconfig
 		vmove usr/share/gtk-doc
-		vmove usr/lib/*.so
+		vmove "usr/lib/*.so"
+		if [ "$build_option_gir" ]; then
+			vmove usr/share/gir-1.0
+		fi
 	}
 }

From a66d5dc5927b07382f5b780a615a1d5e2f937a3f Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:32:15 -0400
Subject: [PATCH 03/29] libxfce4ui: update to 4.13.6.

Use gir build helper (for cross-compilation)
---
 srcpkgs/libxfce4ui/template | 19 +++++++++++--------
 1 file changed, 11 insertions(+), 8 deletions(-)

diff --git a/srcpkgs/libxfce4ui/template b/srcpkgs/libxfce4ui/template
index ac82ac043b3..558dc608995 100644
--- a/srcpkgs/libxfce4ui/template
+++ b/srcpkgs/libxfce4ui/template
@@ -1,24 +1,24 @@
 # Template file for 'libxfce4ui'
 pkgname=libxfce4ui
-version=4.12.1
-revision=3
+version=4.13.6
+revision=1
 build_style=gnu-configure
+build_helper="gir"
 configure_args="--disable-static"
 conf_files="/etc/xdg/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml"
 hostmakedepends="xfce4-dev-tools pkg-config intltool glib-devel gettext-devel"
-makedepends="gtk+-devel gtk+3-devel libxfce4util-devel xfconf-devel dbus-glib-devel
+makedepends="gtk+-devel gtk+3-devel libxfce4util-devel xfconf-devel
  libxml2-devel startup-notification-devel libSM-devel"
 short_desc="Replacement of the old libxfcegui4 library"
 maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="LGPL-2.0-or-later"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=3d619811bfbe7478bb984c16543d980cadd08586365a7bc25e59e3ca6384ff43
+checksum=3c5e505ce56a5993db473efed9962705dd255ffaee17009ed1b3e9f40b543969
 
-pre_configure() {
-	mkdir m4
-	NOCONFIGURE=1 xdt-autogen
-}
+# Package build options
+build_options="gir"
+build_options_default="gir"
 
 libxfce4ui-devel_package() {
 	depends="${makedepends} ${sourcepkg}>=${version}_${revision}"
@@ -28,5 +28,8 @@ libxfce4ui-devel_package() {
 		vmove usr/lib/pkgconfig
 		vmove "usr/lib/*.so"
 		vmove usr/share/gtk-doc
+                if [ "$build_option_gir" ]; then
+                        vmove usr/share/gir-1.0
+                fi
 	}
 }

From daf5cb8d0ec9196ae930b31409000f2d5d8cd051 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:36:47 -0400
Subject: [PATCH 04/29] libwnck: update to 3.32.0.

Switch to meson build style.
---
 srcpkgs/libwnck/template | 13 ++++++-------
 1 file changed, 6 insertions(+), 7 deletions(-)

diff --git a/srcpkgs/libwnck/template b/srcpkgs/libwnck/template
index 1775a4bc55d..83190d54f68 100644
--- a/srcpkgs/libwnck/template
+++ b/srcpkgs/libwnck/template
@@ -1,11 +1,11 @@
 # Template file for 'libwnck'
 pkgname=libwnck
-version=3.30.0
-revision=2
-build_style=gnu-configure
+version=3.32.0
+revision=1
+build_style=meson
 build_helper="gir"
-configure_args="$(vopt_enable gir introspection)"
-hostmakedepends="gdk-pixbuf-devel pkg-config intltool
+#configure_args="$(vopt_enable gir introspection)"
+hostmakedepends="gdk-pixbuf-devel pkg-config intltool glib-devel
  $(vopt_if gir gobject-introspection)"
 makedepends="startup-notification-devel gtk+3-devel libXres-devel"
 short_desc="Library for layout and rendering of text"
@@ -13,7 +13,7 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="LGPL-2.1-or-later"
 homepage="http://www.gnome.org/"
 distfiles="${GNOME_SITE}/${pkgname}/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=ac6d0d2646aa80676d3066651e73abb7bff7ed79be238c9b21a0083e2adc3439
+checksum=9595835cf28d0fc6af5526a18f77f2fcf3ca8c09e36741bb33915b6e69b8e3ca
 
 build_options="gir"
 build_options_default="gir"
@@ -25,7 +25,6 @@ libwnck-devel_package() {
 		vmove usr/include
 		vmove usr/lib/pkgconfig
 		vmove "usr/lib/*.so"
-		vmove usr/share/gtk-doc
 		if [ "$build_option_gir" ]; then
 			vmove usr/share/gir-1.0
 		fi

From c74ebd6c86db372fbde953bf5b60019718fb0b62 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Tue, 2 Jul 2019 08:52:01 -0400
Subject: [PATCH 05/29] xfce4-dev-tools: update to 4.13.0.

---
 srcpkgs/xfce4-dev-tools/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/xfce4-dev-tools/template b/srcpkgs/xfce4-dev-tools/template
index 6e452ee4154..3fe83a41c70 100644
--- a/srcpkgs/xfce4-dev-tools/template
+++ b/srcpkgs/xfce4-dev-tools/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-dev-tools'
 pkgname=xfce4-dev-tools
-version=4.12.0
-revision=2
+version=4.13.0
+revision=1
 build_style=gnu-configure
 hostmakedepends="automake libtool gtk-doc intltool pkg-config"
 makedepends="libglib-devel"
@@ -11,4 +11,4 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=e2e3a654fe9110df81f8c2483c9cbfa6d656fed15d5e5e717d6ef10bd0f5b5cb
+checksum=d24d4db2151a35324c672d4596a6a256f7d92727fe6a9d23648ab53f5207ba3b

From c4c6a1c6efa2a49394a11eaff25fe3b173eccca6 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:37:52 -0400
Subject: [PATCH 06/29] xfce4-panel: update to 4.13.6.

Switch to libwnck, drop dbus-glib, use gir build helper (for cross-compilation)
---
 srcpkgs/xfce4-panel/template | 19 +++++++++++--------
 1 file changed, 11 insertions(+), 8 deletions(-)

diff --git a/srcpkgs/xfce4-panel/template b/srcpkgs/xfce4-panel/template
index ee9c8d5aebc..5a3c55ba164 100644
--- a/srcpkgs/xfce4-panel/template
+++ b/srcpkgs/xfce4-panel/template
@@ -1,23 +1,23 @@
 # Template file for 'xfce4-panel'
 pkgname=xfce4-panel
-version=4.12.2
+version=4.13.6
 revision=1
 build_style=gnu-configure
+build_helper="gir"
 configure_args="--disable-static --enable-gio-unix --enable-gtk3"
 hostmakedepends="xfce4-dev-tools pkg-config intltool gettext-devel glib-devel"
 makedepends="gtk+3-devel libxfce4ui-devel xfconf-devel
- dbus-glib-devel libwnck2-devel garcon-devel exo-devel"
+ libwnck-devel garcon-devel exo-devel"
 short_desc="Next generation panel for the XFCE desktop environment"
 maintainer="Juan RP <xtraeme@voidlinux.org>"
 homepage="https://xfce.org/"
 license="GPL-2"
 distfiles="https://archive.xfce.org/src/xfce/$pkgname/${version%.*}/$pkgname-$version.tar.bz2"
-checksum=42058abb81b8f87691d3999627447de71c3285bcf055f308aab5cefab2de0ce9
+checksum=42411fee7675bb6fb3055395673dc925d43495df93b5e940a1ae3d0a3d2f63a8
 
-pre_configure() {
-	mkdir m4
-	NOCONFIGURE=1 xdt-autogen
-}
+# Package build options
+build_options="gir"
+build_options_default="gir"
 
 xfce4-panel-devel_package() {
 	depends="libxfce4ui-devel ${sourcepkg}>=${version}_${revision}"
@@ -26,6 +26,9 @@ xfce4-panel-devel_package() {
 		vmove usr/include
 		vmove usr/lib/pkgconfig
 		vmove usr/share/gtk-doc
-		vmove usr/lib/*.so
+		vmove "usr/lib/*.so"
+                if [ "$build_option_gir" ]; then
+                        vmove usr/share/gir-1.0
+                fi
 	}
 }

From e9319fb4549abd9494b55e276b04b5a67efe7d56 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:40:46 -0400
Subject: [PATCH 07/29] xfdesktop: update to 4.13.5.

Switch to libwnck, drop dbus-glib
---
 srcpkgs/xfdesktop/template | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/xfdesktop/template b/srcpkgs/xfdesktop/template
index be1056cf50b..7fb2848f4c8 100644
--- a/srcpkgs/xfdesktop/template
+++ b/srcpkgs/xfdesktop/template
@@ -1,16 +1,15 @@
 # Template file for 'xfdesktop'
 pkgname=xfdesktop
-version=4.12.5
+version=4.13.5
 revision=1
 build_style=gnu-configure
-hostmakedepends="pkg-config intltool glib-devel dbus-glib-devel"
-# XXX Add Thunar-devel again once xfdesktop supports the new Thunarx-3 API
+hostmakedepends="pkg-config intltool glib-devel Thunar-devel"
 makedepends="libxfce4ui-devel exo-devel garcon-devel
- libnotify-devel libwnck2-devel"
+ libnotify-devel libwnck-devel"
 depends="hicolor-icon-theme desktop-file-utils"
 short_desc="Desktop manager for the Xfce Desktop Environment"
 maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/xfdesktop/${version%.*}/$pkgname-$version.tar.bz2"
-checksum=3f2426ac28b94cfe5d6fd187c59b4e78f40e66c2842318e158ecd82abe2e7c0a
+checksum=b7d273d36f5f39a446c4d0303148bc595ed7b0f36269619c91526edd1d1caeb6

From 4be7ffe07643bf86d9b462a8dcc1be4d0467ce90 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:41:45 -0400
Subject: [PATCH 08/29] xfwm4: update to 4.13.3.

Switch to libwnck, add Xpresent
---
 srcpkgs/xfwm4/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/xfwm4/template b/srcpkgs/xfwm4/template
index 58d1cc533df..fa2f78ae03e 100644
--- a/srcpkgs/xfwm4/template
+++ b/srcpkgs/xfwm4/template
@@ -1,16 +1,16 @@
 # Template file for 'xfwm4'
 pkgname=xfwm4
-version=4.12.5
+version=4.13.3
 revision=1
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool"
 makedepends="libxfce4ui-devel startup-notification-devel
  libXcomposite-devel libXdamage-devel libXfixes-devel libXrandr-devel
- libXrender-devel dbus-glib-devel libwnck2-devel"
+ libXrender-devel libXpresent-devel libwnck-devel"
 depends="hicolor-icon-theme desktop-file-utils"
 short_desc="Next generation window manager for Xfce"
 maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/xfwm4/${version%.*}/xfwm4-${version}.tar.bz2"
-checksum=7775c02216666c2d023275e7ed6d85e57d965e5cc1407bb6a05c53cc38d8caca
+checksum=12ad274f6662c8afee35fd9b9310e73bd462c423578d448b2d7353e3c8eda6c1

From c0deb78120252f2af06cd5cc2581725a39947da2 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:43:17 -0400
Subject: [PATCH 09/29] thunar-volman: revbump for xfconf

---
 srcpkgs/thunar-volman/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/thunar-volman/template b/srcpkgs/thunar-volman/template
index 15a066edaee..808725a915a 100644
--- a/srcpkgs/thunar-volman/template
+++ b/srcpkgs/thunar-volman/template
@@ -1,7 +1,7 @@
 # Template file for 'thunar-volman'
 pkgname=thunar-volman
 version=0.9.2
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool"
 makedepends="libgudev-devel libnotify-devel libxfce4ui-devel exo-devel"

From 8efe14fbf4e4c374f30df24ec738dbd4222b1d97 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:43:57 -0400
Subject: [PATCH 10/29] xfce4-settings: update to 4.13.7.

---
 srcpkgs/xfce4-settings/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/xfce4-settings/template b/srcpkgs/xfce4-settings/template
index 1944a3acf6e..7f122d774f5 100644
--- a/srcpkgs/xfce4-settings/template
+++ b/srcpkgs/xfce4-settings/template
@@ -1,6 +1,6 @@
 # Template file for 'xfce4-settings'
 pkgname=xfce4-settings
-version=4.12.4
+version=4.13.7
 revision=1
 build_style=gnu-configure
 configure_args="--enable-sound-settings --enable-pluggable-dialogs"
@@ -15,4 +15,4 @@ license="GPL-2.0-only"
 homepage="https://xfce.org/"
 changelog="https://raw.githubusercontent.com/xfce-mirror/xfce4-settings/master/NEWS"
 distfiles="https://archive.xfce.org/src/xfce/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=e2a04cad48bf9e951409d0c841829fa3b4ce632cd799082ef82d0506618b6f9b
+checksum=ac11391eee22cb5fbffe3342916bcf9805f29c722aca825c2f57d98dc167a065

From 9811a79b48cf41b7f4928b20bc9ca1c33bd4361e Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:44:21 -0400
Subject: [PATCH 11/29] xfce4-session: update to 4.13.3.

Switch to libwnck, drop dbus-glib, remove unnecessary --enable-upower
configure flag
---
 srcpkgs/xfce4-session/template | 19 +++++++------------
 1 file changed, 7 insertions(+), 12 deletions(-)

diff --git a/srcpkgs/xfce4-session/template b/srcpkgs/xfce4-session/template
index 6c4b9ecf265..eef01d28e3f 100644
--- a/srcpkgs/xfce4-session/template
+++ b/srcpkgs/xfce4-session/template
@@ -1,12 +1,12 @@
 # Template file for 'xfce4-session'
 pkgname=xfce4-session
-version=4.12.1
-revision=2
+version=4.13.3
+revision=1
 build_style=gnu-configure
-configure_args="--disable-static --enable-upower --enable-polkit"
+configure_args="--disable-static --enable-polkit"
 hostmakedepends="xfce4-dev-tools pkg-config intltool gettext-devel glib-devel iceauth"
-makedepends="libxfce4ui-devel dbus-glib-devel upower-devel
- libwnck2-devel xfce4-panel-devel libSM-devel polkit-devel"
+makedepends="libxfce4ui-devel upower-devel
+ libwnck-devel xfce4-panel-devel libSM-devel polkit-devel"
 depends="iceauth hicolor-icon-theme desktop-file-utils"
 conf_files="/etc/xdg/xfce4/xfconf/xfce-perchannel-xml/xfce4-session.xml"
 short_desc="The session manager for the XFCE desktop environment"
@@ -14,22 +14,17 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/$pkgname/${version%.*}/$pkgname-$version.tar.bz2"
-checksum=97d7f2a2d0af7f3623b68d1f04091e02913b28f9555dab8b0d26c8a1299d08fd
+checksum=eaed34f29aa044d878d60dcb7293a542f48248919e3dcd8df98215121cb6d362
 
-pre_configure() {
-	mkdir m4
-	NOCONFIGURE=1 xdt-autogen
-}
 post_install() {
 	# startxfce4 needs bash.
 	replace_interpreter bash ${DESTDIR}/usr/bin/startxfce4
 }
 
 xfce4-session-devel_package() {
-	depends="libxfce4ui-devel>=4.12 ${sourcepkg}>=${version}_${revision}"
+	depends="libxfce4ui-devel>=4.13 ${sourcepkg}>=${version}_${revision}"
 	short_desc+=" - development files"
 	pkg_install() {
-		vmove usr/include
 		vmove usr/lib/pkgconfig
 		vmove "usr/lib/*.so"
 	}

From ab037ba566d01be3e6927bcd4941ab63d754421a Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:46:36 -0400
Subject: [PATCH 12/29] xfce4-appfinder: update to 4.13.4.

---
 srcpkgs/xfce4-appfinder/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/xfce4-appfinder/template b/srcpkgs/xfce4-appfinder/template
index 0ebe4dd92c7..ef75eb636b6 100644
--- a/srcpkgs/xfce4-appfinder/template
+++ b/srcpkgs/xfce4-appfinder/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-appfinder'
 pkgname=xfce4-appfinder
-version=4.12.0
-revision=3
+version=4.13.4
+revision=1
 build_style=gnu-configure
 configure_args="--enable-gtk3"
 hostmakedepends="pkg-config intltool"
@@ -12,4 +12,4 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=2ad4a58019a76a6b64a816050db25f96854917c2f2e89d6a9df6c18e6c84c567
+checksum=0f4de2a5e2875cfa2862fd73ba1d32fb798df71849f69e68cd28cdde1cf53a02

From bc039f09a4d99710143b1f34cbcb3f9a5d470474 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:47:16 -0400
Subject: [PATCH 13/29] xfce4-clipman-plugin: revbump for xfconf

---
 srcpkgs/xfce4-clipman-plugin/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/xfce4-clipman-plugin/template b/srcpkgs/xfce4-clipman-plugin/template
index 3d973e08e06..987a68f7d5f 100644
--- a/srcpkgs/xfce4-clipman-plugin/template
+++ b/srcpkgs/xfce4-clipman-plugin/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-clipman-plugin'
 pkgname=xfce4-clipman-plugin
 version=1.4.3
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="intltool pkg-config"
 makedepends="xfce4-panel-devel libXtst-devel qrencode-devel"

From 701510064770b03e56a84b4b0e075d621114591f Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:47:43 -0400
Subject: [PATCH 14/29] xfce4-notes-plugin: revbump for xfconf

---
 srcpkgs/xfce4-notes-plugin/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/xfce4-notes-plugin/template b/srcpkgs/xfce4-notes-plugin/template
index ce150733001..1df5d9776e8 100644
--- a/srcpkgs/xfce4-notes-plugin/template
+++ b/srcpkgs/xfce4-notes-plugin/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-notes-plugin'
 pkgname=xfce4-notes-plugin
 version=1.8.1
-revision=2
+revision=3
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool"
 makedepends="xfce4-panel-devel libunique1-devel"

From b2a5d6cfe789db76d22b0cb1e593e4b8fed6a02e Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:48:12 -0400
Subject: [PATCH 15/29] xfce4-notifyd: revbump for xfconf

---
 srcpkgs/xfce4-notifyd/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/xfce4-notifyd/template b/srcpkgs/xfce4-notifyd/template
index cc07838d602..65500dc824e 100644
--- a/srcpkgs/xfce4-notifyd/template
+++ b/srcpkgs/xfce4-notifyd/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-notifyd'
 pkgname=xfce4-notifyd
 version=0.4.4
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool glib-devel dbus-glib-devel"
 makedepends="libnotify-devel xfce4-panel-devel"

From b0a5994608340f29cffac814fbcf44389f95062f Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:49:24 -0400
Subject: [PATCH 16/29] mousepad: remove unnecessary makedepends on
 libxfce4ui-devel

---
 srcpkgs/mousepad/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/mousepad/template b/srcpkgs/mousepad/template
index 54160a9218e..f604781fb34 100644
--- a/srcpkgs/mousepad/template
+++ b/srcpkgs/mousepad/template
@@ -1,10 +1,10 @@
 # Template file for 'mousepad'
 pkgname=mousepad
 version=0.4.1
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="glib-devel intltool pkg-config"
-makedepends="gtksourceview-devel libxfce4ui-devel"
+makedepends="gtksourceview-devel"
 depends="desktop-file-utils hicolor-icon-theme"
 short_desc="Simple text editor for Xfce based on Leafpad"
 maintainer="Juan RP <xtraeme@voidlinux.org>"

From a147b5b408ed10b29ccf1e9fdf58b796b5f4ccda Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:50:10 -0400
Subject: [PATCH 17/29] orage: remove unnecessary makedepends on dbus-glib

---
 srcpkgs/orage/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/orage/template b/srcpkgs/orage/template
index c0a9f23c448..bd0b9fcb6eb 100644
--- a/srcpkgs/orage/template
+++ b/srcpkgs/orage/template
@@ -1,10 +1,10 @@
 # Template file for 'orage'
 pkgname=orage
 version=4.12.1
-revision=3
+revision=4
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool flex"
-makedepends="libical-devel libnotify-devel gtk+-devel dbus-glib-devel
+makedepends="libical-devel libnotify-devel gtk+-devel
  popt-devel xfce4-panel-devel libxfce4util-devel"
 depends="hicolor-icon-theme desktop-file-utils"
 short_desc="Simple calendar application for Xfce"

From 33f9dcc173fc10d8834dfb124cc427518e7d61b2 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:50:51 -0400
Subject: [PATCH 18/29] parole: revbump for xfconf

---
 srcpkgs/parole/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/parole/template b/srcpkgs/parole/template
index efd712729fe..82bdfe94511 100644
--- a/srcpkgs/parole/template
+++ b/srcpkgs/parole/template
@@ -1,7 +1,7 @@
 # Template file for 'parole'
 pkgname=parole
 version=1.0.2
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool glib-devel"
 makedepends="gst-plugins-base1-devel libnotify-devel taglib-devel libxfce4ui-devel"

From 9e85a4acc1e0b8b91e69592fbd806e6c81419e77 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:51:12 -0400
Subject: [PATCH 19/29] ristretto: revbump for xfconf

---
 srcpkgs/ristretto/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/ristretto/template b/srcpkgs/ristretto/template
index 38dbc735472..7e761eb7c57 100644
--- a/srcpkgs/ristretto/template
+++ b/srcpkgs/ristretto/template
@@ -1,7 +1,7 @@
 # Template file for 'ristretto'
 pkgname=ristretto
 version=0.8.4
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="intltool pkg-config"
 makedepends="exo-devel file-devel libexif-devel"

From 2950675236a493e3ea18cfd1c224807a1818c3d8 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:51:31 -0400
Subject: [PATCH 20/29] vala-panel-appmenu: update to 0.7.2

---
 srcpkgs/vala-panel-appmenu/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/vala-panel-appmenu/template b/srcpkgs/vala-panel-appmenu/template
index 47c8b247bba..fa197105c43 100644
--- a/srcpkgs/vala-panel-appmenu/template
+++ b/srcpkgs/vala-panel-appmenu/template
@@ -1,7 +1,7 @@
 # Template file for 'vala-panel-appmenu'
 pkgname=vala-panel-appmenu
-version=0.7.1
-revision=2
+version=0.7.2
+revision=1
 build_style=cmake
 configure_args="-DENABLE_XFCE=ON -DENABLE_VALAPANEL=ON
  -DENABLE_MATE=ON -DENABLE_JAYATANA=OFF -DENABLE_APPMENU_GTK_MODULE=ON"
@@ -15,8 +15,8 @@ short_desc="Global Menu for Vala Panel"
 maintainer="John Eira <john.eira@web.de>"
 license="LGPL-3.0-or-later"
 homepage="https://gitlab.com/vala-panel-project/vala-panel-appmenu"
-distfiles="https://gitlab.com/vala-panel-project/vala-panel-appmenu/uploads/c0f85b42a2a228ad8c3413357e02fb28/vala-panel-appmenu-${version}.tar.xz"
-checksum=54a1b4f6ceca63eb3b79facc4327424bdd82f0fe3b7c6139326dbe0ec0824dcc
+distfiles="https://gitlab.com/vala-panel-project/vala-panel-appmenu/uploads/57fe7a74b38180002154fbd6028075db/vala-panel-appmenu-${version}.tar.xz"
+checksum=80884ebd71b665da7a1eac67752596ecbb29d3a8dd9eee9a2e3212dfc0aab6ae
 
 post_install() {
 	if [ "$CROSS_BUILD" ]; then

From bffb54931ddc448bd9245c846f47df1db30c2ab6 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:52:06 -0400
Subject: [PATCH 21/29] xfce4-places-plugin: update to 1.8.0.

Remove unnecessary patch.
---
 .../patches/undefined-symbol.patch            | 69 -------------------
 srcpkgs/xfce4-places-plugin/template          |  6 +-
 2 files changed, 3 insertions(+), 72 deletions(-)
 delete mode 100644 srcpkgs/xfce4-places-plugin/patches/undefined-symbol.patch

diff --git a/srcpkgs/xfce4-places-plugin/patches/undefined-symbol.patch b/srcpkgs/xfce4-places-plugin/patches/undefined-symbol.patch
deleted file mode 100644
index a94d9ea706f..00000000000
--- a/srcpkgs/xfce4-places-plugin/patches/undefined-symbol.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-From 94d583d0ba257cdc96cde5794ebb7d38001ae3a5 Mon Sep 17 00:00:00 2001
-From: Andrzej <ndrwrdck@gmail.com>
-Date: Tue, 7 Jul 2015 22:26:51 +0100
-Subject: [PATCH] Bug 11939:  xfce4-places-plugin 1.7.0 crashes with undefined
- symbol
-
-Patch from Fedora. Submitted by Kevin Fenzi.
----
- panel-plugin/model.h | 18 +++++++++---------
- 1 file changed, 9 insertions(+), 9 deletions(-)
-
-diff --git a/panel-plugin/model.h b/panel-plugin/model.h
-index 06d9d6f..043e391 100644
---- a/panel-plugin/model.h
-+++ b/panel-plugin/model.h
-@@ -36,13 +36,13 @@ struct _PlacesBookmarkAction
-     void        (*finalize) (PlacesBookmarkAction *self);
- };
- 
--inline PlacesBookmarkAction*
-+extern inline PlacesBookmarkAction*
- places_bookmark_action_create(gchar *label);
- 
--inline void
-+extern inline void
- places_bookmark_action_destroy(PlacesBookmarkAction*);
- 
--inline void
-+extern inline void
- places_bookmark_action_call(PlacesBookmarkAction*);
- 
- /* Places Bookmark */
-@@ -70,10 +70,10 @@ struct _PlacesBookmark
-     void                 (*finalize) (PlacesBookmark *self);
- };
- 
--inline PlacesBookmark*
-+extern inline PlacesBookmark*
- places_bookmark_create(gchar *label);
- 
--inline void
-+extern inline void
- places_bookmark_destroy(PlacesBookmark *bookmark);
- 
- /* Places Bookmark Group */
-@@ -86,16 +86,16 @@ struct _PlacesBookmarkGroup
-     gpointer    priv;
- };
- 
--inline GList*
-+extern inline GList*
- places_bookmark_group_get_bookmarks(PlacesBookmarkGroup*);
- 
--inline gboolean
-+extern inline gboolean
- places_bookmark_group_changed(PlacesBookmarkGroup*);
- 
--inline PlacesBookmarkGroup*
-+extern inline PlacesBookmarkGroup*
- places_bookmark_group_create();
- 
--inline void
-+extern inline void
- places_bookmark_group_destroy(PlacesBookmarkGroup*);
- 
- #endif
--- 
-2.6.4
-
diff --git a/srcpkgs/xfce4-places-plugin/template b/srcpkgs/xfce4-places-plugin/template
index b7f2d8ea2f6..1c1c952a16d 100644
--- a/srcpkgs/xfce4-places-plugin/template
+++ b/srcpkgs/xfce4-places-plugin/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-places-plugin'
 pkgname=xfce4-places-plugin
-version=1.7.0
-revision=3
+version=1.8.0
+revision=1
 build_style=gnu-configure
 hostmakedepends="intltool pkg-config"
 makedepends="exo-devel libglib-devel gtk+-devel libxfce4ui-devel libxfce4util-devel
@@ -11,6 +11,6 @@ maintainer="Steve Prybylski <sa.prybylx@gmail.com>"
 license="GPL-2.0-or-later"
 homepage="https://goodies.xfce.org/projects/panel-plugins/xfce4-places-plugin"
 distfiles="https://archive.xfce.org/src/panel-plugins/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=4175c614749abbb5bcf6f49c88125fb0dd36db69f4c374df23563907b16e2c3f
+checksum=7ba3f46f88c2845cbf413efeefaed29157f8b98571856c6e2bf35e4de5d8ecce
 patch_args="-Np1"
 

From 4bdcc13779fc03595bca9baf726a523cc67f4048 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:52:41 -0400
Subject: [PATCH 22/29] xfce4-power-manager: update to 1.6.3.

---
 srcpkgs/xfce4-power-manager/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/xfce4-power-manager/template b/srcpkgs/xfce4-power-manager/template
index 6b44f4d349f..80f1d396a80 100644
--- a/srcpkgs/xfce4-power-manager/template
+++ b/srcpkgs/xfce4-power-manager/template
@@ -1,6 +1,6 @@
 # Template file for 'xfce4-power-manager'
 pkgname=xfce4-power-manager
-version=1.6.1
+version=1.6.3
 revision=1
 build_style=gnu-configure
 configure_args="--disable-static"
@@ -12,4 +12,4 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/$pkgname/${version%.*}/$pkgname-$version.tar.bz2"
-checksum=1ea825452343b895566068018b6d5078608f8f46ce8075ba6bbb4b848f48656b
+checksum=debd8ac2409b5ac230593894b8bb668298f78bd12891623edbfc32ac87c64011

From 14692cbda277380f406ca43d240ef331594c5531 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:53:06 -0400
Subject: [PATCH 23/29] xfce4-pulseaudio-plugin: revbump for xfconf

---
 srcpkgs/xfce4-pulseaudio-plugin/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/xfce4-pulseaudio-plugin/template b/srcpkgs/xfce4-pulseaudio-plugin/template
index d54728002a6..0ff54c57d27 100644
--- a/srcpkgs/xfce4-pulseaudio-plugin/template
+++ b/srcpkgs/xfce4-pulseaudio-plugin/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-pulseaudio-plugin'
 pkgname=xfce4-pulseaudio-plugin
 version=0.4.1
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="gettext-devel xfce4-dev-tools"
 makedepends="libkeybinder3-devel libnotify-devel pulseaudio-devel xfce4-panel-devel"

From e7406f66d0e967702335a2a5ed278497721ad70e Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:53:28 -0400
Subject: [PATCH 24/29] xfce4-screensaver: revbump for xfconf

---
 srcpkgs/xfce4-screensaver/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/xfce4-screensaver/template b/srcpkgs/xfce4-screensaver/template
index af2dba5fabf..aa45226a504 100644
--- a/srcpkgs/xfce4-screensaver/template
+++ b/srcpkgs/xfce4-screensaver/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-screensaver'
 pkgname=xfce4-screensaver
 version=0.1.4
-revision=1
+revision=2
 build_style=gnu-configure
 configure_args="--without-systemd --with-libgl --with-shadow --with-mit-ext
  --with-xf86gamma-ext --with-x --enable-pam"

From 990c0a2806153894ed3a26c238123bf0cea46b80 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:53:50 -0400
Subject: [PATCH 25/29] xfce4-screenshooter: update to 1.9.5.

---
 srcpkgs/xfce4-screenshooter/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/xfce4-screenshooter/template b/srcpkgs/xfce4-screenshooter/template
index 506544c58c3..860a1ee14d4 100644
--- a/srcpkgs/xfce4-screenshooter/template
+++ b/srcpkgs/xfce4-screenshooter/template
@@ -1,6 +1,6 @@
 # Template file for 'xfce4-screenshooter'
 pkgname=xfce4-screenshooter
-version=1.9.4
+version=1.9.5
 revision=1
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool glib-devel"
@@ -11,4 +11,4 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="https://goodies.xfce.org/projects/applications/xfce4-screenshooter"
 distfiles="https://archive.xfce.org/src/apps/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=c4f3225b3f73f1feb1869807b8b27aec4c32a3e9c2954915a5fb39d18d3a60f2
+checksum=bf35b5432cb920987c6d7ff193600e5dd4d73422b6aa02b4ec5288744053b38c

From 3071a77faeceaf14f72677e716c32af5d21d5763 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:54:20 -0400
Subject: [PATCH 26/29] xfce4-sensors-plugin: update to 1.3.92.

---
 srcpkgs/xfce4-sensors-plugin/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/xfce4-sensors-plugin/template b/srcpkgs/xfce4-sensors-plugin/template
index 4c5053fba55..96b8a00b3af 100644
--- a/srcpkgs/xfce4-sensors-plugin/template
+++ b/srcpkgs/xfce4-sensors-plugin/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-sensors-plugin'
 pkgname=xfce4-sensors-plugin
-version=1.3.0
-revision=2
+version=1.3.92
+revision=1
 build_style=gnu-configure
 configure_args="--disable-static"
 hostmakedepends="pkg-config intltool"
@@ -12,7 +12,7 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="https://goodies.xfce.org/projects/panel-plugins/xfce4-sensors-plugin"
 distfiles="https://archive.xfce.org/src/panel-plugins/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=b7a7834ca84f6751686fa2e20e0b44a2e68ece0cb2716792a765e03b92f65569
+checksum=3dc6643d2c064b7718badff44b948f8d410f00f13db197820b26ae38045f5112
 
 if [ "$CROSS_BUILD" ]; then
 	# Cannot detect these when cross compiling

From acf21efe2da9fab3223611ec0e2f33264ec59c71 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:55:52 -0400
Subject: [PATCH 27/29] xfce4-weather-plugin: update to 0.9.1.

---
 srcpkgs/xfce4-weather-plugin/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/xfce4-weather-plugin/template b/srcpkgs/xfce4-weather-plugin/template
index 8c3bab3185c..e6f9671ba6a 100644
--- a/srcpkgs/xfce4-weather-plugin/template
+++ b/srcpkgs/xfce4-weather-plugin/template
@@ -1,6 +1,6 @@
 # Template file for 'xfce4-weather-plugin'
 pkgname=xfce4-weather-plugin
-version=0.8.11
+version=0.9.1
 revision=1
 build_style=gnu-configure
 configure_args="--disable-upower"
@@ -12,5 +12,5 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="https://goodies.xfce.org/projects/panel-plugins/xfce4-weather-plugin"
 distfiles="https://archive.xfce.org/src/panel-plugins/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=0382ce99c0ad4424afe7096a354f301a9396d12807a0f2ab041912d6ab58145d
+checksum=7cdc18b8df759dee4ceaaf6ce303eff7fda48e247dbc26b78142929213506cfd
 lib32disabled=yes

From 7a127e7ee2676d91d3f1f9500047f4b002b5e68b Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:56:18 -0400
Subject: [PATCH 28/29] xfce4-windowck-plugin: update to 0.4.6.

---
 srcpkgs/xfce4-windowck-plugin/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/xfce4-windowck-plugin/template b/srcpkgs/xfce4-windowck-plugin/template
index 355ae97ad5d..5d897ba7154 100644
--- a/srcpkgs/xfce4-windowck-plugin/template
+++ b/srcpkgs/xfce4-windowck-plugin/template
@@ -1,17 +1,17 @@
 # Template file for 'xfce4-windowck-plugin'
 pkgname=xfce4-windowck-plugin
-version=0.4.4
-revision=2
+version=0.4.6
+revision=1
 build_style=gnu-makefile
 hostmakedepends="intltool xfce4-dev-tools exo-devel python3-devel glib-devel gettext-devel ImageMagick"
 makedepends="libwnck2-devel xfce4-panel-devel xorg-server-devel"
-depends="xfce4-panel>=4.10"
+depends="xfce4-panel>=4.13"
 short_desc="Puts the titlebar of a maximized window into a panel"
 maintainer="skurtix <skurtix@github.com>"
 homepage="https://github.com/cedl38/xfce4-windowck-plugin"
 license="GPL-3"
 distfiles="${homepage}/archive/v${version}.tar.gz"
-checksum=92b6c9e199d32cf96619c31e2cfac19e375575d581e78fa043f9f6a59c1df13f
+checksum=1643fa4a8bdbc401160fae6a132dcab89ed88d10231f84ed058f7a3e842763f7
 
 pre_configure() {
 	autogen_args="--prefix=/usr"

From 3075e0a35c5f4e918e45d3d2b29d5c7ff7c9bdf2 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:56:43 -0400
Subject: [PATCH 29/29] xfce4-xkb-plugin: revbump for xfconf

---
 srcpkgs/xfce4-xkb-plugin/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/xfce4-xkb-plugin/template b/srcpkgs/xfce4-xkb-plugin/template
index 30ec3089bbb..d64ee2670ee 100644
--- a/srcpkgs/xfce4-xkb-plugin/template
+++ b/srcpkgs/xfce4-xkb-plugin/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-xkb-plugin'
 pkgname=xfce4-xkb-plugin
 version=0.8.1
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool"
 makedepends="garcon-devel xfce4-panel-devel libxklavier-devel librsvg-devel libwnck-devel"

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PR PATCH] [Updated] [RFC] xfce4-4.14pre1
       [not found] <gh-mailinglist-notifications-41a7ca26-5023-4802-975b-f1789d68868e-void-packages-11932@inbox.vuxu.org>
@ 2019-07-02 13:05 ` voidlinux-github
  2019-07-02 13:05 ` voidlinux-github
                   ` (5 subsequent siblings)
  6 siblings, 0 replies; 7+ messages in thread
From: voidlinux-github @ 2019-07-02 13:05 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 723 bytes --]

There is an updated pull request by pbui against master on the void-packages repository

https://github.com/pbui/void-packages xfce4-4.14
https://github.com/void-linux/void-packages/pull/11932

[RFC] xfce4-4.14pre1
This updates the core xfce4 packages to 4.14pre1 status as outlined here:

https://wiki.xfce.org/releng/4.14/xfce_4.14pre1

This also includes some revbumps and updates to packages that depend on xfconf (which has a SO bump).

I'm not sure if we want to update all the packages now, wait until 4.14 is released, or update individual packages on a case-by-case basis.  That is what I am marking this with [RFC].

A patch file from https://github.com/void-linux/void-packages/pull/11932.patch is attached

[-- Warning: decoded text below may be mangled --]
[-- Attachment #2: github-pr-xfce4-4.14-11932.patch --]
[-- Type: application/text/x-diff, Size: 37713 bytes --]

From aa66a9411b6d698026033b6427f08b6c954babb3 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:33:32 -0400
Subject: [PATCH 01/29] xfconf: update to 4.13.8.

- Update common/shlibs for libxfconf-0.so.3
- glib-devel needs to be hostmakedepends for cross-compiling
---
 common/shlibs           | 2 +-
 srcpkgs/xfconf/template | 8 ++++----
 2 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index 22c315708e6..f49e5937f7e 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -179,7 +179,7 @@ libnl-genl-3.so.200 libnl3-3.2.1_1
 libnl-cli-3.so.200 libnl3-3.2.1_1
 libreadline.so.8 libreadline8-8.0_1
 libhistory.so.8 libhistory8-8.0_1
-libxfconf-0.so.2 xfconf-4.9.1_1
+libxfconf-0.so.3 xfconf-4.13.7_1
 libxfce4util.so.7 libxfce4util-4.12.1_1
 libxfce4panel-1.0.so.4 xfce4-panel-4.9.2_1
 libxfce4panel-2.0.so.4 xfce4-panel-4.12.0_1
diff --git a/srcpkgs/xfconf/template b/srcpkgs/xfconf/template
index fb150ff36f1..10605f3d8d1 100644
--- a/srcpkgs/xfconf/template
+++ b/srcpkgs/xfconf/template
@@ -1,18 +1,18 @@
 # Template file for 'xfconf'
 pkgname=xfconf
-version=4.12.1
+version=4.13.8
 revision=1
 build_options="perl"
 build_style=gnu-configure
 configure_args="$(vopt_enable perl 'perl-bindings --with-perl-options=INSTALLDIRS=vendor')"
-hostmakedepends="pkg-config intltool"
-makedepends="dbus-glib-devel libxfce4util-devel $(vopt_if perl 'perl-ExtUtils-Depends perl-ExtUtils-PkgConfig perl-Glib')"
+hostmakedepends="pkg-config intltool glib-devel"
+makedepends="libxfce4util-devel $(vopt_if perl 'perl-ExtUtils-Depends perl-ExtUtils-PkgConfig perl-Glib')"
 short_desc="Xfce hierarchical (tree-like) configuration system"
 maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2, LGPL-2.1"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/xfconf/${version%.*}/$pkgname-$version.tar.bz2"
-checksum=35f48564e5694faa54fdc180cd3268e16fc2352946a89a3c2fc12cbe400ada36
+checksum=55e2441c4ff78a7006fabb59647f7bc1f190cbb82327b93ba063ff624a896591
 
 xfconf-devel_package() {
 	depends="dbus-glib-devel ${sourcepkg}>=${version}_${revision}"

From 58902b9f356fb2a2c23323cd62c00eb4ba54ab35 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Tue, 2 Jul 2019 08:51:42 -0400
Subject: [PATCH 02/29] libxfce4util: update to 4.13.4.

Use gir build helper (for cross-compilation)
---
 srcpkgs/libxfce4util/template | 16 ++++++++++++----
 1 file changed, 12 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/libxfce4util/template b/srcpkgs/libxfce4util/template
index 6c2f3cf4a3b..9ebc4f45422 100644
--- a/srcpkgs/libxfce4util/template
+++ b/srcpkgs/libxfce4util/template
@@ -1,8 +1,9 @@
 # Template file for 'libxfce4util'
 pkgname=libxfce4util
-version=4.12.1
-revision=3
+version=4.13.4
+revision=1
 build_style=gnu-configure
+build_helper="gir"
 hostmakedepends="pkg-config intltool"
 makedepends="libglib-devel"
 short_desc="Utility library for the Xfce4 desktop environment"
@@ -10,7 +11,11 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="LGPL-2.0-or-later"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/$pkgname/${version%.*}/$pkgname-$version.tar.bz2"
-checksum=876bdefa2e13cbf68b626b2158892fb93e824e1ef59cf951123a96cefbc8881d
+checksum=57dd4ba226432afdf98cea4700a4679bb1b57ce80713167f99fde50ad87d0863
+
+# Package build options
+build_options="gir"
+build_options_default="gir"
 
 libxfce4util-devel_package() {
 	depends="libglib-devel ${sourcepkg}>=${version}_${revision}"
@@ -19,6 +24,9 @@ libxfce4util-devel_package() {
 		vmove usr/include
 		vmove usr/lib/pkgconfig
 		vmove usr/share/gtk-doc
-		vmove usr/lib/*.so
+		vmove "usr/lib/*.so"
+		if [ "$build_option_gir" ]; then
+			vmove usr/share/gir-1.0
+		fi
 	}
 }

From a66d5dc5927b07382f5b780a615a1d5e2f937a3f Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:32:15 -0400
Subject: [PATCH 03/29] libxfce4ui: update to 4.13.6.

Use gir build helper (for cross-compilation)
---
 srcpkgs/libxfce4ui/template | 19 +++++++++++--------
 1 file changed, 11 insertions(+), 8 deletions(-)

diff --git a/srcpkgs/libxfce4ui/template b/srcpkgs/libxfce4ui/template
index ac82ac043b3..558dc608995 100644
--- a/srcpkgs/libxfce4ui/template
+++ b/srcpkgs/libxfce4ui/template
@@ -1,24 +1,24 @@
 # Template file for 'libxfce4ui'
 pkgname=libxfce4ui
-version=4.12.1
-revision=3
+version=4.13.6
+revision=1
 build_style=gnu-configure
+build_helper="gir"
 configure_args="--disable-static"
 conf_files="/etc/xdg/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml"
 hostmakedepends="xfce4-dev-tools pkg-config intltool glib-devel gettext-devel"
-makedepends="gtk+-devel gtk+3-devel libxfce4util-devel xfconf-devel dbus-glib-devel
+makedepends="gtk+-devel gtk+3-devel libxfce4util-devel xfconf-devel
  libxml2-devel startup-notification-devel libSM-devel"
 short_desc="Replacement of the old libxfcegui4 library"
 maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="LGPL-2.0-or-later"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=3d619811bfbe7478bb984c16543d980cadd08586365a7bc25e59e3ca6384ff43
+checksum=3c5e505ce56a5993db473efed9962705dd255ffaee17009ed1b3e9f40b543969
 
-pre_configure() {
-	mkdir m4
-	NOCONFIGURE=1 xdt-autogen
-}
+# Package build options
+build_options="gir"
+build_options_default="gir"
 
 libxfce4ui-devel_package() {
 	depends="${makedepends} ${sourcepkg}>=${version}_${revision}"
@@ -28,5 +28,8 @@ libxfce4ui-devel_package() {
 		vmove usr/lib/pkgconfig
 		vmove "usr/lib/*.so"
 		vmove usr/share/gtk-doc
+                if [ "$build_option_gir" ]; then
+                        vmove usr/share/gir-1.0
+                fi
 	}
 }

From daf5cb8d0ec9196ae930b31409000f2d5d8cd051 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:36:47 -0400
Subject: [PATCH 04/29] libwnck: update to 3.32.0.

Switch to meson build style.
---
 srcpkgs/libwnck/template | 13 ++++++-------
 1 file changed, 6 insertions(+), 7 deletions(-)

diff --git a/srcpkgs/libwnck/template b/srcpkgs/libwnck/template
index 1775a4bc55d..83190d54f68 100644
--- a/srcpkgs/libwnck/template
+++ b/srcpkgs/libwnck/template
@@ -1,11 +1,11 @@
 # Template file for 'libwnck'
 pkgname=libwnck
-version=3.30.0
-revision=2
-build_style=gnu-configure
+version=3.32.0
+revision=1
+build_style=meson
 build_helper="gir"
-configure_args="$(vopt_enable gir introspection)"
-hostmakedepends="gdk-pixbuf-devel pkg-config intltool
+#configure_args="$(vopt_enable gir introspection)"
+hostmakedepends="gdk-pixbuf-devel pkg-config intltool glib-devel
  $(vopt_if gir gobject-introspection)"
 makedepends="startup-notification-devel gtk+3-devel libXres-devel"
 short_desc="Library for layout and rendering of text"
@@ -13,7 +13,7 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="LGPL-2.1-or-later"
 homepage="http://www.gnome.org/"
 distfiles="${GNOME_SITE}/${pkgname}/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=ac6d0d2646aa80676d3066651e73abb7bff7ed79be238c9b21a0083e2adc3439
+checksum=9595835cf28d0fc6af5526a18f77f2fcf3ca8c09e36741bb33915b6e69b8e3ca
 
 build_options="gir"
 build_options_default="gir"
@@ -25,7 +25,6 @@ libwnck-devel_package() {
 		vmove usr/include
 		vmove usr/lib/pkgconfig
 		vmove "usr/lib/*.so"
-		vmove usr/share/gtk-doc
 		if [ "$build_option_gir" ]; then
 			vmove usr/share/gir-1.0
 		fi

From c74ebd6c86db372fbde953bf5b60019718fb0b62 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Tue, 2 Jul 2019 08:52:01 -0400
Subject: [PATCH 05/29] xfce4-dev-tools: update to 4.13.0.

---
 srcpkgs/xfce4-dev-tools/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/xfce4-dev-tools/template b/srcpkgs/xfce4-dev-tools/template
index 6e452ee4154..3fe83a41c70 100644
--- a/srcpkgs/xfce4-dev-tools/template
+++ b/srcpkgs/xfce4-dev-tools/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-dev-tools'
 pkgname=xfce4-dev-tools
-version=4.12.0
-revision=2
+version=4.13.0
+revision=1
 build_style=gnu-configure
 hostmakedepends="automake libtool gtk-doc intltool pkg-config"
 makedepends="libglib-devel"
@@ -11,4 +11,4 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=e2e3a654fe9110df81f8c2483c9cbfa6d656fed15d5e5e717d6ef10bd0f5b5cb
+checksum=d24d4db2151a35324c672d4596a6a256f7d92727fe6a9d23648ab53f5207ba3b

From c4c6a1c6efa2a49394a11eaff25fe3b173eccca6 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:37:52 -0400
Subject: [PATCH 06/29] xfce4-panel: update to 4.13.6.

Switch to libwnck, drop dbus-glib, use gir build helper (for cross-compilation)
---
 srcpkgs/xfce4-panel/template | 19 +++++++++++--------
 1 file changed, 11 insertions(+), 8 deletions(-)

diff --git a/srcpkgs/xfce4-panel/template b/srcpkgs/xfce4-panel/template
index ee9c8d5aebc..5a3c55ba164 100644
--- a/srcpkgs/xfce4-panel/template
+++ b/srcpkgs/xfce4-panel/template
@@ -1,23 +1,23 @@
 # Template file for 'xfce4-panel'
 pkgname=xfce4-panel
-version=4.12.2
+version=4.13.6
 revision=1
 build_style=gnu-configure
+build_helper="gir"
 configure_args="--disable-static --enable-gio-unix --enable-gtk3"
 hostmakedepends="xfce4-dev-tools pkg-config intltool gettext-devel glib-devel"
 makedepends="gtk+3-devel libxfce4ui-devel xfconf-devel
- dbus-glib-devel libwnck2-devel garcon-devel exo-devel"
+ libwnck-devel garcon-devel exo-devel"
 short_desc="Next generation panel for the XFCE desktop environment"
 maintainer="Juan RP <xtraeme@voidlinux.org>"
 homepage="https://xfce.org/"
 license="GPL-2"
 distfiles="https://archive.xfce.org/src/xfce/$pkgname/${version%.*}/$pkgname-$version.tar.bz2"
-checksum=42058abb81b8f87691d3999627447de71c3285bcf055f308aab5cefab2de0ce9
+checksum=42411fee7675bb6fb3055395673dc925d43495df93b5e940a1ae3d0a3d2f63a8
 
-pre_configure() {
-	mkdir m4
-	NOCONFIGURE=1 xdt-autogen
-}
+# Package build options
+build_options="gir"
+build_options_default="gir"
 
 xfce4-panel-devel_package() {
 	depends="libxfce4ui-devel ${sourcepkg}>=${version}_${revision}"
@@ -26,6 +26,9 @@ xfce4-panel-devel_package() {
 		vmove usr/include
 		vmove usr/lib/pkgconfig
 		vmove usr/share/gtk-doc
-		vmove usr/lib/*.so
+		vmove "usr/lib/*.so"
+                if [ "$build_option_gir" ]; then
+                        vmove usr/share/gir-1.0
+                fi
 	}
 }

From e9319fb4549abd9494b55e276b04b5a67efe7d56 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:40:46 -0400
Subject: [PATCH 07/29] xfdesktop: update to 4.13.5.

Switch to libwnck, drop dbus-glib
---
 srcpkgs/xfdesktop/template | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/xfdesktop/template b/srcpkgs/xfdesktop/template
index be1056cf50b..7fb2848f4c8 100644
--- a/srcpkgs/xfdesktop/template
+++ b/srcpkgs/xfdesktop/template
@@ -1,16 +1,15 @@
 # Template file for 'xfdesktop'
 pkgname=xfdesktop
-version=4.12.5
+version=4.13.5
 revision=1
 build_style=gnu-configure
-hostmakedepends="pkg-config intltool glib-devel dbus-glib-devel"
-# XXX Add Thunar-devel again once xfdesktop supports the new Thunarx-3 API
+hostmakedepends="pkg-config intltool glib-devel Thunar-devel"
 makedepends="libxfce4ui-devel exo-devel garcon-devel
- libnotify-devel libwnck2-devel"
+ libnotify-devel libwnck-devel"
 depends="hicolor-icon-theme desktop-file-utils"
 short_desc="Desktop manager for the Xfce Desktop Environment"
 maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/xfdesktop/${version%.*}/$pkgname-$version.tar.bz2"
-checksum=3f2426ac28b94cfe5d6fd187c59b4e78f40e66c2842318e158ecd82abe2e7c0a
+checksum=b7d273d36f5f39a446c4d0303148bc595ed7b0f36269619c91526edd1d1caeb6

From 4be7ffe07643bf86d9b462a8dcc1be4d0467ce90 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:41:45 -0400
Subject: [PATCH 08/29] xfwm4: update to 4.13.3.

Switch to libwnck, add Xpresent
---
 srcpkgs/xfwm4/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/xfwm4/template b/srcpkgs/xfwm4/template
index 58d1cc533df..fa2f78ae03e 100644
--- a/srcpkgs/xfwm4/template
+++ b/srcpkgs/xfwm4/template
@@ -1,16 +1,16 @@
 # Template file for 'xfwm4'
 pkgname=xfwm4
-version=4.12.5
+version=4.13.3
 revision=1
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool"
 makedepends="libxfce4ui-devel startup-notification-devel
  libXcomposite-devel libXdamage-devel libXfixes-devel libXrandr-devel
- libXrender-devel dbus-glib-devel libwnck2-devel"
+ libXrender-devel libXpresent-devel libwnck-devel"
 depends="hicolor-icon-theme desktop-file-utils"
 short_desc="Next generation window manager for Xfce"
 maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/xfwm4/${version%.*}/xfwm4-${version}.tar.bz2"
-checksum=7775c02216666c2d023275e7ed6d85e57d965e5cc1407bb6a05c53cc38d8caca
+checksum=12ad274f6662c8afee35fd9b9310e73bd462c423578d448b2d7353e3c8eda6c1

From c0deb78120252f2af06cd5cc2581725a39947da2 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:43:17 -0400
Subject: [PATCH 09/29] thunar-volman: revbump for xfconf

---
 srcpkgs/thunar-volman/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/thunar-volman/template b/srcpkgs/thunar-volman/template
index 15a066edaee..808725a915a 100644
--- a/srcpkgs/thunar-volman/template
+++ b/srcpkgs/thunar-volman/template
@@ -1,7 +1,7 @@
 # Template file for 'thunar-volman'
 pkgname=thunar-volman
 version=0.9.2
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool"
 makedepends="libgudev-devel libnotify-devel libxfce4ui-devel exo-devel"

From 8efe14fbf4e4c374f30df24ec738dbd4222b1d97 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:43:57 -0400
Subject: [PATCH 10/29] xfce4-settings: update to 4.13.7.

---
 srcpkgs/xfce4-settings/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/xfce4-settings/template b/srcpkgs/xfce4-settings/template
index 1944a3acf6e..7f122d774f5 100644
--- a/srcpkgs/xfce4-settings/template
+++ b/srcpkgs/xfce4-settings/template
@@ -1,6 +1,6 @@
 # Template file for 'xfce4-settings'
 pkgname=xfce4-settings
-version=4.12.4
+version=4.13.7
 revision=1
 build_style=gnu-configure
 configure_args="--enable-sound-settings --enable-pluggable-dialogs"
@@ -15,4 +15,4 @@ license="GPL-2.0-only"
 homepage="https://xfce.org/"
 changelog="https://raw.githubusercontent.com/xfce-mirror/xfce4-settings/master/NEWS"
 distfiles="https://archive.xfce.org/src/xfce/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=e2a04cad48bf9e951409d0c841829fa3b4ce632cd799082ef82d0506618b6f9b
+checksum=ac11391eee22cb5fbffe3342916bcf9805f29c722aca825c2f57d98dc167a065

From 9811a79b48cf41b7f4928b20bc9ca1c33bd4361e Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:44:21 -0400
Subject: [PATCH 11/29] xfce4-session: update to 4.13.3.

Switch to libwnck, drop dbus-glib, remove unnecessary --enable-upower
configure flag
---
 srcpkgs/xfce4-session/template | 19 +++++++------------
 1 file changed, 7 insertions(+), 12 deletions(-)

diff --git a/srcpkgs/xfce4-session/template b/srcpkgs/xfce4-session/template
index 6c4b9ecf265..eef01d28e3f 100644
--- a/srcpkgs/xfce4-session/template
+++ b/srcpkgs/xfce4-session/template
@@ -1,12 +1,12 @@
 # Template file for 'xfce4-session'
 pkgname=xfce4-session
-version=4.12.1
-revision=2
+version=4.13.3
+revision=1
 build_style=gnu-configure
-configure_args="--disable-static --enable-upower --enable-polkit"
+configure_args="--disable-static --enable-polkit"
 hostmakedepends="xfce4-dev-tools pkg-config intltool gettext-devel glib-devel iceauth"
-makedepends="libxfce4ui-devel dbus-glib-devel upower-devel
- libwnck2-devel xfce4-panel-devel libSM-devel polkit-devel"
+makedepends="libxfce4ui-devel upower-devel
+ libwnck-devel xfce4-panel-devel libSM-devel polkit-devel"
 depends="iceauth hicolor-icon-theme desktop-file-utils"
 conf_files="/etc/xdg/xfce4/xfconf/xfce-perchannel-xml/xfce4-session.xml"
 short_desc="The session manager for the XFCE desktop environment"
@@ -14,22 +14,17 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/$pkgname/${version%.*}/$pkgname-$version.tar.bz2"
-checksum=97d7f2a2d0af7f3623b68d1f04091e02913b28f9555dab8b0d26c8a1299d08fd
+checksum=eaed34f29aa044d878d60dcb7293a542f48248919e3dcd8df98215121cb6d362
 
-pre_configure() {
-	mkdir m4
-	NOCONFIGURE=1 xdt-autogen
-}
 post_install() {
 	# startxfce4 needs bash.
 	replace_interpreter bash ${DESTDIR}/usr/bin/startxfce4
 }
 
 xfce4-session-devel_package() {
-	depends="libxfce4ui-devel>=4.12 ${sourcepkg}>=${version}_${revision}"
+	depends="libxfce4ui-devel>=4.13 ${sourcepkg}>=${version}_${revision}"
 	short_desc+=" - development files"
 	pkg_install() {
-		vmove usr/include
 		vmove usr/lib/pkgconfig
 		vmove "usr/lib/*.so"
 	}

From ab037ba566d01be3e6927bcd4941ab63d754421a Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:46:36 -0400
Subject: [PATCH 12/29] xfce4-appfinder: update to 4.13.4.

---
 srcpkgs/xfce4-appfinder/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/xfce4-appfinder/template b/srcpkgs/xfce4-appfinder/template
index 0ebe4dd92c7..ef75eb636b6 100644
--- a/srcpkgs/xfce4-appfinder/template
+++ b/srcpkgs/xfce4-appfinder/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-appfinder'
 pkgname=xfce4-appfinder
-version=4.12.0
-revision=3
+version=4.13.4
+revision=1
 build_style=gnu-configure
 configure_args="--enable-gtk3"
 hostmakedepends="pkg-config intltool"
@@ -12,4 +12,4 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=2ad4a58019a76a6b64a816050db25f96854917c2f2e89d6a9df6c18e6c84c567
+checksum=0f4de2a5e2875cfa2862fd73ba1d32fb798df71849f69e68cd28cdde1cf53a02

From bc039f09a4d99710143b1f34cbcb3f9a5d470474 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:47:16 -0400
Subject: [PATCH 13/29] xfce4-clipman-plugin: revbump for xfconf

---
 srcpkgs/xfce4-clipman-plugin/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/xfce4-clipman-plugin/template b/srcpkgs/xfce4-clipman-plugin/template
index 3d973e08e06..987a68f7d5f 100644
--- a/srcpkgs/xfce4-clipman-plugin/template
+++ b/srcpkgs/xfce4-clipman-plugin/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-clipman-plugin'
 pkgname=xfce4-clipman-plugin
 version=1.4.3
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="intltool pkg-config"
 makedepends="xfce4-panel-devel libXtst-devel qrencode-devel"

From 701510064770b03e56a84b4b0e075d621114591f Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:47:43 -0400
Subject: [PATCH 14/29] xfce4-notes-plugin: revbump for xfconf

---
 srcpkgs/xfce4-notes-plugin/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/xfce4-notes-plugin/template b/srcpkgs/xfce4-notes-plugin/template
index ce150733001..1df5d9776e8 100644
--- a/srcpkgs/xfce4-notes-plugin/template
+++ b/srcpkgs/xfce4-notes-plugin/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-notes-plugin'
 pkgname=xfce4-notes-plugin
 version=1.8.1
-revision=2
+revision=3
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool"
 makedepends="xfce4-panel-devel libunique1-devel"

From b2a5d6cfe789db76d22b0cb1e593e4b8fed6a02e Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:48:12 -0400
Subject: [PATCH 15/29] xfce4-notifyd: revbump for xfconf

---
 srcpkgs/xfce4-notifyd/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/xfce4-notifyd/template b/srcpkgs/xfce4-notifyd/template
index cc07838d602..65500dc824e 100644
--- a/srcpkgs/xfce4-notifyd/template
+++ b/srcpkgs/xfce4-notifyd/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-notifyd'
 pkgname=xfce4-notifyd
 version=0.4.4
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool glib-devel dbus-glib-devel"
 makedepends="libnotify-devel xfce4-panel-devel"

From b0a5994608340f29cffac814fbcf44389f95062f Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:49:24 -0400
Subject: [PATCH 16/29] mousepad: remove unnecessary makedepends on
 libxfce4ui-devel

---
 srcpkgs/mousepad/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/mousepad/template b/srcpkgs/mousepad/template
index 54160a9218e..f604781fb34 100644
--- a/srcpkgs/mousepad/template
+++ b/srcpkgs/mousepad/template
@@ -1,10 +1,10 @@
 # Template file for 'mousepad'
 pkgname=mousepad
 version=0.4.1
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="glib-devel intltool pkg-config"
-makedepends="gtksourceview-devel libxfce4ui-devel"
+makedepends="gtksourceview-devel"
 depends="desktop-file-utils hicolor-icon-theme"
 short_desc="Simple text editor for Xfce based on Leafpad"
 maintainer="Juan RP <xtraeme@voidlinux.org>"

From a147b5b408ed10b29ccf1e9fdf58b796b5f4ccda Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:50:10 -0400
Subject: [PATCH 17/29] orage: remove unnecessary makedepends on dbus-glib

---
 srcpkgs/orage/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/orage/template b/srcpkgs/orage/template
index c0a9f23c448..bd0b9fcb6eb 100644
--- a/srcpkgs/orage/template
+++ b/srcpkgs/orage/template
@@ -1,10 +1,10 @@
 # Template file for 'orage'
 pkgname=orage
 version=4.12.1
-revision=3
+revision=4
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool flex"
-makedepends="libical-devel libnotify-devel gtk+-devel dbus-glib-devel
+makedepends="libical-devel libnotify-devel gtk+-devel
  popt-devel xfce4-panel-devel libxfce4util-devel"
 depends="hicolor-icon-theme desktop-file-utils"
 short_desc="Simple calendar application for Xfce"

From 33f9dcc173fc10d8834dfb124cc427518e7d61b2 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:50:51 -0400
Subject: [PATCH 18/29] parole: revbump for xfconf

---
 srcpkgs/parole/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/parole/template b/srcpkgs/parole/template
index efd712729fe..82bdfe94511 100644
--- a/srcpkgs/parole/template
+++ b/srcpkgs/parole/template
@@ -1,7 +1,7 @@
 # Template file for 'parole'
 pkgname=parole
 version=1.0.2
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool glib-devel"
 makedepends="gst-plugins-base1-devel libnotify-devel taglib-devel libxfce4ui-devel"

From 9e85a4acc1e0b8b91e69592fbd806e6c81419e77 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:51:12 -0400
Subject: [PATCH 19/29] ristretto: revbump for xfconf

---
 srcpkgs/ristretto/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/ristretto/template b/srcpkgs/ristretto/template
index 38dbc735472..7e761eb7c57 100644
--- a/srcpkgs/ristretto/template
+++ b/srcpkgs/ristretto/template
@@ -1,7 +1,7 @@
 # Template file for 'ristretto'
 pkgname=ristretto
 version=0.8.4
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="intltool pkg-config"
 makedepends="exo-devel file-devel libexif-devel"

From 2950675236a493e3ea18cfd1c224807a1818c3d8 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:51:31 -0400
Subject: [PATCH 20/29] vala-panel-appmenu: update to 0.7.2

---
 srcpkgs/vala-panel-appmenu/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/vala-panel-appmenu/template b/srcpkgs/vala-panel-appmenu/template
index 47c8b247bba..fa197105c43 100644
--- a/srcpkgs/vala-panel-appmenu/template
+++ b/srcpkgs/vala-panel-appmenu/template
@@ -1,7 +1,7 @@
 # Template file for 'vala-panel-appmenu'
 pkgname=vala-panel-appmenu
-version=0.7.1
-revision=2
+version=0.7.2
+revision=1
 build_style=cmake
 configure_args="-DENABLE_XFCE=ON -DENABLE_VALAPANEL=ON
  -DENABLE_MATE=ON -DENABLE_JAYATANA=OFF -DENABLE_APPMENU_GTK_MODULE=ON"
@@ -15,8 +15,8 @@ short_desc="Global Menu for Vala Panel"
 maintainer="John Eira <john.eira@web.de>"
 license="LGPL-3.0-or-later"
 homepage="https://gitlab.com/vala-panel-project/vala-panel-appmenu"
-distfiles="https://gitlab.com/vala-panel-project/vala-panel-appmenu/uploads/c0f85b42a2a228ad8c3413357e02fb28/vala-panel-appmenu-${version}.tar.xz"
-checksum=54a1b4f6ceca63eb3b79facc4327424bdd82f0fe3b7c6139326dbe0ec0824dcc
+distfiles="https://gitlab.com/vala-panel-project/vala-panel-appmenu/uploads/57fe7a74b38180002154fbd6028075db/vala-panel-appmenu-${version}.tar.xz"
+checksum=80884ebd71b665da7a1eac67752596ecbb29d3a8dd9eee9a2e3212dfc0aab6ae
 
 post_install() {
 	if [ "$CROSS_BUILD" ]; then

From bffb54931ddc448bd9245c846f47df1db30c2ab6 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:52:06 -0400
Subject: [PATCH 21/29] xfce4-places-plugin: update to 1.8.0.

Remove unnecessary patch.
---
 .../patches/undefined-symbol.patch            | 69 -------------------
 srcpkgs/xfce4-places-plugin/template          |  6 +-
 2 files changed, 3 insertions(+), 72 deletions(-)
 delete mode 100644 srcpkgs/xfce4-places-plugin/patches/undefined-symbol.patch

diff --git a/srcpkgs/xfce4-places-plugin/patches/undefined-symbol.patch b/srcpkgs/xfce4-places-plugin/patches/undefined-symbol.patch
deleted file mode 100644
index a94d9ea706f..00000000000
--- a/srcpkgs/xfce4-places-plugin/patches/undefined-symbol.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-From 94d583d0ba257cdc96cde5794ebb7d38001ae3a5 Mon Sep 17 00:00:00 2001
-From: Andrzej <ndrwrdck@gmail.com>
-Date: Tue, 7 Jul 2015 22:26:51 +0100
-Subject: [PATCH] Bug 11939:  xfce4-places-plugin 1.7.0 crashes with undefined
- symbol
-
-Patch from Fedora. Submitted by Kevin Fenzi.
----
- panel-plugin/model.h | 18 +++++++++---------
- 1 file changed, 9 insertions(+), 9 deletions(-)
-
-diff --git a/panel-plugin/model.h b/panel-plugin/model.h
-index 06d9d6f..043e391 100644
---- a/panel-plugin/model.h
-+++ b/panel-plugin/model.h
-@@ -36,13 +36,13 @@ struct _PlacesBookmarkAction
-     void        (*finalize) (PlacesBookmarkAction *self);
- };
- 
--inline PlacesBookmarkAction*
-+extern inline PlacesBookmarkAction*
- places_bookmark_action_create(gchar *label);
- 
--inline void
-+extern inline void
- places_bookmark_action_destroy(PlacesBookmarkAction*);
- 
--inline void
-+extern inline void
- places_bookmark_action_call(PlacesBookmarkAction*);
- 
- /* Places Bookmark */
-@@ -70,10 +70,10 @@ struct _PlacesBookmark
-     void                 (*finalize) (PlacesBookmark *self);
- };
- 
--inline PlacesBookmark*
-+extern inline PlacesBookmark*
- places_bookmark_create(gchar *label);
- 
--inline void
-+extern inline void
- places_bookmark_destroy(PlacesBookmark *bookmark);
- 
- /* Places Bookmark Group */
-@@ -86,16 +86,16 @@ struct _PlacesBookmarkGroup
-     gpointer    priv;
- };
- 
--inline GList*
-+extern inline GList*
- places_bookmark_group_get_bookmarks(PlacesBookmarkGroup*);
- 
--inline gboolean
-+extern inline gboolean
- places_bookmark_group_changed(PlacesBookmarkGroup*);
- 
--inline PlacesBookmarkGroup*
-+extern inline PlacesBookmarkGroup*
- places_bookmark_group_create();
- 
--inline void
-+extern inline void
- places_bookmark_group_destroy(PlacesBookmarkGroup*);
- 
- #endif
--- 
-2.6.4
-
diff --git a/srcpkgs/xfce4-places-plugin/template b/srcpkgs/xfce4-places-plugin/template
index b7f2d8ea2f6..1c1c952a16d 100644
--- a/srcpkgs/xfce4-places-plugin/template
+++ b/srcpkgs/xfce4-places-plugin/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-places-plugin'
 pkgname=xfce4-places-plugin
-version=1.7.0
-revision=3
+version=1.8.0
+revision=1
 build_style=gnu-configure
 hostmakedepends="intltool pkg-config"
 makedepends="exo-devel libglib-devel gtk+-devel libxfce4ui-devel libxfce4util-devel
@@ -11,6 +11,6 @@ maintainer="Steve Prybylski <sa.prybylx@gmail.com>"
 license="GPL-2.0-or-later"
 homepage="https://goodies.xfce.org/projects/panel-plugins/xfce4-places-plugin"
 distfiles="https://archive.xfce.org/src/panel-plugins/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=4175c614749abbb5bcf6f49c88125fb0dd36db69f4c374df23563907b16e2c3f
+checksum=7ba3f46f88c2845cbf413efeefaed29157f8b98571856c6e2bf35e4de5d8ecce
 patch_args="-Np1"
 

From 4bdcc13779fc03595bca9baf726a523cc67f4048 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:52:41 -0400
Subject: [PATCH 22/29] xfce4-power-manager: update to 1.6.3.

---
 srcpkgs/xfce4-power-manager/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/xfce4-power-manager/template b/srcpkgs/xfce4-power-manager/template
index 6b44f4d349f..80f1d396a80 100644
--- a/srcpkgs/xfce4-power-manager/template
+++ b/srcpkgs/xfce4-power-manager/template
@@ -1,6 +1,6 @@
 # Template file for 'xfce4-power-manager'
 pkgname=xfce4-power-manager
-version=1.6.1
+version=1.6.3
 revision=1
 build_style=gnu-configure
 configure_args="--disable-static"
@@ -12,4 +12,4 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/$pkgname/${version%.*}/$pkgname-$version.tar.bz2"
-checksum=1ea825452343b895566068018b6d5078608f8f46ce8075ba6bbb4b848f48656b
+checksum=debd8ac2409b5ac230593894b8bb668298f78bd12891623edbfc32ac87c64011

From 14692cbda277380f406ca43d240ef331594c5531 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:53:06 -0400
Subject: [PATCH 23/29] xfce4-pulseaudio-plugin: revbump for xfconf

---
 srcpkgs/xfce4-pulseaudio-plugin/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/xfce4-pulseaudio-plugin/template b/srcpkgs/xfce4-pulseaudio-plugin/template
index d54728002a6..0ff54c57d27 100644
--- a/srcpkgs/xfce4-pulseaudio-plugin/template
+++ b/srcpkgs/xfce4-pulseaudio-plugin/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-pulseaudio-plugin'
 pkgname=xfce4-pulseaudio-plugin
 version=0.4.1
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="gettext-devel xfce4-dev-tools"
 makedepends="libkeybinder3-devel libnotify-devel pulseaudio-devel xfce4-panel-devel"

From e7406f66d0e967702335a2a5ed278497721ad70e Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:53:28 -0400
Subject: [PATCH 24/29] xfce4-screensaver: revbump for xfconf

---
 srcpkgs/xfce4-screensaver/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/xfce4-screensaver/template b/srcpkgs/xfce4-screensaver/template
index af2dba5fabf..aa45226a504 100644
--- a/srcpkgs/xfce4-screensaver/template
+++ b/srcpkgs/xfce4-screensaver/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-screensaver'
 pkgname=xfce4-screensaver
 version=0.1.4
-revision=1
+revision=2
 build_style=gnu-configure
 configure_args="--without-systemd --with-libgl --with-shadow --with-mit-ext
  --with-xf86gamma-ext --with-x --enable-pam"

From 990c0a2806153894ed3a26c238123bf0cea46b80 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:53:50 -0400
Subject: [PATCH 25/29] xfce4-screenshooter: update to 1.9.5.

---
 srcpkgs/xfce4-screenshooter/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/xfce4-screenshooter/template b/srcpkgs/xfce4-screenshooter/template
index 506544c58c3..860a1ee14d4 100644
--- a/srcpkgs/xfce4-screenshooter/template
+++ b/srcpkgs/xfce4-screenshooter/template
@@ -1,6 +1,6 @@
 # Template file for 'xfce4-screenshooter'
 pkgname=xfce4-screenshooter
-version=1.9.4
+version=1.9.5
 revision=1
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool glib-devel"
@@ -11,4 +11,4 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="https://goodies.xfce.org/projects/applications/xfce4-screenshooter"
 distfiles="https://archive.xfce.org/src/apps/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=c4f3225b3f73f1feb1869807b8b27aec4c32a3e9c2954915a5fb39d18d3a60f2
+checksum=bf35b5432cb920987c6d7ff193600e5dd4d73422b6aa02b4ec5288744053b38c

From 3071a77faeceaf14f72677e716c32af5d21d5763 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:54:20 -0400
Subject: [PATCH 26/29] xfce4-sensors-plugin: update to 1.3.92.

---
 srcpkgs/xfce4-sensors-plugin/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/xfce4-sensors-plugin/template b/srcpkgs/xfce4-sensors-plugin/template
index 4c5053fba55..96b8a00b3af 100644
--- a/srcpkgs/xfce4-sensors-plugin/template
+++ b/srcpkgs/xfce4-sensors-plugin/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-sensors-plugin'
 pkgname=xfce4-sensors-plugin
-version=1.3.0
-revision=2
+version=1.3.92
+revision=1
 build_style=gnu-configure
 configure_args="--disable-static"
 hostmakedepends="pkg-config intltool"
@@ -12,7 +12,7 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="https://goodies.xfce.org/projects/panel-plugins/xfce4-sensors-plugin"
 distfiles="https://archive.xfce.org/src/panel-plugins/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=b7a7834ca84f6751686fa2e20e0b44a2e68ece0cb2716792a765e03b92f65569
+checksum=3dc6643d2c064b7718badff44b948f8d410f00f13db197820b26ae38045f5112
 
 if [ "$CROSS_BUILD" ]; then
 	# Cannot detect these when cross compiling

From acf21efe2da9fab3223611ec0e2f33264ec59c71 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:55:52 -0400
Subject: [PATCH 27/29] xfce4-weather-plugin: update to 0.9.1.

---
 srcpkgs/xfce4-weather-plugin/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/xfce4-weather-plugin/template b/srcpkgs/xfce4-weather-plugin/template
index 8c3bab3185c..e6f9671ba6a 100644
--- a/srcpkgs/xfce4-weather-plugin/template
+++ b/srcpkgs/xfce4-weather-plugin/template
@@ -1,6 +1,6 @@
 # Template file for 'xfce4-weather-plugin'
 pkgname=xfce4-weather-plugin
-version=0.8.11
+version=0.9.1
 revision=1
 build_style=gnu-configure
 configure_args="--disable-upower"
@@ -12,5 +12,5 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="https://goodies.xfce.org/projects/panel-plugins/xfce4-weather-plugin"
 distfiles="https://archive.xfce.org/src/panel-plugins/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=0382ce99c0ad4424afe7096a354f301a9396d12807a0f2ab041912d6ab58145d
+checksum=7cdc18b8df759dee4ceaaf6ce303eff7fda48e247dbc26b78142929213506cfd
 lib32disabled=yes

From 7a127e7ee2676d91d3f1f9500047f4b002b5e68b Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:56:18 -0400
Subject: [PATCH 28/29] xfce4-windowck-plugin: update to 0.4.6.

---
 srcpkgs/xfce4-windowck-plugin/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/xfce4-windowck-plugin/template b/srcpkgs/xfce4-windowck-plugin/template
index 355ae97ad5d..5d897ba7154 100644
--- a/srcpkgs/xfce4-windowck-plugin/template
+++ b/srcpkgs/xfce4-windowck-plugin/template
@@ -1,17 +1,17 @@
 # Template file for 'xfce4-windowck-plugin'
 pkgname=xfce4-windowck-plugin
-version=0.4.4
-revision=2
+version=0.4.6
+revision=1
 build_style=gnu-makefile
 hostmakedepends="intltool xfce4-dev-tools exo-devel python3-devel glib-devel gettext-devel ImageMagick"
 makedepends="libwnck2-devel xfce4-panel-devel xorg-server-devel"
-depends="xfce4-panel>=4.10"
+depends="xfce4-panel>=4.13"
 short_desc="Puts the titlebar of a maximized window into a panel"
 maintainer="skurtix <skurtix@github.com>"
 homepage="https://github.com/cedl38/xfce4-windowck-plugin"
 license="GPL-3"
 distfiles="${homepage}/archive/v${version}.tar.gz"
-checksum=92b6c9e199d32cf96619c31e2cfac19e375575d581e78fa043f9f6a59c1df13f
+checksum=1643fa4a8bdbc401160fae6a132dcab89ed88d10231f84ed058f7a3e842763f7
 
 pre_configure() {
 	autogen_args="--prefix=/usr"

From 3075e0a35c5f4e918e45d3d2b29d5c7ff7c9bdf2 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:56:43 -0400
Subject: [PATCH 29/29] xfce4-xkb-plugin: revbump for xfconf

---
 srcpkgs/xfce4-xkb-plugin/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/xfce4-xkb-plugin/template b/srcpkgs/xfce4-xkb-plugin/template
index 30ec3089bbb..d64ee2670ee 100644
--- a/srcpkgs/xfce4-xkb-plugin/template
+++ b/srcpkgs/xfce4-xkb-plugin/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-xkb-plugin'
 pkgname=xfce4-xkb-plugin
 version=0.8.1
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool"
 makedepends="garcon-devel xfce4-panel-devel libxklavier-devel librsvg-devel libwnck-devel"

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PR PATCH] [Updated] [RFC] xfce4-4.14pre2
       [not found] <gh-mailinglist-notifications-41a7ca26-5023-4802-975b-f1789d68868e-void-packages-11932@inbox.vuxu.org>
  2019-07-02 13:05 ` [PR PATCH] [Updated] [RFC] xfce4-4.14pre1 voidlinux-github
  2019-07-02 13:05 ` voidlinux-github
@ 2019-07-02 13:16 ` voidlinux-github
  2019-07-02 13:16 ` voidlinux-github
                   ` (3 subsequent siblings)
  6 siblings, 0 replies; 7+ messages in thread
From: voidlinux-github @ 2019-07-02 13:16 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 723 bytes --]

There is an updated pull request by pbui against master on the void-packages repository

https://github.com/pbui/void-packages xfce4-4.14
https://github.com/void-linux/void-packages/pull/11932

[RFC] xfce4-4.14pre2
This updates the core xfce4 packages to 4.14pre1 status as outlined here:

https://wiki.xfce.org/releng/4.14/xfce_4.14pre1

This also includes some revbumps and updates to packages that depend on xfconf (which has a SO bump).

I'm not sure if we want to update all the packages now, wait until 4.14 is released, or update individual packages on a case-by-case basis.  That is what I am marking this with [RFC].

A patch file from https://github.com/void-linux/void-packages/pull/11932.patch is attached

[-- Warning: decoded text below may be mangled --]
[-- Attachment #2: github-pr-xfce4-4.14-11932.patch --]
[-- Type: application/text/x-diff, Size: 41126 bytes --]

From aa66a9411b6d698026033b6427f08b6c954babb3 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:33:32 -0400
Subject: [PATCH 01/32] xfconf: update to 4.13.8.

- Update common/shlibs for libxfconf-0.so.3
- glib-devel needs to be hostmakedepends for cross-compiling
---
 common/shlibs           | 2 +-
 srcpkgs/xfconf/template | 8 ++++----
 2 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index 22c315708e6..f49e5937f7e 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -179,7 +179,7 @@ libnl-genl-3.so.200 libnl3-3.2.1_1
 libnl-cli-3.so.200 libnl3-3.2.1_1
 libreadline.so.8 libreadline8-8.0_1
 libhistory.so.8 libhistory8-8.0_1
-libxfconf-0.so.2 xfconf-4.9.1_1
+libxfconf-0.so.3 xfconf-4.13.7_1
 libxfce4util.so.7 libxfce4util-4.12.1_1
 libxfce4panel-1.0.so.4 xfce4-panel-4.9.2_1
 libxfce4panel-2.0.so.4 xfce4-panel-4.12.0_1
diff --git a/srcpkgs/xfconf/template b/srcpkgs/xfconf/template
index fb150ff36f1..10605f3d8d1 100644
--- a/srcpkgs/xfconf/template
+++ b/srcpkgs/xfconf/template
@@ -1,18 +1,18 @@
 # Template file for 'xfconf'
 pkgname=xfconf
-version=4.12.1
+version=4.13.8
 revision=1
 build_options="perl"
 build_style=gnu-configure
 configure_args="$(vopt_enable perl 'perl-bindings --with-perl-options=INSTALLDIRS=vendor')"
-hostmakedepends="pkg-config intltool"
-makedepends="dbus-glib-devel libxfce4util-devel $(vopt_if perl 'perl-ExtUtils-Depends perl-ExtUtils-PkgConfig perl-Glib')"
+hostmakedepends="pkg-config intltool glib-devel"
+makedepends="libxfce4util-devel $(vopt_if perl 'perl-ExtUtils-Depends perl-ExtUtils-PkgConfig perl-Glib')"
 short_desc="Xfce hierarchical (tree-like) configuration system"
 maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2, LGPL-2.1"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/xfconf/${version%.*}/$pkgname-$version.tar.bz2"
-checksum=35f48564e5694faa54fdc180cd3268e16fc2352946a89a3c2fc12cbe400ada36
+checksum=55e2441c4ff78a7006fabb59647f7bc1f190cbb82327b93ba063ff624a896591
 
 xfconf-devel_package() {
 	depends="dbus-glib-devel ${sourcepkg}>=${version}_${revision}"

From 58902b9f356fb2a2c23323cd62c00eb4ba54ab35 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Tue, 2 Jul 2019 08:51:42 -0400
Subject: [PATCH 02/32] libxfce4util: update to 4.13.4.

Use gir build helper (for cross-compilation)
---
 srcpkgs/libxfce4util/template | 16 ++++++++++++----
 1 file changed, 12 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/libxfce4util/template b/srcpkgs/libxfce4util/template
index 6c2f3cf4a3b..9ebc4f45422 100644
--- a/srcpkgs/libxfce4util/template
+++ b/srcpkgs/libxfce4util/template
@@ -1,8 +1,9 @@
 # Template file for 'libxfce4util'
 pkgname=libxfce4util
-version=4.12.1
-revision=3
+version=4.13.4
+revision=1
 build_style=gnu-configure
+build_helper="gir"
 hostmakedepends="pkg-config intltool"
 makedepends="libglib-devel"
 short_desc="Utility library for the Xfce4 desktop environment"
@@ -10,7 +11,11 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="LGPL-2.0-or-later"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/$pkgname/${version%.*}/$pkgname-$version.tar.bz2"
-checksum=876bdefa2e13cbf68b626b2158892fb93e824e1ef59cf951123a96cefbc8881d
+checksum=57dd4ba226432afdf98cea4700a4679bb1b57ce80713167f99fde50ad87d0863
+
+# Package build options
+build_options="gir"
+build_options_default="gir"
 
 libxfce4util-devel_package() {
 	depends="libglib-devel ${sourcepkg}>=${version}_${revision}"
@@ -19,6 +24,9 @@ libxfce4util-devel_package() {
 		vmove usr/include
 		vmove usr/lib/pkgconfig
 		vmove usr/share/gtk-doc
-		vmove usr/lib/*.so
+		vmove "usr/lib/*.so"
+		if [ "$build_option_gir" ]; then
+			vmove usr/share/gir-1.0
+		fi
 	}
 }

From a66d5dc5927b07382f5b780a615a1d5e2f937a3f Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:32:15 -0400
Subject: [PATCH 03/32] libxfce4ui: update to 4.13.6.

Use gir build helper (for cross-compilation)
---
 srcpkgs/libxfce4ui/template | 19 +++++++++++--------
 1 file changed, 11 insertions(+), 8 deletions(-)

diff --git a/srcpkgs/libxfce4ui/template b/srcpkgs/libxfce4ui/template
index ac82ac043b3..558dc608995 100644
--- a/srcpkgs/libxfce4ui/template
+++ b/srcpkgs/libxfce4ui/template
@@ -1,24 +1,24 @@
 # Template file for 'libxfce4ui'
 pkgname=libxfce4ui
-version=4.12.1
-revision=3
+version=4.13.6
+revision=1
 build_style=gnu-configure
+build_helper="gir"
 configure_args="--disable-static"
 conf_files="/etc/xdg/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml"
 hostmakedepends="xfce4-dev-tools pkg-config intltool glib-devel gettext-devel"
-makedepends="gtk+-devel gtk+3-devel libxfce4util-devel xfconf-devel dbus-glib-devel
+makedepends="gtk+-devel gtk+3-devel libxfce4util-devel xfconf-devel
  libxml2-devel startup-notification-devel libSM-devel"
 short_desc="Replacement of the old libxfcegui4 library"
 maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="LGPL-2.0-or-later"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=3d619811bfbe7478bb984c16543d980cadd08586365a7bc25e59e3ca6384ff43
+checksum=3c5e505ce56a5993db473efed9962705dd255ffaee17009ed1b3e9f40b543969
 
-pre_configure() {
-	mkdir m4
-	NOCONFIGURE=1 xdt-autogen
-}
+# Package build options
+build_options="gir"
+build_options_default="gir"
 
 libxfce4ui-devel_package() {
 	depends="${makedepends} ${sourcepkg}>=${version}_${revision}"
@@ -28,5 +28,8 @@ libxfce4ui-devel_package() {
 		vmove usr/lib/pkgconfig
 		vmove "usr/lib/*.so"
 		vmove usr/share/gtk-doc
+                if [ "$build_option_gir" ]; then
+                        vmove usr/share/gir-1.0
+                fi
 	}
 }

From daf5cb8d0ec9196ae930b31409000f2d5d8cd051 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:36:47 -0400
Subject: [PATCH 04/32] libwnck: update to 3.32.0.

Switch to meson build style.
---
 srcpkgs/libwnck/template | 13 ++++++-------
 1 file changed, 6 insertions(+), 7 deletions(-)

diff --git a/srcpkgs/libwnck/template b/srcpkgs/libwnck/template
index 1775a4bc55d..83190d54f68 100644
--- a/srcpkgs/libwnck/template
+++ b/srcpkgs/libwnck/template
@@ -1,11 +1,11 @@
 # Template file for 'libwnck'
 pkgname=libwnck
-version=3.30.0
-revision=2
-build_style=gnu-configure
+version=3.32.0
+revision=1
+build_style=meson
 build_helper="gir"
-configure_args="$(vopt_enable gir introspection)"
-hostmakedepends="gdk-pixbuf-devel pkg-config intltool
+#configure_args="$(vopt_enable gir introspection)"
+hostmakedepends="gdk-pixbuf-devel pkg-config intltool glib-devel
  $(vopt_if gir gobject-introspection)"
 makedepends="startup-notification-devel gtk+3-devel libXres-devel"
 short_desc="Library for layout and rendering of text"
@@ -13,7 +13,7 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="LGPL-2.1-or-later"
 homepage="http://www.gnome.org/"
 distfiles="${GNOME_SITE}/${pkgname}/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=ac6d0d2646aa80676d3066651e73abb7bff7ed79be238c9b21a0083e2adc3439
+checksum=9595835cf28d0fc6af5526a18f77f2fcf3ca8c09e36741bb33915b6e69b8e3ca
 
 build_options="gir"
 build_options_default="gir"
@@ -25,7 +25,6 @@ libwnck-devel_package() {
 		vmove usr/include
 		vmove usr/lib/pkgconfig
 		vmove "usr/lib/*.so"
-		vmove usr/share/gtk-doc
 		if [ "$build_option_gir" ]; then
 			vmove usr/share/gir-1.0
 		fi

From c74ebd6c86db372fbde953bf5b60019718fb0b62 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Tue, 2 Jul 2019 08:52:01 -0400
Subject: [PATCH 05/32] xfce4-dev-tools: update to 4.13.0.

---
 srcpkgs/xfce4-dev-tools/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/xfce4-dev-tools/template b/srcpkgs/xfce4-dev-tools/template
index 6e452ee4154..3fe83a41c70 100644
--- a/srcpkgs/xfce4-dev-tools/template
+++ b/srcpkgs/xfce4-dev-tools/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-dev-tools'
 pkgname=xfce4-dev-tools
-version=4.12.0
-revision=2
+version=4.13.0
+revision=1
 build_style=gnu-configure
 hostmakedepends="automake libtool gtk-doc intltool pkg-config"
 makedepends="libglib-devel"
@@ -11,4 +11,4 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=e2e3a654fe9110df81f8c2483c9cbfa6d656fed15d5e5e717d6ef10bd0f5b5cb
+checksum=d24d4db2151a35324c672d4596a6a256f7d92727fe6a9d23648ab53f5207ba3b

From c4c6a1c6efa2a49394a11eaff25fe3b173eccca6 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:37:52 -0400
Subject: [PATCH 06/32] xfce4-panel: update to 4.13.6.

Switch to libwnck, drop dbus-glib, use gir build helper (for cross-compilation)
---
 srcpkgs/xfce4-panel/template | 19 +++++++++++--------
 1 file changed, 11 insertions(+), 8 deletions(-)

diff --git a/srcpkgs/xfce4-panel/template b/srcpkgs/xfce4-panel/template
index ee9c8d5aebc..5a3c55ba164 100644
--- a/srcpkgs/xfce4-panel/template
+++ b/srcpkgs/xfce4-panel/template
@@ -1,23 +1,23 @@
 # Template file for 'xfce4-panel'
 pkgname=xfce4-panel
-version=4.12.2
+version=4.13.6
 revision=1
 build_style=gnu-configure
+build_helper="gir"
 configure_args="--disable-static --enable-gio-unix --enable-gtk3"
 hostmakedepends="xfce4-dev-tools pkg-config intltool gettext-devel glib-devel"
 makedepends="gtk+3-devel libxfce4ui-devel xfconf-devel
- dbus-glib-devel libwnck2-devel garcon-devel exo-devel"
+ libwnck-devel garcon-devel exo-devel"
 short_desc="Next generation panel for the XFCE desktop environment"
 maintainer="Juan RP <xtraeme@voidlinux.org>"
 homepage="https://xfce.org/"
 license="GPL-2"
 distfiles="https://archive.xfce.org/src/xfce/$pkgname/${version%.*}/$pkgname-$version.tar.bz2"
-checksum=42058abb81b8f87691d3999627447de71c3285bcf055f308aab5cefab2de0ce9
+checksum=42411fee7675bb6fb3055395673dc925d43495df93b5e940a1ae3d0a3d2f63a8
 
-pre_configure() {
-	mkdir m4
-	NOCONFIGURE=1 xdt-autogen
-}
+# Package build options
+build_options="gir"
+build_options_default="gir"
 
 xfce4-panel-devel_package() {
 	depends="libxfce4ui-devel ${sourcepkg}>=${version}_${revision}"
@@ -26,6 +26,9 @@ xfce4-panel-devel_package() {
 		vmove usr/include
 		vmove usr/lib/pkgconfig
 		vmove usr/share/gtk-doc
-		vmove usr/lib/*.so
+		vmove "usr/lib/*.so"
+                if [ "$build_option_gir" ]; then
+                        vmove usr/share/gir-1.0
+                fi
 	}
 }

From e9319fb4549abd9494b55e276b04b5a67efe7d56 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:40:46 -0400
Subject: [PATCH 07/32] xfdesktop: update to 4.13.5.

Switch to libwnck, drop dbus-glib
---
 srcpkgs/xfdesktop/template | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/xfdesktop/template b/srcpkgs/xfdesktop/template
index be1056cf50b..7fb2848f4c8 100644
--- a/srcpkgs/xfdesktop/template
+++ b/srcpkgs/xfdesktop/template
@@ -1,16 +1,15 @@
 # Template file for 'xfdesktop'
 pkgname=xfdesktop
-version=4.12.5
+version=4.13.5
 revision=1
 build_style=gnu-configure
-hostmakedepends="pkg-config intltool glib-devel dbus-glib-devel"
-# XXX Add Thunar-devel again once xfdesktop supports the new Thunarx-3 API
+hostmakedepends="pkg-config intltool glib-devel Thunar-devel"
 makedepends="libxfce4ui-devel exo-devel garcon-devel
- libnotify-devel libwnck2-devel"
+ libnotify-devel libwnck-devel"
 depends="hicolor-icon-theme desktop-file-utils"
 short_desc="Desktop manager for the Xfce Desktop Environment"
 maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/xfdesktop/${version%.*}/$pkgname-$version.tar.bz2"
-checksum=3f2426ac28b94cfe5d6fd187c59b4e78f40e66c2842318e158ecd82abe2e7c0a
+checksum=b7d273d36f5f39a446c4d0303148bc595ed7b0f36269619c91526edd1d1caeb6

From 4be7ffe07643bf86d9b462a8dcc1be4d0467ce90 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:41:45 -0400
Subject: [PATCH 08/32] xfwm4: update to 4.13.3.

Switch to libwnck, add Xpresent
---
 srcpkgs/xfwm4/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/xfwm4/template b/srcpkgs/xfwm4/template
index 58d1cc533df..fa2f78ae03e 100644
--- a/srcpkgs/xfwm4/template
+++ b/srcpkgs/xfwm4/template
@@ -1,16 +1,16 @@
 # Template file for 'xfwm4'
 pkgname=xfwm4
-version=4.12.5
+version=4.13.3
 revision=1
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool"
 makedepends="libxfce4ui-devel startup-notification-devel
  libXcomposite-devel libXdamage-devel libXfixes-devel libXrandr-devel
- libXrender-devel dbus-glib-devel libwnck2-devel"
+ libXrender-devel libXpresent-devel libwnck-devel"
 depends="hicolor-icon-theme desktop-file-utils"
 short_desc="Next generation window manager for Xfce"
 maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/xfwm4/${version%.*}/xfwm4-${version}.tar.bz2"
-checksum=7775c02216666c2d023275e7ed6d85e57d965e5cc1407bb6a05c53cc38d8caca
+checksum=12ad274f6662c8afee35fd9b9310e73bd462c423578d448b2d7353e3c8eda6c1

From c0deb78120252f2af06cd5cc2581725a39947da2 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:43:17 -0400
Subject: [PATCH 09/32] thunar-volman: revbump for xfconf

---
 srcpkgs/thunar-volman/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/thunar-volman/template b/srcpkgs/thunar-volman/template
index 15a066edaee..808725a915a 100644
--- a/srcpkgs/thunar-volman/template
+++ b/srcpkgs/thunar-volman/template
@@ -1,7 +1,7 @@
 # Template file for 'thunar-volman'
 pkgname=thunar-volman
 version=0.9.2
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool"
 makedepends="libgudev-devel libnotify-devel libxfce4ui-devel exo-devel"

From 8efe14fbf4e4c374f30df24ec738dbd4222b1d97 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:43:57 -0400
Subject: [PATCH 10/32] xfce4-settings: update to 4.13.7.

---
 srcpkgs/xfce4-settings/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/xfce4-settings/template b/srcpkgs/xfce4-settings/template
index 1944a3acf6e..7f122d774f5 100644
--- a/srcpkgs/xfce4-settings/template
+++ b/srcpkgs/xfce4-settings/template
@@ -1,6 +1,6 @@
 # Template file for 'xfce4-settings'
 pkgname=xfce4-settings
-version=4.12.4
+version=4.13.7
 revision=1
 build_style=gnu-configure
 configure_args="--enable-sound-settings --enable-pluggable-dialogs"
@@ -15,4 +15,4 @@ license="GPL-2.0-only"
 homepage="https://xfce.org/"
 changelog="https://raw.githubusercontent.com/xfce-mirror/xfce4-settings/master/NEWS"
 distfiles="https://archive.xfce.org/src/xfce/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=e2a04cad48bf9e951409d0c841829fa3b4ce632cd799082ef82d0506618b6f9b
+checksum=ac11391eee22cb5fbffe3342916bcf9805f29c722aca825c2f57d98dc167a065

From 9811a79b48cf41b7f4928b20bc9ca1c33bd4361e Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:44:21 -0400
Subject: [PATCH 11/32] xfce4-session: update to 4.13.3.

Switch to libwnck, drop dbus-glib, remove unnecessary --enable-upower
configure flag
---
 srcpkgs/xfce4-session/template | 19 +++++++------------
 1 file changed, 7 insertions(+), 12 deletions(-)

diff --git a/srcpkgs/xfce4-session/template b/srcpkgs/xfce4-session/template
index 6c4b9ecf265..eef01d28e3f 100644
--- a/srcpkgs/xfce4-session/template
+++ b/srcpkgs/xfce4-session/template
@@ -1,12 +1,12 @@
 # Template file for 'xfce4-session'
 pkgname=xfce4-session
-version=4.12.1
-revision=2
+version=4.13.3
+revision=1
 build_style=gnu-configure
-configure_args="--disable-static --enable-upower --enable-polkit"
+configure_args="--disable-static --enable-polkit"
 hostmakedepends="xfce4-dev-tools pkg-config intltool gettext-devel glib-devel iceauth"
-makedepends="libxfce4ui-devel dbus-glib-devel upower-devel
- libwnck2-devel xfce4-panel-devel libSM-devel polkit-devel"
+makedepends="libxfce4ui-devel upower-devel
+ libwnck-devel xfce4-panel-devel libSM-devel polkit-devel"
 depends="iceauth hicolor-icon-theme desktop-file-utils"
 conf_files="/etc/xdg/xfce4/xfconf/xfce-perchannel-xml/xfce4-session.xml"
 short_desc="The session manager for the XFCE desktop environment"
@@ -14,22 +14,17 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/$pkgname/${version%.*}/$pkgname-$version.tar.bz2"
-checksum=97d7f2a2d0af7f3623b68d1f04091e02913b28f9555dab8b0d26c8a1299d08fd
+checksum=eaed34f29aa044d878d60dcb7293a542f48248919e3dcd8df98215121cb6d362
 
-pre_configure() {
-	mkdir m4
-	NOCONFIGURE=1 xdt-autogen
-}
 post_install() {
 	# startxfce4 needs bash.
 	replace_interpreter bash ${DESTDIR}/usr/bin/startxfce4
 }
 
 xfce4-session-devel_package() {
-	depends="libxfce4ui-devel>=4.12 ${sourcepkg}>=${version}_${revision}"
+	depends="libxfce4ui-devel>=4.13 ${sourcepkg}>=${version}_${revision}"
 	short_desc+=" - development files"
 	pkg_install() {
-		vmove usr/include
 		vmove usr/lib/pkgconfig
 		vmove "usr/lib/*.so"
 	}

From ab037ba566d01be3e6927bcd4941ab63d754421a Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:46:36 -0400
Subject: [PATCH 12/32] xfce4-appfinder: update to 4.13.4.

---
 srcpkgs/xfce4-appfinder/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/xfce4-appfinder/template b/srcpkgs/xfce4-appfinder/template
index 0ebe4dd92c7..ef75eb636b6 100644
--- a/srcpkgs/xfce4-appfinder/template
+++ b/srcpkgs/xfce4-appfinder/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-appfinder'
 pkgname=xfce4-appfinder
-version=4.12.0
-revision=3
+version=4.13.4
+revision=1
 build_style=gnu-configure
 configure_args="--enable-gtk3"
 hostmakedepends="pkg-config intltool"
@@ -12,4 +12,4 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=2ad4a58019a76a6b64a816050db25f96854917c2f2e89d6a9df6c18e6c84c567
+checksum=0f4de2a5e2875cfa2862fd73ba1d32fb798df71849f69e68cd28cdde1cf53a02

From bc039f09a4d99710143b1f34cbcb3f9a5d470474 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:47:16 -0400
Subject: [PATCH 13/32] xfce4-clipman-plugin: revbump for xfconf

---
 srcpkgs/xfce4-clipman-plugin/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/xfce4-clipman-plugin/template b/srcpkgs/xfce4-clipman-plugin/template
index 3d973e08e06..987a68f7d5f 100644
--- a/srcpkgs/xfce4-clipman-plugin/template
+++ b/srcpkgs/xfce4-clipman-plugin/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-clipman-plugin'
 pkgname=xfce4-clipman-plugin
 version=1.4.3
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="intltool pkg-config"
 makedepends="xfce4-panel-devel libXtst-devel qrencode-devel"

From 701510064770b03e56a84b4b0e075d621114591f Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:47:43 -0400
Subject: [PATCH 14/32] xfce4-notes-plugin: revbump for xfconf

---
 srcpkgs/xfce4-notes-plugin/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/xfce4-notes-plugin/template b/srcpkgs/xfce4-notes-plugin/template
index ce150733001..1df5d9776e8 100644
--- a/srcpkgs/xfce4-notes-plugin/template
+++ b/srcpkgs/xfce4-notes-plugin/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-notes-plugin'
 pkgname=xfce4-notes-plugin
 version=1.8.1
-revision=2
+revision=3
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool"
 makedepends="xfce4-panel-devel libunique1-devel"

From b2a5d6cfe789db76d22b0cb1e593e4b8fed6a02e Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:48:12 -0400
Subject: [PATCH 15/32] xfce4-notifyd: revbump for xfconf

---
 srcpkgs/xfce4-notifyd/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/xfce4-notifyd/template b/srcpkgs/xfce4-notifyd/template
index cc07838d602..65500dc824e 100644
--- a/srcpkgs/xfce4-notifyd/template
+++ b/srcpkgs/xfce4-notifyd/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-notifyd'
 pkgname=xfce4-notifyd
 version=0.4.4
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool glib-devel dbus-glib-devel"
 makedepends="libnotify-devel xfce4-panel-devel"

From b0a5994608340f29cffac814fbcf44389f95062f Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:49:24 -0400
Subject: [PATCH 16/32] mousepad: remove unnecessary makedepends on
 libxfce4ui-devel

---
 srcpkgs/mousepad/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/mousepad/template b/srcpkgs/mousepad/template
index 54160a9218e..f604781fb34 100644
--- a/srcpkgs/mousepad/template
+++ b/srcpkgs/mousepad/template
@@ -1,10 +1,10 @@
 # Template file for 'mousepad'
 pkgname=mousepad
 version=0.4.1
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="glib-devel intltool pkg-config"
-makedepends="gtksourceview-devel libxfce4ui-devel"
+makedepends="gtksourceview-devel"
 depends="desktop-file-utils hicolor-icon-theme"
 short_desc="Simple text editor for Xfce based on Leafpad"
 maintainer="Juan RP <xtraeme@voidlinux.org>"

From a147b5b408ed10b29ccf1e9fdf58b796b5f4ccda Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:50:10 -0400
Subject: [PATCH 17/32] orage: remove unnecessary makedepends on dbus-glib

---
 srcpkgs/orage/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/orage/template b/srcpkgs/orage/template
index c0a9f23c448..bd0b9fcb6eb 100644
--- a/srcpkgs/orage/template
+++ b/srcpkgs/orage/template
@@ -1,10 +1,10 @@
 # Template file for 'orage'
 pkgname=orage
 version=4.12.1
-revision=3
+revision=4
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool flex"
-makedepends="libical-devel libnotify-devel gtk+-devel dbus-glib-devel
+makedepends="libical-devel libnotify-devel gtk+-devel
  popt-devel xfce4-panel-devel libxfce4util-devel"
 depends="hicolor-icon-theme desktop-file-utils"
 short_desc="Simple calendar application for Xfce"

From 33f9dcc173fc10d8834dfb124cc427518e7d61b2 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:50:51 -0400
Subject: [PATCH 18/32] parole: revbump for xfconf

---
 srcpkgs/parole/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/parole/template b/srcpkgs/parole/template
index efd712729fe..82bdfe94511 100644
--- a/srcpkgs/parole/template
+++ b/srcpkgs/parole/template
@@ -1,7 +1,7 @@
 # Template file for 'parole'
 pkgname=parole
 version=1.0.2
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool glib-devel"
 makedepends="gst-plugins-base1-devel libnotify-devel taglib-devel libxfce4ui-devel"

From 9e85a4acc1e0b8b91e69592fbd806e6c81419e77 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:51:12 -0400
Subject: [PATCH 19/32] ristretto: revbump for xfconf

---
 srcpkgs/ristretto/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/ristretto/template b/srcpkgs/ristretto/template
index 38dbc735472..7e761eb7c57 100644
--- a/srcpkgs/ristretto/template
+++ b/srcpkgs/ristretto/template
@@ -1,7 +1,7 @@
 # Template file for 'ristretto'
 pkgname=ristretto
 version=0.8.4
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="intltool pkg-config"
 makedepends="exo-devel file-devel libexif-devel"

From 2950675236a493e3ea18cfd1c224807a1818c3d8 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:51:31 -0400
Subject: [PATCH 20/32] vala-panel-appmenu: update to 0.7.2

---
 srcpkgs/vala-panel-appmenu/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/vala-panel-appmenu/template b/srcpkgs/vala-panel-appmenu/template
index 47c8b247bba..fa197105c43 100644
--- a/srcpkgs/vala-panel-appmenu/template
+++ b/srcpkgs/vala-panel-appmenu/template
@@ -1,7 +1,7 @@
 # Template file for 'vala-panel-appmenu'
 pkgname=vala-panel-appmenu
-version=0.7.1
-revision=2
+version=0.7.2
+revision=1
 build_style=cmake
 configure_args="-DENABLE_XFCE=ON -DENABLE_VALAPANEL=ON
  -DENABLE_MATE=ON -DENABLE_JAYATANA=OFF -DENABLE_APPMENU_GTK_MODULE=ON"
@@ -15,8 +15,8 @@ short_desc="Global Menu for Vala Panel"
 maintainer="John Eira <john.eira@web.de>"
 license="LGPL-3.0-or-later"
 homepage="https://gitlab.com/vala-panel-project/vala-panel-appmenu"
-distfiles="https://gitlab.com/vala-panel-project/vala-panel-appmenu/uploads/c0f85b42a2a228ad8c3413357e02fb28/vala-panel-appmenu-${version}.tar.xz"
-checksum=54a1b4f6ceca63eb3b79facc4327424bdd82f0fe3b7c6139326dbe0ec0824dcc
+distfiles="https://gitlab.com/vala-panel-project/vala-panel-appmenu/uploads/57fe7a74b38180002154fbd6028075db/vala-panel-appmenu-${version}.tar.xz"
+checksum=80884ebd71b665da7a1eac67752596ecbb29d3a8dd9eee9a2e3212dfc0aab6ae
 
 post_install() {
 	if [ "$CROSS_BUILD" ]; then

From bffb54931ddc448bd9245c846f47df1db30c2ab6 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:52:06 -0400
Subject: [PATCH 21/32] xfce4-places-plugin: update to 1.8.0.

Remove unnecessary patch.
---
 .../patches/undefined-symbol.patch            | 69 -------------------
 srcpkgs/xfce4-places-plugin/template          |  6 +-
 2 files changed, 3 insertions(+), 72 deletions(-)
 delete mode 100644 srcpkgs/xfce4-places-plugin/patches/undefined-symbol.patch

diff --git a/srcpkgs/xfce4-places-plugin/patches/undefined-symbol.patch b/srcpkgs/xfce4-places-plugin/patches/undefined-symbol.patch
deleted file mode 100644
index a94d9ea706f..00000000000
--- a/srcpkgs/xfce4-places-plugin/patches/undefined-symbol.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-From 94d583d0ba257cdc96cde5794ebb7d38001ae3a5 Mon Sep 17 00:00:00 2001
-From: Andrzej <ndrwrdck@gmail.com>
-Date: Tue, 7 Jul 2015 22:26:51 +0100
-Subject: [PATCH] Bug 11939:  xfce4-places-plugin 1.7.0 crashes with undefined
- symbol
-
-Patch from Fedora. Submitted by Kevin Fenzi.
----
- panel-plugin/model.h | 18 +++++++++---------
- 1 file changed, 9 insertions(+), 9 deletions(-)
-
-diff --git a/panel-plugin/model.h b/panel-plugin/model.h
-index 06d9d6f..043e391 100644
---- a/panel-plugin/model.h
-+++ b/panel-plugin/model.h
-@@ -36,13 +36,13 @@ struct _PlacesBookmarkAction
-     void        (*finalize) (PlacesBookmarkAction *self);
- };
- 
--inline PlacesBookmarkAction*
-+extern inline PlacesBookmarkAction*
- places_bookmark_action_create(gchar *label);
- 
--inline void
-+extern inline void
- places_bookmark_action_destroy(PlacesBookmarkAction*);
- 
--inline void
-+extern inline void
- places_bookmark_action_call(PlacesBookmarkAction*);
- 
- /* Places Bookmark */
-@@ -70,10 +70,10 @@ struct _PlacesBookmark
-     void                 (*finalize) (PlacesBookmark *self);
- };
- 
--inline PlacesBookmark*
-+extern inline PlacesBookmark*
- places_bookmark_create(gchar *label);
- 
--inline void
-+extern inline void
- places_bookmark_destroy(PlacesBookmark *bookmark);
- 
- /* Places Bookmark Group */
-@@ -86,16 +86,16 @@ struct _PlacesBookmarkGroup
-     gpointer    priv;
- };
- 
--inline GList*
-+extern inline GList*
- places_bookmark_group_get_bookmarks(PlacesBookmarkGroup*);
- 
--inline gboolean
-+extern inline gboolean
- places_bookmark_group_changed(PlacesBookmarkGroup*);
- 
--inline PlacesBookmarkGroup*
-+extern inline PlacesBookmarkGroup*
- places_bookmark_group_create();
- 
--inline void
-+extern inline void
- places_bookmark_group_destroy(PlacesBookmarkGroup*);
- 
- #endif
--- 
-2.6.4
-
diff --git a/srcpkgs/xfce4-places-plugin/template b/srcpkgs/xfce4-places-plugin/template
index b7f2d8ea2f6..1c1c952a16d 100644
--- a/srcpkgs/xfce4-places-plugin/template
+++ b/srcpkgs/xfce4-places-plugin/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-places-plugin'
 pkgname=xfce4-places-plugin
-version=1.7.0
-revision=3
+version=1.8.0
+revision=1
 build_style=gnu-configure
 hostmakedepends="intltool pkg-config"
 makedepends="exo-devel libglib-devel gtk+-devel libxfce4ui-devel libxfce4util-devel
@@ -11,6 +11,6 @@ maintainer="Steve Prybylski <sa.prybylx@gmail.com>"
 license="GPL-2.0-or-later"
 homepage="https://goodies.xfce.org/projects/panel-plugins/xfce4-places-plugin"
 distfiles="https://archive.xfce.org/src/panel-plugins/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=4175c614749abbb5bcf6f49c88125fb0dd36db69f4c374df23563907b16e2c3f
+checksum=7ba3f46f88c2845cbf413efeefaed29157f8b98571856c6e2bf35e4de5d8ecce
 patch_args="-Np1"
 

From 4bdcc13779fc03595bca9baf726a523cc67f4048 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:52:41 -0400
Subject: [PATCH 22/32] xfce4-power-manager: update to 1.6.3.

---
 srcpkgs/xfce4-power-manager/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/xfce4-power-manager/template b/srcpkgs/xfce4-power-manager/template
index 6b44f4d349f..80f1d396a80 100644
--- a/srcpkgs/xfce4-power-manager/template
+++ b/srcpkgs/xfce4-power-manager/template
@@ -1,6 +1,6 @@
 # Template file for 'xfce4-power-manager'
 pkgname=xfce4-power-manager
-version=1.6.1
+version=1.6.3
 revision=1
 build_style=gnu-configure
 configure_args="--disable-static"
@@ -12,4 +12,4 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/$pkgname/${version%.*}/$pkgname-$version.tar.bz2"
-checksum=1ea825452343b895566068018b6d5078608f8f46ce8075ba6bbb4b848f48656b
+checksum=debd8ac2409b5ac230593894b8bb668298f78bd12891623edbfc32ac87c64011

From 14692cbda277380f406ca43d240ef331594c5531 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:53:06 -0400
Subject: [PATCH 23/32] xfce4-pulseaudio-plugin: revbump for xfconf

---
 srcpkgs/xfce4-pulseaudio-plugin/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/xfce4-pulseaudio-plugin/template b/srcpkgs/xfce4-pulseaudio-plugin/template
index d54728002a6..0ff54c57d27 100644
--- a/srcpkgs/xfce4-pulseaudio-plugin/template
+++ b/srcpkgs/xfce4-pulseaudio-plugin/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-pulseaudio-plugin'
 pkgname=xfce4-pulseaudio-plugin
 version=0.4.1
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="gettext-devel xfce4-dev-tools"
 makedepends="libkeybinder3-devel libnotify-devel pulseaudio-devel xfce4-panel-devel"

From e7406f66d0e967702335a2a5ed278497721ad70e Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:53:28 -0400
Subject: [PATCH 24/32] xfce4-screensaver: revbump for xfconf

---
 srcpkgs/xfce4-screensaver/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/xfce4-screensaver/template b/srcpkgs/xfce4-screensaver/template
index af2dba5fabf..aa45226a504 100644
--- a/srcpkgs/xfce4-screensaver/template
+++ b/srcpkgs/xfce4-screensaver/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-screensaver'
 pkgname=xfce4-screensaver
 version=0.1.4
-revision=1
+revision=2
 build_style=gnu-configure
 configure_args="--without-systemd --with-libgl --with-shadow --with-mit-ext
  --with-xf86gamma-ext --with-x --enable-pam"

From 990c0a2806153894ed3a26c238123bf0cea46b80 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:53:50 -0400
Subject: [PATCH 25/32] xfce4-screenshooter: update to 1.9.5.

---
 srcpkgs/xfce4-screenshooter/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/xfce4-screenshooter/template b/srcpkgs/xfce4-screenshooter/template
index 506544c58c3..860a1ee14d4 100644
--- a/srcpkgs/xfce4-screenshooter/template
+++ b/srcpkgs/xfce4-screenshooter/template
@@ -1,6 +1,6 @@
 # Template file for 'xfce4-screenshooter'
 pkgname=xfce4-screenshooter
-version=1.9.4
+version=1.9.5
 revision=1
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool glib-devel"
@@ -11,4 +11,4 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="https://goodies.xfce.org/projects/applications/xfce4-screenshooter"
 distfiles="https://archive.xfce.org/src/apps/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=c4f3225b3f73f1feb1869807b8b27aec4c32a3e9c2954915a5fb39d18d3a60f2
+checksum=bf35b5432cb920987c6d7ff193600e5dd4d73422b6aa02b4ec5288744053b38c

From 3071a77faeceaf14f72677e716c32af5d21d5763 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:54:20 -0400
Subject: [PATCH 26/32] xfce4-sensors-plugin: update to 1.3.92.

---
 srcpkgs/xfce4-sensors-plugin/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/xfce4-sensors-plugin/template b/srcpkgs/xfce4-sensors-plugin/template
index 4c5053fba55..96b8a00b3af 100644
--- a/srcpkgs/xfce4-sensors-plugin/template
+++ b/srcpkgs/xfce4-sensors-plugin/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-sensors-plugin'
 pkgname=xfce4-sensors-plugin
-version=1.3.0
-revision=2
+version=1.3.92
+revision=1
 build_style=gnu-configure
 configure_args="--disable-static"
 hostmakedepends="pkg-config intltool"
@@ -12,7 +12,7 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="https://goodies.xfce.org/projects/panel-plugins/xfce4-sensors-plugin"
 distfiles="https://archive.xfce.org/src/panel-plugins/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=b7a7834ca84f6751686fa2e20e0b44a2e68ece0cb2716792a765e03b92f65569
+checksum=3dc6643d2c064b7718badff44b948f8d410f00f13db197820b26ae38045f5112
 
 if [ "$CROSS_BUILD" ]; then
 	# Cannot detect these when cross compiling

From acf21efe2da9fab3223611ec0e2f33264ec59c71 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:55:52 -0400
Subject: [PATCH 27/32] xfce4-weather-plugin: update to 0.9.1.

---
 srcpkgs/xfce4-weather-plugin/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/xfce4-weather-plugin/template b/srcpkgs/xfce4-weather-plugin/template
index 8c3bab3185c..e6f9671ba6a 100644
--- a/srcpkgs/xfce4-weather-plugin/template
+++ b/srcpkgs/xfce4-weather-plugin/template
@@ -1,6 +1,6 @@
 # Template file for 'xfce4-weather-plugin'
 pkgname=xfce4-weather-plugin
-version=0.8.11
+version=0.9.1
 revision=1
 build_style=gnu-configure
 configure_args="--disable-upower"
@@ -12,5 +12,5 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="https://goodies.xfce.org/projects/panel-plugins/xfce4-weather-plugin"
 distfiles="https://archive.xfce.org/src/panel-plugins/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=0382ce99c0ad4424afe7096a354f301a9396d12807a0f2ab041912d6ab58145d
+checksum=7cdc18b8df759dee4ceaaf6ce303eff7fda48e247dbc26b78142929213506cfd
 lib32disabled=yes

From 7a127e7ee2676d91d3f1f9500047f4b002b5e68b Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:56:18 -0400
Subject: [PATCH 28/32] xfce4-windowck-plugin: update to 0.4.6.

---
 srcpkgs/xfce4-windowck-plugin/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/xfce4-windowck-plugin/template b/srcpkgs/xfce4-windowck-plugin/template
index 355ae97ad5d..5d897ba7154 100644
--- a/srcpkgs/xfce4-windowck-plugin/template
+++ b/srcpkgs/xfce4-windowck-plugin/template
@@ -1,17 +1,17 @@
 # Template file for 'xfce4-windowck-plugin'
 pkgname=xfce4-windowck-plugin
-version=0.4.4
-revision=2
+version=0.4.6
+revision=1
 build_style=gnu-makefile
 hostmakedepends="intltool xfce4-dev-tools exo-devel python3-devel glib-devel gettext-devel ImageMagick"
 makedepends="libwnck2-devel xfce4-panel-devel xorg-server-devel"
-depends="xfce4-panel>=4.10"
+depends="xfce4-panel>=4.13"
 short_desc="Puts the titlebar of a maximized window into a panel"
 maintainer="skurtix <skurtix@github.com>"
 homepage="https://github.com/cedl38/xfce4-windowck-plugin"
 license="GPL-3"
 distfiles="${homepage}/archive/v${version}.tar.gz"
-checksum=92b6c9e199d32cf96619c31e2cfac19e375575d581e78fa043f9f6a59c1df13f
+checksum=1643fa4a8bdbc401160fae6a132dcab89ed88d10231f84ed058f7a3e842763f7
 
 pre_configure() {
 	autogen_args="--prefix=/usr"

From 3075e0a35c5f4e918e45d3d2b29d5c7ff7c9bdf2 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:56:43 -0400
Subject: [PATCH 29/32] xfce4-xkb-plugin: revbump for xfconf

---
 srcpkgs/xfce4-xkb-plugin/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/xfce4-xkb-plugin/template b/srcpkgs/xfce4-xkb-plugin/template
index 30ec3089bbb..d64ee2670ee 100644
--- a/srcpkgs/xfce4-xkb-plugin/template
+++ b/srcpkgs/xfce4-xkb-plugin/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-xkb-plugin'
 pkgname=xfce4-xkb-plugin
 version=0.8.1
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool"
 makedepends="garcon-devel xfce4-panel-devel libxklavier-devel librsvg-devel libwnck-devel"

From 23a4ae04bc5adc063fc18a98bfcf16ccd7f7b5a4 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Tue, 2 Jul 2019 09:09:54 -0400
Subject: [PATCH 30/32] thunar-volman: update to 0.9.3.

---
 srcpkgs/thunar-volman/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/thunar-volman/template b/srcpkgs/thunar-volman/template
index 808725a915a..0d31e00202a 100644
--- a/srcpkgs/thunar-volman/template
+++ b/srcpkgs/thunar-volman/template
@@ -1,7 +1,7 @@
 # Template file for 'thunar-volman'
 pkgname=thunar-volman
-version=0.9.2
-revision=2
+version=0.9.3
+revision=1
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool"
 makedepends="libgudev-devel libnotify-devel libxfce4ui-devel exo-devel"
@@ -12,4 +12,4 @@ license="GPL-2.0-or-later"
 homepage="https://xfce.org/"
 changelog="https://git.xfce.org/xfce/thunar-volman/plain/NEWS?h=${pkgname}-${version}"
 distfiles="https://archive.xfce.org/src/xfce/$pkgname/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=b944b4299b73d2ca79184922dfea49782e4849f5960e209def71ac700a92ff27
+checksum=29309091db8b0f08c5a727625cc470673134977d7966cae0392f131300f9d5e9

From b129ecb6de18f9113c050c79a5cc71d2edd106dd Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Tue, 2 Jul 2019 09:13:52 -0400
Subject: [PATCH 31/32] tumbler: update to 0.2.5.

---
 srcpkgs/tumbler/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/tumbler/template b/srcpkgs/tumbler/template
index f385ee3d43c..5c2bbc21394 100644
--- a/srcpkgs/tumbler/template
+++ b/srcpkgs/tumbler/template
@@ -1,6 +1,6 @@
 # Template file for 'tumbler'.
 pkgname=tumbler
-version=0.2.3
+version=0.2.5
 revision=1
 build_style=gnu-configure
 configure_args="--disable-gstreamer-thumbnailer"
@@ -12,7 +12,7 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=d022e1bd1559fba33e4bf20fb053b219eca17676ebffb1ceb214fcd58a187d40
+checksum=6447697a861a4854f18348a4dc6aa8b7903a0f22c52350b793fab6bc6968d459
 
 CFLAGS="-I${XBPS_CROSS_BASE}/usr/include/freetype2"
 

From 4e5458ac39e4bc91473e7bb9e1f2c7d8fd14a6f5 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Tue, 2 Jul 2019 09:15:35 -0400
Subject: [PATCH 32/32] garcon: update to 0.6.3.

---
 srcpkgs/garcon/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/garcon/template b/srcpkgs/garcon/template
index 1c61229691d..8240d7b9a11 100644
--- a/srcpkgs/garcon/template
+++ b/srcpkgs/garcon/template
@@ -1,7 +1,7 @@
 # Template file for 'garcon'
 pkgname=garcon
-version=0.6.2
-revision=2
+version=0.6.3
+revision=1
 build_style=gnu-configure
 configure_args="--disable-static"
 hostmakedepends="pkg-config intltool gettext-devel glib-devel"
@@ -12,7 +12,7 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="LGPL-2.0-or-later"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/garcon/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=a87f09648ff10d45c524b3bfe618f18622bdd8b205589d35fed2f12d9c79c47c
+checksum=76b1fea531363e9c5e767f1899039b4fe854edf23f6c0f260807e5551f798401
 
 garcon-devel_package() {
 	depends="${sourcepkg}>=${version}_${revision} libxfce4ui-devel gtk+3-devel"

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PR PATCH] [Updated] [RFC] xfce4-4.14pre2
       [not found] <gh-mailinglist-notifications-41a7ca26-5023-4802-975b-f1789d68868e-void-packages-11932@inbox.vuxu.org>
                   ` (2 preceding siblings ...)
  2019-07-02 13:16 ` [PR PATCH] [Updated] [RFC] xfce4-4.14pre2 voidlinux-github
@ 2019-07-02 13:16 ` voidlinux-github
  2019-07-02 13:19 ` voidlinux-github
                   ` (2 subsequent siblings)
  6 siblings, 0 replies; 7+ messages in thread
From: voidlinux-github @ 2019-07-02 13:16 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 723 bytes --]

There is an updated pull request by pbui against master on the void-packages repository

https://github.com/pbui/void-packages xfce4-4.14
https://github.com/void-linux/void-packages/pull/11932

[RFC] xfce4-4.14pre2
This updates the core xfce4 packages to 4.14pre1 status as outlined here:

https://wiki.xfce.org/releng/4.14/xfce_4.14pre1

This also includes some revbumps and updates to packages that depend on xfconf (which has a SO bump).

I'm not sure if we want to update all the packages now, wait until 4.14 is released, or update individual packages on a case-by-case basis.  That is what I am marking this with [RFC].

A patch file from https://github.com/void-linux/void-packages/pull/11932.patch is attached

[-- Warning: decoded text below may be mangled --]
[-- Attachment #2: github-pr-xfce4-4.14-11932.patch --]
[-- Type: application/text/x-diff, Size: 41126 bytes --]

From aa66a9411b6d698026033b6427f08b6c954babb3 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:33:32 -0400
Subject: [PATCH 01/32] xfconf: update to 4.13.8.

- Update common/shlibs for libxfconf-0.so.3
- glib-devel needs to be hostmakedepends for cross-compiling
---
 common/shlibs           | 2 +-
 srcpkgs/xfconf/template | 8 ++++----
 2 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index 22c315708e6..f49e5937f7e 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -179,7 +179,7 @@ libnl-genl-3.so.200 libnl3-3.2.1_1
 libnl-cli-3.so.200 libnl3-3.2.1_1
 libreadline.so.8 libreadline8-8.0_1
 libhistory.so.8 libhistory8-8.0_1
-libxfconf-0.so.2 xfconf-4.9.1_1
+libxfconf-0.so.3 xfconf-4.13.7_1
 libxfce4util.so.7 libxfce4util-4.12.1_1
 libxfce4panel-1.0.so.4 xfce4-panel-4.9.2_1
 libxfce4panel-2.0.so.4 xfce4-panel-4.12.0_1
diff --git a/srcpkgs/xfconf/template b/srcpkgs/xfconf/template
index fb150ff36f1..10605f3d8d1 100644
--- a/srcpkgs/xfconf/template
+++ b/srcpkgs/xfconf/template
@@ -1,18 +1,18 @@
 # Template file for 'xfconf'
 pkgname=xfconf
-version=4.12.1
+version=4.13.8
 revision=1
 build_options="perl"
 build_style=gnu-configure
 configure_args="$(vopt_enable perl 'perl-bindings --with-perl-options=INSTALLDIRS=vendor')"
-hostmakedepends="pkg-config intltool"
-makedepends="dbus-glib-devel libxfce4util-devel $(vopt_if perl 'perl-ExtUtils-Depends perl-ExtUtils-PkgConfig perl-Glib')"
+hostmakedepends="pkg-config intltool glib-devel"
+makedepends="libxfce4util-devel $(vopt_if perl 'perl-ExtUtils-Depends perl-ExtUtils-PkgConfig perl-Glib')"
 short_desc="Xfce hierarchical (tree-like) configuration system"
 maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2, LGPL-2.1"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/xfconf/${version%.*}/$pkgname-$version.tar.bz2"
-checksum=35f48564e5694faa54fdc180cd3268e16fc2352946a89a3c2fc12cbe400ada36
+checksum=55e2441c4ff78a7006fabb59647f7bc1f190cbb82327b93ba063ff624a896591
 
 xfconf-devel_package() {
 	depends="dbus-glib-devel ${sourcepkg}>=${version}_${revision}"

From 58902b9f356fb2a2c23323cd62c00eb4ba54ab35 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Tue, 2 Jul 2019 08:51:42 -0400
Subject: [PATCH 02/32] libxfce4util: update to 4.13.4.

Use gir build helper (for cross-compilation)
---
 srcpkgs/libxfce4util/template | 16 ++++++++++++----
 1 file changed, 12 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/libxfce4util/template b/srcpkgs/libxfce4util/template
index 6c2f3cf4a3b..9ebc4f45422 100644
--- a/srcpkgs/libxfce4util/template
+++ b/srcpkgs/libxfce4util/template
@@ -1,8 +1,9 @@
 # Template file for 'libxfce4util'
 pkgname=libxfce4util
-version=4.12.1
-revision=3
+version=4.13.4
+revision=1
 build_style=gnu-configure
+build_helper="gir"
 hostmakedepends="pkg-config intltool"
 makedepends="libglib-devel"
 short_desc="Utility library for the Xfce4 desktop environment"
@@ -10,7 +11,11 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="LGPL-2.0-or-later"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/$pkgname/${version%.*}/$pkgname-$version.tar.bz2"
-checksum=876bdefa2e13cbf68b626b2158892fb93e824e1ef59cf951123a96cefbc8881d
+checksum=57dd4ba226432afdf98cea4700a4679bb1b57ce80713167f99fde50ad87d0863
+
+# Package build options
+build_options="gir"
+build_options_default="gir"
 
 libxfce4util-devel_package() {
 	depends="libglib-devel ${sourcepkg}>=${version}_${revision}"
@@ -19,6 +24,9 @@ libxfce4util-devel_package() {
 		vmove usr/include
 		vmove usr/lib/pkgconfig
 		vmove usr/share/gtk-doc
-		vmove usr/lib/*.so
+		vmove "usr/lib/*.so"
+		if [ "$build_option_gir" ]; then
+			vmove usr/share/gir-1.0
+		fi
 	}
 }

From a66d5dc5927b07382f5b780a615a1d5e2f937a3f Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:32:15 -0400
Subject: [PATCH 03/32] libxfce4ui: update to 4.13.6.

Use gir build helper (for cross-compilation)
---
 srcpkgs/libxfce4ui/template | 19 +++++++++++--------
 1 file changed, 11 insertions(+), 8 deletions(-)

diff --git a/srcpkgs/libxfce4ui/template b/srcpkgs/libxfce4ui/template
index ac82ac043b3..558dc608995 100644
--- a/srcpkgs/libxfce4ui/template
+++ b/srcpkgs/libxfce4ui/template
@@ -1,24 +1,24 @@
 # Template file for 'libxfce4ui'
 pkgname=libxfce4ui
-version=4.12.1
-revision=3
+version=4.13.6
+revision=1
 build_style=gnu-configure
+build_helper="gir"
 configure_args="--disable-static"
 conf_files="/etc/xdg/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml"
 hostmakedepends="xfce4-dev-tools pkg-config intltool glib-devel gettext-devel"
-makedepends="gtk+-devel gtk+3-devel libxfce4util-devel xfconf-devel dbus-glib-devel
+makedepends="gtk+-devel gtk+3-devel libxfce4util-devel xfconf-devel
  libxml2-devel startup-notification-devel libSM-devel"
 short_desc="Replacement of the old libxfcegui4 library"
 maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="LGPL-2.0-or-later"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=3d619811bfbe7478bb984c16543d980cadd08586365a7bc25e59e3ca6384ff43
+checksum=3c5e505ce56a5993db473efed9962705dd255ffaee17009ed1b3e9f40b543969
 
-pre_configure() {
-	mkdir m4
-	NOCONFIGURE=1 xdt-autogen
-}
+# Package build options
+build_options="gir"
+build_options_default="gir"
 
 libxfce4ui-devel_package() {
 	depends="${makedepends} ${sourcepkg}>=${version}_${revision}"
@@ -28,5 +28,8 @@ libxfce4ui-devel_package() {
 		vmove usr/lib/pkgconfig
 		vmove "usr/lib/*.so"
 		vmove usr/share/gtk-doc
+                if [ "$build_option_gir" ]; then
+                        vmove usr/share/gir-1.0
+                fi
 	}
 }

From daf5cb8d0ec9196ae930b31409000f2d5d8cd051 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:36:47 -0400
Subject: [PATCH 04/32] libwnck: update to 3.32.0.

Switch to meson build style.
---
 srcpkgs/libwnck/template | 13 ++++++-------
 1 file changed, 6 insertions(+), 7 deletions(-)

diff --git a/srcpkgs/libwnck/template b/srcpkgs/libwnck/template
index 1775a4bc55d..83190d54f68 100644
--- a/srcpkgs/libwnck/template
+++ b/srcpkgs/libwnck/template
@@ -1,11 +1,11 @@
 # Template file for 'libwnck'
 pkgname=libwnck
-version=3.30.0
-revision=2
-build_style=gnu-configure
+version=3.32.0
+revision=1
+build_style=meson
 build_helper="gir"
-configure_args="$(vopt_enable gir introspection)"
-hostmakedepends="gdk-pixbuf-devel pkg-config intltool
+#configure_args="$(vopt_enable gir introspection)"
+hostmakedepends="gdk-pixbuf-devel pkg-config intltool glib-devel
  $(vopt_if gir gobject-introspection)"
 makedepends="startup-notification-devel gtk+3-devel libXres-devel"
 short_desc="Library for layout and rendering of text"
@@ -13,7 +13,7 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="LGPL-2.1-or-later"
 homepage="http://www.gnome.org/"
 distfiles="${GNOME_SITE}/${pkgname}/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=ac6d0d2646aa80676d3066651e73abb7bff7ed79be238c9b21a0083e2adc3439
+checksum=9595835cf28d0fc6af5526a18f77f2fcf3ca8c09e36741bb33915b6e69b8e3ca
 
 build_options="gir"
 build_options_default="gir"
@@ -25,7 +25,6 @@ libwnck-devel_package() {
 		vmove usr/include
 		vmove usr/lib/pkgconfig
 		vmove "usr/lib/*.so"
-		vmove usr/share/gtk-doc
 		if [ "$build_option_gir" ]; then
 			vmove usr/share/gir-1.0
 		fi

From c74ebd6c86db372fbde953bf5b60019718fb0b62 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Tue, 2 Jul 2019 08:52:01 -0400
Subject: [PATCH 05/32] xfce4-dev-tools: update to 4.13.0.

---
 srcpkgs/xfce4-dev-tools/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/xfce4-dev-tools/template b/srcpkgs/xfce4-dev-tools/template
index 6e452ee4154..3fe83a41c70 100644
--- a/srcpkgs/xfce4-dev-tools/template
+++ b/srcpkgs/xfce4-dev-tools/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-dev-tools'
 pkgname=xfce4-dev-tools
-version=4.12.0
-revision=2
+version=4.13.0
+revision=1
 build_style=gnu-configure
 hostmakedepends="automake libtool gtk-doc intltool pkg-config"
 makedepends="libglib-devel"
@@ -11,4 +11,4 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=e2e3a654fe9110df81f8c2483c9cbfa6d656fed15d5e5e717d6ef10bd0f5b5cb
+checksum=d24d4db2151a35324c672d4596a6a256f7d92727fe6a9d23648ab53f5207ba3b

From c4c6a1c6efa2a49394a11eaff25fe3b173eccca6 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:37:52 -0400
Subject: [PATCH 06/32] xfce4-panel: update to 4.13.6.

Switch to libwnck, drop dbus-glib, use gir build helper (for cross-compilation)
---
 srcpkgs/xfce4-panel/template | 19 +++++++++++--------
 1 file changed, 11 insertions(+), 8 deletions(-)

diff --git a/srcpkgs/xfce4-panel/template b/srcpkgs/xfce4-panel/template
index ee9c8d5aebc..5a3c55ba164 100644
--- a/srcpkgs/xfce4-panel/template
+++ b/srcpkgs/xfce4-panel/template
@@ -1,23 +1,23 @@
 # Template file for 'xfce4-panel'
 pkgname=xfce4-panel
-version=4.12.2
+version=4.13.6
 revision=1
 build_style=gnu-configure
+build_helper="gir"
 configure_args="--disable-static --enable-gio-unix --enable-gtk3"
 hostmakedepends="xfce4-dev-tools pkg-config intltool gettext-devel glib-devel"
 makedepends="gtk+3-devel libxfce4ui-devel xfconf-devel
- dbus-glib-devel libwnck2-devel garcon-devel exo-devel"
+ libwnck-devel garcon-devel exo-devel"
 short_desc="Next generation panel for the XFCE desktop environment"
 maintainer="Juan RP <xtraeme@voidlinux.org>"
 homepage="https://xfce.org/"
 license="GPL-2"
 distfiles="https://archive.xfce.org/src/xfce/$pkgname/${version%.*}/$pkgname-$version.tar.bz2"
-checksum=42058abb81b8f87691d3999627447de71c3285bcf055f308aab5cefab2de0ce9
+checksum=42411fee7675bb6fb3055395673dc925d43495df93b5e940a1ae3d0a3d2f63a8
 
-pre_configure() {
-	mkdir m4
-	NOCONFIGURE=1 xdt-autogen
-}
+# Package build options
+build_options="gir"
+build_options_default="gir"
 
 xfce4-panel-devel_package() {
 	depends="libxfce4ui-devel ${sourcepkg}>=${version}_${revision}"
@@ -26,6 +26,9 @@ xfce4-panel-devel_package() {
 		vmove usr/include
 		vmove usr/lib/pkgconfig
 		vmove usr/share/gtk-doc
-		vmove usr/lib/*.so
+		vmove "usr/lib/*.so"
+                if [ "$build_option_gir" ]; then
+                        vmove usr/share/gir-1.0
+                fi
 	}
 }

From e9319fb4549abd9494b55e276b04b5a67efe7d56 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:40:46 -0400
Subject: [PATCH 07/32] xfdesktop: update to 4.13.5.

Switch to libwnck, drop dbus-glib
---
 srcpkgs/xfdesktop/template | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/xfdesktop/template b/srcpkgs/xfdesktop/template
index be1056cf50b..7fb2848f4c8 100644
--- a/srcpkgs/xfdesktop/template
+++ b/srcpkgs/xfdesktop/template
@@ -1,16 +1,15 @@
 # Template file for 'xfdesktop'
 pkgname=xfdesktop
-version=4.12.5
+version=4.13.5
 revision=1
 build_style=gnu-configure
-hostmakedepends="pkg-config intltool glib-devel dbus-glib-devel"
-# XXX Add Thunar-devel again once xfdesktop supports the new Thunarx-3 API
+hostmakedepends="pkg-config intltool glib-devel Thunar-devel"
 makedepends="libxfce4ui-devel exo-devel garcon-devel
- libnotify-devel libwnck2-devel"
+ libnotify-devel libwnck-devel"
 depends="hicolor-icon-theme desktop-file-utils"
 short_desc="Desktop manager for the Xfce Desktop Environment"
 maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/xfdesktop/${version%.*}/$pkgname-$version.tar.bz2"
-checksum=3f2426ac28b94cfe5d6fd187c59b4e78f40e66c2842318e158ecd82abe2e7c0a
+checksum=b7d273d36f5f39a446c4d0303148bc595ed7b0f36269619c91526edd1d1caeb6

From 4be7ffe07643bf86d9b462a8dcc1be4d0467ce90 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:41:45 -0400
Subject: [PATCH 08/32] xfwm4: update to 4.13.3.

Switch to libwnck, add Xpresent
---
 srcpkgs/xfwm4/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/xfwm4/template b/srcpkgs/xfwm4/template
index 58d1cc533df..fa2f78ae03e 100644
--- a/srcpkgs/xfwm4/template
+++ b/srcpkgs/xfwm4/template
@@ -1,16 +1,16 @@
 # Template file for 'xfwm4'
 pkgname=xfwm4
-version=4.12.5
+version=4.13.3
 revision=1
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool"
 makedepends="libxfce4ui-devel startup-notification-devel
  libXcomposite-devel libXdamage-devel libXfixes-devel libXrandr-devel
- libXrender-devel dbus-glib-devel libwnck2-devel"
+ libXrender-devel libXpresent-devel libwnck-devel"
 depends="hicolor-icon-theme desktop-file-utils"
 short_desc="Next generation window manager for Xfce"
 maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/xfwm4/${version%.*}/xfwm4-${version}.tar.bz2"
-checksum=7775c02216666c2d023275e7ed6d85e57d965e5cc1407bb6a05c53cc38d8caca
+checksum=12ad274f6662c8afee35fd9b9310e73bd462c423578d448b2d7353e3c8eda6c1

From c0deb78120252f2af06cd5cc2581725a39947da2 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:43:17 -0400
Subject: [PATCH 09/32] thunar-volman: revbump for xfconf

---
 srcpkgs/thunar-volman/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/thunar-volman/template b/srcpkgs/thunar-volman/template
index 15a066edaee..808725a915a 100644
--- a/srcpkgs/thunar-volman/template
+++ b/srcpkgs/thunar-volman/template
@@ -1,7 +1,7 @@
 # Template file for 'thunar-volman'
 pkgname=thunar-volman
 version=0.9.2
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool"
 makedepends="libgudev-devel libnotify-devel libxfce4ui-devel exo-devel"

From 8efe14fbf4e4c374f30df24ec738dbd4222b1d97 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:43:57 -0400
Subject: [PATCH 10/32] xfce4-settings: update to 4.13.7.

---
 srcpkgs/xfce4-settings/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/xfce4-settings/template b/srcpkgs/xfce4-settings/template
index 1944a3acf6e..7f122d774f5 100644
--- a/srcpkgs/xfce4-settings/template
+++ b/srcpkgs/xfce4-settings/template
@@ -1,6 +1,6 @@
 # Template file for 'xfce4-settings'
 pkgname=xfce4-settings
-version=4.12.4
+version=4.13.7
 revision=1
 build_style=gnu-configure
 configure_args="--enable-sound-settings --enable-pluggable-dialogs"
@@ -15,4 +15,4 @@ license="GPL-2.0-only"
 homepage="https://xfce.org/"
 changelog="https://raw.githubusercontent.com/xfce-mirror/xfce4-settings/master/NEWS"
 distfiles="https://archive.xfce.org/src/xfce/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=e2a04cad48bf9e951409d0c841829fa3b4ce632cd799082ef82d0506618b6f9b
+checksum=ac11391eee22cb5fbffe3342916bcf9805f29c722aca825c2f57d98dc167a065

From 9811a79b48cf41b7f4928b20bc9ca1c33bd4361e Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:44:21 -0400
Subject: [PATCH 11/32] xfce4-session: update to 4.13.3.

Switch to libwnck, drop dbus-glib, remove unnecessary --enable-upower
configure flag
---
 srcpkgs/xfce4-session/template | 19 +++++++------------
 1 file changed, 7 insertions(+), 12 deletions(-)

diff --git a/srcpkgs/xfce4-session/template b/srcpkgs/xfce4-session/template
index 6c4b9ecf265..eef01d28e3f 100644
--- a/srcpkgs/xfce4-session/template
+++ b/srcpkgs/xfce4-session/template
@@ -1,12 +1,12 @@
 # Template file for 'xfce4-session'
 pkgname=xfce4-session
-version=4.12.1
-revision=2
+version=4.13.3
+revision=1
 build_style=gnu-configure
-configure_args="--disable-static --enable-upower --enable-polkit"
+configure_args="--disable-static --enable-polkit"
 hostmakedepends="xfce4-dev-tools pkg-config intltool gettext-devel glib-devel iceauth"
-makedepends="libxfce4ui-devel dbus-glib-devel upower-devel
- libwnck2-devel xfce4-panel-devel libSM-devel polkit-devel"
+makedepends="libxfce4ui-devel upower-devel
+ libwnck-devel xfce4-panel-devel libSM-devel polkit-devel"
 depends="iceauth hicolor-icon-theme desktop-file-utils"
 conf_files="/etc/xdg/xfce4/xfconf/xfce-perchannel-xml/xfce4-session.xml"
 short_desc="The session manager for the XFCE desktop environment"
@@ -14,22 +14,17 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/$pkgname/${version%.*}/$pkgname-$version.tar.bz2"
-checksum=97d7f2a2d0af7f3623b68d1f04091e02913b28f9555dab8b0d26c8a1299d08fd
+checksum=eaed34f29aa044d878d60dcb7293a542f48248919e3dcd8df98215121cb6d362
 
-pre_configure() {
-	mkdir m4
-	NOCONFIGURE=1 xdt-autogen
-}
 post_install() {
 	# startxfce4 needs bash.
 	replace_interpreter bash ${DESTDIR}/usr/bin/startxfce4
 }
 
 xfce4-session-devel_package() {
-	depends="libxfce4ui-devel>=4.12 ${sourcepkg}>=${version}_${revision}"
+	depends="libxfce4ui-devel>=4.13 ${sourcepkg}>=${version}_${revision}"
 	short_desc+=" - development files"
 	pkg_install() {
-		vmove usr/include
 		vmove usr/lib/pkgconfig
 		vmove "usr/lib/*.so"
 	}

From ab037ba566d01be3e6927bcd4941ab63d754421a Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:46:36 -0400
Subject: [PATCH 12/32] xfce4-appfinder: update to 4.13.4.

---
 srcpkgs/xfce4-appfinder/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/xfce4-appfinder/template b/srcpkgs/xfce4-appfinder/template
index 0ebe4dd92c7..ef75eb636b6 100644
--- a/srcpkgs/xfce4-appfinder/template
+++ b/srcpkgs/xfce4-appfinder/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-appfinder'
 pkgname=xfce4-appfinder
-version=4.12.0
-revision=3
+version=4.13.4
+revision=1
 build_style=gnu-configure
 configure_args="--enable-gtk3"
 hostmakedepends="pkg-config intltool"
@@ -12,4 +12,4 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=2ad4a58019a76a6b64a816050db25f96854917c2f2e89d6a9df6c18e6c84c567
+checksum=0f4de2a5e2875cfa2862fd73ba1d32fb798df71849f69e68cd28cdde1cf53a02

From bc039f09a4d99710143b1f34cbcb3f9a5d470474 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:47:16 -0400
Subject: [PATCH 13/32] xfce4-clipman-plugin: revbump for xfconf

---
 srcpkgs/xfce4-clipman-plugin/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/xfce4-clipman-plugin/template b/srcpkgs/xfce4-clipman-plugin/template
index 3d973e08e06..987a68f7d5f 100644
--- a/srcpkgs/xfce4-clipman-plugin/template
+++ b/srcpkgs/xfce4-clipman-plugin/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-clipman-plugin'
 pkgname=xfce4-clipman-plugin
 version=1.4.3
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="intltool pkg-config"
 makedepends="xfce4-panel-devel libXtst-devel qrencode-devel"

From 701510064770b03e56a84b4b0e075d621114591f Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:47:43 -0400
Subject: [PATCH 14/32] xfce4-notes-plugin: revbump for xfconf

---
 srcpkgs/xfce4-notes-plugin/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/xfce4-notes-plugin/template b/srcpkgs/xfce4-notes-plugin/template
index ce150733001..1df5d9776e8 100644
--- a/srcpkgs/xfce4-notes-plugin/template
+++ b/srcpkgs/xfce4-notes-plugin/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-notes-plugin'
 pkgname=xfce4-notes-plugin
 version=1.8.1
-revision=2
+revision=3
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool"
 makedepends="xfce4-panel-devel libunique1-devel"

From b2a5d6cfe789db76d22b0cb1e593e4b8fed6a02e Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:48:12 -0400
Subject: [PATCH 15/32] xfce4-notifyd: revbump for xfconf

---
 srcpkgs/xfce4-notifyd/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/xfce4-notifyd/template b/srcpkgs/xfce4-notifyd/template
index cc07838d602..65500dc824e 100644
--- a/srcpkgs/xfce4-notifyd/template
+++ b/srcpkgs/xfce4-notifyd/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-notifyd'
 pkgname=xfce4-notifyd
 version=0.4.4
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool glib-devel dbus-glib-devel"
 makedepends="libnotify-devel xfce4-panel-devel"

From b0a5994608340f29cffac814fbcf44389f95062f Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:49:24 -0400
Subject: [PATCH 16/32] mousepad: remove unnecessary makedepends on
 libxfce4ui-devel

---
 srcpkgs/mousepad/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/mousepad/template b/srcpkgs/mousepad/template
index 54160a9218e..f604781fb34 100644
--- a/srcpkgs/mousepad/template
+++ b/srcpkgs/mousepad/template
@@ -1,10 +1,10 @@
 # Template file for 'mousepad'
 pkgname=mousepad
 version=0.4.1
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="glib-devel intltool pkg-config"
-makedepends="gtksourceview-devel libxfce4ui-devel"
+makedepends="gtksourceview-devel"
 depends="desktop-file-utils hicolor-icon-theme"
 short_desc="Simple text editor for Xfce based on Leafpad"
 maintainer="Juan RP <xtraeme@voidlinux.org>"

From a147b5b408ed10b29ccf1e9fdf58b796b5f4ccda Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:50:10 -0400
Subject: [PATCH 17/32] orage: remove unnecessary makedepends on dbus-glib

---
 srcpkgs/orage/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/orage/template b/srcpkgs/orage/template
index c0a9f23c448..bd0b9fcb6eb 100644
--- a/srcpkgs/orage/template
+++ b/srcpkgs/orage/template
@@ -1,10 +1,10 @@
 # Template file for 'orage'
 pkgname=orage
 version=4.12.1
-revision=3
+revision=4
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool flex"
-makedepends="libical-devel libnotify-devel gtk+-devel dbus-glib-devel
+makedepends="libical-devel libnotify-devel gtk+-devel
  popt-devel xfce4-panel-devel libxfce4util-devel"
 depends="hicolor-icon-theme desktop-file-utils"
 short_desc="Simple calendar application for Xfce"

From 33f9dcc173fc10d8834dfb124cc427518e7d61b2 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:50:51 -0400
Subject: [PATCH 18/32] parole: revbump for xfconf

---
 srcpkgs/parole/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/parole/template b/srcpkgs/parole/template
index efd712729fe..82bdfe94511 100644
--- a/srcpkgs/parole/template
+++ b/srcpkgs/parole/template
@@ -1,7 +1,7 @@
 # Template file for 'parole'
 pkgname=parole
 version=1.0.2
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool glib-devel"
 makedepends="gst-plugins-base1-devel libnotify-devel taglib-devel libxfce4ui-devel"

From 9e85a4acc1e0b8b91e69592fbd806e6c81419e77 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:51:12 -0400
Subject: [PATCH 19/32] ristretto: revbump for xfconf

---
 srcpkgs/ristretto/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/ristretto/template b/srcpkgs/ristretto/template
index 38dbc735472..7e761eb7c57 100644
--- a/srcpkgs/ristretto/template
+++ b/srcpkgs/ristretto/template
@@ -1,7 +1,7 @@
 # Template file for 'ristretto'
 pkgname=ristretto
 version=0.8.4
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="intltool pkg-config"
 makedepends="exo-devel file-devel libexif-devel"

From 2950675236a493e3ea18cfd1c224807a1818c3d8 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:51:31 -0400
Subject: [PATCH 20/32] vala-panel-appmenu: update to 0.7.2

---
 srcpkgs/vala-panel-appmenu/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/vala-panel-appmenu/template b/srcpkgs/vala-panel-appmenu/template
index 47c8b247bba..fa197105c43 100644
--- a/srcpkgs/vala-panel-appmenu/template
+++ b/srcpkgs/vala-panel-appmenu/template
@@ -1,7 +1,7 @@
 # Template file for 'vala-panel-appmenu'
 pkgname=vala-panel-appmenu
-version=0.7.1
-revision=2
+version=0.7.2
+revision=1
 build_style=cmake
 configure_args="-DENABLE_XFCE=ON -DENABLE_VALAPANEL=ON
  -DENABLE_MATE=ON -DENABLE_JAYATANA=OFF -DENABLE_APPMENU_GTK_MODULE=ON"
@@ -15,8 +15,8 @@ short_desc="Global Menu for Vala Panel"
 maintainer="John Eira <john.eira@web.de>"
 license="LGPL-3.0-or-later"
 homepage="https://gitlab.com/vala-panel-project/vala-panel-appmenu"
-distfiles="https://gitlab.com/vala-panel-project/vala-panel-appmenu/uploads/c0f85b42a2a228ad8c3413357e02fb28/vala-panel-appmenu-${version}.tar.xz"
-checksum=54a1b4f6ceca63eb3b79facc4327424bdd82f0fe3b7c6139326dbe0ec0824dcc
+distfiles="https://gitlab.com/vala-panel-project/vala-panel-appmenu/uploads/57fe7a74b38180002154fbd6028075db/vala-panel-appmenu-${version}.tar.xz"
+checksum=80884ebd71b665da7a1eac67752596ecbb29d3a8dd9eee9a2e3212dfc0aab6ae
 
 post_install() {
 	if [ "$CROSS_BUILD" ]; then

From bffb54931ddc448bd9245c846f47df1db30c2ab6 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:52:06 -0400
Subject: [PATCH 21/32] xfce4-places-plugin: update to 1.8.0.

Remove unnecessary patch.
---
 .../patches/undefined-symbol.patch            | 69 -------------------
 srcpkgs/xfce4-places-plugin/template          |  6 +-
 2 files changed, 3 insertions(+), 72 deletions(-)
 delete mode 100644 srcpkgs/xfce4-places-plugin/patches/undefined-symbol.patch

diff --git a/srcpkgs/xfce4-places-plugin/patches/undefined-symbol.patch b/srcpkgs/xfce4-places-plugin/patches/undefined-symbol.patch
deleted file mode 100644
index a94d9ea706f..00000000000
--- a/srcpkgs/xfce4-places-plugin/patches/undefined-symbol.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-From 94d583d0ba257cdc96cde5794ebb7d38001ae3a5 Mon Sep 17 00:00:00 2001
-From: Andrzej <ndrwrdck@gmail.com>
-Date: Tue, 7 Jul 2015 22:26:51 +0100
-Subject: [PATCH] Bug 11939:  xfce4-places-plugin 1.7.0 crashes with undefined
- symbol
-
-Patch from Fedora. Submitted by Kevin Fenzi.
----
- panel-plugin/model.h | 18 +++++++++---------
- 1 file changed, 9 insertions(+), 9 deletions(-)
-
-diff --git a/panel-plugin/model.h b/panel-plugin/model.h
-index 06d9d6f..043e391 100644
---- a/panel-plugin/model.h
-+++ b/panel-plugin/model.h
-@@ -36,13 +36,13 @@ struct _PlacesBookmarkAction
-     void        (*finalize) (PlacesBookmarkAction *self);
- };
- 
--inline PlacesBookmarkAction*
-+extern inline PlacesBookmarkAction*
- places_bookmark_action_create(gchar *label);
- 
--inline void
-+extern inline void
- places_bookmark_action_destroy(PlacesBookmarkAction*);
- 
--inline void
-+extern inline void
- places_bookmark_action_call(PlacesBookmarkAction*);
- 
- /* Places Bookmark */
-@@ -70,10 +70,10 @@ struct _PlacesBookmark
-     void                 (*finalize) (PlacesBookmark *self);
- };
- 
--inline PlacesBookmark*
-+extern inline PlacesBookmark*
- places_bookmark_create(gchar *label);
- 
--inline void
-+extern inline void
- places_bookmark_destroy(PlacesBookmark *bookmark);
- 
- /* Places Bookmark Group */
-@@ -86,16 +86,16 @@ struct _PlacesBookmarkGroup
-     gpointer    priv;
- };
- 
--inline GList*
-+extern inline GList*
- places_bookmark_group_get_bookmarks(PlacesBookmarkGroup*);
- 
--inline gboolean
-+extern inline gboolean
- places_bookmark_group_changed(PlacesBookmarkGroup*);
- 
--inline PlacesBookmarkGroup*
-+extern inline PlacesBookmarkGroup*
- places_bookmark_group_create();
- 
--inline void
-+extern inline void
- places_bookmark_group_destroy(PlacesBookmarkGroup*);
- 
- #endif
--- 
-2.6.4
-
diff --git a/srcpkgs/xfce4-places-plugin/template b/srcpkgs/xfce4-places-plugin/template
index b7f2d8ea2f6..1c1c952a16d 100644
--- a/srcpkgs/xfce4-places-plugin/template
+++ b/srcpkgs/xfce4-places-plugin/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-places-plugin'
 pkgname=xfce4-places-plugin
-version=1.7.0
-revision=3
+version=1.8.0
+revision=1
 build_style=gnu-configure
 hostmakedepends="intltool pkg-config"
 makedepends="exo-devel libglib-devel gtk+-devel libxfce4ui-devel libxfce4util-devel
@@ -11,6 +11,6 @@ maintainer="Steve Prybylski <sa.prybylx@gmail.com>"
 license="GPL-2.0-or-later"
 homepage="https://goodies.xfce.org/projects/panel-plugins/xfce4-places-plugin"
 distfiles="https://archive.xfce.org/src/panel-plugins/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=4175c614749abbb5bcf6f49c88125fb0dd36db69f4c374df23563907b16e2c3f
+checksum=7ba3f46f88c2845cbf413efeefaed29157f8b98571856c6e2bf35e4de5d8ecce
 patch_args="-Np1"
 

From 4bdcc13779fc03595bca9baf726a523cc67f4048 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:52:41 -0400
Subject: [PATCH 22/32] xfce4-power-manager: update to 1.6.3.

---
 srcpkgs/xfce4-power-manager/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/xfce4-power-manager/template b/srcpkgs/xfce4-power-manager/template
index 6b44f4d349f..80f1d396a80 100644
--- a/srcpkgs/xfce4-power-manager/template
+++ b/srcpkgs/xfce4-power-manager/template
@@ -1,6 +1,6 @@
 # Template file for 'xfce4-power-manager'
 pkgname=xfce4-power-manager
-version=1.6.1
+version=1.6.3
 revision=1
 build_style=gnu-configure
 configure_args="--disable-static"
@@ -12,4 +12,4 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/$pkgname/${version%.*}/$pkgname-$version.tar.bz2"
-checksum=1ea825452343b895566068018b6d5078608f8f46ce8075ba6bbb4b848f48656b
+checksum=debd8ac2409b5ac230593894b8bb668298f78bd12891623edbfc32ac87c64011

From 14692cbda277380f406ca43d240ef331594c5531 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:53:06 -0400
Subject: [PATCH 23/32] xfce4-pulseaudio-plugin: revbump for xfconf

---
 srcpkgs/xfce4-pulseaudio-plugin/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/xfce4-pulseaudio-plugin/template b/srcpkgs/xfce4-pulseaudio-plugin/template
index d54728002a6..0ff54c57d27 100644
--- a/srcpkgs/xfce4-pulseaudio-plugin/template
+++ b/srcpkgs/xfce4-pulseaudio-plugin/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-pulseaudio-plugin'
 pkgname=xfce4-pulseaudio-plugin
 version=0.4.1
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="gettext-devel xfce4-dev-tools"
 makedepends="libkeybinder3-devel libnotify-devel pulseaudio-devel xfce4-panel-devel"

From e7406f66d0e967702335a2a5ed278497721ad70e Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:53:28 -0400
Subject: [PATCH 24/32] xfce4-screensaver: revbump for xfconf

---
 srcpkgs/xfce4-screensaver/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/xfce4-screensaver/template b/srcpkgs/xfce4-screensaver/template
index af2dba5fabf..aa45226a504 100644
--- a/srcpkgs/xfce4-screensaver/template
+++ b/srcpkgs/xfce4-screensaver/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-screensaver'
 pkgname=xfce4-screensaver
 version=0.1.4
-revision=1
+revision=2
 build_style=gnu-configure
 configure_args="--without-systemd --with-libgl --with-shadow --with-mit-ext
  --with-xf86gamma-ext --with-x --enable-pam"

From 990c0a2806153894ed3a26c238123bf0cea46b80 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:53:50 -0400
Subject: [PATCH 25/32] xfce4-screenshooter: update to 1.9.5.

---
 srcpkgs/xfce4-screenshooter/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/xfce4-screenshooter/template b/srcpkgs/xfce4-screenshooter/template
index 506544c58c3..860a1ee14d4 100644
--- a/srcpkgs/xfce4-screenshooter/template
+++ b/srcpkgs/xfce4-screenshooter/template
@@ -1,6 +1,6 @@
 # Template file for 'xfce4-screenshooter'
 pkgname=xfce4-screenshooter
-version=1.9.4
+version=1.9.5
 revision=1
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool glib-devel"
@@ -11,4 +11,4 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="https://goodies.xfce.org/projects/applications/xfce4-screenshooter"
 distfiles="https://archive.xfce.org/src/apps/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=c4f3225b3f73f1feb1869807b8b27aec4c32a3e9c2954915a5fb39d18d3a60f2
+checksum=bf35b5432cb920987c6d7ff193600e5dd4d73422b6aa02b4ec5288744053b38c

From 3071a77faeceaf14f72677e716c32af5d21d5763 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:54:20 -0400
Subject: [PATCH 26/32] xfce4-sensors-plugin: update to 1.3.92.

---
 srcpkgs/xfce4-sensors-plugin/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/xfce4-sensors-plugin/template b/srcpkgs/xfce4-sensors-plugin/template
index 4c5053fba55..96b8a00b3af 100644
--- a/srcpkgs/xfce4-sensors-plugin/template
+++ b/srcpkgs/xfce4-sensors-plugin/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-sensors-plugin'
 pkgname=xfce4-sensors-plugin
-version=1.3.0
-revision=2
+version=1.3.92
+revision=1
 build_style=gnu-configure
 configure_args="--disable-static"
 hostmakedepends="pkg-config intltool"
@@ -12,7 +12,7 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="https://goodies.xfce.org/projects/panel-plugins/xfce4-sensors-plugin"
 distfiles="https://archive.xfce.org/src/panel-plugins/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=b7a7834ca84f6751686fa2e20e0b44a2e68ece0cb2716792a765e03b92f65569
+checksum=3dc6643d2c064b7718badff44b948f8d410f00f13db197820b26ae38045f5112
 
 if [ "$CROSS_BUILD" ]; then
 	# Cannot detect these when cross compiling

From acf21efe2da9fab3223611ec0e2f33264ec59c71 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:55:52 -0400
Subject: [PATCH 27/32] xfce4-weather-plugin: update to 0.9.1.

---
 srcpkgs/xfce4-weather-plugin/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/xfce4-weather-plugin/template b/srcpkgs/xfce4-weather-plugin/template
index 8c3bab3185c..e6f9671ba6a 100644
--- a/srcpkgs/xfce4-weather-plugin/template
+++ b/srcpkgs/xfce4-weather-plugin/template
@@ -1,6 +1,6 @@
 # Template file for 'xfce4-weather-plugin'
 pkgname=xfce4-weather-plugin
-version=0.8.11
+version=0.9.1
 revision=1
 build_style=gnu-configure
 configure_args="--disable-upower"
@@ -12,5 +12,5 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="https://goodies.xfce.org/projects/panel-plugins/xfce4-weather-plugin"
 distfiles="https://archive.xfce.org/src/panel-plugins/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=0382ce99c0ad4424afe7096a354f301a9396d12807a0f2ab041912d6ab58145d
+checksum=7cdc18b8df759dee4ceaaf6ce303eff7fda48e247dbc26b78142929213506cfd
 lib32disabled=yes

From 7a127e7ee2676d91d3f1f9500047f4b002b5e68b Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:56:18 -0400
Subject: [PATCH 28/32] xfce4-windowck-plugin: update to 0.4.6.

---
 srcpkgs/xfce4-windowck-plugin/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/xfce4-windowck-plugin/template b/srcpkgs/xfce4-windowck-plugin/template
index 355ae97ad5d..5d897ba7154 100644
--- a/srcpkgs/xfce4-windowck-plugin/template
+++ b/srcpkgs/xfce4-windowck-plugin/template
@@ -1,17 +1,17 @@
 # Template file for 'xfce4-windowck-plugin'
 pkgname=xfce4-windowck-plugin
-version=0.4.4
-revision=2
+version=0.4.6
+revision=1
 build_style=gnu-makefile
 hostmakedepends="intltool xfce4-dev-tools exo-devel python3-devel glib-devel gettext-devel ImageMagick"
 makedepends="libwnck2-devel xfce4-panel-devel xorg-server-devel"
-depends="xfce4-panel>=4.10"
+depends="xfce4-panel>=4.13"
 short_desc="Puts the titlebar of a maximized window into a panel"
 maintainer="skurtix <skurtix@github.com>"
 homepage="https://github.com/cedl38/xfce4-windowck-plugin"
 license="GPL-3"
 distfiles="${homepage}/archive/v${version}.tar.gz"
-checksum=92b6c9e199d32cf96619c31e2cfac19e375575d581e78fa043f9f6a59c1df13f
+checksum=1643fa4a8bdbc401160fae6a132dcab89ed88d10231f84ed058f7a3e842763f7
 
 pre_configure() {
 	autogen_args="--prefix=/usr"

From 3075e0a35c5f4e918e45d3d2b29d5c7ff7c9bdf2 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:56:43 -0400
Subject: [PATCH 29/32] xfce4-xkb-plugin: revbump for xfconf

---
 srcpkgs/xfce4-xkb-plugin/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/xfce4-xkb-plugin/template b/srcpkgs/xfce4-xkb-plugin/template
index 30ec3089bbb..d64ee2670ee 100644
--- a/srcpkgs/xfce4-xkb-plugin/template
+++ b/srcpkgs/xfce4-xkb-plugin/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-xkb-plugin'
 pkgname=xfce4-xkb-plugin
 version=0.8.1
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool"
 makedepends="garcon-devel xfce4-panel-devel libxklavier-devel librsvg-devel libwnck-devel"

From 23a4ae04bc5adc063fc18a98bfcf16ccd7f7b5a4 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Tue, 2 Jul 2019 09:09:54 -0400
Subject: [PATCH 30/32] thunar-volman: update to 0.9.3.

---
 srcpkgs/thunar-volman/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/thunar-volman/template b/srcpkgs/thunar-volman/template
index 808725a915a..0d31e00202a 100644
--- a/srcpkgs/thunar-volman/template
+++ b/srcpkgs/thunar-volman/template
@@ -1,7 +1,7 @@
 # Template file for 'thunar-volman'
 pkgname=thunar-volman
-version=0.9.2
-revision=2
+version=0.9.3
+revision=1
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool"
 makedepends="libgudev-devel libnotify-devel libxfce4ui-devel exo-devel"
@@ -12,4 +12,4 @@ license="GPL-2.0-or-later"
 homepage="https://xfce.org/"
 changelog="https://git.xfce.org/xfce/thunar-volman/plain/NEWS?h=${pkgname}-${version}"
 distfiles="https://archive.xfce.org/src/xfce/$pkgname/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=b944b4299b73d2ca79184922dfea49782e4849f5960e209def71ac700a92ff27
+checksum=29309091db8b0f08c5a727625cc470673134977d7966cae0392f131300f9d5e9

From b129ecb6de18f9113c050c79a5cc71d2edd106dd Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Tue, 2 Jul 2019 09:13:52 -0400
Subject: [PATCH 31/32] tumbler: update to 0.2.5.

---
 srcpkgs/tumbler/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/tumbler/template b/srcpkgs/tumbler/template
index f385ee3d43c..5c2bbc21394 100644
--- a/srcpkgs/tumbler/template
+++ b/srcpkgs/tumbler/template
@@ -1,6 +1,6 @@
 # Template file for 'tumbler'.
 pkgname=tumbler
-version=0.2.3
+version=0.2.5
 revision=1
 build_style=gnu-configure
 configure_args="--disable-gstreamer-thumbnailer"
@@ -12,7 +12,7 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=d022e1bd1559fba33e4bf20fb053b219eca17676ebffb1ceb214fcd58a187d40
+checksum=6447697a861a4854f18348a4dc6aa8b7903a0f22c52350b793fab6bc6968d459
 
 CFLAGS="-I${XBPS_CROSS_BASE}/usr/include/freetype2"
 

From 4e5458ac39e4bc91473e7bb9e1f2c7d8fd14a6f5 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Tue, 2 Jul 2019 09:15:35 -0400
Subject: [PATCH 32/32] garcon: update to 0.6.3.

---
 srcpkgs/garcon/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/garcon/template b/srcpkgs/garcon/template
index 1c61229691d..8240d7b9a11 100644
--- a/srcpkgs/garcon/template
+++ b/srcpkgs/garcon/template
@@ -1,7 +1,7 @@
 # Template file for 'garcon'
 pkgname=garcon
-version=0.6.2
-revision=2
+version=0.6.3
+revision=1
 build_style=gnu-configure
 configure_args="--disable-static"
 hostmakedepends="pkg-config intltool gettext-devel glib-devel"
@@ -12,7 +12,7 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="LGPL-2.0-or-later"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/garcon/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=a87f09648ff10d45c524b3bfe618f18622bdd8b205589d35fed2f12d9c79c47c
+checksum=76b1fea531363e9c5e767f1899039b4fe854edf23f6c0f260807e5551f798401
 
 garcon-devel_package() {
 	depends="${sourcepkg}>=${version}_${revision} libxfce4ui-devel gtk+3-devel"

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [RFC] xfce4-4.14pre2
       [not found] <gh-mailinglist-notifications-41a7ca26-5023-4802-975b-f1789d68868e-void-packages-11932@inbox.vuxu.org>
                   ` (3 preceding siblings ...)
  2019-07-02 13:16 ` voidlinux-github
@ 2019-07-02 13:19 ` voidlinux-github
  2019-07-28 23:18 ` [PR PATCH] [Updated] " voidlinux-github
  2019-07-28 23:18 ` voidlinux-github
  6 siblings, 0 replies; 7+ messages in thread
From: voidlinux-github @ 2019-07-02 13:19 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 212 bytes --]

New comment by pbui on void-packages repository

https://github.com/void-linux/void-packages/pull/11932#issuecomment-507673392
Comment:
Updated to [xfce-4.14pre2](https://wiki.xfce.org/releng/4.14/xfce_4.14pre2)

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PR PATCH] [Updated] [RFC] xfce4-4.14pre2
       [not found] <gh-mailinglist-notifications-41a7ca26-5023-4802-975b-f1789d68868e-void-packages-11932@inbox.vuxu.org>
                   ` (4 preceding siblings ...)
  2019-07-02 13:19 ` voidlinux-github
@ 2019-07-28 23:18 ` " voidlinux-github
  2019-07-28 23:18 ` voidlinux-github
  6 siblings, 0 replies; 7+ messages in thread
From: voidlinux-github @ 2019-07-28 23:18 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 723 bytes --]

There is an updated pull request by pbui against master on the void-packages repository

https://github.com/pbui/void-packages xfce4-4.14
https://github.com/void-linux/void-packages/pull/11932

[RFC] xfce4-4.14pre2
This updates the core xfce4 packages to 4.14pre1 status as outlined here:

https://wiki.xfce.org/releng/4.14/xfce_4.14pre1

This also includes some revbumps and updates to packages that depend on xfconf (which has a SO bump).

I'm not sure if we want to update all the packages now, wait until 4.14 is released, or update individual packages on a case-by-case basis.  That is what I am marking this with [RFC].

A patch file from https://github.com/void-linux/void-packages/pull/11932.patch is attached

[-- Warning: decoded text below may be mangled --]
[-- Attachment #2: github-pr-xfce4-4.14-11932.patch --]
[-- Type: text/x-diff, Size: 42325 bytes --]

From 4e9604a7e3a821726cda392a5aa155fa1d5a77c2 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:33:32 -0400
Subject: [PATCH 01/33] xfconf: update to 4.13.8.

- Update common/shlibs for libxfconf-0.so.3
- glib-devel needs to be hostmakedepends for cross-compiling
---
 common/shlibs           | 2 +-
 srcpkgs/xfconf/template | 8 ++++----
 2 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index be6f9fc3676..e494cc8cd70 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -180,7 +180,7 @@ libnl-genl-3.so.200 libnl3-3.2.1_1
 libnl-cli-3.so.200 libnl3-3.2.1_1
 libreadline.so.8 libreadline8-8.0_1
 libhistory.so.8 libhistory8-8.0_1
-libxfconf-0.so.2 xfconf-4.9.1_1
+libxfconf-0.so.3 xfconf-4.13.7_1
 libxfce4util.so.7 libxfce4util-4.12.1_1
 libxfce4panel-1.0.so.4 xfce4-panel-4.9.2_1
 libxfce4panel-2.0.so.4 xfce4-panel-4.12.0_1
diff --git a/srcpkgs/xfconf/template b/srcpkgs/xfconf/template
index fb150ff36f1..10605f3d8d1 100644
--- a/srcpkgs/xfconf/template
+++ b/srcpkgs/xfconf/template
@@ -1,18 +1,18 @@
 # Template file for 'xfconf'
 pkgname=xfconf
-version=4.12.1
+version=4.13.8
 revision=1
 build_options="perl"
 build_style=gnu-configure
 configure_args="$(vopt_enable perl 'perl-bindings --with-perl-options=INSTALLDIRS=vendor')"
-hostmakedepends="pkg-config intltool"
-makedepends="dbus-glib-devel libxfce4util-devel $(vopt_if perl 'perl-ExtUtils-Depends perl-ExtUtils-PkgConfig perl-Glib')"
+hostmakedepends="pkg-config intltool glib-devel"
+makedepends="libxfce4util-devel $(vopt_if perl 'perl-ExtUtils-Depends perl-ExtUtils-PkgConfig perl-Glib')"
 short_desc="Xfce hierarchical (tree-like) configuration system"
 maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2, LGPL-2.1"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/xfconf/${version%.*}/$pkgname-$version.tar.bz2"
-checksum=35f48564e5694faa54fdc180cd3268e16fc2352946a89a3c2fc12cbe400ada36
+checksum=55e2441c4ff78a7006fabb59647f7bc1f190cbb82327b93ba063ff624a896591
 
 xfconf-devel_package() {
 	depends="dbus-glib-devel ${sourcepkg}>=${version}_${revision}"

From 2beea1c393d04ba5b469ef7da3433856fe49266b Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Tue, 2 Jul 2019 08:51:42 -0400
Subject: [PATCH 02/33] libxfce4util: update to 4.13.5.

Use gir build helper (for cross-compilation)
---
 srcpkgs/libxfce4util/template | 16 ++++++++++++----
 1 file changed, 12 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/libxfce4util/template b/srcpkgs/libxfce4util/template
index 6c2f3cf4a3b..068a61c6b0d 100644
--- a/srcpkgs/libxfce4util/template
+++ b/srcpkgs/libxfce4util/template
@@ -1,8 +1,9 @@
 # Template file for 'libxfce4util'
 pkgname=libxfce4util
-version=4.12.1
-revision=3
+version=4.13.5
+revision=1
 build_style=gnu-configure
+build_helper="gir"
 hostmakedepends="pkg-config intltool"
 makedepends="libglib-devel"
 short_desc="Utility library for the Xfce4 desktop environment"
@@ -10,7 +11,11 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="LGPL-2.0-or-later"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/$pkgname/${version%.*}/$pkgname-$version.tar.bz2"
-checksum=876bdefa2e13cbf68b626b2158892fb93e824e1ef59cf951123a96cefbc8881d
+checksum=9bbb095252775a6457e927aa2580b84efd1288446fcb54a046b5112ac7849035
+
+# Package build options
+build_options="gir"
+build_options_default="gir"
 
 libxfce4util-devel_package() {
 	depends="libglib-devel ${sourcepkg}>=${version}_${revision}"
@@ -19,6 +24,9 @@ libxfce4util-devel_package() {
 		vmove usr/include
 		vmove usr/lib/pkgconfig
 		vmove usr/share/gtk-doc
-		vmove usr/lib/*.so
+		vmove "usr/lib/*.so"
+		if [ "$build_option_gir" ]; then
+			vmove usr/share/gir-1.0
+		fi
 	}
 }

From 547b5e4f8ef44ff7a6458912ccb781e6cce7720b Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:32:15 -0400
Subject: [PATCH 03/33] libxfce4ui: update to 4.13.7.

Use gir build helper (for cross-compilation)
---
 srcpkgs/libxfce4ui/template | 19 +++++++++++--------
 1 file changed, 11 insertions(+), 8 deletions(-)

diff --git a/srcpkgs/libxfce4ui/template b/srcpkgs/libxfce4ui/template
index ac82ac043b3..8489f748606 100644
--- a/srcpkgs/libxfce4ui/template
+++ b/srcpkgs/libxfce4ui/template
@@ -1,24 +1,24 @@
 # Template file for 'libxfce4ui'
 pkgname=libxfce4ui
-version=4.12.1
-revision=3
+version=4.13.7
+revision=1
 build_style=gnu-configure
+build_helper="gir"
 configure_args="--disable-static"
 conf_files="/etc/xdg/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml"
 hostmakedepends="xfce4-dev-tools pkg-config intltool glib-devel gettext-devel"
-makedepends="gtk+-devel gtk+3-devel libxfce4util-devel xfconf-devel dbus-glib-devel
+makedepends="gtk+-devel gtk+3-devel libxfce4util-devel xfconf-devel
  libxml2-devel startup-notification-devel libSM-devel"
 short_desc="Replacement of the old libxfcegui4 library"
 maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="LGPL-2.0-or-later"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=3d619811bfbe7478bb984c16543d980cadd08586365a7bc25e59e3ca6384ff43
+checksum=b932359b47a5f8bdeae4441728abd19980c1a77f9912bc6cf8a50028b0687b08
 
-pre_configure() {
-	mkdir m4
-	NOCONFIGURE=1 xdt-autogen
-}
+# Package build options
+build_options="gir"
+build_options_default="gir"
 
 libxfce4ui-devel_package() {
 	depends="${makedepends} ${sourcepkg}>=${version}_${revision}"
@@ -28,5 +28,8 @@ libxfce4ui-devel_package() {
 		vmove usr/lib/pkgconfig
 		vmove "usr/lib/*.so"
 		vmove usr/share/gtk-doc
+                if [ "$build_option_gir" ]; then
+                        vmove usr/share/gir-1.0
+                fi
 	}
 }

From dbcaa5df5d8fc49799ede57b6f04e7885fc2c9bc Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:36:47 -0400
Subject: [PATCH 04/33] libwnck: update to 3.32.0.

Switch to meson build style.
---
 srcpkgs/libwnck/template | 13 ++++++-------
 1 file changed, 6 insertions(+), 7 deletions(-)

diff --git a/srcpkgs/libwnck/template b/srcpkgs/libwnck/template
index 1775a4bc55d..83190d54f68 100644
--- a/srcpkgs/libwnck/template
+++ b/srcpkgs/libwnck/template
@@ -1,11 +1,11 @@
 # Template file for 'libwnck'
 pkgname=libwnck
-version=3.30.0
-revision=2
-build_style=gnu-configure
+version=3.32.0
+revision=1
+build_style=meson
 build_helper="gir"
-configure_args="$(vopt_enable gir introspection)"
-hostmakedepends="gdk-pixbuf-devel pkg-config intltool
+#configure_args="$(vopt_enable gir introspection)"
+hostmakedepends="gdk-pixbuf-devel pkg-config intltool glib-devel
  $(vopt_if gir gobject-introspection)"
 makedepends="startup-notification-devel gtk+3-devel libXres-devel"
 short_desc="Library for layout and rendering of text"
@@ -13,7 +13,7 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="LGPL-2.1-or-later"
 homepage="http://www.gnome.org/"
 distfiles="${GNOME_SITE}/${pkgname}/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=ac6d0d2646aa80676d3066651e73abb7bff7ed79be238c9b21a0083e2adc3439
+checksum=9595835cf28d0fc6af5526a18f77f2fcf3ca8c09e36741bb33915b6e69b8e3ca
 
 build_options="gir"
 build_options_default="gir"
@@ -25,7 +25,6 @@ libwnck-devel_package() {
 		vmove usr/include
 		vmove usr/lib/pkgconfig
 		vmove "usr/lib/*.so"
-		vmove usr/share/gtk-doc
 		if [ "$build_option_gir" ]; then
 			vmove usr/share/gir-1.0
 		fi

From ebefeabd00a442eb14a9d474595c2014ebb9a663 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Sun, 28 Jul 2019 17:44:22 -0400
Subject: [PATCH 05/33] exo: update to 0.12.7.

---
 srcpkgs/exo/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/exo/template b/srcpkgs/exo/template
index 4d29768efdc..5bd57972b7d 100644
--- a/srcpkgs/exo/template
+++ b/srcpkgs/exo/template
@@ -1,6 +1,6 @@
 # Template file for 'exo'
 pkgname=exo
-version=0.12.6
+version=0.12.7
 revision=1
 build_style=gnu-configure
 configure_args="--disable-static"
@@ -12,7 +12,7 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2.0-or-later, LGPL-2.1-or-later"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/exo/${version%.*}/exo-${version}.tar.bz2"
-checksum=1417fffc593225d61ba57b050ae2ce66ef37615c9ec66944db32019761441003
+checksum=78d10943b52eb50ce76224ae27c025fb174d39895b31723db90a869d6eeaf1da
 conf_files="/etc/xdg/xfce4/helpers.rc"
 
 pre_configure() {

From 1db2798154767c771cfb65d78e825b606551b361 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Tue, 2 Jul 2019 09:15:35 -0400
Subject: [PATCH 06/33] garcon: update to 0.6.4.

---
 srcpkgs/garcon/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/garcon/template b/srcpkgs/garcon/template
index 1c61229691d..30702c32435 100644
--- a/srcpkgs/garcon/template
+++ b/srcpkgs/garcon/template
@@ -1,7 +1,7 @@
 # Template file for 'garcon'
 pkgname=garcon
-version=0.6.2
-revision=2
+version=0.6.4
+revision=1
 build_style=gnu-configure
 configure_args="--disable-static"
 hostmakedepends="pkg-config intltool gettext-devel glib-devel"
@@ -12,7 +12,7 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="LGPL-2.0-or-later"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/garcon/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=a87f09648ff10d45c524b3bfe618f18622bdd8b205589d35fed2f12d9c79c47c
+checksum=d75e4753037a74733c07b71b8db7a656d869869f0f107f6411a306bbc87a762d
 
 garcon-devel_package() {
 	depends="${sourcepkg}>=${version}_${revision} libxfce4ui-devel gtk+3-devel"

From 781d990fe89b3cdd805ad5b67afeba9731bc4046 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Tue, 2 Jul 2019 08:52:01 -0400
Subject: [PATCH 07/33] xfce4-dev-tools: update to 4.13.0.

---
 srcpkgs/xfce4-dev-tools/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/xfce4-dev-tools/template b/srcpkgs/xfce4-dev-tools/template
index 6e452ee4154..3fe83a41c70 100644
--- a/srcpkgs/xfce4-dev-tools/template
+++ b/srcpkgs/xfce4-dev-tools/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-dev-tools'
 pkgname=xfce4-dev-tools
-version=4.12.0
-revision=2
+version=4.13.0
+revision=1
 build_style=gnu-configure
 hostmakedepends="automake libtool gtk-doc intltool pkg-config"
 makedepends="libglib-devel"
@@ -11,4 +11,4 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=e2e3a654fe9110df81f8c2483c9cbfa6d656fed15d5e5e717d6ef10bd0f5b5cb
+checksum=d24d4db2151a35324c672d4596a6a256f7d92727fe6a9d23648ab53f5207ba3b

From f5cbc7279976217ba50cb35ce5b473e7ab760513 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:37:52 -0400
Subject: [PATCH 08/33] xfce4-panel: update to 4.13.7.

Switch to libwnck, drop dbus-glib, use gir build helper (for cross-compilation)
---
 srcpkgs/xfce4-panel/template | 19 +++++++++++--------
 1 file changed, 11 insertions(+), 8 deletions(-)

diff --git a/srcpkgs/xfce4-panel/template b/srcpkgs/xfce4-panel/template
index ee9c8d5aebc..88ce3b25465 100644
--- a/srcpkgs/xfce4-panel/template
+++ b/srcpkgs/xfce4-panel/template
@@ -1,23 +1,23 @@
 # Template file for 'xfce4-panel'
 pkgname=xfce4-panel
-version=4.12.2
+version=4.13.7
 revision=1
 build_style=gnu-configure
+build_helper="gir"
 configure_args="--disable-static --enable-gio-unix --enable-gtk3"
 hostmakedepends="xfce4-dev-tools pkg-config intltool gettext-devel glib-devel"
 makedepends="gtk+3-devel libxfce4ui-devel xfconf-devel
- dbus-glib-devel libwnck2-devel garcon-devel exo-devel"
+ libwnck-devel garcon-devel exo-devel"
 short_desc="Next generation panel for the XFCE desktop environment"
 maintainer="Juan RP <xtraeme@voidlinux.org>"
 homepage="https://xfce.org/"
 license="GPL-2"
 distfiles="https://archive.xfce.org/src/xfce/$pkgname/${version%.*}/$pkgname-$version.tar.bz2"
-checksum=42058abb81b8f87691d3999627447de71c3285bcf055f308aab5cefab2de0ce9
+checksum=888e30417342b05d566f5ef5a85791b05117fadbbc2f00bc5f29a30d6ba42ba9
 
-pre_configure() {
-	mkdir m4
-	NOCONFIGURE=1 xdt-autogen
-}
+# Package build options
+build_options="gir"
+build_options_default="gir"
 
 xfce4-panel-devel_package() {
 	depends="libxfce4ui-devel ${sourcepkg}>=${version}_${revision}"
@@ -26,6 +26,9 @@ xfce4-panel-devel_package() {
 		vmove usr/include
 		vmove usr/lib/pkgconfig
 		vmove usr/share/gtk-doc
-		vmove usr/lib/*.so
+		vmove "usr/lib/*.so"
+                if [ "$build_option_gir" ]; then
+                        vmove usr/share/gir-1.0
+                fi
 	}
 }

From 59f64b30f6366866f6e96a7144925639b494571c Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Sun, 28 Jul 2019 17:52:58 -0400
Subject: [PATCH 09/33] Thunar: update to 1.8.8.

---
 srcpkgs/Thunar/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/Thunar/template b/srcpkgs/Thunar/template
index 334f8d230db..2a382d12f63 100644
--- a/srcpkgs/Thunar/template
+++ b/srcpkgs/Thunar/template
@@ -1,6 +1,6 @@
 # Template file for 'Thunar'
 pkgname=Thunar
-version=1.8.7
+version=1.8.8
 revision=1
 build_style=gnu-configure
 build_helper="gir"
@@ -15,7 +15,7 @@ license="GPL-2.0-or-later, LGPL-2.1-or-later"
 homepage="https://docs.xfce.org/xfce/thunar/Start"
 changelog="https://raw.githubusercontent.com/xfce-mirror/thunar/master/NEWS"
 distfiles="https://archive.xfce.org/src/xfce/thunar/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=3e033af06751beee23e73cf16cbd97513d3c0adf358d8a42158af38a44b9d329
+checksum=a03761de4a43c36b9daa6029e6e3263a23c8ce429d78a9f9156ab48efdb2800c
 
 post_install() {
 	rm -rf ${DESTDIR}/usr/lib/systemd

From 9960dd43e15975e806aff92ce6ba714c35551c96 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:40:46 -0400
Subject: [PATCH 10/33] xfdesktop: update to 4.13.6.

Switch to libwnck, drop dbus-glib
---
 srcpkgs/xfdesktop/template | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/xfdesktop/template b/srcpkgs/xfdesktop/template
index be1056cf50b..154dd50ec92 100644
--- a/srcpkgs/xfdesktop/template
+++ b/srcpkgs/xfdesktop/template
@@ -1,16 +1,15 @@
 # Template file for 'xfdesktop'
 pkgname=xfdesktop
-version=4.12.5
+version=4.13.6
 revision=1
 build_style=gnu-configure
-hostmakedepends="pkg-config intltool glib-devel dbus-glib-devel"
-# XXX Add Thunar-devel again once xfdesktop supports the new Thunarx-3 API
+hostmakedepends="pkg-config intltool glib-devel Thunar-devel"
 makedepends="libxfce4ui-devel exo-devel garcon-devel
- libnotify-devel libwnck2-devel"
+ libnotify-devel libwnck-devel"
 depends="hicolor-icon-theme desktop-file-utils"
 short_desc="Desktop manager for the Xfce Desktop Environment"
 maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/xfdesktop/${version%.*}/$pkgname-$version.tar.bz2"
-checksum=3f2426ac28b94cfe5d6fd187c59b4e78f40e66c2842318e158ecd82abe2e7c0a
+checksum=f1f65cf31957e4cedd7b11d802f287d7429140c57fc3db7009578cca8398b990

From bc016e5a7fa4373a9fe4a851bb8e3ad73894c88e Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:41:45 -0400
Subject: [PATCH 11/33] xfwm4: update to 4.13.4.

Switch to libwnck, add Xpresent
---
 srcpkgs/xfwm4/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/xfwm4/template b/srcpkgs/xfwm4/template
index 58d1cc533df..3d721848b7e 100644
--- a/srcpkgs/xfwm4/template
+++ b/srcpkgs/xfwm4/template
@@ -1,16 +1,16 @@
 # Template file for 'xfwm4'
 pkgname=xfwm4
-version=4.12.5
+version=4.13.4
 revision=1
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool"
 makedepends="libxfce4ui-devel startup-notification-devel
  libXcomposite-devel libXdamage-devel libXfixes-devel libXrandr-devel
- libXrender-devel dbus-glib-devel libwnck2-devel"
+ libXrender-devel libXpresent-devel libwnck-devel"
 depends="hicolor-icon-theme desktop-file-utils"
 short_desc="Next generation window manager for Xfce"
 maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/xfwm4/${version%.*}/xfwm4-${version}.tar.bz2"
-checksum=7775c02216666c2d023275e7ed6d85e57d965e5cc1407bb6a05c53cc38d8caca
+checksum=31940e0e1d821d839b9ef1462bb1ca36e7935cd7589e4418993e3901ca6c0ec5

From ee58600b0d19f4b4740f3cbd0018ba0b838ac23d Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:43:17 -0400
Subject: [PATCH 12/33] thunar-volman: update to 0.9.4.

---
 srcpkgs/thunar-volman/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/thunar-volman/template b/srcpkgs/thunar-volman/template
index 15a066edaee..6797e585320 100644
--- a/srcpkgs/thunar-volman/template
+++ b/srcpkgs/thunar-volman/template
@@ -1,6 +1,6 @@
 # Template file for 'thunar-volman'
 pkgname=thunar-volman
-version=0.9.2
+version=0.9.4
 revision=1
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool"
@@ -12,4 +12,4 @@ license="GPL-2.0-or-later"
 homepage="https://xfce.org/"
 changelog="https://git.xfce.org/xfce/thunar-volman/plain/NEWS?h=${pkgname}-${version}"
 distfiles="https://archive.xfce.org/src/xfce/$pkgname/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=b944b4299b73d2ca79184922dfea49782e4849f5960e209def71ac700a92ff27
+checksum=c050f80a976fbb5f862c9c99857c761402ddd7980dc6f00d30002903f72abcb6

From 602b789cd31c84071b026a82bba8ea4f714cb62c Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:43:57 -0400
Subject: [PATCH 13/33] xfce4-settings: update to 4.13.8.

---
 srcpkgs/xfce4-settings/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/xfce4-settings/template b/srcpkgs/xfce4-settings/template
index 1944a3acf6e..2b9174d8505 100644
--- a/srcpkgs/xfce4-settings/template
+++ b/srcpkgs/xfce4-settings/template
@@ -1,6 +1,6 @@
 # Template file for 'xfce4-settings'
 pkgname=xfce4-settings
-version=4.12.4
+version=4.13.8
 revision=1
 build_style=gnu-configure
 configure_args="--enable-sound-settings --enable-pluggable-dialogs"
@@ -15,4 +15,4 @@ license="GPL-2.0-only"
 homepage="https://xfce.org/"
 changelog="https://raw.githubusercontent.com/xfce-mirror/xfce4-settings/master/NEWS"
 distfiles="https://archive.xfce.org/src/xfce/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=e2a04cad48bf9e951409d0c841829fa3b4ce632cd799082ef82d0506618b6f9b
+checksum=34ad226860e4cd8c13f6f0dc88e68a37173823c5a4c96ba9bfa89f869df086e7

From 173718697c0d6cba31e219cb51cc6ff1a7345740 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:44:21 -0400
Subject: [PATCH 14/33] xfce4-session: update to 4.13.4.

Switch to libwnck, drop dbus-glib, remove unnecessary --enable-upower
configure flag

Remove xfce4-session-devel as upstream no longer provides libxfsm as a
library.
---
 srcpkgs/xfce4-session-devel    |  1 -
 srcpkgs/xfce4-session/template | 26 ++++++--------------------
 2 files changed, 6 insertions(+), 21 deletions(-)
 delete mode 120000 srcpkgs/xfce4-session-devel

diff --git a/srcpkgs/xfce4-session-devel b/srcpkgs/xfce4-session-devel
deleted file mode 120000
index 865825879d6..00000000000
--- a/srcpkgs/xfce4-session-devel
+++ /dev/null
@@ -1 +0,0 @@
-xfce4-session
\ No newline at end of file
diff --git a/srcpkgs/xfce4-session/template b/srcpkgs/xfce4-session/template
index 6c4b9ecf265..f874df0aa11 100644
--- a/srcpkgs/xfce4-session/template
+++ b/srcpkgs/xfce4-session/template
@@ -1,12 +1,12 @@
 # Template file for 'xfce4-session'
 pkgname=xfce4-session
-version=4.12.1
-revision=2
+version=4.13.4
+revision=1
 build_style=gnu-configure
-configure_args="--disable-static --enable-upower --enable-polkit"
+configure_args="--disable-static --enable-polkit"
 hostmakedepends="xfce4-dev-tools pkg-config intltool gettext-devel glib-devel iceauth"
-makedepends="libxfce4ui-devel dbus-glib-devel upower-devel
- libwnck2-devel xfce4-panel-devel libSM-devel polkit-devel"
+makedepends="libxfce4ui-devel upower-devel
+ libwnck-devel xfce4-panel-devel libSM-devel polkit-devel"
 depends="iceauth hicolor-icon-theme desktop-file-utils"
 conf_files="/etc/xdg/xfce4/xfconf/xfce-perchannel-xml/xfce4-session.xml"
 short_desc="The session manager for the XFCE desktop environment"
@@ -14,23 +14,9 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/$pkgname/${version%.*}/$pkgname-$version.tar.bz2"
-checksum=97d7f2a2d0af7f3623b68d1f04091e02913b28f9555dab8b0d26c8a1299d08fd
+checksum=f52c566767001adafdaaa9188457ad32396233c24a09a681325b64eb3893b799
 
-pre_configure() {
-	mkdir m4
-	NOCONFIGURE=1 xdt-autogen
-}
 post_install() {
 	# startxfce4 needs bash.
 	replace_interpreter bash ${DESTDIR}/usr/bin/startxfce4
 }
-
-xfce4-session-devel_package() {
-	depends="libxfce4ui-devel>=4.12 ${sourcepkg}>=${version}_${revision}"
-	short_desc+=" - development files"
-	pkg_install() {
-		vmove usr/include
-		vmove usr/lib/pkgconfig
-		vmove "usr/lib/*.so"
-	}
-}

From 1be901fd38f3bfd1a4d6264f13c45636eec8c572 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:46:36 -0400
Subject: [PATCH 15/33] xfce4-appfinder: update to 4.13.5.

---
 srcpkgs/xfce4-appfinder/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/xfce4-appfinder/template b/srcpkgs/xfce4-appfinder/template
index 0ebe4dd92c7..5be2d02b14d 100644
--- a/srcpkgs/xfce4-appfinder/template
+++ b/srcpkgs/xfce4-appfinder/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-appfinder'
 pkgname=xfce4-appfinder
-version=4.12.0
-revision=3
+version=4.13.5
+revision=1
 build_style=gnu-configure
 configure_args="--enable-gtk3"
 hostmakedepends="pkg-config intltool"
@@ -12,4 +12,4 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=2ad4a58019a76a6b64a816050db25f96854917c2f2e89d6a9df6c18e6c84c567
+checksum=989f79eddc89c7d324d6d68878faf39292f7342a618a0711f0eb65634ed83960

From c1e963b145bd9086eb7346e38b5c7510064d39ea Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:47:16 -0400
Subject: [PATCH 16/33] xfce4-clipman-plugin: revbump for xfconf

---
 srcpkgs/xfce4-clipman-plugin/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/xfce4-clipman-plugin/template b/srcpkgs/xfce4-clipman-plugin/template
index 3d973e08e06..987a68f7d5f 100644
--- a/srcpkgs/xfce4-clipman-plugin/template
+++ b/srcpkgs/xfce4-clipman-plugin/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-clipman-plugin'
 pkgname=xfce4-clipman-plugin
 version=1.4.3
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="intltool pkg-config"
 makedepends="xfce4-panel-devel libXtst-devel qrencode-devel"

From 22e2510191cf89cb6fe84a14e932126ab736b38c Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:47:43 -0400
Subject: [PATCH 17/33] xfce4-notes-plugin: revbump for xfconf

---
 srcpkgs/xfce4-notes-plugin/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/xfce4-notes-plugin/template b/srcpkgs/xfce4-notes-plugin/template
index ce150733001..1df5d9776e8 100644
--- a/srcpkgs/xfce4-notes-plugin/template
+++ b/srcpkgs/xfce4-notes-plugin/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-notes-plugin'
 pkgname=xfce4-notes-plugin
 version=1.8.1
-revision=2
+revision=3
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool"
 makedepends="xfce4-panel-devel libunique1-devel"

From eb35be7f2022130f25cc94a157be7d7d9be5bcfd Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:48:12 -0400
Subject: [PATCH 18/33] xfce4-notifyd: revbump for xfconf

---
 srcpkgs/xfce4-notifyd/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/xfce4-notifyd/template b/srcpkgs/xfce4-notifyd/template
index cc07838d602..65500dc824e 100644
--- a/srcpkgs/xfce4-notifyd/template
+++ b/srcpkgs/xfce4-notifyd/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-notifyd'
 pkgname=xfce4-notifyd
 version=0.4.4
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool glib-devel dbus-glib-devel"
 makedepends="libnotify-devel xfce4-panel-devel"

From 8fa74f6971e687993f0d4f7db94eaa015e39be2b Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:49:24 -0400
Subject: [PATCH 19/33] mousepad: remove unnecessary makedepends on
 libxfce4ui-devel

---
 srcpkgs/mousepad/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/mousepad/template b/srcpkgs/mousepad/template
index 54160a9218e..f604781fb34 100644
--- a/srcpkgs/mousepad/template
+++ b/srcpkgs/mousepad/template
@@ -1,10 +1,10 @@
 # Template file for 'mousepad'
 pkgname=mousepad
 version=0.4.1
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="glib-devel intltool pkg-config"
-makedepends="gtksourceview-devel libxfce4ui-devel"
+makedepends="gtksourceview-devel"
 depends="desktop-file-utils hicolor-icon-theme"
 short_desc="Simple text editor for Xfce based on Leafpad"
 maintainer="Juan RP <xtraeme@voidlinux.org>"

From d7e8e2cf750efd2a1e7a78f6ce57c7534100c512 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:50:10 -0400
Subject: [PATCH 20/33] orage: remove unnecessary makedepends on dbus-glib

---
 srcpkgs/orage/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/orage/template b/srcpkgs/orage/template
index c0a9f23c448..bd0b9fcb6eb 100644
--- a/srcpkgs/orage/template
+++ b/srcpkgs/orage/template
@@ -1,10 +1,10 @@
 # Template file for 'orage'
 pkgname=orage
 version=4.12.1
-revision=3
+revision=4
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool flex"
-makedepends="libical-devel libnotify-devel gtk+-devel dbus-glib-devel
+makedepends="libical-devel libnotify-devel gtk+-devel
  popt-devel xfce4-panel-devel libxfce4util-devel"
 depends="hicolor-icon-theme desktop-file-utils"
 short_desc="Simple calendar application for Xfce"

From d79ba77016a6ead6e0fda4ad31b4561d7b55158d Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:51:12 -0400
Subject: [PATCH 21/33] ristretto: revbump for xfconf

---
 srcpkgs/ristretto/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/ristretto/template b/srcpkgs/ristretto/template
index 38dbc735472..7e761eb7c57 100644
--- a/srcpkgs/ristretto/template
+++ b/srcpkgs/ristretto/template
@@ -1,7 +1,7 @@
 # Template file for 'ristretto'
 pkgname=ristretto
 version=0.8.4
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="intltool pkg-config"
 makedepends="exo-devel file-devel libexif-devel"

From 461647af8fc2d40ed3af72bad31c15f16aa6fd63 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:51:31 -0400
Subject: [PATCH 22/33] vala-panel-appmenu: update to 0.7.2

---
 srcpkgs/vala-panel-appmenu/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/vala-panel-appmenu/template b/srcpkgs/vala-panel-appmenu/template
index 47c8b247bba..fa197105c43 100644
--- a/srcpkgs/vala-panel-appmenu/template
+++ b/srcpkgs/vala-panel-appmenu/template
@@ -1,7 +1,7 @@
 # Template file for 'vala-panel-appmenu'
 pkgname=vala-panel-appmenu
-version=0.7.1
-revision=2
+version=0.7.2
+revision=1
 build_style=cmake
 configure_args="-DENABLE_XFCE=ON -DENABLE_VALAPANEL=ON
  -DENABLE_MATE=ON -DENABLE_JAYATANA=OFF -DENABLE_APPMENU_GTK_MODULE=ON"
@@ -15,8 +15,8 @@ short_desc="Global Menu for Vala Panel"
 maintainer="John Eira <john.eira@web.de>"
 license="LGPL-3.0-or-later"
 homepage="https://gitlab.com/vala-panel-project/vala-panel-appmenu"
-distfiles="https://gitlab.com/vala-panel-project/vala-panel-appmenu/uploads/c0f85b42a2a228ad8c3413357e02fb28/vala-panel-appmenu-${version}.tar.xz"
-checksum=54a1b4f6ceca63eb3b79facc4327424bdd82f0fe3b7c6139326dbe0ec0824dcc
+distfiles="https://gitlab.com/vala-panel-project/vala-panel-appmenu/uploads/57fe7a74b38180002154fbd6028075db/vala-panel-appmenu-${version}.tar.xz"
+checksum=80884ebd71b665da7a1eac67752596ecbb29d3a8dd9eee9a2e3212dfc0aab6ae
 
 post_install() {
 	if [ "$CROSS_BUILD" ]; then

From 7ae5c59131adf24a60035dc22ea2d802c7836ff6 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:52:06 -0400
Subject: [PATCH 23/33] xfce4-places-plugin: update to 1.8.0.

Remove unnecessary patch.
---
 .../patches/undefined-symbol.patch            | 69 -------------------
 srcpkgs/xfce4-places-plugin/template          |  6 +-
 2 files changed, 3 insertions(+), 72 deletions(-)
 delete mode 100644 srcpkgs/xfce4-places-plugin/patches/undefined-symbol.patch

diff --git a/srcpkgs/xfce4-places-plugin/patches/undefined-symbol.patch b/srcpkgs/xfce4-places-plugin/patches/undefined-symbol.patch
deleted file mode 100644
index a94d9ea706f..00000000000
--- a/srcpkgs/xfce4-places-plugin/patches/undefined-symbol.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-From 94d583d0ba257cdc96cde5794ebb7d38001ae3a5 Mon Sep 17 00:00:00 2001
-From: Andrzej <ndrwrdck@gmail.com>
-Date: Tue, 7 Jul 2015 22:26:51 +0100
-Subject: [PATCH] Bug 11939:  xfce4-places-plugin 1.7.0 crashes with undefined
- symbol
-
-Patch from Fedora. Submitted by Kevin Fenzi.
----
- panel-plugin/model.h | 18 +++++++++---------
- 1 file changed, 9 insertions(+), 9 deletions(-)
-
-diff --git a/panel-plugin/model.h b/panel-plugin/model.h
-index 06d9d6f..043e391 100644
---- a/panel-plugin/model.h
-+++ b/panel-plugin/model.h
-@@ -36,13 +36,13 @@ struct _PlacesBookmarkAction
-     void        (*finalize) (PlacesBookmarkAction *self);
- };
- 
--inline PlacesBookmarkAction*
-+extern inline PlacesBookmarkAction*
- places_bookmark_action_create(gchar *label);
- 
--inline void
-+extern inline void
- places_bookmark_action_destroy(PlacesBookmarkAction*);
- 
--inline void
-+extern inline void
- places_bookmark_action_call(PlacesBookmarkAction*);
- 
- /* Places Bookmark */
-@@ -70,10 +70,10 @@ struct _PlacesBookmark
-     void                 (*finalize) (PlacesBookmark *self);
- };
- 
--inline PlacesBookmark*
-+extern inline PlacesBookmark*
- places_bookmark_create(gchar *label);
- 
--inline void
-+extern inline void
- places_bookmark_destroy(PlacesBookmark *bookmark);
- 
- /* Places Bookmark Group */
-@@ -86,16 +86,16 @@ struct _PlacesBookmarkGroup
-     gpointer    priv;
- };
- 
--inline GList*
-+extern inline GList*
- places_bookmark_group_get_bookmarks(PlacesBookmarkGroup*);
- 
--inline gboolean
-+extern inline gboolean
- places_bookmark_group_changed(PlacesBookmarkGroup*);
- 
--inline PlacesBookmarkGroup*
-+extern inline PlacesBookmarkGroup*
- places_bookmark_group_create();
- 
--inline void
-+extern inline void
- places_bookmark_group_destroy(PlacesBookmarkGroup*);
- 
- #endif
--- 
-2.6.4
-
diff --git a/srcpkgs/xfce4-places-plugin/template b/srcpkgs/xfce4-places-plugin/template
index b7f2d8ea2f6..1c1c952a16d 100644
--- a/srcpkgs/xfce4-places-plugin/template
+++ b/srcpkgs/xfce4-places-plugin/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-places-plugin'
 pkgname=xfce4-places-plugin
-version=1.7.0
-revision=3
+version=1.8.0
+revision=1
 build_style=gnu-configure
 hostmakedepends="intltool pkg-config"
 makedepends="exo-devel libglib-devel gtk+-devel libxfce4ui-devel libxfce4util-devel
@@ -11,6 +11,6 @@ maintainer="Steve Prybylski <sa.prybylx@gmail.com>"
 license="GPL-2.0-or-later"
 homepage="https://goodies.xfce.org/projects/panel-plugins/xfce4-places-plugin"
 distfiles="https://archive.xfce.org/src/panel-plugins/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=4175c614749abbb5bcf6f49c88125fb0dd36db69f4c374df23563907b16e2c3f
+checksum=7ba3f46f88c2845cbf413efeefaed29157f8b98571856c6e2bf35e4de5d8ecce
 patch_args="-Np1"
 

From e00ac68106077c830d8e8274899c80028ca7817b Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:52:41 -0400
Subject: [PATCH 24/33] xfce4-power-manager: update to 1.6.4.

---
 srcpkgs/xfce4-power-manager/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/xfce4-power-manager/template b/srcpkgs/xfce4-power-manager/template
index 6b44f4d349f..086e0ccd5b1 100644
--- a/srcpkgs/xfce4-power-manager/template
+++ b/srcpkgs/xfce4-power-manager/template
@@ -1,6 +1,6 @@
 # Template file for 'xfce4-power-manager'
 pkgname=xfce4-power-manager
-version=1.6.1
+version=1.6.4
 revision=1
 build_style=gnu-configure
 configure_args="--disable-static"
@@ -12,4 +12,4 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/$pkgname/${version%.*}/$pkgname-$version.tar.bz2"
-checksum=1ea825452343b895566068018b6d5078608f8f46ce8075ba6bbb4b848f48656b
+checksum=078df808e68f745769b4c34a4719cfe289d4bf89ca2cd4ed4680f2551a00039e

From 4f4f2b9b14220984ef60ee30bca049e9856cb4e6 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:53:06 -0400
Subject: [PATCH 25/33] xfce4-pulseaudio-plugin: revbump for xfconf

---
 srcpkgs/xfce4-pulseaudio-plugin/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/xfce4-pulseaudio-plugin/template b/srcpkgs/xfce4-pulseaudio-plugin/template
index d54728002a6..0ff54c57d27 100644
--- a/srcpkgs/xfce4-pulseaudio-plugin/template
+++ b/srcpkgs/xfce4-pulseaudio-plugin/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-pulseaudio-plugin'
 pkgname=xfce4-pulseaudio-plugin
 version=0.4.1
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="gettext-devel xfce4-dev-tools"
 makedepends="libkeybinder3-devel libnotify-devel pulseaudio-devel xfce4-panel-devel"

From 8296eea4d14bb99afe21c47e9e03a749ec350c1c Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:53:28 -0400
Subject: [PATCH 26/33] xfce4-screensaver: revbump for xfconf

---
 srcpkgs/xfce4-screensaver/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/xfce4-screensaver/template b/srcpkgs/xfce4-screensaver/template
index af2dba5fabf..aa45226a504 100644
--- a/srcpkgs/xfce4-screensaver/template
+++ b/srcpkgs/xfce4-screensaver/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-screensaver'
 pkgname=xfce4-screensaver
 version=0.1.4
-revision=1
+revision=2
 build_style=gnu-configure
 configure_args="--without-systemd --with-libgl --with-shadow --with-mit-ext
  --with-xf86gamma-ext --with-x --enable-pam"

From 60ecb45d49f787c7187889307214d09790b536b5 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:54:20 -0400
Subject: [PATCH 27/33] xfce4-sensors-plugin: update to 1.3.92.

---
 srcpkgs/xfce4-sensors-plugin/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/xfce4-sensors-plugin/template b/srcpkgs/xfce4-sensors-plugin/template
index 4c5053fba55..96b8a00b3af 100644
--- a/srcpkgs/xfce4-sensors-plugin/template
+++ b/srcpkgs/xfce4-sensors-plugin/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-sensors-plugin'
 pkgname=xfce4-sensors-plugin
-version=1.3.0
-revision=2
+version=1.3.92
+revision=1
 build_style=gnu-configure
 configure_args="--disable-static"
 hostmakedepends="pkg-config intltool"
@@ -12,7 +12,7 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="https://goodies.xfce.org/projects/panel-plugins/xfce4-sensors-plugin"
 distfiles="https://archive.xfce.org/src/panel-plugins/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=b7a7834ca84f6751686fa2e20e0b44a2e68ece0cb2716792a765e03b92f65569
+checksum=3dc6643d2c064b7718badff44b948f8d410f00f13db197820b26ae38045f5112
 
 if [ "$CROSS_BUILD" ]; then
 	# Cannot detect these when cross compiling

From 527329095a7e49dba08af3db8524f75a20bc71e8 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:55:52 -0400
Subject: [PATCH 28/33] xfce4-weather-plugin: update to 0.9.1.

---
 srcpkgs/xfce4-weather-plugin/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/xfce4-weather-plugin/template b/srcpkgs/xfce4-weather-plugin/template
index 8c3bab3185c..e6f9671ba6a 100644
--- a/srcpkgs/xfce4-weather-plugin/template
+++ b/srcpkgs/xfce4-weather-plugin/template
@@ -1,6 +1,6 @@
 # Template file for 'xfce4-weather-plugin'
 pkgname=xfce4-weather-plugin
-version=0.8.11
+version=0.9.1
 revision=1
 build_style=gnu-configure
 configure_args="--disable-upower"
@@ -12,5 +12,5 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="https://goodies.xfce.org/projects/panel-plugins/xfce4-weather-plugin"
 distfiles="https://archive.xfce.org/src/panel-plugins/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=0382ce99c0ad4424afe7096a354f301a9396d12807a0f2ab041912d6ab58145d
+checksum=7cdc18b8df759dee4ceaaf6ce303eff7fda48e247dbc26b78142929213506cfd
 lib32disabled=yes

From f729e1e17531d454b9bbeb4eb55a4c369920d497 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:56:18 -0400
Subject: [PATCH 29/33] xfce4-windowck-plugin: update to 0.4.6.

---
 srcpkgs/xfce4-windowck-plugin/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/xfce4-windowck-plugin/template b/srcpkgs/xfce4-windowck-plugin/template
index 355ae97ad5d..5d897ba7154 100644
--- a/srcpkgs/xfce4-windowck-plugin/template
+++ b/srcpkgs/xfce4-windowck-plugin/template
@@ -1,17 +1,17 @@
 # Template file for 'xfce4-windowck-plugin'
 pkgname=xfce4-windowck-plugin
-version=0.4.4
-revision=2
+version=0.4.6
+revision=1
 build_style=gnu-makefile
 hostmakedepends="intltool xfce4-dev-tools exo-devel python3-devel glib-devel gettext-devel ImageMagick"
 makedepends="libwnck2-devel xfce4-panel-devel xorg-server-devel"
-depends="xfce4-panel>=4.10"
+depends="xfce4-panel>=4.13"
 short_desc="Puts the titlebar of a maximized window into a panel"
 maintainer="skurtix <skurtix@github.com>"
 homepage="https://github.com/cedl38/xfce4-windowck-plugin"
 license="GPL-3"
 distfiles="${homepage}/archive/v${version}.tar.gz"
-checksum=92b6c9e199d32cf96619c31e2cfac19e375575d581e78fa043f9f6a59c1df13f
+checksum=1643fa4a8bdbc401160fae6a132dcab89ed88d10231f84ed058f7a3e842763f7
 
 pre_configure() {
 	autogen_args="--prefix=/usr"

From 11647dd7ff3205ad3e43902b7ecae62fbcf704fb Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:56:43 -0400
Subject: [PATCH 30/33] xfce4-xkb-plugin: revbump for xfconf

---
 srcpkgs/xfce4-xkb-plugin/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/xfce4-xkb-plugin/template b/srcpkgs/xfce4-xkb-plugin/template
index 30ec3089bbb..d64ee2670ee 100644
--- a/srcpkgs/xfce4-xkb-plugin/template
+++ b/srcpkgs/xfce4-xkb-plugin/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-xkb-plugin'
 pkgname=xfce4-xkb-plugin
 version=0.8.1
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool"
 makedepends="garcon-devel xfce4-panel-devel libxklavier-devel librsvg-devel libwnck-devel"

From 0538c94b5c721ea251d5120f2b2b3c72691673a2 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Tue, 2 Jul 2019 09:13:52 -0400
Subject: [PATCH 31/33] tumbler: update to 0.2.6.

---
 srcpkgs/tumbler/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/tumbler/template b/srcpkgs/tumbler/template
index f385ee3d43c..aacdd272080 100644
--- a/srcpkgs/tumbler/template
+++ b/srcpkgs/tumbler/template
@@ -1,6 +1,6 @@
 # Template file for 'tumbler'.
 pkgname=tumbler
-version=0.2.3
+version=0.2.6
 revision=1
 build_style=gnu-configure
 configure_args="--disable-gstreamer-thumbnailer"
@@ -12,7 +12,7 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=d022e1bd1559fba33e4bf20fb053b219eca17676ebffb1ceb214fcd58a187d40
+checksum=74d21781fb0c1e8c11ac803cc5afb469893a0b220721fdc25660c54891a10fa0
 
 CFLAGS="-I${XBPS_CROSS_BASE}/usr/include/freetype2"
 

From aa86a99e748cb82ac129639197d3c42e4a10a1f4 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Thu, 18 Jul 2019 20:38:25 -0400
Subject: [PATCH 32/33] xfce4-terminal: revbump for xfconf

---
 srcpkgs/xfce4-terminal/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/xfce4-terminal/template b/srcpkgs/xfce4-terminal/template
index 4087403c711..22f5df16c60 100644
--- a/srcpkgs/xfce4-terminal/template
+++ b/srcpkgs/xfce4-terminal/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-terminal'
 pkgname=xfce4-terminal
 version=0.8.8
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="intltool pkg-config"
 makedepends="exo-devel vte3-devel"

From 1d4a8d66832d05b4615ea2c21c44e44915be9e6e Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Sun, 28 Jul 2019 19:01:08 -0400
Subject: [PATCH 33/33] parole: revbump for xfconf

---
 srcpkgs/parole/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/parole/template b/srcpkgs/parole/template
index f3266eac70d..3c0b3ffd731 100644
--- a/srcpkgs/parole/template
+++ b/srcpkgs/parole/template
@@ -1,7 +1,7 @@
 # Template file for 'parole'
 pkgname=parole
 version=1.0.3
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool glib-devel"
 makedepends="gst-plugins-base1-devel libnotify-devel taglib-devel libxfce4ui-devel"

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PR PATCH] [Updated] [RFC] xfce4-4.14pre2
       [not found] <gh-mailinglist-notifications-41a7ca26-5023-4802-975b-f1789d68868e-void-packages-11932@inbox.vuxu.org>
                   ` (5 preceding siblings ...)
  2019-07-28 23:18 ` [PR PATCH] [Updated] " voidlinux-github
@ 2019-07-28 23:18 ` voidlinux-github
  6 siblings, 0 replies; 7+ messages in thread
From: voidlinux-github @ 2019-07-28 23:18 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 723 bytes --]

There is an updated pull request by pbui against master on the void-packages repository

https://github.com/pbui/void-packages xfce4-4.14
https://github.com/void-linux/void-packages/pull/11932

[RFC] xfce4-4.14pre2
This updates the core xfce4 packages to 4.14pre1 status as outlined here:

https://wiki.xfce.org/releng/4.14/xfce_4.14pre1

This also includes some revbumps and updates to packages that depend on xfconf (which has a SO bump).

I'm not sure if we want to update all the packages now, wait until 4.14 is released, or update individual packages on a case-by-case basis.  That is what I am marking this with [RFC].

A patch file from https://github.com/void-linux/void-packages/pull/11932.patch is attached

[-- Warning: decoded text below may be mangled --]
[-- Attachment #2: github-pr-xfce4-4.14-11932.patch --]
[-- Type: text/x-diff, Size: 42325 bytes --]

From 4e9604a7e3a821726cda392a5aa155fa1d5a77c2 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:33:32 -0400
Subject: [PATCH 01/33] xfconf: update to 4.13.8.

- Update common/shlibs for libxfconf-0.so.3
- glib-devel needs to be hostmakedepends for cross-compiling
---
 common/shlibs           | 2 +-
 srcpkgs/xfconf/template | 8 ++++----
 2 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index be6f9fc3676..e494cc8cd70 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -180,7 +180,7 @@ libnl-genl-3.so.200 libnl3-3.2.1_1
 libnl-cli-3.so.200 libnl3-3.2.1_1
 libreadline.so.8 libreadline8-8.0_1
 libhistory.so.8 libhistory8-8.0_1
-libxfconf-0.so.2 xfconf-4.9.1_1
+libxfconf-0.so.3 xfconf-4.13.7_1
 libxfce4util.so.7 libxfce4util-4.12.1_1
 libxfce4panel-1.0.so.4 xfce4-panel-4.9.2_1
 libxfce4panel-2.0.so.4 xfce4-panel-4.12.0_1
diff --git a/srcpkgs/xfconf/template b/srcpkgs/xfconf/template
index fb150ff36f1..10605f3d8d1 100644
--- a/srcpkgs/xfconf/template
+++ b/srcpkgs/xfconf/template
@@ -1,18 +1,18 @@
 # Template file for 'xfconf'
 pkgname=xfconf
-version=4.12.1
+version=4.13.8
 revision=1
 build_options="perl"
 build_style=gnu-configure
 configure_args="$(vopt_enable perl 'perl-bindings --with-perl-options=INSTALLDIRS=vendor')"
-hostmakedepends="pkg-config intltool"
-makedepends="dbus-glib-devel libxfce4util-devel $(vopt_if perl 'perl-ExtUtils-Depends perl-ExtUtils-PkgConfig perl-Glib')"
+hostmakedepends="pkg-config intltool glib-devel"
+makedepends="libxfce4util-devel $(vopt_if perl 'perl-ExtUtils-Depends perl-ExtUtils-PkgConfig perl-Glib')"
 short_desc="Xfce hierarchical (tree-like) configuration system"
 maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2, LGPL-2.1"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/xfconf/${version%.*}/$pkgname-$version.tar.bz2"
-checksum=35f48564e5694faa54fdc180cd3268e16fc2352946a89a3c2fc12cbe400ada36
+checksum=55e2441c4ff78a7006fabb59647f7bc1f190cbb82327b93ba063ff624a896591
 
 xfconf-devel_package() {
 	depends="dbus-glib-devel ${sourcepkg}>=${version}_${revision}"

From 2beea1c393d04ba5b469ef7da3433856fe49266b Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Tue, 2 Jul 2019 08:51:42 -0400
Subject: [PATCH 02/33] libxfce4util: update to 4.13.5.

Use gir build helper (for cross-compilation)
---
 srcpkgs/libxfce4util/template | 16 ++++++++++++----
 1 file changed, 12 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/libxfce4util/template b/srcpkgs/libxfce4util/template
index 6c2f3cf4a3b..068a61c6b0d 100644
--- a/srcpkgs/libxfce4util/template
+++ b/srcpkgs/libxfce4util/template
@@ -1,8 +1,9 @@
 # Template file for 'libxfce4util'
 pkgname=libxfce4util
-version=4.12.1
-revision=3
+version=4.13.5
+revision=1
 build_style=gnu-configure
+build_helper="gir"
 hostmakedepends="pkg-config intltool"
 makedepends="libglib-devel"
 short_desc="Utility library for the Xfce4 desktop environment"
@@ -10,7 +11,11 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="LGPL-2.0-or-later"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/$pkgname/${version%.*}/$pkgname-$version.tar.bz2"
-checksum=876bdefa2e13cbf68b626b2158892fb93e824e1ef59cf951123a96cefbc8881d
+checksum=9bbb095252775a6457e927aa2580b84efd1288446fcb54a046b5112ac7849035
+
+# Package build options
+build_options="gir"
+build_options_default="gir"
 
 libxfce4util-devel_package() {
 	depends="libglib-devel ${sourcepkg}>=${version}_${revision}"
@@ -19,6 +24,9 @@ libxfce4util-devel_package() {
 		vmove usr/include
 		vmove usr/lib/pkgconfig
 		vmove usr/share/gtk-doc
-		vmove usr/lib/*.so
+		vmove "usr/lib/*.so"
+		if [ "$build_option_gir" ]; then
+			vmove usr/share/gir-1.0
+		fi
 	}
 }

From 547b5e4f8ef44ff7a6458912ccb781e6cce7720b Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:32:15 -0400
Subject: [PATCH 03/33] libxfce4ui: update to 4.13.7.

Use gir build helper (for cross-compilation)
---
 srcpkgs/libxfce4ui/template | 19 +++++++++++--------
 1 file changed, 11 insertions(+), 8 deletions(-)

diff --git a/srcpkgs/libxfce4ui/template b/srcpkgs/libxfce4ui/template
index ac82ac043b3..8489f748606 100644
--- a/srcpkgs/libxfce4ui/template
+++ b/srcpkgs/libxfce4ui/template
@@ -1,24 +1,24 @@
 # Template file for 'libxfce4ui'
 pkgname=libxfce4ui
-version=4.12.1
-revision=3
+version=4.13.7
+revision=1
 build_style=gnu-configure
+build_helper="gir"
 configure_args="--disable-static"
 conf_files="/etc/xdg/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml"
 hostmakedepends="xfce4-dev-tools pkg-config intltool glib-devel gettext-devel"
-makedepends="gtk+-devel gtk+3-devel libxfce4util-devel xfconf-devel dbus-glib-devel
+makedepends="gtk+-devel gtk+3-devel libxfce4util-devel xfconf-devel
  libxml2-devel startup-notification-devel libSM-devel"
 short_desc="Replacement of the old libxfcegui4 library"
 maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="LGPL-2.0-or-later"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=3d619811bfbe7478bb984c16543d980cadd08586365a7bc25e59e3ca6384ff43
+checksum=b932359b47a5f8bdeae4441728abd19980c1a77f9912bc6cf8a50028b0687b08
 
-pre_configure() {
-	mkdir m4
-	NOCONFIGURE=1 xdt-autogen
-}
+# Package build options
+build_options="gir"
+build_options_default="gir"
 
 libxfce4ui-devel_package() {
 	depends="${makedepends} ${sourcepkg}>=${version}_${revision}"
@@ -28,5 +28,8 @@ libxfce4ui-devel_package() {
 		vmove usr/lib/pkgconfig
 		vmove "usr/lib/*.so"
 		vmove usr/share/gtk-doc
+                if [ "$build_option_gir" ]; then
+                        vmove usr/share/gir-1.0
+                fi
 	}
 }

From dbcaa5df5d8fc49799ede57b6f04e7885fc2c9bc Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:36:47 -0400
Subject: [PATCH 04/33] libwnck: update to 3.32.0.

Switch to meson build style.
---
 srcpkgs/libwnck/template | 13 ++++++-------
 1 file changed, 6 insertions(+), 7 deletions(-)

diff --git a/srcpkgs/libwnck/template b/srcpkgs/libwnck/template
index 1775a4bc55d..83190d54f68 100644
--- a/srcpkgs/libwnck/template
+++ b/srcpkgs/libwnck/template
@@ -1,11 +1,11 @@
 # Template file for 'libwnck'
 pkgname=libwnck
-version=3.30.0
-revision=2
-build_style=gnu-configure
+version=3.32.0
+revision=1
+build_style=meson
 build_helper="gir"
-configure_args="$(vopt_enable gir introspection)"
-hostmakedepends="gdk-pixbuf-devel pkg-config intltool
+#configure_args="$(vopt_enable gir introspection)"
+hostmakedepends="gdk-pixbuf-devel pkg-config intltool glib-devel
  $(vopt_if gir gobject-introspection)"
 makedepends="startup-notification-devel gtk+3-devel libXres-devel"
 short_desc="Library for layout and rendering of text"
@@ -13,7 +13,7 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="LGPL-2.1-or-later"
 homepage="http://www.gnome.org/"
 distfiles="${GNOME_SITE}/${pkgname}/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=ac6d0d2646aa80676d3066651e73abb7bff7ed79be238c9b21a0083e2adc3439
+checksum=9595835cf28d0fc6af5526a18f77f2fcf3ca8c09e36741bb33915b6e69b8e3ca
 
 build_options="gir"
 build_options_default="gir"
@@ -25,7 +25,6 @@ libwnck-devel_package() {
 		vmove usr/include
 		vmove usr/lib/pkgconfig
 		vmove "usr/lib/*.so"
-		vmove usr/share/gtk-doc
 		if [ "$build_option_gir" ]; then
 			vmove usr/share/gir-1.0
 		fi

From ebefeabd00a442eb14a9d474595c2014ebb9a663 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Sun, 28 Jul 2019 17:44:22 -0400
Subject: [PATCH 05/33] exo: update to 0.12.7.

---
 srcpkgs/exo/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/exo/template b/srcpkgs/exo/template
index 4d29768efdc..5bd57972b7d 100644
--- a/srcpkgs/exo/template
+++ b/srcpkgs/exo/template
@@ -1,6 +1,6 @@
 # Template file for 'exo'
 pkgname=exo
-version=0.12.6
+version=0.12.7
 revision=1
 build_style=gnu-configure
 configure_args="--disable-static"
@@ -12,7 +12,7 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2.0-or-later, LGPL-2.1-or-later"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/exo/${version%.*}/exo-${version}.tar.bz2"
-checksum=1417fffc593225d61ba57b050ae2ce66ef37615c9ec66944db32019761441003
+checksum=78d10943b52eb50ce76224ae27c025fb174d39895b31723db90a869d6eeaf1da
 conf_files="/etc/xdg/xfce4/helpers.rc"
 
 pre_configure() {

From 1db2798154767c771cfb65d78e825b606551b361 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Tue, 2 Jul 2019 09:15:35 -0400
Subject: [PATCH 06/33] garcon: update to 0.6.4.

---
 srcpkgs/garcon/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/garcon/template b/srcpkgs/garcon/template
index 1c61229691d..30702c32435 100644
--- a/srcpkgs/garcon/template
+++ b/srcpkgs/garcon/template
@@ -1,7 +1,7 @@
 # Template file for 'garcon'
 pkgname=garcon
-version=0.6.2
-revision=2
+version=0.6.4
+revision=1
 build_style=gnu-configure
 configure_args="--disable-static"
 hostmakedepends="pkg-config intltool gettext-devel glib-devel"
@@ -12,7 +12,7 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="LGPL-2.0-or-later"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/garcon/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=a87f09648ff10d45c524b3bfe618f18622bdd8b205589d35fed2f12d9c79c47c
+checksum=d75e4753037a74733c07b71b8db7a656d869869f0f107f6411a306bbc87a762d
 
 garcon-devel_package() {
 	depends="${sourcepkg}>=${version}_${revision} libxfce4ui-devel gtk+3-devel"

From 781d990fe89b3cdd805ad5b67afeba9731bc4046 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Tue, 2 Jul 2019 08:52:01 -0400
Subject: [PATCH 07/33] xfce4-dev-tools: update to 4.13.0.

---
 srcpkgs/xfce4-dev-tools/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/xfce4-dev-tools/template b/srcpkgs/xfce4-dev-tools/template
index 6e452ee4154..3fe83a41c70 100644
--- a/srcpkgs/xfce4-dev-tools/template
+++ b/srcpkgs/xfce4-dev-tools/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-dev-tools'
 pkgname=xfce4-dev-tools
-version=4.12.0
-revision=2
+version=4.13.0
+revision=1
 build_style=gnu-configure
 hostmakedepends="automake libtool gtk-doc intltool pkg-config"
 makedepends="libglib-devel"
@@ -11,4 +11,4 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=e2e3a654fe9110df81f8c2483c9cbfa6d656fed15d5e5e717d6ef10bd0f5b5cb
+checksum=d24d4db2151a35324c672d4596a6a256f7d92727fe6a9d23648ab53f5207ba3b

From f5cbc7279976217ba50cb35ce5b473e7ab760513 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:37:52 -0400
Subject: [PATCH 08/33] xfce4-panel: update to 4.13.7.

Switch to libwnck, drop dbus-glib, use gir build helper (for cross-compilation)
---
 srcpkgs/xfce4-panel/template | 19 +++++++++++--------
 1 file changed, 11 insertions(+), 8 deletions(-)

diff --git a/srcpkgs/xfce4-panel/template b/srcpkgs/xfce4-panel/template
index ee9c8d5aebc..88ce3b25465 100644
--- a/srcpkgs/xfce4-panel/template
+++ b/srcpkgs/xfce4-panel/template
@@ -1,23 +1,23 @@
 # Template file for 'xfce4-panel'
 pkgname=xfce4-panel
-version=4.12.2
+version=4.13.7
 revision=1
 build_style=gnu-configure
+build_helper="gir"
 configure_args="--disable-static --enable-gio-unix --enable-gtk3"
 hostmakedepends="xfce4-dev-tools pkg-config intltool gettext-devel glib-devel"
 makedepends="gtk+3-devel libxfce4ui-devel xfconf-devel
- dbus-glib-devel libwnck2-devel garcon-devel exo-devel"
+ libwnck-devel garcon-devel exo-devel"
 short_desc="Next generation panel for the XFCE desktop environment"
 maintainer="Juan RP <xtraeme@voidlinux.org>"
 homepage="https://xfce.org/"
 license="GPL-2"
 distfiles="https://archive.xfce.org/src/xfce/$pkgname/${version%.*}/$pkgname-$version.tar.bz2"
-checksum=42058abb81b8f87691d3999627447de71c3285bcf055f308aab5cefab2de0ce9
+checksum=888e30417342b05d566f5ef5a85791b05117fadbbc2f00bc5f29a30d6ba42ba9
 
-pre_configure() {
-	mkdir m4
-	NOCONFIGURE=1 xdt-autogen
-}
+# Package build options
+build_options="gir"
+build_options_default="gir"
 
 xfce4-panel-devel_package() {
 	depends="libxfce4ui-devel ${sourcepkg}>=${version}_${revision}"
@@ -26,6 +26,9 @@ xfce4-panel-devel_package() {
 		vmove usr/include
 		vmove usr/lib/pkgconfig
 		vmove usr/share/gtk-doc
-		vmove usr/lib/*.so
+		vmove "usr/lib/*.so"
+                if [ "$build_option_gir" ]; then
+                        vmove usr/share/gir-1.0
+                fi
 	}
 }

From 59f64b30f6366866f6e96a7144925639b494571c Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Sun, 28 Jul 2019 17:52:58 -0400
Subject: [PATCH 09/33] Thunar: update to 1.8.8.

---
 srcpkgs/Thunar/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/Thunar/template b/srcpkgs/Thunar/template
index 334f8d230db..2a382d12f63 100644
--- a/srcpkgs/Thunar/template
+++ b/srcpkgs/Thunar/template
@@ -1,6 +1,6 @@
 # Template file for 'Thunar'
 pkgname=Thunar
-version=1.8.7
+version=1.8.8
 revision=1
 build_style=gnu-configure
 build_helper="gir"
@@ -15,7 +15,7 @@ license="GPL-2.0-or-later, LGPL-2.1-or-later"
 homepage="https://docs.xfce.org/xfce/thunar/Start"
 changelog="https://raw.githubusercontent.com/xfce-mirror/thunar/master/NEWS"
 distfiles="https://archive.xfce.org/src/xfce/thunar/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=3e033af06751beee23e73cf16cbd97513d3c0adf358d8a42158af38a44b9d329
+checksum=a03761de4a43c36b9daa6029e6e3263a23c8ce429d78a9f9156ab48efdb2800c
 
 post_install() {
 	rm -rf ${DESTDIR}/usr/lib/systemd

From 9960dd43e15975e806aff92ce6ba714c35551c96 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:40:46 -0400
Subject: [PATCH 10/33] xfdesktop: update to 4.13.6.

Switch to libwnck, drop dbus-glib
---
 srcpkgs/xfdesktop/template | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/xfdesktop/template b/srcpkgs/xfdesktop/template
index be1056cf50b..154dd50ec92 100644
--- a/srcpkgs/xfdesktop/template
+++ b/srcpkgs/xfdesktop/template
@@ -1,16 +1,15 @@
 # Template file for 'xfdesktop'
 pkgname=xfdesktop
-version=4.12.5
+version=4.13.6
 revision=1
 build_style=gnu-configure
-hostmakedepends="pkg-config intltool glib-devel dbus-glib-devel"
-# XXX Add Thunar-devel again once xfdesktop supports the new Thunarx-3 API
+hostmakedepends="pkg-config intltool glib-devel Thunar-devel"
 makedepends="libxfce4ui-devel exo-devel garcon-devel
- libnotify-devel libwnck2-devel"
+ libnotify-devel libwnck-devel"
 depends="hicolor-icon-theme desktop-file-utils"
 short_desc="Desktop manager for the Xfce Desktop Environment"
 maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/xfdesktop/${version%.*}/$pkgname-$version.tar.bz2"
-checksum=3f2426ac28b94cfe5d6fd187c59b4e78f40e66c2842318e158ecd82abe2e7c0a
+checksum=f1f65cf31957e4cedd7b11d802f287d7429140c57fc3db7009578cca8398b990

From bc016e5a7fa4373a9fe4a851bb8e3ad73894c88e Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:41:45 -0400
Subject: [PATCH 11/33] xfwm4: update to 4.13.4.

Switch to libwnck, add Xpresent
---
 srcpkgs/xfwm4/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/xfwm4/template b/srcpkgs/xfwm4/template
index 58d1cc533df..3d721848b7e 100644
--- a/srcpkgs/xfwm4/template
+++ b/srcpkgs/xfwm4/template
@@ -1,16 +1,16 @@
 # Template file for 'xfwm4'
 pkgname=xfwm4
-version=4.12.5
+version=4.13.4
 revision=1
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool"
 makedepends="libxfce4ui-devel startup-notification-devel
  libXcomposite-devel libXdamage-devel libXfixes-devel libXrandr-devel
- libXrender-devel dbus-glib-devel libwnck2-devel"
+ libXrender-devel libXpresent-devel libwnck-devel"
 depends="hicolor-icon-theme desktop-file-utils"
 short_desc="Next generation window manager for Xfce"
 maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/xfwm4/${version%.*}/xfwm4-${version}.tar.bz2"
-checksum=7775c02216666c2d023275e7ed6d85e57d965e5cc1407bb6a05c53cc38d8caca
+checksum=31940e0e1d821d839b9ef1462bb1ca36e7935cd7589e4418993e3901ca6c0ec5

From ee58600b0d19f4b4740f3cbd0018ba0b838ac23d Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:43:17 -0400
Subject: [PATCH 12/33] thunar-volman: update to 0.9.4.

---
 srcpkgs/thunar-volman/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/thunar-volman/template b/srcpkgs/thunar-volman/template
index 15a066edaee..6797e585320 100644
--- a/srcpkgs/thunar-volman/template
+++ b/srcpkgs/thunar-volman/template
@@ -1,6 +1,6 @@
 # Template file for 'thunar-volman'
 pkgname=thunar-volman
-version=0.9.2
+version=0.9.4
 revision=1
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool"
@@ -12,4 +12,4 @@ license="GPL-2.0-or-later"
 homepage="https://xfce.org/"
 changelog="https://git.xfce.org/xfce/thunar-volman/plain/NEWS?h=${pkgname}-${version}"
 distfiles="https://archive.xfce.org/src/xfce/$pkgname/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=b944b4299b73d2ca79184922dfea49782e4849f5960e209def71ac700a92ff27
+checksum=c050f80a976fbb5f862c9c99857c761402ddd7980dc6f00d30002903f72abcb6

From 602b789cd31c84071b026a82bba8ea4f714cb62c Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:43:57 -0400
Subject: [PATCH 13/33] xfce4-settings: update to 4.13.8.

---
 srcpkgs/xfce4-settings/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/xfce4-settings/template b/srcpkgs/xfce4-settings/template
index 1944a3acf6e..2b9174d8505 100644
--- a/srcpkgs/xfce4-settings/template
+++ b/srcpkgs/xfce4-settings/template
@@ -1,6 +1,6 @@
 # Template file for 'xfce4-settings'
 pkgname=xfce4-settings
-version=4.12.4
+version=4.13.8
 revision=1
 build_style=gnu-configure
 configure_args="--enable-sound-settings --enable-pluggable-dialogs"
@@ -15,4 +15,4 @@ license="GPL-2.0-only"
 homepage="https://xfce.org/"
 changelog="https://raw.githubusercontent.com/xfce-mirror/xfce4-settings/master/NEWS"
 distfiles="https://archive.xfce.org/src/xfce/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=e2a04cad48bf9e951409d0c841829fa3b4ce632cd799082ef82d0506618b6f9b
+checksum=34ad226860e4cd8c13f6f0dc88e68a37173823c5a4c96ba9bfa89f869df086e7

From 173718697c0d6cba31e219cb51cc6ff1a7345740 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:44:21 -0400
Subject: [PATCH 14/33] xfce4-session: update to 4.13.4.

Switch to libwnck, drop dbus-glib, remove unnecessary --enable-upower
configure flag

Remove xfce4-session-devel as upstream no longer provides libxfsm as a
library.
---
 srcpkgs/xfce4-session-devel    |  1 -
 srcpkgs/xfce4-session/template | 26 ++++++--------------------
 2 files changed, 6 insertions(+), 21 deletions(-)
 delete mode 120000 srcpkgs/xfce4-session-devel

diff --git a/srcpkgs/xfce4-session-devel b/srcpkgs/xfce4-session-devel
deleted file mode 120000
index 865825879d6..00000000000
--- a/srcpkgs/xfce4-session-devel
+++ /dev/null
@@ -1 +0,0 @@
-xfce4-session
\ No newline at end of file
diff --git a/srcpkgs/xfce4-session/template b/srcpkgs/xfce4-session/template
index 6c4b9ecf265..f874df0aa11 100644
--- a/srcpkgs/xfce4-session/template
+++ b/srcpkgs/xfce4-session/template
@@ -1,12 +1,12 @@
 # Template file for 'xfce4-session'
 pkgname=xfce4-session
-version=4.12.1
-revision=2
+version=4.13.4
+revision=1
 build_style=gnu-configure
-configure_args="--disable-static --enable-upower --enable-polkit"
+configure_args="--disable-static --enable-polkit"
 hostmakedepends="xfce4-dev-tools pkg-config intltool gettext-devel glib-devel iceauth"
-makedepends="libxfce4ui-devel dbus-glib-devel upower-devel
- libwnck2-devel xfce4-panel-devel libSM-devel polkit-devel"
+makedepends="libxfce4ui-devel upower-devel
+ libwnck-devel xfce4-panel-devel libSM-devel polkit-devel"
 depends="iceauth hicolor-icon-theme desktop-file-utils"
 conf_files="/etc/xdg/xfce4/xfconf/xfce-perchannel-xml/xfce4-session.xml"
 short_desc="The session manager for the XFCE desktop environment"
@@ -14,23 +14,9 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/$pkgname/${version%.*}/$pkgname-$version.tar.bz2"
-checksum=97d7f2a2d0af7f3623b68d1f04091e02913b28f9555dab8b0d26c8a1299d08fd
+checksum=f52c566767001adafdaaa9188457ad32396233c24a09a681325b64eb3893b799
 
-pre_configure() {
-	mkdir m4
-	NOCONFIGURE=1 xdt-autogen
-}
 post_install() {
 	# startxfce4 needs bash.
 	replace_interpreter bash ${DESTDIR}/usr/bin/startxfce4
 }
-
-xfce4-session-devel_package() {
-	depends="libxfce4ui-devel>=4.12 ${sourcepkg}>=${version}_${revision}"
-	short_desc+=" - development files"
-	pkg_install() {
-		vmove usr/include
-		vmove usr/lib/pkgconfig
-		vmove "usr/lib/*.so"
-	}
-}

From 1be901fd38f3bfd1a4d6264f13c45636eec8c572 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:46:36 -0400
Subject: [PATCH 15/33] xfce4-appfinder: update to 4.13.5.

---
 srcpkgs/xfce4-appfinder/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/xfce4-appfinder/template b/srcpkgs/xfce4-appfinder/template
index 0ebe4dd92c7..5be2d02b14d 100644
--- a/srcpkgs/xfce4-appfinder/template
+++ b/srcpkgs/xfce4-appfinder/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-appfinder'
 pkgname=xfce4-appfinder
-version=4.12.0
-revision=3
+version=4.13.5
+revision=1
 build_style=gnu-configure
 configure_args="--enable-gtk3"
 hostmakedepends="pkg-config intltool"
@@ -12,4 +12,4 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=2ad4a58019a76a6b64a816050db25f96854917c2f2e89d6a9df6c18e6c84c567
+checksum=989f79eddc89c7d324d6d68878faf39292f7342a618a0711f0eb65634ed83960

From c1e963b145bd9086eb7346e38b5c7510064d39ea Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:47:16 -0400
Subject: [PATCH 16/33] xfce4-clipman-plugin: revbump for xfconf

---
 srcpkgs/xfce4-clipman-plugin/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/xfce4-clipman-plugin/template b/srcpkgs/xfce4-clipman-plugin/template
index 3d973e08e06..987a68f7d5f 100644
--- a/srcpkgs/xfce4-clipman-plugin/template
+++ b/srcpkgs/xfce4-clipman-plugin/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-clipman-plugin'
 pkgname=xfce4-clipman-plugin
 version=1.4.3
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="intltool pkg-config"
 makedepends="xfce4-panel-devel libXtst-devel qrencode-devel"

From 22e2510191cf89cb6fe84a14e932126ab736b38c Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:47:43 -0400
Subject: [PATCH 17/33] xfce4-notes-plugin: revbump for xfconf

---
 srcpkgs/xfce4-notes-plugin/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/xfce4-notes-plugin/template b/srcpkgs/xfce4-notes-plugin/template
index ce150733001..1df5d9776e8 100644
--- a/srcpkgs/xfce4-notes-plugin/template
+++ b/srcpkgs/xfce4-notes-plugin/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-notes-plugin'
 pkgname=xfce4-notes-plugin
 version=1.8.1
-revision=2
+revision=3
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool"
 makedepends="xfce4-panel-devel libunique1-devel"

From eb35be7f2022130f25cc94a157be7d7d9be5bcfd Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:48:12 -0400
Subject: [PATCH 18/33] xfce4-notifyd: revbump for xfconf

---
 srcpkgs/xfce4-notifyd/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/xfce4-notifyd/template b/srcpkgs/xfce4-notifyd/template
index cc07838d602..65500dc824e 100644
--- a/srcpkgs/xfce4-notifyd/template
+++ b/srcpkgs/xfce4-notifyd/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-notifyd'
 pkgname=xfce4-notifyd
 version=0.4.4
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool glib-devel dbus-glib-devel"
 makedepends="libnotify-devel xfce4-panel-devel"

From 8fa74f6971e687993f0d4f7db94eaa015e39be2b Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:49:24 -0400
Subject: [PATCH 19/33] mousepad: remove unnecessary makedepends on
 libxfce4ui-devel

---
 srcpkgs/mousepad/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/mousepad/template b/srcpkgs/mousepad/template
index 54160a9218e..f604781fb34 100644
--- a/srcpkgs/mousepad/template
+++ b/srcpkgs/mousepad/template
@@ -1,10 +1,10 @@
 # Template file for 'mousepad'
 pkgname=mousepad
 version=0.4.1
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="glib-devel intltool pkg-config"
-makedepends="gtksourceview-devel libxfce4ui-devel"
+makedepends="gtksourceview-devel"
 depends="desktop-file-utils hicolor-icon-theme"
 short_desc="Simple text editor for Xfce based on Leafpad"
 maintainer="Juan RP <xtraeme@voidlinux.org>"

From d7e8e2cf750efd2a1e7a78f6ce57c7534100c512 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:50:10 -0400
Subject: [PATCH 20/33] orage: remove unnecessary makedepends on dbus-glib

---
 srcpkgs/orage/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/orage/template b/srcpkgs/orage/template
index c0a9f23c448..bd0b9fcb6eb 100644
--- a/srcpkgs/orage/template
+++ b/srcpkgs/orage/template
@@ -1,10 +1,10 @@
 # Template file for 'orage'
 pkgname=orage
 version=4.12.1
-revision=3
+revision=4
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool flex"
-makedepends="libical-devel libnotify-devel gtk+-devel dbus-glib-devel
+makedepends="libical-devel libnotify-devel gtk+-devel
  popt-devel xfce4-panel-devel libxfce4util-devel"
 depends="hicolor-icon-theme desktop-file-utils"
 short_desc="Simple calendar application for Xfce"

From d79ba77016a6ead6e0fda4ad31b4561d7b55158d Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:51:12 -0400
Subject: [PATCH 21/33] ristretto: revbump for xfconf

---
 srcpkgs/ristretto/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/ristretto/template b/srcpkgs/ristretto/template
index 38dbc735472..7e761eb7c57 100644
--- a/srcpkgs/ristretto/template
+++ b/srcpkgs/ristretto/template
@@ -1,7 +1,7 @@
 # Template file for 'ristretto'
 pkgname=ristretto
 version=0.8.4
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="intltool pkg-config"
 makedepends="exo-devel file-devel libexif-devel"

From 461647af8fc2d40ed3af72bad31c15f16aa6fd63 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:51:31 -0400
Subject: [PATCH 22/33] vala-panel-appmenu: update to 0.7.2

---
 srcpkgs/vala-panel-appmenu/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/vala-panel-appmenu/template b/srcpkgs/vala-panel-appmenu/template
index 47c8b247bba..fa197105c43 100644
--- a/srcpkgs/vala-panel-appmenu/template
+++ b/srcpkgs/vala-panel-appmenu/template
@@ -1,7 +1,7 @@
 # Template file for 'vala-panel-appmenu'
 pkgname=vala-panel-appmenu
-version=0.7.1
-revision=2
+version=0.7.2
+revision=1
 build_style=cmake
 configure_args="-DENABLE_XFCE=ON -DENABLE_VALAPANEL=ON
  -DENABLE_MATE=ON -DENABLE_JAYATANA=OFF -DENABLE_APPMENU_GTK_MODULE=ON"
@@ -15,8 +15,8 @@ short_desc="Global Menu for Vala Panel"
 maintainer="John Eira <john.eira@web.de>"
 license="LGPL-3.0-or-later"
 homepage="https://gitlab.com/vala-panel-project/vala-panel-appmenu"
-distfiles="https://gitlab.com/vala-panel-project/vala-panel-appmenu/uploads/c0f85b42a2a228ad8c3413357e02fb28/vala-panel-appmenu-${version}.tar.xz"
-checksum=54a1b4f6ceca63eb3b79facc4327424bdd82f0fe3b7c6139326dbe0ec0824dcc
+distfiles="https://gitlab.com/vala-panel-project/vala-panel-appmenu/uploads/57fe7a74b38180002154fbd6028075db/vala-panel-appmenu-${version}.tar.xz"
+checksum=80884ebd71b665da7a1eac67752596ecbb29d3a8dd9eee9a2e3212dfc0aab6ae
 
 post_install() {
 	if [ "$CROSS_BUILD" ]; then

From 7ae5c59131adf24a60035dc22ea2d802c7836ff6 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:52:06 -0400
Subject: [PATCH 23/33] xfce4-places-plugin: update to 1.8.0.

Remove unnecessary patch.
---
 .../patches/undefined-symbol.patch            | 69 -------------------
 srcpkgs/xfce4-places-plugin/template          |  6 +-
 2 files changed, 3 insertions(+), 72 deletions(-)
 delete mode 100644 srcpkgs/xfce4-places-plugin/patches/undefined-symbol.patch

diff --git a/srcpkgs/xfce4-places-plugin/patches/undefined-symbol.patch b/srcpkgs/xfce4-places-plugin/patches/undefined-symbol.patch
deleted file mode 100644
index a94d9ea706f..00000000000
--- a/srcpkgs/xfce4-places-plugin/patches/undefined-symbol.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-From 94d583d0ba257cdc96cde5794ebb7d38001ae3a5 Mon Sep 17 00:00:00 2001
-From: Andrzej <ndrwrdck@gmail.com>
-Date: Tue, 7 Jul 2015 22:26:51 +0100
-Subject: [PATCH] Bug 11939:  xfce4-places-plugin 1.7.0 crashes with undefined
- symbol
-
-Patch from Fedora. Submitted by Kevin Fenzi.
----
- panel-plugin/model.h | 18 +++++++++---------
- 1 file changed, 9 insertions(+), 9 deletions(-)
-
-diff --git a/panel-plugin/model.h b/panel-plugin/model.h
-index 06d9d6f..043e391 100644
---- a/panel-plugin/model.h
-+++ b/panel-plugin/model.h
-@@ -36,13 +36,13 @@ struct _PlacesBookmarkAction
-     void        (*finalize) (PlacesBookmarkAction *self);
- };
- 
--inline PlacesBookmarkAction*
-+extern inline PlacesBookmarkAction*
- places_bookmark_action_create(gchar *label);
- 
--inline void
-+extern inline void
- places_bookmark_action_destroy(PlacesBookmarkAction*);
- 
--inline void
-+extern inline void
- places_bookmark_action_call(PlacesBookmarkAction*);
- 
- /* Places Bookmark */
-@@ -70,10 +70,10 @@ struct _PlacesBookmark
-     void                 (*finalize) (PlacesBookmark *self);
- };
- 
--inline PlacesBookmark*
-+extern inline PlacesBookmark*
- places_bookmark_create(gchar *label);
- 
--inline void
-+extern inline void
- places_bookmark_destroy(PlacesBookmark *bookmark);
- 
- /* Places Bookmark Group */
-@@ -86,16 +86,16 @@ struct _PlacesBookmarkGroup
-     gpointer    priv;
- };
- 
--inline GList*
-+extern inline GList*
- places_bookmark_group_get_bookmarks(PlacesBookmarkGroup*);
- 
--inline gboolean
-+extern inline gboolean
- places_bookmark_group_changed(PlacesBookmarkGroup*);
- 
--inline PlacesBookmarkGroup*
-+extern inline PlacesBookmarkGroup*
- places_bookmark_group_create();
- 
--inline void
-+extern inline void
- places_bookmark_group_destroy(PlacesBookmarkGroup*);
- 
- #endif
--- 
-2.6.4
-
diff --git a/srcpkgs/xfce4-places-plugin/template b/srcpkgs/xfce4-places-plugin/template
index b7f2d8ea2f6..1c1c952a16d 100644
--- a/srcpkgs/xfce4-places-plugin/template
+++ b/srcpkgs/xfce4-places-plugin/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-places-plugin'
 pkgname=xfce4-places-plugin
-version=1.7.0
-revision=3
+version=1.8.0
+revision=1
 build_style=gnu-configure
 hostmakedepends="intltool pkg-config"
 makedepends="exo-devel libglib-devel gtk+-devel libxfce4ui-devel libxfce4util-devel
@@ -11,6 +11,6 @@ maintainer="Steve Prybylski <sa.prybylx@gmail.com>"
 license="GPL-2.0-or-later"
 homepage="https://goodies.xfce.org/projects/panel-plugins/xfce4-places-plugin"
 distfiles="https://archive.xfce.org/src/panel-plugins/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=4175c614749abbb5bcf6f49c88125fb0dd36db69f4c374df23563907b16e2c3f
+checksum=7ba3f46f88c2845cbf413efeefaed29157f8b98571856c6e2bf35e4de5d8ecce
 patch_args="-Np1"
 

From e00ac68106077c830d8e8274899c80028ca7817b Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:52:41 -0400
Subject: [PATCH 24/33] xfce4-power-manager: update to 1.6.4.

---
 srcpkgs/xfce4-power-manager/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/xfce4-power-manager/template b/srcpkgs/xfce4-power-manager/template
index 6b44f4d349f..086e0ccd5b1 100644
--- a/srcpkgs/xfce4-power-manager/template
+++ b/srcpkgs/xfce4-power-manager/template
@@ -1,6 +1,6 @@
 # Template file for 'xfce4-power-manager'
 pkgname=xfce4-power-manager
-version=1.6.1
+version=1.6.4
 revision=1
 build_style=gnu-configure
 configure_args="--disable-static"
@@ -12,4 +12,4 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/$pkgname/${version%.*}/$pkgname-$version.tar.bz2"
-checksum=1ea825452343b895566068018b6d5078608f8f46ce8075ba6bbb4b848f48656b
+checksum=078df808e68f745769b4c34a4719cfe289d4bf89ca2cd4ed4680f2551a00039e

From 4f4f2b9b14220984ef60ee30bca049e9856cb4e6 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:53:06 -0400
Subject: [PATCH 25/33] xfce4-pulseaudio-plugin: revbump for xfconf

---
 srcpkgs/xfce4-pulseaudio-plugin/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/xfce4-pulseaudio-plugin/template b/srcpkgs/xfce4-pulseaudio-plugin/template
index d54728002a6..0ff54c57d27 100644
--- a/srcpkgs/xfce4-pulseaudio-plugin/template
+++ b/srcpkgs/xfce4-pulseaudio-plugin/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-pulseaudio-plugin'
 pkgname=xfce4-pulseaudio-plugin
 version=0.4.1
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="gettext-devel xfce4-dev-tools"
 makedepends="libkeybinder3-devel libnotify-devel pulseaudio-devel xfce4-panel-devel"

From 8296eea4d14bb99afe21c47e9e03a749ec350c1c Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:53:28 -0400
Subject: [PATCH 26/33] xfce4-screensaver: revbump for xfconf

---
 srcpkgs/xfce4-screensaver/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/xfce4-screensaver/template b/srcpkgs/xfce4-screensaver/template
index af2dba5fabf..aa45226a504 100644
--- a/srcpkgs/xfce4-screensaver/template
+++ b/srcpkgs/xfce4-screensaver/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-screensaver'
 pkgname=xfce4-screensaver
 version=0.1.4
-revision=1
+revision=2
 build_style=gnu-configure
 configure_args="--without-systemd --with-libgl --with-shadow --with-mit-ext
  --with-xf86gamma-ext --with-x --enable-pam"

From 60ecb45d49f787c7187889307214d09790b536b5 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:54:20 -0400
Subject: [PATCH 27/33] xfce4-sensors-plugin: update to 1.3.92.

---
 srcpkgs/xfce4-sensors-plugin/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/xfce4-sensors-plugin/template b/srcpkgs/xfce4-sensors-plugin/template
index 4c5053fba55..96b8a00b3af 100644
--- a/srcpkgs/xfce4-sensors-plugin/template
+++ b/srcpkgs/xfce4-sensors-plugin/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-sensors-plugin'
 pkgname=xfce4-sensors-plugin
-version=1.3.0
-revision=2
+version=1.3.92
+revision=1
 build_style=gnu-configure
 configure_args="--disable-static"
 hostmakedepends="pkg-config intltool"
@@ -12,7 +12,7 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="https://goodies.xfce.org/projects/panel-plugins/xfce4-sensors-plugin"
 distfiles="https://archive.xfce.org/src/panel-plugins/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=b7a7834ca84f6751686fa2e20e0b44a2e68ece0cb2716792a765e03b92f65569
+checksum=3dc6643d2c064b7718badff44b948f8d410f00f13db197820b26ae38045f5112
 
 if [ "$CROSS_BUILD" ]; then
 	# Cannot detect these when cross compiling

From 527329095a7e49dba08af3db8524f75a20bc71e8 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:55:52 -0400
Subject: [PATCH 28/33] xfce4-weather-plugin: update to 0.9.1.

---
 srcpkgs/xfce4-weather-plugin/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/xfce4-weather-plugin/template b/srcpkgs/xfce4-weather-plugin/template
index 8c3bab3185c..e6f9671ba6a 100644
--- a/srcpkgs/xfce4-weather-plugin/template
+++ b/srcpkgs/xfce4-weather-plugin/template
@@ -1,6 +1,6 @@
 # Template file for 'xfce4-weather-plugin'
 pkgname=xfce4-weather-plugin
-version=0.8.11
+version=0.9.1
 revision=1
 build_style=gnu-configure
 configure_args="--disable-upower"
@@ -12,5 +12,5 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="https://goodies.xfce.org/projects/panel-plugins/xfce4-weather-plugin"
 distfiles="https://archive.xfce.org/src/panel-plugins/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=0382ce99c0ad4424afe7096a354f301a9396d12807a0f2ab041912d6ab58145d
+checksum=7cdc18b8df759dee4ceaaf6ce303eff7fda48e247dbc26b78142929213506cfd
 lib32disabled=yes

From f729e1e17531d454b9bbeb4eb55a4c369920d497 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:56:18 -0400
Subject: [PATCH 29/33] xfce4-windowck-plugin: update to 0.4.6.

---
 srcpkgs/xfce4-windowck-plugin/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/xfce4-windowck-plugin/template b/srcpkgs/xfce4-windowck-plugin/template
index 355ae97ad5d..5d897ba7154 100644
--- a/srcpkgs/xfce4-windowck-plugin/template
+++ b/srcpkgs/xfce4-windowck-plugin/template
@@ -1,17 +1,17 @@
 # Template file for 'xfce4-windowck-plugin'
 pkgname=xfce4-windowck-plugin
-version=0.4.4
-revision=2
+version=0.4.6
+revision=1
 build_style=gnu-makefile
 hostmakedepends="intltool xfce4-dev-tools exo-devel python3-devel glib-devel gettext-devel ImageMagick"
 makedepends="libwnck2-devel xfce4-panel-devel xorg-server-devel"
-depends="xfce4-panel>=4.10"
+depends="xfce4-panel>=4.13"
 short_desc="Puts the titlebar of a maximized window into a panel"
 maintainer="skurtix <skurtix@github.com>"
 homepage="https://github.com/cedl38/xfce4-windowck-plugin"
 license="GPL-3"
 distfiles="${homepage}/archive/v${version}.tar.gz"
-checksum=92b6c9e199d32cf96619c31e2cfac19e375575d581e78fa043f9f6a59c1df13f
+checksum=1643fa4a8bdbc401160fae6a132dcab89ed88d10231f84ed058f7a3e842763f7
 
 pre_configure() {
 	autogen_args="--prefix=/usr"

From 11647dd7ff3205ad3e43902b7ecae62fbcf704fb Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Fri, 24 May 2019 11:56:43 -0400
Subject: [PATCH 30/33] xfce4-xkb-plugin: revbump for xfconf

---
 srcpkgs/xfce4-xkb-plugin/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/xfce4-xkb-plugin/template b/srcpkgs/xfce4-xkb-plugin/template
index 30ec3089bbb..d64ee2670ee 100644
--- a/srcpkgs/xfce4-xkb-plugin/template
+++ b/srcpkgs/xfce4-xkb-plugin/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-xkb-plugin'
 pkgname=xfce4-xkb-plugin
 version=0.8.1
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool"
 makedepends="garcon-devel xfce4-panel-devel libxklavier-devel librsvg-devel libwnck-devel"

From 0538c94b5c721ea251d5120f2b2b3c72691673a2 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Tue, 2 Jul 2019 09:13:52 -0400
Subject: [PATCH 31/33] tumbler: update to 0.2.6.

---
 srcpkgs/tumbler/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/tumbler/template b/srcpkgs/tumbler/template
index f385ee3d43c..aacdd272080 100644
--- a/srcpkgs/tumbler/template
+++ b/srcpkgs/tumbler/template
@@ -1,6 +1,6 @@
 # Template file for 'tumbler'.
 pkgname=tumbler
-version=0.2.3
+version=0.2.6
 revision=1
 build_style=gnu-configure
 configure_args="--disable-gstreamer-thumbnailer"
@@ -12,7 +12,7 @@ maintainer="Juan RP <xtraeme@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="https://xfce.org/"
 distfiles="https://archive.xfce.org/src/xfce/${pkgname}/${version%.*}/${pkgname}-${version}.tar.bz2"
-checksum=d022e1bd1559fba33e4bf20fb053b219eca17676ebffb1ceb214fcd58a187d40
+checksum=74d21781fb0c1e8c11ac803cc5afb469893a0b220721fdc25660c54891a10fa0
 
 CFLAGS="-I${XBPS_CROSS_BASE}/usr/include/freetype2"
 

From aa86a99e748cb82ac129639197d3c42e4a10a1f4 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Thu, 18 Jul 2019 20:38:25 -0400
Subject: [PATCH 32/33] xfce4-terminal: revbump for xfconf

---
 srcpkgs/xfce4-terminal/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/xfce4-terminal/template b/srcpkgs/xfce4-terminal/template
index 4087403c711..22f5df16c60 100644
--- a/srcpkgs/xfce4-terminal/template
+++ b/srcpkgs/xfce4-terminal/template
@@ -1,7 +1,7 @@
 # Template file for 'xfce4-terminal'
 pkgname=xfce4-terminal
 version=0.8.8
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="intltool pkg-config"
 makedepends="exo-devel vte3-devel"

From 1d4a8d66832d05b4615ea2c21c44e44915be9e6e Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Sun, 28 Jul 2019 19:01:08 -0400
Subject: [PATCH 33/33] parole: revbump for xfconf

---
 srcpkgs/parole/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/parole/template b/srcpkgs/parole/template
index f3266eac70d..3c0b3ffd731 100644
--- a/srcpkgs/parole/template
+++ b/srcpkgs/parole/template
@@ -1,7 +1,7 @@
 # Template file for 'parole'
 pkgname=parole
 version=1.0.3
-revision=1
+revision=2
 build_style=gnu-configure
 hostmakedepends="pkg-config intltool glib-devel"
 makedepends="gst-plugins-base1-devel libnotify-devel taglib-devel libxfce4ui-devel"

^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, back to index

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
     [not found] <gh-mailinglist-notifications-41a7ca26-5023-4802-975b-f1789d68868e-void-packages-11932@inbox.vuxu.org>
2019-07-02 13:05 ` [PR PATCH] [Updated] [RFC] xfce4-4.14pre1 voidlinux-github
2019-07-02 13:05 ` voidlinux-github
2019-07-02 13:16 ` [PR PATCH] [Updated] [RFC] xfce4-4.14pre2 voidlinux-github
2019-07-02 13:16 ` voidlinux-github
2019-07-02 13:19 ` voidlinux-github
2019-07-28 23:18 ` [PR PATCH] [Updated] " voidlinux-github
2019-07-28 23:18 ` voidlinux-github

Github messages for voidlinux

Archives are clonable: git clone --mirror http://inbox.vuxu.org/voidlinux-github

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.github.voidlinux


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git