Github messages for voidlinux
 help / color / Atom feed
* Re: [Nomerge] sway: update to 1.2.
       [not found] <gh-mailinglist-notifications-41a7ca26-5023-4802-975b-f1789d68868e-void-packages-13999@inbox.vuxu.org>
@ 2019-09-10 16:41 ` voidlinux-github
  2019-10-07 18:29 ` voidlinux-github
                   ` (27 subsequent siblings)
  28 siblings, 0 replies; 29+ messages in thread
From: voidlinux-github @ 2019-09-10 16:41 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 370 bytes --]

New comment by klardotsh on void-packages repository

https://github.com/void-linux/void-packages/pull/13999#issuecomment-530021650

Comment:
@LennyPenny `wayfire` and `sway` both depend on `wlroots`. `sway>=1.2` depends on `wlroots>=0.7` which is incompatible with the Wayfire version Void packages. Thus, everything has to be stuck until that package gets sorted out.

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: [Nomerge] sway: update to 1.2.
       [not found] <gh-mailinglist-notifications-41a7ca26-5023-4802-975b-f1789d68868e-void-packages-13999@inbox.vuxu.org>
  2019-09-10 16:41 ` [Nomerge] sway: update to 1.2 voidlinux-github
@ 2019-10-07 18:29 ` voidlinux-github
  2019-10-07 18:31 ` voidlinux-github
                   ` (26 subsequent siblings)
  28 siblings, 0 replies; 29+ messages in thread
From: voidlinux-github @ 2019-10-07 18:29 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 209 bytes --]

New comment by CameronNemo on void-packages repository

https://github.com/void-linux/void-packages/pull/13999#issuecomment-539144412

Comment:
wayfire is close https://github.com/WayfireWM/wayfire/issues/285

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: [Nomerge] sway: update to 1.2.
       [not found] <gh-mailinglist-notifications-41a7ca26-5023-4802-975b-f1789d68868e-void-packages-13999@inbox.vuxu.org>
  2019-09-10 16:41 ` [Nomerge] sway: update to 1.2 voidlinux-github
  2019-10-07 18:29 ` voidlinux-github
@ 2019-10-07 18:31 ` voidlinux-github
  2019-10-07 19:15 ` voidlinux-github
                   ` (25 subsequent siblings)
  28 siblings, 0 replies; 29+ messages in thread
From: voidlinux-github @ 2019-10-07 18:31 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 190 bytes --]

New comment by Wychmire on void-packages repository

https://github.com/void-linux/void-packages/pull/13999#issuecomment-539145232

Comment:
No new release quite yet though. Hopefully soon!

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: [Nomerge] sway: update to 1.2.
       [not found] <gh-mailinglist-notifications-41a7ca26-5023-4802-975b-f1789d68868e-void-packages-13999@inbox.vuxu.org>
                   ` (2 preceding siblings ...)
  2019-10-07 18:31 ` voidlinux-github
@ 2019-10-07 19:15 ` voidlinux-github
  2019-10-07 23:53 ` [PR PATCH] [Updated] " voidlinux-github
                   ` (24 subsequent siblings)
  28 siblings, 0 replies; 29+ messages in thread
From: voidlinux-github @ 2019-10-07 19:15 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 327 bytes --]

New comment by Wychmire on void-packages repository

https://github.com/void-linux/void-packages/pull/13999#issuecomment-539162234

Comment:
Wayfire has its new release, I can bump it in a separate PR unless someone else wants to/it's bumped in this PR

[new release](https://github.com/WayfireWM/wayfire/releases/tag/0.3.0)

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: [PR PATCH] [Updated] [Nomerge] sway: update to 1.2.
       [not found] <gh-mailinglist-notifications-41a7ca26-5023-4802-975b-f1789d68868e-void-packages-13999@inbox.vuxu.org>
                   ` (3 preceding siblings ...)
  2019-10-07 19:15 ` voidlinux-github
@ 2019-10-07 23:53 ` voidlinux-github
  2019-10-07 23:53 ` voidlinux-github
                   ` (23 subsequent siblings)
  28 siblings, 0 replies; 29+ messages in thread
From: voidlinux-github @ 2019-10-07 23:53 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 349 bytes --]

There is an updated pull request by travankor against master on the void-packages repository

https://github.com/travankor/void-packages sway
https://github.com/void-linux/void-packages/pull/13999

[Nomerge] sway: update to 1.2.
Wayfire needs to be updated.

A patch file from https://github.com/void-linux/void-packages/pull/13999.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-sway-13999.patch --]
[-- Type: text/x-diff, Size: 3859 bytes --]

From 01bfd17e6f2aaa73a9e7e3a008676ad1fed741f1 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 27 Aug 2019 03:04:57 -0700
Subject: [PATCH 1/3] sway: update to 1.2.

---
 srcpkgs/sway/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/sway/template b/srcpkgs/sway/template
index 574ff5f90cd..0a236516283 100644
--- a/srcpkgs/sway/template
+++ b/srcpkgs/sway/template
@@ -1,6 +1,6 @@
 # Template file for 'sway'
 pkgname=sway
-version=1.1.1
+version=1.2
 revision=1
 build_style=meson
 conf_files="/etc/sway/config"
@@ -13,7 +13,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://swaywm.org"
 distfiles="https://github.com/swaywm/${pkgname}/archive/${version}.tar.gz"
-checksum=740bf97556c54da83937a255113d715aaa05e05b44d61fbe85e01b53ff1f9922
+checksum=9f79382577ee132111c290b4d1a1a3e114ef485595c30cf5f181a11575bda846
 
 build_options="elogind"
 desc_option_elogind="Uses elogind instead of setuid for privilege escalation"

From 165e9cff5a62f919b4111d83400f0a8a1e8fc9b3 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 27 Aug 2019 03:30:45 -0700
Subject: [PATCH 2/3] wlroots: update to 0.7.0.

---
 srcpkgs/wlroots/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/wlroots/template b/srcpkgs/wlroots/template
index 7b88e324827..e4951990944 100644
--- a/srcpkgs/wlroots/template
+++ b/srcpkgs/wlroots/template
@@ -1,23 +1,23 @@
 # Template file for 'wlroots'
 pkgname=wlroots
-version=0.6.0
-revision=2
+version=0.7.0
+revision=1
 build_style=meson
 configure_args="-Dlibcap=enabled -Dlogind=enabled -Dlogind-provider=elogind
  -Dxcb-errors=enabled -Dxcb-icccm=enabled -Dxwayland=enabled
- -Dx11-backend=enabled -Dexamples=false -Drootston=false"
+ -Dx11-backend=enabled -Dexamples=false"
 hostmakedepends="pkg-config wayland-devel"
 makedepends="elogind-devel libcap-devel wayland-devel wayland-protocols
  MesaLib-devel libinput-devel libxkbcommon-devel libdrm-devel pixman-devel
  libxcb-devel xcb-util-cursor-devel xcb-util-devel xcb-util-image-devel
  xcb-util-keysyms-devel xcb-util-renderutil-devel xcb-util-wm-devel
  xcb-util-errors-devel xcb-util-xrm-devel freerdp-devel"
-short_desc="Module Wayland compositor library"
+short_desc="Modular Wayland compositor library"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://github.com/swaywm/wlroots"
 distfiles="https://github.com/swaywm/wlroots/archive/${version}.tar.gz"
-checksum=9cf3716f3683d800df8b150f256ff66dad65faf13a9d67c284f67a9444d28c70
+checksum=e93091d49fc4a3dc1743eca7cdfa75584f2922f59036ba0a99194a9fc8b5e818
 
 post_install() {
 	vlicense LICENSE

From 24edf8bd9fb90bdac3491f9c4ee96a5d853e35fe Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Wed, 28 Aug 2019 00:50:07 -0700
Subject: [PATCH 3/3] wayfire: update to 0.3.0.

---
 srcpkgs/wayfire/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/wayfire/template b/srcpkgs/wayfire/template
index 2ee4bd17ae9..9130ec46779 100644
--- a/srcpkgs/wayfire/template
+++ b/srcpkgs/wayfire/template
@@ -1,6 +1,6 @@
 # Template file for 'wayfire'
 pkgname=wayfire
-version=0.2
+version=0.3.0
 revision=1
 build_style=meson
 hostmakedepends="pkg-config wayland-devel"
@@ -9,8 +9,8 @@ short_desc="3D wayland compositor"
 maintainer="Young Jin Park <youngjinpark20@gmail.com>"
 license="MIT"
 homepage="https://wayfire.org"
-distfiles="https://github.com/WayfireWM/wayfire/archive/v${version}.tar.gz"
-checksum=94fe93bb2b86048fd1c7601f97b167767e19618bb6b6226e21c22fbd052540bf
+distfiles="https://github.com/WayfireWM/wayfire/archive/${version}.tar.gz"
+checksum=c686bf5abb7f0db829196785bba4136c85d7b52d701212e21636dad75e1da0aa
 
 case $XBPS_TARGET_MACHINE in
 	*-musl) makedepends+=" libexecinfo-devel"

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: [PR PATCH] [Updated] [Nomerge] sway: update to 1.2.
       [not found] <gh-mailinglist-notifications-41a7ca26-5023-4802-975b-f1789d68868e-void-packages-13999@inbox.vuxu.org>
                   ` (4 preceding siblings ...)
  2019-10-07 23:53 ` [PR PATCH] [Updated] " voidlinux-github
@ 2019-10-07 23:53 ` voidlinux-github
  2019-10-07 23:58 ` voidlinux-github
                   ` (22 subsequent siblings)
  28 siblings, 0 replies; 29+ messages in thread
From: voidlinux-github @ 2019-10-07 23:53 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 349 bytes --]

There is an updated pull request by travankor against master on the void-packages repository

https://github.com/travankor/void-packages sway
https://github.com/void-linux/void-packages/pull/13999

[Nomerge] sway: update to 1.2.
Wayfire needs to be updated.

A patch file from https://github.com/void-linux/void-packages/pull/13999.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-sway-13999.patch --]
[-- Type: text/x-diff, Size: 3859 bytes --]

From 01bfd17e6f2aaa73a9e7e3a008676ad1fed741f1 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 27 Aug 2019 03:04:57 -0700
Subject: [PATCH 1/3] sway: update to 1.2.

---
 srcpkgs/sway/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/sway/template b/srcpkgs/sway/template
index 574ff5f90cd..0a236516283 100644
--- a/srcpkgs/sway/template
+++ b/srcpkgs/sway/template
@@ -1,6 +1,6 @@
 # Template file for 'sway'
 pkgname=sway
-version=1.1.1
+version=1.2
 revision=1
 build_style=meson
 conf_files="/etc/sway/config"
@@ -13,7 +13,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://swaywm.org"
 distfiles="https://github.com/swaywm/${pkgname}/archive/${version}.tar.gz"
-checksum=740bf97556c54da83937a255113d715aaa05e05b44d61fbe85e01b53ff1f9922
+checksum=9f79382577ee132111c290b4d1a1a3e114ef485595c30cf5f181a11575bda846
 
 build_options="elogind"
 desc_option_elogind="Uses elogind instead of setuid for privilege escalation"

From 165e9cff5a62f919b4111d83400f0a8a1e8fc9b3 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 27 Aug 2019 03:30:45 -0700
Subject: [PATCH 2/3] wlroots: update to 0.7.0.

---
 srcpkgs/wlroots/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/wlroots/template b/srcpkgs/wlroots/template
index 7b88e324827..e4951990944 100644
--- a/srcpkgs/wlroots/template
+++ b/srcpkgs/wlroots/template
@@ -1,23 +1,23 @@
 # Template file for 'wlroots'
 pkgname=wlroots
-version=0.6.0
-revision=2
+version=0.7.0
+revision=1
 build_style=meson
 configure_args="-Dlibcap=enabled -Dlogind=enabled -Dlogind-provider=elogind
  -Dxcb-errors=enabled -Dxcb-icccm=enabled -Dxwayland=enabled
- -Dx11-backend=enabled -Dexamples=false -Drootston=false"
+ -Dx11-backend=enabled -Dexamples=false"
 hostmakedepends="pkg-config wayland-devel"
 makedepends="elogind-devel libcap-devel wayland-devel wayland-protocols
  MesaLib-devel libinput-devel libxkbcommon-devel libdrm-devel pixman-devel
  libxcb-devel xcb-util-cursor-devel xcb-util-devel xcb-util-image-devel
  xcb-util-keysyms-devel xcb-util-renderutil-devel xcb-util-wm-devel
  xcb-util-errors-devel xcb-util-xrm-devel freerdp-devel"
-short_desc="Module Wayland compositor library"
+short_desc="Modular Wayland compositor library"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://github.com/swaywm/wlroots"
 distfiles="https://github.com/swaywm/wlroots/archive/${version}.tar.gz"
-checksum=9cf3716f3683d800df8b150f256ff66dad65faf13a9d67c284f67a9444d28c70
+checksum=e93091d49fc4a3dc1743eca7cdfa75584f2922f59036ba0a99194a9fc8b5e818
 
 post_install() {
 	vlicense LICENSE

From 24edf8bd9fb90bdac3491f9c4ee96a5d853e35fe Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Wed, 28 Aug 2019 00:50:07 -0700
Subject: [PATCH 3/3] wayfire: update to 0.3.0.

---
 srcpkgs/wayfire/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/wayfire/template b/srcpkgs/wayfire/template
index 2ee4bd17ae9..9130ec46779 100644
--- a/srcpkgs/wayfire/template
+++ b/srcpkgs/wayfire/template
@@ -1,6 +1,6 @@
 # Template file for 'wayfire'
 pkgname=wayfire
-version=0.2
+version=0.3.0
 revision=1
 build_style=meson
 hostmakedepends="pkg-config wayland-devel"
@@ -9,8 +9,8 @@ short_desc="3D wayland compositor"
 maintainer="Young Jin Park <youngjinpark20@gmail.com>"
 license="MIT"
 homepage="https://wayfire.org"
-distfiles="https://github.com/WayfireWM/wayfire/archive/v${version}.tar.gz"
-checksum=94fe93bb2b86048fd1c7601f97b167767e19618bb6b6226e21c22fbd052540bf
+distfiles="https://github.com/WayfireWM/wayfire/archive/${version}.tar.gz"
+checksum=c686bf5abb7f0db829196785bba4136c85d7b52d701212e21636dad75e1da0aa
 
 case $XBPS_TARGET_MACHINE in
 	*-musl) makedepends+=" libexecinfo-devel"

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: [PR PATCH] [Updated] [Nomerge] sway: update to 1.2.
       [not found] <gh-mailinglist-notifications-41a7ca26-5023-4802-975b-f1789d68868e-void-packages-13999@inbox.vuxu.org>
                   ` (6 preceding siblings ...)
  2019-10-07 23:58 ` voidlinux-github
@ 2019-10-07 23:58 ` voidlinux-github
  2019-10-08  0:04 ` voidlinux-github
                   ` (20 subsequent siblings)
  28 siblings, 0 replies; 29+ messages in thread
From: voidlinux-github @ 2019-10-07 23:58 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 349 bytes --]

There is an updated pull request by travankor against master on the void-packages repository

https://github.com/travankor/void-packages sway
https://github.com/void-linux/void-packages/pull/13999

[Nomerge] sway: update to 1.2.
Wayfire needs to be updated.

A patch file from https://github.com/void-linux/void-packages/pull/13999.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-sway-13999.patch --]
[-- Type: text/x-diff, Size: 3857 bytes --]

From 01bfd17e6f2aaa73a9e7e3a008676ad1fed741f1 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 27 Aug 2019 03:04:57 -0700
Subject: [PATCH 1/3] sway: update to 1.2.

---
 srcpkgs/sway/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/sway/template b/srcpkgs/sway/template
index 574ff5f90cd..0a236516283 100644
--- a/srcpkgs/sway/template
+++ b/srcpkgs/sway/template
@@ -1,6 +1,6 @@
 # Template file for 'sway'
 pkgname=sway
-version=1.1.1
+version=1.2
 revision=1
 build_style=meson
 conf_files="/etc/sway/config"
@@ -13,7 +13,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://swaywm.org"
 distfiles="https://github.com/swaywm/${pkgname}/archive/${version}.tar.gz"
-checksum=740bf97556c54da83937a255113d715aaa05e05b44d61fbe85e01b53ff1f9922
+checksum=9f79382577ee132111c290b4d1a1a3e114ef485595c30cf5f181a11575bda846
 
 build_options="elogind"
 desc_option_elogind="Uses elogind instead of setuid for privilege escalation"

From 5c5c06f8332ac21b0db5bdd9476a64bc5bcb2c5e Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Mon, 7 Oct 2019 16:58:21 -0700
Subject: [PATCH 2/3] wlroots: update to 0.8.1.

---
 srcpkgs/wlroots/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/wlroots/template b/srcpkgs/wlroots/template
index 7b88e324827..75ddb338a15 100644
--- a/srcpkgs/wlroots/template
+++ b/srcpkgs/wlroots/template
@@ -1,23 +1,23 @@
 # Template file for 'wlroots'
 pkgname=wlroots
-version=0.6.0
-revision=2
+version=0.8.1
+revision=1
 build_style=meson
 configure_args="-Dlibcap=enabled -Dlogind=enabled -Dlogind-provider=elogind
  -Dxcb-errors=enabled -Dxcb-icccm=enabled -Dxwayland=enabled
- -Dx11-backend=enabled -Dexamples=false -Drootston=false"
+ -Dx11-backend=enabled -Dexamples=false"
 hostmakedepends="pkg-config wayland-devel"
 makedepends="elogind-devel libcap-devel wayland-devel wayland-protocols
  MesaLib-devel libinput-devel libxkbcommon-devel libdrm-devel pixman-devel
  libxcb-devel xcb-util-cursor-devel xcb-util-devel xcb-util-image-devel
  xcb-util-keysyms-devel xcb-util-renderutil-devel xcb-util-wm-devel
  xcb-util-errors-devel xcb-util-xrm-devel freerdp-devel"
-short_desc="Module Wayland compositor library"
+short_desc="Modular Wayland compositor library"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://github.com/swaywm/wlroots"
 distfiles="https://github.com/swaywm/wlroots/archive/${version}.tar.gz"
-checksum=9cf3716f3683d800df8b150f256ff66dad65faf13a9d67c284f67a9444d28c70
+checksum=202b86e0e21699b6660bbda56afc2e3358db7252f83ff69c89f01926b4900d98
 
 post_install() {
 	vlicense LICENSE

From a90baf336836273bd8af8ca94d684c427101d706 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Mon, 7 Oct 2019 16:58:29 -0700
Subject: [PATCH 3/3] wayfire: update to 0.3.0.

---
 srcpkgs/wayfire/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/wayfire/template b/srcpkgs/wayfire/template
index 2ee4bd17ae9..9130ec46779 100644
--- a/srcpkgs/wayfire/template
+++ b/srcpkgs/wayfire/template
@@ -1,6 +1,6 @@
 # Template file for 'wayfire'
 pkgname=wayfire
-version=0.2
+version=0.3.0
 revision=1
 build_style=meson
 hostmakedepends="pkg-config wayland-devel"
@@ -9,8 +9,8 @@ short_desc="3D wayland compositor"
 maintainer="Young Jin Park <youngjinpark20@gmail.com>"
 license="MIT"
 homepage="https://wayfire.org"
-distfiles="https://github.com/WayfireWM/wayfire/archive/v${version}.tar.gz"
-checksum=94fe93bb2b86048fd1c7601f97b167767e19618bb6b6226e21c22fbd052540bf
+distfiles="https://github.com/WayfireWM/wayfire/archive/${version}.tar.gz"
+checksum=c686bf5abb7f0db829196785bba4136c85d7b52d701212e21636dad75e1da0aa
 
 case $XBPS_TARGET_MACHINE in
 	*-musl) makedepends+=" libexecinfo-devel"

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: [PR PATCH] [Updated] [Nomerge] sway: update to 1.2.
       [not found] <gh-mailinglist-notifications-41a7ca26-5023-4802-975b-f1789d68868e-void-packages-13999@inbox.vuxu.org>
                   ` (5 preceding siblings ...)
  2019-10-07 23:53 ` voidlinux-github
@ 2019-10-07 23:58 ` voidlinux-github
  2019-10-07 23:58 ` voidlinux-github
                   ` (21 subsequent siblings)
  28 siblings, 0 replies; 29+ messages in thread
From: voidlinux-github @ 2019-10-07 23:58 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 349 bytes --]

There is an updated pull request by travankor against master on the void-packages repository

https://github.com/travankor/void-packages sway
https://github.com/void-linux/void-packages/pull/13999

[Nomerge] sway: update to 1.2.
Wayfire needs to be updated.

A patch file from https://github.com/void-linux/void-packages/pull/13999.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-sway-13999.patch --]
[-- Type: text/x-diff, Size: 3857 bytes --]

From 01bfd17e6f2aaa73a9e7e3a008676ad1fed741f1 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 27 Aug 2019 03:04:57 -0700
Subject: [PATCH 1/3] sway: update to 1.2.

---
 srcpkgs/sway/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/sway/template b/srcpkgs/sway/template
index 574ff5f90cd..0a236516283 100644
--- a/srcpkgs/sway/template
+++ b/srcpkgs/sway/template
@@ -1,6 +1,6 @@
 # Template file for 'sway'
 pkgname=sway
-version=1.1.1
+version=1.2
 revision=1
 build_style=meson
 conf_files="/etc/sway/config"
@@ -13,7 +13,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://swaywm.org"
 distfiles="https://github.com/swaywm/${pkgname}/archive/${version}.tar.gz"
-checksum=740bf97556c54da83937a255113d715aaa05e05b44d61fbe85e01b53ff1f9922
+checksum=9f79382577ee132111c290b4d1a1a3e114ef485595c30cf5f181a11575bda846
 
 build_options="elogind"
 desc_option_elogind="Uses elogind instead of setuid for privilege escalation"

From 5c5c06f8332ac21b0db5bdd9476a64bc5bcb2c5e Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Mon, 7 Oct 2019 16:58:21 -0700
Subject: [PATCH 2/3] wlroots: update to 0.8.1.

---
 srcpkgs/wlroots/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/wlroots/template b/srcpkgs/wlroots/template
index 7b88e324827..75ddb338a15 100644
--- a/srcpkgs/wlroots/template
+++ b/srcpkgs/wlroots/template
@@ -1,23 +1,23 @@
 # Template file for 'wlroots'
 pkgname=wlroots
-version=0.6.0
-revision=2
+version=0.8.1
+revision=1
 build_style=meson
 configure_args="-Dlibcap=enabled -Dlogind=enabled -Dlogind-provider=elogind
  -Dxcb-errors=enabled -Dxcb-icccm=enabled -Dxwayland=enabled
- -Dx11-backend=enabled -Dexamples=false -Drootston=false"
+ -Dx11-backend=enabled -Dexamples=false"
 hostmakedepends="pkg-config wayland-devel"
 makedepends="elogind-devel libcap-devel wayland-devel wayland-protocols
  MesaLib-devel libinput-devel libxkbcommon-devel libdrm-devel pixman-devel
  libxcb-devel xcb-util-cursor-devel xcb-util-devel xcb-util-image-devel
  xcb-util-keysyms-devel xcb-util-renderutil-devel xcb-util-wm-devel
  xcb-util-errors-devel xcb-util-xrm-devel freerdp-devel"
-short_desc="Module Wayland compositor library"
+short_desc="Modular Wayland compositor library"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://github.com/swaywm/wlroots"
 distfiles="https://github.com/swaywm/wlroots/archive/${version}.tar.gz"
-checksum=9cf3716f3683d800df8b150f256ff66dad65faf13a9d67c284f67a9444d28c70
+checksum=202b86e0e21699b6660bbda56afc2e3358db7252f83ff69c89f01926b4900d98
 
 post_install() {
 	vlicense LICENSE

From a90baf336836273bd8af8ca94d684c427101d706 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Mon, 7 Oct 2019 16:58:29 -0700
Subject: [PATCH 3/3] wayfire: update to 0.3.0.

---
 srcpkgs/wayfire/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/wayfire/template b/srcpkgs/wayfire/template
index 2ee4bd17ae9..9130ec46779 100644
--- a/srcpkgs/wayfire/template
+++ b/srcpkgs/wayfire/template
@@ -1,6 +1,6 @@
 # Template file for 'wayfire'
 pkgname=wayfire
-version=0.2
+version=0.3.0
 revision=1
 build_style=meson
 hostmakedepends="pkg-config wayland-devel"
@@ -9,8 +9,8 @@ short_desc="3D wayland compositor"
 maintainer="Young Jin Park <youngjinpark20@gmail.com>"
 license="MIT"
 homepage="https://wayfire.org"
-distfiles="https://github.com/WayfireWM/wayfire/archive/v${version}.tar.gz"
-checksum=94fe93bb2b86048fd1c7601f97b167767e19618bb6b6226e21c22fbd052540bf
+distfiles="https://github.com/WayfireWM/wayfire/archive/${version}.tar.gz"
+checksum=c686bf5abb7f0db829196785bba4136c85d7b52d701212e21636dad75e1da0aa
 
 case $XBPS_TARGET_MACHINE in
 	*-musl) makedepends+=" libexecinfo-devel"

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: [PR PATCH] [Updated] [Nomerge] sway: update to 1.2.
       [not found] <gh-mailinglist-notifications-41a7ca26-5023-4802-975b-f1789d68868e-void-packages-13999@inbox.vuxu.org>
                   ` (7 preceding siblings ...)
  2019-10-07 23:58 ` voidlinux-github
@ 2019-10-08  0:04 ` voidlinux-github
  2019-10-08  0:04 ` voidlinux-github
                   ` (19 subsequent siblings)
  28 siblings, 0 replies; 29+ messages in thread
From: voidlinux-github @ 2019-10-08  0:04 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 349 bytes --]

There is an updated pull request by travankor against master on the void-packages repository

https://github.com/travankor/void-packages sway
https://github.com/void-linux/void-packages/pull/13999

[Nomerge] sway: update to 1.2.
Wayfire needs to be updated.

A patch file from https://github.com/void-linux/void-packages/pull/13999.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-sway-13999.patch --]
[-- Type: text/x-diff, Size: 5185 bytes --]

From 01bfd17e6f2aaa73a9e7e3a008676ad1fed741f1 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 27 Aug 2019 03:04:57 -0700
Subject: [PATCH 1/4] sway: update to 1.2.

---
 srcpkgs/sway/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/sway/template b/srcpkgs/sway/template
index 574ff5f90cd..0a236516283 100644
--- a/srcpkgs/sway/template
+++ b/srcpkgs/sway/template
@@ -1,6 +1,6 @@
 # Template file for 'sway'
 pkgname=sway
-version=1.1.1
+version=1.2
 revision=1
 build_style=meson
 conf_files="/etc/sway/config"
@@ -13,7 +13,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://swaywm.org"
 distfiles="https://github.com/swaywm/${pkgname}/archive/${version}.tar.gz"
-checksum=740bf97556c54da83937a255113d715aaa05e05b44d61fbe85e01b53ff1f9922
+checksum=9f79382577ee132111c290b4d1a1a3e114ef485595c30cf5f181a11575bda846
 
 build_options="elogind"
 desc_option_elogind="Uses elogind instead of setuid for privilege escalation"

From 5c5c06f8332ac21b0db5bdd9476a64bc5bcb2c5e Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Mon, 7 Oct 2019 16:58:21 -0700
Subject: [PATCH 2/4] wlroots: update to 0.8.1.

---
 srcpkgs/wlroots/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/wlroots/template b/srcpkgs/wlroots/template
index 7b88e324827..75ddb338a15 100644
--- a/srcpkgs/wlroots/template
+++ b/srcpkgs/wlroots/template
@@ -1,23 +1,23 @@
 # Template file for 'wlroots'
 pkgname=wlroots
-version=0.6.0
-revision=2
+version=0.8.1
+revision=1
 build_style=meson
 configure_args="-Dlibcap=enabled -Dlogind=enabled -Dlogind-provider=elogind
  -Dxcb-errors=enabled -Dxcb-icccm=enabled -Dxwayland=enabled
- -Dx11-backend=enabled -Dexamples=false -Drootston=false"
+ -Dx11-backend=enabled -Dexamples=false"
 hostmakedepends="pkg-config wayland-devel"
 makedepends="elogind-devel libcap-devel wayland-devel wayland-protocols
  MesaLib-devel libinput-devel libxkbcommon-devel libdrm-devel pixman-devel
  libxcb-devel xcb-util-cursor-devel xcb-util-devel xcb-util-image-devel
  xcb-util-keysyms-devel xcb-util-renderutil-devel xcb-util-wm-devel
  xcb-util-errors-devel xcb-util-xrm-devel freerdp-devel"
-short_desc="Module Wayland compositor library"
+short_desc="Modular Wayland compositor library"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://github.com/swaywm/wlroots"
 distfiles="https://github.com/swaywm/wlroots/archive/${version}.tar.gz"
-checksum=9cf3716f3683d800df8b150f256ff66dad65faf13a9d67c284f67a9444d28c70
+checksum=202b86e0e21699b6660bbda56afc2e3358db7252f83ff69c89f01926b4900d98
 
 post_install() {
 	vlicense LICENSE

From a90baf336836273bd8af8ca94d684c427101d706 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Mon, 7 Oct 2019 16:58:29 -0700
Subject: [PATCH 3/4] wayfire: update to 0.3.0.

---
 srcpkgs/wayfire/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/wayfire/template b/srcpkgs/wayfire/template
index 2ee4bd17ae9..9130ec46779 100644
--- a/srcpkgs/wayfire/template
+++ b/srcpkgs/wayfire/template
@@ -1,6 +1,6 @@
 # Template file for 'wayfire'
 pkgname=wayfire
-version=0.2
+version=0.3.0
 revision=1
 build_style=meson
 hostmakedepends="pkg-config wayland-devel"
@@ -9,8 +9,8 @@ short_desc="3D wayland compositor"
 maintainer="Young Jin Park <youngjinpark20@gmail.com>"
 license="MIT"
 homepage="https://wayfire.org"
-distfiles="https://github.com/WayfireWM/wayfire/archive/v${version}.tar.gz"
-checksum=94fe93bb2b86048fd1c7601f97b167767e19618bb6b6226e21c22fbd052540bf
+distfiles="https://github.com/WayfireWM/wayfire/archive/${version}.tar.gz"
+checksum=c686bf5abb7f0db829196785bba4136c85d7b52d701212e21636dad75e1da0aa
 
 case $XBPS_TARGET_MACHINE in
 	*-musl) makedepends+=" libexecinfo-devel"

From 20487b52c9f9b1f7bdc9ad80e30ba8c4ca2709dd Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Mon, 7 Oct 2019 17:03:42 -0700
Subject: [PATCH 4/4] wf-config: update to 0.3.

---
 srcpkgs/wf-config/template | 10 ++++------
 1 file changed, 4 insertions(+), 6 deletions(-)

diff --git a/srcpkgs/wf-config/template b/srcpkgs/wf-config/template
index 98eee65d39e..0cd93421fbe 100644
--- a/srcpkgs/wf-config/template
+++ b/srcpkgs/wf-config/template
@@ -1,6 +1,6 @@
 # Template file for 'wf-config'
 pkgname=wf-config
-version=0.1
+version=0.3
 revision=1
 build_style=meson
 hostmakedepends="pkg-config"
@@ -9,11 +9,9 @@ short_desc="Wayfire library for managing configuration files"
 maintainer="Young Jin Park <youngjinpark20@gmail.com>"
 license="MIT"
 homepage="https://wayfire.org"
-distfiles="https://github.com/WayfireWM/wf-config/archive/v${version}.tar.gz
- https://raw.githubusercontent.com/WayfireWM/wf-config/master/LICENSE>LICENSE.txt"
-checksum="0dac4683013d5a0b143f0e211288c7f2f621740b9ac664359297ff530a7dcdc5
- 7053b1aa75aaccfe2a2bfacd400c0a8694858797ff9c7d584664e2941fb3016e"
+distfiles="https://github.com/WayfireWM/wf-config/archive/${version}.tar.gz"
+checksum=5d1a5038b11a177174b392f3b383d787f568265ce483a5be9178698f548f7c66
 
 post_install() {
-	vlicense ../LICENSE.txt
+	vlicense LICENSE
 }

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: [PR PATCH] [Updated] [Nomerge] sway: update to 1.2.
       [not found] <gh-mailinglist-notifications-41a7ca26-5023-4802-975b-f1789d68868e-void-packages-13999@inbox.vuxu.org>
                   ` (8 preceding siblings ...)
  2019-10-08  0:04 ` voidlinux-github
@ 2019-10-08  0:04 ` voidlinux-github
  2019-10-08  0:54 ` voidlinux-github
                   ` (18 subsequent siblings)
  28 siblings, 0 replies; 29+ messages in thread
From: voidlinux-github @ 2019-10-08  0:04 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 349 bytes --]

There is an updated pull request by travankor against master on the void-packages repository

https://github.com/travankor/void-packages sway
https://github.com/void-linux/void-packages/pull/13999

[Nomerge] sway: update to 1.2.
Wayfire needs to be updated.

A patch file from https://github.com/void-linux/void-packages/pull/13999.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-sway-13999.patch --]
[-- Type: text/x-diff, Size: 5185 bytes --]

From 01bfd17e6f2aaa73a9e7e3a008676ad1fed741f1 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 27 Aug 2019 03:04:57 -0700
Subject: [PATCH 1/4] sway: update to 1.2.

---
 srcpkgs/sway/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/sway/template b/srcpkgs/sway/template
index 574ff5f90cd..0a236516283 100644
--- a/srcpkgs/sway/template
+++ b/srcpkgs/sway/template
@@ -1,6 +1,6 @@
 # Template file for 'sway'
 pkgname=sway
-version=1.1.1
+version=1.2
 revision=1
 build_style=meson
 conf_files="/etc/sway/config"
@@ -13,7 +13,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://swaywm.org"
 distfiles="https://github.com/swaywm/${pkgname}/archive/${version}.tar.gz"
-checksum=740bf97556c54da83937a255113d715aaa05e05b44d61fbe85e01b53ff1f9922
+checksum=9f79382577ee132111c290b4d1a1a3e114ef485595c30cf5f181a11575bda846
 
 build_options="elogind"
 desc_option_elogind="Uses elogind instead of setuid for privilege escalation"

From 5c5c06f8332ac21b0db5bdd9476a64bc5bcb2c5e Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Mon, 7 Oct 2019 16:58:21 -0700
Subject: [PATCH 2/4] wlroots: update to 0.8.1.

---
 srcpkgs/wlroots/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/wlroots/template b/srcpkgs/wlroots/template
index 7b88e324827..75ddb338a15 100644
--- a/srcpkgs/wlroots/template
+++ b/srcpkgs/wlroots/template
@@ -1,23 +1,23 @@
 # Template file for 'wlroots'
 pkgname=wlroots
-version=0.6.0
-revision=2
+version=0.8.1
+revision=1
 build_style=meson
 configure_args="-Dlibcap=enabled -Dlogind=enabled -Dlogind-provider=elogind
  -Dxcb-errors=enabled -Dxcb-icccm=enabled -Dxwayland=enabled
- -Dx11-backend=enabled -Dexamples=false -Drootston=false"
+ -Dx11-backend=enabled -Dexamples=false"
 hostmakedepends="pkg-config wayland-devel"
 makedepends="elogind-devel libcap-devel wayland-devel wayland-protocols
  MesaLib-devel libinput-devel libxkbcommon-devel libdrm-devel pixman-devel
  libxcb-devel xcb-util-cursor-devel xcb-util-devel xcb-util-image-devel
  xcb-util-keysyms-devel xcb-util-renderutil-devel xcb-util-wm-devel
  xcb-util-errors-devel xcb-util-xrm-devel freerdp-devel"
-short_desc="Module Wayland compositor library"
+short_desc="Modular Wayland compositor library"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://github.com/swaywm/wlroots"
 distfiles="https://github.com/swaywm/wlroots/archive/${version}.tar.gz"
-checksum=9cf3716f3683d800df8b150f256ff66dad65faf13a9d67c284f67a9444d28c70
+checksum=202b86e0e21699b6660bbda56afc2e3358db7252f83ff69c89f01926b4900d98
 
 post_install() {
 	vlicense LICENSE

From a90baf336836273bd8af8ca94d684c427101d706 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Mon, 7 Oct 2019 16:58:29 -0700
Subject: [PATCH 3/4] wayfire: update to 0.3.0.

---
 srcpkgs/wayfire/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/wayfire/template b/srcpkgs/wayfire/template
index 2ee4bd17ae9..9130ec46779 100644
--- a/srcpkgs/wayfire/template
+++ b/srcpkgs/wayfire/template
@@ -1,6 +1,6 @@
 # Template file for 'wayfire'
 pkgname=wayfire
-version=0.2
+version=0.3.0
 revision=1
 build_style=meson
 hostmakedepends="pkg-config wayland-devel"
@@ -9,8 +9,8 @@ short_desc="3D wayland compositor"
 maintainer="Young Jin Park <youngjinpark20@gmail.com>"
 license="MIT"
 homepage="https://wayfire.org"
-distfiles="https://github.com/WayfireWM/wayfire/archive/v${version}.tar.gz"
-checksum=94fe93bb2b86048fd1c7601f97b167767e19618bb6b6226e21c22fbd052540bf
+distfiles="https://github.com/WayfireWM/wayfire/archive/${version}.tar.gz"
+checksum=c686bf5abb7f0db829196785bba4136c85d7b52d701212e21636dad75e1da0aa
 
 case $XBPS_TARGET_MACHINE in
 	*-musl) makedepends+=" libexecinfo-devel"

From 20487b52c9f9b1f7bdc9ad80e30ba8c4ca2709dd Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Mon, 7 Oct 2019 17:03:42 -0700
Subject: [PATCH 4/4] wf-config: update to 0.3.

---
 srcpkgs/wf-config/template | 10 ++++------
 1 file changed, 4 insertions(+), 6 deletions(-)

diff --git a/srcpkgs/wf-config/template b/srcpkgs/wf-config/template
index 98eee65d39e..0cd93421fbe 100644
--- a/srcpkgs/wf-config/template
+++ b/srcpkgs/wf-config/template
@@ -1,6 +1,6 @@
 # Template file for 'wf-config'
 pkgname=wf-config
-version=0.1
+version=0.3
 revision=1
 build_style=meson
 hostmakedepends="pkg-config"
@@ -9,11 +9,9 @@ short_desc="Wayfire library for managing configuration files"
 maintainer="Young Jin Park <youngjinpark20@gmail.com>"
 license="MIT"
 homepage="https://wayfire.org"
-distfiles="https://github.com/WayfireWM/wf-config/archive/v${version}.tar.gz
- https://raw.githubusercontent.com/WayfireWM/wf-config/master/LICENSE>LICENSE.txt"
-checksum="0dac4683013d5a0b143f0e211288c7f2f621740b9ac664359297ff530a7dcdc5
- 7053b1aa75aaccfe2a2bfacd400c0a8694858797ff9c7d584664e2941fb3016e"
+distfiles="https://github.com/WayfireWM/wf-config/archive/${version}.tar.gz"
+checksum=5d1a5038b11a177174b392f3b383d787f568265ce483a5be9178698f548f7c66
 
 post_install() {
-	vlicense ../LICENSE.txt
+	vlicense LICENSE
 }

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: [Nomerge] sway: update to 1.2.
       [not found] <gh-mailinglist-notifications-41a7ca26-5023-4802-975b-f1789d68868e-void-packages-13999@inbox.vuxu.org>
                   ` (9 preceding siblings ...)
  2019-10-08  0:04 ` voidlinux-github
@ 2019-10-08  0:54 ` voidlinux-github
  2019-10-08 11:49 ` [PR PATCH] [Updated] " voidlinux-github
                   ` (17 subsequent siblings)
  28 siblings, 0 replies; 29+ messages in thread
From: voidlinux-github @ 2019-10-08  0:54 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 324 bytes --]

New comment by Wychmire on void-packages repository

https://github.com/void-linux/void-packages/pull/13999#issuecomment-539266267

Comment:
@travankor I updated all of wayfire's templates [here](https://github.com/Wychmire/void-packages/tree/wayfire), would probably be easier to copy from there instead of doing it again.

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: [PR PATCH] [Updated] [Nomerge] sway: update to 1.2.
       [not found] <gh-mailinglist-notifications-41a7ca26-5023-4802-975b-f1789d68868e-void-packages-13999@inbox.vuxu.org>
                   ` (11 preceding siblings ...)
  2019-10-08 11:49 ` [PR PATCH] [Updated] " voidlinux-github
@ 2019-10-08 11:49 ` voidlinux-github
  2019-10-08 11:55 ` voidlinux-github
                   ` (15 subsequent siblings)
  28 siblings, 0 replies; 29+ messages in thread
From: voidlinux-github @ 2019-10-08 11:49 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 349 bytes --]

There is an updated pull request by travankor against master on the void-packages repository

https://github.com/travankor/void-packages sway
https://github.com/void-linux/void-packages/pull/13999

[Nomerge] sway: update to 1.2.
Wayfire needs to be updated.

A patch file from https://github.com/void-linux/void-packages/pull/13999.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-sway-13999.patch --]
[-- Type: text/x-diff, Size: 11686 bytes --]

From ad65e91b5bf1bb19850dc211a55cd71a0f3d1889 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 27 Aug 2019 03:04:57 -0700
Subject: [PATCH 1/6] sway: update to 1.2.

---
 srcpkgs/sway/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/sway/template b/srcpkgs/sway/template
index 574ff5f90cd..0a236516283 100644
--- a/srcpkgs/sway/template
+++ b/srcpkgs/sway/template
@@ -1,6 +1,6 @@
 # Template file for 'sway'
 pkgname=sway
-version=1.1.1
+version=1.2
 revision=1
 build_style=meson
 conf_files="/etc/sway/config"
@@ -13,7 +13,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://swaywm.org"
 distfiles="https://github.com/swaywm/${pkgname}/archive/${version}.tar.gz"
-checksum=740bf97556c54da83937a255113d715aaa05e05b44d61fbe85e01b53ff1f9922
+checksum=9f79382577ee132111c290b4d1a1a3e114ef485595c30cf5f181a11575bda846
 
 build_options="elogind"
 desc_option_elogind="Uses elogind instead of setuid for privilege escalation"

From f49bf1fcc77b8a4bc11a76100d1863d87eb0b003 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Mon, 7 Oct 2019 16:58:21 -0700
Subject: [PATCH 2/6] wlroots: update to 0.8.1.

---
 srcpkgs/wlroots/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/wlroots/template b/srcpkgs/wlroots/template
index 7b88e324827..75ddb338a15 100644
--- a/srcpkgs/wlroots/template
+++ b/srcpkgs/wlroots/template
@@ -1,23 +1,23 @@
 # Template file for 'wlroots'
 pkgname=wlroots
-version=0.6.0
-revision=2
+version=0.8.1
+revision=1
 build_style=meson
 configure_args="-Dlibcap=enabled -Dlogind=enabled -Dlogind-provider=elogind
  -Dxcb-errors=enabled -Dxcb-icccm=enabled -Dxwayland=enabled
- -Dx11-backend=enabled -Dexamples=false -Drootston=false"
+ -Dx11-backend=enabled -Dexamples=false"
 hostmakedepends="pkg-config wayland-devel"
 makedepends="elogind-devel libcap-devel wayland-devel wayland-protocols
  MesaLib-devel libinput-devel libxkbcommon-devel libdrm-devel pixman-devel
  libxcb-devel xcb-util-cursor-devel xcb-util-devel xcb-util-image-devel
  xcb-util-keysyms-devel xcb-util-renderutil-devel xcb-util-wm-devel
  xcb-util-errors-devel xcb-util-xrm-devel freerdp-devel"
-short_desc="Module Wayland compositor library"
+short_desc="Modular Wayland compositor library"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://github.com/swaywm/wlroots"
 distfiles="https://github.com/swaywm/wlroots/archive/${version}.tar.gz"
-checksum=9cf3716f3683d800df8b150f256ff66dad65faf13a9d67c284f67a9444d28c70
+checksum=202b86e0e21699b6660bbda56afc2e3358db7252f83ff69c89f01926b4900d98
 
 post_install() {
 	vlicense LICENSE

From 86fbace24f00293d7d098849e9a332e92a6c6457 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 8 Oct 2019 02:36:29 -0700
Subject: [PATCH 3/6] wf-config: update to 0.3.

---
 common/shlibs                            |  2 +-
 srcpkgs/wf-config-devel                  |  1 +
 srcpkgs/wf-config/patches/fix-musl.patch | 13 -------------
 srcpkgs/wf-config/template               | 20 ++++++++++++++------
 4 files changed, 16 insertions(+), 20 deletions(-)
 create mode 120000 srcpkgs/wf-config-devel
 delete mode 100644 srcpkgs/wf-config/patches/fix-musl.patch

diff --git a/common/shlibs b/common/shlibs
index 688275b7d9e..8be530d3a22 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -3411,7 +3411,7 @@ libsnore-qt5.so.0.7 snorenotify-0.7.0_1
 libsnoresettings-qt5.so.0.7 snorenotify-0.7.0_1
 libTECkit.so.0 libteckit-2.5.8_1
 libTECkit_Compiler.so.0 libteckit-2.5.8_1
-libwf-config.so wf-config-0.1_1
+libwf-config.so.0 wf-config-0.3_1
 libQt5Pas.so.1 qt5pas-2.6~beta_1
 libClp.so.1 libClp-1.16.11_1
 libCoinUtils.so.3 libClp-1.16.11_1
diff --git a/srcpkgs/wf-config-devel b/srcpkgs/wf-config-devel
new file mode 120000
index 00000000000..fb3df2e900c
--- /dev/null
+++ b/srcpkgs/wf-config-devel
@@ -0,0 +1 @@
+wf-config/
\ No newline at end of file
diff --git a/srcpkgs/wf-config/patches/fix-musl.patch b/srcpkgs/wf-config/patches/fix-musl.patch
deleted file mode 100644
index b87797ba555..00000000000
--- a/srcpkgs/wf-config/patches/fix-musl.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/config.cpp b/src/config.cpp
-index f586ab5..811ce29 100644
---- src/config.cpp
-+++ src/config.cpp
-@@ -4,6 +4,7 @@
- #include <sstream>
- #include <fstream>
- #include <algorithm>
-+#include <fcntl.h>
- 
- std::ofstream out;
- 
-
diff --git a/srcpkgs/wf-config/template b/srcpkgs/wf-config/template
index 98eee65d39e..adee709a060 100644
--- a/srcpkgs/wf-config/template
+++ b/srcpkgs/wf-config/template
@@ -1,6 +1,6 @@
 # Template file for 'wf-config'
 pkgname=wf-config
-version=0.1
+version=0.3
 revision=1
 build_style=meson
 hostmakedepends="pkg-config"
@@ -9,11 +9,19 @@ short_desc="Wayfire library for managing configuration files"
 maintainer="Young Jin Park <youngjinpark20@gmail.com>"
 license="MIT"
 homepage="https://wayfire.org"
-distfiles="https://github.com/WayfireWM/wf-config/archive/v${version}.tar.gz
- https://raw.githubusercontent.com/WayfireWM/wf-config/master/LICENSE>LICENSE.txt"
-checksum="0dac4683013d5a0b143f0e211288c7f2f621740b9ac664359297ff530a7dcdc5
- 7053b1aa75aaccfe2a2bfacd400c0a8694858797ff9c7d584664e2941fb3016e"
+distfiles="https://github.com/WayfireWM/wf-config/archive/${version}.tar.gz"
+checksum=5d1a5038b11a177174b392f3b383d787f568265ce483a5be9178698f548f7c66
 
 post_install() {
-	vlicense ../LICENSE.txt
+	vlicense LICENSE
+}
+
+wf-config-devel_package() {
+	depends="libevdev-devel wlroots-devel wf-config>=${version}_${revision}"
+	short_desc+=" - development files"
+	pkg_install() {
+		vmove usr/include
+		vmove usr/lib/pkgconfig
+		vmove "usr/lib/*.so"
+	}
 }

From 79ef1c4b5e9e6b0dfabf01a9bfd1d3c6e6a8ed24 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 8 Oct 2019 03:48:04 -0700
Subject: [PATCH 4/6] wfconfig: rename wf-config to wfconfig due to xbps-src
 bug.

---
 common/shlibs                            |  2 +-
 srcpkgs/wf-config-devel                  |  1 -
 srcpkgs/wfconfig-devel                   |  1 +
 srcpkgs/{wf-config => wfconfig}/template | 10 ++++++----
 4 files changed, 8 insertions(+), 6 deletions(-)
 delete mode 120000 srcpkgs/wf-config-devel
 create mode 120000 srcpkgs/wfconfig-devel
 rename srcpkgs/{wf-config => wfconfig}/template (72%)

diff --git a/common/shlibs b/common/shlibs
index 8be530d3a22..3ad5af56f29 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -3411,7 +3411,7 @@ libsnore-qt5.so.0.7 snorenotify-0.7.0_1
 libsnoresettings-qt5.so.0.7 snorenotify-0.7.0_1
 libTECkit.so.0 libteckit-2.5.8_1
 libTECkit_Compiler.so.0 libteckit-2.5.8_1
-libwf-config.so.0 wf-config-0.3_1
+libwf-config.so.0 wfconfig-0.3_1
 libQt5Pas.so.1 qt5pas-2.6~beta_1
 libClp.so.1 libClp-1.16.11_1
 libCoinUtils.so.3 libClp-1.16.11_1
diff --git a/srcpkgs/wf-config-devel b/srcpkgs/wf-config-devel
deleted file mode 120000
index fb3df2e900c..00000000000
--- a/srcpkgs/wf-config-devel
+++ /dev/null
@@ -1 +0,0 @@
-wf-config/
\ No newline at end of file
diff --git a/srcpkgs/wfconfig-devel b/srcpkgs/wfconfig-devel
new file mode 120000
index 00000000000..9806e3a908e
--- /dev/null
+++ b/srcpkgs/wfconfig-devel
@@ -0,0 +1 @@
+wfconfig/
\ No newline at end of file
diff --git a/srcpkgs/wf-config/template b/srcpkgs/wfconfig/template
similarity index 72%
rename from srcpkgs/wf-config/template
rename to srcpkgs/wfconfig/template
index adee709a060..a68939164b9 100644
--- a/srcpkgs/wf-config/template
+++ b/srcpkgs/wfconfig/template
@@ -1,7 +1,8 @@
-# Template file for 'wf-config'
-pkgname=wf-config
+# Template file for 'wfconfig'
+pkgname=wfconfig
 version=0.3
 revision=1
+wrksrc=wf-config-${version}
 build_style=meson
 hostmakedepends="pkg-config"
 makedepends="libevdev-devel wlroots-devel"
@@ -16,8 +17,9 @@ post_install() {
 	vlicense LICENSE
 }
 
-wf-config-devel_package() {
-	depends="libevdev-devel wlroots-devel wf-config>=${version}_${revision}"
+# xbps-src bug: can't have three dashes in keyword
+wfconfig-devel_package() {
+	depends="libevdev-devel wlroots-devel wfconfig>=${version}_${revision}"
 	short_desc+=" - development files"
 	pkg_install() {
 		vmove usr/include

From eecae7a36dd389838e69ec2c676c0c3539f227b5 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 8 Oct 2019 03:49:41 -0700
Subject: [PATCH 5/6] wayfire: update to 0.3.0.

---
 srcpkgs/wayfire/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/wayfire/template b/srcpkgs/wayfire/template
index 2ee4bd17ae9..cdaec561150 100644
--- a/srcpkgs/wayfire/template
+++ b/srcpkgs/wayfire/template
@@ -1,16 +1,16 @@
 # Template file for 'wayfire'
 pkgname=wayfire
-version=0.2
+version=0.3.0
 revision=1
 build_style=meson
 hostmakedepends="pkg-config wayland-devel"
-makedepends="wlroots-devel glm cairo-devel wf-config"
+makedepends="wlroots-devel glm cairo-devel wfconfig-devel"
 short_desc="3D wayland compositor"
 maintainer="Young Jin Park <youngjinpark20@gmail.com>"
 license="MIT"
 homepage="https://wayfire.org"
-distfiles="https://github.com/WayfireWM/wayfire/archive/v${version}.tar.gz"
-checksum=94fe93bb2b86048fd1c7601f97b167767e19618bb6b6226e21c22fbd052540bf
+distfiles="https://github.com/WayfireWM/wayfire/archive/${version}.tar.gz"
+checksum=c686bf5abb7f0db829196785bba4136c85d7b52d701212e21636dad75e1da0aa
 
 case $XBPS_TARGET_MACHINE in
 	*-musl) makedepends+=" libexecinfo-devel"

From 7360847773a4a021b4a8ce441aa582232508d250 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 8 Oct 2019 04:40:29 -0700
Subject: [PATCH 6/6] wf-shell: update to 0.3.

---
 srcpkgs/wf-shell/template | 27 ++++++++++++++++++++++-----
 1 file changed, 22 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/wf-shell/template b/srcpkgs/wf-shell/template
index ccfd8c574a0..e8abf92d28c 100644
--- a/srcpkgs/wf-shell/template
+++ b/srcpkgs/wf-shell/template
@@ -1,16 +1,33 @@
 # Template file for 'wf-shell'
 pkgname=wf-shell
-version=0.1
+version=0.3
 revision=1
+_gtklayershell_hash="d1f9d94be32f8cc61c0a53af7558146570f0fa9f"
+_gvc_hash="468022b708fc1a56154f3b0cc5af3b938fb3e9fb"
+create_wrksrc=yes
+build_wrksrc=${pkgname}-${version}
 build_style=meson
-hostmakedepends="pkg-config wayland-devel"
-makedepends="gtkmm-devel libevdev-devel wlroots-devel wf-config"
+hostmakedepends="pkg-config unzip wayland-devel"
+makedepends="alsa-lib-devel pulseaudio-devel gobject-introspection gtkmm-devel
+ gtk+3-devel libevdev-devel wlroots-devel wfconfig-devel"
 short_desc="Wayfire shell with GTK-based panel and background client"
 maintainer="Young Jin Park <youngjinpark20@gmail.com>"
 license="MIT"
 homepage="https://wayfire.org"
-distfiles="https://github.com/WayfireWM/wf-shell/archive/${version}.tar.gz"
-checksum=625637fddf58a6a1825980e68d156ddb377cf4aae9bf5d844fb15aefee4c6f4f
+distfiles="https://github.com/WayfireWM/wf-shell/archive/${version}.tar.gz
+ https://github.com/wmww/gtk-layer-shell/archive/${_gtklayershell_hash}.zip
+ https://github.com/GNOME/libgnome-volume-control/archive/${_gvc_hash}.zip"
+checksum="326c732415a10215997c0915741fd561a306412327fae123eab67f1af9ee41de
+ a5f43f0f660a4147a2a50c51ee2214b29cf057c3bf0b439451a86b8cc21b9013
+ bf10e33e030f8a5a1ce903cd8201f0882532931d26d530d3ebe2aea174771fd0"
+
+post_extract() {
+	_gtklayershell_dir="${pkgname}-${version}/subprojects/gtk-layer-shell"
+	_gvc_dir="${pkgname}-${version}/subprojects/gvc"
+	rmdir ${_gtklayershell_dir} ${_gvc_dir}
+	mv gtk-layer-shell-d1f9d94be32f8cc61c0a53af7558146570f0fa9f ${_gtklayershell_dir}
+	mv libgnome-volume-control-468022b708fc1a56154f3b0cc5af3b938fb3e9fb ${_gvc_dir}
+}
 
 post_install() {
 	vlicense LICENSE

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: [PR PATCH] [Updated] [Nomerge] sway: update to 1.2.
       [not found] <gh-mailinglist-notifications-41a7ca26-5023-4802-975b-f1789d68868e-void-packages-13999@inbox.vuxu.org>
                   ` (10 preceding siblings ...)
  2019-10-08  0:54 ` voidlinux-github
@ 2019-10-08 11:49 ` voidlinux-github
  2019-10-08 11:49 ` voidlinux-github
                   ` (16 subsequent siblings)
  28 siblings, 0 replies; 29+ messages in thread
From: voidlinux-github @ 2019-10-08 11:49 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 349 bytes --]

There is an updated pull request by travankor against master on the void-packages repository

https://github.com/travankor/void-packages sway
https://github.com/void-linux/void-packages/pull/13999

[Nomerge] sway: update to 1.2.
Wayfire needs to be updated.

A patch file from https://github.com/void-linux/void-packages/pull/13999.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-sway-13999.patch --]
[-- Type: text/x-diff, Size: 11686 bytes --]

From ad65e91b5bf1bb19850dc211a55cd71a0f3d1889 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 27 Aug 2019 03:04:57 -0700
Subject: [PATCH 1/6] sway: update to 1.2.

---
 srcpkgs/sway/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/sway/template b/srcpkgs/sway/template
index 574ff5f90cd..0a236516283 100644
--- a/srcpkgs/sway/template
+++ b/srcpkgs/sway/template
@@ -1,6 +1,6 @@
 # Template file for 'sway'
 pkgname=sway
-version=1.1.1
+version=1.2
 revision=1
 build_style=meson
 conf_files="/etc/sway/config"
@@ -13,7 +13,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://swaywm.org"
 distfiles="https://github.com/swaywm/${pkgname}/archive/${version}.tar.gz"
-checksum=740bf97556c54da83937a255113d715aaa05e05b44d61fbe85e01b53ff1f9922
+checksum=9f79382577ee132111c290b4d1a1a3e114ef485595c30cf5f181a11575bda846
 
 build_options="elogind"
 desc_option_elogind="Uses elogind instead of setuid for privilege escalation"

From f49bf1fcc77b8a4bc11a76100d1863d87eb0b003 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Mon, 7 Oct 2019 16:58:21 -0700
Subject: [PATCH 2/6] wlroots: update to 0.8.1.

---
 srcpkgs/wlroots/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/wlroots/template b/srcpkgs/wlroots/template
index 7b88e324827..75ddb338a15 100644
--- a/srcpkgs/wlroots/template
+++ b/srcpkgs/wlroots/template
@@ -1,23 +1,23 @@
 # Template file for 'wlroots'
 pkgname=wlroots
-version=0.6.0
-revision=2
+version=0.8.1
+revision=1
 build_style=meson
 configure_args="-Dlibcap=enabled -Dlogind=enabled -Dlogind-provider=elogind
  -Dxcb-errors=enabled -Dxcb-icccm=enabled -Dxwayland=enabled
- -Dx11-backend=enabled -Dexamples=false -Drootston=false"
+ -Dx11-backend=enabled -Dexamples=false"
 hostmakedepends="pkg-config wayland-devel"
 makedepends="elogind-devel libcap-devel wayland-devel wayland-protocols
  MesaLib-devel libinput-devel libxkbcommon-devel libdrm-devel pixman-devel
  libxcb-devel xcb-util-cursor-devel xcb-util-devel xcb-util-image-devel
  xcb-util-keysyms-devel xcb-util-renderutil-devel xcb-util-wm-devel
  xcb-util-errors-devel xcb-util-xrm-devel freerdp-devel"
-short_desc="Module Wayland compositor library"
+short_desc="Modular Wayland compositor library"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://github.com/swaywm/wlroots"
 distfiles="https://github.com/swaywm/wlroots/archive/${version}.tar.gz"
-checksum=9cf3716f3683d800df8b150f256ff66dad65faf13a9d67c284f67a9444d28c70
+checksum=202b86e0e21699b6660bbda56afc2e3358db7252f83ff69c89f01926b4900d98
 
 post_install() {
 	vlicense LICENSE

From 86fbace24f00293d7d098849e9a332e92a6c6457 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 8 Oct 2019 02:36:29 -0700
Subject: [PATCH 3/6] wf-config: update to 0.3.

---
 common/shlibs                            |  2 +-
 srcpkgs/wf-config-devel                  |  1 +
 srcpkgs/wf-config/patches/fix-musl.patch | 13 -------------
 srcpkgs/wf-config/template               | 20 ++++++++++++++------
 4 files changed, 16 insertions(+), 20 deletions(-)
 create mode 120000 srcpkgs/wf-config-devel
 delete mode 100644 srcpkgs/wf-config/patches/fix-musl.patch

diff --git a/common/shlibs b/common/shlibs
index 688275b7d9e..8be530d3a22 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -3411,7 +3411,7 @@ libsnore-qt5.so.0.7 snorenotify-0.7.0_1
 libsnoresettings-qt5.so.0.7 snorenotify-0.7.0_1
 libTECkit.so.0 libteckit-2.5.8_1
 libTECkit_Compiler.so.0 libteckit-2.5.8_1
-libwf-config.so wf-config-0.1_1
+libwf-config.so.0 wf-config-0.3_1
 libQt5Pas.so.1 qt5pas-2.6~beta_1
 libClp.so.1 libClp-1.16.11_1
 libCoinUtils.so.3 libClp-1.16.11_1
diff --git a/srcpkgs/wf-config-devel b/srcpkgs/wf-config-devel
new file mode 120000
index 00000000000..fb3df2e900c
--- /dev/null
+++ b/srcpkgs/wf-config-devel
@@ -0,0 +1 @@
+wf-config/
\ No newline at end of file
diff --git a/srcpkgs/wf-config/patches/fix-musl.patch b/srcpkgs/wf-config/patches/fix-musl.patch
deleted file mode 100644
index b87797ba555..00000000000
--- a/srcpkgs/wf-config/patches/fix-musl.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/config.cpp b/src/config.cpp
-index f586ab5..811ce29 100644
---- src/config.cpp
-+++ src/config.cpp
-@@ -4,6 +4,7 @@
- #include <sstream>
- #include <fstream>
- #include <algorithm>
-+#include <fcntl.h>
- 
- std::ofstream out;
- 
-
diff --git a/srcpkgs/wf-config/template b/srcpkgs/wf-config/template
index 98eee65d39e..adee709a060 100644
--- a/srcpkgs/wf-config/template
+++ b/srcpkgs/wf-config/template
@@ -1,6 +1,6 @@
 # Template file for 'wf-config'
 pkgname=wf-config
-version=0.1
+version=0.3
 revision=1
 build_style=meson
 hostmakedepends="pkg-config"
@@ -9,11 +9,19 @@ short_desc="Wayfire library for managing configuration files"
 maintainer="Young Jin Park <youngjinpark20@gmail.com>"
 license="MIT"
 homepage="https://wayfire.org"
-distfiles="https://github.com/WayfireWM/wf-config/archive/v${version}.tar.gz
- https://raw.githubusercontent.com/WayfireWM/wf-config/master/LICENSE>LICENSE.txt"
-checksum="0dac4683013d5a0b143f0e211288c7f2f621740b9ac664359297ff530a7dcdc5
- 7053b1aa75aaccfe2a2bfacd400c0a8694858797ff9c7d584664e2941fb3016e"
+distfiles="https://github.com/WayfireWM/wf-config/archive/${version}.tar.gz"
+checksum=5d1a5038b11a177174b392f3b383d787f568265ce483a5be9178698f548f7c66
 
 post_install() {
-	vlicense ../LICENSE.txt
+	vlicense LICENSE
+}
+
+wf-config-devel_package() {
+	depends="libevdev-devel wlroots-devel wf-config>=${version}_${revision}"
+	short_desc+=" - development files"
+	pkg_install() {
+		vmove usr/include
+		vmove usr/lib/pkgconfig
+		vmove "usr/lib/*.so"
+	}
 }

From 79ef1c4b5e9e6b0dfabf01a9bfd1d3c6e6a8ed24 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 8 Oct 2019 03:48:04 -0700
Subject: [PATCH 4/6] wfconfig: rename wf-config to wfconfig due to xbps-src
 bug.

---
 common/shlibs                            |  2 +-
 srcpkgs/wf-config-devel                  |  1 -
 srcpkgs/wfconfig-devel                   |  1 +
 srcpkgs/{wf-config => wfconfig}/template | 10 ++++++----
 4 files changed, 8 insertions(+), 6 deletions(-)
 delete mode 120000 srcpkgs/wf-config-devel
 create mode 120000 srcpkgs/wfconfig-devel
 rename srcpkgs/{wf-config => wfconfig}/template (72%)

diff --git a/common/shlibs b/common/shlibs
index 8be530d3a22..3ad5af56f29 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -3411,7 +3411,7 @@ libsnore-qt5.so.0.7 snorenotify-0.7.0_1
 libsnoresettings-qt5.so.0.7 snorenotify-0.7.0_1
 libTECkit.so.0 libteckit-2.5.8_1
 libTECkit_Compiler.so.0 libteckit-2.5.8_1
-libwf-config.so.0 wf-config-0.3_1
+libwf-config.so.0 wfconfig-0.3_1
 libQt5Pas.so.1 qt5pas-2.6~beta_1
 libClp.so.1 libClp-1.16.11_1
 libCoinUtils.so.3 libClp-1.16.11_1
diff --git a/srcpkgs/wf-config-devel b/srcpkgs/wf-config-devel
deleted file mode 120000
index fb3df2e900c..00000000000
--- a/srcpkgs/wf-config-devel
+++ /dev/null
@@ -1 +0,0 @@
-wf-config/
\ No newline at end of file
diff --git a/srcpkgs/wfconfig-devel b/srcpkgs/wfconfig-devel
new file mode 120000
index 00000000000..9806e3a908e
--- /dev/null
+++ b/srcpkgs/wfconfig-devel
@@ -0,0 +1 @@
+wfconfig/
\ No newline at end of file
diff --git a/srcpkgs/wf-config/template b/srcpkgs/wfconfig/template
similarity index 72%
rename from srcpkgs/wf-config/template
rename to srcpkgs/wfconfig/template
index adee709a060..a68939164b9 100644
--- a/srcpkgs/wf-config/template
+++ b/srcpkgs/wfconfig/template
@@ -1,7 +1,8 @@
-# Template file for 'wf-config'
-pkgname=wf-config
+# Template file for 'wfconfig'
+pkgname=wfconfig
 version=0.3
 revision=1
+wrksrc=wf-config-${version}
 build_style=meson
 hostmakedepends="pkg-config"
 makedepends="libevdev-devel wlroots-devel"
@@ -16,8 +17,9 @@ post_install() {
 	vlicense LICENSE
 }
 
-wf-config-devel_package() {
-	depends="libevdev-devel wlroots-devel wf-config>=${version}_${revision}"
+# xbps-src bug: can't have three dashes in keyword
+wfconfig-devel_package() {
+	depends="libevdev-devel wlroots-devel wfconfig>=${version}_${revision}"
 	short_desc+=" - development files"
 	pkg_install() {
 		vmove usr/include

From eecae7a36dd389838e69ec2c676c0c3539f227b5 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 8 Oct 2019 03:49:41 -0700
Subject: [PATCH 5/6] wayfire: update to 0.3.0.

---
 srcpkgs/wayfire/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/wayfire/template b/srcpkgs/wayfire/template
index 2ee4bd17ae9..cdaec561150 100644
--- a/srcpkgs/wayfire/template
+++ b/srcpkgs/wayfire/template
@@ -1,16 +1,16 @@
 # Template file for 'wayfire'
 pkgname=wayfire
-version=0.2
+version=0.3.0
 revision=1
 build_style=meson
 hostmakedepends="pkg-config wayland-devel"
-makedepends="wlroots-devel glm cairo-devel wf-config"
+makedepends="wlroots-devel glm cairo-devel wfconfig-devel"
 short_desc="3D wayland compositor"
 maintainer="Young Jin Park <youngjinpark20@gmail.com>"
 license="MIT"
 homepage="https://wayfire.org"
-distfiles="https://github.com/WayfireWM/wayfire/archive/v${version}.tar.gz"
-checksum=94fe93bb2b86048fd1c7601f97b167767e19618bb6b6226e21c22fbd052540bf
+distfiles="https://github.com/WayfireWM/wayfire/archive/${version}.tar.gz"
+checksum=c686bf5abb7f0db829196785bba4136c85d7b52d701212e21636dad75e1da0aa
 
 case $XBPS_TARGET_MACHINE in
 	*-musl) makedepends+=" libexecinfo-devel"

From 7360847773a4a021b4a8ce441aa582232508d250 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 8 Oct 2019 04:40:29 -0700
Subject: [PATCH 6/6] wf-shell: update to 0.3.

---
 srcpkgs/wf-shell/template | 27 ++++++++++++++++++++++-----
 1 file changed, 22 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/wf-shell/template b/srcpkgs/wf-shell/template
index ccfd8c574a0..e8abf92d28c 100644
--- a/srcpkgs/wf-shell/template
+++ b/srcpkgs/wf-shell/template
@@ -1,16 +1,33 @@
 # Template file for 'wf-shell'
 pkgname=wf-shell
-version=0.1
+version=0.3
 revision=1
+_gtklayershell_hash="d1f9d94be32f8cc61c0a53af7558146570f0fa9f"
+_gvc_hash="468022b708fc1a56154f3b0cc5af3b938fb3e9fb"
+create_wrksrc=yes
+build_wrksrc=${pkgname}-${version}
 build_style=meson
-hostmakedepends="pkg-config wayland-devel"
-makedepends="gtkmm-devel libevdev-devel wlroots-devel wf-config"
+hostmakedepends="pkg-config unzip wayland-devel"
+makedepends="alsa-lib-devel pulseaudio-devel gobject-introspection gtkmm-devel
+ gtk+3-devel libevdev-devel wlroots-devel wfconfig-devel"
 short_desc="Wayfire shell with GTK-based panel and background client"
 maintainer="Young Jin Park <youngjinpark20@gmail.com>"
 license="MIT"
 homepage="https://wayfire.org"
-distfiles="https://github.com/WayfireWM/wf-shell/archive/${version}.tar.gz"
-checksum=625637fddf58a6a1825980e68d156ddb377cf4aae9bf5d844fb15aefee4c6f4f
+distfiles="https://github.com/WayfireWM/wf-shell/archive/${version}.tar.gz
+ https://github.com/wmww/gtk-layer-shell/archive/${_gtklayershell_hash}.zip
+ https://github.com/GNOME/libgnome-volume-control/archive/${_gvc_hash}.zip"
+checksum="326c732415a10215997c0915741fd561a306412327fae123eab67f1af9ee41de
+ a5f43f0f660a4147a2a50c51ee2214b29cf057c3bf0b439451a86b8cc21b9013
+ bf10e33e030f8a5a1ce903cd8201f0882532931d26d530d3ebe2aea174771fd0"
+
+post_extract() {
+	_gtklayershell_dir="${pkgname}-${version}/subprojects/gtk-layer-shell"
+	_gvc_dir="${pkgname}-${version}/subprojects/gvc"
+	rmdir ${_gtklayershell_dir} ${_gvc_dir}
+	mv gtk-layer-shell-d1f9d94be32f8cc61c0a53af7558146570f0fa9f ${_gtklayershell_dir}
+	mv libgnome-volume-control-468022b708fc1a56154f3b0cc5af3b938fb3e9fb ${_gvc_dir}
+}
 
 post_install() {
 	vlicense LICENSE

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: [Nomerge] sway: update to 1.2.
       [not found] <gh-mailinglist-notifications-41a7ca26-5023-4802-975b-f1789d68868e-void-packages-13999@inbox.vuxu.org>
                   ` (12 preceding siblings ...)
  2019-10-08 11:49 ` voidlinux-github
@ 2019-10-08 11:55 ` voidlinux-github
  2019-10-08 12:49 ` [PR PATCH] [Updated] " voidlinux-github
                   ` (14 subsequent siblings)
  28 siblings, 0 replies; 29+ messages in thread
From: voidlinux-github @ 2019-10-08 11:55 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 795 bytes --]

New comment by travankor on void-packages repository

https://github.com/void-linux/void-packages/pull/13999#issuecomment-539478347

Comment:
So when I build wayfire, I get this error.
```
=> ERROR: wayfire-0.3.0_1: failed to install 'wlroots-devel-0.8.1_1' dependency! (error 2)
Unable to locate 'wf-config-devel-0.3_1' in repository pool.
=> ERROR: Please see above for the real error, exiting...
```
It seems like xbps-src can't have three dashes in the keyword? I changed wf-config to wfconfig for now.

Unfortunately, `wf-shell` installs -devel headers into the main package because they use gtk-layer-shell as a git submodule. 

I haven't tested the new wlroots/sway to see if it works, but I will be able to a bit later (everything compiles locally).

Also, thanks @Wychmire!

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: [PR PATCH] [Updated] [Nomerge] sway: update to 1.2.
       [not found] <gh-mailinglist-notifications-41a7ca26-5023-4802-975b-f1789d68868e-void-packages-13999@inbox.vuxu.org>
                   ` (14 preceding siblings ...)
  2019-10-08 12:49 ` [PR PATCH] [Updated] " voidlinux-github
@ 2019-10-08 12:49 ` voidlinux-github
  2019-10-08 14:42 ` voidlinux-github
                   ` (12 subsequent siblings)
  28 siblings, 0 replies; 29+ messages in thread
From: voidlinux-github @ 2019-10-08 12:49 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 349 bytes --]

There is an updated pull request by travankor against master on the void-packages repository

https://github.com/travankor/void-packages sway
https://github.com/void-linux/void-packages/pull/13999

[Nomerge] sway: update to 1.2.
Wayfire needs to be updated.

A patch file from https://github.com/void-linux/void-packages/pull/13999.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-sway-13999.patch --]
[-- Type: text/x-diff, Size: 11741 bytes --]

From ad65e91b5bf1bb19850dc211a55cd71a0f3d1889 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 27 Aug 2019 03:04:57 -0700
Subject: [PATCH 1/6] sway: update to 1.2.

---
 srcpkgs/sway/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/sway/template b/srcpkgs/sway/template
index 574ff5f90cd..0a236516283 100644
--- a/srcpkgs/sway/template
+++ b/srcpkgs/sway/template
@@ -1,6 +1,6 @@
 # Template file for 'sway'
 pkgname=sway
-version=1.1.1
+version=1.2
 revision=1
 build_style=meson
 conf_files="/etc/sway/config"
@@ -13,7 +13,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://swaywm.org"
 distfiles="https://github.com/swaywm/${pkgname}/archive/${version}.tar.gz"
-checksum=740bf97556c54da83937a255113d715aaa05e05b44d61fbe85e01b53ff1f9922
+checksum=9f79382577ee132111c290b4d1a1a3e114ef485595c30cf5f181a11575bda846
 
 build_options="elogind"
 desc_option_elogind="Uses elogind instead of setuid for privilege escalation"

From f49bf1fcc77b8a4bc11a76100d1863d87eb0b003 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Mon, 7 Oct 2019 16:58:21 -0700
Subject: [PATCH 2/6] wlroots: update to 0.8.1.

---
 srcpkgs/wlroots/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/wlroots/template b/srcpkgs/wlroots/template
index 7b88e324827..75ddb338a15 100644
--- a/srcpkgs/wlroots/template
+++ b/srcpkgs/wlroots/template
@@ -1,23 +1,23 @@
 # Template file for 'wlroots'
 pkgname=wlroots
-version=0.6.0
-revision=2
+version=0.8.1
+revision=1
 build_style=meson
 configure_args="-Dlibcap=enabled -Dlogind=enabled -Dlogind-provider=elogind
  -Dxcb-errors=enabled -Dxcb-icccm=enabled -Dxwayland=enabled
- -Dx11-backend=enabled -Dexamples=false -Drootston=false"
+ -Dx11-backend=enabled -Dexamples=false"
 hostmakedepends="pkg-config wayland-devel"
 makedepends="elogind-devel libcap-devel wayland-devel wayland-protocols
  MesaLib-devel libinput-devel libxkbcommon-devel libdrm-devel pixman-devel
  libxcb-devel xcb-util-cursor-devel xcb-util-devel xcb-util-image-devel
  xcb-util-keysyms-devel xcb-util-renderutil-devel xcb-util-wm-devel
  xcb-util-errors-devel xcb-util-xrm-devel freerdp-devel"
-short_desc="Module Wayland compositor library"
+short_desc="Modular Wayland compositor library"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://github.com/swaywm/wlroots"
 distfiles="https://github.com/swaywm/wlroots/archive/${version}.tar.gz"
-checksum=9cf3716f3683d800df8b150f256ff66dad65faf13a9d67c284f67a9444d28c70
+checksum=202b86e0e21699b6660bbda56afc2e3358db7252f83ff69c89f01926b4900d98
 
 post_install() {
 	vlicense LICENSE

From 86fbace24f00293d7d098849e9a332e92a6c6457 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 8 Oct 2019 02:36:29 -0700
Subject: [PATCH 3/6] wf-config: update to 0.3.

---
 common/shlibs                            |  2 +-
 srcpkgs/wf-config-devel                  |  1 +
 srcpkgs/wf-config/patches/fix-musl.patch | 13 -------------
 srcpkgs/wf-config/template               | 20 ++++++++++++++------
 4 files changed, 16 insertions(+), 20 deletions(-)
 create mode 120000 srcpkgs/wf-config-devel
 delete mode 100644 srcpkgs/wf-config/patches/fix-musl.patch

diff --git a/common/shlibs b/common/shlibs
index 688275b7d9e..8be530d3a22 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -3411,7 +3411,7 @@ libsnore-qt5.so.0.7 snorenotify-0.7.0_1
 libsnoresettings-qt5.so.0.7 snorenotify-0.7.0_1
 libTECkit.so.0 libteckit-2.5.8_1
 libTECkit_Compiler.so.0 libteckit-2.5.8_1
-libwf-config.so wf-config-0.1_1
+libwf-config.so.0 wf-config-0.3_1
 libQt5Pas.so.1 qt5pas-2.6~beta_1
 libClp.so.1 libClp-1.16.11_1
 libCoinUtils.so.3 libClp-1.16.11_1
diff --git a/srcpkgs/wf-config-devel b/srcpkgs/wf-config-devel
new file mode 120000
index 00000000000..fb3df2e900c
--- /dev/null
+++ b/srcpkgs/wf-config-devel
@@ -0,0 +1 @@
+wf-config/
\ No newline at end of file
diff --git a/srcpkgs/wf-config/patches/fix-musl.patch b/srcpkgs/wf-config/patches/fix-musl.patch
deleted file mode 100644
index b87797ba555..00000000000
--- a/srcpkgs/wf-config/patches/fix-musl.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/config.cpp b/src/config.cpp
-index f586ab5..811ce29 100644
---- src/config.cpp
-+++ src/config.cpp
-@@ -4,6 +4,7 @@
- #include <sstream>
- #include <fstream>
- #include <algorithm>
-+#include <fcntl.h>
- 
- std::ofstream out;
- 
-
diff --git a/srcpkgs/wf-config/template b/srcpkgs/wf-config/template
index 98eee65d39e..adee709a060 100644
--- a/srcpkgs/wf-config/template
+++ b/srcpkgs/wf-config/template
@@ -1,6 +1,6 @@
 # Template file for 'wf-config'
 pkgname=wf-config
-version=0.1
+version=0.3
 revision=1
 build_style=meson
 hostmakedepends="pkg-config"
@@ -9,11 +9,19 @@ short_desc="Wayfire library for managing configuration files"
 maintainer="Young Jin Park <youngjinpark20@gmail.com>"
 license="MIT"
 homepage="https://wayfire.org"
-distfiles="https://github.com/WayfireWM/wf-config/archive/v${version}.tar.gz
- https://raw.githubusercontent.com/WayfireWM/wf-config/master/LICENSE>LICENSE.txt"
-checksum="0dac4683013d5a0b143f0e211288c7f2f621740b9ac664359297ff530a7dcdc5
- 7053b1aa75aaccfe2a2bfacd400c0a8694858797ff9c7d584664e2941fb3016e"
+distfiles="https://github.com/WayfireWM/wf-config/archive/${version}.tar.gz"
+checksum=5d1a5038b11a177174b392f3b383d787f568265ce483a5be9178698f548f7c66
 
 post_install() {
-	vlicense ../LICENSE.txt
+	vlicense LICENSE
+}
+
+wf-config-devel_package() {
+	depends="libevdev-devel wlroots-devel wf-config>=${version}_${revision}"
+	short_desc+=" - development files"
+	pkg_install() {
+		vmove usr/include
+		vmove usr/lib/pkgconfig
+		vmove "usr/lib/*.so"
+	}
 }

From 79ef1c4b5e9e6b0dfabf01a9bfd1d3c6e6a8ed24 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 8 Oct 2019 03:48:04 -0700
Subject: [PATCH 4/6] wfconfig: rename wf-config to wfconfig due to xbps-src
 bug.

---
 common/shlibs                            |  2 +-
 srcpkgs/wf-config-devel                  |  1 -
 srcpkgs/wfconfig-devel                   |  1 +
 srcpkgs/{wf-config => wfconfig}/template | 10 ++++++----
 4 files changed, 8 insertions(+), 6 deletions(-)
 delete mode 120000 srcpkgs/wf-config-devel
 create mode 120000 srcpkgs/wfconfig-devel
 rename srcpkgs/{wf-config => wfconfig}/template (72%)

diff --git a/common/shlibs b/common/shlibs
index 8be530d3a22..3ad5af56f29 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -3411,7 +3411,7 @@ libsnore-qt5.so.0.7 snorenotify-0.7.0_1
 libsnoresettings-qt5.so.0.7 snorenotify-0.7.0_1
 libTECkit.so.0 libteckit-2.5.8_1
 libTECkit_Compiler.so.0 libteckit-2.5.8_1
-libwf-config.so.0 wf-config-0.3_1
+libwf-config.so.0 wfconfig-0.3_1
 libQt5Pas.so.1 qt5pas-2.6~beta_1
 libClp.so.1 libClp-1.16.11_1
 libCoinUtils.so.3 libClp-1.16.11_1
diff --git a/srcpkgs/wf-config-devel b/srcpkgs/wf-config-devel
deleted file mode 120000
index fb3df2e900c..00000000000
--- a/srcpkgs/wf-config-devel
+++ /dev/null
@@ -1 +0,0 @@
-wf-config/
\ No newline at end of file
diff --git a/srcpkgs/wfconfig-devel b/srcpkgs/wfconfig-devel
new file mode 120000
index 00000000000..9806e3a908e
--- /dev/null
+++ b/srcpkgs/wfconfig-devel
@@ -0,0 +1 @@
+wfconfig/
\ No newline at end of file
diff --git a/srcpkgs/wf-config/template b/srcpkgs/wfconfig/template
similarity index 72%
rename from srcpkgs/wf-config/template
rename to srcpkgs/wfconfig/template
index adee709a060..a68939164b9 100644
--- a/srcpkgs/wf-config/template
+++ b/srcpkgs/wfconfig/template
@@ -1,7 +1,8 @@
-# Template file for 'wf-config'
-pkgname=wf-config
+# Template file for 'wfconfig'
+pkgname=wfconfig
 version=0.3
 revision=1
+wrksrc=wf-config-${version}
 build_style=meson
 hostmakedepends="pkg-config"
 makedepends="libevdev-devel wlroots-devel"
@@ -16,8 +17,9 @@ post_install() {
 	vlicense LICENSE
 }
 
-wf-config-devel_package() {
-	depends="libevdev-devel wlroots-devel wf-config>=${version}_${revision}"
+# xbps-src bug: can't have three dashes in keyword
+wfconfig-devel_package() {
+	depends="libevdev-devel wlroots-devel wfconfig>=${version}_${revision}"
 	short_desc+=" - development files"
 	pkg_install() {
 		vmove usr/include

From eecae7a36dd389838e69ec2c676c0c3539f227b5 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 8 Oct 2019 03:49:41 -0700
Subject: [PATCH 5/6] wayfire: update to 0.3.0.

---
 srcpkgs/wayfire/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/wayfire/template b/srcpkgs/wayfire/template
index 2ee4bd17ae9..cdaec561150 100644
--- a/srcpkgs/wayfire/template
+++ b/srcpkgs/wayfire/template
@@ -1,16 +1,16 @@
 # Template file for 'wayfire'
 pkgname=wayfire
-version=0.2
+version=0.3.0
 revision=1
 build_style=meson
 hostmakedepends="pkg-config wayland-devel"
-makedepends="wlroots-devel glm cairo-devel wf-config"
+makedepends="wlroots-devel glm cairo-devel wfconfig-devel"
 short_desc="3D wayland compositor"
 maintainer="Young Jin Park <youngjinpark20@gmail.com>"
 license="MIT"
 homepage="https://wayfire.org"
-distfiles="https://github.com/WayfireWM/wayfire/archive/v${version}.tar.gz"
-checksum=94fe93bb2b86048fd1c7601f97b167767e19618bb6b6226e21c22fbd052540bf
+distfiles="https://github.com/WayfireWM/wayfire/archive/${version}.tar.gz"
+checksum=c686bf5abb7f0db829196785bba4136c85d7b52d701212e21636dad75e1da0aa
 
 case $XBPS_TARGET_MACHINE in
 	*-musl) makedepends+=" libexecinfo-devel"

From 6e86a116de70f33e1046ba689645d6ba54e4166a Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 8 Oct 2019 04:40:29 -0700
Subject: [PATCH 6/6] wf-shell: update to 0.3.

---
 srcpkgs/wf-shell/template | 28 +++++++++++++++++++++++-----
 1 file changed, 23 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/wf-shell/template b/srcpkgs/wf-shell/template
index ccfd8c574a0..02d130d34f6 100644
--- a/srcpkgs/wf-shell/template
+++ b/srcpkgs/wf-shell/template
@@ -1,16 +1,34 @@
 # Template file for 'wf-shell'
 pkgname=wf-shell
-version=0.1
+version=0.3
 revision=1
+_gtklayershell_hash="d1f9d94be32f8cc61c0a53af7558146570f0fa9f"
+_gvc_hash="468022b708fc1a56154f3b0cc5af3b938fb3e9fb"
+create_wrksrc=yes
+build_wrksrc=${pkgname}-${version}
 build_style=meson
-hostmakedepends="pkg-config wayland-devel"
-makedepends="gtkmm-devel libevdev-devel wlroots-devel wf-config"
+hostmakedepends="gobject-introspection pkg-config unzip wayland-devel"
+makedepends="alsa-lib-devel pulseaudio-devel gtkmm-devel
+ gtk+3-devel libevdev-devel wlroots-devel wfconfig-devel"
 short_desc="Wayfire shell with GTK-based panel and background client"
 maintainer="Young Jin Park <youngjinpark20@gmail.com>"
 license="MIT"
 homepage="https://wayfire.org"
-distfiles="https://github.com/WayfireWM/wf-shell/archive/${version}.tar.gz"
-checksum=625637fddf58a6a1825980e68d156ddb377cf4aae9bf5d844fb15aefee4c6f4f
+distfiles="https://github.com/WayfireWM/wf-shell/archive/${version}.tar.gz
+ https://github.com/wmww/gtk-layer-shell/archive/${_gtklayershell_hash}.zip
+ https://github.com/GNOME/libgnome-volume-control/archive/${_gvc_hash}.zip"
+checksum="326c732415a10215997c0915741fd561a306412327fae123eab67f1af9ee41de
+ a5f43f0f660a4147a2a50c51ee2214b29cf057c3bf0b439451a86b8cc21b9013
+ bf10e33e030f8a5a1ce903cd8201f0882532931d26d530d3ebe2aea174771fd0"
+nocross="gobject-introspection from gtk-layer-shell"
+
+post_extract() {
+	_gtklayershell_dir="${pkgname}-${version}/subprojects/gtk-layer-shell"
+	_gvc_dir="${pkgname}-${version}/subprojects/gvc"
+	rmdir ${_gtklayershell_dir} ${_gvc_dir}
+	mv gtk-layer-shell-d1f9d94be32f8cc61c0a53af7558146570f0fa9f ${_gtklayershell_dir}
+	mv libgnome-volume-control-468022b708fc1a56154f3b0cc5af3b938fb3e9fb ${_gvc_dir}
+}
 
 post_install() {
 	vlicense LICENSE

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: [PR PATCH] [Updated] [Nomerge] sway: update to 1.2.
       [not found] <gh-mailinglist-notifications-41a7ca26-5023-4802-975b-f1789d68868e-void-packages-13999@inbox.vuxu.org>
                   ` (13 preceding siblings ...)
  2019-10-08 11:55 ` voidlinux-github
@ 2019-10-08 12:49 ` voidlinux-github
  2019-10-08 12:49 ` voidlinux-github
                   ` (13 subsequent siblings)
  28 siblings, 0 replies; 29+ messages in thread
From: voidlinux-github @ 2019-10-08 12:49 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 349 bytes --]

There is an updated pull request by travankor against master on the void-packages repository

https://github.com/travankor/void-packages sway
https://github.com/void-linux/void-packages/pull/13999

[Nomerge] sway: update to 1.2.
Wayfire needs to be updated.

A patch file from https://github.com/void-linux/void-packages/pull/13999.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-sway-13999.patch --]
[-- Type: text/x-diff, Size: 11741 bytes --]

From ad65e91b5bf1bb19850dc211a55cd71a0f3d1889 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 27 Aug 2019 03:04:57 -0700
Subject: [PATCH 1/6] sway: update to 1.2.

---
 srcpkgs/sway/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/sway/template b/srcpkgs/sway/template
index 574ff5f90cd..0a236516283 100644
--- a/srcpkgs/sway/template
+++ b/srcpkgs/sway/template
@@ -1,6 +1,6 @@
 # Template file for 'sway'
 pkgname=sway
-version=1.1.1
+version=1.2
 revision=1
 build_style=meson
 conf_files="/etc/sway/config"
@@ -13,7 +13,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://swaywm.org"
 distfiles="https://github.com/swaywm/${pkgname}/archive/${version}.tar.gz"
-checksum=740bf97556c54da83937a255113d715aaa05e05b44d61fbe85e01b53ff1f9922
+checksum=9f79382577ee132111c290b4d1a1a3e114ef485595c30cf5f181a11575bda846
 
 build_options="elogind"
 desc_option_elogind="Uses elogind instead of setuid for privilege escalation"

From f49bf1fcc77b8a4bc11a76100d1863d87eb0b003 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Mon, 7 Oct 2019 16:58:21 -0700
Subject: [PATCH 2/6] wlroots: update to 0.8.1.

---
 srcpkgs/wlroots/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/wlroots/template b/srcpkgs/wlroots/template
index 7b88e324827..75ddb338a15 100644
--- a/srcpkgs/wlroots/template
+++ b/srcpkgs/wlroots/template
@@ -1,23 +1,23 @@
 # Template file for 'wlroots'
 pkgname=wlroots
-version=0.6.0
-revision=2
+version=0.8.1
+revision=1
 build_style=meson
 configure_args="-Dlibcap=enabled -Dlogind=enabled -Dlogind-provider=elogind
  -Dxcb-errors=enabled -Dxcb-icccm=enabled -Dxwayland=enabled
- -Dx11-backend=enabled -Dexamples=false -Drootston=false"
+ -Dx11-backend=enabled -Dexamples=false"
 hostmakedepends="pkg-config wayland-devel"
 makedepends="elogind-devel libcap-devel wayland-devel wayland-protocols
  MesaLib-devel libinput-devel libxkbcommon-devel libdrm-devel pixman-devel
  libxcb-devel xcb-util-cursor-devel xcb-util-devel xcb-util-image-devel
  xcb-util-keysyms-devel xcb-util-renderutil-devel xcb-util-wm-devel
  xcb-util-errors-devel xcb-util-xrm-devel freerdp-devel"
-short_desc="Module Wayland compositor library"
+short_desc="Modular Wayland compositor library"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://github.com/swaywm/wlroots"
 distfiles="https://github.com/swaywm/wlroots/archive/${version}.tar.gz"
-checksum=9cf3716f3683d800df8b150f256ff66dad65faf13a9d67c284f67a9444d28c70
+checksum=202b86e0e21699b6660bbda56afc2e3358db7252f83ff69c89f01926b4900d98
 
 post_install() {
 	vlicense LICENSE

From 86fbace24f00293d7d098849e9a332e92a6c6457 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 8 Oct 2019 02:36:29 -0700
Subject: [PATCH 3/6] wf-config: update to 0.3.

---
 common/shlibs                            |  2 +-
 srcpkgs/wf-config-devel                  |  1 +
 srcpkgs/wf-config/patches/fix-musl.patch | 13 -------------
 srcpkgs/wf-config/template               | 20 ++++++++++++++------
 4 files changed, 16 insertions(+), 20 deletions(-)
 create mode 120000 srcpkgs/wf-config-devel
 delete mode 100644 srcpkgs/wf-config/patches/fix-musl.patch

diff --git a/common/shlibs b/common/shlibs
index 688275b7d9e..8be530d3a22 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -3411,7 +3411,7 @@ libsnore-qt5.so.0.7 snorenotify-0.7.0_1
 libsnoresettings-qt5.so.0.7 snorenotify-0.7.0_1
 libTECkit.so.0 libteckit-2.5.8_1
 libTECkit_Compiler.so.0 libteckit-2.5.8_1
-libwf-config.so wf-config-0.1_1
+libwf-config.so.0 wf-config-0.3_1
 libQt5Pas.so.1 qt5pas-2.6~beta_1
 libClp.so.1 libClp-1.16.11_1
 libCoinUtils.so.3 libClp-1.16.11_1
diff --git a/srcpkgs/wf-config-devel b/srcpkgs/wf-config-devel
new file mode 120000
index 00000000000..fb3df2e900c
--- /dev/null
+++ b/srcpkgs/wf-config-devel
@@ -0,0 +1 @@
+wf-config/
\ No newline at end of file
diff --git a/srcpkgs/wf-config/patches/fix-musl.patch b/srcpkgs/wf-config/patches/fix-musl.patch
deleted file mode 100644
index b87797ba555..00000000000
--- a/srcpkgs/wf-config/patches/fix-musl.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/config.cpp b/src/config.cpp
-index f586ab5..811ce29 100644
---- src/config.cpp
-+++ src/config.cpp
-@@ -4,6 +4,7 @@
- #include <sstream>
- #include <fstream>
- #include <algorithm>
-+#include <fcntl.h>
- 
- std::ofstream out;
- 
-
diff --git a/srcpkgs/wf-config/template b/srcpkgs/wf-config/template
index 98eee65d39e..adee709a060 100644
--- a/srcpkgs/wf-config/template
+++ b/srcpkgs/wf-config/template
@@ -1,6 +1,6 @@
 # Template file for 'wf-config'
 pkgname=wf-config
-version=0.1
+version=0.3
 revision=1
 build_style=meson
 hostmakedepends="pkg-config"
@@ -9,11 +9,19 @@ short_desc="Wayfire library for managing configuration files"
 maintainer="Young Jin Park <youngjinpark20@gmail.com>"
 license="MIT"
 homepage="https://wayfire.org"
-distfiles="https://github.com/WayfireWM/wf-config/archive/v${version}.tar.gz
- https://raw.githubusercontent.com/WayfireWM/wf-config/master/LICENSE>LICENSE.txt"
-checksum="0dac4683013d5a0b143f0e211288c7f2f621740b9ac664359297ff530a7dcdc5
- 7053b1aa75aaccfe2a2bfacd400c0a8694858797ff9c7d584664e2941fb3016e"
+distfiles="https://github.com/WayfireWM/wf-config/archive/${version}.tar.gz"
+checksum=5d1a5038b11a177174b392f3b383d787f568265ce483a5be9178698f548f7c66
 
 post_install() {
-	vlicense ../LICENSE.txt
+	vlicense LICENSE
+}
+
+wf-config-devel_package() {
+	depends="libevdev-devel wlroots-devel wf-config>=${version}_${revision}"
+	short_desc+=" - development files"
+	pkg_install() {
+		vmove usr/include
+		vmove usr/lib/pkgconfig
+		vmove "usr/lib/*.so"
+	}
 }

From 79ef1c4b5e9e6b0dfabf01a9bfd1d3c6e6a8ed24 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 8 Oct 2019 03:48:04 -0700
Subject: [PATCH 4/6] wfconfig: rename wf-config to wfconfig due to xbps-src
 bug.

---
 common/shlibs                            |  2 +-
 srcpkgs/wf-config-devel                  |  1 -
 srcpkgs/wfconfig-devel                   |  1 +
 srcpkgs/{wf-config => wfconfig}/template | 10 ++++++----
 4 files changed, 8 insertions(+), 6 deletions(-)
 delete mode 120000 srcpkgs/wf-config-devel
 create mode 120000 srcpkgs/wfconfig-devel
 rename srcpkgs/{wf-config => wfconfig}/template (72%)

diff --git a/common/shlibs b/common/shlibs
index 8be530d3a22..3ad5af56f29 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -3411,7 +3411,7 @@ libsnore-qt5.so.0.7 snorenotify-0.7.0_1
 libsnoresettings-qt5.so.0.7 snorenotify-0.7.0_1
 libTECkit.so.0 libteckit-2.5.8_1
 libTECkit_Compiler.so.0 libteckit-2.5.8_1
-libwf-config.so.0 wf-config-0.3_1
+libwf-config.so.0 wfconfig-0.3_1
 libQt5Pas.so.1 qt5pas-2.6~beta_1
 libClp.so.1 libClp-1.16.11_1
 libCoinUtils.so.3 libClp-1.16.11_1
diff --git a/srcpkgs/wf-config-devel b/srcpkgs/wf-config-devel
deleted file mode 120000
index fb3df2e900c..00000000000
--- a/srcpkgs/wf-config-devel
+++ /dev/null
@@ -1 +0,0 @@
-wf-config/
\ No newline at end of file
diff --git a/srcpkgs/wfconfig-devel b/srcpkgs/wfconfig-devel
new file mode 120000
index 00000000000..9806e3a908e
--- /dev/null
+++ b/srcpkgs/wfconfig-devel
@@ -0,0 +1 @@
+wfconfig/
\ No newline at end of file
diff --git a/srcpkgs/wf-config/template b/srcpkgs/wfconfig/template
similarity index 72%
rename from srcpkgs/wf-config/template
rename to srcpkgs/wfconfig/template
index adee709a060..a68939164b9 100644
--- a/srcpkgs/wf-config/template
+++ b/srcpkgs/wfconfig/template
@@ -1,7 +1,8 @@
-# Template file for 'wf-config'
-pkgname=wf-config
+# Template file for 'wfconfig'
+pkgname=wfconfig
 version=0.3
 revision=1
+wrksrc=wf-config-${version}
 build_style=meson
 hostmakedepends="pkg-config"
 makedepends="libevdev-devel wlroots-devel"
@@ -16,8 +17,9 @@ post_install() {
 	vlicense LICENSE
 }
 
-wf-config-devel_package() {
-	depends="libevdev-devel wlroots-devel wf-config>=${version}_${revision}"
+# xbps-src bug: can't have three dashes in keyword
+wfconfig-devel_package() {
+	depends="libevdev-devel wlroots-devel wfconfig>=${version}_${revision}"
 	short_desc+=" - development files"
 	pkg_install() {
 		vmove usr/include

From eecae7a36dd389838e69ec2c676c0c3539f227b5 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 8 Oct 2019 03:49:41 -0700
Subject: [PATCH 5/6] wayfire: update to 0.3.0.

---
 srcpkgs/wayfire/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/wayfire/template b/srcpkgs/wayfire/template
index 2ee4bd17ae9..cdaec561150 100644
--- a/srcpkgs/wayfire/template
+++ b/srcpkgs/wayfire/template
@@ -1,16 +1,16 @@
 # Template file for 'wayfire'
 pkgname=wayfire
-version=0.2
+version=0.3.0
 revision=1
 build_style=meson
 hostmakedepends="pkg-config wayland-devel"
-makedepends="wlroots-devel glm cairo-devel wf-config"
+makedepends="wlroots-devel glm cairo-devel wfconfig-devel"
 short_desc="3D wayland compositor"
 maintainer="Young Jin Park <youngjinpark20@gmail.com>"
 license="MIT"
 homepage="https://wayfire.org"
-distfiles="https://github.com/WayfireWM/wayfire/archive/v${version}.tar.gz"
-checksum=94fe93bb2b86048fd1c7601f97b167767e19618bb6b6226e21c22fbd052540bf
+distfiles="https://github.com/WayfireWM/wayfire/archive/${version}.tar.gz"
+checksum=c686bf5abb7f0db829196785bba4136c85d7b52d701212e21636dad75e1da0aa
 
 case $XBPS_TARGET_MACHINE in
 	*-musl) makedepends+=" libexecinfo-devel"

From 6e86a116de70f33e1046ba689645d6ba54e4166a Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 8 Oct 2019 04:40:29 -0700
Subject: [PATCH 6/6] wf-shell: update to 0.3.

---
 srcpkgs/wf-shell/template | 28 +++++++++++++++++++++++-----
 1 file changed, 23 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/wf-shell/template b/srcpkgs/wf-shell/template
index ccfd8c574a0..02d130d34f6 100644
--- a/srcpkgs/wf-shell/template
+++ b/srcpkgs/wf-shell/template
@@ -1,16 +1,34 @@
 # Template file for 'wf-shell'
 pkgname=wf-shell
-version=0.1
+version=0.3
 revision=1
+_gtklayershell_hash="d1f9d94be32f8cc61c0a53af7558146570f0fa9f"
+_gvc_hash="468022b708fc1a56154f3b0cc5af3b938fb3e9fb"
+create_wrksrc=yes
+build_wrksrc=${pkgname}-${version}
 build_style=meson
-hostmakedepends="pkg-config wayland-devel"
-makedepends="gtkmm-devel libevdev-devel wlroots-devel wf-config"
+hostmakedepends="gobject-introspection pkg-config unzip wayland-devel"
+makedepends="alsa-lib-devel pulseaudio-devel gtkmm-devel
+ gtk+3-devel libevdev-devel wlroots-devel wfconfig-devel"
 short_desc="Wayfire shell with GTK-based panel and background client"
 maintainer="Young Jin Park <youngjinpark20@gmail.com>"
 license="MIT"
 homepage="https://wayfire.org"
-distfiles="https://github.com/WayfireWM/wf-shell/archive/${version}.tar.gz"
-checksum=625637fddf58a6a1825980e68d156ddb377cf4aae9bf5d844fb15aefee4c6f4f
+distfiles="https://github.com/WayfireWM/wf-shell/archive/${version}.tar.gz
+ https://github.com/wmww/gtk-layer-shell/archive/${_gtklayershell_hash}.zip
+ https://github.com/GNOME/libgnome-volume-control/archive/${_gvc_hash}.zip"
+checksum="326c732415a10215997c0915741fd561a306412327fae123eab67f1af9ee41de
+ a5f43f0f660a4147a2a50c51ee2214b29cf057c3bf0b439451a86b8cc21b9013
+ bf10e33e030f8a5a1ce903cd8201f0882532931d26d530d3ebe2aea174771fd0"
+nocross="gobject-introspection from gtk-layer-shell"
+
+post_extract() {
+	_gtklayershell_dir="${pkgname}-${version}/subprojects/gtk-layer-shell"
+	_gvc_dir="${pkgname}-${version}/subprojects/gvc"
+	rmdir ${_gtklayershell_dir} ${_gvc_dir}
+	mv gtk-layer-shell-d1f9d94be32f8cc61c0a53af7558146570f0fa9f ${_gtklayershell_dir}
+	mv libgnome-volume-control-468022b708fc1a56154f3b0cc5af3b938fb3e9fb ${_gvc_dir}
+}
 
 post_install() {
 	vlicense LICENSE

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: [Nomerge] sway: update to 1.2.
       [not found] <gh-mailinglist-notifications-41a7ca26-5023-4802-975b-f1789d68868e-void-packages-13999@inbox.vuxu.org>
                   ` (15 preceding siblings ...)
  2019-10-08 12:49 ` voidlinux-github
@ 2019-10-08 14:42 ` voidlinux-github
  2019-10-08 15:57 ` voidlinux-github
                   ` (11 subsequent siblings)
  28 siblings, 0 replies; 29+ messages in thread
From: voidlinux-github @ 2019-10-08 14:42 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 756 bytes --]

New comment by Wychmire on void-packages repository

https://github.com/void-linux/void-packages/pull/13999#issuecomment-539546849

Comment:
I created a [new branch](https://github.com/Wychmire/void-packages/tree/sway) based on your fork with the only changes from yours being the use of `wf-config` over `wfconfig`. Could you try cloning it and building wayfire/wf-shell? Everything works fine on my end.

I considered putting gtk-layer-shell in it's own package but since only one package (wf-shell) uses it seemed unnecessary. If another package ends up using it it might be worth making a package with -devel.

I'm running sway 1.2 and wlroots 0.7 locally, everything is working fine. I'll update wlroots to 0.8.1 later today, and try out wayfire.

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: [Nomerge] sway: update to 1.2.
       [not found] <gh-mailinglist-notifications-41a7ca26-5023-4802-975b-f1789d68868e-void-packages-13999@inbox.vuxu.org>
                   ` (16 preceding siblings ...)
  2019-10-08 14:42 ` voidlinux-github
@ 2019-10-08 15:57 ` voidlinux-github
  2019-10-08 16:09 ` voidlinux-github
                   ` (10 subsequent siblings)
  28 siblings, 0 replies; 29+ messages in thread
From: voidlinux-github @ 2019-10-08 15:57 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 362 bytes --]

New comment by travankor on void-packages repository

https://github.com/void-linux/void-packages/pull/13999#issuecomment-539581860

Comment:
Hm, I can build your branch. In that case, I probably ran into some corner case that `xbps-src zap` usually cleans up (I didn't run that at the time).

I will remove that commit and push after I do some local testing.

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: [Nomerge] sway: update to 1.2.
       [not found] <gh-mailinglist-notifications-41a7ca26-5023-4802-975b-f1789d68868e-void-packages-13999@inbox.vuxu.org>
                   ` (17 preceding siblings ...)
  2019-10-08 15:57 ` voidlinux-github
@ 2019-10-08 16:09 ` voidlinux-github
  2019-10-08 16:10 ` [PR PATCH] [Updated] " voidlinux-github
                   ` (9 subsequent siblings)
  28 siblings, 0 replies; 29+ messages in thread
From: voidlinux-github @ 2019-10-08 16:09 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 293 bytes --]

New comment by travankor on void-packages repository

https://github.com/void-linux/void-packages/pull/13999#issuecomment-539581860

Comment:
Hm, I can build your branch. In that case, I probably ran into some corner case that `xbps-src zap` usually cleans up (I didn't run that at the time).

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: [PR PATCH] [Updated] [Nomerge] sway: update to 1.2.
       [not found] <gh-mailinglist-notifications-41a7ca26-5023-4802-975b-f1789d68868e-void-packages-13999@inbox.vuxu.org>
                   ` (18 preceding siblings ...)
  2019-10-08 16:09 ` voidlinux-github
@ 2019-10-08 16:10 ` voidlinux-github
  2019-10-08 16:10 ` voidlinux-github
                   ` (8 subsequent siblings)
  28 siblings, 0 replies; 29+ messages in thread
From: voidlinux-github @ 2019-10-08 16:10 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 349 bytes --]

There is an updated pull request by travankor against master on the void-packages repository

https://github.com/travankor/void-packages sway
https://github.com/void-linux/void-packages/pull/13999

[Nomerge] sway: update to 1.2.
Wayfire needs to be updated.

A patch file from https://github.com/void-linux/void-packages/pull/13999.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-sway-13999.patch --]
[-- Type: text/x-diff, Size: 9237 bytes --]

From ad65e91b5bf1bb19850dc211a55cd71a0f3d1889 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 27 Aug 2019 03:04:57 -0700
Subject: [PATCH 1/5] sway: update to 1.2.

---
 srcpkgs/sway/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/sway/template b/srcpkgs/sway/template
index 574ff5f90cd..0a236516283 100644
--- a/srcpkgs/sway/template
+++ b/srcpkgs/sway/template
@@ -1,6 +1,6 @@
 # Template file for 'sway'
 pkgname=sway
-version=1.1.1
+version=1.2
 revision=1
 build_style=meson
 conf_files="/etc/sway/config"
@@ -13,7 +13,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://swaywm.org"
 distfiles="https://github.com/swaywm/${pkgname}/archive/${version}.tar.gz"
-checksum=740bf97556c54da83937a255113d715aaa05e05b44d61fbe85e01b53ff1f9922
+checksum=9f79382577ee132111c290b4d1a1a3e114ef485595c30cf5f181a11575bda846
 
 build_options="elogind"
 desc_option_elogind="Uses elogind instead of setuid for privilege escalation"

From f49bf1fcc77b8a4bc11a76100d1863d87eb0b003 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Mon, 7 Oct 2019 16:58:21 -0700
Subject: [PATCH 2/5] wlroots: update to 0.8.1.

---
 srcpkgs/wlroots/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/wlroots/template b/srcpkgs/wlroots/template
index 7b88e324827..75ddb338a15 100644
--- a/srcpkgs/wlroots/template
+++ b/srcpkgs/wlroots/template
@@ -1,23 +1,23 @@
 # Template file for 'wlroots'
 pkgname=wlroots
-version=0.6.0
-revision=2
+version=0.8.1
+revision=1
 build_style=meson
 configure_args="-Dlibcap=enabled -Dlogind=enabled -Dlogind-provider=elogind
  -Dxcb-errors=enabled -Dxcb-icccm=enabled -Dxwayland=enabled
- -Dx11-backend=enabled -Dexamples=false -Drootston=false"
+ -Dx11-backend=enabled -Dexamples=false"
 hostmakedepends="pkg-config wayland-devel"
 makedepends="elogind-devel libcap-devel wayland-devel wayland-protocols
  MesaLib-devel libinput-devel libxkbcommon-devel libdrm-devel pixman-devel
  libxcb-devel xcb-util-cursor-devel xcb-util-devel xcb-util-image-devel
  xcb-util-keysyms-devel xcb-util-renderutil-devel xcb-util-wm-devel
  xcb-util-errors-devel xcb-util-xrm-devel freerdp-devel"
-short_desc="Module Wayland compositor library"
+short_desc="Modular Wayland compositor library"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://github.com/swaywm/wlroots"
 distfiles="https://github.com/swaywm/wlroots/archive/${version}.tar.gz"
-checksum=9cf3716f3683d800df8b150f256ff66dad65faf13a9d67c284f67a9444d28c70
+checksum=202b86e0e21699b6660bbda56afc2e3358db7252f83ff69c89f01926b4900d98
 
 post_install() {
 	vlicense LICENSE

From 86fbace24f00293d7d098849e9a332e92a6c6457 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 8 Oct 2019 02:36:29 -0700
Subject: [PATCH 3/5] wf-config: update to 0.3.

---
 common/shlibs                            |  2 +-
 srcpkgs/wf-config-devel                  |  1 +
 srcpkgs/wf-config/patches/fix-musl.patch | 13 -------------
 srcpkgs/wf-config/template               | 20 ++++++++++++++------
 4 files changed, 16 insertions(+), 20 deletions(-)
 create mode 120000 srcpkgs/wf-config-devel
 delete mode 100644 srcpkgs/wf-config/patches/fix-musl.patch

diff --git a/common/shlibs b/common/shlibs
index 688275b7d9e..8be530d3a22 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -3411,7 +3411,7 @@ libsnore-qt5.so.0.7 snorenotify-0.7.0_1
 libsnoresettings-qt5.so.0.7 snorenotify-0.7.0_1
 libTECkit.so.0 libteckit-2.5.8_1
 libTECkit_Compiler.so.0 libteckit-2.5.8_1
-libwf-config.so wf-config-0.1_1
+libwf-config.so.0 wf-config-0.3_1
 libQt5Pas.so.1 qt5pas-2.6~beta_1
 libClp.so.1 libClp-1.16.11_1
 libCoinUtils.so.3 libClp-1.16.11_1
diff --git a/srcpkgs/wf-config-devel b/srcpkgs/wf-config-devel
new file mode 120000
index 00000000000..fb3df2e900c
--- /dev/null
+++ b/srcpkgs/wf-config-devel
@@ -0,0 +1 @@
+wf-config/
\ No newline at end of file
diff --git a/srcpkgs/wf-config/patches/fix-musl.patch b/srcpkgs/wf-config/patches/fix-musl.patch
deleted file mode 100644
index b87797ba555..00000000000
--- a/srcpkgs/wf-config/patches/fix-musl.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/config.cpp b/src/config.cpp
-index f586ab5..811ce29 100644
---- src/config.cpp
-+++ src/config.cpp
-@@ -4,6 +4,7 @@
- #include <sstream>
- #include <fstream>
- #include <algorithm>
-+#include <fcntl.h>
- 
- std::ofstream out;
- 
-
diff --git a/srcpkgs/wf-config/template b/srcpkgs/wf-config/template
index 98eee65d39e..adee709a060 100644
--- a/srcpkgs/wf-config/template
+++ b/srcpkgs/wf-config/template
@@ -1,6 +1,6 @@
 # Template file for 'wf-config'
 pkgname=wf-config
-version=0.1
+version=0.3
 revision=1
 build_style=meson
 hostmakedepends="pkg-config"
@@ -9,11 +9,19 @@ short_desc="Wayfire library for managing configuration files"
 maintainer="Young Jin Park <youngjinpark20@gmail.com>"
 license="MIT"
 homepage="https://wayfire.org"
-distfiles="https://github.com/WayfireWM/wf-config/archive/v${version}.tar.gz
- https://raw.githubusercontent.com/WayfireWM/wf-config/master/LICENSE>LICENSE.txt"
-checksum="0dac4683013d5a0b143f0e211288c7f2f621740b9ac664359297ff530a7dcdc5
- 7053b1aa75aaccfe2a2bfacd400c0a8694858797ff9c7d584664e2941fb3016e"
+distfiles="https://github.com/WayfireWM/wf-config/archive/${version}.tar.gz"
+checksum=5d1a5038b11a177174b392f3b383d787f568265ce483a5be9178698f548f7c66
 
 post_install() {
-	vlicense ../LICENSE.txt
+	vlicense LICENSE
+}
+
+wf-config-devel_package() {
+	depends="libevdev-devel wlroots-devel wf-config>=${version}_${revision}"
+	short_desc+=" - development files"
+	pkg_install() {
+		vmove usr/include
+		vmove usr/lib/pkgconfig
+		vmove "usr/lib/*.so"
+	}
 }

From e18c3c1dd0c1cac1b42baffa8c32ed272f894775 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 8 Oct 2019 09:08:01 -0700
Subject: [PATCH 4/5] wayfire: update to 0.3.0.

---
 srcpkgs/wayfire/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/wayfire/template b/srcpkgs/wayfire/template
index 2ee4bd17ae9..c5e31d12414 100644
--- a/srcpkgs/wayfire/template
+++ b/srcpkgs/wayfire/template
@@ -1,16 +1,16 @@
 # Template file for 'wayfire'
 pkgname=wayfire
-version=0.2
+version=0.3.0
 revision=1
 build_style=meson
 hostmakedepends="pkg-config wayland-devel"
-makedepends="wlroots-devel glm cairo-devel wf-config"
+makedepends="wlroots-devel glm cairo-devel wf-config-devel"
 short_desc="3D wayland compositor"
 maintainer="Young Jin Park <youngjinpark20@gmail.com>"
 license="MIT"
 homepage="https://wayfire.org"
-distfiles="https://github.com/WayfireWM/wayfire/archive/v${version}.tar.gz"
-checksum=94fe93bb2b86048fd1c7601f97b167767e19618bb6b6226e21c22fbd052540bf
+distfiles="https://github.com/WayfireWM/wayfire/archive/${version}.tar.gz"
+checksum=c686bf5abb7f0db829196785bba4136c85d7b52d701212e21636dad75e1da0aa
 
 case $XBPS_TARGET_MACHINE in
 	*-musl) makedepends+=" libexecinfo-devel"

From 40a96f836bffbca095e09fea11cfe523597d20ec Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 8 Oct 2019 09:08:34 -0700
Subject: [PATCH 5/5] wf-shell: update to 0.3.

---
 srcpkgs/wf-shell/template | 28 +++++++++++++++++++++++-----
 1 file changed, 23 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/wf-shell/template b/srcpkgs/wf-shell/template
index ccfd8c574a0..7be6c4bbec3 100644
--- a/srcpkgs/wf-shell/template
+++ b/srcpkgs/wf-shell/template
@@ -1,16 +1,34 @@
 # Template file for 'wf-shell'
 pkgname=wf-shell
-version=0.1
+version=0.3
 revision=1
+_gtklayershell_hash="d1f9d94be32f8cc61c0a53af7558146570f0fa9f"
+_gvc_hash="468022b708fc1a56154f3b0cc5af3b938fb3e9fb"
+create_wrksrc=yes
+build_wrksrc=${pkgname}-${version}
 build_style=meson
-hostmakedepends="pkg-config wayland-devel"
-makedepends="gtkmm-devel libevdev-devel wlroots-devel wf-config"
+hostmakedepends="gobject-introspection pkg-config unzip wayland-devel"
+makedepends="alsa-lib-devel pulseaudio-devel gtkmm-devel
+ gtk+3-devel libevdev-devel wlroots-devel wf-config-devel"
 short_desc="Wayfire shell with GTK-based panel and background client"
 maintainer="Young Jin Park <youngjinpark20@gmail.com>"
 license="MIT"
 homepage="https://wayfire.org"
-distfiles="https://github.com/WayfireWM/wf-shell/archive/${version}.tar.gz"
-checksum=625637fddf58a6a1825980e68d156ddb377cf4aae9bf5d844fb15aefee4c6f4f
+distfiles="https://github.com/WayfireWM/wf-shell/archive/${version}.tar.gz
+ https://github.com/wmww/gtk-layer-shell/archive/${_gtklayershell_hash}.zip
+ https://github.com/GNOME/libgnome-volume-control/archive/${_gvc_hash}.zip"
+checksum="326c732415a10215997c0915741fd561a306412327fae123eab67f1af9ee41de
+ a5f43f0f660a4147a2a50c51ee2214b29cf057c3bf0b439451a86b8cc21b9013
+ bf10e33e030f8a5a1ce903cd8201f0882532931d26d530d3ebe2aea174771fd0"
+nocross="gobject-introspection from gtk-layer-shell"
+
+post_extract() {
+	_gtklayershell_dir="${pkgname}-${version}/subprojects/gtk-layer-shell"
+	_gvc_dir="${pkgname}-${version}/subprojects/gvc"
+	rmdir ${_gtklayershell_dir} ${_gvc_dir}
+	mv gtk-layer-shell-${_gtklayershell_hash} ${_gtklayershell_dir}
+	mv libgnome-volume-control-${_gvc_hash} ${_gvc_dir}
+}
 
 post_install() {
 	vlicense LICENSE

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: [PR PATCH] [Updated] [Nomerge] sway: update to 1.2.
       [not found] <gh-mailinglist-notifications-41a7ca26-5023-4802-975b-f1789d68868e-void-packages-13999@inbox.vuxu.org>
                   ` (19 preceding siblings ...)
  2019-10-08 16:10 ` [PR PATCH] [Updated] " voidlinux-github
@ 2019-10-08 16:10 ` voidlinux-github
  2019-10-08 22:01 ` voidlinux-github
                   ` (7 subsequent siblings)
  28 siblings, 0 replies; 29+ messages in thread
From: voidlinux-github @ 2019-10-08 16:10 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 349 bytes --]

There is an updated pull request by travankor against master on the void-packages repository

https://github.com/travankor/void-packages sway
https://github.com/void-linux/void-packages/pull/13999

[Nomerge] sway: update to 1.2.
Wayfire needs to be updated.

A patch file from https://github.com/void-linux/void-packages/pull/13999.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-sway-13999.patch --]
[-- Type: text/x-diff, Size: 9237 bytes --]

From ad65e91b5bf1bb19850dc211a55cd71a0f3d1889 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 27 Aug 2019 03:04:57 -0700
Subject: [PATCH 1/5] sway: update to 1.2.

---
 srcpkgs/sway/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/sway/template b/srcpkgs/sway/template
index 574ff5f90cd..0a236516283 100644
--- a/srcpkgs/sway/template
+++ b/srcpkgs/sway/template
@@ -1,6 +1,6 @@
 # Template file for 'sway'
 pkgname=sway
-version=1.1.1
+version=1.2
 revision=1
 build_style=meson
 conf_files="/etc/sway/config"
@@ -13,7 +13,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://swaywm.org"
 distfiles="https://github.com/swaywm/${pkgname}/archive/${version}.tar.gz"
-checksum=740bf97556c54da83937a255113d715aaa05e05b44d61fbe85e01b53ff1f9922
+checksum=9f79382577ee132111c290b4d1a1a3e114ef485595c30cf5f181a11575bda846
 
 build_options="elogind"
 desc_option_elogind="Uses elogind instead of setuid for privilege escalation"

From f49bf1fcc77b8a4bc11a76100d1863d87eb0b003 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Mon, 7 Oct 2019 16:58:21 -0700
Subject: [PATCH 2/5] wlroots: update to 0.8.1.

---
 srcpkgs/wlroots/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/wlroots/template b/srcpkgs/wlroots/template
index 7b88e324827..75ddb338a15 100644
--- a/srcpkgs/wlroots/template
+++ b/srcpkgs/wlroots/template
@@ -1,23 +1,23 @@
 # Template file for 'wlroots'
 pkgname=wlroots
-version=0.6.0
-revision=2
+version=0.8.1
+revision=1
 build_style=meson
 configure_args="-Dlibcap=enabled -Dlogind=enabled -Dlogind-provider=elogind
  -Dxcb-errors=enabled -Dxcb-icccm=enabled -Dxwayland=enabled
- -Dx11-backend=enabled -Dexamples=false -Drootston=false"
+ -Dx11-backend=enabled -Dexamples=false"
 hostmakedepends="pkg-config wayland-devel"
 makedepends="elogind-devel libcap-devel wayland-devel wayland-protocols
  MesaLib-devel libinput-devel libxkbcommon-devel libdrm-devel pixman-devel
  libxcb-devel xcb-util-cursor-devel xcb-util-devel xcb-util-image-devel
  xcb-util-keysyms-devel xcb-util-renderutil-devel xcb-util-wm-devel
  xcb-util-errors-devel xcb-util-xrm-devel freerdp-devel"
-short_desc="Module Wayland compositor library"
+short_desc="Modular Wayland compositor library"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://github.com/swaywm/wlroots"
 distfiles="https://github.com/swaywm/wlroots/archive/${version}.tar.gz"
-checksum=9cf3716f3683d800df8b150f256ff66dad65faf13a9d67c284f67a9444d28c70
+checksum=202b86e0e21699b6660bbda56afc2e3358db7252f83ff69c89f01926b4900d98
 
 post_install() {
 	vlicense LICENSE

From 86fbace24f00293d7d098849e9a332e92a6c6457 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 8 Oct 2019 02:36:29 -0700
Subject: [PATCH 3/5] wf-config: update to 0.3.

---
 common/shlibs                            |  2 +-
 srcpkgs/wf-config-devel                  |  1 +
 srcpkgs/wf-config/patches/fix-musl.patch | 13 -------------
 srcpkgs/wf-config/template               | 20 ++++++++++++++------
 4 files changed, 16 insertions(+), 20 deletions(-)
 create mode 120000 srcpkgs/wf-config-devel
 delete mode 100644 srcpkgs/wf-config/patches/fix-musl.patch

diff --git a/common/shlibs b/common/shlibs
index 688275b7d9e..8be530d3a22 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -3411,7 +3411,7 @@ libsnore-qt5.so.0.7 snorenotify-0.7.0_1
 libsnoresettings-qt5.so.0.7 snorenotify-0.7.0_1
 libTECkit.so.0 libteckit-2.5.8_1
 libTECkit_Compiler.so.0 libteckit-2.5.8_1
-libwf-config.so wf-config-0.1_1
+libwf-config.so.0 wf-config-0.3_1
 libQt5Pas.so.1 qt5pas-2.6~beta_1
 libClp.so.1 libClp-1.16.11_1
 libCoinUtils.so.3 libClp-1.16.11_1
diff --git a/srcpkgs/wf-config-devel b/srcpkgs/wf-config-devel
new file mode 120000
index 00000000000..fb3df2e900c
--- /dev/null
+++ b/srcpkgs/wf-config-devel
@@ -0,0 +1 @@
+wf-config/
\ No newline at end of file
diff --git a/srcpkgs/wf-config/patches/fix-musl.patch b/srcpkgs/wf-config/patches/fix-musl.patch
deleted file mode 100644
index b87797ba555..00000000000
--- a/srcpkgs/wf-config/patches/fix-musl.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/config.cpp b/src/config.cpp
-index f586ab5..811ce29 100644
---- src/config.cpp
-+++ src/config.cpp
-@@ -4,6 +4,7 @@
- #include <sstream>
- #include <fstream>
- #include <algorithm>
-+#include <fcntl.h>
- 
- std::ofstream out;
- 
-
diff --git a/srcpkgs/wf-config/template b/srcpkgs/wf-config/template
index 98eee65d39e..adee709a060 100644
--- a/srcpkgs/wf-config/template
+++ b/srcpkgs/wf-config/template
@@ -1,6 +1,6 @@
 # Template file for 'wf-config'
 pkgname=wf-config
-version=0.1
+version=0.3
 revision=1
 build_style=meson
 hostmakedepends="pkg-config"
@@ -9,11 +9,19 @@ short_desc="Wayfire library for managing configuration files"
 maintainer="Young Jin Park <youngjinpark20@gmail.com>"
 license="MIT"
 homepage="https://wayfire.org"
-distfiles="https://github.com/WayfireWM/wf-config/archive/v${version}.tar.gz
- https://raw.githubusercontent.com/WayfireWM/wf-config/master/LICENSE>LICENSE.txt"
-checksum="0dac4683013d5a0b143f0e211288c7f2f621740b9ac664359297ff530a7dcdc5
- 7053b1aa75aaccfe2a2bfacd400c0a8694858797ff9c7d584664e2941fb3016e"
+distfiles="https://github.com/WayfireWM/wf-config/archive/${version}.tar.gz"
+checksum=5d1a5038b11a177174b392f3b383d787f568265ce483a5be9178698f548f7c66
 
 post_install() {
-	vlicense ../LICENSE.txt
+	vlicense LICENSE
+}
+
+wf-config-devel_package() {
+	depends="libevdev-devel wlroots-devel wf-config>=${version}_${revision}"
+	short_desc+=" - development files"
+	pkg_install() {
+		vmove usr/include
+		vmove usr/lib/pkgconfig
+		vmove "usr/lib/*.so"
+	}
 }

From e18c3c1dd0c1cac1b42baffa8c32ed272f894775 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 8 Oct 2019 09:08:01 -0700
Subject: [PATCH 4/5] wayfire: update to 0.3.0.

---
 srcpkgs/wayfire/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/wayfire/template b/srcpkgs/wayfire/template
index 2ee4bd17ae9..c5e31d12414 100644
--- a/srcpkgs/wayfire/template
+++ b/srcpkgs/wayfire/template
@@ -1,16 +1,16 @@
 # Template file for 'wayfire'
 pkgname=wayfire
-version=0.2
+version=0.3.0
 revision=1
 build_style=meson
 hostmakedepends="pkg-config wayland-devel"
-makedepends="wlroots-devel glm cairo-devel wf-config"
+makedepends="wlroots-devel glm cairo-devel wf-config-devel"
 short_desc="3D wayland compositor"
 maintainer="Young Jin Park <youngjinpark20@gmail.com>"
 license="MIT"
 homepage="https://wayfire.org"
-distfiles="https://github.com/WayfireWM/wayfire/archive/v${version}.tar.gz"
-checksum=94fe93bb2b86048fd1c7601f97b167767e19618bb6b6226e21c22fbd052540bf
+distfiles="https://github.com/WayfireWM/wayfire/archive/${version}.tar.gz"
+checksum=c686bf5abb7f0db829196785bba4136c85d7b52d701212e21636dad75e1da0aa
 
 case $XBPS_TARGET_MACHINE in
 	*-musl) makedepends+=" libexecinfo-devel"

From 40a96f836bffbca095e09fea11cfe523597d20ec Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 8 Oct 2019 09:08:34 -0700
Subject: [PATCH 5/5] wf-shell: update to 0.3.

---
 srcpkgs/wf-shell/template | 28 +++++++++++++++++++++++-----
 1 file changed, 23 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/wf-shell/template b/srcpkgs/wf-shell/template
index ccfd8c574a0..7be6c4bbec3 100644
--- a/srcpkgs/wf-shell/template
+++ b/srcpkgs/wf-shell/template
@@ -1,16 +1,34 @@
 # Template file for 'wf-shell'
 pkgname=wf-shell
-version=0.1
+version=0.3
 revision=1
+_gtklayershell_hash="d1f9d94be32f8cc61c0a53af7558146570f0fa9f"
+_gvc_hash="468022b708fc1a56154f3b0cc5af3b938fb3e9fb"
+create_wrksrc=yes
+build_wrksrc=${pkgname}-${version}
 build_style=meson
-hostmakedepends="pkg-config wayland-devel"
-makedepends="gtkmm-devel libevdev-devel wlroots-devel wf-config"
+hostmakedepends="gobject-introspection pkg-config unzip wayland-devel"
+makedepends="alsa-lib-devel pulseaudio-devel gtkmm-devel
+ gtk+3-devel libevdev-devel wlroots-devel wf-config-devel"
 short_desc="Wayfire shell with GTK-based panel and background client"
 maintainer="Young Jin Park <youngjinpark20@gmail.com>"
 license="MIT"
 homepage="https://wayfire.org"
-distfiles="https://github.com/WayfireWM/wf-shell/archive/${version}.tar.gz"
-checksum=625637fddf58a6a1825980e68d156ddb377cf4aae9bf5d844fb15aefee4c6f4f
+distfiles="https://github.com/WayfireWM/wf-shell/archive/${version}.tar.gz
+ https://github.com/wmww/gtk-layer-shell/archive/${_gtklayershell_hash}.zip
+ https://github.com/GNOME/libgnome-volume-control/archive/${_gvc_hash}.zip"
+checksum="326c732415a10215997c0915741fd561a306412327fae123eab67f1af9ee41de
+ a5f43f0f660a4147a2a50c51ee2214b29cf057c3bf0b439451a86b8cc21b9013
+ bf10e33e030f8a5a1ce903cd8201f0882532931d26d530d3ebe2aea174771fd0"
+nocross="gobject-introspection from gtk-layer-shell"
+
+post_extract() {
+	_gtklayershell_dir="${pkgname}-${version}/subprojects/gtk-layer-shell"
+	_gvc_dir="${pkgname}-${version}/subprojects/gvc"
+	rmdir ${_gtklayershell_dir} ${_gvc_dir}
+	mv gtk-layer-shell-${_gtklayershell_hash} ${_gtklayershell_dir}
+	mv libgnome-volume-control-${_gvc_hash} ${_gvc_dir}
+}
 
 post_install() {
 	vlicense LICENSE

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: [Nomerge] sway: update to 1.2.
       [not found] <gh-mailinglist-notifications-41a7ca26-5023-4802-975b-f1789d68868e-void-packages-13999@inbox.vuxu.org>
                   ` (20 preceding siblings ...)
  2019-10-08 16:10 ` voidlinux-github
@ 2019-10-08 22:01 ` voidlinux-github
  2019-10-10  6:33 ` [PR PATCH] [Updated] " voidlinux-github
                   ` (6 subsequent siblings)
  28 siblings, 0 replies; 29+ messages in thread
From: voidlinux-github @ 2019-10-08 22:01 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 425 bytes --]

New comment by Wychmire on void-packages repository

https://github.com/void-linux/void-packages/pull/13999#issuecomment-539722222

Comment:
tested on x86_64 glibc:

Wayfire runs. It's definitely buggy but I think that might just be because it's alpha software. I can't figure out how to exit alt+tab mode w/o killing Wayfire. The wobbly windows are wonderful :D

Sway 1.2 / wlroots 0.8.1  is working smoothly as well.


^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: [PR PATCH] [Updated] [Nomerge] sway: update to 1.2.
       [not found] <gh-mailinglist-notifications-41a7ca26-5023-4802-975b-f1789d68868e-void-packages-13999@inbox.vuxu.org>
                   ` (21 preceding siblings ...)
  2019-10-08 22:01 ` voidlinux-github
@ 2019-10-10  6:33 ` voidlinux-github
  2019-10-10  6:33 ` voidlinux-github
                   ` (5 subsequent siblings)
  28 siblings, 0 replies; 29+ messages in thread
From: voidlinux-github @ 2019-10-10  6:33 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 349 bytes --]

There is an updated pull request by travankor against master on the void-packages repository

https://github.com/travankor/void-packages sway
https://github.com/void-linux/void-packages/pull/13999

[Nomerge] sway: update to 1.2.
Wayfire needs to be updated.

A patch file from https://github.com/void-linux/void-packages/pull/13999.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-sway-13999.patch --]
[-- Type: text/x-diff, Size: 9225 bytes --]

From ad65e91b5bf1bb19850dc211a55cd71a0f3d1889 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 27 Aug 2019 03:04:57 -0700
Subject: [PATCH 1/5] sway: update to 1.2.

---
 srcpkgs/sway/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/sway/template b/srcpkgs/sway/template
index 574ff5f90cd..0a236516283 100644
--- a/srcpkgs/sway/template
+++ b/srcpkgs/sway/template
@@ -1,6 +1,6 @@
 # Template file for 'sway'
 pkgname=sway
-version=1.1.1
+version=1.2
 revision=1
 build_style=meson
 conf_files="/etc/sway/config"
@@ -13,7 +13,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://swaywm.org"
 distfiles="https://github.com/swaywm/${pkgname}/archive/${version}.tar.gz"
-checksum=740bf97556c54da83937a255113d715aaa05e05b44d61fbe85e01b53ff1f9922
+checksum=9f79382577ee132111c290b4d1a1a3e114ef485595c30cf5f181a11575bda846
 
 build_options="elogind"
 desc_option_elogind="Uses elogind instead of setuid for privilege escalation"

From f49bf1fcc77b8a4bc11a76100d1863d87eb0b003 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Mon, 7 Oct 2019 16:58:21 -0700
Subject: [PATCH 2/5] wlroots: update to 0.8.1.

---
 srcpkgs/wlroots/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/wlroots/template b/srcpkgs/wlroots/template
index 7b88e324827..75ddb338a15 100644
--- a/srcpkgs/wlroots/template
+++ b/srcpkgs/wlroots/template
@@ -1,23 +1,23 @@
 # Template file for 'wlroots'
 pkgname=wlroots
-version=0.6.0
-revision=2
+version=0.8.1
+revision=1
 build_style=meson
 configure_args="-Dlibcap=enabled -Dlogind=enabled -Dlogind-provider=elogind
  -Dxcb-errors=enabled -Dxcb-icccm=enabled -Dxwayland=enabled
- -Dx11-backend=enabled -Dexamples=false -Drootston=false"
+ -Dx11-backend=enabled -Dexamples=false"
 hostmakedepends="pkg-config wayland-devel"
 makedepends="elogind-devel libcap-devel wayland-devel wayland-protocols
  MesaLib-devel libinput-devel libxkbcommon-devel libdrm-devel pixman-devel
  libxcb-devel xcb-util-cursor-devel xcb-util-devel xcb-util-image-devel
  xcb-util-keysyms-devel xcb-util-renderutil-devel xcb-util-wm-devel
  xcb-util-errors-devel xcb-util-xrm-devel freerdp-devel"
-short_desc="Module Wayland compositor library"
+short_desc="Modular Wayland compositor library"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://github.com/swaywm/wlroots"
 distfiles="https://github.com/swaywm/wlroots/archive/${version}.tar.gz"
-checksum=9cf3716f3683d800df8b150f256ff66dad65faf13a9d67c284f67a9444d28c70
+checksum=202b86e0e21699b6660bbda56afc2e3358db7252f83ff69c89f01926b4900d98
 
 post_install() {
 	vlicense LICENSE

From 86fbace24f00293d7d098849e9a332e92a6c6457 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 8 Oct 2019 02:36:29 -0700
Subject: [PATCH 3/5] wf-config: update to 0.3.

---
 common/shlibs                            |  2 +-
 srcpkgs/wf-config-devel                  |  1 +
 srcpkgs/wf-config/patches/fix-musl.patch | 13 -------------
 srcpkgs/wf-config/template               | 20 ++++++++++++++------
 4 files changed, 16 insertions(+), 20 deletions(-)
 create mode 120000 srcpkgs/wf-config-devel
 delete mode 100644 srcpkgs/wf-config/patches/fix-musl.patch

diff --git a/common/shlibs b/common/shlibs
index 688275b7d9e..8be530d3a22 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -3411,7 +3411,7 @@ libsnore-qt5.so.0.7 snorenotify-0.7.0_1
 libsnoresettings-qt5.so.0.7 snorenotify-0.7.0_1
 libTECkit.so.0 libteckit-2.5.8_1
 libTECkit_Compiler.so.0 libteckit-2.5.8_1
-libwf-config.so wf-config-0.1_1
+libwf-config.so.0 wf-config-0.3_1
 libQt5Pas.so.1 qt5pas-2.6~beta_1
 libClp.so.1 libClp-1.16.11_1
 libCoinUtils.so.3 libClp-1.16.11_1
diff --git a/srcpkgs/wf-config-devel b/srcpkgs/wf-config-devel
new file mode 120000
index 00000000000..fb3df2e900c
--- /dev/null
+++ b/srcpkgs/wf-config-devel
@@ -0,0 +1 @@
+wf-config/
\ No newline at end of file
diff --git a/srcpkgs/wf-config/patches/fix-musl.patch b/srcpkgs/wf-config/patches/fix-musl.patch
deleted file mode 100644
index b87797ba555..00000000000
--- a/srcpkgs/wf-config/patches/fix-musl.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/config.cpp b/src/config.cpp
-index f586ab5..811ce29 100644
---- src/config.cpp
-+++ src/config.cpp
-@@ -4,6 +4,7 @@
- #include <sstream>
- #include <fstream>
- #include <algorithm>
-+#include <fcntl.h>
- 
- std::ofstream out;
- 
-
diff --git a/srcpkgs/wf-config/template b/srcpkgs/wf-config/template
index 98eee65d39e..adee709a060 100644
--- a/srcpkgs/wf-config/template
+++ b/srcpkgs/wf-config/template
@@ -1,6 +1,6 @@
 # Template file for 'wf-config'
 pkgname=wf-config
-version=0.1
+version=0.3
 revision=1
 build_style=meson
 hostmakedepends="pkg-config"
@@ -9,11 +9,19 @@ short_desc="Wayfire library for managing configuration files"
 maintainer="Young Jin Park <youngjinpark20@gmail.com>"
 license="MIT"
 homepage="https://wayfire.org"
-distfiles="https://github.com/WayfireWM/wf-config/archive/v${version}.tar.gz
- https://raw.githubusercontent.com/WayfireWM/wf-config/master/LICENSE>LICENSE.txt"
-checksum="0dac4683013d5a0b143f0e211288c7f2f621740b9ac664359297ff530a7dcdc5
- 7053b1aa75aaccfe2a2bfacd400c0a8694858797ff9c7d584664e2941fb3016e"
+distfiles="https://github.com/WayfireWM/wf-config/archive/${version}.tar.gz"
+checksum=5d1a5038b11a177174b392f3b383d787f568265ce483a5be9178698f548f7c66
 
 post_install() {
-	vlicense ../LICENSE.txt
+	vlicense LICENSE
+}
+
+wf-config-devel_package() {
+	depends="libevdev-devel wlroots-devel wf-config>=${version}_${revision}"
+	short_desc+=" - development files"
+	pkg_install() {
+		vmove usr/include
+		vmove usr/lib/pkgconfig
+		vmove "usr/lib/*.so"
+	}
 }

From e18c3c1dd0c1cac1b42baffa8c32ed272f894775 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 8 Oct 2019 09:08:01 -0700
Subject: [PATCH 4/5] wayfire: update to 0.3.0.

---
 srcpkgs/wayfire/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/wayfire/template b/srcpkgs/wayfire/template
index 2ee4bd17ae9..c5e31d12414 100644
--- a/srcpkgs/wayfire/template
+++ b/srcpkgs/wayfire/template
@@ -1,16 +1,16 @@
 # Template file for 'wayfire'
 pkgname=wayfire
-version=0.2
+version=0.3.0
 revision=1
 build_style=meson
 hostmakedepends="pkg-config wayland-devel"
-makedepends="wlroots-devel glm cairo-devel wf-config"
+makedepends="wlroots-devel glm cairo-devel wf-config-devel"
 short_desc="3D wayland compositor"
 maintainer="Young Jin Park <youngjinpark20@gmail.com>"
 license="MIT"
 homepage="https://wayfire.org"
-distfiles="https://github.com/WayfireWM/wayfire/archive/v${version}.tar.gz"
-checksum=94fe93bb2b86048fd1c7601f97b167767e19618bb6b6226e21c22fbd052540bf
+distfiles="https://github.com/WayfireWM/wayfire/archive/${version}.tar.gz"
+checksum=c686bf5abb7f0db829196785bba4136c85d7b52d701212e21636dad75e1da0aa
 
 case $XBPS_TARGET_MACHINE in
 	*-musl) makedepends+=" libexecinfo-devel"

From 72b26f8694be78c540c46247af04b925dd481806 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 8 Oct 2019 09:08:34 -0700
Subject: [PATCH 5/5] wf-shell: update to 0.3.

---
 srcpkgs/wf-shell/template | 28 +++++++++++++++++++++++-----
 1 file changed, 23 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/wf-shell/template b/srcpkgs/wf-shell/template
index ccfd8c574a0..d9163376795 100644
--- a/srcpkgs/wf-shell/template
+++ b/srcpkgs/wf-shell/template
@@ -1,16 +1,34 @@
 # Template file for 'wf-shell'
 pkgname=wf-shell
-version=0.1
+version=0.3
 revision=1
+_gtklayershell_hash="d1f9d94be32f8cc61c0a53af7558146570f0fa9f"
+_gvc_hash="468022b708fc1a56154f3b0cc5af3b938fb3e9fb"
+create_wrksrc=yes
+build_wrksrc=${pkgname}-${version}
 build_style=meson
-hostmakedepends="pkg-config wayland-devel"
-makedepends="gtkmm-devel libevdev-devel wlroots-devel wf-config"
+hostmakedepends="gobject-introspection pkg-config wayland-devel"
+makedepends="alsa-lib-devel pulseaudio-devel gtkmm-devel
+ gtk+3-devel libevdev-devel wlroots-devel wf-config-devel"
 short_desc="Wayfire shell with GTK-based panel and background client"
 maintainer="Young Jin Park <youngjinpark20@gmail.com>"
 license="MIT"
 homepage="https://wayfire.org"
-distfiles="https://github.com/WayfireWM/wf-shell/archive/${version}.tar.gz"
-checksum=625637fddf58a6a1825980e68d156ddb377cf4aae9bf5d844fb15aefee4c6f4f
+distfiles="https://github.com/WayfireWM/wf-shell/archive/${version}.tar.gz
+ https://github.com/wmww/gtk-layer-shell/archive/${_gtklayershell_hash}.tar.gz
+ https://github.com/GNOME/libgnome-volume-control/archive/${_gvc_hash}.tar.gz"
+checksum="326c732415a10215997c0915741fd561a306412327fae123eab67f1af9ee41de
+ 0b66a943375e3c8f597ca293f8e0ca0cfa585163ed5a7dfb7956c02147c40c17
+ 3ab63b0073bf21cab80b3974c9f6aa969ff1a4c4911aae6a09681c7d1b2b785f"
+nocross="gobject-introspection from gtk-layer-shell"
+
+post_extract() {
+	_gtklayershell_dir="${build_wrksrc}/subprojects/gtk-layer-shell"
+	_gvc_dir="${build_wrksrc}/subprojects/gvc"
+	rmdir ${_gtklayershell_dir} ${_gvc_dir}
+	mv gtk-layer-shell-${_gtklayershell_hash} ${_gtklayershell_dir}
+	mv libgnome-volume-control-${_gvc_hash} ${_gvc_dir}
+}
 
 post_install() {
 	vlicense LICENSE

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: [PR PATCH] [Updated] [Nomerge] sway: update to 1.2.
       [not found] <gh-mailinglist-notifications-41a7ca26-5023-4802-975b-f1789d68868e-void-packages-13999@inbox.vuxu.org>
                   ` (22 preceding siblings ...)
  2019-10-10  6:33 ` [PR PATCH] [Updated] " voidlinux-github
@ 2019-10-10  6:33 ` voidlinux-github
  2019-10-10  7:14 ` voidlinux-github
                   ` (4 subsequent siblings)
  28 siblings, 0 replies; 29+ messages in thread
From: voidlinux-github @ 2019-10-10  6:33 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 349 bytes --]

There is an updated pull request by travankor against master on the void-packages repository

https://github.com/travankor/void-packages sway
https://github.com/void-linux/void-packages/pull/13999

[Nomerge] sway: update to 1.2.
Wayfire needs to be updated.

A patch file from https://github.com/void-linux/void-packages/pull/13999.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-sway-13999.patch --]
[-- Type: text/x-diff, Size: 9225 bytes --]

From ad65e91b5bf1bb19850dc211a55cd71a0f3d1889 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 27 Aug 2019 03:04:57 -0700
Subject: [PATCH 1/5] sway: update to 1.2.

---
 srcpkgs/sway/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/sway/template b/srcpkgs/sway/template
index 574ff5f90cd..0a236516283 100644
--- a/srcpkgs/sway/template
+++ b/srcpkgs/sway/template
@@ -1,6 +1,6 @@
 # Template file for 'sway'
 pkgname=sway
-version=1.1.1
+version=1.2
 revision=1
 build_style=meson
 conf_files="/etc/sway/config"
@@ -13,7 +13,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://swaywm.org"
 distfiles="https://github.com/swaywm/${pkgname}/archive/${version}.tar.gz"
-checksum=740bf97556c54da83937a255113d715aaa05e05b44d61fbe85e01b53ff1f9922
+checksum=9f79382577ee132111c290b4d1a1a3e114ef485595c30cf5f181a11575bda846
 
 build_options="elogind"
 desc_option_elogind="Uses elogind instead of setuid for privilege escalation"

From f49bf1fcc77b8a4bc11a76100d1863d87eb0b003 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Mon, 7 Oct 2019 16:58:21 -0700
Subject: [PATCH 2/5] wlroots: update to 0.8.1.

---
 srcpkgs/wlroots/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/wlroots/template b/srcpkgs/wlroots/template
index 7b88e324827..75ddb338a15 100644
--- a/srcpkgs/wlroots/template
+++ b/srcpkgs/wlroots/template
@@ -1,23 +1,23 @@
 # Template file for 'wlroots'
 pkgname=wlroots
-version=0.6.0
-revision=2
+version=0.8.1
+revision=1
 build_style=meson
 configure_args="-Dlibcap=enabled -Dlogind=enabled -Dlogind-provider=elogind
  -Dxcb-errors=enabled -Dxcb-icccm=enabled -Dxwayland=enabled
- -Dx11-backend=enabled -Dexamples=false -Drootston=false"
+ -Dx11-backend=enabled -Dexamples=false"
 hostmakedepends="pkg-config wayland-devel"
 makedepends="elogind-devel libcap-devel wayland-devel wayland-protocols
  MesaLib-devel libinput-devel libxkbcommon-devel libdrm-devel pixman-devel
  libxcb-devel xcb-util-cursor-devel xcb-util-devel xcb-util-image-devel
  xcb-util-keysyms-devel xcb-util-renderutil-devel xcb-util-wm-devel
  xcb-util-errors-devel xcb-util-xrm-devel freerdp-devel"
-short_desc="Module Wayland compositor library"
+short_desc="Modular Wayland compositor library"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://github.com/swaywm/wlroots"
 distfiles="https://github.com/swaywm/wlroots/archive/${version}.tar.gz"
-checksum=9cf3716f3683d800df8b150f256ff66dad65faf13a9d67c284f67a9444d28c70
+checksum=202b86e0e21699b6660bbda56afc2e3358db7252f83ff69c89f01926b4900d98
 
 post_install() {
 	vlicense LICENSE

From 86fbace24f00293d7d098849e9a332e92a6c6457 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 8 Oct 2019 02:36:29 -0700
Subject: [PATCH 3/5] wf-config: update to 0.3.

---
 common/shlibs                            |  2 +-
 srcpkgs/wf-config-devel                  |  1 +
 srcpkgs/wf-config/patches/fix-musl.patch | 13 -------------
 srcpkgs/wf-config/template               | 20 ++++++++++++++------
 4 files changed, 16 insertions(+), 20 deletions(-)
 create mode 120000 srcpkgs/wf-config-devel
 delete mode 100644 srcpkgs/wf-config/patches/fix-musl.patch

diff --git a/common/shlibs b/common/shlibs
index 688275b7d9e..8be530d3a22 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -3411,7 +3411,7 @@ libsnore-qt5.so.0.7 snorenotify-0.7.0_1
 libsnoresettings-qt5.so.0.7 snorenotify-0.7.0_1
 libTECkit.so.0 libteckit-2.5.8_1
 libTECkit_Compiler.so.0 libteckit-2.5.8_1
-libwf-config.so wf-config-0.1_1
+libwf-config.so.0 wf-config-0.3_1
 libQt5Pas.so.1 qt5pas-2.6~beta_1
 libClp.so.1 libClp-1.16.11_1
 libCoinUtils.so.3 libClp-1.16.11_1
diff --git a/srcpkgs/wf-config-devel b/srcpkgs/wf-config-devel
new file mode 120000
index 00000000000..fb3df2e900c
--- /dev/null
+++ b/srcpkgs/wf-config-devel
@@ -0,0 +1 @@
+wf-config/
\ No newline at end of file
diff --git a/srcpkgs/wf-config/patches/fix-musl.patch b/srcpkgs/wf-config/patches/fix-musl.patch
deleted file mode 100644
index b87797ba555..00000000000
--- a/srcpkgs/wf-config/patches/fix-musl.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/config.cpp b/src/config.cpp
-index f586ab5..811ce29 100644
---- src/config.cpp
-+++ src/config.cpp
-@@ -4,6 +4,7 @@
- #include <sstream>
- #include <fstream>
- #include <algorithm>
-+#include <fcntl.h>
- 
- std::ofstream out;
- 
-
diff --git a/srcpkgs/wf-config/template b/srcpkgs/wf-config/template
index 98eee65d39e..adee709a060 100644
--- a/srcpkgs/wf-config/template
+++ b/srcpkgs/wf-config/template
@@ -1,6 +1,6 @@
 # Template file for 'wf-config'
 pkgname=wf-config
-version=0.1
+version=0.3
 revision=1
 build_style=meson
 hostmakedepends="pkg-config"
@@ -9,11 +9,19 @@ short_desc="Wayfire library for managing configuration files"
 maintainer="Young Jin Park <youngjinpark20@gmail.com>"
 license="MIT"
 homepage="https://wayfire.org"
-distfiles="https://github.com/WayfireWM/wf-config/archive/v${version}.tar.gz
- https://raw.githubusercontent.com/WayfireWM/wf-config/master/LICENSE>LICENSE.txt"
-checksum="0dac4683013d5a0b143f0e211288c7f2f621740b9ac664359297ff530a7dcdc5
- 7053b1aa75aaccfe2a2bfacd400c0a8694858797ff9c7d584664e2941fb3016e"
+distfiles="https://github.com/WayfireWM/wf-config/archive/${version}.tar.gz"
+checksum=5d1a5038b11a177174b392f3b383d787f568265ce483a5be9178698f548f7c66
 
 post_install() {
-	vlicense ../LICENSE.txt
+	vlicense LICENSE
+}
+
+wf-config-devel_package() {
+	depends="libevdev-devel wlroots-devel wf-config>=${version}_${revision}"
+	short_desc+=" - development files"
+	pkg_install() {
+		vmove usr/include
+		vmove usr/lib/pkgconfig
+		vmove "usr/lib/*.so"
+	}
 }

From e18c3c1dd0c1cac1b42baffa8c32ed272f894775 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 8 Oct 2019 09:08:01 -0700
Subject: [PATCH 4/5] wayfire: update to 0.3.0.

---
 srcpkgs/wayfire/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/wayfire/template b/srcpkgs/wayfire/template
index 2ee4bd17ae9..c5e31d12414 100644
--- a/srcpkgs/wayfire/template
+++ b/srcpkgs/wayfire/template
@@ -1,16 +1,16 @@
 # Template file for 'wayfire'
 pkgname=wayfire
-version=0.2
+version=0.3.0
 revision=1
 build_style=meson
 hostmakedepends="pkg-config wayland-devel"
-makedepends="wlroots-devel glm cairo-devel wf-config"
+makedepends="wlroots-devel glm cairo-devel wf-config-devel"
 short_desc="3D wayland compositor"
 maintainer="Young Jin Park <youngjinpark20@gmail.com>"
 license="MIT"
 homepage="https://wayfire.org"
-distfiles="https://github.com/WayfireWM/wayfire/archive/v${version}.tar.gz"
-checksum=94fe93bb2b86048fd1c7601f97b167767e19618bb6b6226e21c22fbd052540bf
+distfiles="https://github.com/WayfireWM/wayfire/archive/${version}.tar.gz"
+checksum=c686bf5abb7f0db829196785bba4136c85d7b52d701212e21636dad75e1da0aa
 
 case $XBPS_TARGET_MACHINE in
 	*-musl) makedepends+=" libexecinfo-devel"

From 72b26f8694be78c540c46247af04b925dd481806 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 8 Oct 2019 09:08:34 -0700
Subject: [PATCH 5/5] wf-shell: update to 0.3.

---
 srcpkgs/wf-shell/template | 28 +++++++++++++++++++++++-----
 1 file changed, 23 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/wf-shell/template b/srcpkgs/wf-shell/template
index ccfd8c574a0..d9163376795 100644
--- a/srcpkgs/wf-shell/template
+++ b/srcpkgs/wf-shell/template
@@ -1,16 +1,34 @@
 # Template file for 'wf-shell'
 pkgname=wf-shell
-version=0.1
+version=0.3
 revision=1
+_gtklayershell_hash="d1f9d94be32f8cc61c0a53af7558146570f0fa9f"
+_gvc_hash="468022b708fc1a56154f3b0cc5af3b938fb3e9fb"
+create_wrksrc=yes
+build_wrksrc=${pkgname}-${version}
 build_style=meson
-hostmakedepends="pkg-config wayland-devel"
-makedepends="gtkmm-devel libevdev-devel wlroots-devel wf-config"
+hostmakedepends="gobject-introspection pkg-config wayland-devel"
+makedepends="alsa-lib-devel pulseaudio-devel gtkmm-devel
+ gtk+3-devel libevdev-devel wlroots-devel wf-config-devel"
 short_desc="Wayfire shell with GTK-based panel and background client"
 maintainer="Young Jin Park <youngjinpark20@gmail.com>"
 license="MIT"
 homepage="https://wayfire.org"
-distfiles="https://github.com/WayfireWM/wf-shell/archive/${version}.tar.gz"
-checksum=625637fddf58a6a1825980e68d156ddb377cf4aae9bf5d844fb15aefee4c6f4f
+distfiles="https://github.com/WayfireWM/wf-shell/archive/${version}.tar.gz
+ https://github.com/wmww/gtk-layer-shell/archive/${_gtklayershell_hash}.tar.gz
+ https://github.com/GNOME/libgnome-volume-control/archive/${_gvc_hash}.tar.gz"
+checksum="326c732415a10215997c0915741fd561a306412327fae123eab67f1af9ee41de
+ 0b66a943375e3c8f597ca293f8e0ca0cfa585163ed5a7dfb7956c02147c40c17
+ 3ab63b0073bf21cab80b3974c9f6aa969ff1a4c4911aae6a09681c7d1b2b785f"
+nocross="gobject-introspection from gtk-layer-shell"
+
+post_extract() {
+	_gtklayershell_dir="${build_wrksrc}/subprojects/gtk-layer-shell"
+	_gvc_dir="${build_wrksrc}/subprojects/gvc"
+	rmdir ${_gtklayershell_dir} ${_gvc_dir}
+	mv gtk-layer-shell-${_gtklayershell_hash} ${_gtklayershell_dir}
+	mv libgnome-volume-control-${_gvc_hash} ${_gvc_dir}
+}
 
 post_install() {
 	vlicense LICENSE

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: sway: update to 1.2.
       [not found] <gh-mailinglist-notifications-41a7ca26-5023-4802-975b-f1789d68868e-void-packages-13999@inbox.vuxu.org>
                   ` (23 preceding siblings ...)
  2019-10-10  6:33 ` voidlinux-github
@ 2019-10-10  7:14 ` voidlinux-github
  2019-10-11 14:19 ` voidlinux-github
                   ` (3 subsequent siblings)
  28 siblings, 0 replies; 29+ messages in thread
From: voidlinux-github @ 2019-10-10  7:14 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 429 bytes --]

New comment by travankor on void-packages repository

https://github.com/void-linux/void-packages/pull/13999#issuecomment-540426115

Comment:
>Wayfire runs. It's definitely buggy but I think that might just be because it's alpha software. I can't figure out how to exit alt+tab mode w/o killing Wayfire. The wobbly windows are wonderful :D

Nice :)

Wayfire and Sway both run well for me too. I think this is ready to merge.

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: sway: update to 1.2.
       [not found] <gh-mailinglist-notifications-41a7ca26-5023-4802-975b-f1789d68868e-void-packages-13999@inbox.vuxu.org>
                   ` (24 preceding siblings ...)
  2019-10-10  7:14 ` voidlinux-github
@ 2019-10-11 14:19 ` voidlinux-github
  2019-10-11 14:19 ` voidlinux-github
                   ` (2 subsequent siblings)
  28 siblings, 0 replies; 29+ messages in thread
From: voidlinux-github @ 2019-10-11 14:19 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 233 bytes --]

New comment by Wychmire on void-packages repository

https://github.com/void-linux/void-packages/pull/13999#issuecomment-541084202

Comment:
Sway, Wayfire (and deps: wf-config and wf-shell), Wlroots all build on x86_64-musl as well.

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: sway: update to 1.2.
       [not found] <gh-mailinglist-notifications-41a7ca26-5023-4802-975b-f1789d68868e-void-packages-13999@inbox.vuxu.org>
                   ` (25 preceding siblings ...)
  2019-10-11 14:19 ` voidlinux-github
@ 2019-10-11 14:19 ` voidlinux-github
  2019-10-11 15:15 ` voidlinux-github
  2019-10-15 17:45 ` [PR PATCH] [Merged]: " voidlinux-github
  28 siblings, 0 replies; 29+ messages in thread
From: voidlinux-github @ 2019-10-11 14:19 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 275 bytes --]

New comment by Wychmire on void-packages repository

https://github.com/void-linux/void-packages/pull/13999#issuecomment-541084202

Comment:
Sway, Wayfire (and deps: wf-config and wf-shell), Wlroots all compile on x86_64-musl as well.

(edit: changed "build" to "compile")

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: sway: update to 1.2.
       [not found] <gh-mailinglist-notifications-41a7ca26-5023-4802-975b-f1789d68868e-void-packages-13999@inbox.vuxu.org>
                   ` (26 preceding siblings ...)
  2019-10-11 14:19 ` voidlinux-github
@ 2019-10-11 15:15 ` voidlinux-github
  2019-10-15 17:45 ` [PR PATCH] [Merged]: " voidlinux-github
  28 siblings, 0 replies; 29+ messages in thread
From: voidlinux-github @ 2019-10-11 15:15 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 235 bytes --]

New comment by Wychmire on void-packages repository

https://github.com/void-linux/void-packages/pull/13999#issuecomment-541084202

Comment:
Sway, Wayfire (and deps: wf-config and wf-shell), Wlroots all compile on x86_64-musl as well.

^ permalink raw reply	[flat|nested] 29+ messages in thread

* Re: [PR PATCH] [Merged]: sway: update to 1.2.
       [not found] <gh-mailinglist-notifications-41a7ca26-5023-4802-975b-f1789d68868e-void-packages-13999@inbox.vuxu.org>
                   ` (27 preceding siblings ...)
  2019-10-11 15:15 ` voidlinux-github
@ 2019-10-15 17:45 ` voidlinux-github
  28 siblings, 0 replies; 29+ messages in thread
From: voidlinux-github @ 2019-10-15 17:45 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 182 bytes --]

There's a merged pull request on the void-packages repository

sway: update to 1.2.
https://github.com/void-linux/void-packages/pull/13999

Description:
Wayfire needs to be updated.

^ permalink raw reply	[flat|nested] 29+ messages in thread

end of thread, back to index

Thread overview: 29+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
     [not found] <gh-mailinglist-notifications-41a7ca26-5023-4802-975b-f1789d68868e-void-packages-13999@inbox.vuxu.org>
2019-09-10 16:41 ` [Nomerge] sway: update to 1.2 voidlinux-github
2019-10-07 18:29 ` voidlinux-github
2019-10-07 18:31 ` voidlinux-github
2019-10-07 19:15 ` voidlinux-github
2019-10-07 23:53 ` [PR PATCH] [Updated] " voidlinux-github
2019-10-07 23:53 ` voidlinux-github
2019-10-07 23:58 ` voidlinux-github
2019-10-07 23:58 ` voidlinux-github
2019-10-08  0:04 ` voidlinux-github
2019-10-08  0:04 ` voidlinux-github
2019-10-08  0:54 ` voidlinux-github
2019-10-08 11:49 ` [PR PATCH] [Updated] " voidlinux-github
2019-10-08 11:49 ` voidlinux-github
2019-10-08 11:55 ` voidlinux-github
2019-10-08 12:49 ` [PR PATCH] [Updated] " voidlinux-github
2019-10-08 12:49 ` voidlinux-github
2019-10-08 14:42 ` voidlinux-github
2019-10-08 15:57 ` voidlinux-github
2019-10-08 16:09 ` voidlinux-github
2019-10-08 16:10 ` [PR PATCH] [Updated] " voidlinux-github
2019-10-08 16:10 ` voidlinux-github
2019-10-08 22:01 ` voidlinux-github
2019-10-10  6:33 ` [PR PATCH] [Updated] " voidlinux-github
2019-10-10  6:33 ` voidlinux-github
2019-10-10  7:14 ` voidlinux-github
2019-10-11 14:19 ` voidlinux-github
2019-10-11 14:19 ` voidlinux-github
2019-10-11 15:15 ` voidlinux-github
2019-10-15 17:45 ` [PR PATCH] [Merged]: " voidlinux-github

Github messages for voidlinux

Archives are clonable: git clone --mirror http://inbox.vuxu.org/voidlinux-github

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.github.voidlinux


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git