Github messages for voidlinux
 help / color / Atom feed
* [PR PATCH] Kmymoney 5.0.7
@ 2020-01-13  9:01 voidlinux-github
  2020-01-13  9:08 ` [PR PATCH] [Updated] " voidlinux-github
                   ` (5 more replies)
  0 siblings, 6 replies; 7+ messages in thread
From: voidlinux-github @ 2020-01-13  9:01 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 310 bytes --]

There is a new pull request by Hoshpak against master on the void-packages repository

https://github.com/Hoshpak/void-packages kmymoney-5.0.7
https://github.com/void-linux/void-packages/pull/18284

Kmymoney 5.0.7
None

A patch file from https://github.com/void-linux/void-packages/pull/18284.patch is attached

[-- Warning: decoded text below may be mangled --]
[-- Attachment #2: github-pr-kmymoney-5.0.7-18284.patch --]
[-- Type: text/x-diff, Size: 8143 bytes --]

From ee91b5e389daedfdea963dfe3b3e9ecf243e0f31 Mon Sep 17 00:00:00 2001
From: Helmut Pozimski <helmut@pozimski.eu>
Date: Mon, 13 Jan 2020 08:42:32 +0100
Subject: [PATCH 1/5] gwenhywfar: update to 5.1.0. (soname bump)

---
 common/shlibs               |  2 +-
 srcpkgs/gwenhywfar/template | 10 +++++-----
 2 files changed, 6 insertions(+), 6 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index 51692ea249d..8ea6617ba71 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -1484,7 +1484,7 @@ libdom.so.0 libdom-0.0.1_1
 libslang.so.2 slang-2.2.4_1
 libtre.so.5 tre-0.8.0_1
 libktoblzcheck.so.1 ktoblzcheck-1.43_2
-libgwenhywfar.so.60 gwenhywfar-4.10.0beta_1
+libgwenhywfar.so.79 gwenhywfar-5.1.0_1
 libgwengui-gtk2.so.0 gwenhywfar-gtk-4.10.0beta_1
 libgwengui-gtk3.so.0 gwenhywfar-gtk3-4.20.0_1
 libgwengui-cpp.so.0 gwenhywfar-4.10.0beta_1
diff --git a/srcpkgs/gwenhywfar/template b/srcpkgs/gwenhywfar/template
index 2407ac90bcd..687373b71b7 100644
--- a/srcpkgs/gwenhywfar/template
+++ b/srcpkgs/gwenhywfar/template
@@ -1,7 +1,7 @@
 # Template file for 'gwenhywfar'
 pkgname=gwenhywfar
-version=4.20.1
-revision=3
+version=5.1.0
+revision=1
 hostmakedepends="automake pkg-config libgcrypt-devel libtool"
 makedepends="libgcrypt-devel gnutls-devel gtk+-devel qt5-devel gtk+3-devel"
 build_style=gnu-configure
@@ -10,11 +10,11 @@ configure_args="--enable-visibility --disable-binreloc
  --with-qt5-libs=${XBPS_CROSS_BASE}/usr/lib
  --with-qt5-moc=/usr/lib/qt5/bin/moc --with-qt5-uic=/usr/lib/qt5/bin/uic"
 maintainer="Enno Boland <gottox@voidlinux.org>"
-license="LGPL-2.1"
+license="LGPL-2.1-or-later"
 short_desc="OS abstraction functions for various projects"
 homepage="https://github.com/aqbanking/gwenhywfar"
 distfiles="https://github.com/aqbanking/gwenhywfar/archive/${version}.tar.gz"
-checksum=efc4b9dcb51981e7c56e22ac6054ace396c3387667b134128d4e9fcad50544b8
+checksum=414a29c0f28cb8172b780f2aa71a8408ce0b379304714949190398fde3bcbfbf
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" qt5-host-tools qt5-devel"
@@ -22,7 +22,7 @@ fi
 
 pre_configure() {
 	# Build all GUIs
-	sed -i configure.ac -e's;"qt4 gtk2";"qt5 gtk2 gtk3";'
+	vsed -i configure.ac -e's;"qt4 gtk2";"qt5 gtk2 gtk3";'
 	autoreconf -fi
 }
 

From 9d1bf0257a3ef2d8c0e837e1fbc595052a64e48e Mon Sep 17 00:00:00 2001
From: Helmut Pozimski <helmut@pozimski.eu>
Date: Mon, 13 Jan 2020 08:55:46 +0100
Subject: [PATCH 2/5] aqbanking: update to 5.99.45. (soname bump)

---
 common/shlibs              | 2 +-
 srcpkgs/aqbanking/template | 8 ++++----
 2 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index 8ea6617ba71..d9ab1d2ae63 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -1489,7 +1489,7 @@ libgwengui-gtk2.so.0 gwenhywfar-gtk-4.10.0beta_1
 libgwengui-gtk3.so.0 gwenhywfar-gtk3-4.20.0_1
 libgwengui-cpp.so.0 gwenhywfar-4.10.0beta_1
 libgwengui-qt5.so.0 gwenhywfar-qt5-4.15.3_3
-libaqbanking.so.35 aqbanking-5.6.10_1
+libaqbanking.so.43 aqbanking-5.99.45_1
 libaqnone.so.35 aqbanking-5.6.10_1
 libaqhbci.so.24 aqbanking-5.7.8_1
 libaqofxconnect.so.7 aqbanking-5.0.25_1
diff --git a/srcpkgs/aqbanking/template b/srcpkgs/aqbanking/template
index ed906ea0645..dbe2a2f725a 100644
--- a/srcpkgs/aqbanking/template
+++ b/srcpkgs/aqbanking/template
@@ -1,16 +1,16 @@
 # Template file for 'aqbanking'
 pkgname=aqbanking
-version=5.8.2
+version=5.99.45
 revision=1
 build_style=gnu-configure
-hostmakedepends="pkg-config gwenhywfar"
+hostmakedepends="pkg-config gwenhywfar tar"
 makedepends="gwenhywfar-devel xmlsec1-devel ktoblzcheck-devel gmp-devel"
 short_desc="Library for online banking and financial applications"
 maintainer="Enno Boland <gottox@voidlinux.org>"
 license="GPL-2.0-only, GPL-3.0-only"
 homepage="http://www.aquamaniac.de/aqbanking"
-distfiles="https://www.aquamaniac.de/rdm/attachments/download/107/aqbanking-${version}.tar.gz"
-checksum=93ca523fe175e72042db75f8c3fc6255ab058cf82caf52796e15f030809fb15e
+distfiles="https://www.aquamaniac.de/rdm/attachments/download/232/aqbanking-${version}.tar.gz"
+checksum=7e98f6eb817e6efe4a5f803af51781f7a6a8ae769a6c77ae324ed99033bd143f
 disable_parallel_build=yes
 
 if [ "$CROSS_BUILD" ]; then

From 1a80dc9c0587ce9f025bac9d9206c53d0a3da0ac Mon Sep 17 00:00:00 2001
From: Helmut Pozimski <helmut@pozimski.eu>
Date: Mon, 13 Jan 2020 08:45:22 +0100
Subject: [PATCH 3/5] libchipcard: rebuild against gwenhywfar-5.1.0

---
 srcpkgs/libchipcard/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/libchipcard/template b/srcpkgs/libchipcard/template
index 2bc45ae50b7..eb11026f1af 100644
--- a/srcpkgs/libchipcard/template
+++ b/srcpkgs/libchipcard/template
@@ -1,7 +1,7 @@
 # Template file for 'libchipcard'
 pkgname=libchipcard
 version=5.0.4
-revision=2
+revision=3
 build_style=gnu-configure
 hostmakedepends="gwenhywfar-devel pkg-config"
 makedepends="gwenhywfar-devel pcsclite-devel zlib-devel"
@@ -9,7 +9,7 @@ short_desc="A library for easy access to chip cards via chipcard readers"
 maintainer="Matthias Fulz <mfulz@olznet.de>"
 license="LGPL-2.1-only"
 homepage="http://www.libchipcard.de"
-distfiles="https://www.aquamaniac.de/sites/download/download.php?package=02&release=200&file=01&dummy=${pkgname}-${version}.tar.gz"
+distfiles="https://www.aquamaniac.de/rdm/attachments/download/158/libchipcard-${version}.tar.gz"
 checksum=d25a79adcf09f1058ca9168b80e843fadbd556fb0f23c890d871124ad380423a
 
 libchipcard-devel_package() {

From 5ee76b7100d108ed7cf2cb91934d1d5d9be8ccab Mon Sep 17 00:00:00 2001
From: Helmut Pozimski <helmut@pozimski.eu>
Date: Mon, 13 Jan 2020 08:45:22 +0100
Subject: [PATCH 4/5] gnucash: rebuild against gwenhywfar-5.1.0

---
 srcpkgs/gnucash/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/gnucash/template b/srcpkgs/gnucash/template
index 432ec009f1c..401e1d49e02 100644
--- a/srcpkgs/gnucash/template
+++ b/srcpkgs/gnucash/template
@@ -1,11 +1,11 @@
 # Template file for 'gnucash'
 pkgname=gnucash
 version=3.8b
-revision=1
+revision=2
 wrksrc="${pkgname}-${version%b}"
 build_style=cmake
 configure_args="-DWITH_SQL=0 -DWITH_PYTHON=1"
-hostmakedepends="pkg-config guile python3 libxslt perl"
+hostmakedepends="pkg-config guile python3 libxslt perl gettext"
 makedepends="aqbanking-devel boost-devel gc-devel glib-devel gtest-devel guile-devel
  gwenhywfar-devel ktoblzcheck-devel libofx-devel libsecret-devel
  libxslt-devel webkit2gtk-devel python3-devel gwenhywfar-gtk3"

From 779c58da8d95c66bb1721153c98208f6b122b260 Mon Sep 17 00:00:00 2001
From: Helmut Pozimski <helmut@pozimski.eu>
Date: Mon, 13 Jan 2020 10:00:43 +0100
Subject: [PATCH 5/5] kmymoney: update to 5.0.7.

---
 srcpkgs/kmymoney/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/kmymoney/template b/srcpkgs/kmymoney/template
index 5e99dc91cff..310a225d9c3 100644
--- a/srcpkgs/kmymoney/template
+++ b/srcpkgs/kmymoney/template
@@ -1,12 +1,12 @@
 # Template file for 'kmymoney'
 pkgname=kmymoney
-version=5.0.6
-revision=3
+version=5.0.7
+revision=1
 build_style=cmake
 configure_args="-DDESKTOPTOJSON_EXECUTABLE=/usr/bin/desktoptojson
  -DBUILD_TESTING=OFF"
 hostmakedepends="extra-cmake-modules kconfig kcoreaddons kdoctools pkg-config
- python qt5-host-tools qt5-qmake"
+ python3 qt5-host-tools qt5-qmake gettext"
 makedepends="akonadi5-devel aqbanking-devel gmp-devel gmpxx-devel gpgmeqt-devel
  gwenhywfar-devel gwenhywfar-qt5 kactivities5-devel kcmutils-devel
  kcontacts-devel kdewebkit-devel kdiagram-devel kholidays-devel
@@ -18,7 +18,7 @@ maintainer="Helmut Pozimski <helmut@pozimski.eu>"
 license="GPL-2.0-or-later"
 homepage="https://kmymoney.org"
 distfiles="${KDE_SITE}/kmymoney/${version}/src/${pkgname}-${version}.tar.xz"
-checksum=ba945fb26fff581f95e1132f50d222bd51a2458b959a9b7cb468ba617cfa9183
+checksum=d5dcac31db410861fe74955109715012bcddfd095cdbb18c91827a77dffeb5c0
 
 if [ "$CROSS_BUILD" ]; then
 	configure_args+=" -DENABLE_LIBICAL=0"
@@ -26,7 +26,7 @@ fi
 
 post_extract() {
 	if [ "$CROSS_BUILD" ]; then
-		sed /find_package\(Libical\)/d -i CMakeLists.txt
+		vsed /find_package\(Libical\)/d -i CMakeLists.txt
 	fi
 }
 

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PR PATCH] [Updated] Kmymoney 5.0.7
  2020-01-13  9:01 [PR PATCH] Kmymoney 5.0.7 voidlinux-github
@ 2020-01-13  9:08 ` " voidlinux-github
  2020-01-13  9:09 ` voidlinux-github
                   ` (4 subsequent siblings)
  5 siblings, 0 replies; 7+ messages in thread
From: voidlinux-github @ 2020-01-13  9:08 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 315 bytes --]

There is an updated pull request by Hoshpak against master on the void-packages repository

https://github.com/Hoshpak/void-packages kmymoney-5.0.7
https://github.com/void-linux/void-packages/pull/18284

Kmymoney 5.0.7
None

A patch file from https://github.com/void-linux/void-packages/pull/18284.patch is attached

[-- Warning: decoded text below may be mangled --]
[-- Attachment #2: github-pr-kmymoney-5.0.7-18284.patch --]
[-- Type: text/x-diff, Size: 8810 bytes --]

From 9ec7cf3e4001f40b25f8612755167694576b8966 Mon Sep 17 00:00:00 2001
From: Helmut Pozimski <helmut@pozimski.eu>
Date: Mon, 13 Jan 2020 08:42:32 +0100
Subject: [PATCH 1/5] gwenhywfar: update to 5.1.0. (soname bump)

---
 common/shlibs               |  2 +-
 srcpkgs/gwenhywfar/template | 16 ++++++++--------
 2 files changed, 9 insertions(+), 9 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index 51692ea249d..8ea6617ba71 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -1484,7 +1484,7 @@ libdom.so.0 libdom-0.0.1_1
 libslang.so.2 slang-2.2.4_1
 libtre.so.5 tre-0.8.0_1
 libktoblzcheck.so.1 ktoblzcheck-1.43_2
-libgwenhywfar.so.60 gwenhywfar-4.10.0beta_1
+libgwenhywfar.so.79 gwenhywfar-5.1.0_1
 libgwengui-gtk2.so.0 gwenhywfar-gtk-4.10.0beta_1
 libgwengui-gtk3.so.0 gwenhywfar-gtk3-4.20.0_1
 libgwengui-cpp.so.0 gwenhywfar-4.10.0beta_1
diff --git a/srcpkgs/gwenhywfar/template b/srcpkgs/gwenhywfar/template
index 2407ac90bcd..b64ed32297b 100644
--- a/srcpkgs/gwenhywfar/template
+++ b/srcpkgs/gwenhywfar/template
@@ -1,20 +1,20 @@
 # Template file for 'gwenhywfar'
 pkgname=gwenhywfar
-version=4.20.1
-revision=3
-hostmakedepends="automake pkg-config libgcrypt-devel libtool"
-makedepends="libgcrypt-devel gnutls-devel gtk+-devel qt5-devel gtk+3-devel"
+version=5.1.0
+revision=1
 build_style=gnu-configure
 configure_args="--enable-visibility --disable-binreloc
  --with-qt5-includes=${XBPS_CROSS_BASE}/usr/include
  --with-qt5-libs=${XBPS_CROSS_BASE}/usr/lib
  --with-qt5-moc=/usr/lib/qt5/bin/moc --with-qt5-uic=/usr/lib/qt5/bin/uic"
-maintainer="Enno Boland <gottox@voidlinux.org>"
-license="LGPL-2.1"
+hostmakedepends="automake pkg-config libgcrypt-devel libtool"
+makedepends="libgcrypt-devel gnutls-devel gtk+-devel qt5-devel gtk+3-devel"
 short_desc="OS abstraction functions for various projects"
+maintainer="Enno Boland <gottox@voidlinux.org>"
+license="LGPL-2.1-or-later"
 homepage="https://github.com/aqbanking/gwenhywfar"
 distfiles="https://github.com/aqbanking/gwenhywfar/archive/${version}.tar.gz"
-checksum=efc4b9dcb51981e7c56e22ac6054ace396c3387667b134128d4e9fcad50544b8
+checksum=414a29c0f28cb8172b780f2aa71a8408ce0b379304714949190398fde3bcbfbf
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" qt5-host-tools qt5-devel"
@@ -22,7 +22,7 @@ fi
 
 pre_configure() {
 	# Build all GUIs
-	sed -i configure.ac -e's;"qt4 gtk2";"qt5 gtk2 gtk3";'
+	vsed -i configure.ac -e's;"qt4 gtk2";"qt5 gtk2 gtk3";'
 	autoreconf -fi
 }
 

From 84d06dbf6a3fdba520a857da3b6740c055a136df Mon Sep 17 00:00:00 2001
From: Helmut Pozimski <helmut@pozimski.eu>
Date: Mon, 13 Jan 2020 08:55:46 +0100
Subject: [PATCH 2/5] aqbanking: update to 5.99.45. (soname bump)

---
 common/shlibs              | 2 +-
 srcpkgs/aqbanking/template | 8 ++++----
 2 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index 8ea6617ba71..d9ab1d2ae63 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -1489,7 +1489,7 @@ libgwengui-gtk2.so.0 gwenhywfar-gtk-4.10.0beta_1
 libgwengui-gtk3.so.0 gwenhywfar-gtk3-4.20.0_1
 libgwengui-cpp.so.0 gwenhywfar-4.10.0beta_1
 libgwengui-qt5.so.0 gwenhywfar-qt5-4.15.3_3
-libaqbanking.so.35 aqbanking-5.6.10_1
+libaqbanking.so.43 aqbanking-5.99.45_1
 libaqnone.so.35 aqbanking-5.6.10_1
 libaqhbci.so.24 aqbanking-5.7.8_1
 libaqofxconnect.so.7 aqbanking-5.0.25_1
diff --git a/srcpkgs/aqbanking/template b/srcpkgs/aqbanking/template
index ed906ea0645..dbe2a2f725a 100644
--- a/srcpkgs/aqbanking/template
+++ b/srcpkgs/aqbanking/template
@@ -1,16 +1,16 @@
 # Template file for 'aqbanking'
 pkgname=aqbanking
-version=5.8.2
+version=5.99.45
 revision=1
 build_style=gnu-configure
-hostmakedepends="pkg-config gwenhywfar"
+hostmakedepends="pkg-config gwenhywfar tar"
 makedepends="gwenhywfar-devel xmlsec1-devel ktoblzcheck-devel gmp-devel"
 short_desc="Library for online banking and financial applications"
 maintainer="Enno Boland <gottox@voidlinux.org>"
 license="GPL-2.0-only, GPL-3.0-only"
 homepage="http://www.aquamaniac.de/aqbanking"
-distfiles="https://www.aquamaniac.de/rdm/attachments/download/107/aqbanking-${version}.tar.gz"
-checksum=93ca523fe175e72042db75f8c3fc6255ab058cf82caf52796e15f030809fb15e
+distfiles="https://www.aquamaniac.de/rdm/attachments/download/232/aqbanking-${version}.tar.gz"
+checksum=7e98f6eb817e6efe4a5f803af51781f7a6a8ae769a6c77ae324ed99033bd143f
 disable_parallel_build=yes
 
 if [ "$CROSS_BUILD" ]; then

From 0904888b12c4cba36b55ac3dc53345171c8e0df0 Mon Sep 17 00:00:00 2001
From: Helmut Pozimski <helmut@pozimski.eu>
Date: Mon, 13 Jan 2020 08:45:22 +0100
Subject: [PATCH 3/5] libchipcard: rebuild against gwenhywfar-5.1.0

---
 srcpkgs/libchipcard/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/libchipcard/template b/srcpkgs/libchipcard/template
index 2bc45ae50b7..7453dd093c4 100644
--- a/srcpkgs/libchipcard/template
+++ b/srcpkgs/libchipcard/template
@@ -1,15 +1,15 @@
 # Template file for 'libchipcard'
 pkgname=libchipcard
 version=5.0.4
-revision=2
+revision=3
 build_style=gnu-configure
 hostmakedepends="gwenhywfar-devel pkg-config"
 makedepends="gwenhywfar-devel pcsclite-devel zlib-devel"
-short_desc="A library for easy access to chip cards via chipcard readers"
+short_desc="Library for easy access to chip cards via chipcard readers"
 maintainer="Matthias Fulz <mfulz@olznet.de>"
 license="LGPL-2.1-only"
 homepage="http://www.libchipcard.de"
-distfiles="https://www.aquamaniac.de/sites/download/download.php?package=02&release=200&file=01&dummy=${pkgname}-${version}.tar.gz"
+distfiles="https://www.aquamaniac.de/rdm/attachments/download/158/libchipcard-${version}.tar.gz"
 checksum=d25a79adcf09f1058ca9168b80e843fadbd556fb0f23c890d871124ad380423a
 
 libchipcard-devel_package() {

From 2e3bb8d399d383abbb294ab40c2e9aab48ffa497 Mon Sep 17 00:00:00 2001
From: Helmut Pozimski <helmut@pozimski.eu>
Date: Mon, 13 Jan 2020 08:45:22 +0100
Subject: [PATCH 4/5] gnucash: rebuild against gwenhywfar-5.1.0

---
 srcpkgs/gnucash/template | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/gnucash/template b/srcpkgs/gnucash/template
index 432ec009f1c..7efc1112028 100644
--- a/srcpkgs/gnucash/template
+++ b/srcpkgs/gnucash/template
@@ -1,11 +1,11 @@
 # Template file for 'gnucash'
 pkgname=gnucash
 version=3.8b
-revision=1
+revision=2
 wrksrc="${pkgname}-${version%b}"
 build_style=cmake
 configure_args="-DWITH_SQL=0 -DWITH_PYTHON=1"
-hostmakedepends="pkg-config guile python3 libxslt perl"
+hostmakedepends="pkg-config guile python3 libxslt perl gettext"
 makedepends="aqbanking-devel boost-devel gc-devel glib-devel gtest-devel guile-devel
  gwenhywfar-devel ktoblzcheck-devel libofx-devel libsecret-devel
  libxslt-devel webkit2gtk-devel python3-devel gwenhywfar-gtk3"
@@ -17,7 +17,6 @@ homepage="http://www.gnucash.org"
 distfiles="${SOURCEFORGE_SITE}/${pkgname}/${pkgname}-${version}.tar.bz2"
 checksum=0f5eca83d8836a325d9a02c6ed7b4d53e59abcff974e5d90914c9e15d7a87f37
 
-pycompile_module="gnucash"
 pycompile_dirs="usr/share/gnucash/python"
 conf_files="/etc/gnucash/environment"
 nocross="fails to compile guile code when cross-compiling"

From 56a4e5bec509766feaa4b0bdeac0fe8ca3cecb27 Mon Sep 17 00:00:00 2001
From: Helmut Pozimski <helmut@pozimski.eu>
Date: Mon, 13 Jan 2020 10:00:43 +0100
Subject: [PATCH 5/5] kmymoney: update to 5.0.7.

---
 srcpkgs/kmymoney/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/kmymoney/template b/srcpkgs/kmymoney/template
index 5e99dc91cff..310a225d9c3 100644
--- a/srcpkgs/kmymoney/template
+++ b/srcpkgs/kmymoney/template
@@ -1,12 +1,12 @@
 # Template file for 'kmymoney'
 pkgname=kmymoney
-version=5.0.6
-revision=3
+version=5.0.7
+revision=1
 build_style=cmake
 configure_args="-DDESKTOPTOJSON_EXECUTABLE=/usr/bin/desktoptojson
  -DBUILD_TESTING=OFF"
 hostmakedepends="extra-cmake-modules kconfig kcoreaddons kdoctools pkg-config
- python qt5-host-tools qt5-qmake"
+ python3 qt5-host-tools qt5-qmake gettext"
 makedepends="akonadi5-devel aqbanking-devel gmp-devel gmpxx-devel gpgmeqt-devel
  gwenhywfar-devel gwenhywfar-qt5 kactivities5-devel kcmutils-devel
  kcontacts-devel kdewebkit-devel kdiagram-devel kholidays-devel
@@ -18,7 +18,7 @@ maintainer="Helmut Pozimski <helmut@pozimski.eu>"
 license="GPL-2.0-or-later"
 homepage="https://kmymoney.org"
 distfiles="${KDE_SITE}/kmymoney/${version}/src/${pkgname}-${version}.tar.xz"
-checksum=ba945fb26fff581f95e1132f50d222bd51a2458b959a9b7cb468ba617cfa9183
+checksum=d5dcac31db410861fe74955109715012bcddfd095cdbb18c91827a77dffeb5c0
 
 if [ "$CROSS_BUILD" ]; then
 	configure_args+=" -DENABLE_LIBICAL=0"
@@ -26,7 +26,7 @@ fi
 
 post_extract() {
 	if [ "$CROSS_BUILD" ]; then
-		sed /find_package\(Libical\)/d -i CMakeLists.txt
+		vsed /find_package\(Libical\)/d -i CMakeLists.txt
 	fi
 }
 

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PR PATCH] [Updated] Kmymoney 5.0.7
  2020-01-13  9:01 [PR PATCH] Kmymoney 5.0.7 voidlinux-github
  2020-01-13  9:08 ` [PR PATCH] [Updated] " voidlinux-github
@ 2020-01-13  9:09 ` voidlinux-github
  2020-01-16 18:48 ` [PR PATCH] [Updated] [WIP] " voidlinux-github
                   ` (3 subsequent siblings)
  5 siblings, 0 replies; 7+ messages in thread
From: voidlinux-github @ 2020-01-13  9:09 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 315 bytes --]

There is an updated pull request by Hoshpak against master on the void-packages repository

https://github.com/Hoshpak/void-packages kmymoney-5.0.7
https://github.com/void-linux/void-packages/pull/18284

Kmymoney 5.0.7
None

A patch file from https://github.com/void-linux/void-packages/pull/18284.patch is attached

[-- Warning: decoded text below may be mangled --]
[-- Attachment #2: github-pr-kmymoney-5.0.7-18284.patch --]
[-- Type: text/x-diff, Size: 8816 bytes --]

From 997bf433a54aaf9760eb0cd6a38a72afb5b522be Mon Sep 17 00:00:00 2001
From: Helmut Pozimski <helmut@pozimski.eu>
Date: Mon, 13 Jan 2020 08:42:32 +0100
Subject: [PATCH 1/5] gwenhywfar: update to 5.1.0. (soname bump)

---
 common/shlibs               |  2 +-
 srcpkgs/gwenhywfar/template | 16 ++++++++--------
 2 files changed, 9 insertions(+), 9 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index 51692ea249d..8ea6617ba71 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -1484,7 +1484,7 @@ libdom.so.0 libdom-0.0.1_1
 libslang.so.2 slang-2.2.4_1
 libtre.so.5 tre-0.8.0_1
 libktoblzcheck.so.1 ktoblzcheck-1.43_2
-libgwenhywfar.so.60 gwenhywfar-4.10.0beta_1
+libgwenhywfar.so.79 gwenhywfar-5.1.0_1
 libgwengui-gtk2.so.0 gwenhywfar-gtk-4.10.0beta_1
 libgwengui-gtk3.so.0 gwenhywfar-gtk3-4.20.0_1
 libgwengui-cpp.so.0 gwenhywfar-4.10.0beta_1
diff --git a/srcpkgs/gwenhywfar/template b/srcpkgs/gwenhywfar/template
index 2407ac90bcd..7dadfba4950 100644
--- a/srcpkgs/gwenhywfar/template
+++ b/srcpkgs/gwenhywfar/template
@@ -1,20 +1,20 @@
 # Template file for 'gwenhywfar'
 pkgname=gwenhywfar
-version=4.20.1
-revision=3
-hostmakedepends="automake pkg-config libgcrypt-devel libtool"
-makedepends="libgcrypt-devel gnutls-devel gtk+-devel qt5-devel gtk+3-devel"
+version=5.1.0
+revision=1
 build_style=gnu-configure
 configure_args="--enable-visibility --disable-binreloc
  --with-qt5-includes=${XBPS_CROSS_BASE}/usr/include
  --with-qt5-libs=${XBPS_CROSS_BASE}/usr/lib
  --with-qt5-moc=/usr/lib/qt5/bin/moc --with-qt5-uic=/usr/lib/qt5/bin/uic"
-maintainer="Enno Boland <gottox@voidlinux.org>"
-license="LGPL-2.1"
+hostmakedepends="automake pkg-config libgcrypt-devel libtool which"
+makedepends="libgcrypt-devel gnutls-devel gtk+-devel qt5-devel gtk+3-devel"
 short_desc="OS abstraction functions for various projects"
+maintainer="Enno Boland <gottox@voidlinux.org>"
+license="LGPL-2.1-or-later"
 homepage="https://github.com/aqbanking/gwenhywfar"
 distfiles="https://github.com/aqbanking/gwenhywfar/archive/${version}.tar.gz"
-checksum=efc4b9dcb51981e7c56e22ac6054ace396c3387667b134128d4e9fcad50544b8
+checksum=414a29c0f28cb8172b780f2aa71a8408ce0b379304714949190398fde3bcbfbf
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" qt5-host-tools qt5-devel"
@@ -22,7 +22,7 @@ fi
 
 pre_configure() {
 	# Build all GUIs
-	sed -i configure.ac -e's;"qt4 gtk2";"qt5 gtk2 gtk3";'
+	vsed -i configure.ac -e's;"qt4 gtk2";"qt5 gtk2 gtk3";'
 	autoreconf -fi
 }
 

From cd0a00530127719c83ef9efad04e99626a2b08e7 Mon Sep 17 00:00:00 2001
From: Helmut Pozimski <helmut@pozimski.eu>
Date: Mon, 13 Jan 2020 08:55:46 +0100
Subject: [PATCH 2/5] aqbanking: update to 5.99.45. (soname bump)

---
 common/shlibs              | 2 +-
 srcpkgs/aqbanking/template | 8 ++++----
 2 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index 8ea6617ba71..d9ab1d2ae63 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -1489,7 +1489,7 @@ libgwengui-gtk2.so.0 gwenhywfar-gtk-4.10.0beta_1
 libgwengui-gtk3.so.0 gwenhywfar-gtk3-4.20.0_1
 libgwengui-cpp.so.0 gwenhywfar-4.10.0beta_1
 libgwengui-qt5.so.0 gwenhywfar-qt5-4.15.3_3
-libaqbanking.so.35 aqbanking-5.6.10_1
+libaqbanking.so.43 aqbanking-5.99.45_1
 libaqnone.so.35 aqbanking-5.6.10_1
 libaqhbci.so.24 aqbanking-5.7.8_1
 libaqofxconnect.so.7 aqbanking-5.0.25_1
diff --git a/srcpkgs/aqbanking/template b/srcpkgs/aqbanking/template
index ed906ea0645..dbe2a2f725a 100644
--- a/srcpkgs/aqbanking/template
+++ b/srcpkgs/aqbanking/template
@@ -1,16 +1,16 @@
 # Template file for 'aqbanking'
 pkgname=aqbanking
-version=5.8.2
+version=5.99.45
 revision=1
 build_style=gnu-configure
-hostmakedepends="pkg-config gwenhywfar"
+hostmakedepends="pkg-config gwenhywfar tar"
 makedepends="gwenhywfar-devel xmlsec1-devel ktoblzcheck-devel gmp-devel"
 short_desc="Library for online banking and financial applications"
 maintainer="Enno Boland <gottox@voidlinux.org>"
 license="GPL-2.0-only, GPL-3.0-only"
 homepage="http://www.aquamaniac.de/aqbanking"
-distfiles="https://www.aquamaniac.de/rdm/attachments/download/107/aqbanking-${version}.tar.gz"
-checksum=93ca523fe175e72042db75f8c3fc6255ab058cf82caf52796e15f030809fb15e
+distfiles="https://www.aquamaniac.de/rdm/attachments/download/232/aqbanking-${version}.tar.gz"
+checksum=7e98f6eb817e6efe4a5f803af51781f7a6a8ae769a6c77ae324ed99033bd143f
 disable_parallel_build=yes
 
 if [ "$CROSS_BUILD" ]; then

From 70545b7d1fdd250a2c3623bb9706022d82f0a1a3 Mon Sep 17 00:00:00 2001
From: Helmut Pozimski <helmut@pozimski.eu>
Date: Mon, 13 Jan 2020 08:45:22 +0100
Subject: [PATCH 3/5] libchipcard: rebuild against gwenhywfar-5.1.0

---
 srcpkgs/libchipcard/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/libchipcard/template b/srcpkgs/libchipcard/template
index 2bc45ae50b7..7453dd093c4 100644
--- a/srcpkgs/libchipcard/template
+++ b/srcpkgs/libchipcard/template
@@ -1,15 +1,15 @@
 # Template file for 'libchipcard'
 pkgname=libchipcard
 version=5.0.4
-revision=2
+revision=3
 build_style=gnu-configure
 hostmakedepends="gwenhywfar-devel pkg-config"
 makedepends="gwenhywfar-devel pcsclite-devel zlib-devel"
-short_desc="A library for easy access to chip cards via chipcard readers"
+short_desc="Library for easy access to chip cards via chipcard readers"
 maintainer="Matthias Fulz <mfulz@olznet.de>"
 license="LGPL-2.1-only"
 homepage="http://www.libchipcard.de"
-distfiles="https://www.aquamaniac.de/sites/download/download.php?package=02&release=200&file=01&dummy=${pkgname}-${version}.tar.gz"
+distfiles="https://www.aquamaniac.de/rdm/attachments/download/158/libchipcard-${version}.tar.gz"
 checksum=d25a79adcf09f1058ca9168b80e843fadbd556fb0f23c890d871124ad380423a
 
 libchipcard-devel_package() {

From fffb84d7bb6447b1c75abc2f5b6c9080ca183c67 Mon Sep 17 00:00:00 2001
From: Helmut Pozimski <helmut@pozimski.eu>
Date: Mon, 13 Jan 2020 08:45:22 +0100
Subject: [PATCH 4/5] gnucash: rebuild against gwenhywfar-5.1.0

---
 srcpkgs/gnucash/template | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/gnucash/template b/srcpkgs/gnucash/template
index 432ec009f1c..7efc1112028 100644
--- a/srcpkgs/gnucash/template
+++ b/srcpkgs/gnucash/template
@@ -1,11 +1,11 @@
 # Template file for 'gnucash'
 pkgname=gnucash
 version=3.8b
-revision=1
+revision=2
 wrksrc="${pkgname}-${version%b}"
 build_style=cmake
 configure_args="-DWITH_SQL=0 -DWITH_PYTHON=1"
-hostmakedepends="pkg-config guile python3 libxslt perl"
+hostmakedepends="pkg-config guile python3 libxslt perl gettext"
 makedepends="aqbanking-devel boost-devel gc-devel glib-devel gtest-devel guile-devel
  gwenhywfar-devel ktoblzcheck-devel libofx-devel libsecret-devel
  libxslt-devel webkit2gtk-devel python3-devel gwenhywfar-gtk3"
@@ -17,7 +17,6 @@ homepage="http://www.gnucash.org"
 distfiles="${SOURCEFORGE_SITE}/${pkgname}/${pkgname}-${version}.tar.bz2"
 checksum=0f5eca83d8836a325d9a02c6ed7b4d53e59abcff974e5d90914c9e15d7a87f37
 
-pycompile_module="gnucash"
 pycompile_dirs="usr/share/gnucash/python"
 conf_files="/etc/gnucash/environment"
 nocross="fails to compile guile code when cross-compiling"

From 9c86acc4c879b2bb593a096bff0a960515d9f521 Mon Sep 17 00:00:00 2001
From: Helmut Pozimski <helmut@pozimski.eu>
Date: Mon, 13 Jan 2020 10:00:43 +0100
Subject: [PATCH 5/5] kmymoney: update to 5.0.7.

---
 srcpkgs/kmymoney/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/kmymoney/template b/srcpkgs/kmymoney/template
index 5e99dc91cff..310a225d9c3 100644
--- a/srcpkgs/kmymoney/template
+++ b/srcpkgs/kmymoney/template
@@ -1,12 +1,12 @@
 # Template file for 'kmymoney'
 pkgname=kmymoney
-version=5.0.6
-revision=3
+version=5.0.7
+revision=1
 build_style=cmake
 configure_args="-DDESKTOPTOJSON_EXECUTABLE=/usr/bin/desktoptojson
  -DBUILD_TESTING=OFF"
 hostmakedepends="extra-cmake-modules kconfig kcoreaddons kdoctools pkg-config
- python qt5-host-tools qt5-qmake"
+ python3 qt5-host-tools qt5-qmake gettext"
 makedepends="akonadi5-devel aqbanking-devel gmp-devel gmpxx-devel gpgmeqt-devel
  gwenhywfar-devel gwenhywfar-qt5 kactivities5-devel kcmutils-devel
  kcontacts-devel kdewebkit-devel kdiagram-devel kholidays-devel
@@ -18,7 +18,7 @@ maintainer="Helmut Pozimski <helmut@pozimski.eu>"
 license="GPL-2.0-or-later"
 homepage="https://kmymoney.org"
 distfiles="${KDE_SITE}/kmymoney/${version}/src/${pkgname}-${version}.tar.xz"
-checksum=ba945fb26fff581f95e1132f50d222bd51a2458b959a9b7cb468ba617cfa9183
+checksum=d5dcac31db410861fe74955109715012bcddfd095cdbb18c91827a77dffeb5c0
 
 if [ "$CROSS_BUILD" ]; then
 	configure_args+=" -DENABLE_LIBICAL=0"
@@ -26,7 +26,7 @@ fi
 
 post_extract() {
 	if [ "$CROSS_BUILD" ]; then
-		sed /find_package\(Libical\)/d -i CMakeLists.txt
+		vsed /find_package\(Libical\)/d -i CMakeLists.txt
 	fi
 }
 

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PR PATCH] [Updated] [WIP] Kmymoney 5.0.7
  2020-01-13  9:01 [PR PATCH] Kmymoney 5.0.7 voidlinux-github
  2020-01-13  9:08 ` [PR PATCH] [Updated] " voidlinux-github
  2020-01-13  9:09 ` voidlinux-github
@ 2020-01-16 18:48 ` " voidlinux-github
  2020-01-16 18:53 ` voidlinux-github
                   ` (2 subsequent siblings)
  5 siblings, 0 replies; 7+ messages in thread
From: voidlinux-github @ 2020-01-16 18:48 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 321 bytes --]

There is an updated pull request by Hoshpak against master on the void-packages repository

https://github.com/Hoshpak/void-packages kmymoney-5.0.7
https://github.com/void-linux/void-packages/pull/18284

[WIP] Kmymoney 5.0.7
None

A patch file from https://github.com/void-linux/void-packages/pull/18284.patch is attached

[-- Warning: decoded text below may be mangled --]
[-- Attachment #2: github-pr-kmymoney-5.0.7-18284.patch --]
[-- Type: text/x-diff, Size: 11207 bytes --]

From 356e0c06fe80a3d4f54114d5cca5e66f3f622605 Mon Sep 17 00:00:00 2001
From: Helmut Pozimski <helmut@pozimski.eu>
Date: Mon, 13 Jan 2020 08:42:32 +0100
Subject: [PATCH 1/5] gwenhywfar: update to 5.1.0. (soname bump)

---
 common/shlibs                              |  2 +-
 srcpkgs/gwenhywfar/patches/qt5-cross.patch | 28 +++++++++++++
 srcpkgs/gwenhywfar/template                | 46 +++++++++++++++++-----
 3 files changed, 65 insertions(+), 11 deletions(-)
 create mode 100644 srcpkgs/gwenhywfar/patches/qt5-cross.patch

diff --git a/common/shlibs b/common/shlibs
index 51692ea249d..8ea6617ba71 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -1484,7 +1484,7 @@ libdom.so.0 libdom-0.0.1_1
 libslang.so.2 slang-2.2.4_1
 libtre.so.5 tre-0.8.0_1
 libktoblzcheck.so.1 ktoblzcheck-1.43_2
-libgwenhywfar.so.60 gwenhywfar-4.10.0beta_1
+libgwenhywfar.so.79 gwenhywfar-5.1.0_1
 libgwengui-gtk2.so.0 gwenhywfar-gtk-4.10.0beta_1
 libgwengui-gtk3.so.0 gwenhywfar-gtk3-4.20.0_1
 libgwengui-cpp.so.0 gwenhywfar-4.10.0beta_1
diff --git a/srcpkgs/gwenhywfar/patches/qt5-cross.patch b/srcpkgs/gwenhywfar/patches/qt5-cross.patch
new file mode 100644
index 00000000000..41b447e2b73
--- /dev/null
+++ b/srcpkgs/gwenhywfar/patches/qt5-cross.patch
@@ -0,0 +1,28 @@
+--- m4/ax_have_qt.m4.ORIG	2020-01-16 19:40:22.927813462 +0100
++++ m4/ax_have_qt.m4	2020-01-16 19:42:12.106436543 +0100
+@@ -74,6 +74,12 @@
+     [QT_QMAKE="qmake"]
+   )
+ 
++  AC_ARG_WITH(qt5-config,
++    [  --with-qt5-config=FILE   uses given qt configuration],
++    [QT_CONFIGURATION="$withval"],
++    [QT_CONFIGURATION=""]
++  )
++
+   AC_MSG_CHECKING(for Qt)
+   # If we have Qt5 or later in the path, we're golden
+   ver=`$QT_QMAKE --version | grep -o "Qt version ."`
+@@ -122,7 +128,11 @@
+ percent.commands = @echo -n "\$(\$(@))\ "
+ QMAKE_EXTRA_TARGETS += percent
+ EOF
+-    $QT_QMAKE $am_have_qt_pro -o $am_have_qt_makefile
++    if test -z $QT_CONFIGURATION; then
++        $QT_QMAKE $am_have_qt_pro -o $am_have_qt_makefile
++    else
++        $QT_QMAKE $am_have_qt_pro -o $am_have_qt_makefile -qtconf $QT_CONFIGURATION
++    fi
+     QT_CXXFLAGS=`make -s -f $am_have_qt_makefile CXXFLAGS INCPATH`
+     QT_LIBS=`make -s -f $am_have_qt_makefile LIBS`
+     rm $am_have_qt_pro $am_have_qt_makefile
diff --git a/srcpkgs/gwenhywfar/template b/srcpkgs/gwenhywfar/template
index 2407ac90bcd..2cc807c20a5 100644
--- a/srcpkgs/gwenhywfar/template
+++ b/srcpkgs/gwenhywfar/template
@@ -1,20 +1,18 @@
 # Template file for 'gwenhywfar'
 pkgname=gwenhywfar
-version=4.20.1
-revision=3
-hostmakedepends="automake pkg-config libgcrypt-devel libtool"
-makedepends="libgcrypt-devel gnutls-devel gtk+-devel qt5-devel gtk+3-devel"
+version=5.1.0
+revision=1
 build_style=gnu-configure
 configure_args="--enable-visibility --disable-binreloc
- --with-qt5-includes=${XBPS_CROSS_BASE}/usr/include
- --with-qt5-libs=${XBPS_CROSS_BASE}/usr/lib
  --with-qt5-moc=/usr/lib/qt5/bin/moc --with-qt5-uic=/usr/lib/qt5/bin/uic"
-maintainer="Enno Boland <gottox@voidlinux.org>"
-license="LGPL-2.1"
+hostmakedepends="automake pkg-config libgcrypt-devel libtool which"
+makedepends="libgcrypt-devel gnutls-devel gtk+-devel qt5-devel gtk+3-devel"
 short_desc="OS abstraction functions for various projects"
+maintainer="Enno Boland <gottox@voidlinux.org>"
+license="LGPL-2.1-or-later"
 homepage="https://github.com/aqbanking/gwenhywfar"
 distfiles="https://github.com/aqbanking/gwenhywfar/archive/${version}.tar.gz"
-checksum=efc4b9dcb51981e7c56e22ac6054ace396c3387667b134128d4e9fcad50544b8
+checksum=414a29c0f28cb8172b780f2aa71a8408ce0b379304714949190398fde3bcbfbf
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" qt5-host-tools qt5-devel"
@@ -22,8 +20,36 @@ fi
 
 pre_configure() {
 	# Build all GUIs
-	sed -i configure.ac -e's;"qt4 gtk2";"qt5 gtk2 gtk3";'
+	vsed -i configure.ac -e's;"qt4 gtk2";"qt5 gtk2 gtk3";'
 	autoreconf -fi
+	if [ "$CROSS_BUILD" ]; then
+                cat > "${wrksrc}/qt.conf" <<_EOF
+[Paths]
+Sysroot=${XBPS_CROSS_BASE}
+Prefix=${XBPS_CROSS_BASE}/usr
+ArchData=${XBPS_CROSS_BASE}/usr/lib/qt5
+Data=${XBPS_CROSS_BASE}/usr/share/qt5
+Documentation=${XBPS_CROSS_BASE}/usr/share/doc/qt5
+Headers=${XBPS_CROSS_BASE}/usr/include/qt5
+Libraries=${XBPS_CROSS_BASE}/usr/lib
+LibraryExecutables=/usr/lib/qt5/libexec
+Binaries=/usr/lib/qt5/bin
+Tests=${XBPS_CROSS_BASE}/usr/tests
+Plugins=/usr/lib/qt5/plugins
+Imports=${XBPS_CROSS_BASE}/usr/lib/qt5/imports
+Qml2Imports=${XBPS_CROSS_BASE}/usr/lib/qt5/qml
+Translations=${XBPS_CROSS_BASE}/usr/share/qt5/translations
+Settings=${XBPS_CROSS_BASE}/etc/xdg
+Examples=${XBPS_CROSS_BASE}/usr/share/qt5/examples
+HostPrefix=/usr
+HostData=/usr/lib/qt5
+HostBinaries=/usr/lib/qt5/bin
+HostLibraries=/usr/lib
+Spec=linux-g++
+TargetSpec=linux-g++
+_EOF
+	configure_args+=" --with-qt5-config=${wrksrc}/qt.conf"
+        fi
 }
 
 gwenhywfar-gtk_package() {

From 4fcb9cda0b4889e6a9bd12244dd0e6e3aa0c070e Mon Sep 17 00:00:00 2001
From: Helmut Pozimski <helmut@pozimski.eu>
Date: Mon, 13 Jan 2020 08:55:46 +0100
Subject: [PATCH 2/5] aqbanking: update to 5.99.45. (soname bump)

---
 common/shlibs              | 2 +-
 srcpkgs/aqbanking/template | 8 ++++----
 2 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index 8ea6617ba71..d9ab1d2ae63 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -1489,7 +1489,7 @@ libgwengui-gtk2.so.0 gwenhywfar-gtk-4.10.0beta_1
 libgwengui-gtk3.so.0 gwenhywfar-gtk3-4.20.0_1
 libgwengui-cpp.so.0 gwenhywfar-4.10.0beta_1
 libgwengui-qt5.so.0 gwenhywfar-qt5-4.15.3_3
-libaqbanking.so.35 aqbanking-5.6.10_1
+libaqbanking.so.43 aqbanking-5.99.45_1
 libaqnone.so.35 aqbanking-5.6.10_1
 libaqhbci.so.24 aqbanking-5.7.8_1
 libaqofxconnect.so.7 aqbanking-5.0.25_1
diff --git a/srcpkgs/aqbanking/template b/srcpkgs/aqbanking/template
index ed906ea0645..dbe2a2f725a 100644
--- a/srcpkgs/aqbanking/template
+++ b/srcpkgs/aqbanking/template
@@ -1,16 +1,16 @@
 # Template file for 'aqbanking'
 pkgname=aqbanking
-version=5.8.2
+version=5.99.45
 revision=1
 build_style=gnu-configure
-hostmakedepends="pkg-config gwenhywfar"
+hostmakedepends="pkg-config gwenhywfar tar"
 makedepends="gwenhywfar-devel xmlsec1-devel ktoblzcheck-devel gmp-devel"
 short_desc="Library for online banking and financial applications"
 maintainer="Enno Boland <gottox@voidlinux.org>"
 license="GPL-2.0-only, GPL-3.0-only"
 homepage="http://www.aquamaniac.de/aqbanking"
-distfiles="https://www.aquamaniac.de/rdm/attachments/download/107/aqbanking-${version}.tar.gz"
-checksum=93ca523fe175e72042db75f8c3fc6255ab058cf82caf52796e15f030809fb15e
+distfiles="https://www.aquamaniac.de/rdm/attachments/download/232/aqbanking-${version}.tar.gz"
+checksum=7e98f6eb817e6efe4a5f803af51781f7a6a8ae769a6c77ae324ed99033bd143f
 disable_parallel_build=yes
 
 if [ "$CROSS_BUILD" ]; then

From c294e0cb876c9dd7d62a56edb92ce733b7728920 Mon Sep 17 00:00:00 2001
From: Helmut Pozimski <helmut@pozimski.eu>
Date: Mon, 13 Jan 2020 08:45:22 +0100
Subject: [PATCH 3/5] libchipcard: rebuild against gwenhywfar-5.1.0

---
 srcpkgs/libchipcard/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/libchipcard/template b/srcpkgs/libchipcard/template
index 2bc45ae50b7..7453dd093c4 100644
--- a/srcpkgs/libchipcard/template
+++ b/srcpkgs/libchipcard/template
@@ -1,15 +1,15 @@
 # Template file for 'libchipcard'
 pkgname=libchipcard
 version=5.0.4
-revision=2
+revision=3
 build_style=gnu-configure
 hostmakedepends="gwenhywfar-devel pkg-config"
 makedepends="gwenhywfar-devel pcsclite-devel zlib-devel"
-short_desc="A library for easy access to chip cards via chipcard readers"
+short_desc="Library for easy access to chip cards via chipcard readers"
 maintainer="Matthias Fulz <mfulz@olznet.de>"
 license="LGPL-2.1-only"
 homepage="http://www.libchipcard.de"
-distfiles="https://www.aquamaniac.de/sites/download/download.php?package=02&release=200&file=01&dummy=${pkgname}-${version}.tar.gz"
+distfiles="https://www.aquamaniac.de/rdm/attachments/download/158/libchipcard-${version}.tar.gz"
 checksum=d25a79adcf09f1058ca9168b80e843fadbd556fb0f23c890d871124ad380423a
 
 libchipcard-devel_package() {

From cdba36e72174002641dd5bba26585a385d34c38b Mon Sep 17 00:00:00 2001
From: Helmut Pozimski <helmut@pozimski.eu>
Date: Mon, 13 Jan 2020 08:45:22 +0100
Subject: [PATCH 4/5] gnucash: rebuild against gwenhywfar-5.1.0

---
 srcpkgs/gnucash/template | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/gnucash/template b/srcpkgs/gnucash/template
index 432ec009f1c..7efc1112028 100644
--- a/srcpkgs/gnucash/template
+++ b/srcpkgs/gnucash/template
@@ -1,11 +1,11 @@
 # Template file for 'gnucash'
 pkgname=gnucash
 version=3.8b
-revision=1
+revision=2
 wrksrc="${pkgname}-${version%b}"
 build_style=cmake
 configure_args="-DWITH_SQL=0 -DWITH_PYTHON=1"
-hostmakedepends="pkg-config guile python3 libxslt perl"
+hostmakedepends="pkg-config guile python3 libxslt perl gettext"
 makedepends="aqbanking-devel boost-devel gc-devel glib-devel gtest-devel guile-devel
  gwenhywfar-devel ktoblzcheck-devel libofx-devel libsecret-devel
  libxslt-devel webkit2gtk-devel python3-devel gwenhywfar-gtk3"
@@ -17,7 +17,6 @@ homepage="http://www.gnucash.org"
 distfiles="${SOURCEFORGE_SITE}/${pkgname}/${pkgname}-${version}.tar.bz2"
 checksum=0f5eca83d8836a325d9a02c6ed7b4d53e59abcff974e5d90914c9e15d7a87f37
 
-pycompile_module="gnucash"
 pycompile_dirs="usr/share/gnucash/python"
 conf_files="/etc/gnucash/environment"
 nocross="fails to compile guile code when cross-compiling"

From f99af42a532cb3098664b2d6fa20174b734cf19e Mon Sep 17 00:00:00 2001
From: Helmut Pozimski <helmut@pozimski.eu>
Date: Mon, 13 Jan 2020 10:00:43 +0100
Subject: [PATCH 5/5] kmymoney: update to 5.0.7.

---
 srcpkgs/kmymoney/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/kmymoney/template b/srcpkgs/kmymoney/template
index 5e99dc91cff..310a225d9c3 100644
--- a/srcpkgs/kmymoney/template
+++ b/srcpkgs/kmymoney/template
@@ -1,12 +1,12 @@
 # Template file for 'kmymoney'
 pkgname=kmymoney
-version=5.0.6
-revision=3
+version=5.0.7
+revision=1
 build_style=cmake
 configure_args="-DDESKTOPTOJSON_EXECUTABLE=/usr/bin/desktoptojson
  -DBUILD_TESTING=OFF"
 hostmakedepends="extra-cmake-modules kconfig kcoreaddons kdoctools pkg-config
- python qt5-host-tools qt5-qmake"
+ python3 qt5-host-tools qt5-qmake gettext"
 makedepends="akonadi5-devel aqbanking-devel gmp-devel gmpxx-devel gpgmeqt-devel
  gwenhywfar-devel gwenhywfar-qt5 kactivities5-devel kcmutils-devel
  kcontacts-devel kdewebkit-devel kdiagram-devel kholidays-devel
@@ -18,7 +18,7 @@ maintainer="Helmut Pozimski <helmut@pozimski.eu>"
 license="GPL-2.0-or-later"
 homepage="https://kmymoney.org"
 distfiles="${KDE_SITE}/kmymoney/${version}/src/${pkgname}-${version}.tar.xz"
-checksum=ba945fb26fff581f95e1132f50d222bd51a2458b959a9b7cb468ba617cfa9183
+checksum=d5dcac31db410861fe74955109715012bcddfd095cdbb18c91827a77dffeb5c0
 
 if [ "$CROSS_BUILD" ]; then
 	configure_args+=" -DENABLE_LIBICAL=0"
@@ -26,7 +26,7 @@ fi
 
 post_extract() {
 	if [ "$CROSS_BUILD" ]; then
-		sed /find_package\(Libical\)/d -i CMakeLists.txt
+		vsed /find_package\(Libical\)/d -i CMakeLists.txt
 	fi
 }
 

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PR PATCH] [Updated] [WIP] Kmymoney 5.0.7
  2020-01-13  9:01 [PR PATCH] Kmymoney 5.0.7 voidlinux-github
                   ` (2 preceding siblings ...)
  2020-01-16 18:48 ` [PR PATCH] [Updated] [WIP] " voidlinux-github
@ 2020-01-16 18:53 ` voidlinux-github
  2020-01-16 18:55 ` voidlinux-github
  2020-01-16 19:36 ` [PR PATCH] [Merged]: " voidlinux-github
  5 siblings, 0 replies; 7+ messages in thread
From: voidlinux-github @ 2020-01-16 18:53 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 321 bytes --]

There is an updated pull request by Hoshpak against master on the void-packages repository

https://github.com/Hoshpak/void-packages kmymoney-5.0.7
https://github.com/void-linux/void-packages/pull/18284

[WIP] Kmymoney 5.0.7
None

A patch file from https://github.com/void-linux/void-packages/pull/18284.patch is attached

[-- Warning: decoded text below may be mangled --]
[-- Attachment #2: github-pr-kmymoney-5.0.7-18284.patch --]
[-- Type: text/x-diff, Size: 11553 bytes --]

From 356e0c06fe80a3d4f54114d5cca5e66f3f622605 Mon Sep 17 00:00:00 2001
From: Helmut Pozimski <helmut@pozimski.eu>
Date: Mon, 13 Jan 2020 08:42:32 +0100
Subject: [PATCH 1/5] gwenhywfar: update to 5.1.0. (soname bump)

---
 common/shlibs                              |  2 +-
 srcpkgs/gwenhywfar/patches/qt5-cross.patch | 28 +++++++++++++
 srcpkgs/gwenhywfar/template                | 46 +++++++++++++++++-----
 3 files changed, 65 insertions(+), 11 deletions(-)
 create mode 100644 srcpkgs/gwenhywfar/patches/qt5-cross.patch

diff --git a/common/shlibs b/common/shlibs
index 51692ea249d..8ea6617ba71 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -1484,7 +1484,7 @@ libdom.so.0 libdom-0.0.1_1
 libslang.so.2 slang-2.2.4_1
 libtre.so.5 tre-0.8.0_1
 libktoblzcheck.so.1 ktoblzcheck-1.43_2
-libgwenhywfar.so.60 gwenhywfar-4.10.0beta_1
+libgwenhywfar.so.79 gwenhywfar-5.1.0_1
 libgwengui-gtk2.so.0 gwenhywfar-gtk-4.10.0beta_1
 libgwengui-gtk3.so.0 gwenhywfar-gtk3-4.20.0_1
 libgwengui-cpp.so.0 gwenhywfar-4.10.0beta_1
diff --git a/srcpkgs/gwenhywfar/patches/qt5-cross.patch b/srcpkgs/gwenhywfar/patches/qt5-cross.patch
new file mode 100644
index 00000000000..41b447e2b73
--- /dev/null
+++ b/srcpkgs/gwenhywfar/patches/qt5-cross.patch
@@ -0,0 +1,28 @@
+--- m4/ax_have_qt.m4.ORIG	2020-01-16 19:40:22.927813462 +0100
++++ m4/ax_have_qt.m4	2020-01-16 19:42:12.106436543 +0100
+@@ -74,6 +74,12 @@
+     [QT_QMAKE="qmake"]
+   )
+ 
++  AC_ARG_WITH(qt5-config,
++    [  --with-qt5-config=FILE   uses given qt configuration],
++    [QT_CONFIGURATION="$withval"],
++    [QT_CONFIGURATION=""]
++  )
++
+   AC_MSG_CHECKING(for Qt)
+   # If we have Qt5 or later in the path, we're golden
+   ver=`$QT_QMAKE --version | grep -o "Qt version ."`
+@@ -122,7 +128,11 @@
+ percent.commands = @echo -n "\$(\$(@))\ "
+ QMAKE_EXTRA_TARGETS += percent
+ EOF
+-    $QT_QMAKE $am_have_qt_pro -o $am_have_qt_makefile
++    if test -z $QT_CONFIGURATION; then
++        $QT_QMAKE $am_have_qt_pro -o $am_have_qt_makefile
++    else
++        $QT_QMAKE $am_have_qt_pro -o $am_have_qt_makefile -qtconf $QT_CONFIGURATION
++    fi
+     QT_CXXFLAGS=`make -s -f $am_have_qt_makefile CXXFLAGS INCPATH`
+     QT_LIBS=`make -s -f $am_have_qt_makefile LIBS`
+     rm $am_have_qt_pro $am_have_qt_makefile
diff --git a/srcpkgs/gwenhywfar/template b/srcpkgs/gwenhywfar/template
index 2407ac90bcd..2cc807c20a5 100644
--- a/srcpkgs/gwenhywfar/template
+++ b/srcpkgs/gwenhywfar/template
@@ -1,20 +1,18 @@
 # Template file for 'gwenhywfar'
 pkgname=gwenhywfar
-version=4.20.1
-revision=3
-hostmakedepends="automake pkg-config libgcrypt-devel libtool"
-makedepends="libgcrypt-devel gnutls-devel gtk+-devel qt5-devel gtk+3-devel"
+version=5.1.0
+revision=1
 build_style=gnu-configure
 configure_args="--enable-visibility --disable-binreloc
- --with-qt5-includes=${XBPS_CROSS_BASE}/usr/include
- --with-qt5-libs=${XBPS_CROSS_BASE}/usr/lib
  --with-qt5-moc=/usr/lib/qt5/bin/moc --with-qt5-uic=/usr/lib/qt5/bin/uic"
-maintainer="Enno Boland <gottox@voidlinux.org>"
-license="LGPL-2.1"
+hostmakedepends="automake pkg-config libgcrypt-devel libtool which"
+makedepends="libgcrypt-devel gnutls-devel gtk+-devel qt5-devel gtk+3-devel"
 short_desc="OS abstraction functions for various projects"
+maintainer="Enno Boland <gottox@voidlinux.org>"
+license="LGPL-2.1-or-later"
 homepage="https://github.com/aqbanking/gwenhywfar"
 distfiles="https://github.com/aqbanking/gwenhywfar/archive/${version}.tar.gz"
-checksum=efc4b9dcb51981e7c56e22ac6054ace396c3387667b134128d4e9fcad50544b8
+checksum=414a29c0f28cb8172b780f2aa71a8408ce0b379304714949190398fde3bcbfbf
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" qt5-host-tools qt5-devel"
@@ -22,8 +20,36 @@ fi
 
 pre_configure() {
 	# Build all GUIs
-	sed -i configure.ac -e's;"qt4 gtk2";"qt5 gtk2 gtk3";'
+	vsed -i configure.ac -e's;"qt4 gtk2";"qt5 gtk2 gtk3";'
 	autoreconf -fi
+	if [ "$CROSS_BUILD" ]; then
+                cat > "${wrksrc}/qt.conf" <<_EOF
+[Paths]
+Sysroot=${XBPS_CROSS_BASE}
+Prefix=${XBPS_CROSS_BASE}/usr
+ArchData=${XBPS_CROSS_BASE}/usr/lib/qt5
+Data=${XBPS_CROSS_BASE}/usr/share/qt5
+Documentation=${XBPS_CROSS_BASE}/usr/share/doc/qt5
+Headers=${XBPS_CROSS_BASE}/usr/include/qt5
+Libraries=${XBPS_CROSS_BASE}/usr/lib
+LibraryExecutables=/usr/lib/qt5/libexec
+Binaries=/usr/lib/qt5/bin
+Tests=${XBPS_CROSS_BASE}/usr/tests
+Plugins=/usr/lib/qt5/plugins
+Imports=${XBPS_CROSS_BASE}/usr/lib/qt5/imports
+Qml2Imports=${XBPS_CROSS_BASE}/usr/lib/qt5/qml
+Translations=${XBPS_CROSS_BASE}/usr/share/qt5/translations
+Settings=${XBPS_CROSS_BASE}/etc/xdg
+Examples=${XBPS_CROSS_BASE}/usr/share/qt5/examples
+HostPrefix=/usr
+HostData=/usr/lib/qt5
+HostBinaries=/usr/lib/qt5/bin
+HostLibraries=/usr/lib
+Spec=linux-g++
+TargetSpec=linux-g++
+_EOF
+	configure_args+=" --with-qt5-config=${wrksrc}/qt.conf"
+        fi
 }
 
 gwenhywfar-gtk_package() {

From 9891ab74d80cc8f5ad1d6ed2e190411fbcd9b51b Mon Sep 17 00:00:00 2001
From: Helmut Pozimski <helmut@pozimski.eu>
Date: Mon, 13 Jan 2020 08:55:46 +0100
Subject: [PATCH 2/5] aqbanking: update to 5.99.45. (soname bump)

---
 common/shlibs              |  2 +-
 srcpkgs/aqbanking/template | 11 ++++++-----
 2 files changed, 7 insertions(+), 6 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index 8ea6617ba71..d9ab1d2ae63 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -1489,7 +1489,7 @@ libgwengui-gtk2.so.0 gwenhywfar-gtk-4.10.0beta_1
 libgwengui-gtk3.so.0 gwenhywfar-gtk3-4.20.0_1
 libgwengui-cpp.so.0 gwenhywfar-4.10.0beta_1
 libgwengui-qt5.so.0 gwenhywfar-qt5-4.15.3_3
-libaqbanking.so.35 aqbanking-5.6.10_1
+libaqbanking.so.43 aqbanking-5.99.45_1
 libaqnone.so.35 aqbanking-5.6.10_1
 libaqhbci.so.24 aqbanking-5.7.8_1
 libaqofxconnect.so.7 aqbanking-5.0.25_1
diff --git a/srcpkgs/aqbanking/template b/srcpkgs/aqbanking/template
index ed906ea0645..be2e05a0c36 100644
--- a/srcpkgs/aqbanking/template
+++ b/srcpkgs/aqbanking/template
@@ -1,20 +1,21 @@
 # Template file for 'aqbanking'
 pkgname=aqbanking
-version=5.8.2
+version=5.99.45
 revision=1
 build_style=gnu-configure
-hostmakedepends="pkg-config gwenhywfar"
+hostmakedepends="pkg-config gwenhywfar tar"
 makedepends="gwenhywfar-devel xmlsec1-devel ktoblzcheck-devel gmp-devel"
 short_desc="Library for online banking and financial applications"
 maintainer="Enno Boland <gottox@voidlinux.org>"
 license="GPL-2.0-only, GPL-3.0-only"
 homepage="http://www.aquamaniac.de/aqbanking"
-distfiles="https://www.aquamaniac.de/rdm/attachments/download/107/aqbanking-${version}.tar.gz"
-checksum=93ca523fe175e72042db75f8c3fc6255ab058cf82caf52796e15f030809fb15e
+distfiles="https://www.aquamaniac.de/rdm/attachments/download/232/aqbanking-${version}.tar.gz"
+checksum=7e98f6eb817e6efe4a5f803af51781f7a6a8ae769a6c77ae324ed99033bd143f
 disable_parallel_build=yes
 
 if [ "$CROSS_BUILD" ]; then
-	configure_args+=" --with-gwen-dir=${XBPS_CROSS_BASE} -with-xmlmerge=/usr/bin/xmlmerge"
+	export PKG_CONFIG_PATH=${XBPS_CROSS_BASE}/usr/lib/pkgconfig
+	configure_args+=" -with-xmlmerge=/usr/bin/xmlmerge"
 	export CFLAGS+=" -I${XBPS_CROSS_BASE}/usr/include/gwenhywfar4"
 	export CXXFLAGS+=" -I${XBPS_CROSS_BASE}/usr/include/gwenhywfar4"
 fi

From 1d97b4bee4b32c4c2729ea26d605a81e186c0d49 Mon Sep 17 00:00:00 2001
From: Helmut Pozimski <helmut@pozimski.eu>
Date: Mon, 13 Jan 2020 08:45:22 +0100
Subject: [PATCH 3/5] libchipcard: rebuild against gwenhywfar-5.1.0

---
 srcpkgs/libchipcard/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/libchipcard/template b/srcpkgs/libchipcard/template
index 2bc45ae50b7..7453dd093c4 100644
--- a/srcpkgs/libchipcard/template
+++ b/srcpkgs/libchipcard/template
@@ -1,15 +1,15 @@
 # Template file for 'libchipcard'
 pkgname=libchipcard
 version=5.0.4
-revision=2
+revision=3
 build_style=gnu-configure
 hostmakedepends="gwenhywfar-devel pkg-config"
 makedepends="gwenhywfar-devel pcsclite-devel zlib-devel"
-short_desc="A library for easy access to chip cards via chipcard readers"
+short_desc="Library for easy access to chip cards via chipcard readers"
 maintainer="Matthias Fulz <mfulz@olznet.de>"
 license="LGPL-2.1-only"
 homepage="http://www.libchipcard.de"
-distfiles="https://www.aquamaniac.de/sites/download/download.php?package=02&release=200&file=01&dummy=${pkgname}-${version}.tar.gz"
+distfiles="https://www.aquamaniac.de/rdm/attachments/download/158/libchipcard-${version}.tar.gz"
 checksum=d25a79adcf09f1058ca9168b80e843fadbd556fb0f23c890d871124ad380423a
 
 libchipcard-devel_package() {

From 8f9c8f0926f5e746c4398fb1f1557eeb4156b082 Mon Sep 17 00:00:00 2001
From: Helmut Pozimski <helmut@pozimski.eu>
Date: Mon, 13 Jan 2020 08:45:22 +0100
Subject: [PATCH 4/5] gnucash: rebuild against gwenhywfar-5.1.0

---
 srcpkgs/gnucash/template | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/gnucash/template b/srcpkgs/gnucash/template
index 432ec009f1c..7efc1112028 100644
--- a/srcpkgs/gnucash/template
+++ b/srcpkgs/gnucash/template
@@ -1,11 +1,11 @@
 # Template file for 'gnucash'
 pkgname=gnucash
 version=3.8b
-revision=1
+revision=2
 wrksrc="${pkgname}-${version%b}"
 build_style=cmake
 configure_args="-DWITH_SQL=0 -DWITH_PYTHON=1"
-hostmakedepends="pkg-config guile python3 libxslt perl"
+hostmakedepends="pkg-config guile python3 libxslt perl gettext"
 makedepends="aqbanking-devel boost-devel gc-devel glib-devel gtest-devel guile-devel
  gwenhywfar-devel ktoblzcheck-devel libofx-devel libsecret-devel
  libxslt-devel webkit2gtk-devel python3-devel gwenhywfar-gtk3"
@@ -17,7 +17,6 @@ homepage="http://www.gnucash.org"
 distfiles="${SOURCEFORGE_SITE}/${pkgname}/${pkgname}-${version}.tar.bz2"
 checksum=0f5eca83d8836a325d9a02c6ed7b4d53e59abcff974e5d90914c9e15d7a87f37
 
-pycompile_module="gnucash"
 pycompile_dirs="usr/share/gnucash/python"
 conf_files="/etc/gnucash/environment"
 nocross="fails to compile guile code when cross-compiling"

From ea1453e2d3d7f65fe6551425ff31f41b529251ac Mon Sep 17 00:00:00 2001
From: Helmut Pozimski <helmut@pozimski.eu>
Date: Mon, 13 Jan 2020 10:00:43 +0100
Subject: [PATCH 5/5] kmymoney: update to 5.0.7.

---
 srcpkgs/kmymoney/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/kmymoney/template b/srcpkgs/kmymoney/template
index 5e99dc91cff..310a225d9c3 100644
--- a/srcpkgs/kmymoney/template
+++ b/srcpkgs/kmymoney/template
@@ -1,12 +1,12 @@
 # Template file for 'kmymoney'
 pkgname=kmymoney
-version=5.0.6
-revision=3
+version=5.0.7
+revision=1
 build_style=cmake
 configure_args="-DDESKTOPTOJSON_EXECUTABLE=/usr/bin/desktoptojson
  -DBUILD_TESTING=OFF"
 hostmakedepends="extra-cmake-modules kconfig kcoreaddons kdoctools pkg-config
- python qt5-host-tools qt5-qmake"
+ python3 qt5-host-tools qt5-qmake gettext"
 makedepends="akonadi5-devel aqbanking-devel gmp-devel gmpxx-devel gpgmeqt-devel
  gwenhywfar-devel gwenhywfar-qt5 kactivities5-devel kcmutils-devel
  kcontacts-devel kdewebkit-devel kdiagram-devel kholidays-devel
@@ -18,7 +18,7 @@ maintainer="Helmut Pozimski <helmut@pozimski.eu>"
 license="GPL-2.0-or-later"
 homepage="https://kmymoney.org"
 distfiles="${KDE_SITE}/kmymoney/${version}/src/${pkgname}-${version}.tar.xz"
-checksum=ba945fb26fff581f95e1132f50d222bd51a2458b959a9b7cb468ba617cfa9183
+checksum=d5dcac31db410861fe74955109715012bcddfd095cdbb18c91827a77dffeb5c0
 
 if [ "$CROSS_BUILD" ]; then
 	configure_args+=" -DENABLE_LIBICAL=0"
@@ -26,7 +26,7 @@ fi
 
 post_extract() {
 	if [ "$CROSS_BUILD" ]; then
-		sed /find_package\(Libical\)/d -i CMakeLists.txt
+		vsed /find_package\(Libical\)/d -i CMakeLists.txt
 	fi
 }
 

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PR PATCH] [Updated] [WIP] Kmymoney 5.0.7
  2020-01-13  9:01 [PR PATCH] Kmymoney 5.0.7 voidlinux-github
                   ` (3 preceding siblings ...)
  2020-01-16 18:53 ` voidlinux-github
@ 2020-01-16 18:55 ` voidlinux-github
  2020-01-16 19:36 ` [PR PATCH] [Merged]: " voidlinux-github
  5 siblings, 0 replies; 7+ messages in thread
From: voidlinux-github @ 2020-01-16 18:55 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 321 bytes --]

There is an updated pull request by Hoshpak against master on the void-packages repository

https://github.com/Hoshpak/void-packages kmymoney-5.0.7
https://github.com/void-linux/void-packages/pull/18284

[WIP] Kmymoney 5.0.7
None

A patch file from https://github.com/void-linux/void-packages/pull/18284.patch is attached

[-- Warning: decoded text below may be mangled --]
[-- Attachment #2: github-pr-kmymoney-5.0.7-18284.patch --]
[-- Type: text/x-diff, Size: 11586 bytes --]

From 356e0c06fe80a3d4f54114d5cca5e66f3f622605 Mon Sep 17 00:00:00 2001
From: Helmut Pozimski <helmut@pozimski.eu>
Date: Mon, 13 Jan 2020 08:42:32 +0100
Subject: [PATCH 1/5] gwenhywfar: update to 5.1.0. (soname bump)

---
 common/shlibs                              |  2 +-
 srcpkgs/gwenhywfar/patches/qt5-cross.patch | 28 +++++++++++++
 srcpkgs/gwenhywfar/template                | 46 +++++++++++++++++-----
 3 files changed, 65 insertions(+), 11 deletions(-)
 create mode 100644 srcpkgs/gwenhywfar/patches/qt5-cross.patch

diff --git a/common/shlibs b/common/shlibs
index 51692ea249d..8ea6617ba71 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -1484,7 +1484,7 @@ libdom.so.0 libdom-0.0.1_1
 libslang.so.2 slang-2.2.4_1
 libtre.so.5 tre-0.8.0_1
 libktoblzcheck.so.1 ktoblzcheck-1.43_2
-libgwenhywfar.so.60 gwenhywfar-4.10.0beta_1
+libgwenhywfar.so.79 gwenhywfar-5.1.0_1
 libgwengui-gtk2.so.0 gwenhywfar-gtk-4.10.0beta_1
 libgwengui-gtk3.so.0 gwenhywfar-gtk3-4.20.0_1
 libgwengui-cpp.so.0 gwenhywfar-4.10.0beta_1
diff --git a/srcpkgs/gwenhywfar/patches/qt5-cross.patch b/srcpkgs/gwenhywfar/patches/qt5-cross.patch
new file mode 100644
index 00000000000..41b447e2b73
--- /dev/null
+++ b/srcpkgs/gwenhywfar/patches/qt5-cross.patch
@@ -0,0 +1,28 @@
+--- m4/ax_have_qt.m4.ORIG	2020-01-16 19:40:22.927813462 +0100
++++ m4/ax_have_qt.m4	2020-01-16 19:42:12.106436543 +0100
+@@ -74,6 +74,12 @@
+     [QT_QMAKE="qmake"]
+   )
+ 
++  AC_ARG_WITH(qt5-config,
++    [  --with-qt5-config=FILE   uses given qt configuration],
++    [QT_CONFIGURATION="$withval"],
++    [QT_CONFIGURATION=""]
++  )
++
+   AC_MSG_CHECKING(for Qt)
+   # If we have Qt5 or later in the path, we're golden
+   ver=`$QT_QMAKE --version | grep -o "Qt version ."`
+@@ -122,7 +128,11 @@
+ percent.commands = @echo -n "\$(\$(@))\ "
+ QMAKE_EXTRA_TARGETS += percent
+ EOF
+-    $QT_QMAKE $am_have_qt_pro -o $am_have_qt_makefile
++    if test -z $QT_CONFIGURATION; then
++        $QT_QMAKE $am_have_qt_pro -o $am_have_qt_makefile
++    else
++        $QT_QMAKE $am_have_qt_pro -o $am_have_qt_makefile -qtconf $QT_CONFIGURATION
++    fi
+     QT_CXXFLAGS=`make -s -f $am_have_qt_makefile CXXFLAGS INCPATH`
+     QT_LIBS=`make -s -f $am_have_qt_makefile LIBS`
+     rm $am_have_qt_pro $am_have_qt_makefile
diff --git a/srcpkgs/gwenhywfar/template b/srcpkgs/gwenhywfar/template
index 2407ac90bcd..2cc807c20a5 100644
--- a/srcpkgs/gwenhywfar/template
+++ b/srcpkgs/gwenhywfar/template
@@ -1,20 +1,18 @@
 # Template file for 'gwenhywfar'
 pkgname=gwenhywfar
-version=4.20.1
-revision=3
-hostmakedepends="automake pkg-config libgcrypt-devel libtool"
-makedepends="libgcrypt-devel gnutls-devel gtk+-devel qt5-devel gtk+3-devel"
+version=5.1.0
+revision=1
 build_style=gnu-configure
 configure_args="--enable-visibility --disable-binreloc
- --with-qt5-includes=${XBPS_CROSS_BASE}/usr/include
- --with-qt5-libs=${XBPS_CROSS_BASE}/usr/lib
  --with-qt5-moc=/usr/lib/qt5/bin/moc --with-qt5-uic=/usr/lib/qt5/bin/uic"
-maintainer="Enno Boland <gottox@voidlinux.org>"
-license="LGPL-2.1"
+hostmakedepends="automake pkg-config libgcrypt-devel libtool which"
+makedepends="libgcrypt-devel gnutls-devel gtk+-devel qt5-devel gtk+3-devel"
 short_desc="OS abstraction functions for various projects"
+maintainer="Enno Boland <gottox@voidlinux.org>"
+license="LGPL-2.1-or-later"
 homepage="https://github.com/aqbanking/gwenhywfar"
 distfiles="https://github.com/aqbanking/gwenhywfar/archive/${version}.tar.gz"
-checksum=efc4b9dcb51981e7c56e22ac6054ace396c3387667b134128d4e9fcad50544b8
+checksum=414a29c0f28cb8172b780f2aa71a8408ce0b379304714949190398fde3bcbfbf
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" qt5-host-tools qt5-devel"
@@ -22,8 +20,36 @@ fi
 
 pre_configure() {
 	# Build all GUIs
-	sed -i configure.ac -e's;"qt4 gtk2";"qt5 gtk2 gtk3";'
+	vsed -i configure.ac -e's;"qt4 gtk2";"qt5 gtk2 gtk3";'
 	autoreconf -fi
+	if [ "$CROSS_BUILD" ]; then
+                cat > "${wrksrc}/qt.conf" <<_EOF
+[Paths]
+Sysroot=${XBPS_CROSS_BASE}
+Prefix=${XBPS_CROSS_BASE}/usr
+ArchData=${XBPS_CROSS_BASE}/usr/lib/qt5
+Data=${XBPS_CROSS_BASE}/usr/share/qt5
+Documentation=${XBPS_CROSS_BASE}/usr/share/doc/qt5
+Headers=${XBPS_CROSS_BASE}/usr/include/qt5
+Libraries=${XBPS_CROSS_BASE}/usr/lib
+LibraryExecutables=/usr/lib/qt5/libexec
+Binaries=/usr/lib/qt5/bin
+Tests=${XBPS_CROSS_BASE}/usr/tests
+Plugins=/usr/lib/qt5/plugins
+Imports=${XBPS_CROSS_BASE}/usr/lib/qt5/imports
+Qml2Imports=${XBPS_CROSS_BASE}/usr/lib/qt5/qml
+Translations=${XBPS_CROSS_BASE}/usr/share/qt5/translations
+Settings=${XBPS_CROSS_BASE}/etc/xdg
+Examples=${XBPS_CROSS_BASE}/usr/share/qt5/examples
+HostPrefix=/usr
+HostData=/usr/lib/qt5
+HostBinaries=/usr/lib/qt5/bin
+HostLibraries=/usr/lib
+Spec=linux-g++
+TargetSpec=linux-g++
+_EOF
+	configure_args+=" --with-qt5-config=${wrksrc}/qt.conf"
+        fi
 }
 
 gwenhywfar-gtk_package() {

From d0ccbf1bec61a7fdfdcf6d2f630b6bb281640768 Mon Sep 17 00:00:00 2001
From: Helmut Pozimski <helmut@pozimski.eu>
Date: Mon, 13 Jan 2020 08:55:46 +0100
Subject: [PATCH 2/5] aqbanking: update to 5.99.45. (soname bump)

---
 common/shlibs              |  2 +-
 srcpkgs/aqbanking/template | 13 ++++++-------
 2 files changed, 7 insertions(+), 8 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index 8ea6617ba71..d9ab1d2ae63 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -1489,7 +1489,7 @@ libgwengui-gtk2.so.0 gwenhywfar-gtk-4.10.0beta_1
 libgwengui-gtk3.so.0 gwenhywfar-gtk3-4.20.0_1
 libgwengui-cpp.so.0 gwenhywfar-4.10.0beta_1
 libgwengui-qt5.so.0 gwenhywfar-qt5-4.15.3_3
-libaqbanking.so.35 aqbanking-5.6.10_1
+libaqbanking.so.43 aqbanking-5.99.45_1
 libaqnone.so.35 aqbanking-5.6.10_1
 libaqhbci.so.24 aqbanking-5.7.8_1
 libaqofxconnect.so.7 aqbanking-5.0.25_1
diff --git a/srcpkgs/aqbanking/template b/srcpkgs/aqbanking/template
index ed906ea0645..543aa4bb2d5 100644
--- a/srcpkgs/aqbanking/template
+++ b/srcpkgs/aqbanking/template
@@ -1,22 +1,21 @@
 # Template file for 'aqbanking'
 pkgname=aqbanking
-version=5.8.2
+version=5.99.45
 revision=1
 build_style=gnu-configure
-hostmakedepends="pkg-config gwenhywfar"
+hostmakedepends="pkg-config gwenhywfar tar"
 makedepends="gwenhywfar-devel xmlsec1-devel ktoblzcheck-devel gmp-devel"
 short_desc="Library for online banking and financial applications"
 maintainer="Enno Boland <gottox@voidlinux.org>"
 license="GPL-2.0-only, GPL-3.0-only"
 homepage="http://www.aquamaniac.de/aqbanking"
-distfiles="https://www.aquamaniac.de/rdm/attachments/download/107/aqbanking-${version}.tar.gz"
-checksum=93ca523fe175e72042db75f8c3fc6255ab058cf82caf52796e15f030809fb15e
+distfiles="https://www.aquamaniac.de/rdm/attachments/download/232/aqbanking-${version}.tar.gz"
+checksum=7e98f6eb817e6efe4a5f803af51781f7a6a8ae769a6c77ae324ed99033bd143f
 disable_parallel_build=yes
 
 if [ "$CROSS_BUILD" ]; then
-	configure_args+=" --with-gwen-dir=${XBPS_CROSS_BASE} -with-xmlmerge=/usr/bin/xmlmerge"
-	export CFLAGS+=" -I${XBPS_CROSS_BASE}/usr/include/gwenhywfar4"
-	export CXXFLAGS+=" -I${XBPS_CROSS_BASE}/usr/include/gwenhywfar4"
+	export PKG_CONFIG_PATH=${XBPS_CROSS_BASE}/usr/lib/pkgconfig
+	configure_args+=" -with-xmlmerge=/usr/bin/xmlmerge"
 fi
 
 aqbanking-devel_package() {

From 0a77bffae98823c652ded31353b80b21ec902adf Mon Sep 17 00:00:00 2001
From: Helmut Pozimski <helmut@pozimski.eu>
Date: Mon, 13 Jan 2020 08:45:22 +0100
Subject: [PATCH 3/5] libchipcard: rebuild against gwenhywfar-5.1.0

---
 srcpkgs/libchipcard/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/libchipcard/template b/srcpkgs/libchipcard/template
index 2bc45ae50b7..7453dd093c4 100644
--- a/srcpkgs/libchipcard/template
+++ b/srcpkgs/libchipcard/template
@@ -1,15 +1,15 @@
 # Template file for 'libchipcard'
 pkgname=libchipcard
 version=5.0.4
-revision=2
+revision=3
 build_style=gnu-configure
 hostmakedepends="gwenhywfar-devel pkg-config"
 makedepends="gwenhywfar-devel pcsclite-devel zlib-devel"
-short_desc="A library for easy access to chip cards via chipcard readers"
+short_desc="Library for easy access to chip cards via chipcard readers"
 maintainer="Matthias Fulz <mfulz@olznet.de>"
 license="LGPL-2.1-only"
 homepage="http://www.libchipcard.de"
-distfiles="https://www.aquamaniac.de/sites/download/download.php?package=02&release=200&file=01&dummy=${pkgname}-${version}.tar.gz"
+distfiles="https://www.aquamaniac.de/rdm/attachments/download/158/libchipcard-${version}.tar.gz"
 checksum=d25a79adcf09f1058ca9168b80e843fadbd556fb0f23c890d871124ad380423a
 
 libchipcard-devel_package() {

From 8d7b8a419abb369443af2dc68a05a3b59a665961 Mon Sep 17 00:00:00 2001
From: Helmut Pozimski <helmut@pozimski.eu>
Date: Mon, 13 Jan 2020 08:45:22 +0100
Subject: [PATCH 4/5] gnucash: rebuild against gwenhywfar-5.1.0

---
 srcpkgs/gnucash/template | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/gnucash/template b/srcpkgs/gnucash/template
index 432ec009f1c..7efc1112028 100644
--- a/srcpkgs/gnucash/template
+++ b/srcpkgs/gnucash/template
@@ -1,11 +1,11 @@
 # Template file for 'gnucash'
 pkgname=gnucash
 version=3.8b
-revision=1
+revision=2
 wrksrc="${pkgname}-${version%b}"
 build_style=cmake
 configure_args="-DWITH_SQL=0 -DWITH_PYTHON=1"
-hostmakedepends="pkg-config guile python3 libxslt perl"
+hostmakedepends="pkg-config guile python3 libxslt perl gettext"
 makedepends="aqbanking-devel boost-devel gc-devel glib-devel gtest-devel guile-devel
  gwenhywfar-devel ktoblzcheck-devel libofx-devel libsecret-devel
  libxslt-devel webkit2gtk-devel python3-devel gwenhywfar-gtk3"
@@ -17,7 +17,6 @@ homepage="http://www.gnucash.org"
 distfiles="${SOURCEFORGE_SITE}/${pkgname}/${pkgname}-${version}.tar.bz2"
 checksum=0f5eca83d8836a325d9a02c6ed7b4d53e59abcff974e5d90914c9e15d7a87f37
 
-pycompile_module="gnucash"
 pycompile_dirs="usr/share/gnucash/python"
 conf_files="/etc/gnucash/environment"
 nocross="fails to compile guile code when cross-compiling"

From ff3e9ff005ff6d943c85c9eb187a98698e8f4d02 Mon Sep 17 00:00:00 2001
From: Helmut Pozimski <helmut@pozimski.eu>
Date: Mon, 13 Jan 2020 10:00:43 +0100
Subject: [PATCH 5/5] kmymoney: update to 5.0.7.

---
 srcpkgs/kmymoney/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/kmymoney/template b/srcpkgs/kmymoney/template
index 5e99dc91cff..310a225d9c3 100644
--- a/srcpkgs/kmymoney/template
+++ b/srcpkgs/kmymoney/template
@@ -1,12 +1,12 @@
 # Template file for 'kmymoney'
 pkgname=kmymoney
-version=5.0.6
-revision=3
+version=5.0.7
+revision=1
 build_style=cmake
 configure_args="-DDESKTOPTOJSON_EXECUTABLE=/usr/bin/desktoptojson
  -DBUILD_TESTING=OFF"
 hostmakedepends="extra-cmake-modules kconfig kcoreaddons kdoctools pkg-config
- python qt5-host-tools qt5-qmake"
+ python3 qt5-host-tools qt5-qmake gettext"
 makedepends="akonadi5-devel aqbanking-devel gmp-devel gmpxx-devel gpgmeqt-devel
  gwenhywfar-devel gwenhywfar-qt5 kactivities5-devel kcmutils-devel
  kcontacts-devel kdewebkit-devel kdiagram-devel kholidays-devel
@@ -18,7 +18,7 @@ maintainer="Helmut Pozimski <helmut@pozimski.eu>"
 license="GPL-2.0-or-later"
 homepage="https://kmymoney.org"
 distfiles="${KDE_SITE}/kmymoney/${version}/src/${pkgname}-${version}.tar.xz"
-checksum=ba945fb26fff581f95e1132f50d222bd51a2458b959a9b7cb468ba617cfa9183
+checksum=d5dcac31db410861fe74955109715012bcddfd095cdbb18c91827a77dffeb5c0
 
 if [ "$CROSS_BUILD" ]; then
 	configure_args+=" -DENABLE_LIBICAL=0"
@@ -26,7 +26,7 @@ fi
 
 post_extract() {
 	if [ "$CROSS_BUILD" ]; then
-		sed /find_package\(Libical\)/d -i CMakeLists.txt
+		vsed /find_package\(Libical\)/d -i CMakeLists.txt
 	fi
 }
 

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PR PATCH] [Merged]: Kmymoney 5.0.7
  2020-01-13  9:01 [PR PATCH] Kmymoney 5.0.7 voidlinux-github
                   ` (4 preceding siblings ...)
  2020-01-16 18:55 ` voidlinux-github
@ 2020-01-16 19:36 ` " voidlinux-github
  5 siblings, 0 replies; 7+ messages in thread
From: voidlinux-github @ 2020-01-16 19:36 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 152 bytes --]

There's a merged pull request on the void-packages repository

Kmymoney 5.0.7
https://github.com/void-linux/void-packages/pull/18284

Description:
None

^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, back to index

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-01-13  9:01 [PR PATCH] Kmymoney 5.0.7 voidlinux-github
2020-01-13  9:08 ` [PR PATCH] [Updated] " voidlinux-github
2020-01-13  9:09 ` voidlinux-github
2020-01-16 18:48 ` [PR PATCH] [Updated] [WIP] " voidlinux-github
2020-01-16 18:53 ` voidlinux-github
2020-01-16 18:55 ` voidlinux-github
2020-01-16 19:36 ` [PR PATCH] [Merged]: " voidlinux-github

Github messages for voidlinux

Archives are clonable: git clone --mirror http://inbox.vuxu.org/voidlinux-github

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.github.voidlinux


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git