Github messages for voidlinux
 help / color / Atom feed
* [PR PATCH] libphobos2.081: conflict with libphobos
@ 2020-07-28 20:38 Chocimier
  2020-07-29 19:32 ` [PR PATCH] [Updated] " Chocimier
  2020-07-29 19:37 ` [PR PATCH] [Merged]: " Chocimier
  0 siblings, 2 replies; 3+ messages in thread
From: Chocimier @ 2020-07-28 20:38 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 339 bytes --]

There is a new pull request by Chocimier against master on the void-packages repository

https://github.com/Chocimier/void-packages-org libphobos2.081
https://github.com/void-linux/void-packages/pull/23914

libphobos2.081: conflict with libphobos


A patch file from https://github.com/void-linux/void-packages/pull/23914.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-libphobos2.081-23914.patch --]
[-- Type: text/x-diff, Size: 1089 bytes --]

From 5deb8da752c306af3293831d676f519d7764fbbf Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Piotr=20W=C3=B3jcik?= <chocimier@tlen.pl>
Date: Tue, 28 Jul 2020 22:28:49 +0200
Subject: [PATCH] libphobos2.081: conflict with libphobos

---
 srcpkgs/dmd2.081/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/dmd2.081/template b/srcpkgs/dmd2.081/template
index e3b6cfa1f93..237c9711238 100644
--- a/srcpkgs/dmd2.081/template
+++ b/srcpkgs/dmd2.081/template
@@ -1,7 +1,7 @@
 # Template file for 'dmd2.081'
 pkgname=dmd2.081
 version=2.081.1
-revision=1
+revision=2
 create_wrksrc=yes
 hostmakedepends="which"
 makedepends="dmd-bootstrap"
@@ -93,7 +93,7 @@ dmd2.081-doc_package() {
 libphobos2.081_package() {
 	short_desc+=" - standard library"
 	license="Boost License"
-	conflicts="dmd-bootstrap"
+	conflicts="dmd-bootstrap libphobos"
 	pkg_install() {
 		vinstall ${wrksrc}/druntime/generated/linux/release/$_archbits/libdruntime.a 644 usr/lib libdruntime.a
 		vinstall ${wrksrc}/phobos/generated/linux/release/$_archbits/libphobos2.a 644 usr/lib libphobos2.a

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PR PATCH] [Updated] libphobos2.081: conflict with libphobos
  2020-07-28 20:38 [PR PATCH] libphobos2.081: conflict with libphobos Chocimier
@ 2020-07-29 19:32 ` Chocimier
  2020-07-29 19:37 ` [PR PATCH] [Merged]: " Chocimier
  1 sibling, 0 replies; 3+ messages in thread
From: Chocimier @ 2020-07-29 19:32 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 344 bytes --]

There is an updated pull request by Chocimier against master on the void-packages repository

https://github.com/Chocimier/void-packages-org libphobos2.081
https://github.com/void-linux/void-packages/pull/23914

libphobos2.081: conflict with libphobos


A patch file from https://github.com/void-linux/void-packages/pull/23914.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-libphobos2.081-23914.patch --]
[-- Type: text/x-diff, Size: 1306 bytes --]

From 4d461a00e7b24cf312d874d2cf4e83248fb3578b Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Piotr=20W=C3=B3jcik?= <chocimier@tlen.pl>
Date: Tue, 28 Jul 2020 22:28:49 +0200
Subject: [PATCH] libphobos2.081: conflict with libphobos

---
 srcpkgs/dmd2.081/template | 6 ++----
 1 file changed, 2 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/dmd2.081/template b/srcpkgs/dmd2.081/template
index e3b6cfa1f93..6bb0d3160ab 100644
--- a/srcpkgs/dmd2.081/template
+++ b/srcpkgs/dmd2.081/template
@@ -1,7 +1,7 @@
 # Template file for 'dmd2.081'
 pkgname=dmd2.081
 version=2.081.1
-revision=1
+revision=2
 create_wrksrc=yes
 hostmakedepends="which"
 makedepends="dmd-bootstrap"
@@ -75,7 +75,6 @@ do_install() {
 dmd2.081-doc_package() {
 	short_desc="Documentation and sample code for D programming language"
 	replaces="dmd-docs>=0"
-	license="Boost License"
 
 	pkg_install() {
 		cd dmd2
@@ -92,8 +91,7 @@ dmd2.081-doc_package() {
 
 libphobos2.081_package() {
 	short_desc+=" - standard library"
-	license="Boost License"
-	conflicts="dmd-bootstrap"
+	conflicts="dmd-bootstrap libphobos"
 	pkg_install() {
 		vinstall ${wrksrc}/druntime/generated/linux/release/$_archbits/libdruntime.a 644 usr/lib libdruntime.a
 		vinstall ${wrksrc}/phobos/generated/linux/release/$_archbits/libphobos2.a 644 usr/lib libphobos2.a

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PR PATCH] [Merged]: libphobos2.081: conflict with libphobos
  2020-07-28 20:38 [PR PATCH] libphobos2.081: conflict with libphobos Chocimier
  2020-07-29 19:32 ` [PR PATCH] [Updated] " Chocimier
@ 2020-07-29 19:37 ` Chocimier
  1 sibling, 0 replies; 3+ messages in thread
From: Chocimier @ 2020-07-29 19:37 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 173 bytes --]

There's a merged pull request on the void-packages repository

libphobos2.081: conflict with libphobos
https://github.com/void-linux/void-packages/pull/23914

Description:


^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, back to index

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-07-28 20:38 [PR PATCH] libphobos2.081: conflict with libphobos Chocimier
2020-07-29 19:32 ` [PR PATCH] [Updated] " Chocimier
2020-07-29 19:37 ` [PR PATCH] [Merged]: " Chocimier

Github messages for voidlinux

Archives are clonable: git clone --mirror http://inbox.vuxu.org/voidlinux-github

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.github.voidlinux


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git