Github messages for voidlinux
 help / color / mirror / Atom feed
* [PR PATCH] [WIP] Build libva with glx (remove libva-glx)
@ 2020-10-17  7:12 st3r4g
  2020-10-17  8:53 ` [PR PATCH] [Updated] " st3r4g
                   ` (13 more replies)
  0 siblings, 14 replies; 15+ messages in thread
From: st3r4g @ 2020-10-17  7:12 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 470 bytes --]

There is a new pull request by st3r4g against master on the void-packages repository

https://github.com/st3r4g/void-packages libva-with-glx
https://github.com/void-linux/void-packages/pull/25674

[WIP] Build libva with glx (remove libva-glx)
Since we have `libglvnd` now, it should be possible to build libva with glx support without introducing build cycles.
Untested for now

A patch file from https://github.com/void-linux/void-packages/pull/25674.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-libva-with-glx-25674.patch --]
[-- Type: text/x-diff, Size: 8284 bytes --]

From f1723d2d1888e9085098bce1320f80057f6e1a82 Mon Sep 17 00:00:00 2001
From: Stefano Ragni <st3r4g@protonmail.com>
Date: Sat, 17 Oct 2020 09:09:05 +0200
Subject: [PATCH] WIP

---
 srcpkgs/QMPlay2/template            |  4 +--
 srcpkgs/bomi/template               |  4 +--
 srcpkgs/libva-glx/template          | 39 ++++-------------------------
 srcpkgs/libva-glx/update            |  1 -
 srcpkgs/libva-intel-driver/template |  4 +--
 srcpkgs/libva/template              |  6 ++---
 srcpkgs/mpv/template                |  4 +--
 srcpkgs/qtav/template               |  4 +--
 srcpkgs/xine-lib/template           |  4 +--
 9 files changed, 20 insertions(+), 50 deletions(-)
 delete mode 100644 srcpkgs/libva-glx/update

diff --git a/srcpkgs/QMPlay2/template b/srcpkgs/QMPlay2/template
index 4fdb278054d..3afde9c44a7 100644
--- a/srcpkgs/QMPlay2/template
+++ b/srcpkgs/QMPlay2/template
@@ -1,12 +1,12 @@
 # Template file for 'QMPlay2'
 pkgname=QMPlay2
 version=20.07.04
-revision=1
+revision=2
 wrksrc="${pkgname}-src-${version}"
 build_style=cmake
 hostmakedepends="pkg-config qt5-qmake qt5-host-tools"
 makedepends="alsa-lib-devel ffmpeg-devel libass-devel libcdio-devel libgme-devel
- libsidplayfp-devel libva-glx-devel libXv-devel pulseaudio-devel
+ libsidplayfp-devel libva-devel libXv-devel pulseaudio-devel
  qt5-svg-devel qt5-tools-devel qt5-x11extras-devel taglib-devel
  libcdio-paranoia-devel qt5-declarative-devel"
 short_desc="Video and audio player which can play most formats and codecs"
diff --git a/srcpkgs/bomi/template b/srcpkgs/bomi/template
index eb6558441ff..5fcec8d66bf 100644
--- a/srcpkgs/bomi/template
+++ b/srcpkgs/bomi/template
@@ -1,14 +1,14 @@
 # Template file for 'bomi'
 pkgname=bomi
 version=0.9.11
-revision=16
+revision=17
 build_style=configure
 configure_args="--disable-systemd --release --prefix=/usr"
 # does not build using py3.8 because of waf issues
 hostmakedepends="python pkg-config curl perl which"
 makedepends="qt5-devel MesaLib-devel ffmpeg-devel mpg123-devel libass-devel
  libdvdread-devel libdvdnav-devel libbluray-devel icu-devel libxcb-devel
- xcb-util-wm-devel libva-devel libva-glx-devel alsa-lib-devel libvdpau-devel
+ xcb-util-wm-devel libva-devel alsa-lib-devel libvdpau-devel
  qt5-tools-devel qt5-declarative-devel qt5-svg-devel qt5-x11extras-devel
  fribidi-devel libcdio-devel libcdio-paranoia-devel pulseaudio-devel
  samba-devel libchardet-devel"
diff --git a/srcpkgs/libva-glx/template b/srcpkgs/libva-glx/template
index 19ff3ba7980..c105828dcab 100644
--- a/srcpkgs/libva-glx/template
+++ b/srcpkgs/libva-glx/template
@@ -1,44 +1,15 @@
 # Template file for 'libva-glx'
-#
-# THIS PACKAGE IS SPLITTED FROM "libva" TO AVOID A CYCLIC DEPENDENCY:
-#
-# 	libva -> mesa -> libva
-#
-# KEEP THIS PACKAGE SYNCHRONIZED WITH "libva".
-#
 pkgname=libva-glx
 version=2.9.0
-revision=1
-wrksrc="libva-${version}"
-build_style=meson
-configure_args="-Dwith_glx=yes -Dwith_wayland=yes"
-hostmakedepends="pkg-config wayland-devel"
-makedepends="libva-devel libXfixes-devel MesaLib-devel wayland-devel"
-short_desc="Video Acceleration (VA) API - GLX backend"
+revision=2
+build_style=meta
+depends=libva
+short_desc="Video Acceleration (VA) API - GLX backend (removed package)"
 maintainer="Orphaned <orphan@voidlinux.org>"
-license="MIT"
+license="none"
 homepage="https://01.org/linuxmedia/vaapi"
-changelog="https://raw.githubusercontent.com/intel/libva/master/NEWS"
-distfiles="https://github.com/intel/libva/archive/${version}.tar.gz"
-checksum=f31549dd476e01504ba6ff62f69862eb78555a9809ebe737056543a189d619dc
-
-post_install() {
-	# We are only interested in the glx component, remove everything else.
-	mkdir -p ${wrksrc}/temp/usr/lib/pkgconfig ${wrksrc}/temp/usr/include/va
-	mv ${DESTDIR}/usr/lib/libva-glx* ${wrksrc}/temp/usr/lib
-	mv ${DESTDIR}/usr/include/va/va_glx.h ${wrksrc}/temp/usr/include/va
-	mv ${DESTDIR}/usr/lib/pkgconfig/libva-glx.pc ${wrksrc}/temp/usr/lib/pkgconfig
-	rm -rf ${DESTDIR}/*
-	mv ${wrksrc}/temp/* ${DESTDIR}
-	vlicense COPYING
-}
 
 libva-glx-devel_package() {
 	depends="libva-devel ${sourcepkg}-${version}_${revision}"
 	short_desc+=" - development files"
-	pkg_install() {
-		vmove usr/include
-		vmove usr/lib/pkgconfig
-		vmove usr/lib/*.so
-	}
 }
diff --git a/srcpkgs/libva-glx/update b/srcpkgs/libva-glx/update
deleted file mode 100644
index 93fa059287c..00000000000
--- a/srcpkgs/libva-glx/update
+++ /dev/null
@@ -1 +0,0 @@
-pkgname=libva
diff --git a/srcpkgs/libva-intel-driver/template b/srcpkgs/libva-intel-driver/template
index 3cae1ab25b2..63662b4215c 100644
--- a/srcpkgs/libva-intel-driver/template
+++ b/srcpkgs/libva-intel-driver/template
@@ -1,13 +1,13 @@
 # Template file for 'libva-intel-driver'
 pkgname=libva-intel-driver
 version=2.4.1
-revision=1
+revision=2
 archs="i686* x86_64*"
 wrksrc="intel-vaapi-driver-${version}"
 build_style=meson
 configure_args="-Dwith_wayland=yes -Dwith_x11=yes"
 hostmakedepends="pkg-config"
-makedepends="libX11-devel libva-glx-devel libdrm-devel wayland-devel MesaLib-devel"
+makedepends="libX11-devel libva-devel libdrm-devel wayland-devel MesaLib-devel"
 short_desc="Video Acceleration (VA) API - Intel Graphics backend"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
diff --git a/srcpkgs/libva/template b/srcpkgs/libva/template
index d681e84c848..ef6003a8a42 100644
--- a/srcpkgs/libva/template
+++ b/srcpkgs/libva/template
@@ -1,11 +1,11 @@
 # Template file for 'libva'
 pkgname=libva
 version=2.9.0
-revision=1
+revision=2
 build_style=meson
-configure_args="-Dwith_glx=no $(vopt_if wayland -Dwith_wayland=yes)"
+configure_args="-Dwith_glx=yes $(vopt_if wayland -Dwith_wayland=yes)"
 hostmakedepends="pkg-config $(vopt_if wayland wayland-devel)"
-makedepends="libXfixes-devel libXext-devel libdrm-devel
+makedepends="libXfixes-devel libXext-devel libdrm-devel libglvnd-devel
  $(vopt_if wayland 'libffi-devel wayland-devel')"
 short_desc="Video Acceleration (VA) API"
 maintainer="Orphaned <orphan@voidlinux.org>"
diff --git a/srcpkgs/mpv/template b/srcpkgs/mpv/template
index c45a163d0b3..127af87de52 100644
--- a/srcpkgs/mpv/template
+++ b/srcpkgs/mpv/template
@@ -1,7 +1,7 @@
 # Template file for 'mpv'
 pkgname=mpv
 version=0.32.0
-revision=4
+revision=5
 build_style=waf3
 configure_args="--confdir=/etc/mpv --docdir=/usr/share/examples/mpv
  --enable-dvdnav --enable-cdda --enable-libmpv-shared
@@ -14,7 +14,7 @@ configure_args="--confdir=/etc/mpv --docdir=/usr/share/examples/mpv
 hostmakedepends="pkg-config python3-docutils perl $(vopt_if wayland wayland-devel)"
 makedepends="MesaLib-devel ffmpeg-devel harfbuzz-devel lcms2-devel libXv-devel
  libass-devel libbluray-devel libcdio-paranoia-devel libdvdnav-devel
- libguess-devel libuuid-devel libva-glx-devel rubberband-devel uchardet-devel
+ libguess-devel libuuid-devel libva-devel rubberband-devel uchardet-devel
  libarchive-devel $(vopt_if alsa alsa-lib-devel) $(vopt_if caca libcaca-devel)
  $(vopt_if jack jack-devel) $(vopt_if lua lua52-devel)
  $(vopt_if pulseaudio pulseaudio-devel) $(vopt_if sdl2 SDL2-devel)
diff --git a/srcpkgs/qtav/template b/srcpkgs/qtav/template
index c823f7972b8..fbd8d9b35dc 100644
--- a/srcpkgs/qtav/template
+++ b/srcpkgs/qtav/template
@@ -1,11 +1,11 @@
 # Template file for 'qtav'
 pkgname=qtav
 version=1.13.0
-revision=1
+revision=2
 wrksrc="QtAV-${version}"
 build_style=qmake
 makedepends="ffmpeg-devel libass-devel libopenal-devel
- libva-glx-devel libXv-devel pulseaudio-devel
+ libva-devel libXv-devel pulseaudio-devel
  qt5-declarative-devel qt5-svg-devel
  qt5-quickcontrols"
 depends="desktop-file-utils hicolor-icon-theme qt5-svg"
diff --git a/srcpkgs/xine-lib/template b/srcpkgs/xine-lib/template
index ee612b34a23..5a456b13c3d 100644
--- a/srcpkgs/xine-lib/template
+++ b/srcpkgs/xine-lib/template
@@ -1,7 +1,7 @@
 # Template file for 'xine-lib'
 pkgname=xine-lib
 version=1.2.10
-revision=1
+revision=2
 build_style=gnu-configure
 configure_args="--disable-vcd --disable-gnomevfs --without-esound --disable-dxr3
  --disable-oss"
@@ -29,7 +29,7 @@ case "$XBPS_TARGET_MACHINE" in
 		;;
 esac
 case "$XBPS_TARGET_MACHINE" in
-	i686*|x86_64*|ppc64*) makedepends+=" libva-glx-devel libvdpau-devel glu-devel";;
+	i686*|x86_64*|ppc64*) makedepends+=" libva-devel libvdpau-devel glu-devel";;
 esac
 
 CFLAGS="-fcommon"

^ permalink raw reply	[flat|nested] 15+ messages in thread

* Re: [PR PATCH] [Updated] [WIP] Build libva with glx (remove libva-glx)
  2020-10-17  7:12 [PR PATCH] [WIP] Build libva with glx (remove libva-glx) st3r4g
@ 2020-10-17  8:53 ` st3r4g
  2020-10-17 16:08 ` ericonr
                   ` (12 subsequent siblings)
  13 siblings, 0 replies; 15+ messages in thread
From: st3r4g @ 2020-10-17  8:53 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 559 bytes --]

There is an updated pull request by st3r4g against master on the void-packages repository

https://github.com/st3r4g/void-packages libva-with-glx
https://github.com/void-linux/void-packages/pull/25674

[WIP] Build libva with glx (remove libva-glx)
Since we have `libglvnd` now, it should be possible to build libva with glx support without introducing build cycles.
Untested for now
Hmm maybe the transition can be done by replace= and removing libva-glx completely

A patch file from https://github.com/void-linux/void-packages/pull/25674.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-libva-with-glx-25674.patch --]
[-- Type: text/x-diff, Size: 9738 bytes --]

From f38da85d96f82718b1949aa23cd5ae986e80e76c Mon Sep 17 00:00:00 2001
From: Stefano Ragni <st3r4g@protonmail.com>
Date: Sat, 17 Oct 2020 09:09:05 +0200
Subject: [PATCH] WIP

---
 common/shlibs                       |  2 +-
 srcpkgs/QMPlay2/template            |  4 +--
 srcpkgs/bomi/template               |  4 +--
 srcpkgs/libva-glx/template          | 44 -----------------------------
 srcpkgs/libva-glx/update            |  1 -
 srcpkgs/libva-intel-driver/template |  4 +--
 srcpkgs/libva/template              |  9 ++++--
 srcpkgs/mpv/template                |  4 +--
 srcpkgs/qtav/template               |  7 ++---
 srcpkgs/xine-lib/template           |  4 +--
 10 files changed, 20 insertions(+), 63 deletions(-)
 delete mode 100644 srcpkgs/libva-glx/template
 delete mode 100644 srcpkgs/libva-glx/update

diff --git a/common/shlibs b/common/shlibs
index 4b8a40bda01..0913f1af81e 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -881,7 +881,7 @@ libwebpdemux.so.2 libwebp-0.5.0_1
 libwebpdecoder.so.3 libwebp-0.6.0_1
 libva-x11.so.2 libva-2.2.0_1
 libva.so.2 libva-2.2.0_1
-libva-glx.so.2 libva-glx-2.2.0_1
+libva-glx.so.2 libva-2.9.0_2
 libva-drm.so.2 libva-2.2.0_1
 libva-wayland.so.2 libva-2.2.0_1
 libv4l2.so.0 v4l-utils-0.8.5_1
diff --git a/srcpkgs/QMPlay2/template b/srcpkgs/QMPlay2/template
index 4fdb278054d..3afde9c44a7 100644
--- a/srcpkgs/QMPlay2/template
+++ b/srcpkgs/QMPlay2/template
@@ -1,12 +1,12 @@
 # Template file for 'QMPlay2'
 pkgname=QMPlay2
 version=20.07.04
-revision=1
+revision=2
 wrksrc="${pkgname}-src-${version}"
 build_style=cmake
 hostmakedepends="pkg-config qt5-qmake qt5-host-tools"
 makedepends="alsa-lib-devel ffmpeg-devel libass-devel libcdio-devel libgme-devel
- libsidplayfp-devel libva-glx-devel libXv-devel pulseaudio-devel
+ libsidplayfp-devel libva-devel libXv-devel pulseaudio-devel
  qt5-svg-devel qt5-tools-devel qt5-x11extras-devel taglib-devel
  libcdio-paranoia-devel qt5-declarative-devel"
 short_desc="Video and audio player which can play most formats and codecs"
diff --git a/srcpkgs/bomi/template b/srcpkgs/bomi/template
index eb6558441ff..5fcec8d66bf 100644
--- a/srcpkgs/bomi/template
+++ b/srcpkgs/bomi/template
@@ -1,14 +1,14 @@
 # Template file for 'bomi'
 pkgname=bomi
 version=0.9.11
-revision=16
+revision=17
 build_style=configure
 configure_args="--disable-systemd --release --prefix=/usr"
 # does not build using py3.8 because of waf issues
 hostmakedepends="python pkg-config curl perl which"
 makedepends="qt5-devel MesaLib-devel ffmpeg-devel mpg123-devel libass-devel
  libdvdread-devel libdvdnav-devel libbluray-devel icu-devel libxcb-devel
- xcb-util-wm-devel libva-devel libva-glx-devel alsa-lib-devel libvdpau-devel
+ xcb-util-wm-devel libva-devel alsa-lib-devel libvdpau-devel
  qt5-tools-devel qt5-declarative-devel qt5-svg-devel qt5-x11extras-devel
  fribidi-devel libcdio-devel libcdio-paranoia-devel pulseaudio-devel
  samba-devel libchardet-devel"
diff --git a/srcpkgs/libva-glx/template b/srcpkgs/libva-glx/template
deleted file mode 100644
index 19ff3ba7980..00000000000
--- a/srcpkgs/libva-glx/template
+++ /dev/null
@@ -1,44 +0,0 @@
-# Template file for 'libva-glx'
-#
-# THIS PACKAGE IS SPLITTED FROM "libva" TO AVOID A CYCLIC DEPENDENCY:
-#
-# 	libva -> mesa -> libva
-#
-# KEEP THIS PACKAGE SYNCHRONIZED WITH "libva".
-#
-pkgname=libva-glx
-version=2.9.0
-revision=1
-wrksrc="libva-${version}"
-build_style=meson
-configure_args="-Dwith_glx=yes -Dwith_wayland=yes"
-hostmakedepends="pkg-config wayland-devel"
-makedepends="libva-devel libXfixes-devel MesaLib-devel wayland-devel"
-short_desc="Video Acceleration (VA) API - GLX backend"
-maintainer="Orphaned <orphan@voidlinux.org>"
-license="MIT"
-homepage="https://01.org/linuxmedia/vaapi"
-changelog="https://raw.githubusercontent.com/intel/libva/master/NEWS"
-distfiles="https://github.com/intel/libva/archive/${version}.tar.gz"
-checksum=f31549dd476e01504ba6ff62f69862eb78555a9809ebe737056543a189d619dc
-
-post_install() {
-	# We are only interested in the glx component, remove everything else.
-	mkdir -p ${wrksrc}/temp/usr/lib/pkgconfig ${wrksrc}/temp/usr/include/va
-	mv ${DESTDIR}/usr/lib/libva-glx* ${wrksrc}/temp/usr/lib
-	mv ${DESTDIR}/usr/include/va/va_glx.h ${wrksrc}/temp/usr/include/va
-	mv ${DESTDIR}/usr/lib/pkgconfig/libva-glx.pc ${wrksrc}/temp/usr/lib/pkgconfig
-	rm -rf ${DESTDIR}/*
-	mv ${wrksrc}/temp/* ${DESTDIR}
-	vlicense COPYING
-}
-
-libva-glx-devel_package() {
-	depends="libva-devel ${sourcepkg}-${version}_${revision}"
-	short_desc+=" - development files"
-	pkg_install() {
-		vmove usr/include
-		vmove usr/lib/pkgconfig
-		vmove usr/lib/*.so
-	}
-}
diff --git a/srcpkgs/libva-glx/update b/srcpkgs/libva-glx/update
deleted file mode 100644
index 93fa059287c..00000000000
--- a/srcpkgs/libva-glx/update
+++ /dev/null
@@ -1 +0,0 @@
-pkgname=libva
diff --git a/srcpkgs/libva-intel-driver/template b/srcpkgs/libva-intel-driver/template
index 3cae1ab25b2..63662b4215c 100644
--- a/srcpkgs/libva-intel-driver/template
+++ b/srcpkgs/libva-intel-driver/template
@@ -1,13 +1,13 @@
 # Template file for 'libva-intel-driver'
 pkgname=libva-intel-driver
 version=2.4.1
-revision=1
+revision=2
 archs="i686* x86_64*"
 wrksrc="intel-vaapi-driver-${version}"
 build_style=meson
 configure_args="-Dwith_wayland=yes -Dwith_x11=yes"
 hostmakedepends="pkg-config"
-makedepends="libX11-devel libva-glx-devel libdrm-devel wayland-devel MesaLib-devel"
+makedepends="libX11-devel libva-devel libdrm-devel wayland-devel MesaLib-devel"
 short_desc="Video Acceleration (VA) API - Intel Graphics backend"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
diff --git a/srcpkgs/libva/template b/srcpkgs/libva/template
index d681e84c848..4a65f08dd19 100644
--- a/srcpkgs/libva/template
+++ b/srcpkgs/libva/template
@@ -1,11 +1,11 @@
 # Template file for 'libva'
 pkgname=libva
 version=2.9.0
-revision=1
+revision=2
 build_style=meson
-configure_args="-Dwith_glx=no $(vopt_if wayland -Dwith_wayland=yes)"
+configure_args="-Dwith_glx=yes $(vopt_if wayland -Dwith_wayland=yes)"
 hostmakedepends="pkg-config $(vopt_if wayland wayland-devel)"
-makedepends="libXfixes-devel libXext-devel libdrm-devel
+makedepends="libXfixes-devel libXext-devel libdrm-devel libglvnd-devel
  $(vopt_if wayland 'libffi-devel wayland-devel')"
 short_desc="Video Acceleration (VA) API"
 maintainer="Orphaned <orphan@voidlinux.org>"
@@ -15,6 +15,8 @@ changelog="https://raw.githubusercontent.com/intel/libva/master/NEWS"
 distfiles="https://github.com/intel/libva/archive/${version}.tar.gz"
 checksum=f31549dd476e01504ba6ff62f69862eb78555a9809ebe737056543a189d619dc
 
+replaces="libva-glx>=0"
+
 build_options="wayland"
 build_options_default="wayland"
 
@@ -28,6 +30,7 @@ post_install() {
 
 libva-devel_package() {
 	depends="$(vopt_if wayland wayland-devel) ${sourcepkg}>=${version}_${revision}"
+	replaces="libva-glx-devel>=0"
 	short_desc+=" - development files"
 	pkg_install() {
 		vmove usr/include
diff --git a/srcpkgs/mpv/template b/srcpkgs/mpv/template
index c45a163d0b3..127af87de52 100644
--- a/srcpkgs/mpv/template
+++ b/srcpkgs/mpv/template
@@ -1,7 +1,7 @@
 # Template file for 'mpv'
 pkgname=mpv
 version=0.32.0
-revision=4
+revision=5
 build_style=waf3
 configure_args="--confdir=/etc/mpv --docdir=/usr/share/examples/mpv
  --enable-dvdnav --enable-cdda --enable-libmpv-shared
@@ -14,7 +14,7 @@ configure_args="--confdir=/etc/mpv --docdir=/usr/share/examples/mpv
 hostmakedepends="pkg-config python3-docutils perl $(vopt_if wayland wayland-devel)"
 makedepends="MesaLib-devel ffmpeg-devel harfbuzz-devel lcms2-devel libXv-devel
  libass-devel libbluray-devel libcdio-paranoia-devel libdvdnav-devel
- libguess-devel libuuid-devel libva-glx-devel rubberband-devel uchardet-devel
+ libguess-devel libuuid-devel libva-devel rubberband-devel uchardet-devel
  libarchive-devel $(vopt_if alsa alsa-lib-devel) $(vopt_if caca libcaca-devel)
  $(vopt_if jack jack-devel) $(vopt_if lua lua52-devel)
  $(vopt_if pulseaudio pulseaudio-devel) $(vopt_if sdl2 SDL2-devel)
diff --git a/srcpkgs/qtav/template b/srcpkgs/qtav/template
index c823f7972b8..8dd5ce11c3d 100644
--- a/srcpkgs/qtav/template
+++ b/srcpkgs/qtav/template
@@ -1,16 +1,16 @@
 # Template file for 'qtav'
 pkgname=qtav
 version=1.13.0
-revision=1
+revision=2
 wrksrc="QtAV-${version}"
 build_style=qmake
 makedepends="ffmpeg-devel libass-devel libopenal-devel
- libva-glx-devel libXv-devel pulseaudio-devel
+ libva-devel libXv-devel pulseaudio-devel
  qt5-declarative-devel qt5-svg-devel
  qt5-quickcontrols"
 depends="desktop-file-utils hicolor-icon-theme qt5-svg"
-maintainer="Orphaned <orphan@voidlinux.org>"
 short_desc="Cross-platform multimedia playback framework based on Qt and FFmpeg"
+maintainer="Orphaned <orphan@voidlinux.org>"
 license="LGPL-2.1-or-later, GPL-3.0-or-later"
 homepage="http://www.qtav.org"
 changelog="https://raw.githubusercontent.com/wang-bin/QtAV/master/Changelog"
@@ -23,4 +23,3 @@ post_install() {
 	ln -s /usr/lib/qt5/bin/Player ${DESTDIR}/usr/bin/Player
 	ln -s /usr/lib/qt5/bin/QMLPlayer ${DESTDIR}/usr/bin/QMLPlayer
 }
-
diff --git a/srcpkgs/xine-lib/template b/srcpkgs/xine-lib/template
index ee612b34a23..5a456b13c3d 100644
--- a/srcpkgs/xine-lib/template
+++ b/srcpkgs/xine-lib/template
@@ -1,7 +1,7 @@
 # Template file for 'xine-lib'
 pkgname=xine-lib
 version=1.2.10
-revision=1
+revision=2
 build_style=gnu-configure
 configure_args="--disable-vcd --disable-gnomevfs --without-esound --disable-dxr3
  --disable-oss"
@@ -29,7 +29,7 @@ case "$XBPS_TARGET_MACHINE" in
 		;;
 esac
 case "$XBPS_TARGET_MACHINE" in
-	i686*|x86_64*|ppc64*) makedepends+=" libva-glx-devel libvdpau-devel glu-devel";;
+	i686*|x86_64*|ppc64*) makedepends+=" libva-devel libvdpau-devel glu-devel";;
 esac
 
 CFLAGS="-fcommon"

^ permalink raw reply	[flat|nested] 15+ messages in thread

* Re: [WIP] Build libva with glx (remove libva-glx)
  2020-10-17  7:12 [PR PATCH] [WIP] Build libva with glx (remove libva-glx) st3r4g
  2020-10-17  8:53 ` [PR PATCH] [Updated] " st3r4g
@ 2020-10-17 16:08 ` ericonr
  2020-10-17 16:09 ` ericonr
                   ` (11 subsequent siblings)
  13 siblings, 0 replies; 15+ messages in thread
From: ericonr @ 2020-10-17 16:08 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 146 bytes --]

New comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/pull/25674#issuecomment-711036478

Comment:
Nice!

^ permalink raw reply	[flat|nested] 15+ messages in thread

* Re: [WIP] Build libva with glx (remove libva-glx)
  2020-10-17  7:12 [PR PATCH] [WIP] Build libva with glx (remove libva-glx) st3r4g
  2020-10-17  8:53 ` [PR PATCH] [Updated] " st3r4g
  2020-10-17 16:08 ` ericonr
@ 2020-10-17 16:09 ` ericonr
  2020-10-19  8:50 ` st3r4g
                   ` (10 subsequent siblings)
  13 siblings, 0 replies; 15+ messages in thread
From: ericonr @ 2020-10-17 16:09 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 185 bytes --]

New comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/pull/25674#issuecomment-711036478

Comment:
Nice! It seems to have built fine, at least.

^ permalink raw reply	[flat|nested] 15+ messages in thread

* Re: [WIP] Build libva with glx (remove libva-glx)
  2020-10-17  7:12 [PR PATCH] [WIP] Build libva with glx (remove libva-glx) st3r4g
                   ` (2 preceding siblings ...)
  2020-10-17 16:09 ` ericonr
@ 2020-10-19  8:50 ` st3r4g
  2020-10-19  8:51 ` st3r4g
                   ` (9 subsequent siblings)
  13 siblings, 0 replies; 15+ messages in thread
From: st3r4g @ 2020-10-19  8:50 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 500 bytes --]

New comment by st3r4g on void-packages repository

https://github.com/void-linux/void-packages/pull/25674#issuecomment-711868977

Comment:
I have tested that the replacement of `libva-glx` with `libva` happens correctly. Couldn't test `bomi` because it seems to have a problem on its own (some missing stuff for the ui, results in a black window), I'll open an issue for that.

Now I'm thinking that `QMPlay2`, `mpv` and `qtav` don't need to be rebuilt since nothing changes for the binpkg, right?

^ permalink raw reply	[flat|nested] 15+ messages in thread

* Re: [WIP] Build libva with glx (remove libva-glx)
  2020-10-17  7:12 [PR PATCH] [WIP] Build libva with glx (remove libva-glx) st3r4g
                   ` (3 preceding siblings ...)
  2020-10-19  8:50 ` st3r4g
@ 2020-10-19  8:51 ` st3r4g
  2020-10-19  8:53 ` st3r4g
                   ` (8 subsequent siblings)
  13 siblings, 0 replies; 15+ messages in thread
From: st3r4g @ 2020-10-19  8:51 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 556 bytes --]

New comment by st3r4g on void-packages repository

https://github.com/void-linux/void-packages/pull/25674#issuecomment-711868977

Comment:
I have tested that the replacement of `libva-glx` with `libva` happens correctly. Couldn't test `bomi` because it seems to have a problem on its own (some missing stuff for the ui, results in a black window), I'll open an issue for that. But libva initializes fine as seen by the terminal log.

Now I'm thinking that `QMPlay2`, `mpv` and `qtav` don't need to be rebuilt since nothing changes for the binpkg, right?

^ permalink raw reply	[flat|nested] 15+ messages in thread

* Re: [WIP] Build libva with glx (remove libva-glx)
  2020-10-17  7:12 [PR PATCH] [WIP] Build libva with glx (remove libva-glx) st3r4g
                   ` (4 preceding siblings ...)
  2020-10-19  8:51 ` st3r4g
@ 2020-10-19  8:53 ` st3r4g
  2020-10-19 15:17 ` travankor
                   ` (7 subsequent siblings)
  13 siblings, 0 replies; 15+ messages in thread
From: st3r4g @ 2020-10-19  8:53 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 616 bytes --]

New comment by st3r4g on void-packages repository

https://github.com/void-linux/void-packages/pull/25674#issuecomment-711868977

Comment:
I have tested that the replacement of `libva-glx` with `libva` happens correctly. Couldn't test `bomi` because it seems to have a problem on its own (some missing stuff for the ui, results in a black window), I'll open an issue for that. But libva initializes fine as seen by the terminal log.

Now I'm thinking that `QMPlay2`, `mpv` and `qtav` don't need to be rebuilt since nothing changes for the binpkg, right? (because they weren't actually linking to libva-glx before)

^ permalink raw reply	[flat|nested] 15+ messages in thread

* Re: [WIP] Build libva with glx (remove libva-glx)
  2020-10-17  7:12 [PR PATCH] [WIP] Build libva with glx (remove libva-glx) st3r4g
                   ` (5 preceding siblings ...)
  2020-10-19  8:53 ` st3r4g
@ 2020-10-19 15:17 ` travankor
  2020-10-19 15:50 ` [PR PATCH] [Updated] " st3r4g
                   ` (6 subsequent siblings)
  13 siblings, 0 replies; 15+ messages in thread
From: travankor @ 2020-10-19 15:17 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 349 bytes --]

New comment by travankor on void-packages repository

https://github.com/void-linux/void-packages/pull/25674#issuecomment-712237987

Comment:
>Now I'm thinking that QMPlay2, mpv and qtav don't need to be rebuilt since nothing changes for the binpkg, right? (because they weren't actually linking to libva-glx before)

Yes, I think that's correct.

^ permalink raw reply	[flat|nested] 15+ messages in thread

* Re: [PR PATCH] [Updated] [WIP] Build libva with glx (remove libva-glx)
  2020-10-17  7:12 [PR PATCH] [WIP] Build libva with glx (remove libva-glx) st3r4g
                   ` (6 preceding siblings ...)
  2020-10-19 15:17 ` travankor
@ 2020-10-19 15:50 ` st3r4g
  2020-10-19 15:54 ` st3r4g
                   ` (5 subsequent siblings)
  13 siblings, 0 replies; 15+ messages in thread
From: st3r4g @ 2020-10-19 15:50 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 559 bytes --]

There is an updated pull request by st3r4g against master on the void-packages repository

https://github.com/st3r4g/void-packages libva-with-glx
https://github.com/void-linux/void-packages/pull/25674

[WIP] Build libva with glx (remove libva-glx)
Since we have `libglvnd` now, it should be possible to build libva with glx support without introducing build cycles.
Untested for now
Hmm maybe the transition can be done by replace= and removing libva-glx completely

A patch file from https://github.com/void-linux/void-packages/pull/25674.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-libva-with-glx-25674.patch --]
[-- Type: text/x-diff, Size: 10892 bytes --]

From b670eeeb6af48c760134fa1b5db5888db18ae931 Mon Sep 17 00:00:00 2001
From: Stefano Ragni <st3r4g@protonmail.com>
Date: Mon, 19 Oct 2020 17:43:12 +0200
Subject: [PATCH 1/8] libva-glx: remove

---
 srcpkgs/libva-glx/template | 44 --------------------------------------
 srcpkgs/libva-glx/update   |  1 -
 2 files changed, 45 deletions(-)
 delete mode 100644 srcpkgs/libva-glx/template
 delete mode 100644 srcpkgs/libva-glx/update

diff --git a/srcpkgs/libva-glx/template b/srcpkgs/libva-glx/template
deleted file mode 100644
index 19ff3ba7980..00000000000
--- a/srcpkgs/libva-glx/template
+++ /dev/null
@@ -1,44 +0,0 @@
-# Template file for 'libva-glx'
-#
-# THIS PACKAGE IS SPLITTED FROM "libva" TO AVOID A CYCLIC DEPENDENCY:
-#
-# 	libva -> mesa -> libva
-#
-# KEEP THIS PACKAGE SYNCHRONIZED WITH "libva".
-#
-pkgname=libva-glx
-version=2.9.0
-revision=1
-wrksrc="libva-${version}"
-build_style=meson
-configure_args="-Dwith_glx=yes -Dwith_wayland=yes"
-hostmakedepends="pkg-config wayland-devel"
-makedepends="libva-devel libXfixes-devel MesaLib-devel wayland-devel"
-short_desc="Video Acceleration (VA) API - GLX backend"
-maintainer="Orphaned <orphan@voidlinux.org>"
-license="MIT"
-homepage="https://01.org/linuxmedia/vaapi"
-changelog="https://raw.githubusercontent.com/intel/libva/master/NEWS"
-distfiles="https://github.com/intel/libva/archive/${version}.tar.gz"
-checksum=f31549dd476e01504ba6ff62f69862eb78555a9809ebe737056543a189d619dc
-
-post_install() {
-	# We are only interested in the glx component, remove everything else.
-	mkdir -p ${wrksrc}/temp/usr/lib/pkgconfig ${wrksrc}/temp/usr/include/va
-	mv ${DESTDIR}/usr/lib/libva-glx* ${wrksrc}/temp/usr/lib
-	mv ${DESTDIR}/usr/include/va/va_glx.h ${wrksrc}/temp/usr/include/va
-	mv ${DESTDIR}/usr/lib/pkgconfig/libva-glx.pc ${wrksrc}/temp/usr/lib/pkgconfig
-	rm -rf ${DESTDIR}/*
-	mv ${wrksrc}/temp/* ${DESTDIR}
-	vlicense COPYING
-}
-
-libva-glx-devel_package() {
-	depends="libva-devel ${sourcepkg}-${version}_${revision}"
-	short_desc+=" - development files"
-	pkg_install() {
-		vmove usr/include
-		vmove usr/lib/pkgconfig
-		vmove usr/lib/*.so
-	}
-}
diff --git a/srcpkgs/libva-glx/update b/srcpkgs/libva-glx/update
deleted file mode 100644
index 93fa059287c..00000000000
--- a/srcpkgs/libva-glx/update
+++ /dev/null
@@ -1 +0,0 @@
-pkgname=libva

From db344e0fc53be4b9cac191d70635dd8a1f2e0f9f Mon Sep 17 00:00:00 2001
From: Stefano Ragni <st3r4g@protonmail.com>
Date: Mon, 19 Oct 2020 17:43:49 +0200
Subject: [PATCH 2/8] libva: build with glx

---
 common/shlibs          | 2 +-
 srcpkgs/libva/template | 9 ++++++---
 2 files changed, 7 insertions(+), 4 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index 35f08f5f099..838630d0763 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -881,7 +881,7 @@ libwebpdemux.so.2 libwebp-0.5.0_1
 libwebpdecoder.so.3 libwebp-0.6.0_1
 libva-x11.so.2 libva-2.2.0_1
 libva.so.2 libva-2.2.0_1
-libva-glx.so.2 libva-glx-2.2.0_1
+libva-glx.so.2 libva-2.9.0_2
 libva-drm.so.2 libva-2.2.0_1
 libva-wayland.so.2 libva-2.2.0_1
 libv4l2.so.0 v4l-utils-0.8.5_1
diff --git a/srcpkgs/libva/template b/srcpkgs/libva/template
index d681e84c848..4a65f08dd19 100644
--- a/srcpkgs/libva/template
+++ b/srcpkgs/libva/template
@@ -1,11 +1,11 @@
 # Template file for 'libva'
 pkgname=libva
 version=2.9.0
-revision=1
+revision=2
 build_style=meson
-configure_args="-Dwith_glx=no $(vopt_if wayland -Dwith_wayland=yes)"
+configure_args="-Dwith_glx=yes $(vopt_if wayland -Dwith_wayland=yes)"
 hostmakedepends="pkg-config $(vopt_if wayland wayland-devel)"
-makedepends="libXfixes-devel libXext-devel libdrm-devel
+makedepends="libXfixes-devel libXext-devel libdrm-devel libglvnd-devel
  $(vopt_if wayland 'libffi-devel wayland-devel')"
 short_desc="Video Acceleration (VA) API"
 maintainer="Orphaned <orphan@voidlinux.org>"
@@ -15,6 +15,8 @@ changelog="https://raw.githubusercontent.com/intel/libva/master/NEWS"
 distfiles="https://github.com/intel/libva/archive/${version}.tar.gz"
 checksum=f31549dd476e01504ba6ff62f69862eb78555a9809ebe737056543a189d619dc
 
+replaces="libva-glx>=0"
+
 build_options="wayland"
 build_options_default="wayland"
 
@@ -28,6 +30,7 @@ post_install() {
 
 libva-devel_package() {
 	depends="$(vopt_if wayland wayland-devel) ${sourcepkg}>=${version}_${revision}"
+	replaces="libva-glx-devel>=0"
 	short_desc+=" - development files"
 	pkg_install() {
 		vmove usr/include

From 4991515784bd57e363860caa3eb928a0796f8c4e Mon Sep 17 00:00:00 2001
From: Stefano Ragni <st3r4g@protonmail.com>
Date: Mon, 19 Oct 2020 17:46:04 +0200
Subject: [PATCH 3/8] QMPlay2: libva-glx -> libva

---
 srcpkgs/QMPlay2/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/QMPlay2/template b/srcpkgs/QMPlay2/template
index 4fdb278054d..3b26c882191 100644
--- a/srcpkgs/QMPlay2/template
+++ b/srcpkgs/QMPlay2/template
@@ -6,7 +6,7 @@ wrksrc="${pkgname}-src-${version}"
 build_style=cmake
 hostmakedepends="pkg-config qt5-qmake qt5-host-tools"
 makedepends="alsa-lib-devel ffmpeg-devel libass-devel libcdio-devel libgme-devel
- libsidplayfp-devel libva-glx-devel libXv-devel pulseaudio-devel
+ libsidplayfp-devel libva-devel libXv-devel pulseaudio-devel
  qt5-svg-devel qt5-tools-devel qt5-x11extras-devel taglib-devel
  libcdio-paranoia-devel qt5-declarative-devel"
 short_desc="Video and audio player which can play most formats and codecs"

From b3a23472da8a82110b19f46f4f4704fe80ccb92e Mon Sep 17 00:00:00 2001
From: Stefano Ragni <st3r4g@protonmail.com>
Date: Mon, 19 Oct 2020 17:46:21 +0200
Subject: [PATCH 4/8] bomi: libva-glx -> libva

---
 srcpkgs/bomi/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/bomi/template b/srcpkgs/bomi/template
index eb6558441ff..5fcec8d66bf 100644
--- a/srcpkgs/bomi/template
+++ b/srcpkgs/bomi/template
@@ -1,14 +1,14 @@
 # Template file for 'bomi'
 pkgname=bomi
 version=0.9.11
-revision=16
+revision=17
 build_style=configure
 configure_args="--disable-systemd --release --prefix=/usr"
 # does not build using py3.8 because of waf issues
 hostmakedepends="python pkg-config curl perl which"
 makedepends="qt5-devel MesaLib-devel ffmpeg-devel mpg123-devel libass-devel
  libdvdread-devel libdvdnav-devel libbluray-devel icu-devel libxcb-devel
- xcb-util-wm-devel libva-devel libva-glx-devel alsa-lib-devel libvdpau-devel
+ xcb-util-wm-devel libva-devel alsa-lib-devel libvdpau-devel
  qt5-tools-devel qt5-declarative-devel qt5-svg-devel qt5-x11extras-devel
  fribidi-devel libcdio-devel libcdio-paranoia-devel pulseaudio-devel
  samba-devel libchardet-devel"

From 63c9b01e79d49b8f74a3eb3f5cc7345f48649efc Mon Sep 17 00:00:00 2001
From: Stefano Ragni <st3r4g@protonmail.com>
Date: Mon, 19 Oct 2020 17:46:50 +0200
Subject: [PATCH 5/8] libva-intel-driver: libva-glx -> libva

---
 srcpkgs/libva-intel-driver/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/libva-intel-driver/template b/srcpkgs/libva-intel-driver/template
index 3cae1ab25b2..95a54c0fc17 100644
--- a/srcpkgs/libva-intel-driver/template
+++ b/srcpkgs/libva-intel-driver/template
@@ -7,7 +7,7 @@ wrksrc="intel-vaapi-driver-${version}"
 build_style=meson
 configure_args="-Dwith_wayland=yes -Dwith_x11=yes"
 hostmakedepends="pkg-config"
-makedepends="libX11-devel libva-glx-devel libdrm-devel wayland-devel MesaLib-devel"
+makedepends="libX11-devel libva-devel libdrm-devel wayland-devel MesaLib-devel"
 short_desc="Video Acceleration (VA) API - Intel Graphics backend"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"

From a1b47168ef7d3818bd1396fc54bf9f65fe1c49d2 Mon Sep 17 00:00:00 2001
From: Stefano Ragni <st3r4g@protonmail.com>
Date: Mon, 19 Oct 2020 17:47:21 +0200
Subject: [PATCH 6/8] mpv: libva-glx -> libva

---
 srcpkgs/mpv/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/mpv/template b/srcpkgs/mpv/template
index c45a163d0b3..28c083ca597 100644
--- a/srcpkgs/mpv/template
+++ b/srcpkgs/mpv/template
@@ -14,7 +14,7 @@ configure_args="--confdir=/etc/mpv --docdir=/usr/share/examples/mpv
 hostmakedepends="pkg-config python3-docutils perl $(vopt_if wayland wayland-devel)"
 makedepends="MesaLib-devel ffmpeg-devel harfbuzz-devel lcms2-devel libXv-devel
  libass-devel libbluray-devel libcdio-paranoia-devel libdvdnav-devel
- libguess-devel libuuid-devel libva-glx-devel rubberband-devel uchardet-devel
+ libguess-devel libuuid-devel libva-devel rubberband-devel uchardet-devel
  libarchive-devel $(vopt_if alsa alsa-lib-devel) $(vopt_if caca libcaca-devel)
  $(vopt_if jack jack-devel) $(vopt_if lua lua52-devel)
  $(vopt_if pulseaudio pulseaudio-devel) $(vopt_if sdl2 SDL2-devel)

From 1dbf5aade92a89e5463a256eb1d066e5cdf9a5d4 Mon Sep 17 00:00:00 2001
From: Stefano Ragni <st3r4g@protonmail.com>
Date: Mon, 19 Oct 2020 17:48:17 +0200
Subject: [PATCH 7/8] qtav: libva-glx -> libva

---
 srcpkgs/qtav/template | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/qtav/template b/srcpkgs/qtav/template
index c823f7972b8..dcc43c97bf6 100644
--- a/srcpkgs/qtav/template
+++ b/srcpkgs/qtav/template
@@ -5,12 +5,12 @@ revision=1
 wrksrc="QtAV-${version}"
 build_style=qmake
 makedepends="ffmpeg-devel libass-devel libopenal-devel
- libva-glx-devel libXv-devel pulseaudio-devel
+ libva-devel libXv-devel pulseaudio-devel
  qt5-declarative-devel qt5-svg-devel
  qt5-quickcontrols"
 depends="desktop-file-utils hicolor-icon-theme qt5-svg"
-maintainer="Orphaned <orphan@voidlinux.org>"
 short_desc="Cross-platform multimedia playback framework based on Qt and FFmpeg"
+maintainer="Orphaned <orphan@voidlinux.org>"
 license="LGPL-2.1-or-later, GPL-3.0-or-later"
 homepage="http://www.qtav.org"
 changelog="https://raw.githubusercontent.com/wang-bin/QtAV/master/Changelog"
@@ -23,4 +23,3 @@ post_install() {
 	ln -s /usr/lib/qt5/bin/Player ${DESTDIR}/usr/bin/Player
 	ln -s /usr/lib/qt5/bin/QMLPlayer ${DESTDIR}/usr/bin/QMLPlayer
 }
-

From 333a7d7f0ee92081bcf7388443043e87a61db76f Mon Sep 17 00:00:00 2001
From: Stefano Ragni <st3r4g@protonmail.com>
Date: Mon, 19 Oct 2020 17:48:34 +0200
Subject: [PATCH 8/8] xine-lib: libva-glx -> libva

---
 srcpkgs/xine-lib/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/xine-lib/template b/srcpkgs/xine-lib/template
index ee612b34a23..5a456b13c3d 100644
--- a/srcpkgs/xine-lib/template
+++ b/srcpkgs/xine-lib/template
@@ -1,7 +1,7 @@
 # Template file for 'xine-lib'
 pkgname=xine-lib
 version=1.2.10
-revision=1
+revision=2
 build_style=gnu-configure
 configure_args="--disable-vcd --disable-gnomevfs --without-esound --disable-dxr3
  --disable-oss"
@@ -29,7 +29,7 @@ case "$XBPS_TARGET_MACHINE" in
 		;;
 esac
 case "$XBPS_TARGET_MACHINE" in
-	i686*|x86_64*|ppc64*) makedepends+=" libva-glx-devel libvdpau-devel glu-devel";;
+	i686*|x86_64*|ppc64*) makedepends+=" libva-devel libvdpau-devel glu-devel";;
 esac
 
 CFLAGS="-fcommon"

^ permalink raw reply	[flat|nested] 15+ messages in thread

* Re: Build libva with glx (remove libva-glx)
  2020-10-17  7:12 [PR PATCH] [WIP] Build libva with glx (remove libva-glx) st3r4g
                   ` (7 preceding siblings ...)
  2020-10-19 15:50 ` [PR PATCH] [Updated] " st3r4g
@ 2020-10-19 15:54 ` st3r4g
  2020-10-21 15:11 ` st3r4g
                   ` (4 subsequent siblings)
  13 siblings, 0 replies; 15+ messages in thread
From: st3r4g @ 2020-10-19 15:54 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 156 bytes --]

New comment by st3r4g on void-packages repository

https://github.com/void-linux/void-packages/pull/25674#issuecomment-712262295

Comment:
ready for review

^ permalink raw reply	[flat|nested] 15+ messages in thread

* Re: Build libva with glx (remove libva-glx)
  2020-10-17  7:12 [PR PATCH] [WIP] Build libva with glx (remove libva-glx) st3r4g
                   ` (8 preceding siblings ...)
  2020-10-19 15:54 ` st3r4g
@ 2020-10-21 15:11 ` st3r4g
  2020-10-21 16:36 ` ericonr
                   ` (3 subsequent siblings)
  13 siblings, 0 replies; 15+ messages in thread
From: st3r4g @ 2020-10-21 15:11 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 597 bytes --]

New comment by st3r4g on void-packages repository

https://github.com/void-linux/void-packages/pull/25674#issuecomment-713648474

Comment:
> However, you need `libva-glx` and `libva-glx-devel` transitional packages to pull in the new `libva` and `libva-devel`, respectively. While XBPS will recognize the `replaces` directive if a dependant is updated and requires the new merged package, it will not recognize the replacement path on its own. Transitional packages will force this.

But here `libva-glx` depends on `libva` already (and same for `-devel`) so the replacement will always happen.

^ permalink raw reply	[flat|nested] 15+ messages in thread

* Re: Build libva with glx (remove libva-glx)
  2020-10-17  7:12 [PR PATCH] [WIP] Build libva with glx (remove libva-glx) st3r4g
                   ` (9 preceding siblings ...)
  2020-10-21 15:11 ` st3r4g
@ 2020-10-21 16:36 ` ericonr
  2020-10-21 16:42 ` ahesford
                   ` (2 subsequent siblings)
  13 siblings, 0 replies; 15+ messages in thread
From: ericonr @ 2020-10-21 16:36 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 206 bytes --]

New comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/pull/25674#issuecomment-713704501

Comment:
@st3r4g could perhaps add this explanation to the commit message?

^ permalink raw reply	[flat|nested] 15+ messages in thread

* Re: Build libva with glx (remove libva-glx)
  2020-10-17  7:12 [PR PATCH] [WIP] Build libva with glx (remove libva-glx) st3r4g
                   ` (10 preceding siblings ...)
  2020-10-21 16:36 ` ericonr
@ 2020-10-21 16:42 ` ahesford
  2020-10-22  8:25 ` [PR PATCH] [Updated] " st3r4g
  2020-10-22  8:25 ` st3r4g
  13 siblings, 0 replies; 15+ messages in thread
From: ahesford @ 2020-10-21 16:42 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 164 bytes --]

New comment by ahesford on void-packages repository

https://github.com/void-linux/void-packages/pull/25674#issuecomment-713707554

Comment:
OK, that makes sense. 

^ permalink raw reply	[flat|nested] 15+ messages in thread

* Re: [PR PATCH] [Updated] Build libva with glx (remove libva-glx)
  2020-10-17  7:12 [PR PATCH] [WIP] Build libva with glx (remove libva-glx) st3r4g
                   ` (11 preceding siblings ...)
  2020-10-21 16:42 ` ahesford
@ 2020-10-22  8:25 ` st3r4g
  2020-10-22  8:25 ` st3r4g
  13 siblings, 0 replies; 15+ messages in thread
From: st3r4g @ 2020-10-22  8:25 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 553 bytes --]

There is an updated pull request by st3r4g against master on the void-packages repository

https://github.com/st3r4g/void-packages libva-with-glx
https://github.com/void-linux/void-packages/pull/25674

Build libva with glx (remove libva-glx)
Since we have `libglvnd` now, it should be possible to build libva with glx support without introducing build cycles.
Untested for now
Hmm maybe the transition can be done by replace= and removing libva-glx completely

A patch file from https://github.com/void-linux/void-packages/pull/25674.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-libva-with-glx-25674.patch --]
[-- Type: text/x-diff, Size: 11032 bytes --]

From 20d4d536cb1446afdb1f45a8893676931a12003c Mon Sep 17 00:00:00 2001
From: Stefano Ragni <st3r4g@protonmail.com>
Date: Mon, 19 Oct 2020 17:43:12 +0200
Subject: [PATCH 1/8] libva-glx: remove

libva-glx depends on libva already (and same for -devel) so the
replacement will always happen without the need for a transitional
package.
---
 srcpkgs/libva-glx/template | 44 --------------------------------------
 srcpkgs/libva-glx/update   |  1 -
 2 files changed, 45 deletions(-)
 delete mode 100644 srcpkgs/libva-glx/template
 delete mode 100644 srcpkgs/libva-glx/update

diff --git a/srcpkgs/libva-glx/template b/srcpkgs/libva-glx/template
deleted file mode 100644
index 19ff3ba7980..00000000000
--- a/srcpkgs/libva-glx/template
+++ /dev/null
@@ -1,44 +0,0 @@
-# Template file for 'libva-glx'
-#
-# THIS PACKAGE IS SPLITTED FROM "libva" TO AVOID A CYCLIC DEPENDENCY:
-#
-# 	libva -> mesa -> libva
-#
-# KEEP THIS PACKAGE SYNCHRONIZED WITH "libva".
-#
-pkgname=libva-glx
-version=2.9.0
-revision=1
-wrksrc="libva-${version}"
-build_style=meson
-configure_args="-Dwith_glx=yes -Dwith_wayland=yes"
-hostmakedepends="pkg-config wayland-devel"
-makedepends="libva-devel libXfixes-devel MesaLib-devel wayland-devel"
-short_desc="Video Acceleration (VA) API - GLX backend"
-maintainer="Orphaned <orphan@voidlinux.org>"
-license="MIT"
-homepage="https://01.org/linuxmedia/vaapi"
-changelog="https://raw.githubusercontent.com/intel/libva/master/NEWS"
-distfiles="https://github.com/intel/libva/archive/${version}.tar.gz"
-checksum=f31549dd476e01504ba6ff62f69862eb78555a9809ebe737056543a189d619dc
-
-post_install() {
-	# We are only interested in the glx component, remove everything else.
-	mkdir -p ${wrksrc}/temp/usr/lib/pkgconfig ${wrksrc}/temp/usr/include/va
-	mv ${DESTDIR}/usr/lib/libva-glx* ${wrksrc}/temp/usr/lib
-	mv ${DESTDIR}/usr/include/va/va_glx.h ${wrksrc}/temp/usr/include/va
-	mv ${DESTDIR}/usr/lib/pkgconfig/libva-glx.pc ${wrksrc}/temp/usr/lib/pkgconfig
-	rm -rf ${DESTDIR}/*
-	mv ${wrksrc}/temp/* ${DESTDIR}
-	vlicense COPYING
-}
-
-libva-glx-devel_package() {
-	depends="libva-devel ${sourcepkg}-${version}_${revision}"
-	short_desc+=" - development files"
-	pkg_install() {
-		vmove usr/include
-		vmove usr/lib/pkgconfig
-		vmove usr/lib/*.so
-	}
-}
diff --git a/srcpkgs/libva-glx/update b/srcpkgs/libva-glx/update
deleted file mode 100644
index 93fa059287c..00000000000
--- a/srcpkgs/libva-glx/update
+++ /dev/null
@@ -1 +0,0 @@
-pkgname=libva

From 65f01994940b9418c3cd0f07c2aa958e4a2a3c22 Mon Sep 17 00:00:00 2001
From: Stefano Ragni <st3r4g@protonmail.com>
Date: Mon, 19 Oct 2020 17:43:49 +0200
Subject: [PATCH 2/8] libva: build with glx

---
 common/shlibs          | 2 +-
 srcpkgs/libva/template | 9 ++++++---
 2 files changed, 7 insertions(+), 4 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index 671d6d44ee0..d307de1ca9a 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -881,7 +881,7 @@ libwebpdemux.so.2 libwebp-0.5.0_1
 libwebpdecoder.so.3 libwebp-0.6.0_1
 libva-x11.so.2 libva-2.2.0_1
 libva.so.2 libva-2.2.0_1
-libva-glx.so.2 libva-glx-2.2.0_1
+libva-glx.so.2 libva-2.9.0_2
 libva-drm.so.2 libva-2.2.0_1
 libva-wayland.so.2 libva-2.2.0_1
 libv4l2.so.0 v4l-utils-0.8.5_1
diff --git a/srcpkgs/libva/template b/srcpkgs/libva/template
index d681e84c848..4a65f08dd19 100644
--- a/srcpkgs/libva/template
+++ b/srcpkgs/libva/template
@@ -1,11 +1,11 @@
 # Template file for 'libva'
 pkgname=libva
 version=2.9.0
-revision=1
+revision=2
 build_style=meson
-configure_args="-Dwith_glx=no $(vopt_if wayland -Dwith_wayland=yes)"
+configure_args="-Dwith_glx=yes $(vopt_if wayland -Dwith_wayland=yes)"
 hostmakedepends="pkg-config $(vopt_if wayland wayland-devel)"
-makedepends="libXfixes-devel libXext-devel libdrm-devel
+makedepends="libXfixes-devel libXext-devel libdrm-devel libglvnd-devel
  $(vopt_if wayland 'libffi-devel wayland-devel')"
 short_desc="Video Acceleration (VA) API"
 maintainer="Orphaned <orphan@voidlinux.org>"
@@ -15,6 +15,8 @@ changelog="https://raw.githubusercontent.com/intel/libva/master/NEWS"
 distfiles="https://github.com/intel/libva/archive/${version}.tar.gz"
 checksum=f31549dd476e01504ba6ff62f69862eb78555a9809ebe737056543a189d619dc
 
+replaces="libva-glx>=0"
+
 build_options="wayland"
 build_options_default="wayland"
 
@@ -28,6 +30,7 @@ post_install() {
 
 libva-devel_package() {
 	depends="$(vopt_if wayland wayland-devel) ${sourcepkg}>=${version}_${revision}"
+	replaces="libva-glx-devel>=0"
 	short_desc+=" - development files"
 	pkg_install() {
 		vmove usr/include

From 19e64c0ab0033f0ae2a4f0aa11e7934f8479558e Mon Sep 17 00:00:00 2001
From: Stefano Ragni <st3r4g@protonmail.com>
Date: Mon, 19 Oct 2020 17:46:04 +0200
Subject: [PATCH 3/8] QMPlay2: libva-glx -> libva

---
 srcpkgs/QMPlay2/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/QMPlay2/template b/srcpkgs/QMPlay2/template
index 4fdb278054d..3b26c882191 100644
--- a/srcpkgs/QMPlay2/template
+++ b/srcpkgs/QMPlay2/template
@@ -6,7 +6,7 @@ wrksrc="${pkgname}-src-${version}"
 build_style=cmake
 hostmakedepends="pkg-config qt5-qmake qt5-host-tools"
 makedepends="alsa-lib-devel ffmpeg-devel libass-devel libcdio-devel libgme-devel
- libsidplayfp-devel libva-glx-devel libXv-devel pulseaudio-devel
+ libsidplayfp-devel libva-devel libXv-devel pulseaudio-devel
  qt5-svg-devel qt5-tools-devel qt5-x11extras-devel taglib-devel
  libcdio-paranoia-devel qt5-declarative-devel"
 short_desc="Video and audio player which can play most formats and codecs"

From 48deac6e0f14e0cf3f2d2418e405047117327621 Mon Sep 17 00:00:00 2001
From: Stefano Ragni <st3r4g@protonmail.com>
Date: Mon, 19 Oct 2020 17:46:21 +0200
Subject: [PATCH 4/8] bomi: libva-glx -> libva

---
 srcpkgs/bomi/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/bomi/template b/srcpkgs/bomi/template
index eb6558441ff..5fcec8d66bf 100644
--- a/srcpkgs/bomi/template
+++ b/srcpkgs/bomi/template
@@ -1,14 +1,14 @@
 # Template file for 'bomi'
 pkgname=bomi
 version=0.9.11
-revision=16
+revision=17
 build_style=configure
 configure_args="--disable-systemd --release --prefix=/usr"
 # does not build using py3.8 because of waf issues
 hostmakedepends="python pkg-config curl perl which"
 makedepends="qt5-devel MesaLib-devel ffmpeg-devel mpg123-devel libass-devel
  libdvdread-devel libdvdnav-devel libbluray-devel icu-devel libxcb-devel
- xcb-util-wm-devel libva-devel libva-glx-devel alsa-lib-devel libvdpau-devel
+ xcb-util-wm-devel libva-devel alsa-lib-devel libvdpau-devel
  qt5-tools-devel qt5-declarative-devel qt5-svg-devel qt5-x11extras-devel
  fribidi-devel libcdio-devel libcdio-paranoia-devel pulseaudio-devel
  samba-devel libchardet-devel"

From 5f584988397cc89847eab6f2c71d62d19d0c93b0 Mon Sep 17 00:00:00 2001
From: Stefano Ragni <st3r4g@protonmail.com>
Date: Mon, 19 Oct 2020 17:46:50 +0200
Subject: [PATCH 5/8] libva-intel-driver: libva-glx -> libva

---
 srcpkgs/libva-intel-driver/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/libva-intel-driver/template b/srcpkgs/libva-intel-driver/template
index 3cae1ab25b2..95a54c0fc17 100644
--- a/srcpkgs/libva-intel-driver/template
+++ b/srcpkgs/libva-intel-driver/template
@@ -7,7 +7,7 @@ wrksrc="intel-vaapi-driver-${version}"
 build_style=meson
 configure_args="-Dwith_wayland=yes -Dwith_x11=yes"
 hostmakedepends="pkg-config"
-makedepends="libX11-devel libva-glx-devel libdrm-devel wayland-devel MesaLib-devel"
+makedepends="libX11-devel libva-devel libdrm-devel wayland-devel MesaLib-devel"
 short_desc="Video Acceleration (VA) API - Intel Graphics backend"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"

From fd3083e22e184641999dfe0c4a935f7a10e5ecdb Mon Sep 17 00:00:00 2001
From: Stefano Ragni <st3r4g@protonmail.com>
Date: Mon, 19 Oct 2020 17:47:21 +0200
Subject: [PATCH 6/8] mpv: libva-glx -> libva

---
 srcpkgs/mpv/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/mpv/template b/srcpkgs/mpv/template
index c45a163d0b3..28c083ca597 100644
--- a/srcpkgs/mpv/template
+++ b/srcpkgs/mpv/template
@@ -14,7 +14,7 @@ configure_args="--confdir=/etc/mpv --docdir=/usr/share/examples/mpv
 hostmakedepends="pkg-config python3-docutils perl $(vopt_if wayland wayland-devel)"
 makedepends="MesaLib-devel ffmpeg-devel harfbuzz-devel lcms2-devel libXv-devel
  libass-devel libbluray-devel libcdio-paranoia-devel libdvdnav-devel
- libguess-devel libuuid-devel libva-glx-devel rubberband-devel uchardet-devel
+ libguess-devel libuuid-devel libva-devel rubberband-devel uchardet-devel
  libarchive-devel $(vopt_if alsa alsa-lib-devel) $(vopt_if caca libcaca-devel)
  $(vopt_if jack jack-devel) $(vopt_if lua lua52-devel)
  $(vopt_if pulseaudio pulseaudio-devel) $(vopt_if sdl2 SDL2-devel)

From 7d8411e6c209e95b922df01be5f3eaede6098544 Mon Sep 17 00:00:00 2001
From: Stefano Ragni <st3r4g@protonmail.com>
Date: Mon, 19 Oct 2020 17:48:17 +0200
Subject: [PATCH 7/8] qtav: libva-glx -> libva

---
 srcpkgs/qtav/template | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/qtav/template b/srcpkgs/qtav/template
index c823f7972b8..dcc43c97bf6 100644
--- a/srcpkgs/qtav/template
+++ b/srcpkgs/qtav/template
@@ -5,12 +5,12 @@ revision=1
 wrksrc="QtAV-${version}"
 build_style=qmake
 makedepends="ffmpeg-devel libass-devel libopenal-devel
- libva-glx-devel libXv-devel pulseaudio-devel
+ libva-devel libXv-devel pulseaudio-devel
  qt5-declarative-devel qt5-svg-devel
  qt5-quickcontrols"
 depends="desktop-file-utils hicolor-icon-theme qt5-svg"
-maintainer="Orphaned <orphan@voidlinux.org>"
 short_desc="Cross-platform multimedia playback framework based on Qt and FFmpeg"
+maintainer="Orphaned <orphan@voidlinux.org>"
 license="LGPL-2.1-or-later, GPL-3.0-or-later"
 homepage="http://www.qtav.org"
 changelog="https://raw.githubusercontent.com/wang-bin/QtAV/master/Changelog"
@@ -23,4 +23,3 @@ post_install() {
 	ln -s /usr/lib/qt5/bin/Player ${DESTDIR}/usr/bin/Player
 	ln -s /usr/lib/qt5/bin/QMLPlayer ${DESTDIR}/usr/bin/QMLPlayer
 }
-

From 285b99f35e059ff98c165c56761059e91cd55f67 Mon Sep 17 00:00:00 2001
From: Stefano Ragni <st3r4g@protonmail.com>
Date: Mon, 19 Oct 2020 17:48:34 +0200
Subject: [PATCH 8/8] xine-lib: libva-glx -> libva

---
 srcpkgs/xine-lib/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/xine-lib/template b/srcpkgs/xine-lib/template
index ee612b34a23..5a456b13c3d 100644
--- a/srcpkgs/xine-lib/template
+++ b/srcpkgs/xine-lib/template
@@ -1,7 +1,7 @@
 # Template file for 'xine-lib'
 pkgname=xine-lib
 version=1.2.10
-revision=1
+revision=2
 build_style=gnu-configure
 configure_args="--disable-vcd --disable-gnomevfs --without-esound --disable-dxr3
  --disable-oss"
@@ -29,7 +29,7 @@ case "$XBPS_TARGET_MACHINE" in
 		;;
 esac
 case "$XBPS_TARGET_MACHINE" in
-	i686*|x86_64*|ppc64*) makedepends+=" libva-glx-devel libvdpau-devel glu-devel";;
+	i686*|x86_64*|ppc64*) makedepends+=" libva-devel libvdpau-devel glu-devel";;
 esac
 
 CFLAGS="-fcommon"

^ permalink raw reply	[flat|nested] 15+ messages in thread

* Re: Build libva with glx (remove libva-glx)
  2020-10-17  7:12 [PR PATCH] [WIP] Build libva with glx (remove libva-glx) st3r4g
                   ` (12 preceding siblings ...)
  2020-10-22  8:25 ` [PR PATCH] [Updated] " st3r4g
@ 2020-10-22  8:25 ` st3r4g
  13 siblings, 0 replies; 15+ messages in thread
From: st3r4g @ 2020-10-22  8:25 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 215 bytes --]

New comment by st3r4g on void-packages repository

https://github.com/void-linux/void-packages/pull/25674#issuecomment-714323918

Comment:
> @st3r4g could perhaps add this explanation to the commit message?

done

^ permalink raw reply	[flat|nested] 15+ messages in thread

end of thread, other threads:[~2020-10-22  8:25 UTC | newest]

Thread overview: 15+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-10-17  7:12 [PR PATCH] [WIP] Build libva with glx (remove libva-glx) st3r4g
2020-10-17  8:53 ` [PR PATCH] [Updated] " st3r4g
2020-10-17 16:08 ` ericonr
2020-10-17 16:09 ` ericonr
2020-10-19  8:50 ` st3r4g
2020-10-19  8:51 ` st3r4g
2020-10-19  8:53 ` st3r4g
2020-10-19 15:17 ` travankor
2020-10-19 15:50 ` [PR PATCH] [Updated] " st3r4g
2020-10-19 15:54 ` st3r4g
2020-10-21 15:11 ` st3r4g
2020-10-21 16:36 ` ericonr
2020-10-21 16:42 ` ahesford
2020-10-22  8:25 ` [PR PATCH] [Updated] " st3r4g
2020-10-22  8:25 ` st3r4g

Github messages for voidlinux

This inbox may be cloned and mirrored by anyone:

	git clone --mirror http://inbox.vuxu.org/voidlinux-github

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V1 voidlinux-github voidlinux-github/ http://inbox.vuxu.org/voidlinux-github \
		voidlinux-github@inbox.vuxu.org
	public-inbox-index voidlinux-github

Example config snippet for mirrors.
Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.github.voidlinux


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git