Github messages for voidlinux
 help / color / mirror / Atom feed
* [PR PATCH] qtkeychain-qt5: update to 0.11.1
@ 2020-11-18 23:32 yopito
  2020-11-19  0:36 ` [PR PATCH] [Updated] " yopito
                   ` (11 more replies)
  0 siblings, 12 replies; 13+ messages in thread
From: yopito @ 2020-11-18 23:32 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 411 bytes --]

There is a new pull request by yopito against master on the void-packages repository

https://github.com/yopito/void-packages qtkeychain.0111
https://github.com/void-linux/void-packages/pull/26497

qtkeychain-qt5: update to 0.11.1
* build is fine
* works with nextcloud client 3.0.2 for both GNOME keyring and kwallet5

A patch file from https://github.com/void-linux/void-packages/pull/26497.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-qtkeychain.0111-26497.patch --]
[-- Type: text/x-diff, Size: 3301 bytes --]

From c4d11feec5eddfda9512c3b26e5952617379ec73 Mon Sep 17 00:00:00 2001
From: yopito <pierre.bourgin@free.fr>
Date: Thu, 12 Nov 2020 21:09:20 +0100
Subject: [PATCH] qtkeychain-qt5: update to 0.11.1

---
 srcpkgs/qtkeychain-qt5/INSTALL.msg                |  2 +-
 .../patches/use-kwallet-dbus-def.patch            | 15 +++++++++++++++
 srcpkgs/qtkeychain-qt5/template                   | 14 ++++++++++----
 3 files changed, 26 insertions(+), 5 deletions(-)
 create mode 100644 srcpkgs/qtkeychain-qt5/patches/use-kwallet-dbus-def.patch

diff --git a/srcpkgs/qtkeychain-qt5/INSTALL.msg b/srcpkgs/qtkeychain-qt5/INSTALL.msg
index 87e12556a84..b358ca1a984 100644
--- a/srcpkgs/qtkeychain-qt5/INSTALL.msg
+++ b/srcpkgs/qtkeychain-qt5/INSTALL.msg
@@ -1,2 +1,2 @@
 To actually use qtkeychain-qt5 you need to either have kwallet or
-libgnome-keyring installed.
+gnome-keyring installed.
diff --git a/srcpkgs/qtkeychain-qt5/patches/use-kwallet-dbus-def.patch b/srcpkgs/qtkeychain-qt5/patches/use-kwallet-dbus-def.patch
new file mode 100644
index 00000000000..d97fcc7890b
--- /dev/null
+++ b/srcpkgs/qtkeychain-qt5/patches/use-kwallet-dbus-def.patch
@@ -0,0 +1,15 @@
+Use kwallet interface definition from the kwallet package,
+instead of using the out-of-date provided in qtkeychain package
+see https://github.com/frankosterfeld/qtkeychain/issues/172
+
+--- CMakeLists.txt.ORIG	2020-09-08 15:13:16.000000000 +0200
++++ CMakeLists.txt	2020-11-13 13:50:56.648621533 +0100
+@@ -169,7 +169,7 @@
+ 
+     add_definitions(-DKEYCHAIN_DBUS=1)
+     list(APPEND qtkeychain_SOURCES keychain_unix.cpp gnomekeyring.cpp libsecret.cpp plaintextstore.cpp)
+-    qt_add_dbus_interface(qtkeychain_SOURCES ${CMAKE_CURRENT_SOURCE_DIR}/org.kde.KWallet.xml kwallet_interface KWalletInterface)
++    qt_add_dbus_interface(qtkeychain_SOURCES /usr/share/dbus-1/interfaces/kf5_org.kde.KWallet.xml kwallet_interface KWalletInterface)
+     list(APPEND qtkeychain_LIBRARIES ${QTDBUS_LIBRARIES} )
+ endif()
+ 
diff --git a/srcpkgs/qtkeychain-qt5/template b/srcpkgs/qtkeychain-qt5/template
index 9bac2f766d0..95422a84fb0 100644
--- a/srcpkgs/qtkeychain-qt5/template
+++ b/srcpkgs/qtkeychain-qt5/template
@@ -1,22 +1,27 @@
 # Template file for 'qtkeychain-qt5'
 pkgname=qtkeychain-qt5
-version=0.9.1
-revision=2
+version=0.11.1
+revision=1
 wrksrc="${pkgname%-*}-${version}"
 build_style=cmake
 hostmakedepends="pkg-config"
-makedepends="libsecret-devel qt5-tools-devel"
+makedepends="libsecret-devel qt5-tools-devel kwallet"
 short_desc="Platform-independent Qt5 API for storing passwords securely"
 maintainer="Duncaen <duncaen@voidlinux.org>"
 license="BSD-2-Clause"
 homepage="https://github.com/frankosterfeld/qtkeychain"
 distfiles="https://github.com/frankosterfeld/${pkgname%-*}/archive/v${version}.tar.gz"
-checksum=9c2762d9d0759a65cdb80106d547db83c6e9fdea66f1973c6e9014f867c6f28e
+checksum=77fc6841c1743d9e6bd499989481cd9239c21bc9bf0760d41a4f4068d2f0a49d
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" qt5-host-tools qt5-tools-devel"
 fi
 
+post_patch() {
+	# ensure it's not used (see dedicated patch)
+	rm org.kde.KWallet.xml
+}
+
 post_install() {
 	vlicense COPYING
 }
@@ -28,5 +33,6 @@ qtkeychain-qt5-devel_package() {
 		vmove usr/include
 		vmove usr/lib/cmake
 		vmove usr/lib/*.so
+		vmove usr/lib/qt5/mkspecs
 	}
 }

^ permalink raw reply	[flat|nested] 13+ messages in thread

* Re: [PR PATCH] [Updated] qtkeychain-qt5: update to 0.11.1
  2020-11-18 23:32 [PR PATCH] qtkeychain-qt5: update to 0.11.1 yopito
@ 2020-11-19  0:36 ` yopito
  2020-11-19  0:45 ` yopito
                   ` (10 subsequent siblings)
  11 siblings, 0 replies; 13+ messages in thread
From: yopito @ 2020-11-19  0:36 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 416 bytes --]

There is an updated pull request by yopito against master on the void-packages repository

https://github.com/yopito/void-packages qtkeychain.0111
https://github.com/void-linux/void-packages/pull/26497

qtkeychain-qt5: update to 0.11.1
* build is fine
* works with nextcloud client 3.0.2 for both GNOME keyring and kwallet5

A patch file from https://github.com/void-linux/void-packages/pull/26497.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-qtkeychain.0111-26497.patch --]
[-- Type: text/x-diff, Size: 3315 bytes --]

From 5d7c04fdcdeaa9a7b1f71d0a72e2f96bc83cf228 Mon Sep 17 00:00:00 2001
From: yopito <pierre.bourgin@free.fr>
Date: Thu, 12 Nov 2020 21:09:20 +0100
Subject: [PATCH] qtkeychain-qt5: update to 0.11.1

closes #26275
---
 srcpkgs/qtkeychain-qt5/INSTALL.msg                |  2 +-
 .../patches/use-kwallet-dbus-def.patch            | 15 +++++++++++++++
 srcpkgs/qtkeychain-qt5/template                   | 14 ++++++++++----
 3 files changed, 26 insertions(+), 5 deletions(-)
 create mode 100644 srcpkgs/qtkeychain-qt5/patches/use-kwallet-dbus-def.patch

diff --git a/srcpkgs/qtkeychain-qt5/INSTALL.msg b/srcpkgs/qtkeychain-qt5/INSTALL.msg
index 87e12556a84..b358ca1a984 100644
--- a/srcpkgs/qtkeychain-qt5/INSTALL.msg
+++ b/srcpkgs/qtkeychain-qt5/INSTALL.msg
@@ -1,2 +1,2 @@
 To actually use qtkeychain-qt5 you need to either have kwallet or
-libgnome-keyring installed.
+gnome-keyring installed.
diff --git a/srcpkgs/qtkeychain-qt5/patches/use-kwallet-dbus-def.patch b/srcpkgs/qtkeychain-qt5/patches/use-kwallet-dbus-def.patch
new file mode 100644
index 00000000000..d97fcc7890b
--- /dev/null
+++ b/srcpkgs/qtkeychain-qt5/patches/use-kwallet-dbus-def.patch
@@ -0,0 +1,15 @@
+Use kwallet interface definition from the kwallet package,
+instead of using the out-of-date provided in qtkeychain package
+see https://github.com/frankosterfeld/qtkeychain/issues/172
+
+--- CMakeLists.txt.ORIG	2020-09-08 15:13:16.000000000 +0200
++++ CMakeLists.txt	2020-11-13 13:50:56.648621533 +0100
+@@ -169,7 +169,7 @@
+ 
+     add_definitions(-DKEYCHAIN_DBUS=1)
+     list(APPEND qtkeychain_SOURCES keychain_unix.cpp gnomekeyring.cpp libsecret.cpp plaintextstore.cpp)
+-    qt_add_dbus_interface(qtkeychain_SOURCES ${CMAKE_CURRENT_SOURCE_DIR}/org.kde.KWallet.xml kwallet_interface KWalletInterface)
++    qt_add_dbus_interface(qtkeychain_SOURCES /usr/share/dbus-1/interfaces/kf5_org.kde.KWallet.xml kwallet_interface KWalletInterface)
+     list(APPEND qtkeychain_LIBRARIES ${QTDBUS_LIBRARIES} )
+ endif()
+ 
diff --git a/srcpkgs/qtkeychain-qt5/template b/srcpkgs/qtkeychain-qt5/template
index 9bac2f766d0..95422a84fb0 100644
--- a/srcpkgs/qtkeychain-qt5/template
+++ b/srcpkgs/qtkeychain-qt5/template
@@ -1,22 +1,27 @@
 # Template file for 'qtkeychain-qt5'
 pkgname=qtkeychain-qt5
-version=0.9.1
-revision=2
+version=0.11.1
+revision=1
 wrksrc="${pkgname%-*}-${version}"
 build_style=cmake
 hostmakedepends="pkg-config"
-makedepends="libsecret-devel qt5-tools-devel"
+makedepends="libsecret-devel qt5-tools-devel kwallet"
 short_desc="Platform-independent Qt5 API for storing passwords securely"
 maintainer="Duncaen <duncaen@voidlinux.org>"
 license="BSD-2-Clause"
 homepage="https://github.com/frankosterfeld/qtkeychain"
 distfiles="https://github.com/frankosterfeld/${pkgname%-*}/archive/v${version}.tar.gz"
-checksum=9c2762d9d0759a65cdb80106d547db83c6e9fdea66f1973c6e9014f867c6f28e
+checksum=77fc6841c1743d9e6bd499989481cd9239c21bc9bf0760d41a4f4068d2f0a49d
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" qt5-host-tools qt5-tools-devel"
 fi
 
+post_patch() {
+	# ensure it's not used (see dedicated patch)
+	rm org.kde.KWallet.xml
+}
+
 post_install() {
 	vlicense COPYING
 }
@@ -28,5 +33,6 @@ qtkeychain-qt5-devel_package() {
 		vmove usr/include
 		vmove usr/lib/cmake
 		vmove usr/lib/*.so
+		vmove usr/lib/qt5/mkspecs
 	}
 }

^ permalink raw reply	[flat|nested] 13+ messages in thread

* Re: [PR PATCH] [Updated] qtkeychain-qt5: update to 0.11.1
  2020-11-18 23:32 [PR PATCH] qtkeychain-qt5: update to 0.11.1 yopito
  2020-11-19  0:36 ` [PR PATCH] [Updated] " yopito
@ 2020-11-19  0:45 ` yopito
  2020-11-20 22:08 ` yopito
                   ` (9 subsequent siblings)
  11 siblings, 0 replies; 13+ messages in thread
From: yopito @ 2020-11-19  0:45 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 519 bytes --]

There is an updated pull request by yopito against master on the void-packages repository

https://github.com/yopito/void-packages qtkeychain.0111
https://github.com/void-linux/void-packages/pull/26497

qtkeychain-qt5: update to 0.11.1
* build is fine
* fix: detect and launch correctly gnome-keyring if available (deprecated libgnome-keyring uneeded)
* works with nextcloud client 3.0.2 for both GNOME keyring and kwallet5


A patch file from https://github.com/void-linux/void-packages/pull/26497.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-qtkeychain.0111-26497.patch --]
[-- Type: text/x-diff, Size: 3298 bytes --]

From 77bdf4397ed854378d47d992279f2b0af3b4bac7 Mon Sep 17 00:00:00 2001
From: yopito <pierre.bourgin@free.fr>
Date: Thu, 12 Nov 2020 21:09:20 +0100
Subject: [PATCH] qtkeychain-qt5: update to 0.11.1

closes #26275
---
 srcpkgs/qtkeychain-qt5/INSTALL.msg                |  2 +-
 .../patches/use-kwallet-dbus-def.patch            | 15 +++++++++++++++
 srcpkgs/qtkeychain-qt5/template                   | 14 ++++++++++----
 3 files changed, 26 insertions(+), 5 deletions(-)
 create mode 100644 srcpkgs/qtkeychain-qt5/patches/use-kwallet-dbus-def.patch

diff --git a/srcpkgs/qtkeychain-qt5/INSTALL.msg b/srcpkgs/qtkeychain-qt5/INSTALL.msg
index 87e12556a84..b358ca1a984 100644
--- a/srcpkgs/qtkeychain-qt5/INSTALL.msg
+++ b/srcpkgs/qtkeychain-qt5/INSTALL.msg
@@ -1,2 +1,2 @@
 To actually use qtkeychain-qt5 you need to either have kwallet or
-libgnome-keyring installed.
+gnome-keyring installed.
diff --git a/srcpkgs/qtkeychain-qt5/patches/use-kwallet-dbus-def.patch b/srcpkgs/qtkeychain-qt5/patches/use-kwallet-dbus-def.patch
new file mode 100644
index 00000000000..d97fcc7890b
--- /dev/null
+++ b/srcpkgs/qtkeychain-qt5/patches/use-kwallet-dbus-def.patch
@@ -0,0 +1,15 @@
+Use kwallet interface definition from the kwallet package,
+instead of using the out-of-date provided in qtkeychain package
+see https://github.com/frankosterfeld/qtkeychain/issues/172
+
+--- CMakeLists.txt.ORIG	2020-09-08 15:13:16.000000000 +0200
++++ CMakeLists.txt	2020-11-13 13:50:56.648621533 +0100
+@@ -169,7 +169,7 @@
+ 
+     add_definitions(-DKEYCHAIN_DBUS=1)
+     list(APPEND qtkeychain_SOURCES keychain_unix.cpp gnomekeyring.cpp libsecret.cpp plaintextstore.cpp)
+-    qt_add_dbus_interface(qtkeychain_SOURCES ${CMAKE_CURRENT_SOURCE_DIR}/org.kde.KWallet.xml kwallet_interface KWalletInterface)
++    qt_add_dbus_interface(qtkeychain_SOURCES /usr/share/dbus-1/interfaces/kf5_org.kde.KWallet.xml kwallet_interface KWalletInterface)
+     list(APPEND qtkeychain_LIBRARIES ${QTDBUS_LIBRARIES} )
+ endif()
+ 
diff --git a/srcpkgs/qtkeychain-qt5/template b/srcpkgs/qtkeychain-qt5/template
index 9bac2f766d0..7abe507b208 100644
--- a/srcpkgs/qtkeychain-qt5/template
+++ b/srcpkgs/qtkeychain-qt5/template
@@ -1,22 +1,27 @@
 # Template file for 'qtkeychain-qt5'
 pkgname=qtkeychain-qt5
-version=0.9.1
-revision=2
+version=0.11.1
+revision=1
 wrksrc="${pkgname%-*}-${version}"
 build_style=cmake
-hostmakedepends="pkg-config"
+hostmakedepends="pkg-config kwallet"
 makedepends="libsecret-devel qt5-tools-devel"
 short_desc="Platform-independent Qt5 API for storing passwords securely"
 maintainer="Duncaen <duncaen@voidlinux.org>"
 license="BSD-2-Clause"
 homepage="https://github.com/frankosterfeld/qtkeychain"
 distfiles="https://github.com/frankosterfeld/${pkgname%-*}/archive/v${version}.tar.gz"
-checksum=9c2762d9d0759a65cdb80106d547db83c6e9fdea66f1973c6e9014f867c6f28e
+checksum=77fc6841c1743d9e6bd499989481cd9239c21bc9bf0760d41a4f4068d2f0a49d
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" qt5-host-tools qt5-tools-devel"
 fi
 
+post_patch() {
+	# ensure it's not used (see dedicated patch)
+	rm org.kde.KWallet.xml
+}
+
 post_install() {
 	vlicense COPYING
 }
@@ -28,5 +33,6 @@ qtkeychain-qt5-devel_package() {
 		vmove usr/include
 		vmove usr/lib/cmake
 		vmove usr/lib/*.so
+		vmove usr/lib/qt5/mkspecs
 	}
 }

^ permalink raw reply	[flat|nested] 13+ messages in thread

* Re: [PR PATCH] [Updated] qtkeychain-qt5: update to 0.11.1
  2020-11-18 23:32 [PR PATCH] qtkeychain-qt5: update to 0.11.1 yopito
  2020-11-19  0:36 ` [PR PATCH] [Updated] " yopito
  2020-11-19  0:45 ` yopito
@ 2020-11-20 22:08 ` yopito
  2020-11-20 22:10 ` yopito
                   ` (8 subsequent siblings)
  11 siblings, 0 replies; 13+ messages in thread
From: yopito @ 2020-11-20 22:08 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 519 bytes --]

There is an updated pull request by yopito against master on the void-packages repository

https://github.com/yopito/void-packages qtkeychain.0111
https://github.com/void-linux/void-packages/pull/26497

qtkeychain-qt5: update to 0.11.1
* build is fine
* fix: detect and launch correctly gnome-keyring if available (deprecated libgnome-keyring uneeded)
* works with nextcloud client 3.0.2 for both GNOME keyring and kwallet5


A patch file from https://github.com/void-linux/void-packages/pull/26497.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-qtkeychain.0111-26497.patch --]
[-- Type: text/x-diff, Size: 3298 bytes --]

From ee1d66da9bf6327d2e18d485b1ce4bbdd12800bc Mon Sep 17 00:00:00 2001
From: yopito <pierre.bourgin@free.fr>
Date: Fri, 20 Nov 2020 23:08:28 +0100
Subject: [PATCH] qtkeychain-qt5: update to 0.11.1

closes #26275
---
 srcpkgs/qtkeychain-qt5/INSTALL.msg                |  2 +-
 .../patches/use-kwallet-dbus-def.patch            | 15 +++++++++++++++
 srcpkgs/qtkeychain-qt5/template                   | 14 ++++++++++----
 3 files changed, 26 insertions(+), 5 deletions(-)
 create mode 100644 srcpkgs/qtkeychain-qt5/patches/use-kwallet-dbus-def.patch

diff --git a/srcpkgs/qtkeychain-qt5/INSTALL.msg b/srcpkgs/qtkeychain-qt5/INSTALL.msg
index 87e12556a84..b358ca1a984 100644
--- a/srcpkgs/qtkeychain-qt5/INSTALL.msg
+++ b/srcpkgs/qtkeychain-qt5/INSTALL.msg
@@ -1,2 +1,2 @@
 To actually use qtkeychain-qt5 you need to either have kwallet or
-libgnome-keyring installed.
+gnome-keyring installed.
diff --git a/srcpkgs/qtkeychain-qt5/patches/use-kwallet-dbus-def.patch b/srcpkgs/qtkeychain-qt5/patches/use-kwallet-dbus-def.patch
new file mode 100644
index 00000000000..d97fcc7890b
--- /dev/null
+++ b/srcpkgs/qtkeychain-qt5/patches/use-kwallet-dbus-def.patch
@@ -0,0 +1,15 @@
+Use kwallet interface definition from the kwallet package,
+instead of using the out-of-date provided in qtkeychain package
+see https://github.com/frankosterfeld/qtkeychain/issues/172
+
+--- CMakeLists.txt.ORIG	2020-09-08 15:13:16.000000000 +0200
++++ CMakeLists.txt	2020-11-13 13:50:56.648621533 +0100
+@@ -169,7 +169,7 @@
+ 
+     add_definitions(-DKEYCHAIN_DBUS=1)
+     list(APPEND qtkeychain_SOURCES keychain_unix.cpp gnomekeyring.cpp libsecret.cpp plaintextstore.cpp)
+-    qt_add_dbus_interface(qtkeychain_SOURCES ${CMAKE_CURRENT_SOURCE_DIR}/org.kde.KWallet.xml kwallet_interface KWalletInterface)
++    qt_add_dbus_interface(qtkeychain_SOURCES /usr/share/dbus-1/interfaces/kf5_org.kde.KWallet.xml kwallet_interface KWalletInterface)
+     list(APPEND qtkeychain_LIBRARIES ${QTDBUS_LIBRARIES} )
+ endif()
+ 
diff --git a/srcpkgs/qtkeychain-qt5/template b/srcpkgs/qtkeychain-qt5/template
index 9bac2f766d0..7abe507b208 100644
--- a/srcpkgs/qtkeychain-qt5/template
+++ b/srcpkgs/qtkeychain-qt5/template
@@ -1,22 +1,27 @@
 # Template file for 'qtkeychain-qt5'
 pkgname=qtkeychain-qt5
-version=0.9.1
-revision=2
+version=0.11.1
+revision=1
 wrksrc="${pkgname%-*}-${version}"
 build_style=cmake
-hostmakedepends="pkg-config"
+hostmakedepends="pkg-config kwallet"
 makedepends="libsecret-devel qt5-tools-devel"
 short_desc="Platform-independent Qt5 API for storing passwords securely"
 maintainer="Duncaen <duncaen@voidlinux.org>"
 license="BSD-2-Clause"
 homepage="https://github.com/frankosterfeld/qtkeychain"
 distfiles="https://github.com/frankosterfeld/${pkgname%-*}/archive/v${version}.tar.gz"
-checksum=9c2762d9d0759a65cdb80106d547db83c6e9fdea66f1973c6e9014f867c6f28e
+checksum=77fc6841c1743d9e6bd499989481cd9239c21bc9bf0760d41a4f4068d2f0a49d
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" qt5-host-tools qt5-tools-devel"
 fi
 
+post_patch() {
+	# ensure it's not used (see dedicated patch)
+	rm org.kde.KWallet.xml
+}
+
 post_install() {
 	vlicense COPYING
 }
@@ -28,5 +33,6 @@ qtkeychain-qt5-devel_package() {
 		vmove usr/include
 		vmove usr/lib/cmake
 		vmove usr/lib/*.so
+		vmove usr/lib/qt5/mkspecs
 	}
 }

^ permalink raw reply	[flat|nested] 13+ messages in thread

* Re: qtkeychain-qt5: update to 0.11.1
  2020-11-18 23:32 [PR PATCH] qtkeychain-qt5: update to 0.11.1 yopito
                   ` (2 preceding siblings ...)
  2020-11-20 22:08 ` yopito
@ 2020-11-20 22:10 ` yopito
  2020-11-20 22:30 ` ericonr
                   ` (7 subsequent siblings)
  11 siblings, 0 replies; 13+ messages in thread
From: yopito @ 2020-11-20 22:10 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 211 bytes --]

New comment by yopito on void-packages repository

https://github.com/void-linux/void-packages/pull/26497#issuecomment-731433241

Comment:
force push to trigger new builds, without gcc rebuild (as of yesterday)

^ permalink raw reply	[flat|nested] 13+ messages in thread

* Re: qtkeychain-qt5: update to 0.11.1
  2020-11-18 23:32 [PR PATCH] qtkeychain-qt5: update to 0.11.1 yopito
                   ` (3 preceding siblings ...)
  2020-11-20 22:10 ` yopito
@ 2020-11-20 22:30 ` ericonr
  2020-11-20 22:38 ` Duncaen
                   ` (6 subsequent siblings)
  11 siblings, 0 replies; 13+ messages in thread
From: ericonr @ 2020-11-20 22:30 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 164 bytes --]

New comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/pull/26497#issuecomment-731440672

Comment:
@Duncaen good to merge?

^ permalink raw reply	[flat|nested] 13+ messages in thread

* Re: qtkeychain-qt5: update to 0.11.1
  2020-11-18 23:32 [PR PATCH] qtkeychain-qt5: update to 0.11.1 yopito
                   ` (4 preceding siblings ...)
  2020-11-20 22:30 ` ericonr
@ 2020-11-20 22:38 ` Duncaen
  2020-11-20 22:38 ` Duncaen
                   ` (5 subsequent siblings)
  11 siblings, 0 replies; 13+ messages in thread
From: Duncaen @ 2020-11-20 22:38 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 164 bytes --]

New comment by Duncaen on void-packages repository

https://github.com/void-linux/void-packages/pull/26497#issuecomment-731443173

Comment:
Probably, don't use it.

^ permalink raw reply	[flat|nested] 13+ messages in thread

* Re: qtkeychain-qt5: update to 0.11.1
  2020-11-18 23:32 [PR PATCH] qtkeychain-qt5: update to 0.11.1 yopito
                   ` (5 preceding siblings ...)
  2020-11-20 22:38 ` Duncaen
@ 2020-11-20 22:38 ` Duncaen
  2020-11-20 22:40 ` ericonr
                   ` (4 subsequent siblings)
  11 siblings, 0 replies; 13+ messages in thread
From: Duncaen @ 2020-11-20 22:38 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 166 bytes --]

New comment by Duncaen on void-packages repository

https://github.com/void-linux/void-packages/pull/26497#issuecomment-731443173

Comment:
Probably, I don't use it.

^ permalink raw reply	[flat|nested] 13+ messages in thread

* Re: qtkeychain-qt5: update to 0.11.1
  2020-11-18 23:32 [PR PATCH] qtkeychain-qt5: update to 0.11.1 yopito
                   ` (6 preceding siblings ...)
  2020-11-20 22:38 ` Duncaen
@ 2020-11-20 22:40 ` ericonr
  2020-11-21 18:52 ` yopito
                   ` (3 subsequent siblings)
  11 siblings, 0 replies; 13+ messages in thread
From: ericonr @ 2020-11-20 22:40 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 163 bytes --]

New comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/pull/26497#issuecomment-731443797

Comment:
@yopito want to adopt?

^ permalink raw reply	[flat|nested] 13+ messages in thread

* Re: qtkeychain-qt5: update to 0.11.1
  2020-11-18 23:32 [PR PATCH] qtkeychain-qt5: update to 0.11.1 yopito
                   ` (7 preceding siblings ...)
  2020-11-20 22:40 ` ericonr
@ 2020-11-21 18:52 ` yopito
  2020-11-21 18:55 ` [PR PATCH] [Updated] " yopito
                   ` (2 subsequent siblings)
  11 siblings, 0 replies; 13+ messages in thread
From: yopito @ 2020-11-21 18:52 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 213 bytes --]

New comment by yopito on void-packages repository

https://github.com/void-linux/void-packages/pull/26497#issuecomment-731620681

Comment:
make sense since nextcloud is rely on it. I force push again for adoption

^ permalink raw reply	[flat|nested] 13+ messages in thread

* Re: [PR PATCH] [Updated] qtkeychain-qt5: update to 0.11.1
  2020-11-18 23:32 [PR PATCH] qtkeychain-qt5: update to 0.11.1 yopito
                   ` (8 preceding siblings ...)
  2020-11-21 18:52 ` yopito
@ 2020-11-21 18:55 ` yopito
  2020-11-21 20:20 ` [PR PATCH] [Merged]: " ericonr
  2020-11-21 20:20 ` ericonr
  11 siblings, 0 replies; 13+ messages in thread
From: yopito @ 2020-11-21 18:55 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 536 bytes --]

There is an updated pull request by yopito against master on the void-packages repository

https://github.com/yopito/void-packages qtkeychain.0111
https://github.com/void-linux/void-packages/pull/26497

qtkeychain-qt5: update to 0.11.1
* build is fine
* compared to 0.9.1: detect and launch correctly gnome-keyring if available (deprecated libgnome-keyring is uneeded)
* works with nextcloud client 3.0.2 for both GNOME keyring and kwallet5


A patch file from https://github.com/void-linux/void-packages/pull/26497.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-qtkeychain.0111-26497.patch --]
[-- Type: text/x-diff, Size: 3356 bytes --]

From 7a856a80833259ec97d5825454cd8108f1201e08 Mon Sep 17 00:00:00 2001
From: yopito <pierre.bourgin@free.fr>
Date: Fri, 20 Nov 2020 23:08:28 +0100
Subject: [PATCH] qtkeychain-qt5: update to 0.11.1, adopt

closes #26275
---
 srcpkgs/qtkeychain-qt5/INSTALL.msg               |  2 +-
 .../patches/use-kwallet-dbus-def.patch           | 15 +++++++++++++++
 srcpkgs/qtkeychain-qt5/template                  | 16 +++++++++++-----
 3 files changed, 27 insertions(+), 6 deletions(-)
 create mode 100644 srcpkgs/qtkeychain-qt5/patches/use-kwallet-dbus-def.patch

diff --git a/srcpkgs/qtkeychain-qt5/INSTALL.msg b/srcpkgs/qtkeychain-qt5/INSTALL.msg
index 87e12556a843..b358ca1a9842 100644
--- a/srcpkgs/qtkeychain-qt5/INSTALL.msg
+++ b/srcpkgs/qtkeychain-qt5/INSTALL.msg
@@ -1,2 +1,2 @@
 To actually use qtkeychain-qt5 you need to either have kwallet or
-libgnome-keyring installed.
+gnome-keyring installed.
diff --git a/srcpkgs/qtkeychain-qt5/patches/use-kwallet-dbus-def.patch b/srcpkgs/qtkeychain-qt5/patches/use-kwallet-dbus-def.patch
new file mode 100644
index 000000000000..d97fcc7890b2
--- /dev/null
+++ b/srcpkgs/qtkeychain-qt5/patches/use-kwallet-dbus-def.patch
@@ -0,0 +1,15 @@
+Use kwallet interface definition from the kwallet package,
+instead of using the out-of-date provided in qtkeychain package
+see https://github.com/frankosterfeld/qtkeychain/issues/172
+
+--- CMakeLists.txt.ORIG	2020-09-08 15:13:16.000000000 +0200
++++ CMakeLists.txt	2020-11-13 13:50:56.648621533 +0100
+@@ -169,7 +169,7 @@
+ 
+     add_definitions(-DKEYCHAIN_DBUS=1)
+     list(APPEND qtkeychain_SOURCES keychain_unix.cpp gnomekeyring.cpp libsecret.cpp plaintextstore.cpp)
+-    qt_add_dbus_interface(qtkeychain_SOURCES ${CMAKE_CURRENT_SOURCE_DIR}/org.kde.KWallet.xml kwallet_interface KWalletInterface)
++    qt_add_dbus_interface(qtkeychain_SOURCES /usr/share/dbus-1/interfaces/kf5_org.kde.KWallet.xml kwallet_interface KWalletInterface)
+     list(APPEND qtkeychain_LIBRARIES ${QTDBUS_LIBRARIES} )
+ endif()
+ 
diff --git a/srcpkgs/qtkeychain-qt5/template b/srcpkgs/qtkeychain-qt5/template
index 9bac2f766d04..4e4c982850a1 100644
--- a/srcpkgs/qtkeychain-qt5/template
+++ b/srcpkgs/qtkeychain-qt5/template
@@ -1,22 +1,27 @@
 # Template file for 'qtkeychain-qt5'
 pkgname=qtkeychain-qt5
-version=0.9.1
-revision=2
+version=0.11.1
+revision=1
 wrksrc="${pkgname%-*}-${version}"
 build_style=cmake
-hostmakedepends="pkg-config"
+hostmakedepends="pkg-config kwallet"
 makedepends="libsecret-devel qt5-tools-devel"
 short_desc="Platform-independent Qt5 API for storing passwords securely"
-maintainer="Duncaen <duncaen@voidlinux.org>"
+maintainer="yopito <pierre.bourgin@free.fr>"
 license="BSD-2-Clause"
 homepage="https://github.com/frankosterfeld/qtkeychain"
 distfiles="https://github.com/frankosterfeld/${pkgname%-*}/archive/v${version}.tar.gz"
-checksum=9c2762d9d0759a65cdb80106d547db83c6e9fdea66f1973c6e9014f867c6f28e
+checksum=77fc6841c1743d9e6bd499989481cd9239c21bc9bf0760d41a4f4068d2f0a49d
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" qt5-host-tools qt5-tools-devel"
 fi
 
+post_patch() {
+	# ensure it's not used (see dedicated patch)
+	rm org.kde.KWallet.xml
+}
+
 post_install() {
 	vlicense COPYING
 }
@@ -28,5 +33,6 @@ qtkeychain-qt5-devel_package() {
 		vmove usr/include
 		vmove usr/lib/cmake
 		vmove usr/lib/*.so
+		vmove usr/lib/qt5/mkspecs
 	}
 }

^ permalink raw reply	[flat|nested] 13+ messages in thread

* Re: [PR PATCH] [Merged]: qtkeychain-qt5: update to 0.11.1
  2020-11-18 23:32 [PR PATCH] qtkeychain-qt5: update to 0.11.1 yopito
                   ` (9 preceding siblings ...)
  2020-11-21 18:55 ` [PR PATCH] [Updated] " yopito
@ 2020-11-21 20:20 ` ericonr
  2020-11-21 20:20 ` ericonr
  11 siblings, 0 replies; 13+ messages in thread
From: ericonr @ 2020-11-21 20:20 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 374 bytes --]

There's a merged pull request on the void-packages repository

qtkeychain-qt5: update to 0.11.1
https://github.com/void-linux/void-packages/pull/26497

Description:
* build is fine
* compared to 0.9.1: detect and launch correctly gnome-keyring if available (deprecated libgnome-keyring is uneeded)
* works with nextcloud client 3.0.2 for both GNOME keyring and kwallet5


^ permalink raw reply	[flat|nested] 13+ messages in thread

* Re: qtkeychain-qt5: update to 0.11.1
  2020-11-18 23:32 [PR PATCH] qtkeychain-qt5: update to 0.11.1 yopito
                   ` (10 preceding siblings ...)
  2020-11-21 20:20 ` [PR PATCH] [Merged]: " ericonr
@ 2020-11-21 20:20 ` ericonr
  11 siblings, 0 replies; 13+ messages in thread
From: ericonr @ 2020-11-21 20:20 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 148 bytes --]

New comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/pull/26497#issuecomment-731631452

Comment:
Thanks!

^ permalink raw reply	[flat|nested] 13+ messages in thread

end of thread, other threads:[~2020-11-21 20:20 UTC | newest]

Thread overview: 13+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-11-18 23:32 [PR PATCH] qtkeychain-qt5: update to 0.11.1 yopito
2020-11-19  0:36 ` [PR PATCH] [Updated] " yopito
2020-11-19  0:45 ` yopito
2020-11-20 22:08 ` yopito
2020-11-20 22:10 ` yopito
2020-11-20 22:30 ` ericonr
2020-11-20 22:38 ` Duncaen
2020-11-20 22:38 ` Duncaen
2020-11-20 22:40 ` ericonr
2020-11-21 18:52 ` yopito
2020-11-21 18:55 ` [PR PATCH] [Updated] " yopito
2020-11-21 20:20 ` [PR PATCH] [Merged]: " ericonr
2020-11-21 20:20 ` ericonr

Github messages for voidlinux

This inbox may be cloned and mirrored by anyone:

	git clone --mirror http://inbox.vuxu.org/voidlinux-github

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V1 voidlinux-github voidlinux-github/ http://inbox.vuxu.org/voidlinux-github \
		voidlinux-github@inbox.vuxu.org
	public-inbox-index voidlinux-github

Example config snippet for mirrors.
Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.github.voidlinux


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git