Github messages for voidlinux
 help / color / mirror / Atom feed
* [PR PATCH] RFC: rename sip 4.x to sip4, sip5 to sip, update to 6.0.0
@ 2021-01-08  1:14 sgn
  2021-01-08  1:20 ` [PR PATCH] [Updated] " sgn
                   ` (10 more replies)
  0 siblings, 11 replies; 12+ messages in thread
From: sgn @ 2021-01-08  1:14 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 525 bytes --]

There is a new pull request by sgn against master on the void-packages repository

https://github.com/sgn/void-packages sip-rename
https://github.com/void-linux/void-packages/pull/27753

RFC: rename sip 4.x to sip4, sip5 to sip, update to 6.0.0
- Most of our packages have the convention of using versioned-suffix for old packages
- Have `sip5` package with version 6 is weird to me
- I'm expecting sip 4.x will be phased out soon.

A patch file from https://github.com/void-linux/void-packages/pull/27753.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-sip-rename-27753.patch --]
[-- Type: text/x-diff, Size: 11728 bytes --]

From 7d43aaf8a8aa859885091f6d8f5bfabe8c298cc9 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 08:02:10 +0700
Subject: [PATCH 1/8] gns3-gui: not depends on python3-sip

Indirectly depends via PyQt5.
---
 srcpkgs/gns3-gui/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/gns3-gui/template b/srcpkgs/gns3-gui/template
index f7f51364548..1d7d84c4c65 100644
--- a/srcpkgs/gns3-gui/template
+++ b/srcpkgs/gns3-gui/template
@@ -1,11 +1,11 @@
 # Template file for 'gns3-gui'
 pkgname=gns3-gui
 version=2.2.17
-revision=1
+revision=2
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-setuptools python3-psutil python3-jsonschema python3-sentry
- python3-PyQt5-svg python3-PyQt5-websockets python3-sip xterm inetutils-telnet
+ python3-PyQt5-svg python3-PyQt5-websockets xterm inetutils-telnet
  gns3-net-converter python3-distro"
 checkdepends="${depends}"
 short_desc="Graphical Network Simulator 3 - GUI"

From dfc0715c0921903c0416d5a422001348be7b742e Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 08:05:44 +0700
Subject: [PATCH 2/8] sip: rename to sip4

---
 srcpkgs/python3-orocos-kdl/template | 2 +-
 srcpkgs/python3-sip                 | 2 +-
 srcpkgs/python3-sip-devel           | 2 +-
 srcpkgs/{sip => sip4}/template      | 9 ++++++---
 srcpkgs/{sip => sip4}/update        | 0
 5 files changed, 9 insertions(+), 6 deletions(-)
 rename srcpkgs/{sip => sip4}/template (88%)
 rename srcpkgs/{sip => sip4}/update (100%)

diff --git a/srcpkgs/python3-orocos-kdl/template b/srcpkgs/python3-orocos-kdl/template
index 728ed73d780..281ea8978c5 100644
--- a/srcpkgs/python3-orocos-kdl/template
+++ b/srcpkgs/python3-orocos-kdl/template
@@ -6,7 +6,7 @@ wrksrc=orocos_kinematics_dynamics-${version}
 build_wrksrc=python_orocos_kdl
 build_style=cmake
 configure_args="-DPYTHON_VERSION=3 -DSIP_EXECUTABLE=/usr/bin/sip"
-hostmakedepends="python3 python3-sip sip"
+hostmakedepends="python3 python3-sip sip4"
 makedepends="python3-sip-devel python3-devel orocos-kdl-devel eigen3.2"
 depends="python3 python3-sip"
 short_desc="Python3 Bindings for Orocos Kinematics and Dynamics C++ library"
diff --git a/srcpkgs/python3-sip b/srcpkgs/python3-sip
index 633f7c0bcce..27dcc148ae7 120000
--- a/srcpkgs/python3-sip
+++ b/srcpkgs/python3-sip
@@ -1 +1 @@
-sip
\ No newline at end of file
+sip4
\ No newline at end of file
diff --git a/srcpkgs/python3-sip-devel b/srcpkgs/python3-sip-devel
index 633f7c0bcce..27dcc148ae7 120000
--- a/srcpkgs/python3-sip-devel
+++ b/srcpkgs/python3-sip-devel
@@ -1 +1 @@
-sip
\ No newline at end of file
+sip4
\ No newline at end of file
diff --git a/srcpkgs/sip/template b/srcpkgs/sip4/template
similarity index 88%
rename from srcpkgs/sip/template
rename to srcpkgs/sip4/template
index 87d0c5c6ed6..8afbf8e5d0a 100644
--- a/srcpkgs/sip/template
+++ b/srcpkgs/sip4/template
@@ -1,7 +1,8 @@
-# Template file for 'sip'
-pkgname=sip
+# Template file for 'sip4'
+pkgname=sip4
 version=4.19.24
 revision=3
+wrksrc="sip-$version"
 hostmakedepends="python3-devel"
 makedepends="${hostmakedepends}"
 short_desc="Python extension module generator for C/C++ libraries"
@@ -10,12 +11,14 @@ license="GPL-2.0-only, GPL-3.0-only, custom:SIP"
 homepage="https://riverbankcomputing.com/software/sip/intro"
 distfiles="https://www.riverbankcomputing.com/static/Downloads/sip/${version}/sip-${version}.tar.gz"
 checksum=edcd3790bb01938191eef0f6117de0bf56d1136626c0ddb678f3a558d62e41e5
+replaces="sip<=${version}_${revision}"
+provides="sip-${version}_${revision}"
 
 do_build() {
 	python3 configure.py \
 		CC="${CC}" CFLAGS="${CFLAGS}" CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" \
 		LINK="${CXX}" LINK_SHLIB="${CXX}" LFLAGS="${LDFLAGS}" STRIP="" \
-		INCDIR="${XBPS_CROSS_BASE}/${py3_inc}" ${pyqt5}
+		INCDIR="${XBPS_CROSS_BASE}/${py3_inc}"
 	make ${makejobs}
 }
 
diff --git a/srcpkgs/sip/update b/srcpkgs/sip4/update
similarity index 100%
rename from srcpkgs/sip/update
rename to srcpkgs/sip4/update

From 9845eb9dcaedd85d17ee29f585ff90f53a195987 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 08:07:11 +0700
Subject: [PATCH 3/8] sip5: rename to sip

---
 srcpkgs/{sip5 => sip}/template | 9 +++++----
 srcpkgs/{sip5 => sip}/update   | 0
 2 files changed, 5 insertions(+), 4 deletions(-)
 rename srcpkgs/{sip5 => sip}/template (77%)
 rename srcpkgs/{sip5 => sip}/update (100%)

diff --git a/srcpkgs/sip5/template b/srcpkgs/sip/template
similarity index 77%
rename from srcpkgs/sip5/template
rename to srcpkgs/sip/template
index b8e3d0bf10d..4b2090ad89f 100644
--- a/srcpkgs/sip5/template
+++ b/srcpkgs/sip/template
@@ -1,19 +1,20 @@
-# Template file for 'sip5'
-pkgname=sip5
+# Template file for 'sip'
+pkgname=sip
 version=5.5.0
 revision=1
-wrksrc="sip-$version"
 build_style=python3-module
 hostmakedepends="python3-devel python3-setuptools python3-packaging python3-toml"
 makedepends="python3-devel"
 depends="python3-setuptools python3-packaging python3-toml"
-short_desc="SIP 5 - Python 3 bindings generator for C/C++ libraries"
+short_desc="SIP - Python 3 bindings generator for C/C++ libraries"
 maintainer="Đoàn Trần Công Danh <congdanhqx@gmail.com>"
 license="GPL-2.0-only, GPL-3.0-only, custom:SIP"
 homepage="https://riverbankcomputing.com/software/sip/intro"
 distfiles="${PYPI_SITE}/s/sip/sip-${version}.tar.gz"
 checksum=5d024c419b30fea8a6de8c71a560c7ab0bc3c221fbfb14d55a5b865bd58eaac5
 lib32disabled=yes
+replaces="sip5<=${version}_${revision}"
+provides="sip5-${version}_${revision}"
 
 post_install() {
 	sed -n '1,/SUCH DAMAGE/p' sipbuild/project.py >NOTICE
diff --git a/srcpkgs/sip5/update b/srcpkgs/sip/update
similarity index 100%
rename from srcpkgs/sip5/update
rename to srcpkgs/sip/update

From 97b2aaffefe51caa7f9663498b6f8e14a39c5de8 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 08:08:58 +0700
Subject: [PATCH 4/8] sip: update to 6.0.0.

---
 srcpkgs/sip/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/sip/template b/srcpkgs/sip/template
index 4b2090ad89f..3cca9aa59d5 100644
--- a/srcpkgs/sip/template
+++ b/srcpkgs/sip/template
@@ -1,6 +1,6 @@
 # Template file for 'sip'
 pkgname=sip
-version=5.5.0
+version=6.0.0
 revision=1
 build_style=python3-module
 hostmakedepends="python3-devel python3-setuptools python3-packaging python3-toml"
@@ -11,7 +11,7 @@ maintainer="Đoàn Trần Công Danh <congdanhqx@gmail.com>"
 license="GPL-2.0-only, GPL-3.0-only, custom:SIP"
 homepage="https://riverbankcomputing.com/software/sip/intro"
 distfiles="${PYPI_SITE}/s/sip/sip-${version}.tar.gz"
-checksum=5d024c419b30fea8a6de8c71a560c7ab0bc3c221fbfb14d55a5b865bd58eaac5
+checksum=6185160e1aa8e167b5919c4761cbbf68cc7478d34fb655b3a28b3eb9acb5943a
 lib32disabled=yes
 replaces="sip5<=${version}_${revision}"
 provides="sip5-${version}_${revision}"

From 5abce076dbc9aa9585079da275267ee3518e8634 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 07:52:02 +0700
Subject: [PATCH 5/8] python3-PyQt-builder: update to 1.7.0.

---
 srcpkgs/python3-PyQt-builder/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-PyQt-builder/template b/srcpkgs/python3-PyQt-builder/template
index 1d6c8fa73d4..f6801051e10 100644
--- a/srcpkgs/python3-PyQt-builder/template
+++ b/srcpkgs/python3-PyQt-builder/template
@@ -1,17 +1,17 @@
 # Template file for 'python3-PyQt-builder'
 pkgname=python3-PyQt-builder
-version=1.6.0
+version=1.7.0
 revision=1
 wrksrc=PyQt-builder-$version
 build_style=python3-module
 hostmakedepends="python3-setuptools"
-depends="python3 sip5>=5.5.0"
+depends="python3 sip>=6.0.0"
 short_desc="PEP 517 compliant PyQt build system"
 maintainer="Đoàn Trần Công Danh <congdanhqx@gmail.com>"
 license="GPL-2.0-only, GPL-3.0-only, custom:SIP"
 homepage="https://www.riverbankcomputing.com/software/pyqt/"
 distfiles="$PYPI_SITE/P/PyQt-builder/PyQt-builder-$version.tar.gz"
-checksum=fb80f01407718bfc68f78e276f2543fcfc5b5900b1187c1fd1f2ff51a6f2a13c
+checksum=b6e3c826f98ff4006ecb34df491ac6062a023b63a32e9f9f50904867aff72f2e
 
 post_install() {
 	rm -rf $DESTDIR/$py3_sitelib/pyqtbuild/bundle

From 064355da6d7cb85d7198f2b20655604fd96ca5b8 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 07:54:12 +0700
Subject: [PATCH 6/8] python3-PyQt5-webengine: sip5 has been renamed to sip

---
 srcpkgs/python3-PyQt5-webengine/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/python3-PyQt5-webengine/template b/srcpkgs/python3-PyQt5-webengine/template
index 920cae92627..ae385283b7f 100644
--- a/srcpkgs/python3-PyQt5-webengine/template
+++ b/srcpkgs/python3-PyQt5-webengine/template
@@ -3,7 +3,7 @@ pkgname=python3-PyQt5-webengine
 version=5.15.2
 revision=1
 wrksrc="PyQtWebEngine-${version}"
-hostmakedepends="pkg-config qt5-qmake python3-PyQt5 sip5 qt5-webengine-devel
+hostmakedepends="pkg-config qt5-qmake python3-PyQt5 sip qt5-webengine-devel
  python3-PyQt-builder python3-PyQt5-devel
  qt5-declarative-devel qt5-webchannel-devel qt5-location-devel"
 makedepends="qt5-declarative-devel qt5-webchannel-devel qt5-location-devel

From a7c62bc00ef2bbba1042cec7594376ab2386593e Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 07:55:20 +0700
Subject: [PATCH 7/8] python3-PyQt5: depends on new sip

---
 srcpkgs/python3-PyQt5/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-PyQt5/template b/srcpkgs/python3-PyQt5/template
index bac89e57965..2a2733b439c 100644
--- a/srcpkgs/python3-PyQt5/template
+++ b/srcpkgs/python3-PyQt5/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-PyQt5'
 pkgname=python3-PyQt5
 version=5.15.2
-revision=1
+revision=2
 _sipver=12.8.0
 wrksrc="PyQt5-${version}"
 build_helper=qemu
@@ -193,7 +193,7 @@ python3-PyQt5-devel-tools_package() {
 	}
 }
 python3-PyQt5-devel_package() {
-	depends="sip5 python3-PyQt5-${version}_${revision}"
+	depends="sip>=6.0.0 python3-PyQt5-${version}_${revision}"
 	short_desc+=" - development files"
 	pkg_install() {
 		vmove ${py3_sitelib}/PyQt5/bindings

From fcb08c483eaf70fa8476cf2aae2544ca558c9dbf Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 07:56:13 +0700
Subject: [PATCH 8/8] python3-sip-PyQt5: build with new sip

---
 srcpkgs/python3-sip-PyQt5/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-sip-PyQt5/template b/srcpkgs/python3-sip-PyQt5/template
index e1d1c45603d..488783efcaa 100644
--- a/srcpkgs/python3-sip-PyQt5/template
+++ b/srcpkgs/python3-sip-PyQt5/template
@@ -4,7 +4,7 @@ version=12.8.1
 revision=1
 wrksrc="PyQt5_sip-$version"
 build_style=python3-module
-hostmakedepends="python3-devel python3-setuptools sip5"
+hostmakedepends="python3-devel python3-setuptools sip"
 makedepends="python3-devel"
 short_desc="Python 3 PyQt5 SIP bindings with C and C++"
 maintainer="Orphaned <orphan@voidlinux.org>"
@@ -15,5 +15,5 @@ checksum=30e944db9abee9cc757aea16906d4198129558533eb7fadbe48c5da2bd18e0bd
 lib32disabled=yes
 
 post_install() {
-	vlicense /usr/share/licenses/sip5/LICENSE
+	vlicense /usr/share/licenses/sip/LICENSE
 }

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [PR PATCH] [Updated] RFC: rename sip 4.x to sip4, sip5 to sip, update to 6.0.0
  2021-01-08  1:14 [PR PATCH] RFC: rename sip 4.x to sip4, sip5 to sip, update to 6.0.0 sgn
@ 2021-01-08  1:20 ` sgn
  2021-01-08  1:26 ` sgn
                   ` (9 subsequent siblings)
  10 siblings, 0 replies; 12+ messages in thread
From: sgn @ 2021-01-08  1:20 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 530 bytes --]

There is an updated pull request by sgn against master on the void-packages repository

https://github.com/sgn/void-packages sip-rename
https://github.com/void-linux/void-packages/pull/27753

RFC: rename sip 4.x to sip4, sip5 to sip, update to 6.0.0
- Most of our packages have the convention of using versioned-suffix for old packages
- Have `sip5` package with version 6 is weird to me
- I'm expecting sip 4.x will be phased out soon.

A patch file from https://github.com/void-linux/void-packages/pull/27753.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-sip-rename-27753.patch --]
[-- Type: text/x-diff, Size: 11772 bytes --]

From 7d43aaf8a8aa859885091f6d8f5bfabe8c298cc9 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 08:02:10 +0700
Subject: [PATCH 1/8] gns3-gui: not depends on python3-sip

Indirectly depends via PyQt5.
---
 srcpkgs/gns3-gui/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/gns3-gui/template b/srcpkgs/gns3-gui/template
index f7f51364548..1d7d84c4c65 100644
--- a/srcpkgs/gns3-gui/template
+++ b/srcpkgs/gns3-gui/template
@@ -1,11 +1,11 @@
 # Template file for 'gns3-gui'
 pkgname=gns3-gui
 version=2.2.17
-revision=1
+revision=2
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-setuptools python3-psutil python3-jsonschema python3-sentry
- python3-PyQt5-svg python3-PyQt5-websockets python3-sip xterm inetutils-telnet
+ python3-PyQt5-svg python3-PyQt5-websockets xterm inetutils-telnet
  gns3-net-converter python3-distro"
 checkdepends="${depends}"
 short_desc="Graphical Network Simulator 3 - GUI"

From dfc0715c0921903c0416d5a422001348be7b742e Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 08:05:44 +0700
Subject: [PATCH 2/8] sip: rename to sip4

---
 srcpkgs/python3-orocos-kdl/template | 2 +-
 srcpkgs/python3-sip                 | 2 +-
 srcpkgs/python3-sip-devel           | 2 +-
 srcpkgs/{sip => sip4}/template      | 9 ++++++---
 srcpkgs/{sip => sip4}/update        | 0
 5 files changed, 9 insertions(+), 6 deletions(-)
 rename srcpkgs/{sip => sip4}/template (88%)
 rename srcpkgs/{sip => sip4}/update (100%)

diff --git a/srcpkgs/python3-orocos-kdl/template b/srcpkgs/python3-orocos-kdl/template
index 728ed73d780..281ea8978c5 100644
--- a/srcpkgs/python3-orocos-kdl/template
+++ b/srcpkgs/python3-orocos-kdl/template
@@ -6,7 +6,7 @@ wrksrc=orocos_kinematics_dynamics-${version}
 build_wrksrc=python_orocos_kdl
 build_style=cmake
 configure_args="-DPYTHON_VERSION=3 -DSIP_EXECUTABLE=/usr/bin/sip"
-hostmakedepends="python3 python3-sip sip"
+hostmakedepends="python3 python3-sip sip4"
 makedepends="python3-sip-devel python3-devel orocos-kdl-devel eigen3.2"
 depends="python3 python3-sip"
 short_desc="Python3 Bindings for Orocos Kinematics and Dynamics C++ library"
diff --git a/srcpkgs/python3-sip b/srcpkgs/python3-sip
index 633f7c0bcce..27dcc148ae7 120000
--- a/srcpkgs/python3-sip
+++ b/srcpkgs/python3-sip
@@ -1 +1 @@
-sip
\ No newline at end of file
+sip4
\ No newline at end of file
diff --git a/srcpkgs/python3-sip-devel b/srcpkgs/python3-sip-devel
index 633f7c0bcce..27dcc148ae7 120000
--- a/srcpkgs/python3-sip-devel
+++ b/srcpkgs/python3-sip-devel
@@ -1 +1 @@
-sip
\ No newline at end of file
+sip4
\ No newline at end of file
diff --git a/srcpkgs/sip/template b/srcpkgs/sip4/template
similarity index 88%
rename from srcpkgs/sip/template
rename to srcpkgs/sip4/template
index 87d0c5c6ed6..8afbf8e5d0a 100644
--- a/srcpkgs/sip/template
+++ b/srcpkgs/sip4/template
@@ -1,7 +1,8 @@
-# Template file for 'sip'
-pkgname=sip
+# Template file for 'sip4'
+pkgname=sip4
 version=4.19.24
 revision=3
+wrksrc="sip-$version"
 hostmakedepends="python3-devel"
 makedepends="${hostmakedepends}"
 short_desc="Python extension module generator for C/C++ libraries"
@@ -10,12 +11,14 @@ license="GPL-2.0-only, GPL-3.0-only, custom:SIP"
 homepage="https://riverbankcomputing.com/software/sip/intro"
 distfiles="https://www.riverbankcomputing.com/static/Downloads/sip/${version}/sip-${version}.tar.gz"
 checksum=edcd3790bb01938191eef0f6117de0bf56d1136626c0ddb678f3a558d62e41e5
+replaces="sip<=${version}_${revision}"
+provides="sip-${version}_${revision}"
 
 do_build() {
 	python3 configure.py \
 		CC="${CC}" CFLAGS="${CFLAGS}" CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" \
 		LINK="${CXX}" LINK_SHLIB="${CXX}" LFLAGS="${LDFLAGS}" STRIP="" \
-		INCDIR="${XBPS_CROSS_BASE}/${py3_inc}" ${pyqt5}
+		INCDIR="${XBPS_CROSS_BASE}/${py3_inc}"
 	make ${makejobs}
 }
 
diff --git a/srcpkgs/sip/update b/srcpkgs/sip4/update
similarity index 100%
rename from srcpkgs/sip/update
rename to srcpkgs/sip4/update

From 9845eb9dcaedd85d17ee29f585ff90f53a195987 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 08:07:11 +0700
Subject: [PATCH 3/8] sip5: rename to sip

---
 srcpkgs/{sip5 => sip}/template | 9 +++++----
 srcpkgs/{sip5 => sip}/update   | 0
 2 files changed, 5 insertions(+), 4 deletions(-)
 rename srcpkgs/{sip5 => sip}/template (77%)
 rename srcpkgs/{sip5 => sip}/update (100%)

diff --git a/srcpkgs/sip5/template b/srcpkgs/sip/template
similarity index 77%
rename from srcpkgs/sip5/template
rename to srcpkgs/sip/template
index b8e3d0bf10d..4b2090ad89f 100644
--- a/srcpkgs/sip5/template
+++ b/srcpkgs/sip/template
@@ -1,19 +1,20 @@
-# Template file for 'sip5'
-pkgname=sip5
+# Template file for 'sip'
+pkgname=sip
 version=5.5.0
 revision=1
-wrksrc="sip-$version"
 build_style=python3-module
 hostmakedepends="python3-devel python3-setuptools python3-packaging python3-toml"
 makedepends="python3-devel"
 depends="python3-setuptools python3-packaging python3-toml"
-short_desc="SIP 5 - Python 3 bindings generator for C/C++ libraries"
+short_desc="SIP - Python 3 bindings generator for C/C++ libraries"
 maintainer="Đoàn Trần Công Danh <congdanhqx@gmail.com>"
 license="GPL-2.0-only, GPL-3.0-only, custom:SIP"
 homepage="https://riverbankcomputing.com/software/sip/intro"
 distfiles="${PYPI_SITE}/s/sip/sip-${version}.tar.gz"
 checksum=5d024c419b30fea8a6de8c71a560c7ab0bc3c221fbfb14d55a5b865bd58eaac5
 lib32disabled=yes
+replaces="sip5<=${version}_${revision}"
+provides="sip5-${version}_${revision}"
 
 post_install() {
 	sed -n '1,/SUCH DAMAGE/p' sipbuild/project.py >NOTICE
diff --git a/srcpkgs/sip5/update b/srcpkgs/sip/update
similarity index 100%
rename from srcpkgs/sip5/update
rename to srcpkgs/sip/update

From 97b2aaffefe51caa7f9663498b6f8e14a39c5de8 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 08:08:58 +0700
Subject: [PATCH 4/8] sip: update to 6.0.0.

---
 srcpkgs/sip/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/sip/template b/srcpkgs/sip/template
index 4b2090ad89f..3cca9aa59d5 100644
--- a/srcpkgs/sip/template
+++ b/srcpkgs/sip/template
@@ -1,6 +1,6 @@
 # Template file for 'sip'
 pkgname=sip
-version=5.5.0
+version=6.0.0
 revision=1
 build_style=python3-module
 hostmakedepends="python3-devel python3-setuptools python3-packaging python3-toml"
@@ -11,7 +11,7 @@ maintainer="Đoàn Trần Công Danh <congdanhqx@gmail.com>"
 license="GPL-2.0-only, GPL-3.0-only, custom:SIP"
 homepage="https://riverbankcomputing.com/software/sip/intro"
 distfiles="${PYPI_SITE}/s/sip/sip-${version}.tar.gz"
-checksum=5d024c419b30fea8a6de8c71a560c7ab0bc3c221fbfb14d55a5b865bd58eaac5
+checksum=6185160e1aa8e167b5919c4761cbbf68cc7478d34fb655b3a28b3eb9acb5943a
 lib32disabled=yes
 replaces="sip5<=${version}_${revision}"
 provides="sip5-${version}_${revision}"

From 95b9a8ca4735a018dddae141d07e7e2c383d4136 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 07:52:02 +0700
Subject: [PATCH 5/8] python3-PyQt-builder: update to 1.7.0.

---
 srcpkgs/python3-PyQt-builder/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-PyQt-builder/template b/srcpkgs/python3-PyQt-builder/template
index 1d6c8fa73d4..956a6ab1cde 100644
--- a/srcpkgs/python3-PyQt-builder/template
+++ b/srcpkgs/python3-PyQt-builder/template
@@ -1,17 +1,17 @@
 # Template file for 'python3-PyQt-builder'
 pkgname=python3-PyQt-builder
-version=1.6.0
+version=1.7.0
 revision=1
 wrksrc=PyQt-builder-$version
 build_style=python3-module
-hostmakedepends="python3-setuptools"
-depends="python3 sip5>=5.5.0"
+hostmakedepends="python3-setuptools sip"
+depends="python3 sip>=6.0.0"
 short_desc="PEP 517 compliant PyQt build system"
 maintainer="Đoàn Trần Công Danh <congdanhqx@gmail.com>"
 license="GPL-2.0-only, GPL-3.0-only, custom:SIP"
 homepage="https://www.riverbankcomputing.com/software/pyqt/"
 distfiles="$PYPI_SITE/P/PyQt-builder/PyQt-builder-$version.tar.gz"
-checksum=fb80f01407718bfc68f78e276f2543fcfc5b5900b1187c1fd1f2ff51a6f2a13c
+checksum=b6e3c826f98ff4006ecb34df491ac6062a023b63a32e9f9f50904867aff72f2e
 
 post_install() {
 	rm -rf $DESTDIR/$py3_sitelib/pyqtbuild/bundle

From 781d6f102f8db6aaf699c61c09e51590bf1fbc68 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 07:54:12 +0700
Subject: [PATCH 6/8] python3-PyQt5-webengine: sip5 has been renamed to sip

---
 srcpkgs/python3-PyQt5-webengine/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/python3-PyQt5-webengine/template b/srcpkgs/python3-PyQt5-webengine/template
index 920cae92627..ae385283b7f 100644
--- a/srcpkgs/python3-PyQt5-webengine/template
+++ b/srcpkgs/python3-PyQt5-webengine/template
@@ -3,7 +3,7 @@ pkgname=python3-PyQt5-webengine
 version=5.15.2
 revision=1
 wrksrc="PyQtWebEngine-${version}"
-hostmakedepends="pkg-config qt5-qmake python3-PyQt5 sip5 qt5-webengine-devel
+hostmakedepends="pkg-config qt5-qmake python3-PyQt5 sip qt5-webengine-devel
  python3-PyQt-builder python3-PyQt5-devel
  qt5-declarative-devel qt5-webchannel-devel qt5-location-devel"
 makedepends="qt5-declarative-devel qt5-webchannel-devel qt5-location-devel

From 516e226bf8b8b15a3b19b68f0a3814cf5d452a9a Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 07:55:20 +0700
Subject: [PATCH 7/8] python3-PyQt5: depends on new sip

---
 srcpkgs/python3-PyQt5/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-PyQt5/template b/srcpkgs/python3-PyQt5/template
index bac89e57965..2a2733b439c 100644
--- a/srcpkgs/python3-PyQt5/template
+++ b/srcpkgs/python3-PyQt5/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-PyQt5'
 pkgname=python3-PyQt5
 version=5.15.2
-revision=1
+revision=2
 _sipver=12.8.0
 wrksrc="PyQt5-${version}"
 build_helper=qemu
@@ -193,7 +193,7 @@ python3-PyQt5-devel-tools_package() {
 	}
 }
 python3-PyQt5-devel_package() {
-	depends="sip5 python3-PyQt5-${version}_${revision}"
+	depends="sip>=6.0.0 python3-PyQt5-${version}_${revision}"
 	short_desc+=" - development files"
 	pkg_install() {
 		vmove ${py3_sitelib}/PyQt5/bindings

From e8e48b93b2c9cd0302b4899ebcf52f4fa61092bb Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 07:56:13 +0700
Subject: [PATCH 8/8] python3-sip-PyQt5: build with new sip

---
 srcpkgs/python3-sip-PyQt5/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-sip-PyQt5/template b/srcpkgs/python3-sip-PyQt5/template
index e1d1c45603d..488783efcaa 100644
--- a/srcpkgs/python3-sip-PyQt5/template
+++ b/srcpkgs/python3-sip-PyQt5/template
@@ -4,7 +4,7 @@ version=12.8.1
 revision=1
 wrksrc="PyQt5_sip-$version"
 build_style=python3-module
-hostmakedepends="python3-devel python3-setuptools sip5"
+hostmakedepends="python3-devel python3-setuptools sip"
 makedepends="python3-devel"
 short_desc="Python 3 PyQt5 SIP bindings with C and C++"
 maintainer="Orphaned <orphan@voidlinux.org>"
@@ -15,5 +15,5 @@ checksum=30e944db9abee9cc757aea16906d4198129558533eb7fadbe48c5da2bd18e0bd
 lib32disabled=yes
 
 post_install() {
-	vlicense /usr/share/licenses/sip5/LICENSE
+	vlicense /usr/share/licenses/sip/LICENSE
 }

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [PR PATCH] [Updated] RFC: rename sip 4.x to sip4, sip5 to sip, update to 6.0.0
  2021-01-08  1:14 [PR PATCH] RFC: rename sip 4.x to sip4, sip5 to sip, update to 6.0.0 sgn
  2021-01-08  1:20 ` [PR PATCH] [Updated] " sgn
@ 2021-01-08  1:26 ` sgn
  2021-01-08  2:11 ` sgn
                   ` (8 subsequent siblings)
  10 siblings, 0 replies; 12+ messages in thread
From: sgn @ 2021-01-08  1:26 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 530 bytes --]

There is an updated pull request by sgn against master on the void-packages repository

https://github.com/sgn/void-packages sip-rename
https://github.com/void-linux/void-packages/pull/27753

RFC: rename sip 4.x to sip4, sip5 to sip, update to 6.0.0
- Most of our packages have the convention of using versioned-suffix for old packages
- Have `sip5` package with version 6 is weird to me
- I'm expecting sip 4.x will be phased out soon.

A patch file from https://github.com/void-linux/void-packages/pull/27753.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-sip-rename-27753.patch --]
[-- Type: text/x-diff, Size: 11883 bytes --]

From 7d43aaf8a8aa859885091f6d8f5bfabe8c298cc9 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 08:02:10 +0700
Subject: [PATCH 1/8] gns3-gui: not depends on python3-sip

Indirectly depends via PyQt5.
---
 srcpkgs/gns3-gui/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/gns3-gui/template b/srcpkgs/gns3-gui/template
index f7f51364548..1d7d84c4c65 100644
--- a/srcpkgs/gns3-gui/template
+++ b/srcpkgs/gns3-gui/template
@@ -1,11 +1,11 @@
 # Template file for 'gns3-gui'
 pkgname=gns3-gui
 version=2.2.17
-revision=1
+revision=2
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-setuptools python3-psutil python3-jsonschema python3-sentry
- python3-PyQt5-svg python3-PyQt5-websockets python3-sip xterm inetutils-telnet
+ python3-PyQt5-svg python3-PyQt5-websockets xterm inetutils-telnet
  gns3-net-converter python3-distro"
 checkdepends="${depends}"
 short_desc="Graphical Network Simulator 3 - GUI"

From dfc0715c0921903c0416d5a422001348be7b742e Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 08:05:44 +0700
Subject: [PATCH 2/8] sip: rename to sip4

---
 srcpkgs/python3-orocos-kdl/template | 2 +-
 srcpkgs/python3-sip                 | 2 +-
 srcpkgs/python3-sip-devel           | 2 +-
 srcpkgs/{sip => sip4}/template      | 9 ++++++---
 srcpkgs/{sip => sip4}/update        | 0
 5 files changed, 9 insertions(+), 6 deletions(-)
 rename srcpkgs/{sip => sip4}/template (88%)
 rename srcpkgs/{sip => sip4}/update (100%)

diff --git a/srcpkgs/python3-orocos-kdl/template b/srcpkgs/python3-orocos-kdl/template
index 728ed73d780..281ea8978c5 100644
--- a/srcpkgs/python3-orocos-kdl/template
+++ b/srcpkgs/python3-orocos-kdl/template
@@ -6,7 +6,7 @@ wrksrc=orocos_kinematics_dynamics-${version}
 build_wrksrc=python_orocos_kdl
 build_style=cmake
 configure_args="-DPYTHON_VERSION=3 -DSIP_EXECUTABLE=/usr/bin/sip"
-hostmakedepends="python3 python3-sip sip"
+hostmakedepends="python3 python3-sip sip4"
 makedepends="python3-sip-devel python3-devel orocos-kdl-devel eigen3.2"
 depends="python3 python3-sip"
 short_desc="Python3 Bindings for Orocos Kinematics and Dynamics C++ library"
diff --git a/srcpkgs/python3-sip b/srcpkgs/python3-sip
index 633f7c0bcce..27dcc148ae7 120000
--- a/srcpkgs/python3-sip
+++ b/srcpkgs/python3-sip
@@ -1 +1 @@
-sip
\ No newline at end of file
+sip4
\ No newline at end of file
diff --git a/srcpkgs/python3-sip-devel b/srcpkgs/python3-sip-devel
index 633f7c0bcce..27dcc148ae7 120000
--- a/srcpkgs/python3-sip-devel
+++ b/srcpkgs/python3-sip-devel
@@ -1 +1 @@
-sip
\ No newline at end of file
+sip4
\ No newline at end of file
diff --git a/srcpkgs/sip/template b/srcpkgs/sip4/template
similarity index 88%
rename from srcpkgs/sip/template
rename to srcpkgs/sip4/template
index 87d0c5c6ed6..8afbf8e5d0a 100644
--- a/srcpkgs/sip/template
+++ b/srcpkgs/sip4/template
@@ -1,7 +1,8 @@
-# Template file for 'sip'
-pkgname=sip
+# Template file for 'sip4'
+pkgname=sip4
 version=4.19.24
 revision=3
+wrksrc="sip-$version"
 hostmakedepends="python3-devel"
 makedepends="${hostmakedepends}"
 short_desc="Python extension module generator for C/C++ libraries"
@@ -10,12 +11,14 @@ license="GPL-2.0-only, GPL-3.0-only, custom:SIP"
 homepage="https://riverbankcomputing.com/software/sip/intro"
 distfiles="https://www.riverbankcomputing.com/static/Downloads/sip/${version}/sip-${version}.tar.gz"
 checksum=edcd3790bb01938191eef0f6117de0bf56d1136626c0ddb678f3a558d62e41e5
+replaces="sip<=${version}_${revision}"
+provides="sip-${version}_${revision}"
 
 do_build() {
 	python3 configure.py \
 		CC="${CC}" CFLAGS="${CFLAGS}" CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" \
 		LINK="${CXX}" LINK_SHLIB="${CXX}" LFLAGS="${LDFLAGS}" STRIP="" \
-		INCDIR="${XBPS_CROSS_BASE}/${py3_inc}" ${pyqt5}
+		INCDIR="${XBPS_CROSS_BASE}/${py3_inc}"
 	make ${makejobs}
 }
 
diff --git a/srcpkgs/sip/update b/srcpkgs/sip4/update
similarity index 100%
rename from srcpkgs/sip/update
rename to srcpkgs/sip4/update

From 9845eb9dcaedd85d17ee29f585ff90f53a195987 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 08:07:11 +0700
Subject: [PATCH 3/8] sip5: rename to sip

---
 srcpkgs/{sip5 => sip}/template | 9 +++++----
 srcpkgs/{sip5 => sip}/update   | 0
 2 files changed, 5 insertions(+), 4 deletions(-)
 rename srcpkgs/{sip5 => sip}/template (77%)
 rename srcpkgs/{sip5 => sip}/update (100%)

diff --git a/srcpkgs/sip5/template b/srcpkgs/sip/template
similarity index 77%
rename from srcpkgs/sip5/template
rename to srcpkgs/sip/template
index b8e3d0bf10d..4b2090ad89f 100644
--- a/srcpkgs/sip5/template
+++ b/srcpkgs/sip/template
@@ -1,19 +1,20 @@
-# Template file for 'sip5'
-pkgname=sip5
+# Template file for 'sip'
+pkgname=sip
 version=5.5.0
 revision=1
-wrksrc="sip-$version"
 build_style=python3-module
 hostmakedepends="python3-devel python3-setuptools python3-packaging python3-toml"
 makedepends="python3-devel"
 depends="python3-setuptools python3-packaging python3-toml"
-short_desc="SIP 5 - Python 3 bindings generator for C/C++ libraries"
+short_desc="SIP - Python 3 bindings generator for C/C++ libraries"
 maintainer="Đoàn Trần Công Danh <congdanhqx@gmail.com>"
 license="GPL-2.0-only, GPL-3.0-only, custom:SIP"
 homepage="https://riverbankcomputing.com/software/sip/intro"
 distfiles="${PYPI_SITE}/s/sip/sip-${version}.tar.gz"
 checksum=5d024c419b30fea8a6de8c71a560c7ab0bc3c221fbfb14d55a5b865bd58eaac5
 lib32disabled=yes
+replaces="sip5<=${version}_${revision}"
+provides="sip5-${version}_${revision}"
 
 post_install() {
 	sed -n '1,/SUCH DAMAGE/p' sipbuild/project.py >NOTICE
diff --git a/srcpkgs/sip5/update b/srcpkgs/sip/update
similarity index 100%
rename from srcpkgs/sip5/update
rename to srcpkgs/sip/update

From 97b2aaffefe51caa7f9663498b6f8e14a39c5de8 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 08:08:58 +0700
Subject: [PATCH 4/8] sip: update to 6.0.0.

---
 srcpkgs/sip/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/sip/template b/srcpkgs/sip/template
index 4b2090ad89f..3cca9aa59d5 100644
--- a/srcpkgs/sip/template
+++ b/srcpkgs/sip/template
@@ -1,6 +1,6 @@
 # Template file for 'sip'
 pkgname=sip
-version=5.5.0
+version=6.0.0
 revision=1
 build_style=python3-module
 hostmakedepends="python3-devel python3-setuptools python3-packaging python3-toml"
@@ -11,7 +11,7 @@ maintainer="Đoàn Trần Công Danh <congdanhqx@gmail.com>"
 license="GPL-2.0-only, GPL-3.0-only, custom:SIP"
 homepage="https://riverbankcomputing.com/software/sip/intro"
 distfiles="${PYPI_SITE}/s/sip/sip-${version}.tar.gz"
-checksum=5d024c419b30fea8a6de8c71a560c7ab0bc3c221fbfb14d55a5b865bd58eaac5
+checksum=6185160e1aa8e167b5919c4761cbbf68cc7478d34fb655b3a28b3eb9acb5943a
 lib32disabled=yes
 replaces="sip5<=${version}_${revision}"
 provides="sip5-${version}_${revision}"

From 95b9a8ca4735a018dddae141d07e7e2c383d4136 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 07:52:02 +0700
Subject: [PATCH 5/8] python3-PyQt-builder: update to 1.7.0.

---
 srcpkgs/python3-PyQt-builder/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-PyQt-builder/template b/srcpkgs/python3-PyQt-builder/template
index 1d6c8fa73d4..956a6ab1cde 100644
--- a/srcpkgs/python3-PyQt-builder/template
+++ b/srcpkgs/python3-PyQt-builder/template
@@ -1,17 +1,17 @@
 # Template file for 'python3-PyQt-builder'
 pkgname=python3-PyQt-builder
-version=1.6.0
+version=1.7.0
 revision=1
 wrksrc=PyQt-builder-$version
 build_style=python3-module
-hostmakedepends="python3-setuptools"
-depends="python3 sip5>=5.5.0"
+hostmakedepends="python3-setuptools sip"
+depends="python3 sip>=6.0.0"
 short_desc="PEP 517 compliant PyQt build system"
 maintainer="Đoàn Trần Công Danh <congdanhqx@gmail.com>"
 license="GPL-2.0-only, GPL-3.0-only, custom:SIP"
 homepage="https://www.riverbankcomputing.com/software/pyqt/"
 distfiles="$PYPI_SITE/P/PyQt-builder/PyQt-builder-$version.tar.gz"
-checksum=fb80f01407718bfc68f78e276f2543fcfc5b5900b1187c1fd1f2ff51a6f2a13c
+checksum=b6e3c826f98ff4006ecb34df491ac6062a023b63a32e9f9f50904867aff72f2e
 
 post_install() {
 	rm -rf $DESTDIR/$py3_sitelib/pyqtbuild/bundle

From 781d6f102f8db6aaf699c61c09e51590bf1fbc68 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 07:54:12 +0700
Subject: [PATCH 6/8] python3-PyQt5-webengine: sip5 has been renamed to sip

---
 srcpkgs/python3-PyQt5-webengine/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/python3-PyQt5-webengine/template b/srcpkgs/python3-PyQt5-webengine/template
index 920cae92627..ae385283b7f 100644
--- a/srcpkgs/python3-PyQt5-webengine/template
+++ b/srcpkgs/python3-PyQt5-webengine/template
@@ -3,7 +3,7 @@ pkgname=python3-PyQt5-webengine
 version=5.15.2
 revision=1
 wrksrc="PyQtWebEngine-${version}"
-hostmakedepends="pkg-config qt5-qmake python3-PyQt5 sip5 qt5-webengine-devel
+hostmakedepends="pkg-config qt5-qmake python3-PyQt5 sip qt5-webengine-devel
  python3-PyQt-builder python3-PyQt5-devel
  qt5-declarative-devel qt5-webchannel-devel qt5-location-devel"
 makedepends="qt5-declarative-devel qt5-webchannel-devel qt5-location-devel

From 516e226bf8b8b15a3b19b68f0a3814cf5d452a9a Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 07:55:20 +0700
Subject: [PATCH 7/8] python3-PyQt5: depends on new sip

---
 srcpkgs/python3-PyQt5/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-PyQt5/template b/srcpkgs/python3-PyQt5/template
index bac89e57965..2a2733b439c 100644
--- a/srcpkgs/python3-PyQt5/template
+++ b/srcpkgs/python3-PyQt5/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-PyQt5'
 pkgname=python3-PyQt5
 version=5.15.2
-revision=1
+revision=2
 _sipver=12.8.0
 wrksrc="PyQt5-${version}"
 build_helper=qemu
@@ -193,7 +193,7 @@ python3-PyQt5-devel-tools_package() {
 	}
 }
 python3-PyQt5-devel_package() {
-	depends="sip5 python3-PyQt5-${version}_${revision}"
+	depends="sip>=6.0.0 python3-PyQt5-${version}_${revision}"
 	short_desc+=" - development files"
 	pkg_install() {
 		vmove ${py3_sitelib}/PyQt5/bindings

From 8217af3d4448c442b430f5b428dc0351e40c8b3a Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 07:56:13 +0700
Subject: [PATCH 8/8] python3-sip-PyQt5: build with new sip

---
 srcpkgs/python3-sip-PyQt5/template | 8 ++++++--
 1 file changed, 6 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-sip-PyQt5/template b/srcpkgs/python3-sip-PyQt5/template
index e1d1c45603d..8631cad90fb 100644
--- a/srcpkgs/python3-sip-PyQt5/template
+++ b/srcpkgs/python3-sip-PyQt5/template
@@ -4,7 +4,7 @@ version=12.8.1
 revision=1
 wrksrc="PyQt5_sip-$version"
 build_style=python3-module
-hostmakedepends="python3-devel python3-setuptools sip5"
+hostmakedepends="python3-devel python3-setuptools sip"
 makedepends="python3-devel"
 short_desc="Python 3 PyQt5 SIP bindings with C and C++"
 maintainer="Orphaned <orphan@voidlinux.org>"
@@ -14,6 +14,10 @@ distfiles="${PYPI_SITE}/P/PyQt5_sip/PyQt5_sip-${version}.tar.gz"
 checksum=30e944db9abee9cc757aea16906d4198129558533eb7fadbe48c5da2bd18e0bd
 lib32disabled=yes
 
+post_extract() {
+	mkdir -p PyQt5
+}
+
 post_install() {
-	vlicense /usr/share/licenses/sip5/LICENSE
+	vlicense /usr/share/licenses/sip/LICENSE
 }

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [PR PATCH] [Updated] RFC: rename sip 4.x to sip4, sip5 to sip, update to 6.0.0
  2021-01-08  1:14 [PR PATCH] RFC: rename sip 4.x to sip4, sip5 to sip, update to 6.0.0 sgn
  2021-01-08  1:20 ` [PR PATCH] [Updated] " sgn
  2021-01-08  1:26 ` sgn
@ 2021-01-08  2:11 ` sgn
  2021-01-08  2:13 ` sgn
                   ` (7 subsequent siblings)
  10 siblings, 0 replies; 12+ messages in thread
From: sgn @ 2021-01-08  2:11 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 530 bytes --]

There is an updated pull request by sgn against master on the void-packages repository

https://github.com/sgn/void-packages sip-rename
https://github.com/void-linux/void-packages/pull/27753

RFC: rename sip 4.x to sip4, sip5 to sip, update to 6.0.0
- Most of our packages have the convention of using versioned-suffix for old packages
- Have `sip5` package with version 6 is weird to me
- I'm expecting sip 4.x will be phased out soon.

A patch file from https://github.com/void-linux/void-packages/pull/27753.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-sip-rename-27753.patch --]
[-- Type: text/x-diff, Size: 11903 bytes --]

From 7d43aaf8a8aa859885091f6d8f5bfabe8c298cc9 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 08:02:10 +0700
Subject: [PATCH 1/8] gns3-gui: not depends on python3-sip

Indirectly depends via PyQt5.
---
 srcpkgs/gns3-gui/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/gns3-gui/template b/srcpkgs/gns3-gui/template
index f7f51364548..1d7d84c4c65 100644
--- a/srcpkgs/gns3-gui/template
+++ b/srcpkgs/gns3-gui/template
@@ -1,11 +1,11 @@
 # Template file for 'gns3-gui'
 pkgname=gns3-gui
 version=2.2.17
-revision=1
+revision=2
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-setuptools python3-psutil python3-jsonschema python3-sentry
- python3-PyQt5-svg python3-PyQt5-websockets python3-sip xterm inetutils-telnet
+ python3-PyQt5-svg python3-PyQt5-websockets xterm inetutils-telnet
  gns3-net-converter python3-distro"
 checkdepends="${depends}"
 short_desc="Graphical Network Simulator 3 - GUI"

From 7c98c50d7e08a0e8a80ddd2777499ed47666689d Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 08:05:44 +0700
Subject: [PATCH 2/8] sip: rename to sip4

---
 srcpkgs/python3-orocos-kdl/template |  2 +-
 srcpkgs/python3-sip                 |  2 +-
 srcpkgs/python3-sip-devel           |  2 +-
 srcpkgs/{sip => sip4}/template      | 11 +++++++----
 srcpkgs/{sip => sip4}/update        |  0
 5 files changed, 10 insertions(+), 7 deletions(-)
 rename srcpkgs/{sip => sip4}/template (87%)
 rename srcpkgs/{sip => sip4}/update (100%)

diff --git a/srcpkgs/python3-orocos-kdl/template b/srcpkgs/python3-orocos-kdl/template
index 728ed73d780..281ea8978c5 100644
--- a/srcpkgs/python3-orocos-kdl/template
+++ b/srcpkgs/python3-orocos-kdl/template
@@ -6,7 +6,7 @@ wrksrc=orocos_kinematics_dynamics-${version}
 build_wrksrc=python_orocos_kdl
 build_style=cmake
 configure_args="-DPYTHON_VERSION=3 -DSIP_EXECUTABLE=/usr/bin/sip"
-hostmakedepends="python3 python3-sip sip"
+hostmakedepends="python3 python3-sip sip4"
 makedepends="python3-sip-devel python3-devel orocos-kdl-devel eigen3.2"
 depends="python3 python3-sip"
 short_desc="Python3 Bindings for Orocos Kinematics and Dynamics C++ library"
diff --git a/srcpkgs/python3-sip b/srcpkgs/python3-sip
index 633f7c0bcce..27dcc148ae7 120000
--- a/srcpkgs/python3-sip
+++ b/srcpkgs/python3-sip
@@ -1 +1 @@
-sip
\ No newline at end of file
+sip4
\ No newline at end of file
diff --git a/srcpkgs/python3-sip-devel b/srcpkgs/python3-sip-devel
index 633f7c0bcce..27dcc148ae7 120000
--- a/srcpkgs/python3-sip-devel
+++ b/srcpkgs/python3-sip-devel
@@ -1 +1 @@
-sip
\ No newline at end of file
+sip4
\ No newline at end of file
diff --git a/srcpkgs/sip/template b/srcpkgs/sip4/template
similarity index 87%
rename from srcpkgs/sip/template
rename to srcpkgs/sip4/template
index 87d0c5c6ed6..d00cfda21bb 100644
--- a/srcpkgs/sip/template
+++ b/srcpkgs/sip4/template
@@ -1,7 +1,8 @@
-# Template file for 'sip'
-pkgname=sip
+# Template file for 'sip4'
+pkgname=sip4
 version=4.19.24
-revision=3
+revision=4
+wrksrc="sip-$version"
 hostmakedepends="python3-devel"
 makedepends="${hostmakedepends}"
 short_desc="Python extension module generator for C/C++ libraries"
@@ -10,12 +11,14 @@ license="GPL-2.0-only, GPL-3.0-only, custom:SIP"
 homepage="https://riverbankcomputing.com/software/sip/intro"
 distfiles="https://www.riverbankcomputing.com/static/Downloads/sip/${version}/sip-${version}.tar.gz"
 checksum=edcd3790bb01938191eef0f6117de0bf56d1136626c0ddb678f3a558d62e41e5
+replaces="sip<=${version}_${revision}"
+provides="sip-${version}_${revision}"
 
 do_build() {
 	python3 configure.py \
 		CC="${CC}" CFLAGS="${CFLAGS}" CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" \
 		LINK="${CXX}" LINK_SHLIB="${CXX}" LFLAGS="${LDFLAGS}" STRIP="" \
-		INCDIR="${XBPS_CROSS_BASE}/${py3_inc}" ${pyqt5}
+		INCDIR="${XBPS_CROSS_BASE}/${py3_inc}"
 	make ${makejobs}
 }
 
diff --git a/srcpkgs/sip/update b/srcpkgs/sip4/update
similarity index 100%
rename from srcpkgs/sip/update
rename to srcpkgs/sip4/update

From ceee7b2829581e598ad06be10b78dca3020e0b11 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 08:07:11 +0700
Subject: [PATCH 3/8] sip5: rename to sip

---
 srcpkgs/{sip5 => sip}/template | 9 +++++----
 srcpkgs/{sip5 => sip}/update   | 0
 2 files changed, 5 insertions(+), 4 deletions(-)
 rename srcpkgs/{sip5 => sip}/template (77%)
 rename srcpkgs/{sip5 => sip}/update (100%)

diff --git a/srcpkgs/sip5/template b/srcpkgs/sip/template
similarity index 77%
rename from srcpkgs/sip5/template
rename to srcpkgs/sip/template
index b8e3d0bf10d..4b2090ad89f 100644
--- a/srcpkgs/sip5/template
+++ b/srcpkgs/sip/template
@@ -1,19 +1,20 @@
-# Template file for 'sip5'
-pkgname=sip5
+# Template file for 'sip'
+pkgname=sip
 version=5.5.0
 revision=1
-wrksrc="sip-$version"
 build_style=python3-module
 hostmakedepends="python3-devel python3-setuptools python3-packaging python3-toml"
 makedepends="python3-devel"
 depends="python3-setuptools python3-packaging python3-toml"
-short_desc="SIP 5 - Python 3 bindings generator for C/C++ libraries"
+short_desc="SIP - Python 3 bindings generator for C/C++ libraries"
 maintainer="Đoàn Trần Công Danh <congdanhqx@gmail.com>"
 license="GPL-2.0-only, GPL-3.0-only, custom:SIP"
 homepage="https://riverbankcomputing.com/software/sip/intro"
 distfiles="${PYPI_SITE}/s/sip/sip-${version}.tar.gz"
 checksum=5d024c419b30fea8a6de8c71a560c7ab0bc3c221fbfb14d55a5b865bd58eaac5
 lib32disabled=yes
+replaces="sip5<=${version}_${revision}"
+provides="sip5-${version}_${revision}"
 
 post_install() {
 	sed -n '1,/SUCH DAMAGE/p' sipbuild/project.py >NOTICE
diff --git a/srcpkgs/sip5/update b/srcpkgs/sip/update
similarity index 100%
rename from srcpkgs/sip5/update
rename to srcpkgs/sip/update

From 565c0576bc607232e6934872d09d7ff739c42677 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 08:08:58 +0700
Subject: [PATCH 4/8] sip: update to 6.0.0.

---
 srcpkgs/sip/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/sip/template b/srcpkgs/sip/template
index 4b2090ad89f..3cca9aa59d5 100644
--- a/srcpkgs/sip/template
+++ b/srcpkgs/sip/template
@@ -1,6 +1,6 @@
 # Template file for 'sip'
 pkgname=sip
-version=5.5.0
+version=6.0.0
 revision=1
 build_style=python3-module
 hostmakedepends="python3-devel python3-setuptools python3-packaging python3-toml"
@@ -11,7 +11,7 @@ maintainer="Đoàn Trần Công Danh <congdanhqx@gmail.com>"
 license="GPL-2.0-only, GPL-3.0-only, custom:SIP"
 homepage="https://riverbankcomputing.com/software/sip/intro"
 distfiles="${PYPI_SITE}/s/sip/sip-${version}.tar.gz"
-checksum=5d024c419b30fea8a6de8c71a560c7ab0bc3c221fbfb14d55a5b865bd58eaac5
+checksum=6185160e1aa8e167b5919c4761cbbf68cc7478d34fb655b3a28b3eb9acb5943a
 lib32disabled=yes
 replaces="sip5<=${version}_${revision}"
 provides="sip5-${version}_${revision}"

From 0a560927a77100f15e03ffffc745552f01e6762d Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 07:52:02 +0700
Subject: [PATCH 5/8] python3-PyQt-builder: update to 1.7.0.

---
 srcpkgs/python3-PyQt-builder/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-PyQt-builder/template b/srcpkgs/python3-PyQt-builder/template
index 1d6c8fa73d4..956a6ab1cde 100644
--- a/srcpkgs/python3-PyQt-builder/template
+++ b/srcpkgs/python3-PyQt-builder/template
@@ -1,17 +1,17 @@
 # Template file for 'python3-PyQt-builder'
 pkgname=python3-PyQt-builder
-version=1.6.0
+version=1.7.0
 revision=1
 wrksrc=PyQt-builder-$version
 build_style=python3-module
-hostmakedepends="python3-setuptools"
-depends="python3 sip5>=5.5.0"
+hostmakedepends="python3-setuptools sip"
+depends="python3 sip>=6.0.0"
 short_desc="PEP 517 compliant PyQt build system"
 maintainer="Đoàn Trần Công Danh <congdanhqx@gmail.com>"
 license="GPL-2.0-only, GPL-3.0-only, custom:SIP"
 homepage="https://www.riverbankcomputing.com/software/pyqt/"
 distfiles="$PYPI_SITE/P/PyQt-builder/PyQt-builder-$version.tar.gz"
-checksum=fb80f01407718bfc68f78e276f2543fcfc5b5900b1187c1fd1f2ff51a6f2a13c
+checksum=b6e3c826f98ff4006ecb34df491ac6062a023b63a32e9f9f50904867aff72f2e
 
 post_install() {
 	rm -rf $DESTDIR/$py3_sitelib/pyqtbuild/bundle

From bb081ffa3299c57b5f6f5d6e19d90535d42e5528 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 07:54:12 +0700
Subject: [PATCH 6/8] python3-PyQt5-webengine: sip5 has been renamed to sip

---
 srcpkgs/python3-PyQt5-webengine/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/python3-PyQt5-webengine/template b/srcpkgs/python3-PyQt5-webengine/template
index 920cae92627..ae385283b7f 100644
--- a/srcpkgs/python3-PyQt5-webengine/template
+++ b/srcpkgs/python3-PyQt5-webengine/template
@@ -3,7 +3,7 @@ pkgname=python3-PyQt5-webengine
 version=5.15.2
 revision=1
 wrksrc="PyQtWebEngine-${version}"
-hostmakedepends="pkg-config qt5-qmake python3-PyQt5 sip5 qt5-webengine-devel
+hostmakedepends="pkg-config qt5-qmake python3-PyQt5 sip qt5-webengine-devel
  python3-PyQt-builder python3-PyQt5-devel
  qt5-declarative-devel qt5-webchannel-devel qt5-location-devel"
 makedepends="qt5-declarative-devel qt5-webchannel-devel qt5-location-devel

From 67a53bb9eac6c19ffe45bd553494fd4770c86588 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 07:55:20 +0700
Subject: [PATCH 7/8] python3-PyQt5: depends on new sip

---
 srcpkgs/python3-PyQt5/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-PyQt5/template b/srcpkgs/python3-PyQt5/template
index bac89e57965..2a2733b439c 100644
--- a/srcpkgs/python3-PyQt5/template
+++ b/srcpkgs/python3-PyQt5/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-PyQt5'
 pkgname=python3-PyQt5
 version=5.15.2
-revision=1
+revision=2
 _sipver=12.8.0
 wrksrc="PyQt5-${version}"
 build_helper=qemu
@@ -193,7 +193,7 @@ python3-PyQt5-devel-tools_package() {
 	}
 }
 python3-PyQt5-devel_package() {
-	depends="sip5 python3-PyQt5-${version}_${revision}"
+	depends="sip>=6.0.0 python3-PyQt5-${version}_${revision}"
 	short_desc+=" - development files"
 	pkg_install() {
 		vmove ${py3_sitelib}/PyQt5/bindings

From 9c9b650f56a781111d72a8557e17060bcb440e35 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 07:56:13 +0700
Subject: [PATCH 8/8] python3-sip-PyQt5: build with new sip

---
 srcpkgs/python3-sip-PyQt5/template | 8 ++++++--
 1 file changed, 6 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-sip-PyQt5/template b/srcpkgs/python3-sip-PyQt5/template
index e1d1c45603d..8631cad90fb 100644
--- a/srcpkgs/python3-sip-PyQt5/template
+++ b/srcpkgs/python3-sip-PyQt5/template
@@ -4,7 +4,7 @@ version=12.8.1
 revision=1
 wrksrc="PyQt5_sip-$version"
 build_style=python3-module
-hostmakedepends="python3-devel python3-setuptools sip5"
+hostmakedepends="python3-devel python3-setuptools sip"
 makedepends="python3-devel"
 short_desc="Python 3 PyQt5 SIP bindings with C and C++"
 maintainer="Orphaned <orphan@voidlinux.org>"
@@ -14,6 +14,10 @@ distfiles="${PYPI_SITE}/P/PyQt5_sip/PyQt5_sip-${version}.tar.gz"
 checksum=30e944db9abee9cc757aea16906d4198129558533eb7fadbe48c5da2bd18e0bd
 lib32disabled=yes
 
+post_extract() {
+	mkdir -p PyQt5
+}
+
 post_install() {
-	vlicense /usr/share/licenses/sip5/LICENSE
+	vlicense /usr/share/licenses/sip/LICENSE
 }

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [PR PATCH] [Updated] RFC: rename sip 4.x to sip4, sip5 to sip, update to 6.0.0
  2021-01-08  1:14 [PR PATCH] RFC: rename sip 4.x to sip4, sip5 to sip, update to 6.0.0 sgn
                   ` (2 preceding siblings ...)
  2021-01-08  2:11 ` sgn
@ 2021-01-08  2:13 ` sgn
  2021-01-08  5:13 ` ericonr
                   ` (6 subsequent siblings)
  10 siblings, 0 replies; 12+ messages in thread
From: sgn @ 2021-01-08  2:13 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 530 bytes --]

There is an updated pull request by sgn against master on the void-packages repository

https://github.com/sgn/void-packages sip-rename
https://github.com/void-linux/void-packages/pull/27753

RFC: rename sip 4.x to sip4, sip5 to sip, update to 6.0.0
- Most of our packages have the convention of using versioned-suffix for old packages
- Have `sip5` package with version 6 is weird to me
- I'm expecting sip 4.x will be phased out soon.

A patch file from https://github.com/void-linux/void-packages/pull/27753.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-sip-rename-27753.patch --]
[-- Type: text/x-diff, Size: 12226 bytes --]

From 7d43aaf8a8aa859885091f6d8f5bfabe8c298cc9 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 08:02:10 +0700
Subject: [PATCH 1/8] gns3-gui: not depends on python3-sip

Indirectly depends via PyQt5.
---
 srcpkgs/gns3-gui/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/gns3-gui/template b/srcpkgs/gns3-gui/template
index f7f51364548..1d7d84c4c65 100644
--- a/srcpkgs/gns3-gui/template
+++ b/srcpkgs/gns3-gui/template
@@ -1,11 +1,11 @@
 # Template file for 'gns3-gui'
 pkgname=gns3-gui
 version=2.2.17
-revision=1
+revision=2
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-setuptools python3-psutil python3-jsonschema python3-sentry
- python3-PyQt5-svg python3-PyQt5-websockets python3-sip xterm inetutils-telnet
+ python3-PyQt5-svg python3-PyQt5-websockets xterm inetutils-telnet
  gns3-net-converter python3-distro"
 checkdepends="${depends}"
 short_desc="Graphical Network Simulator 3 - GUI"

From 659217d8d32292ea53ebd0f695fae9b683c524de Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 08:05:44 +0700
Subject: [PATCH 2/8] sip: rename to sip4

---
 srcpkgs/python3-orocos-kdl/template |  2 +-
 srcpkgs/python3-sip                 |  2 +-
 srcpkgs/python3-sip-devel           |  2 +-
 srcpkgs/{sip => sip4}/template      | 13 ++++++++-----
 srcpkgs/{sip => sip4}/update        |  0
 5 files changed, 11 insertions(+), 8 deletions(-)
 rename srcpkgs/{sip => sip4}/template (82%)
 rename srcpkgs/{sip => sip4}/update (100%)

diff --git a/srcpkgs/python3-orocos-kdl/template b/srcpkgs/python3-orocos-kdl/template
index 728ed73d780..281ea8978c5 100644
--- a/srcpkgs/python3-orocos-kdl/template
+++ b/srcpkgs/python3-orocos-kdl/template
@@ -6,7 +6,7 @@ wrksrc=orocos_kinematics_dynamics-${version}
 build_wrksrc=python_orocos_kdl
 build_style=cmake
 configure_args="-DPYTHON_VERSION=3 -DSIP_EXECUTABLE=/usr/bin/sip"
-hostmakedepends="python3 python3-sip sip"
+hostmakedepends="python3 python3-sip sip4"
 makedepends="python3-sip-devel python3-devel orocos-kdl-devel eigen3.2"
 depends="python3 python3-sip"
 short_desc="Python3 Bindings for Orocos Kinematics and Dynamics C++ library"
diff --git a/srcpkgs/python3-sip b/srcpkgs/python3-sip
index 633f7c0bcce..27dcc148ae7 120000
--- a/srcpkgs/python3-sip
+++ b/srcpkgs/python3-sip
@@ -1 +1 @@
-sip
\ No newline at end of file
+sip4
\ No newline at end of file
diff --git a/srcpkgs/python3-sip-devel b/srcpkgs/python3-sip-devel
index 633f7c0bcce..27dcc148ae7 120000
--- a/srcpkgs/python3-sip-devel
+++ b/srcpkgs/python3-sip-devel
@@ -1 +1 @@
-sip
\ No newline at end of file
+sip4
\ No newline at end of file
diff --git a/srcpkgs/sip/template b/srcpkgs/sip4/template
similarity index 82%
rename from srcpkgs/sip/template
rename to srcpkgs/sip4/template
index 87d0c5c6ed6..30de98f8320 100644
--- a/srcpkgs/sip/template
+++ b/srcpkgs/sip4/template
@@ -1,7 +1,8 @@
-# Template file for 'sip'
-pkgname=sip
+# Template file for 'sip4'
+pkgname=sip4
 version=4.19.24
-revision=3
+revision=4
+wrksrc="sip-$version"
 hostmakedepends="python3-devel"
 makedepends="${hostmakedepends}"
 short_desc="Python extension module generator for C/C++ libraries"
@@ -10,12 +11,14 @@ license="GPL-2.0-only, GPL-3.0-only, custom:SIP"
 homepage="https://riverbankcomputing.com/software/sip/intro"
 distfiles="https://www.riverbankcomputing.com/static/Downloads/sip/${version}/sip-${version}.tar.gz"
 checksum=edcd3790bb01938191eef0f6117de0bf56d1136626c0ddb678f3a558d62e41e5
+replaces="sip<=${version}_${revision}"
+provides="sip-${version}_${revision}"
 
 do_build() {
 	python3 configure.py \
 		CC="${CC}" CFLAGS="${CFLAGS}" CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" \
 		LINK="${CXX}" LINK_SHLIB="${CXX}" LFLAGS="${LDFLAGS}" STRIP="" \
-		INCDIR="${XBPS_CROSS_BASE}/${py3_inc}" ${pyqt5}
+		INCDIR="${XBPS_CROSS_BASE}/${py3_inc}"
 	make ${makejobs}
 }
 
@@ -40,7 +43,7 @@ python3-sip_package() {
 }
 
 python3-sip-devel_package() {
-	depends="python3-sip-${version}_${revision} sip-${version}_${revision}"
+	depends="python3-sip-${version}_${revision} sip4-${version}_${revision}"
 	short_desc="Python3 SIP bindings - development files"
 	pkg_install() {
 		vmove ${py3_inc}
diff --git a/srcpkgs/sip/update b/srcpkgs/sip4/update
similarity index 100%
rename from srcpkgs/sip/update
rename to srcpkgs/sip4/update

From d8aaa27f6e981010dfb961edc9539eb98e3f7724 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 08:07:11 +0700
Subject: [PATCH 3/8] sip5: rename to sip

---
 srcpkgs/{sip5 => sip}/template | 9 +++++----
 srcpkgs/{sip5 => sip}/update   | 0
 2 files changed, 5 insertions(+), 4 deletions(-)
 rename srcpkgs/{sip5 => sip}/template (77%)
 rename srcpkgs/{sip5 => sip}/update (100%)

diff --git a/srcpkgs/sip5/template b/srcpkgs/sip/template
similarity index 77%
rename from srcpkgs/sip5/template
rename to srcpkgs/sip/template
index b8e3d0bf10d..4b2090ad89f 100644
--- a/srcpkgs/sip5/template
+++ b/srcpkgs/sip/template
@@ -1,19 +1,20 @@
-# Template file for 'sip5'
-pkgname=sip5
+# Template file for 'sip'
+pkgname=sip
 version=5.5.0
 revision=1
-wrksrc="sip-$version"
 build_style=python3-module
 hostmakedepends="python3-devel python3-setuptools python3-packaging python3-toml"
 makedepends="python3-devel"
 depends="python3-setuptools python3-packaging python3-toml"
-short_desc="SIP 5 - Python 3 bindings generator for C/C++ libraries"
+short_desc="SIP - Python 3 bindings generator for C/C++ libraries"
 maintainer="Đoàn Trần Công Danh <congdanhqx@gmail.com>"
 license="GPL-2.0-only, GPL-3.0-only, custom:SIP"
 homepage="https://riverbankcomputing.com/software/sip/intro"
 distfiles="${PYPI_SITE}/s/sip/sip-${version}.tar.gz"
 checksum=5d024c419b30fea8a6de8c71a560c7ab0bc3c221fbfb14d55a5b865bd58eaac5
 lib32disabled=yes
+replaces="sip5<=${version}_${revision}"
+provides="sip5-${version}_${revision}"
 
 post_install() {
 	sed -n '1,/SUCH DAMAGE/p' sipbuild/project.py >NOTICE
diff --git a/srcpkgs/sip5/update b/srcpkgs/sip/update
similarity index 100%
rename from srcpkgs/sip5/update
rename to srcpkgs/sip/update

From 909d574b337c2e2e4b8b615a08e997f832467621 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 08:08:58 +0700
Subject: [PATCH 4/8] sip: update to 6.0.0.

---
 srcpkgs/sip/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/sip/template b/srcpkgs/sip/template
index 4b2090ad89f..3cca9aa59d5 100644
--- a/srcpkgs/sip/template
+++ b/srcpkgs/sip/template
@@ -1,6 +1,6 @@
 # Template file for 'sip'
 pkgname=sip
-version=5.5.0
+version=6.0.0
 revision=1
 build_style=python3-module
 hostmakedepends="python3-devel python3-setuptools python3-packaging python3-toml"
@@ -11,7 +11,7 @@ maintainer="Đoàn Trần Công Danh <congdanhqx@gmail.com>"
 license="GPL-2.0-only, GPL-3.0-only, custom:SIP"
 homepage="https://riverbankcomputing.com/software/sip/intro"
 distfiles="${PYPI_SITE}/s/sip/sip-${version}.tar.gz"
-checksum=5d024c419b30fea8a6de8c71a560c7ab0bc3c221fbfb14d55a5b865bd58eaac5
+checksum=6185160e1aa8e167b5919c4761cbbf68cc7478d34fb655b3a28b3eb9acb5943a
 lib32disabled=yes
 replaces="sip5<=${version}_${revision}"
 provides="sip5-${version}_${revision}"

From 14ef18a30d08920e9e1106171ed3f94a9ea8f516 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 07:52:02 +0700
Subject: [PATCH 5/8] python3-PyQt-builder: update to 1.7.0.

---
 srcpkgs/python3-PyQt-builder/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-PyQt-builder/template b/srcpkgs/python3-PyQt-builder/template
index 1d6c8fa73d4..956a6ab1cde 100644
--- a/srcpkgs/python3-PyQt-builder/template
+++ b/srcpkgs/python3-PyQt-builder/template
@@ -1,17 +1,17 @@
 # Template file for 'python3-PyQt-builder'
 pkgname=python3-PyQt-builder
-version=1.6.0
+version=1.7.0
 revision=1
 wrksrc=PyQt-builder-$version
 build_style=python3-module
-hostmakedepends="python3-setuptools"
-depends="python3 sip5>=5.5.0"
+hostmakedepends="python3-setuptools sip"
+depends="python3 sip>=6.0.0"
 short_desc="PEP 517 compliant PyQt build system"
 maintainer="Đoàn Trần Công Danh <congdanhqx@gmail.com>"
 license="GPL-2.0-only, GPL-3.0-only, custom:SIP"
 homepage="https://www.riverbankcomputing.com/software/pyqt/"
 distfiles="$PYPI_SITE/P/PyQt-builder/PyQt-builder-$version.tar.gz"
-checksum=fb80f01407718bfc68f78e276f2543fcfc5b5900b1187c1fd1f2ff51a6f2a13c
+checksum=b6e3c826f98ff4006ecb34df491ac6062a023b63a32e9f9f50904867aff72f2e
 
 post_install() {
 	rm -rf $DESTDIR/$py3_sitelib/pyqtbuild/bundle

From d233a4582f32c4ca2ac8b0efd318312074b421b1 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 07:54:12 +0700
Subject: [PATCH 6/8] python3-PyQt5-webengine: sip5 has been renamed to sip

---
 srcpkgs/python3-PyQt5-webengine/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/python3-PyQt5-webengine/template b/srcpkgs/python3-PyQt5-webengine/template
index 920cae92627..ae385283b7f 100644
--- a/srcpkgs/python3-PyQt5-webengine/template
+++ b/srcpkgs/python3-PyQt5-webengine/template
@@ -3,7 +3,7 @@ pkgname=python3-PyQt5-webengine
 version=5.15.2
 revision=1
 wrksrc="PyQtWebEngine-${version}"
-hostmakedepends="pkg-config qt5-qmake python3-PyQt5 sip5 qt5-webengine-devel
+hostmakedepends="pkg-config qt5-qmake python3-PyQt5 sip qt5-webengine-devel
  python3-PyQt-builder python3-PyQt5-devel
  qt5-declarative-devel qt5-webchannel-devel qt5-location-devel"
 makedepends="qt5-declarative-devel qt5-webchannel-devel qt5-location-devel

From b7dd767d34759a6c45df5189859c7d8137900f23 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 07:55:20 +0700
Subject: [PATCH 7/8] python3-PyQt5: depends on new sip

---
 srcpkgs/python3-PyQt5/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-PyQt5/template b/srcpkgs/python3-PyQt5/template
index bac89e57965..2a2733b439c 100644
--- a/srcpkgs/python3-PyQt5/template
+++ b/srcpkgs/python3-PyQt5/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-PyQt5'
 pkgname=python3-PyQt5
 version=5.15.2
-revision=1
+revision=2
 _sipver=12.8.0
 wrksrc="PyQt5-${version}"
 build_helper=qemu
@@ -193,7 +193,7 @@ python3-PyQt5-devel-tools_package() {
 	}
 }
 python3-PyQt5-devel_package() {
-	depends="sip5 python3-PyQt5-${version}_${revision}"
+	depends="sip>=6.0.0 python3-PyQt5-${version}_${revision}"
 	short_desc+=" - development files"
 	pkg_install() {
 		vmove ${py3_sitelib}/PyQt5/bindings

From 0828f327385cfcdd880837db4a5bc636b2d3f76b Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 07:56:13 +0700
Subject: [PATCH 8/8] python3-sip-PyQt5: build with new sip

---
 srcpkgs/python3-sip-PyQt5/template | 8 ++++++--
 1 file changed, 6 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-sip-PyQt5/template b/srcpkgs/python3-sip-PyQt5/template
index e1d1c45603d..8631cad90fb 100644
--- a/srcpkgs/python3-sip-PyQt5/template
+++ b/srcpkgs/python3-sip-PyQt5/template
@@ -4,7 +4,7 @@ version=12.8.1
 revision=1
 wrksrc="PyQt5_sip-$version"
 build_style=python3-module
-hostmakedepends="python3-devel python3-setuptools sip5"
+hostmakedepends="python3-devel python3-setuptools sip"
 makedepends="python3-devel"
 short_desc="Python 3 PyQt5 SIP bindings with C and C++"
 maintainer="Orphaned <orphan@voidlinux.org>"
@@ -14,6 +14,10 @@ distfiles="${PYPI_SITE}/P/PyQt5_sip/PyQt5_sip-${version}.tar.gz"
 checksum=30e944db9abee9cc757aea16906d4198129558533eb7fadbe48c5da2bd18e0bd
 lib32disabled=yes
 
+post_extract() {
+	mkdir -p PyQt5
+}
+
 post_install() {
-	vlicense /usr/share/licenses/sip5/LICENSE
+	vlicense /usr/share/licenses/sip/LICENSE
 }

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: RFC: rename sip 4.x to sip4, sip5 to sip, update to 6.0.0
  2021-01-08  1:14 [PR PATCH] RFC: rename sip 4.x to sip4, sip5 to sip, update to 6.0.0 sgn
                   ` (3 preceding siblings ...)
  2021-01-08  2:13 ` sgn
@ 2021-01-08  5:13 ` ericonr
  2021-01-08 14:11 ` sgn
                   ` (5 subsequent siblings)
  10 siblings, 0 replies; 12+ messages in thread
From: ericonr @ 2021-01-08  5:13 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 276 bytes --]

New comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/pull/27753#issuecomment-756550516

Comment:
Maybe add a `sip5` meta package so anyone who uses it standalone gets the update? Kinda bad but I can't think of a better alternative. 

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: RFC: rename sip 4.x to sip4, sip5 to sip, update to 6.0.0
  2021-01-08  1:14 [PR PATCH] RFC: rename sip 4.x to sip4, sip5 to sip, update to 6.0.0 sgn
                   ` (4 preceding siblings ...)
  2021-01-08  5:13 ` ericonr
@ 2021-01-08 14:11 ` sgn
  2021-01-09  2:20 ` [PR PATCH] [Updated] " sgn
                   ` (4 subsequent siblings)
  10 siblings, 0 replies; 12+ messages in thread
From: sgn @ 2021-01-08 14:11 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 406 bytes --]

New comment by sgn on void-packages repository

https://github.com/void-linux/void-packages/pull/27753#issuecomment-756774886

Comment:
> Maybe add a `sip5` meta package so anyone who uses it standalone gets the update? Kinda bad but I can't think of a better alternative.

Well, I don't think anyone would install sip5 without installing python3-PyQt5. Its sole purepose was to support PyQt5 after all.

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [PR PATCH] [Updated] RFC: rename sip 4.x to sip4, sip5 to sip, update to 6.0.0
  2021-01-08  1:14 [PR PATCH] RFC: rename sip 4.x to sip4, sip5 to sip, update to 6.0.0 sgn
                   ` (5 preceding siblings ...)
  2021-01-08 14:11 ` sgn
@ 2021-01-09  2:20 ` sgn
  2021-01-13  0:38 ` sgn
                   ` (3 subsequent siblings)
  10 siblings, 0 replies; 12+ messages in thread
From: sgn @ 2021-01-09  2:20 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 530 bytes --]

There is an updated pull request by sgn against master on the void-packages repository

https://github.com/sgn/void-packages sip-rename
https://github.com/void-linux/void-packages/pull/27753

RFC: rename sip 4.x to sip4, sip5 to sip, update to 6.0.0
- Most of our packages have the convention of using versioned-suffix for old packages
- Have `sip5` package with version 6 is weird to me
- I'm expecting sip 4.x will be phased out soon.

A patch file from https://github.com/void-linux/void-packages/pull/27753.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-sip-rename-27753.patch --]
[-- Type: text/x-diff, Size: 12372 bytes --]

From 7d43aaf8a8aa859885091f6d8f5bfabe8c298cc9 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 08:02:10 +0700
Subject: [PATCH 1/8] gns3-gui: not depends on python3-sip

Indirectly depends via PyQt5.
---
 srcpkgs/gns3-gui/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/gns3-gui/template b/srcpkgs/gns3-gui/template
index f7f51364548..1d7d84c4c65 100644
--- a/srcpkgs/gns3-gui/template
+++ b/srcpkgs/gns3-gui/template
@@ -1,11 +1,11 @@
 # Template file for 'gns3-gui'
 pkgname=gns3-gui
 version=2.2.17
-revision=1
+revision=2
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-setuptools python3-psutil python3-jsonschema python3-sentry
- python3-PyQt5-svg python3-PyQt5-websockets python3-sip xterm inetutils-telnet
+ python3-PyQt5-svg python3-PyQt5-websockets xterm inetutils-telnet
  gns3-net-converter python3-distro"
 checkdepends="${depends}"
 short_desc="Graphical Network Simulator 3 - GUI"

From 542cd9e7b240a974f92f9226f68551d5bb7b45f0 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 08:05:44 +0700
Subject: [PATCH 2/8] sip: rename to sip4

---
 srcpkgs/python3-orocos-kdl/template |  2 +-
 srcpkgs/python3-sip                 |  2 +-
 srcpkgs/python3-sip-devel           |  2 +-
 srcpkgs/sip/update                  |  2 --
 srcpkgs/{sip => sip4}/template      | 13 ++++++++-----
 5 files changed, 11 insertions(+), 10 deletions(-)
 delete mode 100644 srcpkgs/sip/update
 rename srcpkgs/{sip => sip4}/template (82%)

diff --git a/srcpkgs/python3-orocos-kdl/template b/srcpkgs/python3-orocos-kdl/template
index 728ed73d780..281ea8978c5 100644
--- a/srcpkgs/python3-orocos-kdl/template
+++ b/srcpkgs/python3-orocos-kdl/template
@@ -6,7 +6,7 @@ wrksrc=orocos_kinematics_dynamics-${version}
 build_wrksrc=python_orocos_kdl
 build_style=cmake
 configure_args="-DPYTHON_VERSION=3 -DSIP_EXECUTABLE=/usr/bin/sip"
-hostmakedepends="python3 python3-sip sip"
+hostmakedepends="python3 python3-sip sip4"
 makedepends="python3-sip-devel python3-devel orocos-kdl-devel eigen3.2"
 depends="python3 python3-sip"
 short_desc="Python3 Bindings for Orocos Kinematics and Dynamics C++ library"
diff --git a/srcpkgs/python3-sip b/srcpkgs/python3-sip
index 633f7c0bcce..27dcc148ae7 120000
--- a/srcpkgs/python3-sip
+++ b/srcpkgs/python3-sip
@@ -1 +1 @@
-sip
\ No newline at end of file
+sip4
\ No newline at end of file
diff --git a/srcpkgs/python3-sip-devel b/srcpkgs/python3-sip-devel
index 633f7c0bcce..27dcc148ae7 120000
--- a/srcpkgs/python3-sip-devel
+++ b/srcpkgs/python3-sip-devel
@@ -1 +1 @@
-sip
\ No newline at end of file
+sip4
\ No newline at end of file
diff --git a/srcpkgs/sip/update b/srcpkgs/sip/update
deleted file mode 100644
index 3504cf6a067..00000000000
--- a/srcpkgs/sip/update
+++ /dev/null
@@ -1,2 +0,0 @@
-site='https://www.riverbankcomputing.com/software/sip/download'
-ignore='*dev*'
diff --git a/srcpkgs/sip/template b/srcpkgs/sip4/template
similarity index 82%
rename from srcpkgs/sip/template
rename to srcpkgs/sip4/template
index 87d0c5c6ed6..30de98f8320 100644
--- a/srcpkgs/sip/template
+++ b/srcpkgs/sip4/template
@@ -1,7 +1,8 @@
-# Template file for 'sip'
-pkgname=sip
+# Template file for 'sip4'
+pkgname=sip4
 version=4.19.24
-revision=3
+revision=4
+wrksrc="sip-$version"
 hostmakedepends="python3-devel"
 makedepends="${hostmakedepends}"
 short_desc="Python extension module generator for C/C++ libraries"
@@ -10,12 +11,14 @@ license="GPL-2.0-only, GPL-3.0-only, custom:SIP"
 homepage="https://riverbankcomputing.com/software/sip/intro"
 distfiles="https://www.riverbankcomputing.com/static/Downloads/sip/${version}/sip-${version}.tar.gz"
 checksum=edcd3790bb01938191eef0f6117de0bf56d1136626c0ddb678f3a558d62e41e5
+replaces="sip<=${version}_${revision}"
+provides="sip-${version}_${revision}"
 
 do_build() {
 	python3 configure.py \
 		CC="${CC}" CFLAGS="${CFLAGS}" CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" \
 		LINK="${CXX}" LINK_SHLIB="${CXX}" LFLAGS="${LDFLAGS}" STRIP="" \
-		INCDIR="${XBPS_CROSS_BASE}/${py3_inc}" ${pyqt5}
+		INCDIR="${XBPS_CROSS_BASE}/${py3_inc}"
 	make ${makejobs}
 }
 
@@ -40,7 +43,7 @@ python3-sip_package() {
 }
 
 python3-sip-devel_package() {
-	depends="python3-sip-${version}_${revision} sip-${version}_${revision}"
+	depends="python3-sip-${version}_${revision} sip4-${version}_${revision}"
 	short_desc="Python3 SIP bindings - development files"
 	pkg_install() {
 		vmove ${py3_inc}

From 52377b34adbc602ec20200ac48c7907c999d6944 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 08:07:11 +0700
Subject: [PATCH 3/8] sip5: rename to sip

---
 srcpkgs/{sip5 => sip}/template | 9 +++++----
 srcpkgs/sip5/update            | 1 -
 2 files changed, 5 insertions(+), 5 deletions(-)
 rename srcpkgs/{sip5 => sip}/template (77%)
 delete mode 100644 srcpkgs/sip5/update

diff --git a/srcpkgs/sip5/template b/srcpkgs/sip/template
similarity index 77%
rename from srcpkgs/sip5/template
rename to srcpkgs/sip/template
index b8e3d0bf10d..4b2090ad89f 100644
--- a/srcpkgs/sip5/template
+++ b/srcpkgs/sip/template
@@ -1,19 +1,20 @@
-# Template file for 'sip5'
-pkgname=sip5
+# Template file for 'sip'
+pkgname=sip
 version=5.5.0
 revision=1
-wrksrc="sip-$version"
 build_style=python3-module
 hostmakedepends="python3-devel python3-setuptools python3-packaging python3-toml"
 makedepends="python3-devel"
 depends="python3-setuptools python3-packaging python3-toml"
-short_desc="SIP 5 - Python 3 bindings generator for C/C++ libraries"
+short_desc="SIP - Python 3 bindings generator for C/C++ libraries"
 maintainer="Đoàn Trần Công Danh <congdanhqx@gmail.com>"
 license="GPL-2.0-only, GPL-3.0-only, custom:SIP"
 homepage="https://riverbankcomputing.com/software/sip/intro"
 distfiles="${PYPI_SITE}/s/sip/sip-${version}.tar.gz"
 checksum=5d024c419b30fea8a6de8c71a560c7ab0bc3c221fbfb14d55a5b865bd58eaac5
 lib32disabled=yes
+replaces="sip5<=${version}_${revision}"
+provides="sip5-${version}_${revision}"
 
 post_install() {
 	sed -n '1,/SUCH DAMAGE/p' sipbuild/project.py >NOTICE
diff --git a/srcpkgs/sip5/update b/srcpkgs/sip5/update
deleted file mode 100644
index e96ff514fe9..00000000000
--- a/srcpkgs/sip5/update
+++ /dev/null
@@ -1 +0,0 @@
-pkgname=sip

From 7b5a60856e9b1f06230d4349a86859e849d0bfb5 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 08:08:58 +0700
Subject: [PATCH 4/8] sip: update to 6.0.0.

---
 srcpkgs/sip/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/sip/template b/srcpkgs/sip/template
index 4b2090ad89f..3cca9aa59d5 100644
--- a/srcpkgs/sip/template
+++ b/srcpkgs/sip/template
@@ -1,6 +1,6 @@
 # Template file for 'sip'
 pkgname=sip
-version=5.5.0
+version=6.0.0
 revision=1
 build_style=python3-module
 hostmakedepends="python3-devel python3-setuptools python3-packaging python3-toml"
@@ -11,7 +11,7 @@ maintainer="Đoàn Trần Công Danh <congdanhqx@gmail.com>"
 license="GPL-2.0-only, GPL-3.0-only, custom:SIP"
 homepage="https://riverbankcomputing.com/software/sip/intro"
 distfiles="${PYPI_SITE}/s/sip/sip-${version}.tar.gz"
-checksum=5d024c419b30fea8a6de8c71a560c7ab0bc3c221fbfb14d55a5b865bd58eaac5
+checksum=6185160e1aa8e167b5919c4761cbbf68cc7478d34fb655b3a28b3eb9acb5943a
 lib32disabled=yes
 replaces="sip5<=${version}_${revision}"
 provides="sip5-${version}_${revision}"

From 62536eb2c24f0149e7c9876482a8e7b1a5879682 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 07:52:02 +0700
Subject: [PATCH 5/8] python3-PyQt-builder: update to 1.7.0.

---
 srcpkgs/python3-PyQt-builder/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-PyQt-builder/template b/srcpkgs/python3-PyQt-builder/template
index 1d6c8fa73d4..956a6ab1cde 100644
--- a/srcpkgs/python3-PyQt-builder/template
+++ b/srcpkgs/python3-PyQt-builder/template
@@ -1,17 +1,17 @@
 # Template file for 'python3-PyQt-builder'
 pkgname=python3-PyQt-builder
-version=1.6.0
+version=1.7.0
 revision=1
 wrksrc=PyQt-builder-$version
 build_style=python3-module
-hostmakedepends="python3-setuptools"
-depends="python3 sip5>=5.5.0"
+hostmakedepends="python3-setuptools sip"
+depends="python3 sip>=6.0.0"
 short_desc="PEP 517 compliant PyQt build system"
 maintainer="Đoàn Trần Công Danh <congdanhqx@gmail.com>"
 license="GPL-2.0-only, GPL-3.0-only, custom:SIP"
 homepage="https://www.riverbankcomputing.com/software/pyqt/"
 distfiles="$PYPI_SITE/P/PyQt-builder/PyQt-builder-$version.tar.gz"
-checksum=fb80f01407718bfc68f78e276f2543fcfc5b5900b1187c1fd1f2ff51a6f2a13c
+checksum=b6e3c826f98ff4006ecb34df491ac6062a023b63a32e9f9f50904867aff72f2e
 
 post_install() {
 	rm -rf $DESTDIR/$py3_sitelib/pyqtbuild/bundle

From a8fe905dcde1cc2cf1ac976981348644e76ec3ce Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 07:56:13 +0700
Subject: [PATCH 6/8] python3-sip-PyQt5: build with new sip

---
 srcpkgs/python3-sip-PyQt5/template | 8 ++++++--
 1 file changed, 6 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-sip-PyQt5/template b/srcpkgs/python3-sip-PyQt5/template
index e1d1c45603d..8631cad90fb 100644
--- a/srcpkgs/python3-sip-PyQt5/template
+++ b/srcpkgs/python3-sip-PyQt5/template
@@ -4,7 +4,7 @@ version=12.8.1
 revision=1
 wrksrc="PyQt5_sip-$version"
 build_style=python3-module
-hostmakedepends="python3-devel python3-setuptools sip5"
+hostmakedepends="python3-devel python3-setuptools sip"
 makedepends="python3-devel"
 short_desc="Python 3 PyQt5 SIP bindings with C and C++"
 maintainer="Orphaned <orphan@voidlinux.org>"
@@ -14,6 +14,10 @@ distfiles="${PYPI_SITE}/P/PyQt5_sip/PyQt5_sip-${version}.tar.gz"
 checksum=30e944db9abee9cc757aea16906d4198129558533eb7fadbe48c5da2bd18e0bd
 lib32disabled=yes
 
+post_extract() {
+	mkdir -p PyQt5
+}
+
 post_install() {
-	vlicense /usr/share/licenses/sip5/LICENSE
+	vlicense /usr/share/licenses/sip/LICENSE
 }

From 6591c27b0c8316949a3a1e69f54133691951f14d Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 07:55:20 +0700
Subject: [PATCH 7/8] python3-PyQt5: depends on new sip

---
 srcpkgs/python3-PyQt5/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-PyQt5/template b/srcpkgs/python3-PyQt5/template
index bac89e57965..2a2733b439c 100644
--- a/srcpkgs/python3-PyQt5/template
+++ b/srcpkgs/python3-PyQt5/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-PyQt5'
 pkgname=python3-PyQt5
 version=5.15.2
-revision=1
+revision=2
 _sipver=12.8.0
 wrksrc="PyQt5-${version}"
 build_helper=qemu
@@ -193,7 +193,7 @@ python3-PyQt5-devel-tools_package() {
 	}
 }
 python3-PyQt5-devel_package() {
-	depends="sip5 python3-PyQt5-${version}_${revision}"
+	depends="sip>=6.0.0 python3-PyQt5-${version}_${revision}"
 	short_desc+=" - development files"
 	pkg_install() {
 		vmove ${py3_sitelib}/PyQt5/bindings

From ad4d25be403d0fda87362690a2f825916b65ead2 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 07:54:12 +0700
Subject: [PATCH 8/8] python3-PyQt5-webengine: sip5 has been renamed to sip

---
 srcpkgs/python3-PyQt5-webengine/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/python3-PyQt5-webengine/template b/srcpkgs/python3-PyQt5-webengine/template
index 920cae92627..ae385283b7f 100644
--- a/srcpkgs/python3-PyQt5-webengine/template
+++ b/srcpkgs/python3-PyQt5-webengine/template
@@ -3,7 +3,7 @@ pkgname=python3-PyQt5-webengine
 version=5.15.2
 revision=1
 wrksrc="PyQtWebEngine-${version}"
-hostmakedepends="pkg-config qt5-qmake python3-PyQt5 sip5 qt5-webengine-devel
+hostmakedepends="pkg-config qt5-qmake python3-PyQt5 sip qt5-webengine-devel
  python3-PyQt-builder python3-PyQt5-devel
  qt5-declarative-devel qt5-webchannel-devel qt5-location-devel"
 makedepends="qt5-declarative-devel qt5-webchannel-devel qt5-location-devel

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [PR PATCH] [Updated] RFC: rename sip 4.x to sip4, sip5 to sip, update to 6.0.0
  2021-01-08  1:14 [PR PATCH] RFC: rename sip 4.x to sip4, sip5 to sip, update to 6.0.0 sgn
                   ` (6 preceding siblings ...)
  2021-01-09  2:20 ` [PR PATCH] [Updated] " sgn
@ 2021-01-13  0:38 ` sgn
  2021-01-13  0:43 ` sgn
                   ` (2 subsequent siblings)
  10 siblings, 0 replies; 12+ messages in thread
From: sgn @ 2021-01-13  0:38 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 530 bytes --]

There is an updated pull request by sgn against master on the void-packages repository

https://github.com/sgn/void-packages sip-rename
https://github.com/void-linux/void-packages/pull/27753

RFC: rename sip 4.x to sip4, sip5 to sip, update to 6.0.0
- Most of our packages have the convention of using versioned-suffix for old packages
- Have `sip5` package with version 6 is weird to me
- I'm expecting sip 4.x will be phased out soon.

A patch file from https://github.com/void-linux/void-packages/pull/27753.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-sip-rename-27753.patch --]
[-- Type: text/x-diff, Size: 11458 bytes --]

From 1b7ac1be8f3494a776b548f9c9c90796f9957b02 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 08:05:44 +0700
Subject: [PATCH 1/8] sip: rename to sip4

---
 srcpkgs/python3-sip            |  2 +-
 srcpkgs/python3-sip-devel      |  2 +-
 srcpkgs/{sip => sip4}/template | 13 ++++++++-----
 srcpkgs/{sip => sip4}/update   |  0
 4 files changed, 10 insertions(+), 7 deletions(-)
 rename srcpkgs/{sip => sip4}/template (82%)
 rename srcpkgs/{sip => sip4}/update (100%)

diff --git a/srcpkgs/python3-sip b/srcpkgs/python3-sip
index 633f7c0bcce..27dcc148ae7 120000
--- a/srcpkgs/python3-sip
+++ b/srcpkgs/python3-sip
@@ -1 +1 @@
-sip
\ No newline at end of file
+sip4
\ No newline at end of file
diff --git a/srcpkgs/python3-sip-devel b/srcpkgs/python3-sip-devel
index 633f7c0bcce..27dcc148ae7 120000
--- a/srcpkgs/python3-sip-devel
+++ b/srcpkgs/python3-sip-devel
@@ -1 +1 @@
-sip
\ No newline at end of file
+sip4
\ No newline at end of file
diff --git a/srcpkgs/sip/template b/srcpkgs/sip4/template
similarity index 82%
rename from srcpkgs/sip/template
rename to srcpkgs/sip4/template
index 87d0c5c6ed6..30de98f8320 100644
--- a/srcpkgs/sip/template
+++ b/srcpkgs/sip4/template
@@ -1,7 +1,8 @@
-# Template file for 'sip'
-pkgname=sip
+# Template file for 'sip4'
+pkgname=sip4
 version=4.19.24
-revision=3
+revision=4
+wrksrc="sip-$version"
 hostmakedepends="python3-devel"
 makedepends="${hostmakedepends}"
 short_desc="Python extension module generator for C/C++ libraries"
@@ -10,12 +11,14 @@ license="GPL-2.0-only, GPL-3.0-only, custom:SIP"
 homepage="https://riverbankcomputing.com/software/sip/intro"
 distfiles="https://www.riverbankcomputing.com/static/Downloads/sip/${version}/sip-${version}.tar.gz"
 checksum=edcd3790bb01938191eef0f6117de0bf56d1136626c0ddb678f3a558d62e41e5
+replaces="sip<=${version}_${revision}"
+provides="sip-${version}_${revision}"
 
 do_build() {
 	python3 configure.py \
 		CC="${CC}" CFLAGS="${CFLAGS}" CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" \
 		LINK="${CXX}" LINK_SHLIB="${CXX}" LFLAGS="${LDFLAGS}" STRIP="" \
-		INCDIR="${XBPS_CROSS_BASE}/${py3_inc}" ${pyqt5}
+		INCDIR="${XBPS_CROSS_BASE}/${py3_inc}"
 	make ${makejobs}
 }
 
@@ -40,7 +43,7 @@ python3-sip_package() {
 }
 
 python3-sip-devel_package() {
-	depends="python3-sip-${version}_${revision} sip-${version}_${revision}"
+	depends="python3-sip-${version}_${revision} sip4-${version}_${revision}"
 	short_desc="Python3 SIP bindings - development files"
 	pkg_install() {
 		vmove ${py3_inc}
diff --git a/srcpkgs/sip/update b/srcpkgs/sip4/update
similarity index 100%
rename from srcpkgs/sip/update
rename to srcpkgs/sip4/update

From ddd28d598c8027ff7a3906053fc12e93794e9f6b Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Wed, 13 Jan 2021 07:36:15 +0700
Subject: [PATCH 2/8] python3-orocos-kdl: sip renamed to sip4

---
 srcpkgs/python3-orocos-kdl/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/python3-orocos-kdl/template b/srcpkgs/python3-orocos-kdl/template
index 728ed73d780..281ea8978c5 100644
--- a/srcpkgs/python3-orocos-kdl/template
+++ b/srcpkgs/python3-orocos-kdl/template
@@ -6,7 +6,7 @@ wrksrc=orocos_kinematics_dynamics-${version}
 build_wrksrc=python_orocos_kdl
 build_style=cmake
 configure_args="-DPYTHON_VERSION=3 -DSIP_EXECUTABLE=/usr/bin/sip"
-hostmakedepends="python3 python3-sip sip"
+hostmakedepends="python3 python3-sip sip4"
 makedepends="python3-sip-devel python3-devel orocos-kdl-devel eigen3.2"
 depends="python3 python3-sip"
 short_desc="Python3 Bindings for Orocos Kinematics and Dynamics C++ library"

From c8f9fc49939603ca58d754283f41b34cd9901949 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 08:07:11 +0700
Subject: [PATCH 3/8] sip5: rename to sip

---
 srcpkgs/{sip5 => sip}/template | 9 +++++----
 srcpkgs/{sip5 => sip}/update   | 0
 2 files changed, 5 insertions(+), 4 deletions(-)
 rename srcpkgs/{sip5 => sip}/template (77%)
 rename srcpkgs/{sip5 => sip}/update (100%)

diff --git a/srcpkgs/sip5/template b/srcpkgs/sip/template
similarity index 77%
rename from srcpkgs/sip5/template
rename to srcpkgs/sip/template
index b8e3d0bf10d..4b2090ad89f 100644
--- a/srcpkgs/sip5/template
+++ b/srcpkgs/sip/template
@@ -1,19 +1,20 @@
-# Template file for 'sip5'
-pkgname=sip5
+# Template file for 'sip'
+pkgname=sip
 version=5.5.0
 revision=1
-wrksrc="sip-$version"
 build_style=python3-module
 hostmakedepends="python3-devel python3-setuptools python3-packaging python3-toml"
 makedepends="python3-devel"
 depends="python3-setuptools python3-packaging python3-toml"
-short_desc="SIP 5 - Python 3 bindings generator for C/C++ libraries"
+short_desc="SIP - Python 3 bindings generator for C/C++ libraries"
 maintainer="Đoàn Trần Công Danh <congdanhqx@gmail.com>"
 license="GPL-2.0-only, GPL-3.0-only, custom:SIP"
 homepage="https://riverbankcomputing.com/software/sip/intro"
 distfiles="${PYPI_SITE}/s/sip/sip-${version}.tar.gz"
 checksum=5d024c419b30fea8a6de8c71a560c7ab0bc3c221fbfb14d55a5b865bd58eaac5
 lib32disabled=yes
+replaces="sip5<=${version}_${revision}"
+provides="sip5-${version}_${revision}"
 
 post_install() {
 	sed -n '1,/SUCH DAMAGE/p' sipbuild/project.py >NOTICE
diff --git a/srcpkgs/sip5/update b/srcpkgs/sip/update
similarity index 100%
rename from srcpkgs/sip5/update
rename to srcpkgs/sip/update

From b68a83aee45779c78e66fc37da7996a609a5b3aa Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 08:08:58 +0700
Subject: [PATCH 4/8] sip: update to 6.0.0.

---
 srcpkgs/sip/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/sip/template b/srcpkgs/sip/template
index 4b2090ad89f..3cca9aa59d5 100644
--- a/srcpkgs/sip/template
+++ b/srcpkgs/sip/template
@@ -1,6 +1,6 @@
 # Template file for 'sip'
 pkgname=sip
-version=5.5.0
+version=6.0.0
 revision=1
 build_style=python3-module
 hostmakedepends="python3-devel python3-setuptools python3-packaging python3-toml"
@@ -11,7 +11,7 @@ maintainer="Đoàn Trần Công Danh <congdanhqx@gmail.com>"
 license="GPL-2.0-only, GPL-3.0-only, custom:SIP"
 homepage="https://riverbankcomputing.com/software/sip/intro"
 distfiles="${PYPI_SITE}/s/sip/sip-${version}.tar.gz"
-checksum=5d024c419b30fea8a6de8c71a560c7ab0bc3c221fbfb14d55a5b865bd58eaac5
+checksum=6185160e1aa8e167b5919c4761cbbf68cc7478d34fb655b3a28b3eb9acb5943a
 lib32disabled=yes
 replaces="sip5<=${version}_${revision}"
 provides="sip5-${version}_${revision}"

From 1ee87924391e5062359c2dd9d1061d4f6b27fc78 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 07:52:02 +0700
Subject: [PATCH 5/8] python3-PyQt-builder: update to 1.7.0.

---
 srcpkgs/python3-PyQt-builder/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-PyQt-builder/template b/srcpkgs/python3-PyQt-builder/template
index 1d6c8fa73d4..956a6ab1cde 100644
--- a/srcpkgs/python3-PyQt-builder/template
+++ b/srcpkgs/python3-PyQt-builder/template
@@ -1,17 +1,17 @@
 # Template file for 'python3-PyQt-builder'
 pkgname=python3-PyQt-builder
-version=1.6.0
+version=1.7.0
 revision=1
 wrksrc=PyQt-builder-$version
 build_style=python3-module
-hostmakedepends="python3-setuptools"
-depends="python3 sip5>=5.5.0"
+hostmakedepends="python3-setuptools sip"
+depends="python3 sip>=6.0.0"
 short_desc="PEP 517 compliant PyQt build system"
 maintainer="Đoàn Trần Công Danh <congdanhqx@gmail.com>"
 license="GPL-2.0-only, GPL-3.0-only, custom:SIP"
 homepage="https://www.riverbankcomputing.com/software/pyqt/"
 distfiles="$PYPI_SITE/P/PyQt-builder/PyQt-builder-$version.tar.gz"
-checksum=fb80f01407718bfc68f78e276f2543fcfc5b5900b1187c1fd1f2ff51a6f2a13c
+checksum=b6e3c826f98ff4006ecb34df491ac6062a023b63a32e9f9f50904867aff72f2e
 
 post_install() {
 	rm -rf $DESTDIR/$py3_sitelib/pyqtbuild/bundle

From ccc59dcf675b209dbeccb4be42371a724cbef35c Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 07:54:12 +0700
Subject: [PATCH 6/8] python3-PyQt5-webengine: sip5 has been renamed to sip

---
 srcpkgs/python3-PyQt5-webengine/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/python3-PyQt5-webengine/template b/srcpkgs/python3-PyQt5-webengine/template
index 920cae92627..ae385283b7f 100644
--- a/srcpkgs/python3-PyQt5-webengine/template
+++ b/srcpkgs/python3-PyQt5-webengine/template
@@ -3,7 +3,7 @@ pkgname=python3-PyQt5-webengine
 version=5.15.2
 revision=1
 wrksrc="PyQtWebEngine-${version}"
-hostmakedepends="pkg-config qt5-qmake python3-PyQt5 sip5 qt5-webengine-devel
+hostmakedepends="pkg-config qt5-qmake python3-PyQt5 sip qt5-webengine-devel
  python3-PyQt-builder python3-PyQt5-devel
  qt5-declarative-devel qt5-webchannel-devel qt5-location-devel"
 makedepends="qt5-declarative-devel qt5-webchannel-devel qt5-location-devel

From 7e064d8e708fa86762bce45947b0167cdfc5c0c7 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 07:55:20 +0700
Subject: [PATCH 7/8] python3-PyQt5: depends on new sip

---
 srcpkgs/python3-PyQt5/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-PyQt5/template b/srcpkgs/python3-PyQt5/template
index bac89e57965..2a2733b439c 100644
--- a/srcpkgs/python3-PyQt5/template
+++ b/srcpkgs/python3-PyQt5/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-PyQt5'
 pkgname=python3-PyQt5
 version=5.15.2
-revision=1
+revision=2
 _sipver=12.8.0
 wrksrc="PyQt5-${version}"
 build_helper=qemu
@@ -193,7 +193,7 @@ python3-PyQt5-devel-tools_package() {
 	}
 }
 python3-PyQt5-devel_package() {
-	depends="sip5 python3-PyQt5-${version}_${revision}"
+	depends="sip>=6.0.0 python3-PyQt5-${version}_${revision}"
 	short_desc+=" - development files"
 	pkg_install() {
 		vmove ${py3_sitelib}/PyQt5/bindings

From b550ccb0c923c844b53ebb6e856f118964f169a7 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 07:56:13 +0700
Subject: [PATCH 8/8] python3-sip-PyQt5: build with new sip

---
 srcpkgs/python3-sip-PyQt5/template | 8 ++++++--
 1 file changed, 6 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-sip-PyQt5/template b/srcpkgs/python3-sip-PyQt5/template
index e1d1c45603d..8631cad90fb 100644
--- a/srcpkgs/python3-sip-PyQt5/template
+++ b/srcpkgs/python3-sip-PyQt5/template
@@ -4,7 +4,7 @@ version=12.8.1
 revision=1
 wrksrc="PyQt5_sip-$version"
 build_style=python3-module
-hostmakedepends="python3-devel python3-setuptools sip5"
+hostmakedepends="python3-devel python3-setuptools sip"
 makedepends="python3-devel"
 short_desc="Python 3 PyQt5 SIP bindings with C and C++"
 maintainer="Orphaned <orphan@voidlinux.org>"
@@ -14,6 +14,10 @@ distfiles="${PYPI_SITE}/P/PyQt5_sip/PyQt5_sip-${version}.tar.gz"
 checksum=30e944db9abee9cc757aea16906d4198129558533eb7fadbe48c5da2bd18e0bd
 lib32disabled=yes
 
+post_extract() {
+	mkdir -p PyQt5
+}
+
 post_install() {
-	vlicense /usr/share/licenses/sip5/LICENSE
+	vlicense /usr/share/licenses/sip/LICENSE
 }

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [PR PATCH] [Updated] RFC: rename sip 4.x to sip4, sip5 to sip, update to 6.0.0
  2021-01-08  1:14 [PR PATCH] RFC: rename sip 4.x to sip4, sip5 to sip, update to 6.0.0 sgn
                   ` (7 preceding siblings ...)
  2021-01-13  0:38 ` sgn
@ 2021-01-13  0:43 ` sgn
  2021-01-13 11:55 ` sgn
  2021-01-13 14:27 ` [PR PATCH] [Merged]: " sgn
  10 siblings, 0 replies; 12+ messages in thread
From: sgn @ 2021-01-13  0:43 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 530 bytes --]

There is an updated pull request by sgn against master on the void-packages repository

https://github.com/sgn/void-packages sip-rename
https://github.com/void-linux/void-packages/pull/27753

RFC: rename sip 4.x to sip4, sip5 to sip, update to 6.0.0
- Most of our packages have the convention of using versioned-suffix for old packages
- Have `sip5` package with version 6 is weird to me
- I'm expecting sip 4.x will be phased out soon.

A patch file from https://github.com/void-linux/void-packages/pull/27753.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-sip-rename-27753.patch --]
[-- Type: text/x-diff, Size: 12340 bytes --]

From 1b7ac1be8f3494a776b548f9c9c90796f9957b02 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 08:05:44 +0700
Subject: [PATCH 1/9] sip: rename to sip4

---
 srcpkgs/python3-sip            |  2 +-
 srcpkgs/python3-sip-devel      |  2 +-
 srcpkgs/{sip => sip4}/template | 13 ++++++++-----
 srcpkgs/{sip => sip4}/update   |  0
 4 files changed, 10 insertions(+), 7 deletions(-)
 rename srcpkgs/{sip => sip4}/template (82%)
 rename srcpkgs/{sip => sip4}/update (100%)

diff --git a/srcpkgs/python3-sip b/srcpkgs/python3-sip
index 633f7c0bcce..27dcc148ae7 120000
--- a/srcpkgs/python3-sip
+++ b/srcpkgs/python3-sip
@@ -1 +1 @@
-sip
\ No newline at end of file
+sip4
\ No newline at end of file
diff --git a/srcpkgs/python3-sip-devel b/srcpkgs/python3-sip-devel
index 633f7c0bcce..27dcc148ae7 120000
--- a/srcpkgs/python3-sip-devel
+++ b/srcpkgs/python3-sip-devel
@@ -1 +1 @@
-sip
\ No newline at end of file
+sip4
\ No newline at end of file
diff --git a/srcpkgs/sip/template b/srcpkgs/sip4/template
similarity index 82%
rename from srcpkgs/sip/template
rename to srcpkgs/sip4/template
index 87d0c5c6ed6..30de98f8320 100644
--- a/srcpkgs/sip/template
+++ b/srcpkgs/sip4/template
@@ -1,7 +1,8 @@
-# Template file for 'sip'
-pkgname=sip
+# Template file for 'sip4'
+pkgname=sip4
 version=4.19.24
-revision=3
+revision=4
+wrksrc="sip-$version"
 hostmakedepends="python3-devel"
 makedepends="${hostmakedepends}"
 short_desc="Python extension module generator for C/C++ libraries"
@@ -10,12 +11,14 @@ license="GPL-2.0-only, GPL-3.0-only, custom:SIP"
 homepage="https://riverbankcomputing.com/software/sip/intro"
 distfiles="https://www.riverbankcomputing.com/static/Downloads/sip/${version}/sip-${version}.tar.gz"
 checksum=edcd3790bb01938191eef0f6117de0bf56d1136626c0ddb678f3a558d62e41e5
+replaces="sip<=${version}_${revision}"
+provides="sip-${version}_${revision}"
 
 do_build() {
 	python3 configure.py \
 		CC="${CC}" CFLAGS="${CFLAGS}" CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" \
 		LINK="${CXX}" LINK_SHLIB="${CXX}" LFLAGS="${LDFLAGS}" STRIP="" \
-		INCDIR="${XBPS_CROSS_BASE}/${py3_inc}" ${pyqt5}
+		INCDIR="${XBPS_CROSS_BASE}/${py3_inc}"
 	make ${makejobs}
 }
 
@@ -40,7 +43,7 @@ python3-sip_package() {
 }
 
 python3-sip-devel_package() {
-	depends="python3-sip-${version}_${revision} sip-${version}_${revision}"
+	depends="python3-sip-${version}_${revision} sip4-${version}_${revision}"
 	short_desc="Python3 SIP bindings - development files"
 	pkg_install() {
 		vmove ${py3_inc}
diff --git a/srcpkgs/sip/update b/srcpkgs/sip4/update
similarity index 100%
rename from srcpkgs/sip/update
rename to srcpkgs/sip4/update

From ddd28d598c8027ff7a3906053fc12e93794e9f6b Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Wed, 13 Jan 2021 07:36:15 +0700
Subject: [PATCH 2/9] python3-orocos-kdl: sip renamed to sip4

---
 srcpkgs/python3-orocos-kdl/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/python3-orocos-kdl/template b/srcpkgs/python3-orocos-kdl/template
index 728ed73d780..281ea8978c5 100644
--- a/srcpkgs/python3-orocos-kdl/template
+++ b/srcpkgs/python3-orocos-kdl/template
@@ -6,7 +6,7 @@ wrksrc=orocos_kinematics_dynamics-${version}
 build_wrksrc=python_orocos_kdl
 build_style=cmake
 configure_args="-DPYTHON_VERSION=3 -DSIP_EXECUTABLE=/usr/bin/sip"
-hostmakedepends="python3 python3-sip sip"
+hostmakedepends="python3 python3-sip sip4"
 makedepends="python3-sip-devel python3-devel orocos-kdl-devel eigen3.2"
 depends="python3 python3-sip"
 short_desc="Python3 Bindings for Orocos Kinematics and Dynamics C++ library"

From c8f9fc49939603ca58d754283f41b34cd9901949 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 08:07:11 +0700
Subject: [PATCH 3/9] sip5: rename to sip

---
 srcpkgs/{sip5 => sip}/template | 9 +++++----
 srcpkgs/{sip5 => sip}/update   | 0
 2 files changed, 5 insertions(+), 4 deletions(-)
 rename srcpkgs/{sip5 => sip}/template (77%)
 rename srcpkgs/{sip5 => sip}/update (100%)

diff --git a/srcpkgs/sip5/template b/srcpkgs/sip/template
similarity index 77%
rename from srcpkgs/sip5/template
rename to srcpkgs/sip/template
index b8e3d0bf10d..4b2090ad89f 100644
--- a/srcpkgs/sip5/template
+++ b/srcpkgs/sip/template
@@ -1,19 +1,20 @@
-# Template file for 'sip5'
-pkgname=sip5
+# Template file for 'sip'
+pkgname=sip
 version=5.5.0
 revision=1
-wrksrc="sip-$version"
 build_style=python3-module
 hostmakedepends="python3-devel python3-setuptools python3-packaging python3-toml"
 makedepends="python3-devel"
 depends="python3-setuptools python3-packaging python3-toml"
-short_desc="SIP 5 - Python 3 bindings generator for C/C++ libraries"
+short_desc="SIP - Python 3 bindings generator for C/C++ libraries"
 maintainer="Đoàn Trần Công Danh <congdanhqx@gmail.com>"
 license="GPL-2.0-only, GPL-3.0-only, custom:SIP"
 homepage="https://riverbankcomputing.com/software/sip/intro"
 distfiles="${PYPI_SITE}/s/sip/sip-${version}.tar.gz"
 checksum=5d024c419b30fea8a6de8c71a560c7ab0bc3c221fbfb14d55a5b865bd58eaac5
 lib32disabled=yes
+replaces="sip5<=${version}_${revision}"
+provides="sip5-${version}_${revision}"
 
 post_install() {
 	sed -n '1,/SUCH DAMAGE/p' sipbuild/project.py >NOTICE
diff --git a/srcpkgs/sip5/update b/srcpkgs/sip/update
similarity index 100%
rename from srcpkgs/sip5/update
rename to srcpkgs/sip/update

From b68a83aee45779c78e66fc37da7996a609a5b3aa Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 08:08:58 +0700
Subject: [PATCH 4/9] sip: update to 6.0.0.

---
 srcpkgs/sip/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/sip/template b/srcpkgs/sip/template
index 4b2090ad89f..3cca9aa59d5 100644
--- a/srcpkgs/sip/template
+++ b/srcpkgs/sip/template
@@ -1,6 +1,6 @@
 # Template file for 'sip'
 pkgname=sip
-version=5.5.0
+version=6.0.0
 revision=1
 build_style=python3-module
 hostmakedepends="python3-devel python3-setuptools python3-packaging python3-toml"
@@ -11,7 +11,7 @@ maintainer="Đoàn Trần Công Danh <congdanhqx@gmail.com>"
 license="GPL-2.0-only, GPL-3.0-only, custom:SIP"
 homepage="https://riverbankcomputing.com/software/sip/intro"
 distfiles="${PYPI_SITE}/s/sip/sip-${version}.tar.gz"
-checksum=5d024c419b30fea8a6de8c71a560c7ab0bc3c221fbfb14d55a5b865bd58eaac5
+checksum=6185160e1aa8e167b5919c4761cbbf68cc7478d34fb655b3a28b3eb9acb5943a
 lib32disabled=yes
 replaces="sip5<=${version}_${revision}"
 provides="sip5-${version}_${revision}"

From 1ee87924391e5062359c2dd9d1061d4f6b27fc78 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 07:52:02 +0700
Subject: [PATCH 5/9] python3-PyQt-builder: update to 1.7.0.

---
 srcpkgs/python3-PyQt-builder/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-PyQt-builder/template b/srcpkgs/python3-PyQt-builder/template
index 1d6c8fa73d4..956a6ab1cde 100644
--- a/srcpkgs/python3-PyQt-builder/template
+++ b/srcpkgs/python3-PyQt-builder/template
@@ -1,17 +1,17 @@
 # Template file for 'python3-PyQt-builder'
 pkgname=python3-PyQt-builder
-version=1.6.0
+version=1.7.0
 revision=1
 wrksrc=PyQt-builder-$version
 build_style=python3-module
-hostmakedepends="python3-setuptools"
-depends="python3 sip5>=5.5.0"
+hostmakedepends="python3-setuptools sip"
+depends="python3 sip>=6.0.0"
 short_desc="PEP 517 compliant PyQt build system"
 maintainer="Đoàn Trần Công Danh <congdanhqx@gmail.com>"
 license="GPL-2.0-only, GPL-3.0-only, custom:SIP"
 homepage="https://www.riverbankcomputing.com/software/pyqt/"
 distfiles="$PYPI_SITE/P/PyQt-builder/PyQt-builder-$version.tar.gz"
-checksum=fb80f01407718bfc68f78e276f2543fcfc5b5900b1187c1fd1f2ff51a6f2a13c
+checksum=b6e3c826f98ff4006ecb34df491ac6062a023b63a32e9f9f50904867aff72f2e
 
 post_install() {
 	rm -rf $DESTDIR/$py3_sitelib/pyqtbuild/bundle

From ccc59dcf675b209dbeccb4be42371a724cbef35c Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 07:54:12 +0700
Subject: [PATCH 6/9] python3-PyQt5-webengine: sip5 has been renamed to sip

---
 srcpkgs/python3-PyQt5-webengine/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/python3-PyQt5-webengine/template b/srcpkgs/python3-PyQt5-webengine/template
index 920cae92627..ae385283b7f 100644
--- a/srcpkgs/python3-PyQt5-webengine/template
+++ b/srcpkgs/python3-PyQt5-webengine/template
@@ -3,7 +3,7 @@ pkgname=python3-PyQt5-webengine
 version=5.15.2
 revision=1
 wrksrc="PyQtWebEngine-${version}"
-hostmakedepends="pkg-config qt5-qmake python3-PyQt5 sip5 qt5-webengine-devel
+hostmakedepends="pkg-config qt5-qmake python3-PyQt5 sip qt5-webengine-devel
  python3-PyQt-builder python3-PyQt5-devel
  qt5-declarative-devel qt5-webchannel-devel qt5-location-devel"
 makedepends="qt5-declarative-devel qt5-webchannel-devel qt5-location-devel

From 7e064d8e708fa86762bce45947b0167cdfc5c0c7 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 07:55:20 +0700
Subject: [PATCH 7/9] python3-PyQt5: depends on new sip

---
 srcpkgs/python3-PyQt5/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-PyQt5/template b/srcpkgs/python3-PyQt5/template
index bac89e57965..2a2733b439c 100644
--- a/srcpkgs/python3-PyQt5/template
+++ b/srcpkgs/python3-PyQt5/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-PyQt5'
 pkgname=python3-PyQt5
 version=5.15.2
-revision=1
+revision=2
 _sipver=12.8.0
 wrksrc="PyQt5-${version}"
 build_helper=qemu
@@ -193,7 +193,7 @@ python3-PyQt5-devel-tools_package() {
 	}
 }
 python3-PyQt5-devel_package() {
-	depends="sip5 python3-PyQt5-${version}_${revision}"
+	depends="sip>=6.0.0 python3-PyQt5-${version}_${revision}"
 	short_desc+=" - development files"
 	pkg_install() {
 		vmove ${py3_sitelib}/PyQt5/bindings

From b550ccb0c923c844b53ebb6e856f118964f169a7 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 07:56:13 +0700
Subject: [PATCH 8/9] python3-sip-PyQt5: build with new sip

---
 srcpkgs/python3-sip-PyQt5/template | 8 ++++++--
 1 file changed, 6 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-sip-PyQt5/template b/srcpkgs/python3-sip-PyQt5/template
index e1d1c45603d..8631cad90fb 100644
--- a/srcpkgs/python3-sip-PyQt5/template
+++ b/srcpkgs/python3-sip-PyQt5/template
@@ -4,7 +4,7 @@ version=12.8.1
 revision=1
 wrksrc="PyQt5_sip-$version"
 build_style=python3-module
-hostmakedepends="python3-devel python3-setuptools sip5"
+hostmakedepends="python3-devel python3-setuptools sip"
 makedepends="python3-devel"
 short_desc="Python 3 PyQt5 SIP bindings with C and C++"
 maintainer="Orphaned <orphan@voidlinux.org>"
@@ -14,6 +14,10 @@ distfiles="${PYPI_SITE}/P/PyQt5_sip/PyQt5_sip-${version}.tar.gz"
 checksum=30e944db9abee9cc757aea16906d4198129558533eb7fadbe48c5da2bd18e0bd
 lib32disabled=yes
 
+post_extract() {
+	mkdir -p PyQt5
+}
+
 post_install() {
-	vlicense /usr/share/licenses/sip5/LICENSE
+	vlicense /usr/share/licenses/sip/LICENSE
 }

From b9b99a48939131cc640c39cb6c560d341f87c13c Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Wed, 13 Jan 2021 07:42:23 +0700
Subject: [PATCH 9/9] sip: add dummy sip5

---
 srcpkgs/sip/template | 6 ++++++
 srcpkgs/sip5         | 1 +
 2 files changed, 7 insertions(+)
 create mode 120000 srcpkgs/sip5

diff --git a/srcpkgs/sip/template b/srcpkgs/sip/template
index 3cca9aa59d5..d7a1186a253 100644
--- a/srcpkgs/sip/template
+++ b/srcpkgs/sip/template
@@ -21,3 +21,9 @@ post_install() {
 	vlicense NOTICE
 	vlicense LICENSE
 }
+
+sip5_package() {
+	short_desc+=" - transition"
+	build_style=meta
+	depends=sip-${version}_${revision}
+}
diff --git a/srcpkgs/sip5 b/srcpkgs/sip5
new file mode 120000
index 00000000000..633f7c0bcce
--- /dev/null
+++ b/srcpkgs/sip5
@@ -0,0 +1 @@
+sip
\ No newline at end of file

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [PR PATCH] [Updated] RFC: rename sip 4.x to sip4, sip5 to sip, update to 6.0.0
  2021-01-08  1:14 [PR PATCH] RFC: rename sip 4.x to sip4, sip5 to sip, update to 6.0.0 sgn
                   ` (8 preceding siblings ...)
  2021-01-13  0:43 ` sgn
@ 2021-01-13 11:55 ` sgn
  2021-01-13 14:27 ` [PR PATCH] [Merged]: " sgn
  10 siblings, 0 replies; 12+ messages in thread
From: sgn @ 2021-01-13 11:55 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 530 bytes --]

There is an updated pull request by sgn against master on the void-packages repository

https://github.com/sgn/void-packages sip-rename
https://github.com/void-linux/void-packages/pull/27753

RFC: rename sip 4.x to sip4, sip5 to sip, update to 6.0.0
- Most of our packages have the convention of using versioned-suffix for old packages
- Have `sip5` package with version 6 is weird to me
- I'm expecting sip 4.x will be phased out soon.

A patch file from https://github.com/void-linux/void-packages/pull/27753.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-sip-rename-27753.patch --]
[-- Type: text/x-diff, Size: 11882 bytes --]

From 1b7ac1be8f3494a776b548f9c9c90796f9957b02 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 08:05:44 +0700
Subject: [PATCH 1/8] sip: rename to sip4

---
 srcpkgs/python3-sip            |  2 +-
 srcpkgs/python3-sip-devel      |  2 +-
 srcpkgs/{sip => sip4}/template | 13 ++++++++-----
 srcpkgs/{sip => sip4}/update   |  0
 4 files changed, 10 insertions(+), 7 deletions(-)
 rename srcpkgs/{sip => sip4}/template (82%)
 rename srcpkgs/{sip => sip4}/update (100%)

diff --git a/srcpkgs/python3-sip b/srcpkgs/python3-sip
index 633f7c0bcce..27dcc148ae7 120000
--- a/srcpkgs/python3-sip
+++ b/srcpkgs/python3-sip
@@ -1 +1 @@
-sip
\ No newline at end of file
+sip4
\ No newline at end of file
diff --git a/srcpkgs/python3-sip-devel b/srcpkgs/python3-sip-devel
index 633f7c0bcce..27dcc148ae7 120000
--- a/srcpkgs/python3-sip-devel
+++ b/srcpkgs/python3-sip-devel
@@ -1 +1 @@
-sip
\ No newline at end of file
+sip4
\ No newline at end of file
diff --git a/srcpkgs/sip/template b/srcpkgs/sip4/template
similarity index 82%
rename from srcpkgs/sip/template
rename to srcpkgs/sip4/template
index 87d0c5c6ed6..30de98f8320 100644
--- a/srcpkgs/sip/template
+++ b/srcpkgs/sip4/template
@@ -1,7 +1,8 @@
-# Template file for 'sip'
-pkgname=sip
+# Template file for 'sip4'
+pkgname=sip4
 version=4.19.24
-revision=3
+revision=4
+wrksrc="sip-$version"
 hostmakedepends="python3-devel"
 makedepends="${hostmakedepends}"
 short_desc="Python extension module generator for C/C++ libraries"
@@ -10,12 +11,14 @@ license="GPL-2.0-only, GPL-3.0-only, custom:SIP"
 homepage="https://riverbankcomputing.com/software/sip/intro"
 distfiles="https://www.riverbankcomputing.com/static/Downloads/sip/${version}/sip-${version}.tar.gz"
 checksum=edcd3790bb01938191eef0f6117de0bf56d1136626c0ddb678f3a558d62e41e5
+replaces="sip<=${version}_${revision}"
+provides="sip-${version}_${revision}"
 
 do_build() {
 	python3 configure.py \
 		CC="${CC}" CFLAGS="${CFLAGS}" CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" \
 		LINK="${CXX}" LINK_SHLIB="${CXX}" LFLAGS="${LDFLAGS}" STRIP="" \
-		INCDIR="${XBPS_CROSS_BASE}/${py3_inc}" ${pyqt5}
+		INCDIR="${XBPS_CROSS_BASE}/${py3_inc}"
 	make ${makejobs}
 }
 
@@ -40,7 +43,7 @@ python3-sip_package() {
 }
 
 python3-sip-devel_package() {
-	depends="python3-sip-${version}_${revision} sip-${version}_${revision}"
+	depends="python3-sip-${version}_${revision} sip4-${version}_${revision}"
 	short_desc="Python3 SIP bindings - development files"
 	pkg_install() {
 		vmove ${py3_inc}
diff --git a/srcpkgs/sip/update b/srcpkgs/sip4/update
similarity index 100%
rename from srcpkgs/sip/update
rename to srcpkgs/sip4/update

From ddd28d598c8027ff7a3906053fc12e93794e9f6b Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Wed, 13 Jan 2021 07:36:15 +0700
Subject: [PATCH 2/8] python3-orocos-kdl: sip renamed to sip4

---
 srcpkgs/python3-orocos-kdl/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/python3-orocos-kdl/template b/srcpkgs/python3-orocos-kdl/template
index 728ed73d780..281ea8978c5 100644
--- a/srcpkgs/python3-orocos-kdl/template
+++ b/srcpkgs/python3-orocos-kdl/template
@@ -6,7 +6,7 @@ wrksrc=orocos_kinematics_dynamics-${version}
 build_wrksrc=python_orocos_kdl
 build_style=cmake
 configure_args="-DPYTHON_VERSION=3 -DSIP_EXECUTABLE=/usr/bin/sip"
-hostmakedepends="python3 python3-sip sip"
+hostmakedepends="python3 python3-sip sip4"
 makedepends="python3-sip-devel python3-devel orocos-kdl-devel eigen3.2"
 depends="python3 python3-sip"
 short_desc="Python3 Bindings for Orocos Kinematics and Dynamics C++ library"

From c7757101f0e5e068c42a6ccef5e60321d5c8bd24 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 08:07:11 +0700
Subject: [PATCH 3/8] sip5: rename to sip

---
 srcpkgs/{sip5 => sip}/template | 15 +++++++++++----
 srcpkgs/{sip5 => sip}/update   |  0
 srcpkgs/sip5                   |  1 +
 3 files changed, 12 insertions(+), 4 deletions(-)
 rename srcpkgs/{sip5 => sip}/template (69%)
 rename srcpkgs/{sip5 => sip}/update (100%)
 create mode 120000 srcpkgs/sip5

diff --git a/srcpkgs/sip5/template b/srcpkgs/sip/template
similarity index 69%
rename from srcpkgs/sip5/template
rename to srcpkgs/sip/template
index b8e3d0bf10d..72577b77f0c 100644
--- a/srcpkgs/sip5/template
+++ b/srcpkgs/sip/template
@@ -1,22 +1,29 @@
-# Template file for 'sip5'
-pkgname=sip5
+# Template file for 'sip'
+pkgname=sip
 version=5.5.0
 revision=1
-wrksrc="sip-$version"
 build_style=python3-module
 hostmakedepends="python3-devel python3-setuptools python3-packaging python3-toml"
 makedepends="python3-devel"
 depends="python3-setuptools python3-packaging python3-toml"
-short_desc="SIP 5 - Python 3 bindings generator for C/C++ libraries"
+short_desc="SIP - Python 3 bindings generator for C/C++ libraries"
 maintainer="Đoàn Trần Công Danh <congdanhqx@gmail.com>"
 license="GPL-2.0-only, GPL-3.0-only, custom:SIP"
 homepage="https://riverbankcomputing.com/software/sip/intro"
 distfiles="${PYPI_SITE}/s/sip/sip-${version}.tar.gz"
 checksum=5d024c419b30fea8a6de8c71a560c7ab0bc3c221fbfb14d55a5b865bd58eaac5
 lib32disabled=yes
+replaces="sip5<=${version}_${revision}"
+provides="sip5-${version}_${revision}"
 
 post_install() {
 	sed -n '1,/SUCH DAMAGE/p' sipbuild/project.py >NOTICE
 	vlicense NOTICE
 	vlicense LICENSE
 }
+
+sip5_package() {
+	short_desc+=" - transition"
+	build_style=meta
+	depends="sip>=${version}_${revision}"
+}
diff --git a/srcpkgs/sip5/update b/srcpkgs/sip/update
similarity index 100%
rename from srcpkgs/sip5/update
rename to srcpkgs/sip/update
diff --git a/srcpkgs/sip5 b/srcpkgs/sip5
new file mode 120000
index 00000000000..633f7c0bcce
--- /dev/null
+++ b/srcpkgs/sip5
@@ -0,0 +1 @@
+sip
\ No newline at end of file

From 9bdbb05ed4fc51b9276dbc751b8df45ad09ac40a Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 08:08:58 +0700
Subject: [PATCH 4/8] sip: update to 6.0.0.

---
 srcpkgs/sip/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/sip/template b/srcpkgs/sip/template
index 72577b77f0c..eb7a4ac56f4 100644
--- a/srcpkgs/sip/template
+++ b/srcpkgs/sip/template
@@ -1,6 +1,6 @@
 # Template file for 'sip'
 pkgname=sip
-version=5.5.0
+version=6.0.0
 revision=1
 build_style=python3-module
 hostmakedepends="python3-devel python3-setuptools python3-packaging python3-toml"
@@ -11,7 +11,7 @@ maintainer="Đoàn Trần Công Danh <congdanhqx@gmail.com>"
 license="GPL-2.0-only, GPL-3.0-only, custom:SIP"
 homepage="https://riverbankcomputing.com/software/sip/intro"
 distfiles="${PYPI_SITE}/s/sip/sip-${version}.tar.gz"
-checksum=5d024c419b30fea8a6de8c71a560c7ab0bc3c221fbfb14d55a5b865bd58eaac5
+checksum=6185160e1aa8e167b5919c4761cbbf68cc7478d34fb655b3a28b3eb9acb5943a
 lib32disabled=yes
 replaces="sip5<=${version}_${revision}"
 provides="sip5-${version}_${revision}"

From 09937ba3c28c91074489bd86db5ace7b1381963a Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 07:52:02 +0700
Subject: [PATCH 5/8] python3-PyQt-builder: update to 1.7.0.

---
 srcpkgs/python3-PyQt-builder/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-PyQt-builder/template b/srcpkgs/python3-PyQt-builder/template
index 1d6c8fa73d4..956a6ab1cde 100644
--- a/srcpkgs/python3-PyQt-builder/template
+++ b/srcpkgs/python3-PyQt-builder/template
@@ -1,17 +1,17 @@
 # Template file for 'python3-PyQt-builder'
 pkgname=python3-PyQt-builder
-version=1.6.0
+version=1.7.0
 revision=1
 wrksrc=PyQt-builder-$version
 build_style=python3-module
-hostmakedepends="python3-setuptools"
-depends="python3 sip5>=5.5.0"
+hostmakedepends="python3-setuptools sip"
+depends="python3 sip>=6.0.0"
 short_desc="PEP 517 compliant PyQt build system"
 maintainer="Đoàn Trần Công Danh <congdanhqx@gmail.com>"
 license="GPL-2.0-only, GPL-3.0-only, custom:SIP"
 homepage="https://www.riverbankcomputing.com/software/pyqt/"
 distfiles="$PYPI_SITE/P/PyQt-builder/PyQt-builder-$version.tar.gz"
-checksum=fb80f01407718bfc68f78e276f2543fcfc5b5900b1187c1fd1f2ff51a6f2a13c
+checksum=b6e3c826f98ff4006ecb34df491ac6062a023b63a32e9f9f50904867aff72f2e
 
 post_install() {
 	rm -rf $DESTDIR/$py3_sitelib/pyqtbuild/bundle

From 669b9eaf20cd315b5f8e5ac2db3736345ab12b45 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 07:54:12 +0700
Subject: [PATCH 6/8] python3-PyQt5-webengine: sip5 has been renamed to sip

---
 srcpkgs/python3-PyQt5-webengine/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/python3-PyQt5-webengine/template b/srcpkgs/python3-PyQt5-webengine/template
index 920cae92627..ae385283b7f 100644
--- a/srcpkgs/python3-PyQt5-webengine/template
+++ b/srcpkgs/python3-PyQt5-webengine/template
@@ -3,7 +3,7 @@ pkgname=python3-PyQt5-webengine
 version=5.15.2
 revision=1
 wrksrc="PyQtWebEngine-${version}"
-hostmakedepends="pkg-config qt5-qmake python3-PyQt5 sip5 qt5-webengine-devel
+hostmakedepends="pkg-config qt5-qmake python3-PyQt5 sip qt5-webengine-devel
  python3-PyQt-builder python3-PyQt5-devel
  qt5-declarative-devel qt5-webchannel-devel qt5-location-devel"
 makedepends="qt5-declarative-devel qt5-webchannel-devel qt5-location-devel

From 732d5d844acb130e28bb2d471a26773224b065b9 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 07:55:20 +0700
Subject: [PATCH 7/8] python3-PyQt5: depends on new sip

---
 srcpkgs/python3-PyQt5/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-PyQt5/template b/srcpkgs/python3-PyQt5/template
index bac89e57965..2a2733b439c 100644
--- a/srcpkgs/python3-PyQt5/template
+++ b/srcpkgs/python3-PyQt5/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-PyQt5'
 pkgname=python3-PyQt5
 version=5.15.2
-revision=1
+revision=2
 _sipver=12.8.0
 wrksrc="PyQt5-${version}"
 build_helper=qemu
@@ -193,7 +193,7 @@ python3-PyQt5-devel-tools_package() {
 	}
 }
 python3-PyQt5-devel_package() {
-	depends="sip5 python3-PyQt5-${version}_${revision}"
+	depends="sip>=6.0.0 python3-PyQt5-${version}_${revision}"
 	short_desc+=" - development files"
 	pkg_install() {
 		vmove ${py3_sitelib}/PyQt5/bindings

From 0415a476e24f5c05ae90907913e4b97e66f6b5df Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 8 Jan 2021 07:56:13 +0700
Subject: [PATCH 8/8] python3-sip-PyQt5: build with new sip

---
 srcpkgs/python3-sip-PyQt5/template | 9 +++++++--
 1 file changed, 7 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-sip-PyQt5/template b/srcpkgs/python3-sip-PyQt5/template
index e1d1c45603d..e144a1e91f2 100644
--- a/srcpkgs/python3-sip-PyQt5/template
+++ b/srcpkgs/python3-sip-PyQt5/template
@@ -4,7 +4,7 @@ version=12.8.1
 revision=1
 wrksrc="PyQt5_sip-$version"
 build_style=python3-module
-hostmakedepends="python3-devel python3-setuptools sip5"
+hostmakedepends="python3-devel python3-setuptools sip"
 makedepends="python3-devel"
 short_desc="Python 3 PyQt5 SIP bindings with C and C++"
 maintainer="Orphaned <orphan@voidlinux.org>"
@@ -14,6 +14,11 @@ distfiles="${PYPI_SITE}/P/PyQt5_sip/PyQt5_sip-${version}.tar.gz"
 checksum=30e944db9abee9cc757aea16906d4198129558533eb7fadbe48c5da2bd18e0bd
 lib32disabled=yes
 
+post_extract() {
+	# for do_check
+	mkdir -p PyQt5
+}
+
 post_install() {
-	vlicense /usr/share/licenses/sip5/LICENSE
+	vlicense /usr/share/licenses/sip/LICENSE
 }

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [PR PATCH] [Merged]: RFC: rename sip 4.x to sip4, sip5 to sip, update to 6.0.0
  2021-01-08  1:14 [PR PATCH] RFC: rename sip 4.x to sip4, sip5 to sip, update to 6.0.0 sgn
                   ` (9 preceding siblings ...)
  2021-01-13 11:55 ` sgn
@ 2021-01-13 14:27 ` sgn
  10 siblings, 0 replies; 12+ messages in thread
From: sgn @ 2021-01-13 14:27 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 379 bytes --]

There's a merged pull request on the void-packages repository

RFC: rename sip 4.x to sip4, sip5 to sip, update to 6.0.0
https://github.com/void-linux/void-packages/pull/27753

Description:
- Most of our packages have the convention of using versioned-suffix for old packages
- Have `sip5` package with version 6 is weird to me
- I'm expecting sip 4.x will be phased out soon.

^ permalink raw reply	[flat|nested] 12+ messages in thread

end of thread, other threads:[~2021-01-13 14:27 UTC | newest]

Thread overview: 12+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-01-08  1:14 [PR PATCH] RFC: rename sip 4.x to sip4, sip5 to sip, update to 6.0.0 sgn
2021-01-08  1:20 ` [PR PATCH] [Updated] " sgn
2021-01-08  1:26 ` sgn
2021-01-08  2:11 ` sgn
2021-01-08  2:13 ` sgn
2021-01-08  5:13 ` ericonr
2021-01-08 14:11 ` sgn
2021-01-09  2:20 ` [PR PATCH] [Updated] " sgn
2021-01-13  0:38 ` sgn
2021-01-13  0:43 ` sgn
2021-01-13 11:55 ` sgn
2021-01-13 14:27 ` [PR PATCH] [Merged]: " sgn

Github messages for voidlinux

This inbox may be cloned and mirrored by anyone:

	git clone --mirror http://inbox.vuxu.org/voidlinux-github

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V1 voidlinux-github voidlinux-github/ http://inbox.vuxu.org/voidlinux-github \
		voidlinux-github@inbox.vuxu.org
	public-inbox-index voidlinux-github

Example config snippet for mirrors.
Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.github.voidlinux


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git