Github messages for voidlinux
 help / color / mirror / Atom feed
* [PR PATCH] python3-pytest-mock: update to 3.5.1
@ 2021-02-20  1:34 heliocat
  2021-02-20  1:54 ` [PR PATCH] [Updated] " heliocat
                   ` (10 more replies)
  0 siblings, 11 replies; 12+ messages in thread
From: heliocat @ 2021-02-20  1:34 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1780 bytes --]

There is a new pull request by heliocat against master on the void-packages repository

https://github.com/heliocat/void-packages python3-pytest-mock
https://github.com/void-linux/void-packages/pull/28903

python3-pytest-mock: update to 3.5.1
Breaking changes:
drop deprecated mock alias to mocker
drop python 2.7 and 3.4 support

<!-- Mark items with [x] where applicable -->

#### General
- [ ] This is a new package and it conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements)

#### Have the results of the proposed changes been tested?
- [ ] I use the packages affected by the proposed changes on a regular basis and confirm this PR works for me
- [x] I generally don't use the affected packages but briefly tested this PR

<!--
If GitHub CI cannot be used to validate the build result (for example, if the
build is likely to take several hours), make sure to
[skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration).
When skipping CI, uncomment and fill out the following section.
Note: for builds that are likely to complete in less than 2 hours, it is not
acceptable to skip CI.
-->
<!-- 
#### Does it build and run successfully? 
(Please choose at least one native build and, if supported, at least one cross build. More are better.)
- [ ] I built this PR locally for my native architecture, (ARCH-LIBC)
- [ ] I built this PR locally for these architectures (if supported. mark crossbuilds):
  - [ ] aarch64-musl
  - [ ] armv7l
  - [ ] armv6l-musl
-->
Updating some low-hanging fruit, I noted any breaking changes as documented.

A patch file from https://github.com/void-linux/void-packages/pull/28903.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-python3-pytest-mock-28903.patch --]
[-- Type: text/x-diff, Size: 1240 bytes --]

From 3b3ea92b3aea2b5eddf72e37c3e9b3398e65e56d Mon Sep 17 00:00:00 2001
From: Colin Booth <colin@heliocat.net>
Date: Fri, 19 Feb 2021 00:56:14 -0800
Subject: [PATCH] python3-pytest-mock: update to 3.5.1

Breaking changes:
drop deprecated mock alias to mocker
drop python 2.7 and 3.4 support
---
 srcpkgs/python3-pytest-mock/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-pytest-mock/template b/srcpkgs/python3-pytest-mock/template
index c1dc8183009..1d7b4ceedfe 100644
--- a/srcpkgs/python3-pytest-mock/template
+++ b/srcpkgs/python3-pytest-mock/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-pytest-mock'
 pkgname=python3-pytest-mock
-version=1.10.4
-revision=4
+version=3.5.1
+revision=1
 wrksrc="${pkgname#*-}-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -12,7 +12,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://github.com/pytest-dev/pytest-mock/"
 distfiles="${PYPI_SITE}/p/pytest-mock/pytest-mock-${version}.tar.gz"
-checksum=5bf5771b1db93beac965a7347dc81c675ec4090cb841e49d9d34637a25c30568
+checksum=a1e2aba6af9560d313c642dae7e00a2a12b022b80301d9d7fc8ec6858e1dd9fc
 
 pre_build() {
 	sed -i setup.py \

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [PR PATCH] [Updated] python3-pytest-mock: update to 3.5.1
  2021-02-20  1:34 [PR PATCH] python3-pytest-mock: update to 3.5.1 heliocat
@ 2021-02-20  1:54 ` heliocat
  2021-02-20 19:53 ` [PR REVIEW] " ericonr
                   ` (9 subsequent siblings)
  10 siblings, 0 replies; 12+ messages in thread
From: heliocat @ 2021-02-20  1:54 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1785 bytes --]

There is an updated pull request by heliocat against master on the void-packages repository

https://github.com/heliocat/void-packages python3-pytest-mock
https://github.com/void-linux/void-packages/pull/28903

python3-pytest-mock: update to 3.5.1
Breaking changes:
drop deprecated mock alias to mocker
drop python 2.7 and 3.4 support

<!-- Mark items with [x] where applicable -->

#### General
- [ ] This is a new package and it conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements)

#### Have the results of the proposed changes been tested?
- [ ] I use the packages affected by the proposed changes on a regular basis and confirm this PR works for me
- [x] I generally don't use the affected packages but briefly tested this PR

<!--
If GitHub CI cannot be used to validate the build result (for example, if the
build is likely to take several hours), make sure to
[skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration).
When skipping CI, uncomment and fill out the following section.
Note: for builds that are likely to complete in less than 2 hours, it is not
acceptable to skip CI.
-->
<!-- 
#### Does it build and run successfully? 
(Please choose at least one native build and, if supported, at least one cross build. More are better.)
- [ ] I built this PR locally for my native architecture, (ARCH-LIBC)
- [ ] I built this PR locally for these architectures (if supported. mark crossbuilds):
  - [ ] aarch64-musl
  - [ ] armv7l
  - [ ] armv6l-musl
-->
Updating some low-hanging fruit, I noted any breaking changes as documented.

A patch file from https://github.com/void-linux/void-packages/pull/28903.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-python3-pytest-mock-28903.patch --]
[-- Type: text/x-diff, Size: 1580 bytes --]

From 3f661d99c1dacf8a0eb99ffe9c6389b7fda1ce81 Mon Sep 17 00:00:00 2001
From: Colin Booth <colin@heliocat.net>
Date: Fri, 19 Feb 2021 00:56:14 -0800
Subject: [PATCH] python3-pytest-mock: update to 3.5.1

Breaking changes:
drop deprecated mock alias to mocker
drop python 2.7 and 3.4 support

Note that pytest-mock needs pytest-mock installed to be able to test
itself so I'm stubbing out do_check. If someone wants to take a stab at
getting this cleaned up be my guest.
---
 srcpkgs/python3-pytest-mock/template | 11 ++++++++---
 1 file changed, 8 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-pytest-mock/template b/srcpkgs/python3-pytest-mock/template
index c1dc8183009..7a930f8841b 100644
--- a/srcpkgs/python3-pytest-mock/template
+++ b/srcpkgs/python3-pytest-mock/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-pytest-mock'
 pkgname=python3-pytest-mock
-version=1.10.4
-revision=4
+version=3.5.1
+revision=1
 wrksrc="${pkgname#*-}-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -12,7 +12,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://github.com/pytest-dev/pytest-mock/"
 distfiles="${PYPI_SITE}/p/pytest-mock/pytest-mock-${version}.tar.gz"
-checksum=5bf5771b1db93beac965a7347dc81c675ec4090cb841e49d9d34637a25c30568
+checksum=a1e2aba6af9560d313c642dae7e00a2a12b022b80301d9d7fc8ec6858e1dd9fc
 
 pre_build() {
 	sed -i setup.py \
@@ -20,6 +20,11 @@ pre_build() {
 		-e "s|use_scm_version=.*|version='${version}',|"
 }
 
+do_check() {
+	:
+}
+
+
 post_install() {
 	vlicense LICENSE
 }

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [PR REVIEW] python3-pytest-mock: update to 3.5.1
  2021-02-20  1:34 [PR PATCH] python3-pytest-mock: update to 3.5.1 heliocat
  2021-02-20  1:54 ` [PR PATCH] [Updated] " heliocat
@ 2021-02-20 19:53 ` ericonr
  2021-02-20 19:54 ` ericonr
                   ` (8 subsequent siblings)
  10 siblings, 0 replies; 12+ messages in thread
From: ericonr @ 2021-02-20 19:53 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 170 bytes --]

New review comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/pull/28903#discussion_r579700996

Comment:
Please move to `vsed`


^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [PR REVIEW] python3-pytest-mock: update to 3.5.1
  2021-02-20  1:34 [PR PATCH] python3-pytest-mock: update to 3.5.1 heliocat
  2021-02-20  1:54 ` [PR PATCH] [Updated] " heliocat
  2021-02-20 19:53 ` [PR REVIEW] " ericonr
@ 2021-02-20 19:54 ` ericonr
  2021-02-20 20:05 ` ericonr
                   ` (7 subsequent siblings)
  10 siblings, 0 replies; 12+ messages in thread
From: ericonr @ 2021-02-20 19:54 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 188 bytes --]

New review comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/pull/28903#discussion_r579701020

Comment:
Use `make_check=no` with a comment why ;)

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: python3-pytest-mock: update to 3.5.1
  2021-02-20  1:34 [PR PATCH] python3-pytest-mock: update to 3.5.1 heliocat
                   ` (2 preceding siblings ...)
  2021-02-20 19:54 ` ericonr
@ 2021-02-20 20:05 ` ericonr
  2021-02-20 20:10 ` ericonr
                   ` (6 subsequent siblings)
  10 siblings, 0 replies; 12+ messages in thread
From: ericonr @ 2021-02-20 20:05 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 247 bytes --]

New comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/pull/28903#issuecomment-782741723

Comment:
I'm running tests for package which use this one. So far `python3-natsort`, `python3-aiohttp2` have failed

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: python3-pytest-mock: update to 3.5.1
  2021-02-20  1:34 [PR PATCH] python3-pytest-mock: update to 3.5.1 heliocat
                   ` (3 preceding siblings ...)
  2021-02-20 20:05 ` ericonr
@ 2021-02-20 20:10 ` ericonr
  2021-02-20 20:27 ` ericonr
                   ` (5 subsequent siblings)
  10 siblings, 0 replies; 12+ messages in thread
From: ericonr @ 2021-02-20 20:10 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 261 bytes --]

New comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/pull/28903#issuecomment-782741723

Comment:
I'm running tests for package which use this one. So far `python3-natsort`, `python3-aiohttp2` have failed

Also `tox`

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: python3-pytest-mock: update to 3.5.1
  2021-02-20  1:34 [PR PATCH] python3-pytest-mock: update to 3.5.1 heliocat
                   ` (4 preceding siblings ...)
  2021-02-20 20:10 ` ericonr
@ 2021-02-20 20:27 ` ericonr
  2021-02-20 22:18 ` heliocat
                   ` (4 subsequent siblings)
  10 siblings, 0 replies; 12+ messages in thread
From: ericonr @ 2021-02-20 20:27 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 217 bytes --]

New comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/pull/28903#issuecomment-782744681

Comment:
All three also fail with old -mock, so I think we can stick with the update.

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: python3-pytest-mock: update to 3.5.1
  2021-02-20  1:34 [PR PATCH] python3-pytest-mock: update to 3.5.1 heliocat
                   ` (5 preceding siblings ...)
  2021-02-20 20:27 ` ericonr
@ 2021-02-20 22:18 ` heliocat
  2021-02-20 22:34 ` [PR PATCH] [Updated] " heliocat
                   ` (3 subsequent siblings)
  10 siblings, 0 replies; 12+ messages in thread
From: heliocat @ 2021-02-20 22:18 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 349 bytes --]

New comment by heliocat on void-packages repository

https://github.com/void-linux/void-packages/pull/28903#issuecomment-782757937

Comment:
I just ran through all of the dependent packages. natsort and aiohttp2 both fail their tests at the same places and at the same rates. Tox passed both old and new tests with the skip section in the template.

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [PR PATCH] [Updated] python3-pytest-mock: update to 3.5.1
  2021-02-20  1:34 [PR PATCH] python3-pytest-mock: update to 3.5.1 heliocat
                   ` (6 preceding siblings ...)
  2021-02-20 22:18 ` heliocat
@ 2021-02-20 22:34 ` heliocat
  2021-02-22 18:11 ` [PR REVIEW] " heliocat
                   ` (2 subsequent siblings)
  10 siblings, 0 replies; 12+ messages in thread
From: heliocat @ 2021-02-20 22:34 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1785 bytes --]

There is an updated pull request by heliocat against master on the void-packages repository

https://github.com/heliocat/void-packages python3-pytest-mock
https://github.com/void-linux/void-packages/pull/28903

python3-pytest-mock: update to 3.5.1
Breaking changes:
drop deprecated mock alias to mocker
drop python 2.7 and 3.4 support

<!-- Mark items with [x] where applicable -->

#### General
- [ ] This is a new package and it conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements)

#### Have the results of the proposed changes been tested?
- [ ] I use the packages affected by the proposed changes on a regular basis and confirm this PR works for me
- [x] I generally don't use the affected packages but briefly tested this PR

<!--
If GitHub CI cannot be used to validate the build result (for example, if the
build is likely to take several hours), make sure to
[skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration).
When skipping CI, uncomment and fill out the following section.
Note: for builds that are likely to complete in less than 2 hours, it is not
acceptable to skip CI.
-->
<!-- 
#### Does it build and run successfully? 
(Please choose at least one native build and, if supported, at least one cross build. More are better.)
- [ ] I built this PR locally for my native architecture, (ARCH-LIBC)
- [ ] I built this PR locally for these architectures (if supported. mark crossbuilds):
  - [ ] aarch64-musl
  - [ ] armv7l
  - [ ] armv6l-musl
-->
Updating some low-hanging fruit, I noted any breaking changes as documented.

A patch file from https://github.com/void-linux/void-packages/pull/28903.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-python3-pytest-mock-28903.patch --]
[-- Type: text/x-diff, Size: 1464 bytes --]

From a3a321cc6d9d245ccc868c968249ff7a4c10c8f5 Mon Sep 17 00:00:00 2001
From: Colin Booth <colin@heliocat.net>
Date: Fri, 19 Feb 2021 00:56:14 -0800
Subject: [PATCH] python3-pytest-mock: update to 3.5.1

Breaking changes:
drop deprecated mock alias to mocker
drop python 2.7 and 3.4 support
---
 srcpkgs/python3-pytest-mock/template | 12 ++++++++----
 1 file changed, 8 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-pytest-mock/template b/srcpkgs/python3-pytest-mock/template
index c1dc8183009..43ce2c84270 100644
--- a/srcpkgs/python3-pytest-mock/template
+++ b/srcpkgs/python3-pytest-mock/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-pytest-mock'
 pkgname=python3-pytest-mock
-version=1.10.4
-revision=4
+version=3.5.1
+revision=1
 wrksrc="${pkgname#*-}-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -12,10 +12,14 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://github.com/pytest-dev/pytest-mock/"
 distfiles="${PYPI_SITE}/p/pytest-mock/pytest-mock-${version}.tar.gz"
-checksum=5bf5771b1db93beac965a7347dc81c675ec4090cb841e49d9d34637a25c30568
+checksum=a1e2aba6af9560d313c642dae7e00a2a12b022b80301d9d7fc8ec6858e1dd9fc
+
+# pytest-mock requires pytest-mock to be installed so it'll always fail during
+# packaging
+make_check=no
 
 pre_build() {
-	sed -i setup.py \
+	vsed -i setup.py \
 		-e '/setup_requires=/d' \
 		-e "s|use_scm_version=.*|version='${version}',|"
 }

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [PR REVIEW] python3-pytest-mock: update to 3.5.1
  2021-02-20  1:34 [PR PATCH] python3-pytest-mock: update to 3.5.1 heliocat
                   ` (7 preceding siblings ...)
  2021-02-20 22:34 ` [PR PATCH] [Updated] " heliocat
@ 2021-02-22 18:11 ` heliocat
  2021-02-22 18:12 ` heliocat
  2021-02-22 19:13 ` [PR PATCH] [Merged]: " ericonr
  10 siblings, 0 replies; 12+ messages in thread
From: heliocat @ 2021-02-22 18:11 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 152 bytes --]

New review comment by heliocat on void-packages repository

https://github.com/void-linux/void-packages/pull/28903#discussion_r580474190

Comment:
done

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [PR REVIEW] python3-pytest-mock: update to 3.5.1
  2021-02-20  1:34 [PR PATCH] python3-pytest-mock: update to 3.5.1 heliocat
                   ` (8 preceding siblings ...)
  2021-02-22 18:11 ` [PR REVIEW] " heliocat
@ 2021-02-22 18:12 ` heliocat
  2021-02-22 19:13 ` [PR PATCH] [Merged]: " ericonr
  10 siblings, 0 replies; 12+ messages in thread
From: heliocat @ 2021-02-22 18:12 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 152 bytes --]

New review comment by heliocat on void-packages repository

https://github.com/void-linux/void-packages/pull/28903#discussion_r580474418

Comment:
done

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [PR PATCH] [Merged]: python3-pytest-mock: update to 3.5.1
  2021-02-20  1:34 [PR PATCH] python3-pytest-mock: update to 3.5.1 heliocat
                   ` (9 preceding siblings ...)
  2021-02-22 18:12 ` heliocat
@ 2021-02-22 19:13 ` ericonr
  10 siblings, 0 replies; 12+ messages in thread
From: ericonr @ 2021-02-22 19:13 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1615 bytes --]

There's a merged pull request on the void-packages repository

python3-pytest-mock: update to 3.5.1
https://github.com/void-linux/void-packages/pull/28903

Description:
Breaking changes:
drop deprecated mock alias to mocker
drop python 2.7 and 3.4 support

<!-- Mark items with [x] where applicable -->

#### General
- [ ] This is a new package and it conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements)

#### Have the results of the proposed changes been tested?
- [ ] I use the packages affected by the proposed changes on a regular basis and confirm this PR works for me
- [x] I generally don't use the affected packages but briefly tested this PR

<!--
If GitHub CI cannot be used to validate the build result (for example, if the
build is likely to take several hours), make sure to
[skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration).
When skipping CI, uncomment and fill out the following section.
Note: for builds that are likely to complete in less than 2 hours, it is not
acceptable to skip CI.
-->
<!-- 
#### Does it build and run successfully? 
(Please choose at least one native build and, if supported, at least one cross build. More are better.)
- [ ] I built this PR locally for my native architecture, (ARCH-LIBC)
- [ ] I built this PR locally for these architectures (if supported. mark crossbuilds):
  - [ ] aarch64-musl
  - [ ] armv7l
  - [ ] armv6l-musl
-->
Updating some low-hanging fruit, I noted any breaking changes as documented.

^ permalink raw reply	[flat|nested] 12+ messages in thread

end of thread, other threads:[~2021-02-22 19:13 UTC | newest]

Thread overview: 12+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-02-20  1:34 [PR PATCH] python3-pytest-mock: update to 3.5.1 heliocat
2021-02-20  1:54 ` [PR PATCH] [Updated] " heliocat
2021-02-20 19:53 ` [PR REVIEW] " ericonr
2021-02-20 19:54 ` ericonr
2021-02-20 20:05 ` ericonr
2021-02-20 20:10 ` ericonr
2021-02-20 20:27 ` ericonr
2021-02-20 22:18 ` heliocat
2021-02-20 22:34 ` [PR PATCH] [Updated] " heliocat
2021-02-22 18:11 ` [PR REVIEW] " heliocat
2021-02-22 18:12 ` heliocat
2021-02-22 19:13 ` [PR PATCH] [Merged]: " ericonr

Github messages for voidlinux

This inbox may be cloned and mirrored by anyone:

	git clone --mirror http://inbox.vuxu.org/voidlinux-github

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V1 voidlinux-github voidlinux-github/ http://inbox.vuxu.org/voidlinux-github \
		voidlinux-github@inbox.vuxu.org
	public-inbox-index voidlinux-github

Example config snippet for mirrors.
Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.github.voidlinux


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git