Github messages for voidlinux
 help / color / mirror / Atom feed
* [PR PATCH] ansible-base: add python3-packaging as a runtime dependency
@ 2021-05-03 17:25 dstolfa
  2021-05-04  1:59 ` ericonr
                   ` (2 more replies)
  0 siblings, 3 replies; 4+ messages in thread
From: dstolfa @ 2021-05-03 17:25 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1525 bytes --]

There is a new pull request by dstolfa against master on the void-packages repository

https://github.com/dstolfa/void-packages master
https://github.com/void-linux/void-packages/pull/30644

ansible-base: add python3-packaging as a runtime dependency
Running the current ansible package results in a warning:

"[WARNING]: packaging Python module unavailable; unable to validate collection Ansible version requirements"

A simple web search leads to the Ansible developers stating that
python3-packaging is a dependency for ansible-base[1], and this commit
adds it.

[1]: https://github.com/ansible/ansible/issues/72117


#### General
- [ ] This is a new package and it conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements)

#### Have the results of the proposed changes been tested?
- [x] I use the packages affected by the proposed changes on a regular basis and confirm this PR works for me
- [ ] I generally don't use the affected packages but briefly tested this PR


#### Does it build and run successfully? 
(Please choose at least one native build and, if supported, at least one cross build. More are better.)
- [x] I built this PR locally for my native architecture, (ARCH-LIBC)
- [x] I built this PR locally for these architectures (if supported. mark crossbuilds):
  - [x] aarch64-musl
  - [x] armv7l
  - [x] armv6l-musl



A patch file from https://github.com/void-linux/void-packages/pull/30644.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-master-30644.patch --]
[-- Type: text/x-diff, Size: 1271 bytes --]

From ba3bf15be283c751865ed504d00e4eb0891c9f5a Mon Sep 17 00:00:00 2001
From: Domagoj Stolfa <ds815@gmx.com>
Date: Mon, 3 May 2021 18:17:02 +0100
Subject: [PATCH] ansible-base: add python3-packaging as a runtime dependency

Running the current ansible package results in a warning:

"[WARNING]: packaging Python module unavailable; unable to validate collection Ansible version requirements"

A simple web search leads to the Ansible developers stating that
python3-packaging is a dependency for ansible-base[1], and this commit
adds it.

[1]: https://github.com/ansible/ansible/issues/72117
---
 srcpkgs/ansible-base/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/ansible-base/template b/srcpkgs/ansible-base/template
index 195856106a84..68036326c93d 100644
--- a/srcpkgs/ansible-base/template
+++ b/srcpkgs/ansible-base/template
@@ -5,7 +5,7 @@ revision=1
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="${hostmakedepends} python3-cryptography python3-Jinja2 python3-paramiko
- python3-yaml"
+ python3-yaml python3-packaging"
 short_desc="Simple deployment, configuration management and execution framework"
 maintainer="Jan Christian Grünhage <jan.christian@gruenhage.xyz>"
 license="GPL-3.0-or-later"

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: ansible-base: add python3-packaging as a runtime dependency
  2021-05-03 17:25 [PR PATCH] ansible-base: add python3-packaging as a runtime dependency dstolfa
@ 2021-05-04  1:59 ` ericonr
  2021-05-04  7:54 ` [PR PATCH] [Updated] " dstolfa
  2021-05-04 21:04 ` [PR PATCH] [Merged]: " ericonr
  2 siblings, 0 replies; 4+ messages in thread
From: ericonr @ 2021-05-04  1:59 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 205 bytes --]

New comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/pull/30644#issuecomment-831641489

Comment:
You need to increase the revision for the package to be rebuilt.

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PR PATCH] [Updated] ansible-base: add python3-packaging as a runtime dependency
  2021-05-03 17:25 [PR PATCH] ansible-base: add python3-packaging as a runtime dependency dstolfa
  2021-05-04  1:59 ` ericonr
@ 2021-05-04  7:54 ` dstolfa
  2021-05-04 21:04 ` [PR PATCH] [Merged]: " ericonr
  2 siblings, 0 replies; 4+ messages in thread
From: dstolfa @ 2021-05-04  7:54 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1530 bytes --]

There is an updated pull request by dstolfa against master on the void-packages repository

https://github.com/dstolfa/void-packages master
https://github.com/void-linux/void-packages/pull/30644

ansible-base: add python3-packaging as a runtime dependency
Running the current ansible package results in a warning:

"[WARNING]: packaging Python module unavailable; unable to validate collection Ansible version requirements"

A simple web search leads to the Ansible developers stating that
python3-packaging is a dependency for ansible-base[1], and this commit
adds it.

[1]: https://github.com/ansible/ansible/issues/72117


#### General
- [ ] This is a new package and it conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements)

#### Have the results of the proposed changes been tested?
- [x] I use the packages affected by the proposed changes on a regular basis and confirm this PR works for me
- [ ] I generally don't use the affected packages but briefly tested this PR


#### Does it build and run successfully? 
(Please choose at least one native build and, if supported, at least one cross build. More are better.)
- [x] I built this PR locally for my native architecture, (ARCH-LIBC)
- [x] I built this PR locally for these architectures (if supported. mark crossbuilds):
  - [x] aarch64-musl
  - [x] armv7l
  - [x] armv6l-musl



A patch file from https://github.com/void-linux/void-packages/pull/30644.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-master-30644.patch --]
[-- Type: text/x-diff, Size: 1364 bytes --]

From e35043bf6a6dfe0bbb15e46d804377f01a46b22d Mon Sep 17 00:00:00 2001
From: Domagoj Stolfa <ds815@gmx.com>
Date: Mon, 3 May 2021 18:17:02 +0100
Subject: [PATCH] ansible-base: add python3-packaging as a runtime dependency

Running the current ansible package results in a warning:

"[WARNING]: packaging Python module unavailable; unable to validate collection Ansible version requirements"

A simple web search leads to the Ansible developers stating that
python3-packaging is a dependency for ansible-base[1], and this commit
adds it.

[1]: https://github.com/ansible/ansible/issues/72117
---
 srcpkgs/ansible-base/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/ansible-base/template b/srcpkgs/ansible-base/template
index 195856106a84..1d959c2367c3 100644
--- a/srcpkgs/ansible-base/template
+++ b/srcpkgs/ansible-base/template
@@ -1,11 +1,11 @@
 # Template file for 'ansible-base'
 pkgname=ansible-base
 version=2.10.8
-revision=1
+revision=2
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="${hostmakedepends} python3-cryptography python3-Jinja2 python3-paramiko
- python3-yaml"
+ python3-yaml python3-packaging"
 short_desc="Simple deployment, configuration management and execution framework"
 maintainer="Jan Christian Grünhage <jan.christian@gruenhage.xyz>"
 license="GPL-3.0-or-later"

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PR PATCH] [Merged]: ansible-base: add python3-packaging as a runtime dependency
  2021-05-03 17:25 [PR PATCH] ansible-base: add python3-packaging as a runtime dependency dstolfa
  2021-05-04  1:59 ` ericonr
  2021-05-04  7:54 ` [PR PATCH] [Updated] " dstolfa
@ 2021-05-04 21:04 ` ericonr
  2 siblings, 0 replies; 4+ messages in thread
From: ericonr @ 2021-05-04 21:04 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1375 bytes --]

There's a merged pull request on the void-packages repository

ansible-base: add python3-packaging as a runtime dependency
https://github.com/void-linux/void-packages/pull/30644

Description:
Running the current ansible package results in a warning:

"[WARNING]: packaging Python module unavailable; unable to validate collection Ansible version requirements"

A simple web search leads to the Ansible developers stating that
python3-packaging is a dependency for ansible-base[1], and this commit
adds it.

[1]: https://github.com/ansible/ansible/issues/72117


#### General
- [ ] This is a new package and it conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements)

#### Have the results of the proposed changes been tested?
- [x] I use the packages affected by the proposed changes on a regular basis and confirm this PR works for me
- [ ] I generally don't use the affected packages but briefly tested this PR


#### Does it build and run successfully? 
(Please choose at least one native build and, if supported, at least one cross build. More are better.)
- [x] I built this PR locally for my native architecture, (ARCH-LIBC)
- [x] I built this PR locally for these architectures (if supported. mark crossbuilds):
  - [x] aarch64-musl
  - [x] armv7l
  - [x] armv6l-musl



^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2021-05-04 21:04 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-05-03 17:25 [PR PATCH] ansible-base: add python3-packaging as a runtime dependency dstolfa
2021-05-04  1:59 ` ericonr
2021-05-04  7:54 ` [PR PATCH] [Updated] " dstolfa
2021-05-04 21:04 ` [PR PATCH] [Merged]: " ericonr

Github messages for voidlinux

This inbox may be cloned and mirrored by anyone:

	git clone --mirror http://inbox.vuxu.org/voidlinux-github

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V1 voidlinux-github voidlinux-github/ http://inbox.vuxu.org/voidlinux-github \
		voidlinux-github@inbox.vuxu.org
	public-inbox-index voidlinux-github

Example config snippet for mirrors.
Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.github.voidlinux


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git