Github messages for voidlinux
 help / color / mirror / Atom feed
* [PR PATCH] blender: update to 2.93.0.
@ 2021-06-08 14:08 kkga
  2021-06-08 16:46 ` [PR PATCH] [Updated] " kkga
                   ` (8 more replies)
  0 siblings, 9 replies; 10+ messages in thread
From: kkga @ 2021-06-08 14:08 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1563 bytes --]

There is a new pull request by kkga against master on the void-packages repository

https://github.com/kkga/void-packages update-blender
https://github.com/void-linux/void-packages/pull/31363

blender: update to 2.93.0.
<!-- Mark items with [x] where applicable -->

#### General
- [ ] This is a new package and it conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements)

#### Have the results of the proposed changes been tested?
- [ ] I use the packages affected by the proposed changes on a regular basis and confirm this PR works for me
- [x] I generally don't use the affected packages but briefly tested this PR

<!--
If GitHub CI cannot be used to validate the build result (for example, if the
build is likely to take several hours), make sure to
[skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration).
When skipping CI, uncomment and fill out the following section.
Note: for builds that are likely to complete in less than 2 hours, it is not
acceptable to skip CI.
-->
<!-- 
#### Does it build and run successfully? 
(Please choose at least one native build and, if supported, at least one cross build. More are better.)
- [ ] I built this PR locally for my native architecture, (ARCH-LIBC)
- [ ] I built this PR locally for these architectures (if supported. mark crossbuilds):
  - [ ] aarch64-musl
  - [ ] armv7l
  - [ ] armv6l-musl
-->


A patch file from https://github.com/void-linux/void-packages/pull/31363.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-update-blender-31363.patch --]
[-- Type: text/x-diff, Size: 1425 bytes --]

From 3f2d85b3fd544dfc5dd111fc06344aafc92880ba Mon Sep 17 00:00:00 2001
From: Gadzhi Kharkharov <me@kkga.me>
Date: Tue, 8 Jun 2021 17:08:18 +0300
Subject: [PATCH] blender: update to 2.93.0.

---
 srcpkgs/blender/template | 14 +++++++-------
 1 file changed, 7 insertions(+), 7 deletions(-)

diff --git a/srcpkgs/blender/template b/srcpkgs/blender/template
index e480e63b8aa0..2fd21e6d2a74 100644
--- a/srcpkgs/blender/template
+++ b/srcpkgs/blender/template
@@ -1,6 +1,6 @@
 # Template file for 'blender'
 pkgname=blender
-version=2.92.0
+version=2.93.0
 revision=2
 archs="x86_64* ppc64*"
 build_style="cmake"
@@ -26,7 +26,7 @@ maintainer="Enno Boland <gottox@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="http://www.blender.org"
 distfiles="http://download.blender.org/source/${pkgname}-${version}.tar.xz"
-checksum=e791cfc403292383577c3c8ce2cd34e5aa2cd8da0a7483041049a1609ddb4595
+checksum=ba3b634a46d717c7b40dcaef33e1075a4fa29d68a2c109d23339ea3414be5938
 python_version=3
 CXXFLAGS="-DNDEBUG"
 CFLAGS="$CXXFLAGS"
@@ -42,9 +42,9 @@ case "$XBPS_TARGET_MACHINE" in
 esac
 
 case "$XBPS_TARGET_MACHINE" in
-x86_64*)
-	# Enable Intel Open Image Denoise on x86_64
-	makedepends+=" openimagedenoise-devel"
-	configure_args+=" -DWITH_OPENIMAGEDENOISE=ON"
-	;;
+	x86_64*)
+		# Enable Intel Open Image Denoise on x86_64
+		makedepends+=" openimagedenoise-devel"
+		configure_args+=" -DWITH_OPENIMAGEDENOISE=ON"
+		;;
 esac

^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: [PR PATCH] [Updated] blender: update to 2.93.0.
  2021-06-08 14:08 [PR PATCH] blender: update to 2.93.0 kkga
@ 2021-06-08 16:46 ` kkga
  2021-06-09  7:38 ` biopsin
                   ` (7 subsequent siblings)
  8 siblings, 0 replies; 10+ messages in thread
From: kkga @ 2021-06-08 16:46 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1568 bytes --]

There is an updated pull request by kkga against master on the void-packages repository

https://github.com/kkga/void-packages update-blender
https://github.com/void-linux/void-packages/pull/31363

blender: update to 2.93.0.
<!-- Mark items with [x] where applicable -->

#### General
- [ ] This is a new package and it conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements)

#### Have the results of the proposed changes been tested?
- [ ] I use the packages affected by the proposed changes on a regular basis and confirm this PR works for me
- [x] I generally don't use the affected packages but briefly tested this PR

<!--
If GitHub CI cannot be used to validate the build result (for example, if the
build is likely to take several hours), make sure to
[skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration).
When skipping CI, uncomment and fill out the following section.
Note: for builds that are likely to complete in less than 2 hours, it is not
acceptable to skip CI.
-->
<!-- 
#### Does it build and run successfully? 
(Please choose at least one native build and, if supported, at least one cross build. More are better.)
- [ ] I built this PR locally for my native architecture, (ARCH-LIBC)
- [ ] I built this PR locally for these architectures (if supported. mark crossbuilds):
  - [ ] aarch64-musl
  - [ ] armv7l
  - [ ] armv6l-musl
-->


A patch file from https://github.com/void-linux/void-packages/pull/31363.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-update-blender-31363.patch --]
[-- Type: text/x-diff, Size: 1498 bytes --]

From 8cc9d5cfcda2deacff30e8adf6f6645290596e2a Mon Sep 17 00:00:00 2001
From: Gadzhi Kharkharov <me@kkga.me>
Date: Tue, 8 Jun 2021 17:08:18 +0300
Subject: [PATCH] blender: update to 2.93.0.

---
 srcpkgs/blender/template | 16 ++++++++--------
 1 file changed, 8 insertions(+), 8 deletions(-)

diff --git a/srcpkgs/blender/template b/srcpkgs/blender/template
index e480e63b8aa0..d1d016c84c45 100644
--- a/srcpkgs/blender/template
+++ b/srcpkgs/blender/template
@@ -1,7 +1,7 @@
 # Template file for 'blender'
 pkgname=blender
-version=2.92.0
-revision=2
+version=2.93.0
+revision=1
 archs="x86_64* ppc64*"
 build_style="cmake"
 pycompile_dirs="/usr/share/blender/${version%.*}/scripts"
@@ -26,7 +26,7 @@ maintainer="Enno Boland <gottox@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="http://www.blender.org"
 distfiles="http://download.blender.org/source/${pkgname}-${version}.tar.xz"
-checksum=e791cfc403292383577c3c8ce2cd34e5aa2cd8da0a7483041049a1609ddb4595
+checksum=ba3b634a46d717c7b40dcaef33e1075a4fa29d68a2c109d23339ea3414be5938
 python_version=3
 CXXFLAGS="-DNDEBUG"
 CFLAGS="$CXXFLAGS"
@@ -42,9 +42,9 @@ case "$XBPS_TARGET_MACHINE" in
 esac
 
 case "$XBPS_TARGET_MACHINE" in
-x86_64*)
-	# Enable Intel Open Image Denoise on x86_64
-	makedepends+=" openimagedenoise-devel"
-	configure_args+=" -DWITH_OPENIMAGEDENOISE=ON"
-	;;
+	x86_64*)
+		# Enable Intel Open Image Denoise on x86_64
+		makedepends+=" openimagedenoise-devel"
+		configure_args+=" -DWITH_OPENIMAGEDENOISE=ON"
+		;;
 esac

^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: blender: update to 2.93.0.
  2021-06-08 14:08 [PR PATCH] blender: update to 2.93.0 kkga
  2021-06-08 16:46 ` [PR PATCH] [Updated] " kkga
@ 2021-06-09  7:38 ` biopsin
  2021-06-09  8:00 ` [PR PATCH] [Updated] " kkga
                   ` (6 subsequent siblings)
  8 siblings, 0 replies; 10+ messages in thread
From: biopsin @ 2021-06-09  7:38 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 166 bytes --]

New comment by biopsin on void-packages repository

https://github.com/void-linux/void-packages/pull/31363#issuecomment-857464027

Comment:
Please update openimageio

^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: [PR PATCH] [Updated] blender: update to 2.93.0.
  2021-06-08 14:08 [PR PATCH] blender: update to 2.93.0 kkga
  2021-06-08 16:46 ` [PR PATCH] [Updated] " kkga
  2021-06-09  7:38 ` biopsin
@ 2021-06-09  8:00 ` kkga
  2021-06-09  8:02 ` kkga
                   ` (5 subsequent siblings)
  8 siblings, 0 replies; 10+ messages in thread
From: kkga @ 2021-06-09  8:00 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1568 bytes --]

There is an updated pull request by kkga against master on the void-packages repository

https://github.com/kkga/void-packages update-blender
https://github.com/void-linux/void-packages/pull/31363

blender: update to 2.93.0.
<!-- Mark items with [x] where applicable -->

#### General
- [ ] This is a new package and it conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements)

#### Have the results of the proposed changes been tested?
- [ ] I use the packages affected by the proposed changes on a regular basis and confirm this PR works for me
- [x] I generally don't use the affected packages but briefly tested this PR

<!--
If GitHub CI cannot be used to validate the build result (for example, if the
build is likely to take several hours), make sure to
[skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration).
When skipping CI, uncomment and fill out the following section.
Note: for builds that are likely to complete in less than 2 hours, it is not
acceptable to skip CI.
-->
<!-- 
#### Does it build and run successfully? 
(Please choose at least one native build and, if supported, at least one cross build. More are better.)
- [ ] I built this PR locally for my native architecture, (ARCH-LIBC)
- [ ] I built this PR locally for these architectures (if supported. mark crossbuilds):
  - [ ] aarch64-musl
  - [ ] armv7l
  - [ ] armv6l-musl
-->


A patch file from https://github.com/void-linux/void-packages/pull/31363.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-update-blender-31363.patch --]
[-- Type: text/x-diff, Size: 1498 bytes --]

From bc96e5e2f001469018dfece636e60261cb030c6c Mon Sep 17 00:00:00 2001
From: Gadzhi Kharkharov <me@kkga.me>
Date: Tue, 8 Jun 2021 17:08:18 +0300
Subject: [PATCH] blender: update to 2.93.0.

---
 srcpkgs/blender/template | 16 ++++++++--------
 1 file changed, 8 insertions(+), 8 deletions(-)

diff --git a/srcpkgs/blender/template b/srcpkgs/blender/template
index e480e63b8aa0..d1d016c84c45 100644
--- a/srcpkgs/blender/template
+++ b/srcpkgs/blender/template
@@ -1,7 +1,7 @@
 # Template file for 'blender'
 pkgname=blender
-version=2.92.0
-revision=2
+version=2.93.0
+revision=1
 archs="x86_64* ppc64*"
 build_style="cmake"
 pycompile_dirs="/usr/share/blender/${version%.*}/scripts"
@@ -26,7 +26,7 @@ maintainer="Enno Boland <gottox@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="http://www.blender.org"
 distfiles="http://download.blender.org/source/${pkgname}-${version}.tar.xz"
-checksum=e791cfc403292383577c3c8ce2cd34e5aa2cd8da0a7483041049a1609ddb4595
+checksum=ba3b634a46d717c7b40dcaef33e1075a4fa29d68a2c109d23339ea3414be5938
 python_version=3
 CXXFLAGS="-DNDEBUG"
 CFLAGS="$CXXFLAGS"
@@ -42,9 +42,9 @@ case "$XBPS_TARGET_MACHINE" in
 esac
 
 case "$XBPS_TARGET_MACHINE" in
-x86_64*)
-	# Enable Intel Open Image Denoise on x86_64
-	makedepends+=" openimagedenoise-devel"
-	configure_args+=" -DWITH_OPENIMAGEDENOISE=ON"
-	;;
+	x86_64*)
+		# Enable Intel Open Image Denoise on x86_64
+		makedepends+=" openimagedenoise-devel"
+		configure_args+=" -DWITH_OPENIMAGEDENOISE=ON"
+		;;
 esac

^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: [PR PATCH] [Updated] blender: update to 2.93.0.
  2021-06-08 14:08 [PR PATCH] blender: update to 2.93.0 kkga
                   ` (2 preceding siblings ...)
  2021-06-09  8:00 ` [PR PATCH] [Updated] " kkga
@ 2021-06-09  8:02 ` kkga
  2021-06-09 12:58 ` biopsin
                   ` (4 subsequent siblings)
  8 siblings, 0 replies; 10+ messages in thread
From: kkga @ 2021-06-09  8:02 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1568 bytes --]

There is an updated pull request by kkga against master on the void-packages repository

https://github.com/kkga/void-packages update-blender
https://github.com/void-linux/void-packages/pull/31363

blender: update to 2.93.0.
<!-- Mark items with [x] where applicable -->

#### General
- [ ] This is a new package and it conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements)

#### Have the results of the proposed changes been tested?
- [ ] I use the packages affected by the proposed changes on a regular basis and confirm this PR works for me
- [x] I generally don't use the affected packages but briefly tested this PR

<!--
If GitHub CI cannot be used to validate the build result (for example, if the
build is likely to take several hours), make sure to
[skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration).
When skipping CI, uncomment and fill out the following section.
Note: for builds that are likely to complete in less than 2 hours, it is not
acceptable to skip CI.
-->
<!-- 
#### Does it build and run successfully? 
(Please choose at least one native build and, if supported, at least one cross build. More are better.)
- [ ] I built this PR locally for my native architecture, (ARCH-LIBC)
- [ ] I built this PR locally for these architectures (if supported. mark crossbuilds):
  - [ ] aarch64-musl
  - [ ] armv7l
  - [ ] armv6l-musl
-->


A patch file from https://github.com/void-linux/void-packages/pull/31363.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-update-blender-31363.patch --]
[-- Type: text/x-diff, Size: 2695 bytes --]

From 086cb175f579c6e1777e541863a8c3f8ee663d0f Mon Sep 17 00:00:00 2001
From: Gadzhi Kharkharov <me@kkga.me>
Date: Tue, 8 Jun 2021 17:08:18 +0300
Subject: [PATCH] blender: update to 2.93.0.

---
 srcpkgs/blender/template     | 16 ++++++++--------
 srcpkgs/openimageio/template |  8 ++++----
 2 files changed, 12 insertions(+), 12 deletions(-)

diff --git a/srcpkgs/blender/template b/srcpkgs/blender/template
index e480e63b8aa0..d1d016c84c45 100644
--- a/srcpkgs/blender/template
+++ b/srcpkgs/blender/template
@@ -1,7 +1,7 @@
 # Template file for 'blender'
 pkgname=blender
-version=2.92.0
-revision=2
+version=2.93.0
+revision=1
 archs="x86_64* ppc64*"
 build_style="cmake"
 pycompile_dirs="/usr/share/blender/${version%.*}/scripts"
@@ -26,7 +26,7 @@ maintainer="Enno Boland <gottox@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="http://www.blender.org"
 distfiles="http://download.blender.org/source/${pkgname}-${version}.tar.xz"
-checksum=e791cfc403292383577c3c8ce2cd34e5aa2cd8da0a7483041049a1609ddb4595
+checksum=ba3b634a46d717c7b40dcaef33e1075a4fa29d68a2c109d23339ea3414be5938
 python_version=3
 CXXFLAGS="-DNDEBUG"
 CFLAGS="$CXXFLAGS"
@@ -42,9 +42,9 @@ case "$XBPS_TARGET_MACHINE" in
 esac
 
 case "$XBPS_TARGET_MACHINE" in
-x86_64*)
-	# Enable Intel Open Image Denoise on x86_64
-	makedepends+=" openimagedenoise-devel"
-	configure_args+=" -DWITH_OPENIMAGEDENOISE=ON"
-	;;
+	x86_64*)
+		# Enable Intel Open Image Denoise on x86_64
+		makedepends+=" openimagedenoise-devel"
+		configure_args+=" -DWITH_OPENIMAGEDENOISE=ON"
+		;;
 esac
diff --git a/srcpkgs/openimageio/template b/srcpkgs/openimageio/template
index 15ece11d1418..c8743d7510a4 100644
--- a/srcpkgs/openimageio/template
+++ b/srcpkgs/openimageio/template
@@ -1,7 +1,7 @@
 # Template file for 'openimageio'
 pkgname=openimageio
-version=2.2.13.1
-revision=2
+version=2.2.15.1
+revision=1
 wrksrc="oiio-Release-${version}"
 build_style=cmake
 configure_args="-DUSE_OPENGL=0 -DUSE_QT=0 -DUSE_PYTHON=0 -DOIIO_BUILD_TESTS=1
@@ -17,13 +17,13 @@ license="BSD-3-Clause"
 homepage="https://sites.google.com/site/openimageio/home"
 changelog="https://raw.githubusercontent.com/OpenImageIO/oiio/release/CHANGES.md"
 distfiles="https://github.com/OpenImageIO/oiio/archive/Release-${version}.tar.gz"
-checksum=7f810124e866ac14ad9c11b0ab528a6ed4c8e62a190cc44a77eed8159f57405c
+checksum=f222c6b51a40aabbc80ddf4055535be9af1ffa907452fa6d1ffa7674854aab17
 # Runs checks even for features we disabled.
 make_check=no
 
 CXXFLAGS="-faligned-new"
 case "$XBPS_TARGET_MACHINE" in
-	i686*|x86_64*) configure_args+=" -DUSE_SIMD=sse2" ;;
+	i686* | x86_64*) configure_args+=" -DUSE_SIMD=sse2" ;;
 esac
 
 if [ "$XBPS_TARGET_NO_ATOMIC8" ]; then

^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: blender: update to 2.93.0.
  2021-06-08 14:08 [PR PATCH] blender: update to 2.93.0 kkga
                   ` (3 preceding siblings ...)
  2021-06-09  8:02 ` kkga
@ 2021-06-09 12:58 ` biopsin
  2021-06-10  7:31 ` [PR PATCH] [Updated] " kkga
                   ` (3 subsequent siblings)
  8 siblings, 0 replies; 10+ messages in thread
From: biopsin @ 2021-06-09 12:58 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 274 bytes --]

New comment by biopsin on void-packages repository

https://github.com/void-linux/void-packages/pull/31363#issuecomment-857671871

Comment:
Thank you, also push openimageio to it's own commit for the record. 
(it's not obvious there are changes beond blender in this PR)


^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: [PR PATCH] [Updated] blender: update to 2.93.0.
  2021-06-08 14:08 [PR PATCH] blender: update to 2.93.0 kkga
                   ` (4 preceding siblings ...)
  2021-06-09 12:58 ` biopsin
@ 2021-06-10  7:31 ` kkga
  2021-06-10  7:32 ` kkga
                   ` (2 subsequent siblings)
  8 siblings, 0 replies; 10+ messages in thread
From: kkga @ 2021-06-10  7:31 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1568 bytes --]

There is an updated pull request by kkga against master on the void-packages repository

https://github.com/kkga/void-packages update-blender
https://github.com/void-linux/void-packages/pull/31363

blender: update to 2.93.0.
<!-- Mark items with [x] where applicable -->

#### General
- [ ] This is a new package and it conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements)

#### Have the results of the proposed changes been tested?
- [ ] I use the packages affected by the proposed changes on a regular basis and confirm this PR works for me
- [x] I generally don't use the affected packages but briefly tested this PR

<!--
If GitHub CI cannot be used to validate the build result (for example, if the
build is likely to take several hours), make sure to
[skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration).
When skipping CI, uncomment and fill out the following section.
Note: for builds that are likely to complete in less than 2 hours, it is not
acceptable to skip CI.
-->
<!-- 
#### Does it build and run successfully? 
(Please choose at least one native build and, if supported, at least one cross build. More are better.)
- [ ] I built this PR locally for my native architecture, (ARCH-LIBC)
- [ ] I built this PR locally for these architectures (if supported. mark crossbuilds):
  - [ ] aarch64-musl
  - [ ] armv7l
  - [ ] armv6l-musl
-->


A patch file from https://github.com/void-linux/void-packages/pull/31363.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-update-blender-31363.patch --]
[-- Type: text/x-diff, Size: 2854 bytes --]

From 3b54ca5e203ca85c893ad43838437a7ec475260a Mon Sep 17 00:00:00 2001
From: Gadzhi Kharkharov <me@kkga.me>
Date: Tue, 8 Jun 2021 17:08:18 +0300
Subject: [PATCH 1/2] blender: update to 2.93.0.

---
 srcpkgs/blender/template | 16 ++++++++--------
 1 file changed, 8 insertions(+), 8 deletions(-)

diff --git a/srcpkgs/blender/template b/srcpkgs/blender/template
index e480e63b8aa0..d1d016c84c45 100644
--- a/srcpkgs/blender/template
+++ b/srcpkgs/blender/template
@@ -1,7 +1,7 @@
 # Template file for 'blender'
 pkgname=blender
-version=2.92.0
-revision=2
+version=2.93.0
+revision=1
 archs="x86_64* ppc64*"
 build_style="cmake"
 pycompile_dirs="/usr/share/blender/${version%.*}/scripts"
@@ -26,7 +26,7 @@ maintainer="Enno Boland <gottox@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="http://www.blender.org"
 distfiles="http://download.blender.org/source/${pkgname}-${version}.tar.xz"
-checksum=e791cfc403292383577c3c8ce2cd34e5aa2cd8da0a7483041049a1609ddb4595
+checksum=ba3b634a46d717c7b40dcaef33e1075a4fa29d68a2c109d23339ea3414be5938
 python_version=3
 CXXFLAGS="-DNDEBUG"
 CFLAGS="$CXXFLAGS"
@@ -42,9 +42,9 @@ case "$XBPS_TARGET_MACHINE" in
 esac
 
 case "$XBPS_TARGET_MACHINE" in
-x86_64*)
-	# Enable Intel Open Image Denoise on x86_64
-	makedepends+=" openimagedenoise-devel"
-	configure_args+=" -DWITH_OPENIMAGEDENOISE=ON"
-	;;
+	x86_64*)
+		# Enable Intel Open Image Denoise on x86_64
+		makedepends+=" openimagedenoise-devel"
+		configure_args+=" -DWITH_OPENIMAGEDENOISE=ON"
+		;;
 esac

From 281403c7881550b641d21cfddd2a372d07abfdb0 Mon Sep 17 00:00:00 2001
From: Gadzhi Kharkharov <me@kkga.me>
Date: Thu, 10 Jun 2021 10:30:28 +0300
Subject: [PATCH 2/2] openimageio: update to 2.2.15.1.

---
 srcpkgs/openimageio/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/openimageio/template b/srcpkgs/openimageio/template
index 15ece11d1418..c447873645fa 100644
--- a/srcpkgs/openimageio/template
+++ b/srcpkgs/openimageio/template
@@ -1,6 +1,6 @@
 # Template file for 'openimageio'
 pkgname=openimageio
-version=2.2.13.1
+version=2.2.15.1
 revision=2
 wrksrc="oiio-Release-${version}"
 build_style=cmake
@@ -17,13 +17,13 @@ license="BSD-3-Clause"
 homepage="https://sites.google.com/site/openimageio/home"
 changelog="https://raw.githubusercontent.com/OpenImageIO/oiio/release/CHANGES.md"
 distfiles="https://github.com/OpenImageIO/oiio/archive/Release-${version}.tar.gz"
-checksum=7f810124e866ac14ad9c11b0ab528a6ed4c8e62a190cc44a77eed8159f57405c
+checksum=f222c6b51a40aabbc80ddf4055535be9af1ffa907452fa6d1ffa7674854aab17
 # Runs checks even for features we disabled.
 make_check=no
 
 CXXFLAGS="-faligned-new"
 case "$XBPS_TARGET_MACHINE" in
-	i686*|x86_64*) configure_args+=" -DUSE_SIMD=sse2" ;;
+	i686* | x86_64*) configure_args+=" -DUSE_SIMD=sse2" ;;
 esac
 
 if [ "$XBPS_TARGET_NO_ATOMIC8" ]; then

^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: [PR PATCH] [Updated] blender: update to 2.93.0.
  2021-06-08 14:08 [PR PATCH] blender: update to 2.93.0 kkga
                   ` (5 preceding siblings ...)
  2021-06-10  7:31 ` [PR PATCH] [Updated] " kkga
@ 2021-06-10  7:32 ` kkga
  2021-06-10  7:34 ` kkga
  2021-06-11 19:36 ` [PR PATCH] [Closed]: " ericonr
  8 siblings, 0 replies; 10+ messages in thread
From: kkga @ 2021-06-10  7:32 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1568 bytes --]

There is an updated pull request by kkga against master on the void-packages repository

https://github.com/kkga/void-packages update-blender
https://github.com/void-linux/void-packages/pull/31363

blender: update to 2.93.0.
<!-- Mark items with [x] where applicable -->

#### General
- [ ] This is a new package and it conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements)

#### Have the results of the proposed changes been tested?
- [ ] I use the packages affected by the proposed changes on a regular basis and confirm this PR works for me
- [x] I generally don't use the affected packages but briefly tested this PR

<!--
If GitHub CI cannot be used to validate the build result (for example, if the
build is likely to take several hours), make sure to
[skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration).
When skipping CI, uncomment and fill out the following section.
Note: for builds that are likely to complete in less than 2 hours, it is not
acceptable to skip CI.
-->
<!-- 
#### Does it build and run successfully? 
(Please choose at least one native build and, if supported, at least one cross build. More are better.)
- [ ] I built this PR locally for my native architecture, (ARCH-LIBC)
- [ ] I built this PR locally for these architectures (if supported. mark crossbuilds):
  - [ ] aarch64-musl
  - [ ] armv7l
  - [ ] armv6l-musl
-->


A patch file from https://github.com/void-linux/void-packages/pull/31363.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-update-blender-31363.patch --]
[-- Type: text/x-diff, Size: 2947 bytes --]

From 3b54ca5e203ca85c893ad43838437a7ec475260a Mon Sep 17 00:00:00 2001
From: Gadzhi Kharkharov <me@kkga.me>
Date: Tue, 8 Jun 2021 17:08:18 +0300
Subject: [PATCH 1/2] blender: update to 2.93.0.

---
 srcpkgs/blender/template | 16 ++++++++--------
 1 file changed, 8 insertions(+), 8 deletions(-)

diff --git a/srcpkgs/blender/template b/srcpkgs/blender/template
index e480e63b8aa0..d1d016c84c45 100644
--- a/srcpkgs/blender/template
+++ b/srcpkgs/blender/template
@@ -1,7 +1,7 @@
 # Template file for 'blender'
 pkgname=blender
-version=2.92.0
-revision=2
+version=2.93.0
+revision=1
 archs="x86_64* ppc64*"
 build_style="cmake"
 pycompile_dirs="/usr/share/blender/${version%.*}/scripts"
@@ -26,7 +26,7 @@ maintainer="Enno Boland <gottox@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="http://www.blender.org"
 distfiles="http://download.blender.org/source/${pkgname}-${version}.tar.xz"
-checksum=e791cfc403292383577c3c8ce2cd34e5aa2cd8da0a7483041049a1609ddb4595
+checksum=ba3b634a46d717c7b40dcaef33e1075a4fa29d68a2c109d23339ea3414be5938
 python_version=3
 CXXFLAGS="-DNDEBUG"
 CFLAGS="$CXXFLAGS"
@@ -42,9 +42,9 @@ case "$XBPS_TARGET_MACHINE" in
 esac
 
 case "$XBPS_TARGET_MACHINE" in
-x86_64*)
-	# Enable Intel Open Image Denoise on x86_64
-	makedepends+=" openimagedenoise-devel"
-	configure_args+=" -DWITH_OPENIMAGEDENOISE=ON"
-	;;
+	x86_64*)
+		# Enable Intel Open Image Denoise on x86_64
+		makedepends+=" openimagedenoise-devel"
+		configure_args+=" -DWITH_OPENIMAGEDENOISE=ON"
+		;;
 esac

From 864f034a7f40e445374b736348ff915ebc0788c7 Mon Sep 17 00:00:00 2001
From: Gadzhi Kharkharov <me@kkga.me>
Date: Thu, 10 Jun 2021 10:30:28 +0300
Subject: [PATCH 2/2] openimageio: update to 2.2.15.1.

---
 srcpkgs/openimageio/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/openimageio/template b/srcpkgs/openimageio/template
index 15ece11d1418..c8743d7510a4 100644
--- a/srcpkgs/openimageio/template
+++ b/srcpkgs/openimageio/template
@@ -1,7 +1,7 @@
 # Template file for 'openimageio'
 pkgname=openimageio
-version=2.2.13.1
-revision=2
+version=2.2.15.1
+revision=1
 wrksrc="oiio-Release-${version}"
 build_style=cmake
 configure_args="-DUSE_OPENGL=0 -DUSE_QT=0 -DUSE_PYTHON=0 -DOIIO_BUILD_TESTS=1
@@ -17,13 +17,13 @@ license="BSD-3-Clause"
 homepage="https://sites.google.com/site/openimageio/home"
 changelog="https://raw.githubusercontent.com/OpenImageIO/oiio/release/CHANGES.md"
 distfiles="https://github.com/OpenImageIO/oiio/archive/Release-${version}.tar.gz"
-checksum=7f810124e866ac14ad9c11b0ab528a6ed4c8e62a190cc44a77eed8159f57405c
+checksum=f222c6b51a40aabbc80ddf4055535be9af1ffa907452fa6d1ffa7674854aab17
 # Runs checks even for features we disabled.
 make_check=no
 
 CXXFLAGS="-faligned-new"
 case "$XBPS_TARGET_MACHINE" in
-	i686*|x86_64*) configure_args+=" -DUSE_SIMD=sse2" ;;
+	i686* | x86_64*) configure_args+=" -DUSE_SIMD=sse2" ;;
 esac
 
 if [ "$XBPS_TARGET_NO_ATOMIC8" ]; then

^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: [PR PATCH] [Updated] blender: update to 2.93.0.
  2021-06-08 14:08 [PR PATCH] blender: update to 2.93.0 kkga
                   ` (6 preceding siblings ...)
  2021-06-10  7:32 ` kkga
@ 2021-06-10  7:34 ` kkga
  2021-06-11 19:36 ` [PR PATCH] [Closed]: " ericonr
  8 siblings, 0 replies; 10+ messages in thread
From: kkga @ 2021-06-10  7:34 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1568 bytes --]

There is an updated pull request by kkga against master on the void-packages repository

https://github.com/kkga/void-packages update-blender
https://github.com/void-linux/void-packages/pull/31363

blender: update to 2.93.0.
<!-- Mark items with [x] where applicable -->

#### General
- [ ] This is a new package and it conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements)

#### Have the results of the proposed changes been tested?
- [ ] I use the packages affected by the proposed changes on a regular basis and confirm this PR works for me
- [x] I generally don't use the affected packages but briefly tested this PR

<!--
If GitHub CI cannot be used to validate the build result (for example, if the
build is likely to take several hours), make sure to
[skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration).
When skipping CI, uncomment and fill out the following section.
Note: for builds that are likely to complete in less than 2 hours, it is not
acceptable to skip CI.
-->
<!-- 
#### Does it build and run successfully? 
(Please choose at least one native build and, if supported, at least one cross build. More are better.)
- [ ] I built this PR locally for my native architecture, (ARCH-LIBC)
- [ ] I built this PR locally for these architectures (if supported. mark crossbuilds):
  - [ ] aarch64-musl
  - [ ] armv7l
  - [ ] armv6l-musl
-->


A patch file from https://github.com/void-linux/void-packages/pull/31363.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-update-blender-31363.patch --]
[-- Type: text/x-diff, Size: 2947 bytes --]

From 942675c97a4971d8bea80a8669f2a71dac643e1c Mon Sep 17 00:00:00 2001
From: Gadzhi Kharkharov <me@kkga.me>
Date: Tue, 8 Jun 2021 17:08:18 +0300
Subject: [PATCH 1/2] blender: update to 2.93.0.

---
 srcpkgs/blender/template | 16 ++++++++--------
 1 file changed, 8 insertions(+), 8 deletions(-)

diff --git a/srcpkgs/blender/template b/srcpkgs/blender/template
index e480e63b8aa0..d1d016c84c45 100644
--- a/srcpkgs/blender/template
+++ b/srcpkgs/blender/template
@@ -1,7 +1,7 @@
 # Template file for 'blender'
 pkgname=blender
-version=2.92.0
-revision=2
+version=2.93.0
+revision=1
 archs="x86_64* ppc64*"
 build_style="cmake"
 pycompile_dirs="/usr/share/blender/${version%.*}/scripts"
@@ -26,7 +26,7 @@ maintainer="Enno Boland <gottox@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="http://www.blender.org"
 distfiles="http://download.blender.org/source/${pkgname}-${version}.tar.xz"
-checksum=e791cfc403292383577c3c8ce2cd34e5aa2cd8da0a7483041049a1609ddb4595
+checksum=ba3b634a46d717c7b40dcaef33e1075a4fa29d68a2c109d23339ea3414be5938
 python_version=3
 CXXFLAGS="-DNDEBUG"
 CFLAGS="$CXXFLAGS"
@@ -42,9 +42,9 @@ case "$XBPS_TARGET_MACHINE" in
 esac
 
 case "$XBPS_TARGET_MACHINE" in
-x86_64*)
-	# Enable Intel Open Image Denoise on x86_64
-	makedepends+=" openimagedenoise-devel"
-	configure_args+=" -DWITH_OPENIMAGEDENOISE=ON"
-	;;
+	x86_64*)
+		# Enable Intel Open Image Denoise on x86_64
+		makedepends+=" openimagedenoise-devel"
+		configure_args+=" -DWITH_OPENIMAGEDENOISE=ON"
+		;;
 esac

From 6529c8bfb297cf86626cd91ecf63800a37c7372d Mon Sep 17 00:00:00 2001
From: Gadzhi Kharkharov <me@kkga.me>
Date: Thu, 10 Jun 2021 10:30:28 +0300
Subject: [PATCH 2/2] openimageio: update to 2.2.15.1.

---
 srcpkgs/openimageio/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/openimageio/template b/srcpkgs/openimageio/template
index 15ece11d1418..c8743d7510a4 100644
--- a/srcpkgs/openimageio/template
+++ b/srcpkgs/openimageio/template
@@ -1,7 +1,7 @@
 # Template file for 'openimageio'
 pkgname=openimageio
-version=2.2.13.1
-revision=2
+version=2.2.15.1
+revision=1
 wrksrc="oiio-Release-${version}"
 build_style=cmake
 configure_args="-DUSE_OPENGL=0 -DUSE_QT=0 -DUSE_PYTHON=0 -DOIIO_BUILD_TESTS=1
@@ -17,13 +17,13 @@ license="BSD-3-Clause"
 homepage="https://sites.google.com/site/openimageio/home"
 changelog="https://raw.githubusercontent.com/OpenImageIO/oiio/release/CHANGES.md"
 distfiles="https://github.com/OpenImageIO/oiio/archive/Release-${version}.tar.gz"
-checksum=7f810124e866ac14ad9c11b0ab528a6ed4c8e62a190cc44a77eed8159f57405c
+checksum=f222c6b51a40aabbc80ddf4055535be9af1ffa907452fa6d1ffa7674854aab17
 # Runs checks even for features we disabled.
 make_check=no
 
 CXXFLAGS="-faligned-new"
 case "$XBPS_TARGET_MACHINE" in
-	i686*|x86_64*) configure_args+=" -DUSE_SIMD=sse2" ;;
+	i686* | x86_64*) configure_args+=" -DUSE_SIMD=sse2" ;;
 esac
 
 if [ "$XBPS_TARGET_NO_ATOMIC8" ]; then

^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: [PR PATCH] [Closed]: blender: update to 2.93.0.
  2021-06-08 14:08 [PR PATCH] blender: update to 2.93.0 kkga
                   ` (7 preceding siblings ...)
  2021-06-10  7:34 ` kkga
@ 2021-06-11 19:36 ` ericonr
  8 siblings, 0 replies; 10+ messages in thread
From: ericonr @ 2021-06-11 19:36 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1411 bytes --]

There's a closed pull request on the void-packages repository

blender: update to 2.93.0.
https://github.com/void-linux/void-packages/pull/31363

Description:
<!-- Mark items with [x] where applicable -->

#### General
- [ ] This is a new package and it conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements)

#### Have the results of the proposed changes been tested?
- [ ] I use the packages affected by the proposed changes on a regular basis and confirm this PR works for me
- [x] I generally don't use the affected packages but briefly tested this PR

<!--
If GitHub CI cannot be used to validate the build result (for example, if the
build is likely to take several hours), make sure to
[skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration).
When skipping CI, uncomment and fill out the following section.
Note: for builds that are likely to complete in less than 2 hours, it is not
acceptable to skip CI.
-->
<!-- 
#### Does it build and run successfully? 
(Please choose at least one native build and, if supported, at least one cross build. More are better.)
- [ ] I built this PR locally for my native architecture, (ARCH-LIBC)
- [ ] I built this PR locally for these architectures (if supported. mark crossbuilds):
  - [ ] aarch64-musl
  - [ ] armv7l
  - [ ] armv6l-musl
-->


^ permalink raw reply	[flat|nested] 10+ messages in thread

end of thread, other threads:[~2021-06-11 19:36 UTC | newest]

Thread overview: 10+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-06-08 14:08 [PR PATCH] blender: update to 2.93.0 kkga
2021-06-08 16:46 ` [PR PATCH] [Updated] " kkga
2021-06-09  7:38 ` biopsin
2021-06-09  8:00 ` [PR PATCH] [Updated] " kkga
2021-06-09  8:02 ` kkga
2021-06-09 12:58 ` biopsin
2021-06-10  7:31 ` [PR PATCH] [Updated] " kkga
2021-06-10  7:32 ` kkga
2021-06-10  7:34 ` kkga
2021-06-11 19:36 ` [PR PATCH] [Closed]: " ericonr

Github messages for voidlinux

This inbox may be cloned and mirrored by anyone:

	git clone --mirror http://inbox.vuxu.org/voidlinux-github

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V1 voidlinux-github voidlinux-github/ http://inbox.vuxu.org/voidlinux-github \
		voidlinux-github@inbox.vuxu.org
	public-inbox-index voidlinux-github

Example config snippet for mirrors.
Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.github.voidlinux


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git