Github messages for voidlinux
 help / color / mirror / Atom feed
* [PR PATCH] Omnibus lint pass for SPDX warnings - packages starting with Q
@ 2021-05-11 19:14 heliocat
  2021-06-10  7:49 ` [PR PATCH] [Updated] " heliocat
  0 siblings, 1 reply; 2+ messages in thread
From: heliocat @ 2021-05-11 19:14 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1614 bytes --]

There is a new pull request by heliocat against master on the void-packages repository

https://github.com/heliocat/void-packages lint_q
https://github.com/void-linux/void-packages/pull/30807

Omnibus lint pass for SPDX warnings - packages starting with Q
<!-- Mark items with [x] where applicable -->

#### General
- [ ] This is a new package and it conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements)

#### Have the results of the proposed changes been tested?
- [ ] I use the packages affected by the proposed changes on a regular basis and confirm this PR works for me
- [x] I generally don't use the affected packages but briefly tested this PR

<!--
If GitHub CI cannot be used to validate the build result (for example, if the
build is likely to take several hours), make sure to
[skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration).
When skipping CI, uncomment and fill out the following section.
Note: for builds that are likely to complete in less than 2 hours, it is not
acceptable to skip CI.
-->

#### Does it build and run successfully? 
(Please choose at least one native build and, if supported, at least one cross build. More are better.)
- [x] I built this PR locally for my native architecture, (x86_64)
- [x] I built this PR locally for these architectures (if supported. mark crossbuilds):
  - [x] aarch64-musl
  - [ ] armv7l
  - [ ] armv6l-musl



A patch file from https://github.com/void-linux/void-packages/pull/30807.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-lint_q-30807.patch --]
[-- Type: text/x-diff, Size: 10505 bytes --]

From bf45e0323c2c7c2fad088b819e0d4606165abbb0 Mon Sep 17 00:00:00 2001
From: Colin Booth <colin@heliocat.net>
Date: Mon, 10 May 2021 22:11:43 -0700
Subject: [PATCH 1/9] qarma: fix license, other lint

---
 srcpkgs/qarma/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/qarma/template b/srcpkgs/qarma/template
index 40351ba5c360..79c53bac5f3b 100644
--- a/srcpkgs/qarma/template
+++ b/srcpkgs/qarma/template
@@ -1,18 +1,18 @@
 # Template file for 'qarma'
 pkgname=qarma
 version=t1
-revision=1
+revision=2
 build_style=qmake
-provides="zenity-${version}_${revision}"
-replaces="zenity>=0"
 hostmakedepends="qt5-qmake qt5-host-tools"
 makedepends="qt5-x11extras-devel"
-maintainer="Orphaned <orphan@voidlinux.org>"
 short_desc="Tool to create dialog boxes, based on Qt"
+maintainer="Orphaned <orphan@voidlinux.org>"
+license="GPL-2.0-only"
 homepage="https://github.com/luebking/qarma"
-license="GPL-2"
 distfiles="https://github.com/luebking/qarma/archive/${version}.tar.gz"
 checksum=ebce381d2884e4109998bc4a966f1eb08cc549b2725b0f4c5525b30849754794
+replaces="zenity>=0"
+provides="zenity-${version}_${revision}"
 
 post_install() {
 	ln -s /usr/bin/qarma ${DESTDIR}/usr/bin/zenity

From 8f15e498aec39d3735590c7b652b6f263d0d159e Mon Sep 17 00:00:00 2001
From: Colin Booth <colin@heliocat.net>
Date: Mon, 10 May 2021 23:02:42 -0700
Subject: [PATCH 2/9] qemacs: fix license

---
 srcpkgs/qemacs/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/qemacs/template b/srcpkgs/qemacs/template
index 6805ba8e238b..15d4ed36cdba 100644
--- a/srcpkgs/qemacs/template
+++ b/srcpkgs/qemacs/template
@@ -1,7 +1,7 @@
 # Template file for 'qemacs'
 pkgname=qemacs
 version=0.5.0.20170701
-revision=2
+revision=3
 wrksrc="${pkgname}"
 build_style=configure
 configure_args="--prefix=/usr --mandir=/usr/share/man
@@ -9,8 +9,8 @@ configure_args="--prefix=/usr --mandir=/usr/share/man
 hostmakedepends="cvs"
 short_desc="Small but powerful Emacs clone (with UTF-8, HTML, shell, dired)"
 maintainer="Leah Neukirchen <leah@vuxu.org>"
-license="LGPL-2.1"
-homepage="http://bellard.org/qemacs/"
+license="LGPL-2.1-or-later"
+homepage="https://bellard.org/qemacs/"
 
 do_fetch() {
 	cvs -d :pserver:anonymous@cvs.savannah.nongnu.org:/sources/qemacs \

From 40a7378bfe8ecbb33b41a5a830835e066957142b Mon Sep 17 00:00:00 2001
From: Colin Booth <colin@heliocat.net>
Date: Mon, 10 May 2021 23:05:20 -0700
Subject: [PATCH 3/9] qemuconf: fix license, other lint

---
 srcpkgs/qemuconf/template | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/qemuconf/template b/srcpkgs/qemuconf/template
index 365497fd4cd7..5ae35040ce05 100644
--- a/srcpkgs/qemuconf/template
+++ b/srcpkgs/qemuconf/template
@@ -1,20 +1,21 @@
 # Template file for 'qemuconf'
 pkgname=qemuconf
 version=0.2.1
-revision=2
+revision=3
 build_style=gnu-makefile
 make_install_target="install-runit"
 conf_files="/etc/qemu.d/generic.conf"
 depends="qemu"
-short_desc="simple qemu launcher with config file support"
+short_desc="Simple qemu launcher with config file support"
 maintainer="Enno Boland <gottox@voidlinux.org>"
-license="GPL-3"
+license="MIT"
 homepage="https://github.com/Gottox/qemuconf"
 distfiles="https://github.com/Gottox/qemuconf/archive/v${version}.tar.gz"
 checksum=8b57872e6f7d281e7ed7d142ff05efb50e2fbe2c46e656a30fbb1705b4382548
 
 post_install() {
 	vinstall generic.conf 644 etc/qemu.d
+	vlicense LICENSE
 	vbin qemuconf_import.sh
 	ln -s /run/runit/supervise.qemu-generic $DESTDIR/etc/sv/qemu-generic/supervise
 }

From 86dfd2e849d437537bdd61c0f50d6ac436154b6f Mon Sep 17 00:00:00 2001
From: Colin Booth <colin@heliocat.net>
Date: Mon, 10 May 2021 23:32:08 -0700
Subject: [PATCH 4/9] qgo: fix license

---
 srcpkgs/qgo/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/qgo/template b/srcpkgs/qgo/template
index 82e76ecfafb1..44003270fb5c 100644
--- a/srcpkgs/qgo/template
+++ b/srcpkgs/qgo/template
@@ -1,13 +1,13 @@
 # Template file for 'qgo'
 pkgname=qgo
 version=2.1.1
-revision=1
+revision=2
 build_style=qmake
 hostmakedepends="git qt5-qmake qt5-tools qt5-host-tools"
 makedepends="qt5-devel qt5-multimedia-devel pulseaudio-devel"
 short_desc="Go/Weiqi/Baduk client that supports the IGS, GTP and SGF protocols"
 maintainer='Brandon Wilson <x@wilsonb.com>'
-license="GPL-2"
+license="GPL-2.0-or-later"
 homepage="https://github.com/pzorin/qgo"
 distfiles="https://github.com/xelxebar/${pkgname}/archive/v${version}.tar.gz"
 checksum="e4a36f92abded9536e2bedb5748fd3aba6d150248b1b26a6985763dc4c15434e"

From 0a7524b3734e40fb3ed681d2950d1d74630962fb Mon Sep 17 00:00:00 2001
From: Colin Booth <colin@heliocat.net>
Date: Mon, 10 May 2021 23:51:23 -0700
Subject: [PATCH 5/9] quingy: fix license, other lint

---
 srcpkgs/qingy/template | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)

diff --git a/srcpkgs/qingy/template b/srcpkgs/qingy/template
index 02c89bd1ccae..64f7f1f97ee5 100644
--- a/srcpkgs/qingy/template
+++ b/srcpkgs/qingy/template
@@ -1,20 +1,20 @@
 # Template file for 'qingy'
 pkgname=qingy
 version=1.0.0
-revision=29
-lib32disabled=yes
+revision=30
 build_style=gnu-configure
-makedepends="ncurses-devel libgcrypt-devel
- $(vopt_if pam pam-devel) $(vopt_if x11 'libXScrnSaver-devel libX11-devel xorgproto')"
 configure_args="--disable-optimizations --disable-static --disable-DirectFB-support
  --enable-crypto=libgcrypt $(vopt_enable pam) $(vopt_enable x11 x-support)"
+makedepends="ncurses-devel libgcrypt-devel
+ $(vopt_if pam pam-devel) $(vopt_if x11 'libXScrnSaver-devel libX11-devel xorgproto')"
 short_desc="Qingy Is Not Getty"
 maintainer="Jens E. Becker <v2px@v2px.de>"
-license="GPL-2"
+license="GPL-2.0-or-later"
 homepage="http://qingy.sourceforge.net"
 #distfiles="${SOURCEFORGE_SITE}/${pkgname}/${pkgname}-${version}.tar.bz2"
-distfiles="https://sources.voidlinux.org/qingy-1.0.0/qingy-1.0.0.tar.bz2"
+distfiles="https://sources.voidlinux.org/qingy-${version}/qingy-${version}.tar.bz2"
 checksum=de4b4b398d5ba81ab2544729864676a04ddc6ae818b357ee09a8770293740cd3
+lib32disabled=yes
 
 make_dirs="/var/lib/misc 0755 root root"
 

From 663269a4fd5410bef7654a3a49c15e70805e6165 Mon Sep 17 00:00:00 2001
From: Colin Booth <colin@heliocat.net>
Date: Tue, 11 May 2021 00:07:40 -0700
Subject: [PATCH 6/9] qoauth-qt5: fix license, http->https

---
 srcpkgs/qoauth-qt5/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/qoauth-qt5/template b/srcpkgs/qoauth-qt5/template
index ce38576e0e4c..d95b0bd2200f 100644
--- a/srcpkgs/qoauth-qt5/template
+++ b/srcpkgs/qoauth-qt5/template
@@ -1,7 +1,7 @@
 # Template file for 'qoauth-qt5'
 pkgname=qoauth-qt5
 version=2.0.0
-revision=1
+revision=2
 _gitrev=4b01e9fa5198f9e175f5e8e19868b32101f22b98
 wrksrc="qoauth-${_gitrev}"
 build_style=qmake
@@ -9,8 +9,8 @@ hostmakedepends="qt5-qmake qt5-host-tools"
 makedepends="qt5-devel qca-qt5-devel"
 short_desc="Support with OAuth-powered network services"
 maintainer="Orphaned <orphan@voidlinux.org>"
-license="GPL-2.1"
-homepage="http://github.com/ayoy/qoauth"
+license="LGPL-2.1-or-later"
+homepage="https://github.com/ayoy/qoauth"
 distfiles="https://github.com/ayoy/qoauth/archive/${_gitrev}.tar.gz>${pkgname}-${version}.tar.gz"
 checksum=9eef13bd6095d68ba7902514b300c23cb81a69a090ba82ced9d7cdf76a65d8e4
 

From 17fff82101dfc243da07085d14ff24476beabc5c Mon Sep 17 00:00:00 2001
From: Colin Booth <colin@heliocat.net>
Date: Tue, 11 May 2021 00:42:12 -0700
Subject: [PATCH 7/9] qqwing: fix license, http->https

---
 srcpkgs/qqwing/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/qqwing/template b/srcpkgs/qqwing/template
index ed31e0276bff..a65c90925df0 100644
--- a/srcpkgs/qqwing/template
+++ b/srcpkgs/qqwing/template
@@ -1,13 +1,13 @@
 # Template file for 'qqwing'
 pkgname=qqwing
 version=1.3.4
-revision=4
+revision=5
 build_style=gnu-configure
 hostmakedepends="automake libtool pkg-config"
 short_desc="Sudoku generating and solving library"
 maintainer="Orphaned <orphan@voidlinux.org>"
-license="GPL-2"
-homepage="http://qqwing.com/"
+license="GPL-2.0-or-later"
+homepage="https://qqwing.com/"
 distfiles="https://github.com/stephenostermiller/${pkgname}/archive/v${version}.tar.gz>${pkgname}-${version}.tar.gz"
 checksum=dc5d61b4470862b190d437f8143d4090639c164d34461c4caa5c081c5c91e6cc
 

From 7feee25418ba4d17e9a7244f4c1e944e9fd16437 Mon Sep 17 00:00:00 2001
From: Colin Booth <colin@heliocat.net>
Date: Tue, 11 May 2021 10:35:28 -0700
Subject: [PATCH 8/9] quota: fix license

---
 srcpkgs/quota/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/quota/template b/srcpkgs/quota/template
index 2751287061fd..1a3900de2404 100644
--- a/srcpkgs/quota/template
+++ b/srcpkgs/quota/template
@@ -1,7 +1,7 @@
 # Template file for 'quota'
 pkgname=quota
 version=4.06
-revision=1
+revision=2
 build_style=gnu-configure
 make_build_args="V=1"
 conf_files="/etc/quotagrpadmins /etc/quotatab /etc/warnquota.conf"
@@ -9,7 +9,7 @@ hostmakedepends="pkg-config automake gettext-devel"
 makedepends="dbus-devel e2fsprogs-devel libldap-devel libnl3-devel libtirpc-devel"
 short_desc="Linux disk quota tool"
 maintainer="Leah Neukirchen <leah@vuxu.org>"
-license="GPL-2"
+license="GPL-2.0-or-later"
 homepage="https://sourceforge.net/projects/linuxquota/"
 distfiles="${SOURCEFORGE_SITE}/linuxquota/quota-tools/${pkgname}-${version}.tar.gz"
 checksum=2f3e03039f378d4f0d97acdb49daf581dcaad64d2e1ddf129495fd579fbd268d

From 88112df81e613cb0276afba636b3caaa0e3eb46f Mon Sep 17 00:00:00 2001
From: Colin Booth <colin@heliocat.net>
Date: Tue, 11 May 2021 10:52:53 -0700
Subject: [PATCH 9/9] qupzilla: fix license, homepage

Setting the license and homepage to match that of falkon browser.
---
 srcpkgs/qupzilla/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/qupzilla/template b/srcpkgs/qupzilla/template
index 06bdbfb072d1..31c7d30695f6 100644
--- a/srcpkgs/qupzilla/template
+++ b/srcpkgs/qupzilla/template
@@ -2,10 +2,10 @@
 pkgname=qupzilla
 reverts="3.0.1_1"
 version=2.2.6
-revision=3
+revision=4
 build_style=meta
 depends="falkon>=${version}_${revision}"
 short_desc="Lightweight multiplatform browser (transitional dummy package)"
 maintainer="Orphaned <orphan@voidlinux.org>"
-license="GPL-3"
-homepage="https://qupzilla.com/"
+license="GPL-3.0-or-later"
+homepage="https://github.com/KDE/falkon"

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: [PR PATCH] [Updated] Omnibus lint pass for SPDX warnings - packages starting with Q
  2021-05-11 19:14 [PR PATCH] Omnibus lint pass for SPDX warnings - packages starting with Q heliocat
@ 2021-06-10  7:49 ` heliocat
  0 siblings, 0 replies; 2+ messages in thread
From: heliocat @ 2021-06-10  7:49 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1619 bytes --]

There is an updated pull request by heliocat against master on the void-packages repository

https://github.com/heliocat/void-packages lint_q
https://github.com/void-linux/void-packages/pull/30807

Omnibus lint pass for SPDX warnings - packages starting with Q
<!-- Mark items with [x] where applicable -->

#### General
- [ ] This is a new package and it conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements)

#### Have the results of the proposed changes been tested?
- [ ] I use the packages affected by the proposed changes on a regular basis and confirm this PR works for me
- [x] I generally don't use the affected packages but briefly tested this PR

<!--
If GitHub CI cannot be used to validate the build result (for example, if the
build is likely to take several hours), make sure to
[skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration).
When skipping CI, uncomment and fill out the following section.
Note: for builds that are likely to complete in less than 2 hours, it is not
acceptable to skip CI.
-->

#### Does it build and run successfully? 
(Please choose at least one native build and, if supported, at least one cross build. More are better.)
- [x] I built this PR locally for my native architecture, (x86_64)
- [x] I built this PR locally for these architectures (if supported. mark crossbuilds):
  - [x] aarch64-musl
  - [ ] armv7l
  - [ ] armv6l-musl



A patch file from https://github.com/void-linux/void-packages/pull/30807.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-lint_q-30807.patch --]
[-- Type: text/x-diff, Size: 10505 bytes --]

From 144e640fff3c93e5068a31b9c66c6c9dee4a795c Mon Sep 17 00:00:00 2001
From: Colin Booth <colin@heliocat.net>
Date: Mon, 10 May 2021 22:11:43 -0700
Subject: [PATCH 1/9] qarma: fix license, other lint

---
 srcpkgs/qarma/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/qarma/template b/srcpkgs/qarma/template
index 40351ba5c360..79c53bac5f3b 100644
--- a/srcpkgs/qarma/template
+++ b/srcpkgs/qarma/template
@@ -1,18 +1,18 @@
 # Template file for 'qarma'
 pkgname=qarma
 version=t1
-revision=1
+revision=2
 build_style=qmake
-provides="zenity-${version}_${revision}"
-replaces="zenity>=0"
 hostmakedepends="qt5-qmake qt5-host-tools"
 makedepends="qt5-x11extras-devel"
-maintainer="Orphaned <orphan@voidlinux.org>"
 short_desc="Tool to create dialog boxes, based on Qt"
+maintainer="Orphaned <orphan@voidlinux.org>"
+license="GPL-2.0-only"
 homepage="https://github.com/luebking/qarma"
-license="GPL-2"
 distfiles="https://github.com/luebking/qarma/archive/${version}.tar.gz"
 checksum=ebce381d2884e4109998bc4a966f1eb08cc549b2725b0f4c5525b30849754794
+replaces="zenity>=0"
+provides="zenity-${version}_${revision}"
 
 post_install() {
 	ln -s /usr/bin/qarma ${DESTDIR}/usr/bin/zenity

From dc1f95bc8a57f8ac8b79f695b14fbcb10e025aec Mon Sep 17 00:00:00 2001
From: Colin Booth <colin@heliocat.net>
Date: Mon, 10 May 2021 23:02:42 -0700
Subject: [PATCH 2/9] qemacs: fix license

---
 srcpkgs/qemacs/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/qemacs/template b/srcpkgs/qemacs/template
index 6805ba8e238b..15d4ed36cdba 100644
--- a/srcpkgs/qemacs/template
+++ b/srcpkgs/qemacs/template
@@ -1,7 +1,7 @@
 # Template file for 'qemacs'
 pkgname=qemacs
 version=0.5.0.20170701
-revision=2
+revision=3
 wrksrc="${pkgname}"
 build_style=configure
 configure_args="--prefix=/usr --mandir=/usr/share/man
@@ -9,8 +9,8 @@ configure_args="--prefix=/usr --mandir=/usr/share/man
 hostmakedepends="cvs"
 short_desc="Small but powerful Emacs clone (with UTF-8, HTML, shell, dired)"
 maintainer="Leah Neukirchen <leah@vuxu.org>"
-license="LGPL-2.1"
-homepage="http://bellard.org/qemacs/"
+license="LGPL-2.1-or-later"
+homepage="https://bellard.org/qemacs/"
 
 do_fetch() {
 	cvs -d :pserver:anonymous@cvs.savannah.nongnu.org:/sources/qemacs \

From 6e002f33b62b41a988c177da41a16820e19c0923 Mon Sep 17 00:00:00 2001
From: Colin Booth <colin@heliocat.net>
Date: Mon, 10 May 2021 23:05:20 -0700
Subject: [PATCH 3/9] qemuconf: fix license, other lint

---
 srcpkgs/qemuconf/template | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/qemuconf/template b/srcpkgs/qemuconf/template
index 365497fd4cd7..5ae35040ce05 100644
--- a/srcpkgs/qemuconf/template
+++ b/srcpkgs/qemuconf/template
@@ -1,20 +1,21 @@
 # Template file for 'qemuconf'
 pkgname=qemuconf
 version=0.2.1
-revision=2
+revision=3
 build_style=gnu-makefile
 make_install_target="install-runit"
 conf_files="/etc/qemu.d/generic.conf"
 depends="qemu"
-short_desc="simple qemu launcher with config file support"
+short_desc="Simple qemu launcher with config file support"
 maintainer="Enno Boland <gottox@voidlinux.org>"
-license="GPL-3"
+license="MIT"
 homepage="https://github.com/Gottox/qemuconf"
 distfiles="https://github.com/Gottox/qemuconf/archive/v${version}.tar.gz"
 checksum=8b57872e6f7d281e7ed7d142ff05efb50e2fbe2c46e656a30fbb1705b4382548
 
 post_install() {
 	vinstall generic.conf 644 etc/qemu.d
+	vlicense LICENSE
 	vbin qemuconf_import.sh
 	ln -s /run/runit/supervise.qemu-generic $DESTDIR/etc/sv/qemu-generic/supervise
 }

From b373aa43ec016202f877c8a7666086b1421d97f8 Mon Sep 17 00:00:00 2001
From: Colin Booth <colin@heliocat.net>
Date: Mon, 10 May 2021 23:32:08 -0700
Subject: [PATCH 4/9] qgo: fix license

---
 srcpkgs/qgo/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/qgo/template b/srcpkgs/qgo/template
index 82e76ecfafb1..44003270fb5c 100644
--- a/srcpkgs/qgo/template
+++ b/srcpkgs/qgo/template
@@ -1,13 +1,13 @@
 # Template file for 'qgo'
 pkgname=qgo
 version=2.1.1
-revision=1
+revision=2
 build_style=qmake
 hostmakedepends="git qt5-qmake qt5-tools qt5-host-tools"
 makedepends="qt5-devel qt5-multimedia-devel pulseaudio-devel"
 short_desc="Go/Weiqi/Baduk client that supports the IGS, GTP and SGF protocols"
 maintainer='Brandon Wilson <x@wilsonb.com>'
-license="GPL-2"
+license="GPL-2.0-or-later"
 homepage="https://github.com/pzorin/qgo"
 distfiles="https://github.com/xelxebar/${pkgname}/archive/v${version}.tar.gz"
 checksum="e4a36f92abded9536e2bedb5748fd3aba6d150248b1b26a6985763dc4c15434e"

From 942b26cb325225f0be629a28c94b1bbc2a0fc47d Mon Sep 17 00:00:00 2001
From: Colin Booth <colin@heliocat.net>
Date: Mon, 10 May 2021 23:51:23 -0700
Subject: [PATCH 5/9] quingy: fix license, other lint

---
 srcpkgs/qingy/template | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)

diff --git a/srcpkgs/qingy/template b/srcpkgs/qingy/template
index 02c89bd1ccae..64f7f1f97ee5 100644
--- a/srcpkgs/qingy/template
+++ b/srcpkgs/qingy/template
@@ -1,20 +1,20 @@
 # Template file for 'qingy'
 pkgname=qingy
 version=1.0.0
-revision=29
-lib32disabled=yes
+revision=30
 build_style=gnu-configure
-makedepends="ncurses-devel libgcrypt-devel
- $(vopt_if pam pam-devel) $(vopt_if x11 'libXScrnSaver-devel libX11-devel xorgproto')"
 configure_args="--disable-optimizations --disable-static --disable-DirectFB-support
  --enable-crypto=libgcrypt $(vopt_enable pam) $(vopt_enable x11 x-support)"
+makedepends="ncurses-devel libgcrypt-devel
+ $(vopt_if pam pam-devel) $(vopt_if x11 'libXScrnSaver-devel libX11-devel xorgproto')"
 short_desc="Qingy Is Not Getty"
 maintainer="Jens E. Becker <v2px@v2px.de>"
-license="GPL-2"
+license="GPL-2.0-or-later"
 homepage="http://qingy.sourceforge.net"
 #distfiles="${SOURCEFORGE_SITE}/${pkgname}/${pkgname}-${version}.tar.bz2"
-distfiles="https://sources.voidlinux.org/qingy-1.0.0/qingy-1.0.0.tar.bz2"
+distfiles="https://sources.voidlinux.org/qingy-${version}/qingy-${version}.tar.bz2"
 checksum=de4b4b398d5ba81ab2544729864676a04ddc6ae818b357ee09a8770293740cd3
+lib32disabled=yes
 
 make_dirs="/var/lib/misc 0755 root root"
 

From 2e2865c3dbca045f4ac9a60185b09434389646fe Mon Sep 17 00:00:00 2001
From: Colin Booth <colin@heliocat.net>
Date: Tue, 11 May 2021 00:07:40 -0700
Subject: [PATCH 6/9] qoauth-qt5: fix license, http->https

---
 srcpkgs/qoauth-qt5/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/qoauth-qt5/template b/srcpkgs/qoauth-qt5/template
index ce38576e0e4c..d95b0bd2200f 100644
--- a/srcpkgs/qoauth-qt5/template
+++ b/srcpkgs/qoauth-qt5/template
@@ -1,7 +1,7 @@
 # Template file for 'qoauth-qt5'
 pkgname=qoauth-qt5
 version=2.0.0
-revision=1
+revision=2
 _gitrev=4b01e9fa5198f9e175f5e8e19868b32101f22b98
 wrksrc="qoauth-${_gitrev}"
 build_style=qmake
@@ -9,8 +9,8 @@ hostmakedepends="qt5-qmake qt5-host-tools"
 makedepends="qt5-devel qca-qt5-devel"
 short_desc="Support with OAuth-powered network services"
 maintainer="Orphaned <orphan@voidlinux.org>"
-license="GPL-2.1"
-homepage="http://github.com/ayoy/qoauth"
+license="LGPL-2.1-or-later"
+homepage="https://github.com/ayoy/qoauth"
 distfiles="https://github.com/ayoy/qoauth/archive/${_gitrev}.tar.gz>${pkgname}-${version}.tar.gz"
 checksum=9eef13bd6095d68ba7902514b300c23cb81a69a090ba82ced9d7cdf76a65d8e4
 

From 3701902b56ce04b93ef5aeaed5462cf13c703fe3 Mon Sep 17 00:00:00 2001
From: Colin Booth <colin@heliocat.net>
Date: Tue, 11 May 2021 00:42:12 -0700
Subject: [PATCH 7/9] qqwing: fix license, http->https

---
 srcpkgs/qqwing/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/qqwing/template b/srcpkgs/qqwing/template
index ed31e0276bff..a65c90925df0 100644
--- a/srcpkgs/qqwing/template
+++ b/srcpkgs/qqwing/template
@@ -1,13 +1,13 @@
 # Template file for 'qqwing'
 pkgname=qqwing
 version=1.3.4
-revision=4
+revision=5
 build_style=gnu-configure
 hostmakedepends="automake libtool pkg-config"
 short_desc="Sudoku generating and solving library"
 maintainer="Orphaned <orphan@voidlinux.org>"
-license="GPL-2"
-homepage="http://qqwing.com/"
+license="GPL-2.0-or-later"
+homepage="https://qqwing.com/"
 distfiles="https://github.com/stephenostermiller/${pkgname}/archive/v${version}.tar.gz>${pkgname}-${version}.tar.gz"
 checksum=dc5d61b4470862b190d437f8143d4090639c164d34461c4caa5c081c5c91e6cc
 

From 08c95acc4463f60acea6984cf4d695c1a5ff62c8 Mon Sep 17 00:00:00 2001
From: Colin Booth <colin@heliocat.net>
Date: Tue, 11 May 2021 10:35:28 -0700
Subject: [PATCH 8/9] quota: fix license

---
 srcpkgs/quota/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/quota/template b/srcpkgs/quota/template
index 2751287061fd..1a3900de2404 100644
--- a/srcpkgs/quota/template
+++ b/srcpkgs/quota/template
@@ -1,7 +1,7 @@
 # Template file for 'quota'
 pkgname=quota
 version=4.06
-revision=1
+revision=2
 build_style=gnu-configure
 make_build_args="V=1"
 conf_files="/etc/quotagrpadmins /etc/quotatab /etc/warnquota.conf"
@@ -9,7 +9,7 @@ hostmakedepends="pkg-config automake gettext-devel"
 makedepends="dbus-devel e2fsprogs-devel libldap-devel libnl3-devel libtirpc-devel"
 short_desc="Linux disk quota tool"
 maintainer="Leah Neukirchen <leah@vuxu.org>"
-license="GPL-2"
+license="GPL-2.0-or-later"
 homepage="https://sourceforge.net/projects/linuxquota/"
 distfiles="${SOURCEFORGE_SITE}/linuxquota/quota-tools/${pkgname}-${version}.tar.gz"
 checksum=2f3e03039f378d4f0d97acdb49daf581dcaad64d2e1ddf129495fd579fbd268d

From e6d0dd9bae106f06c008d4a02dbb27c9d8a6d7c0 Mon Sep 17 00:00:00 2001
From: Colin Booth <colin@heliocat.net>
Date: Tue, 11 May 2021 10:52:53 -0700
Subject: [PATCH 9/9] qupzilla: fix license, homepage

Setting the license and homepage to match that of falkon browser.
---
 srcpkgs/qupzilla/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/qupzilla/template b/srcpkgs/qupzilla/template
index 06bdbfb072d1..31c7d30695f6 100644
--- a/srcpkgs/qupzilla/template
+++ b/srcpkgs/qupzilla/template
@@ -2,10 +2,10 @@
 pkgname=qupzilla
 reverts="3.0.1_1"
 version=2.2.6
-revision=3
+revision=4
 build_style=meta
 depends="falkon>=${version}_${revision}"
 short_desc="Lightweight multiplatform browser (transitional dummy package)"
 maintainer="Orphaned <orphan@voidlinux.org>"
-license="GPL-3"
-homepage="https://qupzilla.com/"
+license="GPL-3.0-or-later"
+homepage="https://github.com/KDE/falkon"

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2021-06-10  7:49 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-05-11 19:14 [PR PATCH] Omnibus lint pass for SPDX warnings - packages starting with Q heliocat
2021-06-10  7:49 ` [PR PATCH] [Updated] " heliocat

Github messages for voidlinux

This inbox may be cloned and mirrored by anyone:

	git clone --mirror http://inbox.vuxu.org/voidlinux-github

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V1 voidlinux-github voidlinux-github/ http://inbox.vuxu.org/voidlinux-github \
		voidlinux-github@inbox.vuxu.org
	public-inbox-index voidlinux-github

Example config snippet for mirrors.
Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.github.voidlinux


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git