Github messages for voidlinux
 help / color / mirror / Atom feed
* [PR PATCH] notcuses + growlight update.
@ 2021-12-05 13:44 mobinmob
  2021-12-31 15:45 ` [PR PATCH] [Updated] " mobinmob
                   ` (15 more replies)
  0 siblings, 16 replies; 17+ messages in thread
From: mobinmob @ 2021-12-05 13:44 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1215 bytes --]

There is a new pull request by mobinmob against master on the void-packages repository

https://github.com/mobinmob/void-packages notcurses
https://github.com/void-linux/void-packages/pull/34395

notcuses + growlight update.
<!-- Uncomment relevant sections and delete options which are not applicable -->

#### Testing the changes
- I tested the changes in this PR: **YES**
<!--
#### New package
- This new package conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements): **YES**|**NO**
-->

<!-- Note: If the build is likely to take more than 2 hours, please [skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration)
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->
<!-- 
#### Local build testing
- I built this PR locally for my native architecture, (ARCH-LIBC)
- I built this PR locally for these architectures (if supported. mark crossbuilds):
  - aarch64-musl
  - armv7l
  - armv6l-musl
-->


A patch file from https://github.com/void-linux/void-packages/pull/34395.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-notcurses-34395.patch --]
[-- Type: text/x-diff, Size: 5229 bytes --]

From ffa456e7dbe5d67c7e3c5def0fc5149ae80dfd80 Mon Sep 17 00:00:00 2001
From: mobinmob <mobinmob@disroot.org>
Date: Sun, 5 Dec 2021 15:41:50 +0200
Subject: [PATCH 1/3] New package: libdeflate-1.8.

---
 common/shlibs               |  1 +
 srcpkgs/libdeflate-devel    |  1 +
 srcpkgs/libdeflate/template | 27 +++++++++++++++++++++++++++
 3 files changed, 29 insertions(+)
 create mode 120000 srcpkgs/libdeflate-devel
 create mode 100644 srcpkgs/libdeflate/template

diff --git a/common/shlibs b/common/shlibs
index abdf7b261f8a..ee659f876449 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -4071,3 +4071,4 @@ libm4ri-0.0.20200125.so m4ri-20200125_1
 libm4rie-0.0.20200125.so m4rie-20200125_1
 libptytty.so.0 libptytty-2.0_1
 libcoeurl.so.0 coeurl-0.1.0_1
+libdeflate.so.0 libdeflate-1.8_1
diff --git a/srcpkgs/libdeflate-devel b/srcpkgs/libdeflate-devel
new file mode 120000
index 000000000000..e29c9946ff06
--- /dev/null
+++ b/srcpkgs/libdeflate-devel
@@ -0,0 +1 @@
+libdeflate
\ No newline at end of file
diff --git a/srcpkgs/libdeflate/template b/srcpkgs/libdeflate/template
new file mode 100644
index 000000000000..a2c0c3ac5469
--- /dev/null
+++ b/srcpkgs/libdeflate/template
@@ -0,0 +1,27 @@
+# Template file for 'libdeflate'
+pkgname=libdeflate
+version=1.8
+revision=1
+build_style=gnu-makefile
+make_build_args="PREFIX=/usr PROG_SUFFIX=libdeflate"
+checkdepends="zlib-devel"
+short_desc="Optimized library for DEFLATE/zlib/gzip (de)compression"
+maintainer="mobinmob <mobinmob@disroot.org>"
+license="MIT"
+homepage="https://github.com/ebiggers/libdeflate"
+distfiles="https://github.com/ebiggers/libdeflate/archive/refs/tags/v${version}.tar.gz"
+checksum=50711ad4e9d3862f8dfb11b97eb53631a86ee3ce49c0e68ec2b6d059a9662f61
+
+post_install() {
+	vlicense COPYING
+}
+
+libdeflate-devel_package() {
+	short_desc+=" - development files"
+	depends="${sourcepkg}>=${version}_${revision}"
+	pkg_install() {
+		vmove usr/include
+		vmove "usr/lib/*.a"
+		vmove "usr/lib/*.so"
+	}
+}

From 95e0222337bddd7e51c6ecac7340b424d0a8a83b Mon Sep 17 00:00:00 2001
From: mobinmob <mobinmob@disroot.org>
Date: Sun, 5 Dec 2021 15:42:01 +0200
Subject: [PATCH 2/3] notcurses: update to 3.0.0.

---
 common/shlibs              | 6 +++---
 srcpkgs/notcurses/template | 6 +++---
 2 files changed, 6 insertions(+), 6 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index ee659f876449..1d2a759d4ec8 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -3947,9 +3947,9 @@ liburing.so.2 liburing-2.0_1
 libbson-1.0.so.0 libbson-1.17.4_2
 libsonic.so.0 libsonic-0.2.0_1
 libtickit.so.3 libtickit-0.4.1_1
-libnotcurses.so.2 notcurses-2.4.9_1
-libnotcurses-core.so.2 notcurses-2.4.9_1
-libnotcurses++.so.2 notcurses-2.4.9_1
+libnotcurses.so.3 notcurses-3.0.0_1
+libnotcurses-core.so.3 notcurses-3.0.0_1
+libnotcurses++.so.3 notcurses-3.0.0_1
 libevemu.so.3 evemu-2.7.0_1
 libantilib.so.1 libantimicrox-3.1.2_1
 libinih.so.0 inih-52_1
diff --git a/srcpkgs/notcurses/template b/srcpkgs/notcurses/template
index c43cf269a988..8c37be88a218 100644
--- a/srcpkgs/notcurses/template
+++ b/srcpkgs/notcurses/template
@@ -1,12 +1,12 @@
 # Template file for 'notcurses'
 pkgname=notcurses
-version=2.4.9
+version=3.0.0
 revision=1
 build_style=cmake
 configure_args="-DUSE_STATIC=ON $(vopt_bool man USE_PANDOC)"
 hostmakedepends="pkg-config $(vopt_if man pandoc)"
 makedepends="libunistring-devel ffmpeg-devel ncurses-libtinfo-devel qrcodegen-devel doctest-devel
- zlib-devel"
+ libdeflate-devel"
 depends="ncurses-base"
 short_desc="Blingful character graphics/TUI library"
 maintainer="mobinmob <mobinmob@disroot.org>"
@@ -14,7 +14,7 @@ license="Apache-2.0"
 homepage="https://nick-black.com/dankwiki/index.php/Notcurses"
 changelog="https://raw.githubusercontent.com/dankamongmen/notcurses/master/NEWS.md"
 distfiles="https://github.com/dankamongmen/notcurses/archive/v${version}.tar.gz"
-checksum=a2771ad1633e0158f8273fa8b30b5bce0f12e1205e863045f4ae186b6b52f537
+checksum=b4839108ca8f9aef31d2f537485cbd878356bbcd4ad4f7a4dd19e72201d01cee
 
 build_options="man"
 desc_option_man="Use pandoc for manpages"

From 385590abdec4f6c27155f52530d3e7ba4d8f3e79 Mon Sep 17 00:00:00 2001
From: mobinmob <mobinmob@disroot.org>
Date: Sun, 5 Dec 2021 15:42:12 +0200
Subject: [PATCH 3/3] growlight: update to 1.2.38.

---
 srcpkgs/growlight/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/growlight/template b/srcpkgs/growlight/template
index 923b5da9a1ce..3703defbdfef 100644
--- a/srcpkgs/growlight/template
+++ b/srcpkgs/growlight/template
@@ -1,7 +1,7 @@
 # Template file for 'growlight'
 pkgname=growlight
-version=1.2.37
-revision=2
+version=1.2.38
+revision=1
 build_style=cmake
 configure_args="$(vopt_bool zfs USE_LIBZFS) $(vopt_bool man USE_PANDOC)"
 hostmakedepends="pkg-config $(vopt_if man pandoc)"
@@ -14,7 +14,7 @@ maintainer="mobinmob <mobinmob@disroot.org>"
 license="GPL-3.0-or-later"
 homepage="https://nick-black.com/dankwiki/index.php/Growlight"
 distfiles="https://github.com/dankamongmen/growlight/archive/v${version}.tar.gz"
-checksum=82a349b623dcfd5db6dc56332f52a2c605775dba31f926576466e9896240a090
+checksum=9c8a5854ba30aa66a7b806b75f00784942f29711dbde0787a29f06583e6ec7a3
 
 build_options="man zfs"
 

^ permalink raw reply	[flat|nested] 17+ messages in thread

* Re: [PR PATCH] [Updated] notcuses + growlight update.
  2021-12-05 13:44 [PR PATCH] notcuses + growlight update mobinmob
@ 2021-12-31 15:45 ` mobinmob
  2021-12-31 15:46 ` mobinmob
                   ` (14 subsequent siblings)
  15 siblings, 0 replies; 17+ messages in thread
From: mobinmob @ 2021-12-31 15:45 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1220 bytes --]

There is an updated pull request by mobinmob against master on the void-packages repository

https://github.com/mobinmob/void-packages notcurses
https://github.com/void-linux/void-packages/pull/34395

notcuses + growlight update.
<!-- Uncomment relevant sections and delete options which are not applicable -->

#### Testing the changes
- I tested the changes in this PR: **YES**
<!--
#### New package
- This new package conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements): **YES**|**NO**
-->

<!-- Note: If the build is likely to take more than 2 hours, please [skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration)
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->
<!-- 
#### Local build testing
- I built this PR locally for my native architecture, (ARCH-LIBC)
- I built this PR locally for these architectures (if supported. mark crossbuilds):
  - aarch64-musl
  - armv7l
  - armv6l-musl
-->


A patch file from https://github.com/void-linux/void-packages/pull/34395.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-notcurses-34395.patch --]
[-- Type: text/x-diff, Size: 5262 bytes --]

From 109005d30756750b09d8fe329232094d323b090f Mon Sep 17 00:00:00 2001
From: mobinmob <mobinmob@disroot.org>
Date: Fri, 31 Dec 2021 17:34:46 +0200
Subject: [PATCH 1/3] New package: libdeflate-1.8.

---
 common/shlibs               |  1 +
 srcpkgs/libdeflate-devel    |  1 +
 srcpkgs/libdeflate/template | 27 +++++++++++++++++++++++++++
 3 files changed, 29 insertions(+)
 create mode 120000 srcpkgs/libdeflate-devel
 create mode 100644 srcpkgs/libdeflate/template

diff --git a/common/shlibs b/common/shlibs
index 999d3ad714b8..84564939148a 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -4097,3 +4097,4 @@ libkmailconfirmbeforedeleting.so.5 kdepim-addons-21.08.3_1
 libkaddressbookprivate.so.5 kaddressbook-21.08.3_1
 libcodec2.so.1.0 codec2-1.0.1_1
 libx86emu.so.3 libx86emu-3.4_1
+libdeflate.so.0 libdeflate-1.8_1
diff --git a/srcpkgs/libdeflate-devel b/srcpkgs/libdeflate-devel
new file mode 120000
index 000000000000..e29c9946ff06
--- /dev/null
+++ b/srcpkgs/libdeflate-devel
@@ -0,0 +1 @@
+libdeflate
\ No newline at end of file
diff --git a/srcpkgs/libdeflate/template b/srcpkgs/libdeflate/template
new file mode 100644
index 000000000000..a2c0c3ac5469
--- /dev/null
+++ b/srcpkgs/libdeflate/template
@@ -0,0 +1,27 @@
+# Template file for 'libdeflate'
+pkgname=libdeflate
+version=1.8
+revision=1
+build_style=gnu-makefile
+make_build_args="PREFIX=/usr PROG_SUFFIX=libdeflate"
+checkdepends="zlib-devel"
+short_desc="Optimized library for DEFLATE/zlib/gzip (de)compression"
+maintainer="mobinmob <mobinmob@disroot.org>"
+license="MIT"
+homepage="https://github.com/ebiggers/libdeflate"
+distfiles="https://github.com/ebiggers/libdeflate/archive/refs/tags/v${version}.tar.gz"
+checksum=50711ad4e9d3862f8dfb11b97eb53631a86ee3ce49c0e68ec2b6d059a9662f61
+
+post_install() {
+	vlicense COPYING
+}
+
+libdeflate-devel_package() {
+	short_desc+=" - development files"
+	depends="${sourcepkg}>=${version}_${revision}"
+	pkg_install() {
+		vmove usr/include
+		vmove "usr/lib/*.a"
+		vmove "usr/lib/*.so"
+	}
+}

From 339da6240a39680aeaa20a914488a357e7d32b6e Mon Sep 17 00:00:00 2001
From: mobinmob <mobinmob@disroot.org>
Date: Fri, 31 Dec 2021 17:34:52 +0200
Subject: [PATCH 2/3] notcurses: update to 3.0.2.

---
 common/shlibs              | 6 +++---
 srcpkgs/notcurses/template | 6 +++---
 2 files changed, 6 insertions(+), 6 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index 84564939148a..a0716dabfc25 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -3950,9 +3950,9 @@ liburing.so.2 liburing-2.0_1
 libbson-1.0.so.0 libbson-1.17.4_2
 libsonic.so.0 libsonic-0.2.0_1
 libtickit.so.3 libtickit-0.4.1_1
-libnotcurses.so.2 notcurses-2.4.9_1
-libnotcurses-core.so.2 notcurses-2.4.9_1
-libnotcurses++.so.2 notcurses-2.4.9_1
+libnotcurses.so.3 notcurses-3.0.2_1
+libnotcurses-core.so.3 notcurses-3.0.2_1
+libnotcurses++.so.3 notcurses-3.0.2_1
 libevemu.so.3 evemu-2.7.0_1
 libantilib.so.1 libantimicrox-3.1.2_1
 libinih.so.0 inih-52_1
diff --git a/srcpkgs/notcurses/template b/srcpkgs/notcurses/template
index c43cf269a988..76742c57672b 100644
--- a/srcpkgs/notcurses/template
+++ b/srcpkgs/notcurses/template
@@ -1,12 +1,12 @@
 # Template file for 'notcurses'
 pkgname=notcurses
-version=2.4.9
+version=3.0.2
 revision=1
 build_style=cmake
 configure_args="-DUSE_STATIC=ON $(vopt_bool man USE_PANDOC)"
 hostmakedepends="pkg-config $(vopt_if man pandoc)"
 makedepends="libunistring-devel ffmpeg-devel ncurses-libtinfo-devel qrcodegen-devel doctest-devel
- zlib-devel"
+ libdeflate-devel"
 depends="ncurses-base"
 short_desc="Blingful character graphics/TUI library"
 maintainer="mobinmob <mobinmob@disroot.org>"
@@ -14,7 +14,7 @@ license="Apache-2.0"
 homepage="https://nick-black.com/dankwiki/index.php/Notcurses"
 changelog="https://raw.githubusercontent.com/dankamongmen/notcurses/master/NEWS.md"
 distfiles="https://github.com/dankamongmen/notcurses/archive/v${version}.tar.gz"
-checksum=a2771ad1633e0158f8273fa8b30b5bce0f12e1205e863045f4ae186b6b52f537
+checksum=b4839108ca8f9aef31d2f537485cbd878356bbcd4ad4f7a4dd19e72201d01cee
 
 build_options="man"
 desc_option_man="Use pandoc for manpages"

From df7ab3ad1f106de7ed1fdb743e7d14c983866ef3 Mon Sep 17 00:00:00 2001
From: mobinmob <mobinmob@disroot.org>
Date: Fri, 31 Dec 2021 17:34:57 +0200
Subject: [PATCH 3/3] growlight: update to 1.2.38.

---
 srcpkgs/growlight/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/growlight/template b/srcpkgs/growlight/template
index 923b5da9a1ce..3703defbdfef 100644
--- a/srcpkgs/growlight/template
+++ b/srcpkgs/growlight/template
@@ -1,7 +1,7 @@
 # Template file for 'growlight'
 pkgname=growlight
-version=1.2.37
-revision=2
+version=1.2.38
+revision=1
 build_style=cmake
 configure_args="$(vopt_bool zfs USE_LIBZFS) $(vopt_bool man USE_PANDOC)"
 hostmakedepends="pkg-config $(vopt_if man pandoc)"
@@ -14,7 +14,7 @@ maintainer="mobinmob <mobinmob@disroot.org>"
 license="GPL-3.0-or-later"
 homepage="https://nick-black.com/dankwiki/index.php/Growlight"
 distfiles="https://github.com/dankamongmen/growlight/archive/v${version}.tar.gz"
-checksum=82a349b623dcfd5db6dc56332f52a2c605775dba31f926576466e9896240a090
+checksum=9c8a5854ba30aa66a7b806b75f00784942f29711dbde0787a29f06583e6ec7a3
 
 build_options="man zfs"
 

^ permalink raw reply	[flat|nested] 17+ messages in thread

* Re: notcuses + growlight update.
  2021-12-05 13:44 [PR PATCH] notcuses + growlight update mobinmob
  2021-12-31 15:45 ` [PR PATCH] [Updated] " mobinmob
@ 2021-12-31 15:46 ` mobinmob
  2021-12-31 16:04 ` [PR PATCH] [Updated] " mobinmob
                   ` (13 subsequent siblings)
  15 siblings, 0 replies; 17+ messages in thread
From: mobinmob @ 2021-12-31 15:46 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 192 bytes --]

New comment by mobinmob on void-packages repository

https://github.com/void-linux/void-packages/pull/34395#issuecomment-1003404761

Comment:
- Update notcurses to 3.0.2.
- Rebase on master.

^ permalink raw reply	[flat|nested] 17+ messages in thread

* Re: [PR PATCH] [Updated] notcuses + growlight update.
  2021-12-05 13:44 [PR PATCH] notcuses + growlight update mobinmob
  2021-12-31 15:45 ` [PR PATCH] [Updated] " mobinmob
  2021-12-31 15:46 ` mobinmob
@ 2021-12-31 16:04 ` mobinmob
  2022-01-06 11:03 ` mobinmob
                   ` (12 subsequent siblings)
  15 siblings, 0 replies; 17+ messages in thread
From: mobinmob @ 2021-12-31 16:04 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1220 bytes --]

There is an updated pull request by mobinmob against master on the void-packages repository

https://github.com/mobinmob/void-packages notcurses
https://github.com/void-linux/void-packages/pull/34395

notcuses + growlight update.
<!-- Uncomment relevant sections and delete options which are not applicable -->

#### Testing the changes
- I tested the changes in this PR: **YES**
<!--
#### New package
- This new package conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements): **YES**|**NO**
-->

<!-- Note: If the build is likely to take more than 2 hours, please [skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration)
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->
<!-- 
#### Local build testing
- I built this PR locally for my native architecture, (ARCH-LIBC)
- I built this PR locally for these architectures (if supported. mark crossbuilds):
  - aarch64-musl
  - armv7l
  - armv6l-musl
-->


A patch file from https://github.com/void-linux/void-packages/pull/34395.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-notcurses-34395.patch --]
[-- Type: text/x-diff, Size: 5262 bytes --]

From 109005d30756750b09d8fe329232094d323b090f Mon Sep 17 00:00:00 2001
From: mobinmob <mobinmob@disroot.org>
Date: Fri, 31 Dec 2021 17:34:46 +0200
Subject: [PATCH 1/3] New package: libdeflate-1.8.

---
 common/shlibs               |  1 +
 srcpkgs/libdeflate-devel    |  1 +
 srcpkgs/libdeflate/template | 27 +++++++++++++++++++++++++++
 3 files changed, 29 insertions(+)
 create mode 120000 srcpkgs/libdeflate-devel
 create mode 100644 srcpkgs/libdeflate/template

diff --git a/common/shlibs b/common/shlibs
index 999d3ad714b8..84564939148a 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -4097,3 +4097,4 @@ libkmailconfirmbeforedeleting.so.5 kdepim-addons-21.08.3_1
 libkaddressbookprivate.so.5 kaddressbook-21.08.3_1
 libcodec2.so.1.0 codec2-1.0.1_1
 libx86emu.so.3 libx86emu-3.4_1
+libdeflate.so.0 libdeflate-1.8_1
diff --git a/srcpkgs/libdeflate-devel b/srcpkgs/libdeflate-devel
new file mode 120000
index 000000000000..e29c9946ff06
--- /dev/null
+++ b/srcpkgs/libdeflate-devel
@@ -0,0 +1 @@
+libdeflate
\ No newline at end of file
diff --git a/srcpkgs/libdeflate/template b/srcpkgs/libdeflate/template
new file mode 100644
index 000000000000..a2c0c3ac5469
--- /dev/null
+++ b/srcpkgs/libdeflate/template
@@ -0,0 +1,27 @@
+# Template file for 'libdeflate'
+pkgname=libdeflate
+version=1.8
+revision=1
+build_style=gnu-makefile
+make_build_args="PREFIX=/usr PROG_SUFFIX=libdeflate"
+checkdepends="zlib-devel"
+short_desc="Optimized library for DEFLATE/zlib/gzip (de)compression"
+maintainer="mobinmob <mobinmob@disroot.org>"
+license="MIT"
+homepage="https://github.com/ebiggers/libdeflate"
+distfiles="https://github.com/ebiggers/libdeflate/archive/refs/tags/v${version}.tar.gz"
+checksum=50711ad4e9d3862f8dfb11b97eb53631a86ee3ce49c0e68ec2b6d059a9662f61
+
+post_install() {
+	vlicense COPYING
+}
+
+libdeflate-devel_package() {
+	short_desc+=" - development files"
+	depends="${sourcepkg}>=${version}_${revision}"
+	pkg_install() {
+		vmove usr/include
+		vmove "usr/lib/*.a"
+		vmove "usr/lib/*.so"
+	}
+}

From ab69c05d15daa5323f7d0bc2beb65ac24b0f45f1 Mon Sep 17 00:00:00 2001
From: mobinmob <mobinmob@disroot.org>
Date: Fri, 31 Dec 2021 18:03:07 +0200
Subject: [PATCH 2/3] notcurses: update to 3.0.2.

---
 common/shlibs              | 6 +++---
 srcpkgs/notcurses/template | 6 +++---
 2 files changed, 6 insertions(+), 6 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index 84564939148a..a0716dabfc25 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -3950,9 +3950,9 @@ liburing.so.2 liburing-2.0_1
 libbson-1.0.so.0 libbson-1.17.4_2
 libsonic.so.0 libsonic-0.2.0_1
 libtickit.so.3 libtickit-0.4.1_1
-libnotcurses.so.2 notcurses-2.4.9_1
-libnotcurses-core.so.2 notcurses-2.4.9_1
-libnotcurses++.so.2 notcurses-2.4.9_1
+libnotcurses.so.3 notcurses-3.0.2_1
+libnotcurses-core.so.3 notcurses-3.0.2_1
+libnotcurses++.so.3 notcurses-3.0.2_1
 libevemu.so.3 evemu-2.7.0_1
 libantilib.so.1 libantimicrox-3.1.2_1
 libinih.so.0 inih-52_1
diff --git a/srcpkgs/notcurses/template b/srcpkgs/notcurses/template
index c43cf269a988..69d421961dd4 100644
--- a/srcpkgs/notcurses/template
+++ b/srcpkgs/notcurses/template
@@ -1,12 +1,12 @@
 # Template file for 'notcurses'
 pkgname=notcurses
-version=2.4.9
+version=3.0.2
 revision=1
 build_style=cmake
 configure_args="-DUSE_STATIC=ON $(vopt_bool man USE_PANDOC)"
 hostmakedepends="pkg-config $(vopt_if man pandoc)"
 makedepends="libunistring-devel ffmpeg-devel ncurses-libtinfo-devel qrcodegen-devel doctest-devel
- zlib-devel"
+ libdeflate-devel"
 depends="ncurses-base"
 short_desc="Blingful character graphics/TUI library"
 maintainer="mobinmob <mobinmob@disroot.org>"
@@ -14,7 +14,7 @@ license="Apache-2.0"
 homepage="https://nick-black.com/dankwiki/index.php/Notcurses"
 changelog="https://raw.githubusercontent.com/dankamongmen/notcurses/master/NEWS.md"
 distfiles="https://github.com/dankamongmen/notcurses/archive/v${version}.tar.gz"
-checksum=a2771ad1633e0158f8273fa8b30b5bce0f12e1205e863045f4ae186b6b52f537
+checksum=051ee9557f5842ead9f633495c9e28066a1c72ef5a15cbb72218a167df6ab1cc
 
 build_options="man"
 desc_option_man="Use pandoc for manpages"

From 795d4434028fd50185bd9b714e64ef8d7f82bc76 Mon Sep 17 00:00:00 2001
From: mobinmob <mobinmob@disroot.org>
Date: Fri, 31 Dec 2021 18:03:26 +0200
Subject: [PATCH 3/3] growlight: update to 1.2.38.

---
 srcpkgs/growlight/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/growlight/template b/srcpkgs/growlight/template
index 923b5da9a1ce..3703defbdfef 100644
--- a/srcpkgs/growlight/template
+++ b/srcpkgs/growlight/template
@@ -1,7 +1,7 @@
 # Template file for 'growlight'
 pkgname=growlight
-version=1.2.37
-revision=2
+version=1.2.38
+revision=1
 build_style=cmake
 configure_args="$(vopt_bool zfs USE_LIBZFS) $(vopt_bool man USE_PANDOC)"
 hostmakedepends="pkg-config $(vopt_if man pandoc)"
@@ -14,7 +14,7 @@ maintainer="mobinmob <mobinmob@disroot.org>"
 license="GPL-3.0-or-later"
 homepage="https://nick-black.com/dankwiki/index.php/Growlight"
 distfiles="https://github.com/dankamongmen/growlight/archive/v${version}.tar.gz"
-checksum=82a349b623dcfd5db6dc56332f52a2c605775dba31f926576466e9896240a090
+checksum=9c8a5854ba30aa66a7b806b75f00784942f29711dbde0787a29f06583e6ec7a3
 
 build_options="man zfs"
 

^ permalink raw reply	[flat|nested] 17+ messages in thread

* Re: [PR PATCH] [Updated] notcuses + growlight update.
  2021-12-05 13:44 [PR PATCH] notcuses + growlight update mobinmob
                   ` (2 preceding siblings ...)
  2021-12-31 16:04 ` [PR PATCH] [Updated] " mobinmob
@ 2022-01-06 11:03 ` mobinmob
  2022-01-06 11:04 ` mobinmob
                   ` (11 subsequent siblings)
  15 siblings, 0 replies; 17+ messages in thread
From: mobinmob @ 2022-01-06 11:03 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1220 bytes --]

There is an updated pull request by mobinmob against master on the void-packages repository

https://github.com/mobinmob/void-packages notcurses
https://github.com/void-linux/void-packages/pull/34395

notcuses + growlight update.
<!-- Uncomment relevant sections and delete options which are not applicable -->

#### Testing the changes
- I tested the changes in this PR: **YES**
<!--
#### New package
- This new package conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements): **YES**|**NO**
-->

<!-- Note: If the build is likely to take more than 2 hours, please [skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration)
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->
<!-- 
#### Local build testing
- I built this PR locally for my native architecture, (ARCH-LIBC)
- I built this PR locally for these architectures (if supported. mark crossbuilds):
  - aarch64-musl
  - armv7l
  - armv6l-musl
-->


A patch file from https://github.com/void-linux/void-packages/pull/34395.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-notcurses-34395.patch --]
[-- Type: text/x-diff, Size: 5260 bytes --]

From 0ce47b7634b9142bc041b06d0d911fc1f4b9d6a2 Mon Sep 17 00:00:00 2001
From: mobinmob <mobinmob@disroot.org>
Date: Fri, 31 Dec 2021 17:34:46 +0200
Subject: [PATCH 1/3] New package: libdeflate-1.8.

---
 common/shlibs               |  1 +
 srcpkgs/libdeflate-devel    |  1 +
 srcpkgs/libdeflate/template | 27 +++++++++++++++++++++++++++
 3 files changed, 29 insertions(+)
 create mode 120000 srcpkgs/libdeflate-devel
 create mode 100644 srcpkgs/libdeflate/template

diff --git a/common/shlibs b/common/shlibs
index 999d3ad714b8..84564939148a 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -4097,3 +4097,4 @@ libkmailconfirmbeforedeleting.so.5 kdepim-addons-21.08.3_1
 libkaddressbookprivate.so.5 kaddressbook-21.08.3_1
 libcodec2.so.1.0 codec2-1.0.1_1
 libx86emu.so.3 libx86emu-3.4_1
+libdeflate.so.0 libdeflate-1.8_1
diff --git a/srcpkgs/libdeflate-devel b/srcpkgs/libdeflate-devel
new file mode 120000
index 000000000000..e29c9946ff06
--- /dev/null
+++ b/srcpkgs/libdeflate-devel
@@ -0,0 +1 @@
+libdeflate
\ No newline at end of file
diff --git a/srcpkgs/libdeflate/template b/srcpkgs/libdeflate/template
new file mode 100644
index 000000000000..a2c0c3ac5469
--- /dev/null
+++ b/srcpkgs/libdeflate/template
@@ -0,0 +1,27 @@
+# Template file for 'libdeflate'
+pkgname=libdeflate
+version=1.8
+revision=1
+build_style=gnu-makefile
+make_build_args="PREFIX=/usr PROG_SUFFIX=libdeflate"
+checkdepends="zlib-devel"
+short_desc="Optimized library for DEFLATE/zlib/gzip (de)compression"
+maintainer="mobinmob <mobinmob@disroot.org>"
+license="MIT"
+homepage="https://github.com/ebiggers/libdeflate"
+distfiles="https://github.com/ebiggers/libdeflate/archive/refs/tags/v${version}.tar.gz"
+checksum=50711ad4e9d3862f8dfb11b97eb53631a86ee3ce49c0e68ec2b6d059a9662f61
+
+post_install() {
+	vlicense COPYING
+}
+
+libdeflate-devel_package() {
+	short_desc+=" - development files"
+	depends="${sourcepkg}>=${version}_${revision}"
+	pkg_install() {
+		vmove usr/include
+		vmove "usr/lib/*.a"
+		vmove "usr/lib/*.so"
+	}
+}

From 43a66dd20775d4d850fab3dc7e4920c1e732cbd1 Mon Sep 17 00:00:00 2001
From: mobinmob <mobinmob@disroot.org>
Date: Thu, 6 Jan 2022 11:59:15 +0200
Subject: [PATCH 2/3] notcurses: update to 3.0.3.

---
 common/shlibs              | 6 +++---
 srcpkgs/notcurses/template | 6 +++---
 2 files changed, 6 insertions(+), 6 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index 84564939148a..a0716dabfc25 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -3950,9 +3950,9 @@ liburing.so.2 liburing-2.0_1
 libbson-1.0.so.0 libbson-1.17.4_2
 libsonic.so.0 libsonic-0.2.0_1
 libtickit.so.3 libtickit-0.4.1_1
-libnotcurses.so.2 notcurses-2.4.9_1
-libnotcurses-core.so.2 notcurses-2.4.9_1
-libnotcurses++.so.2 notcurses-2.4.9_1
+libnotcurses.so.3 notcurses-3.0.2_1
+libnotcurses-core.so.3 notcurses-3.0.2_1
+libnotcurses++.so.3 notcurses-3.0.2_1
 libevemu.so.3 evemu-2.7.0_1
 libantilib.so.1 libantimicrox-3.1.2_1
 libinih.so.0 inih-52_1
diff --git a/srcpkgs/notcurses/template b/srcpkgs/notcurses/template
index c43cf269a988..e88c8ef66295 100644
--- a/srcpkgs/notcurses/template
+++ b/srcpkgs/notcurses/template
@@ -1,12 +1,12 @@
 # Template file for 'notcurses'
 pkgname=notcurses
-version=2.4.9
+version=3.0.3
 revision=1
 build_style=cmake
 configure_args="-DUSE_STATIC=ON $(vopt_bool man USE_PANDOC)"
 hostmakedepends="pkg-config $(vopt_if man pandoc)"
 makedepends="libunistring-devel ffmpeg-devel ncurses-libtinfo-devel qrcodegen-devel doctest-devel
- zlib-devel"
+ libdeflate-devel"
 depends="ncurses-base"
 short_desc="Blingful character graphics/TUI library"
 maintainer="mobinmob <mobinmob@disroot.org>"
@@ -14,7 +14,7 @@ license="Apache-2.0"
 homepage="https://nick-black.com/dankwiki/index.php/Notcurses"
 changelog="https://raw.githubusercontent.com/dankamongmen/notcurses/master/NEWS.md"
 distfiles="https://github.com/dankamongmen/notcurses/archive/v${version}.tar.gz"
-checksum=a2771ad1633e0158f8273fa8b30b5bce0f12e1205e863045f4ae186b6b52f537
+checksum=3be27640578f5b79c921d018cb14448867326737bc0d512c9f11c047dc9e478a
 
 build_options="man"
 desc_option_man="Use pandoc for manpages"

From 6350c6b97f7605842b695c9dfcef2d302008f0d8 Mon Sep 17 00:00:00 2001
From: mobinmob <mobinmob@disroot.org>
Date: Thu, 6 Jan 2022 11:59:22 +0200
Subject: [PATCH 3/3] growlight: update to 1.2.38.

---
 srcpkgs/growlight/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/growlight/template b/srcpkgs/growlight/template
index 923b5da9a1ce..3703defbdfef 100644
--- a/srcpkgs/growlight/template
+++ b/srcpkgs/growlight/template
@@ -1,7 +1,7 @@
 # Template file for 'growlight'
 pkgname=growlight
-version=1.2.37
-revision=2
+version=1.2.38
+revision=1
 build_style=cmake
 configure_args="$(vopt_bool zfs USE_LIBZFS) $(vopt_bool man USE_PANDOC)"
 hostmakedepends="pkg-config $(vopt_if man pandoc)"
@@ -14,7 +14,7 @@ maintainer="mobinmob <mobinmob@disroot.org>"
 license="GPL-3.0-or-later"
 homepage="https://nick-black.com/dankwiki/index.php/Growlight"
 distfiles="https://github.com/dankamongmen/growlight/archive/v${version}.tar.gz"
-checksum=82a349b623dcfd5db6dc56332f52a2c605775dba31f926576466e9896240a090
+checksum=9c8a5854ba30aa66a7b806b75f00784942f29711dbde0787a29f06583e6ec7a3
 
 build_options="man zfs"
 

^ permalink raw reply	[flat|nested] 17+ messages in thread

* Re: notcuses + growlight update.
  2021-12-05 13:44 [PR PATCH] notcuses + growlight update mobinmob
                   ` (3 preceding siblings ...)
  2022-01-06 11:03 ` mobinmob
@ 2022-01-06 11:04 ` mobinmob
  2022-01-10 17:45 ` [PR PATCH] [Updated] " mobinmob
                   ` (10 subsequent siblings)
  15 siblings, 0 replies; 17+ messages in thread
From: mobinmob @ 2022-01-06 11:04 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 192 bytes --]

New comment by mobinmob on void-packages repository

https://github.com/void-linux/void-packages/pull/34395#issuecomment-1006481387

Comment:
- Update notcurses to 3.0.3,
- Rebase on master.

^ permalink raw reply	[flat|nested] 17+ messages in thread

* Re: [PR PATCH] [Updated] notcuses + growlight update.
  2021-12-05 13:44 [PR PATCH] notcuses + growlight update mobinmob
                   ` (4 preceding siblings ...)
  2022-01-06 11:04 ` mobinmob
@ 2022-01-10 17:45 ` mobinmob
  2022-01-10 17:46 ` mobinmob
                   ` (9 subsequent siblings)
  15 siblings, 0 replies; 17+ messages in thread
From: mobinmob @ 2022-01-10 17:45 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1220 bytes --]

There is an updated pull request by mobinmob against master on the void-packages repository

https://github.com/mobinmob/void-packages notcurses
https://github.com/void-linux/void-packages/pull/34395

notcuses + growlight update.
<!-- Uncomment relevant sections and delete options which are not applicable -->

#### Testing the changes
- I tested the changes in this PR: **YES**
<!--
#### New package
- This new package conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements): **YES**|**NO**
-->

<!-- Note: If the build is likely to take more than 2 hours, please [skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration)
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->
<!-- 
#### Local build testing
- I built this PR locally for my native architecture, (ARCH-LIBC)
- I built this PR locally for these architectures (if supported. mark crossbuilds):
  - aarch64-musl
  - armv7l
  - armv6l-musl
-->


A patch file from https://github.com/void-linux/void-packages/pull/34395.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-notcurses-34395.patch --]
[-- Type: text/x-diff, Size: 5262 bytes --]

From 7701edaf4da3acc071727cee9c3b8cfb13cc1073 Mon Sep 17 00:00:00 2001
From: mobinmob <mobinmob@disroot.org>
Date: Fri, 31 Dec 2021 17:34:46 +0200
Subject: [PATCH 1/3] New package: libdeflate-1.8.

---
 common/shlibs               |  1 +
 srcpkgs/libdeflate-devel    |  1 +
 srcpkgs/libdeflate/template | 27 +++++++++++++++++++++++++++
 3 files changed, 29 insertions(+)
 create mode 120000 srcpkgs/libdeflate-devel
 create mode 100644 srcpkgs/libdeflate/template

diff --git a/common/shlibs b/common/shlibs
index 999d3ad714b8..84564939148a 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -4097,3 +4097,4 @@ libkmailconfirmbeforedeleting.so.5 kdepim-addons-21.08.3_1
 libkaddressbookprivate.so.5 kaddressbook-21.08.3_1
 libcodec2.so.1.0 codec2-1.0.1_1
 libx86emu.so.3 libx86emu-3.4_1
+libdeflate.so.0 libdeflate-1.8_1
diff --git a/srcpkgs/libdeflate-devel b/srcpkgs/libdeflate-devel
new file mode 120000
index 000000000000..e29c9946ff06
--- /dev/null
+++ b/srcpkgs/libdeflate-devel
@@ -0,0 +1 @@
+libdeflate
\ No newline at end of file
diff --git a/srcpkgs/libdeflate/template b/srcpkgs/libdeflate/template
new file mode 100644
index 000000000000..a2c0c3ac5469
--- /dev/null
+++ b/srcpkgs/libdeflate/template
@@ -0,0 +1,27 @@
+# Template file for 'libdeflate'
+pkgname=libdeflate
+version=1.8
+revision=1
+build_style=gnu-makefile
+make_build_args="PREFIX=/usr PROG_SUFFIX=libdeflate"
+checkdepends="zlib-devel"
+short_desc="Optimized library for DEFLATE/zlib/gzip (de)compression"
+maintainer="mobinmob <mobinmob@disroot.org>"
+license="MIT"
+homepage="https://github.com/ebiggers/libdeflate"
+distfiles="https://github.com/ebiggers/libdeflate/archive/refs/tags/v${version}.tar.gz"
+checksum=50711ad4e9d3862f8dfb11b97eb53631a86ee3ce49c0e68ec2b6d059a9662f61
+
+post_install() {
+	vlicense COPYING
+}
+
+libdeflate-devel_package() {
+	short_desc+=" - development files"
+	depends="${sourcepkg}>=${version}_${revision}"
+	pkg_install() {
+		vmove usr/include
+		vmove "usr/lib/*.a"
+		vmove "usr/lib/*.so"
+	}
+}

From 0b1fda512997f06cb023a3dd12e67628fd186250 Mon Sep 17 00:00:00 2001
From: mobinmob <mobinmob@disroot.org>
Date: Mon, 10 Jan 2022 19:44:14 +0200
Subject: [PATCH 2/3] notcurses: update to 3.0.4.

---
 common/shlibs              | 6 +++---
 srcpkgs/notcurses/template | 6 +++---
 2 files changed, 6 insertions(+), 6 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index 84564939148a..a0716dabfc25 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -3950,9 +3950,9 @@ liburing.so.2 liburing-2.0_1
 libbson-1.0.so.0 libbson-1.17.4_2
 libsonic.so.0 libsonic-0.2.0_1
 libtickit.so.3 libtickit-0.4.1_1
-libnotcurses.so.2 notcurses-2.4.9_1
-libnotcurses-core.so.2 notcurses-2.4.9_1
-libnotcurses++.so.2 notcurses-2.4.9_1
+libnotcurses.so.3 notcurses-3.0.2_1
+libnotcurses-core.so.3 notcurses-3.0.2_1
+libnotcurses++.so.3 notcurses-3.0.2_1
 libevemu.so.3 evemu-2.7.0_1
 libantilib.so.1 libantimicrox-3.1.2_1
 libinih.so.0 inih-52_1
diff --git a/srcpkgs/notcurses/template b/srcpkgs/notcurses/template
index c43cf269a988..2d1f4bc5d084 100644
--- a/srcpkgs/notcurses/template
+++ b/srcpkgs/notcurses/template
@@ -1,12 +1,12 @@
 # Template file for 'notcurses'
 pkgname=notcurses
-version=2.4.9
+version=3.0.4
 revision=1
 build_style=cmake
 configure_args="-DUSE_STATIC=ON $(vopt_bool man USE_PANDOC)"
 hostmakedepends="pkg-config $(vopt_if man pandoc)"
 makedepends="libunistring-devel ffmpeg-devel ncurses-libtinfo-devel qrcodegen-devel doctest-devel
- zlib-devel"
+ libdeflate-devel"
 depends="ncurses-base"
 short_desc="Blingful character graphics/TUI library"
 maintainer="mobinmob <mobinmob@disroot.org>"
@@ -14,7 +14,7 @@ license="Apache-2.0"
 homepage="https://nick-black.com/dankwiki/index.php/Notcurses"
 changelog="https://raw.githubusercontent.com/dankamongmen/notcurses/master/NEWS.md"
 distfiles="https://github.com/dankamongmen/notcurses/archive/v${version}.tar.gz"
-checksum=a2771ad1633e0158f8273fa8b30b5bce0f12e1205e863045f4ae186b6b52f537
+checksum=467f826ab98e80a35a0ed10ff8f402fa6eba7e9d8cc297980856d73f659f4c19
 
 build_options="man"
 desc_option_man="Use pandoc for manpages"

From 407279d91c1fa78e709c99d2731dbfb656c59927 Mon Sep 17 00:00:00 2001
From: mobinmob <mobinmob@disroot.org>
Date: Mon, 10 Jan 2022 19:44:20 +0200
Subject: [PATCH 3/3] growlight: update to 1.2.38.

---
 srcpkgs/growlight/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/growlight/template b/srcpkgs/growlight/template
index 923b5da9a1ce..3703defbdfef 100644
--- a/srcpkgs/growlight/template
+++ b/srcpkgs/growlight/template
@@ -1,7 +1,7 @@
 # Template file for 'growlight'
 pkgname=growlight
-version=1.2.37
-revision=2
+version=1.2.38
+revision=1
 build_style=cmake
 configure_args="$(vopt_bool zfs USE_LIBZFS) $(vopt_bool man USE_PANDOC)"
 hostmakedepends="pkg-config $(vopt_if man pandoc)"
@@ -14,7 +14,7 @@ maintainer="mobinmob <mobinmob@disroot.org>"
 license="GPL-3.0-or-later"
 homepage="https://nick-black.com/dankwiki/index.php/Growlight"
 distfiles="https://github.com/dankamongmen/growlight/archive/v${version}.tar.gz"
-checksum=82a349b623dcfd5db6dc56332f52a2c605775dba31f926576466e9896240a090
+checksum=9c8a5854ba30aa66a7b806b75f00784942f29711dbde0787a29f06583e6ec7a3
 
 build_options="man zfs"
 

^ permalink raw reply	[flat|nested] 17+ messages in thread

* Re: notcuses + growlight update.
  2021-12-05 13:44 [PR PATCH] notcuses + growlight update mobinmob
                   ` (5 preceding siblings ...)
  2022-01-10 17:45 ` [PR PATCH] [Updated] " mobinmob
@ 2022-01-10 17:46 ` mobinmob
  2022-01-13 19:54 ` [PR REVIEW] " Piraty
                   ` (8 subsequent siblings)
  15 siblings, 0 replies; 17+ messages in thread
From: mobinmob @ 2022-01-10 17:46 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 192 bytes --]

New comment by mobinmob on void-packages repository

https://github.com/void-linux/void-packages/pull/34395#issuecomment-1009172601

Comment:
- Update notcurses to 3.0.4.
- Rebase on master.

^ permalink raw reply	[flat|nested] 17+ messages in thread

* Re: [PR REVIEW] notcuses + growlight update.
  2021-12-05 13:44 [PR PATCH] notcuses + growlight update mobinmob
                   ` (6 preceding siblings ...)
  2022-01-10 17:46 ` mobinmob
@ 2022-01-13 19:54 ` Piraty
  2022-01-14 13:52 ` [PR PATCH] [Updated] " mobinmob
                   ` (7 subsequent siblings)
  15 siblings, 0 replies; 17+ messages in thread
From: Piraty @ 2022-01-13 19:54 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 242 bytes --]

New review comment by Piraty on void-packages repository

https://github.com/void-linux/void-packages/pull/34395#discussion_r784279739

Comment:
PREFIX should not be required..? https://github.com/ebiggers/libdeflate/blob/master/Makefile#L80

^ permalink raw reply	[flat|nested] 17+ messages in thread

* Re: [PR PATCH] [Updated] notcuses + growlight update.
  2021-12-05 13:44 [PR PATCH] notcuses + growlight update mobinmob
                   ` (7 preceding siblings ...)
  2022-01-13 19:54 ` [PR REVIEW] " Piraty
@ 2022-01-14 13:52 ` mobinmob
  2022-01-14 13:52 ` [PR REVIEW] " mobinmob
                   ` (6 subsequent siblings)
  15 siblings, 0 replies; 17+ messages in thread
From: mobinmob @ 2022-01-14 13:52 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1220 bytes --]

There is an updated pull request by mobinmob against master on the void-packages repository

https://github.com/mobinmob/void-packages notcurses
https://github.com/void-linux/void-packages/pull/34395

notcuses + growlight update.
<!-- Uncomment relevant sections and delete options which are not applicable -->

#### Testing the changes
- I tested the changes in this PR: **YES**
<!--
#### New package
- This new package conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements): **YES**|**NO**
-->

<!-- Note: If the build is likely to take more than 2 hours, please [skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration)
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->
<!-- 
#### Local build testing
- I built this PR locally for my native architecture, (ARCH-LIBC)
- I built this PR locally for these architectures (if supported. mark crossbuilds):
  - aarch64-musl
  - armv7l
  - armv6l-musl
-->


A patch file from https://github.com/void-linux/void-packages/pull/34395.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-notcurses-34395.patch --]
[-- Type: text/x-diff, Size: 5250 bytes --]

From d1449e3485924826ff69229f33956dc5872f8be3 Mon Sep 17 00:00:00 2001
From: mobinmob <mobinmob@disroot.org>
Date: Fri, 14 Jan 2022 15:50:11 +0200
Subject: [PATCH 1/3] New package: libdeflate-1.8.

---
 common/shlibs               |  1 +
 srcpkgs/libdeflate-devel    |  1 +
 srcpkgs/libdeflate/template | 27 +++++++++++++++++++++++++++
 3 files changed, 29 insertions(+)
 create mode 120000 srcpkgs/libdeflate-devel
 create mode 100644 srcpkgs/libdeflate/template

diff --git a/common/shlibs b/common/shlibs
index ebbd48a3d84c..1d00f0388b80 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -4097,3 +4097,4 @@ libkmailconfirmbeforedeleting.so.5 kdepim-addons-21.08.3_1
 libkaddressbookprivate.so.5 kaddressbook-21.08.3_1
 libcodec2.so.1.0 codec2-1.0.1_1
 libx86emu.so.3 libx86emu-3.4_1
+libdeflate.so.0 libdeflate-1.8_1
diff --git a/srcpkgs/libdeflate-devel b/srcpkgs/libdeflate-devel
new file mode 120000
index 000000000000..e29c9946ff06
--- /dev/null
+++ b/srcpkgs/libdeflate-devel
@@ -0,0 +1 @@
+libdeflate
\ No newline at end of file
diff --git a/srcpkgs/libdeflate/template b/srcpkgs/libdeflate/template
new file mode 100644
index 000000000000..39a30bd14bee
--- /dev/null
+++ b/srcpkgs/libdeflate/template
@@ -0,0 +1,27 @@
+# Template file for 'libdeflate'
+pkgname=libdeflate
+version=1.8
+revision=1
+build_style=gnu-makefile
+make_build_args="PROG_SUFFIX=libdeflate"
+checkdepends="zlib-devel"
+short_desc="Optimized library for DEFLATE/zlib/gzip (de)compression"
+maintainer="mobinmob <mobinmob@disroot.org>"
+license="MIT"
+homepage="https://github.com/ebiggers/libdeflate"
+distfiles="https://github.com/ebiggers/libdeflate/archive/refs/tags/v${version}.tar.gz"
+checksum=50711ad4e9d3862f8dfb11b97eb53631a86ee3ce49c0e68ec2b6d059a9662f61
+
+post_install() {
+	vlicense COPYING
+}
+
+libdeflate-devel_package() {
+	short_desc+=" - development files"
+	depends="${sourcepkg}>=${version}_${revision}"
+	pkg_install() {
+		vmove usr/include
+		vmove "usr/lib/*.a"
+		vmove "usr/lib/*.so"
+	}
+}

From f72a361d6047da744a43a3d9a4ba170f1b56df2f Mon Sep 17 00:00:00 2001
From: mobinmob <mobinmob@disroot.org>
Date: Fri, 14 Jan 2022 15:50:30 +0200
Subject: [PATCH 2/3] notcurses: update to 3.0.4.

---
 common/shlibs              | 6 +++---
 srcpkgs/notcurses/template | 6 +++---
 2 files changed, 6 insertions(+), 6 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index 1d00f0388b80..069f0e4fdf66 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -3950,9 +3950,9 @@ liburing.so.2 liburing-2.0_1
 libbson-1.0.so.0 libbson-1.17.4_2
 libsonic.so.0 libsonic-0.2.0_1
 libtickit.so.3 libtickit-0.4.1_1
-libnotcurses.so.2 notcurses-2.4.9_1
-libnotcurses-core.so.2 notcurses-2.4.9_1
-libnotcurses++.so.2 notcurses-2.4.9_1
+libnotcurses.so.3 notcurses-3.0.2_1
+libnotcurses-core.so.3 notcurses-3.0.2_1
+libnotcurses++.so.3 notcurses-3.0.2_1
 libevemu.so.3 evemu-2.7.0_1
 libantilib.so.1 libantimicrox-3.1.2_1
 libinih.so.0 inih-52_1
diff --git a/srcpkgs/notcurses/template b/srcpkgs/notcurses/template
index c43cf269a988..2d1f4bc5d084 100644
--- a/srcpkgs/notcurses/template
+++ b/srcpkgs/notcurses/template
@@ -1,12 +1,12 @@
 # Template file for 'notcurses'
 pkgname=notcurses
-version=2.4.9
+version=3.0.4
 revision=1
 build_style=cmake
 configure_args="-DUSE_STATIC=ON $(vopt_bool man USE_PANDOC)"
 hostmakedepends="pkg-config $(vopt_if man pandoc)"
 makedepends="libunistring-devel ffmpeg-devel ncurses-libtinfo-devel qrcodegen-devel doctest-devel
- zlib-devel"
+ libdeflate-devel"
 depends="ncurses-base"
 short_desc="Blingful character graphics/TUI library"
 maintainer="mobinmob <mobinmob@disroot.org>"
@@ -14,7 +14,7 @@ license="Apache-2.0"
 homepage="https://nick-black.com/dankwiki/index.php/Notcurses"
 changelog="https://raw.githubusercontent.com/dankamongmen/notcurses/master/NEWS.md"
 distfiles="https://github.com/dankamongmen/notcurses/archive/v${version}.tar.gz"
-checksum=a2771ad1633e0158f8273fa8b30b5bce0f12e1205e863045f4ae186b6b52f537
+checksum=467f826ab98e80a35a0ed10ff8f402fa6eba7e9d8cc297980856d73f659f4c19
 
 build_options="man"
 desc_option_man="Use pandoc for manpages"

From 4e0a92d885bc1eb11b9bca23e1a1834a3e177019 Mon Sep 17 00:00:00 2001
From: mobinmob <mobinmob@disroot.org>
Date: Fri, 14 Jan 2022 15:50:36 +0200
Subject: [PATCH 3/3] growlight: update to 1.2.38.

---
 srcpkgs/growlight/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/growlight/template b/srcpkgs/growlight/template
index 923b5da9a1ce..3703defbdfef 100644
--- a/srcpkgs/growlight/template
+++ b/srcpkgs/growlight/template
@@ -1,7 +1,7 @@
 # Template file for 'growlight'
 pkgname=growlight
-version=1.2.37
-revision=2
+version=1.2.38
+revision=1
 build_style=cmake
 configure_args="$(vopt_bool zfs USE_LIBZFS) $(vopt_bool man USE_PANDOC)"
 hostmakedepends="pkg-config $(vopt_if man pandoc)"
@@ -14,7 +14,7 @@ maintainer="mobinmob <mobinmob@disroot.org>"
 license="GPL-3.0-or-later"
 homepage="https://nick-black.com/dankwiki/index.php/Growlight"
 distfiles="https://github.com/dankamongmen/growlight/archive/v${version}.tar.gz"
-checksum=82a349b623dcfd5db6dc56332f52a2c605775dba31f926576466e9896240a090
+checksum=9c8a5854ba30aa66a7b806b75f00784942f29711dbde0787a29f06583e6ec7a3
 
 build_options="man zfs"
 

^ permalink raw reply	[flat|nested] 17+ messages in thread

* Re: [PR REVIEW] notcuses + growlight update.
  2021-12-05 13:44 [PR PATCH] notcuses + growlight update mobinmob
                   ` (8 preceding siblings ...)
  2022-01-14 13:52 ` [PR PATCH] [Updated] " mobinmob
@ 2022-01-14 13:52 ` mobinmob
  2022-01-22 14:23 ` [PR PATCH] [Updated] " mobinmob
                   ` (5 subsequent siblings)
  15 siblings, 0 replies; 17+ messages in thread
From: mobinmob @ 2022-01-14 13:52 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 169 bytes --]

New review comment by mobinmob on void-packages repository

https://github.com/void-linux/void-packages/pull/34395#discussion_r784858741

Comment:
Yep, fixed. Thanks :)

^ permalink raw reply	[flat|nested] 17+ messages in thread

* Re: [PR PATCH] [Updated] notcuses + growlight update.
  2021-12-05 13:44 [PR PATCH] notcuses + growlight update mobinmob
                   ` (9 preceding siblings ...)
  2022-01-14 13:52 ` [PR REVIEW] " mobinmob
@ 2022-01-22 14:23 ` mobinmob
  2022-01-22 14:24 ` mobinmob
                   ` (4 subsequent siblings)
  15 siblings, 0 replies; 17+ messages in thread
From: mobinmob @ 2022-01-22 14:23 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1220 bytes --]

There is an updated pull request by mobinmob against master on the void-packages repository

https://github.com/mobinmob/void-packages notcurses
https://github.com/void-linux/void-packages/pull/34395

notcuses + growlight update.
<!-- Uncomment relevant sections and delete options which are not applicable -->

#### Testing the changes
- I tested the changes in this PR: **YES**
<!--
#### New package
- This new package conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements): **YES**|**NO**
-->

<!-- Note: If the build is likely to take more than 2 hours, please [skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration)
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->
<!-- 
#### Local build testing
- I built this PR locally for my native architecture, (ARCH-LIBC)
- I built this PR locally for these architectures (if supported. mark crossbuilds):
  - aarch64-musl
  - armv7l
  - armv6l-musl
-->


A patch file from https://github.com/void-linux/void-packages/pull/34395.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-notcurses-34395.patch --]
[-- Type: text/x-diff, Size: 5358 bytes --]

From 0ffa6e3503e623223816aab60bc050e9b938e61c Mon Sep 17 00:00:00 2001
From: mobinmob <mobinmob@disroot.org>
Date: Sat, 22 Jan 2022 16:20:48 +0200
Subject: [PATCH 1/3] notcurses: update to 3.0.5.

Also:
- update shlibs and add libnotcurses-ffi.so.3 (@dontlaugh).
---
 common/shlibs              | 7 ++++---
 srcpkgs/notcurses/template | 6 +++---
 2 files changed, 7 insertions(+), 6 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index 6fe46eaaeb05..81b10645010a 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -3952,9 +3952,10 @@ liburing.so.2 liburing-2.0_1
 libbson-1.0.so.0 libbson-1.17.4_2
 libsonic.so.0 libsonic-0.2.0_1
 libtickit.so.3 libtickit-0.4.1_1
-libnotcurses.so.2 notcurses-2.4.9_1
-libnotcurses-core.so.2 notcurses-2.4.9_1
-libnotcurses++.so.2 notcurses-2.4.9_1
+libnotcurses.so.3 notcurses-3.0.5_1
+libnotcurses-core.so.3 notcurses-3.0.5_1
+libnotcurses++.so.3 notcurses-3.0.5_1
+libnotcurses-ffi.so.3 notcurses-3.0.5_1
 libevemu.so.3 evemu-2.7.0_1
 libantilib.so.1 libantimicrox-3.1.2_1
 libinih.so.0 inih-52_1
diff --git a/srcpkgs/notcurses/template b/srcpkgs/notcurses/template
index c43cf269a988..b4e33f45aa1c 100644
--- a/srcpkgs/notcurses/template
+++ b/srcpkgs/notcurses/template
@@ -1,12 +1,12 @@
 # Template file for 'notcurses'
 pkgname=notcurses
-version=2.4.9
+version=3.0.5
 revision=1
 build_style=cmake
 configure_args="-DUSE_STATIC=ON $(vopt_bool man USE_PANDOC)"
 hostmakedepends="pkg-config $(vopt_if man pandoc)"
 makedepends="libunistring-devel ffmpeg-devel ncurses-libtinfo-devel qrcodegen-devel doctest-devel
- zlib-devel"
+ libdeflate-devel"
 depends="ncurses-base"
 short_desc="Blingful character graphics/TUI library"
 maintainer="mobinmob <mobinmob@disroot.org>"
@@ -14,7 +14,7 @@ license="Apache-2.0"
 homepage="https://nick-black.com/dankwiki/index.php/Notcurses"
 changelog="https://raw.githubusercontent.com/dankamongmen/notcurses/master/NEWS.md"
 distfiles="https://github.com/dankamongmen/notcurses/archive/v${version}.tar.gz"
-checksum=a2771ad1633e0158f8273fa8b30b5bce0f12e1205e863045f4ae186b6b52f537
+checksum=accb41b9bad3415017207c0992c791e4d887c505d5aa1b3be0c44456489e537d
 
 build_options="man"
 desc_option_man="Use pandoc for manpages"

From 34cae4f1b1c341c39b5583f8bf2d0dba8a4a127e Mon Sep 17 00:00:00 2001
From: mobinmob <mobinmob@disroot.org>
Date: Sat, 22 Jan 2022 16:20:57 +0200
Subject: [PATCH 2/3] New package: libdeflate-1.9

---
 common/shlibs               |  1 +
 srcpkgs/libdeflate-devel    |  1 +
 srcpkgs/libdeflate/template | 27 +++++++++++++++++++++++++++
 3 files changed, 29 insertions(+)
 create mode 120000 srcpkgs/libdeflate-devel
 create mode 100644 srcpkgs/libdeflate/template

diff --git a/common/shlibs b/common/shlibs
index 81b10645010a..ab74a1fd25a9 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -4101,3 +4101,4 @@ libkmailconfirmbeforedeleting.so.5 kdepim-addons-21.08.3_1
 libkaddressbookprivate.so.5 kaddressbook-21.08.3_1
 libcodec2.so.1.0 codec2-1.0.1_1
 libx86emu.so.3 libx86emu-3.4_1
+libdeflate.so.0 libdeflate-1.8_1
diff --git a/srcpkgs/libdeflate-devel b/srcpkgs/libdeflate-devel
new file mode 120000
index 000000000000..e29c9946ff06
--- /dev/null
+++ b/srcpkgs/libdeflate-devel
@@ -0,0 +1 @@
+libdeflate
\ No newline at end of file
diff --git a/srcpkgs/libdeflate/template b/srcpkgs/libdeflate/template
new file mode 100644
index 000000000000..8a080992b12e
--- /dev/null
+++ b/srcpkgs/libdeflate/template
@@ -0,0 +1,27 @@
+# Template file for 'libdeflate'
+pkgname=libdeflate
+version=1.9
+revision=1
+build_style=gnu-makefile
+make_build_args="PROG_SUFFIX=libdeflate"
+checkdepends="zlib-devel"
+short_desc="Optimized library for DEFLATE/zlib/gzip (de)compression"
+maintainer="mobinmob <mobinmob@disroot.org>"
+license="MIT"
+homepage="https://github.com/ebiggers/libdeflate"
+distfiles="https://github.com/ebiggers/libdeflate/archive/refs/tags/v${version}.tar.gz"
+checksum=a537ab6125c226b874c02b166488b326aece954930260dbf682d88fc339137e3
+
+post_install() {
+	vlicense COPYING
+}
+
+libdeflate-devel_package() {
+	short_desc+=" - development files"
+	depends="${sourcepkg}>=${version}_${revision}"
+	pkg_install() {
+		vmove usr/include
+		vmove "usr/lib/*.a"
+		vmove "usr/lib/*.so"
+	}
+}

From 4cf254f1017239d1aee816f95d4da05c85574ad9 Mon Sep 17 00:00:00 2001
From: mobinmob <mobinmob@disroot.org>
Date: Sat, 22 Jan 2022 16:21:10 +0200
Subject: [PATCH 3/3] growlight: update to 1.2.38.

---
 srcpkgs/growlight/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/growlight/template b/srcpkgs/growlight/template
index 923b5da9a1ce..3703defbdfef 100644
--- a/srcpkgs/growlight/template
+++ b/srcpkgs/growlight/template
@@ -1,7 +1,7 @@
 # Template file for 'growlight'
 pkgname=growlight
-version=1.2.37
-revision=2
+version=1.2.38
+revision=1
 build_style=cmake
 configure_args="$(vopt_bool zfs USE_LIBZFS) $(vopt_bool man USE_PANDOC)"
 hostmakedepends="pkg-config $(vopt_if man pandoc)"
@@ -14,7 +14,7 @@ maintainer="mobinmob <mobinmob@disroot.org>"
 license="GPL-3.0-or-later"
 homepage="https://nick-black.com/dankwiki/index.php/Growlight"
 distfiles="https://github.com/dankamongmen/growlight/archive/v${version}.tar.gz"
-checksum=82a349b623dcfd5db6dc56332f52a2c605775dba31f926576466e9896240a090
+checksum=9c8a5854ba30aa66a7b806b75f00784942f29711dbde0787a29f06583e6ec7a3
 
 build_options="man zfs"
 

^ permalink raw reply	[flat|nested] 17+ messages in thread

* Re: notcuses + growlight update.
  2021-12-05 13:44 [PR PATCH] notcuses + growlight update mobinmob
                   ` (10 preceding siblings ...)
  2022-01-22 14:23 ` [PR PATCH] [Updated] " mobinmob
@ 2022-01-22 14:24 ` mobinmob
  2022-01-22 16:50 ` [PR REVIEW] " Piraty
                   ` (3 subsequent siblings)
  15 siblings, 0 replies; 17+ messages in thread
From: mobinmob @ 2022-01-22 14:24 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 317 bytes --]

New comment by mobinmob on void-packages repository

https://github.com/void-linux/void-packages/pull/34395#issuecomment-1019280121

Comment:
- Rebase on master.
- Add some suggestions by @dontlaugh in https://github.com/void-linux/void-packages/pull/35169
- Update notcurses to 3.0.5.
- Update libdeflate to 1.9.

^ permalink raw reply	[flat|nested] 17+ messages in thread

* Re: [PR REVIEW] notcuses + growlight update.
  2021-12-05 13:44 [PR PATCH] notcuses + growlight update mobinmob
                   ` (11 preceding siblings ...)
  2022-01-22 14:24 ` mobinmob
@ 2022-01-22 16:50 ` Piraty
  2022-01-23  9:08 ` [PR PATCH] [Updated] " mobinmob
                   ` (2 subsequent siblings)
  15 siblings, 0 replies; 17+ messages in thread
From: Piraty @ 2022-01-22 16:50 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 181 bytes --]

New review comment by Piraty on void-packages repository

https://github.com/void-linux/void-packages/pull/34395#discussion_r790160226

Comment:
put the pc file in `-devel` as well

^ permalink raw reply	[flat|nested] 17+ messages in thread

* Re: [PR PATCH] [Updated] notcuses + growlight update.
  2021-12-05 13:44 [PR PATCH] notcuses + growlight update mobinmob
                   ` (12 preceding siblings ...)
  2022-01-22 16:50 ` [PR REVIEW] " Piraty
@ 2022-01-23  9:08 ` mobinmob
  2022-01-23  9:09 ` mobinmob
  2022-01-23  9:10 ` [PR REVIEW] " mobinmob
  15 siblings, 0 replies; 17+ messages in thread
From: mobinmob @ 2022-01-23  9:08 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1220 bytes --]

There is an updated pull request by mobinmob against master on the void-packages repository

https://github.com/mobinmob/void-packages notcurses
https://github.com/void-linux/void-packages/pull/34395

notcuses + growlight update.
<!-- Uncomment relevant sections and delete options which are not applicable -->

#### Testing the changes
- I tested the changes in this PR: **YES**
<!--
#### New package
- This new package conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements): **YES**|**NO**
-->

<!-- Note: If the build is likely to take more than 2 hours, please [skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration)
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->
<!-- 
#### Local build testing
- I built this PR locally for my native architecture, (ARCH-LIBC)
- I built this PR locally for these architectures (if supported. mark crossbuilds):
  - aarch64-musl
  - armv7l
  - armv6l-musl
-->


A patch file from https://github.com/void-linux/void-packages/pull/34395.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-notcurses-34395.patch --]
[-- Type: text/x-diff, Size: 5323 bytes --]

From 9c28fce7a13fa128bfcd463166ea5406b8e78d24 Mon Sep 17 00:00:00 2001
From: mobinmob <mobinmob@disroot.org>
Date: Sun, 23 Jan 2022 11:07:33 +0200
Subject: [PATCH 1/3] notcurses: update to 3.0.5.

---
 common/shlibs              | 7 ++++---
 srcpkgs/notcurses/template | 6 +++---
 2 files changed, 7 insertions(+), 6 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index 6fe46eaaeb05..81b10645010a 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -3952,9 +3952,10 @@ liburing.so.2 liburing-2.0_1
 libbson-1.0.so.0 libbson-1.17.4_2
 libsonic.so.0 libsonic-0.2.0_1
 libtickit.so.3 libtickit-0.4.1_1
-libnotcurses.so.2 notcurses-2.4.9_1
-libnotcurses-core.so.2 notcurses-2.4.9_1
-libnotcurses++.so.2 notcurses-2.4.9_1
+libnotcurses.so.3 notcurses-3.0.5_1
+libnotcurses-core.so.3 notcurses-3.0.5_1
+libnotcurses++.so.3 notcurses-3.0.5_1
+libnotcurses-ffi.so.3 notcurses-3.0.5_1
 libevemu.so.3 evemu-2.7.0_1
 libantilib.so.1 libantimicrox-3.1.2_1
 libinih.so.0 inih-52_1
diff --git a/srcpkgs/notcurses/template b/srcpkgs/notcurses/template
index c43cf269a988..b4e33f45aa1c 100644
--- a/srcpkgs/notcurses/template
+++ b/srcpkgs/notcurses/template
@@ -1,12 +1,12 @@
 # Template file for 'notcurses'
 pkgname=notcurses
-version=2.4.9
+version=3.0.5
 revision=1
 build_style=cmake
 configure_args="-DUSE_STATIC=ON $(vopt_bool man USE_PANDOC)"
 hostmakedepends="pkg-config $(vopt_if man pandoc)"
 makedepends="libunistring-devel ffmpeg-devel ncurses-libtinfo-devel qrcodegen-devel doctest-devel
- zlib-devel"
+ libdeflate-devel"
 depends="ncurses-base"
 short_desc="Blingful character graphics/TUI library"
 maintainer="mobinmob <mobinmob@disroot.org>"
@@ -14,7 +14,7 @@ license="Apache-2.0"
 homepage="https://nick-black.com/dankwiki/index.php/Notcurses"
 changelog="https://raw.githubusercontent.com/dankamongmen/notcurses/master/NEWS.md"
 distfiles="https://github.com/dankamongmen/notcurses/archive/v${version}.tar.gz"
-checksum=a2771ad1633e0158f8273fa8b30b5bce0f12e1205e863045f4ae186b6b52f537
+checksum=accb41b9bad3415017207c0992c791e4d887c505d5aa1b3be0c44456489e537d
 
 build_options="man"
 desc_option_man="Use pandoc for manpages"

From 65611a9139d0549b2694a39f6a787ae481c51dcb Mon Sep 17 00:00:00 2001
From: mobinmob <mobinmob@disroot.org>
Date: Sun, 23 Jan 2022 11:07:43 +0200
Subject: [PATCH 2/3] New package: libdeflate-1.9

---
 common/shlibs               |  1 +
 srcpkgs/libdeflate-devel    |  1 +
 srcpkgs/libdeflate/template | 28 ++++++++++++++++++++++++++++
 3 files changed, 30 insertions(+)
 create mode 120000 srcpkgs/libdeflate-devel
 create mode 100644 srcpkgs/libdeflate/template

diff --git a/common/shlibs b/common/shlibs
index 81b10645010a..ab74a1fd25a9 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -4101,3 +4101,4 @@ libkmailconfirmbeforedeleting.so.5 kdepim-addons-21.08.3_1
 libkaddressbookprivate.so.5 kaddressbook-21.08.3_1
 libcodec2.so.1.0 codec2-1.0.1_1
 libx86emu.so.3 libx86emu-3.4_1
+libdeflate.so.0 libdeflate-1.8_1
diff --git a/srcpkgs/libdeflate-devel b/srcpkgs/libdeflate-devel
new file mode 120000
index 000000000000..e29c9946ff06
--- /dev/null
+++ b/srcpkgs/libdeflate-devel
@@ -0,0 +1 @@
+libdeflate
\ No newline at end of file
diff --git a/srcpkgs/libdeflate/template b/srcpkgs/libdeflate/template
new file mode 100644
index 000000000000..865b442a3710
--- /dev/null
+++ b/srcpkgs/libdeflate/template
@@ -0,0 +1,28 @@
+# Template file for 'libdeflate'
+pkgname=libdeflate
+version=1.9
+revision=1
+build_style=gnu-makefile
+make_build_args="PROG_SUFFIX=libdeflate"
+checkdepends="zlib-devel"
+short_desc="Optimized library for DEFLATE/zlib/gzip (de)compression"
+maintainer="mobinmob <mobinmob@disroot.org>"
+license="MIT"
+homepage="https://github.com/ebiggers/libdeflate"
+distfiles="https://github.com/ebiggers/libdeflate/archive/refs/tags/v${version}.tar.gz"
+checksum=a537ab6125c226b874c02b166488b326aece954930260dbf682d88fc339137e3
+
+post_install() {
+	vlicense COPYING
+}
+
+libdeflate-devel_package() {
+	short_desc+=" - development files"
+	depends="${sourcepkg}>=${version}_${revision}"
+	pkg_install() {
+		vmove usr/include
+		vmove "usr/lib/*.a"
+		vmove "usr/lib/*.so"
+		vmove "/usr/lib/pkgconfig"
+	}
+}

From 07e7413179ee03bcefa2b91f0a783c6882f5d37b Mon Sep 17 00:00:00 2001
From: mobinmob <mobinmob@disroot.org>
Date: Sun, 23 Jan 2022 11:07:52 +0200
Subject: [PATCH 3/3] growlight: update to 1.2.38.

---
 srcpkgs/growlight/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/growlight/template b/srcpkgs/growlight/template
index 923b5da9a1ce..3703defbdfef 100644
--- a/srcpkgs/growlight/template
+++ b/srcpkgs/growlight/template
@@ -1,7 +1,7 @@
 # Template file for 'growlight'
 pkgname=growlight
-version=1.2.37
-revision=2
+version=1.2.38
+revision=1
 build_style=cmake
 configure_args="$(vopt_bool zfs USE_LIBZFS) $(vopt_bool man USE_PANDOC)"
 hostmakedepends="pkg-config $(vopt_if man pandoc)"
@@ -14,7 +14,7 @@ maintainer="mobinmob <mobinmob@disroot.org>"
 license="GPL-3.0-or-later"
 homepage="https://nick-black.com/dankwiki/index.php/Growlight"
 distfiles="https://github.com/dankamongmen/growlight/archive/v${version}.tar.gz"
-checksum=82a349b623dcfd5db6dc56332f52a2c605775dba31f926576466e9896240a090
+checksum=9c8a5854ba30aa66a7b806b75f00784942f29711dbde0787a29f06583e6ec7a3
 
 build_options="man zfs"
 

^ permalink raw reply	[flat|nested] 17+ messages in thread

* Re: [PR PATCH] [Updated] notcuses + growlight update.
  2021-12-05 13:44 [PR PATCH] notcuses + growlight update mobinmob
                   ` (13 preceding siblings ...)
  2022-01-23  9:08 ` [PR PATCH] [Updated] " mobinmob
@ 2022-01-23  9:09 ` mobinmob
  2022-01-23  9:10 ` [PR REVIEW] " mobinmob
  15 siblings, 0 replies; 17+ messages in thread
From: mobinmob @ 2022-01-23  9:09 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1220 bytes --]

There is an updated pull request by mobinmob against master on the void-packages repository

https://github.com/mobinmob/void-packages notcurses
https://github.com/void-linux/void-packages/pull/34395

notcuses + growlight update.
<!-- Uncomment relevant sections and delete options which are not applicable -->

#### Testing the changes
- I tested the changes in this PR: **YES**
<!--
#### New package
- This new package conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements): **YES**|**NO**
-->

<!-- Note: If the build is likely to take more than 2 hours, please [skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration)
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->
<!-- 
#### Local build testing
- I built this PR locally for my native architecture, (ARCH-LIBC)
- I built this PR locally for these architectures (if supported. mark crossbuilds):
  - aarch64-musl
  - armv7l
  - armv6l-musl
-->


A patch file from https://github.com/void-linux/void-packages/pull/34395.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-notcurses-34395.patch --]
[-- Type: text/x-diff, Size: 5390 bytes --]

From cb2926bc600d824bc88c3f1057905de6fd4cc4e9 Mon Sep 17 00:00:00 2001
From: mobinmob <mobinmob@disroot.org>
Date: Sun, 23 Jan 2022 11:07:33 +0200
Subject: [PATCH 1/3] notcurses: update to 3.0.5.

Also:
 - update shlibs and add libnotcurses-ffi.so.3 (@dontlaugh).
---
 common/shlibs              | 7 ++++---
 srcpkgs/notcurses/template | 6 +++---
 2 files changed, 7 insertions(+), 6 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index 6fe46eaaeb05..81b10645010a 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -3952,9 +3952,10 @@ liburing.so.2 liburing-2.0_1
 libbson-1.0.so.0 libbson-1.17.4_2
 libsonic.so.0 libsonic-0.2.0_1
 libtickit.so.3 libtickit-0.4.1_1
-libnotcurses.so.2 notcurses-2.4.9_1
-libnotcurses-core.so.2 notcurses-2.4.9_1
-libnotcurses++.so.2 notcurses-2.4.9_1
+libnotcurses.so.3 notcurses-3.0.5_1
+libnotcurses-core.so.3 notcurses-3.0.5_1
+libnotcurses++.so.3 notcurses-3.0.5_1
+libnotcurses-ffi.so.3 notcurses-3.0.5_1
 libevemu.so.3 evemu-2.7.0_1
 libantilib.so.1 libantimicrox-3.1.2_1
 libinih.so.0 inih-52_1
diff --git a/srcpkgs/notcurses/template b/srcpkgs/notcurses/template
index c43cf269a988..b4e33f45aa1c 100644
--- a/srcpkgs/notcurses/template
+++ b/srcpkgs/notcurses/template
@@ -1,12 +1,12 @@
 # Template file for 'notcurses'
 pkgname=notcurses
-version=2.4.9
+version=3.0.5
 revision=1
 build_style=cmake
 configure_args="-DUSE_STATIC=ON $(vopt_bool man USE_PANDOC)"
 hostmakedepends="pkg-config $(vopt_if man pandoc)"
 makedepends="libunistring-devel ffmpeg-devel ncurses-libtinfo-devel qrcodegen-devel doctest-devel
- zlib-devel"
+ libdeflate-devel"
 depends="ncurses-base"
 short_desc="Blingful character graphics/TUI library"
 maintainer="mobinmob <mobinmob@disroot.org>"
@@ -14,7 +14,7 @@ license="Apache-2.0"
 homepage="https://nick-black.com/dankwiki/index.php/Notcurses"
 changelog="https://raw.githubusercontent.com/dankamongmen/notcurses/master/NEWS.md"
 distfiles="https://github.com/dankamongmen/notcurses/archive/v${version}.tar.gz"
-checksum=a2771ad1633e0158f8273fa8b30b5bce0f12e1205e863045f4ae186b6b52f537
+checksum=accb41b9bad3415017207c0992c791e4d887c505d5aa1b3be0c44456489e537d
 
 build_options="man"
 desc_option_man="Use pandoc for manpages"

From 3d681d29d869b8101a23807e4101638fe6df586d Mon Sep 17 00:00:00 2001
From: mobinmob <mobinmob@disroot.org>
Date: Sun, 23 Jan 2022 11:07:43 +0200
Subject: [PATCH 2/3] New package: libdeflate-1.9

---
 common/shlibs               |  1 +
 srcpkgs/libdeflate-devel    |  1 +
 srcpkgs/libdeflate/template | 28 ++++++++++++++++++++++++++++
 3 files changed, 30 insertions(+)
 create mode 120000 srcpkgs/libdeflate-devel
 create mode 100644 srcpkgs/libdeflate/template

diff --git a/common/shlibs b/common/shlibs
index 81b10645010a..ab74a1fd25a9 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -4101,3 +4101,4 @@ libkmailconfirmbeforedeleting.so.5 kdepim-addons-21.08.3_1
 libkaddressbookprivate.so.5 kaddressbook-21.08.3_1
 libcodec2.so.1.0 codec2-1.0.1_1
 libx86emu.so.3 libx86emu-3.4_1
+libdeflate.so.0 libdeflate-1.8_1
diff --git a/srcpkgs/libdeflate-devel b/srcpkgs/libdeflate-devel
new file mode 120000
index 000000000000..e29c9946ff06
--- /dev/null
+++ b/srcpkgs/libdeflate-devel
@@ -0,0 +1 @@
+libdeflate
\ No newline at end of file
diff --git a/srcpkgs/libdeflate/template b/srcpkgs/libdeflate/template
new file mode 100644
index 000000000000..865b442a3710
--- /dev/null
+++ b/srcpkgs/libdeflate/template
@@ -0,0 +1,28 @@
+# Template file for 'libdeflate'
+pkgname=libdeflate
+version=1.9
+revision=1
+build_style=gnu-makefile
+make_build_args="PROG_SUFFIX=libdeflate"
+checkdepends="zlib-devel"
+short_desc="Optimized library for DEFLATE/zlib/gzip (de)compression"
+maintainer="mobinmob <mobinmob@disroot.org>"
+license="MIT"
+homepage="https://github.com/ebiggers/libdeflate"
+distfiles="https://github.com/ebiggers/libdeflate/archive/refs/tags/v${version}.tar.gz"
+checksum=a537ab6125c226b874c02b166488b326aece954930260dbf682d88fc339137e3
+
+post_install() {
+	vlicense COPYING
+}
+
+libdeflate-devel_package() {
+	short_desc+=" - development files"
+	depends="${sourcepkg}>=${version}_${revision}"
+	pkg_install() {
+		vmove usr/include
+		vmove "usr/lib/*.a"
+		vmove "usr/lib/*.so"
+		vmove "/usr/lib/pkgconfig"
+	}
+}

From ba2589162b08f7b767badb6bc500130105cfb29f Mon Sep 17 00:00:00 2001
From: mobinmob <mobinmob@disroot.org>
Date: Sun, 23 Jan 2022 11:07:52 +0200
Subject: [PATCH 3/3] growlight: update to 1.2.38.

---
 srcpkgs/growlight/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/growlight/template b/srcpkgs/growlight/template
index 923b5da9a1ce..3703defbdfef 100644
--- a/srcpkgs/growlight/template
+++ b/srcpkgs/growlight/template
@@ -1,7 +1,7 @@
 # Template file for 'growlight'
 pkgname=growlight
-version=1.2.37
-revision=2
+version=1.2.38
+revision=1
 build_style=cmake
 configure_args="$(vopt_bool zfs USE_LIBZFS) $(vopt_bool man USE_PANDOC)"
 hostmakedepends="pkg-config $(vopt_if man pandoc)"
@@ -14,7 +14,7 @@ maintainer="mobinmob <mobinmob@disroot.org>"
 license="GPL-3.0-or-later"
 homepage="https://nick-black.com/dankwiki/index.php/Growlight"
 distfiles="https://github.com/dankamongmen/growlight/archive/v${version}.tar.gz"
-checksum=82a349b623dcfd5db6dc56332f52a2c605775dba31f926576466e9896240a090
+checksum=9c8a5854ba30aa66a7b806b75f00784942f29711dbde0787a29f06583e6ec7a3
 
 build_options="man zfs"
 

^ permalink raw reply	[flat|nested] 17+ messages in thread

* Re: [PR REVIEW] notcuses + growlight update.
  2021-12-05 13:44 [PR PATCH] notcuses + growlight update mobinmob
                   ` (14 preceding siblings ...)
  2022-01-23  9:09 ` mobinmob
@ 2022-01-23  9:10 ` mobinmob
  15 siblings, 0 replies; 17+ messages in thread
From: mobinmob @ 2022-01-23  9:10 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 153 bytes --]

New review comment by mobinmob on void-packages repository

https://github.com/void-linux/void-packages/pull/34395#discussion_r790248020

Comment:
Done.

^ permalink raw reply	[flat|nested] 17+ messages in thread

end of thread, other threads:[~2022-01-23  9:10 UTC | newest]

Thread overview: 17+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-12-05 13:44 [PR PATCH] notcuses + growlight update mobinmob
2021-12-31 15:45 ` [PR PATCH] [Updated] " mobinmob
2021-12-31 15:46 ` mobinmob
2021-12-31 16:04 ` [PR PATCH] [Updated] " mobinmob
2022-01-06 11:03 ` mobinmob
2022-01-06 11:04 ` mobinmob
2022-01-10 17:45 ` [PR PATCH] [Updated] " mobinmob
2022-01-10 17:46 ` mobinmob
2022-01-13 19:54 ` [PR REVIEW] " Piraty
2022-01-14 13:52 ` [PR PATCH] [Updated] " mobinmob
2022-01-14 13:52 ` [PR REVIEW] " mobinmob
2022-01-22 14:23 ` [PR PATCH] [Updated] " mobinmob
2022-01-22 14:24 ` mobinmob
2022-01-22 16:50 ` [PR REVIEW] " Piraty
2022-01-23  9:08 ` [PR PATCH] [Updated] " mobinmob
2022-01-23  9:09 ` mobinmob
2022-01-23  9:10 ` [PR REVIEW] " mobinmob

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).