Github messages for voidlinux
 help / color / mirror / Atom feed
* [PR PATCH] Ayatana indicators
@ 2022-01-20 15:34 tibequadorian
  2022-01-21 14:55 ` [RFC] " ericonr
                   ` (9 more replies)
  0 siblings, 10 replies; 11+ messages in thread
From: tibequadorian @ 2022-01-20 15:34 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1494 bytes --]

There is a new pull request by tibequadorian against master on the void-packages repository

https://github.com/tibequadorian/void-packages ayatana-indicators
https://github.com/void-linux/void-packages/pull/35135

Ayatana indicators
<!-- Uncomment relevant sections and delete options which are not applicable -->

#### Testing the changes
- I tested the changes in this PR: **YES**

`libappindicator` hasn't seen a release since 2012 (almost 10 years!)
Debian has removed it in buster and switched to [libayatana-appindicator](https://ayatanaindicators.github.io/).
This PR is intended to prepare void linux for it. Let me know what you think...

<!--
#### New package
- This new package conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements): **YES**|**NO**
-->

<!-- Note: If the build is likely to take more than 2 hours, please [skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration)
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->
<!-- 
#### Local build testing
- I built this PR locally for my native architecture, (ARCH-LIBC)
- I built this PR locally for these architectures (if supported. mark crossbuilds):
  - aarch64-musl
  - armv7l
  - armv6l-musl
-->


A patch file from https://github.com/void-linux/void-packages/pull/35135.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-ayatana-indicators-35135.patch --]
[-- Type: text/x-diff, Size: 8265 bytes --]

From df8ad2c170e29b8cc28bddf0c34b6ba162858dfb Mon Sep 17 00:00:00 2001
From: tibequadorian <tibequadorian@posteo.de>
Date: Mon, 17 Jan 2022 16:37:25 +0100
Subject: [PATCH 1/3] New package: ayatana-ido-0.9.0

---
 common/shlibs                |  1 +
 srcpkgs/ayatana-ido-devel    |  1 +
 srcpkgs/ayatana-ido/template | 26 ++++++++++++++++++++++++++
 3 files changed, 28 insertions(+)
 create mode 120000 srcpkgs/ayatana-ido-devel
 create mode 100644 srcpkgs/ayatana-ido/template

diff --git a/common/shlibs b/common/shlibs
index b07e14379e28..c008858e9469 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -4098,3 +4098,4 @@ libkmailconfirmbeforedeleting.so.5 kdepim-addons-21.08.3_1
 libkaddressbookprivate.so.5 kaddressbook-21.08.3_1
 libcodec2.so.1.0 codec2-1.0.1_1
 libx86emu.so.3 libx86emu-3.4_1
+libayatana-ido3-0.4.so.0 ayatana-ido-0.9.0_1
diff --git a/srcpkgs/ayatana-ido-devel b/srcpkgs/ayatana-ido-devel
new file mode 120000
index 000000000000..2e1aa73a149c
--- /dev/null
+++ b/srcpkgs/ayatana-ido-devel
@@ -0,0 +1 @@
+ayatana-ido
\ No newline at end of file
diff --git a/srcpkgs/ayatana-ido/template b/srcpkgs/ayatana-ido/template
new file mode 100644
index 000000000000..cf14fea35aba
--- /dev/null
+++ b/srcpkgs/ayatana-ido/template
@@ -0,0 +1,26 @@
+# Template file for 'ayatana-ido'
+pkgname=ayatana-ido
+version=0.9.0
+revision=1
+build_helper="gir"
+build_style=cmake
+hostmakedepends="pkg-config gobject-introspection vala"
+makedepends="gtk+3-devel glib-devel"
+short_desc="Ayatana Indicator Display Objects"
+maintainer="tibequadorian <tibequadorian@posteo.de>"
+license="LGPL-3.0-or-later"
+homepage="https://ayatanaindicators.github.io/"
+distfiles="https://github.com/AyatanaIndicators/${pkgname}/archive/${version}.tar.gz"
+checksum=e09b182a67ea65e188a689a2ff792c9a3830740f1aec6679bbd6021235402b4b
+
+ayatana-ido-devel_package() {
+	short_desc+=" - development files"
+	depends="${sourcepkg}>=${version}_${revision} ${makedepends}"
+	pkg_install() {
+		vmove usr/include
+		vmove "usr/lib/*.so"
+		vmove usr/lib/pkgconfig
+		vmove usr/share/gir-1.0
+		vmove usr/share/vala
+	}
+}

From 3aa37b7a2417507538c4a9fc484c9c07abee50c9 Mon Sep 17 00:00:00 2001
From: tibequadorian <tibequadorian@posteo.de>
Date: Mon, 17 Jan 2022 16:38:40 +0100
Subject: [PATCH 2/3] New package: libayatana-indicator-0.9.0

---
 common/shlibs                         |  1 +
 srcpkgs/libayatana-indicator-devel    |  1 +
 srcpkgs/libayatana-indicator/template | 23 +++++++++++++++++++++++
 3 files changed, 25 insertions(+)
 create mode 120000 srcpkgs/libayatana-indicator-devel
 create mode 100644 srcpkgs/libayatana-indicator/template

diff --git a/common/shlibs b/common/shlibs
index c008858e9469..78465d5620c9 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -4099,3 +4099,4 @@ libkaddressbookprivate.so.5 kaddressbook-21.08.3_1
 libcodec2.so.1.0 codec2-1.0.1_1
 libx86emu.so.3 libx86emu-3.4_1
 libayatana-ido3-0.4.so.0 ayatana-ido-0.9.0_1
+libayatana-indicator3.so.7 libayatana-indicator-0.9.0_1
diff --git a/srcpkgs/libayatana-indicator-devel b/srcpkgs/libayatana-indicator-devel
new file mode 120000
index 000000000000..fdfe7dbb5d64
--- /dev/null
+++ b/srcpkgs/libayatana-indicator-devel
@@ -0,0 +1 @@
+libayatana-indicator
\ No newline at end of file
diff --git a/srcpkgs/libayatana-indicator/template b/srcpkgs/libayatana-indicator/template
new file mode 100644
index 000000000000..64063481858d
--- /dev/null
+++ b/srcpkgs/libayatana-indicator/template
@@ -0,0 +1,23 @@
+# Template file for 'libayatana-indicator'
+pkgname=libayatana-indicator
+version=0.9.0
+revision=1
+build_style=cmake
+hostmakedepends="pkg-config python3"
+makedepends="glib-devel gtk+3-devel ayatana-ido-devel"
+short_desc="Ayatana Indicators Shared Library"
+maintainer="tibequadorian <tibequadorian@posteo.de>"
+license="GPL-3.0-or-later"
+homepage="https://ayatanaindicators.github.io/"
+distfiles="https://github.com/AyatanaIndicators/${pkgname}/archive/${version}.tar.gz"
+checksum=b72c31e64f2a6a7d8f8a35a725d02416cfae7c35e0d42f5664792f7d22d465a4
+
+libayatana-indicator-devel_package() {
+	short_desc+=" - development files"
+	depends="${sourcepkg}>=${version}_${revision} ${makedepends}"
+	pkg_install() {
+		vmove usr/include
+		vmove usr/lib/pkgconfig
+		vmove "usr/lib/*.so"
+	}
+}

From 2d4e020212216083751898e714cd58e96feffe6d Mon Sep 17 00:00:00 2001
From: tibequadorian <tibequadorian@posteo.de>
Date: Mon, 17 Jan 2022 16:44:14 +0100
Subject: [PATCH 3/3] New package: libayatana-appindicator-0.5.90

---
 common/shlibs                                 |  1 +
 srcpkgs/libayatana-appindicator-devel         |  1 +
 .../0001-Fix-build-with-musl-libc.patch       | 27 ++++++++++++++++
 srcpkgs/libayatana-appindicator/template      | 32 +++++++++++++++++++
 4 files changed, 61 insertions(+)
 create mode 120000 srcpkgs/libayatana-appindicator-devel
 create mode 100644 srcpkgs/libayatana-appindicator/patches/0001-Fix-build-with-musl-libc.patch
 create mode 100644 srcpkgs/libayatana-appindicator/template

diff --git a/common/shlibs b/common/shlibs
index 78465d5620c9..73f33485bf19 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -4100,3 +4100,4 @@ libcodec2.so.1.0 codec2-1.0.1_1
 libx86emu.so.3 libx86emu-3.4_1
 libayatana-ido3-0.4.so.0 ayatana-ido-0.9.0_1
 libayatana-indicator3.so.7 libayatana-indicator-0.9.0_1
+libayatana-appindicator3.so.1 libayatana-appindicator-0.5.90_1
diff --git a/srcpkgs/libayatana-appindicator-devel b/srcpkgs/libayatana-appindicator-devel
new file mode 120000
index 000000000000..a2ff93abbc17
--- /dev/null
+++ b/srcpkgs/libayatana-appindicator-devel
@@ -0,0 +1 @@
+libayatana-appindicator
\ No newline at end of file
diff --git a/srcpkgs/libayatana-appindicator/patches/0001-Fix-build-with-musl-libc.patch b/srcpkgs/libayatana-appindicator/patches/0001-Fix-build-with-musl-libc.patch
new file mode 100644
index 000000000000..cc3d59650d34
--- /dev/null
+++ b/srcpkgs/libayatana-appindicator/patches/0001-Fix-build-with-musl-libc.patch
@@ -0,0 +1,27 @@
+From 89415c01b730e3a1f6f66402b5c439fb04bda201 Mon Sep 17 00:00:00 2001
+From: Luca Weiss <luca@z3ntu.xyz>
+Date: Tue, 7 Dec 2021 22:22:53 +0100
+Subject: [PATCH] Fix build with musl libc
+
+canonicalize_file_name() is a GNU extension not supported by musl libc.
+Use realpath() from POSIX instead.
+---
+ src/app-indicator.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/app-indicator.c b/src/app-indicator.c
+index a0e1553..cb0086f 100644
+--- a/src/app-indicator.c
++++ b/src/app-indicator.c
+@@ -2081,7 +2081,7 @@ append_snap_prefix (const gchar *path)
+ 	g_autofree gchar *canon_path = NULL;
+ 
+ 	if (snap != NULL && path != NULL) {
+-		canon_path = canonicalize_file_name(path);
++		canon_path = realpath(path, NULL);
+ 
+ 		if (g_str_has_prefix (canon_path, "/tmp/")) {
+ 			g_warning ("Using '/tmp' paths in SNAP environment will lead to unreadable resources");
+-- 
+2.34.1
+
diff --git a/srcpkgs/libayatana-appindicator/template b/srcpkgs/libayatana-appindicator/template
new file mode 100644
index 000000000000..3a807f987592
--- /dev/null
+++ b/srcpkgs/libayatana-appindicator/template
@@ -0,0 +1,32 @@
+# Template file for 'libayatana-appindicator'
+pkgname=libayatana-appindicator
+version=0.5.90
+revision=1
+build_helper="gir"
+build_style=cmake
+configure_args="-DENABLE_BINDINGS_MONO=OFF -DENABLE_BINDINGS_VALA=$(vopt_if vala ON OFF)"
+hostmakedepends="pkg-config gobject-introspection $(vopt_if vala vala)"
+makedepends="glib-devel gtk+3-devel libdbusmenu-gtk3-devel libayatana-indicator-devel"
+short_desc="Ayatana Application Indicators Shared Library"
+maintainer="tibequadorian <tibequadorian@posteo.de>"
+license="LGPL-3.0-or-later"
+homepage="https://ayatanaindicators.github.io/"
+distfiles="https://github.com/AyatanaIndicators/${pkgname}/archive/${version}.tar.gz"
+checksum=15319ca7fda90c6bd85311bbe83eefe1e322de32df2c7f5174b0d5a7537c27b4
+
+build_options="vala"
+build_options_default="vala"
+
+libayatana-appindicator-devel_package() {
+	short_desc+=" - development files"
+	depends="${sourcepkg}>=${version}_${revision} ${makedepends}"
+	pkg_install() {
+		vmove usr/include
+		vmove "usr/lib/*.so"
+		vmove usr/lib/pkgconfig
+		vmove usr/share/gir-1.0
+		if [ "$build_option_vala" ]; then
+			vmove usr/share/vala
+		fi
+	}
+}

^ permalink raw reply	[flat|nested] 11+ messages in thread

* Re: [RFC] Ayatana indicators
  2022-01-20 15:34 [PR PATCH] Ayatana indicators tibequadorian
@ 2022-01-21 14:55 ` ericonr
  2022-01-21 22:18 ` tibequadorian
                   ` (8 subsequent siblings)
  9 siblings, 0 replies; 11+ messages in thread
From: ericonr @ 2022-01-21 14:55 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 272 bytes --]

New comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/pull/35135#issuecomment-1018582783

Comment:
I think if we are doing this it'd make more sense to replace libappindicator entirely, maybe?

Do you think there are downsides?

^ permalink raw reply	[flat|nested] 11+ messages in thread

* Re: [RFC] Ayatana indicators
  2022-01-20 15:34 [PR PATCH] Ayatana indicators tibequadorian
  2022-01-21 14:55 ` [RFC] " ericonr
@ 2022-01-21 22:18 ` tibequadorian
  2022-01-21 22:31 ` tibequadorian
                   ` (7 subsequent siblings)
  9 siblings, 0 replies; 11+ messages in thread
From: tibequadorian @ 2022-01-21 22:18 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 765 bytes --]

New comment by tibequadorian on void-packages repository

https://github.com/void-linux/void-packages/pull/35135#issuecomment-1018905481

Comment:
> I think if we are doing this it'd make more sense to replace libappindicator entirely, maybe?

That's right. Currently 5 packages use libappindicator, but some need to be patched to use libayatana-appindicator instead.

- droidcam: not supported, [issue](https://github.com/dev47apps/droidcam/issues/182)
- gromit-mpx: [supported](https://github.com/bk138/gromit-mpx/commit/2a838303154df4a90495c4f93741846cbd63d37f), but not released yet
- network-manager-applet: supported
- psensor: not supported
- remmina: [supported](https://gitlab.com/Remmina/Remmina/-/commit/a34133add92c217943acad64bb0e41de0f2f619c)

^ permalink raw reply	[flat|nested] 11+ messages in thread

* Re: [RFC] Ayatana indicators
  2022-01-20 15:34 [PR PATCH] Ayatana indicators tibequadorian
  2022-01-21 14:55 ` [RFC] " ericonr
  2022-01-21 22:18 ` tibequadorian
@ 2022-01-21 22:31 ` tibequadorian
  2022-01-28 22:31 ` [PR PATCH] [Updated] " tibequadorian
                   ` (6 subsequent siblings)
  9 siblings, 0 replies; 11+ messages in thread
From: tibequadorian @ 2022-01-21 22:31 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 399 bytes --]

New comment by tibequadorian on void-packages repository

https://github.com/void-linux/void-packages/pull/35135#issuecomment-1018911851

Comment:
I would replace the dependency in all packages that support it, and leave the other packages untouched. I don't want to create unnecessary overhead by adding patches. (except for gromit-mpx, where the patch will be obsolete in the next release anyway)

^ permalink raw reply	[flat|nested] 11+ messages in thread

* Re: [PR PATCH] [Updated] [RFC] Ayatana indicators
  2022-01-20 15:34 [PR PATCH] Ayatana indicators tibequadorian
                   ` (2 preceding siblings ...)
  2022-01-21 22:31 ` tibequadorian
@ 2022-01-28 22:31 ` tibequadorian
  2022-01-28 22:57 ` tibequadorian
                   ` (5 subsequent siblings)
  9 siblings, 0 replies; 11+ messages in thread
From: tibequadorian @ 2022-01-28 22:31 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1556 bytes --]

There is an updated pull request by tibequadorian against master on the void-packages repository

https://github.com/tibequadorian/void-packages ayatana-indicators
https://github.com/void-linux/void-packages/pull/35135

[RFC] Ayatana indicators
`libappindicator` hasn't seen a release since 2012 (almost 10 years!)
Debian has removed it in buster and switched to [libayatana-appindicator](https://ayatanaindicators.github.io/).
This PR is intended to prepare void linux for it. Let me know what you think...

I successfully built and tested `network-manager-applet` with it.

<!-- Uncomment relevant sections and delete options which are not applicable -->

#### Testing the changes
- I tested the changes in this PR: **YES**

#### New package
- This new package conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements): **YES**

<!-- Note: If the build is likely to take more than 2 hours, please [skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration)
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->
<!-- 
#### Local build testing
- I built this PR locally for my native architecture, (ARCH-LIBC)
- I built this PR locally for these architectures (if supported. mark crossbuilds):
  - aarch64-musl
  - armv7l
  - armv6l-musl
-->


A patch file from https://github.com/void-linux/void-packages/pull/35135.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-ayatana-indicators-35135.patch --]
[-- Type: text/x-diff, Size: 23425 bytes --]

From c116accc86d5af53de72e82ffc6f3a1680f061bf Mon Sep 17 00:00:00 2001
From: tibequadorian <tibequadorian@posteo.de>
Date: Mon, 17 Jan 2022 16:37:25 +0100
Subject: [PATCH 1/9] New package: ayatana-ido-0.9.0

---
 common/shlibs                |  1 +
 srcpkgs/ayatana-ido-devel    |  1 +
 srcpkgs/ayatana-ido/template | 26 ++++++++++++++++++++++++++
 3 files changed, 28 insertions(+)
 create mode 120000 srcpkgs/ayatana-ido-devel
 create mode 100644 srcpkgs/ayatana-ido/template

diff --git a/common/shlibs b/common/shlibs
index edcf9daee61c..4530bee988ce 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -4103,3 +4103,4 @@ libkaddressbookprivate.so.5 kaddressbook-21.08.3_1
 libcodec2.so.1.0 codec2-1.0.1_1
 libx86emu.so.3 libx86emu-3.4_1
 libdeflate.so.0 libdeflate-1.8_1
+libayatana-ido3-0.4.so.0 ayatana-ido-0.9.0_1
diff --git a/srcpkgs/ayatana-ido-devel b/srcpkgs/ayatana-ido-devel
new file mode 120000
index 000000000000..2e1aa73a149c
--- /dev/null
+++ b/srcpkgs/ayatana-ido-devel
@@ -0,0 +1 @@
+ayatana-ido
\ No newline at end of file
diff --git a/srcpkgs/ayatana-ido/template b/srcpkgs/ayatana-ido/template
new file mode 100644
index 000000000000..cf14fea35aba
--- /dev/null
+++ b/srcpkgs/ayatana-ido/template
@@ -0,0 +1,26 @@
+# Template file for 'ayatana-ido'
+pkgname=ayatana-ido
+version=0.9.0
+revision=1
+build_helper="gir"
+build_style=cmake
+hostmakedepends="pkg-config gobject-introspection vala"
+makedepends="gtk+3-devel glib-devel"
+short_desc="Ayatana Indicator Display Objects"
+maintainer="tibequadorian <tibequadorian@posteo.de>"
+license="LGPL-3.0-or-later"
+homepage="https://ayatanaindicators.github.io/"
+distfiles="https://github.com/AyatanaIndicators/${pkgname}/archive/${version}.tar.gz"
+checksum=e09b182a67ea65e188a689a2ff792c9a3830740f1aec6679bbd6021235402b4b
+
+ayatana-ido-devel_package() {
+	short_desc+=" - development files"
+	depends="${sourcepkg}>=${version}_${revision} ${makedepends}"
+	pkg_install() {
+		vmove usr/include
+		vmove "usr/lib/*.so"
+		vmove usr/lib/pkgconfig
+		vmove usr/share/gir-1.0
+		vmove usr/share/vala
+	}
+}

From 3d997ff07e16b61770a279329de85eb44cbbacc4 Mon Sep 17 00:00:00 2001
From: tibequadorian <tibequadorian@posteo.de>
Date: Mon, 17 Jan 2022 16:38:40 +0100
Subject: [PATCH 2/9] New package: libayatana-indicator-0.9.0

---
 common/shlibs                         |  1 +
 srcpkgs/libayatana-indicator-devel    |  1 +
 srcpkgs/libayatana-indicator/template | 23 +++++++++++++++++++++++
 3 files changed, 25 insertions(+)
 create mode 120000 srcpkgs/libayatana-indicator-devel
 create mode 100644 srcpkgs/libayatana-indicator/template

diff --git a/common/shlibs b/common/shlibs
index 4530bee988ce..b5f26b9c465f 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -4104,3 +4104,4 @@ libcodec2.so.1.0 codec2-1.0.1_1
 libx86emu.so.3 libx86emu-3.4_1
 libdeflate.so.0 libdeflate-1.8_1
 libayatana-ido3-0.4.so.0 ayatana-ido-0.9.0_1
+libayatana-indicator3.so.7 libayatana-indicator-0.9.0_1
diff --git a/srcpkgs/libayatana-indicator-devel b/srcpkgs/libayatana-indicator-devel
new file mode 120000
index 000000000000..fdfe7dbb5d64
--- /dev/null
+++ b/srcpkgs/libayatana-indicator-devel
@@ -0,0 +1 @@
+libayatana-indicator
\ No newline at end of file
diff --git a/srcpkgs/libayatana-indicator/template b/srcpkgs/libayatana-indicator/template
new file mode 100644
index 000000000000..64063481858d
--- /dev/null
+++ b/srcpkgs/libayatana-indicator/template
@@ -0,0 +1,23 @@
+# Template file for 'libayatana-indicator'
+pkgname=libayatana-indicator
+version=0.9.0
+revision=1
+build_style=cmake
+hostmakedepends="pkg-config python3"
+makedepends="glib-devel gtk+3-devel ayatana-ido-devel"
+short_desc="Ayatana Indicators Shared Library"
+maintainer="tibequadorian <tibequadorian@posteo.de>"
+license="GPL-3.0-or-later"
+homepage="https://ayatanaindicators.github.io/"
+distfiles="https://github.com/AyatanaIndicators/${pkgname}/archive/${version}.tar.gz"
+checksum=b72c31e64f2a6a7d8f8a35a725d02416cfae7c35e0d42f5664792f7d22d465a4
+
+libayatana-indicator-devel_package() {
+	short_desc+=" - development files"
+	depends="${sourcepkg}>=${version}_${revision} ${makedepends}"
+	pkg_install() {
+		vmove usr/include
+		vmove usr/lib/pkgconfig
+		vmove "usr/lib/*.so"
+	}
+}

From 9c9616a0bc9990dee7d7bd55639af82d6fea73fe Mon Sep 17 00:00:00 2001
From: tibequadorian <tibequadorian@posteo.de>
Date: Mon, 17 Jan 2022 16:44:14 +0100
Subject: [PATCH 3/9] New package: libayatana-appindicator-0.5.90

---
 common/shlibs                                 |  1 +
 srcpkgs/libayatana-appindicator-devel         |  1 +
 .../0001-Fix-build-with-musl-libc.patch       | 27 ++++++++++++++++
 srcpkgs/libayatana-appindicator/template      | 32 +++++++++++++++++++
 4 files changed, 61 insertions(+)
 create mode 120000 srcpkgs/libayatana-appindicator-devel
 create mode 100644 srcpkgs/libayatana-appindicator/patches/0001-Fix-build-with-musl-libc.patch
 create mode 100644 srcpkgs/libayatana-appindicator/template

diff --git a/common/shlibs b/common/shlibs
index b5f26b9c465f..c08c2cfbab0d 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -4105,3 +4105,4 @@ libx86emu.so.3 libx86emu-3.4_1
 libdeflate.so.0 libdeflate-1.8_1
 libayatana-ido3-0.4.so.0 ayatana-ido-0.9.0_1
 libayatana-indicator3.so.7 libayatana-indicator-0.9.0_1
+libayatana-appindicator3.so.1 libayatana-appindicator-0.5.90_1
diff --git a/srcpkgs/libayatana-appindicator-devel b/srcpkgs/libayatana-appindicator-devel
new file mode 120000
index 000000000000..a2ff93abbc17
--- /dev/null
+++ b/srcpkgs/libayatana-appindicator-devel
@@ -0,0 +1 @@
+libayatana-appindicator
\ No newline at end of file
diff --git a/srcpkgs/libayatana-appindicator/patches/0001-Fix-build-with-musl-libc.patch b/srcpkgs/libayatana-appindicator/patches/0001-Fix-build-with-musl-libc.patch
new file mode 100644
index 000000000000..cc3d59650d34
--- /dev/null
+++ b/srcpkgs/libayatana-appindicator/patches/0001-Fix-build-with-musl-libc.patch
@@ -0,0 +1,27 @@
+From 89415c01b730e3a1f6f66402b5c439fb04bda201 Mon Sep 17 00:00:00 2001
+From: Luca Weiss <luca@z3ntu.xyz>
+Date: Tue, 7 Dec 2021 22:22:53 +0100
+Subject: [PATCH] Fix build with musl libc
+
+canonicalize_file_name() is a GNU extension not supported by musl libc.
+Use realpath() from POSIX instead.
+---
+ src/app-indicator.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/app-indicator.c b/src/app-indicator.c
+index a0e1553..cb0086f 100644
+--- a/src/app-indicator.c
++++ b/src/app-indicator.c
+@@ -2081,7 +2081,7 @@ append_snap_prefix (const gchar *path)
+ 	g_autofree gchar *canon_path = NULL;
+ 
+ 	if (snap != NULL && path != NULL) {
+-		canon_path = canonicalize_file_name(path);
++		canon_path = realpath(path, NULL);
+ 
+ 		if (g_str_has_prefix (canon_path, "/tmp/")) {
+ 			g_warning ("Using '/tmp' paths in SNAP environment will lead to unreadable resources");
+-- 
+2.34.1
+
diff --git a/srcpkgs/libayatana-appindicator/template b/srcpkgs/libayatana-appindicator/template
new file mode 100644
index 000000000000..3a807f987592
--- /dev/null
+++ b/srcpkgs/libayatana-appindicator/template
@@ -0,0 +1,32 @@
+# Template file for 'libayatana-appindicator'
+pkgname=libayatana-appindicator
+version=0.5.90
+revision=1
+build_helper="gir"
+build_style=cmake
+configure_args="-DENABLE_BINDINGS_MONO=OFF -DENABLE_BINDINGS_VALA=$(vopt_if vala ON OFF)"
+hostmakedepends="pkg-config gobject-introspection $(vopt_if vala vala)"
+makedepends="glib-devel gtk+3-devel libdbusmenu-gtk3-devel libayatana-indicator-devel"
+short_desc="Ayatana Application Indicators Shared Library"
+maintainer="tibequadorian <tibequadorian@posteo.de>"
+license="LGPL-3.0-or-later"
+homepage="https://ayatanaindicators.github.io/"
+distfiles="https://github.com/AyatanaIndicators/${pkgname}/archive/${version}.tar.gz"
+checksum=15319ca7fda90c6bd85311bbe83eefe1e322de32df2c7f5174b0d5a7537c27b4
+
+build_options="vala"
+build_options_default="vala"
+
+libayatana-appindicator-devel_package() {
+	short_desc+=" - development files"
+	depends="${sourcepkg}>=${version}_${revision} ${makedepends}"
+	pkg_install() {
+		vmove usr/include
+		vmove "usr/lib/*.so"
+		vmove usr/lib/pkgconfig
+		vmove usr/share/gir-1.0
+		if [ "$build_option_vala" ]; then
+			vmove usr/share/vala
+		fi
+	}
+}

From 756d0246ce07086b1f66851bdbd9dc5daeb9dac1 Mon Sep 17 00:00:00 2001
From: tibequadorian <tibequadorian@posteo.de>
Date: Sat, 22 Jan 2022 00:17:56 +0100
Subject: [PATCH 4/9] droidcam: replace libappindicator with
 libayatana-appindicator.

---
 .../0001-Use-ayatana-appindicator.patch       | 39 +++++++++++++++++++
 srcpkgs/droidcam/template                     |  5 ++-
 2 files changed, 42 insertions(+), 2 deletions(-)
 create mode 100644 srcpkgs/droidcam/patches/0001-Use-ayatana-appindicator.patch

diff --git a/srcpkgs/droidcam/patches/0001-Use-ayatana-appindicator.patch b/srcpkgs/droidcam/patches/0001-Use-ayatana-appindicator.patch
new file mode 100644
index 000000000000..b0edc62b671f
--- /dev/null
+++ b/srcpkgs/droidcam/patches/0001-Use-ayatana-appindicator.patch
@@ -0,0 +1,39 @@
+From f4be7f8d8e67583170ff036fe6313e8cf9a5d11d Mon Sep 17 00:00:00 2001
+From: tibequadorian <tibequadorian@posteo.de>
+Date: Sat, 22 Jan 2022 00:06:10 +0100
+Subject: [PATCH] Use ayatana-appindicator
+
+---
+ Makefile       | 2 +-
+ src/droidcam.c | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 7be3c15..b7f16c4 100644
+--- a/Makefile
++++ b/Makefile
+@@ -13,7 +13,7 @@ JPEG_LIB ?= $(JPEG_DIR)/lib`getconf LONG_BIT`
+ CC   = gcc
+ CFLAGS = -Wall -O2
+ GTK   = `pkg-config --libs --cflags gtk+-3.0` `pkg-config --libs x11`
+-GTK  += `pkg-config --cflags --libs appindicator3-0.1`
++GTK  += `pkg-config --cflags --libs ayatana-appindicator3-0.1`
+ LIBAV = `pkg-config --libs --cflags libswscale libavutil`
+ LIBS  =  -lspeex -lasound -lpthread -lm
+ JPEG  = -I$(JPEG_INCLUDE) $(JPEG_LIB)/libturbojpeg.a
+diff --git a/src/droidcam.c b/src/droidcam.c
+index cfb6458..6857978 100644
+--- a/src/droidcam.c
++++ b/src/droidcam.c
+@@ -7,7 +7,7 @@
+  */
+ 
+ #include <gtk/gtk.h>
+-#include <libappindicator/app-indicator.h>
++#include <libayatana-appindicator/app-indicator.h>
+ #include <X11/Xlib.h>
+ #include <stdint.h>
+ 
+-- 
+2.34.1
+
diff --git a/srcpkgs/droidcam/template b/srcpkgs/droidcam/template
index 1357308432ef..f4ae48850166 100644
--- a/srcpkgs/droidcam/template
+++ b/srcpkgs/droidcam/template
@@ -1,12 +1,13 @@
 # Template file for 'droidcam'
 pkgname=droidcam
 version=1.8.1
-revision=1
+revision=2
 build_style=gnu-makefile
 make_build_args="USBMUXD=-lusbmuxd-2.0 JPEG=-lturbojpeg"
 hostmakedepends="pkg-config"
 makedepends="pkg-config libjpeg-turbo-devel ffmpeg-devel alsa-lib-devel
- speex-devel libusbmuxd-devel libplist-devel gtk+3-devel libappindicator-devel"
+ speex-devel libusbmuxd-devel libplist-devel gtk+3-devel
+ libayatana-appindicator-devel"
 depends="v4l2loopback"
 short_desc="Tool for using your android device as a wireless/usb webcam"
 maintainer="ibrokemypie <ibrokemypie@bastardi.net>"

From 073400cba2b5838013d7eee614f98cdd909ca2df Mon Sep 17 00:00:00 2001
From: tibequadorian <tibequadorian@posteo.de>
Date: Sat, 22 Jan 2022 00:18:35 +0100
Subject: [PATCH 5/9] gromit-mpx: replace libappindicator with
 libayatana-appindicator.

---
 .../0001-Use-ayatana-appindicator.patch       | 64 +++++++++++++++++++
 srcpkgs/gromit-mpx/template                   |  4 +-
 2 files changed, 66 insertions(+), 2 deletions(-)
 create mode 100644 srcpkgs/gromit-mpx/patches/0001-Use-ayatana-appindicator.patch

diff --git a/srcpkgs/gromit-mpx/patches/0001-Use-ayatana-appindicator.patch b/srcpkgs/gromit-mpx/patches/0001-Use-ayatana-appindicator.patch
new file mode 100644
index 000000000000..db484fcf1fba
--- /dev/null
+++ b/srcpkgs/gromit-mpx/patches/0001-Use-ayatana-appindicator.patch
@@ -0,0 +1,64 @@
+From d5f08a1addeae4eb411b17c8ab77fdf7ef1417a5 Mon Sep 17 00:00:00 2001
+From: tibequadorian <tibequadorian@posteo.de>
+Date: Sat, 22 Jan 2022 00:37:05 +0100
+Subject: [PATCH] Use ayatana appindicator
+
+---
+ CMakeLists.txt   | 8 ++++----
+ src/gromit-mpx.h | 2 +-
+ 2 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 1a501e9..7a82562 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -22,21 +22,21 @@ configure_file(build-config.h_cmake_in build-config.h)
+ find_package(PkgConfig)
+ 
+ pkg_check_modules(gtk3 REQUIRED "gtk+-3.0 >= 3.22")
+-pkg_check_modules(appindicator3 REQUIRED "appindicator3-0.1 >= 0.4.92")
++pkg_check_modules(ayatana-appindicator3 REQUIRED "ayatana-appindicator3-0.1 >= 0.5")
+ pkg_check_modules(xinput REQUIRED "xi >= 1.3")
+ pkg_check_modules(x11 REQUIRED x11)
+ 
+ include_directories(
+     ${CMAKE_CURRENT_BINARY_DIR}
+     ${gtk3_INCLUDE_DIRS}
+-    ${appindicator3_INCLUDE_DIRS}
++    ${ayatana-appindicator3_INCLUDE_DIRS}
+     ${xinput_INCLUDE_DIRS}
+     ${x11_INCLUDE_DIRS}
+ )
+ 
+ link_directories(
+     ${gtk3_LIBRARY_DIRS}
+-    ${appindicator3_LIBRARY_DIRS}
++    ${ayatana-appindicator3_LIBRARY_DIRS}
+     ${xinput_LIBRARY_DIRS}
+     ${x11_LIBRARY_DIRS}
+ )
+@@ -58,7 +58,7 @@ add_executable(${target_name} ${sources})
+ 
+ target_link_libraries(${target_name}
+     ${gtk3_LIBRARIES}
+-    ${appindicator3_LIBRARIES}
++    ${ayatana-appindicator3_LIBRARIES}
+     ${xinput_LIBRARIES}
+     ${x11_LIBRARIES}
+     -lm
+diff --git a/src/gromit-mpx.h b/src/gromit-mpx.h
+index f060163..29f7ef5 100644
+--- a/src/gromit-mpx.h
++++ b/src/gromit-mpx.h
+@@ -27,7 +27,7 @@
+ #include <glib.h>
+ #include <gdk/gdk.h>
+ #include <gtk/gtk.h>
+-#include <libappindicator/app-indicator.h>
++#include <libayatana-appindicator/app-indicator.h>
+ 
+ 
+ #define GROMIT_MOUSE_EVENTS ( GDK_BUTTON_MOTION_MASK | \
+-- 
+2.34.1
+
diff --git a/srcpkgs/gromit-mpx/template b/srcpkgs/gromit-mpx/template
index 31156c076f67..1c97175612a9 100644
--- a/srcpkgs/gromit-mpx/template
+++ b/srcpkgs/gromit-mpx/template
@@ -1,10 +1,10 @@
 # Template file for 'gromit-mpx'
 pkgname=gromit-mpx
 version=1.4
-revision=1
+revision=2
 build_style=cmake
 hostmakedepends="pkg-config"
-makedepends="gtk+3-devel libappindicator-devel libdbusmenu-glib-devel"
+makedepends="gtk+3-devel libayatana-appindicator-devel libdbusmenu-glib-devel"
 short_desc="Multi-pointer annotation tool"
 maintainer="Toyam Cox <Vaelatern@gmail.com>"
 license="GPL-2.0-only"

From f2659bc9c72dea9c7eba477c7617ba22dfc74f96 Mon Sep 17 00:00:00 2001
From: tibequadorian <tibequadorian@posteo.de>
Date: Sat, 22 Jan 2022 00:18:49 +0100
Subject: [PATCH 6/9] network-manager-applet: replace libappindicator with
 libayatana-appindicator.

---
 srcpkgs/network-manager-applet/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/network-manager-applet/template b/srcpkgs/network-manager-applet/template
index 958d5b228960..e8680d192311 100644
--- a/srcpkgs/network-manager-applet/template
+++ b/srcpkgs/network-manager-applet/template
@@ -1,12 +1,12 @@
 # Template file for 'network-manager-applet'
 pkgname=network-manager-applet
 version=1.24.0
-revision=1
+revision=2
 build_style=meson
 configure_args="-Dselinux=false"
 hostmakedepends="dbus-glib-devel glib-devel intltool pkg-config"
 makedepends="ModemManager-devel NetworkManager-devel iso-codes jansson-devel
- libappindicator-devel libapparmor-devel libdbusmenu-gtk3-devel
+ libayatana-appindicator-devel libapparmor-devel libdbusmenu-gtk3-devel
  libgnome-keyring-devel libgudev-devel libnotify-devel libnma-devel
  libsecret-devel polkit-devel mobile-broadband-provider-info"
 depends="NetworkManager hicolor-icon-theme iso-codes"

From a4ddea07ed1c3bf3f6620df39f5211fc0d626e57 Mon Sep 17 00:00:00 2001
From: tibequadorian <tibequadorian@posteo.de>
Date: Sat, 22 Jan 2022 00:18:53 +0100
Subject: [PATCH 7/9] psensor: replace libappindicator with
 libayatana-appindicator.

---
 .../0001-Use-ayatana-appindicator.patch       | 53 +++++++++++++++++++
 srcpkgs/psensor/template                      |  6 +--
 2 files changed, 56 insertions(+), 3 deletions(-)
 create mode 100644 srcpkgs/psensor/patches/0001-Use-ayatana-appindicator.patch

diff --git a/srcpkgs/psensor/patches/0001-Use-ayatana-appindicator.patch b/srcpkgs/psensor/patches/0001-Use-ayatana-appindicator.patch
new file mode 100644
index 000000000000..f8350ca6f77f
--- /dev/null
+++ b/srcpkgs/psensor/patches/0001-Use-ayatana-appindicator.patch
@@ -0,0 +1,53 @@
+From d84498639263d6a8f8d4b4adddf3dab66631876b Mon Sep 17 00:00:00 2001
+From: tibequadorian <tibequadorian@posteo.de>
+Date: Sat, 22 Jan 2022 00:15:13 +0100
+Subject: [PATCH] Use ayatana appindicator
+
+---
+ configure.ac          | 2 +-
+ src/ui.h              | 2 +-
+ src/ui_appindicator.c | 2 +-
+ 3 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 48b10eb..2ff857d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -117,7 +117,7 @@ AC_SUBST(LIBNOTIFY_LIBS)
+ 
+ # Checks AppIndicator 
+ APPINDICATOR_LIBS=
+-PKG_CHECK_MODULES(APPINDICATOR, appindicator3-0.1,
++PKG_CHECK_MODULES(APPINDICATOR, ayatana-appindicator3-0.1,
+      [AC_DEFINE([HAVE_APPINDICATOR],[1],[Use AppIndicator3-0.1])],
+      [AC_MSG_WARN(AppIndicator 3-0.1 not present")])
+ AM_CONDITIONAL(APPINDICATOR, test -n "$APPINDICATOR_LIBS")
+diff --git a/src/ui.h b/src/ui.h
+index 426f29c..43ae4be 100644
+--- a/src/ui.h
++++ b/src/ui.h
+@@ -27,7 +27,7 @@
+ #include <gtk/gtk.h>
+ 
+ #if defined(HAVE_APPINDICATOR)
+-#include <libappindicator/app-indicator.h>
++#include <libayatana-appindicator/app-indicator.h>
+ #endif
+ 
+ #include "psensor.h"
+diff --git a/src/ui_appindicator.c b/src/ui_appindicator.c
+index ed4cc64..b3179c0 100644
+--- a/src/ui_appindicator.c
++++ b/src/ui_appindicator.c
+@@ -21,7 +21,7 @@
+ #include <string.h>
+ 
+ #include <gtk/gtk.h>
+-#include <libappindicator/app-indicator.h>
++#include <libayatana-appindicator/app-indicator.h>
+ 
+ #include <cfg.h>
+ #include <psensor.h>
+-- 
+2.34.1
+
diff --git a/srcpkgs/psensor/template b/srcpkgs/psensor/template
index 00cf7ba46a69..51ae60f7c50f 100644
--- a/srcpkgs/psensor/template
+++ b/srcpkgs/psensor/template
@@ -1,12 +1,12 @@
 # Template file for 'psensor'
 pkgname=psensor
 version=1.2.1
-revision=1
+revision=2
 build_style=gnu-configure
-hostmakedepends="pkg-config glib-devel"
+hostmakedepends="pkg-config glib-devel automake"
 makedepends="gtk+3-devel udisks2-devel libgtop-devel json-c-devel
  libsensors-devel libatasmart-devel libcurl-devel libnotify-devel
- libappindicator-devel libmicrohttpd-devel"
+ libayatana-appindicator-devel libmicrohttpd-devel"
 depends="lm_sensors"
 short_desc="Graphical hardware temperature monitor for Linux"
 maintainer="Foxlet <foxlet@furcode.co>"

From 77b6b12c6f192f2e774db147eb83d3226bc932a4 Mon Sep 17 00:00:00 2001
From: tibequadorian <tibequadorian@posteo.de>
Date: Sat, 22 Jan 2022 00:18:58 +0100
Subject: [PATCH 8/9] remmina: replace libappindicator with
 libayatana-appindicator.

---
 srcpkgs/remmina/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/remmina/template b/srcpkgs/remmina/template
index 22843f86aa51..272affa56ee9 100644
--- a/srcpkgs/remmina/template
+++ b/srcpkgs/remmina/template
@@ -1,7 +1,7 @@
 # Template file for 'remmina'
 pkgname=remmina
 version=1.4.23
-revision=1
+revision=2
 wrksrc="Remmina-v${version}"
 build_style=cmake
 configure_args="-DWITH_APPINDICATOR=OFF -DCMAKE_USE_PTHREADS_INIT=ON"
@@ -12,7 +12,7 @@ makedepends="avahi-glib-libs-devel avahi-ui-libs-devel freerdp-devel
  libsecret-devel libsodium-devel libsoup-devel libssh-devel libva-devel
  libvncserver-devel libxkbfile-devel opus-devel phodav-devel
  spice-gtk-devel spice-protocol telepathy-glib-devel usbredir-devel
- vte3-devel libappindicator-devel"
+ vte3-devel libayatana-appindicator-devel"
 depends="desktop-file-utils hicolor-icon-theme"
 short_desc="Remote desktop client written in GTK+"
 maintainer="Frank Steinborn <steinex@nognu.de>"

From fa8faae898807a3e7adc8897b5f40e7b80209df2 Mon Sep 17 00:00:00 2001
From: tibequadorian <tibequadorian@posteo.de>
Date: Sat, 22 Jan 2022 00:23:49 +0100
Subject: [PATCH 9/9] libappindicator: remove package

---
 common/shlibs                     |  1 -
 srcpkgs/libappindicator-devel     |  1 -
 srcpkgs/libappindicator/template  | 45 -------------------------------
 srcpkgs/removed-packages/template |  1 +
 4 files changed, 1 insertion(+), 47 deletions(-)
 delete mode 120000 srcpkgs/libappindicator-devel
 delete mode 100644 srcpkgs/libappindicator/template

diff --git a/common/shlibs b/common/shlibs
index c08c2cfbab0d..9bb7f2bed132 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -3061,7 +3061,6 @@ libappstream-builder.so.8 appstream-glib-0.6.13_1
 libflatpak.so.0 flatpak-0.9.3_2
 libnanomsg.so.5 nanomsg-1.1.3_1
 libindicator3.so.7 libindicator-12.10.1_1
-libappindicator3.so.1 libappindicator-12.10.0_1
 libscanmem.so.1 libscanmem-0.17_5
 libsctp.so.1 lksctp-tools-1.0.17_1
 libwithsctp.so.1 lksctp-tools-1.0.17_1
diff --git a/srcpkgs/libappindicator-devel b/srcpkgs/libappindicator-devel
deleted file mode 120000
index 8bd81b384994..000000000000
--- a/srcpkgs/libappindicator-devel
+++ /dev/null
@@ -1 +0,0 @@
-libappindicator
\ No newline at end of file
diff --git a/srcpkgs/libappindicator/template b/srcpkgs/libappindicator/template
deleted file mode 100644
index 11fc6f6d1527..000000000000
--- a/srcpkgs/libappindicator/template
+++ /dev/null
@@ -1,45 +0,0 @@
-# Template file for 'libappindicator'
-pkgname=libappindicator
-version=12.10.0
-revision=3
-build_style=gnu-configure
-build_helper="gir"
-configure_args="--with-gtk=3"
-hostmakedepends="pkg-config python glib-devel"
-makedepends="gtk+3-devel glib-devel glib-networking libdbusmenu-glib-devel
- libdbusmenu-gtk3-devel libindicator-devel dbus-glib-devel python-devel
- python-gobject2-devel pygtk-devel"
-short_desc="Library to allow applications to export a menu"
-maintainer="Toyam Cox <Vaelatern@gmail.com>"
-license="LGPL-2.1"
-homepage="https://launchpad.net/libappindicator"
-distfiles="https://launchpad.net/libappindicator/${version%.*}/${version}/+download/libappindicator-${version}.tar.gz"
-checksum=d5907c1f98084acf28fd19593cb70672caa0ca1cf82d747ba6f4830d4cc3b49f
-
-# since this package depends on features that have already been removed in
-# gtk+4, we need to ignore the depreciated problem. GTK is going away from the
-# idea of app indicators in taskbars.
-CFLAGS="-Wno-deprecated-declarations -Wno-error=incompatible-pointer-types"
-
-# Avoid errors for macros deprecated since glib-2.58 */
-CFLAGS+=" -DGLIB_VERSION_MIN_REQUIRED=GLIB_VERSION_2_56 -DGLIB_VERSION_MAX_ALLOWED=GLIB_VERSION_2_56"
-
-
-pre_configure() {
-	if [ "$CROSS_BUILD" ]; then
-		sed -i 's:^py_prefix=`:py_prefix='"$XBPS_CROSS_BASE"'`:' configure
-	fi
-}
-
-libappindicator-devel_package() {
-	short_desc+=" - development files"
-	depends="${sourcepkg}>=${version}_${revision} gtk+3-devel libdbusmenu-glib-devel"
-	pkg_install() {
-		vmove usr/include
-		vmove usr/lib/pkgconfig
-		vmove usr/lib/*.so
-		vmove usr/lib/*.a
-		vmove usr/share/gir-1.0
-		vmove usr/share/gtk-doc
-	}
-}
diff --git a/srcpkgs/removed-packages/template b/srcpkgs/removed-packages/template
index 39c9dc05730b..946ab3c34913 100644
--- a/srcpkgs/removed-packages/template
+++ b/srcpkgs/removed-packages/template
@@ -195,6 +195,7 @@ replaces="
  keepassx<=0.4.4_2
  key-mon<=1.17_5
  libapp<=20140527_2
+ libappindicator<=12.10.0_3
  libco-devel<=20_1
  libco<=20_1
  libdbusmenu-qt<=0.9.2_4

^ permalink raw reply	[flat|nested] 11+ messages in thread

* Re: [RFC] Ayatana indicators
  2022-01-20 15:34 [PR PATCH] Ayatana indicators tibequadorian
                   ` (3 preceding siblings ...)
  2022-01-28 22:31 ` [PR PATCH] [Updated] " tibequadorian
@ 2022-01-28 22:57 ` tibequadorian
  2022-02-15 21:03 ` [PR PATCH] [Closed]: " tibequadorian
                   ` (4 subsequent siblings)
  9 siblings, 0 replies; 11+ messages in thread
From: tibequadorian @ 2022-01-28 22:57 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 537 bytes --]

New comment by tibequadorian on void-packages repository

https://github.com/void-linux/void-packages/pull/35135#issuecomment-1024725752

Comment:
Ok i've revised it now and removed libappindicator completely and patched the necessary packages, otherwise it doesn't make any sense. I'll leave the PR open if you eventually decide to merge :) I'm not sure myself if it's right thing to do because so many (ok actually four) patches needed :P but the debian folks probably have a point by saying that libappindicator upstream is a mess...

^ permalink raw reply	[flat|nested] 11+ messages in thread

* Re: [PR PATCH] [Closed]: [RFC] Ayatana indicators
  2022-01-20 15:34 [PR PATCH] Ayatana indicators tibequadorian
                   ` (4 preceding siblings ...)
  2022-01-28 22:57 ` tibequadorian
@ 2022-02-15 21:03 ` tibequadorian
  2022-02-18  3:48 ` ericonr
                   ` (3 subsequent siblings)
  9 siblings, 0 replies; 11+ messages in thread
From: tibequadorian @ 2022-02-15 21:03 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1365 bytes --]

There's a closed pull request on the void-packages repository

[RFC] Ayatana indicators
https://github.com/void-linux/void-packages/pull/35135

Description:
`libappindicator` hasn't seen a release since 2012 (almost 10 years!)
Debian has removed it in buster and switched to [libayatana-appindicator](https://ayatanaindicators.github.io/).
This PR is intended to prepare void linux for it. Let me know what you think...

I successfully built and tested all changed packages.

<!-- Uncomment relevant sections and delete options which are not applicable -->

#### Testing the changes
- I tested the changes in this PR: **YES**

#### New package
- This new package conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements): **YES**

<!-- Note: If the build is likely to take more than 2 hours, please [skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration)
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->
<!-- 
#### Local build testing
- I built this PR locally for my native architecture, (ARCH-LIBC)
- I built this PR locally for these architectures (if supported. mark crossbuilds):
  - aarch64-musl
  - armv7l
  - armv6l-musl
-->


^ permalink raw reply	[flat|nested] 11+ messages in thread

* Re: [RFC] Ayatana indicators
  2022-01-20 15:34 [PR PATCH] Ayatana indicators tibequadorian
                   ` (5 preceding siblings ...)
  2022-02-15 21:03 ` [PR PATCH] [Closed]: " tibequadorian
@ 2022-02-18  3:48 ` ericonr
  2022-02-18  3:49 ` ericonr
                   ` (2 subsequent siblings)
  9 siblings, 0 replies; 11+ messages in thread
From: ericonr @ 2022-02-18  3:48 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 236 bytes --]

New comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/pull/35135#issuecomment-1043838749

Comment:
Sorry for the lack of activity here :/

It would be nice if the patches were upstreamed :/


^ permalink raw reply	[flat|nested] 11+ messages in thread

* Re: [RFC] Ayatana indicators
  2022-01-20 15:34 [PR PATCH] Ayatana indicators tibequadorian
                   ` (6 preceding siblings ...)
  2022-02-18  3:48 ` ericonr
@ 2022-02-18  3:49 ` ericonr
  2022-02-18  9:17 ` tibequadorian
  2022-03-05 20:17 ` tibequadorian
  9 siblings, 0 replies; 11+ messages in thread
From: ericonr @ 2022-02-18  3:49 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 153 bytes --]

New comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/pull/35135#issuecomment-1043838919

Comment:
(by debian)

^ permalink raw reply	[flat|nested] 11+ messages in thread

* Re: [RFC] Ayatana indicators
  2022-01-20 15:34 [PR PATCH] Ayatana indicators tibequadorian
                   ` (7 preceding siblings ...)
  2022-02-18  3:49 ` ericonr
@ 2022-02-18  9:17 ` tibequadorian
  2022-03-05 20:17 ` tibequadorian
  9 siblings, 0 replies; 11+ messages in thread
From: tibequadorian @ 2022-02-18  9:17 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 259 bytes --]

New comment by tibequadorian on void-packages repository

https://github.com/void-linux/void-packages/pull/35135#issuecomment-1044196495

Comment:
No problem. Yes I know so currently I don't want this PR to be merged. May reopen it if patches are upstreamed.

^ permalink raw reply	[flat|nested] 11+ messages in thread

* Re: [RFC] Ayatana indicators
  2022-01-20 15:34 [PR PATCH] Ayatana indicators tibequadorian
                   ` (8 preceding siblings ...)
  2022-02-18  9:17 ` tibequadorian
@ 2022-03-05 20:17 ` tibequadorian
  9 siblings, 0 replies; 11+ messages in thread
From: tibequadorian @ 2022-03-05 20:17 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 769 bytes --]

New comment by tibequadorian on void-packages repository

https://github.com/void-linux/void-packages/pull/35135#issuecomment-1018905481

Comment:
> I think if we are doing this it'd make more sense to replace libappindicator entirely, maybe?

That's right. Currently 5 packages use libappindicator, but some need to be patched to use libayatana-appindicator instead.

- droidcam: [supported](https://github.com/dev47apps/droidcam/commit/71a74d22ed700650a83b7cb653bd92b0ed3cd01a)
- gromit-mpx: [supported](https://github.com/bk138/gromit-mpx/commit/2a838303154df4a90495c4f93741846cbd63d37f)
- network-manager-applet: supported
- psensor: not supported
- remmina: [supported](https://gitlab.com/Remmina/Remmina/-/commit/a34133add92c217943acad64bb0e41de0f2f619c)

^ permalink raw reply	[flat|nested] 11+ messages in thread

end of thread, other threads:[~2022-03-05 20:17 UTC | newest]

Thread overview: 11+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-01-20 15:34 [PR PATCH] Ayatana indicators tibequadorian
2022-01-21 14:55 ` [RFC] " ericonr
2022-01-21 22:18 ` tibequadorian
2022-01-21 22:31 ` tibequadorian
2022-01-28 22:31 ` [PR PATCH] [Updated] " tibequadorian
2022-01-28 22:57 ` tibequadorian
2022-02-15 21:03 ` [PR PATCH] [Closed]: " tibequadorian
2022-02-18  3:48 ` ericonr
2022-02-18  3:49 ` ericonr
2022-02-18  9:17 ` tibequadorian
2022-03-05 20:17 ` tibequadorian

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).