Github messages for voidlinux
 help / color / mirror / Atom feed
* [PR PATCH] [WIP] New package: modrana-0.56.17
@ 2022-08-03 22:46 TinfoilSubmarine
  2022-08-03 22:48 ` [PR PATCH] [Updated] " TinfoilSubmarine
                   ` (7 more replies)
  0 siblings, 8 replies; 9+ messages in thread
From: TinfoilSubmarine @ 2022-08-03 22:46 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1617 bytes --]

There is a new pull request by TinfoilSubmarine against master on the void-packages repository

https://github.com/TinfoilSubmarine/void-packages maint/modrana
https://github.com/void-linux/void-packages/pull/38461

[WIP] New package: modrana-0.56.17
<!-- Uncomment relevant sections and delete options which are not applicable -->

#### Testing the changes
- I tested the changes in this PR: **briefly**

<!--
#### New package
- This new package conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements): **YES**|**NO**
-->

<!-- Note: If the build is likely to take more than 2 hours, please add ci skip tag as described in
https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->
<!--
#### Local build testing
- I built this PR locally for my native architecture, (ARCH-LIBC)
- I built this PR locally for these architectures (if supported. mark crossbuilds):
  - aarch64-musl
  - armv7l
  - armv6l-musl
-->

Closes https://github.com/void-linux/void-packages/issues/36929

As noted in the modrana template, the latest version is only mentioned in the commit log and is not tagged. Not sure why...

I got pyotherside cross-compiling working, but need help with figuring out how to make modrana cross-build, specifically for `make launcher`

[ci skip]

A patch file from https://github.com/void-linux/void-packages/pull/38461.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-maint/modrana-38461.patch --]
[-- Type: text/x-diff, Size: 2749 bytes --]

From b56383c9356da3c9849a02f8ab26417c34be147d Mon Sep 17 00:00:00 2001
From: Joel Beckmeyer <joel@beckmeyer.us>
Date: Wed, 3 Aug 2022 15:21:21 -0400
Subject: [PATCH 1/2] New package: pyotherside-1.5.9

---
 srcpkgs/pyotherside/template | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
 create mode 100644 srcpkgs/pyotherside/template

diff --git a/srcpkgs/pyotherside/template b/srcpkgs/pyotherside/template
new file mode 100644
index 000000000000..a36325408dff
--- /dev/null
+++ b/srcpkgs/pyotherside/template
@@ -0,0 +1,22 @@
+# Template file for 'pyotherside'
+pkgname=pyotherside
+version=1.5.9
+revision=1
+wrksrc="pyotherside-${version}"
+build_style=qmake
+configure_args="PYTHON_CONFIG=${XBPS_CROSS_BASE}/usr/bin/python3-config"
+hostmakedepends="qt5-qmake qt5-host-tools"
+makedepends="python3-devel qt5-svg-devel qt5-declarative-devel"
+short_desc="Asynchronous Python 3 Bindings for Qt 5"
+maintainer="Joel Beckmeyer <joel@beckmeyer.us>"
+license="ISC"
+homepage="https://thp.io/2011/pyotherside/"
+distfiles="https://github.com/thp/pyotherside/archive/${version}.tar.gz"
+checksum=189cb0b973e40fcb6b95fd51b0bcd6cc8494b514d49ffe966ec488cf05bbf51e
+
+post_install() {
+	vlicense LICENSE
+
+	# remove tests polluting /usr
+	rm ${DESTDIR}/usr/tests/qtquicktests/qtquicktests
+}

From a543a6561f17a4f0db077dc7e9e89eed799021c0 Mon Sep 17 00:00:00 2001
From: Joel Beckmeyer <joel@beckmeyer.us>
Date: Tue, 31 May 2022 10:26:17 -0400
Subject: [PATCH 2/2] New package: modrana-0.56.17

---
 srcpkgs/modrana/template | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
 create mode 100644 srcpkgs/modrana/template

diff --git a/srcpkgs/modrana/template b/srcpkgs/modrana/template
new file mode 100644
index 000000000000..3b85e2c19c5c
--- /dev/null
+++ b/srcpkgs/modrana/template
@@ -0,0 +1,31 @@
+# Template file for 'modrana'
+pkgname=modrana
+version=0.57.3
+revision=1
+# releases aren't tagged in git
+_version_commit=dbd558d407abe7a3a4a352c96b618147cade4bd9
+wrksrc="modrana-${_version_commit}"
+hostmakedepends="rsync python3 qt5-qmake"
+makedepends="qt5-declarative-devel"
+depends="pyotherside"
+short_desc="Flexible GPS navigation system for mobile devices"
+maintainer="Joel Beckmeyer <joel@beckmeyer.us>"
+license="GPL-3.0-or-later"
+homepage="https://modrana.org"
+distfiles="https://github.com/M4rtinK/modrana/archive/${_version_commit}.tar.gz"
+checksum=7f93e4660997a8cba4194709c4566dec667da1c99ae45dd66ea6df71b8c637a6
+python_version=3
+
+do_build() {
+	make VersionFile
+	make
+	make rsync
+	make bytecode-python3
+	make launcher
+}
+
+do_install() {
+	make DESTDIR="$DESTDIR" install
+	# not sure why the gtk binary is still here, only qt is supported/working
+	rm ${DESTDIR}/usr/bin/modrana-gtk
+}

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: [PR PATCH] [Updated] [WIP] New package: modrana-0.56.17
  2022-08-03 22:46 [PR PATCH] [WIP] New package: modrana-0.56.17 TinfoilSubmarine
@ 2022-08-03 22:48 ` TinfoilSubmarine
  2022-08-03 23:06 ` [PR REVIEW] " classabbyamp
                   ` (6 subsequent siblings)
  7 siblings, 0 replies; 9+ messages in thread
From: TinfoilSubmarine @ 2022-08-03 22:48 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1622 bytes --]

There is an updated pull request by TinfoilSubmarine against master on the void-packages repository

https://github.com/TinfoilSubmarine/void-packages maint/modrana
https://github.com/void-linux/void-packages/pull/38461

[WIP] New package: modrana-0.56.17
<!-- Uncomment relevant sections and delete options which are not applicable -->

#### Testing the changes
- I tested the changes in this PR: **briefly**

<!--
#### New package
- This new package conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements): **YES**|**NO**
-->

<!-- Note: If the build is likely to take more than 2 hours, please add ci skip tag as described in
https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->
<!--
#### Local build testing
- I built this PR locally for my native architecture, (ARCH-LIBC)
- I built this PR locally for these architectures (if supported. mark crossbuilds):
  - aarch64-musl
  - armv7l
  - armv6l-musl
-->

Closes https://github.com/void-linux/void-packages/issues/36929

As noted in the modrana template, the latest version is only mentioned in the commit log and is not tagged. Not sure why...

I got pyotherside cross-compiling working, but need help with figuring out how to make modrana cross-build, specifically for `make launcher`

[ci skip]

A patch file from https://github.com/void-linux/void-packages/pull/38461.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-maint/modrana-38461.patch --]
[-- Type: text/x-diff, Size: 2715 bytes --]

From 3aea3533fdff8a06befb0b6c5034359143a9b6c4 Mon Sep 17 00:00:00 2001
From: Joel Beckmeyer <joel@beckmeyer.us>
Date: Wed, 3 Aug 2022 15:21:21 -0400
Subject: [PATCH 1/2] New package: pyotherside-1.5.9

---
 srcpkgs/pyotherside/template | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
 create mode 100644 srcpkgs/pyotherside/template

diff --git a/srcpkgs/pyotherside/template b/srcpkgs/pyotherside/template
new file mode 100644
index 000000000000..f0e98f649109
--- /dev/null
+++ b/srcpkgs/pyotherside/template
@@ -0,0 +1,21 @@
+# Template file for 'pyotherside'
+pkgname=pyotherside
+version=1.5.9
+revision=1
+build_style=qmake
+configure_args="PYTHON_CONFIG=${XBPS_CROSS_BASE}/usr/bin/python3-config"
+hostmakedepends="qt5-qmake qt5-host-tools"
+makedepends="python3-devel qt5-svg-devel qt5-declarative-devel"
+short_desc="Asynchronous Python 3 Bindings for Qt 5"
+maintainer="Joel Beckmeyer <joel@beckmeyer.us>"
+license="ISC"
+homepage="https://thp.io/2011/pyotherside/"
+distfiles="https://github.com/thp/pyotherside/archive/${version}.tar.gz"
+checksum=189cb0b973e40fcb6b95fd51b0bcd6cc8494b514d49ffe966ec488cf05bbf51e
+
+post_install() {
+	vlicense LICENSE
+
+	# remove tests polluting /usr
+	rm ${DESTDIR}/usr/tests/qtquicktests/qtquicktests
+}

From 32ef86b141018c577438133ca1e70212c3913a76 Mon Sep 17 00:00:00 2001
From: Joel Beckmeyer <joel@beckmeyer.us>
Date: Tue, 31 May 2022 10:26:17 -0400
Subject: [PATCH 2/2] New package: modrana-0.56.17

---
 srcpkgs/modrana/template | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
 create mode 100644 srcpkgs/modrana/template

diff --git a/srcpkgs/modrana/template b/srcpkgs/modrana/template
new file mode 100644
index 000000000000..3b85e2c19c5c
--- /dev/null
+++ b/srcpkgs/modrana/template
@@ -0,0 +1,31 @@
+# Template file for 'modrana'
+pkgname=modrana
+version=0.57.3
+revision=1
+# releases aren't tagged in git
+_version_commit=dbd558d407abe7a3a4a352c96b618147cade4bd9
+wrksrc="modrana-${_version_commit}"
+hostmakedepends="rsync python3 qt5-qmake"
+makedepends="qt5-declarative-devel"
+depends="pyotherside"
+short_desc="Flexible GPS navigation system for mobile devices"
+maintainer="Joel Beckmeyer <joel@beckmeyer.us>"
+license="GPL-3.0-or-later"
+homepage="https://modrana.org"
+distfiles="https://github.com/M4rtinK/modrana/archive/${_version_commit}.tar.gz"
+checksum=7f93e4660997a8cba4194709c4566dec667da1c99ae45dd66ea6df71b8c637a6
+python_version=3
+
+do_build() {
+	make VersionFile
+	make
+	make rsync
+	make bytecode-python3
+	make launcher
+}
+
+do_install() {
+	make DESTDIR="$DESTDIR" install
+	# not sure why the gtk binary is still here, only qt is supported/working
+	rm ${DESTDIR}/usr/bin/modrana-gtk
+}

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: [PR REVIEW] [WIP] New package: modrana-0.56.17
  2022-08-03 22:46 [PR PATCH] [WIP] New package: modrana-0.56.17 TinfoilSubmarine
  2022-08-03 22:48 ` [PR PATCH] [Updated] " TinfoilSubmarine
@ 2022-08-03 23:06 ` classabbyamp
  2022-08-04 15:32 ` [PR PATCH] [Updated] " TinfoilSubmarine
                   ` (5 subsequent siblings)
  7 siblings, 0 replies; 9+ messages in thread
From: classabbyamp @ 2022-08-03 23:06 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 347 bytes --]

New review comment by classabbyamp on void-packages repository

https://github.com/void-linux/void-packages/pull/38461#discussion_r937205639

Comment:
this could maybe be `make VersionFile all rsync bytecode-python3 launcher`? (not sure if this will work due to parallelism)

also this might be able to be done with one of the make buildstyles?

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: [PR PATCH] [Updated] [WIP] New package: modrana-0.56.17
  2022-08-03 22:46 [PR PATCH] [WIP] New package: modrana-0.56.17 TinfoilSubmarine
  2022-08-03 22:48 ` [PR PATCH] [Updated] " TinfoilSubmarine
  2022-08-03 23:06 ` [PR REVIEW] " classabbyamp
@ 2022-08-04 15:32 ` TinfoilSubmarine
  2022-08-04 15:32 ` [PR REVIEW] " TinfoilSubmarine
                   ` (4 subsequent siblings)
  7 siblings, 0 replies; 9+ messages in thread
From: TinfoilSubmarine @ 2022-08-04 15:32 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1622 bytes --]

There is an updated pull request by TinfoilSubmarine against master on the void-packages repository

https://github.com/TinfoilSubmarine/void-packages maint/modrana
https://github.com/void-linux/void-packages/pull/38461

[WIP] New package: modrana-0.56.17
<!-- Uncomment relevant sections and delete options which are not applicable -->

#### Testing the changes
- I tested the changes in this PR: **briefly**

<!--
#### New package
- This new package conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements): **YES**|**NO**
-->

<!-- Note: If the build is likely to take more than 2 hours, please add ci skip tag as described in
https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->
<!--
#### Local build testing
- I built this PR locally for my native architecture, (ARCH-LIBC)
- I built this PR locally for these architectures (if supported. mark crossbuilds):
  - aarch64-musl
  - armv7l
  - armv6l-musl
-->

Closes https://github.com/void-linux/void-packages/issues/36929

As noted in the modrana template, the latest version is only mentioned in the commit log and is not tagged. Not sure why...

I got pyotherside cross-compiling working, but need help with figuring out how to make modrana cross-build, specifically for `make launcher`

[ci skip]

A patch file from https://github.com/void-linux/void-packages/pull/38461.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-maint/modrana-38461.patch --]
[-- Type: text/x-diff, Size: 2921 bytes --]

From 3df6aa282340ea53770f543d1bca49f1ba48608c Mon Sep 17 00:00:00 2001
From: Joel Beckmeyer <joel@beckmeyer.us>
Date: Wed, 3 Aug 2022 15:21:21 -0400
Subject: [PATCH 1/2] New package: pyotherside-1.5.9

---
 srcpkgs/pyotherside/template | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
 create mode 100644 srcpkgs/pyotherside/template

diff --git a/srcpkgs/pyotherside/template b/srcpkgs/pyotherside/template
new file mode 100644
index 000000000000..f0e98f649109
--- /dev/null
+++ b/srcpkgs/pyotherside/template
@@ -0,0 +1,21 @@
+# Template file for 'pyotherside'
+pkgname=pyotherside
+version=1.5.9
+revision=1
+build_style=qmake
+configure_args="PYTHON_CONFIG=${XBPS_CROSS_BASE}/usr/bin/python3-config"
+hostmakedepends="qt5-qmake qt5-host-tools"
+makedepends="python3-devel qt5-svg-devel qt5-declarative-devel"
+short_desc="Asynchronous Python 3 Bindings for Qt 5"
+maintainer="Joel Beckmeyer <joel@beckmeyer.us>"
+license="ISC"
+homepage="https://thp.io/2011/pyotherside/"
+distfiles="https://github.com/thp/pyotherside/archive/${version}.tar.gz"
+checksum=189cb0b973e40fcb6b95fd51b0bcd6cc8494b514d49ffe966ec488cf05bbf51e
+
+post_install() {
+	vlicense LICENSE
+
+	# remove tests polluting /usr
+	rm ${DESTDIR}/usr/tests/qtquicktests/qtquicktests
+}

From c226535d53674af7f55d3f6dc17f33fe44aa30df Mon Sep 17 00:00:00 2001
From: Joel Beckmeyer <joel@beckmeyer.us>
Date: Tue, 31 May 2022 10:26:17 -0400
Subject: [PATCH 2/2] New package: modrana-0.56.17

---
 srcpkgs/modrana/template | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
 create mode 100644 srcpkgs/modrana/template

diff --git a/srcpkgs/modrana/template b/srcpkgs/modrana/template
new file mode 100644
index 000000000000..b5857176b8f5
--- /dev/null
+++ b/srcpkgs/modrana/template
@@ -0,0 +1,31 @@
+# Template file for 'modrana'
+pkgname=modrana
+version=0.57.3
+revision=1
+# releases aren't tagged in git
+_version_commit=dbd558d407abe7a3a4a352c96b618147cade4bd9
+wrksrc="modrana-${_version_commit}"
+build_style=gnu-makefile
+build_helper=qmake
+make_build_target="VersionFile all rsync launcher"
+hostmakedepends="rsync qt5-qmake qt5-host-tools"
+makedepends="qt5-declarative-devel"
+depends="pyotherside"
+short_desc="Flexible GPS navigation system for mobile devices"
+maintainer="Joel Beckmeyer <joel@beckmeyer.us>"
+license="GPL-3.0-or-later"
+homepage="https://modrana.org"
+distfiles="https://github.com/M4rtinK/modrana/archive/${_version_commit}.tar.gz"
+checksum=7f93e4660997a8cba4194709c4566dec667da1c99ae45dd66ea6df71b8c637a6
+python_version=3
+make_use_env=yes
+disable_parallel_build=yes
+
+post_install() {
+	# not sure why the gtk binary is still here, only qt is supported/working
+	rm ${DESTDIR}/usr/bin/modrana-gtk
+	# broken, tries to invoke QT launcher with wrong patch (/usr/modrana), just
+	# use modrana-qt5
+	rm ${DESTDIR}/usr/bin/modrana
+	rm ${DESTDIR}/usr/share/applications/modrana.desktop
+}

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: [PR REVIEW] [WIP] New package: modrana-0.56.17
  2022-08-03 22:46 [PR PATCH] [WIP] New package: modrana-0.56.17 TinfoilSubmarine
                   ` (2 preceding siblings ...)
  2022-08-04 15:32 ` [PR PATCH] [Updated] " TinfoilSubmarine
@ 2022-08-04 15:32 ` TinfoilSubmarine
  2022-08-04 15:33 ` [PR PATCH] [Updated] " TinfoilSubmarine
                   ` (3 subsequent siblings)
  7 siblings, 0 replies; 9+ messages in thread
From: TinfoilSubmarine @ 2022-08-04 15:32 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 241 bytes --]

New review comment by TinfoilSubmarine on void-packages repository

https://github.com/void-linux/void-packages/pull/38461#discussion_r937938562

Comment:
Thanks, took a little bit of fiddling, but I got it to use `build_style=gnu-makefile`

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: [PR PATCH] [Updated] [WIP] New package: modrana-0.56.17
  2022-08-03 22:46 [PR PATCH] [WIP] New package: modrana-0.56.17 TinfoilSubmarine
                   ` (3 preceding siblings ...)
  2022-08-04 15:32 ` [PR REVIEW] " TinfoilSubmarine
@ 2022-08-04 15:33 ` TinfoilSubmarine
  2022-08-04 15:37 ` TinfoilSubmarine
                   ` (2 subsequent siblings)
  7 siblings, 0 replies; 9+ messages in thread
From: TinfoilSubmarine @ 2022-08-04 15:33 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1613 bytes --]

There is an updated pull request by TinfoilSubmarine against master on the void-packages repository

https://github.com/TinfoilSubmarine/void-packages maint/modrana
https://github.com/void-linux/void-packages/pull/38461

[WIP] New package: modrana-0.56.17
<!-- Uncomment relevant sections and delete options which are not applicable -->

#### Testing the changes
- I tested the changes in this PR: **briefly**

<!--
#### New package
- This new package conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements): **YES**|**NO**
-->

<!-- Note: If the build is likely to take more than 2 hours, please add ci skip tag as described in
https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->
<!--
#### Local build testing
- I built this PR locally for my native architecture, (ARCH-LIBC)
- I built this PR locally for these architectures (if supported. mark crossbuilds):
  - aarch64-musl
  - armv7l
  - armv6l-musl
-->

Closes https://github.com/void-linux/void-packages/issues/36929

As noted in the modrana template, the latest version is only mentioned in the commit log and is not tagged. Not sure why...

~~I got pyotherside cross-compiling working, but need help with figuring out how to make modrana cross-build, specifically for `make launcher`~~

A patch file from https://github.com/void-linux/void-packages/pull/38461.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-maint/modrana-38461.patch --]
[-- Type: text/x-diff, Size: 2921 bytes --]

From 3df6aa282340ea53770f543d1bca49f1ba48608c Mon Sep 17 00:00:00 2001
From: Joel Beckmeyer <joel@beckmeyer.us>
Date: Wed, 3 Aug 2022 15:21:21 -0400
Subject: [PATCH 1/2] New package: pyotherside-1.5.9

---
 srcpkgs/pyotherside/template | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
 create mode 100644 srcpkgs/pyotherside/template

diff --git a/srcpkgs/pyotherside/template b/srcpkgs/pyotherside/template
new file mode 100644
index 000000000000..f0e98f649109
--- /dev/null
+++ b/srcpkgs/pyotherside/template
@@ -0,0 +1,21 @@
+# Template file for 'pyotherside'
+pkgname=pyotherside
+version=1.5.9
+revision=1
+build_style=qmake
+configure_args="PYTHON_CONFIG=${XBPS_CROSS_BASE}/usr/bin/python3-config"
+hostmakedepends="qt5-qmake qt5-host-tools"
+makedepends="python3-devel qt5-svg-devel qt5-declarative-devel"
+short_desc="Asynchronous Python 3 Bindings for Qt 5"
+maintainer="Joel Beckmeyer <joel@beckmeyer.us>"
+license="ISC"
+homepage="https://thp.io/2011/pyotherside/"
+distfiles="https://github.com/thp/pyotherside/archive/${version}.tar.gz"
+checksum=189cb0b973e40fcb6b95fd51b0bcd6cc8494b514d49ffe966ec488cf05bbf51e
+
+post_install() {
+	vlicense LICENSE
+
+	# remove tests polluting /usr
+	rm ${DESTDIR}/usr/tests/qtquicktests/qtquicktests
+}

From 94521c6c4884dca03f3ea2915fc24679532113e4 Mon Sep 17 00:00:00 2001
From: Joel Beckmeyer <joel@beckmeyer.us>
Date: Tue, 31 May 2022 10:26:17 -0400
Subject: [PATCH 2/2] New package: modrana-0.56.17

---
 srcpkgs/modrana/template | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
 create mode 100644 srcpkgs/modrana/template

diff --git a/srcpkgs/modrana/template b/srcpkgs/modrana/template
new file mode 100644
index 000000000000..6c20d04a1728
--- /dev/null
+++ b/srcpkgs/modrana/template
@@ -0,0 +1,31 @@
+# Template file for 'modrana'
+pkgname=modrana
+version=0.57.3
+revision=1
+# releases aren't tagged in git
+_version_commit=dbd558d407abe7a3a4a352c96b618147cade4bd9
+wrksrc="modrana-${_version_commit}"
+build_style=gnu-makefile
+build_helper=qmake
+make_build_target="VersionFile all rsync launcher"
+make_use_env=yes
+hostmakedepends="rsync qt5-qmake qt5-host-tools"
+makedepends="qt5-declarative-devel"
+depends="pyotherside"
+short_desc="Flexible GPS navigation system for mobile devices"
+maintainer="Joel Beckmeyer <joel@beckmeyer.us>"
+license="GPL-3.0-or-later"
+homepage="https://modrana.org"
+distfiles="https://github.com/M4rtinK/modrana/archive/${_version_commit}.tar.gz"
+checksum=7f93e4660997a8cba4194709c4566dec667da1c99ae45dd66ea6df71b8c637a6
+python_version=3
+disable_parallel_build=yes
+
+post_install() {
+	# not sure why the gtk binary is still here, only qt is supported/working
+	rm ${DESTDIR}/usr/bin/modrana-gtk
+	# broken, tries to invoke QT launcher with wrong patch (/usr/modrana), just
+	# use modrana-qt5
+	rm ${DESTDIR}/usr/bin/modrana
+	rm ${DESTDIR}/usr/share/applications/modrana.desktop
+}

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: [PR PATCH] [Updated] [WIP] New package: modrana-0.56.17
  2022-08-03 22:46 [PR PATCH] [WIP] New package: modrana-0.56.17 TinfoilSubmarine
                   ` (4 preceding siblings ...)
  2022-08-04 15:33 ` [PR PATCH] [Updated] " TinfoilSubmarine
@ 2022-08-04 15:37 ` TinfoilSubmarine
  2022-09-07 20:06 ` [PR PATCH] [Updated] " TinfoilSubmarine
  2022-09-07 20:14 ` TinfoilSubmarine
  7 siblings, 0 replies; 9+ messages in thread
From: TinfoilSubmarine @ 2022-08-04 15:37 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1613 bytes --]

There is an updated pull request by TinfoilSubmarine against master on the void-packages repository

https://github.com/TinfoilSubmarine/void-packages maint/modrana
https://github.com/void-linux/void-packages/pull/38461

[WIP] New package: modrana-0.56.17
<!-- Uncomment relevant sections and delete options which are not applicable -->

#### Testing the changes
- I tested the changes in this PR: **briefly**

<!--
#### New package
- This new package conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements): **YES**|**NO**
-->

<!-- Note: If the build is likely to take more than 2 hours, please add ci skip tag as described in
https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->
<!--
#### Local build testing
- I built this PR locally for my native architecture, (ARCH-LIBC)
- I built this PR locally for these architectures (if supported. mark crossbuilds):
  - aarch64-musl
  - armv7l
  - armv6l-musl
-->

Closes https://github.com/void-linux/void-packages/issues/36929

As noted in the modrana template, the latest version is only mentioned in the commit log and is not tagged. Not sure why...

~~I got pyotherside cross-compiling working, but need help with figuring out how to make modrana cross-build, specifically for `make launcher`~~

A patch file from https://github.com/void-linux/void-packages/pull/38461.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-maint/modrana-38461.patch --]
[-- Type: text/x-diff, Size: 2920 bytes --]

From 3df6aa282340ea53770f543d1bca49f1ba48608c Mon Sep 17 00:00:00 2001
From: Joel Beckmeyer <joel@beckmeyer.us>
Date: Wed, 3 Aug 2022 15:21:21 -0400
Subject: [PATCH 1/2] New package: pyotherside-1.5.9

---
 srcpkgs/pyotherside/template | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
 create mode 100644 srcpkgs/pyotherside/template

diff --git a/srcpkgs/pyotherside/template b/srcpkgs/pyotherside/template
new file mode 100644
index 000000000000..f0e98f649109
--- /dev/null
+++ b/srcpkgs/pyotherside/template
@@ -0,0 +1,21 @@
+# Template file for 'pyotherside'
+pkgname=pyotherside
+version=1.5.9
+revision=1
+build_style=qmake
+configure_args="PYTHON_CONFIG=${XBPS_CROSS_BASE}/usr/bin/python3-config"
+hostmakedepends="qt5-qmake qt5-host-tools"
+makedepends="python3-devel qt5-svg-devel qt5-declarative-devel"
+short_desc="Asynchronous Python 3 Bindings for Qt 5"
+maintainer="Joel Beckmeyer <joel@beckmeyer.us>"
+license="ISC"
+homepage="https://thp.io/2011/pyotherside/"
+distfiles="https://github.com/thp/pyotherside/archive/${version}.tar.gz"
+checksum=189cb0b973e40fcb6b95fd51b0bcd6cc8494b514d49ffe966ec488cf05bbf51e
+
+post_install() {
+	vlicense LICENSE
+
+	# remove tests polluting /usr
+	rm ${DESTDIR}/usr/tests/qtquicktests/qtquicktests
+}

From 24508cbe764b62b6f21f1f6c2872d741f050ef27 Mon Sep 17 00:00:00 2001
From: Joel Beckmeyer <joel@beckmeyer.us>
Date: Tue, 31 May 2022 10:26:17 -0400
Subject: [PATCH 2/2] New package: modrana-0.56.17

---
 srcpkgs/modrana/template | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
 create mode 100644 srcpkgs/modrana/template

diff --git a/srcpkgs/modrana/template b/srcpkgs/modrana/template
new file mode 100644
index 000000000000..abb9de14debb
--- /dev/null
+++ b/srcpkgs/modrana/template
@@ -0,0 +1,31 @@
+# Template file for 'modrana'
+pkgname=modrana
+version=0.57.3
+revision=1
+# releases aren't tagged in git
+_version_commit=dbd558d407abe7a3a4a352c96b618147cade4bd9
+wrksrc="modrana-${_version_commit}"
+build_style=gnu-makefile
+build_helper=qmake
+make_build_target="VersionFile all rsync launcher"
+make_use_env=yes
+hostmakedepends="rsync qt5-qmake qt5-host-tools"
+makedepends="qt5-declarative-devel"
+depends="pyotherside"
+short_desc="Flexible GPS navigation system for mobile devices"
+maintainer="Joel Beckmeyer <joel@beckmeyer.us>"
+license="GPL-3.0-or-later"
+homepage="https://modrana.org"
+distfiles="https://github.com/M4rtinK/modrana/archive/${_version_commit}.tar.gz"
+checksum=7f93e4660997a8cba4194709c4566dec667da1c99ae45dd66ea6df71b8c637a6
+python_version=3
+disable_parallel_build=yes
+
+post_install() {
+	# not sure why the gtk binary is still here, only qt is supported/working
+	rm ${DESTDIR}/usr/bin/modrana-gtk
+	# broken, tries to invoke QT launcher with wrong path (/usr/modrana), just
+	# use modrana-qt5
+	rm ${DESTDIR}/usr/bin/modrana
+	rm ${DESTDIR}/usr/share/applications/modrana.desktop
+}

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: [PR PATCH] [Updated] New package: modrana-0.56.17
  2022-08-03 22:46 [PR PATCH] [WIP] New package: modrana-0.56.17 TinfoilSubmarine
                   ` (5 preceding siblings ...)
  2022-08-04 15:37 ` TinfoilSubmarine
@ 2022-09-07 20:06 ` TinfoilSubmarine
  2022-09-07 20:14 ` TinfoilSubmarine
  7 siblings, 0 replies; 9+ messages in thread
From: TinfoilSubmarine @ 2022-09-07 20:06 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1607 bytes --]

There is an updated pull request by TinfoilSubmarine against master on the void-packages repository

https://github.com/TinfoilSubmarine/void-packages maint/modrana
https://github.com/void-linux/void-packages/pull/38461

New package: modrana-0.56.17
<!-- Uncomment relevant sections and delete options which are not applicable -->

#### Testing the changes
- I tested the changes in this PR: **briefly**

<!--
#### New package
- This new package conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements): **YES**|**NO**
-->

<!-- Note: If the build is likely to take more than 2 hours, please add ci skip tag as described in
https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->
<!--
#### Local build testing
- I built this PR locally for my native architecture, (ARCH-LIBC)
- I built this PR locally for these architectures (if supported. mark crossbuilds):
  - aarch64-musl
  - armv7l
  - armv6l-musl
-->

Closes https://github.com/void-linux/void-packages/issues/36929

As noted in the modrana template, the latest version is only mentioned in the commit log and is not tagged. Not sure why...

~~I got pyotherside cross-compiling working, but need help with figuring out how to make modrana cross-build, specifically for `make launcher`~~

A patch file from https://github.com/void-linux/void-packages/pull/38461.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-maint/modrana-38461.patch --]
[-- Type: text/x-diff, Size: 2920 bytes --]

From bc0fd78f9defd46b162e20f07ae0f40603a908bb Mon Sep 17 00:00:00 2001
From: Joel Beckmeyer <joel@beckmeyer.us>
Date: Wed, 3 Aug 2022 15:21:21 -0400
Subject: [PATCH 1/2] New package: pyotherside-1.6.0

---
 srcpkgs/pyotherside/template | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
 create mode 100644 srcpkgs/pyotherside/template

diff --git a/srcpkgs/pyotherside/template b/srcpkgs/pyotherside/template
new file mode 100644
index 000000000000..97dc745b4d6c
--- /dev/null
+++ b/srcpkgs/pyotherside/template
@@ -0,0 +1,21 @@
+# Template file for 'pyotherside'
+pkgname=pyotherside
+version=1.6.0
+revision=1
+build_style=qmake
+configure_args="PYTHON_CONFIG=${XBPS_CROSS_BASE}/usr/bin/python3-config"
+hostmakedepends="qt5-qmake qt5-host-tools"
+makedepends="python3-devel qt5-svg-devel qt5-declarative-devel"
+short_desc="Asynchronous Python 3 Bindings for Qt 5"
+maintainer="Joel Beckmeyer <joel@beckmeyer.us>"
+license="ISC"
+homepage="https://thp.io/2011/pyotherside/"
+distfiles="https://github.com/thp/pyotherside/archive/${version}.tar.gz"
+checksum=ead71d0a549acb6664d72745fae5b1d4e433274c64be6a680ceeeef0754451ab
+
+post_install() {
+	vlicense LICENSE
+
+	# remove tests polluting /usr
+	rm ${DESTDIR}/usr/tests/qtquicktests/qtquicktests
+}

From 81b69d288a2af2971a56238e8b7032fad929f0a8 Mon Sep 17 00:00:00 2001
From: Joel Beckmeyer <joel@beckmeyer.us>
Date: Tue, 31 May 2022 10:26:17 -0400
Subject: [PATCH 2/2] New package: modrana-0.56.17

---
 srcpkgs/modrana/template | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
 create mode 100644 srcpkgs/modrana/template

diff --git a/srcpkgs/modrana/template b/srcpkgs/modrana/template
new file mode 100644
index 000000000000..abb9de14debb
--- /dev/null
+++ b/srcpkgs/modrana/template
@@ -0,0 +1,31 @@
+# Template file for 'modrana'
+pkgname=modrana
+version=0.57.3
+revision=1
+# releases aren't tagged in git
+_version_commit=dbd558d407abe7a3a4a352c96b618147cade4bd9
+wrksrc="modrana-${_version_commit}"
+build_style=gnu-makefile
+build_helper=qmake
+make_build_target="VersionFile all rsync launcher"
+make_use_env=yes
+hostmakedepends="rsync qt5-qmake qt5-host-tools"
+makedepends="qt5-declarative-devel"
+depends="pyotherside"
+short_desc="Flexible GPS navigation system for mobile devices"
+maintainer="Joel Beckmeyer <joel@beckmeyer.us>"
+license="GPL-3.0-or-later"
+homepage="https://modrana.org"
+distfiles="https://github.com/M4rtinK/modrana/archive/${_version_commit}.tar.gz"
+checksum=7f93e4660997a8cba4194709c4566dec667da1c99ae45dd66ea6df71b8c637a6
+python_version=3
+disable_parallel_build=yes
+
+post_install() {
+	# not sure why the gtk binary is still here, only qt is supported/working
+	rm ${DESTDIR}/usr/bin/modrana-gtk
+	# broken, tries to invoke QT launcher with wrong path (/usr/modrana), just
+	# use modrana-qt5
+	rm ${DESTDIR}/usr/bin/modrana
+	rm ${DESTDIR}/usr/share/applications/modrana.desktop
+}

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: [PR PATCH] [Updated] New package: modrana-0.56.17
  2022-08-03 22:46 [PR PATCH] [WIP] New package: modrana-0.56.17 TinfoilSubmarine
                   ` (6 preceding siblings ...)
  2022-09-07 20:06 ` [PR PATCH] [Updated] " TinfoilSubmarine
@ 2022-09-07 20:14 ` TinfoilSubmarine
  7 siblings, 0 replies; 9+ messages in thread
From: TinfoilSubmarine @ 2022-09-07 20:14 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1607 bytes --]

There is an updated pull request by TinfoilSubmarine against master on the void-packages repository

https://github.com/TinfoilSubmarine/void-packages maint/modrana
https://github.com/void-linux/void-packages/pull/38461

New package: modrana-0.56.17
<!-- Uncomment relevant sections and delete options which are not applicable -->

#### Testing the changes
- I tested the changes in this PR: **briefly**

<!--
#### New package
- This new package conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements): **YES**|**NO**
-->

<!-- Note: If the build is likely to take more than 2 hours, please add ci skip tag as described in
https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->
<!--
#### Local build testing
- I built this PR locally for my native architecture, (ARCH-LIBC)
- I built this PR locally for these architectures (if supported. mark crossbuilds):
  - aarch64-musl
  - armv7l
  - armv6l-musl
-->

Closes https://github.com/void-linux/void-packages/issues/36929

As noted in the modrana template, the latest version is only mentioned in the commit log and is not tagged. Not sure why...

~~I got pyotherside cross-compiling working, but need help with figuring out how to make modrana cross-build, specifically for `make launcher`~~

A patch file from https://github.com/void-linux/void-packages/pull/38461.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-maint/modrana-38461.patch --]
[-- Type: text/x-diff, Size: 2919 bytes --]

From bc0fd78f9defd46b162e20f07ae0f40603a908bb Mon Sep 17 00:00:00 2001
From: Joel Beckmeyer <joel@beckmeyer.us>
Date: Wed, 3 Aug 2022 15:21:21 -0400
Subject: [PATCH 1/2] New package: pyotherside-1.6.0

---
 srcpkgs/pyotherside/template | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
 create mode 100644 srcpkgs/pyotherside/template

diff --git a/srcpkgs/pyotherside/template b/srcpkgs/pyotherside/template
new file mode 100644
index 000000000000..97dc745b4d6c
--- /dev/null
+++ b/srcpkgs/pyotherside/template
@@ -0,0 +1,21 @@
+# Template file for 'pyotherside'
+pkgname=pyotherside
+version=1.6.0
+revision=1
+build_style=qmake
+configure_args="PYTHON_CONFIG=${XBPS_CROSS_BASE}/usr/bin/python3-config"
+hostmakedepends="qt5-qmake qt5-host-tools"
+makedepends="python3-devel qt5-svg-devel qt5-declarative-devel"
+short_desc="Asynchronous Python 3 Bindings for Qt 5"
+maintainer="Joel Beckmeyer <joel@beckmeyer.us>"
+license="ISC"
+homepage="https://thp.io/2011/pyotherside/"
+distfiles="https://github.com/thp/pyotherside/archive/${version}.tar.gz"
+checksum=ead71d0a549acb6664d72745fae5b1d4e433274c64be6a680ceeeef0754451ab
+
+post_install() {
+	vlicense LICENSE
+
+	# remove tests polluting /usr
+	rm ${DESTDIR}/usr/tests/qtquicktests/qtquicktests
+}

From dd049f6b9ec5ea967d78f1be35214b30b72f0107 Mon Sep 17 00:00:00 2001
From: Joel Beckmeyer <joel@beckmeyer.us>
Date: Tue, 31 May 2022 10:26:17 -0400
Subject: [PATCH 2/2] New package: modrana-0.57.3

---
 srcpkgs/modrana/template | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
 create mode 100644 srcpkgs/modrana/template

diff --git a/srcpkgs/modrana/template b/srcpkgs/modrana/template
new file mode 100644
index 000000000000..abb9de14debb
--- /dev/null
+++ b/srcpkgs/modrana/template
@@ -0,0 +1,31 @@
+# Template file for 'modrana'
+pkgname=modrana
+version=0.57.3
+revision=1
+# releases aren't tagged in git
+_version_commit=dbd558d407abe7a3a4a352c96b618147cade4bd9
+wrksrc="modrana-${_version_commit}"
+build_style=gnu-makefile
+build_helper=qmake
+make_build_target="VersionFile all rsync launcher"
+make_use_env=yes
+hostmakedepends="rsync qt5-qmake qt5-host-tools"
+makedepends="qt5-declarative-devel"
+depends="pyotherside"
+short_desc="Flexible GPS navigation system for mobile devices"
+maintainer="Joel Beckmeyer <joel@beckmeyer.us>"
+license="GPL-3.0-or-later"
+homepage="https://modrana.org"
+distfiles="https://github.com/M4rtinK/modrana/archive/${_version_commit}.tar.gz"
+checksum=7f93e4660997a8cba4194709c4566dec667da1c99ae45dd66ea6df71b8c637a6
+python_version=3
+disable_parallel_build=yes
+
+post_install() {
+	# not sure why the gtk binary is still here, only qt is supported/working
+	rm ${DESTDIR}/usr/bin/modrana-gtk
+	# broken, tries to invoke QT launcher with wrong path (/usr/modrana), just
+	# use modrana-qt5
+	rm ${DESTDIR}/usr/bin/modrana
+	rm ${DESTDIR}/usr/share/applications/modrana.desktop
+}

^ permalink raw reply	[flat|nested] 9+ messages in thread

end of thread, other threads:[~2022-09-07 20:14 UTC | newest]

Thread overview: 9+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-08-03 22:46 [PR PATCH] [WIP] New package: modrana-0.56.17 TinfoilSubmarine
2022-08-03 22:48 ` [PR PATCH] [Updated] " TinfoilSubmarine
2022-08-03 23:06 ` [PR REVIEW] " classabbyamp
2022-08-04 15:32 ` [PR PATCH] [Updated] " TinfoilSubmarine
2022-08-04 15:32 ` [PR REVIEW] " TinfoilSubmarine
2022-08-04 15:33 ` [PR PATCH] [Updated] " TinfoilSubmarine
2022-08-04 15:37 ` TinfoilSubmarine
2022-09-07 20:06 ` [PR PATCH] [Updated] " TinfoilSubmarine
2022-09-07 20:14 ` TinfoilSubmarine

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).