Github messages for voidlinux
 help / color / Atom feed
* [PR PATCH] New package: Viber
@ 2019-07-29 16:41 voidlinux-github
  2019-07-29 16:45 ` [PR PATCH] [Updated] " voidlinux-github
                   ` (5 more replies)
  0 siblings, 6 replies; 7+ messages in thread
From: voidlinux-github @ 2019-07-29 16:41 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 546 bytes --]

There is a new pull request by 66Ton99 against master on the void-packages repository

https://github.com/66Ton99/void-packages viber
https://github.com/void-linux/void-packages/pull/13401

New package: Viber
New package: viber-10.3.0_37

I has a problem - it can't be versioned "https://download.cdn.viber.com/cdn/desktop/Linux/viber.deb" it does not have any parameters.
Does exist any way to disable "checksum" it is checks inside "preinst" script?

A patch file from https://github.com/void-linux/void-packages/pull/13401.patch is attached

[-- Warning: decoded text below may be mangled --]
[-- Attachment #2: github-pr-viber-13401.patch --]
[-- Type: text/x-diff, Size: 1234 bytes --]

From 86e14308da360f3f3a1061e741a0ad67608126b0 Mon Sep 17 00:00:00 2001
From: Anton Shapka <anton.shapka@oracle.com>
Date: Mon, 29 Jul 2019 19:25:45 +0300
Subject: [PATCH] New package: Viber

---
 srcpkgs/viber/template | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
 create mode 100644 srcpkgs/viber/template

diff --git a/srcpkgs/viber/template b/srcpkgs/viber/template
new file mode 100644
index 00000000000..a2995b139dc
--- /dev/null
+++ b/srcpkgs/viber/template
@@ -0,0 +1,31 @@
+# Template file for 'viber'
+pkgname=viber
+version=10.3.0
+revision=37
+build_style=fetch
+archs="x86_64"
+short_desc="Viber is a cross-platform voice over IP (VoIP) and instant messaging (IM) software application"
+license="viber"
+homepage="https://www.viber.com/"
+repository=nonfree
+nostrip=yes
+distfiles="https://download.cdn.viber.com/cdn/desktop/Linux/viber.deb"
+checksum=a5d7d99afc8c186643d1393152a4729c4fc805f4241896c2f004c721619efe7c
+
+do_extract() {
+	ar x ${XBPS_SRCDISTDIR}/${pkgname}-${version}/viber.deb
+	unxz data.tar.xz
+	tar xopf data.tar
+	rm data.tar
+	gunzip control.tar.gz
+	tar xopf control.tar
+	rm control.tar
+}
+
+do_install() {
+	vcopy usr /
+	vcopy opt /
+	vbin preinst
+	vbin postinst
+}
+

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PR PATCH] [Updated] New package: Viber
  2019-07-29 16:41 [PR PATCH] New package: Viber voidlinux-github
  2019-07-29 16:45 ` [PR PATCH] [Updated] " voidlinux-github
@ 2019-07-29 16:45 ` voidlinux-github
  2019-07-30  9:55 ` voidlinux-github
                   ` (3 subsequent siblings)
  5 siblings, 0 replies; 7+ messages in thread
From: voidlinux-github @ 2019-07-29 16:45 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 551 bytes --]

There is an updated pull request by 66Ton99 against master on the void-packages repository

https://github.com/66Ton99/void-packages viber
https://github.com/void-linux/void-packages/pull/13401

New package: Viber
New package: viber-10.3.0_37

I has a problem - it can't be versioned "https://download.cdn.viber.com/cdn/desktop/Linux/viber.deb" it does not have any parameters.
Does exist any way to disable "checksum" it is checks inside "preinst" script?

A patch file from https://github.com/void-linux/void-packages/pull/13401.patch is attached

[-- Warning: decoded text below may be mangled --]
[-- Attachment #2: github-pr-viber-13401.patch --]
[-- Type: text/x-diff, Size: 1181 bytes --]

From 38e83426c4cb0d6891660cfce2559fd8c3c5edb1 Mon Sep 17 00:00:00 2001
From: Anton Shapka <anton.shapka@oracle.com>
Date: Mon, 29 Jul 2019 19:25:45 +0300
Subject: [PATCH] New package: Viber

---
 srcpkgs/viber/template | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
 create mode 100644 srcpkgs/viber/template

diff --git a/srcpkgs/viber/template b/srcpkgs/viber/template
new file mode 100644
index 00000000000..29c5a31976e
--- /dev/null
+++ b/srcpkgs/viber/template
@@ -0,0 +1,30 @@
+# Template file for 'viber'
+pkgname=viber
+version=10.3.0
+revision=37
+build_style=fetch
+short_desc="Viber is a cross-platform VoIP and IM software application"
+license="viber"
+homepage="https://www.viber.com/"
+distfiles="https://download.cdn.viber.com/cdn/desktop/Linux/viber.deb"
+checksum=a5d7d99afc8c186643d1393152a4729c4fc805f4241896c2f004c721619efe7c
+nostrip=yes
+repository=nonfree
+
+do_extract() {
+	ar x ${XBPS_SRCDISTDIR}/${pkgname}-${version}/viber.deb
+	unxz data.tar.xz
+	tar xopf data.tar
+	rm data.tar
+	gunzip control.tar.gz
+	tar xopf control.tar
+	rm control.tar
+}
+
+do_install() {
+	vcopy usr /
+	vcopy opt /
+	vbin preinst
+	vbin postinst
+}
+

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PR PATCH] [Updated] New package: Viber
  2019-07-29 16:41 [PR PATCH] New package: Viber voidlinux-github
@ 2019-07-29 16:45 ` " voidlinux-github
  2019-07-29 16:45 ` voidlinux-github
                   ` (4 subsequent siblings)
  5 siblings, 0 replies; 7+ messages in thread
From: voidlinux-github @ 2019-07-29 16:45 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 551 bytes --]

There is an updated pull request by 66Ton99 against master on the void-packages repository

https://github.com/66Ton99/void-packages viber
https://github.com/void-linux/void-packages/pull/13401

New package: Viber
New package: viber-10.3.0_37

I has a problem - it can't be versioned "https://download.cdn.viber.com/cdn/desktop/Linux/viber.deb" it does not have any parameters.
Does exist any way to disable "checksum" it is checks inside "preinst" script?

A patch file from https://github.com/void-linux/void-packages/pull/13401.patch is attached

[-- Warning: decoded text below may be mangled --]
[-- Attachment #2: github-pr-viber-13401.patch --]
[-- Type: text/x-diff, Size: 1181 bytes --]

From 38e83426c4cb0d6891660cfce2559fd8c3c5edb1 Mon Sep 17 00:00:00 2001
From: Anton Shapka <anton.shapka@oracle.com>
Date: Mon, 29 Jul 2019 19:25:45 +0300
Subject: [PATCH] New package: Viber

---
 srcpkgs/viber/template | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
 create mode 100644 srcpkgs/viber/template

diff --git a/srcpkgs/viber/template b/srcpkgs/viber/template
new file mode 100644
index 00000000000..29c5a31976e
--- /dev/null
+++ b/srcpkgs/viber/template
@@ -0,0 +1,30 @@
+# Template file for 'viber'
+pkgname=viber
+version=10.3.0
+revision=37
+build_style=fetch
+short_desc="Viber is a cross-platform VoIP and IM software application"
+license="viber"
+homepage="https://www.viber.com/"
+distfiles="https://download.cdn.viber.com/cdn/desktop/Linux/viber.deb"
+checksum=a5d7d99afc8c186643d1393152a4729c4fc805f4241896c2f004c721619efe7c
+nostrip=yes
+repository=nonfree
+
+do_extract() {
+	ar x ${XBPS_SRCDISTDIR}/${pkgname}-${version}/viber.deb
+	unxz data.tar.xz
+	tar xopf data.tar
+	rm data.tar
+	gunzip control.tar.gz
+	tar xopf control.tar
+	rm control.tar
+}
+
+do_install() {
+	vcopy usr /
+	vcopy opt /
+	vbin preinst
+	vbin postinst
+}
+

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PR PATCH] [Updated] New package: Viber
  2019-07-29 16:41 [PR PATCH] New package: Viber voidlinux-github
  2019-07-29 16:45 ` [PR PATCH] [Updated] " voidlinux-github
  2019-07-29 16:45 ` voidlinux-github
@ 2019-07-30  9:55 ` voidlinux-github
  2019-07-30  9:55 ` voidlinux-github
                   ` (2 subsequent siblings)
  5 siblings, 0 replies; 7+ messages in thread
From: voidlinux-github @ 2019-07-30  9:55 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 552 bytes --]

There is an updated pull request by 66Ton99 against master on the void-packages repository

https://github.com/66Ton99/void-packages viber
https://github.com/void-linux/void-packages/pull/13401

New package: Viber
New package: viber-10.3.0_37

It has a problem - it can't be versioned "https://download.cdn.viber.com/cdn/desktop/Linux/viber.deb" it does not have any parameters.
Does exist any way to disable "checksum" it is checks inside "preinst" script?

A patch file from https://github.com/void-linux/void-packages/pull/13401.patch is attached

[-- Warning: decoded text below may be mangled --]
[-- Attachment #2: github-pr-viber-13401.patch --]
[-- Type: text/x-diff, Size: 1669 bytes --]

From b6faf863a095617aae57feaae46dd2ca6f915565 Mon Sep 17 00:00:00 2001
From: Anton Shapka <anton.shapka@oracle.com>
Date: Mon, 29 Jul 2019 19:25:45 +0300
Subject: [PATCH] New package: Viber

---
 srcpkgs/viber/template | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)
 create mode 100644 srcpkgs/viber/template

diff --git a/srcpkgs/viber/template b/srcpkgs/viber/template
new file mode 100644
index 00000000000..b0512fa06e7
--- /dev/null
+++ b/srcpkgs/viber/template
@@ -0,0 +1,35 @@
+# Template file for 'viber'
+pkgname=viber
+version=10.3.0
+revision=37
+archs="x86_64"
+build_style=fetch
+short_desc="Viber is a cross-platform VoIP and IM software application"
+license="viber"
+homepage="https://www.viber.com/"
+_openssl_version=1.0-1.0.2.s-1
+distfiles="https://download.cdn.viber.com/cdn/desktop/Linux/viber.deb https://sgp.mirror.pkgbuild.com/core/os/x86_64/openssl-${_openssl_version}-x86_64.pkg.tar.xz"
+checksum="a5d7d99afc8c186643d1393152a4729c4fc805f4241896c2f004c721619efe7c 13c5b5c1a372cf9c481b2beb7e5fc607ccf52173d6075ae10281e4a3da179514"
+nostrip=yes
+repository=nonfree
+
+do_extract() {
+	ar x ${XBPS_SRCDISTDIR}/${pkgname}-${version}/viber.deb
+	unxz data.tar.xz
+	tar xopf data.tar
+	gunzip control.tar.gz
+	tar xopf control.tar
+	unxz -f ${XBPS_SRCDISTDIR}/${pkgname}-${version}/openssl-${_openssl_version}-x86_64.pkg.tar.xz --stdout > openssl.tar
+	mkdir openssl
+	tar xopf openssl.tar -C openssl
+}
+
+do_install() {
+	vcopy usr /
+	vcopy opt /
+	vbin preinst
+	vbin postinst
+	vcopy openssl/usr/lib/libssl.so.1.0.0 /opt/viber/lib/libssl.so
+	vcopy openssl/usr/lib/libcrypto.so.1.0.0 /opt/viber/lib/libcrypto.so
+}
+

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PR PATCH] [Updated] New package: Viber
  2019-07-29 16:41 [PR PATCH] New package: Viber voidlinux-github
                   ` (2 preceding siblings ...)
  2019-07-30  9:55 ` voidlinux-github
@ 2019-07-30  9:55 ` voidlinux-github
  2019-07-30 10:11 ` voidlinux-github
  2019-07-30 10:11 ` voidlinux-github
  5 siblings, 0 replies; 7+ messages in thread
From: voidlinux-github @ 2019-07-30  9:55 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 552 bytes --]

There is an updated pull request by 66Ton99 against master on the void-packages repository

https://github.com/66Ton99/void-packages viber
https://github.com/void-linux/void-packages/pull/13401

New package: Viber
New package: viber-10.3.0_37

It has a problem - it can't be versioned "https://download.cdn.viber.com/cdn/desktop/Linux/viber.deb" it does not have any parameters.
Does exist any way to disable "checksum" it is checks inside "preinst" script?

A patch file from https://github.com/void-linux/void-packages/pull/13401.patch is attached

[-- Warning: decoded text below may be mangled --]
[-- Attachment #2: github-pr-viber-13401.patch --]
[-- Type: text/x-diff, Size: 1669 bytes --]

From b6faf863a095617aae57feaae46dd2ca6f915565 Mon Sep 17 00:00:00 2001
From: Anton Shapka <anton.shapka@oracle.com>
Date: Mon, 29 Jul 2019 19:25:45 +0300
Subject: [PATCH] New package: Viber

---
 srcpkgs/viber/template | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)
 create mode 100644 srcpkgs/viber/template

diff --git a/srcpkgs/viber/template b/srcpkgs/viber/template
new file mode 100644
index 00000000000..b0512fa06e7
--- /dev/null
+++ b/srcpkgs/viber/template
@@ -0,0 +1,35 @@
+# Template file for 'viber'
+pkgname=viber
+version=10.3.0
+revision=37
+archs="x86_64"
+build_style=fetch
+short_desc="Viber is a cross-platform VoIP and IM software application"
+license="viber"
+homepage="https://www.viber.com/"
+_openssl_version=1.0-1.0.2.s-1
+distfiles="https://download.cdn.viber.com/cdn/desktop/Linux/viber.deb https://sgp.mirror.pkgbuild.com/core/os/x86_64/openssl-${_openssl_version}-x86_64.pkg.tar.xz"
+checksum="a5d7d99afc8c186643d1393152a4729c4fc805f4241896c2f004c721619efe7c 13c5b5c1a372cf9c481b2beb7e5fc607ccf52173d6075ae10281e4a3da179514"
+nostrip=yes
+repository=nonfree
+
+do_extract() {
+	ar x ${XBPS_SRCDISTDIR}/${pkgname}-${version}/viber.deb
+	unxz data.tar.xz
+	tar xopf data.tar
+	gunzip control.tar.gz
+	tar xopf control.tar
+	unxz -f ${XBPS_SRCDISTDIR}/${pkgname}-${version}/openssl-${_openssl_version}-x86_64.pkg.tar.xz --stdout > openssl.tar
+	mkdir openssl
+	tar xopf openssl.tar -C openssl
+}
+
+do_install() {
+	vcopy usr /
+	vcopy opt /
+	vbin preinst
+	vbin postinst
+	vcopy openssl/usr/lib/libssl.so.1.0.0 /opt/viber/lib/libssl.so
+	vcopy openssl/usr/lib/libcrypto.so.1.0.0 /opt/viber/lib/libcrypto.so
+}
+

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PR PATCH] [Updated] New package: Viber
  2019-07-29 16:41 [PR PATCH] New package: Viber voidlinux-github
                   ` (4 preceding siblings ...)
  2019-07-30 10:11 ` voidlinux-github
@ 2019-07-30 10:11 ` voidlinux-github
  5 siblings, 0 replies; 7+ messages in thread
From: voidlinux-github @ 2019-07-30 10:11 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 552 bytes --]

There is an updated pull request by 66Ton99 against master on the void-packages repository

https://github.com/66Ton99/void-packages viber
https://github.com/void-linux/void-packages/pull/13401

New package: Viber
New package: viber-10.3.0_37

It has a problem - it can't be versioned "https://download.cdn.viber.com/cdn/desktop/Linux/viber.deb" it does not have any parameters.
Does exist any way to disable "checksum" it is checks inside "preinst" script?

A patch file from https://github.com/void-linux/void-packages/pull/13401.patch is attached

[-- Warning: decoded text below may be mangled --]
[-- Attachment #2: github-pr-viber-13401.patch --]
[-- Type: text/x-diff, Size: 1683 bytes --]

From 89740a1e5035ce33dc03257af4a6f95a5aad64c7 Mon Sep 17 00:00:00 2001
From: Anton Shapka <anton.shapka@oracle.com>
Date: Mon, 29 Jul 2019 19:25:45 +0300
Subject: [PATCH] New package: Viber

---
 srcpkgs/viber/template | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)
 create mode 100644 srcpkgs/viber/template

diff --git a/srcpkgs/viber/template b/srcpkgs/viber/template
new file mode 100644
index 00000000000..8aa1b263f5b
--- /dev/null
+++ b/srcpkgs/viber/template
@@ -0,0 +1,36 @@
+# Template file for 'viber'
+pkgname=viber
+version=10.3.0
+revision=37
+archs="x86_64"
+build_style=fetch
+short_desc="Viber is a cross-platform VoIP and IM software application"
+license="viber"
+homepage="https://www.viber.com/"
+_openssl_version=1.0-1.0.2.s-1
+distfiles="https://download.cdn.viber.com/cdn/desktop/Linux/viber.deb https://sgp.mirror.pkgbuild.com/core/os/x86_64/openssl-${_openssl_version}-x86_64.pkg.tar.xz"
+checksum="a5d7d99afc8c186643d1393152a4729c4fc805f4241896c2f004c721619efe7c 13c5b5c1a372cf9c481b2beb7e5fc607ccf52173d6075ae10281e4a3da179514"
+nocross=yes
+nostrip=yes
+repository=nonfree
+
+do_extract() {
+	ar x ${XBPS_SRCDISTDIR}/${pkgname}-${version}/viber.deb
+	unxz data.tar.xz
+	tar xopf data.tar
+	gunzip control.tar.gz
+	tar xopf control.tar
+	unxz -f ${XBPS_SRCDISTDIR}/${pkgname}-${version}/openssl-${_openssl_version}-x86_64.pkg.tar.xz --stdout > openssl.tar
+	mkdir openssl
+	tar xopf openssl.tar -C openssl
+}
+
+do_install() {
+	vcopy usr /
+	vcopy opt /
+	vbin preinst
+	vbin postinst
+	vcopy openssl/usr/lib/libssl.so.1.0.0 /opt/viber/lib/libssl.so
+	vcopy openssl/usr/lib/libcrypto.so.1.0.0 /opt/viber/lib/libcrypto.so
+}
+

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PR PATCH] [Updated] New package: Viber
  2019-07-29 16:41 [PR PATCH] New package: Viber voidlinux-github
                   ` (3 preceding siblings ...)
  2019-07-30  9:55 ` voidlinux-github
@ 2019-07-30 10:11 ` voidlinux-github
  2019-07-30 10:11 ` voidlinux-github
  5 siblings, 0 replies; 7+ messages in thread
From: voidlinux-github @ 2019-07-30 10:11 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 552 bytes --]

There is an updated pull request by 66Ton99 against master on the void-packages repository

https://github.com/66Ton99/void-packages viber
https://github.com/void-linux/void-packages/pull/13401

New package: Viber
New package: viber-10.3.0_37

It has a problem - it can't be versioned "https://download.cdn.viber.com/cdn/desktop/Linux/viber.deb" it does not have any parameters.
Does exist any way to disable "checksum" it is checks inside "preinst" script?

A patch file from https://github.com/void-linux/void-packages/pull/13401.patch is attached

[-- Warning: decoded text below may be mangled --]
[-- Attachment #2: github-pr-viber-13401.patch --]
[-- Type: text/x-diff, Size: 1683 bytes --]

From 89740a1e5035ce33dc03257af4a6f95a5aad64c7 Mon Sep 17 00:00:00 2001
From: Anton Shapka <anton.shapka@oracle.com>
Date: Mon, 29 Jul 2019 19:25:45 +0300
Subject: [PATCH] New package: Viber

---
 srcpkgs/viber/template | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)
 create mode 100644 srcpkgs/viber/template

diff --git a/srcpkgs/viber/template b/srcpkgs/viber/template
new file mode 100644
index 00000000000..8aa1b263f5b
--- /dev/null
+++ b/srcpkgs/viber/template
@@ -0,0 +1,36 @@
+# Template file for 'viber'
+pkgname=viber
+version=10.3.0
+revision=37
+archs="x86_64"
+build_style=fetch
+short_desc="Viber is a cross-platform VoIP and IM software application"
+license="viber"
+homepage="https://www.viber.com/"
+_openssl_version=1.0-1.0.2.s-1
+distfiles="https://download.cdn.viber.com/cdn/desktop/Linux/viber.deb https://sgp.mirror.pkgbuild.com/core/os/x86_64/openssl-${_openssl_version}-x86_64.pkg.tar.xz"
+checksum="a5d7d99afc8c186643d1393152a4729c4fc805f4241896c2f004c721619efe7c 13c5b5c1a372cf9c481b2beb7e5fc607ccf52173d6075ae10281e4a3da179514"
+nocross=yes
+nostrip=yes
+repository=nonfree
+
+do_extract() {
+	ar x ${XBPS_SRCDISTDIR}/${pkgname}-${version}/viber.deb
+	unxz data.tar.xz
+	tar xopf data.tar
+	gunzip control.tar.gz
+	tar xopf control.tar
+	unxz -f ${XBPS_SRCDISTDIR}/${pkgname}-${version}/openssl-${_openssl_version}-x86_64.pkg.tar.xz --stdout > openssl.tar
+	mkdir openssl
+	tar xopf openssl.tar -C openssl
+}
+
+do_install() {
+	vcopy usr /
+	vcopy opt /
+	vbin preinst
+	vbin postinst
+	vcopy openssl/usr/lib/libssl.so.1.0.0 /opt/viber/lib/libssl.so
+	vcopy openssl/usr/lib/libcrypto.so.1.0.0 /opt/viber/lib/libcrypto.so
+}
+

^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, back to index

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-07-29 16:41 [PR PATCH] New package: Viber voidlinux-github
2019-07-29 16:45 ` [PR PATCH] [Updated] " voidlinux-github
2019-07-29 16:45 ` voidlinux-github
2019-07-30  9:55 ` voidlinux-github
2019-07-30  9:55 ` voidlinux-github
2019-07-30 10:11 ` voidlinux-github
2019-07-30 10:11 ` voidlinux-github

Github messages for voidlinux

Archives are clonable: git clone --mirror http://inbox.vuxu.org/voidlinux-github

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.github.voidlinux


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git