Github messages for voidlinux
 help / color / Atom feed
* [PR PATCH] audacious: enable Qt interface
@ 2019-09-03  7:35 voidlinux-github
  2019-09-03  9:05 ` voidlinux-github
                   ` (24 more replies)
  0 siblings, 25 replies; 26+ messages in thread
From: voidlinux-github @ 2019-09-03  7:35 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 385 bytes --]

There is a new pull request by bra1nwave against master on the void-packages repository

https://github.com/bra1nwave/void-packages audacious
https://github.com/void-linux/void-packages/pull/14178

audacious: enable Qt interface
closes  https://github.com/void-linux/void-packages/issues/14171

A patch file from https://github.com/void-linux/void-packages/pull/14178.patch is attached

[-- Warning: decoded text below may be mangled --]
[-- Attachment #2: github-pr-audacious-14178.patch --]
[-- Type: text/x-diff, Size: 3354 bytes --]

From 60cfa3647db7db3ae0d83e3e92cecc17bcbf4a0a Mon Sep 17 00:00:00 2001
From: bra1nwave <brainwave@openmailbox.org>
Date: Tue, 3 Sep 2019 09:16:37 +0200
Subject: [PATCH 1/2] audacious: enable Qt interface

---
 common/shlibs              |  1 +
 srcpkgs/audacious/template | 12 ++++++++----
 2 files changed, 9 insertions(+), 4 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index e29b965c040..6850c6d3e6a 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -1149,6 +1149,7 @@ libguess.so.1 libguess-1.1_1
 libaudcore.so.5 audacious-3.9_1
 libaudgui.so.5 audacious-3.9_1
 libaudtag.so.3 audacious-3.8_1
+libaudqt.so.2 audacious-3.10.1_2
 libgstreamer-1.0.so.0 gstreamer1-1.0.0_1
 libgstbase-1.0.so.0 gstreamer1-1.0.0_1
 libgstcontroller-1.0.so.0 gstreamer1-1.0.0_1
diff --git a/srcpkgs/audacious/template b/srcpkgs/audacious/template
index 69528553607..1a136863961 100644
--- a/srcpkgs/audacious/template
+++ b/srcpkgs/audacious/template
@@ -1,11 +1,11 @@
 # Template file for 'audacious'
 pkgname=audacious
 version=3.10.1
-revision=1
+revision=2
 build_style=gnu-configure
-configure_args="--enable-thunar"
+configure_args="--enable-qt"
 hostmakedepends="pkg-config glib-devel"
-makedepends="libSM-devel gtk+-devel dbus-glib-devel libguess-devel"
+makedepends="libSM-devel gtk+-devel dbus-glib-devel libguess-devel qt5-devel"
 depends="desktop-file-utils hicolor-icon-theme"
 short_desc="Lightweight, advanced audio player focused on audio quality"
 maintainer="Orphaned <orphan@voidlinux.org>"
@@ -14,6 +14,10 @@ homepage="https://audacious-media-player.org/"
 distfiles="https://distfiles.${pkgname}-media-player.org/${pkgname}-${version}.tar.bz2"
 checksum=8366e840bb3c9448c2cf0cf9a0800155b0bd7cc212a28ba44990c3d2289c6b93
 
+if [ "$CROSS_BUILD" ]; then
+	hostmakedepends+=" qt5-host-tools"
+fi
+
 post_install() {
 	vlicense COPYING
 }
@@ -24,6 +28,6 @@ audacious-devel_package() {
 	pkg_install() {
 		vmove usr/include
 		vmove usr/lib/pkgconfig
-		vmove usr/lib/*.so
+		vmove "usr/lib/*.so"
 	}
 }

From 6e76d22ae197adebd75b17b9a900bc173dfc6693 Mon Sep 17 00:00:00 2001
From: bra1nwave <brainwave@openmailbox.org>
Date: Tue, 3 Sep 2019 09:16:53 +0200
Subject: [PATCH 2/2] audacious-plugins: enable Qt interface - add cue support

---
 srcpkgs/audacious-plugins/template | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/audacious-plugins/template b/srcpkgs/audacious-plugins/template
index d97bf72f30e..3e3d681a45c 100644
--- a/srcpkgs/audacious-plugins/template
+++ b/srcpkgs/audacious-plugins/template
@@ -1,14 +1,16 @@
 # Template file for 'audacious-plugins'
 pkgname=audacious-plugins
 version=3.10.1
-revision=3
+revision=4
 build_style=gnu-configure
+configure_args="--enable-qt"
 hostmakedepends="pkg-config"
 makedepends="audacious-devel alsa-lib-devel pulseaudio-devel jack-devel
  lame-devel libvorbis-devel libflac-devel mpg123-devel faad2-devel ffmpeg-devel
  libmodplug-devel fluidsynth-devel libcdio-paranoia-devel wavpack-devel libnotify-devel
  libcurl-devel libmtp-devel neon-devel libmms-devel gtk+-devel libxml2-devel
- libbs2b-devel libsoxr-devel libsidplayfp-devel"
+ libbs2b-devel libsoxr-devel libsidplayfp-devel qt5-devel qt5-multimedia-devel
+ libcue-devel"
 short_desc="Plugins for the Audacious media player"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="BSD-2-Clause"

^ permalink raw reply	[flat|nested] 26+ messages in thread

* Re: audacious: enable Qt interface
  2019-09-03  7:35 [PR PATCH] audacious: enable Qt interface voidlinux-github
@ 2019-09-03  9:05 ` voidlinux-github
  2019-09-03 10:09 ` [PR PATCH] [Updated] " voidlinux-github
                   ` (23 subsequent siblings)
  24 siblings, 0 replies; 26+ messages in thread
From: voidlinux-github @ 2019-09-03  9:05 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 176 bytes --]

New comment by Piraty on void-packages repository

https://github.com/void-linux/void-packages/pull/14178#issuecomment-527372580

Comment:
I think a built option would be good

^ permalink raw reply	[flat|nested] 26+ messages in thread

* Re: [PR PATCH] [Updated] audacious: enable Qt interface
  2019-09-03  7:35 [PR PATCH] audacious: enable Qt interface voidlinux-github
  2019-09-03  9:05 ` voidlinux-github
@ 2019-09-03 10:09 ` " voidlinux-github
  2019-09-03 10:09 ` voidlinux-github
                   ` (22 subsequent siblings)
  24 siblings, 0 replies; 26+ messages in thread
From: voidlinux-github @ 2019-09-03 10:09 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 433 bytes --]

There is an updated pull request by bra1nwave against master on the void-packages repository

https://github.com/bra1nwave/void-packages audacious
https://github.com/void-linux/void-packages/pull/14178

audacious: enable Qt interface
closes  https://github.com/void-linux/void-packages/issues/14171

Should I add a build option for Qt/GTK?

A patch file from https://github.com/void-linux/void-packages/pull/14178.patch is attached

[-- Warning: decoded text below may be mangled --]
[-- Attachment #2: github-pr-audacious-14178.patch --]
[-- Type: text/x-diff, Size: 4129 bytes --]

From d2cf21a4d2fec013bd3b703e464ceecdb58a6b8a Mon Sep 17 00:00:00 2001
From: bra1nwave <brainwave@openmailbox.org>
Date: Tue, 3 Sep 2019 09:16:37 +0200
Subject: [PATCH 1/2] audacious: enable Qt interface

---
 common/shlibs              |  1 +
 srcpkgs/audacious/template | 17 +++++++++++++----
 2 files changed, 14 insertions(+), 4 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index e29b965c040..6850c6d3e6a 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -1149,6 +1149,7 @@ libguess.so.1 libguess-1.1_1
 libaudcore.so.5 audacious-3.9_1
 libaudgui.so.5 audacious-3.9_1
 libaudtag.so.3 audacious-3.8_1
+libaudqt.so.2 audacious-3.10.1_2
 libgstreamer-1.0.so.0 gstreamer1-1.0.0_1
 libgstbase-1.0.so.0 gstreamer1-1.0.0_1
 libgstcontroller-1.0.so.0 gstreamer1-1.0.0_1
diff --git a/srcpkgs/audacious/template b/srcpkgs/audacious/template
index 69528553607..316e7f202ba 100644
--- a/srcpkgs/audacious/template
+++ b/srcpkgs/audacious/template
@@ -1,11 +1,12 @@
 # Template file for 'audacious'
 pkgname=audacious
 version=3.10.1
-revision=1
+revision=2
 build_style=gnu-configure
-configure_args="--enable-thunar"
+configure_args="$(vopt_enable qt) $(vopt_if gtk2 --enable-gtk --disable-gtk)"
 hostmakedepends="pkg-config glib-devel"
-makedepends="libSM-devel gtk+-devel dbus-glib-devel libguess-devel"
+makedepends="libSM-devel dbus-glib-devel libguess-devel $(vopt_if gtk2 gtk+-devel)
+$(vopt_if qt qt5-devel)"
 depends="desktop-file-utils hicolor-icon-theme"
 short_desc="Lightweight, advanced audio player focused on audio quality"
 maintainer="Orphaned <orphan@voidlinux.org>"
@@ -14,6 +15,14 @@ homepage="https://audacious-media-player.org/"
 distfiles="https://distfiles.${pkgname}-media-player.org/${pkgname}-${version}.tar.bz2"
 checksum=8366e840bb3c9448c2cf0cf9a0800155b0bd7cc212a28ba44990c3d2289c6b93
 
+build_options="gtk2 qt"
+build_options_default="gtk2 qt"
+desc_option_gtk2="Enable support for the GTK+2 GUI toolkit"
+
+if [ "$CROSS_BUILD" ]; then
+	hostmakedepends+=" qt5-host-tools"
+fi
+
 post_install() {
 	vlicense COPYING
 }
@@ -24,6 +33,6 @@ audacious-devel_package() {
 	pkg_install() {
 		vmove usr/include
 		vmove usr/lib/pkgconfig
-		vmove usr/lib/*.so
+		vmove "usr/lib/*.so"
 	}
 }

From efbe60ee37c01b567e4fdf026f0900dc7e2e4040 Mon Sep 17 00:00:00 2001
From: bra1nwave <brainwave@openmailbox.org>
Date: Tue, 3 Sep 2019 09:16:53 +0200
Subject: [PATCH 2/2] audacious-plugins: enable Qt interface - add cue support

---
 srcpkgs/audacious-plugins/template | 12 +++++++++---
 1 file changed, 9 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/audacious-plugins/template b/srcpkgs/audacious-plugins/template
index d97bf72f30e..f5d73412d62 100644
--- a/srcpkgs/audacious-plugins/template
+++ b/srcpkgs/audacious-plugins/template
@@ -1,14 +1,16 @@
 # Template file for 'audacious-plugins'
 pkgname=audacious-plugins
 version=3.10.1
-revision=3
+revision=4
 build_style=gnu-configure
+configure_args="$(vopt_enable qt) $(vopt_if gtk2 --enable-gtk --disable-gtk)"
 hostmakedepends="pkg-config"
 makedepends="audacious-devel alsa-lib-devel pulseaudio-devel jack-devel
  lame-devel libvorbis-devel libflac-devel mpg123-devel faad2-devel ffmpeg-devel
  libmodplug-devel fluidsynth-devel libcdio-paranoia-devel wavpack-devel libnotify-devel
- libcurl-devel libmtp-devel neon-devel libmms-devel gtk+-devel libxml2-devel
- libbs2b-devel libsoxr-devel libsidplayfp-devel"
+ libcurl-devel libmtp-devel neon-devel libmms-devel libxml2-devel
+ libbs2b-devel libsoxr-devel libsidplayfp-devel qt5-devel libcue-devel
+ $(vopt_if gtk2 gtk+-devel) $(vopt_if qt 'qt5-devel qt5-multimedia-devel')"
 short_desc="Plugins for the Audacious media player"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="BSD-2-Clause"
@@ -16,6 +18,10 @@ homepage="https://audacious-media-player.org/"
 distfiles="https://distfiles.audacious-media-player.org/${pkgname}-${version}.tar.bz2"
 checksum=eec3177631f99729bf0e94223b627406cc648c70e6646e35613c7b55040a2642
 
+build_options="gtk2 qt"
+build_options_default="gtk2 qt"
+desc_option_gtk2="Enable support for the GTK+2 GUI toolkit"
+
 post_install() {
 	vlicense COPYING
 }

^ permalink raw reply	[flat|nested] 26+ messages in thread

* Re: [PR PATCH] [Updated] audacious: enable Qt interface
  2019-09-03  7:35 [PR PATCH] audacious: enable Qt interface voidlinux-github
  2019-09-03  9:05 ` voidlinux-github
  2019-09-03 10:09 ` [PR PATCH] [Updated] " voidlinux-github
@ 2019-09-03 10:09 ` voidlinux-github
  2019-09-03 10:12 ` voidlinux-github
                   ` (21 subsequent siblings)
  24 siblings, 0 replies; 26+ messages in thread
From: voidlinux-github @ 2019-09-03 10:09 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 433 bytes --]

There is an updated pull request by bra1nwave against master on the void-packages repository

https://github.com/bra1nwave/void-packages audacious
https://github.com/void-linux/void-packages/pull/14178

audacious: enable Qt interface
closes  https://github.com/void-linux/void-packages/issues/14171

Should I add a build option for Qt/GTK?

A patch file from https://github.com/void-linux/void-packages/pull/14178.patch is attached

[-- Warning: decoded text below may be mangled --]
[-- Attachment #2: github-pr-audacious-14178.patch --]
[-- Type: text/x-diff, Size: 4129 bytes --]

From d2cf21a4d2fec013bd3b703e464ceecdb58a6b8a Mon Sep 17 00:00:00 2001
From: bra1nwave <brainwave@openmailbox.org>
Date: Tue, 3 Sep 2019 09:16:37 +0200
Subject: [PATCH 1/2] audacious: enable Qt interface

---
 common/shlibs              |  1 +
 srcpkgs/audacious/template | 17 +++++++++++++----
 2 files changed, 14 insertions(+), 4 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index e29b965c040..6850c6d3e6a 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -1149,6 +1149,7 @@ libguess.so.1 libguess-1.1_1
 libaudcore.so.5 audacious-3.9_1
 libaudgui.so.5 audacious-3.9_1
 libaudtag.so.3 audacious-3.8_1
+libaudqt.so.2 audacious-3.10.1_2
 libgstreamer-1.0.so.0 gstreamer1-1.0.0_1
 libgstbase-1.0.so.0 gstreamer1-1.0.0_1
 libgstcontroller-1.0.so.0 gstreamer1-1.0.0_1
diff --git a/srcpkgs/audacious/template b/srcpkgs/audacious/template
index 69528553607..316e7f202ba 100644
--- a/srcpkgs/audacious/template
+++ b/srcpkgs/audacious/template
@@ -1,11 +1,12 @@
 # Template file for 'audacious'
 pkgname=audacious
 version=3.10.1
-revision=1
+revision=2
 build_style=gnu-configure
-configure_args="--enable-thunar"
+configure_args="$(vopt_enable qt) $(vopt_if gtk2 --enable-gtk --disable-gtk)"
 hostmakedepends="pkg-config glib-devel"
-makedepends="libSM-devel gtk+-devel dbus-glib-devel libguess-devel"
+makedepends="libSM-devel dbus-glib-devel libguess-devel $(vopt_if gtk2 gtk+-devel)
+$(vopt_if qt qt5-devel)"
 depends="desktop-file-utils hicolor-icon-theme"
 short_desc="Lightweight, advanced audio player focused on audio quality"
 maintainer="Orphaned <orphan@voidlinux.org>"
@@ -14,6 +15,14 @@ homepage="https://audacious-media-player.org/"
 distfiles="https://distfiles.${pkgname}-media-player.org/${pkgname}-${version}.tar.bz2"
 checksum=8366e840bb3c9448c2cf0cf9a0800155b0bd7cc212a28ba44990c3d2289c6b93
 
+build_options="gtk2 qt"
+build_options_default="gtk2 qt"
+desc_option_gtk2="Enable support for the GTK+2 GUI toolkit"
+
+if [ "$CROSS_BUILD" ]; then
+	hostmakedepends+=" qt5-host-tools"
+fi
+
 post_install() {
 	vlicense COPYING
 }
@@ -24,6 +33,6 @@ audacious-devel_package() {
 	pkg_install() {
 		vmove usr/include
 		vmove usr/lib/pkgconfig
-		vmove usr/lib/*.so
+		vmove "usr/lib/*.so"
 	}
 }

From efbe60ee37c01b567e4fdf026f0900dc7e2e4040 Mon Sep 17 00:00:00 2001
From: bra1nwave <brainwave@openmailbox.org>
Date: Tue, 3 Sep 2019 09:16:53 +0200
Subject: [PATCH 2/2] audacious-plugins: enable Qt interface - add cue support

---
 srcpkgs/audacious-plugins/template | 12 +++++++++---
 1 file changed, 9 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/audacious-plugins/template b/srcpkgs/audacious-plugins/template
index d97bf72f30e..f5d73412d62 100644
--- a/srcpkgs/audacious-plugins/template
+++ b/srcpkgs/audacious-plugins/template
@@ -1,14 +1,16 @@
 # Template file for 'audacious-plugins'
 pkgname=audacious-plugins
 version=3.10.1
-revision=3
+revision=4
 build_style=gnu-configure
+configure_args="$(vopt_enable qt) $(vopt_if gtk2 --enable-gtk --disable-gtk)"
 hostmakedepends="pkg-config"
 makedepends="audacious-devel alsa-lib-devel pulseaudio-devel jack-devel
  lame-devel libvorbis-devel libflac-devel mpg123-devel faad2-devel ffmpeg-devel
  libmodplug-devel fluidsynth-devel libcdio-paranoia-devel wavpack-devel libnotify-devel
- libcurl-devel libmtp-devel neon-devel libmms-devel gtk+-devel libxml2-devel
- libbs2b-devel libsoxr-devel libsidplayfp-devel"
+ libcurl-devel libmtp-devel neon-devel libmms-devel libxml2-devel
+ libbs2b-devel libsoxr-devel libsidplayfp-devel qt5-devel libcue-devel
+ $(vopt_if gtk2 gtk+-devel) $(vopt_if qt 'qt5-devel qt5-multimedia-devel')"
 short_desc="Plugins for the Audacious media player"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="BSD-2-Clause"
@@ -16,6 +18,10 @@ homepage="https://audacious-media-player.org/"
 distfiles="https://distfiles.audacious-media-player.org/${pkgname}-${version}.tar.bz2"
 checksum=eec3177631f99729bf0e94223b627406cc648c70e6646e35613c7b55040a2642
 
+build_options="gtk2 qt"
+build_options_default="gtk2 qt"
+desc_option_gtk2="Enable support for the GTK+2 GUI toolkit"
+
 post_install() {
 	vlicense COPYING
 }

^ permalink raw reply	[flat|nested] 26+ messages in thread

* Re: [PR PATCH] [Updated] audacious: enable Qt interface
  2019-09-03  7:35 [PR PATCH] audacious: enable Qt interface voidlinux-github
                   ` (2 preceding siblings ...)
  2019-09-03 10:09 ` voidlinux-github
@ 2019-09-03 10:12 ` voidlinux-github
  2019-09-03 10:12 ` voidlinux-github
                   ` (20 subsequent siblings)
  24 siblings, 0 replies; 26+ messages in thread
From: voidlinux-github @ 2019-09-03 10:12 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 433 bytes --]

There is an updated pull request by bra1nwave against master on the void-packages repository

https://github.com/bra1nwave/void-packages audacious
https://github.com/void-linux/void-packages/pull/14178

audacious: enable Qt interface
closes  https://github.com/void-linux/void-packages/issues/14171

Should I add a build option for Qt/GTK?

A patch file from https://github.com/void-linux/void-packages/pull/14178.patch is attached

[-- Warning: decoded text below may be mangled --]
[-- Attachment #2: github-pr-audacious-14178.patch --]
[-- Type: text/x-diff, Size: 4069 bytes --]

From ff836e6b401498cd61c84761dd869bd5b29300f5 Mon Sep 17 00:00:00 2001
From: bra1nwave <brainwave@openmailbox.org>
Date: Tue, 3 Sep 2019 09:16:37 +0200
Subject: [PATCH 1/2] audacious: enable Qt interface

---
 common/shlibs              |  1 +
 srcpkgs/audacious/template | 17 +++++++++++++----
 2 files changed, 14 insertions(+), 4 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index e29b965c040..6850c6d3e6a 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -1149,6 +1149,7 @@ libguess.so.1 libguess-1.1_1
 libaudcore.so.5 audacious-3.9_1
 libaudgui.so.5 audacious-3.9_1
 libaudtag.so.3 audacious-3.8_1
+libaudqt.so.2 audacious-3.10.1_2
 libgstreamer-1.0.so.0 gstreamer1-1.0.0_1
 libgstbase-1.0.so.0 gstreamer1-1.0.0_1
 libgstcontroller-1.0.so.0 gstreamer1-1.0.0_1
diff --git a/srcpkgs/audacious/template b/srcpkgs/audacious/template
index 69528553607..866b69214a1 100644
--- a/srcpkgs/audacious/template
+++ b/srcpkgs/audacious/template
@@ -1,11 +1,12 @@
 # Template file for 'audacious'
 pkgname=audacious
 version=3.10.1
-revision=1
+revision=2
 build_style=gnu-configure
-configure_args="--enable-thunar"
+configure_args="$(vopt_enable qt) $(vopt_if gtk2)"
 hostmakedepends="pkg-config glib-devel"
-makedepends="libSM-devel gtk+-devel dbus-glib-devel libguess-devel"
+makedepends="libSM-devel dbus-glib-devel libguess-devel $(vopt_if gtk2 gtk+-devel)
+$(vopt_if qt qt5-devel)"
 depends="desktop-file-utils hicolor-icon-theme"
 short_desc="Lightweight, advanced audio player focused on audio quality"
 maintainer="Orphaned <orphan@voidlinux.org>"
@@ -14,6 +15,14 @@ homepage="https://audacious-media-player.org/"
 distfiles="https://distfiles.${pkgname}-media-player.org/${pkgname}-${version}.tar.bz2"
 checksum=8366e840bb3c9448c2cf0cf9a0800155b0bd7cc212a28ba44990c3d2289c6b93
 
+build_options="gtk2 qt"
+build_options_default="gtk2 qt"
+desc_option_gtk2="Enable support for the GTK+2 GUI toolkit"
+
+if [ "$CROSS_BUILD" ]; then
+	hostmakedepends+=" qt5-host-tools"
+fi
+
 post_install() {
 	vlicense COPYING
 }
@@ -24,6 +33,6 @@ audacious-devel_package() {
 	pkg_install() {
 		vmove usr/include
 		vmove usr/lib/pkgconfig
-		vmove usr/lib/*.so
+		vmove "usr/lib/*.so"
 	}
 }

From 09162143366a6db6ac6771961701d7163e013e40 Mon Sep 17 00:00:00 2001
From: bra1nwave <brainwave@openmailbox.org>
Date: Tue, 3 Sep 2019 09:16:53 +0200
Subject: [PATCH 2/2] audacious-plugins: enable Qt interface - add cue support

---
 srcpkgs/audacious-plugins/template | 12 +++++++++---
 1 file changed, 9 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/audacious-plugins/template b/srcpkgs/audacious-plugins/template
index d97bf72f30e..4487983b6e7 100644
--- a/srcpkgs/audacious-plugins/template
+++ b/srcpkgs/audacious-plugins/template
@@ -1,14 +1,16 @@
 # Template file for 'audacious-plugins'
 pkgname=audacious-plugins
 version=3.10.1
-revision=3
+revision=4
 build_style=gnu-configure
+configure_args="$(vopt_enable qt) $(vopt_enable gtk2)"
 hostmakedepends="pkg-config"
 makedepends="audacious-devel alsa-lib-devel pulseaudio-devel jack-devel
  lame-devel libvorbis-devel libflac-devel mpg123-devel faad2-devel ffmpeg-devel
  libmodplug-devel fluidsynth-devel libcdio-paranoia-devel wavpack-devel libnotify-devel
- libcurl-devel libmtp-devel neon-devel libmms-devel gtk+-devel libxml2-devel
- libbs2b-devel libsoxr-devel libsidplayfp-devel"
+ libcurl-devel libmtp-devel neon-devel libmms-devel libxml2-devel
+ libbs2b-devel libsoxr-devel libsidplayfp-devel libcue-devel
+ $(vopt_if gtk2 gtk+-devel) $(vopt_if qt 'qt5-devel qt5-multimedia-devel')"
 short_desc="Plugins for the Audacious media player"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="BSD-2-Clause"
@@ -16,6 +18,10 @@ homepage="https://audacious-media-player.org/"
 distfiles="https://distfiles.audacious-media-player.org/${pkgname}-${version}.tar.bz2"
 checksum=eec3177631f99729bf0e94223b627406cc648c70e6646e35613c7b55040a2642
 
+build_options="gtk2 qt"
+build_options_default="gtk2 qt"
+desc_option_gtk2="Enable support for the GTK+2 GUI toolkit"
+
 post_install() {
 	vlicense COPYING
 }

^ permalink raw reply	[flat|nested] 26+ messages in thread

* Re: [PR PATCH] [Updated] audacious: enable Qt interface
  2019-09-03  7:35 [PR PATCH] audacious: enable Qt interface voidlinux-github
                   ` (3 preceding siblings ...)
  2019-09-03 10:12 ` voidlinux-github
@ 2019-09-03 10:12 ` voidlinux-github
  2019-09-03 10:16 ` voidlinux-github
                   ` (19 subsequent siblings)
  24 siblings, 0 replies; 26+ messages in thread
From: voidlinux-github @ 2019-09-03 10:12 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 433 bytes --]

There is an updated pull request by bra1nwave against master on the void-packages repository

https://github.com/bra1nwave/void-packages audacious
https://github.com/void-linux/void-packages/pull/14178

audacious: enable Qt interface
closes  https://github.com/void-linux/void-packages/issues/14171

Should I add a build option for Qt/GTK?

A patch file from https://github.com/void-linux/void-packages/pull/14178.patch is attached

[-- Warning: decoded text below may be mangled --]
[-- Attachment #2: github-pr-audacious-14178.patch --]
[-- Type: text/x-diff, Size: 4069 bytes --]

From ff836e6b401498cd61c84761dd869bd5b29300f5 Mon Sep 17 00:00:00 2001
From: bra1nwave <brainwave@openmailbox.org>
Date: Tue, 3 Sep 2019 09:16:37 +0200
Subject: [PATCH 1/2] audacious: enable Qt interface

---
 common/shlibs              |  1 +
 srcpkgs/audacious/template | 17 +++++++++++++----
 2 files changed, 14 insertions(+), 4 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index e29b965c040..6850c6d3e6a 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -1149,6 +1149,7 @@ libguess.so.1 libguess-1.1_1
 libaudcore.so.5 audacious-3.9_1
 libaudgui.so.5 audacious-3.9_1
 libaudtag.so.3 audacious-3.8_1
+libaudqt.so.2 audacious-3.10.1_2
 libgstreamer-1.0.so.0 gstreamer1-1.0.0_1
 libgstbase-1.0.so.0 gstreamer1-1.0.0_1
 libgstcontroller-1.0.so.0 gstreamer1-1.0.0_1
diff --git a/srcpkgs/audacious/template b/srcpkgs/audacious/template
index 69528553607..866b69214a1 100644
--- a/srcpkgs/audacious/template
+++ b/srcpkgs/audacious/template
@@ -1,11 +1,12 @@
 # Template file for 'audacious'
 pkgname=audacious
 version=3.10.1
-revision=1
+revision=2
 build_style=gnu-configure
-configure_args="--enable-thunar"
+configure_args="$(vopt_enable qt) $(vopt_if gtk2)"
 hostmakedepends="pkg-config glib-devel"
-makedepends="libSM-devel gtk+-devel dbus-glib-devel libguess-devel"
+makedepends="libSM-devel dbus-glib-devel libguess-devel $(vopt_if gtk2 gtk+-devel)
+$(vopt_if qt qt5-devel)"
 depends="desktop-file-utils hicolor-icon-theme"
 short_desc="Lightweight, advanced audio player focused on audio quality"
 maintainer="Orphaned <orphan@voidlinux.org>"
@@ -14,6 +15,14 @@ homepage="https://audacious-media-player.org/"
 distfiles="https://distfiles.${pkgname}-media-player.org/${pkgname}-${version}.tar.bz2"
 checksum=8366e840bb3c9448c2cf0cf9a0800155b0bd7cc212a28ba44990c3d2289c6b93
 
+build_options="gtk2 qt"
+build_options_default="gtk2 qt"
+desc_option_gtk2="Enable support for the GTK+2 GUI toolkit"
+
+if [ "$CROSS_BUILD" ]; then
+	hostmakedepends+=" qt5-host-tools"
+fi
+
 post_install() {
 	vlicense COPYING
 }
@@ -24,6 +33,6 @@ audacious-devel_package() {
 	pkg_install() {
 		vmove usr/include
 		vmove usr/lib/pkgconfig
-		vmove usr/lib/*.so
+		vmove "usr/lib/*.so"
 	}
 }

From 09162143366a6db6ac6771961701d7163e013e40 Mon Sep 17 00:00:00 2001
From: bra1nwave <brainwave@openmailbox.org>
Date: Tue, 3 Sep 2019 09:16:53 +0200
Subject: [PATCH 2/2] audacious-plugins: enable Qt interface - add cue support

---
 srcpkgs/audacious-plugins/template | 12 +++++++++---
 1 file changed, 9 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/audacious-plugins/template b/srcpkgs/audacious-plugins/template
index d97bf72f30e..4487983b6e7 100644
--- a/srcpkgs/audacious-plugins/template
+++ b/srcpkgs/audacious-plugins/template
@@ -1,14 +1,16 @@
 # Template file for 'audacious-plugins'
 pkgname=audacious-plugins
 version=3.10.1
-revision=3
+revision=4
 build_style=gnu-configure
+configure_args="$(vopt_enable qt) $(vopt_enable gtk2)"
 hostmakedepends="pkg-config"
 makedepends="audacious-devel alsa-lib-devel pulseaudio-devel jack-devel
  lame-devel libvorbis-devel libflac-devel mpg123-devel faad2-devel ffmpeg-devel
  libmodplug-devel fluidsynth-devel libcdio-paranoia-devel wavpack-devel libnotify-devel
- libcurl-devel libmtp-devel neon-devel libmms-devel gtk+-devel libxml2-devel
- libbs2b-devel libsoxr-devel libsidplayfp-devel"
+ libcurl-devel libmtp-devel neon-devel libmms-devel libxml2-devel
+ libbs2b-devel libsoxr-devel libsidplayfp-devel libcue-devel
+ $(vopt_if gtk2 gtk+-devel) $(vopt_if qt 'qt5-devel qt5-multimedia-devel')"
 short_desc="Plugins for the Audacious media player"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="BSD-2-Clause"
@@ -16,6 +18,10 @@ homepage="https://audacious-media-player.org/"
 distfiles="https://distfiles.audacious-media-player.org/${pkgname}-${version}.tar.bz2"
 checksum=eec3177631f99729bf0e94223b627406cc648c70e6646e35613c7b55040a2642
 
+build_options="gtk2 qt"
+build_options_default="gtk2 qt"
+desc_option_gtk2="Enable support for the GTK+2 GUI toolkit"
+
 post_install() {
 	vlicense COPYING
 }

^ permalink raw reply	[flat|nested] 26+ messages in thread

* Re: [PR PATCH] [Updated] audacious: enable Qt interface
  2019-09-03  7:35 [PR PATCH] audacious: enable Qt interface voidlinux-github
                   ` (5 preceding siblings ...)
  2019-09-03 10:16 ` voidlinux-github
@ 2019-09-03 10:16 ` voidlinux-github
  2019-09-03 10:21 ` voidlinux-github
                   ` (17 subsequent siblings)
  24 siblings, 0 replies; 26+ messages in thread
From: voidlinux-github @ 2019-09-03 10:16 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 433 bytes --]

There is an updated pull request by bra1nwave against master on the void-packages repository

https://github.com/bra1nwave/void-packages audacious
https://github.com/void-linux/void-packages/pull/14178

audacious: enable Qt interface
closes  https://github.com/void-linux/void-packages/issues/14171

Should I add a build option for Qt/GTK?

A patch file from https://github.com/void-linux/void-packages/pull/14178.patch is attached

[-- Warning: decoded text below may be mangled --]
[-- Attachment #2: github-pr-audacious-14178.patch --]
[-- Type: text/x-diff, Size: 4073 bytes --]

From 023776a7265904bd977dc6c320f5366d172496c3 Mon Sep 17 00:00:00 2001
From: bra1nwave <brainwave@openmailbox.org>
Date: Tue, 3 Sep 2019 09:16:37 +0200
Subject: [PATCH 1/2] audacious: enable Qt interface

---
 common/shlibs              |  1 +
 srcpkgs/audacious/template | 17 +++++++++++++----
 2 files changed, 14 insertions(+), 4 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index e29b965c040..6850c6d3e6a 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -1149,6 +1149,7 @@ libguess.so.1 libguess-1.1_1
 libaudcore.so.5 audacious-3.9_1
 libaudgui.so.5 audacious-3.9_1
 libaudtag.so.3 audacious-3.8_1
+libaudqt.so.2 audacious-3.10.1_2
 libgstreamer-1.0.so.0 gstreamer1-1.0.0_1
 libgstbase-1.0.so.0 gstreamer1-1.0.0_1
 libgstcontroller-1.0.so.0 gstreamer1-1.0.0_1
diff --git a/srcpkgs/audacious/template b/srcpkgs/audacious/template
index 69528553607..ed141af4ed0 100644
--- a/srcpkgs/audacious/template
+++ b/srcpkgs/audacious/template
@@ -1,11 +1,12 @@
 # Template file for 'audacious'
 pkgname=audacious
 version=3.10.1
-revision=1
+revision=2
 build_style=gnu-configure
-configure_args="--enable-thunar"
+configure_args="$(vopt_enable qt) $(vopt_enable gtk2)"
 hostmakedepends="pkg-config glib-devel"
-makedepends="libSM-devel gtk+-devel dbus-glib-devel libguess-devel"
+makedepends="libSM-devel dbus-glib-devel libguess-devel $(vopt_if gtk2 gtk+-devel)
+$(vopt_if qt qt5-devel)"
 depends="desktop-file-utils hicolor-icon-theme"
 short_desc="Lightweight, advanced audio player focused on audio quality"
 maintainer="Orphaned <orphan@voidlinux.org>"
@@ -14,6 +15,14 @@ homepage="https://audacious-media-player.org/"
 distfiles="https://distfiles.${pkgname}-media-player.org/${pkgname}-${version}.tar.bz2"
 checksum=8366e840bb3c9448c2cf0cf9a0800155b0bd7cc212a28ba44990c3d2289c6b93
 
+build_options="gtk2 qt"
+build_options_default="gtk2 qt"
+desc_option_gtk2="Enable support for the GTK+2 GUI toolkit"
+
+if [ "$CROSS_BUILD" ]; then
+	hostmakedepends+=" qt5-host-tools"
+fi
+
 post_install() {
 	vlicense COPYING
 }
@@ -24,6 +33,6 @@ audacious-devel_package() {
 	pkg_install() {
 		vmove usr/include
 		vmove usr/lib/pkgconfig
-		vmove usr/lib/*.so
+		vmove "usr/lib/*.so"
 	}
 }

From 8907882f1e50df390f024f3685ba20ed6dad7ccb Mon Sep 17 00:00:00 2001
From: bra1nwave <brainwave@openmailbox.org>
Date: Tue, 3 Sep 2019 09:16:53 +0200
Subject: [PATCH 2/2] audacious-plugins: enable Qt interface - add cue support

---
 srcpkgs/audacious-plugins/template | 12 +++++++++---
 1 file changed, 9 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/audacious-plugins/template b/srcpkgs/audacious-plugins/template
index d97bf72f30e..4487983b6e7 100644
--- a/srcpkgs/audacious-plugins/template
+++ b/srcpkgs/audacious-plugins/template
@@ -1,14 +1,16 @@
 # Template file for 'audacious-plugins'
 pkgname=audacious-plugins
 version=3.10.1
-revision=3
+revision=4
 build_style=gnu-configure
+configure_args="$(vopt_enable qt) $(vopt_enable gtk2)"
 hostmakedepends="pkg-config"
 makedepends="audacious-devel alsa-lib-devel pulseaudio-devel jack-devel
  lame-devel libvorbis-devel libflac-devel mpg123-devel faad2-devel ffmpeg-devel
  libmodplug-devel fluidsynth-devel libcdio-paranoia-devel wavpack-devel libnotify-devel
- libcurl-devel libmtp-devel neon-devel libmms-devel gtk+-devel libxml2-devel
- libbs2b-devel libsoxr-devel libsidplayfp-devel"
+ libcurl-devel libmtp-devel neon-devel libmms-devel libxml2-devel
+ libbs2b-devel libsoxr-devel libsidplayfp-devel libcue-devel
+ $(vopt_if gtk2 gtk+-devel) $(vopt_if qt 'qt5-devel qt5-multimedia-devel')"
 short_desc="Plugins for the Audacious media player"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="BSD-2-Clause"
@@ -16,6 +18,10 @@ homepage="https://audacious-media-player.org/"
 distfiles="https://distfiles.audacious-media-player.org/${pkgname}-${version}.tar.bz2"
 checksum=eec3177631f99729bf0e94223b627406cc648c70e6646e35613c7b55040a2642
 
+build_options="gtk2 qt"
+build_options_default="gtk2 qt"
+desc_option_gtk2="Enable support for the GTK+2 GUI toolkit"
+
 post_install() {
 	vlicense COPYING
 }

^ permalink raw reply	[flat|nested] 26+ messages in thread

* Re: [PR PATCH] [Updated] audacious: enable Qt interface
  2019-09-03  7:35 [PR PATCH] audacious: enable Qt interface voidlinux-github
                   ` (4 preceding siblings ...)
  2019-09-03 10:12 ` voidlinux-github
@ 2019-09-03 10:16 ` voidlinux-github
  2019-09-03 10:16 ` voidlinux-github
                   ` (18 subsequent siblings)
  24 siblings, 0 replies; 26+ messages in thread
From: voidlinux-github @ 2019-09-03 10:16 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 433 bytes --]

There is an updated pull request by bra1nwave against master on the void-packages repository

https://github.com/bra1nwave/void-packages audacious
https://github.com/void-linux/void-packages/pull/14178

audacious: enable Qt interface
closes  https://github.com/void-linux/void-packages/issues/14171

Should I add a build option for Qt/GTK?

A patch file from https://github.com/void-linux/void-packages/pull/14178.patch is attached

[-- Warning: decoded text below may be mangled --]
[-- Attachment #2: github-pr-audacious-14178.patch --]
[-- Type: text/x-diff, Size: 4073 bytes --]

From 023776a7265904bd977dc6c320f5366d172496c3 Mon Sep 17 00:00:00 2001
From: bra1nwave <brainwave@openmailbox.org>
Date: Tue, 3 Sep 2019 09:16:37 +0200
Subject: [PATCH 1/2] audacious: enable Qt interface

---
 common/shlibs              |  1 +
 srcpkgs/audacious/template | 17 +++++++++++++----
 2 files changed, 14 insertions(+), 4 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index e29b965c040..6850c6d3e6a 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -1149,6 +1149,7 @@ libguess.so.1 libguess-1.1_1
 libaudcore.so.5 audacious-3.9_1
 libaudgui.so.5 audacious-3.9_1
 libaudtag.so.3 audacious-3.8_1
+libaudqt.so.2 audacious-3.10.1_2
 libgstreamer-1.0.so.0 gstreamer1-1.0.0_1
 libgstbase-1.0.so.0 gstreamer1-1.0.0_1
 libgstcontroller-1.0.so.0 gstreamer1-1.0.0_1
diff --git a/srcpkgs/audacious/template b/srcpkgs/audacious/template
index 69528553607..ed141af4ed0 100644
--- a/srcpkgs/audacious/template
+++ b/srcpkgs/audacious/template
@@ -1,11 +1,12 @@
 # Template file for 'audacious'
 pkgname=audacious
 version=3.10.1
-revision=1
+revision=2
 build_style=gnu-configure
-configure_args="--enable-thunar"
+configure_args="$(vopt_enable qt) $(vopt_enable gtk2)"
 hostmakedepends="pkg-config glib-devel"
-makedepends="libSM-devel gtk+-devel dbus-glib-devel libguess-devel"
+makedepends="libSM-devel dbus-glib-devel libguess-devel $(vopt_if gtk2 gtk+-devel)
+$(vopt_if qt qt5-devel)"
 depends="desktop-file-utils hicolor-icon-theme"
 short_desc="Lightweight, advanced audio player focused on audio quality"
 maintainer="Orphaned <orphan@voidlinux.org>"
@@ -14,6 +15,14 @@ homepage="https://audacious-media-player.org/"
 distfiles="https://distfiles.${pkgname}-media-player.org/${pkgname}-${version}.tar.bz2"
 checksum=8366e840bb3c9448c2cf0cf9a0800155b0bd7cc212a28ba44990c3d2289c6b93
 
+build_options="gtk2 qt"
+build_options_default="gtk2 qt"
+desc_option_gtk2="Enable support for the GTK+2 GUI toolkit"
+
+if [ "$CROSS_BUILD" ]; then
+	hostmakedepends+=" qt5-host-tools"
+fi
+
 post_install() {
 	vlicense COPYING
 }
@@ -24,6 +33,6 @@ audacious-devel_package() {
 	pkg_install() {
 		vmove usr/include
 		vmove usr/lib/pkgconfig
-		vmove usr/lib/*.so
+		vmove "usr/lib/*.so"
 	}
 }

From 8907882f1e50df390f024f3685ba20ed6dad7ccb Mon Sep 17 00:00:00 2001
From: bra1nwave <brainwave@openmailbox.org>
Date: Tue, 3 Sep 2019 09:16:53 +0200
Subject: [PATCH 2/2] audacious-plugins: enable Qt interface - add cue support

---
 srcpkgs/audacious-plugins/template | 12 +++++++++---
 1 file changed, 9 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/audacious-plugins/template b/srcpkgs/audacious-plugins/template
index d97bf72f30e..4487983b6e7 100644
--- a/srcpkgs/audacious-plugins/template
+++ b/srcpkgs/audacious-plugins/template
@@ -1,14 +1,16 @@
 # Template file for 'audacious-plugins'
 pkgname=audacious-plugins
 version=3.10.1
-revision=3
+revision=4
 build_style=gnu-configure
+configure_args="$(vopt_enable qt) $(vopt_enable gtk2)"
 hostmakedepends="pkg-config"
 makedepends="audacious-devel alsa-lib-devel pulseaudio-devel jack-devel
  lame-devel libvorbis-devel libflac-devel mpg123-devel faad2-devel ffmpeg-devel
  libmodplug-devel fluidsynth-devel libcdio-paranoia-devel wavpack-devel libnotify-devel
- libcurl-devel libmtp-devel neon-devel libmms-devel gtk+-devel libxml2-devel
- libbs2b-devel libsoxr-devel libsidplayfp-devel"
+ libcurl-devel libmtp-devel neon-devel libmms-devel libxml2-devel
+ libbs2b-devel libsoxr-devel libsidplayfp-devel libcue-devel
+ $(vopt_if gtk2 gtk+-devel) $(vopt_if qt 'qt5-devel qt5-multimedia-devel')"
 short_desc="Plugins for the Audacious media player"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="BSD-2-Clause"
@@ -16,6 +18,10 @@ homepage="https://audacious-media-player.org/"
 distfiles="https://distfiles.audacious-media-player.org/${pkgname}-${version}.tar.bz2"
 checksum=eec3177631f99729bf0e94223b627406cc648c70e6646e35613c7b55040a2642
 
+build_options="gtk2 qt"
+build_options_default="gtk2 qt"
+desc_option_gtk2="Enable support for the GTK+2 GUI toolkit"
+
 post_install() {
 	vlicense COPYING
 }

^ permalink raw reply	[flat|nested] 26+ messages in thread

* Re: [PR PATCH] [Updated] audacious: enable Qt interface
  2019-09-03  7:35 [PR PATCH] audacious: enable Qt interface voidlinux-github
                   ` (6 preceding siblings ...)
  2019-09-03 10:16 ` voidlinux-github
@ 2019-09-03 10:21 ` voidlinux-github
  2019-09-03 10:21 ` voidlinux-github
                   ` (16 subsequent siblings)
  24 siblings, 0 replies; 26+ messages in thread
From: voidlinux-github @ 2019-09-03 10:21 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 433 bytes --]

There is an updated pull request by bra1nwave against master on the void-packages repository

https://github.com/bra1nwave/void-packages audacious
https://github.com/void-linux/void-packages/pull/14178

audacious: enable Qt interface
closes  https://github.com/void-linux/void-packages/issues/14171

Should I add a build option for Qt/GTK?

A patch file from https://github.com/void-linux/void-packages/pull/14178.patch is attached

[-- Warning: decoded text below may be mangled --]
[-- Attachment #2: github-pr-audacious-14178.patch --]
[-- Type: text/x-diff, Size: 4063 bytes --]

From b08ebd73f36bde1adff67d9a14c7c203c823e38d Mon Sep 17 00:00:00 2001
From: bra1nwave <brainwave@openmailbox.org>
Date: Tue, 3 Sep 2019 09:16:37 +0200
Subject: [PATCH 1/2] audacious: enable Qt interface

---
 common/shlibs              |  1 +
 srcpkgs/audacious/template | 17 +++++++++++++----
 2 files changed, 14 insertions(+), 4 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index e29b965c040..6850c6d3e6a 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -1149,6 +1149,7 @@ libguess.so.1 libguess-1.1_1
 libaudcore.so.5 audacious-3.9_1
 libaudgui.so.5 audacious-3.9_1
 libaudtag.so.3 audacious-3.8_1
+libaudqt.so.2 audacious-3.10.1_2
 libgstreamer-1.0.so.0 gstreamer1-1.0.0_1
 libgstbase-1.0.so.0 gstreamer1-1.0.0_1
 libgstcontroller-1.0.so.0 gstreamer1-1.0.0_1
diff --git a/srcpkgs/audacious/template b/srcpkgs/audacious/template
index 69528553607..172ba3788e2 100644
--- a/srcpkgs/audacious/template
+++ b/srcpkgs/audacious/template
@@ -1,11 +1,12 @@
 # Template file for 'audacious'
 pkgname=audacious
 version=3.10.1
-revision=1
+revision=2
 build_style=gnu-configure
-configure_args="--enable-thunar"
+configure_args="$(vopt_enable qt) $(vopt_enable gtk)"
 hostmakedepends="pkg-config glib-devel"
-makedepends="libSM-devel gtk+-devel dbus-glib-devel libguess-devel"
+makedepends="libSM-devel dbus-glib-devel libguess-devel $(vopt_if gtk gtk+-devel)
+$(vopt_if qt qt5-devel)"
 depends="desktop-file-utils hicolor-icon-theme"
 short_desc="Lightweight, advanced audio player focused on audio quality"
 maintainer="Orphaned <orphan@voidlinux.org>"
@@ -14,6 +15,14 @@ homepage="https://audacious-media-player.org/"
 distfiles="https://distfiles.${pkgname}-media-player.org/${pkgname}-${version}.tar.bz2"
 checksum=8366e840bb3c9448c2cf0cf9a0800155b0bd7cc212a28ba44990c3d2289c6b93
 
+build_options="gtk qt"
+build_options_default="gtk qt"
+desc_option_gtk="Enable support for the GTK+2 GUI toolkit"
+
+if [ "$CROSS_BUILD" ]; then
+	hostmakedepends+=" qt5-host-tools"
+fi
+
 post_install() {
 	vlicense COPYING
 }
@@ -24,6 +33,6 @@ audacious-devel_package() {
 	pkg_install() {
 		vmove usr/include
 		vmove usr/lib/pkgconfig
-		vmove usr/lib/*.so
+		vmove "usr/lib/*.so"
 	}
 }

From 200c85244edfe208e4362d53a420751385288b87 Mon Sep 17 00:00:00 2001
From: bra1nwave <brainwave@openmailbox.org>
Date: Tue, 3 Sep 2019 09:16:53 +0200
Subject: [PATCH 2/2] audacious-plugins: enable Qt interface - add cue support

---
 srcpkgs/audacious-plugins/template | 12 +++++++++---
 1 file changed, 9 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/audacious-plugins/template b/srcpkgs/audacious-plugins/template
index d97bf72f30e..32a2f72b385 100644
--- a/srcpkgs/audacious-plugins/template
+++ b/srcpkgs/audacious-plugins/template
@@ -1,14 +1,16 @@
 # Template file for 'audacious-plugins'
 pkgname=audacious-plugins
 version=3.10.1
-revision=3
+revision=4
 build_style=gnu-configure
+configure_args="$(vopt_enable qt) $(vopt_enable gtk)"
 hostmakedepends="pkg-config"
 makedepends="audacious-devel alsa-lib-devel pulseaudio-devel jack-devel
  lame-devel libvorbis-devel libflac-devel mpg123-devel faad2-devel ffmpeg-devel
  libmodplug-devel fluidsynth-devel libcdio-paranoia-devel wavpack-devel libnotify-devel
- libcurl-devel libmtp-devel neon-devel libmms-devel gtk+-devel libxml2-devel
- libbs2b-devel libsoxr-devel libsidplayfp-devel"
+ libcurl-devel libmtp-devel neon-devel libmms-devel libxml2-devel
+ libbs2b-devel libsoxr-devel libsidplayfp-devel libcue-devel
+ $(vopt_if gtk gtk+-devel) $(vopt_if qt 'qt5-devel qt5-multimedia-devel')"
 short_desc="Plugins for the Audacious media player"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="BSD-2-Clause"
@@ -16,6 +18,10 @@ homepage="https://audacious-media-player.org/"
 distfiles="https://distfiles.audacious-media-player.org/${pkgname}-${version}.tar.bz2"
 checksum=eec3177631f99729bf0e94223b627406cc648c70e6646e35613c7b55040a2642
 
+build_options="gtk qt"
+build_options_default="gtk qt"
+desc_option_gtk="Enable support for the GTK+2 GUI toolkit"
+
 post_install() {
 	vlicense COPYING
 }

^ permalink raw reply	[flat|nested] 26+ messages in thread

* Re: [PR PATCH] [Updated] audacious: enable Qt interface
  2019-09-03  7:35 [PR PATCH] audacious: enable Qt interface voidlinux-github
                   ` (7 preceding siblings ...)
  2019-09-03 10:21 ` voidlinux-github
@ 2019-09-03 10:21 ` voidlinux-github
  2019-09-03 10:25 ` voidlinux-github
                   ` (15 subsequent siblings)
  24 siblings, 0 replies; 26+ messages in thread
From: voidlinux-github @ 2019-09-03 10:21 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 433 bytes --]

There is an updated pull request by bra1nwave against master on the void-packages repository

https://github.com/bra1nwave/void-packages audacious
https://github.com/void-linux/void-packages/pull/14178

audacious: enable Qt interface
closes  https://github.com/void-linux/void-packages/issues/14171

Should I add a build option for Qt/GTK?

A patch file from https://github.com/void-linux/void-packages/pull/14178.patch is attached

[-- Warning: decoded text below may be mangled --]
[-- Attachment #2: github-pr-audacious-14178.patch --]
[-- Type: text/x-diff, Size: 4063 bytes --]

From b08ebd73f36bde1adff67d9a14c7c203c823e38d Mon Sep 17 00:00:00 2001
From: bra1nwave <brainwave@openmailbox.org>
Date: Tue, 3 Sep 2019 09:16:37 +0200
Subject: [PATCH 1/2] audacious: enable Qt interface

---
 common/shlibs              |  1 +
 srcpkgs/audacious/template | 17 +++++++++++++----
 2 files changed, 14 insertions(+), 4 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index e29b965c040..6850c6d3e6a 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -1149,6 +1149,7 @@ libguess.so.1 libguess-1.1_1
 libaudcore.so.5 audacious-3.9_1
 libaudgui.so.5 audacious-3.9_1
 libaudtag.so.3 audacious-3.8_1
+libaudqt.so.2 audacious-3.10.1_2
 libgstreamer-1.0.so.0 gstreamer1-1.0.0_1
 libgstbase-1.0.so.0 gstreamer1-1.0.0_1
 libgstcontroller-1.0.so.0 gstreamer1-1.0.0_1
diff --git a/srcpkgs/audacious/template b/srcpkgs/audacious/template
index 69528553607..172ba3788e2 100644
--- a/srcpkgs/audacious/template
+++ b/srcpkgs/audacious/template
@@ -1,11 +1,12 @@
 # Template file for 'audacious'
 pkgname=audacious
 version=3.10.1
-revision=1
+revision=2
 build_style=gnu-configure
-configure_args="--enable-thunar"
+configure_args="$(vopt_enable qt) $(vopt_enable gtk)"
 hostmakedepends="pkg-config glib-devel"
-makedepends="libSM-devel gtk+-devel dbus-glib-devel libguess-devel"
+makedepends="libSM-devel dbus-glib-devel libguess-devel $(vopt_if gtk gtk+-devel)
+$(vopt_if qt qt5-devel)"
 depends="desktop-file-utils hicolor-icon-theme"
 short_desc="Lightweight, advanced audio player focused on audio quality"
 maintainer="Orphaned <orphan@voidlinux.org>"
@@ -14,6 +15,14 @@ homepage="https://audacious-media-player.org/"
 distfiles="https://distfiles.${pkgname}-media-player.org/${pkgname}-${version}.tar.bz2"
 checksum=8366e840bb3c9448c2cf0cf9a0800155b0bd7cc212a28ba44990c3d2289c6b93
 
+build_options="gtk qt"
+build_options_default="gtk qt"
+desc_option_gtk="Enable support for the GTK+2 GUI toolkit"
+
+if [ "$CROSS_BUILD" ]; then
+	hostmakedepends+=" qt5-host-tools"
+fi
+
 post_install() {
 	vlicense COPYING
 }
@@ -24,6 +33,6 @@ audacious-devel_package() {
 	pkg_install() {
 		vmove usr/include
 		vmove usr/lib/pkgconfig
-		vmove usr/lib/*.so
+		vmove "usr/lib/*.so"
 	}
 }

From 200c85244edfe208e4362d53a420751385288b87 Mon Sep 17 00:00:00 2001
From: bra1nwave <brainwave@openmailbox.org>
Date: Tue, 3 Sep 2019 09:16:53 +0200
Subject: [PATCH 2/2] audacious-plugins: enable Qt interface - add cue support

---
 srcpkgs/audacious-plugins/template | 12 +++++++++---
 1 file changed, 9 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/audacious-plugins/template b/srcpkgs/audacious-plugins/template
index d97bf72f30e..32a2f72b385 100644
--- a/srcpkgs/audacious-plugins/template
+++ b/srcpkgs/audacious-plugins/template
@@ -1,14 +1,16 @@
 # Template file for 'audacious-plugins'
 pkgname=audacious-plugins
 version=3.10.1
-revision=3
+revision=4
 build_style=gnu-configure
+configure_args="$(vopt_enable qt) $(vopt_enable gtk)"
 hostmakedepends="pkg-config"
 makedepends="audacious-devel alsa-lib-devel pulseaudio-devel jack-devel
  lame-devel libvorbis-devel libflac-devel mpg123-devel faad2-devel ffmpeg-devel
  libmodplug-devel fluidsynth-devel libcdio-paranoia-devel wavpack-devel libnotify-devel
- libcurl-devel libmtp-devel neon-devel libmms-devel gtk+-devel libxml2-devel
- libbs2b-devel libsoxr-devel libsidplayfp-devel"
+ libcurl-devel libmtp-devel neon-devel libmms-devel libxml2-devel
+ libbs2b-devel libsoxr-devel libsidplayfp-devel libcue-devel
+ $(vopt_if gtk gtk+-devel) $(vopt_if qt 'qt5-devel qt5-multimedia-devel')"
 short_desc="Plugins for the Audacious media player"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="BSD-2-Clause"
@@ -16,6 +18,10 @@ homepage="https://audacious-media-player.org/"
 distfiles="https://distfiles.audacious-media-player.org/${pkgname}-${version}.tar.bz2"
 checksum=eec3177631f99729bf0e94223b627406cc648c70e6646e35613c7b55040a2642
 
+build_options="gtk qt"
+build_options_default="gtk qt"
+desc_option_gtk="Enable support for the GTK+2 GUI toolkit"
+
 post_install() {
 	vlicense COPYING
 }

^ permalink raw reply	[flat|nested] 26+ messages in thread

* Re: audacious: enable Qt interface
  2019-09-03  7:35 [PR PATCH] audacious: enable Qt interface voidlinux-github
                   ` (8 preceding siblings ...)
  2019-09-03 10:21 ` voidlinux-github
@ 2019-09-03 10:25 ` voidlinux-github
  2019-09-04 16:35 ` voidlinux-github
                   ` (14 subsequent siblings)
  24 siblings, 0 replies; 26+ messages in thread
From: voidlinux-github @ 2019-09-03 10:25 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 147 bytes --]

New comment by bra1nwave on void-packages repository

https://github.com/void-linux/void-packages/pull/14178#issuecomment-527400053

Comment:
Done

^ permalink raw reply	[flat|nested] 26+ messages in thread

* Re: audacious: enable Qt interface
  2019-09-03  7:35 [PR PATCH] audacious: enable Qt interface voidlinux-github
                   ` (9 preceding siblings ...)
  2019-09-03 10:25 ` voidlinux-github
@ 2019-09-04 16:35 ` voidlinux-github
  2019-09-04 16:47 ` voidlinux-github
                   ` (13 subsequent siblings)
  24 siblings, 0 replies; 26+ messages in thread
From: voidlinux-github @ 2019-09-04 16:35 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 222 bytes --]

New comment by Chocimier on void-packages repository

https://github.com/void-linux/void-packages/pull/14178#issuecomment-527982691

Comment:
Default build depends on both qt and gtk now. Can they be split out to subpkgs?

^ permalink raw reply	[flat|nested] 26+ messages in thread

* Re: audacious: enable Qt interface
  2019-09-03  7:35 [PR PATCH] audacious: enable Qt interface voidlinux-github
                   ` (10 preceding siblings ...)
  2019-09-04 16:35 ` voidlinux-github
@ 2019-09-04 16:47 ` voidlinux-github
  2019-09-04 16:52 ` voidlinux-github
                   ` (12 subsequent siblings)
  24 siblings, 0 replies; 26+ messages in thread
From: voidlinux-github @ 2019-09-04 16:47 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 797 bytes --]

New comment by xtraeme on void-packages repository

https://github.com/void-linux/void-packages/pull/14178#issuecomment-527987181

Comment:
+1

El mié., 4 sept. 2019 18:35, Piotr <notifications@github.com> escribió:

> Default build depends on both qt and gtk now. Can they be split out to
> subpkgs?
>
> —
> You are receiving this because you are subscribed to this thread.
> Reply to this email directly, view it on GitHub
> <https://github.com/void-linux/void-packages/pull/14178?email_source=notifications&email_token=AAGR7KKXAAKL6ZL2DJEOAXTQH7PU5A5CNFSM4ITC6QH2YY3PNVWWK3TUL52HS4DFVREXG43VMVBW63LNMVXHJKTDN5WW2ZLOORPWSZGOD54GAYY#issuecomment-527982691>,
> or mute the thread
> <https://github.com/notifications/unsubscribe-auth/AAGR7KN2N4VY3PRSKOYKTB3QH7PU5ANCNFSM4ITC6QHQ>
> .
>


^ permalink raw reply	[flat|nested] 26+ messages in thread

* Re: audacious: enable Qt interface
  2019-09-03  7:35 [PR PATCH] audacious: enable Qt interface voidlinux-github
                   ` (11 preceding siblings ...)
  2019-09-04 16:47 ` voidlinux-github
@ 2019-09-04 16:52 ` voidlinux-github
  2019-09-04 16:56 ` voidlinux-github
                   ` (11 subsequent siblings)
  24 siblings, 0 replies; 26+ messages in thread
From: voidlinux-github @ 2019-09-04 16:52 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 290 bytes --]

New comment by bra1nwave on void-packages repository

https://github.com/void-linux/void-packages/pull/14178#issuecomment-527989071

Comment:
> Default build depends on both qt and gtk now. Can they be split out to subpkgs?

Yeah, I think so. Then the build options are redundant, right?

^ permalink raw reply	[flat|nested] 26+ messages in thread

* Re: audacious: enable Qt interface
  2019-09-03  7:35 [PR PATCH] audacious: enable Qt interface voidlinux-github
                   ` (12 preceding siblings ...)
  2019-09-04 16:52 ` voidlinux-github
@ 2019-09-04 16:56 ` voidlinux-github
  2019-09-04 17:01 ` voidlinux-github
                   ` (10 subsequent siblings)
  24 siblings, 0 replies; 26+ messages in thread
From: voidlinux-github @ 2019-09-04 16:56 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 302 bytes --]

New comment by bra1nwave on void-packages repository

https://github.com/void-linux/void-packages/pull/14178#issuecomment-527989071

Comment:
> Default build depends on both qt and gtk now. Can they be split out to subpkgs?

Yeah, I think so. Then the build options are (obviously) redundant, right?

^ permalink raw reply	[flat|nested] 26+ messages in thread

* Re: audacious: enable Qt interface
  2019-09-03  7:35 [PR PATCH] audacious: enable Qt interface voidlinux-github
                   ` (13 preceding siblings ...)
  2019-09-04 16:56 ` voidlinux-github
@ 2019-09-04 17:01 ` voidlinux-github
  2019-09-05  7:24 ` voidlinux-github
                   ` (9 subsequent siblings)
  24 siblings, 0 replies; 26+ messages in thread
From: voidlinux-github @ 2019-09-04 17:01 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 175 bytes --]

New comment by Chocimier on void-packages repository

https://github.com/void-linux/void-packages/pull/14178#issuecomment-527992554

Comment:
Yes, no need for build options.


^ permalink raw reply	[flat|nested] 26+ messages in thread

* Re: audacious: enable Qt interface
  2019-09-03  7:35 [PR PATCH] audacious: enable Qt interface voidlinux-github
                   ` (14 preceding siblings ...)
  2019-09-04 17:01 ` voidlinux-github
@ 2019-09-05  7:24 ` voidlinux-github
  2019-09-09 12:12 ` voidlinux-github
                   ` (8 subsequent siblings)
  24 siblings, 0 replies; 26+ messages in thread
From: voidlinux-github @ 2019-09-05  7:24 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 789 bytes --]

New comment by bra1nwave on void-packages repository

https://github.com/void-linux/void-packages/pull/14178#issuecomment-528235612

Comment:
It's not easy as I thought it would be. The main culprit here is `audacious-plugins`. It has a lot of various .so plugins which either depend on GTK or QT. Sure, we can hunt down every SO, but this would be a nightmare to maintain. 

There is also the problem that some plugins that were not previously dependent on Qt are now depending on it. Which means I cannot move it into a subpkg.

We have (IMHO) two alternatives:
- Keep the Build options and make GTK the default one. If someone only needs the Qt version, he/she can build it with `-o ~gtk,qt`
- Make separate (`audacious-qt` and `audacious-qt-plugins`) templates with disabled GTK

^ permalink raw reply	[flat|nested] 26+ messages in thread

* Re: audacious: enable Qt interface
  2019-09-03  7:35 [PR PATCH] audacious: enable Qt interface voidlinux-github
                   ` (15 preceding siblings ...)
  2019-09-05  7:24 ` voidlinux-github
@ 2019-09-09 12:12 ` voidlinux-github
  2019-09-09 12:16 ` voidlinux-github
                   ` (7 subsequent siblings)
  24 siblings, 0 replies; 26+ messages in thread
From: voidlinux-github @ 2019-09-09 12:12 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 551 bytes --]

New comment by Piraty on void-packages repository

https://github.com/void-linux/void-packages/pull/14178#issuecomment-529443510

Comment:
You could also do two builds in the template (one for each variant toolkit) and split results in corespoinding subpackages, which is not a nice thing either. Also dependency-overwriting if the shared package is possible, but even worse.

I'd say: only support one toolkit and go for a default build option. If demand should arise to provide both versions at the same time, we can still warmup this discussion.

^ permalink raw reply	[flat|nested] 26+ messages in thread

* Re: audacious: enable Qt interface
  2019-09-03  7:35 [PR PATCH] audacious: enable Qt interface voidlinux-github
                   ` (16 preceding siblings ...)
  2019-09-09 12:12 ` voidlinux-github
@ 2019-09-09 12:16 ` voidlinux-github
  2019-09-09 12:25 ` voidlinux-github
                   ` (6 subsequent siblings)
  24 siblings, 0 replies; 26+ messages in thread
From: voidlinux-github @ 2019-09-09 12:16 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 311 bytes --]

New comment by Piraty on void-packages repository

https://github.com/void-linux/void-packages/pull/14178#issuecomment-529443510

Comment:
I'd say: only support one toolkit and go for a default build option. If demand should arise to provide both versions at the same time, we can still warmup this discussion.

^ permalink raw reply	[flat|nested] 26+ messages in thread

* Re: audacious: enable Qt interface
  2019-09-03  7:35 [PR PATCH] audacious: enable Qt interface voidlinux-github
                   ` (17 preceding siblings ...)
  2019-09-09 12:16 ` voidlinux-github
@ 2019-09-09 12:25 ` voidlinux-github
  2019-09-11 16:03 ` [PR PATCH] [Updated] " voidlinux-github
                   ` (5 subsequent siblings)
  24 siblings, 0 replies; 26+ messages in thread
From: voidlinux-github @ 2019-09-09 12:25 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 422 bytes --]

New comment by Piraty on void-packages repository

https://github.com/void-linux/void-packages/pull/14178#issuecomment-529443510

Comment:
I'd say: only support one toolkit and go for a default build option. If demand should arise to provide both versions at the same time, we can still warmup this discussion.
@bra1nwave Both build options probably should conflict, can you please account for that with `vopt_conflict`?

^ permalink raw reply	[flat|nested] 26+ messages in thread

* Re: [PR PATCH] [Updated] audacious: enable Qt interface
  2019-09-03  7:35 [PR PATCH] audacious: enable Qt interface voidlinux-github
                   ` (18 preceding siblings ...)
  2019-09-09 12:25 ` voidlinux-github
@ 2019-09-11 16:03 ` " voidlinux-github
  2019-09-11 16:03 ` voidlinux-github
                   ` (4 subsequent siblings)
  24 siblings, 0 replies; 26+ messages in thread
From: voidlinux-github @ 2019-09-11 16:03 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 433 bytes --]

There is an updated pull request by bra1nwave against master on the void-packages repository

https://github.com/bra1nwave/void-packages audacious
https://github.com/void-linux/void-packages/pull/14178

audacious: enable Qt interface
closes  https://github.com/void-linux/void-packages/issues/14171

Should I add a build option for Qt/GTK?

A patch file from https://github.com/void-linux/void-packages/pull/14178.patch is attached

[-- Warning: decoded text below may be mangled --]
[-- Attachment #2: github-pr-audacious-14178.patch --]
[-- Type: text/x-diff, Size: 4104 bytes --]

From 3b07e06908d3de0065424808a784967f377b2afb Mon Sep 17 00:00:00 2001
From: bra1nwave <brainwave@openmailbox.org>
Date: Tue, 3 Sep 2019 09:16:37 +0200
Subject: [PATCH 1/2] audacious: enable Qt interface

---
 common/shlibs              |  1 +
 srcpkgs/audacious/template | 18 ++++++++++++++----
 2 files changed, 15 insertions(+), 4 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index 09df4f3ceca..30b3b4653d5 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -1151,6 +1151,7 @@ libguess.so.1 libguess-1.1_1
 libaudcore.so.5 audacious-3.9_1
 libaudgui.so.5 audacious-3.9_1
 libaudtag.so.3 audacious-3.8_1
+libaudqt.so.2 audacious-3.10.1_2
 libgstreamer-1.0.so.0 gstreamer1-1.0.0_1
 libgstbase-1.0.so.0 gstreamer1-1.0.0_1
 libgstcontroller-1.0.so.0 gstreamer1-1.0.0_1
diff --git a/srcpkgs/audacious/template b/srcpkgs/audacious/template
index 69528553607..5add753405e 100644
--- a/srcpkgs/audacious/template
+++ b/srcpkgs/audacious/template
@@ -1,11 +1,12 @@
 # Template file for 'audacious'
 pkgname=audacious
 version=3.10.1
-revision=1
+revision=2
 build_style=gnu-configure
-configure_args="--enable-thunar"
+configure_args="$(vopt_enable gtk) $(vopt_enable qt)"
 hostmakedepends="pkg-config glib-devel"
-makedepends="libSM-devel gtk+-devel dbus-glib-devel libguess-devel"
+makedepends="libSM-devel dbus-glib-devel libguess-devel $(vopt_if gtk gtk+-devel)
+$(vopt_if qt qt5-devel)"
 depends="desktop-file-utils hicolor-icon-theme"
 short_desc="Lightweight, advanced audio player focused on audio quality"
 maintainer="Orphaned <orphan@voidlinux.org>"
@@ -14,6 +15,15 @@ homepage="https://audacious-media-player.org/"
 distfiles="https://distfiles.${pkgname}-media-player.org/${pkgname}-${version}.tar.bz2"
 checksum=8366e840bb3c9448c2cf0cf9a0800155b0bd7cc212a28ba44990c3d2289c6b93
 
+build_options="gtk qt"
+build_options_default="gtk"
+desc_option_gtk="Enable support for the GTK+2 GUI toolkit"
+vopt_conflict gtk qt
+
+if [ "$CROSS_BUILD" ]; then
+	hostmakedepends+=" qt5-host-tools"
+fi
+
 post_install() {
 	vlicense COPYING
 }
@@ -24,6 +34,6 @@ audacious-devel_package() {
 	pkg_install() {
 		vmove usr/include
 		vmove usr/lib/pkgconfig
-		vmove usr/lib/*.so
+		vmove "usr/lib/*.so"
 	}
 }

From 04ed9d59ad99bb0c702c331efbb07a6b0a3d585b Mon Sep 17 00:00:00 2001
From: bra1nwave <brainwave@openmailbox.org>
Date: Tue, 3 Sep 2019 09:16:53 +0200
Subject: [PATCH 2/2] audacious-plugins: enable Qt interface - add cue support

---
 srcpkgs/audacious-plugins/template | 13 ++++++++++---
 1 file changed, 10 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/audacious-plugins/template b/srcpkgs/audacious-plugins/template
index d97bf72f30e..a50d65e7819 100644
--- a/srcpkgs/audacious-plugins/template
+++ b/srcpkgs/audacious-plugins/template
@@ -1,14 +1,16 @@
 # Template file for 'audacious-plugins'
 pkgname=audacious-plugins
 version=3.10.1
-revision=3
+revision=4
 build_style=gnu-configure
+configure_args="$(vopt_enable gtk) $(vopt_enable qt)"
 hostmakedepends="pkg-config"
 makedepends="audacious-devel alsa-lib-devel pulseaudio-devel jack-devel
  lame-devel libvorbis-devel libflac-devel mpg123-devel faad2-devel ffmpeg-devel
  libmodplug-devel fluidsynth-devel libcdio-paranoia-devel wavpack-devel libnotify-devel
- libcurl-devel libmtp-devel neon-devel libmms-devel gtk+-devel libxml2-devel
- libbs2b-devel libsoxr-devel libsidplayfp-devel"
+ libcurl-devel libmtp-devel neon-devel libmms-devel libxml2-devel
+ libbs2b-devel libsoxr-devel libsidplayfp-devel libcue-devel
+ $(vopt_if gtk gtk+-devel) $(vopt_if qt 'qt5-devel qt5-multimedia-devel')"
 short_desc="Plugins for the Audacious media player"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="BSD-2-Clause"
@@ -16,6 +18,11 @@ homepage="https://audacious-media-player.org/"
 distfiles="https://distfiles.audacious-media-player.org/${pkgname}-${version}.tar.bz2"
 checksum=eec3177631f99729bf0e94223b627406cc648c70e6646e35613c7b55040a2642
 
+build_options="gtk qt"
+build_options_default="gtk"
+desc_option_gtk="Enable support for the GTK+2 GUI toolkit"
+vopt_conflict gtk qt
+
 post_install() {
 	vlicense COPYING
 }

^ permalink raw reply	[flat|nested] 26+ messages in thread

* Re: [PR PATCH] [Updated] audacious: enable Qt interface
  2019-09-03  7:35 [PR PATCH] audacious: enable Qt interface voidlinux-github
                   ` (19 preceding siblings ...)
  2019-09-11 16:03 ` [PR PATCH] [Updated] " voidlinux-github
@ 2019-09-11 16:03 ` voidlinux-github
  2019-09-11 16:04 ` voidlinux-github
                   ` (3 subsequent siblings)
  24 siblings, 0 replies; 26+ messages in thread
From: voidlinux-github @ 2019-09-11 16:03 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 433 bytes --]

There is an updated pull request by bra1nwave against master on the void-packages repository

https://github.com/bra1nwave/void-packages audacious
https://github.com/void-linux/void-packages/pull/14178

audacious: enable Qt interface
closes  https://github.com/void-linux/void-packages/issues/14171

Should I add a build option for Qt/GTK?

A patch file from https://github.com/void-linux/void-packages/pull/14178.patch is attached

[-- Warning: decoded text below may be mangled --]
[-- Attachment #2: github-pr-audacious-14178.patch --]
[-- Type: text/x-diff, Size: 4104 bytes --]

From 3b07e06908d3de0065424808a784967f377b2afb Mon Sep 17 00:00:00 2001
From: bra1nwave <brainwave@openmailbox.org>
Date: Tue, 3 Sep 2019 09:16:37 +0200
Subject: [PATCH 1/2] audacious: enable Qt interface

---
 common/shlibs              |  1 +
 srcpkgs/audacious/template | 18 ++++++++++++++----
 2 files changed, 15 insertions(+), 4 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index 09df4f3ceca..30b3b4653d5 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -1151,6 +1151,7 @@ libguess.so.1 libguess-1.1_1
 libaudcore.so.5 audacious-3.9_1
 libaudgui.so.5 audacious-3.9_1
 libaudtag.so.3 audacious-3.8_1
+libaudqt.so.2 audacious-3.10.1_2
 libgstreamer-1.0.so.0 gstreamer1-1.0.0_1
 libgstbase-1.0.so.0 gstreamer1-1.0.0_1
 libgstcontroller-1.0.so.0 gstreamer1-1.0.0_1
diff --git a/srcpkgs/audacious/template b/srcpkgs/audacious/template
index 69528553607..5add753405e 100644
--- a/srcpkgs/audacious/template
+++ b/srcpkgs/audacious/template
@@ -1,11 +1,12 @@
 # Template file for 'audacious'
 pkgname=audacious
 version=3.10.1
-revision=1
+revision=2
 build_style=gnu-configure
-configure_args="--enable-thunar"
+configure_args="$(vopt_enable gtk) $(vopt_enable qt)"
 hostmakedepends="pkg-config glib-devel"
-makedepends="libSM-devel gtk+-devel dbus-glib-devel libguess-devel"
+makedepends="libSM-devel dbus-glib-devel libguess-devel $(vopt_if gtk gtk+-devel)
+$(vopt_if qt qt5-devel)"
 depends="desktop-file-utils hicolor-icon-theme"
 short_desc="Lightweight, advanced audio player focused on audio quality"
 maintainer="Orphaned <orphan@voidlinux.org>"
@@ -14,6 +15,15 @@ homepage="https://audacious-media-player.org/"
 distfiles="https://distfiles.${pkgname}-media-player.org/${pkgname}-${version}.tar.bz2"
 checksum=8366e840bb3c9448c2cf0cf9a0800155b0bd7cc212a28ba44990c3d2289c6b93
 
+build_options="gtk qt"
+build_options_default="gtk"
+desc_option_gtk="Enable support for the GTK+2 GUI toolkit"
+vopt_conflict gtk qt
+
+if [ "$CROSS_BUILD" ]; then
+	hostmakedepends+=" qt5-host-tools"
+fi
+
 post_install() {
 	vlicense COPYING
 }
@@ -24,6 +34,6 @@ audacious-devel_package() {
 	pkg_install() {
 		vmove usr/include
 		vmove usr/lib/pkgconfig
-		vmove usr/lib/*.so
+		vmove "usr/lib/*.so"
 	}
 }

From 04ed9d59ad99bb0c702c331efbb07a6b0a3d585b Mon Sep 17 00:00:00 2001
From: bra1nwave <brainwave@openmailbox.org>
Date: Tue, 3 Sep 2019 09:16:53 +0200
Subject: [PATCH 2/2] audacious-plugins: enable Qt interface - add cue support

---
 srcpkgs/audacious-plugins/template | 13 ++++++++++---
 1 file changed, 10 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/audacious-plugins/template b/srcpkgs/audacious-plugins/template
index d97bf72f30e..a50d65e7819 100644
--- a/srcpkgs/audacious-plugins/template
+++ b/srcpkgs/audacious-plugins/template
@@ -1,14 +1,16 @@
 # Template file for 'audacious-plugins'
 pkgname=audacious-plugins
 version=3.10.1
-revision=3
+revision=4
 build_style=gnu-configure
+configure_args="$(vopt_enable gtk) $(vopt_enable qt)"
 hostmakedepends="pkg-config"
 makedepends="audacious-devel alsa-lib-devel pulseaudio-devel jack-devel
  lame-devel libvorbis-devel libflac-devel mpg123-devel faad2-devel ffmpeg-devel
  libmodplug-devel fluidsynth-devel libcdio-paranoia-devel wavpack-devel libnotify-devel
- libcurl-devel libmtp-devel neon-devel libmms-devel gtk+-devel libxml2-devel
- libbs2b-devel libsoxr-devel libsidplayfp-devel"
+ libcurl-devel libmtp-devel neon-devel libmms-devel libxml2-devel
+ libbs2b-devel libsoxr-devel libsidplayfp-devel libcue-devel
+ $(vopt_if gtk gtk+-devel) $(vopt_if qt 'qt5-devel qt5-multimedia-devel')"
 short_desc="Plugins for the Audacious media player"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="BSD-2-Clause"
@@ -16,6 +18,11 @@ homepage="https://audacious-media-player.org/"
 distfiles="https://distfiles.audacious-media-player.org/${pkgname}-${version}.tar.bz2"
 checksum=eec3177631f99729bf0e94223b627406cc648c70e6646e35613c7b55040a2642
 
+build_options="gtk qt"
+build_options_default="gtk"
+desc_option_gtk="Enable support for the GTK+2 GUI toolkit"
+vopt_conflict gtk qt
+
 post_install() {
 	vlicense COPYING
 }

^ permalink raw reply	[flat|nested] 26+ messages in thread

* Re: audacious: enable Qt interface
  2019-09-03  7:35 [PR PATCH] audacious: enable Qt interface voidlinux-github
                   ` (20 preceding siblings ...)
  2019-09-11 16:03 ` voidlinux-github
@ 2019-09-11 16:04 ` voidlinux-github
  2019-09-13  8:34 ` [PR PATCH] [Updated] " voidlinux-github
                   ` (2 subsequent siblings)
  24 siblings, 0 replies; 26+ messages in thread
From: voidlinux-github @ 2019-09-11 16:04 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 155 bytes --]

New comment by bra1nwave on void-packages repository

https://github.com/void-linux/void-packages/pull/14178#issuecomment-530449231

Comment:
@Piraty Done

^ permalink raw reply	[flat|nested] 26+ messages in thread

* Re: [PR PATCH] [Updated] audacious: enable Qt interface
  2019-09-03  7:35 [PR PATCH] audacious: enable Qt interface voidlinux-github
                   ` (22 preceding siblings ...)
  2019-09-13  8:34 ` [PR PATCH] [Updated] " voidlinux-github
@ 2019-09-13  8:34 ` voidlinux-github
  2019-09-13 22:06 ` [PR PATCH] [Merged]: " voidlinux-github
  24 siblings, 0 replies; 26+ messages in thread
From: voidlinux-github @ 2019-09-13  8:34 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 433 bytes --]

There is an updated pull request by bra1nwave against master on the void-packages repository

https://github.com/bra1nwave/void-packages audacious
https://github.com/void-linux/void-packages/pull/14178

audacious: enable Qt interface
closes  https://github.com/void-linux/void-packages/issues/14171

Should I add a build option for Qt/GTK?

A patch file from https://github.com/void-linux/void-packages/pull/14178.patch is attached

[-- Warning: decoded text below may be mangled --]
[-- Attachment #2: github-pr-audacious-14178.patch --]
[-- Type: text/x-diff, Size: 4101 bytes --]

From ff21198b3f4611db1fca75c746176062ce163fee Mon Sep 17 00:00:00 2001
From: bra1nwave <brainwave@openmailbox.org>
Date: Tue, 3 Sep 2019 09:16:37 +0200
Subject: [PATCH 1/2] audacious: enable Qt interface

---
 common/shlibs              |  1 +
 srcpkgs/audacious/template | 16 +++++++++++-----
 2 files changed, 12 insertions(+), 5 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index 09df4f3ceca..30b3b4653d5 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -1151,6 +1151,7 @@ libguess.so.1 libguess-1.1_1
 libaudcore.so.5 audacious-3.9_1
 libaudgui.so.5 audacious-3.9_1
 libaudtag.so.3 audacious-3.8_1
+libaudqt.so.2 audacious-3.10.1_2
 libgstreamer-1.0.so.0 gstreamer1-1.0.0_1
 libgstbase-1.0.so.0 gstreamer1-1.0.0_1
 libgstcontroller-1.0.so.0 gstreamer1-1.0.0_1
diff --git a/srcpkgs/audacious/template b/srcpkgs/audacious/template
index 69528553607..e925bb3683f 100644
--- a/srcpkgs/audacious/template
+++ b/srcpkgs/audacious/template
@@ -1,11 +1,12 @@
 # Template file for 'audacious'
 pkgname=audacious
 version=3.10.1
-revision=1
+revision=2
 build_style=gnu-configure
-configure_args="--enable-thunar"
-hostmakedepends="pkg-config glib-devel"
-makedepends="libSM-devel gtk+-devel dbus-glib-devel libguess-devel"
+configure_args="$(vopt_enable gtk) $(vopt_enable qt)"
+hostmakedepends="pkg-config glib-devel $(vopt_if qt qt5-host-tools)"
+makedepends="libSM-devel dbus-glib-devel libguess-devel $(vopt_if gtk gtk+-devel)
+ $(vopt_if qt qt5-devel)"
 depends="desktop-file-utils hicolor-icon-theme"
 short_desc="Lightweight, advanced audio player focused on audio quality"
 maintainer="Orphaned <orphan@voidlinux.org>"
@@ -14,6 +15,11 @@ homepage="https://audacious-media-player.org/"
 distfiles="https://distfiles.${pkgname}-media-player.org/${pkgname}-${version}.tar.bz2"
 checksum=8366e840bb3c9448c2cf0cf9a0800155b0bd7cc212a28ba44990c3d2289c6b93
 
+build_options="gtk qt"
+build_options_default="gtk"
+desc_option_gtk="Enable support for the GTK+2 GUI toolkit"
+vopt_conflict gtk qt
+
 post_install() {
 	vlicense COPYING
 }
@@ -24,6 +30,6 @@ audacious-devel_package() {
 	pkg_install() {
 		vmove usr/include
 		vmove usr/lib/pkgconfig
-		vmove usr/lib/*.so
+		vmove "usr/lib/*.so"
 	}
 }

From e0c36d75b5fcfee7a4b0fbcb342edf4f8aaf277b Mon Sep 17 00:00:00 2001
From: bra1nwave <brainwave@openmailbox.org>
Date: Tue, 3 Sep 2019 09:16:53 +0200
Subject: [PATCH 2/2] audacious-plugins: enable Qt interface - add cue support

---
 srcpkgs/audacious-plugins/template | 13 ++++++++++---
 1 file changed, 10 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/audacious-plugins/template b/srcpkgs/audacious-plugins/template
index d97bf72f30e..a50d65e7819 100644
--- a/srcpkgs/audacious-plugins/template
+++ b/srcpkgs/audacious-plugins/template
@@ -1,14 +1,16 @@
 # Template file for 'audacious-plugins'
 pkgname=audacious-plugins
 version=3.10.1
-revision=3
+revision=4
 build_style=gnu-configure
+configure_args="$(vopt_enable gtk) $(vopt_enable qt)"
 hostmakedepends="pkg-config"
 makedepends="audacious-devel alsa-lib-devel pulseaudio-devel jack-devel
  lame-devel libvorbis-devel libflac-devel mpg123-devel faad2-devel ffmpeg-devel
  libmodplug-devel fluidsynth-devel libcdio-paranoia-devel wavpack-devel libnotify-devel
- libcurl-devel libmtp-devel neon-devel libmms-devel gtk+-devel libxml2-devel
- libbs2b-devel libsoxr-devel libsidplayfp-devel"
+ libcurl-devel libmtp-devel neon-devel libmms-devel libxml2-devel
+ libbs2b-devel libsoxr-devel libsidplayfp-devel libcue-devel
+ $(vopt_if gtk gtk+-devel) $(vopt_if qt 'qt5-devel qt5-multimedia-devel')"
 short_desc="Plugins for the Audacious media player"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="BSD-2-Clause"
@@ -16,6 +18,11 @@ homepage="https://audacious-media-player.org/"
 distfiles="https://distfiles.audacious-media-player.org/${pkgname}-${version}.tar.bz2"
 checksum=eec3177631f99729bf0e94223b627406cc648c70e6646e35613c7b55040a2642
 
+build_options="gtk qt"
+build_options_default="gtk"
+desc_option_gtk="Enable support for the GTK+2 GUI toolkit"
+vopt_conflict gtk qt
+
 post_install() {
 	vlicense COPYING
 }

^ permalink raw reply	[flat|nested] 26+ messages in thread

* Re: [PR PATCH] [Updated] audacious: enable Qt interface
  2019-09-03  7:35 [PR PATCH] audacious: enable Qt interface voidlinux-github
                   ` (21 preceding siblings ...)
  2019-09-11 16:04 ` voidlinux-github
@ 2019-09-13  8:34 ` " voidlinux-github
  2019-09-13  8:34 ` voidlinux-github
  2019-09-13 22:06 ` [PR PATCH] [Merged]: " voidlinux-github
  24 siblings, 0 replies; 26+ messages in thread
From: voidlinux-github @ 2019-09-13  8:34 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 433 bytes --]

There is an updated pull request by bra1nwave against master on the void-packages repository

https://github.com/bra1nwave/void-packages audacious
https://github.com/void-linux/void-packages/pull/14178

audacious: enable Qt interface
closes  https://github.com/void-linux/void-packages/issues/14171

Should I add a build option for Qt/GTK?

A patch file from https://github.com/void-linux/void-packages/pull/14178.patch is attached

[-- Warning: decoded text below may be mangled --]
[-- Attachment #2: github-pr-audacious-14178.patch --]
[-- Type: text/x-diff, Size: 4101 bytes --]

From ff21198b3f4611db1fca75c746176062ce163fee Mon Sep 17 00:00:00 2001
From: bra1nwave <brainwave@openmailbox.org>
Date: Tue, 3 Sep 2019 09:16:37 +0200
Subject: [PATCH 1/2] audacious: enable Qt interface

---
 common/shlibs              |  1 +
 srcpkgs/audacious/template | 16 +++++++++++-----
 2 files changed, 12 insertions(+), 5 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index 09df4f3ceca..30b3b4653d5 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -1151,6 +1151,7 @@ libguess.so.1 libguess-1.1_1
 libaudcore.so.5 audacious-3.9_1
 libaudgui.so.5 audacious-3.9_1
 libaudtag.so.3 audacious-3.8_1
+libaudqt.so.2 audacious-3.10.1_2
 libgstreamer-1.0.so.0 gstreamer1-1.0.0_1
 libgstbase-1.0.so.0 gstreamer1-1.0.0_1
 libgstcontroller-1.0.so.0 gstreamer1-1.0.0_1
diff --git a/srcpkgs/audacious/template b/srcpkgs/audacious/template
index 69528553607..e925bb3683f 100644
--- a/srcpkgs/audacious/template
+++ b/srcpkgs/audacious/template
@@ -1,11 +1,12 @@
 # Template file for 'audacious'
 pkgname=audacious
 version=3.10.1
-revision=1
+revision=2
 build_style=gnu-configure
-configure_args="--enable-thunar"
-hostmakedepends="pkg-config glib-devel"
-makedepends="libSM-devel gtk+-devel dbus-glib-devel libguess-devel"
+configure_args="$(vopt_enable gtk) $(vopt_enable qt)"
+hostmakedepends="pkg-config glib-devel $(vopt_if qt qt5-host-tools)"
+makedepends="libSM-devel dbus-glib-devel libguess-devel $(vopt_if gtk gtk+-devel)
+ $(vopt_if qt qt5-devel)"
 depends="desktop-file-utils hicolor-icon-theme"
 short_desc="Lightweight, advanced audio player focused on audio quality"
 maintainer="Orphaned <orphan@voidlinux.org>"
@@ -14,6 +15,11 @@ homepage="https://audacious-media-player.org/"
 distfiles="https://distfiles.${pkgname}-media-player.org/${pkgname}-${version}.tar.bz2"
 checksum=8366e840bb3c9448c2cf0cf9a0800155b0bd7cc212a28ba44990c3d2289c6b93
 
+build_options="gtk qt"
+build_options_default="gtk"
+desc_option_gtk="Enable support for the GTK+2 GUI toolkit"
+vopt_conflict gtk qt
+
 post_install() {
 	vlicense COPYING
 }
@@ -24,6 +30,6 @@ audacious-devel_package() {
 	pkg_install() {
 		vmove usr/include
 		vmove usr/lib/pkgconfig
-		vmove usr/lib/*.so
+		vmove "usr/lib/*.so"
 	}
 }

From e0c36d75b5fcfee7a4b0fbcb342edf4f8aaf277b Mon Sep 17 00:00:00 2001
From: bra1nwave <brainwave@openmailbox.org>
Date: Tue, 3 Sep 2019 09:16:53 +0200
Subject: [PATCH 2/2] audacious-plugins: enable Qt interface - add cue support

---
 srcpkgs/audacious-plugins/template | 13 ++++++++++---
 1 file changed, 10 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/audacious-plugins/template b/srcpkgs/audacious-plugins/template
index d97bf72f30e..a50d65e7819 100644
--- a/srcpkgs/audacious-plugins/template
+++ b/srcpkgs/audacious-plugins/template
@@ -1,14 +1,16 @@
 # Template file for 'audacious-plugins'
 pkgname=audacious-plugins
 version=3.10.1
-revision=3
+revision=4
 build_style=gnu-configure
+configure_args="$(vopt_enable gtk) $(vopt_enable qt)"
 hostmakedepends="pkg-config"
 makedepends="audacious-devel alsa-lib-devel pulseaudio-devel jack-devel
  lame-devel libvorbis-devel libflac-devel mpg123-devel faad2-devel ffmpeg-devel
  libmodplug-devel fluidsynth-devel libcdio-paranoia-devel wavpack-devel libnotify-devel
- libcurl-devel libmtp-devel neon-devel libmms-devel gtk+-devel libxml2-devel
- libbs2b-devel libsoxr-devel libsidplayfp-devel"
+ libcurl-devel libmtp-devel neon-devel libmms-devel libxml2-devel
+ libbs2b-devel libsoxr-devel libsidplayfp-devel libcue-devel
+ $(vopt_if gtk gtk+-devel) $(vopt_if qt 'qt5-devel qt5-multimedia-devel')"
 short_desc="Plugins for the Audacious media player"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="BSD-2-Clause"
@@ -16,6 +18,11 @@ homepage="https://audacious-media-player.org/"
 distfiles="https://distfiles.audacious-media-player.org/${pkgname}-${version}.tar.bz2"
 checksum=eec3177631f99729bf0e94223b627406cc648c70e6646e35613c7b55040a2642
 
+build_options="gtk qt"
+build_options_default="gtk"
+desc_option_gtk="Enable support for the GTK+2 GUI toolkit"
+vopt_conflict gtk qt
+
 post_install() {
 	vlicense COPYING
 }

^ permalink raw reply	[flat|nested] 26+ messages in thread

* Re: [PR PATCH] [Merged]: audacious: enable Qt interface
  2019-09-03  7:35 [PR PATCH] audacious: enable Qt interface voidlinux-github
                   ` (23 preceding siblings ...)
  2019-09-13  8:34 ` voidlinux-github
@ 2019-09-13 22:06 ` " voidlinux-github
  24 siblings, 0 replies; 26+ messages in thread
From: voidlinux-github @ 2019-09-13 22:06 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 271 bytes --]

There's a merged pull request on the void-packages repository

audacious: enable Qt interface
https://github.com/void-linux/void-packages/pull/14178

Description:
closes  https://github.com/void-linux/void-packages/issues/14171

Should I add a build option for Qt/GTK?

^ permalink raw reply	[flat|nested] 26+ messages in thread

end of thread, back to index

Thread overview: 26+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-09-03  7:35 [PR PATCH] audacious: enable Qt interface voidlinux-github
2019-09-03  9:05 ` voidlinux-github
2019-09-03 10:09 ` [PR PATCH] [Updated] " voidlinux-github
2019-09-03 10:09 ` voidlinux-github
2019-09-03 10:12 ` voidlinux-github
2019-09-03 10:12 ` voidlinux-github
2019-09-03 10:16 ` voidlinux-github
2019-09-03 10:16 ` voidlinux-github
2019-09-03 10:21 ` voidlinux-github
2019-09-03 10:21 ` voidlinux-github
2019-09-03 10:25 ` voidlinux-github
2019-09-04 16:35 ` voidlinux-github
2019-09-04 16:47 ` voidlinux-github
2019-09-04 16:52 ` voidlinux-github
2019-09-04 16:56 ` voidlinux-github
2019-09-04 17:01 ` voidlinux-github
2019-09-05  7:24 ` voidlinux-github
2019-09-09 12:12 ` voidlinux-github
2019-09-09 12:16 ` voidlinux-github
2019-09-09 12:25 ` voidlinux-github
2019-09-11 16:03 ` [PR PATCH] [Updated] " voidlinux-github
2019-09-11 16:03 ` voidlinux-github
2019-09-11 16:04 ` voidlinux-github
2019-09-13  8:34 ` [PR PATCH] [Updated] " voidlinux-github
2019-09-13  8:34 ` voidlinux-github
2019-09-13 22:06 ` [PR PATCH] [Merged]: " voidlinux-github

Github messages for voidlinux

Archives are clonable: git clone --mirror http://inbox.vuxu.org/voidlinux-github

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.github.voidlinux


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git