Github messages for voidlinux
 help / color / Atom feed
* [ISSUE] libglvnd-devel conflicts with rpi-userland-devel
@ 2020-01-14  4:20 voidlinux-github
  0 siblings, 0 replies; only message in thread
From: voidlinux-github @ 2020-01-14  4:20 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1197 bytes --]

New issue by Johnnynator on void-packages repository

https://github.com/void-linux/void-packages/issues/18299

Description:
<!-- Don't request update of package. We have a script for that. https://alpha.de.repo.voidlinux.org/void-updates/void-updates.txt . However, a quality pull request may help. -->
### System

* xuname:  
  *output of ``xuname`` (part of xtools)*
* package:  
  *affected package(s) including the version*

### Expected behavior
No conflicts
### Actual behavior
```
libdrm-devel-2.4.100_1: coERROR: libglvnd-devel-1.3.0_1: file `/usr/lib/pkgconfig/egl.pc' already installed by package rpi-userland-devel-20190501_2.
ERROR: libglvnd-devel-1.3.0_1: file `/usr/lib/pkgconfig/glesv2.pc' already installed by package rpi-userland-devel-20190501_2.
```
### Steps to reproduce the behavior
`./xbps-src pkg EmulationStation-rpi -a armv7l`

`rpi-userland-devel` keeps everything in `/opt/vc/lib` but moves the pkgconfig to `/usr/lib` so they conflict with `libgvlnd` and most likely also always did, nobody just noticed/cared about it.
https://github.com/void-linux/void-packages/blob/e58027461027de6c2b123791fee3f2b2ed8b3c4a/srcpkgs/rpi-userland/template#L57



^ permalink raw reply	[flat|nested] only message in thread

only message in thread, back to index

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-01-14  4:20 [ISSUE] libglvnd-devel conflicts with rpi-userland-devel voidlinux-github

Github messages for voidlinux

Archives are clonable: git clone --mirror http://inbox.vuxu.org/voidlinux-github

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.github.voidlinux


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git