Github messages for voidlinux
 help / color / mirror / Atom feed
* [PR PATCH] gzdoom: fix depends for audio
@ 2020-04-05  5:50 25thom
  2020-08-09  4:20 ` [PR REVIEW] " ericonr
  2020-11-22  5:08 ` [PR PATCH] [Closed]: " the-maldridge
  0 siblings, 2 replies; 3+ messages in thread
From: 25thom @ 2020-04-05  5:50 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 523 bytes --]

There is a new pull request by 25thom against master on the void-packages repository

https://github.com/25thom/void-packages patch-2
https://github.com/void-linux/void-packages/pull/20665

gzdoom: fix depends for audio
GZDoom needs libopenal, or FMOD [https://zdoom.org/wiki/Compile_GZDoom_on_Linux#Install_dependencies] to have sound playback. FMOD is not in the Void repo, so adding OpenAL as a dependency is a cheap workaround.

A patch file from https://github.com/void-linux/void-packages/pull/20665.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-patch-2-20665.patch --]
[-- Type: text/x-diff, Size: 1367 bytes --]

From 5fc9d97839230f78dd47c973c0436f7b27442624 Mon Sep 17 00:00:00 2001
From: 25thom <55524001+25thom@users.noreply.github.com>
Date: Sun, 5 Apr 2020 01:49:58 -0400
Subject: [PATCH] gzdoom: fix depends for audio

GZDoom needs libopenal, or FMOD [https://zdoom.org/wiki/Compile_GZDoom_on_Linux#Install_dependencies] to have sound playback. FMOD is not in the Void repo, so adding OpenAL as a dependency is a cheap workaround.
---
 srcpkgs/gzdoom/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/gzdoom/template b/srcpkgs/gzdoom/template
index 83935bacf7c..ac185d40e80 100644
--- a/srcpkgs/gzdoom/template
+++ b/srcpkgs/gzdoom/template
@@ -1,14 +1,14 @@
 # Template file for 'gzdoom'
 pkgname=gzdoom
 version=4.2.4
-revision=1
+revision=2
 _tagdate=2019-07-09
 wrksrc="${pkgname}-g${version}"
 build_style=cmake
 configure_args="-DINSTALL_PK3_PATH=share/gzdoom"
 hostmakedepends="pkg-config"
-makedepends="SDL2-devel gtk+3-devel fluidsynth-devel libgme-devel libgomp-devel ppl-devel"
-depends="libfluidsynth gtk+3"
+makedepends="SDL2-devel gtk+3-devel fluidsynth-devel libgme-devel libgomp-devel ppl-devel libopenal-devel libsndfile-devel"
+depends="libfluidsynth gtk+3 libopenal libsndfile"
 short_desc="Advanced Doom source port with OpenGL support"
 maintainer="Michael Straube <straubem@gmx.de>"
 license="GPL-3.0-or-later"

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PR REVIEW] gzdoom: fix depends for audio
  2020-04-05  5:50 [PR PATCH] gzdoom: fix depends for audio 25thom
@ 2020-08-09  4:20 ` ericonr
  2020-11-22  5:08 ` [PR PATCH] [Closed]: " the-maldridge
  1 sibling, 0 replies; 3+ messages in thread
From: ericonr @ 2020-08-09  4:20 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 317 bytes --]

New review comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/pull/20665#discussion_r467534083

Comment:
Please break the makedepends line at 80 columns, and `libopenal` and `libsndfile` shouldn't need to be in depends, `xbps-src` should be able to detect them at build time.

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PR PATCH] [Closed]: gzdoom: fix depends for audio
  2020-04-05  5:50 [PR PATCH] gzdoom: fix depends for audio 25thom
  2020-08-09  4:20 ` [PR REVIEW] " ericonr
@ 2020-11-22  5:08 ` the-maldridge
  1 sibling, 0 replies; 3+ messages in thread
From: the-maldridge @ 2020-11-22  5:08 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 374 bytes --]

There's a closed pull request on the void-packages repository

gzdoom: fix depends for audio
https://github.com/void-linux/void-packages/pull/20665

Description:
GZDoom needs libopenal, or FMOD [https://zdoom.org/wiki/Compile_GZDoom_on_Linux#Install_dependencies] to have sound playback. FMOD is not in the Void repo, so adding OpenAL as a dependency is a cheap workaround.

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2020-11-22  5:08 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-04-05  5:50 [PR PATCH] gzdoom: fix depends for audio 25thom
2020-08-09  4:20 ` [PR REVIEW] " ericonr
2020-11-22  5:08 ` [PR PATCH] [Closed]: " the-maldridge

Github messages for voidlinux

This inbox may be cloned and mirrored by anyone:

	git clone --mirror http://inbox.vuxu.org/voidlinux-github

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V1 voidlinux-github voidlinux-github/ http://inbox.vuxu.org/voidlinux-github \
		voidlinux-github@inbox.vuxu.org
	public-inbox-index voidlinux-github

Example config snippet for mirrors.
Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.github.voidlinux


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git