Github messages for voidlinux
 help / color / Atom feed
* [PR PATCH] rapydscript-ng: add explicit python_version
@ 2020-05-26 10:19 fosslinux
  2020-05-26 10:43 ` Piraty
                   ` (4 more replies)
  0 siblings, 5 replies; 6+ messages in thread
From: fosslinux @ 2020-05-26 10:19 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 354 bytes --]

There is a new pull request by fosslinux against master on the void-packages repository

https://github.com/fosslinux/void-packages rapydscript-ng-python-version
https://github.com/void-linux/void-packages/pull/22311

rapydscript-ng: add explicit python_version


A patch file from https://github.com/void-linux/void-packages/pull/22311.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-rapydscript-ng-python-version-22311.patch --]
[-- Type: text/x-diff, Size: 873 bytes --]

From 2728a0219c895615f5a2f176d3320502746ea770 Mon Sep 17 00:00:00 2001
From: fosslinux <fosslinux@aussies.space>
Date: Tue, 26 May 2020 20:17:08 +1000
Subject: [PATCH] rapydscript-ng: add explicit python_version

---
 srcpkgs/rapydscript-ng/template | 1 +
 1 file changed, 1 insertion(+)

diff --git a/srcpkgs/rapydscript-ng/template b/srcpkgs/rapydscript-ng/template
index d5f04b75877..a55c208425c 100644
--- a/srcpkgs/rapydscript-ng/template
+++ b/srcpkgs/rapydscript-ng/template
@@ -12,6 +12,7 @@ homepage="https://github.com/kovidgoyal/rapydscript-ng"
 changelog="https://raw.githubusercontent.com/kovidgoyal/rapydscript-ng/master/CHANGELOG.md"
 distfiles="${homepage}/archive/v${version}.tar.gz"
 checksum=11540118ce88f33b974884f08d1627938bc57669f0eefc1392bf9fc9d411ae03
+python_version=3 # seems to be compatible with both
 
 do_build() {
 	npm install --no-optional

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: rapydscript-ng: add explicit python_version
  2020-05-26 10:19 [PR PATCH] rapydscript-ng: add explicit python_version fosslinux
@ 2020-05-26 10:43 ` Piraty
  2020-06-01  6:41 ` bra1nwave
                   ` (3 subsequent siblings)
  4 siblings, 0 replies; 6+ messages in thread
From: Piraty @ 2020-05-26 10:43 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 151 bytes --]

New comment by Piraty on void-packages repository

https://github.com/void-linux/void-packages/pull/22311#issuecomment-633949325

Comment:
@bra1nwave 

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: rapydscript-ng: add explicit python_version
  2020-05-26 10:19 [PR PATCH] rapydscript-ng: add explicit python_version fosslinux
  2020-05-26 10:43 ` Piraty
@ 2020-06-01  6:41 ` bra1nwave
  2020-06-01 20:26 ` Piraty
                   ` (2 subsequent siblings)
  4 siblings, 0 replies; 6+ messages in thread
From: bra1nwave @ 2020-06-01  6:41 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 302 bytes --]

New comment by bra1nwave on void-packages repository

https://github.com/void-linux/void-packages/pull/22311#issuecomment-636643429

Comment:
LGTM. Only [one](https://github.com/kovidgoyal/rapydscript-ng/blob/master/publish.py) script is converted, which is only useful for the upstream dev(s) anyway.

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: rapydscript-ng: add explicit python_version
  2020-05-26 10:19 [PR PATCH] rapydscript-ng: add explicit python_version fosslinux
  2020-05-26 10:43 ` Piraty
  2020-06-01  6:41 ` bra1nwave
@ 2020-06-01 20:26 ` Piraty
  2020-06-02  6:16 ` [PR PATCH] [Updated] " fosslinux
  2020-06-02  6:16 ` fosslinux
  4 siblings, 0 replies; 6+ messages in thread
From: Piraty @ 2020-06-01 20:26 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 191 bytes --]

New comment by Piraty on void-packages repository

https://github.com/void-linux/void-packages/pull/22311#issuecomment-637083895

Comment:
@fosslinux please revbump so the package is rebuilt

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PR PATCH] [Updated] rapydscript-ng: add explicit python_version
  2020-05-26 10:19 [PR PATCH] rapydscript-ng: add explicit python_version fosslinux
                   ` (2 preceding siblings ...)
  2020-06-01 20:26 ` Piraty
@ 2020-06-02  6:16 ` fosslinux
  2020-06-02  6:16 ` fosslinux
  4 siblings, 0 replies; 6+ messages in thread
From: fosslinux @ 2020-06-02  6:16 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 359 bytes --]

There is an updated pull request by fosslinux against master on the void-packages repository

https://github.com/fosslinux/void-packages rapydscript-ng-python-version
https://github.com/void-linux/void-packages/pull/22311

rapydscript-ng: add explicit python_version


A patch file from https://github.com/void-linux/void-packages/pull/22311.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-rapydscript-ng-python-version-22311.patch --]
[-- Type: text/x-diff, Size: 1067 bytes --]

From c30806f508a6c13f92313c21ecb828a823c3fc3f Mon Sep 17 00:00:00 2001
From: fosslinux <fosslinux@aussies.space>
Date: Tue, 26 May 2020 20:17:08 +1000
Subject: [PATCH] rapydscript-ng: add explicit python_version

---
 srcpkgs/rapydscript-ng/template | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/srcpkgs/rapydscript-ng/template b/srcpkgs/rapydscript-ng/template
index d5f04b75877..681fe9781cc 100644
--- a/srcpkgs/rapydscript-ng/template
+++ b/srcpkgs/rapydscript-ng/template
@@ -1,7 +1,7 @@
 # Template file for 'rapydscript-ng'
 pkgname=rapydscript-ng
 version=0.7.20
-revision=1
+revision=2
 archs=noarch
 hostmakedepends="nodejs"
 depends="nodejs"
@@ -12,6 +12,7 @@ homepage="https://github.com/kovidgoyal/rapydscript-ng"
 changelog="https://raw.githubusercontent.com/kovidgoyal/rapydscript-ng/master/CHANGELOG.md"
 distfiles="${homepage}/archive/v${version}.tar.gz"
 checksum=11540118ce88f33b974884f08d1627938bc57669f0eefc1392bf9fc9d411ae03
+python_version=3 # seems to be compatible with both
 
 do_build() {
 	npm install --no-optional

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: rapydscript-ng: add explicit python_version
  2020-05-26 10:19 [PR PATCH] rapydscript-ng: add explicit python_version fosslinux
                   ` (3 preceding siblings ...)
  2020-06-02  6:16 ` [PR PATCH] [Updated] " fosslinux
@ 2020-06-02  6:16 ` fosslinux
  4 siblings, 0 replies; 6+ messages in thread
From: fosslinux @ 2020-06-02  6:16 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 155 bytes --]

New comment by fosslinux on void-packages repository

https://github.com/void-linux/void-packages/pull/22311#issuecomment-637302789

Comment:
@Piraty done

^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, back to index

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-05-26 10:19 [PR PATCH] rapydscript-ng: add explicit python_version fosslinux
2020-05-26 10:43 ` Piraty
2020-06-01  6:41 ` bra1nwave
2020-06-01 20:26 ` Piraty
2020-06-02  6:16 ` [PR PATCH] [Updated] " fosslinux
2020-06-02  6:16 ` fosslinux

Github messages for voidlinux

Archives are clonable: git clone --mirror http://inbox.vuxu.org/voidlinux-github

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.github.voidlinux


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git