Github messages for voidlinux
 help / color / mirror / Atom feed
* [PR PATCH] stepmania: update to 5.1.0-b2
@ 2020-07-22 19:46 jason1987d
  2020-07-22 19:59 ` [PR REVIEW] " ericonr
                   ` (33 more replies)
  0 siblings, 34 replies; 35+ messages in thread
From: jason1987d @ 2020-07-22 19:46 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 718 bytes --]

There is a new pull request by jason1987d against master on the void-packages repository

https://github.com/jason1987d/void-packages stepmania-5.1.0-b2
https://github.com/void-linux/void-packages/pull/23747

stepmania: update to 5.1.0-b2
The current version 5.0.12 results in an error "Fatal: crash from within the crash signal handler" upon running stepmania. From https://github.com/stepmania/stepmania/issues/1606 the suggested workaround is to use the 5.1 branch. The version 5.1-beta2 is technically a release that has been available for a long time. There are also 5.3 alpha releases, but this 5.1 I have tested to run.

A patch file from https://github.com/void-linux/void-packages/pull/23747.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-stepmania-5.1.0-b2-23747.patch --]
[-- Type: text/x-diff, Size: 2438 bytes --]

From 548d17e568d7362c74e673b9b1e66a9540f3bb7c Mon Sep 17 00:00:00 2001
From: Jason Manley <jason@jasondavid.tv>
Date: Wed, 22 Jul 2020 14:41:10 -0500
Subject: [PATCH] stepmania: update to 5.1.0-b2

---
 srcpkgs/stepmania/template | 31 +++++++++++++++++++------------
 1 file changed, 19 insertions(+), 12 deletions(-)

diff --git a/srcpkgs/stepmania/template b/srcpkgs/stepmania/template
index 9ec2c4c2421..082456d62ba 100644
--- a/srcpkgs/stepmania/template
+++ b/srcpkgs/stepmania/template
@@ -1,28 +1,35 @@
 # Template file for 'stepmania'
 pkgname=stepmania
-version=5.0.12
-revision=2
+version=5.1.0
+revision=1
+archs="i686 x86_64"
 build_style=cmake
 cmake_builddir="Build"
 hostmakedepends="nasm yasm pkg-config git"
 makedepends="libmad-devel libvorbis-devel pcre-devel libjpeg-turbo-devel
-alsa-lib-devel libXrandr-devel libva-devel glew-devel"
+alsa-lib-devel libXrandr-devel libva-devel glew-devel pulseaudio-devel"
 short_desc="Advanced rhythm game"
-maintainer="Michael Aldridge <maldridge@voidlinux.org>"
+maintainer="Jason Manley <jason@jasondavid.tv>"
 license="MIT"
 homepage="http://www.stepmania.com/"
-distfiles="https://github.com/stepmania/stepmania/archive/v${version}.tar.gz"
-checksum=df79bcadd69d4ed60cf560d45386ec275181343495ffd744c3ff8f73c83d4755
+distfiles="https://github.com/stepmania/stepmania/archive/v${version}-b2.tar.gz"
+checksum=2e311df9b661ba287b046ce377eb0b41e426b73e169841df99fc9fe2baa89310
 
-# Upstream has stated that only x86 hardware can meed the performance
-# constraints and that musl is not supported due to interop issues
-# with Windows
-archs="i686 x86_64"
+post_extract() {
+	mv ${XBPS_BUILDDIR}/{stepmania-5.1.0-b2,stepmania-5.1.0}
+
+	sed -i 's/NOT OSS_FOUND AND NOT JACK_FOUND AND NOT ALSA_FOUND AND NOT PULSE_FOUND/NOT OSS_FOUND AND NOT JACK_FOUND AND NOT ALSA_FOUND AND NOT PULSEAUDIO_FOUND/g' ${XBPS_BUILDDIR}/stepmania-5.1.0/StepmaniaCore.cmake
+
+	for i in 16 22 24 32 36 48 64 72 96 128 192 256
+	do
+		vinstall ${XBPS_BUILDDIR}/stepmania-5.1.0/icons/hicolor/${i}x${i}/apps/stepmania-ssc.png 644 usr/share/icons/hicolor/${i}x${i}/apps stepmania-ssc.png
+	done
+	vinstall ${XBPS_BUILDDIR}/stepmania-5.1.0/stepmania.desktop 644 usr/share/applications stepmania.desktop
+}
 
 post_install() {
 	vlicense Docs/Licenses.txt
-
 	mkdir -p ${DESTDIR}/usr/bin
 	cd ${DESTDIR}
-	ln -sf ../../opt/stepmania-5.0/stepmania usr/bin/
+	ln -sf ../../opt/stepmania-5.1/stepmania usr/bin/
 }

^ permalink raw reply	[flat|nested] 35+ messages in thread

* Re: [PR REVIEW] stepmania: update to 5.1.0-b2
  2020-07-22 19:46 [PR PATCH] stepmania: update to 5.1.0-b2 jason1987d
@ 2020-07-22 19:59 ` ericonr
  2020-07-22 19:59 ` ericonr
                   ` (32 subsequent siblings)
  33 siblings, 0 replies; 35+ messages in thread
From: ericonr @ 2020-07-22 19:59 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 342 bytes --]

New review comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/pull/23747#discussion_r459045819

Comment:
Have you tried building for others? If it builds and their license doesn't forbid it, I don't see any issues. If it doesn't work, keep the comment about this being an upstream recommendation too.

^ permalink raw reply	[flat|nested] 35+ messages in thread

* Re: [PR REVIEW] stepmania: update to 5.1.0-b2
  2020-07-22 19:46 [PR PATCH] stepmania: update to 5.1.0-b2 jason1987d
                   ` (3 preceding siblings ...)
  2020-07-22 19:59 ` ericonr
@ 2020-07-22 19:59 ` ericonr
  2020-07-22 20:06 ` ericonr
                   ` (28 subsequent siblings)
  33 siblings, 0 replies; 35+ messages in thread
From: ericonr @ 2020-07-22 19:59 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 172 bytes --]

New review comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/pull/23747#discussion_r459045107

Comment:
`stepmania-${version%.*}`

^ permalink raw reply	[flat|nested] 35+ messages in thread

* Re: [PR REVIEW] stepmania: update to 5.1.0-b2
  2020-07-22 19:46 [PR PATCH] stepmania: update to 5.1.0-b2 jason1987d
  2020-07-22 19:59 ` [PR REVIEW] " ericonr
@ 2020-07-22 19:59 ` ericonr
  2020-07-22 19:59 ` ericonr
                   ` (31 subsequent siblings)
  33 siblings, 0 replies; 35+ messages in thread
From: ericonr @ 2020-07-22 19:59 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 221 bytes --]

New review comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/pull/23747#discussion_r459047871

Comment:
Use `vsed`. Could you have used `s/PULSE_FOUND/PULSEAUDIO_FOUND/` instead?

^ permalink raw reply	[flat|nested] 35+ messages in thread

* Re: [PR REVIEW] stepmania: update to 5.1.0-b2
  2020-07-22 19:46 [PR PATCH] stepmania: update to 5.1.0-b2 jason1987d
  2020-07-22 19:59 ` [PR REVIEW] " ericonr
  2020-07-22 19:59 ` ericonr
@ 2020-07-22 19:59 ` ericonr
  2020-07-22 19:59 ` ericonr
                   ` (30 subsequent siblings)
  33 siblings, 0 replies; 35+ messages in thread
From: ericonr @ 2020-07-22 19:59 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 165 bytes --]

New review comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/pull/23747#discussion_r459046798

Comment:
`version=5.1.0.b2`

^ permalink raw reply	[flat|nested] 35+ messages in thread

* Re: [PR REVIEW] stepmania: update to 5.1.0-b2
  2020-07-22 19:46 [PR PATCH] stepmania: update to 5.1.0-b2 jason1987d
                   ` (2 preceding siblings ...)
  2020-07-22 19:59 ` ericonr
@ 2020-07-22 19:59 ` ericonr
  2020-07-22 19:59 ` ericonr
                   ` (29 subsequent siblings)
  33 siblings, 0 replies; 35+ messages in thread
From: ericonr @ 2020-07-22 19:59 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 178 bytes --]

New review comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/pull/23747#discussion_r459047007

Comment:
`v${version%.*}-${version##*.}`

^ permalink raw reply	[flat|nested] 35+ messages in thread

* Re: [PR REVIEW] stepmania: update to 5.1.0-b2
  2020-07-22 19:46 [PR PATCH] stepmania: update to 5.1.0-b2 jason1987d
                   ` (5 preceding siblings ...)
  2020-07-22 20:06 ` ericonr
@ 2020-07-22 20:06 ` ericonr
  2020-07-22 20:08 ` ericonr
                   ` (26 subsequent siblings)
  33 siblings, 0 replies; 35+ messages in thread
From: ericonr @ 2020-07-22 20:06 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 197 bytes --]

New review comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/pull/23747#discussion_r459051574

Comment:
You can just set `wrksrc=${pkgname}-${version%.*}`

^ permalink raw reply	[flat|nested] 35+ messages in thread

* Re: [PR REVIEW] stepmania: update to 5.1.0-b2
  2020-07-22 19:46 [PR PATCH] stepmania: update to 5.1.0-b2 jason1987d
                   ` (4 preceding siblings ...)
  2020-07-22 19:59 ` ericonr
@ 2020-07-22 20:06 ` ericonr
  2020-07-22 20:06 ` ericonr
                   ` (27 subsequent siblings)
  33 siblings, 0 replies; 35+ messages in thread
From: ericonr @ 2020-07-22 20:06 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 182 bytes --]

New review comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/pull/23747#discussion_r459051739

Comment:
This shouldn't be necessary either.

^ permalink raw reply	[flat|nested] 35+ messages in thread

* Re: [PR REVIEW] stepmania: update to 5.1.0-b2
  2020-07-22 19:46 [PR PATCH] stepmania: update to 5.1.0-b2 jason1987d
                   ` (6 preceding siblings ...)
  2020-07-22 20:06 ` ericonr
@ 2020-07-22 20:08 ` ericonr
  2020-07-22 20:18 ` ericonr
                   ` (25 subsequent siblings)
  33 siblings, 0 replies; 35+ messages in thread
From: ericonr @ 2020-07-22 20:08 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 237 bytes --]

New review comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/pull/23747#discussion_r459053164

Comment:
I believe their stance on this has changed, btw. At least there are open issues about ARM.

^ permalink raw reply	[flat|nested] 35+ messages in thread

* Re: [PR REVIEW] stepmania: update to 5.1.0-b2
  2020-07-22 19:46 [PR PATCH] stepmania: update to 5.1.0-b2 jason1987d
                   ` (7 preceding siblings ...)
  2020-07-22 20:08 ` ericonr
@ 2020-07-22 20:18 ` ericonr
  2020-07-22 20:21 ` ericonr
                   ` (24 subsequent siblings)
  33 siblings, 0 replies; 35+ messages in thread
From: ericonr @ 2020-07-22 20:18 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 259 bytes --]

New review comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/pull/23747#discussion_r459058267

Comment:
Actually this one is now wrong.

`${version%.*.b*}` would work, I guess. Not sure what the best one to use is.

^ permalink raw reply	[flat|nested] 35+ messages in thread

* Re: [PR REVIEW] stepmania: update to 5.1.0-b2
  2020-07-22 19:46 [PR PATCH] stepmania: update to 5.1.0-b2 jason1987d
                   ` (8 preceding siblings ...)
  2020-07-22 20:18 ` ericonr
@ 2020-07-22 20:21 ` ericonr
  2020-07-23  2:31 ` [PR PATCH] [Updated] " jason1987d
                   ` (23 subsequent siblings)
  33 siblings, 0 replies; 35+ messages in thread
From: ericonr @ 2020-07-22 20:21 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 258 bytes --]

New review comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/pull/23747#discussion_r459058267

Comment:
Actually this one is now wrong.

`${version%.*.*}` would work, I guess. Not sure what the best one to use is.

^ permalink raw reply	[flat|nested] 35+ messages in thread

* Re: [PR PATCH] [Updated] stepmania: update to 5.1.0-b2
  2020-07-22 19:46 [PR PATCH] stepmania: update to 5.1.0-b2 jason1987d
                   ` (9 preceding siblings ...)
  2020-07-22 20:21 ` ericonr
@ 2020-07-23  2:31 ` jason1987d
  2020-07-23  2:32 ` jason1987d
                   ` (22 subsequent siblings)
  33 siblings, 0 replies; 35+ messages in thread
From: jason1987d @ 2020-07-23  2:31 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 723 bytes --]

There is an updated pull request by jason1987d against master on the void-packages repository

https://github.com/jason1987d/void-packages stepmania-5.1.0-b2
https://github.com/void-linux/void-packages/pull/23747

stepmania: update to 5.1.0-b2
The current version 5.0.12 results in an error "Fatal: crash from within the crash signal handler" upon running stepmania. From https://github.com/stepmania/stepmania/issues/1606 the suggested workaround is to use the 5.1 branch. The version 5.1-beta2 is technically a release that has been available for a long time. There are also 5.3 alpha releases, but this 5.1 I have tested to run.

A patch file from https://github.com/void-linux/void-packages/pull/23747.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-stepmania-5.1.0-b2-23747.patch --]
[-- Type: text/x-diff, Size: 2439 bytes --]

From 96f703f3f7cdf4228a20fd97276c0a953f396a81 Mon Sep 17 00:00:00 2001
From: Jason Manley <jason@jasondavid.tv>
Date: Wed, 22 Jul 2020 14:41:10 -0500
Subject: [PATCH] stepmania: update to 5.1.0-b2.

---
 srcpkgs/stepmania/template | 31 +++++++++++++++++++------------
 1 file changed, 19 insertions(+), 12 deletions(-)

diff --git a/srcpkgs/stepmania/template b/srcpkgs/stepmania/template
index 9ec2c4c2421..082456d62ba 100644
--- a/srcpkgs/stepmania/template
+++ b/srcpkgs/stepmania/template
@@ -1,28 +1,35 @@
 # Template file for 'stepmania'
 pkgname=stepmania
-version=5.0.12
-revision=2
+version=5.1.0
+revision=1
+archs="i686 x86_64"
 build_style=cmake
 cmake_builddir="Build"
 hostmakedepends="nasm yasm pkg-config git"
 makedepends="libmad-devel libvorbis-devel pcre-devel libjpeg-turbo-devel
-alsa-lib-devel libXrandr-devel libva-devel glew-devel"
+alsa-lib-devel libXrandr-devel libva-devel glew-devel pulseaudio-devel"
 short_desc="Advanced rhythm game"
-maintainer="Michael Aldridge <maldridge@voidlinux.org>"
+maintainer="Jason Manley <jason@jasondavid.tv>"
 license="MIT"
 homepage="http://www.stepmania.com/"
-distfiles="https://github.com/stepmania/stepmania/archive/v${version}.tar.gz"
-checksum=df79bcadd69d4ed60cf560d45386ec275181343495ffd744c3ff8f73c83d4755
+distfiles="https://github.com/stepmania/stepmania/archive/v${version}-b2.tar.gz"
+checksum=2e311df9b661ba287b046ce377eb0b41e426b73e169841df99fc9fe2baa89310
 
-# Upstream has stated that only x86 hardware can meed the performance
-# constraints and that musl is not supported due to interop issues
-# with Windows
-archs="i686 x86_64"
+post_extract() {
+	mv ${XBPS_BUILDDIR}/{stepmania-5.1.0-b2,stepmania-5.1.0}
+
+	sed -i 's/NOT OSS_FOUND AND NOT JACK_FOUND AND NOT ALSA_FOUND AND NOT PULSE_FOUND/NOT OSS_FOUND AND NOT JACK_FOUND AND NOT ALSA_FOUND AND NOT PULSEAUDIO_FOUND/g' ${XBPS_BUILDDIR}/stepmania-5.1.0/StepmaniaCore.cmake
+
+	for i in 16 22 24 32 36 48 64 72 96 128 192 256
+	do
+		vinstall ${XBPS_BUILDDIR}/stepmania-5.1.0/icons/hicolor/${i}x${i}/apps/stepmania-ssc.png 644 usr/share/icons/hicolor/${i}x${i}/apps stepmania-ssc.png
+	done
+	vinstall ${XBPS_BUILDDIR}/stepmania-5.1.0/stepmania.desktop 644 usr/share/applications stepmania.desktop
+}
 
 post_install() {
 	vlicense Docs/Licenses.txt
-
 	mkdir -p ${DESTDIR}/usr/bin
 	cd ${DESTDIR}
-	ln -sf ../../opt/stepmania-5.0/stepmania usr/bin/
+	ln -sf ../../opt/stepmania-5.1/stepmania usr/bin/
 }

^ permalink raw reply	[flat|nested] 35+ messages in thread

* Re: [PR PATCH] [Updated] stepmania: update to 5.1.0-b2
  2020-07-22 19:46 [PR PATCH] stepmania: update to 5.1.0-b2 jason1987d
                   ` (10 preceding siblings ...)
  2020-07-23  2:31 ` [PR PATCH] [Updated] " jason1987d
@ 2020-07-23  2:32 ` jason1987d
  2020-07-23  2:34 ` jason1987d
                   ` (21 subsequent siblings)
  33 siblings, 0 replies; 35+ messages in thread
From: jason1987d @ 2020-07-23  2:32 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 723 bytes --]

There is an updated pull request by jason1987d against master on the void-packages repository

https://github.com/jason1987d/void-packages stepmania-5.1.0-b2
https://github.com/void-linux/void-packages/pull/23747

stepmania: update to 5.1.0-b2
The current version 5.0.12 results in an error "Fatal: crash from within the crash signal handler" upon running stepmania. From https://github.com/stepmania/stepmania/issues/1606 the suggested workaround is to use the 5.1 branch. The version 5.1-beta2 is technically a release that has been available for a long time. There are also 5.3 alpha releases, but this 5.1 I have tested to run.

A patch file from https://github.com/void-linux/void-packages/pull/23747.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-stepmania-5.1.0-b2-23747.patch --]
[-- Type: text/x-diff, Size: 2463 bytes --]

From 371015f03b0b996fc41d46dde923c27cd5090927 Mon Sep 17 00:00:00 2001
From: Jason Manley <jason@jasondavid.tv>
Date: Wed, 22 Jul 2020 14:41:10 -0500
Subject: [PATCH] stepmania: update to 5.1.0-b2.

---
 srcpkgs/stepmania/template | 31 ++++++++++++++++++-------------
 1 file changed, 18 insertions(+), 13 deletions(-)

diff --git a/srcpkgs/stepmania/template b/srcpkgs/stepmania/template
index 9ec2c4c2421..57c929fefb2 100644
--- a/srcpkgs/stepmania/template
+++ b/srcpkgs/stepmania/template
@@ -1,28 +1,33 @@
 # Template file for 'stepmania'
 pkgname=stepmania
-version=5.0.12
-revision=2
+version=5.1.0.b2
+revision=1
+archs="i686 x86_64"
+# Upstream has stated that only x86 hardware can meed the performance constraints and that musl is not supported due to interop issues with Windows
 build_style=cmake
 cmake_builddir="Build"
 hostmakedepends="nasm yasm pkg-config git"
-makedepends="libmad-devel libvorbis-devel pcre-devel libjpeg-turbo-devel
-alsa-lib-devel libXrandr-devel libva-devel glew-devel"
+makedepends="libmad-devel libvorbis-devel pcre-devel libjpeg-turbo-devel alsa-lib-devel libXrandr-devel libva-devel glew-devel pulseaudio-devel"
 short_desc="Advanced rhythm game"
-maintainer="Michael Aldridge <maldridge@voidlinux.org>"
+maintainer="Jason Manley <jason@jasondavid.tv>"
 license="MIT"
 homepage="http://www.stepmania.com/"
-distfiles="https://github.com/stepmania/stepmania/archive/v${version}.tar.gz"
-checksum=df79bcadd69d4ed60cf560d45386ec275181343495ffd744c3ff8f73c83d4755
+distfiles="https://github.com/stepmania/stepmania/archive/v${version%.*}-${version##*.}.tar.gz"
+wrksrc=${pkgname}-${version%.*}
+checksum=2e311df9b661ba287b046ce377eb0b41e426b73e169841df99fc9fe2baa89310
 
-# Upstream has stated that only x86 hardware can meed the performance
-# constraints and that musl is not supported due to interop issues
-# with Windows
-archs="i686 x86_64"
+post_extract() {
+	vsed -i 's/PULSE_FOUND/PULSEAUDIO_FOUND/g' ${wrksrc}/StepmaniaCore.cmake
+	for i in 16 22 24 32 36 48 64 72 96 128 192 256
+	do
+		vinstall ${wrksrc}/icons/hicolor/${i}x${i}/apps/stepmania-ssc.png 644 usr/share/icons/hicolor/${i}x${i}/apps stepmania-ssc.png
+	done
+	vinstall ${wrksrc}/stepmania.desktop 644 usr/share/applications stepmania.desktop
+}
 
 post_install() {
 	vlicense Docs/Licenses.txt
-
 	mkdir -p ${DESTDIR}/usr/bin
 	cd ${DESTDIR}
-	ln -sf ../../opt/stepmania-5.0/stepmania usr/bin/
+	ln -sf ../../opt/${version%.*.*}/stepmania usr/bin/
 }

^ permalink raw reply	[flat|nested] 35+ messages in thread

* Re: stepmania: update to 5.1.0-b2
  2020-07-22 19:46 [PR PATCH] stepmania: update to 5.1.0-b2 jason1987d
                   ` (11 preceding siblings ...)
  2020-07-23  2:32 ` jason1987d
@ 2020-07-23  2:34 ` jason1987d
  2020-07-23  3:24 ` [PR PATCH] [Updated] " jason1987d
                   ` (20 subsequent siblings)
  33 siblings, 0 replies; 35+ messages in thread
From: jason1987d @ 2020-07-23  2:34 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 308 bytes --]

New comment by jason1987d on void-packages repository

https://github.com/void-linux/void-packages/pull/23747#issuecomment-662790752

Comment:
I made the changes you suggested, and it builds successfully. Figuring out the version shenanigans was tricky at first anyway, glad you could help make that proper.

^ permalink raw reply	[flat|nested] 35+ messages in thread

* Re: [PR PATCH] [Updated] stepmania: update to 5.1.0-b2
  2020-07-22 19:46 [PR PATCH] stepmania: update to 5.1.0-b2 jason1987d
                   ` (12 preceding siblings ...)
  2020-07-23  2:34 ` jason1987d
@ 2020-07-23  3:24 ` jason1987d
  2020-07-23  3:32 ` jason1987d
                   ` (19 subsequent siblings)
  33 siblings, 0 replies; 35+ messages in thread
From: jason1987d @ 2020-07-23  3:24 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 723 bytes --]

There is an updated pull request by jason1987d against master on the void-packages repository

https://github.com/jason1987d/void-packages stepmania-5.1.0-b2
https://github.com/void-linux/void-packages/pull/23747

stepmania: update to 5.1.0-b2
The current version 5.0.12 results in an error "Fatal: crash from within the crash signal handler" upon running stepmania. From https://github.com/stepmania/stepmania/issues/1606 the suggested workaround is to use the 5.1 branch. The version 5.1-beta2 is technically a release that has been available for a long time. There are also 5.3 alpha releases, but this 5.1 I have tested to run.

A patch file from https://github.com/void-linux/void-packages/pull/23747.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-stepmania-5.1.0-b2-23747.patch --]
[-- Type: text/x-diff, Size: 2463 bytes --]

From 084a8ab48fbc2470ddb9c7c4c77d91a18e1d257b Mon Sep 17 00:00:00 2001
From: Jason Manley <jason@jasondavid.tv>
Date: Wed, 22 Jul 2020 14:41:10 -0500
Subject: [PATCH] stepmania: update to 5.1.0-b2.

---
 srcpkgs/stepmania/template | 31 ++++++++++++++++++-------------
 1 file changed, 18 insertions(+), 13 deletions(-)

diff --git a/srcpkgs/stepmania/template b/srcpkgs/stepmania/template
index 9ec2c4c2421..73d26489771 100644
--- a/srcpkgs/stepmania/template
+++ b/srcpkgs/stepmania/template
@@ -1,28 +1,33 @@
 # Template file for 'stepmania'
 pkgname=stepmania
-version=5.0.12
-revision=2
+version=5.1.0.b2
+revision=1
+archs="i686 x86_64"
+# Upstream has stated that only x86 hardware can meed the performance constraints and that musl is not supported due to interop issues with Windows
+wrksrc=${pkgname}-${version%.*}
 build_style=cmake
 cmake_builddir="Build"
 hostmakedepends="nasm yasm pkg-config git"
-makedepends="libmad-devel libvorbis-devel pcre-devel libjpeg-turbo-devel
-alsa-lib-devel libXrandr-devel libva-devel glew-devel"
+makedepends="libmad-devel libvorbis-devel pcre-devel libjpeg-turbo-devel alsa-lib-devel libXrandr-devel libva-devel glew-devel pulseaudio-devel"
 short_desc="Advanced rhythm game"
-maintainer="Michael Aldridge <maldridge@voidlinux.org>"
+maintainer="Jason Manley <jason@jasondavid.tv>"
 license="MIT"
 homepage="http://www.stepmania.com/"
-distfiles="https://github.com/stepmania/stepmania/archive/v${version}.tar.gz"
-checksum=df79bcadd69d4ed60cf560d45386ec275181343495ffd744c3ff8f73c83d4755
+distfiles="https://github.com/stepmania/stepmania/archive/v${version%.*}-${version##*.}.tar.gz"
+checksum=2e311df9b661ba287b046ce377eb0b41e426b73e169841df99fc9fe2baa89310
 
-# Upstream has stated that only x86 hardware can meed the performance
-# constraints and that musl is not supported due to interop issues
-# with Windows
-archs="i686 x86_64"
+post_extract() {
+	vsed -i 's/PULSE_FOUND/PULSEAUDIO_FOUND/g' ${wrksrc}/StepmaniaCore.cmake
+	for i in 16 22 24 32 36 48 64 72 96 128 192 256
+	do
+		vinstall ${wrksrc}/icons/hicolor/${i}x${i}/apps/stepmania-ssc.png 644 usr/share/icons/hicolor/${i}x${i}/apps stepmania-ssc.png
+	done
+	vinstall ${wrksrc}/stepmania.desktop 644 usr/share/applications stepmania.desktop
+}
 
 post_install() {
 	vlicense Docs/Licenses.txt
-
 	mkdir -p ${DESTDIR}/usr/bin
 	cd ${DESTDIR}
-	ln -sf ../../opt/stepmania-5.0/stepmania usr/bin/
+	ln -sf ../../opt/${version%.*.*}/stepmania usr/bin/
 }

^ permalink raw reply	[flat|nested] 35+ messages in thread

* Re: stepmania: update to 5.1.0-b2
  2020-07-22 19:46 [PR PATCH] stepmania: update to 5.1.0-b2 jason1987d
                   ` (13 preceding siblings ...)
  2020-07-23  3:24 ` [PR PATCH] [Updated] " jason1987d
@ 2020-07-23  3:32 ` jason1987d
  2020-07-23  3:48 ` jason1987d
                   ` (18 subsequent siblings)
  33 siblings, 0 replies; 35+ messages in thread
From: jason1987d @ 2020-07-23  3:32 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 230 bytes --]

New comment by jason1987d on void-packages repository

https://github.com/void-linux/void-packages/pull/23747#issuecomment-662802346

Comment:
I spoke too soon. There still seems to be an issue on the wrksrc and version trickery.

^ permalink raw reply	[flat|nested] 35+ messages in thread

* Re: stepmania: update to 5.1.0-b2
  2020-07-22 19:46 [PR PATCH] stepmania: update to 5.1.0-b2 jason1987d
                   ` (14 preceding siblings ...)
  2020-07-23  3:32 ` jason1987d
@ 2020-07-23  3:48 ` jason1987d
  2020-07-23  4:13 ` [PR PATCH] [Updated] " jason1987d
                   ` (17 subsequent siblings)
  33 siblings, 0 replies; 35+ messages in thread
From: jason1987d @ 2020-07-23  3:48 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 305 bytes --]

New comment by jason1987d on void-packages repository

https://github.com/void-linux/void-packages/pull/23747#issuecomment-662802346

Comment:
I spoke too soon. There still seems to be an issue on the wrksrc and version trickery. But I am testing another regex for wrksrc that seems to be working so far.

^ permalink raw reply	[flat|nested] 35+ messages in thread

* Re: [PR PATCH] [Updated] stepmania: update to 5.1.0-b2
  2020-07-22 19:46 [PR PATCH] stepmania: update to 5.1.0-b2 jason1987d
                   ` (15 preceding siblings ...)
  2020-07-23  3:48 ` jason1987d
@ 2020-07-23  4:13 ` jason1987d
  2020-07-23  5:07 ` ericonr
                   ` (16 subsequent siblings)
  33 siblings, 0 replies; 35+ messages in thread
From: jason1987d @ 2020-07-23  4:13 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 723 bytes --]

There is an updated pull request by jason1987d against master on the void-packages repository

https://github.com/jason1987d/void-packages stepmania-5.1.0-b2
https://github.com/void-linux/void-packages/pull/23747

stepmania: update to 5.1.0-b2
The current version 5.0.12 results in an error "Fatal: crash from within the crash signal handler" upon running stepmania. From https://github.com/stepmania/stepmania/issues/1606 the suggested workaround is to use the 5.1 branch. The version 5.1-beta2 is technically a release that has been available for a long time. There are also 5.3 alpha releases, but this 5.1 I have tested to run.

A patch file from https://github.com/void-linux/void-packages/pull/23747.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-stepmania-5.1.0-b2-23747.patch --]
[-- Type: text/x-diff, Size: 2507 bytes --]

From 4bc8ed17a82f472241b6c92183f189c7e5e8d1ad Mon Sep 17 00:00:00 2001
From: Jason Manley <jason@jasondavid.tv>
Date: Wed, 22 Jul 2020 14:41:10 -0500
Subject: [PATCH] stepmania: update to 5.1.0-b2.

---
 srcpkgs/stepmania/template | 32 +++++++++++++++++++-------------
 1 file changed, 19 insertions(+), 13 deletions(-)

diff --git a/srcpkgs/stepmania/template b/srcpkgs/stepmania/template
index 9ec2c4c2421..b381a7f852a 100644
--- a/srcpkgs/stepmania/template
+++ b/srcpkgs/stepmania/template
@@ -1,28 +1,34 @@
 # Template file for 'stepmania'
 pkgname=stepmania
-version=5.0.12
-revision=2
+version=5.1.0.b2
+revision=1
+archs="i686 x86_64"
+# Upstream has stated that only x86 hardware can meed the performance constraints and that musl is not supported due to interop issues with Windows
+wrksrc=${pkgname}-${version%.*}-${version##*.}
 build_style=cmake
 cmake_builddir="Build"
 hostmakedepends="nasm yasm pkg-config git"
-makedepends="libmad-devel libvorbis-devel pcre-devel libjpeg-turbo-devel
-alsa-lib-devel libXrandr-devel libva-devel glew-devel"
+makedepends="libmad-devel libvorbis-devel pcre-devel libjpeg-turbo-devel alsa-lib-devel libXrandr-devel libva-devel glew-devel pulseaudio-devel"
 short_desc="Advanced rhythm game"
-maintainer="Michael Aldridge <maldridge@voidlinux.org>"
+maintainer="Jason Manley <jason@jasondavid.tv>"
 license="MIT"
 homepage="http://www.stepmania.com/"
-distfiles="https://github.com/stepmania/stepmania/archive/v${version}.tar.gz"
-checksum=df79bcadd69d4ed60cf560d45386ec275181343495ffd744c3ff8f73c83d4755
+distfiles="https://github.com/stepmania/stepmania/archive/v${version%.*}-${version##*.}.tar.gz"
+checksum=2e311df9b661ba287b046ce377eb0b41e426b73e169841df99fc9fe2baa89310
 
-# Upstream has stated that only x86 hardware can meed the performance
-# constraints and that musl is not supported due to interop issues
-# with Windows
-archs="i686 x86_64"
+post_extract() {
+	echo ${wrksrc}
+	vsed -i 's/PULSE_FOUND/PULSEAUDIO_FOUND/g' ${wrksrc}/StepmaniaCore.cmake
+	for i in 16 22 24 32 36 48 64 72 96 128 192 256
+	do
+		vinstall ${wrksrc}/icons/hicolor/${i}x${i}/apps/stepmania-ssc.png 644 usr/share/icons/hicolor/${i}x${i}/apps stepmania-ssc.png
+	done
+	vinstall ${wrksrc}/stepmania.desktop 644 usr/share/applications stepmania.desktop
+}
 
 post_install() {
 	vlicense Docs/Licenses.txt
-
 	mkdir -p ${DESTDIR}/usr/bin
 	cd ${DESTDIR}
-	ln -sf ../../opt/stepmania-5.0/stepmania usr/bin/
+	ln -sf ../../opt/${pkgname}-${version%.*.*}/stepmania usr/bin/
 }

^ permalink raw reply	[flat|nested] 35+ messages in thread

* Re: stepmania: update to 5.1.0-b2
  2020-07-22 19:46 [PR PATCH] stepmania: update to 5.1.0-b2 jason1987d
                   ` (16 preceding siblings ...)
  2020-07-23  4:13 ` [PR PATCH] [Updated] " jason1987d
@ 2020-07-23  5:07 ` ericonr
  2020-07-23 14:24 ` [PR PATCH] [Updated] " jason1987d
                   ` (15 subsequent siblings)
  33 siblings, 0 replies; 35+ messages in thread
From: ericonr @ 2020-07-23  5:07 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 3848 bytes --]

New comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/pull/23747#issuecomment-662820521

Comment:
So, @the-maldridge has to accept this beta version first. And I cleaned it up a bit and corrected some things for you:

```
diff --git a/srcpkgs/stepmania/template b/srcpkgs/stepmania/template
index b381a7f852..d5b78e5939 100644
--- a/srcpkgs/stepmania/template
+++ b/srcpkgs/stepmania/template
@@ -2,13 +2,13 @@
 pkgname=stepmania
 version=5.1.0.b2
 revision=1
+# compilation errors with musl
 archs="i686 x86_64"
-# Upstream has stated that only x86 hardware can meed the performance constraints and that musl is not supported due to interop issues with Windows
 wrksrc=${pkgname}-${version%.*}-${version##*.}
 build_style=cmake
-cmake_builddir="Build"
-hostmakedepends="nasm yasm pkg-config git"
-makedepends="libmad-devel libvorbis-devel pcre-devel libjpeg-turbo-devel alsa-lib-devel libXrandr-devel libva-devel glew-devel pulseaudio-devel"
+hostmakedepends="yasm pkg-config git"
+makedepends="libmad-devel libvorbis-devel pcre-devel libjpeg-turbo-devel
+ alsa-lib-devel libXrandr-devel libva-devel glew-devel pulseaudio-devel"
 short_desc="Advanced rhythm game"
 maintainer="Jason Manley <jason@jasondavid.tv>"
 license="MIT"
@@ -16,19 +16,19 @@ homepage="http://www.stepmania.com/"
 distfiles="https://github.com/stepmania/stepmania/archive/v${version%.*}-${version##*.}.tar.gz"
 checksum=2e311df9b661ba287b046ce377eb0b41e426b73e169841df99fc9fe2baa89310
 
-post_extract() {
-	echo ${wrksrc}
-	vsed -i 's/PULSE_FOUND/PULSEAUDIO_FOUND/g' ${wrksrc}/StepmaniaCore.cmake
+post_patch() {
+	vsed -i 's/PULSE_FOUND/PULSEAUDIO_FOUND/g' StepmaniaCore.cmake
+}
+
+post_install() {
 	for i in 16 22 24 32 36 48 64 72 96 128 192 256
 	do
-		vinstall ${wrksrc}/icons/hicolor/${i}x${i}/apps/stepmania-ssc.png 644 usr/share/icons/hicolor/${i}x${i}/apps stepmania-ssc.png
+		vinstall icons/hicolor/${i}x${i}/apps/stepmania-ssc.png 644 \
+			usr/share/icons/hicolor/${i}x${i}/apps stepmania-ssc.png
 	done
-	vinstall ${wrksrc}/stepmania.desktop 644 usr/share/applications stepmania.desktop
-}
 
-post_install() {
+	vinstall stepmania.desktop 644 usr/share/applications stepmania.desktop
 	vlicense Docs/Licenses.txt
-	mkdir -p ${DESTDIR}/usr/bin
-	cd ${DESTDIR}
-	ln -sf ../../opt/${pkgname}-${version%.*.*}/stepmania usr/bin/
+	vmkdir usr/bin
+	ln -sf ../../opt/${version%.*.*}/stepmania ${DESTDIR}/usr/bin/
 }
```

If you want, the final template looks like:

```
# Template file for 'stepmania'
pkgname=stepmania
version=5.1.0.b2
revision=1
# compilation errors with musl
archs="i686 x86_64"
wrksrc=${pkgname}-${version%.*}-${version##*.}
build_style=cmake
hostmakedepends="yasm pkg-config git"
makedepends="libmad-devel libvorbis-devel pcre-devel libjpeg-turbo-devel
 alsa-lib-devel libXrandr-devel libva-devel glew-devel pulseaudio-devel"
short_desc="Advanced rhythm game"
maintainer="Jason Manley <jason@jasondavid.tv>"
license="MIT"
homepage="http://www.stepmania.com/"
distfiles="https://github.com/stepmania/stepmania/archive/v${version%.*}-${version##*.}.tar.gz"
checksum=2e311df9b661ba287b046ce377eb0b41e426b73e169841df99fc9fe2baa89310

post_patch() {
	vsed -i 's/PULSE_FOUND/PULSEAUDIO_FOUND/g' StepmaniaCore.cmake
}

post_install() {
	for i in 16 22 24 32 36 48 64 72 96 128 192 256
	do
		vinstall icons/hicolor/${i}x${i}/apps/stepmania-ssc.png 644 \
			usr/share/icons/hicolor/${i}x${i}/apps stepmania-ssc.png
	done

	vinstall stepmania.desktop 644 usr/share/applications stepmania.desktop
	vlicense Docs/Licenses.txt
	vmkdir usr/bin
	ln -sf ../../opt/${version%.*.*}/stepmania ${DESTDIR}/usr/bin/
}
```

It's probably `nocross=yes` instead of restricting arches, but I don't have an easy way of testing that.

^ permalink raw reply	[flat|nested] 35+ messages in thread

* Re: [PR PATCH] [Updated] stepmania: update to 5.1.0-b2
  2020-07-22 19:46 [PR PATCH] stepmania: update to 5.1.0-b2 jason1987d
                   ` (17 preceding siblings ...)
  2020-07-23  5:07 ` ericonr
@ 2020-07-23 14:24 ` jason1987d
  2020-07-23 14:25 ` jason1987d
                   ` (14 subsequent siblings)
  33 siblings, 0 replies; 35+ messages in thread
From: jason1987d @ 2020-07-23 14:24 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 723 bytes --]

There is an updated pull request by jason1987d against master on the void-packages repository

https://github.com/jason1987d/void-packages stepmania-5.1.0-b2
https://github.com/void-linux/void-packages/pull/23747

stepmania: update to 5.1.0-b2
The current version 5.0.12 results in an error "Fatal: crash from within the crash signal handler" upon running stepmania. From https://github.com/stepmania/stepmania/issues/1606 the suggested workaround is to use the 5.1 branch. The version 5.1-beta2 is technically a release that has been available for a long time. There are also 5.3 alpha releases, but this 5.1 I have tested to run.

A patch file from https://github.com/void-linux/void-packages/pull/23747.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-stepmania-5.1.0-b2-23747.patch --]
[-- Type: text/x-diff, Size: 2425 bytes --]

From cae03cf63cfa7d783c1980a3bd038451ef923faf Mon Sep 17 00:00:00 2001
From: Jason Manley <jason@jasondavid.tv>
Date: Wed, 22 Jul 2020 14:41:10 -0500
Subject: [PATCH] stepmania: update to 5.1.0-b2.

---
 srcpkgs/stepmania/template | 38 ++++++++++++++++++++++----------------
 1 file changed, 22 insertions(+), 16 deletions(-)

diff --git a/srcpkgs/stepmania/template b/srcpkgs/stepmania/template
index 9ec2c4c2421..865e19585ef 100644
--- a/srcpkgs/stepmania/template
+++ b/srcpkgs/stepmania/template
@@ -1,28 +1,34 @@
 # Template file for 'stepmania'
 pkgname=stepmania
-version=5.0.12
-revision=2
+version=5.1.0.b2
+revision=1
+# compilation errors with musl
+archs="i686 x86_64"
+wrksrc=${pkgname}-${version%.*}-${version##*.}
 build_style=cmake
 cmake_builddir="Build"
-hostmakedepends="nasm yasm pkg-config git"
-makedepends="libmad-devel libvorbis-devel pcre-devel libjpeg-turbo-devel
-alsa-lib-devel libXrandr-devel libva-devel glew-devel"
+hostmakedepends="yasm pkg-config git"
+makedepends="libmad-devel libvorbis-devel pcre-devel libjpeg-turbo-devel 
+ alsa-lib-devel libXrandr-devel libva-devel glew-devel pulseaudio-devel"
 short_desc="Advanced rhythm game"
-maintainer="Michael Aldridge <maldridge@voidlinux.org>"
+maintainer="Jason Manley <jason@jasondavid.tv>"
 license="MIT"
 homepage="http://www.stepmania.com/"
-distfiles="https://github.com/stepmania/stepmania/archive/v${version}.tar.gz"
-checksum=df79bcadd69d4ed60cf560d45386ec275181343495ffd744c3ff8f73c83d4755
+distfiles="https://github.com/stepmania/stepmania/archive/v${version%.*}-${version##*.}.tar.gz"
+checksum=2e311df9b661ba287b046ce377eb0b41e426b73e169841df99fc9fe2baa89310
 
-# Upstream has stated that only x86 hardware can meed the performance
-# constraints and that musl is not supported due to interop issues
-# with Windows
-archs="i686 x86_64"
+post_patch() {
+	vsed -i 's/PULSE_FOUND/PULSEAUDIO_FOUND/g' ${wrksrc}/StepmaniaCore.cmake
+}
 
 post_install() {
+	for i in 16 22 24 32 36 48 64 72 96 128 192 256
+	do
+		vinstall icons/hicolor/${i}x${i}/apps/stepmania-ssc.png 644 \
+			usr/share/icons/hicolor/${i}x${i}/apps stepmania-ssc.png
+	done
+	vinstall stepmania.desktop 644 usr/share/applications stepmania.desktop
 	vlicense Docs/Licenses.txt
-
-	mkdir -p ${DESTDIR}/usr/bin
-	cd ${DESTDIR}
-	ln -sf ../../opt/stepmania-5.0/stepmania usr/bin/
+	vmkdir -p usr/bin
+	ln -sf ../../opt/${pkgname}-${version%.*.*}/stepmania usr/bin/
 }

^ permalink raw reply	[flat|nested] 35+ messages in thread

* Re: stepmania: update to 5.1.0-b2
  2020-07-22 19:46 [PR PATCH] stepmania: update to 5.1.0-b2 jason1987d
                   ` (18 preceding siblings ...)
  2020-07-23 14:24 ` [PR PATCH] [Updated] " jason1987d
@ 2020-07-23 14:25 ` jason1987d
  2020-07-23 14:28 ` ericonr
                   ` (13 subsequent siblings)
  33 siblings, 0 replies; 35+ messages in thread
From: jason1987d @ 2020-07-23 14:25 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 303 bytes --]

New comment by jason1987d on void-packages repository

https://github.com/void-linux/void-packages/pull/23747#issuecomment-663037834

Comment:
Your template looks good, except for the last line with the symlink. The directory is /opt/stepmania-5.1 , your version creates /opt/5.1 which is a stale link.

^ permalink raw reply	[flat|nested] 35+ messages in thread

* Re: stepmania: update to 5.1.0-b2
  2020-07-22 19:46 [PR PATCH] stepmania: update to 5.1.0-b2 jason1987d
                   ` (19 preceding siblings ...)
  2020-07-23 14:25 ` jason1987d
@ 2020-07-23 14:28 ` ericonr
  2020-07-23 15:53 ` jason1987d
                   ` (12 subsequent siblings)
  33 siblings, 0 replies; 35+ messages in thread
From: ericonr @ 2020-07-23 14:28 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 189 bytes --]

New comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/pull/23747#issuecomment-663039172

Comment:
Oops, that was an artifact! Thanks for noticing.

^ permalink raw reply	[flat|nested] 35+ messages in thread

* Re: stepmania: update to 5.1.0-b2
  2020-07-22 19:46 [PR PATCH] stepmania: update to 5.1.0-b2 jason1987d
                   ` (20 preceding siblings ...)
  2020-07-23 14:28 ` ericonr
@ 2020-07-23 15:53 ` jason1987d
  2020-07-23 16:02 ` [PR PATCH] [Updated] " jason1987d
                   ` (11 subsequent siblings)
  33 siblings, 0 replies; 35+ messages in thread
From: jason1987d @ 2020-07-23 15:53 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 239 bytes --]

New comment by jason1987d on void-packages repository

https://github.com/void-linux/void-packages/pull/23747#issuecomment-663086185

Comment:
Although now I'm faced with an error in post_install:
/bin/install: invalid mode ‘usr/bin’

^ permalink raw reply	[flat|nested] 35+ messages in thread

* Re: [PR PATCH] [Updated] stepmania: update to 5.1.0-b2
  2020-07-22 19:46 [PR PATCH] stepmania: update to 5.1.0-b2 jason1987d
                   ` (21 preceding siblings ...)
  2020-07-23 15:53 ` jason1987d
@ 2020-07-23 16:02 ` jason1987d
  2020-07-23 16:13 ` [PR REVIEW] " ericonr
                   ` (10 subsequent siblings)
  33 siblings, 0 replies; 35+ messages in thread
From: jason1987d @ 2020-07-23 16:02 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 723 bytes --]

There is an updated pull request by jason1987d against master on the void-packages repository

https://github.com/jason1987d/void-packages stepmania-5.1.0-b2
https://github.com/void-linux/void-packages/pull/23747

stepmania: update to 5.1.0-b2
The current version 5.0.12 results in an error "Fatal: crash from within the crash signal handler" upon running stepmania. From https://github.com/stepmania/stepmania/issues/1606 the suggested workaround is to use the 5.1 branch. The version 5.1-beta2 is technically a release that has been available for a long time. There are also 5.3 alpha releases, but this 5.1 I have tested to run.

A patch file from https://github.com/void-linux/void-packages/pull/23747.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-stepmania-5.1.0-b2-23747.patch --]
[-- Type: text/x-diff, Size: 2348 bytes --]

From 7055743e8a8ba8176f55e1336c030140d96c513d Mon Sep 17 00:00:00 2001
From: Jason Manley <jason@jasondavid.tv>
Date: Wed, 22 Jul 2020 14:41:10 -0500
Subject: [PATCH] stepmania: update to 5.1.0-b2.

---
 srcpkgs/stepmania/template | 36 +++++++++++++++++++++---------------
 1 file changed, 21 insertions(+), 15 deletions(-)

diff --git a/srcpkgs/stepmania/template b/srcpkgs/stepmania/template
index 9ec2c4c2421..bd72e8668e2 100644
--- a/srcpkgs/stepmania/template
+++ b/srcpkgs/stepmania/template
@@ -1,28 +1,34 @@
 # Template file for 'stepmania'
 pkgname=stepmania
-version=5.0.12
-revision=2
+version=5.1.0.b2
+revision=1
+# compilation errors with musl
+archs="i686 x86_64"
+wrksrc=${pkgname}-${version%.*}-${version##*.}
 build_style=cmake
 cmake_builddir="Build"
-hostmakedepends="nasm yasm pkg-config git"
+hostmakedepends="yasm pkg-config git"
 makedepends="libmad-devel libvorbis-devel pcre-devel libjpeg-turbo-devel
-alsa-lib-devel libXrandr-devel libva-devel glew-devel"
+ alsa-lib-devel libXrandr-devel libva-devel glew-devel pulseaudio-devel"
 short_desc="Advanced rhythm game"
-maintainer="Michael Aldridge <maldridge@voidlinux.org>"
+maintainer="Jason Manley <jason@jasondavid.tv>"
 license="MIT"
 homepage="http://www.stepmania.com/"
-distfiles="https://github.com/stepmania/stepmania/archive/v${version}.tar.gz"
-checksum=df79bcadd69d4ed60cf560d45386ec275181343495ffd744c3ff8f73c83d4755
+distfiles="https://github.com/stepmania/stepmania/archive/v${version%.*}-${version##*.}.tar.gz"
+checksum=2e311df9b661ba287b046ce377eb0b41e426b73e169841df99fc9fe2baa89310
 
-# Upstream has stated that only x86 hardware can meed the performance
-# constraints and that musl is not supported due to interop issues
-# with Windows
-archs="i686 x86_64"
+post_patch() {
+	vsed -i 's/PULSE_FOUND/PULSEAUDIO_FOUND/g' ${wrksrc}/StepmaniaCore.cmake
+}
 
 post_install() {
+	for i in 16 22 24 32 36 48 64 72 96 128 192 256
+	do
+		vinstall icons/hicolor/${i}x${i}/apps/stepmania-ssc.png 644 \
+			usr/share/icons/hicolor/${i}x${i}/apps stepmania-ssc.png
+	done
+	vinstall stepmania.desktop 644 usr/share/applications stepmania.desktop
 	vlicense Docs/Licenses.txt
-
-	mkdir -p ${DESTDIR}/usr/bin
-	cd ${DESTDIR}
-	ln -sf ../../opt/stepmania-5.0/stepmania usr/bin/
+	vmkdir -p usr/bin
+	ln -sf ../../opt/${pkgname}-${version%.*.*}/stepmania usr/bin/
 }

^ permalink raw reply	[flat|nested] 35+ messages in thread

* Re: [PR REVIEW] stepmania: update to 5.1.0-b2
  2020-07-22 19:46 [PR PATCH] stepmania: update to 5.1.0-b2 jason1987d
                   ` (22 preceding siblings ...)
  2020-07-23 16:02 ` [PR PATCH] [Updated] " jason1987d
@ 2020-07-23 16:13 ` ericonr
  2020-07-23 16:20 ` [PR PATCH] [Updated] " jason1987d
                   ` (9 subsequent siblings)
  33 siblings, 0 replies; 35+ messages in thread
From: ericonr @ 2020-07-23 16:13 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 175 bytes --]

New review comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/pull/23747#discussion_r459567104

Comment:
you don't need the `-p` flag

^ permalink raw reply	[flat|nested] 35+ messages in thread

* Re: [PR PATCH] [Updated] stepmania: update to 5.1.0-b2
  2020-07-22 19:46 [PR PATCH] stepmania: update to 5.1.0-b2 jason1987d
                   ` (23 preceding siblings ...)
  2020-07-23 16:13 ` [PR REVIEW] " ericonr
@ 2020-07-23 16:20 ` jason1987d
  2020-07-23 16:54 ` [PR REVIEW] " jason1987d
                   ` (8 subsequent siblings)
  33 siblings, 0 replies; 35+ messages in thread
From: jason1987d @ 2020-07-23 16:20 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 723 bytes --]

There is an updated pull request by jason1987d against master on the void-packages repository

https://github.com/jason1987d/void-packages stepmania-5.1.0-b2
https://github.com/void-linux/void-packages/pull/23747

stepmania: update to 5.1.0-b2
The current version 5.0.12 results in an error "Fatal: crash from within the crash signal handler" upon running stepmania. From https://github.com/stepmania/stepmania/issues/1606 the suggested workaround is to use the 5.1 branch. The version 5.1-beta2 is technically a release that has been available for a long time. There are also 5.3 alpha releases, but this 5.1 I have tested to run.

A patch file from https://github.com/void-linux/void-packages/pull/23747.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-stepmania-5.1.0-b2-23747.patch --]
[-- Type: text/x-diff, Size: 2345 bytes --]

From 3fb50f1ae1a92079f21d8235cfd6d311da8afc53 Mon Sep 17 00:00:00 2001
From: Jason Manley <jason@jasondavid.tv>
Date: Wed, 22 Jul 2020 14:41:10 -0500
Subject: [PATCH] stepmania: update to 5.1.0-b2.

---
 srcpkgs/stepmania/template | 36 +++++++++++++++++++++---------------
 1 file changed, 21 insertions(+), 15 deletions(-)

diff --git a/srcpkgs/stepmania/template b/srcpkgs/stepmania/template
index 9ec2c4c2421..cb7a1862660 100644
--- a/srcpkgs/stepmania/template
+++ b/srcpkgs/stepmania/template
@@ -1,28 +1,34 @@
 # Template file for 'stepmania'
 pkgname=stepmania
-version=5.0.12
-revision=2
+version=5.1.0.b2
+revision=1
+# compilation errors with musl
+archs="i686 x86_64"
+wrksrc=${pkgname}-${version%.*}-${version##*.}
 build_style=cmake
 cmake_builddir="Build"
-hostmakedepends="nasm yasm pkg-config git"
+hostmakedepends="yasm pkg-config git"
 makedepends="libmad-devel libvorbis-devel pcre-devel libjpeg-turbo-devel
-alsa-lib-devel libXrandr-devel libva-devel glew-devel"
+ alsa-lib-devel libXrandr-devel libva-devel glew-devel pulseaudio-devel"
 short_desc="Advanced rhythm game"
-maintainer="Michael Aldridge <maldridge@voidlinux.org>"
+maintainer="Jason Manley <jason@jasondavid.tv>"
 license="MIT"
 homepage="http://www.stepmania.com/"
-distfiles="https://github.com/stepmania/stepmania/archive/v${version}.tar.gz"
-checksum=df79bcadd69d4ed60cf560d45386ec275181343495ffd744c3ff8f73c83d4755
+distfiles="https://github.com/stepmania/stepmania/archive/v${version%.*}-${version##*.}.tar.gz"
+checksum=2e311df9b661ba287b046ce377eb0b41e426b73e169841df99fc9fe2baa89310
 
-# Upstream has stated that only x86 hardware can meed the performance
-# constraints and that musl is not supported due to interop issues
-# with Windows
-archs="i686 x86_64"
+post_patch() {
+	vsed -i 's/PULSE_FOUND/PULSEAUDIO_FOUND/g' ${wrksrc}/StepmaniaCore.cmake
+}
 
 post_install() {
+	for i in 16 22 24 32 36 48 64 72 96 128 192 256
+	do
+		vinstall icons/hicolor/${i}x${i}/apps/stepmania-ssc.png 644 \
+			usr/share/icons/hicolor/${i}x${i}/apps stepmania-ssc.png
+	done
+	vinstall stepmania.desktop 644 usr/share/applications stepmania.desktop
 	vlicense Docs/Licenses.txt
-
-	mkdir -p ${DESTDIR}/usr/bin
-	cd ${DESTDIR}
-	ln -sf ../../opt/stepmania-5.0/stepmania usr/bin/
+	vmkdir usr/bin
+	ln -sf ../../opt/${pkgname}-${version%.*.*}/stepmania usr/bin/
 }

^ permalink raw reply	[flat|nested] 35+ messages in thread

* Re: [PR REVIEW] stepmania: update to 5.1.0-b2
  2020-07-22 19:46 [PR PATCH] stepmania: update to 5.1.0-b2 jason1987d
                   ` (24 preceding siblings ...)
  2020-07-23 16:20 ` [PR PATCH] [Updated] " jason1987d
@ 2020-07-23 16:54 ` jason1987d
  2020-07-23 18:05 ` jason1987d
                   ` (7 subsequent siblings)
  33 siblings, 0 replies; 35+ messages in thread
From: jason1987d @ 2020-07-23 16:54 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 301 bytes --]

New review comment by jason1987d on void-packages repository

https://github.com/void-linux/void-packages/pull/23747#discussion_r459591695

Comment:
I think the actual error is with the ln -sf ../../opt/${version%.*.*}/stepmania ${DESTDIR}/usr/bin/ version regex here.... maybe ${version%.*} instead?

^ permalink raw reply	[flat|nested] 35+ messages in thread

* Re: [PR REVIEW] stepmania: update to 5.1.0-b2
  2020-07-22 19:46 [PR PATCH] stepmania: update to 5.1.0-b2 jason1987d
                   ` (25 preceding siblings ...)
  2020-07-23 16:54 ` [PR REVIEW] " jason1987d
@ 2020-07-23 18:05 ` jason1987d
  2020-07-23 19:46 ` [PR PATCH] [Updated] " jason1987d
                   ` (6 subsequent siblings)
  33 siblings, 0 replies; 35+ messages in thread
From: jason1987d @ 2020-07-23 18:05 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 331 bytes --]

New review comment by jason1987d on void-packages repository

https://github.com/void-linux/void-packages/pull/23747#discussion_r459633066

Comment:
However, I think I might just hardcode the version as ${pkgname}-5.1 as the version number will have a different format over time (eventually to 5.3.x) on the stepmania development.

^ permalink raw reply	[flat|nested] 35+ messages in thread

* Re: [PR PATCH] [Updated] stepmania: update to 5.1.0-b2
  2020-07-22 19:46 [PR PATCH] stepmania: update to 5.1.0-b2 jason1987d
                   ` (26 preceding siblings ...)
  2020-07-23 18:05 ` jason1987d
@ 2020-07-23 19:46 ` jason1987d
  2020-07-23 19:46 ` jason1987d
                   ` (5 subsequent siblings)
  33 siblings, 0 replies; 35+ messages in thread
From: jason1987d @ 2020-07-23 19:46 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 723 bytes --]

There is an updated pull request by jason1987d against master on the void-packages repository

https://github.com/jason1987d/void-packages stepmania-5.1.0-b2
https://github.com/void-linux/void-packages/pull/23747

stepmania: update to 5.1.0-b2
The current version 5.0.12 results in an error "Fatal: crash from within the crash signal handler" upon running stepmania. From https://github.com/stepmania/stepmania/issues/1606 the suggested workaround is to use the 5.1 branch. The version 5.1-beta2 is technically a release that has been available for a long time. There are also 5.3 alpha releases, but this 5.1 I have tested to run.

A patch file from https://github.com/void-linux/void-packages/pull/23747.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-stepmania-5.1.0-b2-23747.patch --]
[-- Type: text/x-diff, Size: 2345 bytes --]

From 27091a5b3748aabf3aad9925901d5aec2bb1d7df Mon Sep 17 00:00:00 2001
From: Jason Manley <jason@jasondavid.tv>
Date: Wed, 22 Jul 2020 14:41:10 -0500
Subject: [PATCH] stepmania: update to 5.1.0-b2.

---
 srcpkgs/stepmania/template | 36 +++++++++++++++++++++---------------
 1 file changed, 21 insertions(+), 15 deletions(-)

diff --git a/srcpkgs/stepmania/template b/srcpkgs/stepmania/template
index 9ec2c4c2421..cb7a1862660 100644
--- a/srcpkgs/stepmania/template
+++ b/srcpkgs/stepmania/template
@@ -1,28 +1,34 @@
 # Template file for 'stepmania'
 pkgname=stepmania
-version=5.0.12
-revision=2
+version=5.1.0.b2
+revision=1
+# compilation errors with musl
+archs="i686 x86_64"
+wrksrc=${pkgname}-${version%.*}-${version##*.}
 build_style=cmake
 cmake_builddir="Build"
-hostmakedepends="nasm yasm pkg-config git"
+hostmakedepends="yasm pkg-config git"
 makedepends="libmad-devel libvorbis-devel pcre-devel libjpeg-turbo-devel
-alsa-lib-devel libXrandr-devel libva-devel glew-devel"
+ alsa-lib-devel libXrandr-devel libva-devel glew-devel pulseaudio-devel"
 short_desc="Advanced rhythm game"
-maintainer="Michael Aldridge <maldridge@voidlinux.org>"
+maintainer="Jason Manley <jason@jasondavid.tv>"
 license="MIT"
 homepage="http://www.stepmania.com/"
-distfiles="https://github.com/stepmania/stepmania/archive/v${version}.tar.gz"
-checksum=df79bcadd69d4ed60cf560d45386ec275181343495ffd744c3ff8f73c83d4755
+distfiles="https://github.com/stepmania/stepmania/archive/v${version%.*}-${version##*.}.tar.gz"
+checksum=2e311df9b661ba287b046ce377eb0b41e426b73e169841df99fc9fe2baa89310
 
-# Upstream has stated that only x86 hardware can meed the performance
-# constraints and that musl is not supported due to interop issues
-# with Windows
-archs="i686 x86_64"
+post_patch() {
+	vsed -i 's/PULSE_FOUND/PULSEAUDIO_FOUND/g' ${wrksrc}/StepmaniaCore.cmake
+}
 
 post_install() {
+	for i in 16 22 24 32 36 48 64 72 96 128 192 256
+	do
+		vinstall icons/hicolor/${i}x${i}/apps/stepmania-ssc.png 644 \
+			usr/share/icons/hicolor/${i}x${i}/apps stepmania-ssc.png
+	done
+	vinstall stepmania.desktop 644 usr/share/applications stepmania.desktop
 	vlicense Docs/Licenses.txt
-
-	mkdir -p ${DESTDIR}/usr/bin
-	cd ${DESTDIR}
-	ln -sf ../../opt/stepmania-5.0/stepmania usr/bin/
+	vmkdir usr/bin
+	ln -sf ../../opt/${pkgname}-${version%.*.*}/stepmania usr/bin/
 }

^ permalink raw reply	[flat|nested] 35+ messages in thread

* Re: [PR PATCH] [Updated] stepmania: update to 5.1.0-b2
  2020-07-22 19:46 [PR PATCH] stepmania: update to 5.1.0-b2 jason1987d
                   ` (27 preceding siblings ...)
  2020-07-23 19:46 ` [PR PATCH] [Updated] " jason1987d
@ 2020-07-23 19:46 ` jason1987d
  2020-07-23 20:21 ` jason1987d
                   ` (4 subsequent siblings)
  33 siblings, 0 replies; 35+ messages in thread
From: jason1987d @ 2020-07-23 19:46 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 723 bytes --]

There is an updated pull request by jason1987d against master on the void-packages repository

https://github.com/jason1987d/void-packages stepmania-5.1.0-b2
https://github.com/void-linux/void-packages/pull/23747

stepmania: update to 5.1.0-b2
The current version 5.0.12 results in an error "Fatal: crash from within the crash signal handler" upon running stepmania. From https://github.com/stepmania/stepmania/issues/1606 the suggested workaround is to use the 5.1 branch. The version 5.1-beta2 is technically a release that has been available for a long time. There are also 5.3 alpha releases, but this 5.1 I have tested to run.

A patch file from https://github.com/void-linux/void-packages/pull/23747.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-stepmania-5.1.0-b2-23747.patch --]
[-- Type: text/x-diff, Size: 2339 bytes --]

From 2e9a377af0a7fc68eff3885effad25ccad428c15 Mon Sep 17 00:00:00 2001
From: Jason Manley <jason@jasondavid.tv>
Date: Wed, 22 Jul 2020 14:41:10 -0500
Subject: [PATCH] stepmania: update to 5.1.0-b2.

---
 srcpkgs/stepmania/template | 35 +++++++++++++++++++++--------------
 1 file changed, 21 insertions(+), 14 deletions(-)

diff --git a/srcpkgs/stepmania/template b/srcpkgs/stepmania/template
index 9ec2c4c2421..def8bd1f5de 100644
--- a/srcpkgs/stepmania/template
+++ b/srcpkgs/stepmania/template
@@ -1,28 +1,35 @@
 # Template file for 'stepmania'
 pkgname=stepmania
-version=5.0.12
-revision=2
+version=5.1.0.b2
+revision=1
+# compilation errors with musl
+archs="i686 x86_64"
+wrksrc=${pkgname}-${version%.*}-${version##*.}
 build_style=cmake
 cmake_builddir="Build"
-hostmakedepends="nasm yasm pkg-config git"
+hostmakedepends="yasm pkg-config git"
 makedepends="libmad-devel libvorbis-devel pcre-devel libjpeg-turbo-devel
-alsa-lib-devel libXrandr-devel libva-devel glew-devel"
+ alsa-lib-devel libXrandr-devel libva-devel glew-devel pulseaudio-devel"
 short_desc="Advanced rhythm game"
-maintainer="Michael Aldridge <maldridge@voidlinux.org>"
+maintainer="Jason Manley <jason@jasondavid.tv>"
 license="MIT"
 homepage="http://www.stepmania.com/"
-distfiles="https://github.com/stepmania/stepmania/archive/v${version}.tar.gz"
-checksum=df79bcadd69d4ed60cf560d45386ec275181343495ffd744c3ff8f73c83d4755
+distfiles="https://github.com/stepmania/stepmania/archive/v${version%.*}-${version##*.}.tar.gz"
+checksum=2e311df9b661ba287b046ce377eb0b41e426b73e169841df99fc9fe2baa89310
 
-# Upstream has stated that only x86 hardware can meed the performance
-# constraints and that musl is not supported due to interop issues
-# with Windows
-archs="i686 x86_64"
+post_patch() {
+	vsed -i 's/PULSE_FOUND/PULSEAUDIO_FOUND/g' ${wrksrc}/StepmaniaCore.cmake
+}
 
 post_install() {
+	for i in 16 22 24 32 36 48 64 72 96 128 192 256
+	do
+		vinstall icons/hicolor/${i}x${i}/apps/stepmania-ssc.png 644 \
+			usr/share/icons/hicolor/${i}x${i}/apps stepmania-ssc.png
+	done
+	vinstall stepmania.desktop 644 usr/share/applications stepmania.desktop
 	vlicense Docs/Licenses.txt
-
 	mkdir -p ${DESTDIR}/usr/bin
-	cd ${DESTDIR}
-	ln -sf ../../opt/stepmania-5.0/stepmania usr/bin/
+        cd ${DESTDIR}
+        ln -sf /opt/stepmania-5.1/stepmania usr/bin/
 }

^ permalink raw reply	[flat|nested] 35+ messages in thread

* Re: [PR PATCH] [Updated] stepmania: update to 5.1.0-b2
  2020-07-22 19:46 [PR PATCH] stepmania: update to 5.1.0-b2 jason1987d
                   ` (28 preceding siblings ...)
  2020-07-23 19:46 ` jason1987d
@ 2020-07-23 20:21 ` jason1987d
  2020-11-09  4:18 ` jason1987d
                   ` (3 subsequent siblings)
  33 siblings, 0 replies; 35+ messages in thread
From: jason1987d @ 2020-07-23 20:21 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 723 bytes --]

There is an updated pull request by jason1987d against master on the void-packages repository

https://github.com/jason1987d/void-packages stepmania-5.1.0-b2
https://github.com/void-linux/void-packages/pull/23747

stepmania: update to 5.1.0-b2
The current version 5.0.12 results in an error "Fatal: crash from within the crash signal handler" upon running stepmania. From https://github.com/stepmania/stepmania/issues/1606 the suggested workaround is to use the 5.1 branch. The version 5.1-beta2 is technically a release that has been available for a long time. There are also 5.3 alpha releases, but this 5.1 I have tested to run.

A patch file from https://github.com/void-linux/void-packages/pull/23747.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-stepmania-5.1.0-b2-23747.patch --]
[-- Type: text/x-diff, Size: 2348 bytes --]

From d17fe43eabf3839a3cfa829167c6b1902eab7294 Mon Sep 17 00:00:00 2001
From: Jason Manley <jason@jasondavid.tv>
Date: Wed, 22 Jul 2020 14:41:10 -0500
Subject: [PATCH] stepmania: update to 5.1.0-b2.

---
 srcpkgs/stepmania/template | 35 ++++++++++++++++++++---------------
 1 file changed, 20 insertions(+), 15 deletions(-)

diff --git a/srcpkgs/stepmania/template b/srcpkgs/stepmania/template
index 9ec2c4c2421..0db238ba84b 100644
--- a/srcpkgs/stepmania/template
+++ b/srcpkgs/stepmania/template
@@ -1,28 +1,33 @@
 # Template file for 'stepmania'
 pkgname=stepmania
-version=5.0.12
-revision=2
+version=5.1.0.b2
+revision=1
+# compilation errors with musl
+archs="i686 x86_64"
+wrksrc=${pkgname}-${version%.*}-${version##*.}
 build_style=cmake
 cmake_builddir="Build"
-hostmakedepends="nasm yasm pkg-config git"
+hostmakedepends="yasm pkg-config git"
 makedepends="libmad-devel libvorbis-devel pcre-devel libjpeg-turbo-devel
-alsa-lib-devel libXrandr-devel libva-devel glew-devel"
+ alsa-lib-devel libXrandr-devel libva-devel glew-devel pulseaudio-devel"
 short_desc="Advanced rhythm game"
-maintainer="Michael Aldridge <maldridge@voidlinux.org>"
+maintainer="Jason Manley <jason@jasondavid.tv>"
 license="MIT"
 homepage="http://www.stepmania.com/"
-distfiles="https://github.com/stepmania/stepmania/archive/v${version}.tar.gz"
-checksum=df79bcadd69d4ed60cf560d45386ec275181343495ffd744c3ff8f73c83d4755
+distfiles="https://github.com/stepmania/stepmania/archive/v${version%.*}-${version##*.}.tar.gz"
+checksum=2e311df9b661ba287b046ce377eb0b41e426b73e169841df99fc9fe2baa89310
 
-# Upstream has stated that only x86 hardware can meed the performance
-# constraints and that musl is not supported due to interop issues
-# with Windows
-archs="i686 x86_64"
+post_patch() {
+	vsed -i 's/PULSE_FOUND/PULSEAUDIO_FOUND/g' ${wrksrc}/StepmaniaCore.cmake
+}
 
 post_install() {
+	for i in 16 22 24 32 36 48 64 72 96 128 192 256
+	do
+		vinstall icons/hicolor/${i}x${i}/apps/stepmania-ssc.png 644 \
+			usr/share/icons/hicolor/${i}x${i}/apps stepmania-ssc.png
+	done
+	vsed -i 's/Exec=stepmania/Exec=\/opt\/stepmania-5.1\/stepmania/g' stepmania.desktop
+	vinstall stepmania.desktop 644 usr/share/applications stepmania.desktop
 	vlicense Docs/Licenses.txt
-
-	mkdir -p ${DESTDIR}/usr/bin
-	cd ${DESTDIR}
-	ln -sf ../../opt/stepmania-5.0/stepmania usr/bin/
 }

^ permalink raw reply	[flat|nested] 35+ messages in thread

* Re: stepmania: update to 5.1.0-b2
  2020-07-22 19:46 [PR PATCH] stepmania: update to 5.1.0-b2 jason1987d
                   ` (29 preceding siblings ...)
  2020-07-23 20:21 ` jason1987d
@ 2020-11-09  4:18 ` jason1987d
  2020-11-09  4:18 ` jason1987d
                   ` (2 subsequent siblings)
  33 siblings, 0 replies; 35+ messages in thread
From: jason1987d @ 2020-11-09  4:18 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 318 bytes --]

New comment by jason1987d on void-packages repository

https://github.com/void-linux/void-packages/pull/23747#issuecomment-723744228

Comment:
Haven't heard on this in awhile. Stepmania development has moved a little forward as well, 5.3 alpha 4.9.1 is the official release from a new team for this Project Moondance.

^ permalink raw reply	[flat|nested] 35+ messages in thread

* Re: stepmania: update to 5.1.0-b2
  2020-07-22 19:46 [PR PATCH] stepmania: update to 5.1.0-b2 jason1987d
                   ` (30 preceding siblings ...)
  2020-11-09  4:18 ` jason1987d
@ 2020-11-09  4:18 ` jason1987d
  2020-11-09 13:10 ` ericonr
  2020-11-21 18:24 ` [PR PATCH] [Closed]: " jason1987d
  33 siblings, 0 replies; 35+ messages in thread
From: jason1987d @ 2020-11-09  4:18 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 261 bytes --]

New comment by jason1987d on void-packages repository

https://github.com/void-linux/void-packages/pull/23747#issuecomment-723744331

Comment:
I will clarify on my last comment, this version 5.1.0-b2 technically works whereas the "current" 5.0.12 does not run.

^ permalink raw reply	[flat|nested] 35+ messages in thread

* Re: stepmania: update to 5.1.0-b2
  2020-07-22 19:46 [PR PATCH] stepmania: update to 5.1.0-b2 jason1987d
                   ` (31 preceding siblings ...)
  2020-11-09  4:18 ` jason1987d
@ 2020-11-09 13:10 ` ericonr
  2020-11-21 18:24 ` [PR PATCH] [Closed]: " jason1987d
  33 siblings, 0 replies; 35+ messages in thread
From: ericonr @ 2020-11-09 13:10 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 310 bytes --]

New comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/pull/23747#issuecomment-724002610

Comment:
Sorry about the delay here. I think @the-maldridge didnt' want to move to a beta release, which is why I stopped messing with it.

What's this about Project Moondance?

^ permalink raw reply	[flat|nested] 35+ messages in thread

* Re: [PR PATCH] [Closed]: stepmania: update to 5.1.0-b2
  2020-07-22 19:46 [PR PATCH] stepmania: update to 5.1.0-b2 jason1987d
                   ` (32 preceding siblings ...)
  2020-11-09 13:10 ` ericonr
@ 2020-11-21 18:24 ` jason1987d
  33 siblings, 0 replies; 35+ messages in thread
From: jason1987d @ 2020-11-21 18:24 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 550 bytes --]

There's a closed pull request on the void-packages repository

stepmania: update to 5.1.0-b2
https://github.com/void-linux/void-packages/pull/23747

Description:
The current version 5.0.12 results in an error "Fatal: crash from within the crash signal handler" upon running stepmania. From https://github.com/stepmania/stepmania/issues/1606 the suggested workaround is to use the 5.1 branch. The version 5.1-beta2 is technically a release that has been available for a long time. There are also 5.3 alpha releases, but this 5.1 I have tested to run.

^ permalink raw reply	[flat|nested] 35+ messages in thread

end of thread, other threads:[~2020-11-21 18:24 UTC | newest]

Thread overview: 35+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-07-22 19:46 [PR PATCH] stepmania: update to 5.1.0-b2 jason1987d
2020-07-22 19:59 ` [PR REVIEW] " ericonr
2020-07-22 19:59 ` ericonr
2020-07-22 19:59 ` ericonr
2020-07-22 19:59 ` ericonr
2020-07-22 19:59 ` ericonr
2020-07-22 20:06 ` ericonr
2020-07-22 20:06 ` ericonr
2020-07-22 20:08 ` ericonr
2020-07-22 20:18 ` ericonr
2020-07-22 20:21 ` ericonr
2020-07-23  2:31 ` [PR PATCH] [Updated] " jason1987d
2020-07-23  2:32 ` jason1987d
2020-07-23  2:34 ` jason1987d
2020-07-23  3:24 ` [PR PATCH] [Updated] " jason1987d
2020-07-23  3:32 ` jason1987d
2020-07-23  3:48 ` jason1987d
2020-07-23  4:13 ` [PR PATCH] [Updated] " jason1987d
2020-07-23  5:07 ` ericonr
2020-07-23 14:24 ` [PR PATCH] [Updated] " jason1987d
2020-07-23 14:25 ` jason1987d
2020-07-23 14:28 ` ericonr
2020-07-23 15:53 ` jason1987d
2020-07-23 16:02 ` [PR PATCH] [Updated] " jason1987d
2020-07-23 16:13 ` [PR REVIEW] " ericonr
2020-07-23 16:20 ` [PR PATCH] [Updated] " jason1987d
2020-07-23 16:54 ` [PR REVIEW] " jason1987d
2020-07-23 18:05 ` jason1987d
2020-07-23 19:46 ` [PR PATCH] [Updated] " jason1987d
2020-07-23 19:46 ` jason1987d
2020-07-23 20:21 ` jason1987d
2020-11-09  4:18 ` jason1987d
2020-11-09  4:18 ` jason1987d
2020-11-09 13:10 ` ericonr
2020-11-21 18:24 ` [PR PATCH] [Closed]: " jason1987d

Github messages for voidlinux

This inbox may be cloned and mirrored by anyone:

	git clone --mirror http://inbox.vuxu.org/voidlinux-github

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V1 voidlinux-github voidlinux-github/ http://inbox.vuxu.org/voidlinux-github \
		voidlinux-github@inbox.vuxu.org
	public-inbox-index voidlinux-github

Example config snippet for mirrors.
Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.github.voidlinux


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git