Github messages for voidlinux
 help / color / Atom feed
* [PR PATCH] [WIP] New package: teams-1.3.00.16851
@ 2020-07-30  3:55 jason1987d
  2020-07-30  6:22 ` sgn
  2020-07-30  6:22 ` [PR PATCH] [Closed]: " sgn
  0 siblings, 2 replies; 3+ messages in thread
From: jason1987d @ 2020-07-30  3:55 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 2443 bytes --]

There is a new pull request by jason1987d against master on the void-packages repository

https://github.com/jason1987d/void-packages teams-1.3.00.16851
https://github.com/void-linux/void-packages/pull/23941

[WIP] New package: teams-1.3.00.16851
Main error right now that has me stuck is ...
`=> teams-1.3.00.16851_1: running post-install hook: 11-pkglint-elf-in-usrshare ...
=> ERROR: teams-1.3.00.16851_1: ELF files found in /usr/share:
=> ERROR:    /usr/share/libEGL.so
=> ERROR:    /usr/share/teams
=> ERROR:    /usr/share/libGLESv2.so
=> ERROR:    /usr/share/libffmpeg.so
=> ERROR:    /usr/share/swiftshader/libEGL.so
=> ERROR:    /usr/share/swiftshader/libGLESv2.so
=> ERROR:    /usr/share/resources/app.asar.unpacked/node_modules/node-spellcheckr/build/Release/spellchecker.node
=> ERROR:    /usr/share/resources/app.asar.unpacked/node_modules/keytar3/build/Release/keytar.node
=> ERROR:    /usr/share/resources/app.asar.unpacked/node_modules/keytar4/build/Release/keytar.node
=> ERROR:    /usr/share/resources/app.asar.unpacked/node_modules/v8-profiler-next/build/Release/profiler.node
=> ERROR:    /usr/share/resources/app.asar.unpacked/node_modules/@msteams/node-locale-info-provider/build/Release/node-locale-info-provider.node
=> ERROR:    /usr/share/resources/app.asar.unpacked/node_modules/@msteams/electron-modules-package-utils/build/Release/package-utils.node
=> ERROR:    /usr/share/resources/app.asar.unpacked/node_modules/media-hid/build/Release/media-hid.node
=> ERROR:    /usr/share/resources/app.asar.unpacked/node_modules/slimcore/bin/slimcore.node
=> ERROR:    /usr/share/resources/app.asar.unpacked/node_modules/slimcore/bin/sharing-indicator.node
=> ERROR:    /usr/share/resources/app.asar.unpacked/node_modules/slimcore/bin/rect-overlay
=> ERROR:    /usr/share/resources/app.asar.unpacked/node_modules/keyboard-layout/build/Release/keyboard-layout-manager.node
=> ERROR:    /usr/share/resources/app.asar.unpacked/node_modules/native-utils/build/Release/native-utils.node
=> ERROR:    /usr/share/resources/app.asar.unpacked/node_modules/modern-osutils/build/Release/modern-osutils.node
=> ERROR:    /usr/share/resources/app.asar.unpacked/node_modules/@microsoft/fasttext-languagedetector/build/Release/fastText-languagedetector.node
=> ERROR: teams-1.3.00.16851_1: cannot continue with installation!`

A patch file from https://github.com/void-linux/void-packages/pull/23941.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-teams-1.3.00.16851-23941.patch --]
[-- Type: text/x-diff, Size: 2526 bytes --]

From 2dc8e42155ae1070b3945585089ba0368189528d Mon Sep 17 00:00:00 2001
From: Jason Manley <jason@jasondavid.tv>
Date: Wed, 29 Jul 2020 22:53:35 -0500
Subject: [PATCH] New package: teams-1.3.00.16851

---
 srcpkgs/teams/template | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)
 create mode 100644 srcpkgs/teams/template

diff --git a/srcpkgs/teams/template b/srcpkgs/teams/template
new file mode 100644
index 00000000000..a3204a7262b
--- /dev/null
+++ b/srcpkgs/teams/template
@@ -0,0 +1,32 @@
+# Template file for 'teams'
+pkgname=teams
+version=1.3.00.16851
+revision=1
+archs="x86_64"
+#build_style=fetch
+# depends = libasound2 (>= 1.0.16), libatk-bridge2.0-0 (>= 2.5.3), libatk1.0-0 (>= 1.12.4), libc6 (>= 2.17), libcairo2 (>= 1.10.0), libcups2 (>= 1.4.0), libexpat1 (>= 2.0.1), libgcc1 (>= 1:3.0), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.35.8), libgtk-3-0 (>= 3.10.0), libnspr4 (>= 2:4.9-2~), libnss3 (>= 2:3.22), libpango-1.0-0 (>= 1.14.0), libpangocairo-1.0-0 (>= 1.14.0), libuuid1 (>= 2.16), libx11-6 (>= 2:1.4.99.1), libx11-xcb1, libxcb1 (>= 1.6), libxcomposite1 (>= 1:0.3-1), libxcursor1 (>> 1.1.2), libxdamage1 (>= 1:1.1), libxext6, libxfixes3, libxi6 (>= 2:1.2.99.4), libxrandr2 (>= 2:1.2.99.3), libxrender1, libxss1, libxtst6, apt-transport-https, libfontconfig1 (>= 2.11.0), libdbus-1-3 (>= 1.6.18), libstdc++6 (>= 4.8.1)
+depends="libsndfile alsa-lib atk glibc cairo libcups expat libgcc gdk-pixbuf glib gtk+3 nspr nss pango libuuid libX11 libxcb libXcomposite libXcursor libXdamage libXext libXfixes libXrender libXt libXtst fontconfig dbus libstdc++"
+short_desc="Microsoft Teams client for Linux"
+maintainer="Jason Manley <jason@jasondavid.tv>"
+license="custom:Microsoft"
+homepage="https://www.microsoft.com/teams"
+# way to get around this usage of amd64 vs x86_64 ? symlink amd64.sh in common/cross-profiles ?
+distfiles="https://packages.microsoft.com/repos/ms-teams/pool/main/t/${pkgname}/${pkgname}_${version}_amd64.deb"
+checksum=23838c8f8dea4960dce8bba559cd7ee3cdedc78ea7fdb226139b5b2204eee4d6
+repository=nonfree
+restricted=yes
+nostrip=yes
+
+do_extract() {
+	ar x ${XBPS_SRCDISTDIR}/${pkgname}-${version}/${pkgname}_${version}_amd64.deb
+	bsdtar -xf data.tar.xz
+}
+
+do_install() {
+	#vmkdir usr/share usr/bin
+	vbin usr/bin/teams 755 usr/bin/teams
+	vcopy usr/share/teams usr/share/
+	vinstall usr/share/applications/teams.desktop 644 usr/share/applications
+	vinstall usr/share/pixmaps/teams.png 644 usr/share/pixmaps
+	vlicense usr/share/teams/LICENSE
+}

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [WIP] New package: teams-1.3.00.16851
  2020-07-30  3:55 [PR PATCH] [WIP] New package: teams-1.3.00.16851 jason1987d
@ 2020-07-30  6:22 ` sgn
  2020-07-30  6:22 ` [PR PATCH] [Closed]: " sgn
  1 sibling, 0 replies; 3+ messages in thread
From: sgn @ 2020-07-30  6:22 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 267 bytes --]

New comment by sgn on void-packages repository

https://github.com/void-linux/void-packages/pull/23941#issuecomment-666149895

Comment:
We shipped `teams` as `teams-bin`. See https://github.com/void-linux/void-packages/commit/2226a4750b768adb2ac06d5f1698bdaa9671c262

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PR PATCH] [Closed]: [WIP] New package: teams-1.3.00.16851
  2020-07-30  3:55 [PR PATCH] [WIP] New package: teams-1.3.00.16851 jason1987d
  2020-07-30  6:22 ` sgn
@ 2020-07-30  6:22 ` sgn
  1 sibling, 0 replies; 3+ messages in thread
From: sgn @ 2020-07-30  6:22 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 2275 bytes --]

There's a closed pull request on the void-packages repository

[WIP] New package: teams-1.3.00.16851
https://github.com/void-linux/void-packages/pull/23941

Description:
Main error right now that has me stuck is ...
`=> teams-1.3.00.16851_1: running post-install hook: 11-pkglint-elf-in-usrshare ...
=> ERROR: teams-1.3.00.16851_1: ELF files found in /usr/share:
=> ERROR:    /usr/share/libEGL.so
=> ERROR:    /usr/share/teams
=> ERROR:    /usr/share/libGLESv2.so
=> ERROR:    /usr/share/libffmpeg.so
=> ERROR:    /usr/share/swiftshader/libEGL.so
=> ERROR:    /usr/share/swiftshader/libGLESv2.so
=> ERROR:    /usr/share/resources/app.asar.unpacked/node_modules/node-spellcheckr/build/Release/spellchecker.node
=> ERROR:    /usr/share/resources/app.asar.unpacked/node_modules/keytar3/build/Release/keytar.node
=> ERROR:    /usr/share/resources/app.asar.unpacked/node_modules/keytar4/build/Release/keytar.node
=> ERROR:    /usr/share/resources/app.asar.unpacked/node_modules/v8-profiler-next/build/Release/profiler.node
=> ERROR:    /usr/share/resources/app.asar.unpacked/node_modules/@msteams/node-locale-info-provider/build/Release/node-locale-info-provider.node
=> ERROR:    /usr/share/resources/app.asar.unpacked/node_modules/@msteams/electron-modules-package-utils/build/Release/package-utils.node
=> ERROR:    /usr/share/resources/app.asar.unpacked/node_modules/media-hid/build/Release/media-hid.node
=> ERROR:    /usr/share/resources/app.asar.unpacked/node_modules/slimcore/bin/slimcore.node
=> ERROR:    /usr/share/resources/app.asar.unpacked/node_modules/slimcore/bin/sharing-indicator.node
=> ERROR:    /usr/share/resources/app.asar.unpacked/node_modules/slimcore/bin/rect-overlay
=> ERROR:    /usr/share/resources/app.asar.unpacked/node_modules/keyboard-layout/build/Release/keyboard-layout-manager.node
=> ERROR:    /usr/share/resources/app.asar.unpacked/node_modules/native-utils/build/Release/native-utils.node
=> ERROR:    /usr/share/resources/app.asar.unpacked/node_modules/modern-osutils/build/Release/modern-osutils.node
=> ERROR:    /usr/share/resources/app.asar.unpacked/node_modules/@microsoft/fasttext-languagedetector/build/Release/fastText-languagedetector.node
=> ERROR: teams-1.3.00.16851_1: cannot continue with installation!`

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, back to index

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-07-30  3:55 [PR PATCH] [WIP] New package: teams-1.3.00.16851 jason1987d
2020-07-30  6:22 ` sgn
2020-07-30  6:22 ` [PR PATCH] [Closed]: " sgn

Github messages for voidlinux

Archives are clonable: git clone --mirror http://inbox.vuxu.org/voidlinux-github

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.github.voidlinux


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git