Github messages for voidlinux
 help / color / mirror / Atom feed
* [PR PATCH] bootiso: add bc depedencies
@ 2020-10-13  1:44 hervyqa
  2020-10-17  4:21 ` [PR PATCH] [Updated] " hervyqa
  0 siblings, 1 reply; 2+ messages in thread
From: hervyqa @ 2020-10-13  1:44 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 311 bytes --]

There is a new pull request by hervyqa against master on the void-packages repository

https://github.com/hervyqa/void-packages master
https://github.com/void-linux/void-packages/pull/25555

bootiso: add bc depedencies


A patch file from https://github.com/void-linux/void-packages/pull/25555.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-master-25555.patch --]
[-- Type: text/x-diff, Size: 881 bytes --]

From 6d476e260a96994739883059b2be7f7393c0c190 Mon Sep 17 00:00:00 2001
From: hervyqa <hervyqa@protonmail.com>
Date: Tue, 13 Oct 2020 08:41:04 +0700
Subject: [PATCH] bootiso: add bc depedencies

---
 srcpkgs/bootiso/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/bootiso/template b/srcpkgs/bootiso/template
index 78a6205c546..2c2c9e6e335 100644
--- a/srcpkgs/bootiso/template
+++ b/srcpkgs/bootiso/template
@@ -5,7 +5,7 @@ revision=1
 archs=noarch
 build_style=gnu-makefile
 make_install_args="prefix=/usr"
-depends="bash binutils coreutils curl dosfstools e2fsprogs eudev exfat-utils
+depends="bash bc binutils coreutils curl dosfstools e2fsprogs eudev exfat-utils
  f2fs-tools file findutils gawk grep ncurses ntfs-3g rsync syslinux tar util-linux
  wimlib jq"
 short_desc="Create a USB bootable device from an ISO image easily and securely"

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: [PR PATCH] [Updated] bootiso: add bc depedencies
  2020-10-13  1:44 [PR PATCH] bootiso: add bc depedencies hervyqa
@ 2020-10-17  4:21 ` hervyqa
  0 siblings, 0 replies; 2+ messages in thread
From: hervyqa @ 2020-10-17  4:21 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 316 bytes --]

There is an updated pull request by hervyqa against master on the void-packages repository

https://github.com/hervyqa/void-packages master
https://github.com/void-linux/void-packages/pull/25555

bootiso: add bc depedencies


A patch file from https://github.com/void-linux/void-packages/pull/25555.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-master-25555.patch --]
[-- Type: text/x-diff, Size: 424520 bytes --]

From 6d476e260a96994739883059b2be7f7393c0c190 Mon Sep 17 00:00:00 2001
From: hervyqa <hervyqa@protonmail.com>
Date: Tue, 13 Oct 2020 08:41:04 +0700
Subject: [PATCH 001/312] bootiso: add bc depedencies

---
 srcpkgs/bootiso/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/bootiso/template b/srcpkgs/bootiso/template
index 78a6205c546..2c2c9e6e335 100644
--- a/srcpkgs/bootiso/template
+++ b/srcpkgs/bootiso/template
@@ -5,7 +5,7 @@ revision=1
 archs=noarch
 build_style=gnu-makefile
 make_install_args="prefix=/usr"
-depends="bash binutils coreutils curl dosfstools e2fsprogs eudev exfat-utils
+depends="bash bc binutils coreutils curl dosfstools e2fsprogs eudev exfat-utils
  f2fs-tools file findutils gawk grep ncurses ntfs-3g rsync syslinux tar util-linux
  wimlib jq"
 short_desc="Create a USB bootable device from an ISO image easily and securely"

From 4ef3d3d7e4f7d83167d447f6ac31be01236c24f2 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?J=C3=BCrgen=20Buchm=C3=BCller?= <pullmoll@t-online.de>
Date: Tue, 13 Oct 2020 09:49:33 +0200
Subject: [PATCH 002/312] kea: update to 1.9.0

---
 common/shlibs        | 16 ++++++++--------
 srcpkgs/kea/template |  4 ++--
 2 files changed, 10 insertions(+), 10 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index e0a61266068..1a12253c004 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -2951,25 +2951,25 @@ libkj-async-0.7.0.so capnproto-0.7.0_1
 libkj-test-0.7.0.so capnproto-0.7.0_1
 libkj-0.7.0.so capnproto-0.7.0_1
 libkea-asiodns.so.1 libkea-1.7.0_1
-libkea-asiolink.so.9 libkea-1.8.0_1
+libkea-asiolink.so.19 libkea-1.9.0_1
 libkea-cc.so.8 libkea-1.6.0_1
 libkea-cfgclient.so.10 libkea-1.8.0_1
 libkea-cryptolink.so.5 libkea-1.7.0_1
 libkea-database.so.6 libkea-1.8.0_1
-libkea-dhcp++.so.19 libkea-1.8.0_1
+libkea-dhcp++.so.30 libkea-1.9.0_1
 libkea-dhcp_ddns.so.3 libkea-1.8.0_1
-libkea-dhcpsrv.so.27 libkea-1.8.0_1
+libkea-dhcpsrv.so.38 libkea-1.9.0_1
 libkea-dns++.so.5 libkea-1.8.0_1
-libkea-eval.so.12 libkea-1.7.0_1
+libkea-eval.so.22 libkea-1.9.0_1
 libkea-exceptions.so.0 libkea-1.1.0_1
-libkea-hooks.so.15 libkea-1.7.10_1
-libkea-http.so.7 libkea-1.8.0_1
+libkea-hooks.so.26 libkea-1.9.0_1
+libkea-http.so.18 libkea-1.9.0_1
 libkea-log.so.6 libkea-1.7.9_1
 libkea-pgsql.so.4 libkea-1.8.0_1
 libkea-process.so.11 libkea-1.8.0_1
-libkea-stats.so.6 libkea-1.7.10_1
+libkea-stats.so.16 libkea-1.9.0_1
 libkea-util-io.so.0 libkea-1.1.0_1
-libkea-util.so.16 libkea-1.8.0_1
+libkea-util.so.26 libkea-1.9.0_1
 libytnef.so.0 ytnef-1.8_1
 libpisock.so.9 pilot-link-0.12.5_1
 libpisync.so.1 pilot-link-0.12.5_1
diff --git a/srcpkgs/kea/template b/srcpkgs/kea/template
index bede2fed6db..d4785b7edb7 100644
--- a/srcpkgs/kea/template
+++ b/srcpkgs/kea/template
@@ -1,6 +1,6 @@
 # Template file for 'kea'
 pkgname=kea
-version=1.8.0
+version=1.9.0
 revision=1
 build_style=gnu-configure
 configure_args="--enable-generate-docs --with-openssl=${XBPS_CROSS_BASE}/usr
@@ -20,7 +20,7 @@ maintainer="Jürgen Buchmüller <pullmoll@t-online.de>"
 license="MPL-2.0, Apache-2.0"
 homepage="https://kea.isc.org"
 distfiles="http://ftp.isc.org/isc/kea/${version/.P/-P}/kea-${version/.P/-P}.tar.gz"
-checksum=3d91106fba3698194fb80da4149af709c7b2e89881311522816e561fca0ec0ea
+checksum=4ca801b474aa392156c9480e56d12490b5c514fe3ea4a17d70ebf9fb30ff44e3
 
 build_options="botan mysql pgsql"
 desc_option_botan="With Botan SSL support"

From 63ed7fdb44423d23b8dc6393fed42187882d1cf5 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Tue, 13 Oct 2020 07:45:57 -0400
Subject: [PATCH 003/312] Solaar: update to 1.0.3.

---
 srcpkgs/Solaar/template | 11 +++--------
 1 file changed, 3 insertions(+), 8 deletions(-)

diff --git a/srcpkgs/Solaar/template b/srcpkgs/Solaar/template
index 1ba1c2ea72c..aaa5af639fc 100644
--- a/srcpkgs/Solaar/template
+++ b/srcpkgs/Solaar/template
@@ -1,7 +1,7 @@
 # Template file for 'Solaar'
 pkgname=Solaar
-version=1.0.2
-revision=2
+version=1.0.3
+revision=1
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-pyudev"
@@ -10,9 +10,4 @@ maintainer="Young Jin Park <youngjinpark20@gmail.com>"
 license="GPL-3.0-or-later"
 homepage="https://pwr-solaar.github.io/Solaar/"
 distfiles="https://github.com/pwr-Solaar/Solaar/archive/${version}.tar.gz"
-checksum=fd5898264b12f48270f1a7a4f437b97483a14f2aca71383a8c513d8ed536fd41
-
-post_install() {
-	vmkdir usr/lib/udev
-	mv ${DESTDIR}/etc/udev/rules.d ${DESTDIR}/usr/lib/udev
-}
+checksum=f4712eac64a7b0c53d68863a47293dcf04ef0d21481147e03b594df933ecdae9

From f4d3e5f90428d785a7344e69508ee663514a3c34 Mon Sep 17 00:00:00 2001
From: Piraty <piraty1@inbox.ru>
Date: Tue, 13 Oct 2020 14:46:27 +0200
Subject: [PATCH 004/312] go-for-it: update to 1.8.6.

---
 srcpkgs/go-for-it/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/go-for-it/template b/srcpkgs/go-for-it/template
index 35558baccdb..e6d281782d9 100644
--- a/srcpkgs/go-for-it/template
+++ b/srcpkgs/go-for-it/template
@@ -1,6 +1,6 @@
 # Template file for 'go-for-it'
 pkgname=go-for-it
-version=1.8.5
+version=1.8.6
 revision=1
 wrksrc="Go-For-It-${version}"
 build_style=cmake
@@ -11,4 +11,4 @@ maintainer="Piraty <piraty1@inbox.ru>"
 license="GPL-3.0-only"
 homepage="https://github.com/JMoerman/Go-For-It"
 distfiles="https://github.com/JMoerman/Go-For-It/archive/${version}.tar.gz"
-checksum=f3f91d8f11f1401ab808f58696bc813aa892ea9781bc76ed29e33aaaec87bfbd
+checksum=7da5396b253797a051f906301286799ab1cfacf713e6e24f5557bfb182a8f019

From af1a37dc05fe5076d381a829f1976d073ea13bb6 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Tue, 13 Oct 2020 19:59:02 +0700
Subject: [PATCH 005/312] udiskie: rebuild for Python 3.9

---
 srcpkgs/udiskie/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/udiskie/template b/srcpkgs/udiskie/template
index 47c25a730c1..4eaa6717861 100644
--- a/srcpkgs/udiskie/template
+++ b/srcpkgs/udiskie/template
@@ -1,7 +1,7 @@
 # Template file for 'udiskie'
 pkgname=udiskie
 version=2.2.0
-revision=2
+revision=3
 build_style=python3-module
 hostmakedepends="gettext python3-setuptools python3-gobject"
 depends="gtk+3 libnotify python3-docopt python3-gobject python3-keyutils

From 4fdd043dbe239b07ff10fcb57cf66bbed5c94a48 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Tue, 13 Oct 2020 20:11:04 +0700
Subject: [PATCH 006/312] jrnl: rebuild for Python 3.9

---
 srcpkgs/jrnl/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/jrnl/template b/srcpkgs/jrnl/template
index 032ba2a3c06..c94d555e829 100644
--- a/srcpkgs/jrnl/template
+++ b/srcpkgs/jrnl/template
@@ -1,7 +1,7 @@
 # Template file for 'jrnl'
 pkgname=jrnl
 version=1.9.8
-revision=5
+revision=6
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-cryptography python3-dateutil python3-keyring

From 0b02ac4e527af694a1a3069ab778dfaa14d42ac8 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Tue, 13 Oct 2020 20:11:04 +0700
Subject: [PATCH 007/312] PhotoCollage: rebuild for Python 3.9

---
 srcpkgs/PhotoCollage/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/PhotoCollage/template b/srcpkgs/PhotoCollage/template
index 39c24a430be..964603cf90c 100644
--- a/srcpkgs/PhotoCollage/template
+++ b/srcpkgs/PhotoCollage/template
@@ -1,7 +1,7 @@
 # Template file for 'PhotoCollage'
 pkgname=PhotoCollage
 version=1.4.4
-revision=3
+revision=4
 build_style=python3-module
 hostmakedepends="gettext python3"
 depends="python3-Pillow python3-gobject"

From 4ef41de36445326f56722d390e453c2cacdba454 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Tue, 13 Oct 2020 20:11:04 +0700
Subject: [PATCH 008/312] onionshare: rebuild for Python 3.9

---
 srcpkgs/onionshare/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/onionshare/template b/srcpkgs/onionshare/template
index b9d4fe0fafb..4a175464893 100644
--- a/srcpkgs/onionshare/template
+++ b/srcpkgs/onionshare/template
@@ -1,7 +1,7 @@
 # Template file for 'onionshare'
 pkgname=onionshare
 version=2.2
-revision=4
+revision=5
 build_style=python3-module
 pycompile_dirs="/usr/share/nautilus-python/extensions"
 hostmakedepends="python3-setuptools"

From 8fc22c421ce6c45ae5e48e38fb8bac392e0adadd Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Tue, 13 Oct 2020 20:11:05 +0700
Subject: [PATCH 009/312] puddletag: rebuild for Python 3.9

---
 srcpkgs/puddletag/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/puddletag/template b/srcpkgs/puddletag/template
index 44bd3eff777..7a55df56b10 100644
--- a/srcpkgs/puddletag/template
+++ b/srcpkgs/puddletag/template
@@ -1,7 +1,7 @@
 # Template file for 'puddletag'
 pkgname=puddletag
 version=2.0.1
-revision=1
+revision=2
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3 python3-configobj python3-mutagen python3-parsing python3-PyQt5 python3-PyQt5-svg"

From 08a87bba09cdf96126bc8aad0aabc84c0d8dcf17 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Tue, 13 Oct 2020 09:32:36 -0400
Subject: [PATCH 010/312] jrnl: update to 1.9.9.

---
 srcpkgs/jrnl/template | 13 ++++++-------
 1 file changed, 6 insertions(+), 7 deletions(-)

diff --git a/srcpkgs/jrnl/template b/srcpkgs/jrnl/template
index c94d555e829..63d9ff8159e 100644
--- a/srcpkgs/jrnl/template
+++ b/srcpkgs/jrnl/template
@@ -1,18 +1,17 @@
 # Template file for 'jrnl'
 pkgname=jrnl
-version=1.9.8
-revision=6
+version=1.9.9
+revision=1
 build_style=python3-module
 hostmakedepends="python3-setuptools"
-depends="python3-cryptography python3-dateutil python3-keyring
-python3-keyrings-alt python3-parsedatetime python3-passlib python3-pytz
-python3-setuptools python3-six python3-tzlocal python3-xdg python3-yaml"
+depends="python3-parsedatetime python3-pytz python3-six python3-tzlocal
+ python3-keyring python3-keyrings-alt python3-dateutil python3-passlib"
 short_desc="Simple journal application for your command line"
 maintainer="travankor <travankor@tuta.io>"
 license="MIT"
 homepage="http://jrnl.sh"
-distfiles="https://github.com/maebert/jrnl/archive/${version}.tar.gz"
-checksum=ec9dcf01f67a2329218fcd090b56042379937b269ddbd8c0c64097636f012e63
+distfiles="https://github.com/jrnl-org/jrnl/archive/v${version}.tar.gz"
+checksum=7db114fa0d09b601c35d7e1d6456711845d7521a6a3251b6c27939317cadc0ea
 
 post_install() {
 	vlicense LICENSE

From 0829ba7b32146211d299624b85a0c49ef1e1db40 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Tue, 13 Oct 2020 09:37:57 -0400
Subject: [PATCH 011/312] TwitchNotifier: rebuild for Python 3.9

---
 srcpkgs/TwitchNotifier/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/TwitchNotifier/template b/srcpkgs/TwitchNotifier/template
index ce8823f35ba..39a8c31c904 100644
--- a/srcpkgs/TwitchNotifier/template
+++ b/srcpkgs/TwitchNotifier/template
@@ -1,7 +1,7 @@
 # Template file for 'TwitchNotifier'
 pkgname=TwitchNotifier
 version=0.5
-revision=3
+revision=4
 build_style=python3-module
 hostmakedepends="python3-devel"
 makedepends="python3-devel"

From b7839d4473eb7ff713296c6f178c03fe948ed468 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 9 Oct 2020 20:09:02 +0700
Subject: [PATCH 012/312] gtkglext: kill pangox

---
 srcpkgs/gtkglext/patches/kill-pangox.patch | 68 ++++++++++++++++++++++
 srcpkgs/gtkglext/template                  | 14 ++++-
 2 files changed, 79 insertions(+), 3 deletions(-)
 create mode 100644 srcpkgs/gtkglext/patches/kill-pangox.patch

diff --git a/srcpkgs/gtkglext/patches/kill-pangox.patch b/srcpkgs/gtkglext/patches/kill-pangox.patch
new file mode 100644
index 00000000000..5f68c77e5e6
--- /dev/null
+++ b/srcpkgs/gtkglext/patches/kill-pangox.patch
@@ -0,0 +1,68 @@
+diff --git configure.in configure.in
+index e5b678c..f4937d0 100644
+--- configure.in
++++ configure.in
+@@ -59,10 +59,6 @@ m4_define([gmodule_required_version], [2.0.0])
+ m4_define([pango_pkg], [pango])
+ m4_define([pango_required_version], [1.0.0])
+ 
+-# Pangox
+-m4_define([pangox_pkg], [pangox])
+-m4_define([pangox_required_version], [1.0.0])
+-
+ # PangoFT2
+ m4_define([pangoft2_pkg], [pangoft2])
+ m4_define([pangoft2_required_version], [1.0.0])
+@@ -349,7 +345,6 @@ PKG_CHECK_MODULES([BASE_DEPENDENCIES], [\
+ gtk_pkg >= gtk_required_version \
+ gdk_pkg >= gdk_required_version \
+ pango_pkg >= pango_required_version \
+-pangox_pkg >= pangox_required_version \
+ gmodule_pkg >= gmodule_required_version \
+ ])
+ 
+@@ -794,7 +789,7 @@ LIBS="$save_LIBS"
+ # CFLAGS and LIBS
+ ##################################################
+ 
+-GDKGLEXT_PACKAGES="gdk_pkg pango_pkg pangox_pkg gmodule_pkg"
++GDKGLEXT_PACKAGES="gdk_pkg pango_pkg gmodule_pkg"
+ GDKGLEXT_EXTRA_CFLAGS="$GL_CFLAGS $GDKGLEXT_WIN_CFLAGS"
+ GDKGLEXT_EXTRA_LIBS="$GL_LIBS $GDKGLEXT_WIN_LIBS"
+ GDKGLEXT_DEP_CFLAGS="$GDKGLEXT_EXTRA_CFLAGS `$PKG_CONFIG --cflags $GDKGLEXT_PACKAGES`"
+diff --git gdk/Makefile.am gdk/Makefile.am
+index 700213e..09f6ba7 100644
+--- gdk/Makefile.am
++++ gdk/Makefile.am
+@@ -73,7 +73,6 @@ gdkglext_public_h_sources = \
+ 	gdkgldrawable.h		\
+ 	gdkglpixmap.h		\
+ 	gdkglwindow.h		\
+-	gdkglfont.h		\
+ 	gdkglshapes.h		\
+ 	gdkglglext.h
+ 
+diff --git gdk/gdkgl.h gdk/gdkgl.h
+index f22a31c..fc80db3 100644
+--- gdk/gdkgl.h
++++ gdk/gdkgl.h
+@@ -33,7 +33,6 @@
+ #include <gdk/gdkgldrawable.h>
+ #include <gdk/gdkglpixmap.h>
+ #include <gdk/gdkglwindow.h>
+-#include <gdk/gdkglfont.h>
+ #include <gdk/gdkglshapes.h>
+ 
+ #endif /* __GDK_GL_H__ */
+diff --git gdk/x11/Makefile.am gdk/x11/Makefile.am
+index a7fb6f6..526b7cc 100644
+--- gdk/x11/Makefile.am
++++ gdk/x11/Makefile.am
+@@ -35,7 +35,6 @@ gdkglext_x11_c_sources = \
+ 	gdkgldrawable-x11.c	\
+ 	gdkglpixmap-x11.c	\
+ 	gdkglwindow-x11.c	\
+-	gdkglfont-x11.c		\
+ 	gdkglglxext.c
+ 
+ gdkglext_x11_headers = \
diff --git a/srcpkgs/gtkglext/template b/srcpkgs/gtkglext/template
index e4911af5430..737a9741598 100644
--- a/srcpkgs/gtkglext/template
+++ b/srcpkgs/gtkglext/template
@@ -1,11 +1,11 @@
 # Template file for 'gtkglext'
 pkgname=gtkglext
 version=1.2.0
-revision=7
+revision=8
 build_style=gnu-configure
 configure_args="--disable-static"
-hostmakedepends="pkg-config glib-devel"
-makedepends="pangox-compat-devel libXt-devel gtk+-devel glu-devel"
+hostmakedepends="pkg-config glib-devel automake libtool gtk+-devel"
+makedepends="libXt-devel gtk+-devel glu-devel"
 short_desc="OpenGL extension to GTK+"
 maintainer="Martin Riese <grauehaare@gmx.de>"
 license="GPL-2.0-or-later, LGPL-2.1-or-later"
@@ -13,6 +13,14 @@ homepage="https://projects.gnome.org/gtkglext"
 distfiles="${SOURCEFORGE_SITE}/gtkglext/gtkglext/${version}/gtkglext-${version}.tar.gz"
 checksum=e5073f3c6b816e7fa67d359d9745a5bb5de94a628ac85f624c992925a46844f9
 
+pre_configure() {
+	autoreconf -fi
+}
+
+post_patch() {
+	rm -f gdk/x11/gdkglfont-x11.c
+}
+
 gtkglext-devel_package() {
 	short_desc+=" - development files"
 	depends="${makedepends} ${sourcepkg}>=${version}_${revision}"

From 76fb5d1962006b3f69b772ca705435c471ad13f3 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 9 Oct 2020 20:09:38 +0700
Subject: [PATCH 013/312] pangox-compat: drop

- ftbfs
- last updated 10 years ago
---
 common/shlibs                  |  1 -
 srcpkgs/pangox-compat-devel    |  1 -
 srcpkgs/pangox-compat/template | 25 -------------------------
 3 files changed, 27 deletions(-)
 delete mode 120000 srcpkgs/pangox-compat-devel
 delete mode 100644 srcpkgs/pangox-compat/template

diff --git a/common/shlibs b/common/shlibs
index 1a12253c004..ee61480ccea 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -91,7 +91,6 @@ libatk-1.0.so.0 atk-1.26.0_1
 libpangocairo-1.0.so.0 pango-1.24.0_1
 libpangoft2-1.0.so.0 pango-1.24.0_1
 libpangoxft-1.0.so.0 pango-xft-1.36.3_2
-libpangox-1.0.so.0 pangox-compat-0.0.2_1
 libpango-1.0.so.0 pango-1.24.0_1
 libcairo.so.2 cairo-1.8.6_1
 libcairo-gobject.so.2 cairo-1.8.6_1
diff --git a/srcpkgs/pangox-compat-devel b/srcpkgs/pangox-compat-devel
deleted file mode 120000
index bb1b03dc520..00000000000
--- a/srcpkgs/pangox-compat-devel
+++ /dev/null
@@ -1 +0,0 @@
-pangox-compat
\ No newline at end of file
diff --git a/srcpkgs/pangox-compat/template b/srcpkgs/pangox-compat/template
deleted file mode 100644
index 58a37c01e21..00000000000
--- a/srcpkgs/pangox-compat/template
+++ /dev/null
@@ -1,25 +0,0 @@
-# Template file for 'pangox-compat'
-pkgname=pangox-compat
-version=0.0.2
-revision=4
-build_style=gnu-configure
-configure_args="--disable-static"
-hostmakedepends="pkg-config"
-makedepends="pango-devel"
-replaces="pango<1.32"
-short_desc="Library for layout and rendering of text (pangox compat library)"
-maintainer="Orphaned <orphan@voidlinux.org>"
-homepage="http://www.pango.org/"
-license="LGPL-2.1"
-distfiles="${GNOME_SITE}/${pkgname}/0.0/${pkgname}-${version}.tar.xz"
-checksum=552092b3b6c23f47f4beee05495d0f9a153781f62a1c4b7ec53857a37dfce046
-
-pangox-compat-devel_package() {
-	depends="libX11-devel pango-devel>=1.31 ${sourcepkg}-${version}_${revision}"
-	short_desc+=" -- development files"
-	pkg_install() {
-		vmove usr/include
-		vmove usr/lib/pkgconfig
-		vmove "usr/lib/*.so"
-	}
-}

From eec6721377941216dfe7a92f6e28dc5eb2acb844 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 9 Oct 2020 21:17:50 +0700
Subject: [PATCH 014/312] gnubg: s/-Wl,--no-as-needed//, fix arm-cross

Use www.gnu.org as homepage, old site is unreachable

- arm-cross fixed by @fosslinux
Co-authored-by: fosslinux <fosslinux@aussies.space>
---
 srcpkgs/gnubg/template | 25 ++++++++++++-------------
 1 file changed, 12 insertions(+), 13 deletions(-)

diff --git a/srcpkgs/gnubg/template b/srcpkgs/gnubg/template
index 4bbe300c6c6..173af550bb4 100644
--- a/srcpkgs/gnubg/template
+++ b/srcpkgs/gnubg/template
@@ -1,28 +1,28 @@
 # Template file for 'gnubg'
 pkgname=gnubg
 version=1.06.002
-revision=2
+revision=3
 build_style=gnu-configure
 configure_args="--disable-cputest ax_cv_gcc_x86_cpuid_0x00000001=6000000"
-if [ "$XBPS_TARGET_MACHINE" = x86_64 ]; then
-	configure_args+=" --enable-simd=sse2"
-fi
-hostmakedepends="pkg-config python-devel gdk-pixbuf-devel"
-if [ "$CROSS_BUILD" ]; then
-	hostmakedepends+=" ${pkgname}"
-fi
+hostmakedepends="pkg-config python gdk-pixbuf-devel"
 makedepends="libcurl-devel libglib-devel gtk+-devel gtkglext-devel python-devel
  libcanberra-devel readline-devel readline sqlite-devel"
+depends="python"
 short_desc="GNU Backgammon game"
 maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="GPL-3.0-or-later"
-homepage="http://www.gnubg.org"
-distfiles="http://www.gnubg.org/media/sources/$pkgname-release-$version-sources.tar.gz"
+homepage="https://www.gnu.org/software/gnubg/"
+distfiles="$GNU_SITE/gnubg/$pkgname-release-$version-sources.tar.gz"
 checksum=ce1b0b0c1900717cc598032a14cf8c0ee60faf24d84368b39922c0102983bc87
-LDFLAGS="-Wl,--no-as-needed -lm -lreadline"
+LDLIBS="-lm -lreadline -lpython2.7"
+
+if [ "$CROSS_BUILD" ]; then
+	hostmakedepends+=" ${pkgname}"
+	CPPFLAGS="-I$XBPS_CROSS_BASE/usr/include/python2.7"
+fi
 
 case "$XBPS_TARGET_MACHINE" in
-	arm*) broken="https://build.voidlinux.org/builders/armv7l_builder/builds/6536/steps/shell_3/logs/stdio" ;;
+	x86_64*) configure_args+=" --enable-simd=sse2" ;;
 esac
 
 pre_configure() {
@@ -32,4 +32,3 @@ pre_configure() {
 		makebearoff -t 6x6 -f gnubg_ts0.bd
 	fi
 }
-

From 08b7f2dd4e7b286f6cf7f74ff73f4c702f1f785d Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 9 Oct 2020 22:15:54 +0700
Subject: [PATCH 015/312] pcb: merge pcb-data in

---
 srcpkgs/pcb-data     |  1 -
 srcpkgs/pcb/template | 13 +++----------
 2 files changed, 3 insertions(+), 11 deletions(-)
 delete mode 120000 srcpkgs/pcb-data

diff --git a/srcpkgs/pcb-data b/srcpkgs/pcb-data
deleted file mode 120000
index 660275f2247..00000000000
--- a/srcpkgs/pcb-data
+++ /dev/null
@@ -1 +0,0 @@
-pcb
\ No newline at end of file
diff --git a/srcpkgs/pcb/template b/srcpkgs/pcb/template
index 882fffad2c7..c9546e05b02 100644
--- a/srcpkgs/pcb/template
+++ b/srcpkgs/pcb/template
@@ -1,8 +1,8 @@
-# Template file for 'pcb'.
+# Template file for 'pcb'
 pkgname=pcb
 reverts=20140316_4
 version=4.2.2
-revision=1
+revision=2
 build_style=gnu-configure
 configure_args="--disable-update-desktop-database --disable-update-mime-database"
 hostmakedepends="flex geda gerbv intltool netpbm pkg-config
@@ -16,11 +16,4 @@ license="GPL-2.0-or-later"
 homepage="http://pcb.geda-project.org/news.html"
 distfiles="${SOURCEFORGE_SITE}/${pkgname}/${pkgname}-${version}.tar.gz"
 checksum=1ceeaf1bdbe0508b9b140ca421eb600836579114c04dee939341c5d594f36e5d
-
-pcb-data_package() {
-	archs=noarch
-	short_desc+=" - data files"
-	pkg_install() {
-		vmove usr/share/pcb
-	}
-}
+replaces="pcb-data>=0"

From fc8ab664c2171f4fe968af4a6fe9b5b8c904237e Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Sat, 10 Oct 2020 11:34:34 +0700
Subject: [PATCH 016/312] vba-m: not requires gtkglext anymore

---
 srcpkgs/vba-m/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/vba-m/template b/srcpkgs/vba-m/template
index 8d69e721e36..659de62621c 100644
--- a/srcpkgs/vba-m/template
+++ b/srcpkgs/vba-m/template
@@ -2,14 +2,14 @@
 pkgname=vba-m
 reverts=1292_2
 version=2.1.4
-revision=2
+revision=3
 archs="x86_64* i686*"
 wrksrc="visualboyadvance-m-${version}"
 build_style=cmake
 configure_args="-DENABLE_GTK=TRUE -DENABLE_FFMPEG=TRUE -DENABLE_LINK=TRUE"
 hostmakedepends="gettext pkg-config unzip zip yasm wxWidgets-common-devel"
 makedepends="zlib-devel libpng-devel MesaLib-devel libopenal-devel SDL2-devel
- gtkmm2-devel gtkglext-devel gtkglextmm-devel ffmpeg-devel gtk+3-devel
+ gtkmm2-devel ffmpeg-devel gtk+3-devel
  SFML-devel wxWidgets-gtk3-devel libgomp-devel"
 short_desc="Gameboy Advance Emulator"
 maintainer="Andrea Brancaleoni <abc@pompel.me>"

From 664ca9c7071bddf6be01af4717d51d56221daa7f Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Sat, 10 Oct 2020 11:31:35 +0700
Subject: [PATCH 017/312] gtkglextmm: drop package

- Nothing else needs this library
- Last updated 10 years ago
- Need PangoX
---
 common/shlibs                                 |   2 -
 srcpkgs/gtkglextmm-devel                      |   1 -
 .../patches/fix_ftbfs_gtk_2_20.patch          |  28 ----
 .../patches/fix_ftbfs_gtk_2_36.patch          | 121 ------------------
 .../patches/fix_ftbfs_gtk_2_37.patch          |  24 ----
 .../patches/gtkglextmm-1.2.0-aclocal.patch    |  11 --
 srcpkgs/gtkglextmm/template                   |  27 ----
 7 files changed, 214 deletions(-)
 delete mode 120000 srcpkgs/gtkglextmm-devel
 delete mode 100644 srcpkgs/gtkglextmm/patches/fix_ftbfs_gtk_2_20.patch
 delete mode 100644 srcpkgs/gtkglextmm/patches/fix_ftbfs_gtk_2_36.patch
 delete mode 100644 srcpkgs/gtkglextmm/patches/fix_ftbfs_gtk_2_37.patch
 delete mode 100644 srcpkgs/gtkglextmm/patches/gtkglextmm-1.2.0-aclocal.patch
 delete mode 100644 srcpkgs/gtkglextmm/template

diff --git a/common/shlibs b/common/shlibs
index ee61480ccea..e50e44f1246 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -2212,8 +2212,6 @@ libwebsockets.so.15 libwebsockets-3.2.0_1
 libnfc.so.0 libnfc-1.7.1_1
 libfuzzy.so.2 libfuzzy-2.12_1
 libSDL_gfx.so.15 SDL_gfx-2.0.25_2
-libgdkglextmm-x11-1.2.so.0 gtkglextmm-1.2.0_1
-libgtkglextmm-x11-1.2.so.0 gtkglextmm-1.2.0_1
 libsfml-network.so.2.5 SFML-2.5.0_1
 libsfml-system.so.2.5 SFML-2.5.0_1
 libsfml-window.so.2.5 SFML-2.5.0_1
diff --git a/srcpkgs/gtkglextmm-devel b/srcpkgs/gtkglextmm-devel
deleted file mode 120000
index d514cfcb39d..00000000000
--- a/srcpkgs/gtkglextmm-devel
+++ /dev/null
@@ -1 +0,0 @@
-gtkglextmm
\ No newline at end of file
diff --git a/srcpkgs/gtkglextmm/patches/fix_ftbfs_gtk_2_20.patch b/srcpkgs/gtkglextmm/patches/fix_ftbfs_gtk_2_20.patch
deleted file mode 100644
index acf7c1b4fea..00000000000
--- a/srcpkgs/gtkglextmm/patches/fix_ftbfs_gtk_2_20.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-Description: Fix FTBFS due to missing GdkSpanFunc definition
- .
- The sequence of #include directives is important - if gtk/gtkglwidget.h
- is included first, before widget.h, it includes gdk.h without undefing
- GDK_DISABLE_DEPRECATED - this leads to GdkSpanFunc not being defined
- and compilation errors. 
- The fix is to first include widget.h which includes the right gdkmm header
- which defines GDK_DISABLE_DEPRECATED before including gdk.h.
-Forwarded: no
-Bug-Ubuntu: http://launchpad.net/bugs/662572
-
-Index: gtkglextmm-1.2.0/gtkglext/gtkmm/gl/widget.cc
-===================================================================
---- gtkglext/gtkmm/gl/widget.cc	2010-12-08 13:31:59.651270000 +0100
-+++ gtkglext/gtkmm/gl/widget.cc	2010-12-08 13:32:10.871270000 +0100
-@@ -17,10 +17,10 @@
-  * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307  USA.
-  */
- 
--#include <gtk/gtkglwidget.h>
--
- #include "widget.h"
- 
-+#include <gtk/gtkglwidget.h>
-+
- namespace Gtk
- {
-   namespace GL
diff --git a/srcpkgs/gtkglextmm/patches/fix_ftbfs_gtk_2_36.patch b/srcpkgs/gtkglextmm/patches/fix_ftbfs_gtk_2_36.patch
deleted file mode 100644
index 8156bae16b8..00000000000
--- a/srcpkgs/gtkglextmm/patches/fix_ftbfs_gtk_2_36.patch
+++ /dev/null
@@ -1,121 +0,0 @@
-Index: gtkglextmm-1.2.0/gdkglext/gdkmm/gl/wrap_init.cc
-===================================================================
---- gdkglext/gdkmm/gl/wrap_init.cc	2013-05-16 23:40:48.363207736 +0200
-+++ gdkglext/gdkmm/gl/wrap_init.cc	2013-05-16 23:42:40.193801834 +0200
-@@ -1,15 +1,8 @@
--
--#include <glib.h>
--
- // Disable the 'const' function attribute of the get_type() functions.
- // GCC would optimize them out because we don't use the return value.
- #undef  G_GNUC_CONST
- #define G_GNUC_CONST /* empty */
- 
--#include <gdkmm/gl/wrap_init.h>
--#include <glibmm/error.h>
--#include <glibmm/object.h>
--
- // #include the widget headers so that we can call the get_type() static methods:
- 
- #include "tokens.h"
-@@ -19,6 +12,12 @@
- #include "pixmap.h"
- #include "window.h"
- 
-+#include <glib.h>
-+
-+#include <gdkmm/gl/wrap_init.h>
-+#include <glibmm/error.h>
-+#include <glibmm/object.h>
-+
- extern "C"
- {
- 
-Index: gtkglextmm-1.2.0/gdkglext/gdkmm/gl/query.cc
-===================================================================
---- gdkglext/gdkmm/gl/query.cc	2013-05-16 23:40:48.363207736 +0200
-+++ gdkglext/gdkmm/gl/query.cc	2013-05-16 23:42:40.193801834 +0200
-@@ -17,10 +17,10 @@
-  * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307  USA.
-  */
- 
--#include <gdk/gdkglquery.h>
--
- #include "query.h"
- 
-+#include <gdk/gdkglquery.h>
-+
- namespace Gdk
- {
-   namespace GL
-Index: gtkglextmm-1.2.0/gdkglext/gdkmm/gl/pixmapext.cc
-===================================================================
---- gdkglext/gdkmm/gl/pixmapext.cc	2013-05-16 23:40:48.363207736 +0200
-+++ gdkglext/gdkmm/gl/pixmapext.cc	2013-05-16 23:42:40.193801834 +0200
-@@ -17,11 +17,11 @@
-  * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307  USA.
-  */
- 
-+#include "pixmapext.h"
-+
- #include <gdk/gdkgldrawable.h>
- #include <gdk/gdkglpixmap.h>
- 
--#include "pixmapext.h"
--
- namespace Gdk
- {
-   namespace GL
-Index: gtkglextmm-1.2.0/gdkglext/gdkmm/gl/windowext.cc
-===================================================================
---- gdkglext/gdkmm/gl/windowext.cc	2013-05-16 23:40:48.363207736 +0200
-+++ gdkglext/gdkmm/gl/windowext.cc	2013-05-16 23:42:40.193801834 +0200
-@@ -17,11 +17,11 @@
-  * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307  USA.
-  */
- 
-+#include "windowext.h"
-+
- #include <gdk/gdkgldrawable.h>
- #include <gdk/gdkglwindow.h>
- 
--#include "windowext.h"
--
- namespace Gdk
- {
-   namespace GL
-Index: gtkglextmm-1.2.0/gdkglext/gdkmm/gl/font.cc
-===================================================================
---- gdkglext/gdkmm/gl/font.cc	2004-05-18 08:01:49.000000000 +0200
-+++ gdkglext/gdkmm/gl/font.cc	2013-05-16 23:43:07.637456821 +0200
-@@ -17,10 +17,10 @@
-  * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307  USA.
-  */
- 
--#include <gdk/gdkglfont.h>
--
- #include "font.h"
- 
-+#include <gdk/gdkglfont.h>
-+
- namespace Gdk
- {
-   namespace GL
-Index: gtkglextmm-1.2.0/gdkglext/gdkmm/gl/init.cc
-===================================================================
---- gdkglext/gdkmm/gl/init.cc	2003-02-27 10:49:24.000000000 +0100
-+++ gdkglext/gdkmm/gl/init.cc	2013-05-16 23:44:38.320316782 +0200
-@@ -19,11 +19,11 @@
- 
- #include <cstdlib>
- 
--#include <gdk/gdkglinit.h>
--
- #include "wrap_init.h"
- #include "init.h"
- 
-+#include <gdk/gdkglinit.h>
-+
- namespace Gdk
- {
-   namespace GL
diff --git a/srcpkgs/gtkglextmm/patches/fix_ftbfs_gtk_2_37.patch b/srcpkgs/gtkglextmm/patches/fix_ftbfs_gtk_2_37.patch
deleted file mode 100644
index 59cbd7763f9..00000000000
--- a/srcpkgs/gtkglextmm/patches/fix_ftbfs_gtk_2_37.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff --git a/gtkglext/gtkmm/gl/drawingarea.cc b/gtkglext/gtkmm/gl/drawingarea.cc
-index 82bb7f4..5a8c5e3 100644
---- gtkglext/gtkmm/gl/drawingarea.cc
-+++ gtkglext/gtkmm/gl/drawingarea.cc
-@@ -17,6 +17,7 @@
-  * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307  USA.
-  */
- 
-+#include <glibmm.h>
- #include "drawingarea.h"
- 
- namespace Gtk
-diff --git a/gtkglext/gtkmm/gl/widget.cc b/gtkglext/gtkmm/gl/widget.cc
-index 598d6e2..2d6833b 100644
---- gtkglext/gtkmm/gl/widget.cc
-+++ gtkglext/gtkmm/gl/widget.cc
-@@ -17,6 +17,7 @@
-  * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307  USA.
-  */
- 
-+#include <glibmm.h>
- #include "widget.h"
- 
- #include <gtk/gtkglwidget.h>
diff --git a/srcpkgs/gtkglextmm/patches/gtkglextmm-1.2.0-aclocal.patch b/srcpkgs/gtkglextmm/patches/gtkglextmm-1.2.0-aclocal.patch
deleted file mode 100644
index 25c319645fc..00000000000
--- a/srcpkgs/gtkglextmm/patches/gtkglextmm-1.2.0-aclocal.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- m4macros/gtkglextmm.m4	2004-05-18 08:29:34.000000000 +0200
-+++ m4macros/gtkglextmm.m4	2006-05-31 16:46:09.000000000 +0200
-@@ -222,7 +222,7 @@
- dnl AC_GTKGLEXTMM_SUPPORTS_MULTIHEAD([ACTION-IF-SUPPORTED [, ACTION-IF-NOT-SUPPORTED]])
- dnl Checks whether gtkglextmm supports multihead.
- dnl
--AC_DEFUN(AC_GTKGLEXTMM_SUPPORTS_MULTIHEAD,
-+AC_DEFUN([AC_GTKGLEXTMM_SUPPORTS_MULTIHEAD],
- [ AC_LANG_SAVE
-   AC_LANG_CPLUSPLUS
-   AC_CACHE_CHECK([whether gtkglextmm supports multihead],
diff --git a/srcpkgs/gtkglextmm/template b/srcpkgs/gtkglextmm/template
deleted file mode 100644
index 3fea41e8284..00000000000
--- a/srcpkgs/gtkglextmm/template
+++ /dev/null
@@ -1,27 +0,0 @@
-# Template file for 'gtkglextmm'
-pkgname=gtkglextmm
-version=1.2.0
-revision=3
-build_style=gnu-configure
-hostmakedepends="pkg-config"
-makedepends="gtkglext-devel gtkmm2-devel pangomm-devel"
-short_desc="C++ bindings for gtkglext"
-maintainer="Andrea Brancaleoni <abc@pompel.me>"
-license="LGPL-2.1"
-homepage="https://projects.gnome.org/gtkglext/"
-distfiles="${SOURCEFORGE_SITE}/gtkglext/${pkgname}-${version}.tar.bz2"
-checksum=6cd4bd2a240e5eb1e3a24c5a3ebbf7ed905b522b888439778043fdeb58771fea
-
-gtkglextmm-devel_package() {
-	depends="${makedepends} ${sourcepkg}-${version}_${revision}"
-	short_desc+=" - development files"
-	pkg_install() {
-		vmove usr/include
-		vmove usr/lib/pkgconfig
-		vmove "usr/lib/*.a"
-		vmove "usr/lib/*.so"
-		vmove usr/share/doc
-		vmove usr/share/aclocal
-		vmove usr/lib/gtkglextmm-1.2
-	}
-}

From e1f6444654a96494a712f9be9b18dd7fe84e9dd0 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 9 Oct 2020 23:36:18 +0700
Subject: [PATCH 018/312] ufoai: merge ufoai-data back, kill pangox

---
 srcpkgs/ufoai-data                         |  1 -
 srcpkgs/ufoai/patches/kill-pangox.patch    | 39 ++++++++++++++++++++++
 srcpkgs/ufoai/patches/sdl2_gl_orthof.patch | 17 ++++++++++
 srcpkgs/ufoai/template                     | 22 +++++-------
 4 files changed, 64 insertions(+), 15 deletions(-)
 delete mode 120000 srcpkgs/ufoai-data
 create mode 100644 srcpkgs/ufoai/patches/kill-pangox.patch
 create mode 100644 srcpkgs/ufoai/patches/sdl2_gl_orthof.patch

diff --git a/srcpkgs/ufoai-data b/srcpkgs/ufoai-data
deleted file mode 120000
index 92362c4dbe5..00000000000
--- a/srcpkgs/ufoai-data
+++ /dev/null
@@ -1 +0,0 @@
-ufoai
\ No newline at end of file
diff --git a/srcpkgs/ufoai/patches/kill-pangox.patch b/srcpkgs/ufoai/patches/kill-pangox.patch
new file mode 100644
index 00000000000..c72a37648b5
--- /dev/null
+++ b/srcpkgs/ufoai/patches/kill-pangox.patch
@@ -0,0 +1,39 @@
+--- src/tools/radiant/libs/gtkutil/glfont.cpp.orig	2020-10-10 12:51:38.707431160 +0700
++++ src/tools/radiant/libs/gtkutil/glfont.cpp	2020-10-10 12:51:59.843621038 +0700
+@@ -26,35 +26,7 @@
+ 
+ GLFont glfont_create (const std::string& font_string)
+ {
+-	GLuint font_list_base = glGenLists(256);
+-	gint font_height = 0;
+-
+-	PangoFontDescription* font_desc = pango_font_description_from_string(font_string.c_str());
+-
+-	PangoFont* font = gdk_gl_font_use_pango_font(font_desc, 0, 256, font_list_base);
+-
+-	if (font != 0) {
+-		PangoFontMetrics* font_metrics = pango_font_get_metrics(font, 0);
+-
+-		font_height = pango_font_metrics_get_ascent(font_metrics) + pango_font_metrics_get_descent(font_metrics);
+-		font_height = PANGO_PIXELS(font_height);
+-
+-		pango_font_metrics_unref(font_metrics);
+-	} else {
+-		globalErrorStream() << "Failed to initialize font " << font_string << "\n";
+-		pango_font_description_free(font_desc);
+-		return GLFont(-1, -1);
+-	}
+-
+-	pango_font_description_free(font_desc);
+-
+-	// fix for pango/gtkglext metrix bug
+-	if (font_height > 16)
+-		font_height = 16;
+-
+-	globalOutputStream() << "Use font " << font_string << "\n";
+-
+-	return GLFont(font_list_base, font_height);
++	return GLFont(-1, -1);
+ }
+ 
+ void glfont_release (GLFont& font)
diff --git a/srcpkgs/ufoai/patches/sdl2_gl_orthof.patch b/srcpkgs/ufoai/patches/sdl2_gl_orthof.patch
new file mode 100644
index 00000000000..3d9ffd070ce
--- /dev/null
+++ b/srcpkgs/ufoai/patches/sdl2_gl_orthof.patch
@@ -0,0 +1,17 @@
+SDL_opengl.h dosen't have the nessecary headers. GL/gl.h has the parts
+of SDL_opengl.h needed for SDL_opengl_glext.h, then include
+SDL_opengl_glext.h which has the *f functions.
+
+--- src/client/renderer/r_gl.h  2020-10-08 07:50:29.818581990 +1100
++++ src/client/renderer/r_gl.h  2020-10-08 07:52:16.805006133 +1100
+@@ -29,7 +29,8 @@
+ #include "../../ports/android/r_gles_android.h"
+ #include <stdlib.h>
+ #else
+-#include <SDL_opengl.h>
++#include <GL/gl.h>
++#include <SDL_opengl_glext.h>
+ #endif
+
+ inline void R_DrawArrays (GLint first, GLsizei count) {
+
diff --git a/srcpkgs/ufoai/template b/srcpkgs/ufoai/template
index 6463d2c47c6..18fd7317619 100644
--- a/srcpkgs/ufoai/template
+++ b/srcpkgs/ufoai/template
@@ -1,28 +1,31 @@
 # Template file for 'ufoai'
 pkgname=ufoai
 version=2.5
-revision=2
+revision=3
 create_wrksrc=yes
 build_style=gnu-makefile
-hostmakedepends="pkg-config"
+hostmakedepends="pkg-config gettext"
 makedepends="MesaLib-devel glu-devel libjpeg-turbo-devel
  libvorbis-devel libopenal-devel xvidcore-devel libtheora-devel
  SDL2_image-devel SDL2_mixer-devel SDL2_ttf-devel libcurl-devel
  gtkglext-devel gtksourceview2-devel"
-depends="ufoai-data>=${version} ca-certificates"
+depends="ca-certificates"
 short_desc="UFO Alien Invasion"
 maintainer="Jürgen Buchmüller <pullmoll@t-online.de>"
-license="GPL-2"
+license="GPL-2.0-or-later"
 homepage="http://ufoai.org/"
 distfiles="
  ${SOURCEFORGE_SITE}/${pkgname}/UFO_AI%202.x/${version}/${pkgname}-${version}-source.tar.bz2
  ${SOURCEFORGE_SITE}/${pkgname}/UFO_AI%202.x/${version}/${pkgname}-${version}-data.tar"
 checksum="0c7cc3bc9efeb276f71cbe6ee8ff7c76f98d183de79f1a069fa63059cf182a8f
  5e706a424aff6a2ea30a4c798129d6304e897387eadf808528129b512b7dcdb0"
-broken="ELF in /usr/share"
+replaces="ufoai-data>=0"
+ignore_elf_dirs="/usr/share/ufoai"
+broken="game doesn't work"
 
 # suppress a lot of warnings
 CXXFLAGS="-Wno-cast-align -Wno-cast-qual -Wno-inline"
+LDFLAGS="-lX11"
 
 post_extract() {
 	cd ${wrksrc}
@@ -67,15 +70,6 @@ post_install() {
 	sed -i ${DESTDIR}/usr/share/applications/* -e "s;/usr/games/;;"
 }
 
-ufoai-data_package() {
-	short_desc+=" - data files"
-	archs=noarch
-	pkg_install() {
-		vmove usr/share/ufoai/base/*.pk3
-		vmove usr/share/ufoai/base/i18n
-	}
-}
-
 ufoai-radiant_package() {
 	short_desc+=" - map editor"
 	depends="${sourcepkg}>=${version}_${revision}"

From 4bd32f5ae3029754ddf6998cc9148a8001e450ae Mon Sep 17 00:00:00 2001
From: Piraty <piraty1@inbox.ru>
Date: Tue, 13 Oct 2020 17:16:13 +0200
Subject: [PATCH 019/312] nmap: update to 7.91.

zenmap is actually python2
---
 srcpkgs/nmap/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/nmap/template b/srcpkgs/nmap/template
index fd2c2eb986c..7d46635229b 100644
--- a/srcpkgs/nmap/template
+++ b/srcpkgs/nmap/template
@@ -1,6 +1,6 @@
 # Template file for 'nmap'
 pkgname=nmap
-version=7.90
+version=7.91
 revision=1
 build_style=gnu-configure
 configure_args="--without-ndiff --with-openssl --with-zenmap $(vopt_with lua liblua)"
@@ -11,8 +11,8 @@ maintainer="Piraty <piraty1@inbox.ru>"
 license="custom:nmap"
 homepage="https://nmap.org"
 distfiles="https://nmap.org/dist/nmap-${version}.tar.bz2"
-checksum=5557c3458275e8c43e1d0cfa5dad4e71dd39e091e2029a293891ad54098a40e8
-python_version=3
+checksum=18cc4b5070511c51eb243cdd2b0b30ff9b2c4dc4544c6312f75ce3a67a593300
+python_version=2
 
 build_options="lua"
 build_options_default="lua"

From d60efc56e94de0c19481808922ba614af56422a8 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 24 Sep 2020 18:06:17 +0200
Subject: [PATCH 020/312] qt5: add patch for Qt5GuiConfigExtras.cmake to find
 GL libs when cross compiling

[ci skip]
---
 srcpkgs/qt5/patches/0002-gl-lib-dir.patch     | 15 ++++
 .../qt5/patches/0060-upstream-65243ad7.patch  | 87 +++++++++++++++++++
 srcpkgs/qt5/template                          |  2 +-
 3 files changed, 103 insertions(+), 1 deletion(-)
 create mode 100644 srcpkgs/qt5/patches/0002-gl-lib-dir.patch
 create mode 100644 srcpkgs/qt5/patches/0060-upstream-65243ad7.patch

diff --git a/srcpkgs/qt5/patches/0002-gl-lib-dir.patch b/srcpkgs/qt5/patches/0002-gl-lib-dir.patch
new file mode 100644
index 00000000000..d74d4e97d1d
--- /dev/null
+++ b/srcpkgs/qt5/patches/0002-gl-lib-dir.patch
@@ -0,0 +1,15 @@
+--- ./qtbase/src/gui/Qt5GuiConfigExtras.cmake.in	2020-09-19 13:27:22.130997854 +0200
++++ -	2020-09-19 13:36:44.503955926 +0200
+@@ -106,12 +106,6 @@
+                 set(Qt5Gui_${_cmake_lib_name}_LIBRARY ${_lib})
+             else()
+                 find_library(Qt5Gui_${_cmake_lib_name}_LIBRARY ${_lib}
+-!!IF !isEmpty(CROSS_COMPILE)
+-                    PATHS \"${LibDir}\"
+-!!IF !mac
+-                    NO_DEFAULT_PATH
+-!!ENDIF
+-!!ENDIF
+                 )
+             endif()
+ !!IF mac
diff --git a/srcpkgs/qt5/patches/0060-upstream-65243ad7.patch b/srcpkgs/qt5/patches/0060-upstream-65243ad7.patch
new file mode 100644
index 00000000000..d11ae1d8865
--- /dev/null
+++ b/srcpkgs/qt5/patches/0060-upstream-65243ad7.patch
@@ -0,0 +1,87 @@
+From 65243ad7aef48af4689ea4454916b504025b5051 Mon Sep 17 00:00:00 2001
+From: Friedemann Kleint <Friedemann.Kleint@qt.io>
+Date: Fri, 25 Sep 2020 14:10:58 +0200
+Subject: Emit QScreen::geometryChanged when the logical DPI changes
+
+Add the missing call to QScreenPrivate::emitGeometryChangeSignals()
+along with an emission of physicalDotsPerInchChanged()
+since that is calculated from geometry and physical size.
+
+Rearrange the code in
+QGuiApplicationPrivate::processScreenGeometryChange()
+to prevent duplicate emissions of geometryChanged(),
+physicalDotsPerInchChanged() which this change would introduce.
+
+Amends 5290027e3bab75f14fc0a2b7c206594d9cb91e76.
+
+Task-number: QTBUG-76902
+Task-number: QTBUG-79248
+Fixes: QTBUG-86604
+Change-Id: I3dc2ec5ccd9c6413e92f9246242f323e8afc5e57
+Reviewed-by: David Edmundson <davidedmundson@kde.org>
+(cherry picked from commit 5c7307775d32ae0a54acad8ae7a1c9d3cff7d45e)
+Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
+---
+ src/gui/kernel/qguiapplication.cpp | 11 +++++------
+ src/gui/kernel/qscreen.cpp         |  6 ++++++
+ 2 files changed, 11 insertions(+), 6 deletions(-)
+
+diff --git a/src/gui/kernel/qguiapplication.cpp b/src/gui/kernel/qguiapplication.cpp
+index 239a78313c..ef09060581 100644
+--- qtbase/src/gui/kernel/qguiapplication.cpp
++++ qtbase/src/gui/kernel/qguiapplication.cpp
+@@ -3162,13 +3162,14 @@ void QGuiApplicationPrivate::processScreenGeometryChange(QWindowSystemInterfaceP
+     bool availableGeometryChanged = e->availableGeometry != s->d_func()->availableGeometry;
+     s->d_func()->availableGeometry = e->availableGeometry;
+ 
+-    if (geometryChanged) {
+-        Qt::ScreenOrientation primaryOrientation = s->primaryOrientation();
++    const Qt::ScreenOrientation primaryOrientation = s->primaryOrientation();
++    if (geometryChanged)
+         s->d_func()->updatePrimaryOrientation();
+ 
+-        emit s->geometryChanged(s->geometry());
++    s->d_func()->emitGeometryChangeSignals(geometryChanged, availableGeometryChanged);
++
++    if (geometryChanged) {
+         emit s->physicalSizeChanged(s->physicalSize());
+-        emit s->physicalDotsPerInchChanged(s->physicalDotsPerInch());
+         emit s->logicalDotsPerInchChanged(s->logicalDotsPerInch());
+ 
+         if (s->primaryOrientation() != primaryOrientation)
+@@ -3178,8 +3179,6 @@ void QGuiApplicationPrivate::processScreenGeometryChange(QWindowSystemInterfaceP
+             updateFilteredScreenOrientation(s);
+     }
+ 
+-    s->d_func()->emitGeometryChangeSignals(geometryChanged, availableGeometryChanged);
+-
+     resetCachedDevicePixelRatio();
+ }
+ 
+diff --git a/src/gui/kernel/qscreen.cpp b/src/gui/kernel/qscreen.cpp
+index df628fcc73..a1afc1ba14 100644
+--- qtbase/src/gui/kernel/qscreen.cpp
++++ qtbase/src/gui/kernel/qscreen.cpp
+@@ -88,6 +88,9 @@ void QScreenPrivate::updateGeometriesWithSignals()
+ void QScreenPrivate::emitGeometryChangeSignals(bool geometryChanged, bool availableGeometryChanged)
+ {
+     Q_Q(QScreen);
++    if (geometryChanged)
++        emit q->geometryChanged(geometry);
++
+     if (availableGeometryChanged)
+         emit q->availableGeometryChanged(availableGeometry);
+ 
+@@ -96,6 +99,9 @@ void QScreenPrivate::emitGeometryChangeSignals(bool geometryChanged, bool availa
+         for (QScreen* sibling : siblings)
+             emit sibling->virtualGeometryChanged(sibling->virtualGeometry());
+     }
++
++    if (geometryChanged)
++        emit q->physicalDotsPerInchChanged(q->physicalDotsPerInch());
+ }
+ 
+ void QScreenPrivate::setPlatformScreen(QPlatformScreen *screen)
+-- 
+cgit v1.2.1
+
diff --git a/srcpkgs/qt5/template b/srcpkgs/qt5/template
index 8dd5b6eaaf2..1954048e2b1 100644
--- a/srcpkgs/qt5/template
+++ b/srcpkgs/qt5/template
@@ -1,7 +1,7 @@
 # Template file for 'qt5'
 pkgname=qt5
 version=5.15.1
-revision=1
+revision=2
 wrksrc="qt-everywhere-src-${version}"
 build_style=meta
 hostmakedepends="cmake clang flex perl glib-devel pkg-config

From fef400cec3d24aa1686d2ab5eeaf3c513c98a444 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Tue, 13 Oct 2020 23:41:13 +0700
Subject: [PATCH 021/312] Cataclysm-DDA-tiles: remove dependency:
 Cataclysm-DDA-tiles-data

---
 srcpkgs/Cataclysm-DDA/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/Cataclysm-DDA/template b/srcpkgs/Cataclysm-DDA/template
index 64262000719..7cc73c18306 100644
--- a/srcpkgs/Cataclysm-DDA/template
+++ b/srcpkgs/Cataclysm-DDA/template
@@ -1,7 +1,7 @@
 # Template file for 'Cataclysm-DDA'
 pkgname=Cataclysm-DDA
 version=0.E
-revision=3
+revision=4
 build_style=cmake
 configure_args="-DRELEASE=1 $(vopt_bool backtrace BACKTRACE) -DUSE_HOME_DIR=1 -DPREFIX=/usr"
 hostmakedepends="gettext pkg-config"
@@ -50,7 +50,7 @@ do_check() {
 
 Cataclysm-DDA-tiles_package() {
 	short_desc+=" - SDL tiles version"
-	depends="Cataclysm-DDA-data Cataclysm-DDA-tiles-data"
+	depends="Cataclysm-DDA-data"
 	replaces="Cataclysm-DDA-tiles-data>=0"
 	pkg_install() {
 		vmove usr/bin/cataclysm-tiles

From ab8199226ca0d4596e4854fe2a30e5487ec7385e Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Tue, 13 Oct 2020 23:42:00 +0700
Subject: [PATCH 022/312] Cendric: remove dependency Cendric-data

---
 srcpkgs/Cendric/template | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/srcpkgs/Cendric/template b/srcpkgs/Cendric/template
index 1cb0e84b3e9..d119619af35 100644
--- a/srcpkgs/Cendric/template
+++ b/srcpkgs/Cendric/template
@@ -1,13 +1,12 @@
 # Template file for 'Cendric'
 pkgname=Cendric
 version=1.1.3
-revision=2
+revision=3
 wrksrc="Cendric2-${version}"
 build_style=cmake
 configure_args="-DUSE_SYSTEM_SFML=on -DCENDRIC_EXTERNAL_DOCUMENT_FOLDER=on
  -DUSE_SYSTEM_PATHS=on"
 makedepends="SFML-devel"
-depends="Cendric-data"
 short_desc="RPG Platformer"
 maintainer="John <me@johnnynator.dev>"
 license="MIT, CC-BY-NC-SA-4.0"

From 425ed8dc5622b5f3f073771542006380e1c0c2e6 Mon Sep 17 00:00:00 2001
From: Helmut Pozimski <helmut@pozimski.eu>
Date: Tue, 13 Oct 2020 21:31:44 +0200
Subject: [PATCH 023/312] asunder: update to 2.9.7.

---
 srcpkgs/asunder/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/asunder/template b/srcpkgs/asunder/template
index ddf33bfec46..b176114f1f4 100644
--- a/srcpkgs/asunder/template
+++ b/srcpkgs/asunder/template
@@ -1,6 +1,6 @@
 # Template file for 'asunder'
 pkgname=asunder
-version=2.9.6
+version=2.9.7
 revision=1
 build_style=gnu-configure
 hostmakedepends="intltool pkg-config"
@@ -11,7 +11,7 @@ maintainer="Helmut Pozimski <helmut@pozimski.eu>"
 license="GPL-2.0-or-later"
 homepage="http://littlesvr.ca/asunder/"
 distfiles="http://littlesvr.ca/asunder/releases/asunder-${version}.tar.bz2"
-checksum=ea3c7fa65b2373461eb3d9f929aa85499aa00359a43dbbd80d1e1f48056a96f9
+checksum=c1c97cd34c04b8595e95df8a9a7dbc64a1e61f494b7a0cd2873802ad111874f4
 
 pre_build() {
 	vsed -i 's:cd syslogng && $(MAKE) install:true:' Makefile.in

From fb42fdc171a08e54b6748253a4ad7469ab86bf1c Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Sun, 11 Oct 2020 18:35:16 +0200
Subject: [PATCH 024/312] alpine: update to 2.24.

---
 srcpkgs/alpine/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/alpine/template b/srcpkgs/alpine/template
index 0efe0d0aa21..108c99547bb 100644
--- a/srcpkgs/alpine/template
+++ b/srcpkgs/alpine/template
@@ -1,8 +1,8 @@
 # Template file for 'alpine'
 pkgname=alpine
-version=2.23.2
-revision=3
-_githash=7b8875f8bb237a156a1250629e8c684706bd202f
+version=2.24
+revision=1
+_githash=3165f59b344fb4d56d161541f294754d56bcb372
 _gitshort="${_githash:0:7}"
 wrksrc="${pkgname}-${_gitshort}"
 build_style=gnu-configure
@@ -17,7 +17,7 @@ maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="Apache-2.0"
 homepage="https://repo.or.cz/alpine.git"
 distfiles="https://repo.or.cz/alpine.git/snapshot/${_githash}.tar.gz"
-checksum=07593d4a47d48f0253ad341f0baf0d1a17eb2b9356a1c96abc0f15688d8fd3b4
+checksum=aa8f55b32732f8ea49e23cb11d9151e9ecb0dd1e057f25131988df69fbebc855
 
 post_extract() {
 	sed -i -e '/run test program/s/^/: /' \

From 7bcc2ecb6ee776b7dd3e5a1642b7fcaa3b696ad4 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Sun, 11 Oct 2020 18:51:37 +0200
Subject: [PATCH 025/312] apk-tools: update to 2.12.0.

---
 srcpkgs/apk-tools/patches/includes.patch | 21 ---------------------
 srcpkgs/apk-tools/template               | 15 ++++++++-------
 2 files changed, 8 insertions(+), 28 deletions(-)
 delete mode 100644 srcpkgs/apk-tools/patches/includes.patch

diff --git a/srcpkgs/apk-tools/patches/includes.patch b/srcpkgs/apk-tools/patches/includes.patch
deleted file mode 100644
index 606b421ba2f..00000000000
--- a/srcpkgs/apk-tools/patches/includes.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- src/archive.c.orig  2018-10-19 14:12:08.563391676 +0200
-+++ src/archive.c       2018-10-19 14:12:34.374508920 +0200
-@@ -24,6 +24,7 @@
- #include <limits.h>
- #include <stdint.h>
- #include <stdlib.h>
-+#include <sys/sysmacros.h>
-
- #include "apk_defines.h"
- #include "apk_print.h"
-
---- src/database.c.orig 2018-10-19 14:13:54.465872730 +0200
-+++ src/database.c      2018-10-19 14:14:11.279949108 +0200
-@@ -28,6 +28,7 @@
- #include <sys/mount.h>
- #include <sys/statvfs.h>
- #include <linux/magic.h>
-+#include <sys/sysmacros.h>
-
- #include "apk_defines.h"
- #include "apk_package.h"
diff --git a/srcpkgs/apk-tools/template b/srcpkgs/apk-tools/template
index 87ecbd8a144..dbdc782a0a9 100644
--- a/srcpkgs/apk-tools/template
+++ b/srcpkgs/apk-tools/template
@@ -1,19 +1,20 @@
 # Template file for 'apk-tools'
 pkgname=apk-tools
-version=2.10.5
-revision=2
+version=2.12.0
+revision=1
 build_style=gnu-makefile
-make_build_args="LUAAPK="
-hostmakedepends="pkg-config"
-makedepends="libressl-devel zlib-devel lua52-devel"
+# Link libapk statically
+make_build_args="LUAAPK=no LDFLAGS_apk.static= static"
+hostmakedepends="pkg-config lua53 lua53-zlib"
+makedepends="libressl-devel zlib-devel"
 short_desc="Alpine Package Keeper (Alpine package manager)"
 maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="GPL-2.0-only"
 homepage="http://git.alpinelinux.org/cgit/apk-tools"
 distfiles="http://git.alpinelinux.org/cgit/${pkgname}/snapshot/${pkgname}-${version}.tar.bz2"
-checksum=d0de1793ff56d4a311841cf4f13a51bb1cc1c0a259d8748c1e633f8f11c6f965
+checksum=763ed44a5b33f8cf6054b9ad6de53c355a37dcdf954024bbc59b953c675b78c6
 CFLAGS="-Wno-error"
 
 do_install() {
-	vbin src/apk
+	vbin src/apk.static apk
 }

From a8549b32e5dc303268d5dc019994b85a374752a7 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Sun, 11 Oct 2020 19:09:57 +0200
Subject: [PATCH 026/312] borg: update to 1.1.14.

---
 srcpkgs/borg/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/borg/template b/srcpkgs/borg/template
index de4d757e342..8d7e50b445a 100644
--- a/srcpkgs/borg/template
+++ b/srcpkgs/borg/template
@@ -1,7 +1,7 @@
 # Template file for 'borg'
 pkgname=borg
-version=1.1.13
-revision=3
+version=1.1.14
+revision=1
 wrksrc="borgbackup-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools python3-devel libressl-devel"
@@ -13,7 +13,7 @@ license="BSD-3-Clause"
 homepage="https://borgbackup.github.io/"
 changelog="https://borgbackup.readthedocs.io/en/stable/changes.html#changelog"
 distfiles="${PYPI_SITE}/b/borgbackup/borgbackup-${version}.tar.gz"
-checksum=164a8666a61071ce2fa6c60627c7646f12e3a8e74cd38f046be72f5ea91b3821
+checksum=7dbb0747cc948673f695cd6de284af215f810fed2eb2a615ef26ddc7c691edba
 
 export BORG_OPENSSL_PREFIX="${XBPS_CROSS_BASE}/usr"
 export BORG_LIBLZ4_PREFIX="${XBPS_CROSS_BASE}/usr"

From ed5de3eececea88c3517c2e77ecfba8bd579859a Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Sun, 11 Oct 2020 19:10:00 +0200
Subject: [PATCH 027/312] fzf: update to 0.23.1.

---
 srcpkgs/fzf/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/fzf/template b/srcpkgs/fzf/template
index 948d4b58a16..405061a6c59 100644
--- a/srcpkgs/fzf/template
+++ b/srcpkgs/fzf/template
@@ -1,7 +1,7 @@
 # Template file for 'fzf'
 pkgname=fzf
-version=0.22.0
-revision=2
+version=0.23.1
+revision=1
 build_style=go
 go_import_path=github.com/junegunn/fzf
 hostmakedepends="git"
@@ -12,7 +12,7 @@ license="MIT"
 homepage="https://github.com/junegunn/fzf"
 changelog="https://raw.githubusercontent.com/junegunn/fzf/master/CHANGELOG.md"
 distfiles="https://github.com/junegunn/fzf/archive/${version}.tar.gz"
-checksum=3090748bb656333ed98490fe62133760e5da40ba4cd429a8142b4a0b69d05586
+checksum=07576e47d2d446366eb7806fd9f825a2340cc3dc7f799f1f53fe038ca9bf30f6
 
 post_install() {
 	cd ${wrksrc}

From 54f4ff111d99bcfbf5bfb62c200a03ec19833e60 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Sun, 11 Oct 2020 19:10:22 +0200
Subject: [PATCH 028/312] python3-boto3: update to 1.15.16.

---
 srcpkgs/python3-boto3/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-boto3/template b/srcpkgs/python3-boto3/template
index 46fe01e4725..b7b2ad01979 100644
--- a/srcpkgs/python3-boto3/template
+++ b/srcpkgs/python3-boto3/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-boto3'
 pkgname=python3-boto3
-version=1.15.9
-revision=2
+version=1.15.16
+revision=1
 wrksrc="boto3-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,7 +11,7 @@ maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="MIT"
 homepage="https://github.com/boto/boto3"
 distfiles="https://github.com/boto/boto3/archive/${version}.tar.gz"
-checksum=01fcdb50d9b845c28ee897b47f603447ac60f271132d7848827c606c390b0343
+checksum=0947cc0f878880e54075dce924e87c78aad64095fce6f4210594ad330726fef0
 
 post_install() {
 	vlicense LICENSE

From a7aef9ddc42aa8e91125e238374704030feadb3a Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Tue, 13 Oct 2020 22:30:29 +0200
Subject: [PATCH 029/312] dos2unix: update to 7.4.2.

---
 srcpkgs/dos2unix/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/dos2unix/template b/srcpkgs/dos2unix/template
index bc5293f459e..5aaf52636c4 100644
--- a/srcpkgs/dos2unix/template
+++ b/srcpkgs/dos2unix/template
@@ -1,6 +1,6 @@
 # Template file for 'dos2unix'
 pkgname=dos2unix
-version=7.4.1
+version=7.4.2
 revision=1
 build_style=gnu-makefile
 hostmakedepends="gettext"
@@ -9,7 +9,7 @@ maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="BSD-2-Clause"
 homepage="http://waterlan.home.xs4all.nl/dos2unix.html"
 distfiles="http://waterlan.home.xs4all.nl/${pkgname}/${pkgname}-${version}.tar.gz"
-checksum=1cd58a60b03ed28fa39046102a185c5e88c4f7665e1e0417c25de7f8b9f78623
+checksum=6035c58df6ea2832e868b599dfa0d60ad41ca3ecc8aa27822c4b7a9789d3ae01
 
 post_install() {
 	rm -rf ${DESTDIR}/usr/share/doc/${pkgname}-${version}

From 4dfd6a6775be009a9695e3bd36efa2633943e747 Mon Sep 17 00:00:00 2001
From: travankor <travankor@tuta.io>
Date: Tue, 22 Sep 2020 09:12:34 -0700
Subject: [PATCH 030/312] falkon: add KDE build option.

This allows to build falkon without optional KDE libraries.
---
 srcpkgs/falkon/template | 8 ++++++--
 1 file changed, 6 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/falkon/template b/srcpkgs/falkon/template
index 6c9f1f201ad..70d3df9a9c0 100644
--- a/srcpkgs/falkon/template
+++ b/srcpkgs/falkon/template
@@ -4,11 +4,11 @@ version=3.1.0
 revision=4
 build_style=cmake
 hostmakedepends="extra-cmake-modules gettext pkg-config
- qt5-qmake qt5-host-tools python3 kcoreaddons"
+ qt5-qmake qt5-host-tools python3 $(vopt_if kde kcoreaddons)"
 makedepends="qt5-devel qt5-plugin-mysql qt5-plugin-odbc qt5-plugin-pgsql
  qt5-plugin-sqlite qt5-plugin-tds qt5-declarative-devel qt5-webchannel-devel
  qt5-webengine-devel qt5-location-devel qt5-x11extras-devel qt5-tools-devel
- kwallet-devel kio-devel purpose-devel"
+ $(vopt_if kde 'kwallet-devel kio-devel purpose-devel' 'ki18n-devel xcb-util-devel')"
 depends="qt5-plugin-sqlite"
 short_desc="Cross-platform Qt Web Browser"
 maintainer="Helmut Pozimski <helmut@pozimski.eu>"
@@ -18,3 +18,7 @@ distfiles="${KDE_SITE}/falkon/${version%.*}/falkon-${version}.tar.xz"
 checksum=ce743cd80c0e2d525a784e29c9b487f73480119b0567f9ce8ef1f44cca527587
 
 LDFLAGS="-Wl,--no-fatal-warnings"
+
+build_options="kde"
+desc_option_kde="KDE integration"
+build_options_default="kde"

From 6ae3f5f4deedbb0e2d49ca7991349f440bc7bc26 Mon Sep 17 00:00:00 2001
From: Paper <paper@tilde.institute>
Date: Tue, 13 Oct 2020 23:11:12 +0200
Subject: [PATCH 031/312] terminator: update to 2.0.1, add dependency

close: #25575
---
 srcpkgs/terminator/template | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/terminator/template b/srcpkgs/terminator/template
index 644c42b5af9..db55cc6c38c 100644
--- a/srcpkgs/terminator/template
+++ b/srcpkgs/terminator/template
@@ -1,14 +1,15 @@
 # Template file for 'terminator'
 pkgname=terminator
-version=1.92
-revision=2
+version=2.0.1
+revision=1
 build_style=python3-module
 hostmakedepends="intltool python3-setuptools"
 depends="desktop-file-utils gsettings-desktop-schemas libkeybinder3 libnotify
- python3-dbus python3-gobject python3-psutil vte3 pango"
+ python3-dbus python3-gobject python3-psutil python3-configobj vte3 pango"
 short_desc="Tiling terminal emulator application"
 maintainer="Enno Boland <gottox@voidlinux.org>"
 license="GPL-2.0-only"
 homepage="https://gnome-terminator.org"
+changelog="https://raw.githubusercontent.com/gnome-terminator/terminator/master/CHANGELOG.md"
 distfiles="https://github.com/gnome-terminator/terminator/releases/download/v$version/terminator-$version.tar.gz"
-checksum=1f94d676ad42c814e159e6374dca81e4e68ac1f03f2013395ba99b69c17573f1
+checksum=e6a21ea18c48b9dcb8fac3b48fd90bc49768de13c2a749047c46a6e0f14abb24

From c0c133a92d5d23f3132cf6b0a82f3cb9b5dbc3a3 Mon Sep 17 00:00:00 2001
From: Stefano Ragni <st3r4g@protonmail.com>
Date: Thu, 1 Oct 2020 15:07:20 +0200
Subject: [PATCH 032/312] New package: python3-pytaglib-1.4.6

---
 srcpkgs/python3-pytaglib/template | 14 ++++++++++++++
 1 file changed, 14 insertions(+)
 create mode 100644 srcpkgs/python3-pytaglib/template

diff --git a/srcpkgs/python3-pytaglib/template b/srcpkgs/python3-pytaglib/template
new file mode 100644
index 00000000000..98121d054b9
--- /dev/null
+++ b/srcpkgs/python3-pytaglib/template
@@ -0,0 +1,14 @@
+# Template file for 'python3-pytaglib'
+pkgname=python3-pytaglib
+version=1.4.6
+revision=1
+wrksrc="pytaglib-${version}"
+build_style=python3-module
+hostmakedepends="python3-setuptools"
+makedepends="python3-devel taglib-devel"
+short_desc="Python bindings for the TagLib C++ library"
+maintainer="Stefano Ragni <st3r4g@protonmail.com>"
+license="GPL-3.0-or-later"
+homepage="https://github.com/supermihi/pytaglib"
+distfiles="https://github.com/supermihi/pytaglib/archive/v${version}.tar.gz"
+checksum=360b12d5b4c948cebf75acf86fac6b33a3f044eab6fcfe8949a1cd0f9c22bd25

From aa9787a97d84ddd8c2f6836e015b2a15c654892a Mon Sep 17 00:00:00 2001
From: Stefano Ragni <st3r4g@protonmail.com>
Date: Thu, 1 Oct 2020 15:07:58 +0200
Subject: [PATCH 033/312] nicotine+: update to 2.1.2

Closes: #25229 [via git-merge-pr]
---
 srcpkgs/nicotine+/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/nicotine+/template b/srcpkgs/nicotine+/template
index 59d92e13ce2..b84d54f90e0 100644
--- a/srcpkgs/nicotine+/template
+++ b/srcpkgs/nicotine+/template
@@ -1,14 +1,14 @@
 # Template file for 'nicotine+'
 pkgname=nicotine+
-version=2.0.1
-revision=2
+version=2.1.2
+revision=1
 wrksrc="nicotine-plus-${version}"
 build_style=python3-module
-hostmakedepends="python3"
-depends="gtk+3 python3-gobject python3-miniupnpc python3-mutagen"
+hostmakedepends="python3-setuptools gettext"
+depends="gtk+3 python3-gobject python3-miniupnpc python3-pytaglib"
 short_desc="Soulseek music-sharing client written in Python"
 maintainer="doggone <doggone@airmail.cc>"
 license="GPL-3.0-or-later"
 homepage="https://nicotine-plus.org"
 distfiles="https://github.com/Nicotine-Plus/nicotine-plus/archive/${version}.tar.gz"
-checksum=229acf6e287e1c3ae7d07b04b85230c3fa2edc0c17298583e2f13dd986bbda5a
+checksum=3ed18ade97183c632836eb8e304a515fc19a35babb46cc6e6747bcfd8205dcdf

From ad4688a1feb888a9b79abbace08fedc8919cb245 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Wed, 14 Oct 2020 10:24:50 +0200
Subject: [PATCH 034/312] perl-WWW-Mechanize: update to 2.02.

---
 srcpkgs/perl-WWW-Mechanize/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/perl-WWW-Mechanize/template b/srcpkgs/perl-WWW-Mechanize/template
index c3dce8e3724..3af38d74fd0 100644
--- a/srcpkgs/perl-WWW-Mechanize/template
+++ b/srcpkgs/perl-WWW-Mechanize/template
@@ -1,6 +1,6 @@
 # Template file for 'perl-WWW-Mechanize'
 pkgname=perl-WWW-Mechanize
-version=2.01
+version=2.02
 revision=1
 archs=noarch
 wrksrc="${pkgname/perl-/}-${version}"
@@ -17,4 +17,4 @@ maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="Artistic-1.0-Perl, GPL-1.0-or-later"
 homepage="https://metacpan.org/release/WWW-Mechanize"
 distfiles="${CPAN_SITE}/WWW/${pkgname/perl-/}-${version}.tar.gz"
-checksum=d875564942943a4a23174fffbe7eaea787b6ab7401aa98cbd63e7467df3133ca
+checksum=67e2c449a7fe9cc2e5471f4c92bfb1875a7c6cea955479294ac45b8cbd5dc45f

From 5ff9e4ae314d87b31fddbe53084373cb7dbdc50c Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Wed, 14 Oct 2020 10:24:54 +0200
Subject: [PATCH 035/312] ugrep: update to 3.0.2.

---
 srcpkgs/ugrep/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/ugrep/template b/srcpkgs/ugrep/template
index 372be51be26..ca0e49eeba6 100644
--- a/srcpkgs/ugrep/template
+++ b/srcpkgs/ugrep/template
@@ -1,6 +1,6 @@
 # Template file for 'ugrep'
 pkgname=ugrep
-version=3.0.1
+version=3.0.2
 revision=1
 build_style=gnu-configure
 configure_args="--disable-avx"
@@ -10,4 +10,4 @@ maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="BSD-3-Clause"
 homepage="https://github.com/Genivia/ugrep"
 distfiles="https://github.com/Genivia/ugrep/archive/v${version}.tar.gz"
-checksum=4508d193740f2ccbdb64a5fe0130e3e87bc8770adfae7eaf9ba15b33824d5d76
+checksum=b383590b11cc6ddb6e673371ca3b9656c1f7b5315792dcdff6d8484f5e0c77ca

From ae715ecf043d87eed29f4a490ca0ef105fadffe2 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Wed, 14 Oct 2020 11:40:58 +0200
Subject: [PATCH 036/312] Rocket.Chat-Desktop: update to 3.0.3.

---
 srcpkgs/Rocket.Chat-Desktop/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/Rocket.Chat-Desktop/template b/srcpkgs/Rocket.Chat-Desktop/template
index 5dc9551283f..50b063a1349 100644
--- a/srcpkgs/Rocket.Chat-Desktop/template
+++ b/srcpkgs/Rocket.Chat-Desktop/template
@@ -1,6 +1,6 @@
 # Template file for 'Rocket.Chat-Desktop'
 pkgname=Rocket.Chat-Desktop
-version=3.0.2
+version=3.0.3
 revision=1
 _electron_ver=10
 wrksrc="Rocket.Chat.Electron-${version}"
@@ -12,7 +12,7 @@ maintainer="John <me@johnnynator.dev>"
 license="MIT"
 homepage="https://rocket.chat/"
 distfiles="https://github.com/RocketChat/Rocket.Chat.Electron/archive/${version}.tar.gz"
-checksum=5ca518421dde4fbbf5f3b3b1904dd63562bc43f16bb9c169ffed07022033a0df
+checksum=c8c4f4d29ffe7cee825e7967bdabe1abdadc7153f169c36ee971b491a29628b1
 
 export USE_SYSTEM_APP_BUILDER=true
 

From 09b545dcab5de437099dbe30bb0a924797348df9 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Wed, 14 Oct 2020 12:56:47 +0200
Subject: [PATCH 037/312] Rocket.Chat-Desktop: mark broken on i686

---
 srcpkgs/Rocket.Chat-Desktop/template | 4 ++++
 1 file changed, 4 insertions(+)

diff --git a/srcpkgs/Rocket.Chat-Desktop/template b/srcpkgs/Rocket.Chat-Desktop/template
index 50b063a1349..6b9879918fb 100644
--- a/srcpkgs/Rocket.Chat-Desktop/template
+++ b/srcpkgs/Rocket.Chat-Desktop/template
@@ -16,6 +16,10 @@ checksum=c8c4f4d29ffe7cee825e7967bdabe1abdadc7153f169c36ee971b491a29628b1
 
 export USE_SYSTEM_APP_BUILDER=true
 
+case "$XBPS_TARGET_MACHINE" in
+	i686*) broken="https://build.voidlinux.org/builders/i686_builder/builds/27897/steps/shell_3/logs/stdio"
+esac
+
 do_configure() {
 	# we can't make electron skip binary download as that fails in do_build
 	# so instead, force a bogus architecture so it downloads its binary

From 6c7fdc4e6b610df1d38c21480c46980952452e9d Mon Sep 17 00:00:00 2001
From: Piraty <piraty1@inbox.ru>
Date: Wed, 14 Oct 2020 13:22:57 +0200
Subject: [PATCH 038/312] python3-mygpoclient: apply patch for python3.9

---
 .../python3-fix-comparison-with-literal.patch | 37 +++++++++++++++++++
 srcpkgs/python3-mygpoclient/template          |  4 +-
 2 files changed, 39 insertions(+), 2 deletions(-)
 create mode 100644 srcpkgs/python3-mygpoclient/patches/python3-fix-comparison-with-literal.patch

diff --git a/srcpkgs/python3-mygpoclient/patches/python3-fix-comparison-with-literal.patch b/srcpkgs/python3-mygpoclient/patches/python3-fix-comparison-with-literal.patch
new file mode 100644
index 00000000000..b9425ea1eae
--- /dev/null
+++ b/srcpkgs/python3-mygpoclient/patches/python3-fix-comparison-with-literal.patch
@@ -0,0 +1,37 @@
+upstream: yes
+
+From bdf8c8ce38cff8938bab3544c6dbb0d509ce7720 Mon Sep 17 00:00:00 2001
+From: Eric Le Lay <elelay@macports.org>
+Date: Sun, 22 Mar 2020 16:19:08 +0100
+Subject: [PATCH] use == for comparison with literal
+
+See https://bugs.python.org/issue34850
+---
+ mygpoclient/locator.py | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/mygpoclient/locator.py b/mygpoclient/locator.py
+index c0dc9d7..810f973 100644
+--- mygpoclient/locator.py
++++ mygpoclient/locator.py
+@@ -317,17 +317,17 @@ def settings_uri(self, type, scope_param1, scope_param2):
+ 
+         filename = self._username + '/%(type)s.json' % locals()
+ 
+-        if type is 'device':
++        if type == 'device':
+             if scope_param1 is None:
+                 raise ValueError('Devicename not specified')
+             filename += '?device=%(scope_param1)s' % locals()
+ 
+-        if type is 'podcast':
++        if type == 'podcast':
+             if scope_param1 is None:
+                 raise ValueError('Podcast URL not specified')
+             filename += '?podcast=%s' % quote(scope_param1)
+ 
+-        if type is 'episode':
++        if type == 'episode':
+             if (scope_param1 is None) or (scope_param2 is None):
+                 raise ValueError('Podcast or Episode URL not specified')
+             filename += '?podcast=%s&episode=%s' % (quote(scope_param1), quote(scope_param2))
diff --git a/srcpkgs/python3-mygpoclient/template b/srcpkgs/python3-mygpoclient/template
index a3d39790977..6ed17293703 100644
--- a/srcpkgs/python3-mygpoclient/template
+++ b/srcpkgs/python3-mygpoclient/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-mygpoclient'
 pkgname=python3-mygpoclient
 version=1.8
-revision=5
+revision=6
 wrksrc="mygpoclient-${version}"
 build_style=python3-module
 hostmakedepends="python3-devel"
@@ -15,5 +15,5 @@ checksum=65fcb3ab220a2ba2d32a77f969b423a2f663413b6c485b7b02e5a955b28e68d2
 conflicts="python-mygpoclient>=0"
 
 pre_build() {
-	sed -i '/share\/man\/man1/d' setup.py
+	vsed -i '/share\/man\/man1/d' setup.py
 }

From 85c057caf1f5ac7267487f8b0b9ee7f3c8c7b758 Mon Sep 17 00:00:00 2001
From: Toyam Cox <Vaelatern@voidlinux.org>
Date: Thu, 1 Oct 2020 14:02:33 -0400
Subject: [PATCH 039/312] gromit-mpx: update to 1.3.1.

---
 srcpkgs/gromit-mpx/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/gromit-mpx/template b/srcpkgs/gromit-mpx/template
index e04cb81c875..ebedebbce5c 100644
--- a/srcpkgs/gromit-mpx/template
+++ b/srcpkgs/gromit-mpx/template
@@ -1,13 +1,13 @@
 # Template file for 'gromit-mpx'
 pkgname=gromit-mpx
-version=1.3
+version=1.3.1
 revision=1
 build_style=cmake
 hostmakedepends="pkg-config"
 makedepends="gtk+3-devel libappindicator-devel libdbusmenu-glib-devel"
 short_desc="Multi-pointer annotation tool"
 maintainer="Toyam Cox <Vaelatern@gmail.com>"
-license="GPL-2"
+license="GPL-2.0-only"
 homepage="https://github.com/bk138/gromit-mpx"
 distfiles="https://github.com/bk138/${pkgname}/archive/${version}.tar.gz"
-checksum=f9decb58e733f60de33efd88fa396d99d4d966a23a6dbb3f813f090de3b8eb72
+checksum=1639e5e5365daf48826808c882ccd3c6f0483bb4e707332b7a057b6a57398ff0

From 8dbf5e11336dc5c6e52f3ce6f8bafe6bd4f5c313 Mon Sep 17 00:00:00 2001
From: q66 <daniel@octaforge.org>
Date: Wed, 14 Oct 2020 16:00:13 +0200
Subject: [PATCH 040/312] monero-gui: fix typo

---
 srcpkgs/monero-gui/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/monero-gui/template b/srcpkgs/monero-gui/template
index 1439a122b3f..777c197370a 100644
--- a/srcpkgs/monero-gui/template
+++ b/srcpkgs/monero-gui/template
@@ -48,7 +48,7 @@ case "$XBPS_TARGET_MACHINE" in
 	mips*) configure_args+=" -DARCH=mipsr32 -DNO_AES=ON" ;;
 	ppc64le*) configure_args+=" -DARCH=ppc64le" ;;
 	ppc64*) configure_args+=" -DARCH=ppc64" ;;
-	ppc*) configure_arch+=" -DARCH=ppc"     ;;
+	ppc*) configure_args+=" -DARCH=ppc"     ;;
 	*) configure_args+=" -DARCH=default" ;;
 esac
 

From adfac4fd3b299bee85e6cd082e0f83a66b3a864c Mon Sep 17 00:00:00 2001
From: q66 <daniel@octaforge.org>
Date: Wed, 14 Oct 2020 16:39:37 +0200
Subject: [PATCH 041/312] Rocket.Chat-Desktop: maybe unbreak on i686

---
 srcpkgs/Rocket.Chat-Desktop/template | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/Rocket.Chat-Desktop/template b/srcpkgs/Rocket.Chat-Desktop/template
index 6b9879918fb..59d7363dac2 100644
--- a/srcpkgs/Rocket.Chat-Desktop/template
+++ b/srcpkgs/Rocket.Chat-Desktop/template
@@ -16,15 +16,16 @@ checksum=c8c4f4d29ffe7cee825e7967bdabe1abdadc7153f169c36ee971b491a29628b1
 
 export USE_SYSTEM_APP_BUILDER=true
 
-case "$XBPS_TARGET_MACHINE" in
-	i686*) broken="https://build.voidlinux.org/builders/i686_builder/builds/27897/steps/shell_3/logs/stdio"
-esac
-
 do_configure() {
 	# we can't make electron skip binary download as that fails in do_build
 	# so instead, force a bogus architecture so it downloads its binary
 	# artifact, it will use the system one later anyway
-	npm_config_arch=x64 \
+	# but this appears to fail on i686, so don't override there
+	local carch=x64
+	case "$XBPS_TARGET_MACHINE" in
+		i686*) carch=ia32 ;;
+	esac
+	npm_config_arch=$carch \
 		yarn upgrade electron@"$(</usr/lib/electron${_electron_ver}/version)" \
 			--non-interactive
 }

From f72199b9343e6498d817fa20bc00ac656b42f427 Mon Sep 17 00:00:00 2001
From: Daniel Lewan <vision360.daniel@gmail.com>
Date: Sun, 11 Oct 2020 10:30:38 +0200
Subject: [PATCH 042/312] lf: update to r17.

Closes: #25513 [via git-merge-pr]
---
 srcpkgs/lf/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/lf/template b/srcpkgs/lf/template
index ca60fe15b2e..304b10b6209 100644
--- a/srcpkgs/lf/template
+++ b/srcpkgs/lf/template
@@ -1,6 +1,6 @@
 # Template file for 'lf'
 pkgname=lf
-version=r16
+version=r17
 revision=1
 build_style=go
 go_import_path="github.com/gokcehan/${pkgname}"
@@ -11,13 +11,13 @@ maintainer="Daniel Lewan <vision360.daniel@gmail.com>"
 license="MIT"
 homepage="https://github.com/gokcehan/lf"
 distfiles="https://github.com/gokcehan/lf/archive/${version}.tar.gz"
-checksum=92031b31c194f0af11fc0f00d575db0dc9bb2c6c80bccc73fa19de02e82d00b1
+checksum=a6906f6c40de8cbd643d0dc6a7a25b83a6403f0e87a8352289189bea17123342
 
 post_install() {
 	vlicense LICENSE
 	vsconf etc/lfrc.example lfrc
 	vman lf.1
-	vinstall etc/lf.fish 644 usr/share/fish/vendor_completions.d
-	vinstall etc/lf.zsh 644 usr/share/zsh/site-functions _lf
+	vcompletion etc/lf.fish fish
+	vcompletion etc/lf.zsh zsh
 	vinstall lf.desktop 644 usr/share/applications
 }

From dfa0a43502391eeb94b22d2adcf429b60c68bcb6 Mon Sep 17 00:00:00 2001
From: Daniel Lewan <vision360.daniel@gmail.com>
Date: Sun, 11 Oct 2020 10:41:29 +0200
Subject: [PATCH 043/312] lazygit: update to 0.23.1.

Closes: #25514 [via git-merge-pr]
---
 srcpkgs/lazygit/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/lazygit/template b/srcpkgs/lazygit/template
index 9615f564489..abaf69ade0d 100644
--- a/srcpkgs/lazygit/template
+++ b/srcpkgs/lazygit/template
@@ -1,6 +1,6 @@
 # Template file for 'lazygit'
 pkgname=lazygit
-version=0.22.7
+version=0.23.1
 revision=1
 build_style=go
 go_import_path=github.com/jesseduffield/lazygit
@@ -11,7 +11,7 @@ maintainer="Nathan Owens <ndowens04@gmail.com>"
 license="MIT"
 homepage="https://github.com/jesseduffield/lazygit"
 distfiles="https://github.com/jesseduffield/lazygit/archive/v${version}.tar.gz"
-checksum=712228f82e4e80f72f4437037c3dbfbf1d83a4f1ee7b8205f741175c4d00c60a
+checksum=754a7751f609305fdbfc6630ec18cfd22f4b7b8e77ed9084e9e11a789a5788de
 
 post_install() {
 	vlicense LICENSE

From 678882c65636b6322f7196fd765a30ed1d2d06eb Mon Sep 17 00:00:00 2001
From: Daniel Lewan <vision360.daniel@gmail.com>
Date: Sun, 11 Oct 2020 11:19:07 +0200
Subject: [PATCH 044/312] kakoune: update to 2020.09.01.

Closes: #25515 [via git-merge-pr]
---
 srcpkgs/kakoune/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kakoune/template b/srcpkgs/kakoune/template
index 58aea3b2fed..934795a45f6 100644
--- a/srcpkgs/kakoune/template
+++ b/srcpkgs/kakoune/template
@@ -1,7 +1,7 @@
 # Template file for 'kakoune'
 pkgname=kakoune
 reverts=20180409_1
-version=2020.08.04
+version=2020.09.01
 revision=1
 build_wrksrc="src"
 build_style=gnu-makefile
@@ -14,4 +14,4 @@ maintainer="Jakub Skrzypnik <j.skrzypnik@openmailbox.org>"
 license="Unlicense"
 homepage="https://kakoune.org"
 distfiles="https://github.com/mawww/kakoune/releases/download/v${version}/kakoune-${version}.tar.bz2"
-checksum=02469fac1ff83191165536fa52f01907db5be0a734bc90570924b3edbb9cf121
+checksum=861a89c56b5d0ae39628cb706c37a8b55bc289bfbe3c72466ad0e2757ccf0175

From e4296f8c8c88e412a91bb78dd4f135fb4434f8b0 Mon Sep 17 00:00:00 2001
From: mobinmob <mobinmob@disroot.org>
Date: Sun, 11 Oct 2020 12:58:52 +0300
Subject: [PATCH 045/312] plata-theme: update to 0.9.9.

Closes: #25516 [via git-merge-pr]
---
 srcpkgs/plata-theme/template | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/plata-theme/template b/srcpkgs/plata-theme/template
index 7701b8598c7..266af145aed 100644
--- a/srcpkgs/plata-theme/template
+++ b/srcpkgs/plata-theme/template
@@ -1,8 +1,7 @@
 # Template file for 'plata-theme'
 pkgname=plata-theme
-version=0.9.8
+version=0.9.9
 revision=1
-archs=noarch
 build_style=gnu-configure
 configure_args="--enable-parallel --enable-telegram"
 hostmakedepends="automake libtool pkg-config glib-devel libxml2 sassc inkscape
@@ -14,7 +13,7 @@ maintainer="mobinmob <mobinmob@disroot.org>"
 license="CC-BY-SA-4.0, GPL-2.0-or-later"
 homepage="https://gitlab.com/tista500/plata-theme"
 distfiles="https://gitlab.com/tista500/plata-theme/-/archive/${version}/plata-theme-${version}.tar.gz"
-checksum=c9529b4a2087d75a87c9abff8250fa55cfc61667fa884d43d40f3e02be1261ad
+checksum=d5cc388b164990d2e88bae1db56ea296054c7c068e64875ec65378221327395c
 
 pre_configure() {
 	autoreconf -fi

From 93e8190f3d1f14f7131e3b59d239e070c3312b0c Mon Sep 17 00:00:00 2001
From: Daniel Lewan <vision360.daniel@gmail.com>
Date: Sun, 11 Oct 2020 12:04:14 +0200
Subject: [PATCH 046/312] just: update to 0.8.0.

Closes: #25518 [via git-merge-pr]
---
 srcpkgs/just/template | 8 ++++++--
 1 file changed, 6 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/just/template b/srcpkgs/just/template
index 054abc6f841..0c585b5929a 100644
--- a/srcpkgs/just/template
+++ b/srcpkgs/just/template
@@ -1,6 +1,6 @@
 # Template file for 'just'
 pkgname=just
-version=0.5.8
+version=0.8.0
 revision=1
 build_style=cargo
 short_desc="Just a command runner"
@@ -9,8 +9,12 @@ license="CC0-1.0"
 homepage="https://github.com/casey/just"
 changelog="https://raw.githubusercontent.com/casey/just/master/CHANGELOG.md"
 distfiles="https://github.com/casey/just/archive/v${version}.tar.gz"
-checksum=f0d3363f7e7604aeb355fe631421bccddb458756b5d951b25c071aa38d3e72a7
+checksum=624cf1681cf7df8e50b70f37b29e4194cf4ad7327a335fcdf94dd83b19e45a2b
 
 post_install() {
 	vlicense LICENSE
+	vman man/just.1
+	vcompletion completions/just.bash bash
+	vcompletion completions/just.fish fish
+	vcompletion completions/just.zsh  zsh
 }

From 78e70bb3c5d0e69887ab5810c30995f92fb0118d Mon Sep 17 00:00:00 2001
From: Gadzhi Kharkharov <me@kkga.me>
Date: Sun, 11 Oct 2020 13:33:11 +0300
Subject: [PATCH 047/312] godot: update to 3.2.3.

Closes: #25519 [via git-merge-pr]
---
 srcpkgs/godot/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/godot/template b/srcpkgs/godot/template
index dc0c3a90e36..5b17ece10d0 100644
--- a/srcpkgs/godot/template
+++ b/srcpkgs/godot/template
@@ -1,6 +1,6 @@
 # Template file for 'godot'
 pkgname=godot
-version=3.2.2
+version=3.2.3
 revision=1
 archs="x86_64* i686* aarch64* armv7* ppc64*"
 wrksrc="${pkgname}-${version}-stable"
@@ -27,7 +27,7 @@ maintainer="Nick Hahn <nick.hahn@hotmail.de>"
 license="MIT"
 homepage="https://www.godotengine.org/"
 distfiles="https://github.com/godotengine/${pkgname}/archive/${version}-stable.tar.gz"
-checksum=9a071aba23fc912976203d35212a94207b7cb667c0b5353b3525f9b7e6899017
+checksum=4c2a8e7da1ad05c6223b0ff6cf2be124dad6708b56a8ec9910dc2aaf82a553ae
 nocross=https://build.voidlinux.org/builders/armv7l_builder/builds/6342/steps/shell_3/logs/stdio
 
 CFLAGS+=" -fPIE -fPIC"

From 758d0757b8fcad9d0e3e1cb8805994d763cebbf7 Mon Sep 17 00:00:00 2001
From: Dash Eclipse <dash@ezup.dev>
Date: Sun, 11 Oct 2020 13:27:50 +0000
Subject: [PATCH 048/312] multimon-ng: update to 1.1.9.

Closes: #25522 [via git-merge-pr]
---
 srcpkgs/multimon-ng/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/multimon-ng/template b/srcpkgs/multimon-ng/template
index bed649b0c7d..80c0689d519 100644
--- a/srcpkgs/multimon-ng/template
+++ b/srcpkgs/multimon-ng/template
@@ -1,6 +1,6 @@
 # Template file for 'multimon-ng'
 pkgname=multimon-ng
-version=1.1.8
+version=1.1.9
 revision=1
 build_style=cmake
 configure_args="-DX11_SUPPORT=$(vopt_if x11 ON OFF)
@@ -11,7 +11,7 @@ maintainer="bra1nwave <brainwave@openmailbox.org>"
 license="GPL-2.0-or-later"
 homepage="https://github.com/EliasOenal/multimon-ng"
 distfiles="${homepage}/archive/${version}.tar.gz"
-checksum=a97c3107b6b1264e60a36220a286a5774578812604bc684aae146f47640373ac
+checksum=7426a599972eb2e22bdc9696531e6a9e3ee4f18949ed891cabe8fe9586a74854
 
 build_options="pulseaudio x11"
 build_options_default="pulseaudio x11"

From 02ac351351145329d99f622317ee2c8c2a5393c4 Mon Sep 17 00:00:00 2001
From: Neel Chotai <neel@chot.ai>
Date: Sun, 11 Oct 2020 18:33:22 +0100
Subject: [PATCH 049/312] flameshot: update to 0.8.4

Closes: #25527 [via git-merge-pr]
---
 srcpkgs/flameshot/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/flameshot/template b/srcpkgs/flameshot/template
index f1063a02c28..817723e2bf8 100644
--- a/srcpkgs/flameshot/template
+++ b/srcpkgs/flameshot/template
@@ -1,6 +1,6 @@
 # Template file for 'flameshot'
 pkgname=flameshot
-version=0.8.3
+version=0.8.4
 revision=1
 build_style=cmake
 hostmakedepends="qt5-qmake qt5-host-tools"
@@ -11,4 +11,4 @@ maintainer="Neel Chotai <neel@chot.ai>"
 license="GPL-3.0-or-later"
 homepage="https://github.com/lupoDharkael/flameshot"
 distfiles="https://github.com/lupoDharkael/flameshot/archive/v${version}.tar.gz"
-checksum=73b0e52d389518b58e4488931e14ef40d611a2bd8661c06e187c211fb947fd05
+checksum=e20739a9268212babf32db6944169afa206303ba38daff9e590f8ce6ce459f15

From a9188a6a4298ebd0b778c8911c55e1e48ba9875e Mon Sep 17 00:00:00 2001
From: Neel Chotai <neel@chot.ai>
Date: Sun, 11 Oct 2020 18:33:39 +0100
Subject: [PATCH 050/312] kibi: update to 0.2.1

Closes: #25528 [via git-merge-pr]
---
 srcpkgs/kibi/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kibi/template b/srcpkgs/kibi/template
index 9938ef9a790..03a41d180ff 100644
--- a/srcpkgs/kibi/template
+++ b/srcpkgs/kibi/template
@@ -1,6 +1,6 @@
 # Template file for 'kibi'
 pkgname=kibi
-version=0.2.0
+version=0.2.1
 revision=1
 build_style=cargo
 short_desc="Lightweight, configurable text editor"
@@ -8,7 +8,7 @@ maintainer="Neel Chotai <neel@chot.ai>"
 license="Apache-2.0, MIT"
 homepage="https://github.com/ilai-deutel/kibi"
 distfiles="https://github.com/ilai-deutel/kibi/archive/v${version}.tar.gz"
-checksum=7af69657ce50816e45e9111138cf9e050f74289bba3ceaa2a52e4715951c8885
+checksum=f6171a2c1be66aa52814b736d6c06ad9ad50b71869e4447196e16ecf951eb494
 
 post_install() {
 	vdoc README.md

From 57680d6bf0908ebccf336bb76fd8bd4ccaa1a734 Mon Sep 17 00:00:00 2001
From: Gadzhi Kharkharov <me@kkga.me>
Date: Mon, 12 Oct 2020 09:44:02 +0300
Subject: [PATCH 051/312] skim: update to 0.8.2.

Closes: #25537 [via git-merge-pr]
---
 srcpkgs/skim/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/skim/template b/srcpkgs/skim/template
index 4bbc8266af1..3dc02149524 100644
--- a/srcpkgs/skim/template
+++ b/srcpkgs/skim/template
@@ -1,6 +1,6 @@
 # Template file for 'skim'
 pkgname=skim
-version=0.8.0
+version=0.8.2
 revision=2
 build_style=cargo
 short_desc="Fuzzy Finder in rust"
@@ -8,7 +8,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://github.com/lotabout/skim"
 distfiles="https://github.com/lotabout/skim/archive/v${version}.tar.gz"
-checksum=42ac516aba6c9116fe96ff9dc5ac22fc7b14f809fbcdb5aaf93b9b36955da4dc
+checksum=@c7002dc66d290a8bb1363de7c636474323d031415f303368afa8ecfe8c01b184
 
 post_install() {
 	vbin bin/sk-tmux

From 46035aafb6da6950d123355e3dcdb29cc1cb88ae Mon Sep 17 00:00:00 2001
From: Alex Lohr <alex.lohr@logmein.com>
Date: Mon, 12 Oct 2020 09:31:27 +0200
Subject: [PATCH 052/312] slack-desktop: update to 4.10.0

Closes: #25538 [via git-merge-pr]
---
 srcpkgs/slack-desktop/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/slack-desktop/template b/srcpkgs/slack-desktop/template
index 331f04ce571..751c7c8c967 100644
--- a/srcpkgs/slack-desktop/template
+++ b/srcpkgs/slack-desktop/template
@@ -1,6 +1,6 @@
 # Template file for 'slack-desktop'
 pkgname=slack-desktop
-version=4.9.1
+version=4.10.0
 revision=1
 archs="x86_64"
 hostmakedepends="tar xz"
@@ -10,7 +10,7 @@ maintainer="Diogo Leal <diogo@diogoleal.com>"
 license="custom:Proprietary"
 homepage="https://slack.com/"
 distfiles="https://slack-ssb-updates.global.ssl.fastly.net/linux_releases/${pkgname}-${version}-amd64.deb"
-checksum=919c7da48f52ffa41699cc24adbde2a6d5b98887471c53d11ac1594677c90bd9
+checksum=054759cc92ae902f1c36bb89c69c504fa5473e8180eb87bb1a2a1c2540a4fc72
 restricted=yes
 repository="nonfree"
 nopie=yes

From 1d849d187c25982cee8412b90c949c1ef3dbb8ea Mon Sep 17 00:00:00 2001
From: Imran Khan <imrankhan@teknik.io>
Date: Mon, 12 Oct 2020 19:59:14 +0600
Subject: [PATCH 053/312] fselect: update to 0.7.1.

Closes: #25540 [via git-merge-pr]
---
 srcpkgs/fselect/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/fselect/template b/srcpkgs/fselect/template
index 734ef3fd9f6..45a78a0dc69 100644
--- a/srcpkgs/fselect/template
+++ b/srcpkgs/fselect/template
@@ -1,6 +1,6 @@
 # Template file for 'fselect'
 pkgname=fselect
-version=0.6.10
+version=0.7.1
 revision=1
 build_style=cargo
 short_desc="Find files with SQL-like queries"
@@ -8,7 +8,7 @@ maintainer="SolitudeSF <solitudesf@protonmail.com>"
 license="Apache-2.0, MIT"
 homepage="https://github.com/jhspetersson/fselect"
 distfiles="${homepage}/archive/${version}.tar.gz"
-checksum=1fa86cd22fdb4a38338c343f9a917e579a6f680c961e9dca8d1a2178ab4d926b
+checksum=38cb9c56aa6568088d6dbdc9512c0fd16e05b07f55684b2c8c9fa09533f58f84
 
 post_install() {
 	vlicense LICENSE-MIT

From aa4ab238ecb1ccb39d60b01b8b8853d79b211b45 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?J=C3=BCrgen=20Buchm=C3=BCller?= <pullmoll@t-online.de>
Date: Wed, 14 Oct 2020 16:50:08 +0200
Subject: [PATCH 054/312] mozjs78: broken for mips*

---
 srcpkgs/mozjs78/template | 4 ++++
 1 file changed, 4 insertions(+)

diff --git a/srcpkgs/mozjs78/template b/srcpkgs/mozjs78/template
index c7223af51b0..38e6aded7c7 100644
--- a/srcpkgs/mozjs78/template
+++ b/srcpkgs/mozjs78/template
@@ -27,6 +27,10 @@ if [ "$XBPS_TARGET_NO_ATOMIC8" ]; then
 	LDFLAGS+=" -latomic"
 fi
 
+case "$XBPS_TARGET_MACHINE" in
+	mips*) broken="no matching function for call to 'js::jit::MacroAssembler::unboxInt32(const js::jit::BaseObjectElementIndex&, js::jit::Register&)'";;
+esac
+
 do_configure() {
 	local _args
 	# use gcc as assembler to avoid errors

From 53aaf66eef07c1fad09d97164a060f1c39db84b6 Mon Sep 17 00:00:00 2001
From: Helmut Pozimski <helmut@pozimski.eu>
Date: Wed, 14 Oct 2020 17:22:11 +0200
Subject: [PATCH 055/312] monero: update to 0.17.1.0.

---
 srcpkgs/monero/template | 18 ++++++++----------
 1 file changed, 8 insertions(+), 10 deletions(-)

diff --git a/srcpkgs/monero/template b/srcpkgs/monero/template
index c9f0f5e06a8..36ac5f3bc27 100644
--- a/srcpkgs/monero/template
+++ b/srcpkgs/monero/template
@@ -1,18 +1,17 @@
 # Template file for 'monero'
 pkgname=monero
-version=0.17.0.1
+version=0.17.1.0
 revision=1
 _randomx_version="1.1.8"
 # the revision monero uses as a submodule for the specific version
 _rapidjson_gitrev="129d19ba7f496df5e33658527a7158c79b99c21c"
 _supercop_gitrev="633500ad8c8759995049ccd022107d1fa8a1bbc9"
 build_style=cmake
-configure_args="-DBUILD_GUI_DEPS=ON"
 conf_files="/etc/monerod.conf"
 make_dirs="
  /var/lib/monero 0750 monero monero
  /var/log/monero 0755 monero monero"
-hostmakedepends="pkg-config qt5-host-tools tar"
+hostmakedepends="pkg-config"
 makedepends="libressl-devel boost-devel libldns-devel libunwind-devel
  readline-devel unbound-devel miniupnpc-devel expat-devel
  cppzmq czmq-devel libsodium-devel"
@@ -24,11 +23,11 @@ distfiles="https://github.com/monero-project/monero/archive/v${version}.tar.gz
  https://github.com/tevador/RandomX/archive/v${_randomx_version}.tar.gz
  https://github.com/Tencent/rapidjson/archive/${_rapidjson_gitrev}.tar.gz
  https://github.com/monero-project/supercop/archive/${_supercop_gitrev}.tar.gz"
-checksum="490f59c669992fc9bc74103dc2c82c968d07fecb6e2831d2d356575dc78862fb
+checksum="4a8e5a4c256b20da69e7d4c50657ddb968669e5cbc449f60cd555108fe8cafd1
  f982a12d18b1d260bef2a1d3c46ae4902975fbf63abb38ca6413c96d1778db3a
  44b007d419ac21b6affec58991e865ee572346ead19b73cf1c3e4e11c7a81273
  b973b9d8269ec4d97c3c3443f0dad96d09f72b1b30e616e0947557adbdbb03f7"
-skip_extraction="v${_randomx_version}.tar.gz ${_rapidjson_gitrev}.tar.gz"
+skip_extraction="v${_randomx_version}.tar.gz ${_rapidjson_gitrev}.tar.gz ${_supercop_gitrev}.tar.gz"
 system_accounts="monero"
 
 if [ "$CROSS_BUILD" ]; then
@@ -43,7 +42,7 @@ case "$XBPS_TARGET_MACHINE" in
 	mips*) configure_args+=" -DARCH=mipsr32 -DNO_AES=ON" ;;
 	ppc64le*) configure_args+=" -DARCH=ppc64le" ;;
 	ppc64*) configure_args+=" -DARCH=ppc64" ;;
-	ppc*) configure_arch+=" -DARCH=ppc"	;;
+	ppc*) configure_args+=" -DARCH=ppc"	;;
 	*) configure_args+=" -DARCH=default" ;;
 esac
 
@@ -57,11 +56,11 @@ case "$XBPS_TARGET_MACHINE" in
 esac
 
 post_extract() {
-	tar xzf ${XBPS_SRCDISTDIR}/${pkgname}-${version}/v${_randomx_version}.tar.gz \
+	bsdtar xzf ${XBPS_SRCDISTDIR}/${pkgname}-${version}/v${_randomx_version}.tar.gz \
 		--strip-components=1 -C ${wrksrc}/external/randomx
-	tar xzf ${XBPS_SRCDISTDIR}/${pkgname}-${version}/${_rapidjson_gitrev}.tar.gz \
+	bsdtar xzf ${XBPS_SRCDISTDIR}/${pkgname}-${version}/${_rapidjson_gitrev}.tar.gz \
 		--strip-components=1 -C ${wrksrc}/external/rapidjson
-	tar xzf ${XBPS_SRCDISTDIR}/${pkgname}-${version}/${_supercop_gitrev}.tar.gz \
+	bsdtar xzf ${XBPS_SRCDISTDIR}/${pkgname}-${version}/${_supercop_gitrev}.tar.gz \
 		--strip-components=1 -C ${wrksrc}/external/supercop
 }
 
@@ -95,6 +94,5 @@ monero-devel_package() {
 	pkg_install() {
 		vlicense LICENSE
 		vmove usr/include
-		vmove "usr/lib/*.a"
 	}
 }

From 5a54a9f875d1508d57ca650b887f19e862ca4cbd Mon Sep 17 00:00:00 2001
From: Helmut Pozimski <helmut@pozimski.eu>
Date: Wed, 14 Oct 2020 17:24:15 +0200
Subject: [PATCH 056/312] monero-gui: add update file

---
 srcpkgs/monero-gui/update | 2 ++
 1 file changed, 2 insertions(+)
 create mode 100644 srcpkgs/monero-gui/update

diff --git a/srcpkgs/monero-gui/update b/srcpkgs/monero-gui/update
new file mode 100644
index 00000000000..32c77fffe97
--- /dev/null
+++ b/srcpkgs/monero-gui/update
@@ -0,0 +1,2 @@
+site="https://github.com/monero-project/monero-gui/tags"
+pattern='/archive/(v?|\Qmonero-gui\E-)?\K[\d\.]+(?=\.tar\.gz")'

From fb98f46ee8f1d45a4f81d228fb84d099b38607ba Mon Sep 17 00:00:00 2001
From: Justin Berthault <justin.berthault@zaclys.net>
Date: Sat, 10 Oct 2020 23:02:12 +0200
Subject: [PATCH 057/312] musescore: update to 3.5.1.

Closes: #25496 [via git-merge-pr]
---
 srcpkgs/musescore/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/musescore/template b/srcpkgs/musescore/template
index 10534b358d9..96242d516f5 100644
--- a/srcpkgs/musescore/template
+++ b/srcpkgs/musescore/template
@@ -1,6 +1,6 @@
 # Template file for 'musescore'
 pkgname=musescore
-version=3.4.2
+version=3.5.1
 revision=1
 wrksrc="MuseScore-${version}"
 build_style=gnu-makefile
@@ -18,7 +18,7 @@ maintainer="Brian Olsen <bnolsen@comcast.net>"
 license="GPL-2.0-or-later"
 homepage="https://musescore.org/"
 distfiles="https://github.com/musescore/MuseScore/archive/v${version}.tar.gz"
-checksum=2604aa9db0b9e8ac3b067aeb98effce07f29e8ea510729d7a76f66e0c4e3f95d
+checksum=4fa9d3b3f90861447f78858786ed6e351ea691408551ee92e089d4bba1039e5a
 nocross="genManual: cannot execute binary file: Exec format error"
 
 build_options="webengine"

From 8d5a39110b0fb4f4a4c068180f8c59203ca7e5ac Mon Sep 17 00:00:00 2001
From: Anton Afanasyev <anton@doubleasoftware.com>
Date: Sat, 10 Oct 2020 11:46:35 -0700
Subject: [PATCH 058/312] CLion: update to 2020.2.4.

Closes: #25494 [via git-merge-pr]
---
 srcpkgs/CLion/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/CLion/template b/srcpkgs/CLion/template
index 02a59c0a1ac..4cb9d3653d4 100644
--- a/srcpkgs/CLion/template
+++ b/srcpkgs/CLion/template
@@ -1,6 +1,6 @@
 # Template file for 'CLion'
 pkgname=CLion
-version=2020.2.3
+version=2020.2.4
 revision=1
 archs="i686 x86_64"
 wrksrc="clion-${version}"
@@ -10,7 +10,7 @@ maintainer="Anton Afanasyev <anton@doubleasoftware.com>"
 license="custom:Commercial"
 homepage="https://www.jetbrains.com/clion"
 distfiles="https://download.jetbrains.com/cpp/CLion-${version}.tar.gz"
-checksum=b863b5b1ed664c21428e5afafb39ebf7f30d062ef53731f3d093d7ee74abb4cd
+checksum=4301a1572908592e25fd9234c290eabcd44e53b23ababd7ed518a93728527976
 repository=nonfree
 restricted=yes
 nopie=yes

From bfc2494c5b1afd0a572bb74910ce654b1a3f7063 Mon Sep 17 00:00:00 2001
From: Roberto Ricci <ricci@disroot.org>
Date: Wed, 7 Oct 2020 14:05:20 +0200
Subject: [PATCH 059/312] teams-bin: update to 1.3.00.25560

Closes: #25490 [via git-merge-pr]
---
 srcpkgs/teams-bin/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/teams-bin/template b/srcpkgs/teams-bin/template
index 93641949612..8f992f061e4 100644
--- a/srcpkgs/teams-bin/template
+++ b/srcpkgs/teams-bin/template
@@ -1,6 +1,6 @@
 # Template file for 'teams-bin'
 pkgname=teams-bin
-version=1.3.00.16851
+version=1.3.00.25560
 revision=1
 archs="x86_64"
 hostmakedepends="xz"
@@ -9,7 +9,7 @@ maintainer="Piraty <piraty1@inbox.ru>"
 license="custom:Proprietary"
 homepage="https://teams.microsoft.com/downloads"
 distfiles="https://packages.microsoft.com/repos/ms-teams/pool/main/t/teams/teams_${version}_amd64.deb"
-checksum=23838c8f8dea4960dce8bba559cd7ee3cdedc78ea7fdb226139b5b2204eee4d6
+checksum=acfe094beacbacfc29641c1c9a85ec4bb61157d371fad67e03108b6d706aec4e
 
 repository=nonfree
 restricted=yes

From 5d3f17343c688f4f82900d71c812b1b86bad3cdd Mon Sep 17 00:00:00 2001
From: Paper <paper@tilde.institute>
Date: Fri, 9 Oct 2020 21:57:43 +0200
Subject: [PATCH 060/312] flake8: update to 3.8.4

Closes: #25477 [via git-merge-pr]
---
 srcpkgs/flake8/template | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/flake8/template b/srcpkgs/flake8/template
index da71302508c..8a7d34b0e81 100644
--- a/srcpkgs/flake8/template
+++ b/srcpkgs/flake8/template
@@ -1,7 +1,7 @@
 # Template file for 'flake8'
 pkgname=flake8
-version=3.8.3
-revision=2
+version=3.8.4
+revision=1
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-setuptools python3-pycodestyle>=2.6.0<2.7.0
@@ -13,11 +13,12 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="MIT"
 homepage="https://gitlab.com/pycqa/flake8"
 distfiles="${PYPI_SITE}/f/flake8/flake8-${version}.tar.gz"
-checksum=f04b9fcbac03b0a3e58c0ab3a0ecc462e023a9faf046d57794184028123aa208
+checksum=aadae8761ec651813c24be05c6f7b4680857ef6afaae4651a4eccaef97ce6c3b
 
 do_check() {
 	PYTHONPATH="${wrksrc}/src" python3 -m pytest
 }
+
 post_install() {
 	vlicense LICENSE
 }

From df56c94242c4345fdb5291999fc95e32d0ac903d Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Benjam=C3=ADn=20Albi=C3=B1ana?= <benalb@gmail.com>
Date: Fri, 9 Oct 2020 19:29:31 +0200
Subject: [PATCH 061/312] doctl: update to 1.48.1.

Closes: #25473 [via git-merge-pr]
---
 srcpkgs/doctl/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/doctl/template b/srcpkgs/doctl/template
index 47afa4e847e..6f08b27bb7f 100644
--- a/srcpkgs/doctl/template
+++ b/srcpkgs/doctl/template
@@ -1,6 +1,6 @@
 # Template file for 'doctl'
 pkgname=doctl
-version=1.48.0
+version=1.48.1
 revision=1
 build_style=go
 go_import_path="github.com/digitalocean/doctl/cmd/doctl"
@@ -11,4 +11,4 @@ maintainer="Benjamín Albiñana <benalb@gmail.com>"
 license="Apache-2.0"
 homepage="https://github.com/digitalocean/doctl"
 distfiles="https://github.com/digitalocean/doctl/archive/v${version}.tar.gz"
-checksum=43f4be1a5316688579c3df1846dc7088478dc5ddc3e4fa1176a953609123f046
+checksum=3be10bf29e0f1e9af87b63d22f9eb28c8adccdb9daa5567d2b4ac022e5cdc51e

From 82449cf9080a125f70d3027caa6d8ba4c460fe43 Mon Sep 17 00:00:00 2001
From: Anthony Iliopoulos <ailiop@altatus.com>
Date: Fri, 9 Oct 2020 18:55:35 +0200
Subject: [PATCH 062/312] luakit: update to 2.2.1.

Closes: #25471 [via git-merge-pr]
---
 srcpkgs/luakit/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/luakit/template b/srcpkgs/luakit/template
index 33587f26196..f5f8bfc372c 100644
--- a/srcpkgs/luakit/template
+++ b/srcpkgs/luakit/template
@@ -1,7 +1,7 @@
 # Template file for 'luakit'
 pkgname=luakit
 reverts="2017.08.10_1"
-version=2.2
+version=2.2.1
 revision=1
 conf_files="/etc/xdg/luakit/*.lua"
 hostmakedepends="pkg-config LuaJIT"
@@ -13,7 +13,7 @@ license="GPL-3.0-or-later"
 homepage="https://luakit.github.io/"
 changelog="https://github.com/luakit/luakit/blob/develop/CHANGELOG.md"
 distfiles="https://github.com/luakit/luakit/archive/${version}.tar.gz"
-checksum=704929a324984afe246c63263667eb1d64c060b4f7f74ced59fec5d402c377dc
+checksum=f35359f5863fabe2b9d426f4d3ef6d29ce5bb3bac7b4c8e0824242f89868c80e
 
 case "${XBPS_TARGET_MACHINE}" in
 	aarch64) broken="LuaJIT-devel marked as unsupported";;

From 752814746a1e094545fa4fbdbb27c33286649d3a Mon Sep 17 00:00:00 2001
From: Anthony Iliopoulos <ailiop@altatus.com>
Date: Fri, 9 Oct 2020 18:19:28 +0200
Subject: [PATCH 063/312] chrony: update to 4.0.

Closes: #25470 [via git-merge-pr]
---
 srcpkgs/chrony/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/chrony/template b/srcpkgs/chrony/template
index 34c692d04cd..d28017e567e 100644
--- a/srcpkgs/chrony/template
+++ b/srcpkgs/chrony/template
@@ -1,7 +1,7 @@
 # Template file for 'chrony'
 # When Updating: Please confirm the upstream config still refers to make_dirs
 pkgname=chrony
-version=3.5.1
+version=4.0
 revision=1
 build_style=gnu-configure
 configure_args="--without-nss --enable-scfilter
@@ -10,11 +10,11 @@ hostmakedepends="pkg-config"
 makedepends="libcap-devel libedit-devel libseccomp-devel libtomcrypt-devel"
 conf_files="/etc/chrony.conf"
 short_desc="Versatile implementation of the Network Time Protocol (NTP)"
-maintainer="Orphaned <orphan@voidlinux.org>"
+maintainer="Anthony Iliopoulos <ailiop@altatus.com>"
 license="GPL-2.0-only"
 homepage="https://chrony.tuxfamily.org/"
 distfiles="https://download.tuxfamily.org/chrony/${pkgname}-${version}.tar.gz"
-checksum=1ba82f70db85d414cd7420c39858e3ceca4b9eb8b028cbe869512c3a14a2dca7
+checksum=be27ea14c55e7a4434b2fa51d53018c7051c42fa6a3198c9aa6a1658bae0c625
 system_accounts="chrony"
 chrony_homedir="/var/lib/chrony"
 

From ae011f62a436cc3f25014940a76c98e20e9eb28f Mon Sep 17 00:00:00 2001
From: Anthony Iliopoulos <ailiop@altatus.com>
Date: Fri, 9 Oct 2020 18:48:16 +0200
Subject: [PATCH 064/312] iana-etc: update to 20200918.

Closes: #25464 [via git-merge-pr]
---
 srcpkgs/iana-etc/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/iana-etc/template b/srcpkgs/iana-etc/template
index d5c65a2c441..cceed1a50bb 100644
--- a/srcpkgs/iana-etc/template
+++ b/srcpkgs/iana-etc/template
@@ -1,6 +1,6 @@
 # Template file for 'iana-etc'
 pkgname=iana-etc
-version=20200910
+version=20200918
 revision=1
 bootstrap=yes
 short_desc="Unix /etc/services and /etc/protocols files"

From 6d7228f541e41964ee8dbd661930ba8ba4270759 Mon Sep 17 00:00:00 2001
From: Anthony Iliopoulos <ailiop@altatus.com>
Date: Fri, 9 Oct 2020 18:47:15 +0200
Subject: [PATCH 065/312] lttng-modules-dkms: update to 2.12.3.

Closes: #25463 [via git-merge-pr]
---
 srcpkgs/lttng-modules-dkms/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/lttng-modules-dkms/template b/srcpkgs/lttng-modules-dkms/template
index c41a0a49c5f..a86877cd623 100644
--- a/srcpkgs/lttng-modules-dkms/template
+++ b/srcpkgs/lttng-modules-dkms/template
@@ -1,6 +1,6 @@
 # Template file for 'lttng-modules-dkms'
 pkgname=lttng-modules-dkms
-version=2.12.2
+version=2.12.3
 revision=1
 wrksrc="lttng-modules-${version}"
 depends="dkms"
@@ -9,7 +9,7 @@ maintainer="Alexander Egorenkov <egorenar-dev@posteo.net>"
 license="LGPL-2.1-only, GPL-2.0-only, MIT"
 homepage="https://lttng.org"
 distfiles="${homepage}/files/lttng-modules/lttng-modules-${version}.tar.bz2"
-checksum=df50bc3bd58679705714f17721acf619a8b0cedc694f8a97052aa5099626feca
+checksum=673ef85c9f03e9b8fed10795e09d4e68add39404b70068d08b10f7b85754d7f0
 
 dkms_modules="lttng-modules ${version}"
 

From 4cca72334a114f97a6506ae8cf740f8fb547732f Mon Sep 17 00:00:00 2001
From: Anthony Iliopoulos <ailiop@altatus.com>
Date: Fri, 9 Oct 2020 18:15:26 +0200
Subject: [PATCH 066/312] fuse3: update to 3.10.0.

Closes: #25460 [via git-merge-pr]
---
 srcpkgs/fuse3/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/fuse3/template b/srcpkgs/fuse3/template
index 27e60ccf786..a17a6650b06 100644
--- a/srcpkgs/fuse3/template
+++ b/srcpkgs/fuse3/template
@@ -1,6 +1,6 @@
 # Template file for 'fuse3'
 pkgname=fuse3
-version=3.9.3
+version=3.10.0
 revision=1
 wrksrc="fuse-${version}"
 build_style=meson
@@ -12,7 +12,7 @@ maintainer="Anthony Iliopoulos <ailiop@altatus.com>"
 license="GPL-2.0-or-later, LGPL-2.1-or-later"
 homepage="https://github.com/libfuse/libfuse"
 distfiles="https://github.com/libfuse/libfuse/releases/download/fuse-${version}/fuse-${version}.tar.xz"
-checksum=cd45270a064d2ae14f17cfc914f1555106d6c5091025b0b2698b860399d4ede6
+checksum=26517954567f237a7dbcb532755ba0d2c77575c5d90db7566b6e40ec05b0a039
 conf_files="/etc/fuse.conf"
 
 post_install() {

From 3848cb7ce463f6fefc868cfc0232fab037e90c78 Mon Sep 17 00:00:00 2001
From: Anthony Iliopoulos <ailiop@altatus.com>
Date: Sun, 11 Oct 2020 15:26:07 +0200
Subject: [PATCH 067/312] ndctl: update to 70.1.

Closes: #25459 [via git-merge-pr]
---
 srcpkgs/ndctl/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/ndctl/template b/srcpkgs/ndctl/template
index c82761ea1ee..2adff1c47ea 100644
--- a/srcpkgs/ndctl/template
+++ b/srcpkgs/ndctl/template
@@ -1,6 +1,6 @@
 # Template file for 'ndctl'
 pkgname=ndctl
-version=69
+version=70.1
 revision=1
 build_style=gnu-configure
 configure_args="--disable-docs --without-systemd"
@@ -12,7 +12,7 @@ maintainer="Anthony Iliopoulos <ailiop@altatus.com>"
 license="LGPL-2.1-only, GPL-2.0-only"
 homepage="https://github.com/pmem/ndctl"
 distfiles="https://github.com/pmem/ndctl/archive/v${version}.tar.gz"
-checksum=b9da06939c6e558e6eb49681452741996b18a4cade9b2ef342f73debcf263a98
+checksum=2b2a7e6228481076dc807df7a658ba91017658fcb932e8bea489330380d2d682
 conf_files="/etc/ndctl/monitor.conf"
 
 case "$XBPS_TARGET_MACHINE" in

From 69f2a63a1cb64a9204da1fae4d66581998540d6f Mon Sep 17 00:00:00 2001
From: Anthony Iliopoulos <ailiop@altatus.com>
Date: Fri, 9 Oct 2020 18:12:25 +0200
Subject: [PATCH 068/312] acpica-utils: update to 20200925.

Closes: #25458 [via git-merge-pr]
---
 srcpkgs/acpica-utils/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/acpica-utils/template b/srcpkgs/acpica-utils/template
index 8baf07d7527..a47d5bf51af 100644
--- a/srcpkgs/acpica-utils/template
+++ b/srcpkgs/acpica-utils/template
@@ -1,6 +1,6 @@
 # Template file for 'acpica-utils'
 pkgname=acpica-utils
-version=20200717
+version=20200925
 revision=1
 archs="i686* x86_64* aarch64*"
 wrksrc="acpica-unix-${version}"
@@ -10,7 +10,7 @@ maintainer="Anthony Iliopoulos <ailiop@altatus.com>"
 license="GPL-2.0-only, BSD-3-Clause"
 homepage="https://www.acpica.org/"
 distfiles="https://acpica.org/sites/acpica/files/acpica-unix-${version}.tar.gz"
-checksum=cb99903ef240732f395af40c23b9b19c7899033f48840743544eebb6da72a828
+checksum=d44388e21e3d2e47c6d39e9c897935d3f775f04fec76271dcba072c74f834589
 
 do_build() {
 	vsed -e 's/-Werror//g' \

From 6b404491b9125c2f6b8e6c08155b89b3fe450035 Mon Sep 17 00:00:00 2001
From: q66 <daniel@octaforge.org>
Date: Wed, 14 Oct 2020 18:35:33 +0200
Subject: [PATCH 069/312] avahi-discover: drop stale symlink

---
 srcpkgs/avahi-python | 1 -
 1 file changed, 1 deletion(-)
 delete mode 120000 srcpkgs/avahi-python

diff --git a/srcpkgs/avahi-python b/srcpkgs/avahi-python
deleted file mode 120000
index 19fb54cd099..00000000000
--- a/srcpkgs/avahi-python
+++ /dev/null
@@ -1 +0,0 @@
-avahi-discover
\ No newline at end of file

From 8ee9d7c89f7e10d5614d21b4751dba15bfd38a29 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C3=89rico=20Rolim?= <erico.erc@gmail.com>
Date: Wed, 2 Sep 2020 16:16:21 -0300
Subject: [PATCH 070/312] kaitai-struct-compiler: drop noarch.

Also rebuild to appear in musl repositories and xlint.
---
 srcpkgs/kaitai-struct-compiler/template | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/kaitai-struct-compiler/template b/srcpkgs/kaitai-struct-compiler/template
index 011a403ca88..ce81b388f6a 100644
--- a/srcpkgs/kaitai-struct-compiler/template
+++ b/srcpkgs/kaitai-struct-compiler/template
@@ -1,13 +1,12 @@
 # Template file for 'kaitai-struct-compiler'
 pkgname=kaitai-struct-compiler
 version=0.8
-revision=1
-archs=noarch
+revision=2
 hostmakedepends="unzip"
 depends="virtual?java-environment"
 short_desc="Compiler for the Kaitai declarative binary format parsing language"
 maintainer="Andrea Brancaleoni <abc@pompel.me>"
-license="GPL-3"
+license="GPL-3.0-or-later"
 homepage="http://kaitai.io"
 distfiles="https://bintray.com/kaitai-io/universal/download_file?file_path=${version}%2F${pkgname}-${version}.zip"
 checksum=545fc10e134db2901cad8817be1b440fca6f2bad8b92b2948ebe0647f3ffa2c9

From 6c0ec23c761e3f774ec89bf4f84080ffad02563f Mon Sep 17 00:00:00 2001
From: mustaqim <git@mustaqim.ml>
Date: Sun, 4 Oct 2020 06:14:49 +0200
Subject: [PATCH 071/312] Remove package: imlib2-webp-1.0

---
 srcpkgs/imlib2-webp          |  1 +
 srcpkgs/imlib2-webp/template | 17 -----------------
 srcpkgs/imlib2/template      |  8 +++++++-
 3 files changed, 8 insertions(+), 18 deletions(-)
 create mode 120000 srcpkgs/imlib2-webp
 delete mode 100644 srcpkgs/imlib2-webp/template

diff --git a/srcpkgs/imlib2-webp b/srcpkgs/imlib2-webp
new file mode 120000
index 00000000000..1c681089c93
--- /dev/null
+++ b/srcpkgs/imlib2-webp
@@ -0,0 +1 @@
+imlib2
\ No newline at end of file
diff --git a/srcpkgs/imlib2-webp/template b/srcpkgs/imlib2-webp/template
deleted file mode 100644
index 82be878061d..00000000000
--- a/srcpkgs/imlib2-webp/template
+++ /dev/null
@@ -1,17 +0,0 @@
-# Template file for 'imlib2-webp'
-pkgname=imlib2-webp
-version=1.0
-revision=1
-build_style=gnu-makefile
-hostmakedepends="pkg-config"
-makedepends="imlib2-devel libwebp-devel"
-short_desc="WebP loader for Imlib2"
-maintainer="mustaqim <mustaqim@pm.me>"
-license="custom:The Regents of the University of California, BSD-4-Clause-UC"
-homepage="https://www.hauweele.net/~gawen/imlib2-webp.html"
-distfiles="https://github.com/gawen947/imlib2-webp/archive/v${version}.tar.gz"
-checksum=252328cc4e7d232bc2fbbf1c38b963a1847e22f7ee21dd7362b7c0583dca4334
-
-post_install() {
-	vlicense COPYING
-}
diff --git a/srcpkgs/imlib2/template b/srcpkgs/imlib2/template
index 46e77f7c021..3a152b61706 100644
--- a/srcpkgs/imlib2/template
+++ b/srcpkgs/imlib2/template
@@ -1,7 +1,7 @@
 # Template file for 'imlib2'
 pkgname=imlib2
 version=1.7.0
-revision=1
+revision=2
 build_style=gnu-configure
 configure_args="--disable-static --sysconfdir=/etc/imlib2 --enable-visibility-hiding"
 hostmakedepends="pkg-config"
@@ -36,3 +36,9 @@ imlib2-devel_package() {
 		vmove "usr/lib/*.so"
 	}
 }
+
+imlib2-webp_package() {
+	build_style=meta
+	depends="${sourcepkg}>=${version}_${revision}"
+	short_desc="WebP loader for Imlib2 (transitional dummy package)"
+}

From a1a245c9b27673f7b78d1214604faaab0d996d96 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Wed, 14 Oct 2020 20:14:50 +0200
Subject: [PATCH 072/312] linux5.8: update to 5.8.15.

---
 srcpkgs/linux5.8/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/linux5.8/template b/srcpkgs/linux5.8/template
index 0c351b7fd26..0d7eadaa5da 100644
--- a/srcpkgs/linux5.8/template
+++ b/srcpkgs/linux5.8/template
@@ -1,6 +1,6 @@
 # Template file for 'linux5.8'
 pkgname=linux5.8
-version=5.8.14
+version=5.8.15
 revision=1
 wrksrc="linux-${version}"
 short_desc="Linux kernel and modules (${version%.*} series)"
@@ -8,7 +8,7 @@ maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="GPL-2.0-only"
 homepage="https://www.kernel.org"
 distfiles="https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-${version}.tar.xz"
-checksum=ee767991808d234ad9acd17f0ba94ba7979d30c528876bee6fba337ea540f0af
+checksum=72811c4e131b3b6cfb38b74684d22b6403d57bd334b42e35d2fc0a902cc1d641
 python_version=3
 patch_args="-Np1"
 

From 94acd7683f7e9b8fcb64a34f8d9e708068ffd18e Mon Sep 17 00:00:00 2001
From: Isaac Freund <ifreund@ifreund.xyz>
Date: Wed, 14 Oct 2020 17:46:16 +0200
Subject: [PATCH 073/312] foot: update to 1.5.2.

---
 srcpkgs/foot/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/foot/template b/srcpkgs/foot/template
index 33648155889..0e82f39b3e6 100644
--- a/srcpkgs/foot/template
+++ b/srcpkgs/foot/template
@@ -1,6 +1,6 @@
 # Template file for 'foot'
 pkgname=foot
-version=1.5.1
+version=1.5.2
 revision=1
 wrksrc=$pkgname
 build_style=meson
@@ -14,7 +14,7 @@ maintainer="Isaac Freund <ifreund@ifreund.xyz>"
 license="MIT"
 homepage="https://codeberg.org/dnkl/foot"
 distfiles="${homepage}/archive/${version}.tar.gz"
-checksum=ab17c3c3b504275c86998b954b9ae1f0e5fc895611be26d2cc26c78e498ced9d
+checksum=e6103117bc77627dd5ea7a3f79324e21ae6a65d31100fb4d09b09528a8cb3846
 
 post_install() {
 	vlicense LICENSE

From 4405dc530ffed028d6c83cae341a2d10022d291d Mon Sep 17 00:00:00 2001
From: Isaac Freund <ifreund@ifreund.xyz>
Date: Wed, 14 Oct 2020 17:55:44 +0200
Subject: [PATCH 074/312] vips: update to 8.10.2.

---
 srcpkgs/vips/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/vips/template b/srcpkgs/vips/template
index f138af3461a..dd65451ad85 100644
--- a/srcpkgs/vips/template
+++ b/srcpkgs/vips/template
@@ -1,7 +1,7 @@
 # Template file for 'vips'
 pkgname=vips
-version=8.10.1
-revision=2
+version=8.10.2
+revision=1
 build_style=gnu-configure
 build_helper=gir
 configure_args="--enable-introspection=$(vopt_if gir yes no)"
@@ -33,7 +33,7 @@ maintainer="Isaac Freund <ifreund@ifreund.xyz>"
 license="LGPL-2.1-or-later"
 homepage="https://libvips.github.io/libvips/"
 distfiles="https://github.com/libvips/libvips/releases/download/v${version}/vips-${version}.tar.gz"
-checksum=e089bb4f73e1dce866ae53e25604ea4f94535488a45bb4f633032e1d2f4e2dda
+checksum=c1d0d9cb54d75cd4f66dce787fbcac99f834f6621fbf47bce9e02ef65b4ab02a
 python_version=3
 
 build_options="gir hdf5"

From b20f01f17b097af61a915ca13b1bf4838f196347 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Mon, 12 Oct 2020 14:32:19 -0400
Subject: [PATCH 075/312] blender: update to 2.90.1.

[ci skip]

Closes: #25547
---
 srcpkgs/blender/patches/disable_werror.patch |  10 +-
 srcpkgs/blender/patches/musl.patch           | 149 +++++++++-------
 srcpkgs/blender/patches/python39.patch       | 176 +++----------------
 srcpkgs/blender/template                     |  26 +--
 4 files changed, 127 insertions(+), 234 deletions(-)

diff --git a/srcpkgs/blender/patches/disable_werror.patch b/srcpkgs/blender/patches/disable_werror.patch
index 635956f2aa9..9fada907e1c 100644
--- a/srcpkgs/blender/patches/disable_werror.patch
+++ b/srcpkgs/blender/patches/disable_werror.patch
@@ -6,8 +6,8 @@ index f22688f..c32aad1 100644
  
  # Warnings
  if(CMAKE_COMPILER_IS_GNUCXX)
--	ADD_CHECK_CXX_COMPILER_FLAG(CMAKE_CXX_FLAGS _has_cxxflag_float_conversion "-Werror=float-conversion")
--	ADD_CHECK_CXX_COMPILER_FLAG(CMAKE_CXX_FLAGS _has_cxxflag_double_promotion "-Werror=double-promotion")
- 	ADD_CHECK_CXX_COMPILER_FLAG(CMAKE_CXX_FLAGS _has_no_error_unused_macros "-Wno-error=unused-macros")
- 	unset(_has_cxxflag_float_conversion)
- 	unset(_has_cxxflag_double_promotion)
+-  ADD_CHECK_CXX_COMPILER_FLAG(CMAKE_CXX_FLAGS _has_cxxflag_float_conversion "-Werror=float-conversion")
+-  ADD_CHECK_CXX_COMPILER_FLAG(CMAKE_CXX_FLAGS _has_cxxflag_double_promotion "-Werror=double-promotion")
+   ADD_CHECK_CXX_COMPILER_FLAG(CMAKE_CXX_FLAGS _has_no_error_unused_macros "-Wno-error=unused-macros")
+   unset(_has_cxxflag_float_conversion)
+   unset(_has_cxxflag_double_promotion)
diff --git a/srcpkgs/blender/patches/musl.patch b/srcpkgs/blender/patches/musl.patch
index c095171df1b..5cfded1586d 100644
--- a/srcpkgs/blender/patches/musl.patch
+++ b/srcpkgs/blender/patches/musl.patch
@@ -1,90 +1,111 @@
-diff -ru blender-2.82.org/CMakeLists.txt blender-2.82/CMakeLists.txt
---- blender-2.82.org/CMakeLists.txt	2020-02-13 01:42:10.000000000 -0800
-+++ blender-2.82/CMakeLists.txt	2020-02-28 03:28:50.491903370 -0800
-@@ -848,6 +848,19 @@
-   endif()
- endif()
+From 8f2b2e92ffdec658d4eb999f41acf6c74a5b32ed Mon Sep 17 00:00:00 2001
+From: Leon Marz <lmarz@cs.uni-frankfurt.de>
+Date: Tue, 1 Sep 2020 09:09:50 +0200
+Subject: [PATCH 1/2] musl fixes
+
+[ Taken from https://git.alpinelinux.org/aports/plain/testing/blender/0001-musl-fixes.patch ]
+
+Original Patch by Nathanael Copa
+
+---
+ CMakeLists.txt                              | 13 +++++++++++++
+ intern/guardedalloc/intern/mallocn_intern.h |  2 +-
+ intern/libc_compat/libc_compat.c            |  2 --
+ source/blender/blenlib/intern/system.c      |  4 +++-
+ source/creator/creator_signals.c            |  2 +-
+ 5 files changed, 18 insertions(+), 5 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index cee8675..111e6e3 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -138,6 +138,19 @@ get_blender_version()
+ #-----------------------------------------------------------------------------
+ # Options
  
-+# musl-libc related checks (missing execinfo.h, and feenableexcept())
++# musl-libc related checks (missing execinfo.h and feenableexcept())
 +include(CheckIncludeFiles)
 +check_include_files(execinfo.h HAVE_EXECINFO_H)
-+if (HAVE_EXECINFO_H)
++if(HAVE_EXECINFO_H)
 +  add_definitions(-DHAVE_EXECINFO_H)
 +endif()
 +
 +include(CheckLibraryExists)
 +check_library_exists(m feenableexcept "fenv.h" HAVE_FEENABLEEXCEPT)
-+if (HAVE_FEENABLEEXCEPT)
++if(HAVE_FEENABLEEXCEPT)
 +  add_definitions(-DHAVE_FEENABLEEXCEPT)
 +endif()
 +
- # See TEST_SSE_SUPPORT() for how this is defined.
- 
- # Do it globally, SSE2 is required for quite some time now.
-diff -ru blender-2.78.orig/source/blender/blenlib/intern/system.c blender-2.78a/source/blender/blenlib/intern/system.c
---- blender-2.78.orig/source/blender/blenlib/intern/system.c	2016-10-25 09:59:23.000000000 +0000
-+++ blender-2.78a/source/blender/blenlib/intern/system.c	2017-02-07 14:44:35.213040733 +0000
-@@ -77,7 +77,7 @@
- {
- 	/* ------------- */
- 	/* Linux / Apple */
--#if defined(__linux__) || defined(__APPLE__)
-+#if (defined(__linux__) && defined(HAVE_EXECINFO_H)) || defined(__APPLE__)
- 
- #define SIZE 100
- 	void *buffer[SIZE];
-diff -ru blender-2.78.orig/source/creator/creator_signals.c blender-2.78a/source/creator/creator_signals.c
---- blender-2.78.orig/source/creator/creator_signals.c	2016-10-24 14:13:56.000000000 +0000
-+++ blender-2.78a/source/creator/creator_signals.c	2017-02-07 14:47:01.888625973 +0000
-@@ -309,7 +309,7 @@
- 	 * set breakpoints on sig_handle_fpe */
- 	signal(SIGFPE, sig_handle_fpe);
- 
--# if defined(__linux__) && defined(__GNUC__)
-+# if defined(__linux__) && defined(__GNUC__) && defined(HAVE_FEENABLEEXCEPT)
- 	feenableexcept(FE_DIVBYZERO | FE_INVALID | FE_OVERFLOW);
- # endif /* defined(__linux__) && defined(__GNUC__) */
- # if defined(OSX_SSE_FPE)
---- a/source/blender/blenlib/intern/system.c	2019-07-30 21:05:30.702224608 +0200
-+++ -	2019-07-30 21:13:21.535328709 +0200
-@@ -38,10 +38,13 @@
- #  include <dbghelp.h>
- #  pragma warning(pop)
- #else
--#  include <execinfo.h>
- #  include <unistd.h>
- #endif
- 
-+#if (defined(__linux__) && defined(HAVE_EXECINFO_H)) || defined(__APPLE__)
-+#  include <execinfo.h>
-+#endif
-+
- int BLI_cpu_support_sse2(void)
- {
- #if defined(__x86_64__) || defined(_M_X64)
---- a/intern/guardedalloc/intern/mallocn_intern.h	2019-07-24 09:41:39.000000000 +0200
-+++ -	2019-10-20 00:03:13.450031866 +0200
-@@ -40,7 +40,7 @@
+ # Blender internal features
+ option(WITH_BLENDER "Build blender (disable to build only the blender player)" ON)
+ mark_as_advanced(WITH_BLENDER)
+diff --git a/intern/guardedalloc/intern/mallocn_intern.h b/intern/guardedalloc/intern/mallocn_intern.h
+index 8fc3e43..ee443c4 100644
+--- a/intern/guardedalloc/intern/mallocn_intern.h
++++ b/intern/guardedalloc/intern/mallocn_intern.h
+@@ -33,7 +33,7 @@
  #undef HAVE_MALLOC_STATS
  #define USE_MALLOC_USABLE_SIZE /* internal, when we have malloc_usable_size() */
  
 -#if defined(__linux__) || (defined(__FreeBSD_kernel__) && !defined(__FreeBSD__)) || \
-+#if (defined(__FreeBSD_kernel__) && !defined(__FreeBSD__)) || \
++#if defined(__linux__) && defined(HAVE_EXECINFO_H) || (defined(__FreeBSD_kernel__) && !defined(__FreeBSD__)) || \
      defined(__GLIBC__)
  #  include <malloc.h>
  #  define HAVE_MALLOC_STATS
+diff --git a/intern/libc_compat/libc_compat.c b/intern/libc_compat/libc_compat.c
+index 78e387e..d21c281 100644
 --- a/intern/libc_compat/libc_compat.c
 +++ b/intern/libc_compat/libc_compat.c
-@@ -21,10 +21,10 @@
-  * incompatible with the system libraries that Blender is built on. To solve
-  * this we add a few -ffast-math symbols that can be missing. */
- 
--#ifdef __linux__
+@@ -25,7 +25,6 @@
  #  include <features.h>
  #  include <math.h>
  
-+#ifdef __GLIBC__
- #  if defined(__GLIBC_PREREQ) && __GLIBC_PREREQ(2, 31)
+-#  if defined(__GLIBC_PREREQ) && __GLIBC_PREREQ(2, 31)
  
  double __exp_finite(double x);
+ double __exp2_finite(double x);
+@@ -124,5 +123,4 @@ float __powf_finite(float x, float y)
+   return powf(x, y);
+ }
+ 
+-#  endif /* __GLIBC_PREREQ */
+ #endif   /* __linux__ */
+diff --git a/source/blender/blenlib/intern/system.c b/source/blender/blenlib/intern/system.c
+index 20edbb9..6e856cd 100644
+--- a/source/blender/blenlib/intern/system.c
++++ b/source/blender/blenlib/intern/system.c
+@@ -35,7 +35,9 @@
+ 
+ #  include "BLI_winstuff.h"
+ #else
++#if defined(HAVE_EXECINFO_H)
+ #  include <execinfo.h>
++#endif
+ #  include <unistd.h>
+ #endif
+ 
+@@ -80,7 +82,7 @@ void BLI_system_backtrace(FILE *fp)
+ {
+   /* ------------- */
+   /* Linux / Apple */
+-#  if defined(__linux__) || defined(__APPLE__)
++#  if defined(__linux__) && defined(HAVE_EXECINFO_H) || defined(__APPLE__)
+ 
+ #    define SIZE 100
+   void *buffer[SIZE];
+diff --git a/source/creator/creator_signals.c b/source/creator/creator_signals.c
+index ad0b7b2..01d5e37 100644
+--- a/source/creator/creator_signals.c
++++ b/source/creator/creator_signals.c
+@@ -269,7 +269,7 @@ void main_signal_setup_fpe(void)
+    * set breakpoints on sig_handle_fpe */
+   signal(SIGFPE, sig_handle_fpe);
  
+-#    if defined(__linux__) && defined(__GNUC__)
++#    if defined(__linux__) && defined(__GNUC__) && defined(HAVE_FEENABLEEXCEPT)
+   feenableexcept(FE_DIVBYZERO | FE_INVALID | FE_OVERFLOW);
+ #    endif /* defined(__linux__) && defined(__GNUC__) */
+ #    if defined(OSX_SSE_FPE)
+-- 
+2.28.0
+
diff --git a/srcpkgs/blender/patches/python39.patch b/srcpkgs/blender/patches/python39.patch
index 9c87fa95c6f..1e14eb06203 100644
--- a/srcpkgs/blender/patches/python39.patch
+++ b/srcpkgs/blender/patches/python39.patch
@@ -1,153 +1,25 @@
-From 56d0df51a36fdce7ec2d1fbb7b47b1d95b591b5f Mon Sep 17 00:00:00 2001
-From: Campbell Barton <ideasman42@gmail.com>
-Date: Mon, 22 Jun 2020 14:51:20 +1000
-Subject: [PATCH] Python: support building again version 3.9 (unreleased)
+The deprecated PyEval_ReleaseLock() triggers a segfault with Python 3.9.0.
+See issue at https://developer.blender.org/T81688 and fix at
+https://developer.blender.org/rB5edba9b42f684bf8b99894bb6988e7f46180e12c
 
-Resolves T78089, no functional changes.
----
- .../blender/python/mathutils/mathutils_Matrix.c  | 16 +++++++++-------
- .../python/mathutils/mathutils_Quaternion.c      | 14 ++++++++------
- .../blender/python/mathutils/mathutils_Vector.c  |  6 +++---
- 3 files changed, 20 insertions(+), 16 deletions(-)
-
-diff --git a/source/blender/python/mathutils/mathutils_Matrix.c b/source/blender/python/mathutils/mathutils_Matrix.c
-index 327ee4dd1c3..63137e094b7 100644
---- a/source/blender/python/mathutils/mathutils_Matrix.c
-+++ b/source/blender/python/mathutils/mathutils_Matrix.c
-@@ -42,7 +42,8 @@ static PyObject *Matrix_copy_notest(MatrixObject *self, const float *matrix);
- static PyObject *Matrix_copy(MatrixObject *self);
- static PyObject *Matrix_deepcopy(MatrixObject *self, PyObject *args);
- static int Matrix_ass_slice(MatrixObject *self, int begin, int end, PyObject *value);
--static PyObject *matrix__apply_to_copy(PyNoArgsFunction matrix_func, MatrixObject *self);
-+static PyObject *matrix__apply_to_copy(PyObject *(*matrix_func)(MatrixObject *),
-+                                       MatrixObject *self);
- static PyObject *MatrixAccess_CreatePyObject(MatrixObject *matrix, const eMatrixAccess_t type);
- 
- static int matrix_row_vector_check(MatrixObject *mat, VectorObject *vec, int row)
-@@ -395,14 +396,15 @@ static PyObject *Matrix_new(PyTypeObject *type, PyObject *args, PyObject *kwds)
-   return NULL;
- }
- 
--static PyObject *matrix__apply_to_copy(PyNoArgsFunction matrix_func, MatrixObject *self)
-+static PyObject *matrix__apply_to_copy(PyObject *(*matrix_func)(MatrixObject *),
-+                                       MatrixObject *self)
- {
-   PyObject *ret = Matrix_copy(self);
-   if (ret) {
--    PyObject *ret_dummy = matrix_func(ret);
-+    PyObject *ret_dummy = matrix_func((MatrixObject *)ret);
-     if (ret_dummy) {
-       Py_DECREF(ret_dummy);
--      return (PyObject *)ret;
-+      return ret;
-     }
-     else { /* error */
-       Py_DECREF(ret);
-@@ -1738,7 +1740,7 @@ PyDoc_STRVAR(
-     "   .. note:: When the matrix cant be adjugated a :exc:`ValueError` exception is raised.\n");
- static PyObject *Matrix_adjugated(MatrixObject *self)
- {
--  return matrix__apply_to_copy((PyNoArgsFunction)Matrix_adjugate, self);
-+  return matrix__apply_to_copy(Matrix_adjugate, self);
- }
- 
- PyDoc_STRVAR(
-@@ -1946,7 +1948,7 @@ PyDoc_STRVAR(Matrix_transposed_doc,
-              "   :rtype: :class:`Matrix`\n");
- static PyObject *Matrix_transposed(MatrixObject *self)
- {
--  return matrix__apply_to_copy((PyNoArgsFunction)Matrix_transpose, self);
-+  return matrix__apply_to_copy(Matrix_transpose, self);
- }
- 
- /*---------------------------matrix.normalize() ------------------*/
-@@ -1992,7 +1994,7 @@ PyDoc_STRVAR(Matrix_normalized_doc,
-              "   :rtype: :class:`Matrix`\n");
- static PyObject *Matrix_normalized(MatrixObject *self)
- {
--  return matrix__apply_to_copy((PyNoArgsFunction)Matrix_normalize, self);
-+  return matrix__apply_to_copy(Matrix_normalize, self);
- }
- 
- /*---------------------------matrix.zero() -----------------------*/
-diff --git a/source/blender/python/mathutils/mathutils_Quaternion.c b/source/blender/python/mathutils/mathutils_Quaternion.c
-index 39d84c1ac96..7ce0ea5f249 100644
---- a/source/blender/python/mathutils/mathutils_Quaternion.c
-+++ b/source/blender/python/mathutils/mathutils_Quaternion.c
-@@ -34,7 +34,8 @@
- 
- #define QUAT_SIZE 4
- 
--static PyObject *quat__apply_to_copy(PyNoArgsFunction quat_func, QuaternionObject *self);
-+static PyObject *quat__apply_to_copy(PyObject *(*quat_func)(QuaternionObject *),
-+                                     QuaternionObject *self);
- static void quat__axis_angle_sanitize(float axis[3], float *angle);
- static PyObject *Quaternion_copy(QuaternionObject *self);
- static PyObject *Quaternion_deepcopy(QuaternionObject *self, PyObject *args);
-@@ -463,7 +464,7 @@ PyDoc_STRVAR(Quaternion_normalized_doc,
-              "   :rtype: :class:`Quaternion`\n");
- static PyObject *Quaternion_normalized(QuaternionObject *self)
- {
--  return quat__apply_to_copy((PyNoArgsFunction)Quaternion_normalize, self);
-+  return quat__apply_to_copy(Quaternion_normalize, self);
- }
- 
- PyDoc_STRVAR(Quaternion_invert_doc,
-@@ -490,7 +491,7 @@ PyDoc_STRVAR(Quaternion_inverted_doc,
-              "   :rtype: :class:`Quaternion`\n");
- static PyObject *Quaternion_inverted(QuaternionObject *self)
- {
--  return quat__apply_to_copy((PyNoArgsFunction)Quaternion_invert, self);
-+  return quat__apply_to_copy(Quaternion_invert, self);
- }
- 
- PyDoc_STRVAR(Quaternion_identity_doc,
-@@ -553,7 +554,7 @@ PyDoc_STRVAR(Quaternion_conjugated_doc,
-              "   :rtype: :class:`Quaternion`\n");
- static PyObject *Quaternion_conjugated(QuaternionObject *self)
- {
--  return quat__apply_to_copy((PyNoArgsFunction)Quaternion_conjugate, self);
-+  return quat__apply_to_copy(Quaternion_conjugate, self);
- }
- 
- PyDoc_STRVAR(Quaternion_copy_doc,
-@@ -1385,10 +1386,11 @@ static PyObject *Quaternion_new(PyTypeObject *type, PyObject *args, PyObject *kw
-   return Quaternion_CreatePyObject(quat, type);
- }
- 
--static PyObject *quat__apply_to_copy(PyNoArgsFunction quat_func, QuaternionObject *self)
-+static PyObject *quat__apply_to_copy(PyObject *(*quat_func)(QuaternionObject *),
-+                                     QuaternionObject *self)
- {
-   PyObject *ret = Quaternion_copy(self);
--  PyObject *ret_dummy = quat_func(ret);
-+  PyObject *ret_dummy = quat_func((QuaternionObject *)ret);
-   if (ret_dummy) {
-     Py_DECREF(ret_dummy);
-     return ret;
-diff --git a/source/blender/python/mathutils/mathutils_Vector.c b/source/blender/python/mathutils/mathutils_Vector.c
-index ace7480ee81..15ae811fd91 100644
---- a/source/blender/python/mathutils/mathutils_Vector.c
-+++ b/source/blender/python/mathutils/mathutils_Vector.c
-@@ -96,10 +96,10 @@ static PyObject *Vector_new(PyTypeObject *type, PyObject *args, PyObject *kwds)
-   return Vector_CreatePyObject_alloc(vec, size, type);
- }
- 
--static PyObject *vec__apply_to_copy(PyNoArgsFunction vec_func, VectorObject *self)
-+static PyObject *vec__apply_to_copy(PyObject *(*vec_func)(VectorObject *), VectorObject *self)
- {
-   PyObject *ret = Vector_copy(self);
--  PyObject *ret_dummy = vec_func(ret);
-+  PyObject *ret_dummy = vec_func((VectorObject *)ret);
-   if (ret_dummy) {
-     Py_DECREF(ret_dummy);
-     return (PyObject *)ret;
-@@ -376,7 +376,7 @@ PyDoc_STRVAR(Vector_normalized_doc,
-              "   :rtype: :class:`Vector`\n");
- static PyObject *Vector_normalized(VectorObject *self)
- {
--  return vec__apply_to_copy((PyNoArgsFunction)Vector_normalize, self);
-+  return vec__apply_to_copy(Vector_normalize, self);
- }
- 
- PyDoc_STRVAR(Vector_resize_doc,
+--- a/source/blender/python/generic/bpy_threads.c	2020-10-13 15:29:16.708347045 -0400
++++ b/source/blender/python/generic/bpy_threads.c	2020-10-13 15:29:43.123345331 -0400
+@@ -29,14 +29,11 @@
+ /* analogue of PyEval_SaveThread() */
+ BPy_ThreadStatePtr BPY_thread_save(void)
+ {
+-  PyThreadState *tstate = PyThreadState_Swap(NULL);
+-  /* note: tstate can be NULL when quitting Blender */
+-
+-  if (tstate && PyEval_ThreadsInitialized()) {
+-    PyEval_ReleaseLock();
++  /* The thread-state can be NULL when quitting Blender. */
++  if (_PyThreadState_UncheckedGet()) {
++    return (BPy_ThreadStatePtr)PyEval_SaveThread();
+   }
+-
+-  return (BPy_ThreadStatePtr)tstate;
++  return NULL;
+ }
+ 
+ /* analogue of PyEval_RestoreThread() */
diff --git a/srcpkgs/blender/template b/srcpkgs/blender/template
index 731f4af9f68..b724ef01318 100644
--- a/srcpkgs/blender/template
+++ b/srcpkgs/blender/template
@@ -1,15 +1,17 @@
 # Template file for 'blender'
 pkgname=blender
-version=2.83.6
-revision=3
-archs="x86_64* i686* ppc64*"
+version=2.90.1
+revision=1
+archs="x86_64* ppc64*"
 build_style="cmake"
 pycompile_dirs="/usr/share/blender/${version%.*}/scripts"
-configure_args="-DWITH_INSTALL_PORTABLE=OFF -DWITH_PYTHON_INSTALL=OFF -DWITH_JACK=ON -DWITH_CODEC_FFMPEG=ON
- -DWITH_CODEC_SNDFILE=ON -DWITH_OPENMP=ON -DWITH_FFTW3=ON -DWITH_MOD_OCEANSIM=ON -DWITH_CYCLES=ON
- -DWITH_OPENCOLORIO=ON -DWITH_IMAGE_OPENEXR=ON -DWITH_IMAGE_OPENJPEG=ON -DWITH_OPENSUBDIV=ON
- -DWITH_OPENCOLLADA=ON -DWITH_SYSTEM_GLEW=ON -DWITH_OPENVDB=ON -DWITH_ALEMBIC=ON -DWITH_BUILDINFO=OFF
- -DPYTHON_VERSION=$py3_ver -DPYTHON_LIBPATH=/usr/lib -DPYTHON_LIBRARY='python${py3_ver}${py3_abiver}'
+configure_args="-DWITH_INSTALL_PORTABLE=OFF -DWITH_PYTHON_INSTALL=OFF
+ -DWITH_JACK=ON -DWITH_CODEC_FFMPEG=ON -DWITH_CODEC_SNDFILE=ON -DWITH_OPENMP=ON
+ -DWITH_FFTW3=ON -DWITH_MOD_OCEANSIM=ON -DWITH_CYCLES_EMBREE=OFF -DWITH_OPENCOLORIO=ON
+ -DWITH_IMAGE_OPENEXR=ON -DWITH_IMAGE_OPENJPEG=ON -DWITH_OPENSUBDIV=ON
+ -DWITH_OPENCOLLADA=ON -DWITH_SYSTEM_GLEW=ON -DWITH_OPENVDB=ON -DWITH_ALEMBIC=ON
+ -DWITH_BUILDINFO=OFF -DPYTHON_VERSION=$py3_ver -DPYTHON_LIBPATH=/usr/lib
+ -DPYTHON_LIBRARY='python${py3_ver}${py3_abiver}'
  -DPYTHON_INCLUDE_DIRS=/$py3_inc"
 makedepends="libgomp-devel libpng-devel tiff-devel python3-devel glu-devel
  glew-devel freetype-devel jack-devel libopenal-devel libsndfile-devel
@@ -23,15 +25,13 @@ maintainer="Enno Boland <gottox@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="http://www.blender.org"
 distfiles="http://download.blender.org/source/${pkgname}-${version}.tar.xz"
-checksum=2338297d6061efd98c05878e954450ef26ba2dfe49658d6156f6b3eaf9b92de0
+checksum=e78dcc946c823ad1bd89bcc6938fc6b375540ec3eff58649586acf1f6a653d99
 python_version=3
 patch_args="-Np1"
 
 case "$XBPS_TARGET_MACHINE" in
-*-musl) # crashes at startup in jemallocs free()
-	;;
-*) makedepends+=" jemalloc-devel"
-	;;
+	*-musl) ;;
+	*) makedepends+=" jemalloc-devel" ;;
 esac
 
 case "$XBPS_TARGET_MACHINE" in

From 35e6058480145453c61f3af70f197d21bfc27295 Mon Sep 17 00:00:00 2001
From: Imran Khan <imrankhan@teknik.io>
Date: Wed, 14 Oct 2020 15:01:26 +0600
Subject: [PATCH 076/312] txr: update to 244.

---
 srcpkgs/txr/template | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/txr/template b/srcpkgs/txr/template
index 5b439fca970..c3b0931c69a 100644
--- a/srcpkgs/txr/template
+++ b/srcpkgs/txr/template
@@ -1,12 +1,11 @@
 # Template file for 'txr'
 pkgname=txr
-version=243
+version=244
 revision=1
 archs="x86_64* i686* aarch64* arm* ppc64* mips*"
 build_style=configure
 configure_args="--prefix=/usr"
 make_check_target=tests
-hostmakedepends="bison flex"
 makedepends="libffi-devel"
 short_desc="Programming language for convenient data munging"
 maintainer="Oliver Kiddle <okiddle@yahoo.co.uk>"
@@ -14,7 +13,7 @@ license="BSD-2-Clause"
 homepage="http://www.nongnu.org/txr/"
 changelog="http://www.kylheku.com/cgit/txr/tree/RELNOTES?id=${pkgname}-${version}"
 distfiles="http://www.kylheku.com/cgit/txr/snapshot/${pkgname}-${version}.tar.bz2"
-checksum=dcf5f478769f50f51797f44c56b49fb731f5114460eee78e12ad8619b86c62a3
+checksum=192cebb4edf89fcf0010cf3982a058ee5019abf28336bcf47cd3a5c1bb392b58
 nopie=yes
 
 if [ "$CROSS_BUILD" ]; then

From d7beb09e24f0de46e77000988e77278728810be0 Mon Sep 17 00:00:00 2001
From: Paper <paper@tilde.institute>
Date: Wed, 14 Oct 2020 11:00:04 +0200
Subject: [PATCH 077/312] nautilus: update to 3.38.1

---
 srcpkgs/nautilus/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/nautilus/template b/srcpkgs/nautilus/template
index e45228fa051..f7108f9b062 100644
--- a/srcpkgs/nautilus/template
+++ b/srcpkgs/nautilus/template
@@ -1,6 +1,6 @@
 # Template file for 'nautilus'
 pkgname=nautilus
-version=3.38.0
+version=3.38.1
 revision=1
 build_style=meson
 build_helper="gir"
@@ -8,7 +8,7 @@ configure_args="-Dtests=headless -Dintrospection=$(vopt_if gir true false)"
 hostmakedepends="gettext glib-devel libxslt pkg-config tracker3"
 makedepends="exempi-devel gnome-autoar-devel gnome-desktop-devel gtk+3-devel
  libexif-devel libgexiv2-devel libglib-devel libnotify-devel libseccomp-devel
- libX11-devel libxml2-devel tracker3-devel gst-plugins-base1-devel"
+ libX11-devel libxml2-devel tracker3-devel gst-plugins-base1-devel harfbuzz-devel"
 depends="desktop-file-utils gsettings-desktop-schemas hicolor-icon-theme
  tracker3-miners tracker3"
 checkdepends="tracker3 tracker3-miners python3-gobject dbus"
@@ -17,7 +17,7 @@ maintainer="Enno Boland <gottox@voidlinux.org>"
 license="GPL-2.0-or-later, LGPL-2.1-or-later"
 homepage="https://wiki.gnome.org/Nautilus"
 distfiles="${GNOME_SITE}/${pkgname}/${version::4}/${pkgname}-${version}.tar.xz"
-checksum=c6f330f9f3f7dbf35afb6ec2094b746ee75d5e928c8f6780dab26672086ccac0
+checksum=0a3e812b13b774b7fd6f222f55acd1f87fb2973d9af60c04b7d25cb52222d0fd
 
 build_options="gir"
 build_options_default="gir"

From d0e3f030fd192ea8c72b04c20ede454cef662c05 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:44:30 +0200
Subject: [PATCH 078/312] attica: update to 5.75.0

[ci skip]
---
 srcpkgs/attica/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/attica/template b/srcpkgs/attica/template
index 6b71a3273fe..47c15fb49d4 100644
--- a/srcpkgs/attica/template
+++ b/srcpkgs/attica/template
@@ -1,6 +1,6 @@
 # Template file for 'attica'
 pkgname=attica
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -11,7 +11,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later"
 homepage="https://invent.kde.org/frameworks/attica"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=8b52e5be795bd3c5200d516333800a745ea8c550208460faac5f456a0c245e0d
+checksum=fcc0b11620de9d88141fcb36aa2eddc19a78c023a2c753eb9de404271280288d
 
 attica-devel_package() {
 	depends="${makedepends} ${sourcepkg}>=${version}_${revision}"

From cff8ce42068d9ba370b3074e97d4e4571aec20ec Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:44:32 +0200
Subject: [PATCH 079/312] baloo5: update to 5.75.0

[ci skip]
---
 srcpkgs/baloo5/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/baloo5/template b/srcpkgs/baloo5/template
index 323e8d30fa5..256011665ef 100644
--- a/srcpkgs/baloo5/template
+++ b/srcpkgs/baloo5/template
@@ -1,6 +1,6 @@
 # Template file for 'baloo5'
 pkgname=baloo5
-version=5.74.0
+version=5.75.0
 revision=1
 wrksrc="${pkgname%5}-${version}"
 build_style=cmake
@@ -15,7 +15,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later"
 homepage="https://community.kde.org/Baloo"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname%5}-${version}.tar.xz"
-checksum=780b30431c2c9a3d8b30589962116be6f788355ea82fed0c800027e5de69cee0
+checksum=e26e0b76eb57889592131c7a95134e32288a8c67d6660342dcc961f37c1926f0
 
 baloo5-devel_package() {
 	short_desc+=" - development"

From e7691770a6ef18e4eab5f7e1b6cbcab6ed001762 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:44:34 +0200
Subject: [PATCH 080/312] bluez-qt5: update to 5.75.0

[ci skip]
---
 srcpkgs/bluez-qt5/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/bluez-qt5/template b/srcpkgs/bluez-qt5/template
index fed1279006c..276a386e52d 100644
--- a/srcpkgs/bluez-qt5/template
+++ b/srcpkgs/bluez-qt5/template
@@ -1,6 +1,6 @@
 # Template file for 'bluez-qt5'
 pkgname=bluez-qt5
-version=5.74.0
+version=5.75.0
 revision=1
 wrksrc="${pkgname%5}-${version}"
 build_style=cmake
@@ -13,7 +13,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later"
 homepage="https://invent.kde.org/frameworks/bluez-qt"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname%5}-${version}.tar.xz"
-checksum=2671e9d2cd12a8a6ff55f268e9fa3f5c05f2c629a7649e4e81fb12eab7cfdd2d
+checksum=f00446dd89a0d1340256b7c4a1f38de05e5be04a76298956e4bcd153979bad3f
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" qt5-host-tools qt5-qmake"

From f6454a3b2a507218f6a8a18b61ddec35b6f5b51d Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 19:09:32 +0200
Subject: [PATCH 081/312] fixup! breeze-icons: update to 5.75.0

---
 srcpkgs/breeze-icons/template | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/srcpkgs/breeze-icons/template b/srcpkgs/breeze-icons/template
index a02f331a58d..56502349438 100644
--- a/srcpkgs/breeze-icons/template
+++ b/srcpkgs/breeze-icons/template
@@ -3,7 +3,8 @@ pkgname=breeze-icons
 version=5.74.0
 revision=1
 build_style=cmake
-hostmakedepends="kcoreaddons extra-cmake-modules qt5-host-tools qt5-devel libxml2"
+hostmakedepends="kcoreaddons extra-cmake-modules qt5-host-tools qt5-devel
+ python3-lxml libxml2"
 makedepends="qt5-devel"
 checkdepends="fdupes"
 short_desc="Breeze icon theme"

From 845c851ca6e83377ab845584375ef9f80c16c120 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:44:45 +0200
Subject: [PATCH 082/312] extra-cmake-modules: update to 5.75.0

[ci skip]
---
 srcpkgs/extra-cmake-modules/template | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/extra-cmake-modules/template b/srcpkgs/extra-cmake-modules/template
index 3968946335d..e1fda6f39a6 100644
--- a/srcpkgs/extra-cmake-modules/template
+++ b/srcpkgs/extra-cmake-modules/template
@@ -1,8 +1,7 @@
 # Template file for 'extra-cmake-modules'
 pkgname=extra-cmake-modules
-version=5.74.0
+version=5.75.0
 revision=1
-archs=noarch
 build_style=cmake
 configure_args="-DBUILD_HTML_DOCS=OFF -DBUILD_TESTING=OFF"
 hostmakedepends="python3-Sphinx qt5-tools"
@@ -12,7 +11,7 @@ maintainer="John <me@johnnynator.dev>"
 license="BSD-3-Clause"
 homepage="https://invent.kde.org/frameworks/extra-cmake-modules"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=71406067bcd99ac106e0e3bfbb073653b18fd6d01039c0298d9767680977364f
+checksum=878d47a901056d5303bf37414d787046e1d38fac2bd9f2f5ddd00a9dd6b9f4eb
 python_version=3
 
 post_install() {

From ba089d3ee1b3a6883c3a8ae51c3bba0efc9da369 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:44:48 +0200
Subject: [PATCH 083/312] frameworkintegration: update to 5.75.0

[ci skip]
---
 srcpkgs/frameworkintegration/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/frameworkintegration/template b/srcpkgs/frameworkintegration/template
index 549b6e08b2c..d8cde43f2d4 100644
--- a/srcpkgs/frameworkintegration/template
+++ b/srcpkgs/frameworkintegration/template
@@ -1,6 +1,6 @@
 # Template file for 'frameworkintegration'
 pkgname=frameworkintegration
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -12,7 +12,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.0-or-later"
 homepage="https://invent.kde.org/frameworks/frameworkintegration"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=70afc459048776b0e74ed549687833fefe78db5e4c93189639a223ba43a90ba5
+checksum=a98dc6aa464f35f97ef51bfa7873d6d905623417543aaf94ec974f24603e3b0b
 
 frameworkintegration-devel_package() {
 	short_desc+=" - development"

From 1720a18e79146d6e7c93dd72cac09416f91067ee Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:44:51 +0200
Subject: [PATCH 084/312] kactivities5-stats: update to 5.75.0

[ci skip]
---
 srcpkgs/kactivities5-stats/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kactivities5-stats/template b/srcpkgs/kactivities5-stats/template
index 23f8d077555..12344729e7b 100644
--- a/srcpkgs/kactivities5-stats/template
+++ b/srcpkgs/kactivities5-stats/template
@@ -1,6 +1,6 @@
 # Template file for 'kactivities5-stats'
 pkgname=kactivities5-stats
-version=5.74.0
+version=5.75.0
 revision=1
 wrksrc="${pkgname/5/}-${version}"
 build_style=cmake
@@ -12,7 +12,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.0-or-later, LGPL-2.1-or-later"
 homepage="https://api.kde.org/frameworks/kactivities/html/index.html"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname/5/}-${version}.tar.xz"
-checksum=57858648049ac607f3d6003a22f58a66a2bf5e981b8eda45663fb09b5234dece
+checksum=eee926b1d49c460f1220957e52858df5271aee3b9c77b848e2969f0afe743aad
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" qt5-host-tools qt5-qmake"

From 572013d278bc73ac68a3c49dd0440db4420f948e Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:44:56 +0200
Subject: [PATCH 085/312] kactivities5: update to 5.75.0

[ci skip]
---
 srcpkgs/kactivities5/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kactivities5/template b/srcpkgs/kactivities5/template
index 2992f169b65..2be312362e2 100644
--- a/srcpkgs/kactivities5/template
+++ b/srcpkgs/kactivities5/template
@@ -1,6 +1,6 @@
 # Template file for 'kactivities5'
 pkgname=kactivities5
-version=5.74.0
+version=5.75.0
 revision=1
 wrksrc="${pkgname%5}-${version}"
 build_style=cmake
@@ -15,7 +15,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later, GPL-2.0-or-later"
 homepage="https://invent.kde.org/frameworks/kactivities"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname%5}-${version}.tar.xz"
-checksum=da5e23b9a59572852c74e207f3acc00b38ff420008c8dfa5f970b748c2c2ae0e
+checksum=d25fa31d9ad8bed6af1adbd589945494d1f5741e18e7bb5d67371749c6565e08
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" qt5-host-tools"

From bbfd0998b4ae16bc116609a9e77a51bb99a71809 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:44:58 +0200
Subject: [PATCH 086/312] kapidox: update to 5.75.0

[ci skip]
---
 srcpkgs/kapidox/template | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/kapidox/template b/srcpkgs/kapidox/template
index 189ec787ae0..8fb78f075d6 100644
--- a/srcpkgs/kapidox/template
+++ b/srcpkgs/kapidox/template
@@ -1,18 +1,19 @@
 # Template file for 'kapidox'
 pkgname=kapidox
-version=5.74.0
-revision=3
+version=5.75.0
+revision=1
 build_style=cmake
 hostmakedepends="kcoreaddons extra-cmake-modules python3 python3-setuptools"
 makedepends="python3-Jinja2 python3-yaml"
 depends="python3-Jinja2 python3-yaml doxygen"
 short_desc="API documentation generation tool for KDE framework"
 maintainer="John <me@johnnynator.dev>"
-license="BSD-2-Clause"
+license="BSD-2-Clause, CC0-1.0"
 homepage="https://invent.kde.org/frameworks/kapidox"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=7c5b56b924fe6ae5b3a183d4ff5236cb8c6690fc2bda2f685073d620ec61d2c0
+checksum=80e2a7bb86ed6c87c9d556d5c0f4059e3968fdbbc585bc041a55d130455d07d2
 
 post_install() {
-	vlicense LICENSE
+	vlicense LICENSES/BSD-2-Clause.txt
+	vlicense LICENSES/CC0-1.0.txt
 }

From ec451b0744435d3b4535eba9ca60749daff51440 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:45:04 +0200
Subject: [PATCH 087/312] karchive: update to 5.75.0

[ci skip]
---
 srcpkgs/karchive/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/karchive/template b/srcpkgs/karchive/template
index 0297734da5d..2360372a5ca 100644
--- a/srcpkgs/karchive/template
+++ b/srcpkgs/karchive/template
@@ -1,6 +1,6 @@
 # Template file for 'karchive'
 pkgname=karchive
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -11,7 +11,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.0-only, LGPL-2.0-or-later"
 homepage="https://invent.kde.org/frameworks/karchive"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=deba7aedd9cbf707a56cabeb33d231d64db36c3e5ff866b543c374613be1fc21
+checksum=0c833c766d2301335490a1b36197bae20b2e45d1350f4f8100e6e00d5502eaab
 
 karchive-devel_package() {
 	short_desc+=" - development"

From 758ee857100c178b43930aa8b037f6e831739c3d Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:45:06 +0200
Subject: [PATCH 088/312] kauth: update to 5.75.0

[ci skip]
---
 srcpkgs/kauth/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kauth/template b/srcpkgs/kauth/template
index cf853a3b918..a276ef87763 100644
--- a/srcpkgs/kauth/template
+++ b/srcpkgs/kauth/template
@@ -1,6 +1,6 @@
 # Template file for 'kauth'
 pkgname=kauth
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 hostmakedepends="kcoreaddons extra-cmake-modules pkg-config"
@@ -10,7 +10,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later"
 homepage="https://invent.kde.org/frameworks/kauth"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=e0aa6206c4bf9220d1c4882b8b77f9cf9202646b64b8a249a60a9d4b272e3bfc
+checksum=c2c316b783f3d531c6f3a308087dcdc59211920df8b10f6814272ebf6c8fd083
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" kcoreaddons qt5-host-tools qt5-qmake qt5-tools-devel polkit-qt5-devel"

From ef371711fb7171c23641ecad88f4a2492e08165d Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:45:08 +0200
Subject: [PATCH 089/312] kbookmarks: update to 5.75.0

[ci skip]
---
 srcpkgs/kbookmarks/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kbookmarks/template b/srcpkgs/kbookmarks/template
index fb4413fa7a1..0e4c38fe594 100644
--- a/srcpkgs/kbookmarks/template
+++ b/srcpkgs/kbookmarks/template
@@ -1,6 +1,6 @@
 # Template file for 'kbookmarks'
 pkgname=kbookmarks
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -11,7 +11,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.0-only"
 homepage="https://invent.kde.org/frameworks/kbookmarks"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=d72d6ea4c97757dd940353c2b70ef1b8645ae1a9659bfaf1236dc90df3a3eac2
+checksum=56320e443ba0ec52822b84a968ada0e34331b12251f84df839fc165fcb14e458
 
 kbookmarks-devel_package() {
 	short_desc+=" - development"

From bc4c54f1aed165dc1b65e4485d2de45d05c1a53b Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:45:13 +0200
Subject: [PATCH 090/312] kcalendarcore: update to 5.75.0

[ci skip]
---
 srcpkgs/kcalendarcore/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kcalendarcore/template b/srcpkgs/kcalendarcore/template
index 11fe28501a2..dd533e37478 100644
--- a/srcpkgs/kcalendarcore/template
+++ b/srcpkgs/kcalendarcore/template
@@ -1,7 +1,7 @@
 # Template file for 'kcalendarcore'
 pkgname=kcalendarcore
 reverts="19.08.3_1 19.08.2_1 19.08.1_1 19.08.0_1 19.04.3_1 19.04.2_1 19.04.1_1 19.04.0_1 18.12.3_1 18.12.2_1 18.12.1_1 18.12.0_2 18.12.0_1 18.08.3_1 18.08.2_1 18.08.1_1 18.08.0_1 18.04.3_1 17.12.3_1"
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 hostmakedepends="kcoreaddons extra-cmake-modules qt5-qmake qt5-host-tools"
@@ -12,7 +12,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.0-or-later"
 homepage="${KDE_SITE}https://invent.kde.org/frameworks/kcalendarcore"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=003cb076e3094d8327049f776b176ea1c1365f810e3dc8d245938b6c76598e82
+checksum=02ff08c6462a5f0552c85a1da98320ca0a1c8d7295a05230f4b27b7a3f0a3dbc
 replaces="kcalcore>=0"
 
 do_check() {

From 9caffcaebf10206782ca0c2de201142b557e08ff Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:45:15 +0200
Subject: [PATCH 091/312] kcmutils: update to 5.75.0

[ci skip]
---
 srcpkgs/kcmutils/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kcmutils/template b/srcpkgs/kcmutils/template
index 801821b9fd4..50d40b27107 100644
--- a/srcpkgs/kcmutils/template
+++ b/srcpkgs/kcmutils/template
@@ -1,6 +1,6 @@
 # Template file for 'kcmutils'
 pkgname=kcmutils
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -12,7 +12,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.0-or-later, LGPL-2.0-only"
 homepage="https://invent.kde.org/frameworks/kcmutils"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=c2d54364997ed75961ad875d73a667f6bc8d6732cfacd7ad40ba84c594d567c7
+checksum=dd7926548cd05b98c0013cbeac204e47860c517b9121a80c3a739bbbffaba3cd
 
 kcmutils-devel_package() {
 	short_desc+=" - development"

From 7a0600e1d962c30e514d5517355537b10d602e68 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:45:17 +0200
Subject: [PATCH 092/312] kcodecs: update to 5.75.0

[ci skip]
---
 srcpkgs/kcodecs/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kcodecs/template b/srcpkgs/kcodecs/template
index 976e565b165..0287b02c7b6 100644
--- a/srcpkgs/kcodecs/template
+++ b/srcpkgs/kcodecs/template
@@ -1,6 +1,6 @@
 # Template file for 'kcodecs'
 pkgname=kcodecs
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -11,7 +11,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.0-only, LGPL-2.0-or-later"
 homepage="https://invent.kde.org/frameworks/kcodecs"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=5a69b9224e9fb89b729e6c0c478d6a0c353a65a4ef0134059b6772f904b8f6a3
+checksum=cf4498c00368cc667910776cf54de02838f17b5f2d0bd48749ec5a2000346327
 
 kcodecs-devel_package() {
 	depends="${makedepends} ${sourcepkg}>=${version}_${revision}"

From e616649045b03bab2bc6c84f31eee38a44fe89d1 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:45:22 +0200
Subject: [PATCH 093/312] kcompletion: update to 5.75.0

[ci skip]
---
 srcpkgs/kcompletion/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kcompletion/template b/srcpkgs/kcompletion/template
index 6ea3b6bfe4d..ddbeadbce63 100644
--- a/srcpkgs/kcompletion/template
+++ b/srcpkgs/kcompletion/template
@@ -1,6 +1,6 @@
 # Template file for 'kcompletion'
 pkgname=kcompletion
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 hostmakedepends="kcoreaddons extra-cmake-modules"
@@ -10,7 +10,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.0-or-later"
 homepage="https://invent.kde.org/frameworks/kcompletion"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=5bec7f31bab8eb724bfb01690bd1585b43eccca4e37c80cc3729af2f7c7b2875
+checksum=409b2759b6ac476b16fd6b5efd78381e9a840bae041fef35285404d2b79eeeff
 
 if [ "CROSS_BUILD" ]; then
 	hostmakedepends+=" qt5-host-tools qt5-qmake qt5-tools-devel"

From e50636257fc1c440e8275770f971d376332c1c45 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:45:25 +0200
Subject: [PATCH 094/312] kconfig: update to 5.75.0

[ci skip]
---
 srcpkgs/kconfig/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kconfig/template b/srcpkgs/kconfig/template
index d3e47fde1ec..e11d30ad95c 100644
--- a/srcpkgs/kconfig/template
+++ b/srcpkgs/kconfig/template
@@ -1,6 +1,6 @@
 # Template file for 'kconfig'
 pkgname=kconfig
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -11,7 +11,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.0-only, LGPL-2.0-or-later, LGPL-2.1-or-later"
 homepage="https://invent.kde.org/frameworks/kconfig"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=dfeff0649f8987f88a01827c06468b87547509d9e46920902a55f6a0d6adc5db
+checksum=38aa7cabcb042d3f2614d0229f7a4f65952b19b5c7edd78ee2b0401fd6dd4290
 
 kconfig-devel_package() {
 	short_desc+=" - development"

From 260bee29cc5927f6b5f61c07f7b0e6372955cdd3 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:45:27 +0200
Subject: [PATCH 095/312] kconfigwidgets: update to 5.75.0

[ci skip]
---
 srcpkgs/kconfigwidgets/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kconfigwidgets/template b/srcpkgs/kconfigwidgets/template
index 9a573f97516..1370b5516c6 100644
--- a/srcpkgs/kconfigwidgets/template
+++ b/srcpkgs/kconfigwidgets/template
@@ -1,6 +1,6 @@
 # Template file for 'kconfigwidgets'
 pkgname=kconfigwidgets
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -13,7 +13,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.0-or-later"
 homepage="https://invent.kde.org/frameworks/kconfigwidgets"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=e14b5b409c7b242796ca7119cb9d41b11728222b79e00bdcc62822d991120dd4
+checksum=cd99dc233d1aaf30fbb910f2f268cffc1e11d3480b7c592d2a566aaf4812f083
 
 kconfigwidgets-devel_package() {
 	short_desc+=" - development"

From 9d07e5120a1d07a9e9e410445d283c4f755b9fa6 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:45:32 +0200
Subject: [PATCH 096/312] kcontacts: update to 5.75.0

[ci skip]
---
 srcpkgs/kcontacts/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kcontacts/template b/srcpkgs/kcontacts/template
index 7ba8e825e16..45a0c0b2b66 100644
--- a/srcpkgs/kcontacts/template
+++ b/srcpkgs/kcontacts/template
@@ -1,7 +1,7 @@
 # Template file for 'kcontacts'
 pkgname=kcontacts
 reverts="19.08.2_1 19.08.1_1 19.08.0_1 19.04.3_1"
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 hostmakedepends="extra-cmake-modules qt5-qmake qt5-host-tools python3
@@ -12,7 +12,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later"
 homepage="https://invent.kde.org/frameworks/kcontacts"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=4e669178cff15812c4c3281a0505ab87e55a6820fa0c1974164f9c77d0eda10c
+checksum=8c77f9c5cf9ea630c779096a91f96322f34adc66c9fa64a85dddb294a905d069
 
 pre_check() {
 	export QT_QPA_PLATFORM=offscreen

From e59036283683f042a060383cf621ee536c577a1c Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:45:35 +0200
Subject: [PATCH 097/312] kcoreaddons: update to 5.75.0

[ci skip]
---
 srcpkgs/kcoreaddons/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kcoreaddons/template b/srcpkgs/kcoreaddons/template
index 7a0f6cd0d9d..ba9efd6e3df 100644
--- a/srcpkgs/kcoreaddons/template
+++ b/srcpkgs/kcoreaddons/template
@@ -1,6 +1,6 @@
 # Template file for 'kcoreaddons'
 pkgname=kcoreaddons
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -12,7 +12,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.0-or-later, LGPL-2.1-or-later"
 homepage="https://invent.kde.org/frameworks/kcoreaddons"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=e122d0750c594dc68dea20e40c833b6615f5ddf21a2b2e439c7236e73f4523a8
+checksum=9ca2cf82ddc12e27ff73aaefdf616c3eb6552a3a5531f014b5bf52a34a4c73f9
 
 post_install() {
 	vsed -e 's;${_IMPORT_PREFIX};/usr;g' \

From 042faab93c1b8f942128dc9d5c683656637371b0 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:45:37 +0200
Subject: [PATCH 098/312] kcrash: update to 5.75.0

[ci skip]
---
 srcpkgs/kcrash/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kcrash/template b/srcpkgs/kcrash/template
index 1dd1c8d0620..7ad169e541f 100644
--- a/srcpkgs/kcrash/template
+++ b/srcpkgs/kcrash/template
@@ -1,6 +1,6 @@
 # Template file for 'kcrash'
 pkgname=kcrash
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -11,7 +11,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.0-or-later"
 homepage="https://invent.kde.org/frameworks/kcrash"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=4aaffaed77c0aebf7f68183ed2256173a35c7200be1e99984cbfd9c9f332b07f
+checksum=1c8950bf699e4df86c2ebe29a364be53017b45d127c1d052c7ac4ef13b96db3a
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" qt5-host-tools kwindowsystem-devel kcoreaddons"

From a5ae28b50dd292c1f3f1a246a55140185da603ac Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:45:42 +0200
Subject: [PATCH 099/312] kdav: update to 5.75.0

[ci skip]
---
 srcpkgs/kdav/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kdav/template b/srcpkgs/kdav/template
index 815f19c2a30..be69ddb2765 100644
--- a/srcpkgs/kdav/template
+++ b/srcpkgs/kdav/template
@@ -1,7 +1,7 @@
 # Template file for 'kdav'
 pkgname=kdav
 reverts="19.04.0_1 19.04.1_1 19.04.2_1 19.04.3_1 19.08.0_1 19.08.1_1 19.08.2_1 19.08.3_1 19.12.0_1 19.12.1_1 19.12.2_1 19.12.3_1 20.04.0_1 20.04.1_1 20.04.2_1 20.04.3_1"
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 hostmakedepends="extra-cmake-modules qt5-qmake qt5-host-tools python3
@@ -12,7 +12,7 @@ maintainer="John <me@johnnynator.dev>"
 license="GPL-2.0-or-later"
 homepage="https://invent.kde.org/frameworks/kdav"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=4c7e67756e1ac72c65bb560ab0714edcfe7890d9f52d813f86e1db16f37f8dc1
+checksum=4442abb9afb177085e9d2c82cdb87c67f7992d770b1bee922b84806b9f44256e
 
 pre_check() {
 	export QT_QPA_PLATFORM=offscreen

From f4b0c4d05770b22083adc0d6ce019e4f7ee252f4 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:45:45 +0200
Subject: [PATCH 100/312] kdbusaddons: update to 5.75.0

[ci skip]
---
 srcpkgs/kdbusaddons/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kdbusaddons/template b/srcpkgs/kdbusaddons/template
index f9bf3ca68ec..7bbe9effc8d 100644
--- a/srcpkgs/kdbusaddons/template
+++ b/srcpkgs/kdbusaddons/template
@@ -1,6 +1,6 @@
 # Template file for 'kdbusaddons'
 pkgname=kdbusaddons
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -11,7 +11,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.0-or-later, LGPL-2.1-or-later"
 homepage="https://invent.kde.org/frameworks/kdbusaddons"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=e2c5131e7eb0daaa348801ed1b553dd043918663f6dcaa50ad95f55e0d30b4a2
+checksum=25826b091a22d876621dca040ca47ea1ec34119d300be91f19629a82c7f84af1
 
 kdbusaddons-devel_package() {
 	short_desc+=" - development"

From cd496c4307bf7515465594da50aad0aa05e2e607 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:45:47 +0200
Subject: [PATCH 101/312] kdeclarative: update to 5.75.0

[ci skip]
---
 srcpkgs/kdeclarative/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kdeclarative/template b/srcpkgs/kdeclarative/template
index 7a4181282a4..09e30ca5c31 100644
--- a/srcpkgs/kdeclarative/template
+++ b/srcpkgs/kdeclarative/template
@@ -1,6 +1,6 @@
 # Template file for 'kdeclarative'
 pkgname=kdeclarative
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -12,7 +12,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.0-or-later, LGPL-2.1-or-later"
 homepage="https://invent.kde.org/frameworks/kdeclarative"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=387c41626c145ddd1fc76d102b5ceaf37321cd02ca7395a10084cfd009bd0422
+checksum=585b3b7d97c26542c8325050d1c4f7e36cf6111c43cf630cd2a729a36963109b
 
 kdeclarative-devel_package() {
 	short_desc+=" - development"

From 22a5b00e9c14fac5080ea70dfb9bee480a2dbaf6 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:45:52 +0200
Subject: [PATCH 102/312] kded: update to 5.75.0

[ci skip]
---
 srcpkgs/kded/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kded/template b/srcpkgs/kded/template
index 333af0e2c24..b70fde290e7 100644
--- a/srcpkgs/kded/template
+++ b/srcpkgs/kded/template
@@ -1,6 +1,6 @@
 # Template file for 'kded'
 pkgname=kded
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -11,7 +11,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.0-only, LGPL-2.0-or-later"
 homepage="https://invent.kde.org/frameworks/kded"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=e6bf23e59afbd7d1f89082f748db1c0370413a40c99bdfc6f08a54fbd58471f1
+checksum=dd811f4e8058348f772133d910aa8623fde4208c50c7d7a834605cf04f8f097d
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" qt5-host-tools qt5-qmake kdoctools"

From de983310549729f441082ff5231d5b199ab5639d Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:45:55 +0200
Subject: [PATCH 103/312] kdelibs4support: update to 5.75.0

[ci skip]
---
 srcpkgs/kdelibs4support/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kdelibs4support/template b/srcpkgs/kdelibs4support/template
index 05d16c848ee..b89ee953802 100644
--- a/srcpkgs/kdelibs4support/template
+++ b/srcpkgs/kdelibs4support/template
@@ -1,6 +1,6 @@
 # Template file for 'kdelibs4support'
 pkgname=kdelibs4support
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF
@@ -16,7 +16,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.0-or-later, LGPL-2.1-or-later"
 homepage="https://invent.kde.org/frameworks/kdelibs4support"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/portingAids/${pkgname}-${version}.tar.xz"
-checksum=39547b7b312d7b2abece14c8692256a9aa55c8ceba816e8f39d4bc861b742be2
+checksum=54466e73d05dfbb6ffd65b2018d689b8c807e0569e59da29a70daf2ac195461d
 
 if [ "$CROSS_BUILD" ]; then
 	# gettaddrinfo runtime test is always fine (can't be achieved in crossbuild)

From dd25167759a0ada41bd57a2b87b0658dcc4f811b Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:45:57 +0200
Subject: [PATCH 104/312] kdesignerplugin: update to 5.75.0

[ci skip]
---
 srcpkgs/kdesignerplugin/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kdesignerplugin/template b/srcpkgs/kdesignerplugin/template
index 06a216dabd5..570224dec7c 100644
--- a/srcpkgs/kdesignerplugin/template
+++ b/srcpkgs/kdesignerplugin/template
@@ -1,6 +1,6 @@
 # Template file for 'kdesignerplugin'
 pkgname=kdesignerplugin
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -13,7 +13,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-only"
 homepage="https://invent.kde.org/frameworks/kdesignerplugin"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/portingAids/${pkgname}-${version}.tar.xz"
-checksum=14370fa37567e0ea9e4f2bbb34605b218b3bbad70e4c2945bd5bf179dd9e4f79
+checksum=fd8812b4fb6922091b53da72eb74104f9438be3063e65ffe23d6948a292f18e9
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" qt5-host-tools qt5-qmake qt5-tools python kgendesignerplugin kdoctools"

From 6ade5062a9281322b07abeba14b8892cd1072208 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:46:03 +0200
Subject: [PATCH 105/312] kdesu: update to 5.75.0

[ci skip]
---
 srcpkgs/kdesu/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kdesu/template b/srcpkgs/kdesu/template
index 42dbd25309e..617ff6df4b9 100644
--- a/srcpkgs/kdesu/template
+++ b/srcpkgs/kdesu/template
@@ -1,6 +1,6 @@
 # Template file for 'kdesu'
 pkgname=kdesu
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -12,7 +12,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.0-only"
 homepage="https://invent.kde.org/frameworks/kdesu"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=7b59327835ca7a49e26e1adcc69b94309025d1ce82b53673e82edf43ad8d8afc
+checksum=c9ac069e7958f95f69891b78bd752310688624dc02f6e1595d4c41645f0a2bd9
 
 kdesu-devel_package() {
 	short_desc+=" - development"

From 8e3dfaf2ad54720d7276e65b1cfcb6da1674de85 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:46:05 +0200
Subject: [PATCH 106/312] kdewebkit: update to 5.75.0

[ci skip]
---
 srcpkgs/kdewebkit/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kdewebkit/template b/srcpkgs/kdewebkit/template
index 52fc65961e9..cca0879d3d4 100644
--- a/srcpkgs/kdewebkit/template
+++ b/srcpkgs/kdewebkit/template
@@ -1,6 +1,6 @@
 # Template file for 'kdewebkit'
 pkgname=kdewebkit
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -12,7 +12,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.0-or-later"
 homepage="https://invent.kde.org/frameworks/kdewebkit"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/portingAids/${pkgname}-${version}.tar.xz"
-checksum=b13bbb90d80ce9fc633aff15059363513d3242746984909d08c84db33af66a45
+checksum=c02b5e206713e436b464eb6c5813096736d3806b458fdf0502b8920efe12e400
 
 kdewebkit-devel_package() {
 	short_desc+=" - development"

From 4002746894a4be71aec1f1e2164ccbf6c6178acd Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:46:07 +0200
Subject: [PATCH 107/312] kdnssd: update to 5.75.0

[ci skip]
---
 srcpkgs/kdnssd/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kdnssd/template b/srcpkgs/kdnssd/template
index d4e9ca5752e..cb297405c7b 100644
--- a/srcpkgs/kdnssd/template
+++ b/srcpkgs/kdnssd/template
@@ -1,6 +1,6 @@
 # Template file for 'kdnssd'
 pkgname=kdnssd
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -11,7 +11,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.0-or-later"
 homepage="https://invent.kde.org/frameworks/kdnssd"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=5c07b6dbe07ca994fcae084af0a9c2703d1450ad52d371be09cc849ba5f40cd0
+checksum=3f197cabab50316fdc6852b90a3ec064ba99b2c8289093198c76d21ec03ddc8b
 
 kdnssd-devel_package() {
 	short_desc+=" - development"

From ee4f7a8c47deb491020e8b9e2d4a4d68c8cf5b03 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:46:13 +0200
Subject: [PATCH 108/312] kdoctools: update to 5.75.0

[ci skip]
---
 srcpkgs/kdoctools/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kdoctools/template b/srcpkgs/kdoctools/template
index d3fcc053183..9aabfe9b423 100644
--- a/srcpkgs/kdoctools/template
+++ b/srcpkgs/kdoctools/template
@@ -1,6 +1,6 @@
 # Template file for 'kdoctools'
 pkgname=kdoctools
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -12,7 +12,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later"
 homepage="https://invent.kde.org/frameworks/kdoctools"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=4b54e7a7fb1328ceb4c0a95d620f226c8d8401f93ef28f165e37783b0ce3054e
+checksum=4463dd3021ebff078a92d0556f37cbfa1b16ba970e8ad510bf397bd55f49381a
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" qt5-host-tools qt5-qmake python kdoctools-devel"

From f7b34e8a9575e80cf2c009351eb52003038fc912 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:46:15 +0200
Subject: [PATCH 109/312] kemoticons: update to 5.75.0

[ci skip]
---
 srcpkgs/kemoticons/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kemoticons/template b/srcpkgs/kemoticons/template
index 778ebcb16a8..7ac48fc6d36 100644
--- a/srcpkgs/kemoticons/template
+++ b/srcpkgs/kemoticons/template
@@ -1,6 +1,6 @@
 # Template file for 'kemoticons'
 pkgname=kemoticons
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -11,7 +11,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later, CC-BY-4.0"
 homepage="https://invent.kde.org/frameworks/kemoticons"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=405c1d72ed812a6915276b9810e997b17572f7ecf66d58dea8869eed45da3702
+checksum=4ac70cee9d7fafe6ef9668d37a146489b341804e0bf0dba6a7cce2d6ecaa78c1
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" qt5-host-tools qt5-qmake"

From 5b838f2b8be048cb974d2c923b6ee10d22e4adf0 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:46:20 +0200
Subject: [PATCH 110/312] kfilemetadata5: update to 5.75.0

[ci skip]
---
 srcpkgs/kfilemetadata5/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kfilemetadata5/template b/srcpkgs/kfilemetadata5/template
index 4ff732f985e..7440a9e4fa8 100644
--- a/srcpkgs/kfilemetadata5/template
+++ b/srcpkgs/kfilemetadata5/template
@@ -1,6 +1,6 @@
 # Template file for 'kfilemetadata5'
 pkgname=kfilemetadata5
-version=5.74.0
+version=5.75.0
 revision=1
 wrksrc="${pkgname%5}-${version}"
 build_style=cmake
@@ -14,7 +14,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later"
 homepage="https://invent.kde.org/frameworks/kfilemetadata"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname%5}-${version}.tar.xz"
-checksum=c5fab0101a39265eeb1884522ed548ae106cd434d6313be1fc0bdba4f29dc5a8
+checksum=2798207b796cc37638d3a4fe84cb8be1479b074db772c12d402fc6bfbd5cf0ca
 
 kfilemetadata5-devel_package() {
 	short_desc+=" - development"

From c0b7e9be2db0f3b9f12726c095ca8aea4f7d94e3 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:46:23 +0200
Subject: [PATCH 111/312] kglobalaccel: update to 5.75.0

[ci skip]
---
 srcpkgs/kglobalaccel/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kglobalaccel/template b/srcpkgs/kglobalaccel/template
index 0a8ebaa789c..cc7c902b50c 100644
--- a/srcpkgs/kglobalaccel/template
+++ b/srcpkgs/kglobalaccel/template
@@ -1,6 +1,6 @@
 # Template file for 'kglobalaccel'
 pkgname=kglobalaccel
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -11,7 +11,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.0-or-later"
 homepage="https://invent.kde.org/frameworks/kglobalaccel"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=492d0f4198dc7bbfcfaf518804d9a99d22ac49a27ffb3816d147d36be159318f
+checksum=a4d0e1f87317870120772444fa6736ce020668675be08d5e445a3ce5a60355d4
 
 kglobalaccel-devel_package() {
 	short_desc+=" - development"

From e64d36ff158781a954c235ad63514ae51ba6c75e Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:46:25 +0200
Subject: [PATCH 112/312] kguiaddons: update to 5.75.0

[ci skip]
---
 srcpkgs/kguiaddons/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kguiaddons/template b/srcpkgs/kguiaddons/template
index 8e23778ed65..500aec8f1e3 100644
--- a/srcpkgs/kguiaddons/template
+++ b/srcpkgs/kguiaddons/template
@@ -1,6 +1,6 @@
 # Template file for 'kguiaddons'
 pkgname=kguiaddons
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -11,7 +11,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.0-only, LGPL-2.0-or-later, LGPL-2.1-or-later"
 homepage="https://invent.kde.org/frameworks/kguiaddons"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=bb7c5b88e1738b22571f2f135202b3c08230911fcb8d089b8676d4d59af4578b
+checksum=58aba1bd986020f7b4bde0d35a7b09730716cbdffde734e6d29cc9d18500253b
 
 kguiaddons-devel_package() {
 	short_desc+=" - development"

From 76646560c0cbf53733c5c7afa83eba13b32a93d9 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:46:27 +0200
Subject: [PATCH 113/312] kholidays: update to 5.75.0

[ci skip]
---
 srcpkgs/kholidays/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kholidays/template b/srcpkgs/kholidays/template
index 0255443126e..05d439d3a76 100644
--- a/srcpkgs/kholidays/template
+++ b/srcpkgs/kholidays/template
@@ -1,7 +1,7 @@
 # Template file for 'kholidays'
 pkgname=kholidays
 reverts="17.12.3_1 17.12.1_1 17.12.0_1 17.04.3_1"
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 hostmakedepends="kcoreaddons extra-cmake-modules"
@@ -11,7 +11,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later"
 homepage="https://invent.kde.org/frameworks/kholidays"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=effb264ecd3b439c01a7b52f33ef2f6ee77083322300d66d3e8f7369b43f9b8f
+checksum=2ff86514a1165c88fc81b47476c5671b5e840633d3bf04cfe513881e4a0db7e5
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" qt5-host-tools qt5-qmake"

From 188ffee6dcdb01b730a77e8b516b8f5c91599c58 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:46:31 +0200
Subject: [PATCH 114/312] khtml: update to 5.75.0

[ci skip]
---
 srcpkgs/khtml/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/khtml/template b/srcpkgs/khtml/template
index 2858dd335ba..a66667fec68 100644
--- a/srcpkgs/khtml/template
+++ b/srcpkgs/khtml/template
@@ -1,6 +1,6 @@
 # Template file for 'khtml'
 pkgname=khtml
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DDESKTOPTOJSON_EXECUTABLE=/usr/bin/desktoptojson"
@@ -12,7 +12,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.0-or-later"
 homepage="https://invent.kde.org/frameworks/khtml"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/portingAids/${pkgname}-${version}.tar.xz"
-checksum=f656f2796ccaa0f47bec33e36b4f7d53cd80dc8a5393ce869a7ae6c8c2bc67e5
+checksum=942951da89f0a1d7f74d5771bcfa166f8851e94923952d86c0d62ee445d43f25
 
 pre_check() {
 	export QT_QPA_PLATFORM=offscreen

From 240610a6456019924e89541af52bcf087f7ea3ec Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:46:34 +0200
Subject: [PATCH 115/312] ki18n: update to 5.75.0

[ci skip]
---
 srcpkgs/ki18n/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/ki18n/template b/srcpkgs/ki18n/template
index 76253c9c193..36782359852 100644
--- a/srcpkgs/ki18n/template
+++ b/srcpkgs/ki18n/template
@@ -1,6 +1,6 @@
 # Template file for 'ki18n'
 pkgname=ki18n
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -11,7 +11,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.0-or-later"
 homepage="https://invent.kde.org/frameworks/ki18n"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=bcbb95a81cd8f808fc8314741309c4b4ec25fc1c347e285a7cfefc006df3009c
+checksum=71f22a4ef4a9e750a1813c9fe37b552d9e053e6e2249079b5908d078160130d3
 
 ki18n-devel_package() {
 	short_desc+=" - development"

From c700aa4c2aab4df092e1828b5ca188a69944c0eb Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:46:36 +0200
Subject: [PATCH 116/312] kiconthemes: update to 5.75.0

[ci skip]
---
 srcpkgs/kiconthemes/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kiconthemes/template b/srcpkgs/kiconthemes/template
index a0a865d9cfb..59516eecf2e 100644
--- a/srcpkgs/kiconthemes/template
+++ b/srcpkgs/kiconthemes/template
@@ -1,6 +1,6 @@
 # Template file for 'kiconthemes'
 pkgname=kiconthemes
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -12,7 +12,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.0-only, GPL-2.0-or-later"
 homepage="https://invent.kde.org/frameworks/kiconthemes"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=f51f0c75f50da3d119448f387c65fa69785c2c1bc82b61407bb92bf80cab31b5
+checksum=250b551ecfc5381c36267c51fdc86948ed85b1f477b12bd15a57d2d4e44a88db
 
 kiconthemes-devel_package() {
 	short_desc+=" - development"

From c0f56bce790197fa5b0784a850da6210ff8e9e4b Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:46:41 +0200
Subject: [PATCH 117/312] kidletime: update to 5.75.0

[ci skip]
---
 srcpkgs/kidletime/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kidletime/template b/srcpkgs/kidletime/template
index 86a8e97068e..311ae3171ef 100644
--- a/srcpkgs/kidletime/template
+++ b/srcpkgs/kidletime/template
@@ -1,6 +1,6 @@
 # Template file for 'kidletime'
 pkgname=kidletime
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -11,7 +11,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.0-or-later"
 homepage="https://invent.kde.org/frameworks/kidletime"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=62ba9e38467e74e928191200109e9312f1f6959a6b9474bf1a47c95833ae7feb
+checksum=da1a980bec52f00baa20bb1f886fc32392587ffd467404888d3a1cb5897bd200
 
 kidletime-devel_package() {
 	short_desc+=" - development"

From 7ba5cbfec81b01d38ffb56527bc747bd82c0c90d Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:46:43 +0200
Subject: [PATCH 118/312] kimageformats: update to 5.75.0

[ci skip]
---
 srcpkgs/kimageformats/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kimageformats/template b/srcpkgs/kimageformats/template
index 2e3daa41302..1c96c114393 100644
--- a/srcpkgs/kimageformats/template
+++ b/srcpkgs/kimageformats/template
@@ -1,6 +1,6 @@
 # Template file for 'kimageformats'
 pkgname=kimageformats
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -11,4 +11,4 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.0-or-later"
 homepage="https://invent.kde.org/frameworks/kimageformats"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=732c94512a26ff4c4fcdea46ce26fcd7c700c129188c181115fbb0facac937fe
+checksum=7ea083bc1b67cf069df1bcf3235f00a750a269cfb38b5ade6e971ece11e46a65

From 2a17830353068e44881ad73210e0744f8dc11ec0 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:46:45 +0200
Subject: [PATCH 119/312] kinit: update to 5.75.0

[ci skip]
---
 srcpkgs/kinit/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kinit/template b/srcpkgs/kinit/template
index 89b1c1654e7..75d2311848d 100644
--- a/srcpkgs/kinit/template
+++ b/srcpkgs/kinit/template
@@ -1,6 +1,6 @@
 # Template file for 'kinit'
 pkgname=kinit
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -12,7 +12,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.0-only"
 homepage="https://invent.kde.org/frameworks/kinit"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=e952750a9d2c5d72f2fbf8faff55ffdae0e667bf5fc4e1e1f1fd985464bb8092
+checksum=f4f6f0caf7bfe7a321b0e822735ac5377e2b46600249ae77010a1252a5b87647
 
 kinit-devel_package() {
 	short_desc+=" - development"

From 19128c1ed49e378bebbdf9efeb791f9ec461afad Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:46:48 +0200
Subject: [PATCH 120/312] kio: update to 5.75.0

[ci skip]
---
 srcpkgs/kio/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/kio/template b/srcpkgs/kio/template
index 6372addf27c..9a51c076991 100644
--- a/srcpkgs/kio/template
+++ b/srcpkgs/kio/template
@@ -1,7 +1,7 @@
 # Template file for 'kio'
 pkgname=kio
-version=5.74.1
-revision=2
+version=5.75.0
+revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF
  -DDESKTOPTOJSON_EXECUTABLE=/usr/bin/desktoptojson"
@@ -15,7 +15,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.0-or-later"
 homepage="https://invent.kde.org/frameworks/kio"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=2f88a383b751194d4f327d3f87f8ea25fe882f8cc5c58a368529d9ab7143a6e7
+checksum=27af8d83d0ea6c68fc62675a0d0d34e94489e9e518c4a4c32fa9d4784510bc8e
 
 CXXFLAGS+=" -fpermissive"
 

From 818532a7637b3dd2beea7970d071ea6a244d7e88 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:46:50 +0200
Subject: [PATCH 121/312] kirigami2: update to 5.75.0

[ci skip]
---
 srcpkgs/kirigami2/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kirigami2/template b/srcpkgs/kirigami2/template
index 86d026b5e59..ede25809dca 100644
--- a/srcpkgs/kirigami2/template
+++ b/srcpkgs/kirigami2/template
@@ -1,6 +1,6 @@
 # Template file for 'kirigami2'
 pkgname=kirigami2
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 hostmakedepends="kcoreaddons extra-cmake-modules qt5-qmake qt5-host-tools"
@@ -12,7 +12,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="LGPL-2.0-or-later"
 homepage="https://techbase.kde.org/Kirigami"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/kirigami2-${version}.tar.xz"
-checksum=9706915f219ef9394b030dbb24974d4fddef091008954cf75cf97cc97586e35f
+checksum=cde28a432e2ce56aae6f29eb557dc838af6846eb7dcba587113f73ebf11fca7d
 
 kirigami2-devel_package() {
 	short_desc+=" - development"

From 70958926b4017b40852cebd24e5ce78cfd5e3c53 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:46:55 +0200
Subject: [PATCH 122/312] kitemmodels: update to 5.75.0

[ci skip]
---
 srcpkgs/kitemmodels/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kitemmodels/template b/srcpkgs/kitemmodels/template
index bfb1345b1ff..2b5b063d128 100644
--- a/srcpkgs/kitemmodels/template
+++ b/srcpkgs/kitemmodels/template
@@ -1,6 +1,6 @@
 # Template file for 'kitemmodels'
 pkgname=kitemmodels
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -11,7 +11,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.0-or-later"
 homepage="https://invent.kde.org/frameworks/kitemmodels"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=89c91051445137959e3dd7276d428adaff09b1ca9980f37d4a66d0c34c7b36c1
+checksum=fb3f4caa2e55ffb5e21ea8f65bcb6ea9b074c54f9dbbce458ba7320d6c50fdb6
 
 kitemmodels-devel_package() {
 	short_desc+=" - development"

From d4c76c9d9ddc2e94b23c5ea08b387e71ad66ceca Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:46:58 +0200
Subject: [PATCH 123/312] kitemviews: update to 5.75.0

[ci skip]
---
 srcpkgs/kitemviews/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kitemviews/template b/srcpkgs/kitemviews/template
index d2c57b652eb..b60359b98c6 100644
--- a/srcpkgs/kitemviews/template
+++ b/srcpkgs/kitemviews/template
@@ -1,6 +1,6 @@
 # Template file for 'kitemviews'
 pkgname=kitemviews
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -11,7 +11,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.0-only, LGPL-2.0-or-later"
 homepage="https://invent.kde.org/frameworks/kitemviews"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=09417ce8b84dc81575ec3612ad0c19d923b2511051c0cb3b98282a013bae5ef7
+checksum=071f2886cfb213c01cfeb26a9c98b26b720ff6928c5db04d4ead9ca34f72cac1
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" qt5-qmake qt5-host-tools qt5-tools-devel"

From 5e89b6458e840acb5dcd5782c3a95a7e9a81fbdd Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:47:04 +0200
Subject: [PATCH 124/312] kjobwidgets: update to 5.75.0

[ci skip]
---
 srcpkgs/kjobwidgets/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kjobwidgets/template b/srcpkgs/kjobwidgets/template
index cd1cc93a21d..78613b57eb7 100644
--- a/srcpkgs/kjobwidgets/template
+++ b/srcpkgs/kjobwidgets/template
@@ -1,6 +1,6 @@
 # Template file for 'kjobwidgets'
 pkgname=kjobwidgets
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -11,7 +11,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.0-only, LGPL-2.0-or-later"
 homepage="https://invent.kde.org/frameworks/kjobwidgets"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=76fd0c9634316b5d18fe9e25e77a5511fd2bddd0beef3d5207aca811718c2299
+checksum=6cac9b64d4b13211e5f3c001986933ae461af4d08ef1e5351e2cfd432c22b478
 
 kjobwidgets-devel_package() {
 	short_desc+=" - development"

From 1b0627e9363c86b6b6fa1f9768cfda1e82b17a76 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:47:09 +0200
Subject: [PATCH 125/312] kjs: update to 5.75.0

[ci skip]
---
 srcpkgs/kjs/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kjs/template b/srcpkgs/kjs/template
index 8eb9c93e065..d94fc8c1308 100644
--- a/srcpkgs/kjs/template
+++ b/srcpkgs/kjs/template
@@ -1,6 +1,6 @@
 # Template file for 'kjs'
 pkgname=kjs
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -11,7 +11,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.0-or-later"
 homepage="https://invent.kde.org/frameworks/kjs"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/portingAids/${pkgname}-${version}.tar.xz"
-checksum=4f097c24570319b7dd825a875eff8cb9911e06f8fc552a4547f281cb4eebbb34
+checksum=d7411680164f2c9d989528d690888a703c15cd106cddb2665f1325dfb5fe2efa
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" qt5-host-tools qt5-qmake kdoctools kjs"

From 02e88ebaabd09fb1aa743133b2099af04248051f Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:47:11 +0200
Subject: [PATCH 126/312] kjsembed: update to 5.75.0

[ci skip]
---
 srcpkgs/kjsembed/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kjsembed/template b/srcpkgs/kjsembed/template
index 91c00f1b73d..356cb6c1484 100644
--- a/srcpkgs/kjsembed/template
+++ b/srcpkgs/kjsembed/template
@@ -1,6 +1,6 @@
 # Template file for 'kjsembed'
 pkgname=kjsembed
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -11,7 +11,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.0-or-later"
 homepage="https://invent.kde.org/frameworks/kjsembed"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/portingAids/${pkgname}-${version}.tar.xz"
-checksum=7d2f26648f9df429d84db67b2fe35731cbf29b9c0a49d48c26e519cd094f1be4
+checksum=1127c6f558f9272881ec733a21caa0b93376d9a86ffd2a7558fc299fb3a7efe3
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" qt5-host-tools qt5-qmake python kdoctools"

From 04215874621f5b45ef2490a1cfa181806b7bfc3b Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:47:13 +0200
Subject: [PATCH 127/312] kmediaplayer: update to 5.75.0

[ci skip]
---
 srcpkgs/kmediaplayer/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kmediaplayer/template b/srcpkgs/kmediaplayer/template
index 71ab6fc408f..b9d9419c026 100644
--- a/srcpkgs/kmediaplayer/template
+++ b/srcpkgs/kmediaplayer/template
@@ -1,6 +1,6 @@
 # Template file for 'kmediaplayer'
 pkgname=kmediaplayer
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -12,7 +12,7 @@ maintainer="John <me@johnnynator.dev>"
 license="X11"
 homepage="https://invent.kde.org/frameworks/kmediaplayer"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/portingAids/${pkgname}-${version}.tar.xz"
-checksum=a97d2b7439219b1cf2c0c0430d30d586ea937f0fc0e9f3f9d98823db0c2cb78a
+checksum=17cb03fe28f830fd21b5ad7ab93852395ee32cb8de053a026d7402a68a81d796
 
 kmediaplayer-devel_package() {
 	short_desc+=" - development"

From a47a0fe5e4386dcba6dfeb0311ae9730fd5614a6 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:47:19 +0200
Subject: [PATCH 128/312] knewstuff: update to 5.75.0

[ci skip]
---
 srcpkgs/knewstuff/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/knewstuff/template b/srcpkgs/knewstuff/template
index 49568680f49..49d560e9fc1 100644
--- a/srcpkgs/knewstuff/template
+++ b/srcpkgs/knewstuff/template
@@ -1,6 +1,6 @@
 # Template file for 'knewstuff'
 pkgname=knewstuff
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -12,7 +12,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later"
 homepage="https://invent.kde.org/frameworks/knewstuff"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=638ba6cee3091a94a0ef60977b6e22c7b58267ea6fd1bc17d3e7ac47bd9a3d27
+checksum=1a1f8771ac879e7f08ce688c63a9b0f8bb60d8d3460acf739752c5e05d26c980
 
 knewstuff-devel_package() {
 	short_desc+=" - development"

From 18bafeac5e29d47e4e61903290886c8b3361863b Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:47:21 +0200
Subject: [PATCH 129/312] knotifications: update to 5.75.0

[ci skip]
---
 srcpkgs/knotifications/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/knotifications/template b/srcpkgs/knotifications/template
index 1ab576aa619..5d6dcbce07e 100644
--- a/srcpkgs/knotifications/template
+++ b/srcpkgs/knotifications/template
@@ -1,6 +1,6 @@
 # Template file for 'knotifications'
 pkgname=knotifications
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -12,7 +12,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later"
 homepage="https://invent.kde.org/frameworks/knotifications"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=cbf41ef923a5af6fb5964c8d46a5c52eed023e6c6e8e3e8b74079ff41307927c
+checksum=15be8f602c3f364b0b72be837c41ddc622a5447129b9d3dcb355f297dc18f9db
 
 knotifications-devel_package() {
 	short_desc+=" - development"

From 59d9102d8ebfe7bb4d04e36fda1dad5b948b0d86 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:47:23 +0200
Subject: [PATCH 130/312] knotifyconfig: update to 5.75.0

[ci skip]
---
 srcpkgs/knotifyconfig/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/knotifyconfig/template b/srcpkgs/knotifyconfig/template
index ba3b76fa1bb..2863398c593 100644
--- a/srcpkgs/knotifyconfig/template
+++ b/srcpkgs/knotifyconfig/template
@@ -1,6 +1,6 @@
 # Template file for 'knotifyconfig'
 pkgname=knotifyconfig
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -12,7 +12,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later"
 homepage="https://invent.kde.org/frameworks/knotifyconfig"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=8586b39c621068ef31e74884e20cc061577ae8bec50e6e75c88e9bcab46d8e55
+checksum=b98f5ff6f92e147d36e1204261895ee1557af847ede00333b0cb946dcd00a94b
 
 knotifyconfig-devel_package() {
 	short_desc+=" - development"

From 9c54b72c725ca5e8cf1367c81d81acdf9de80695 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:47:25 +0200
Subject: [PATCH 131/312] kpackage: update to 5.75.0

[ci skip]
---
 srcpkgs/kpackage/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kpackage/template b/srcpkgs/kpackage/template
index afeeef19e3e..b3a1cfe2e90 100644
--- a/srcpkgs/kpackage/template
+++ b/srcpkgs/kpackage/template
@@ -1,6 +1,6 @@
 # Template file for 'kpackage'
 pkgname=kpackage
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -11,7 +11,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later"
 homepage="https://invent.kde.org/frameworks/kpackage"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=b5616d265b2f404b3bc8e389644185d66bf59a685ab40bbf646d36c3f56ff6ae
+checksum=9dd7b8fb029a52c886e2b6c43c4492720851b1242659ebd5dd4a066e569733eb
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" qt5-host-tools qt5-qmake python kdoctools"

From a4cbccfa5805ba135150eab8c4bddb8c21fab56d Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:47:27 +0200
Subject: [PATCH 132/312] kparts: update to 5.75.0

[ci skip]
---
 srcpkgs/kparts/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kparts/template b/srcpkgs/kparts/template
index 97e952927d7..8a3206a6373 100644
--- a/srcpkgs/kparts/template
+++ b/srcpkgs/kparts/template
@@ -1,6 +1,6 @@
 # Template file for 'kparts'
 pkgname=kparts
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 hostmakedepends="kcoreaddons extra-cmake-modules gettext
@@ -11,7 +11,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later"
 homepage="https://invent.kde.org/frameworks/kparts"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=c7dd6ac7d4697f2ac5a63445630997b3f6ccad3b7e65752eb52311a396763504
+checksum=ea745811e4b14a9c62fae161eb6bf97306d28a082e25430dac183d0772ba7fee
 
 pre_check() {
 	export QT_QPA_PLATFORM=offscreen

From 4c8e0f9863f9c3a92226633859be651649587ac1 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:47:29 +0200
Subject: [PATCH 133/312] kpeople: update to 5.75.0

[ci skip]
---
 srcpkgs/kpeople/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kpeople/template b/srcpkgs/kpeople/template
index a33bf5c37ce..67a3d9c1960 100644
--- a/srcpkgs/kpeople/template
+++ b/srcpkgs/kpeople/template
@@ -1,6 +1,6 @@
 # Template file for 'kpeople'
 pkgname=kpeople
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -13,7 +13,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later"
 homepage="https://invent.kde.org/frameworks/kpeople"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=8be0f4cc2223637137f51ee67f4bf2540917dc72be6dfccae01960c9ab0c70c8
+checksum=8b8a8fa8829db7b36c0bf0eeb3bc9ba4733d7ce8b9db6bd3b2721a3f39d40367
 
 kpeople-devel_package() {
 	short_desc+=" - development"

From 06e6c2f8d0348b58bf63ee75a2204e84bc12c55e Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:47:31 +0200
Subject: [PATCH 134/312] kplotting: update to 5.75.0

[ci skip]
---
 srcpkgs/kplotting/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kplotting/template b/srcpkgs/kplotting/template
index cc129aecb8c..254ed487a4c 100644
--- a/srcpkgs/kplotting/template
+++ b/srcpkgs/kplotting/template
@@ -1,6 +1,6 @@
 # Template file for 'kplotting'
 pkgname=kplotting
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -11,7 +11,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later"
 homepage="https://invent.kde.org/frameworks/kplotting"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=135adb95ebed1cbc1b29a481ee0fcbaf25003dbb2449a119c147c3b661377eaa
+checksum=55fded2f312d104fe9e22c6baa04fc125dba9bba45db03f02f6811ab3f04a0ae
 
 kplotting-devel_package() {
 	short_desc+=" - development"

From 450e4b36377df6b393a599bc0088055178d1e411 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:47:33 +0200
Subject: [PATCH 135/312] kpty: update to 5.75.0

[ci skip]
---
 srcpkgs/kpty/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kpty/template b/srcpkgs/kpty/template
index 18ed53ed9b7..e09c9d8e31a 100644
--- a/srcpkgs/kpty/template
+++ b/srcpkgs/kpty/template
@@ -1,6 +1,6 @@
 # Template file for 'kpty'
 pkgname=kpty
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -11,7 +11,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.0-or-later, LGPL-2.1-or-later"
 homepage="https://invent.kde.org/frameworks/kpty"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=9760f656b565e4d2fcd6190062eae7021c338d73f73c59ce299d7ecca0b6aaec
+checksum=ef5484c65fae63acf744787293e74008601063a5eb74f3183449e85895e27c67
 
 kpty-devel_package() {
 	short_desc+=" - development"

From 11251f27120727ce054032dc60b55ac8e0a3df2b Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:47:35 +0200
Subject: [PATCH 136/312] kquickcharts: update to 5.75.0

[ci skip]
---
 srcpkgs/kquickcharts/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kquickcharts/template b/srcpkgs/kquickcharts/template
index 4da3d1ae5b6..eb2a5c3d64d 100644
--- a/srcpkgs/kquickcharts/template
+++ b/srcpkgs/kquickcharts/template
@@ -1,6 +1,6 @@
 # Template file for 'kquickcharts'
 pkgname=kquickcharts
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 hostmakedepends="extra-cmake-modules qt5-qmake qt5-host-tools"
@@ -10,7 +10,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-only OR LGPL-3.0-only"
 homepage="https://community.kde.org/Frameworks"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/kquickcharts-${version}.tar.xz"
-checksum=ee8eeb869fc365d96f37246750c131130255dd12ef6791d40b8ea3e971f6ed83
+checksum=d2595bf1f8b6c5c46961cb95feed2b1f0f16b377ef65cb6fb12bbfcec0c81b82
 
 do_check() {
 	export QT_QPA_PLATFORM=offscreen

From 854972f4afccd469d31a0bc35d0ff4ef49511281 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:47:39 +0200
Subject: [PATCH 137/312] kross: update to 5.75.0

[ci skip]
---
 srcpkgs/kross/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kross/template b/srcpkgs/kross/template
index ece6a91db9b..372b67e92b9 100644
--- a/srcpkgs/kross/template
+++ b/srcpkgs/kross/template
@@ -1,6 +1,6 @@
 # Template file for 'kross'
 pkgname=kross
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF
@@ -13,7 +13,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later"
 homepage="https://invent.kde.org/frameworks/kross"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/portingAids/${pkgname}-${version}.tar.xz"
-checksum=7437097d4440df07eb69a1e07c1353508ab93916023cf2f9a02a3005d51b1c5c
+checksum=59b34c638893e9489d545c0ae7b5751208ced9315981d59719af28815b258757
 
 if [ "$XBPS_TARGET_NO_ATOMIC8" ]; then
 	makedepends+=" libatomic-devel"

From 517b606fee8279ec1a0ddf66f42a98176c09657b Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:47:41 +0200
Subject: [PATCH 138/312] krunner: update to 5.75.0

[ci skip]
---
 srcpkgs/krunner/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/krunner/template b/srcpkgs/krunner/template
index 07672d7b6ac..dee709bfbcd 100644
--- a/srcpkgs/krunner/template
+++ b/srcpkgs/krunner/template
@@ -1,6 +1,6 @@
 # Template file for 'krunner'
 pkgname=krunner
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -12,7 +12,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later"
 homepage="https://invent.kde.org/frameworks/krunner"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=ab1c004a8bffa8f88f5aac3b993fca265a5da3b4210c0359c15b8f68f77c65ec
+checksum=50383177abd782ad852985162a00d86e94d1abf8775ceb75825a7015fff21c66
 
 krunner-devel_package() {
 	short_desc+=" - development"

From 9aea01cd7555e311336648bec29b52a6f77174c8 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:47:43 +0200
Subject: [PATCH 139/312] kservice: update to 5.75.0

[ci skip]
---
 srcpkgs/kservice/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kservice/template b/srcpkgs/kservice/template
index d41e6a86a17..2ad67d11810 100644
--- a/srcpkgs/kservice/template
+++ b/srcpkgs/kservice/template
@@ -1,6 +1,6 @@
 # Template file for 'kservice'
 pkgname=kservice
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -11,7 +11,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.0-or-later, LGPL-2.1-or-later"
 homepage="https://invent.kde.org/frameworks/kservice"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=9c8eb1a8d83909401d837b8ecc40d495bd7612b2fd4d3ea1894967ba881ad9da
+checksum=17ceccf833d8da807dfaee2c3eb5c0ca7ee6b876c2454b5d6914a91eeb0a7f80
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" qt5-host-tools qt5-devel kcoreaddons kdoctools"

From f1010feeaed44f58e9611c00179fdf0aae882005 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:47:45 +0200
Subject: [PATCH 140/312] ksolid: update to 5.75.0

[ci skip]
---
 srcpkgs/ksolid/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/ksolid/template b/srcpkgs/ksolid/template
index c8acbbd0927..e6e06f0845c 100644
--- a/srcpkgs/ksolid/template
+++ b/srcpkgs/ksolid/template
@@ -1,6 +1,6 @@
 # Template file for 'ksolid'
 pkgname=ksolid
-version=5.74.0
+version=5.75.0
 revision=1
 wrksrc="${pkgname#k}-${version}"
 build_style=cmake
@@ -14,7 +14,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later"
 homepage="https://invent.kde.org/frameworks/solid"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname#k}-${version}.tar.xz"
-checksum=70e2356267ed1fdd3a13cd729d91c622aad1ea68a51e1172b0ed9db2468cd4e6
+checksum=471bb76ca0971ab945f2270490b1f72300d86b2b36094ac610e5af69df738a77
 
 libksolid_package() {
 	short_desc+=" - runtime library"

From cd836d18aa8f071edcc144cbcbdc0a2f2773ff98 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:47:48 +0200
Subject: [PATCH 141/312] ktexteditor: update to 5.75.0

[ci skip]
---
 srcpkgs/ktexteditor/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/ktexteditor/template b/srcpkgs/ktexteditor/template
index 0327880d43e..2f9d0b9e569 100644
--- a/srcpkgs/ktexteditor/template
+++ b/srcpkgs/ktexteditor/template
@@ -1,6 +1,6 @@
 # Template file for 'ktexteditor'
 pkgname=ktexteditor
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF
@@ -13,7 +13,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.0-or-later"
 homepage="https://invent.kde.org/frameworks/ktexteditor"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=2cb91de5b56e1b6ebcfbbbb923aae8baa644a168e10e14222b31e21e17ecc4a1
+checksum=acb689e7d5fdaeb43dd2450cd51bca7153d3923df968be46e4aaf2871232f983
 
 ktexteditor-devel_package() {
 	short_desc+=" - development"

From ac935c08ced72bb670e54a2616bc090b18fb3c53 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:47:50 +0200
Subject: [PATCH 142/312] ktextwidgets: update to 5.75.0

[ci skip]
---
 srcpkgs/ktextwidgets/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/ktextwidgets/template b/srcpkgs/ktextwidgets/template
index 9b83bb564bc..d8562b9fc93 100644
--- a/srcpkgs/ktextwidgets/template
+++ b/srcpkgs/ktextwidgets/template
@@ -1,6 +1,6 @@
 # Template file for 'ktextwidgets'
 pkgname=ktextwidgets
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -12,7 +12,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.0-or-later, LGPL-2.1-or-later"
 homepage="https://invent.kde.org/frameworks/ktextwidgets"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=dcb8ba04284bca6436d83b6c3d8137f5ba1da881aa4feab9eb656de29a2ee742
+checksum=6b92145ceaa758b1d73a337078771899ad14b8ade26c5388cb04f752b982521a
 
 ktextwidgets-devel_package() {
 	short_desc+=" - development"

From 27284d50a22e94edf1771d4a0ed0ac896f1df06c Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:47:52 +0200
Subject: [PATCH 143/312] kunitconversion: update to 5.75.0

[ci skip]
---
 srcpkgs/kunitconversion/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kunitconversion/template b/srcpkgs/kunitconversion/template
index f91dfdedc38..0941a896ccb 100644
--- a/srcpkgs/kunitconversion/template
+++ b/srcpkgs/kunitconversion/template
@@ -1,6 +1,6 @@
 # Template file for 'kunitconversion'
 pkgname=kunitconversion
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 hostmakedepends="kcoreaddons extra-cmake-modules qt5-host-tools ki18n-devel
@@ -11,7 +11,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later"
 homepage="https://invent.kde.org/frameworks/kunitconversion"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=55a6cc919bea7e09582709c11bcce33c51bd714f1846c941ccbf240a15cad959
+checksum=bb0587276d081163cb86328370c77d9ebc109fc3b633f46af299656de900a36a
 
 kunitconversion-devel_package() {
 	short_desc+=" - development"

From 0cc3654cde7d51cc4a9bb30ce89c9dcebb5c9d5a Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:47:54 +0200
Subject: [PATCH 144/312] kwallet: update to 5.75.0

[ci skip]
---
 srcpkgs/kwallet/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kwallet/template b/srcpkgs/kwallet/template
index 61819935136..e9b03e0e4d4 100644
--- a/srcpkgs/kwallet/template
+++ b/srcpkgs/kwallet/template
@@ -1,6 +1,6 @@
 # Template file for 'kwallet'
 pkgname=kwallet
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -13,7 +13,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later"
 homepage="https://invent.kde.org/frameworks/kwallet"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=7abcf5230c7112628d4b1ac37648ab2d7fb147e4fda61e7aa0fd0da1d59cb0a1
+checksum=87b28d5b0c93f6085d6ccabc78b3e21590889767432ef22316f3e87322df1363
 
 kwallet-devel_package() {
 	short_desc+=" - development"

From 5f0455b492fe67941a001fea052cce5775b93471 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:47:56 +0200
Subject: [PATCH 145/312] kwayland: update to 5.75.0

[ci skip]
---
 srcpkgs/kwayland/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kwayland/template b/srcpkgs/kwayland/template
index 57a91c0a8f9..77d8cfdab35 100644
--- a/srcpkgs/kwayland/template
+++ b/srcpkgs/kwayland/template
@@ -1,6 +1,6 @@
 # Template file for 'kwayland'
 pkgname=kwayland
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -12,7 +12,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later"
 homepage="https://invent.kde.org/frameworks/kwayland"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=27c04e1a77df7af476fdcfcbc175c9078fc636a6ab10fa9cc41c6029400631fb
+checksum=4476113932b26484698b09a4653c8ffc9772122f4ada42b0cb327527f8f2d9c0
 
 kwayland-devel_package() {
 	short_desc+=" - development"

From 6ed70d781c0c6b2001f648f189bbf6d9b208dc28 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:47:59 +0200
Subject: [PATCH 146/312] kwidgetsaddons: update to 5.75.0

[ci skip]
---
 srcpkgs/kwidgetsaddons/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kwidgetsaddons/template b/srcpkgs/kwidgetsaddons/template
index d70328b4cb0..e2edc7bc512 100644
--- a/srcpkgs/kwidgetsaddons/template
+++ b/srcpkgs/kwidgetsaddons/template
@@ -1,6 +1,6 @@
 # Template file for 'kwidgetsaddons'
 pkgname=kwidgetsaddons
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -11,7 +11,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.0-or-later, LGPL-2.1-or-later"
 homepage="https://invent.kde.org/frameworks/kwidgetsaddons"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=5b61c13a6ebb1e248fe38bd3912919f4bf6be93d74bb2f8b1d97caf6dd9a2342
+checksum=9e46a967e7f98f570ab97d231e648770b0c6056a34d8efe0b3201a14f0e17bc0
 
 kwidgetsaddons-devel_package() {
 	short_desc+=" - development"

From 005725fd366ae53b3f6f713b1055155297c31fda Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:48:01 +0200
Subject: [PATCH 147/312] kwindowsystem: update to 5.75.0

[ci skip]
---
 srcpkgs/kwindowsystem/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kwindowsystem/template b/srcpkgs/kwindowsystem/template
index 6689faaf8c4..144912f594f 100644
--- a/srcpkgs/kwindowsystem/template
+++ b/srcpkgs/kwindowsystem/template
@@ -1,6 +1,6 @@
 # Template file for 'kwindowsystem'
 pkgname=kwindowsystem
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -11,7 +11,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later"
 homepage="https://invent.kde.org/frameworks/kwindowsystem"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=33da54b0f76a661919445c9352c04cc23f9b6a0f4c842a76aa810091ca09b12f
+checksum=4c180ec41aad90ed83e97db72216913e650b2719946803eec0d6e4cee7aab743
 
 kwindowsystem-devel_package() {
 	short_desc+=" - development"

From 98c7aafe7589199fa8a2acd31765a276f529298f Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:48:03 +0200
Subject: [PATCH 148/312] kxmlgui: update to 5.75.0

[ci skip]
---
 srcpkgs/kxmlgui/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kxmlgui/template b/srcpkgs/kxmlgui/template
index 3e9afb72362..2986278f9c6 100644
--- a/srcpkgs/kxmlgui/template
+++ b/srcpkgs/kxmlgui/template
@@ -1,6 +1,6 @@
 # Template file for 'kxmlgui'
 pkgname=kxmlgui
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -12,7 +12,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.0-or-later, LGPL-2.1-or-later"
 homepage="https://invent.kde.org/frameworks/kxmlgui"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=c5601a811c5d680b370ccf0388de71a49af090718b5f25716c38ce9689c783a1
+checksum=8d5a45cf5ddeb650f76f16872e2b6c7a8d808757fc23d3000e11803bf83f7c91
 
 kxmlgui-devel_package() {
 	short_desc+=" - development"

From 108df050b82178fc0675b3f3876c4767b13ec1c6 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:48:05 +0200
Subject: [PATCH 149/312] kxmlrpcclient: update to 5.75.0

[ci skip]
---
 srcpkgs/kxmlrpcclient/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kxmlrpcclient/template b/srcpkgs/kxmlrpcclient/template
index b93ed186f0d..248b30c726e 100644
--- a/srcpkgs/kxmlrpcclient/template
+++ b/srcpkgs/kxmlrpcclient/template
@@ -1,6 +1,6 @@
 # Template file for 'kxmlrpcclient'
 pkgname=kxmlrpcclient
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -12,7 +12,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later, BSD-2-Clause"
 homepage="https://invent.kde.org/frameworks/kxmlrpcclient"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/portingAids/${pkgname}-${version}.tar.xz"
-checksum=df71bc7082721c83fcccdc4bc221eb456bcff01cc50b29494ed3054e268363c9
+checksum=8292beafee7a1ea2ad81d1e7603c35a0fe69e585d0d5cbe6c546d4a97741dc8b
 
 post_install() {
 	vlicense LICENSES/BSD-2-Clause.txt

From a7b734812eff1d96612f53a83ef8d612f21cb64f Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:48:08 +0200
Subject: [PATCH 150/312] modemmanager-qt5: update to 5.75.0

[ci skip]
---
 srcpkgs/modemmanager-qt5/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/modemmanager-qt5/template b/srcpkgs/modemmanager-qt5/template
index 348af7d49fb..5993eefef1c 100644
--- a/srcpkgs/modemmanager-qt5/template
+++ b/srcpkgs/modemmanager-qt5/template
@@ -1,6 +1,6 @@
 # Template file for 'modemmanager-qt5'
 pkgname=modemmanager-qt5
-version=5.74.0
+version=5.75.0
 revision=1
 wrksrc="${pkgname%5}-${version}"
 build_style=cmake
@@ -12,7 +12,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later"
 homepage="https://invent.kde.org/frameworks/modemmanager-qt"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname%5}-${version}.tar.xz"
-checksum=4f7e93ed667aef5b4189efd25a05cba8c59682298534438e14dcac995b8e466d
+checksum=9e1ab6e61421ab5fb227f0c04593b27e067f1855a111a0192514d99e442bce80
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" qt5-host-tools qt5-qmake"

From 86bb1c3734c57bc8ff77796034ff21d91fddd6f3 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:48:10 +0200
Subject: [PATCH 151/312] networkmanager-qt5: update to 5.75.0

[ci skip]
---
 srcpkgs/networkmanager-qt5/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/networkmanager-qt5/template b/srcpkgs/networkmanager-qt5/template
index 96b01400601..d5d83001225 100644
--- a/srcpkgs/networkmanager-qt5/template
+++ b/srcpkgs/networkmanager-qt5/template
@@ -1,6 +1,6 @@
 # Template file for 'networkmanager-qt5'
 pkgname=networkmanager-qt5
-version=5.74.0
+version=5.75.0
 revision=1
 wrksrc="${pkgname%5}-${version}"
 build_style=cmake
@@ -13,7 +13,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later"
 homepage="https://invent.kde.org/frameworks/networkmanager-qt"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname%5}-${version}.tar.xz"
-checksum=2da8d87b188b6b4870d7128eca2562f442c32dce7928ac237e2deacb046cd154
+checksum=ba9d15eb5e0e624ffaac591cdaad43dc62e60ccfa25b98be686b58800b41018b
 
 networkmanager-qt5-devel_package() {
 	short_desc+=" - development"

From da542c7b382098971009c6f71a0d726e940fe49a Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:48:57 +0200
Subject: [PATCH 152/312] oxygen-icons5: update to 5.75.0

[ci skip]
---
 srcpkgs/oxygen-icons5/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/oxygen-icons5/template b/srcpkgs/oxygen-icons5/template
index 175c8763caf..f02d4401b69 100644
--- a/srcpkgs/oxygen-icons5/template
+++ b/srcpkgs/oxygen-icons5/template
@@ -1,7 +1,7 @@
 # Template file for 'oxygen-icons5'
 pkgname=oxygen-icons5
-version=5.74.0
-revision=2
+version=5.75.0
+revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
 hostmakedepends="kcoreaddons extra-cmake-modules qt5-qmake qt5-host-tools"
@@ -11,7 +11,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later, LGPL-3.0-or-later"
 homepage="https://invent.kde.org/frameworks/oxygen-icons5"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=a6627b15fc386c31ae97ceb27ab85acaf06e5daccd7cf8740a8d5acf3debb073
+checksum=c50d58e7f67ef3011bf169a38a6d4fe11b5bdc383a5adcdbb46c6fdc1605e503
 conflicts="oxygen-icons>=0"
 
 oxygen-icons_package() {

From fb5752de8a33cc9def0ae7d0d3d586187cb6e94a Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:49:00 +0200
Subject: [PATCH 153/312] plasma-framework: update to 5.75.0

[ci skip]
---
 srcpkgs/plasma-framework/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/plasma-framework/template b/srcpkgs/plasma-framework/template
index f32b3023560..3527d01433d 100644
--- a/srcpkgs/plasma-framework/template
+++ b/srcpkgs/plasma-framework/template
@@ -1,6 +1,6 @@
 # Template file for 'plasma-framework'
 pkgname=plasma-framework
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF
@@ -15,7 +15,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later"
 homepage="https://invent.kde.org/frameworks/plasma-framework"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=8342cfff3c632ebff8d6869ec88e9e9f6737e7ce6b251c12bf3f9421dd198bf1
+checksum=a6a68cdfeaeded999ebe7207c524f8a4a6fd13562a6d95b9f6137730ada0697a
 
 plasma-framework-devel_package() {
 	short_desc+=" - development"

From 067d4c2f2fe4edb4a372067af8943fa74bac58ef Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:49:02 +0200
Subject: [PATCH 154/312] prison: update to 5.75.0

[ci skip]
---
 srcpkgs/prison/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/prison/template b/srcpkgs/prison/template
index 476a56a7084..dcbd3f4c873 100644
--- a/srcpkgs/prison/template
+++ b/srcpkgs/prison/template
@@ -1,7 +1,7 @@
 # Template file for 'prison'
 pkgname=prison
-version=5.74.0
-revision=2
+version=5.75.0
+revision=1
 build_style=cmake
 hostmakedepends="kcoreaddons extra-cmake-modules qt5-tools doxygen qt5-declarative-devel"
 makedepends="qt5-devel libdmtx-devel qrencode-devel ecm-devel qt5-plugin-sqlite
@@ -11,7 +11,7 @@ maintainer="John <me@johnnynator.dev>"
 license="MIT"
 homepage="https://community.kde.org/Frameworks"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/prison-${version}.tar.xz"
-checksum=8cf56653c591ec2110fb39c91dd3cff60a68ca2b60e32d7c9fae14944636da51
+checksum=7e1ee466b0eed9b861f9b746dc5579f1e82d5e165696116c5c657dd35038ade0
 
 if [ "$CROSS_BUILD" ];then
 	hostmakedepends+=" qt5-qmake qt5-host-tools"

From 2ea01e6ca63fb54fef3f9d8290bef08a9ea7a0ac Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:49:04 +0200
Subject: [PATCH 155/312] purpose: update to 5.75.0

[ci skip]
---
 srcpkgs/purpose/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/purpose/template b/srcpkgs/purpose/template
index 0bcfd5a7307..973fc6cf0c3 100644
--- a/srcpkgs/purpose/template
+++ b/srcpkgs/purpose/template
@@ -1,6 +1,6 @@
 # Template file for 'purpose'
 pkgname=purpose
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 hostmakedepends="kcoreaddons qt5-qmake qt5-host-tools extra-cmake-modules
@@ -12,7 +12,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later"
 homepage="https://invent.kde.org/frameworks/purpose"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=1f65696558e82808b2beb3715da2e833a6e1f214f33bcc670ef0f023bb044205
+checksum=7c9ccf7d2813a9253a217d7a2da1f0ba39dd0eec0bb071633fe58dcd2ccb0ffb
 
 do_check() {
 	export QT_QPA_PLATFORM=offscreen

From 52a7861dca682aa1020e4b9a0055437905a4166d Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:49:06 +0200
Subject: [PATCH 156/312] qqc2-desktop-style: update to 5.75.0

[ci skip]
---
 srcpkgs/qqc2-desktop-style/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/qqc2-desktop-style/template b/srcpkgs/qqc2-desktop-style/template
index 99a852ff872..2d54a1294fe 100644
--- a/srcpkgs/qqc2-desktop-style/template
+++ b/srcpkgs/qqc2-desktop-style/template
@@ -1,6 +1,6 @@
 # Template file for 'qqc2-desktop-style'
 pkgname=qqc2-desktop-style
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 hostmakedepends="kcoreaddons qt5-qmake qt5-host-tools extra-cmake-modules"
@@ -10,7 +10,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.0-or-later, LGPL-3.0-only, GPL-2.0-or-later"
 homepage="https://invent.kde.org/frameworks/qqc2-desktop-style"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=1605a9904ae59ed2acb3439bedfa1acb51dcb02d59f1e4b37d9c64ee45b7be83
+checksum=770895c4363973ddcbac281526de8297a4df37bfe1df08be59e62a8caf9368d3
 
 qqc2-desktop-style-devel_package() {
 	depends="${sourcepkg}>=${version}_${revision}"

From b164885a409851cc916860932d18dda64128754d Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:49:08 +0200
Subject: [PATCH 157/312] sonnet: update to 5.75.0

[ci skip]
---
 srcpkgs/sonnet/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/sonnet/template b/srcpkgs/sonnet/template
index 5c100537ea3..a3d88fe3f9b 100644
--- a/srcpkgs/sonnet/template
+++ b/srcpkgs/sonnet/template
@@ -1,6 +1,6 @@
 # Template file for 'sonnet'
 pkgname=sonnet
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -11,7 +11,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later"
 homepage="https://invent.kde.org/frameworks/sonnet"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=ec72860cac92a9611b15f1055592434cf2bb44fe428abb474f4f227b4f9f94d6
+checksum=626055b262b3a43e6e947cf7f0383565324f42d6b24ab07b98c6cf054271c9e0
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" qt5-host-tools qt5-tools-devel sonnet"

From 57581e600c6d0e2ac3925e0362c574b8f114a70c Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:49:10 +0200
Subject: [PATCH 158/312] syndication: update to 5.75.0

[ci skip]
---
 srcpkgs/syndication/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/syndication/template b/srcpkgs/syndication/template
index d97d1dc6988..9280861e747 100644
--- a/srcpkgs/syndication/template
+++ b/srcpkgs/syndication/template
@@ -1,7 +1,7 @@
 # Template file for 'syndication'
 pkgname=syndication
 reverts="18.08.0_1 18.08.0_2 18.08.1_1"
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 hostmakedepends="kcoreaddons extra-cmake-modules qt5-qmake qt5-host-tools"
@@ -11,7 +11,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later"
 homepage="https://community.kde.org/KDE_PIM"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/syndication-${version}.tar.xz"
-checksum=b4049d28a956fb4783f44262a01dec66067b3f7eb45040eef2939f7b06941ca8
+checksum=922a938c6a96287075eae1f5fd18d343e9fdbbb5213d1f5f9b0c454986b6008c
 
 syndication-devel_package() {
 	short_desc+=" - development"

From dbea0af167cf57c26ff9265abe6ba368311946d3 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:49:12 +0200
Subject: [PATCH 159/312] syntax-highlighting: update to 5.75.0

[ci skip]
---
 srcpkgs/syntax-highlighting/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/syntax-highlighting/template b/srcpkgs/syntax-highlighting/template
index faab193d95c..4b31b9cad8d 100644
--- a/srcpkgs/syntax-highlighting/template
+++ b/srcpkgs/syntax-highlighting/template
@@ -1,6 +1,6 @@
 # Template file for 'syntax-highlighting'
 pkgname=syntax-highlighting
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -11,7 +11,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later"
 homepage="https://invent.kde.org/frameworks/syntax-highlighting"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=a29fad2b869df141d0e68c4b61769c20759dc1b31be7a8570e2b717a18a08e9b
+checksum=c5db1b9a268fa81a1cf72e83c1b3147e4cf4e043da45d917df0165f42ca0d07f
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" qt5-host-tools qt5-qmake qt5-tools syntax-highlighting qt5-devel qt5-tools-devel"

From 83316b52c0048d147fed24f348858d08d52dae28 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Sat, 10 Oct 2020 15:49:14 +0200
Subject: [PATCH 160/312] threadweaver: update to 5.75.0

[ci skip]
---
 srcpkgs/threadweaver/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/threadweaver/template b/srcpkgs/threadweaver/template
index df85de22cdb..d9a3c8dbd64 100644
--- a/srcpkgs/threadweaver/template
+++ b/srcpkgs/threadweaver/template
@@ -1,6 +1,6 @@
 # Template file for 'threadweaver'
 pkgname=threadweaver
-version=5.74.0
+version=5.75.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -11,7 +11,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later"
 homepage="https://invent.kde.org/frameworks/threadweaver"
 distfiles="${KDE_SITE}/frameworks/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=32ecaf58bf1d2ab2e7f92d98f592b2169d6e2e320d632d225ceaeccc5fb17d62
+checksum=d082f863fb119e2b98c9e01877b2730eedc0b54392449e3cc9bd54d7803d16ff
 
 threadweaver-devel_package() {
 	short_desc+=" - development"

From e0706c4c1adeefab08727ff5804cbb53712805de Mon Sep 17 00:00:00 2001
From: Paper <paper@tilde.institute>
Date: Sat, 5 Sep 2020 16:03:58 +0200
Subject: [PATCH 161/312] sdcv: update to 0.5.3

---
 srcpkgs/sdcv/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/sdcv/template b/srcpkgs/sdcv/template
index 8e792ca1300..982fc2911b2 100644
--- a/srcpkgs/sdcv/template
+++ b/srcpkgs/sdcv/template
@@ -1,7 +1,7 @@
 # Template file for 'sdcv'
 pkgname=sdcv
-version=0.5.2
-revision=3
+version=0.5.3
+revision=1
 build_style=cmake
 hostmakedepends="pkg-config glib-devel"
 makedepends="zlib-devel readline-devel glib-devel"
@@ -10,7 +10,7 @@ maintainer="Casper Ti. Vector <caspervector@gmail.com>"
 license="GPL-2.0-only"
 homepage="https://dushistov.github.io/sdcv/"
 distfiles="https://github.com/Dushistov/sdcv/archive/v$version.tar.gz"
-checksum=ec08dc084a0748d5a89df01a20bbf294f09b0366295cd418000f15d2e043c4f7
+checksum=75fb95b1607fdd2fb9f7795d3432d295904614150575ae539202f680499803c9
 
 post_extract() {
 	rm po/*.po

From 0ff3b68d9e53b1c6a14cef36398014ba8eacbfaf Mon Sep 17 00:00:00 2001
From: Paper <paper@tilde.institute>
Date: Wed, 14 Oct 2020 10:48:50 +0200
Subject: [PATCH 162/312] python3-mypy: update to 0.790

---
 srcpkgs/python3-mypy/template | 7 +++----
 1 file changed, 3 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-mypy/template b/srcpkgs/python3-mypy/template
index 6fef0e9f8c0..86611f04690 100644
--- a/srcpkgs/python3-mypy/template
+++ b/srcpkgs/python3-mypy/template
@@ -1,10 +1,9 @@
 # Template file for 'python3-mypy'
 pkgname=python3-mypy
-version=0.761
-revision=2
+version=0.790
+revision=1
 wrksrc="mypy-${version}"
 build_style=python3-module
-pycompile_module="mypy"
 hostmakedepends="python3-setuptools"
 depends="python3-mypy_extensions python3-typed-ast python3-typing_extensions"
 short_desc="Optional static typing for Python3"
@@ -12,7 +11,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://github.com/python/mypy"
 distfiles="${PYPI_SITE}/m/mypy/mypy-${version}.tar.gz"
-checksum=85baab8d74ec601e86134afe2bcccd87820f79d2f8d5798c889507d1088287bf
+checksum=2b21ba45ad9ef2e2eb88ce4aeadd0112d0f5026418324176fd494a6824b74975
 
 post_install() {
 	vlicense LICENSE

From a60c32151756dbfa716c8e7a906ee31c5e68318b Mon Sep 17 00:00:00 2001
From: Paper <paper@tilde.institute>
Date: Tue, 13 Oct 2020 11:04:36 +0200
Subject: [PATCH 163/312] gemget: update to 1.6.0

---
 srcpkgs/gemget/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/gemget/template b/srcpkgs/gemget/template
index bf92722422e..985c497b821 100644
--- a/srcpkgs/gemget/template
+++ b/srcpkgs/gemget/template
@@ -1,6 +1,6 @@
 # Template file for 'gemget'
 pkgname=gemget
-version=1.5.0
+version=1.6.0
 revision=1
 build_style=go
 go_import_path="github.com/makeworld-the-better-one/gemget"
@@ -9,7 +9,7 @@ maintainer="Paper <paper@tilde.institute>"
 license="MIT"
 homepage="https://github.com/makeworld-the-better-one/gemget/"
 distfiles="https://github.com/makeworld-the-better-one/gemget/archive/v$version.tar.gz"
-checksum=71338371553a71a0a48afeec45b6f372a4fad4737cc76e9f47e8aae989225c0d
+checksum=2a435af153272c53e82508a1e294142c15259224e94294d15f09c8a0c6f10f7b
 
 post_install() {
 	vlicense LICENSE

From 2896111c6715d72408b071d1c2c1e9bf91fde5b8 Mon Sep 17 00:00:00 2001
From: lemmi <lemmi@nerd2nerd.org>
Date: Wed, 14 Oct 2020 23:58:49 +0200
Subject: [PATCH 164/312] obs: update to 26.0.2.

---
 srcpkgs/obs/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/obs/template b/srcpkgs/obs/template
index ebfea9ae44d..b7777f103fe 100644
--- a/srcpkgs/obs/template
+++ b/srcpkgs/obs/template
@@ -1,7 +1,7 @@
 # Template file for 'obs'
 pkgname=obs
-version=26.0.0
-revision=2
+version=26.0.2
+revision=1
 archs="i686* x86_64* ppc64le*"
 wrksrc="obs-studio-${version}"
 build_style=cmake
@@ -17,7 +17,7 @@ license="GPL-2.0-or-later"
 homepage="https://obsproject.com"
 changelog="https://github.com/obsproject/obs-studio/releases"
 distfiles="https://github.com/obsproject/obs-studio/archive/${version}.tar.gz"
-checksum=7495f081b4f6adf42742687c1bb7938fcb337a3de23cd2740378e98392925b74
+checksum=06eef30156d21f179f590599ab866b7745209045825a3bf8461a85b60d880ed5
 
 CFLAGS="-fcommon"
 

From 898ed013ef0a7a285297d5281f8e9428b2ff3583 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Mon, 12 Oct 2020 11:32:24 -0400
Subject: [PATCH 165/312] New package: python3-sgmllib-1.0.0.

Needed for python3-feedparser >= 6.0
---
 srcpkgs/python3-sgmllib/template | 14 ++++++++++++++
 1 file changed, 14 insertions(+)
 create mode 100644 srcpkgs/python3-sgmllib/template

diff --git a/srcpkgs/python3-sgmllib/template b/srcpkgs/python3-sgmllib/template
new file mode 100644
index 00000000000..fca40a2fb97
--- /dev/null
+++ b/srcpkgs/python3-sgmllib/template
@@ -0,0 +1,14 @@
+# Template file for 'python3-sgmllib'
+pkgname=python3-sgmllib
+version=1.0.0
+revision=1
+wrksrc="sgmllib3k-${version}"
+build_style=python3-module
+hostmakedepends="python3-setuptools"
+depends="python3"
+short_desc="Port of sgmllib for Python3"
+maintainer="Peter Bui <pbui@github.bx612.space>"
+license="PSF-2.0"
+homepage="https://pypi.org/project/sgmllib3k/"
+distfiles="${PYPI_SITE}/s/sgmllib3k/sgmllib3k-${version}.tar.gz"
+checksum=7868fb1c8bfa764c1ac563d3cf369c381d1325d36124933a726f29fcdaa812e9

From 0d6d26bca8082dd27436843a8a391f1aa0cbd14b Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Mon, 12 Oct 2020 11:34:16 -0400
Subject: [PATCH 166/312] python3-feedparser: update to 6.0.1.

- Split off from python-feedparser.  Python2 version is now deprecated
  and unsupported by upstream:

    https://github.com/kurtmckee/feedparser/issues/228

  Since no other packages in void-packages now depend on
  python-feedparser, drop Python2 version.

- python3-feedparser now requires separate python3-sgmllib (which was
  provided in Python2 and bundled in Python3 module previously).
---
 srcpkgs/python-feedparser/template  | 28 ----------------------------
 srcpkgs/python3-feedparser          |  1 -
 srcpkgs/python3-feedparser/template | 18 ++++++++++++++++++
 3 files changed, 18 insertions(+), 29 deletions(-)
 delete mode 100644 srcpkgs/python-feedparser/template
 delete mode 120000 srcpkgs/python3-feedparser
 create mode 100644 srcpkgs/python3-feedparser/template

diff --git a/srcpkgs/python-feedparser/template b/srcpkgs/python-feedparser/template
deleted file mode 100644
index 993e350e560..00000000000
--- a/srcpkgs/python-feedparser/template
+++ /dev/null
@@ -1,28 +0,0 @@
-# Template file for 'python-feedparser'
-pkgname=python-feedparser
-version=5.2.1
-revision=8
-wrksrc="feedparser-${version}"
-build_style=python-module
-pycompile_module="feedparser.py"
-hostmakedepends="python-setuptools python3-setuptools"
-depends="python"
-maintainer="Orphaned <orphan@voidlinux.org>"
-license="BSD-2-Clause"
-homepage="https://pypi.org/project/feedparser/"
-short_desc="Parse Atom and RSS feeds in Python2"
-distfiles="${PYPI_SITE}/f/feedparser/feedparser-${version}.tar.bz2"
-checksum=ce875495c90ebd74b179855449040003a1beb40cd13d5f037a0654251e260b02
-
-post_install() {
-	vlicense LICENSE
-}
-
-python3-feedparser_package() {
-	depends="python3"
-	pycompile_module="feedparser.py"
-	short_desc="${short_desc/Python2/Python3}"
-	pkg_install() {
-		vmove usr/lib/python3*
-	}
-}
diff --git a/srcpkgs/python3-feedparser b/srcpkgs/python3-feedparser
deleted file mode 120000
index 1e305c4f3d7..00000000000
--- a/srcpkgs/python3-feedparser
+++ /dev/null
@@ -1 +0,0 @@
-python-feedparser
\ No newline at end of file
diff --git a/srcpkgs/python3-feedparser/template b/srcpkgs/python3-feedparser/template
new file mode 100644
index 00000000000..949f350665e
--- /dev/null
+++ b/srcpkgs/python3-feedparser/template
@@ -0,0 +1,18 @@
+# Template file for 'python3-feedparser'
+pkgname=python3-feedparser
+version=6.0.1
+revision=1
+wrksrc="feedparser-${version}"
+build_style=python3-module
+hostmakedepends="python3-setuptools"
+depends="python3-sgmllib"
+short_desc="Parse Atom and RSS feeds in Python3"
+maintainer="Peter Bui <pbui@github.bx612.space>"
+license="BSD-2-Clause"
+homepage="https://pypi.org/project/feedparser/"
+distfiles="${PYPI_SITE}/f/feedparser/feedparser-${version}.tar.gz"
+checksum=6ca88edcaa43f428345968df903a87f020843eda5e28d7ea24a612158d61e74c
+
+post_install() {
+	vlicense LICENSE
+}

From e9f67c338b4740f18a3d3d3147d5ff8f5af32fb7 Mon Sep 17 00:00:00 2001
From: Evgeny Ermakov <evgeny.v.ermakov@gmail.com>
Date: Sun, 11 Oct 2020 22:14:31 +1100
Subject: [PATCH 167/312] zeromq: update to 4.3.3

Closes: #25521 [via git-merge-pr]
---
 srcpkgs/zeromq/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/zeromq/template b/srcpkgs/zeromq/template
index 25c4d6f7351..86e03e9cab5 100644
--- a/srcpkgs/zeromq/template
+++ b/srcpkgs/zeromq/template
@@ -1,6 +1,6 @@
 # Template file for 'zeromq'
 pkgname=zeromq
-version=4.3.2
+version=4.3.3
 revision=1
 build_style=gnu-configure
 configure_args="--with-libsodium"
@@ -11,7 +11,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="LGPL-3.0-or-later"
 homepage="http://www.zeromq.org"
 distfiles="https://github.com/zeromq/libzmq/releases/download/v${version}/zeromq-${version}.tar.gz"
-checksum=ebd7b5c830d6428956b67a0454a7f8cbed1de74b3b01e5c33c5378e22740f763
+checksum=9d9285db37ae942ed0780c016da87060497877af45094ff9e1a1ca736e3875a2
 
 zeromq-devel_package() {
 	depends="${sourcepkg}-${version}_${revision}"

From b7f1418abddd9e26492d804e4dfc151362e60b67 Mon Sep 17 00:00:00 2001
From: fosslinux <fosslinux@aussies.space>
Date: Mon, 12 Oct 2020 21:03:37 +1100
Subject: [PATCH 168/312] nodejs: update to 14.13.1.

patch is needed for configure script to support python3.9, taken from
master, droppable in next release.

Closes: #25539 [via git-merge-pr]
---
 srcpkgs/nodejs/patches/python3.9.patch | 35 ++++++++++++++++++++++++++
 srcpkgs/nodejs/template                |  6 ++---
 2 files changed, 38 insertions(+), 3 deletions(-)
 create mode 100644 srcpkgs/nodejs/patches/python3.9.patch

diff --git a/srcpkgs/nodejs/patches/python3.9.patch b/srcpkgs/nodejs/patches/python3.9.patch
new file mode 100644
index 00000000000..c6902083209
--- /dev/null
+++ b/srcpkgs/nodejs/patches/python3.9.patch
@@ -0,0 +1,35 @@
+From c8b950a7afcc3e7c222bb94fabccc7e2fb447457 Mon Sep 17 00:00:00 2001
+From: cclauss <cclauss@me.com>
+Date: Tue, 6 Oct 2020 17:51:24 +0200
+Subject: [PATCH] build: gitHub actions: Python 3.9 and actions/setup-python@v2
+
+PR-URL: https://github.com/nodejs/node/pull/35521
+Reviewed-By: Richard Lau <rlau@redhat.com>
+Reviewed-By: Shelley Vohr <codebytere@gmail.com>
+Reviewed-By: Rich Trott <rtrott@gmail.com>
+Reviewed-By: Jiawen Geng <technicalcute@gmail.com>
+Reviewed-By: Myles Borins <myles.borins@gmail.com>
+
+Modified by fosslinux to remove .github stuff.
+
+diff --git configure configure
+index 7e8c4cff832..07581d9c5a4 100755
+--- configure
++++ configure
+@@ -5,6 +5,7 @@
+ # as is the fact that the ] goes on a new line.
+ _=[ 'exec' '/bin/sh' '-c' '''
+ test ${FORCE_PYTHON2} && exec python2 "$0" "$@"  # workaround for gclient
++command -v python3.9 >/dev/null && exec python3.9 "$0" "$@"
+ command -v python3.8 >/dev/null && exec python3.8 "$0" "$@"
+ command -v python3.7 >/dev/null && exec python3.7 "$0" "$@"
+ command -v python3.6 >/dev/null && exec python3.6 "$0" "$@"
+@@ -19,7 +20,7 @@ import sys
+ from distutils.spawn import find_executable
+ 
+ print('Node.js configure: Found Python {0}.{1}.{2}...'.format(*sys.version_info))
+-acceptable_pythons = ((3, 8), (3, 7), (3, 6), (3, 5), (2, 7))
++acceptable_pythons = ((3, 9), (3, 8), (3, 7), (3, 6), (3, 5), (2, 7))
+ if sys.version_info[:2] in acceptable_pythons:
+   import configure
+ else:
diff --git a/srcpkgs/nodejs/template b/srcpkgs/nodejs/template
index 98a9a248811..91f2889fd52 100644
--- a/srcpkgs/nodejs/template
+++ b/srcpkgs/nodejs/template
@@ -1,6 +1,6 @@
 # Template file for 'nodejs'
 pkgname=nodejs
-version=14.13.0
+version=14.13.1
 revision=1
 wrksrc="node-v${version}"
 # Need these for host v8 for torque, see https://github.com/nodejs/node/pull/21079
@@ -8,7 +8,7 @@ hostmakedepends="which pkg-config python3 zlib-devel $(vopt_if icu icu-devel)
  $(vopt_if ssl libressl-devel) $(vopt_if libuv libuv-devel)
  $(vopt_if http_parser http-parser-devel) $(vopt_if nghttp2 nghttp2-devel)
  $(vopt_if cares c-ares-devel) $(vopt_if http_parser llhttp-devel)"
-makedepends="zlib-devel python3-devel $(vopt_if icu icu-devel)
+makedepends="zlib-devel $(vopt_if icu icu-devel)
  $(vopt_if ssl libressl-devel) $(vopt_if libuv libuv-devel)
  $(vopt_if http_parser http-parser-devel) $(vopt_if nghttp2 nghttp2-devel)
  $(vopt_if cares c-ares-devel) $(vopt_if http_parser llhttp-devel)"
@@ -17,7 +17,7 @@ maintainer="Enno Boland <gottox@voidlinux.org>"
 license="MIT"
 homepage="https://nodejs.org/"
 distfiles="${homepage}/dist/v${version}/node-v${version}.tar.gz"
-checksum=8538b2e76aa06ee0e6eb1c118426c3c5ca53b2e49d66591738eacf76e89edd61
+checksum=f0080d3284ea1585e255a3f459ce151e8106a33f4ce8bed0da15ff99c6a082a5
 python_version=3
 
 build_options="ssl libuv http_parser icu nghttp2 cares"

From 60e941bdc08359b3785ca657414ea57667df4d2f Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Wed, 14 Oct 2020 20:55:25 -0400
Subject: [PATCH 169/312] New package: python3-setuptools_scm-4.1.2

---
 srcpkgs/python3-setuptools_scm/template | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)
 create mode 100644 srcpkgs/python3-setuptools_scm/template

diff --git a/srcpkgs/python3-setuptools_scm/template b/srcpkgs/python3-setuptools_scm/template
new file mode 100644
index 00000000000..c20dce402f4
--- /dev/null
+++ b/srcpkgs/python3-setuptools_scm/template
@@ -0,0 +1,18 @@
+# Template file for 'python3-setuptools_scm'
+pkgname=python3-setuptools_scm
+version=4.1.2
+revision=1
+wrksrc="${pkgname#python3-}-${version}"
+build_style=python3-module
+hostmakedepends="python3-setuptools"
+depends="python3-setuptools python3-wheel"
+short_desc="Manage Python package versions with SCM tags"
+maintainer="Andrew J. Hesford <ajh@sideband.org>"
+license="MIT"
+homepage="https://github.com/pypa/setuptools_scm"
+distfiles="${PYPI_SITE}/s/setuptools_scm/setuptools_scm-${version}.tar.gz"
+checksum=a8994582e716ec690f33fec70cca0f85bd23ec974e3f783233e4879090a7faa8
+
+post_install() {
+	vlicense LICENSE
+}

From b6e3b3bb36f6bc33dcb6f79de5c6bfabcf365a3e Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Wed, 14 Oct 2020 21:07:43 -0400
Subject: [PATCH 170/312] afew: add python3-setuptools_scm to hostmakedepends

---
 srcpkgs/afew/template | 9 ++-------
 1 file changed, 2 insertions(+), 7 deletions(-)

diff --git a/srcpkgs/afew/template b/srcpkgs/afew/template
index e89ee064a6c..a8ca1dac5b1 100644
--- a/srcpkgs/afew/template
+++ b/srcpkgs/afew/template
@@ -1,9 +1,9 @@
 # Template file for 'afew'
 pkgname=afew
 version=3.0.1
-revision=2
+revision=3
 build_style=python3-module
-hostmakedepends="python3-setuptools python3-Sphinx pkg-config"
+hostmakedepends="python3-setuptools_scm python3-Sphinx pkg-config"
 depends="notmuch-python3 python3-dkimpy python3-chardet notmuch"
 checkdepends="python3-pytest python3-freezegun $depends"
 short_desc="Initial tagging script for notmuch mail"
@@ -13,11 +13,6 @@ homepage="https://github.com/afewmail/afew"
 distfiles="${PYPI_SITE}/a/afew/afew-${version}.tar.gz"
 checksum=ce857fe1a3bc0982c1dac81aef66cacc148e4f9db06da720f869392af1c2ee72
 
-post_patch() {
-	# version is pre-generated
-	vsed -i -e "s/'setuptools_scm'//" setup.py
-}
-
 post_build() {
 	python3 setup.py build_sphinx -b man
 }

From 5389f8f17f2568349936c0d36ba48c8f7a59873a Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Wed, 14 Oct 2020 21:22:45 -0400
Subject: [PATCH 171/312] python3-Cheroot: update to 8.4.5.

---
 srcpkgs/python3-Cheroot/template | 24 +++++++++++-------------
 1 file changed, 11 insertions(+), 13 deletions(-)

diff --git a/srcpkgs/python3-Cheroot/template b/srcpkgs/python3-Cheroot/template
index 95fb8cd16fd..7dc5e26bf18 100644
--- a/srcpkgs/python3-Cheroot/template
+++ b/srcpkgs/python3-Cheroot/template
@@ -1,29 +1,27 @@
 # Template file for 'python3-Cheroot'
 pkgname=python3-Cheroot
-version=8.3.1
-revision=3
+version=8.4.5
+revision=1
 wrksrc="cheroot-${version}"
 build_style=python3-module
-hostmakedepends="python3-setuptools"
-depends="python3-setuptools python3-six python3-more-itertools
- python3-jaraco.functools"
+hostmakedepends="python3-setuptools_scm"
+depends="python3-setuptools python3-six
+ python3-more-itertools python3-jaraco.functools"
 short_desc="High-performance, pure-Python HTTP server (Python3)"
 maintainer="bra1nwave <bra1nwave@protonmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/cherrypy/cheroot"
 changelog="https://github.com/cherrypy/cheroot/blob/master/CHANGES.rst"
 distfiles="${PYPI_SITE}/c/cheroot/cheroot-${version}.tar.gz"
-checksum=7076d5845f64d729e4155ec2650ad24ee70209340d11b9e619a82e9210a579b8
-conflicts="python-Cheroot>=0"
+checksum=b6c18caf5f79cdae668c35fc8309fc88ea4a964cce9e2ca8504fab13bcf57301
+alternatives="cheroot:cheroot:/usr/bin/cheroot3"
 
-pre_build() {
-	vsed -i setup.cfg \
-		-e '/setuptools_scm/d' \
-		-e '/use_scm_version/d' \
-		-e "/name = /a\
-		version = ${version}"
+post_patch() {
+	# Don't need setuptools_scm_git_archive for the tarball
+	vsed -e '/setuptools_scm_git_archive/d' -i setup.cfg
 }
 
 post_install() {
+	mv "${DESTDIR}/usr/bin/cheroot" "${DESTDIR}/usr/bin/cheroot3"
 	vlicense LICENSE.md
 }

From bd3821da26f9d456bba0aef78b0ead714aefc9ea Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Wed, 14 Oct 2020 21:25:08 -0400
Subject: [PATCH 172/312] python3-CherryPy: add python3-setuptools_scm to
 hostmakedepends

---
 srcpkgs/python3-CherryPy/template | 14 ++++----------
 1 file changed, 4 insertions(+), 10 deletions(-)

diff --git a/srcpkgs/python3-CherryPy/template b/srcpkgs/python3-CherryPy/template
index c21123b9baf..90b48900c9d 100644
--- a/srcpkgs/python3-CherryPy/template
+++ b/srcpkgs/python3-CherryPy/template
@@ -1,12 +1,12 @@
 # Template file for 'python3-CherryPy'
 pkgname=python3-CherryPy
 version=18.6.0
-revision=2
+revision=3
 wrksrc="CherryPy-${version}"
 build_style=python3-module
-hostmakedepends="python3-setuptools"
-depends="python3-setuptools python3-Cheroot python3-portend python3-zc.lockfile
- python3-jaraco.collections"
+hostmakedepends="python3-setuptools_scm"
+depends="python3-setuptools python3-Cheroot python3-portend
+ python3-zc.lockfile python3-jaraco.collections"
 short_desc="Object-oriented HTTP framework (Python3)"
 maintainer="bra1nwave <bra1nwave@protonmail.com>"
 license="BSD-3-Clause"
@@ -16,12 +16,6 @@ distfiles="${PYPI_SITE}/C/CherryPy/CherryPy-${version}.tar.gz"
 checksum=56608edd831ad00991ae585625e0206ed61cf1a0850e4b2cc48489fb2308c499
 alternatives="cherrypy:cherryd:/usr/bin/cherryd3"
 
-pre_build() {
-	vsed -i setup.py \
-		-e '/setuptools_scm/d' \
-		-e "s|use_scm_version=True|version='${version}'|"
-}
-
 post_install() {
 	mv ${DESTDIR}/usr/bin/cherryd{,3}
 	vlicense LICENSE.md

From 42e244764dd3f5b55383f80287376fc421614a4d Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Wed, 14 Oct 2020 21:31:09 -0400
Subject: [PATCH 173/312] python3-ansible-lint: update distfiles, fix egg-info
 version

---
 srcpkgs/python3-ansible-lint/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/python3-ansible-lint/template b/srcpkgs/python3-ansible-lint/template
index dfb1a82418d..80fa8dbe130 100644
--- a/srcpkgs/python3-ansible-lint/template
+++ b/srcpkgs/python3-ansible-lint/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-ansible-lint'
 pkgname=python3-ansible-lint
 version=4.3.5
-revision=1
+revision=2
 wrksrc="ansible-lint-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,12 +11,12 @@ maintainer="Joseph LaFreniere <joseph@lafreniere.xyz>"
 license="MIT"
 homepage="https://github.com/willthames/ansible-lint"
 changelog="https://raw.githubusercontent.com/willthames/ansible-lint/master/CHANGELOG.md"
-distfiles="${homepage}/archive/v${version}.tar.gz"
-checksum=df5ffb79cbd76ab02bf6dd4b493502d6ba59fafb669d6f57f487251a6c955adc
+distfiles="${PYPI_SITE}/a/ansible-lint/ansible-lint-${version}.tar.gz"
+checksum=bec230cf5fcc4d976246d4170da3ae289715f99185529ca8bba4b3c173035656
 
 post_patch() {
-	vsed -i pyproject.toml -e '/setuptools_scm/d'
-	vsed -i setup.cfg -e '/setup_requires =/,/setuptools_scm_git_archive/d'
+	# scm versioning is broken in this release
+	vsed -e "/name =/a version = ${version}" -e "/setuptools_scm/d" -i setup.cfg
 }
 
 post_install() {

From 6d33ec2952a85773170d71a9aa9aad4fa323af72 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Wed, 14 Oct 2020 21:33:31 -0400
Subject: [PATCH 174/312] python3-portend: update to 2.6.

---
 srcpkgs/python3-portend/template | 15 +++++----------
 1 file changed, 5 insertions(+), 10 deletions(-)

diff --git a/srcpkgs/python3-portend/template b/srcpkgs/python3-portend/template
index 6cf1d03eda6..42bf48ae2ec 100644
--- a/srcpkgs/python3-portend/template
+++ b/srcpkgs/python3-portend/template
@@ -1,24 +1,19 @@
 # Template file for 'python3-portend'
 pkgname=python3-portend
-version=2.5
-revision=4
+version=2.6
+revision=1
 wrksrc="portend-${version}"
 build_style=python3-module
-hostmakedepends="python3-setuptools"
+hostmakedepends="python3-setuptools_scm"
 depends="python3-tempora"
 short_desc="TCP port monitoring utilities (Python3)"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://github.com/jaraco/portend"
 changelog="https://github.com/jaraco/portend/blob/master/CHANGES.rst"
-distfiles="https://github.com/jaraco/portend/archive/${version}.tar.gz"
-checksum=69fa3194739142b62bd6e44f0f0cb0828ddee521f4c7b4634abc5b5e9a54f85a
+distfiles="${PYPI_SITE}/p/portend/portend-${version}.tar.gz"
+checksum=600dd54175e17e9347e5f3d4217aa8bcf4bf4fa5ffbc4df034e5ec1ba7cdaff5
 
-pre_build() {
-	sed -i setup.py \
-		-e '/setuptools_scm/d' \
-		-e "s|use_scm_version=True|version='${version}'|"
-}
 post_install() {
 	vlicense LICENSE
 }

From 6f091da45bee772a7e3406389a5b5ecc7d58998b Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Wed, 14 Oct 2020 21:44:01 -0400
Subject: [PATCH 175/312] python3-tempora: update to 4.0.0.

---
 srcpkgs/python3-tempora/template | 17 ++++++-----------
 1 file changed, 6 insertions(+), 11 deletions(-)

diff --git a/srcpkgs/python3-tempora/template b/srcpkgs/python3-tempora/template
index c4dbebd31b3..fac5a88deff 100644
--- a/srcpkgs/python3-tempora/template
+++ b/srcpkgs/python3-tempora/template
@@ -1,25 +1,20 @@
 # Template file for 'python3-tempora'
 pkgname=python3-tempora
-version=2.0.0
-revision=3
+version=4.0.0
+revision=1
 wrksrc="tempora-${version}"
 build_style=python3-module
-hostmakedepends="python3-setuptools"
+hostmakedepends="python3-setuptools_scm python3-toml"
 depends="python3-setuptools python3-six python3-pytz"
 short_desc="Objects and routines pertaining to date and time (Python3)"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://github.com/jaraco/tempora"
 distfiles="${PYPI_SITE}/t/tempora/tempora-${version}.tar.gz"
-checksum=f11df59b34b9a87d395cce031274f6ff3d2be2171dd1db32dff9ab1fcb5352fa
-conflicts="python-tempora>=0"
-
-pre_build() {
-	vsed -i setup.py \
-		 -e '/setuptools_scm/d' \
-		 -e "s|use_scm_version=True|version='${version}'|"
-}
+checksum=599a3a910b377f2b544c7b221582ecf4cb049b017c994b37f2b1a9ed1099716e
+alternatives="tempora:calc-prorate:/usr/bin/calc-prorate3"
 
 post_install() {
 	vlicense LICENSE
+	mv "${DESTDIR}/usr/bin/calc-prorate" "${DESTDIR}/usr/bin/calc-prorate3"
 }

From 6e8fc22bee3a2a61279ae1d1f2ebe57eced20054 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Wed, 14 Oct 2020 21:47:08 -0400
Subject: [PATCH 176/312] python3-ultrajson: update to 4.0.1.

Closes #25614.
---
 srcpkgs/python3-ultrajson/template | 10 +++-------
 1 file changed, 3 insertions(+), 7 deletions(-)

diff --git a/srcpkgs/python3-ultrajson/template b/srcpkgs/python3-ultrajson/template
index faf1e2e7628..6be2b6d92d5 100644
--- a/srcpkgs/python3-ultrajson/template
+++ b/srcpkgs/python3-ultrajson/template
@@ -1,21 +1,17 @@
 # Template file for 'python3-ultrajson'
 pkgname=python3-ultrajson
-version=4.0.0
+version=4.0.1
 revision=1
 wrksrc="ujson-${version}"
 build_style=python3-module
-hostmakedepends="python3-setuptools"
+hostmakedepends="python3-setuptools_scm"
 makedepends="python3-devel"
 short_desc="Ultra fast JSON encoder and decoder for Python"
 maintainer="Andrew J. Hesford <ajh@sideband.org>"
 license="BSD-3-Clause"
 homepage="https://github.com/ultrajson/ultrajson"
 distfiles="${PYPI_SITE}/u/ujson/ujson-${version}.tar.gz"
-checksum=dba37ad41906d7f9ff52deeb729b9add7e305b94673b41979e9a6c5914083aa8
-
-post_patch() {
-	vsed -i setup.py -e 's/"setuptools_scm"//g'
-}
+checksum=26cf6241b36ff5ce4539ae687b6b02673109c5e3efc96148806a7873eaa229d3
 
 post_install() {
 	vlicense LICENSE.txt

From a51429653322bf41b8e566d816f002087ae10ad7 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Tue, 13 Oct 2020 22:43:49 -0400
Subject: [PATCH 177/312] hplip: add patch to fix scanning

This replaces the deprecated isAlive() method with is_alive().  This was
only made evident with the transition to Python 3.9.
---
 srcpkgs/hplip/patches/sane.patch | 31 +++++++++++++++++++++++++++++++
 srcpkgs/hplip/template           |  2 +-
 2 files changed, 32 insertions(+), 1 deletion(-)
 create mode 100644 srcpkgs/hplip/patches/sane.patch

diff --git a/srcpkgs/hplip/patches/sane.patch b/srcpkgs/hplip/patches/sane.patch
new file mode 100644
index 00000000000..b30660952df
--- /dev/null
+++ b/srcpkgs/hplip/patches/sane.patch
@@ -0,0 +1,31 @@
+--- scan/sane.py.orig	2020-10-13 22:29:59.456276307 -0400
++++ scan/sane.py	2020-10-13 22:32:44.663586789 -0400
+@@ -378,14 +378,14 @@
+ 
+     def isScanActive(self):
+         if self.scan_thread is not None:
+-            return self.scan_thread.isAlive() and self.scan_thread.scan_active
++            return self.scan_thread.is_alive() and self.scan_thread.scan_active
+         else:
+             return False
+ 
+ 
+     def waitForScanDone(self):
+         if self.scan_thread is not None and \
+-            self.scan_thread.isAlive() and \
++            self.scan_thread.is_alive() and \
+             self.scan_thread.scan_active:
+ 
+             try:
+@@ -398,9 +398,9 @@
+         #time.sleep(0.5)
+         if self.scan_thread is not None:
+             while True:
+-                #print self.scan_thread.isAlive()
++                #print self.scan_thread.is_alive()
+                 #print self.scan_thread.scan_active
+-                if self.scan_thread.isAlive() and \
++                if self.scan_thread.is_alive() and \
+                     self.scan_thread.scan_active:
+                     return
+ 
diff --git a/srcpkgs/hplip/template b/srcpkgs/hplip/template
index 527d16a7b5d..bf66601fe64 100644
--- a/srcpkgs/hplip/template
+++ b/srcpkgs/hplip/template
@@ -1,7 +1,7 @@
 # Template file for 'hplip'
 pkgname=hplip
 version=3.20.9
-revision=2
+revision=3
 build_style=gnu-configure
 pycompile_dirs="usr/share/hplip"
 configure_args="

From aa59168adbe4b37b89160154ca2a4f362fc7ae00 Mon Sep 17 00:00:00 2001
From: Peter Bui <pbui@github.bx612.space>
Date: Tue, 13 Oct 2020 23:00:11 -0400
Subject: [PATCH 178/312] python3-lazy-object-proxy: update to 1.5.1.

Also add python3-setuptools_scm to hostmakedepends and remove a broken
post_patch that caused the egg version to be set to 0.0.0 rather than
the true version, causing programs like pylint to break.

Closes: #25586 [via git-merge-pr]
---
 srcpkgs/python3-lazy-object-proxy/template | 12 ++++--------
 1 file changed, 4 insertions(+), 8 deletions(-)

diff --git a/srcpkgs/python3-lazy-object-proxy/template b/srcpkgs/python3-lazy-object-proxy/template
index cf606a1869f..9ad5a7ed0db 100644
--- a/srcpkgs/python3-lazy-object-proxy/template
+++ b/srcpkgs/python3-lazy-object-proxy/template
@@ -1,21 +1,17 @@
 # Template file for 'python3-lazy-object-proxy'
 pkgname=python3-lazy-object-proxy
-version=1.4.3
-revision=4
+version=1.5.1
+revision=1
 wrksrc="lazy-object-proxy-${version}"
 build_style=python3-module
-hostmakedepends="python3-setuptools"
+hostmakedepends="python3-setuptools_scm"
 makedepends="python3-devel"
 short_desc="Fast and thorough lazy object proxy (Python3)"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="BSD-2-Clause"
 homepage="https://github.com/ionelmc/python-lazy-object-proxy"
 distfiles="${PYPI_SITE}/l/lazy-object-proxy/lazy-object-proxy-${version}.tar.gz"
-checksum=f3900e8a5de27447acbf900b4750b0ddfd7ec1ea7fbaf11dfa911141bc522af0
-
-post_patch() {
-	vsed -i '/setuptools_scm/d' setup.cfg
-}
+checksum=9723364577b79ad9958a68851fe2acb94da6fd25170c595516a8289e6a129043
 
 post_install() {
 	vlicense LICENSE

From b687f294e612f765d056bedaa1be6a41b5e8974c Mon Sep 17 00:00:00 2001
From: Karl Nilsson <karl.robert.nilsson@gmail.com>
Date: Tue, 13 Oct 2020 17:40:08 -0400
Subject: [PATCH 179/312] python3-numpy-stl: update to 2.11.3.

Closes: #25580 [via git-merge-pr]
---
 srcpkgs/python3-numpy-stl/template | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-numpy-stl/template b/srcpkgs/python3-numpy-stl/template
index 2876d3266ad..71a5eb52e85 100644
--- a/srcpkgs/python3-numpy-stl/template
+++ b/srcpkgs/python3-numpy-stl/template
@@ -1,18 +1,19 @@
 # Template file for 'python3-numpy-stl'
 pkgname=python3-numpy-stl
-version=2.11.2
-revision=2
+version=2.11.3
+revision=1
 wrksrc="numpy-stl-${version}"
 build_style=python3-module
+build_helper="numpy"
 hostmakedepends="python3-setuptools python3-Cython"
-makedepends="python3-devel python3-numpy"
+makedepends="python3-devel"
 depends="python3-setuptools python3-numpy python3-utils"
 short_desc="Python3 library to make working with STL files fast and easy"
 maintainer="Karl Nilsson <karl.robert.nilsson@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/WoLpH/numpy-stl/"
 distfiles="https://github.com/WoLpH/numpy-stl/archive/v${version}.tar.gz"
-checksum=d1985a27fa8c28e5883bf9cb9c3c33a0ac7fad196fc6162d59c701ab18740ac4
+checksum=c425c3cf7e3125fff2772a654202b29fb20ea47d43e194cb560acb1c59f8c724
 
 conflicts="python-numpy-stl>=0"
 

From 57ba1486ed7430c7b6c2ff74eda47f593b7226f1 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Benjam=C3=ADn=20Albi=C3=B1ana?= <benalb@gmail.com>
Date: Tue, 13 Oct 2020 13:13:06 +0200
Subject: [PATCH 180/312] croc: update to 8.5.1.

---
 srcpkgs/croc/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/croc/template b/srcpkgs/croc/template
index 27b3741223c..89049e4c80f 100644
--- a/srcpkgs/croc/template
+++ b/srcpkgs/croc/template
@@ -1,6 +1,6 @@
 # Template file for 'croc'
 pkgname=croc
-version=8.4.0
+version=8.5.1
 revision=1
 build_style=go
 go_import_path=github.com/schollz/croc/v${version%%.*}
@@ -10,7 +10,7 @@ maintainer="Benjamín Albiñana <benalb@gmail.com>"
 license="MIT"
 homepage="https://github.com/schollz/croc"
 distfiles="https://github.com/schollz/croc/archive/v${version}.tar.gz"
-checksum=7818976d1c773f79c4f92f83693ee4c02fc57852d99dfb09548427953c2b8fb3
+checksum=2ab0a479196b8ca3f024d5dad7e42c871e043a846c14beb374c48f2c172390d7
 
 post_install() {
 	vlicense LICENSE

From cdb7c51f3a2457029f571d42d3abdca1e7761125 Mon Sep 17 00:00:00 2001
From: Paper <paper@tilde.institute>
Date: Tue, 13 Oct 2020 11:11:27 +0200
Subject: [PATCH 181/312] duf: update to 0.4.0

---
 srcpkgs/duf/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/duf/template b/srcpkgs/duf/template
index 73b01421802..1cc966ef907 100644
--- a/srcpkgs/duf/template
+++ b/srcpkgs/duf/template
@@ -1,6 +1,6 @@
 # Template file for 'duf'
 pkgname=duf
-version=0.3.1
+version=0.4.0
 revision=1
 build_style=go
 go_import_path="github.com/muesli/duf"
@@ -9,7 +9,7 @@ maintainer="Paper <paper@tilde.institute>"
 license="MIT"
 homepage="https://github.com/muesli/duf/"
 distfiles="https://github.com/muesli/duf/archive/v$version.tar.gz"
-checksum=98b5cdc4a7b3c5eddc0ec397c65860110b446e85cc4f3cfe3e32f31ce524e90d
+checksum=da6b0bb601d7b9a92cfd41005eae7a66573d28e77625f4e747b285207980784b
 
 post_install() {
 	vlicense LICENSE

From bb4331410f8a771d65436755c152a81f471b2865 Mon Sep 17 00:00:00 2001
From: Evgeny Ermakov <evgeny.v.ermakov@gmail.com>
Date: Tue, 13 Oct 2020 17:03:32 +1100
Subject: [PATCH 182/312] cJSON: update to 1.7.14

---
 srcpkgs/cJSON/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/cJSON/template b/srcpkgs/cJSON/template
index c8ababeff8b..e4ad38673e1 100644
--- a/srcpkgs/cJSON/template
+++ b/srcpkgs/cJSON/template
@@ -1,6 +1,6 @@
 # Template file for 'cJSON'
 pkgname=cJSON
-version=1.7.13
+version=1.7.14
 revision=1
 build_style=cmake
 short_desc="Ultralightweight JSON parser in ANSI C"
@@ -8,7 +8,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://github.com/DaveGamble/cJSON"
 distfiles="https://github.com/DaveGamble/cJSON/archive/v${version}.tar.gz"
-checksum=d4e77a38f540f2c37f55758f2666655314f1f51c716fea5f279659940efdcf04
+checksum=fb50a663eefdc76bafa80c82bc045af13b1363e8f45cec8b442007aef6a41343
 
 post_install() {
 	vlicense LICENSE

From 15ba4be69467152f1f5258a8374ff28acd6352d3 Mon Sep 17 00:00:00 2001
From: mobinmob <mobinmob@disroot.org>
Date: Tue, 13 Oct 2020 01:18:19 +0300
Subject: [PATCH 183/312] brisk-menu: update to 0.6.2.

---
 srcpkgs/brisk-menu/template | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/brisk-menu/template b/srcpkgs/brisk-menu/template
index f440391e26e..5f7847ec49b 100644
--- a/srcpkgs/brisk-menu/template
+++ b/srcpkgs/brisk-menu/template
@@ -1,8 +1,7 @@
 # Template file for 'brisk-menu'
 pkgname=brisk-menu
-version=0.6.1
+version=0.6.2
 revision=1
-wrksrc="${pkgname}-v${version}"
 build_style=meson
 hostmakedepends="glib pkg-config intltool glib-devel"
 makedepends="gtk+3-devel mate-menus-devel libmate-panel-devel libnotify-devel"
@@ -12,7 +11,7 @@ maintainer="Jasu Koponen <jasu.koponen@hotmail.com>"
 license="GPL-2.0-only, CC-BY-SA-4.0"
 homepage="https://github.com/getsolus/brisk-menu"
 distfiles="${homepage}/releases/download/v${version}/${pkgname}-v${version}.tar.xz"
-checksum=9cf9ae307a780afe5b808b8233ac85ecf948f846efbcfb60a6adcc8fd77017aa
+checksum=5a87f4dcf7365e81a571128bf0b8199eb06a6fcd7e15ec7739be0ccff1326488
 
 post_install() {
 	vlicense LICENSE.CC-BY-SA-4.0

From df6a4791193896fc9581e14850dce5a366772edc Mon Sep 17 00:00:00 2001
From: fosslinux <fosslinux@aussies.space>
Date: Sun, 11 Oct 2020 11:45:45 +1100
Subject: [PATCH 184/312] projectM: fix GUI applications for cross.

The template had a note:
`TODO: find out why these files aren't generated for the cross build`,
regarding the desktop files and icons that weren't being installed.
This was actually because the GUI application's weren't being built
at all! The build system could not find QT. Force enabling these
applications and doing qt shenanigans, including `build_helper=qmake`,
fixes these issues.
---
 srcpkgs/projectM/template | 17 +++++++++--------
 1 file changed, 9 insertions(+), 8 deletions(-)

diff --git a/srcpkgs/projectM/template b/srcpkgs/projectM/template
index d7e5c0fa547..6d9fc6a0a94 100644
--- a/srcpkgs/projectM/template
+++ b/srcpkgs/projectM/template
@@ -1,10 +1,13 @@
 # Template file for 'projectM'
 pkgname=projectM
 version=3.1.7
-revision=2
+revision=3
 build_style=gnu-configure
-configure_args="--datadir=/usr/libexec"
-hostmakedepends="pkg-config qt5-host-tools automake libtool which"
+build_helper=qmake
+configure_args="--datadir=/usr/libexec --enable-qt --enable-pulseaudio
+ --enable-jack --enable-sdl"
+hostmakedepends="pkg-config qt5-host-tools automake libtool which qt5-qmake
+ qt5-tools-devel"
 makedepends="pulseaudio-devel alsa-lib-devel glew-devel ftgl-devel libXext-devel
  SDL2-devel gtkglext-devel jack-devel qt5-tools-devel libvisual-devel glm
  MesaLib-devel glu-devel"
@@ -21,11 +24,9 @@ if [ "$XBPS_TARGET_LIBC" = "musl" ]; then
 fi
 
 post_install() {
-	if [ ! "$CROSS_BUILD" ]; then
-		# fix location of desktop files
-		# TODO: find out why these files aren't generated for the cross build
-		mv $DESTDIR/usr/libexec/{applications,icons} $DESTDIR/usr/share
-	fi
+	# fix location of desktop files
+	vmkdir usr/share
+	mv $DESTDIR/usr/libexec/{applications,icons} $DESTDIR/usr/share
 }
 
 projectM-devel_package() {

From ff35c786b125651526c3fb0f3f08d659eb3490fa Mon Sep 17 00:00:00 2001
From: Sora Morimoto <sora@morimoto.io>
Date: Sun, 11 Oct 2020 08:37:20 +0900
Subject: [PATCH 185/312] direnv: update to 2.23.0

Signed-off-by: Sora Morimoto <sora@morimoto.io>
---
 srcpkgs/direnv/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/direnv/template b/srcpkgs/direnv/template
index 387e2fe6c95..0956156c8bd 100644
--- a/srcpkgs/direnv/template
+++ b/srcpkgs/direnv/template
@@ -1,6 +1,6 @@
 # Template file for 'direnv'
 pkgname=direnv
-version=2.22.0
+version=2.23.0
 revision=1
 build_style=go
 go_import_path=github.com/direnv/direnv
@@ -10,7 +10,7 @@ license="MIT"
 homepage="https://direnv.net/"
 changelog="https://raw.githubusercontent.com/direnv/direnv/master/CHANGELOG.md"
 distfiles="https://github.com/direnv/direnv/archive/v${version}.tar.gz"
-checksum=bf35d267a28dcace4109c3256f2cd7cb0ca3b8d461d2fbf848db3f65b809befd
+checksum=d28bc959680a309d0d54f754edfe622cdde14a4b806fdd32d285d47a322098b9
 
 post_install() {
 	vlicense LICENSE

From 502f29ca59940ecd34572c9408d9162759588e99 Mon Sep 17 00:00:00 2001
From: mobinmob <mobinmob@disroot.org>
Date: Sun, 11 Oct 2020 00:39:19 +0300
Subject: [PATCH 186/312] font-awesome5: update to 5.15.1.

---
 srcpkgs/font-awesome5/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/font-awesome5/template b/srcpkgs/font-awesome5/template
index 8bebc017207..b7fedfdcc83 100644
--- a/srcpkgs/font-awesome5/template
+++ b/srcpkgs/font-awesome5/template
@@ -1,6 +1,6 @@
 # Template file for 'font-awesome5'
 pkgname=font-awesome5
-version=5.15.0
+version=5.15.1
 revision=1
 wrksrc="Font-Awesome-${version}"
 depends="font-util"
@@ -9,7 +9,7 @@ maintainer="mobinmob <mobinmob@disroot.org>"
 license="OFL-1.1"
 homepage="https://fontawesome.com"
 distfiles="https://github.com/FortAwesome/Font-Awesome/archive/${version}.tar.gz"
-checksum=93cd86e9b6662023f54329af401eee2eada64825d050e7a71eb9eebf6455880f
+checksum=f229f46cd6cabb6380c7c503772cb42ed19497da26a002005509388c8930e7e1
 conflicts="font-awesome>=0"
 font_dirs="/usr/share/fonts/OTF"
 

From 9afddbc0e36210297500fece48990f797169c4e6 Mon Sep 17 00:00:00 2001
From: mobinmob <mobinmob@disroot.org>
Date: Sun, 11 Oct 2020 01:13:18 +0300
Subject: [PATCH 187/312] wps-office: update to 11.1.0.9662.

---
 srcpkgs/wps-office/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/wps-office/template b/srcpkgs/wps-office/template
index 887a52679fc..784fa18d063 100644
--- a/srcpkgs/wps-office/template
+++ b/srcpkgs/wps-office/template
@@ -1,6 +1,6 @@
 # Template file for 'wps-office'
 pkgname=wps-office
-version=11.1.0.9615
+version=11.1.0.9662
 revision=1
 archs="x86_64"
 create_wrksrc=yes
@@ -10,11 +10,11 @@ maintainer="Michael Aldridge <maldridge@voidlinux.org>"
 #The old Kingsoft WPS Community License has disappeared from the
 #site. There is an EULA in the archive which is instaled as license
 #and a non-downloadable EULA which is accesible from inside the program:
-#https://www.wps.com/eula?distsrc=2019help&lang=en_US&version=11.1.0.9505
+#https://www.wps.com/eula?distsrc=2020help&lang=en_US&version=11.1.0.9662
 license="custom:EULA"
 homepage="http://wps-community.org"
 changelog="http://linux.wps.com/wpslinuxlog.html"
-checksum=3b9e6c1f8f25b51ae08aad4a37bfd7fd25ce535479126833678b147c5f910252
+checksum=3a22598c26e639d822db62282931b849943c9ccec559d69c57a412a81f52def8
 allow_unknown_shlibs=yes
 nodebug=yes
 restricted=yes
@@ -23,7 +23,7 @@ restricted=yes
 #The programs themselves are PIE, but the error reporter isn't :/
 nopie=yes
 
-_disturl=http://wdl1.pcfg.cache.wpscdn.com/wpsdl/wpsoffice/download/linux/9615/
+_disturl=http://wdl1.pcfg.cache.wpscdn.com/wpsdl/wpsoffice/download/linux/9662/
 _distTar="${pkgname}-${version}.XA-1.x86_64.rpm"
 distfiles="${_disturl}/${_distTar}"
 

From dd6a83c8261fc7d496849e770505ce273d49167e Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?J=C3=A1n=20Priner?= <johnkie4@gmail.com>
Date: Sat, 10 Oct 2020 15:47:54 +0200
Subject: [PATCH 188/312] python3-pathspec: update to 0.8.0

---
 srcpkgs/python3-pathspec/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-pathspec/template b/srcpkgs/python3-pathspec/template
index 421aaf078b5..48181640d87 100644
--- a/srcpkgs/python3-pathspec/template
+++ b/srcpkgs/python3-pathspec/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-pathspec'
 pkgname=python3-pathspec
-version=0.6.0
-revision=4
+version=0.8.0
+revision=1
 wrksrc="pathspec-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,7 +11,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="MPL-2.0"
 homepage="https://github.com/cpburnz/python-path-specification"
 distfiles="${PYPI_SITE}/p/pathspec/pathspec-${version}.tar.gz"
-checksum=e285ccc8b0785beadd4c18e5708b12bb8fcf529a1e61215b3feff1d1e559ea5c
+checksum=da45173eb3a6f2a5a487efba21f050af2b41948be6ab52b6a1e3ff22bb8b7061
 
 do_check() {
 	python3 setup.py test

From 0796b893ae3554bc603356dbde6741ad256692ec Mon Sep 17 00:00:00 2001
From: Mate GABRI <mate.gabri@playhq.com>
Date: Tue, 13 Oct 2020 09:47:23 +1100
Subject: [PATCH 189/312] terraform: update to 0.13.4

---
 srcpkgs/terraform/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/terraform/template b/srcpkgs/terraform/template
index b9e019711da..9ddd8b5e43a 100644
--- a/srcpkgs/terraform/template
+++ b/srcpkgs/terraform/template
@@ -1,6 +1,6 @@
 # Template file for 'terraform'
 pkgname=terraform
-version=0.13.2
+version=0.13.4
 revision=1
 build_style=go
 go_import_path="github.com/hashicorp/$pkgname"
@@ -9,4 +9,4 @@ maintainer="Andrea Brancaleoni <abc@pompel.me>"
 license="MPL-2.0"
 homepage="https://www.terraform.io/"
 distfiles="https://$go_import_path/archive/v$version.tar.gz"
-checksum=f1138827f4a60f028860dddb742d8c1ab06d0b6975c9312bc7e9b399e8e040b5
+checksum=a8fd0574594c534b3bf2c0b71eee88aff502a551a788f610f88b52a715f00c10

From ee21532235f1ed6f18fde5565a5d9b68f772062a Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Lucas=20Treffenst=C3=A4dt?=
 <lucas.treffenstaedt@tngtech.com>
Date: Wed, 7 Oct 2020 09:30:58 +0200
Subject: [PATCH 190/312] intellij-idea-ultimate-edition: update to 2020.2.3.

---
 srcpkgs/intellij-idea-ultimate-edition/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/intellij-idea-ultimate-edition/template b/srcpkgs/intellij-idea-ultimate-edition/template
index 96b820f5c20..75dabe36b59 100644
--- a/srcpkgs/intellij-idea-ultimate-edition/template
+++ b/srcpkgs/intellij-idea-ultimate-edition/template
@@ -1,16 +1,16 @@
 # Template file for 'intellij-idea-ultimate-edition'
 pkgname=intellij-idea-ultimate-edition
-version=2020.2.2
+version=2020.2.3
 revision=1
 archs="i686 x86_64"
-wrksrc="idea-IU-202.7319.50"
+wrksrc="idea-IU-202.7660.26"
 depends="giflib libXtst jetbrains-jdk-bin"
 short_desc="Most intelligent Java IDE"
 maintainer="Anton Afanasyev <anton@doubleasoftware.com>"
 license="custom:Commercial"
 homepage="https://www.jetbrains.com/idea"
 distfiles="https://download.jetbrains.com/idea/ideaIU-${version}-no-jbr.tar.gz"
-checksum=269ba62b3ec9214864244ab490273cad6fb87f15ed6739c31129e7b758fe2685
+checksum=e086eb02343c28fab22fd83f7984b377f60bd15aa0f9733a142d99a0ec8c2690
 repository=nonfree
 restricted=yes
 nopie=yes

From 78ebd53842415709ca3bb3d37a9a3b180a661357 Mon Sep 17 00:00:00 2001
From: mobinmob <mobinmob@disroot.org>
Date: Mon, 5 Oct 2020 14:10:44 +0300
Subject: [PATCH 191/312] skype: update to 8.65.0.76.

---
 srcpkgs/skype/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/skype/template b/srcpkgs/skype/template
index 75a73da9ff0..889295b1a49 100644
--- a/srcpkgs/skype/template
+++ b/srcpkgs/skype/template
@@ -1,7 +1,7 @@
 # Template file for 'skype'
 # This just repackages the debian package.
 pkgname=skype
-version=8.64.0.81
+version=8.65.0.76
 revision=1
 archs="x86_64"
 depends="elogind"
@@ -10,7 +10,7 @@ maintainer="Lon Willett <xgit@lonw.net>"
 license="custom:skype-servicesagreement"
 homepage="https://www.skype.com"
 distfiles="https://repo.skype.com/deb/pool/main/s/skypeforlinux/skypeforlinux_${version}_amd64.deb"
-checksum=507e16e5dfc98eaf2ffc33a5288da882ccb10e02978f0bc73da92e350bb9da5c
+checksum=45f5add7369eda359a50ed3bc179aa1f6757391648d02ff1bd5ffa9331db6f2d
 repository="nonfree"
 nostrip="yes"
 

From 99d00ef7a78faa5a14758c76db91e3c917feefe2 Mon Sep 17 00:00:00 2001
From: Anthony Iliopoulos <ailiop@altatus.com>
Date: Sun, 4 Oct 2020 12:50:21 +0200
Subject: [PATCH 192/312] php: update to 7.4.11.

---
 srcpkgs/php/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/php/template b/srcpkgs/php/template
index 705faecb9c8..db56578a49f 100644
--- a/srcpkgs/php/template
+++ b/srcpkgs/php/template
@@ -1,6 +1,6 @@
 # Template file for 'php'
 pkgname=php
-version=7.4.10
+version=7.4.11
 revision=1
 hostmakedepends="bison pkg-config apache-devel"
 makedepends="apache-devel enchant-devel freetds-devel freetype-devel gdbm-devel
@@ -13,7 +13,7 @@ maintainer="Steve Prybylski <sa.prybylx@gmail.com>"
 license="PHP-3.01"
 homepage="https://www.php.net"
 distfiles="http://www.php.net/distributions/php-${version}.tar.xz"
-checksum=c2d90b00b14284588a787b100dee54c2400e7db995b457864d66f00ad64fb010
+checksum=5d31675a9b9c21b5bd03389418218c30b26558246870caba8eb54f5856e2d6ce
 
 conf_files="/etc/php/php.ini"
 

From fc1579e402d961269087b679522c9b674071778a Mon Sep 17 00:00:00 2001
From: Anthony Iliopoulos <ailiop@altatus.com>
Date: Sun, 4 Oct 2020 11:18:02 +0200
Subject: [PATCH 193/312] fbpdf: update to 0.0.20200616.

---
 srcpkgs/fbpdf/template | 16 +++++++++-------
 1 file changed, 9 insertions(+), 7 deletions(-)

diff --git a/srcpkgs/fbpdf/template b/srcpkgs/fbpdf/template
index f35418727ae..7032449c393 100644
--- a/srcpkgs/fbpdf/template
+++ b/srcpkgs/fbpdf/template
@@ -1,27 +1,29 @@
 # Template file for 'fbpdf'
 pkgname=fbpdf
-version=0.0.20181018
+version=0.0.20200616
 revision=1
-wrksrc=fbpdf-dfe9f00
+_githash=f59002487edba502aaa93e9aec3bb6ebbbe41b0e
+_gitshort="${_githash:0:7}"
+wrksrc="fbpdf-${_gitshort}"
 build_style=gnu-makefile
 makedepends="djvulibre-devel freetype-devel harfbuzz-devel libressl-devel
  mupdf-devel"
 short_desc="Small framebuffer PDF/DJVU viewer"
 maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="ISC"
-homepage="http://repo.or.cz/w/fbpdf.git"
-distfiles="http://repo.or.cz/fbpdf.git/snapshot/dfe9f0067549f759cdc04f2f62b4f89cd6e1b199.tar.gz"
-checksum=f2ff9b9f4679963d091650ad55083af65abab26e57906618cd76d23326ff825a
+homepage="https://repo.or.cz/w/fbpdf.git"
+distfiles="https://repo.or.cz/fbpdf.git/snapshot/${_githash}.tar.gz"
+checksum=a86483a3ec144b68b89641abccb848b390ad901732c5e6043e3eb67e0ede7986
 
 pre_build() {
 	# Can't do it via LDFLAGS, that messes up the linking order
-	sed 's/-threads/& -lfreetype -lharfbuzz -lz -ljbig2dec -ljpeg -lopenjp2/' \
+	vsed 's/-threads/& -lfreetype -lharfbuzz -lz -ljbig2dec -ljpeg -lopenjp2/' \
 		-i Makefile
 }
 
 do_install() {
 	vbin fbpdf
 	vbin fbdjvu
-	vdoc README # no manpage
+	vman fbpdf.1
 	vlicense LICENSE
 }

From bdb1184c85179b49210beba49fbabcb28c23e11b Mon Sep 17 00:00:00 2001
From: Paper <paper@tilde.institute>
Date: Thu, 1 Oct 2020 13:02:29 +0200
Subject: [PATCH 194/312] nvimpager: update to 0.7

---
 srcpkgs/nvimpager/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/nvimpager/template b/srcpkgs/nvimpager/template
index 55361bf11e4..d9203155ea4 100644
--- a/srcpkgs/nvimpager/template
+++ b/srcpkgs/nvimpager/template
@@ -1,6 +1,6 @@
 # Template file for 'nvimpager'
 pkgname=nvimpager
-version=0.6
+version=0.7
 revision=1
 # In pre_build, date is the date of the last commit in the nvimpager repo.
 # It should be changed when updating to a new version.
@@ -17,14 +17,14 @@ license="BSD-2-Clause"
 homepage="https://github.com/lucc/nvimpager"
 distfiles="${homepage}/archive/v${version}.tar.gz
  https://www.vim.org/scripts/download_script.php?src_id=14498>AnsiEsc.vba.gz"
-checksum="0415a57ae53d20a9ecdc5d85c22a2847319631f31d9c5b09fe22506183148c46
+checksum="cb4eee0ef2569412b0528eacd7efd6af960bebc11d8749258d8ba83c975ebf4b
  a80d8c95a2e497e190831f1b580205653c595c6f51b48d4cb89fb33eaea5ed03"
 
 pre_build() {
 	cat <<< \
 "---
 footer: Version v${version}
-date: 2019-03-05
+date: 2020-09-25
 ..." \
 	> metadata.yml
 

From 7cc9c55dbea105d3ef6015ef3071e2d63e7122d6 Mon Sep 17 00:00:00 2001
From: Artur Sinila <personal@logarithmus.dev>
Date: Tue, 29 Sep 2020 02:55:05 +0300
Subject: [PATCH 195/312] common/build-helper/rust.sh: dynamic linking to
 libpcre2 on musl

---
 common/build-helper/rust.sh | 3 +++
 1 file changed, 3 insertions(+)

diff --git a/common/build-helper/rust.sh b/common/build-helper/rust.sh
index a62503583f3..6fcd3bd7d9e 100644
--- a/common/build-helper/rust.sh
+++ b/common/build-helper/rust.sh
@@ -38,3 +38,6 @@ export SODIUM_INC_DIR="${XBPS_CROSS_BASE}/usr/lib"
 
 # openssl-sys
 export OPENSSL_NO_VENDOR=1
+
+# pcre2-sys, only necessary for musl targets
+export PCRE2_SYS_STATIC=0

From 2ec4ac8e0e9289dc23bb8b2de800fe41d5a3d1c4 Mon Sep 17 00:00:00 2001
From: Artur Sinila <personal@logarithmus.dev>
Date: Tue, 29 Sep 2020 03:32:25 +0300
Subject: [PATCH 196/312] ripgrep: revbump to use system-provided libpcre2 on
 musl

---
 srcpkgs/ripgrep/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/ripgrep/template b/srcpkgs/ripgrep/template
index 339d2de3a39..b2ec6ad3d34 100644
--- a/srcpkgs/ripgrep/template
+++ b/srcpkgs/ripgrep/template
@@ -1,7 +1,7 @@
 # Template file for 'ripgrep'
 pkgname=ripgrep
 version=12.1.1
-revision=1
+revision=2
 build_style=cargo
 configure_args="--features=pcre2"
 hostmakedepends="ruby-asciidoctor pkg-config"

From b88cc12abd331a0cb09a04f5b2139edb01eee4fb Mon Sep 17 00:00:00 2001
From: Neel Chotai <neel@chot.ai>
Date: Thu, 15 Oct 2020 01:36:20 +0100
Subject: [PATCH 197/312] glances: update to 3.1.5

---
 srcpkgs/glances/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/glances/template b/srcpkgs/glances/template
index 4aa28b55cd2..0598978094c 100644
--- a/srcpkgs/glances/template
+++ b/srcpkgs/glances/template
@@ -1,17 +1,17 @@
 # Template file for 'glances'
 pkgname=glances
-version=3.1.4.1
-revision=2
+version=3.1.5
+revision=1
 build_style=python3-module
 hostmakedepends="python3-setuptools"
-depends="${hostmakedepends} python3-future python3-psutil"
+depends="python3-setuptools python3-future python3-psutil"
 checkdepends="python3-psutil"
 short_desc="Cross-platform curses-based monitoring tool"
 maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="LGPL-3.0-or-later"
 homepage="https://github.com/nicolargo/glances"
 distfiles="https://github.com/nicolargo/glances/archive/v${version}.tar.gz"
-checksum=0347a0b949451fd0022c0f22e54092fe526120a776af1f2bde1ea7ba61d6b792
+checksum=e60ea1274e882f9d64d16c12690bd71dcc70ebe7e93690d773275f92fa126b24
 
 post_install() {
 	vsconf conf/glances.conf

From c4e509e059154c76986178bc3965ec23dd3fef2b Mon Sep 17 00:00:00 2001
From: Cameron Nemo <cnemo@tutanota.com>
Date: Tue, 13 Oct 2020 21:53:05 -0700
Subject: [PATCH 198/312] discord: remove unused GConf dependency

[ci skip]
---
 srcpkgs/discord/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/discord/template b/srcpkgs/discord/template
index 9816f3ecb5d..a84b25f0300 100644
--- a/srcpkgs/discord/template
+++ b/srcpkgs/discord/template
@@ -1,10 +1,10 @@
 # Template file for 'discord'
 pkgname=discord
 version=0.0.12
-revision=1
+revision=2
 archs="x86_64"
 wrksrc="Discord"
-depends="alsa-lib dbus-glib gtk+3 GConf libnotify nss libXtst libcxx libatomic"
+depends="alsa-lib dbus-glib gtk+3 libnotify nss libXtst libcxx libatomic"
 short_desc="Chat and VOIP application"
 maintainer="Ryan Conwell <ryanconwell@protonmail.com>"
 license="custom:Proprietary"

From a8a0eec18d5b934fae70488e67bc76ea9f281823 Mon Sep 17 00:00:00 2001
From: Cameron Nemo <cnemo@tutanota.com>
Date: Mon, 12 Oct 2020 19:26:29 -0700
Subject: [PATCH 199/312] fuse-overlayfs: update to 1.2.0.

---
 srcpkgs/fuse-overlayfs/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/fuse-overlayfs/template b/srcpkgs/fuse-overlayfs/template
index 7c010091e67..48eb4985dcf 100644
--- a/srcpkgs/fuse-overlayfs/template
+++ b/srcpkgs/fuse-overlayfs/template
@@ -1,6 +1,6 @@
 # Template file for 'fuse-overlayfs'
 pkgname=fuse-overlayfs
-version=1.1.2
+version=1.2.0
 revision=1
 build_style=gnu-configure
 hostmakedepends="autoconf automake pkg-config"
@@ -10,7 +10,7 @@ maintainer="Cameron Nemo <cnemo@tutanota.com>"
 license="GPL-3.0-or-later"
 homepage="https://github.com/containers/fuse-overlayfs"
 distfiles="https://github.com/containers/fuse-overlayfs/archive/v${version}.tar.gz"
-checksum=1c0fa67f806c44d5c51f4bce02fdcb546137a2688a8de76d93d07b79defc9cac
+checksum=5df218732244059057686194b0e1fef66fb822d4087db48af88e1bc29bb1afde
 
 pre_configure() {
 	./autogen.sh

From 0fd8affcbd7bf0c4f5258f86d8f5c7530ad97336 Mon Sep 17 00:00:00 2001
From: Cameron Nemo <cnemo@tutanota.com>
Date: Mon, 12 Oct 2020 19:11:34 -0700
Subject: [PATCH 200/312] podman: update to 2.1.1.

---
 srcpkgs/podman/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/podman/template b/srcpkgs/podman/template
index 46703514fdd..a35adc43e59 100644
--- a/srcpkgs/podman/template
+++ b/srcpkgs/podman/template
@@ -1,6 +1,6 @@
 # Template file for 'podman'
 pkgname=podman
-version=2.1.0
+version=2.1.1
 revision=1
 build_style=go
 go_import_path="github.com/containers/podman/v2"
@@ -15,7 +15,7 @@ maintainer="Cameron Nemo <cnemo@tutanota.com>"
 license="Apache-2.0"
 homepage="https://podman.io/"
 distfiles="https://github.com/containers/libpod/archive/v${version}.tar.gz"
-checksum=b3098ef71b8f93829ad144352d7223ce4f60f7571e779be5b97fc70538250781
+checksum=5ebaa6e0dbd7fd1863f70d2bc71dc8a94e195c3339c17e3cac4560c9ec5747f8
 
 if [ "$CROSS_BUILD" ]; then
 	go_build_tags+=" containers_image_openpgp"

From 7805ceec81ae36cabd786f24dd1aa4ba0985efe8 Mon Sep 17 00:00:00 2001
From: Neel Chotai <neel@chot.ai>
Date: Fri, 28 Feb 2020 12:50:22 +0000
Subject: [PATCH 201/312] New package: grex-1.0.0

Closes: #19620 [via git-merge-pr]
---
 srcpkgs/grex/template | 15 +++++++++++++++
 1 file changed, 15 insertions(+)
 create mode 100644 srcpkgs/grex/template

diff --git a/srcpkgs/grex/template b/srcpkgs/grex/template
new file mode 100644
index 00000000000..a2c2d6d3244
--- /dev/null
+++ b/srcpkgs/grex/template
@@ -0,0 +1,15 @@
+# Template file for 'grex'
+pkgname=grex
+version=1.1.0
+revision=1
+build_style=cargo
+short_desc="Tool for generating regular expressions from user-provided test cases"
+maintainer="Neel Chotai <neel@chot.ai>"
+license="Apache-2.0"
+homepage="https://github.com/pemistahl/grex"
+distfiles="https://github.com/pemistahl/grex/archive/v${version}.tar.gz"
+checksum=52a9d5ddc15c7fb227c87147d991bfabe2aae1fbef8169893a9111dcd3aa641f
+
+post_install() {
+	vdoc README.md
+}

From 5fe9643401b25d196f34e49139cbb771079d242c Mon Sep 17 00:00:00 2001
From: Piraty <piraty1@inbox.ru>
Date: Thu, 15 Oct 2020 13:01:32 +0200
Subject: [PATCH 202/312] zig: enable on aarch64

---
 srcpkgs/zig/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/zig/template b/srcpkgs/zig/template
index c3ab8e62a11..e34d6471728 100644
--- a/srcpkgs/zig/template
+++ b/srcpkgs/zig/template
@@ -1,8 +1,8 @@
 # Template file for 'zig'
 pkgname=zig
 version=0.6.0
-revision=1
-archs="x86_64*"
+revision=2
+archs="x86_64* aarch64*"
 build_style=cmake
 makedepends="clang llvm10 lld-devel"
 short_desc="Programming language designed for robustness, optimality, and clarity"

From 8632fca7fe83aef84ea1f82874af22af33620a93 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Thu, 15 Oct 2020 13:09:52 +0200
Subject: [PATCH 203/312] earlyoom: update to 1.6.2.

---
 srcpkgs/earlyoom/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/earlyoom/template b/srcpkgs/earlyoom/template
index a53e9a32c25..338bc8896b3 100644
--- a/srcpkgs/earlyoom/template
+++ b/srcpkgs/earlyoom/template
@@ -1,6 +1,6 @@
 # Template file for 'earlyoom'
 pkgname=earlyoom
-version=1.6.1
+version=1.6.2
 revision=1
 build_style=gnu-makefile
 make_check_target=test
@@ -11,7 +11,7 @@ maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="MIT"
 homepage="https://github.com/rfjakob/earlyoom"
 distfiles="https://github.com/rfjakob/${pkgname}/archive/v${version}.tar.gz"
-checksum=bcd3fab4da5e1dddec952a0974c866ec90c5f9159c995f9162c45488c4d03340
+checksum=227234cf9e77831c21c748bd361e1a7c415e158b96034eacd59e70586779bb6c
 CFLAGS="-DVERSION='\"${version}\"'"
 
 do_install() {

From 2acb482ed1f1fcc458546e1d4807133594733c17 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Thu, 15 Oct 2020 13:11:20 +0200
Subject: [PATCH 204/312] i2c-tools: update to 4.2.

---
 srcpkgs/i2c-tools/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/i2c-tools/template b/srcpkgs/i2c-tools/template
index 455f617545d..0c15cdfd6ed 100644
--- a/srcpkgs/i2c-tools/template
+++ b/srcpkgs/i2c-tools/template
@@ -1,16 +1,16 @@
 # Template file for 'i2c-tools'
 pkgname=i2c-tools
-version=4.1
+version=4.2
 revision=1
 build_style=gnu-makefile
 make_install_args="sbindir=/usr/bin"
 depends="perl"
 short_desc="Heterogeneous set of I2C tools"
 maintainer="Leah Neukirchen <leah@vuxu.org>"
-license="GPL-2"
+license="GPL-2.0-or-later"
 homepage="https://packages.debian.org/sid/i2c-tools"
 distfiles="${DEBIAN_SITE}/main/i/${pkgname}/${pkgname}_${version}.orig.tar.xz"
-checksum=57b219efd183795bd545dd5a60d9eabbe9dcb6f8fb92bc7ba2122b87f98527d5
+checksum=37f2dabc7082d185903ff21d1f584b5dcb4dd2eb2c879bbd8d7c50ae900dacd6
 
 i2c-tools-devel_package() {
 	short_desc+=" - development files"

From 90c81e221194c28a1a31e0389aa5946d686a08c8 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Thu, 15 Oct 2020 13:13:27 +0200
Subject: [PATCH 205/312] radvd: update to 2.19.

---
 srcpkgs/radvd/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/radvd/template b/srcpkgs/radvd/template
index fafc62bb93c..1a6ff6e0eba 100644
--- a/srcpkgs/radvd/template
+++ b/srcpkgs/radvd/template
@@ -1,6 +1,6 @@
 # Template file for 'radvd'
 pkgname=radvd
-version=2.18
+version=2.19
 revision=1
 build_style=gnu-configure
 hostmakedepends="flex"
@@ -9,7 +9,7 @@ maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="custom"
 homepage="http://www.litech.org/radvd/"
 distfiles="http://www.litech.org/radvd/dist/${pkgname}-${version}.tar.xz"
-checksum=e1bffefe6537e4b205d33afda35fec6014e5f860cc364850068a6ed9c6a65cdc
+checksum=564e04597f71a9057d02290da0dd21b592d277ceb0e7277550991d788213e240
 
 conf_files="/etc/radvd.conf"
 

From 8a20996104ccee4e6a7244c3b64ec33f1f0fd5b7 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Thu, 15 Oct 2020 13:14:37 +0200
Subject: [PATCH 206/312] wpull: remove, unmaintained, broken with Python 3.8+.

---
 srcpkgs/wpull/template | 20 --------------------
 srcpkgs/wpull/update   |  1 -
 2 files changed, 21 deletions(-)
 delete mode 100644 srcpkgs/wpull/template
 delete mode 100644 srcpkgs/wpull/update

diff --git a/srcpkgs/wpull/template b/srcpkgs/wpull/template
deleted file mode 100644
index ad1ce72103f..00000000000
--- a/srcpkgs/wpull/template
+++ /dev/null
@@ -1,20 +0,0 @@
-# Template file for 'wpull'
-pkgname=wpull
-version=2.0.3
-revision=3
-build_style=python3-module
-pycompile_module="wpull"
-hostmakedepends="python3-setuptools"
-depends="python3-chardet python3-dnspython python3-html5lib python3-lxml
- python3-namedlist python3-psutil python3-SQLAlchemy python3-tornado
- python3-Yapsy"
-short_desc="Wget-compatible web downloader and crawler"
-maintainer="Leah Neukirchen <leah@vuxu.org>"
-homepage="https://github.com/chfoo/wpull"
-license="GPL-3.0-only"
-distfiles="${homepage}/archive/v${version}.tar.gz"
-checksum=45649c2b95c1cc8f6226900c50fd1595f2aa325af5cbd1bd1c84ddc82fb414e9
-
-pre_build() {
-	sed -i 's/dnspython3/dnspython/' setup.py  # needed for dnspython>=1.13.0
-}
diff --git a/srcpkgs/wpull/update b/srcpkgs/wpull/update
deleted file mode 100644
index e9b0a0a5ea4..00000000000
--- a/srcpkgs/wpull/update
+++ /dev/null
@@ -1 +0,0 @@
-ignore="*b*"

From dc34a9c96532c7d8ca6d39dc78ea51d83b0480f2 Mon Sep 17 00:00:00 2001
From: Frank Steinborn <steinex@nognu.de>
Date: Thu, 15 Oct 2020 12:06:14 +0200
Subject: [PATCH 207/312] vegeta: update to 12.8.4.

---
 srcpkgs/vegeta/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/vegeta/template b/srcpkgs/vegeta/template
index 042c3546031..9a8b008db2e 100644
--- a/srcpkgs/vegeta/template
+++ b/srcpkgs/vegeta/template
@@ -1,6 +1,6 @@
 # Template file for 'vegeta'
 pkgname=vegeta
-version=12.8.3
+version=12.8.4
 revision=1
 wrksrc=${pkgname}-${version}
 build_style=go
@@ -10,7 +10,7 @@ maintainer="Frank Steinborn <steinex@nognu.de>"
 license="MIT"
 homepage="https://github.com/tsenart/vegeta"
 distfiles="https://$go_import_path/archive/v$version.tar.gz"
-checksum=2e6326b2fe0ef273ae784600e2181e32d307b62beb29cc84ffc8ddd0d5352df9
+checksum=418249d07f04da0a587df45abe34705166de9e54a836e27e387c719ebab3e357
 
 post_install() {
 	vlicense LICENSE

From 042acb4407f340c93132305015023909a7a9f9cb Mon Sep 17 00:00:00 2001
From: Frank Steinborn <steinex@nognu.de>
Date: Thu, 15 Oct 2020 12:04:32 +0200
Subject: [PATCH 208/312] dmidecode: update to 3.3.

---
 srcpkgs/dmidecode/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/dmidecode/template b/srcpkgs/dmidecode/template
index 045b5dc6777..b576c9dc493 100644
--- a/srcpkgs/dmidecode/template
+++ b/srcpkgs/dmidecode/template
@@ -1,13 +1,13 @@
 # Template file for 'dmidecode'
 pkgname=dmidecode
-version=3.2
+version=3.3
 revision=1
 build_style=gnu-makefile
 make_build_args="prefix=/usr sbindir=/usr/bin"
 make_install_args="prefix=/usr sbindir=/usr/bin"
 short_desc="Desktop Management Interface table related utilities"
 maintainer="Frank Steinborn <steinex@nognu.de>"
-license="GPL-2"
+license="GPL-2.0-or-later"
 homepage="http://www.nongnu.org/dmidecode"
 distfiles="${NONGNU_SITE}/${pkgname}/${pkgname}-${version}.tar.xz"
-checksum=077006fa2da0d06d6383728112f2edef9684e9c8da56752e97cd45a11f838edd
+checksum=82c737a780614c38a783e8055340d295e332fb12c7f418b5d21a0797d3fb1455

From 91f2925612ba4fe9edf6b2941436c683f20afddf Mon Sep 17 00:00:00 2001
From: Sora Morimoto <sora@morimoto.io>
Date: Thu, 15 Oct 2020 19:24:41 +0900
Subject: [PATCH 209/312] bandwhich: update to 0.20.0

Signed-off-by: Sora Morimoto <sora@morimoto.io>
---
 srcpkgs/bandwhich/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/bandwhich/template b/srcpkgs/bandwhich/template
index da3c022d55d..ee5e75f5d52 100644
--- a/srcpkgs/bandwhich/template
+++ b/srcpkgs/bandwhich/template
@@ -1,6 +1,6 @@
 # Template file for 'bandwhich'
 pkgname=bandwhich
-version=0.17.0
+version=0.20.0
 revision=1
 build_style=cargo
 short_desc="Terminal bandwidth utilization tool"
@@ -8,7 +8,7 @@ maintainer="Jan Christian Grünhage <jan.christian@gruenhage.xyz>"
 license="MIT"
 homepage="https://github.com/imsnif/bandwhich"
 distfiles="${homepage}/archive/${version}.tar.gz"
-checksum=9bcde0e10d0a601105d89fa808c0ee2c7880de40877619ae5350b9e2c9e4f343
+checksum=4bbf05be32439049edd50bd1e4d5a2a95b0be8d36782e4100732f0cc9f19ba12
 
 post_install() {
 	vlicense LICENSE.md

From e6c677c34bbb1176ab460b30ad74545b70648b04 Mon Sep 17 00:00:00 2001
From: Cameron Nemo <cnemo@tutanota.com>
Date: Mon, 12 Oct 2020 20:00:27 -0700
Subject: [PATCH 210/312] raft: update to 0.9.25

---
 srcpkgs/raft/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/raft/template b/srcpkgs/raft/template
index da6ef2c9cb0..2d27d54bc12 100644
--- a/srcpkgs/raft/template
+++ b/srcpkgs/raft/template
@@ -1,6 +1,6 @@
 # Template file for 'raft'
 pkgname=raft
-version=0.9.23
+version=0.9.25
 revision=1
 build_style=gnu-configure
 configure_args="--enable-example=no"
@@ -11,7 +11,7 @@ maintainer="Julio Galvan <juliogalvan@protonmail.com>"
 license="custom:LGPL-3.0-only-linking-exception"
 homepage="https://github.com/canonical/raft"
 distfiles="https://github.com/canonical/raft/archive/v${version}.tar.gz"
-checksum=e4bda601b1f632c2ea9ec74e59c311e773503e16b798bd07f3764244fbbfc82f
+checksum=fac55dc1cea66c7e2e6525d3be0aebedff8c31ec568efb6a911c6bb0ea99268d
 
 pre_configure() {
 	autoreconf -i

From 75f97993f4db669be49345e4aca3c9623d85e901 Mon Sep 17 00:00:00 2001
From: Cameron Nemo <cnemo@tutanota.com>
Date: Mon, 12 Oct 2020 19:38:10 -0700
Subject: [PATCH 211/312] dqlite: update to 1.6.0

---
 srcpkgs/dqlite/template | 10 +++-------
 1 file changed, 3 insertions(+), 7 deletions(-)

diff --git a/srcpkgs/dqlite/template b/srcpkgs/dqlite/template
index b638c8231d7..ed948d34356 100644
--- a/srcpkgs/dqlite/template
+++ b/srcpkgs/dqlite/template
@@ -1,20 +1,16 @@
 # Template file for 'dqlite'
 pkgname=dqlite
-version=1.5.0
+version=1.6.0
 revision=1
 build_style=gnu-configure
 hostmakedepends="pkg-config automake libtool"
-makedepends="sqlite-replication-devel raft-devel libco-devel"
-depends="sqlite-replication"
+makedepends="sqlite-devel raft-devel"
 short_desc="Distributed SQLite database using the Raft algorithm"
 maintainer="Cameron Nemo <cnemo@tutanota.com>"
 license="custom:LGPL-3.0-only-linking-exception"
 homepage="https://github.com/canonical/dqlite"
 distfiles="${homepage}/archive/v${version}.tar.gz"
-checksum=1ea4a4a70460bce98eb8d473fd642322223bfd9897f348276c4b270194e3b95f
-
-_libdir="/usr/lib/sqlite-replication"
-LDFLAGS="-L${XBPS_CROSS_BASE}${_libdir} -Wl,-R${_libdir}"
+checksum=8671396a9510c7c125e706973a8ffb2e4540ac605f1f3e9720a63876448f5d93
 
 pre_configure() {
 	autoreconf -i

From 3ee19527edc10573abb1fb69caa6634d449eb6b9 Mon Sep 17 00:00:00 2001
From: Cameron Nemo <cnemo@tutanota.com>
Date: Mon, 12 Oct 2020 20:04:04 -0700
Subject: [PATCH 212/312] lxd: update to 4.6

Closes: #25559 [via git-merge-pr]
---
 srcpkgs/lxd/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/lxd/template b/srcpkgs/lxd/template
index b0d4bbf81b2..46e8a424256 100644
--- a/srcpkgs/lxd/template
+++ b/srcpkgs/lxd/template
@@ -1,6 +1,6 @@
 # Template file for 'lxd'
 pkgname=lxd
-version=4.3
+version=4.6
 revision=1
 build_style=go
 go_import_path=github.com/lxc/lxd
@@ -15,7 +15,7 @@ maintainer="Cameron Nemo <cnemo@tutanota.com>"
 license="Apache-2.0"
 homepage="https://linuxcontainers.org/lxd"
 distfiles="https://linuxcontainers.org/downloads/lxd/lxd-${version}.tar.gz"
-checksum=b6891ee6086a2d26409385fcd50d627e6a72e0af17f88c5693c1e100ed9dca1f
+checksum=3702f5eafba6dba2ab21c2119bc74e8b55514d697c1fac80343adeea94d72e04
 system_groups="lxd"
 
 _libdir="/usr/lib/sqlite-replication"

From 0e45c2704b71d421f0b7c67c6514c07828ad5914 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Tue, 13 Oct 2020 23:11:18 +0700
Subject: [PATCH 213/312] gmic: cross compile

---
 srcpkgs/gmic/template | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/gmic/template b/srcpkgs/gmic/template
index 58498e25ea0..6d6f4ec13ba 100644
--- a/srcpkgs/gmic/template
+++ b/srcpkgs/gmic/template
@@ -4,7 +4,8 @@ version=2.8.0
 revision=1
 build_wrksrc="src"
 build_style=gnu-makefile
-hostmakedepends="pkg-config gimp"
+build_helper=qmake
+hostmakedepends="pkg-config gimp qt5-host-tools qt5-qmake"
 makedepends="fftw-devel ilmbase-devel libopenexr-devel MesaLib-devel libopencv-devel
  libgomp-devel lcms2-devel libpng-devel libjpeg-turbo-devel tiff-devel libcurl-devel
  gtk+-devel gimp-devel qt5-devel"
@@ -15,9 +16,9 @@ homepage="http://gmic.eu/"
 distfiles="http://gmic.eu/files/source/gmic_${version}.tar.gz"
 checksum=d1ca5c726f7570af3a6f0bca27eeb66ef1e6a1b6a17bdaeaf0d59be40b9cd075
 disable_parallel_build="yes"
-nocross="https://build.voidlinux.org/builders/armv7l_builder/builds/8869/steps/shell_3/logs/stdio"
 
-pre_build() {
+post_patch() {
+	vsed -i -e "s,-I[\$](USR),-I$XBPS_CROSS_BASE/usr,g" Makefile
 	# Fix library names for openexr-2.4.0
 	vsed -i Makefile -e "s;-lIlmImf -lHalf;-lIlmImf-2_4 -lHalf-2_4;"
 	# Not supported on ppc but we already compile for baselines

From 9f3efead343b36cd48a18f63a31cf39710eca9d5 Mon Sep 17 00:00:00 2001
From: Helmut Pozimski <helmut@pozimski.eu>
Date: Thu, 15 Oct 2020 17:30:59 +0200
Subject: [PATCH 214/312] monero-gui: update to 0.17.1.0.

---
 srcpkgs/monero-gui/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/monero-gui/template b/srcpkgs/monero-gui/template
index 777c197370a..a977cdb62e2 100644
--- a/srcpkgs/monero-gui/template
+++ b/srcpkgs/monero-gui/template
@@ -1,8 +1,8 @@
 # Template file for 'monero-gui'
 pkgname=monero-gui
-version=0.17.0.1
+version=0.17.1.0
 revision=1
-_monero_version=0.17.0.1
+_monero_version=0.17.1.0
 _randomx_version="1.1.8"
 # the revision monero uses as a submodule for the specific version
 _rapidjson_gitrev="129d19ba7f496df5e33658527a7158c79b99c21c"
@@ -24,8 +24,8 @@ distfiles="https://github.com/monero-project/monero-gui/archive/v${version}.tar.
  https://github.com/tevador/RandomX/archive/v${_randomx_version}.tar.gz
  https://github.com/Tencent/rapidjson/archive/${_rapidjson_gitrev}.tar.gz
  https://github.com/monero-project/supercop/archive/${_supercop_gitrev}.tar.gz"
-checksum="98324e610d04426dbac80c83ae8f5c642101d0e175d71123f42513cc45361d31
- 490f59c669992fc9bc74103dc2c82c968d07fecb6e2831d2d356575dc78862fb
+checksum="0b7a72df2056c15b48506aaaad65a41901d1c942ef6516cc1a2090777212e2a6
+ 4a8e5a4c256b20da69e7d4c50657ddb968669e5cbc449f60cd555108fe8cafd1
  f982a12d18b1d260bef2a1d3c46ae4902975fbf63abb38ca6413c96d1778db3a
  44b007d419ac21b6affec58991e865ee572346ead19b73cf1c3e4e11c7a81273
  b973b9d8269ec4d97c3c3443f0dad96d09f72b1b30e616e0947557adbdbb03f7"

From 5ce74bf875ec69f5bcd28e35b8e6d717ce56e521 Mon Sep 17 00:00:00 2001
From: Helmut Pozimski <helmut@pozimski.eu>
Date: Thu, 15 Oct 2020 17:33:28 +0200
Subject: [PATCH 215/312] linux5.4: update to 5.4.71.

---
 srcpkgs/linux5.4/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/linux5.4/template b/srcpkgs/linux5.4/template
index 30f267bebc1..154d04ce202 100644
--- a/srcpkgs/linux5.4/template
+++ b/srcpkgs/linux5.4/template
@@ -1,6 +1,6 @@
 # Template file for 'linux5.4'
 pkgname=linux5.4
-version=5.4.70
+version=5.4.71
 revision=1
 wrksrc="linux-${version}"
 short_desc="Linux kernel and modules (${version%.*} series)"
@@ -8,7 +8,7 @@ maintainer="Helmut Pozimski <helmut@pozimski.eu>"
 license="GPL-2.0-only"
 homepage="https://www.kernel.org"
 distfiles="https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-${version}.tar.xz"
-checksum=c0b3d8085c5ba235df38b00b740e053659709e8a5ca21957a239f6bc22c45007
+checksum=737049ef3cf38d46ee3b377354336cdbc1c4dd95b4e54975a70716f96c8d6cc7
 python_version=3
 patch_args="-Np1"
 

From a7ea3ed05afff0e2ecee9ca636978f4d8c32836a Mon Sep 17 00:00:00 2001
From: Helmut Pozimski <helmut@pozimski.eu>
Date: Thu, 15 Oct 2020 17:34:42 +0200
Subject: [PATCH 216/312] linux4.19: update to 4.19.151.

---
 srcpkgs/linux4.19/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/linux4.19/template b/srcpkgs/linux4.19/template
index 5dde2939ea5..6d21f5882c6 100644
--- a/srcpkgs/linux4.19/template
+++ b/srcpkgs/linux4.19/template
@@ -1,6 +1,6 @@
 # Template file for 'linux4.19'
 pkgname=linux4.19
-version=4.19.150
+version=4.19.151
 revision=1
 wrksrc="linux-${version}"
 short_desc="Linux kernel and modules (${version%.*} series)"
@@ -8,7 +8,7 @@ maintainer="Helmut Pozimski <helmut@pozimski.eu>"
 license="GPL-2.0-only"
 homepage="https://www.kernel.org"
 distfiles="https://cdn.kernel.org/pub/linux/kernel/v4.x/linux-${version}.tar.xz"
-checksum=f2f709ef086a4d8cb3c15a857daa44dfecf1b88d7d7c53c980fb180f6dccbace
+checksum=c7b134c6d45f77df0909c225300e64379d7f9d69abd9ad73ff6a289aa2b6a36e
 python_version=2 #unverified
 patch_args="-Np1"
 

From a10857fda8791e2c0b3515d54af892bd7c35f8f8 Mon Sep 17 00:00:00 2001
From: Gerardo Di iorio <arete74@gmail.com>
Date: Tue, 13 Oct 2020 08:12:28 +0200
Subject: [PATCH 217/312] cpuid: update to 20201006.

---
 srcpkgs/cpuid/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/cpuid/template b/srcpkgs/cpuid/template
index d86c4609d0f..b9df3bd7f33 100644
--- a/srcpkgs/cpuid/template
+++ b/srcpkgs/cpuid/template
@@ -1,17 +1,17 @@
 # Template file for 'cpuid'
 pkgname=cpuid
-version=20200427
+version=20201006
 revision=1
 archs="i686* x86_64*"
 build_style=gnu-makefile
 hostmakedepends="perl"
 short_desc="Linux tool to dump x86 CPUID information about the CPU(s)"
-maintainer="Orphaned <orphan@voidlinux.org>"
+maintainer="Gerardo Di Iorio  <arete74@gmail.com>"
 license="GPL-2.0-or-later"
 homepage="http://www.etallen.com/cpuid.html"
 distfiles="http://www.etallen.com/cpuid/cpuid-${version}.src.tar.gz"
-checksum=c1a9463f1f2175086120e9079e318bbd383dc1e574fafb2f724879f1d11061d4
+checksum=13c53f16408341d11ed489b352f218ec4dbb5bedb796a9d059e924770a9c56a6
 
 post_extract() {
-	sed -i 's|BUILDROOT=|BUILDROOT=${DESTDIR}|' Makefile
+	vsed -i 's|BUILDROOT=|BUILDROOT=${DESTDIR}|' Makefile
 }

From 089f788f8dfcb4135eee5affbce4f8d49d41c4b9 Mon Sep 17 00:00:00 2001
From: tkiatd <tkiatd@outlook.com>
Date: Mon, 5 Oct 2020 23:26:59 +0700
Subject: [PATCH 218/312] python3-pem: update to 20.1.0

---
 srcpkgs/python3-pem/template | 7 +++----
 1 file changed, 3 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-pem/template b/srcpkgs/python3-pem/template
index 6682e156dc2..9622282b836 100644
--- a/srcpkgs/python3-pem/template
+++ b/srcpkgs/python3-pem/template
@@ -1,10 +1,9 @@
 # Template file for 'python3-pem'
 pkgname=python3-pem
-version=19.3.0
-revision=2
+version=20.1.0
+revision=1
 wrksrc="pem-${version}"
 build_style=python3-module
-pycompile_module="pem"
 hostmakedepends="python3-setuptools"
 depends="python3"
 short_desc="Easy PEM file parsing in Python3"
@@ -12,7 +11,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://pem.readthedocs.io/en/stable/"
 distfiles="${PYPI_SITE}/p/pem/pem-${version}.tar.gz"
-checksum=d10058932ec7b9bbc81c40862275395b9faa287353a9152b642393e7efcdb526
+checksum=2763631a5ffe55f1f21fa34abafdba174a8eeb670d84f66dcfd7a523b44608f6
 
 post_install() {
 	vlicense LICENSE

From c2dc2940f0008ce3a2c63da0eadcee80a3f36e9b Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 16 Oct 2020 00:06:08 +0700
Subject: [PATCH 219/312] texlive: stop ship psutils' man-pages

---
 srcpkgs/texlive/template | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

diff --git a/srcpkgs/texlive/template b/srcpkgs/texlive/template
index 7f629ed6fb8..f416e853534 100644
--- a/srcpkgs/texlive/template
+++ b/srcpkgs/texlive/template
@@ -1,7 +1,7 @@
 # Template file for 'texlive'
 pkgname=texlive
 version=20200406
-revision=4
+revision=5
 wrksrc="texlive-${version}-source"
 build_wrksrc="build"
 build_style=gnu-configure
@@ -227,6 +227,11 @@ EOF
 }
 
 post_install() {
+	# Those pages are psutils' man-pages
+	for f in extractres includeres psbook psjoin psnup psresize psselect pstops
+	do
+		rm -f $DESTDIR/usr/share/man/man1/$f.1
+	done
 	cp -rf ${wrksrc}/texk/tests/TeXLive \
 		"${DESTDIR}/usr/share/texmf-dist/scripts/texlive"
 	sed -i -e 's:^\(TEXMFROOT *= *\)$SELFAUTOPARENT$:\1/usr/share:g' \

From 1546040dd70af988826720e945c3b0385a382412 Mon Sep 17 00:00:00 2001
From: Duncaen <duncaen@voidlinux.org>
Date: Thu, 15 Oct 2020 15:05:12 +0200
Subject: [PATCH 220/312] cppcheck: update to 2.2.

---
 srcpkgs/cppcheck/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/cppcheck/template b/srcpkgs/cppcheck/template
index e16eca1158e..b24d8eff2d7 100644
--- a/srcpkgs/cppcheck/template
+++ b/srcpkgs/cppcheck/template
@@ -1,6 +1,6 @@
 # Template file for 'cppcheck'
 pkgname=cppcheck
-version=2.1
+version=2.2
 revision=1
 build_style=gnu-makefile
 make_build_args="
@@ -18,7 +18,7 @@ license="GPL-3.0-or-later"
 homepage="http://cppcheck.sourceforge.net"
 changelog="https://sourceforge.net/p/cppcheck/news/"
 distfiles="https://github.com/danmar/cppcheck/archive/${version}.tar.gz"
-checksum=447d44bbaa555fa78b89dd2cb0203fd4c6f18269db8a78638b968ba7c72cb02e
+checksum=ad96290a1842c5934bf9c4268cb270953f3078d4ce33a9a53922d6cb6daf61aa
 
 post_install() {
 	vman cppcheck.1

From cd5ccfae646115b2cfd07eeb2f9837e6c4fa4571 Mon Sep 17 00:00:00 2001
From: Domenico Panella <domenico@VoidDomenico.localdomain>
Date: Tue, 13 Oct 2020 18:08:03 +0200
Subject: [PATCH 221/312] kio-gdrive : update to 20.08.1

---
 srcpkgs/kio-gdrive/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/kio-gdrive/template b/srcpkgs/kio-gdrive/template
index f0d678ce084..9068246a961 100644
--- a/srcpkgs/kio-gdrive/template
+++ b/srcpkgs/kio-gdrive/template
@@ -1,7 +1,7 @@
 # Template file for 'kio-gdrive'
 pkgname=kio-gdrive
-version=1.3.0
-revision=2
+version=20.08.1
+revision=1
 build_style=cmake
 hostmakedepends="extra-cmake-modules intltool pkg-config qt5-qmake qt5-host-tools
  kcoreaddons libaccounts-qt5-devel kdoctools"
@@ -11,5 +11,5 @@ short_desc="KIO slave that enables access and edit Google Drive files"
 maintainer="Piotr Wójcik <chocimier@tlen.pl>"
 license="GPL-2.0-or-later"
 homepage="https://community.kde.org/KIO_GDrive"
-distfiles="${KDE_SITE}/kio-gdrive/${version}/src/kio-gdrive-${version}.tar.xz"
-checksum=697a9382bebb6b6fdfd37cadad9c6e9516258e375704b979799447ad629f7906
+distfiles="${KDE_SITE}/release-service/${version}/src/kio-gdrive-${version}.tar.xz"
+checksum=5104136948ee60cd527109bb9e8830e6a12f6062a29f34bc995b2625b0280825

From 663cfeadd1f769fc4a8deb977a8db6d82a38832b Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Andr=C3=A9=20Cerqueira?= <acerqueira021@gmail.com>
Date: Fri, 21 Aug 2020 18:14:58 +0100
Subject: [PATCH 222/312] New package: epson-inkjet-printer-escpr2-1.1.22

---
 srcpkgs/epson-inkjet-printer-escpr2/template | 30 ++++++++++++++++++++
 1 file changed, 30 insertions(+)
 create mode 100644 srcpkgs/epson-inkjet-printer-escpr2/template

diff --git a/srcpkgs/epson-inkjet-printer-escpr2/template b/srcpkgs/epson-inkjet-printer-escpr2/template
new file mode 100644
index 00000000000..60a87ad3048
--- /dev/null
+++ b/srcpkgs/epson-inkjet-printer-escpr2/template
@@ -0,0 +1,30 @@
+# Template file for 'epson-inkjet-printer-escpr2'
+pkgname=epson-inkjet-printer-escpr2
+version=1.1.22
+revision=1
+archs="x86_64 i686 aarch64 armv7l"
+create_wrksrc=yes
+build_wrksrc=${pkgname}-${version}
+build_style=gnu-configure
+configure_args="--with-cupsfilterdir=/usr/lib/cups/filter --with-cupsppddir=/usr/share/ppd"
+hostmakedepends="automake rpmextract "
+makedepends="cups-devel ghostscript-devel"
+short_desc="Epson Inkjet Printer Driver 2 (ESC/P-R) for Linux"
+maintainer="André Cerqueira <acerqueira021@gmail.com>"
+license="custom:Proprietary"
+homepage="http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX"
+distfiles="https://download3.ebz.epson.net/dsc/f/03/00/12/02/82/a2b1cbcb5138ebca303987e685d76263c0c25e5e/${pkgname}-${version}-1lsb3.2.src.rpm"
+checksum=797c9ead379f5cbba399eaeff631e09faf1b46a9cd7a52c5dfe30481d5b7481e
+nocross="configure: error: cannot run C compiled programs"
+restricted=yes
+repository=nonfree
+
+post_extract() {
+	bsdtar xf ${pkgname}-${version}-1lsb3.2.tar.gz
+}
+
+post_install() {
+	vlicense COPYING
+	vlicense COPYING.EPSON
+	vlicense COPYING.LIB
+}

From 5f8759b0f7b3b24fe9ba9e94a39dbb8ed77a6673 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Benjam=C3=ADn=20Albi=C3=B1ana?= <benalb@gmail.com>
Date: Thu, 15 Oct 2020 18:29:57 +0200
Subject: [PATCH 223/312] exiftool: update to 12.08.

---
 srcpkgs/exiftool/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/exiftool/template b/srcpkgs/exiftool/template
index 78b75f6977a..723af13c819 100644
--- a/srcpkgs/exiftool/template
+++ b/srcpkgs/exiftool/template
@@ -1,6 +1,6 @@
 # Template file for 'exiftool'
 pkgname=exiftool
-version=12.07
+version=12.08
 revision=1
 wrksrc="Image-ExifTool-${version}"
 build_style=perl-module
@@ -13,4 +13,4 @@ license="Artistic-1.0-Perl, GPL-1.0-or-later"
 homepage="https://exiftool.org/"
 changelog="https://exiftool.org/history.html"
 distfiles="https://exiftool.org/Image-ExifTool-${version}.tar.gz"
-checksum=d6720b53de21188bca746f4f1a0c2745486c6b8d5815f93b5590551f20cbbd6a
+checksum=9a5f3fb7eb98cb97e54f18a28e13d6c63e1f62ee3392969303e83db3de7b2286

From 5493052010c897d53899a7bf15d0be76275de862 Mon Sep 17 00:00:00 2001
From: Ophidiophobia <sandstrahl700@gmx.de>
Date: Sun, 4 Oct 2020 08:35:33 +0200
Subject: [PATCH 224/312] mesa: update to 20.2.1

---
 srcpkgs/mesa/patches/add-use-elf-tls.patch |  6 +++--
 srcpkgs/mesa/patches/musl.patch            | 26 ++++++++++------------
 srcpkgs/mesa/template                      | 11 ++++++---
 3 files changed, 24 insertions(+), 19 deletions(-)

diff --git a/srcpkgs/mesa/patches/add-use-elf-tls.patch b/srcpkgs/mesa/patches/add-use-elf-tls.patch
index d5b933d586d..617d8c0e946 100644
--- a/srcpkgs/mesa/patches/add-use-elf-tls.patch
+++ b/srcpkgs/mesa/patches/add-use-elf-tls.patch
@@ -9,10 +9,12 @@ index d228de0..972cd79 100644
  endif
  
  # Android uses emutls for versions <= P/28. For USE_ELF_TLS we need ELF TLS.
--if not ['windows', 'freebsd'].contains(host_machine.system()) and (not with_platform_android or get_option('platform-sdk-version') >= 29)
+ use_elf_tls = false
+-if not ['windows', 'freebsd', 'openbsd'].contains(host_machine.system()) and (not with_platform_android or get_option('platform-sdk-version') >= 29)
 +with_use_elf_tls = get_option('use-elf-tls')
-+if not ['windows', 'freebsd'].contains(host_machine.system()) and with_use_elf_tls and (not with_platform_android or get_option('platform-sdk-version') >= 29)
++if not ['windows', 'freebsd', 'openbsd'].contains(host_machine.system()) and with_use_elf_tls and (not with_platform_android or get_option('platform-sdk-version') >= 29)
    pre_args += '-DUSE_ELF_TLS'
+   use_elf_tls = true
  endif
 
 diff --git meson_options.txt meson_options.txt
diff --git a/srcpkgs/mesa/patches/musl.patch b/srcpkgs/mesa/patches/musl.patch
index ba679adab15..f00f0f78c99 100644
--- a/srcpkgs/mesa/patches/musl.patch
+++ b/srcpkgs/mesa/patches/musl.patch
@@ -9,8 +9,8 @@
  #include "pipe/p_compiler.h"
  #include "pipe/p_state.h"
  
---- src/gallium/state_trackers/nine/threadpool.h.orig	2015-05-07 14:10:53.443337212 +0200
-+++ src/gallium/state_trackers/nine/threadpool.h	2015-05-07 14:11:04.210307653 +0200
+--- src/gallium/frontends/nine/threadpool.h.orig	2015-05-07 14:10:53.443337212 +0200
++++ src/gallium/frontends/nine/threadpool.h	2015-05-07 14:11:04.210307653 +0200
 @@ -24,6 +24,8 @@
  #ifndef _THREADPOOL_H_
  #define _THREADPOOL_H_
@@ -20,18 +20,16 @@
  #define MAXTHREADS 1
  
  struct threadpool {
---- src/util/rand_xor.c.orig	2017-06-20 00:38:57.199474067 +0200
-+++ src/util/rand_xor.c	2017-06-20 00:40:31.351279557 +0200
-@@ -23,7 +23,9 @@
-  */
- 
- #if defined(__linux__)
-+#include <sys/types.h>
- #include <sys/file.h>
-+#include <sys/stat.h>
+--- src/util/rand_xor.c.orig	2020-10-03 12:27:48.489024729 +0200
++++ src/util/rand_xor.c	2020-10-03 12:31:05.927113521 +0200
+@@ -28,6 +28,7 @@
+ #if defined(HAVE_GETRANDOM)
+ #include <sys/random.h>
+ #endif
++#include <sys/types.h>		/* size_t, ssize_t */
  #include <unistd.h>
  #include <fcntl.h>
- #else
+ #endif
 --- src/amd/vulkan/winsys/amdgpu/radv_amdgpu_winsys.h
 +++ src/amd/vulkan/winsys/amdgpu/radv_amdgpu_winsys.h
 @@ -28,6 +28,8 @@
@@ -43,8 +41,8 @@
  #include "radv_radeon_winsys.h"
  #include "ac_gpu_info.h"
  #include "addrlib/addrinterface.h"
---- src/gallium/state_trackers/nine/nine_debug.c.orig	2020-03-06 07:46:48.278918421 +0100
-+++ src/gallium/state_trackers/nine/nine_debug.c	2020-03-06 07:51:32.919964119 +0100
+--- src/gallium/frontends/nine/nine_debug.c.orig	2020-03-06 07:46:48.278918421 +0100
++++ src/gallium/frontends/nine/nine_debug.c	2020-03-06 07:51:32.919964119 +0100
 @@ -65,7 +65,7 @@ _nine_debug_printf( unsigned long flag,
  {
      static boolean first = TRUE;
diff --git a/srcpkgs/mesa/template b/srcpkgs/mesa/template
index 13de387a00b..0ec6360e0b3 100644
--- a/srcpkgs/mesa/template
+++ b/srcpkgs/mesa/template
@@ -1,6 +1,6 @@
 # Template file for 'mesa'
 pkgname=mesa
-version=20.1.9
+version=20.2.1
 revision=1
 wrksrc="mesa-${version}"
 build_style=meson
@@ -23,7 +23,7 @@ license="MIT, LGPL-2.1-or-later"
 homepage="https://www.mesa3d.org/"
 changelog="https://docs.mesa3d.org/relnotes/${version}.html"
 distfiles="https://mesa.freedesktop.org/archive/mesa-${version}.tar.xz"
-checksum=b251ca0769b722058986640d48f8457c596142cfbee1a83cba91b83391427382
+checksum=d1a46d9a3f291bc0e0374600bdcb59844fa3eafaa50398e472a36fc65fd0244a
 
 build_options="wayland"
 build_options_default="wayland"
@@ -146,6 +146,11 @@ else
 	configure_args+=" -Dgallium-vdpau=false -Dgallium-va=false -Dgallium-xvmc=false"
 fi
 
+# empty values introduced by leading comma are not allowed; the whole enumeration can be empty
+# _gallium_drivers is not affected by this problem
+_vulkan_drivers=${_vulkan_drivers/=,/=}
+_dri_drivers=${_dri_drivers/=,/=}
+
 configure_args+=" ${_gallium_drivers} ${_vulkan_drivers} ${_dri_drivers}"
 
 if [ "$_have_vulkan" ]; then
@@ -180,7 +185,7 @@ post_configure() {
 }
 
 post_install() {
-	vlicense docs/license.html
+	vlicense docs/license.rst
 	case "$XBPS_TARGET_MACHINE" in
 		i686*)
 			vsed -e 's#/usr/lib/#/usr/lib32/#g' \

From a482ba1490732e9b515668fafe9b006a1cb39a34 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Thu, 15 Oct 2020 10:05:21 -0400
Subject: [PATCH 225/312] python3-prompt_toolkit: update to 3.0.8.

---
 srcpkgs/python3-prompt_toolkit/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-prompt_toolkit/template b/srcpkgs/python3-prompt_toolkit/template
index 11fa1be366b..04e7f216796 100644
--- a/srcpkgs/python3-prompt_toolkit/template
+++ b/srcpkgs/python3-prompt_toolkit/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-prompt_toolkit'
 pkgname=python3-prompt_toolkit
-version=3.0.7
-revision=2
+version=3.0.8
+revision=1
 wrksrc="prompt_toolkit-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -12,7 +12,7 @@ maintainer="Andrew J. Hesford <ajh@sideband.org>"
 license="BSD-3-Clause"
 homepage="https://github.com/prompt-toolkit/python-prompt-toolkit"
 distfiles="${PYPI_SITE}/p/prompt_toolkit/prompt_toolkit-${version}.tar.gz"
-checksum=822f4605f28f7d2ba6b0b09a31e25e140871e96364d1d377667b547bb3bf4489
+checksum=25c95d2ac813909f813c93fde734b6e44406d1477a9faef7c915ff37d39c0a8c
 conflicts="python3-prompt_toolkit2<=2.0.9_4"
 
 do_check() {

From bce58ada68ef3bc9a7584e3e790dd82727eefcd5 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Thu, 15 Oct 2020 10:05:25 -0400
Subject: [PATCH 226/312] python3-bokeh: update to 2.2.2.

---
 srcpkgs/python3-bokeh/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-bokeh/template b/srcpkgs/python3-bokeh/template
index 2d5c49b9158..f7aef8df038 100644
--- a/srcpkgs/python3-bokeh/template
+++ b/srcpkgs/python3-bokeh/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-bokeh'
 pkgname=python3-bokeh
-version=2.2.1
-revision=3
+version=2.2.2
+revision=1
 wrksrc="${pkgname#*-}-${version}"
 build_style=python3-module
 make_build_args="--build-js"
@@ -15,7 +15,7 @@ license="BSD-3-Clause"
 homepage="https://bokeh.org"
 changelog="https://raw.githubusercontent.com/bokeh/bokeh/main/CHANGELOG"
 distfiles="https://github.com/bokeh/bokeh/archive/${version}.tar.gz"
-checksum=41a06e0b9e27ced981e68ffa664cdb7bced937c3a292486616adda56fcded933
+checksum=4d96db25b968aa240a4ffc4bee6172521b9aae9aca971b64eb7705db883026a5
 
 post_install() {
 	vlicense LICENSE.txt

From 703354ffe12e937531aff39a8a8e4cbbb0698131 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Thu, 15 Oct 2020 10:05:28 -0400
Subject: [PATCH 227/312] python3-Pillow: update to 8.0.0.

---
 srcpkgs/python3-Pillow/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-Pillow/template b/srcpkgs/python3-Pillow/template
index 841250be9f2..a67ac4a8fb1 100644
--- a/srcpkgs/python3-Pillow/template
+++ b/srcpkgs/python3-Pillow/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-Pillow'
 pkgname=python3-Pillow
-version=7.2.0
-revision=2
+version=8.0.0
+revision=1
 wrksrc="Pillow-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -14,7 +14,7 @@ license="custom:PIL"
 homepage="https://python-pillow.org"
 changelog="https://raw.githubusercontent.com/python-pillow/Pillow/master/CHANGES.rst"
 distfiles="${PYPI_SITE}/P/Pillow/Pillow-${version}.tar.gz"
-checksum=97f9e7953a77d5a70f49b9a48da7776dc51e9b738151b22dacf101641594a626
+checksum=59304c67d12394815331eda95ec892bf54ad95e0aa7bc1ccd8e0a4a5a25d4bf3
 
 post_install() {
 	vlicense LICENSE

From 4ac05d7414c5aa5af37a47c962c59fc1e6a1616a Mon Sep 17 00:00:00 2001
From: Abigail G <dev@kb6.ee>
Date: Thu, 15 Oct 2020 17:35:00 -0400
Subject: [PATCH 228/312] New package: chezmoi-1.8.7

---
 srcpkgs/chezmoi/template | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
 create mode 100644 srcpkgs/chezmoi/template

diff --git a/srcpkgs/chezmoi/template b/srcpkgs/chezmoi/template
new file mode 100644
index 00000000000..90cc4b661f3
--- /dev/null
+++ b/srcpkgs/chezmoi/template
@@ -0,0 +1,25 @@
+# Template file for 'chezmoi'
+pkgname=chezmoi
+version=1.8.7
+revision=1
+build_style=go
+go_import_path="github.com/twpayne/chezmoi"
+go_build_tags="noembeddocs noupgrade"
+go_ldflags="-X main.version=${version} -X main.commit=v${version} -X main.builtBy=xbps -X github.com/twpayne/chezmoi/cmd.DocsDir=/usr/share/doc/chezmoi"
+hostmakedepends="git"
+short_desc="Manage your dotfiles across multiple machines, securely"
+maintainer="Abigail G <dev@kb6.ee>"
+license="MIT"
+homepage="https://chezmoi.io/"
+distfiles="https://github.com/twpayne/${pkgname}/archive/v${version}.tar.gz"
+checksum=65800222506317ae0c419aec9e9daafe577b6c668490031453fd53f813788668
+
+post_install() {
+	vlicense LICENSE
+
+	for f in docs/*; do vdoc $f; done
+
+	vcompletion completions/chezmoi-completion.bash bash chezmoi
+	vcompletion completions/chezmoi.fish fish chezmoi
+	vcompletion completions/chezmoi.zsh zsh chezmoi
+}

From fda63ff63bf5c3883189615b175d1d79bc98b3ad Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?J=C3=BCrgen=20Buchm=C3=BCller?= <pullmoll@t-online.de>
Date: Fri, 16 Oct 2020 13:28:35 +0200
Subject: [PATCH 229/312] xf86-video-intel: update to 2.99.917.20200515

---
 srcpkgs/xf86-video-intel/template | 12 +++++++-----
 1 file changed, 7 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/xf86-video-intel/template b/srcpkgs/xf86-video-intel/template
index bf7ebbc28fd..a7408b88c10 100644
--- a/srcpkgs/xf86-video-intel/template
+++ b/srcpkgs/xf86-video-intel/template
@@ -1,8 +1,8 @@
 # Template file for 'xf86-video-intel'
 pkgname=xf86-video-intel
-version=2.99.917.899
-revision=2
-_commit=f66d39544bb8339130c96d282a80f87ca1606caf
+version=2.99.917.20200515
+revision=1
+_commit=5ca3ac1a90af177eb111a965e9b4dd8a27cc58fc
 archs="i686* x86_64*"
 build_style=gnu-configure
 configure_args="--with-default-dri=3"
@@ -20,9 +20,11 @@ CFLAGS="-fcommon"
 LDFLAGS="-Wl,-z,lazy"
 
 do_fetch() {
-	git clone https://gitlab.freedesktop.org/xorg/driver/xf86-video-intel ${wrksrc}
+	git clone --single-branch \
+		https://gitlab.freedesktop.org/xorg/driver/xf86-video-intel.git \
+		${wrksrc}
 	cd ${wrksrc}
-	git reset --hard $_commit
+	git reset --hard ${_commit}
 }
 
 pre_configure() {

From f675aa1501416001f1846a37772dc1140e800e33 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Thu, 15 Oct 2020 22:03:49 -0400
Subject: [PATCH 230/312] cpp-utilities: update to 5.7.0.

---
 srcpkgs/cpp-utilities/template | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/cpp-utilities/template b/srcpkgs/cpp-utilities/template
index d5349fb989f..e4da16a6f28 100644
--- a/srcpkgs/cpp-utilities/template
+++ b/srcpkgs/cpp-utilities/template
@@ -1,15 +1,16 @@
 # Template file for 'cpp-utilities'
 pkgname=cpp-utilities
-version=5.6.0
+version=5.7.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_SHARED_LIBS:BOOL=ON"
+hostmakedepends="pkg-config"
 short_desc="C++ library for argument parsing, IO, parsing and more"
 maintainer="Andrew J. Hesford <ajh@sideband.org>"
 license="GPL-2.0-only"
 homepage="https://github.com/Martchus/cpp-utilities"
 distfiles="https://github.com/Martchus/${pkgname}/archive/v${version}.tar.gz"
-checksum=31fd1de5279c1267c049bf8d900a85d38af11d3c8757a934e694dab46f52fc56
+checksum=971f0b6f3474411215190867250f619db5728dad4e3e7834b3761a14d4477f7c
 
 cpp-utilities-devel_package() {
 	short_desc+=" - development files"

From 6809867c63b2c0a4ae0516f5ffafd9907a889294 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Thu, 15 Oct 2020 22:05:02 -0400
Subject: [PATCH 231/312] qtutilities: update to 6.3.0.

---
 srcpkgs/qtutilities/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/qtutilities/template b/srcpkgs/qtutilities/template
index a596942c72b..92aa0b72668 100644
--- a/srcpkgs/qtutilities/template
+++ b/srcpkgs/qtutilities/template
@@ -1,6 +1,6 @@
 # Template file for 'qtutilities'
 pkgname=qtutilities
-version=6.2.1
+version=6.3.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_SHARED_LIBS:BOOL=ON"
@@ -11,7 +11,7 @@ maintainer="Andrew J. Hesford <ajh@sideband.org>"
 license="GPL-2.0-only"
 homepage="https://github.com/Martchus/qtutilities"
 distfiles="https://github.com/Martchus/${pkgname}/archive/v${version}.tar.gz"
-checksum=5b5fcf7380dde168c9e4e023b66788dd80c72c59a6e1258e2fdff50366280adc
+checksum=e58f571d69e357b877a575b95aea82d6ed32043cefcc7f59c8c6f7cf513a6ccd
 
 qtutilities-devel_package() {
 	short_desc+=" - development files"

From d8a4edf272ecfd90ea71f0a527219c302b16ebeb Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Thu, 15 Oct 2020 22:06:18 -0400
Subject: [PATCH 232/312] tagparser: update to 9.3.0.

---
 srcpkgs/tagparser/template | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/tagparser/template b/srcpkgs/tagparser/template
index 00772e2b644..b020382cbf1 100644
--- a/srcpkgs/tagparser/template
+++ b/srcpkgs/tagparser/template
@@ -1,16 +1,17 @@
 # Template file for 'tagparser'
 pkgname=tagparser
-version=9.2.0
+version=9.3.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_SHARED_LIBS:BOOL=ON"
-makedepends="cpp-utilities-devel zlib-devel"
+hostmakedepends="pkg-config"
+makedepends="cpp-utilities-devel zlib-devel libressl-devel"
 short_desc="C++ library for handling AAC, ID3, Vorbis, Opus, FLAC and Matroska tags"
 maintainer="Andrew J. Hesford <ajh@sideband.org>"
 license="GPL-2.0-only"
 homepage="https://github.com/Martchus/tagparser"
 distfiles="https://github.com/Martchus/${pkgname}/archive/v${version}.tar.gz"
-checksum=05538d4e034f5f008f1b253b7612b6519bb98d566347045bc3b76d5a3b5a7830
+checksum=5aa10fee7019bcd88053bea8a805379e07e257121eb1b06a7c2c8a6c86576dc6
 
 tagparser-devel_package() {
 	short_desc+=" - development files"

From 0de0637031777cdaaaf7e2fe981b85c4738736e9 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Thu, 15 Oct 2020 22:08:37 -0400
Subject: [PATCH 233/312] tageditor: update to 3.3.9.

---
 srcpkgs/tageditor/template | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/tageditor/template b/srcpkgs/tageditor/template
index 797e8ab9409..01470e4ac84 100644
--- a/srcpkgs/tageditor/template
+++ b/srcpkgs/tageditor/template
@@ -1,16 +1,17 @@
 # Template file for 'tageditor'
 pkgname=tageditor
-version=3.3.8
+version=3.3.9
 revision=1
 build_style=cmake
 configure_args="-DBUILD_SHARED_LIBS:BOOL=ON"
+hostmakedepends="pkg-config"
 makedepends="tagparser-devel cpp-utilities-devel"
 short_desc="Tag editor for AAC, ID3, Vorbis, Opus, FLAC and Matroska"
 maintainer="Andrew J. Hesford <ajh@sideband.org>"
 license="GPL-2.0-only"
 homepage="https://github.com/Martchus/tageditor"
 distfiles="https://github.com/Martchus/${pkgname}/archive/v${version}.tar.gz"
-checksum=6ad8f190ca0f2133c3a0cd508248329a80abc89a20629c20e0c2835329e2812c
+checksum=1ab9f843788046834ded52b99606908fde9327ca975376418ebf44139ca522ba
 
 build_options="qt webengine webkit script"
 build_options_default="qt"

From f7ee92d7bd766f0acc39fb47dd3e3199f0de6d26 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Thu, 15 Oct 2020 21:42:36 -0400
Subject: [PATCH 234/312] protobuf24: update to 3.13.0.1.

---
 srcpkgs/protobuf24/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/protobuf24/template b/srcpkgs/protobuf24/template
index 872c4cfa97f..220137e1040 100644
--- a/srcpkgs/protobuf24/template
+++ b/srcpkgs/protobuf24/template
@@ -1,7 +1,7 @@
 # Template file for 'protobuf24'
 pkgname=protobuf24
-version=3.13.0
-revision=2
+version=3.13.0.1
+revision=1
 wrksrc="protobuf-${version}"
 build_style=gnu-configure
 hostmakedepends="pkg-config automake libtool"
@@ -12,7 +12,7 @@ license="BSD-3-Clause"
 homepage="https://developers.google.com/protocol-buffers/"
 changelog="https://raw.githubusercontent.com/google/protobuf/master/CHANGES.txt"
 distfiles="https://github.com/protocolbuffers/protobuf/archive/v${version}.tar.gz"
-checksum=9b4ee22c250fe31b16f1a24d61467e40780a3fbb9b91c3b65be2a376ed913a1a
+checksum=7d663c8dc81d282dc92e884b38e9c179671e31ccacce311154420e65f7d142c6
 
 # Switch to versioned package
 conflicts="protobuf18>=0 protobuf23>=0"

From d10e2952ad8b229514b6950f62bc4bb372323347 Mon Sep 17 00:00:00 2001
From: Frank Steinborn <steinex@nognu.de>
Date: Fri, 16 Oct 2020 14:14:50 +0200
Subject: [PATCH 235/312] xterm: update to 361.

Closes: #25654 [via git-merge-pr]
---
 srcpkgs/xterm/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/xterm/template b/srcpkgs/xterm/template
index 62d2e0f5985..5ece04ebed9 100644
--- a/srcpkgs/xterm/template
+++ b/srcpkgs/xterm/template
@@ -1,6 +1,6 @@
 # Template file for 'xterm'
 pkgname=xterm
-version=360
+version=361
 revision=1
 build_style=gnu-configure
 configure_args="--enable-wide-chars --enable-88-color --enable-broken-osc
@@ -20,7 +20,7 @@ license="MIT"
 homepage="http://invisible-island.net/xterm/"
 changelog="http://invisible-island.net/xterm/xterm.log.html"
 distfiles="https://invisible-mirror.net/archives/xterm/xterm-${version}.tgz"
-checksum=a5f6e1f1de01fa9fddf132d9fb7a9a749a411f1e77ee6a7fdf1c8c0c1db80dba
+checksum=85610f20d5e47205cc1b6876f7a4da28d6ae051bd8eac0b932e92c37a73a623f
 
 post_install() {
 	for f in {u,}xterm.desktop; do

From 2847a420184919a973f4884e4f1e6c836cd81024 Mon Sep 17 00:00:00 2001
From: Ramdziana F Y <ramdzian@gmail.com>
Date: Fri, 16 Oct 2020 21:17:21 +0700
Subject: [PATCH 236/312] vivaldi: update to 3.4.2066.76

Closes: #25656 [via git-merge-pr]
---
 srcpkgs/vivaldi/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/vivaldi/template b/srcpkgs/vivaldi/template
index c5b2dfc7307..97682c73362 100644
--- a/srcpkgs/vivaldi/template
+++ b/srcpkgs/vivaldi/template
@@ -1,6 +1,6 @@
 # Template file for 'vivaldi'
 pkgname=vivaldi
-version=3.3.2022.47
+version=3.4.2066.76
 revision=1
 _release=1
 archs="i686 x86_64"
@@ -18,10 +18,10 @@ nostrip=yes
 
 if [ "$XBPS_TARGET_MACHINE" = "x86_64" ]; then
 	_debarch=amd64
-	checksum=7f1fec43720935f1a945a9b0cbe05b1a150d92d7825747119c0ae5b270a42a53
+	checksum=f9d457943b40e2bd4edd6d7d6cf069bd9cb690b5da60f7ec314837840194abfa
 else
 	_debarch=i386
-	checksum=57d502ab896b41d45654db632e64fecee088069d8418183f5e9010a47c2cd533
+	checksum=2f14886f922c7cce8dc274b6b51472966262361aa53a4401c9e01532a49ee02e
 fi
 
 distfiles="https://downloads.vivaldi.com/stable/vivaldi-stable_${version}-${_release}_${_debarch}.deb"

From fe744458091b3b7b826d764bf9100226da380c0b Mon Sep 17 00:00:00 2001
From: Paper <paper@tilde.institute>
Date: Thu, 15 Oct 2020 23:46:57 +0200
Subject: [PATCH 237/312] python3-gobject: update to 3.38.0

Closes: #25645 [via git-merge-pr]
---
 srcpkgs/python3-gobject/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-gobject/template b/srcpkgs/python3-gobject/template
index 45e557faf82..219749a5acb 100644
--- a/srcpkgs/python3-gobject/template
+++ b/srcpkgs/python3-gobject/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-gobject'
 pkgname=python3-gobject
-version=3.36.1
-revision=2
+version=3.38.0
+revision=1
 wrksrc="pygobject-${version}"
 build_style=meson
 build_helper="gir"
@@ -14,7 +14,7 @@ maintainer="Enno Boland <gottox@voidlinux.org>"
 license="LGPL-2.1-or-later"
 homepage="https://pygobject.readthedocs.io/"
 distfiles="${GNOME_SITE}/pygobject/${version%.*}/pygobject-${version}.tar.xz"
-checksum=d1bf42802d1cec113b5adaa0e7bf7f3745b44521dc2163588d276d5cd61d718f
+checksum=0372d1bb9122fc19f500a249b1f38c2bb67485000f5887497b4b205b3e7084d5
 
 python3-gobject-devel_package() {
 	depends="libgirepository-devel python3-cairo-devel

From 7670ba01ff2cf7e43c829a6ef88789bb12d37ec8 Mon Sep 17 00:00:00 2001
From: Urs Schulz <voidpkgs@ursschulz.de>
Date: Fri, 25 Sep 2020 12:19:25 +0200
Subject: [PATCH 238/312] perl-Mojolicious: update to 8.59.

Closes: #25643 [via git-merge-pr]
---
 srcpkgs/perl-Mojolicious/template | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/perl-Mojolicious/template b/srcpkgs/perl-Mojolicious/template
index 14cf2b6160e..b0946412136 100644
--- a/srcpkgs/perl-Mojolicious/template
+++ b/srcpkgs/perl-Mojolicious/template
@@ -1,8 +1,7 @@
 # Template file for 'perl-Mojolicious'
 pkgname=perl-Mojolicious
-version=8.42
+version=8.59
 revision=1
-archs=noarch
 wrksrc="${pkgname//perl-/}-${version}"
 build_style=perl-module
 hostmakedepends="perl"
@@ -12,4 +11,4 @@ maintainer="Urs Schulz <voidpkgs@ursschulz.de>"
 license="Artistic-1.0-Perl, GPL-1.0-or-later"
 homepage="https://metacpan.org/release/Mojolicious"
 distfiles="${CPAN_SITE}/${pkgname//perl-/}/${pkgname//perl-/}-${version}.tar.gz"
-checksum=f61ceb04565714d18915b12d90bfda069286c7244d5545e811970d103aab3ff9
+checksum=02e43fec088c4fc2ad0a9eaec51c4500bb1976dd97f43be58f1e5b03c74b0197

From 126b57dac4a0fc5d4f9426840d188c4d18269d34 Mon Sep 17 00:00:00 2001
From: Urs Schulz <voidpkgs@ursschulz.de>
Date: Fri, 25 Sep 2020 13:10:02 +0200
Subject: [PATCH 239/312] bCNC: update to 0.9.14.307.

Closes: #25642 [via git-merge-pr]
---
 srcpkgs/bCNC/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/bCNC/template b/srcpkgs/bCNC/template
index 97abf12b4f7..bffca03f61f 100644
--- a/srcpkgs/bCNC/template
+++ b/srcpkgs/bCNC/template
@@ -1,7 +1,7 @@
 # Template file for 'bCNC'
 pkgname=bCNC
-version=0.9.14.306
-revision=3
+version=0.9.14.307
+revision=1
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-pyserial python3-Pillow python3-tkinter python3-numpy python3-scipy"
@@ -10,7 +10,7 @@ maintainer="Urs Schulz <voidpkgs@ursschulz.de>"
 license="GPL-2.0-only"
 homepage="https://github.com/vlachoudis/bCNC"
 distfiles="${PYPI_SITE}/b/${pkgname}/${pkgname}-${version}.tar.gz"
-checksum=3af8590e3d2b6320fc1d0db019ba5584736c7a30dd205de531656f6d8f3b04cc
+checksum=005c3f2a0b244abab81dc3f6df2001f530db655165611165e7009e28b94cda5f
 
 post_install() {
 	vmkdir usr/share/applications

From 65bca5be483ca7ef7417f7151e5b5fa75a33cdaa Mon Sep 17 00:00:00 2001
From: Felix Van der Jeugt <felix.vanderjeugt@posteo.net>
Date: Thu, 15 Oct 2020 15:03:44 +0200
Subject: [PATCH 240/312] qutebrowser: update to 1.14.0

Closes: #25635 [via git-merge-pr]
---
 srcpkgs/qutebrowser/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/qutebrowser/template b/srcpkgs/qutebrowser/template
index ef7e343d368..e8c3da508ca 100644
--- a/srcpkgs/qutebrowser/template
+++ b/srcpkgs/qutebrowser/template
@@ -1,7 +1,7 @@
 # Template file for 'qutebrowser'
 pkgname=qutebrowser
-version=1.13.1
-revision=3
+version=1.14.0
+revision=1
 build_style=python3-module
 hostmakedepends="python3-setuptools asciidoc"
 depends="python3-PyQt5-quick python3-Jinja2 python3-Pygments python3-pyPEG2
@@ -13,7 +13,7 @@ license="GPL-3.0-or-later"
 homepage="https://qutebrowser.org/"
 changelog="https://raw.githubusercontent.com/qutebrowser/qutebrowser/master/doc/changelog.asciidoc"
 distfiles="https://github.com/qutebrowser/qutebrowser/releases/download/v${version}/qutebrowser-${version}.tar.gz"
-checksum=2896851f07c6258cf8991975eed200ca8477ae393a6a7a40249035b2f36ee2d8
+checksum=76eb14097bab873ffae73bb4d017b4d22aa5c4604d45f0b9570dfaed4720374a
 nostrip=yes
 
 build_options="webengine"

From 6a25d87275fafe84a4bddff301f60a01e3dadbec Mon Sep 17 00:00:00 2001
From: tkiatd <tkiatd@outlook.com>
Date: Mon, 5 Oct 2020 22:01:34 +0700
Subject: [PATCH 241/312] python-urwid: update to 2.1.2

Closes: #25636 [via git-merge-pr]
---
 srcpkgs/python-urwid/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python-urwid/template b/srcpkgs/python-urwid/template
index 7250dfc3306..b7eb4393a54 100644
--- a/srcpkgs/python-urwid/template
+++ b/srcpkgs/python-urwid/template
@@ -1,7 +1,7 @@
 # Template file for 'python-urwid'
 pkgname=python-urwid
-version=2.1.0
-revision=2
+version=2.1.2
+revision=1
 wrksrc="urwid-${version}"
 build_style="python-module"
 hostmakedepends="python-setuptools python3-setuptools"
@@ -12,7 +12,7 @@ license="LGPL-2.1-or-later"
 homepage="http://urwid.org/"
 changelog="https://raw.githubusercontent.com/urwid/urwid/master/docs/changelog.rst"
 distfiles="${PYPI_SITE}/u/urwid/urwid-${version}.tar.gz"
-checksum=0896f36060beb6bf3801cb554303fef336a79661401797551ba106d23ab4cd86
+checksum=588bee9c1cb208d0906a9f73c613d2bd32c3ed3702012f51efe318a3f2127eae
 
 python3-urwid_package() {
 	short_desc="${short_desc/Python2/Python3}"

From 2fbd8a8f31e3878bcc4408baa327338fbb8b64d9 Mon Sep 17 00:00:00 2001
From: Olaf Mersmann <olafm@p-value.net>
Date: Wed, 14 Oct 2020 11:52:07 +0200
Subject: [PATCH 242/312] vdirsyncer: cherry pick Python 3.9 fixes.

---
 ...01-Update-usage-of-deprecated-method.patch | 19 +++++++++++++++++++
 srcpkgs/vdirsyncer/template                   |  2 +-
 2 files changed, 20 insertions(+), 1 deletion(-)
 create mode 100644 srcpkgs/vdirsyncer/patches/0001-Update-usage-of-deprecated-method.patch

diff --git a/srcpkgs/vdirsyncer/patches/0001-Update-usage-of-deprecated-method.patch b/srcpkgs/vdirsyncer/patches/0001-Update-usage-of-deprecated-method.patch
new file mode 100644
index 00000000000..cf140da496e
--- /dev/null
+++ b/srcpkgs/vdirsyncer/patches/0001-Update-usage-of-deprecated-method.patch
@@ -0,0 +1,19 @@
+Source: Upstream
+Upstream: Yes
+Reason: Python 3.9 compatibility fix.
+diff --git a/vdirsyncer/storage/dav.py b/vdirsyncer/storage/dav.py
+index 07d164f..a7e2422 100644
+--- vdirsyncer/storage/dav.py
++++ vdirsyncer/storage/dav.py
+@@ -124,7 +124,7 @@ def _merge_xml(items):
+         return None
+     rv = items[0]
+     for item in items[1:]:
+-        rv.extend(item.getiterator())
++        rv.extend(item.iter())
+     return rv
+ 
+ 
+-- 
+2.28.0
+
diff --git a/srcpkgs/vdirsyncer/template b/srcpkgs/vdirsyncer/template
index d791cb2edd0..906b77950d3 100644
--- a/srcpkgs/vdirsyncer/template
+++ b/srcpkgs/vdirsyncer/template
@@ -1,7 +1,7 @@
 # Template file for 'vdirsyncer'
 pkgname=vdirsyncer
 version=0.16.8
-revision=2
+revision=3
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-atomicwrites python3-click python3-click-log

From 2ed37234bb1b16e06e710a53efb95dd69b118379 Mon Sep 17 00:00:00 2001
From: Paper <paper@tilde.institute>
Date: Mon, 12 Oct 2020 21:40:06 +0200
Subject: [PATCH 243/312] python3-Markdown: update to 3.3.1

Closes: #25549 [via git-merge-pr]
---
 srcpkgs/python3-Markdown/template | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-Markdown/template b/srcpkgs/python3-Markdown/template
index ef11fca0c8e..be2efb5fadd 100644
--- a/srcpkgs/python3-Markdown/template
+++ b/srcpkgs/python3-Markdown/template
@@ -1,17 +1,18 @@
 # Template file for 'python3-Markdown'
 pkgname=python3-Markdown
-version=3.2.2
-revision=2
+version=3.3.1
+revision=1
 wrksrc="Markdown-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-setuptools"
+checkdepends="python3-yaml"
 short_desc="Python3 implementation of John Gruber's Markdown"
 maintainer="Peter Bui <pbui@github.bx612.space>"
 license="BSD-3-Clause"
-homepage="https://github.com/waylan/Python-Markdown"
+homepage="https://github.com/Python-Markdown/markdown"
 distfiles="${PYPI_SITE}/M/Markdown/Markdown-${version}.tar.gz"
-checksum=1fafe3f1ecabfb514a5285fca634a53c1b32a81cb0feb154264d55bf2ff22c17
+checksum=c3ce9ebb035c078cac0f2036068d054e7dc34354eeecc49c173c33c96b124af6
 alternatives="markdown:markdown_py:/usr/bin/markdown_py3"
 
 post_install() {

From 2d3ea95a946b4997861fe9bbf249e4797bd91a21 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Fri, 16 Oct 2020 12:09:39 -0400
Subject: [PATCH 244/312] tox: update to 3.20.1.

---
 srcpkgs/tox/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/tox/template b/srcpkgs/tox/template
index 214ed60a03d..4354e586e24 100644
--- a/srcpkgs/tox/template
+++ b/srcpkgs/tox/template
@@ -1,7 +1,7 @@
 # Template file for 'tox'
 pkgname=tox
-version=3.19.0
-revision=2
+version=3.20.1
+revision=1
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-filelock python3-packaging
@@ -13,7 +13,7 @@ license="MIT"
 homepage="https://tox.readthedocs.io/en/latest/"
 changelog="https://tox.readthedocs.io/en/latest/changelog.html"
 distfiles="${PYPI_SITE}/t/tox/tox-${version}.tar.gz"
-checksum=17e61a93afe5c49281fb969ab71f7a3f22d7586d1c56f9a74219910f356fe7d3
+checksum=4321052bfe28f9d85082341ca8e233e3ea901fdd14dab8a5d3fbd810269fbaf6
 
 post_install() {
 	vlicense LICENSE

From a43d6a4984630c27ac66caedd2e22dd2473f03b9 Mon Sep 17 00:00:00 2001
From: Aleksey Tulinov <aleksey.tulinov@gmail.com>
Date: Thu, 15 Oct 2020 23:19:39 +0300
Subject: [PATCH 245/312] cross-x86_64-w64-mingw32: update to 8.0.0

[ci skip]
---
 srcpkgs/cross-x86_64-w64-mingw32/template | 44 +++++++++++------------
 1 file changed, 22 insertions(+), 22 deletions(-)

diff --git a/srcpkgs/cross-x86_64-w64-mingw32/template b/srcpkgs/cross-x86_64-w64-mingw32/template
index 0711aae3637..3db21abb692 100644
--- a/srcpkgs/cross-x86_64-w64-mingw32/template
+++ b/srcpkgs/cross-x86_64-w64-mingw32/template
@@ -1,17 +1,17 @@
 # Template file for 'cross-x86_64-w64-mingw32'
-_gcc_version=9.3.0
-_binutils_version=2.32
-_gmp_version=6.1.2
-_mpfr_version=4.0.1
+_gcc_version=10.2.0
+_binutils_version=2.34
+_gmp_version=6.2.0
+_mpfr_version=4.1.0
 _mpc_version=1.1.0
-_isl_version=0.19
-_mingw_version=6.0.0
+_isl_version=0.21
+_mingw_version=8.0.0
 
 pkgname=cross-x86_64-w64-mingw32
 version=$_mingw_version
-revision=5
+revision=1
 create_wrksrc=yes
-hostmakedepends="flex perl python3 tar"
+hostmakedepends="tar flex perl texinfo"
 makedepends="zlib-devel"
 # it's ok to build with current's -devel packages
 # although it might break the package during compiler updates
@@ -22,20 +22,20 @@ maintainer="Aleksey Tulinov <aleksey.tulinov@gmail.com>"
 homepage="https://sourceforge.net/projects/mingw-w64/"
 license="GPL-2.0-or-later, GPL-3.0-or-later, ZPL-2.1"
 distfiles="
- ${GNU_SITE}/binutils/binutils-${_binutils_version}.tar.bz2
+ ${GNU_SITE}/binutils/binutils-${_binutils_version}.tar.xz
  ${GNU_SITE}/gcc/gcc-${_gcc_version}/gcc-${_gcc_version}.tar.xz
  ${GNU_SITE}/mpc/mpc-${_mpc_version}.tar.gz
- https://gmplib.org/download/gmp/gmp-${_gmp_version}.tar.xz
- http://www.mpfr.org/mpfr-${_mpfr_version}/mpfr-${_mpfr_version}.tar.xz
+ ${GNU_SITE}/gmp/gmp-${_gmp_version}.tar.xz
+ ${GNU_SITE}/mpfr/mpfr-${_mpfr_version}.tar.xz
  http://isl.gforge.inria.fr/isl-${_isl_version}.tar.bz2
  ${SOURCEFORGE_SITE}/project/mingw-w64/mingw-w64/mingw-w64-release/mingw-w64-v${_mingw_version}.tar.bz2"
-checksum="de38b15c902eb2725eac6af21183a5f34ea4634cb0bcef19612b50e5ed31072d
- 71e197867611f6054aa1119b13a0c0abac12834765fe2d81f35ac57f84f742d1
+checksum="f00b0e8803dc9bab1e2165bd568528135be734df3fabf8d0161828cd56028952
+ b8dd4368bb9c7f0b98188317ee0254dd8cc99d1e3a18d0ff146c855fe16c1d8c
  6985c538143c1208dcb1ac42cedad6ff52e267b47e5f970183a3e75125b43c2e
- 87b565e89a9a684fe4ebeeddb8399dce2599f9c9049854ca8c0dfbdea0e21912
- 67874a60826303ee2fb6affc6dc0ddd3e749e9bfcb4c8655e3953d0458a6e16e
- d59726f34f7852a081fbd3defd1ab2136f174110fc2e0c8d10bb122173fa9ed8
- 805e11101e26d7897fce7d49cbb140d7bac15f3e085a91e0001e80b2adaf48f0"
+ 258e6cd51b3fbdfc185c716d55f82c08aff57df0c6fbd143cf6ed561267a1526
+ 0c98a3f1732ff6ca4ea690552079da9c597872d30e96ec28414ee23c95558a7f
+ d18ca11f8ad1a39ab6d03d3dcb3365ab416720fcb65b42d69f34f51bf0a0e859
+ 44c740ea6ab3924bc3aa169bad11ad3c5766c5c8459e3126d44eabb8735a5762"
 
 nocross=yes
 nopie=yes
@@ -46,7 +46,7 @@ lib32disabled=yes  # disable build of 32bits packages
 nostrip_files="libgcc.a libgcc_eh.a libgcc_s.a libgcov.a
  libatomic.a libatomic.dll.a libquadmath.a libquadmath.dll.a
  libssp.a libssp.dll.a libssp_nonshared.a
- libstdc++.a libstdc++.dll.a libsupc++.a"
+ libstdc++.a libstdc++.dll.a libstdc++fs.a libsupc++.a"
 
 # https://sourceforge.net/p/mingw-w64/wiki2/Cross%20Win32%20and%20Win64%20compiler/
 # https://gcc.gnu.org/install/configure.html
@@ -269,7 +269,7 @@ cross-x86_64-w64-mingw32-crt_package() {
 	# this subpackage exists to skip strip step on CRT files
 	nostrip=yes
 	noverifyrdeps=yes
-	noshlibsprovides=yes
+	noshlibprovides=yes
 	lib32disabled=yes
 	pkg_install() {
 		DESTDIR="$PKGDESTDIR" _install_crt "x86_64-w64-mingw32"
@@ -282,12 +282,12 @@ cross-i686-w64-mingw32_package() {
 	nopie=yes
 	nodebug=yes
 	noverifyrdeps=yes
-	noshlibsprovides=yes
+	noshlibprovides=yes
 	lib32disabled=yes
 	nostrip_files="libgcc.a libgcc_eh.a libgcc_s.a libgcov.a
 	 libatomic.a libatomic.dll.a libquadmath.a libquadmath.dll.a
 	 libssp.a libssp.dll.a libssp_nonshared.a
-	 libstdc++.a libstdc++.dll.a libsupc++.a"
+	 libstdc++.a libstdc++.dll.a libstdc++fs.a libsupc++.a"
 	pkg_install() {
 		DESTDIR="$PKGDESTDIR" _install_toolchain "i686-w64-mingw32"
 	}
@@ -299,7 +299,7 @@ cross-i686-w64-mingw32-crt_package() {
 	nodebug=yes
 	nostrip=yes
 	noverifyrdeps=yes
-	noshlibsprovides=yes
+	noshlibprovides=yes
 	lib32disabled=yes
 	pkg_install() {
 		DESTDIR="$PKGDESTDIR" _install_crt "i686-w64-mingw32"

From 7705481975c8a1276d618d015e9d80dc3309cabd Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Fri, 16 Oct 2020 12:40:30 -0400
Subject: [PATCH 246/312] sane: remove incorrect shlib-provides

Without noshlibprovides in the main package, xbps-src detects every
driver in /usr/lib/sane with an incorrect soname of libsane.so.1 and
adds libsane.so.1 to the shlib-provides list for that package. This
allows ignorepkg=libsane to prevent installation (or allow removal) of
the package that actually installs this shlib, breaking everything that
depends on it. When sane does not provide libsane.so.1, libsane will not
be removable or ignorable when anything depends on the shlib.
---
 srcpkgs/sane/template | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/srcpkgs/sane/template b/srcpkgs/sane/template
index 4812273c94d..aaaf65d5d2d 100644
--- a/srcpkgs/sane/template
+++ b/srcpkgs/sane/template
@@ -2,7 +2,7 @@
 pkgname=sane
 _gitlab_release_hash=8bf1cae2e1803aefab9e5331550e5d5d
 version=1.0.31
-revision=1
+revision=2
 wrksrc="sane-backends-${version}"
 build_style=gnu-configure
 configure_args="--disable-locking --enable-ipv6 --enable-pthread
@@ -20,6 +20,7 @@ license="GPL-2.0-or-later, SANE-exception"
 homepage="http://www.sane-project.org/"
 distfiles="https://gitlab.com/sane-project/backends/uploads/${_gitlab_release_hash}/sane-backends-${version}.tar.gz"
 checksum=4a3b10fcb398ed854777d979498645edfe66fcac2f2fd2b9117a79ff45e2a5aa
+noshlibprovides="avoid false detection of device drivers"
 
 build_options="snmp"
 

From 8f10d4ac224e7bc4cc1d3a967f554f507d666690 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C3=89rico=20Rolim?= <erico.erc@gmail.com>
Date: Fri, 16 Oct 2020 14:55:22 -0300
Subject: [PATCH 247/312] chezmoi: touch to trigger build on glibc builders.

Also split too long go_ldflags line.
---
 srcpkgs/chezmoi/template | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/srcpkgs/chezmoi/template b/srcpkgs/chezmoi/template
index 90cc4b661f3..225b200a37b 100644
--- a/srcpkgs/chezmoi/template
+++ b/srcpkgs/chezmoi/template
@@ -5,7 +5,8 @@ revision=1
 build_style=go
 go_import_path="github.com/twpayne/chezmoi"
 go_build_tags="noembeddocs noupgrade"
-go_ldflags="-X main.version=${version} -X main.commit=v${version} -X main.builtBy=xbps -X github.com/twpayne/chezmoi/cmd.DocsDir=/usr/share/doc/chezmoi"
+go_ldflags="-X main.version=${version} -X main.commit=v${version} -X main.builtBy=xbps
+ -X github.com/twpayne/chezmoi/cmd.DocsDir=/usr/share/doc/chezmoi"
 hostmakedepends="git"
 short_desc="Manage your dotfiles across multiple machines, securely"
 maintainer="Abigail G <dev@kb6.ee>"

From 5e3f5925e7546861d4e1a408fe92863d05c5186e Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C3=89rico=20Rolim?= <erico.erc@gmail.com>
Date: Wed, 2 Sep 2020 16:49:04 -0300
Subject: [PATCH 248/312] apache-maven: add which, install in /usr/lib, remove
 noarch.

Also add replaces for apache-maven-bin.
---
 srcpkgs/apache-maven/INSTALL.msg           |  5 -----
 srcpkgs/apache-maven/files/apache-maven.sh |  3 ---
 srcpkgs/apache-maven/template              | 19 ++++++++++---------
 3 files changed, 10 insertions(+), 17 deletions(-)
 delete mode 100644 srcpkgs/apache-maven/INSTALL.msg
 delete mode 100644 srcpkgs/apache-maven/files/apache-maven.sh

diff --git a/srcpkgs/apache-maven/INSTALL.msg b/srcpkgs/apache-maven/INSTALL.msg
deleted file mode 100644
index d49b2df7f77..00000000000
--- a/srcpkgs/apache-maven/INSTALL.msg
+++ /dev/null
@@ -1,5 +0,0 @@
-Apache Maven makes use of shell variables which you could set
-by logging out and logging back in. Alternatively you may source
-/etc/profile.d/apache-maven.sh in your shell.
-Additionally note that the primary installation, including configuration
-files, is under /usr/share/apache-maven/
diff --git a/srcpkgs/apache-maven/files/apache-maven.sh b/srcpkgs/apache-maven/files/apache-maven.sh
deleted file mode 100644
index c5e1cd0f192..00000000000
--- a/srcpkgs/apache-maven/files/apache-maven.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-
-export PATH=$PATH:/usr/share/apache-maven/bin
diff --git a/srcpkgs/apache-maven/template b/srcpkgs/apache-maven/template
index a6c9fd3e5a2..c9603329c2c 100644
--- a/srcpkgs/apache-maven/template
+++ b/srcpkgs/apache-maven/template
@@ -1,10 +1,9 @@
 # Template file for 'apache-maven'
 pkgname=apache-maven
 version=3.6.3
-revision=1
-archs=noarch
+revision=2
 hostmakedepends="openjdk8"
-depends="virtual?java-environment"
+depends="virtual?java-environment which"
 short_desc="Software project management and comprehension tool"
 maintainer="Michael Aldridge <maldridge@voidlinux.org>"
 license="Apache-2.0"
@@ -13,19 +12,21 @@ distfiles="https://www-us.apache.org/dist/maven/maven-3/${version}/source/${pkgn
  https://www-us.apache.org/dist/maven/maven-3/${version}/binaries/apache-maven-${version}-bin.tar.gz"
 checksum="7c1c990ba64dd4f88688120cc2ec93bf33dd500d2a62ae5cd57bd4b7f6335c07
  26ad91d751b3a9a53087aefa743f4e16a17741d3915b219cf74112bf87a438c5"
+replaces="apache-maven-bin>=0"
 
 do_build() {
 	source /etc/profile.d/10_openjdk8.sh
-	./bin/mvn package -DskipTests -Drat.skip=true -Dmaven.repo.local=repo -DdistributionTargetDir=${DESTDIR}/usr/share/${pkgname}/
+	./bin/mvn package -DskipTests -Drat.skip=true -Dmaven.repo.local=repo -DdistributionTargetDir=${DESTDIR}/usr/lib/${pkgname}
 }
 
 do_install() {
 	# contains bundled native libraries that might not match the platform
 	# disables ansi color support
-	rm -rf ${DESTDIR}/usr/share/${pkgname}/lib/jansi-native
-	rm -f ${DESTDIR}/usr/share/${pkgname}/lib/jansi-*.jar
+	rm -r ${DESTDIR}/usr/lib/${pkgname}/lib/jansi-native
+	rm ${DESTDIR}/usr/lib/${pkgname}/lib/jansi-*.jar
 
-	mkdir -p ${DESTDIR}/etc/profile.d
-	vinstall ${FILESDIR}/apache-maven.sh 0755 etc/profile.d/
-	vlicense LICENSE
+	vmkdir usr/bin
+	ln -s /usr/lib/${pkgname}/bin/mvn ${DESTDIR}/usr/bin
+	ln -s /usr/lib/${pkgname}/bin/mvnDebug ${DESTDIR}/usr/bin
+	ln -s /usr/lib/${pkgname}/bin/mvnyjp ${DESTDIR}/usr/bin
 }

From f1c9629dcd616ea66d1de968eb85e32ee16f581d Mon Sep 17 00:00:00 2001
From: Kartik Singh <kartik.ynwa@gmail.com>
Date: Fri, 9 Oct 2020 14:03:31 +0530
Subject: [PATCH 249/312] dbeaver: use apache-maven, update to 7.2.2.

Add comment for archs.

Closes: #25451 [via git-merge-pr]
---
 srcpkgs/dbeaver/template | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/dbeaver/template b/srcpkgs/dbeaver/template
index eb8b88adf5d..249080f8239 100644
--- a/srcpkgs/dbeaver/template
+++ b/srcpkgs/dbeaver/template
@@ -1,15 +1,16 @@
 # Template file for 'dbeaver'
 pkgname=dbeaver
-version=7.2.0
+version=7.2.2
 revision=1
+# the build downloads binaries linked to glibc
 archs="x86_64"
-hostmakedepends="apache-maven-bin"
+hostmakedepends="apache-maven"
 short_desc="Free Universal Database Tool"
 maintainer="Kyle Nusbaum <knusbaum+void@sdf.org>"
 license="Apache-2.0"
 homepage="https://dbeaver.io"
 distfiles="https://github.com/dbeaver/dbeaver/archive/${version}.tar.gz"
-checksum=ac1bde32670e88a637c6c62105c6fc960e4ed292cbcfb260f22d97b2203ffb58
+checksum=57ab79f61498d70bedddffe33e6a5c1201bcf1ae3575ac574196c53442bc0829
 nopie=true
 
 do_build() {

From 3845ab176dc308c540fd841608ee12e5e5af735a Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C3=89rico=20Rolim?= <erico.erc@gmail.com>
Date: Wed, 2 Sep 2020 18:14:44 -0300
Subject: [PATCH 250/312] runelite-launcher: use apache-maven, remove noarch

---
 srcpkgs/runelite-launcher/template | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/runelite-launcher/template b/srcpkgs/runelite-launcher/template
index f4717951c59..9b083e779e7 100644
--- a/srcpkgs/runelite-launcher/template
+++ b/srcpkgs/runelite-launcher/template
@@ -1,10 +1,9 @@
 # Template file for 'runelite-launcher'
 pkgname=runelite-launcher
 version=2.1.3
-revision=1
-archs=noarch
+revision=2
 wrksrc="launcher-${version}"
-hostmakedepends="apache-maven-bin"
+hostmakedepends="apache-maven"
 depends="virtual?java-runtime"
 short_desc="Open source Old School RuneScape client"
 maintainer="Matteo Signer <matteo.signer@gmail.com>"

From f08c457bb9697ebd4857708b45988747022c68ca Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C3=89rico=20Rolim?= <erico.erc@gmail.com>
Date: Wed, 2 Sep 2020 18:13:46 -0300
Subject: [PATCH 251/312] apache-maven-bin: remove package.

---
 srcpkgs/apache-maven-bin/template | 22 ----------------------
 srcpkgs/apache-maven-bin/update   |  2 --
 2 files changed, 24 deletions(-)
 delete mode 100644 srcpkgs/apache-maven-bin/template
 delete mode 100644 srcpkgs/apache-maven-bin/update

diff --git a/srcpkgs/apache-maven-bin/template b/srcpkgs/apache-maven-bin/template
deleted file mode 100644
index 44c692de7f0..00000000000
--- a/srcpkgs/apache-maven-bin/template
+++ /dev/null
@@ -1,22 +0,0 @@
-# Template file for 'apache-maven-bin'
-pkgname=apache-maven-bin
-version=3.3.9
-revision=2
-wrksrc=apache-maven-3.3.9
-depends="virtual?java-environment which"
-short_desc="A tool for building and managing Java-based projects"
-maintainer="Spencer H <spencernh77@gmail.com>"
-license="Apache-2.0"
-homepage="https://maven.apache.org"
-distfiles="https://www-us.apache.org/dist/maven/maven-3/${version}/binaries/apache-maven-${version}-bin.tar.gz>apache-maven-${version}.tar.gz"
-checksum=6e3e9c949ab4695a204f74038717aa7b2689b1be94875899ac1b3fe42800ff82
-
-do_install() {
-	vmkdir opt/apache-maven
-	vmkdir usr/bin
-	vcopy "*" opt/apache-maven
-	ln -s /opt/apache-maven/bin/mvn ${DESTDIR}/usr/bin/mvn
-	ln -s /opt/apache-maven/bin/mvnDebug ${DESTDIR}/usr/bin/mvnDebug
-	ln -s /opt/apache-maven/bin/mvnyjp ${DESTDIR}/usr/bin/mvnyjp
-}
-
diff --git a/srcpkgs/apache-maven-bin/update b/srcpkgs/apache-maven-bin/update
deleted file mode 100644
index 9400a38bf3d..00000000000
--- a/srcpkgs/apache-maven-bin/update
+++ /dev/null
@@ -1,2 +0,0 @@
-site="https://www-us.apache.org/dist/maven/maven-3/"
-pattern="[0-9.]+(?=\/<)"

From f7c20f4533f13866f9695c3492d1cb5540a83625 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C3=89rico=20Rolim?= <erico.erc@gmail.com>
Date: Wed, 2 Sep 2020 18:19:38 -0300
Subject: [PATCH 252/312] tuxguitar: clean up.

Use virtual java package for depends and remove line setting PATH.
---
 srcpkgs/tuxguitar/template | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/srcpkgs/tuxguitar/template b/srcpkgs/tuxguitar/template
index 80f6d18b6c2..19a3420936b 100644
--- a/srcpkgs/tuxguitar/template
+++ b/srcpkgs/tuxguitar/template
@@ -5,7 +5,7 @@ revision=1
 wrksrc="${pkgname}-${version}-src"
 hostmakedepends="apache-maven openjdk8"
 makedepends="alsa-lib-devel fluidsynth-devel jack-devel"
-depends="openjdk8-jre icedtea-sound gtk+3 hicolor-icon-theme desktop-file-utils"
+depends="virtual?java-environment icedtea-sound gtk+3 hicolor-icon-theme desktop-file-utils"
 short_desc="Multitrack guitar tablature editor and player"
 maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.0-only"
@@ -30,7 +30,6 @@ post_extract() {
 do_build() {
 	export MAVEN_OPTS="$MAVEN_OPTS -Duser.home=$wrksrc"
 	export JAVA_HOME="/usr/lib/jvm/java-1.8-openjdk"
-	PATH=$PATH:/usr/share/apache-maven/bin
 	for _i in . TuxGuitar-{lib,gm-utils} \
 		build-scripts/{tuxguitar,native-modules/tuxguitar-{alsa,oss,jack,fluidsynth}}-linux-$_arch; do
 		(

From 76c9485c087515875dc8034978f87074f3df45f5 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Fri, 16 Oct 2020 14:23:11 -0400
Subject: [PATCH 253/312] python3-pytools: update to 2020.4.2.

---
 srcpkgs/python3-pytools/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-pytools/template b/srcpkgs/python3-pytools/template
index d65496c03f4..5a6bb453a44 100644
--- a/srcpkgs/python3-pytools/template
+++ b/srcpkgs/python3-pytools/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-pytools'
 pkgname=python3-pytools
-version=2020.4
-revision=2
+version=2020.4.2
+revision=1
 wrksrc=${pkgname#*-}-${version}
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -12,7 +12,7 @@ maintainer="Andrew J. Hesford <ajh@sideband.org>"
 license="X11"
 homepage="https://pypi.org/project/pytools"
 distfiles="${PYPI_SITE}/p/pytools/pytools-${version}.tar.gz"
-checksum=37db39ff11a1b5fc8aec875ae4ddb3d6c21aa0e95bddc9c841aa98e1631ae460
+checksum=a1304b07cb9102d566123f87aa4b5ad55e65d4c55e0af9985906ad11b2ffbdce
 
 post_install() {
 	vlicense LICENSE

From 35f168058f3551fa6e826309e4462ef320b3e84e Mon Sep 17 00:00:00 2001
From: Johannes <johannes.brechtmann@gmail.com>
Date: Wed, 14 Oct 2020 20:26:38 +0200
Subject: [PATCH 254/312] gcc: fix order of postdep_objects_CXX

make sure crt* objects come after anything else

fixes #25535

[ci skip]
---
 srcpkgs/gcc/patches/fix-vtv-link-order.patch | 20 ++++++++++++++++++++
 srcpkgs/gcc/template                         |  2 +-
 2 files changed, 21 insertions(+), 1 deletion(-)
 create mode 100644 srcpkgs/gcc/patches/fix-vtv-link-order.patch

diff --git a/srcpkgs/gcc/patches/fix-vtv-link-order.patch b/srcpkgs/gcc/patches/fix-vtv-link-order.patch
new file mode 100644
index 00000000000..3315c3e990b
--- /dev/null
+++ b/srcpkgs/gcc/patches/fix-vtv-link-order.patch
@@ -0,0 +1,20 @@
+put vtv_end.o in front of postdep_objects_CXX
+having it after crtendS.o leads to missing zero termination in eh_frame section
+
+This is in line with comment in libgcc/vtv_end.c:
+
+   When the GCC driver inserts vtv_start.o into the link line (just
+   after crtbegin.o) it also inserts vtv_end.o into the link line,
+   just before crtend.o.
+
+--- libstdc++-v3/configure
++++ libstdc++-v3/configure
+@@ -15443,7 +15443,7 @@
+ 
+ if test "$enable_vtable_verify" = yes; then
+   predep_objects_CXX="${predep_objects_CXX} ${glibcxx_builddir}/../libgcc/vtv_start.o"
+-  postdep_objects_CXX="${postdep_objects_CXX} ${glibcxx_builddir}/../libgcc/vtv_end.o"
++  postdep_objects_CXX="${glibcxx_builddir}/../libgcc/vtv_end.o ${postdep_objects_CXX}" 
+ fi
+ 
+ 
diff --git a/srcpkgs/gcc/template b/srcpkgs/gcc/template
index ead6f05a498..f4e2f949933 100644
--- a/srcpkgs/gcc/template
+++ b/srcpkgs/gcc/template
@@ -8,7 +8,7 @@ _isl_version=0.21
 
 pkgname=gcc
 version=${_minorver}.0
-revision=6
+revision=7
 short_desc="GNU Compiler Collection"
 maintainer="Enno Boland <gottox@voidlinux.org>"
 homepage="http://gcc.gnu.org"

From c4d750d7fdadacc498abe32b0f130943dc1577a5 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Fri, 16 Oct 2020 15:45:51 -0400
Subject: [PATCH 255/312] tox: add python3-setuptools_scm to hostmakedepends

---
 srcpkgs/tox/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/tox/template b/srcpkgs/tox/template
index 4354e586e24..2d39e47d019 100644
--- a/srcpkgs/tox/template
+++ b/srcpkgs/tox/template
@@ -1,9 +1,9 @@
 # Template file for 'tox'
 pkgname=tox
 version=3.20.1
-revision=1
+revision=2
 build_style=python3-module
-hostmakedepends="python3-setuptools"
+hostmakedepends="python3-setuptools_scm"
 depends="python3-filelock python3-packaging
  python3-pluggy python3-pytest python3-toml python3-virtualenv"
 checkdepends="${depends} python3-flaky python3-pathlib2"

From c9c023a4610c004a5c58c1ab29eff9a7501163d1 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Fri, 16 Oct 2020 15:50:27 -0400
Subject: [PATCH 256/312] python3-iniconfig: update to 1.1.1.

---
 srcpkgs/python3-iniconfig/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-iniconfig/template b/srcpkgs/python3-iniconfig/template
index faffc52860a..8f35b984210 100644
--- a/srcpkgs/python3-iniconfig/template
+++ b/srcpkgs/python3-iniconfig/template
@@ -1,10 +1,10 @@
 # Template file for 'python3-iniconfig'
 pkgname=python3-iniconfig
-version=1.0.1
-revision=2
+version=1.1.1
+revision=1
 wrksrc="iniconfig-${version}"
 build_style=python3-module
-hostmakedepends="python3-setuptools"
+hostmakedepends="python3-setuptools_scm"
 depends="python3"
 checkdepends="python3-py python3-pytest"
 short_desc="Brain-dead simple config-ini parsing"
@@ -12,7 +12,7 @@ maintainer="Piotr Wójcik <chocimier@tlen.pl>"
 license="MIT"
 homepage="https://github.com/RonnyPfannschmidt/iniconfig"
 distfiles="${PYPI_SITE}/i/iniconfig/iniconfig-${version}.tar.gz"
-checksum=e5f92f89355a67de0595932a6c6c02ab4afddc6fcdc0bfc5becd0d60884d3f69
+checksum=bc3af051d7d14b2ee5ef9969666def0cd1a000e121eaea580d4a313df4b37f32
 
 post_install() {
 	vlicense LICENSE

From a185f28cc720edea9666e8d2cdf4603e90d28d3f Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Fri, 16 Oct 2020 15:54:32 -0400
Subject: [PATCH 257/312] python3-py: add python3-setuptools_scm to
 hostmakedepends

---
 srcpkgs/python3-py/template | 8 ++------
 1 file changed, 2 insertions(+), 6 deletions(-)

diff --git a/srcpkgs/python3-py/template b/srcpkgs/python3-py/template
index 7232bbd5e65..20d27196850 100644
--- a/srcpkgs/python3-py/template
+++ b/srcpkgs/python3-py/template
@@ -1,10 +1,10 @@
 # Template file for 'python3-py'
 pkgname=python3-py
 version=1.9.0
-revision=3
+revision=4
 wrksrc="py-${version}"
 build_style=python3-module
-hostmakedepends="python3-setuptools"
+hostmakedepends="python3-setuptools_scm"
 depends="python3"
 checkdepends="python3-pytest"
 short_desc="Python3 development support library"
@@ -15,10 +15,6 @@ changelog="https://github.com/pytest-dev/py/raw/master/CHANGELOG"
 distfiles="${PYPI_SITE}/p/py/py-${version}.tar.gz"
 checksum=9ca6883ce56b4e8da7e79ac18787889fa5206c79dcc67fb065376cd2fe03f342
 
-post_extract() {
-	vsed -i -e 's/"setuptools-scm"//' setup.py
-}
-
 do_check() {
 	python3 -m pytest
 }

From 95a3ded2afc3c5a3c8cd5419bf7fe9e358a12d8c Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Fri, 16 Oct 2020 16:09:31 -0400
Subject: [PATCH 258/312] python3-setuptools: update to 50.3.1.

---
 srcpkgs/python3-setuptools/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-setuptools/template b/srcpkgs/python3-setuptools/template
index 6e7326f93e9..5d22601328d 100644
--- a/srcpkgs/python3-setuptools/template
+++ b/srcpkgs/python3-setuptools/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-setuptools'
 pkgname=python3-setuptools
-version=50.3.0
-revision=2
+version=50.3.1
+revision=1
 wrksrc="setuptools-${version}"
 build_style=python3-module
 hostmakedepends="python3-devel"
@@ -11,7 +11,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="MIT"
 homepage="https://github.com/pypa/setuptools"
 distfiles="${PYPI_SITE}/s/setuptools/setuptools-${version}.zip"
-checksum=39060a59d91cf5cf403fa3bacbb52df4205a8c3585e0b9ba4b30e0e19d4c4b18
+checksum=0e9772768fa6e9d3cf818a3e6e24dd2236f319d2c478312995edcb30ddeb8343
 alternatives="setuptools:easy_install:/usr/bin/easy_install3"
 provides="python3-distribute-${version}_1"
 replaces="python3-distribute>=0"

From 4d2c573ca66ecf34109a677411571b740e2390c1 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 17 Sep 2020 21:10:06 +0200
Subject: [PATCH 259/312] bluedevil: update to 5.20.0

[ci skip]
---
 srcpkgs/bluedevil/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/bluedevil/template b/srcpkgs/bluedevil/template
index 024af3eac2e..88dc6986ab7 100644
--- a/srcpkgs/bluedevil/template
+++ b/srcpkgs/bluedevil/template
@@ -1,6 +1,6 @@
 # Template file for 'bluedevil'
 pkgname=bluedevil
-version=5.19.5
+version=5.20.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -12,7 +12,7 @@ maintainer="John <me@johnnynator.dev>"
 license="GPL-2.0-or-later, LGPL-2.1-or-later"
 homepage="https://invent.kde.org/plasma/bluedevil"
 distfiles="${KDE_SITE}/plasma/${version}/${pkgname}-${version}.tar.xz"
-checksum=e857e3c73a3d6c08bb44506f35a8359b480e960d32ae189b9b5bddcbcf5ffe2d
+checksum=67285a99af29fa121657f3ad3f6a17a22d56190414a40341e7948a097228804f
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" kpackage-devel kconfig-devel kcoreaddons-devel"

From 0c2f55eb37c319c45394e8803652288fd6824cdc Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 17 Sep 2020 21:10:12 +0200
Subject: [PATCH 260/312] breeze-gtk: update to 5.20.0

[ci skip]
---
 srcpkgs/breeze-gtk/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/breeze-gtk/template b/srcpkgs/breeze-gtk/template
index 9406928b8e9..c29a0f7b490 100644
--- a/srcpkgs/breeze-gtk/template
+++ b/srcpkgs/breeze-gtk/template
@@ -1,6 +1,6 @@
 # Template file for 'breeze-gtk'
 pkgname=breeze-gtk
-version=5.19.5
+version=5.20.0
 revision=1
 build_style=cmake
 hostmakedepends="extra-cmake-modules sassc python3 python3-cairo"
@@ -10,7 +10,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later"
 homepage="https://invent.kde.org/plasma/breeze-gtk"
 distfiles="${KDE_SITE}/plasma/${version}/${pkgname}-${version}.tar.xz"
-checksum=5213b2f6815e542cda6bf9ae153636285e178962c6a59ff9ab4fe5c07dc256c8
+checksum=52f643d03db5fa7b154c502e741af33e9903b31f19ad4328ede84e10f7a36c74
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" qt5-devel"

From cb44ff5132d717860a967bc33163318cd1d775b6 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 17 Sep 2020 21:10:22 +0200
Subject: [PATCH 261/312] breeze: update to 5.20.0

[ci skip]
---
 srcpkgs/breeze/template | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/breeze/template b/srcpkgs/breeze/template
index f155945e11b..28678f79b23 100644
--- a/srcpkgs/breeze/template
+++ b/srcpkgs/breeze/template
@@ -1,6 +1,6 @@
 # Template file for 'breeze'
 pkgname=breeze
-version=5.19.5
+version=5.20.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -14,7 +14,7 @@ maintainer="John <me@johnnynator.dev>"
 license="GPL-2.0-or-later"
 homepage="https://invent.kde.org/plasma/breeze"
 distfiles="${KDE_SITE}/plasma/${version}/${pkgname}-${version}.tar.xz"
-checksum=61116665a534a0acd833f9bb499dbe983bb07088c0006988fbd929f60f0ff336
+checksum=f360c5803c434b8ce771232b030779d8c92b3bcb5b7c940f3524d6e9afb05db1
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" kpackage-devel kconfig-devel kcoreaddons-devel plasma-framework"
@@ -23,7 +23,6 @@ fi
 
 breeze-snow-cursor-theme_package() {
 	short_desc="Breeze Snow cursor theme"
-	archs=noarch
 	pkg_install() {
 		vmove usr/share/icons/Breeze_Snow
 	}

From e65aff5115e98bc9389595115539ca9fc8a065ac Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 17 Sep 2020 21:10:25 +0200
Subject: [PATCH 262/312] kactivitymanagerd: update to 5.20.0

[ci skip]
---
 srcpkgs/kactivitymanagerd/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kactivitymanagerd/template b/srcpkgs/kactivitymanagerd/template
index 8621864c907..558179d294a 100644
--- a/srcpkgs/kactivitymanagerd/template
+++ b/srcpkgs/kactivitymanagerd/template
@@ -1,6 +1,6 @@
 # Template file for 'kactivitymanagerd'
 pkgname=kactivitymanagerd
-version=5.19.5
+version=5.20.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -12,7 +12,7 @@ maintainer="John <me@johnnynator.dev>"
 license="GPL-2.0-or-later"
 homepage="https://invent.kde.org/plasma/kactivitymanagerd"
 distfiles="${KDE_SITE}/plasma/${version}/${pkgname}-${version}.tar.xz"
-checksum=eec1a0996812d89b98e93a3a2dec15527fd553c2c9c608ad7f1858f01749c3b0
+checksum=3edc81cc588db4405e1b51831288bdd9ad5c33ef097620549bf936fc7ec21fbe
 
 if [ "$CROSS_BUILD" ]; then
 	configure_args+=" -DRUN_RESULT_VAR=0"

From cddbf7c1ed900e79e13ff23c2f4b307d060feb31 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 17 Sep 2020 21:10:29 +0200
Subject: [PATCH 263/312] kde-cli-tools: update to 5.20.0

[ci skip]
---
 srcpkgs/kde-cli-tools/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kde-cli-tools/template b/srcpkgs/kde-cli-tools/template
index aafaa533351..99e182ee95f 100644
--- a/srcpkgs/kde-cli-tools/template
+++ b/srcpkgs/kde-cli-tools/template
@@ -1,6 +1,6 @@
 # Template file for 'kde-cli-tools'
 pkgname=kde-cli-tools
-version=5.19.5
+version=5.20.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -13,7 +13,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later, GPL-2.0-or-later"
 homepage="https://invent.kde.org/plasma/kde-cli-tools"
 distfiles="${KDE_SITE}/plasma/${version}/${pkgname}-${version}.tar.xz"
-checksum=07314832aee0b424451120e0aad59fdaab96ba713279dc1937cf36ef9b5389c7
+checksum=a5875dab2a31dd4f024d178c8eaeb20262950292330435d51e9088de25b0b0af
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" kdoctools kcoreaddons python qt5-host-tools qt5-qmake"

From e913eb1fd4ed0c860c20fcf1d724cdb8d709b095 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 17 Sep 2020 21:10:31 +0200
Subject: [PATCH 264/312] kde-gtk-config5: update to 5.20.0

[ci skip]
---
 srcpkgs/kde-gtk-config5/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/kde-gtk-config5/template b/srcpkgs/kde-gtk-config5/template
index e9dc8191d70..c05c33d41ff 100644
--- a/srcpkgs/kde-gtk-config5/template
+++ b/srcpkgs/kde-gtk-config5/template
@@ -1,21 +1,21 @@
 # Template file for 'kde-gtk-config5'
 pkgname=kde-gtk-config5
-version=5.19.5
+version=5.20.0
 revision=1
 wrksrc="${pkgname%5}-${version}"
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
 hostmakedepends="extra-cmake-modules pkg-config qt5-qmake qt5-host-tools
- gettext"
+ sassc gettext"
 makedepends="kcmutils-devel knewstuff-devel gtk+-devel gtk+3-devel
- gsettings-desktop-schemas-devel"
+ kdecoration-devel gsettings-desktop-schemas-devel"
 depends="kde-cli-tools gsettings-desktop-schemas"
 short_desc="GTK2 and GTK3 Configurator for KDE"
 maintainer="John <me@johnnynator.dev>"
 license="GPL-2.0-or-later, LGPL-2.1-or-later"
 homepage="https://invent.kde.org/plasma/kde-gtk-config"
 distfiles="${KDE_SITE}/plasma/${version}/${pkgname%5}-${version}.tar.xz"
-checksum=e9b79917994a18001691ce675d5f2e95367c872694d82540fb245ab6e57035a3
+checksum=89590b6950c343e67a15d89058461eef6379e824861197f525e2678d0e901df2
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" kcoreaddons"

From 4befc91ac4370a62364963957d582d3174ac8714 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 17 Sep 2020 21:10:33 +0200
Subject: [PATCH 265/312] kdecoration: update to 5.20.0

[ci skip]
---
 srcpkgs/kdecoration/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kdecoration/template b/srcpkgs/kdecoration/template
index 32bb643d269..84013d54fa7 100644
--- a/srcpkgs/kdecoration/template
+++ b/srcpkgs/kdecoration/template
@@ -1,6 +1,6 @@
 # Template file for 'kdecoration'
 pkgname=kdecoration
-version=5.19.5
+version=5.20.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -11,7 +11,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later"
 homepage="https://invent.kde.org/plasma/kdecoration"
 distfiles="${KDE_SITE}/plasma/${version}/${pkgname}-${version}.tar.xz"
-checksum=ce3ef7bb09405645699939cc3481d1fad67b1c5b758b64adfc4d81e5ffb1c85e
+checksum=3dd92c7384fd2665af13715b4073eeee9d6c5969d578049c6ae72dc4c287a747
 
 kdecoration-devel_package() {
 	short_desc+=" - development"

From f246f13d0ea70f5221192dbdcfa30e44ab3fe9c8 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 17 Sep 2020 21:10:36 +0200
Subject: [PATCH 266/312] kdeplasma-addons5: update to 5.20.0

[ci skip]
---
 srcpkgs/kdeplasma-addons5/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kdeplasma-addons5/template b/srcpkgs/kdeplasma-addons5/template
index cebeaf51398..a92aa60513b 100644
--- a/srcpkgs/kdeplasma-addons5/template
+++ b/srcpkgs/kdeplasma-addons5/template
@@ -1,6 +1,6 @@
 # Template file for 'kdeplasma-addons5'
 pkgname=kdeplasma-addons5
-version=5.19.5
+version=5.20.0
 revision=1
 wrksrc="${pkgname%5}-${version}"
 build_style=cmake
@@ -14,7 +14,7 @@ maintainer="John <me@johnnynator.dev>"
 license="GPL-2.0-or-later, LGPL-2.1-or-later"
 homepage="https://invent.kde.org/plasma/kdeplasma-addons"
 distfiles="${KDE_SITE}/plasma/${version}/${pkgname%5}-${version}.tar.xz"
-checksum=659e10b553c7db1abd488f77c43a919046f5e7f29126972926afe1350f93ff23
+checksum=e1a8b6e9d8ae044590ca6a6f0f97922d8f2ea0bd626c8108e2a8553caf22ff97
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" kpackage-devel kconfig-devel kcoreaddons-devel plasma-framework"

From e385ca1b34da32037a7b01fe2fc074163c505922 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 17 Sep 2020 21:10:38 +0200
Subject: [PATCH 267/312] kgamma5: update to 5.20.0

[ci skip]
---
 srcpkgs/kgamma5/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kgamma5/template b/srcpkgs/kgamma5/template
index c2792cad4ea..ec98441519c 100644
--- a/srcpkgs/kgamma5/template
+++ b/srcpkgs/kgamma5/template
@@ -1,6 +1,6 @@
 # Template file for 'kgamma5'
 pkgname=kgamma5
-version=5.19.5
+version=5.20.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -11,7 +11,7 @@ maintainer="John <me@johnnynator.dev>"
 license="GPL-2.0-or-later"
 homepage="https://invent.kde.org/plasma/kgamma5"
 distfiles="${KDE_SITE}/plasma/${version}/${pkgname}-${version}.tar.xz"
-checksum=d6e70e2638c65283895ead3791957853553d02ee864b2f928c3b0df4611ca023
+checksum=614f92fc14a3c7ed5b7e44579d715d4f7d6387ffab04863d081ef45be375bd0f
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" qt5-devel kdoctools"

From 07c37264e269923f0cf031b8de5047bc2dd7e540 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 17 Sep 2020 21:10:42 +0200
Subject: [PATCH 268/312] khotkeys: update to 5.20.0

[ci skip]
---
 srcpkgs/khotkeys/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/khotkeys/template b/srcpkgs/khotkeys/template
index ad48a01fb74..13fa9964f6c 100644
--- a/srcpkgs/khotkeys/template
+++ b/srcpkgs/khotkeys/template
@@ -1,6 +1,6 @@
 # Template file for 'khotkeys'
 pkgname=khotkeys
-version=5.19.5
+version=5.20.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -12,7 +12,7 @@ maintainer="John <me@johnnynator.dev>"
 license="GPL-2.0-only, LGPL-2.0-or-later"
 homepage="https://invent.kde.org/plasma/khotkeys"
 distfiles="${KDE_SITE}/plasma/${version}/${pkgname}-${version}.tar.xz"
-checksum=568cb61eb385a3776d96b21aa77188377b02e56e3bf46f9d9ffddb83a9b31bda
+checksum=0e470ba928c5ce09e1a533cd83e02bb7943baac146c6c92354b0c3dc0393953a
 
 if [ "$CROSS_BUILD" ]; then
 	configure_args+=" -DDESKTOPTOJSON_EXECUTABLE=/usr/bin/desktoptojson"

From cb2b7903929ae55e2ff1dec033cebc0000579c7c Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 17 Sep 2020 21:10:46 +0200
Subject: [PATCH 269/312] kinfocenter: update to 5.20.0

[ci skip]
---
 srcpkgs/kinfocenter/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kinfocenter/template b/srcpkgs/kinfocenter/template
index 034d2e1d04d..4e6e0458f5b 100644
--- a/srcpkgs/kinfocenter/template
+++ b/srcpkgs/kinfocenter/template
@@ -1,6 +1,6 @@
 # Template file for 'kinfocenter'
 pkgname=kinfocenter
-version=5.19.5
+version=5.20.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -14,7 +14,7 @@ maintainer="John <me@johnnynator.dev>"
 license="GPL-2.0-or-later, LGPL-2.1-or-later, GFDL-1.2"
 homepage="https://invent.kde.org/plasma/kinfocenter"
 distfiles="${KDE_SITE}/plasma/${version}/${pkgname}-${version}.tar.xz"
-checksum=ffae6f6fc311cedfac2b380dcbc9f15588952cbcd66b144f4ae717801cb2bc31
+checksum=606557c20868b97f97ce4f7c6af45fdb8984914d70734924b9968f70b5faaa45
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" kpackage-devel kconfig-devel kcoreaddons-devel kdoctools-devel"

From dd3f63588c223669c3b7f7e19e47d65e7dea0dd6 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 17 Sep 2020 21:10:49 +0200
Subject: [PATCH 270/312] kmenuedit: update to 5.20.0

[ci skip]
---
 srcpkgs/kmenuedit/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kmenuedit/template b/srcpkgs/kmenuedit/template
index 1a1f349f0d3..f9f1310792c 100644
--- a/srcpkgs/kmenuedit/template
+++ b/srcpkgs/kmenuedit/template
@@ -1,6 +1,6 @@
 # Template file for 'kmenuedit'
 pkgname=kmenuedit
-version=5.19.5
+version=5.20.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -13,4 +13,4 @@ maintainer="John <me@johnnynator.dev>"
 license="GPL-2"
 homepage="https://invent.kde.org/plasma/kmenuedit"
 distfiles="${KDE_SITE}/plasma/${version}/${pkgname}-${version}.tar.xz"
-checksum=f4701c74c304d46f5146943aa297300fb38a9c3b1efad39d4fbf3238d49989f6
+checksum=0dcc63fba88f76e723686760223af5d22464f7357a7e80540b369b2a6782e75e

From bc88e4e00a9eb156629a1671ab0f94943c60938b Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 17 Sep 2020 21:10:52 +0200
Subject: [PATCH 271/312] kscreen: update to 5.20.0

[ci skip]
---
 srcpkgs/kscreen/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kscreen/template b/srcpkgs/kscreen/template
index 2e16f76ff83..ca1a3ae627f 100644
--- a/srcpkgs/kscreen/template
+++ b/srcpkgs/kscreen/template
@@ -1,6 +1,6 @@
 # Template file for 'kscreen'
 pkgname=kscreen
-version=5.19.5
+version=5.20.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -14,7 +14,7 @@ maintainer="John <me@johnnynator.dev>"
 license="GPL-2.0-or-later, LGPL-2.1-or-later"
 homepage="https://invent.kde.org/plasma/kscreen"
 distfiles="${KDE_SITE}/plasma/${version}/${pkgname}-${version}.tar.xz"
-checksum=0d72c687a405358e6aa6b388a648134e8e9236b7ed60e36a31068960d07b56e8
+checksum=fad43bdaf4706501c7d130dd885229d3b4a4ed327f2d352d577f3c34be2a3edd
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" kpackage-devel kconfig-devel kcoreaddons-devel plasma-framework"

From b8b6cc173f4028400f2e26a5953f2e963629c51c Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 17 Sep 2020 21:10:54 +0200
Subject: [PATCH 272/312] kscreenlocker: update to 5.20.0

[ci skip]
---
 srcpkgs/kscreenlocker/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kscreenlocker/template b/srcpkgs/kscreenlocker/template
index 497ca49e861..8ab56afca43 100644
--- a/srcpkgs/kscreenlocker/template
+++ b/srcpkgs/kscreenlocker/template
@@ -1,6 +1,6 @@
 # Template file for 'kscreenlocker'
 pkgname=kscreenlocker
-version=5.19.5
+version=5.20.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -13,7 +13,7 @@ maintainer="John <me@johnnynator.dev>"
 license="GPL-2.0-or-later"
 homepage="https://invent.kde.org/plasma/kscreenlocker"
 distfiles="${KDE_SITE}/plasma/${version}/${pkgname}-${version}.tar.xz"
-checksum=b13b2081971db1347d6a77dec416725995ca20a5b7bf05f21c72a68e15d6a5b9
+checksum=d8a3b5a7137b4f6c9fe0ad0b625ebc16f5c024e527f77f9a3f6744570a1c46a2
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" wayland-devel"

From 16c3396804b77ed09c0493fdecae1b81dabe7ba5 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 17 Sep 2020 21:10:57 +0200
Subject: [PATCH 273/312] ksshaskpass: update to 5.20.0

[ci skip]
---
 srcpkgs/ksshaskpass/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/ksshaskpass/template b/srcpkgs/ksshaskpass/template
index 48135a1dc22..667adcf60e3 100644
--- a/srcpkgs/ksshaskpass/template
+++ b/srcpkgs/ksshaskpass/template
@@ -1,6 +1,6 @@
 # Template file for 'ksshaskpass'
 pkgname=ksshaskpass
-version=5.19.5
+version=5.20.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -12,4 +12,4 @@ maintainer="John <me@johnnynator.dev>"
 license="GPL-2.0-or-later"
 homepage="https://invent.kde.org/plasma/ksshaskpass"
 distfiles="${KDE_SITE}/plasma/${version}/${pkgname}-${version}.tar.xz"
-checksum=51c7dbcc434fb993ae756ce6ef8bf7511033617cc3367478382e1490b6505bcc
+checksum=8793169684de4c0c281bb128dfc67335d34c214d38b8434e021296bb7a5fbae3

From 8f8e5ef44040afe38e2e7fca065271616f45c129 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 17 Sep 2020 21:10:59 +0200
Subject: [PATCH 274/312] ksysguard: update to 5.20.0

[ci skip]
---
 srcpkgs/ksysguard/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/ksysguard/template b/srcpkgs/ksysguard/template
index b51cf83c408..0ac54151352 100644
--- a/srcpkgs/ksysguard/template
+++ b/srcpkgs/ksysguard/template
@@ -1,6 +1,6 @@
 # Template file for 'ksysguard'
 pkgname=ksysguard
-version=5.19.5
+version=5.20.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -13,4 +13,4 @@ maintainer="John <me@johnnynator.dev>"
 license="GPL-2.0-or-later, GFDL-1.2"
 homepage="https://invent.kde.org/plasma/ksysguard"
 distfiles="${KDE_SITE}/plasma/${version}/${pkgname}-${version}.tar.xz"
-checksum=e1a66dc9750482ada19da5d3e9ec06893f859930f0e8e5a910a5751e9f267c47
+checksum=5e972b4e8bd799f902013b408e4677ef28b7a40c3be4739234c86ba92b2d1e84

From e8c07bb6f3be7b33a4b0b2766beaccad916d255a Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 17 Sep 2020 21:11:03 +0200
Subject: [PATCH 275/312] kwallet-pam: update to 5.20.0

[ci skip]
---
 srcpkgs/kwallet-pam/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kwallet-pam/template b/srcpkgs/kwallet-pam/template
index fe90f556e58..2af203e644c 100644
--- a/srcpkgs/kwallet-pam/template
+++ b/srcpkgs/kwallet-pam/template
@@ -1,6 +1,6 @@
 # Template file for 'kwallet-pam'
 pkgname=kwallet-pam
-version=5.19.5
+version=5.20.0
 revision=1
 build_style=cmake
 hostmakedepends="qt5-qmake qt5-host-tools extra-cmake-modules"
@@ -11,4 +11,4 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later"
 homepage="https://invent.kde.org/plasma/kwallet-pam"
 distfiles="${KDE_SITE}/plasma/${version}/${pkgname}-${version}.tar.xz"
-checksum=788aed97654b82b3512870dbf2b0d0f521503631d094bba07a7eff1125a7916f
+checksum=3f72384f1f28bc071cfa475cebec2f4315686a3713fbc778d953635272493d69

From 25d6b218984146b8a8584ebc3862c34131f6c30c Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 17 Sep 2020 21:11:05 +0200
Subject: [PATCH 276/312] kwayland-integration: update to 5.20.0

[ci skip]
---
 srcpkgs/kwayland-integration/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kwayland-integration/template b/srcpkgs/kwayland-integration/template
index cdc51f162a8..8324845f098 100644
--- a/srcpkgs/kwayland-integration/template
+++ b/srcpkgs/kwayland-integration/template
@@ -1,6 +1,6 @@
 # Template file for 'kwayland-integration'
 pkgname=kwayland-integration
-version=5.19.5
+version=5.20.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -11,4 +11,4 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later"
 homepage="https://invent.kde.org/plasma/kwayland-integration"
 distfiles="${KDE_SITE}/plasma/${version}/${pkgname}-${version}.tar.xz"
-checksum=6d1bed734cd256604736417846f891abad9bd7c2a45527fc6fc10560322c8a14
+checksum=4a1ec22d8d0fb7bb3302605ce211b52353fe93b9b29744db0cc9a961ba67707a

From 4f95c354489cef36768d326c2da71bf65b5c0837 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 17 Sep 2020 21:11:08 +0200
Subject: [PATCH 277/312] kwayland-server: update to 5.20.0

[ci skip]
---
 srcpkgs/kwayland-server/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kwayland-server/template b/srcpkgs/kwayland-server/template
index 3e275673ea2..b3c9f2c963c 100644
--- a/srcpkgs/kwayland-server/template
+++ b/srcpkgs/kwayland-server/template
@@ -1,6 +1,6 @@
 # Template file for 'kwayland-server'
 pkgname=kwayland-server
-version=5.19.5
+version=5.20.0
 revision=1
 build_style=cmake
 configure_args="-DWaylandScanner_EXECUTABLE=/usr/bin/wayland-scanner"
@@ -12,7 +12,7 @@ maintainer="John <me@johnnynator.dev>"
 license="GPL-3.0-or-later"
 homepage="https://invent.kde.org/plasma/kwayland-server"
 distfiles="${KDE_SITE}/plasma/${version}/${pkgname}-${version}.tar.xz"
-checksum=50fd9c9f68fd514dfd1ad05e65c8767afa154a3eed792f335214eee188c8541a
+checksum=e40253814bad7fa4ae829f1d3a752ba9bd89d92c5e89a72c6b857668ed75ecd6
 
 kwayland-server-devel_package() {
 	depends="${sourcepkg}>=${version}_${revision}"

From 049d4446e0d5ae36d43f33d83a1c7f912cc3513a Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 17 Sep 2020 21:11:12 +0200
Subject: [PATCH 278/312] kwin: update to 5.20.0

[ci skip]
---
 srcpkgs/kwin/patches/musl.patch | 10 ++++++++++
 srcpkgs/kwin/template           | 10 ++++++----
 2 files changed, 16 insertions(+), 4 deletions(-)
 create mode 100644 srcpkgs/kwin/patches/musl.patch

diff --git a/srcpkgs/kwin/patches/musl.patch b/srcpkgs/kwin/patches/musl.patch
new file mode 100644
index 00000000000..2751e77e10d
--- /dev/null
+++ b/srcpkgs/kwin/patches/musl.patch
@@ -0,0 +1,10 @@
+--- 3rdparty/xcursor.c	2020-09-19 14:34:54.765245866 +0200
++++ -	2020-09-19 14:35:18.599411888 +0200
+@@ -27,6 +27,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
++#define _GNU_SOURCE
+ #include <dirent.h>
+ 
+ /*
diff --git a/srcpkgs/kwin/template b/srcpkgs/kwin/template
index ee2fc8b890c..1083ea22ce6 100644
--- a/srcpkgs/kwin/template
+++ b/srcpkgs/kwin/template
@@ -1,7 +1,7 @@
 # Template file for 'kwin'
 pkgname=kwin
-version=5.19.5
-revision=2
+version=5.20.0
+revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
 hostmakedepends="extra-cmake-modules gettext breeze pkg-config"
@@ -9,14 +9,16 @@ makedepends="plasma-framework-devel kcmutils-devel knewstuff-devel
  kscreenlocker-devel kinit-devel xcb-util-cursor-devel qt5-multimedia-devel
  kdecoration-devel libxkbcommon-devel libinput-devel libSM-devel
  libICE-devel xcb-util-wm-devel qt5-sensors-devel libcap-devel
- kwayland-server-devel"
+ kwayland-server-devel $(vopt_if pipewire pipewire-devel)"
 depends="breeze hicolor-icon-theme kinit qt5-core>=5.15.1<5.15.2"
 short_desc="KDE Window manager"
 maintainer="John <me@johnnynator.dev>"
 license="GPL-2.0-or-later"
 homepage="https://invent.kde.org/plasma/kwin"
 distfiles="${KDE_SITE}/plasma/${version}/${pkgname}-${version}.tar.xz"
-checksum=36afa37b773d31c0bcb8f4e32fa1f06cc33e15ad00e729ba36f120bbe034903b
+checksum=b91d6101d0a303d42ce05c1a04d7e2e2b0c91ecde3153dac36b17e73cd1a9c96
+
+build_options="pipewire"
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" qt5-qmake qt5-host-tools kcoreaddons kconfig"

From 6f010eab5e2e8a4d8cfce7c0058e7fefff6861e0 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 17 Sep 2020 21:11:15 +0200
Subject: [PATCH 279/312] kwrited: update to 5.20.0

[ci skip]
---
 srcpkgs/kwrited/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kwrited/template b/srcpkgs/kwrited/template
index 06d9b498bee..e7eff31ad29 100644
--- a/srcpkgs/kwrited/template
+++ b/srcpkgs/kwrited/template
@@ -1,6 +1,6 @@
 # Template file for 'kwrited'
 pkgname=kwrited
-version=5.19.5
+version=5.20.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -11,4 +11,4 @@ maintainer="John <me@johnnynator.dev>"
 license="GPL-2.0-or-later"
 homepage="https://invent.kde.org/plasma/kwrited"
 distfiles="${KDE_SITE}/plasma/${version}/${pkgname}-${version}.tar.xz"
-checksum=c934d9c85581db575da0559713f1c0bba0541749ea36a51f9cbce7454c2af4db
+checksum=a0ac927655804be22426049ee8b520133b10c8901d364fdd0ef8e03ce17b9b82

From a063db14caa260c82a4cfc36d1e9a05a4d6bf1e5 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 17 Sep 2020 21:11:21 +0200
Subject: [PATCH 280/312] libkscreen: update to 5.20.0

[ci skip]
---
 srcpkgs/libkscreen/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/libkscreen/template b/srcpkgs/libkscreen/template
index c83334190de..9d5f409f45a 100644
--- a/srcpkgs/libkscreen/template
+++ b/srcpkgs/libkscreen/template
@@ -1,6 +1,6 @@
 # Template file for 'libkscreen'
 pkgname=libkscreen
-version=5.19.5
+version=5.20.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -11,7 +11,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later"
 homepage="https://invent.kde.org/plasma/libkscreen"
 distfiles="${KDE_SITE}/plasma/${version}/${pkgname}-${version}.tar.xz"
-checksum=11351cbed924264c6ccd8b95bd7fcaeed3477abb31e962894b0630ef41bdc165
+checksum=45c799f0d2c8c9d5ef2f6d0cc0451d5ae25c9d6f955924f57202fc88c85f655e
 
 libkscreen-devel_package() {
 	short_desc+=" - development"

From 8fae2b9d02d0a29791841be02c14f4c6f3ad3a0c Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 17 Sep 2020 21:11:25 +0200
Subject: [PATCH 281/312] libksysguard: update to 5.20.0

[ci skip]
---
 common/shlibs                 | 1 +
 srcpkgs/libksysguard/template | 4 ++--
 2 files changed, 3 insertions(+), 2 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index e50e44f1246..4b8a40bda01 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -471,6 +471,7 @@ libksgrd.so.9 libksysguard-5.18.90_1
 libprocesscore.so.9 libksysguard-5.18.90_1
 liblsofui.so.9 libksysguard-5.18.90_1
 libKSysGuardSensorFaces.so.1 libksysguard-5.18.90_1
+libKSysGuardFormatter.so.1 libksysguard-5.19.5_1
 libKWaylandServer.so.5 kwayland-server-5.18.90_1
 libxenctrl.so.4.14 xen-libs-4.14.0_1
 libxenfsimage.so.4.14 xen-libs-4.14.0_1
diff --git a/srcpkgs/libksysguard/template b/srcpkgs/libksysguard/template
index da1f7eec880..3cc75a5a066 100644
--- a/srcpkgs/libksysguard/template
+++ b/srcpkgs/libksysguard/template
@@ -1,6 +1,6 @@
 # Template file for 'libksysguard'
 pkgname=libksysguard
-version=5.19.5
+version=5.20.0
 revision=1
 build_style=cmake
 hostmakedepends="extra-cmake-modules gettext kauth qt5-host-tools qt5-qmake"
@@ -11,7 +11,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later"
 homepage="https://invent.kde.org/plasma/libksysguard"
 distfiles="${KDE_SITE}/plasma/${version}/${pkgname}-${version}.tar.xz"
-checksum=d8adb311dae1a699a3fd3fbdc9e6cdde037503ca303b70f12d33b985ee80a0cd
+checksum=dd0be43db2170a5babdfc5afb56c418fa838ced9f5a9a99ee60ae34e4f4b67af
 
 build_options="webengine"
 

From fb643715b66ef99909e4955e9252707546f61f9b Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 17 Sep 2020 21:11:28 +0200
Subject: [PATCH 282/312] milou: update to 5.20.0

[ci skip]
---
 srcpkgs/milou/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/milou/template b/srcpkgs/milou/template
index 9f9b678aceb..5e9da08d0b1 100644
--- a/srcpkgs/milou/template
+++ b/srcpkgs/milou/template
@@ -1,6 +1,6 @@
 # Template file for 'milou'
 pkgname=milou
-version=5.19.5
+version=5.20.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -12,7 +12,7 @@ maintainer="John <me@johnnynator.dev>"
 license="GPL-2.0-or-later, LPGL-2.1-or-later"
 homepage="https://invent.kde.org/plasma/milou"
 distfiles="${KDE_SITE}/plasma/${version}/${pkgname}-${version}.tar.xz"
-checksum=edc6e5c646a98f6f3eada802995c1308c84a5ae7aef467e9d4ce1deaf8a9040e
+checksum=7637f088a6030e17bb6513c42b1d83645c86db07f1b29f5354322f59cff0821e
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" kpackage-devel kconfig-devel kcoreaddons-devel plasma-framework"

From f7eb279992bec277218bf0169b4ddc0175c12b55 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 17 Sep 2020 21:11:32 +0200
Subject: [PATCH 283/312] oxygen: update to 5.20.0

[ci skip]
---
 srcpkgs/oxygen/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/oxygen/template b/srcpkgs/oxygen/template
index 5c737cbcaea..f95a82c2c56 100644
--- a/srcpkgs/oxygen/template
+++ b/srcpkgs/oxygen/template
@@ -1,6 +1,6 @@
 # Template file for 'oxygen'
 pkgname=oxygen
-version=5.19.5
+version=5.20.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -13,4 +13,4 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later, GPL-2.0-or-later"
 homepage="https://invent.kde.org/plasma/oxygen"
 distfiles="${KDE_SITE}/plasma/${version}/${pkgname}-${version}.tar.xz"
-checksum=4217d4da0f851d6e3fc25cdaa3f3123611e5e89d676ba33fa1c0fd02cddb0c35
+checksum=d01f9ca96d7693c02e97ee9b6a8c55c47ef96b4bde7a7c159813ff41ce0d3d09

From 2e5fba845d012228946d9020fb8622f38cfe5300 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 17 Sep 2020 21:11:34 +0200
Subject: [PATCH 284/312] plasma-browser-integration: update to 5.20.0

[ci skip]
---
 srcpkgs/plasma-browser-integration/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/plasma-browser-integration/template b/srcpkgs/plasma-browser-integration/template
index c7330e57bb6..fff2c4f873f 100644
--- a/srcpkgs/plasma-browser-integration/template
+++ b/srcpkgs/plasma-browser-integration/template
@@ -1,6 +1,6 @@
 # Template file for 'plasma-browser-integration'
 pkgname=plasma-browser-integration
-version=5.19.5
+version=5.20.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -13,7 +13,7 @@ maintainer="1is7ac3 <isaac.qa13@gmail.com>"
 license="GPL-3.0-or-later"
 homepage="https://invent.kde.org/plasma/plasma-browser-integration"
 distfiles="${KDE_SITE}/plasma/${version}/${pkgname}-${version}.tar.xz"
-checksum=29cb30b86f9f25857ba7e67bcb892e9a1dabfd4eec1767b0c4ca0a1400d61dcf
+checksum=8fb5bff4b1f170187bd7100ad3465b4e3cd4854c6d593a87ef162c9f7e0b9fe3
 
 if [ "${CROSS_BUILD}" ]; then
 	configure_args+=" -DDESKTOPTOJSON_EXECUTABLE=/usr/bin/desktoptojson"

From 0807ac18a413fe657d263f9587ccfdf72fe821cb Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 17 Sep 2020 21:12:50 +0200
Subject: [PATCH 285/312] plasma-desktop: update to 5.20.0

[ci skip]
---
 .../patches/no-discover-recommendation.patch      | 15 +++++++++++++++
 srcpkgs/plasma-desktop/template                   |  5 +++--
 2 files changed, 18 insertions(+), 2 deletions(-)
 create mode 100644 srcpkgs/plasma-desktop/patches/no-discover-recommendation.patch

diff --git a/srcpkgs/plasma-desktop/patches/no-discover-recommendation.patch b/srcpkgs/plasma-desktop/patches/no-discover-recommendation.patch
new file mode 100644
index 00000000000..c2c50bc46c3
--- /dev/null
+++ b/srcpkgs/plasma-desktop/patches/no-discover-recommendation.patch
@@ -0,0 +1,15 @@
+We don't ship Discover and the taskmanager doesn't check if the defaults even
+exist and having a not working link by default in the taskbar is well, useless.
+
+---
+--- applets/taskmanager/package/contents/config/main.xml	2020-09-17 13:26:23.000000000 +0200
++++ -	2020-09-18 17:24:15.772878765 +0200
+@@ -77,7 +77,7 @@
+     </entry>
+     <entry name="launchers" type="StringList">
+       <label>The list of launcher tasks on the widget. Usually .desktop file or executable URLs. Special URLs such as preferred://browser that expand to default applications are supported.</label>
+-      <default>applications:systemsettings.desktop,applications:org.kde.discover.desktop,preferred://filemanager,preferred://browser</default>
++      <default>applications:systemsettings.desktop,preferred://filemanager,preferred://browser</default>
+     </entry>
+     <entry name="middleClickAction" type="Enum">
+       <label>What to do on middle-mouse click on a task button.</label>
diff --git a/srcpkgs/plasma-desktop/template b/srcpkgs/plasma-desktop/template
index abf7a431a87..780966031c4 100644
--- a/srcpkgs/plasma-desktop/template
+++ b/srcpkgs/plasma-desktop/template
@@ -1,6 +1,6 @@
 # Template file for 'plasma-desktop'
 pkgname=plasma-desktop
-version=5.19.5
+version=5.20.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -15,7 +15,8 @@ maintainer="John <me@johnnynator.dev>"
 license="GPL-2.0-or-later, LGPL-2.0-or-later, LGPL-2.1-or-later, GFDL-1.2"
 homepage="https://invent.kde.org/plasma/plasma-desktop"
 distfiles="${KDE_SITE}/plasma/${version}/${pkgname}-${version}.tar.xz"
-checksum=c63e1c81edc438656f9159e235be31e3b1b11a3f8ecbe5b97b21fcc91eb71a70
+checksum=4bf5aa68ac132fa651a2694af772342ece61da2a3a2c1d7c6da75c84bec6b87f
+replaces="user-manager>=0"
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" kconfig-devel kcoreaddons-devel kded

From 5a5cfc3f48c1c9150d643a5dafa801c63f80550c Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 17 Sep 2020 21:13:09 +0200
Subject: [PATCH 286/312] plasma-integration: update to 5.20.0

[ci skip]
---
 srcpkgs/plasma-integration/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/plasma-integration/template b/srcpkgs/plasma-integration/template
index f82030b8e57..d4370729a8b 100644
--- a/srcpkgs/plasma-integration/template
+++ b/srcpkgs/plasma-integration/template
@@ -1,6 +1,6 @@
 # Template file for 'plasma-integration'
 pkgname=plasma-integration
-version=5.19.5
+version=5.20.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -14,4 +14,4 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.0-or-later"
 homepage="https://invent.kde.org/plasma/plasma-integration"
 distfiles="${KDE_SITE}/plasma/${version}/${pkgname}-${version}.tar.xz"
-checksum=f7fdd854e78e366a310116ef190bd7bed42df15a059d8ad75b763cbcebfb6389
+checksum=a6382a4330d2a2117578c2e2d42e4e7588622c522e8cbfe4c537918680479e2b

From 80132e24d5c25dc03ea7d66ea3ee19536fbbde54 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 17 Sep 2020 21:13:11 +0200
Subject: [PATCH 287/312] plasma-nm: update to 5.20.0

[ci skip]
---
 srcpkgs/plasma-nm/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/plasma-nm/template b/srcpkgs/plasma-nm/template
index 7f9e18b413a..229d51dabf2 100644
--- a/srcpkgs/plasma-nm/template
+++ b/srcpkgs/plasma-nm/template
@@ -1,6 +1,6 @@
 # Template file for 'plasma-nm'
 pkgname=plasma-nm
-version=5.19.5
+version=5.20.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -15,7 +15,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later"
 homepage="https://invent.kde.org/plasma/plasma-nm"
 distfiles="${KDE_SITE}/plasma/${version}/${pkgname}-${version}.tar.xz"
-checksum=433fe0329bacaede666d4d0962c5dedf6b4449f7c7ad08870ae9554ad64f2bb9
+checksum=a0a3593714d165844719c1adbd1ab596a578c15579d9c5533b9e15c2cd8f9dfb
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" kpackage-devel kconfig-devel kcoreaddons-devel plasma-framework"

From 4db8ec957005356ddf4e9e4957cf693e18b8062b Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 17 Sep 2020 21:13:13 +0200
Subject: [PATCH 288/312] plasma-pa: update to 5.20.0

[ci skip]
---
 srcpkgs/plasma-pa/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/plasma-pa/template b/srcpkgs/plasma-pa/template
index 14ff2b40773..dd7a41610b5 100644
--- a/srcpkgs/plasma-pa/template
+++ b/srcpkgs/plasma-pa/template
@@ -1,6 +1,6 @@
 # Template file for 'plasma-pa'
 pkgname=plasma-pa
-version=5.19.5
+version=5.20.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -13,7 +13,7 @@ maintainer="John <me@johnnynator.dev>"
 license="LGPL-2.1-or-later"
 homepage="https://invent.kde.org/plasma/plasma-pa"
 distfiles="${KDE_SITE}/plasma/${version}/${pkgname}-${version}.tar.xz"
-checksum=b00eb9bc7c7bd35f3ae78f58522cea8d1dd86b9b20585dff83fb93ef64af91d8
+checksum=8735726a0ce31d522ac410863a5940a4505eb7c98feab893bc38ed5217b57999
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" kpackage-devel kconfig-devel kcoreaddons-devel"

From 5b633170a5dc2e222a84576a5f72d37e458cc835 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 17 Sep 2020 21:13:15 +0200
Subject: [PATCH 289/312] plasma-sdk: update to 5.20.0

[ci skip]
---
 srcpkgs/plasma-sdk/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/plasma-sdk/template b/srcpkgs/plasma-sdk/template
index d6bc9717b13..1d079cbd040 100644
--- a/srcpkgs/plasma-sdk/template
+++ b/srcpkgs/plasma-sdk/template
@@ -1,6 +1,6 @@
 # Template file for 'plasma-sdk'
 pkgname=plasma-sdk
-version=5.19.5
+version=5.20.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -13,7 +13,7 @@ maintainer="John <me@johnnynator.dev>"
 license="GPL-2.0-or-later, LGPL-2.1-or-later"
 homepage="https://invent.kde.org/plasma/plasma-sdk"
 distfiles="${KDE_SITE}/plasma/${version}/${pkgname}-${version}.tar.xz"
-checksum=8c434adbb6c68ce42581152269d7e0717f16362017290a96f2c5f1922930da20
+checksum=b1d7cf1f64f5468c1769d7f442d7e324254a84a74b777313fb2e2bd97e3bcc5c
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" kpackage-devel kconfig-devel kcoreaddons-devel plasma-framework"

From 45eddefbd0a799b702742033b516103e6d2c833b Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 17 Sep 2020 21:13:17 +0200
Subject: [PATCH 290/312] plasma-thunderbolt: update to 5.20.0

[ci skip]
---
 srcpkgs/plasma-thunderbolt/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/plasma-thunderbolt/template b/srcpkgs/plasma-thunderbolt/template
index 879a67aae99..66972471847 100644
--- a/srcpkgs/plasma-thunderbolt/template
+++ b/srcpkgs/plasma-thunderbolt/template
@@ -1,6 +1,6 @@
 # Template file for 'plasma-thunderbolt'
 pkgname=plasma-thunderbolt
-version=5.19.5
+version=5.20.0
 revision=1
 build_style=cmake
 hostmakedepends="extra-cmake-modules kcoreaddons kcmutils
@@ -12,7 +12,7 @@ maintainer="John <me@johnnynator.dev>"
 license="GPL-3.0-or-later"
 homepage="https://invent.kde.org/plasma/plasma-thunderbolt"
 distfiles="${KDE_SITE}/plasma/${version}/${pkgname}-${version}.tar.xz"
-checksum=959b4eb43b58d46895c94c94c082b28277ca197cdcaa25880800502ace6d0295
+checksum=01b98dbc133a70c792ec5cce8f7ae404f9cbe3897b19308ad746215c19b93715
 
 do_check() {
 	: # Requires running dbus and bolt services

From 17b879ea350d3fce6da35c8a478e20e7b968b2c0 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 17 Sep 2020 21:13:20 +0200
Subject: [PATCH 291/312] plasma-vault: update to 5.20.0

[ci skip]
---
 srcpkgs/plasma-vault/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/plasma-vault/template b/srcpkgs/plasma-vault/template
index 1d7b3dd8562..45baaa1a4dc 100644
--- a/srcpkgs/plasma-vault/template
+++ b/srcpkgs/plasma-vault/template
@@ -1,6 +1,6 @@
 # Template file for 'plasma-vault'
 pkgname=plasma-vault
-version=5.19.5
+version=5.20.0
 revision=1
 build_style=cmake
 hostmakedepends="extra-cmake-modules kcoreaddons qt5-qmake qt5-host-tools
@@ -11,7 +11,7 @@ maintainer="Giuseppe Fierro <gspe@ae-design.ws>"
 license="GPL-2.0-or-later, LGPL-2.0-or-later, LGPL-2.1-or-later"
 homepage="https://github.com/KDE/plasma-vault"
 distfiles="${KDE_SITE}/plasma/${version}/${pkgname}-${version}.tar.xz"
-checksum=7f81321f32f3784683fa7d9511dca9bfba70a7a9181a33e832d864c639b05204
+checksum=8143a48b6b158a012a02b12e6167374bf3238f9b6c053d21af10f809de3ec7ef
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" kpackage-devel kconfig-devel kcoreaddons-devel plasma-framework"

From dbd7ee7662abbf1e70f7f990e77f3628a0541ead Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 17 Sep 2020 21:18:49 +0200
Subject: [PATCH 292/312] plasma-workspace: update to 5.20.0

[ci skip]
---
 srcpkgs/plasma-workspace/template | 15 +++++++++------
 1 file changed, 9 insertions(+), 6 deletions(-)

diff --git a/srcpkgs/plasma-workspace/template b/srcpkgs/plasma-workspace/template
index e842147983c..08855af0d79 100644
--- a/srcpkgs/plasma-workspace/template
+++ b/srcpkgs/plasma-workspace/template
@@ -1,17 +1,18 @@
 # Template file for 'plasma-workspace'
 pkgname=plasma-workspace
-version=5.19.5
+version=5.20.0
 revision=1
 build_style=cmake
-configure_args="-DBUILD_TESTING=OFF"
+configure_args="-DBUILD_TESTING=OFF -DWaylandScanner_EXECUTABLE=/usr/bin/wayland-scanner"
 hostmakedepends="extra-cmake-modules iso-codes pkg-config kdoctools kcoreaddons
- gettext"
+ qt5-wayland plasma-wayland-protocols gettext wayland-devel"
 makedepends="qt5-devel qt5-declarative-devel qt5-script-devel plasma-framework-devel
  krunner-devel kjsembed-devel knotifyconfig-devel kdesu-devel knewstuff-devel
  kcmutils-devel kidletime-devel kdelibs4support-devel libksysguard-devel
  baloo5-devel ktexteditor-devel kwin-devel libxcb-devel libXtst-devel
  libqalculate-devel prison-devel kholidays-devel ksolid-devel kpeople-devel
- libkscreen-devel kactivities5-stats-devel"
+ libXft-devel libkscreen-devel kactivities5-stats-devel
+ $(vopt_if pipewire pipewire-devel)"
 depends="kactivitymanagerd kwin iso-codes milou plasma-integration
  kquickcharts qt5-wayland xorg-server-xwayland"
 short_desc="KDE Window manager"
@@ -19,10 +20,12 @@ maintainer="John <me@johnnynator.dev>"
 license="GPL-2.0-or-later, GFDL-1.2-or-later, LGPL-2.1-or-later"
 homepage="https://invent.kde.org/plasma/plasma-workspace"
 distfiles="${KDE_SITE}/plasma/${version}/${pkgname}-${version}.tar.xz"
-checksum=490329e08e63016edd696a9132bf80b76ef51dacf53308b865d2e27b67ce8127
+checksum=20fc599fdfc6477c7315fdf3059bae7ac4843294e550a8d18b6cf1af2ed2b2ca
+
+build_options="pipewire"
 
 if [ "$CROSS_BUILD" ]; then
-	hostmakedepends+=" kpackage-devel kconfig-devel kcoreaddons-devel plasma-framework"
+	hostmakedepends+=" kcmutils kpackage-devel kconfig-devel kcoreaddons-devel plasma-framework"
 	configure_args+=" -DKF5_HOST_TOOLING=/usr/lib/cmake"
 fi
 

From c03b74c0df5a305960501cd7739d7cf4b964d45f Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 17 Sep 2020 21:18:51 +0200
Subject: [PATCH 293/312] polkit-kde-agent: update to 5.20.0

[ci skip]
---
 srcpkgs/polkit-kde-agent/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/polkit-kde-agent/template b/srcpkgs/polkit-kde-agent/template
index f11a0a73409..7cd84ee627d 100644
--- a/srcpkgs/polkit-kde-agent/template
+++ b/srcpkgs/polkit-kde-agent/template
@@ -1,6 +1,6 @@
 # Template file for 'polkit-kde-agent'
 pkgname=polkit-kde-agent
-version=5.19.5
+version=5.20.0
 revision=1
 wrksrc="${pkgname}-1-${version}"
 build_style=cmake
@@ -13,4 +13,4 @@ maintainer="John <me@johnnynator.dev>"
 license="GPL-2.0-or-later"
 homepage="https://commits.kde.org/polkit-kde-agent"
 distfiles="${KDE_SITE}/plasma/${version}/${pkgname}-1-${version}.tar.xz"
-checksum=076129f450a82780f354d7ec18300094db3f7233cb52f4e57298b973750adb30
+checksum=838d2354f32dc305cdd485b69dc70b7e7a6c408d72ae623929493fcdea28455c

From df3bc274385abde258c80e6694dacd516c56e694 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 17 Sep 2020 21:18:55 +0200
Subject: [PATCH 294/312] powerdevil: update to 5.20.0

[ci skip]
---
 srcpkgs/powerdevil/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/powerdevil/template b/srcpkgs/powerdevil/template
index cee4e994895..65fdc3253a4 100644
--- a/srcpkgs/powerdevil/template
+++ b/srcpkgs/powerdevil/template
@@ -1,6 +1,6 @@
 # Template file for 'powerdevil'
 pkgname=powerdevil
-version=5.19.5
+version=5.20.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -13,4 +13,4 @@ maintainer="John <me@johnnynator.dev>"
 license="GPL-2.0-or-later"
 homepage="https://invent.kde.org/plasma/powerdevil"
 distfiles="${KDE_SITE}/plasma/${version}/${pkgname}-${version}.tar.xz"
-checksum=d15f013c50928097f6b719aca46ec2a93a997dcbb7584bcb09f18015cca8ac1a
+checksum=f2a383473e1dc2e7067cb808c02ad657a6999361bdfb3fbdcac4c99e5cf8fcee

From d5e056e1604f841d941512ad1cce6bc1e73cfa88 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 17 Sep 2020 21:18:57 +0200
Subject: [PATCH 295/312] sddm-kcm: update to 5.20.0

[ci skip]
---
 srcpkgs/sddm-kcm/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/sddm-kcm/template b/srcpkgs/sddm-kcm/template
index b114a88b006..042be4db803 100644
--- a/srcpkgs/sddm-kcm/template
+++ b/srcpkgs/sddm-kcm/template
@@ -1,6 +1,6 @@
 # Template file for 'sddm-kcm'
 pkgname=sddm-kcm
-version=5.19.5
+version=5.20.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -14,4 +14,4 @@ maintainer="John <me@johnnynator.dev>"
 license="GPL-2.0-or-later"
 homepage="https://invent.kde.org/plasma/sddm-kcm"
 distfiles="${KDE_SITE}/plasma/${version}/${pkgname}-${version}.tar.xz"
-checksum=3ba2c6821fc847fca2cb8123748bf05cdd9c45557a0ecab5dc43a37a5ebde738
+checksum=c0d75983f8e1ebc4c7f57524fc6028c40446eaa35f9972088d1ebb17469fa3e1

From 1064d493d06e638c150f69cecddcd93ef7272727 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 17 Sep 2020 21:19:00 +0200
Subject: [PATCH 296/312] systemsettings: update to 5.20.0.1

[ci skip]
---
 srcpkgs/systemsettings/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/systemsettings/template b/srcpkgs/systemsettings/template
index 277fa40336a..87f4217e579 100644
--- a/srcpkgs/systemsettings/template
+++ b/srcpkgs/systemsettings/template
@@ -1,6 +1,6 @@
 # Template file for 'systemsettings'
 pkgname=systemsettings
-version=5.19.5
+version=5.20.0.1
 revision=1
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
@@ -12,8 +12,8 @@ short_desc="KDE System settings"
 maintainer="John <me@johnnynator.dev>"
 license="GPL-2.0-or-later, GFDL-1.2"
 homepage="https://invent.kde.org/plasma/systemsettings"
-distfiles="${KDE_SITE}/plasma/${version}/${pkgname}-${version}.tar.xz"
-checksum=ba8fdc2b8c861e7271bad7f6c5cdb92b0c2eee08ef81b86e28bba064259e2ff9
+distfiles="${KDE_SITE}/plasma/${version%.1}/${pkgname}-${version}.tar.xz"
+checksum=fd6309845f6b1a88a4a6e5c60b92da4d2ce4c3aacb0d998ac51575306ca451e2
 
 if [ "$CROSS_BUILD" ]; then
 	hostmakedepends+=" python qt5-qmake qt5-host-tools kconfig

From bb25ff3c862c3e79f15a811524ec62c5d072e069 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 17 Sep 2020 21:19:02 +0200
Subject: [PATCH 297/312] Remove package: user-manager-5.19.5

[ci skip]
---
 srcpkgs/user-manager/template | 17 -----------------
 1 file changed, 17 deletions(-)
 delete mode 100644 srcpkgs/user-manager/template

diff --git a/srcpkgs/user-manager/template b/srcpkgs/user-manager/template
deleted file mode 100644
index 5a87e92e2fd..00000000000
--- a/srcpkgs/user-manager/template
+++ /dev/null
@@ -1,17 +0,0 @@
-# Template file for 'user-manager'
-pkgname=user-manager
-version=5.19.5
-revision=1
-build_style=cmake
-configure_args="-DBUILD_TESTING=OFF"
-hostmakedepends="extra-cmake-modules pkg-config qt5-qmake qt5-host-tools
- gettext kcoreaddons"
-makedepends="accountsservice-devel kdelibs4support-devel libpwquality-devel
- kdesignerplugin-devel kdoctools-devel kcmutils-devel"
-depends="accountsservice"
-short_desc="KDE user manager"
-maintainer="John <me@johnnynator.dev>"
-license="GPL-2.0-or-later"
-homepage="https://invent.kde.org/plasma/user-manager"
-distfiles="${KDE_SITE}/plasma/${version}/${pkgname}-${version}.tar.xz"
-checksum=39260b2575f6287c8086984417bba18682ca2ba3840d93f95667d0d2faa461cc

From 245fe2e5a9cd5831bb26852c927a95e312592770 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 17 Sep 2020 21:19:04 +0200
Subject: [PATCH 298/312] xdg-desktop-portal-kde: update to 5.20.0

[ci skip]
---
 srcpkgs/xdg-desktop-portal-kde/template | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/xdg-desktop-portal-kde/template b/srcpkgs/xdg-desktop-portal-kde/template
index 849fd81c430..7fd92b8b870 100644
--- a/srcpkgs/xdg-desktop-portal-kde/template
+++ b/srcpkgs/xdg-desktop-portal-kde/template
@@ -1,10 +1,11 @@
 # Template file for 'xdg-desktop-portal-kde'
 pkgname=xdg-desktop-portal-kde
-version=5.19.5
+version=5.20.0
 revision=1
 build_style=cmake
+configure_args="-DWaylandScanner_EXECUTABLE=/usr/bin/wayland-scanner"
 hostmakedepends="extra-cmake-modules qt5-qmake qt5-host-tools kcoreaddons gettext
- pkg-config"
+ wayland-devel plasma-wayland-protocols pkg-config qt5-wayland"
 makedepends="glib-devel kio-devel kwayland-devel libepoxy-devel pipewire-devel
  plasma-framework-devel kdeclarative-devel kirigami2-devel"
 short_desc="Backend implementation for xdg-desktop-portal that is using Qt/KF5"
@@ -12,4 +13,4 @@ maintainer="John <me@johnnynator.dev>"
 license="GPL-3.0-or-later"
 homepage="https://phabricator.kde.org/source/xdg-desktop-portal-kde/"
 distfiles="${KDE_SITE}/plasma/${version}/${pkgname}-${version}.tar.xz"
-checksum=055e7c379dc3e0edb8d87515468b8d16a70bd99765f269a211ce655eb3e1ea45
+checksum=0afd9418a291ea4a8cb1eaa85234b4210ca399493a2f614cf62a45d644dbe5bb

From 9f64188d1479bda54c77fbb12dab862fa97d98d3 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 17 Sep 2020 21:19:17 +0200
Subject: [PATCH 299/312] plasma-workspace-wallpapers: update to 5.20.0.

---
 srcpkgs/plasma-workspace-wallpapers/template | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/plasma-workspace-wallpapers/template b/srcpkgs/plasma-workspace-wallpapers/template
index 70665885c70..1eb02b5d743 100644
--- a/srcpkgs/plasma-workspace-wallpapers/template
+++ b/srcpkgs/plasma-workspace-wallpapers/template
@@ -1,8 +1,7 @@
 # Template file for 'plasma-workspace-wallpapers'
 pkgname=plasma-workspace-wallpapers
-version=5.19.5
+version=5.20.0
 revision=1
-archs=noarch
 build_style=cmake
 configure_args="-DBUILD_TESTING=OFF"
 hostmakedepends="extra-cmake-modules qt5-qmake qt5-host-tools"
@@ -11,4 +10,4 @@ maintainer="John <me@johnnynator.dev>"
 license="GPL-2.0-or-later"
 homepage="https://invent.kde.org/plasma/plasma-workspace-wallpapers"
 distfiles="${KDE_SITE}/plasma/${version}/${pkgname}-${version}.tar.xz"
-checksum=4aeec36035356cca71c0966e9d7dbc7d9fca6be4c27abd990f0fa954a91374f9
+checksum=23f7b0b795c702f834dfb737e19d3a4f48a906471cdec98ec1248d4c970532ef

From 53a85e29bd1dc0d03af56d911a81a25cb86053a7 Mon Sep 17 00:00:00 2001
From: John <me@johnnynator.dev>
Date: Thu, 17 Sep 2020 21:23:17 +0200
Subject: [PATCH 300/312] kde5: update to 5.20.0.

[ci skip]
---
 srcpkgs/kde5/template | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/srcpkgs/kde5/template b/srcpkgs/kde5/template
index d25ad7c73a2..3d9df2828ec 100644
--- a/srcpkgs/kde5/template
+++ b/srcpkgs/kde5/template
@@ -1,6 +1,6 @@
 # Template file for 'kde5'
 pkgname=kde5
-version=5.19.0
+version=5.20.0
 revision=1
 build_style=meta
 depends="bluedevil>=${version}
@@ -22,7 +22,6 @@ depends="bluedevil>=${version}
  plasma-workspace-wallpapers>=${version}
  powerdevil>=${version}
  sddm-kcm>=${version}
- user-manager>=${version}
  xdg-desktop-portal-kde>=${version}
  plasma-thunderbolt>=${version}
  elogind

From 3ce0a4d548fbb9eba96264a815424c4708d8b887 Mon Sep 17 00:00:00 2001
From: Johannes <johannes.brechtmann@gmail.com>
Date: Fri, 16 Oct 2020 13:05:18 +0200
Subject: [PATCH 301/312] kdenlive: update to 20.08.2.

---
 srcpkgs/kdenlive/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kdenlive/template b/srcpkgs/kdenlive/template
index d79cdc8f13c..cdef703f357 100644
--- a/srcpkgs/kdenlive/template
+++ b/srcpkgs/kdenlive/template
@@ -1,6 +1,6 @@
 # Template file for 'kdenlive'
 pkgname=kdenlive
-version=20.08.1
+version=20.08.2
 revision=1
 build_style=cmake
 hostmakedepends="
@@ -17,7 +17,7 @@ maintainer="johannes <johannes.brechtmann@gmail.com>"
 license="GPL-3.0-or-later"
 homepage="https://kdenlive.org"
 distfiles="${KDE_SITE}/release-service/${version}/src/${pkgname}-${version}.tar.xz"
-checksum=f99e3f22c3d5e41a3ca251299d010ac2bc44933091c25d360104d562a1090873
+checksum=535df45a148f0f94271e045ef0c93575fded83da7a2b727aeaf90e61e1d7c418
 
 # needed for mlt to work on musl
 CXXFLAGS="-DHAVE_LOCALE_H=1"

From 354d7b0fec31f45c8926db6db8ad6f28d254ffe2 Mon Sep 17 00:00:00 2001
From: Johannes <johannes.brechtmann@gmail.com>
Date: Fri, 16 Oct 2020 20:22:46 +0200
Subject: [PATCH 302/312] ImageMagick6: update to 6.9.11.34.

---
 srcpkgs/ImageMagick6/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/ImageMagick6/template b/srcpkgs/ImageMagick6/template
index 865031c4d76..715e6b4951b 100644
--- a/srcpkgs/ImageMagick6/template
+++ b/srcpkgs/ImageMagick6/template
@@ -1,7 +1,7 @@
 # Template file for 'ImageMagick6'
 pkgname=ImageMagick6
 _majorver=6.9.11
-_patchver=32
+_patchver=34
 version="${_majorver}.${_patchver}"
 revision=1
 wrksrc="${pkgname}-${_majorver}-${_patchver}"
@@ -20,7 +20,7 @@ maintainer="Johannes <johannes.brechtmann@gmail.com>"
 license="ImageMagick"
 homepage="https://www.imagemagick.org/"
 distfiles="https://github.com/ImageMagick/ImageMagick6/archive/${_majorver}-${_patchver}.tar.gz"
-checksum=c5b7d9cc5959ab72f8b1aa027b2fbfd69ce576527b8e5cf7ae02415eb2a4de3f
+checksum=6ad724edd690b895740cfc2a3e4d966f68987d52fbb630a14c7bc01c22e4368e
 
 keep_libtool_archives=yes
 conf_files="/etc/ImageMagick-${_majorver%%.*}/*.xml"

From 35416952f6f8af22cf59f8c3fc67d95ca79ca40e Mon Sep 17 00:00:00 2001
From: Johannes <johannes.brechtmann@gmail.com>
Date: Fri, 16 Oct 2020 20:22:42 +0200
Subject: [PATCH 303/312] ImageMagick: update to 7.0.10.34.

---
 srcpkgs/ImageMagick/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/ImageMagick/template b/srcpkgs/ImageMagick/template
index 777c787c43c..35da16f98e1 100644
--- a/srcpkgs/ImageMagick/template
+++ b/srcpkgs/ImageMagick/template
@@ -1,7 +1,7 @@
 # Template file for 'ImageMagick'
 pkgname=ImageMagick
 _majorver=7.0.10
-_patchver=32
+_patchver=34
 version="${_majorver}.${_patchver}"
 revision=1
 wrksrc="${pkgname}-${_majorver}-${_patchver}"
@@ -21,7 +21,7 @@ license="ImageMagick"
 homepage="https://www.imagemagick.org/"
 changelog="https://imagemagick.org/script/changelog.php"
 distfiles="https://github.com/ImageMagick/ImageMagick/archive/${_majorver}-${_patchver}.tar.gz"
-checksum=6a48b36b1ff66e281f26692a66d8d7b253d4e7c3d0e3e4ca71ea8a547bdc2ca4
+checksum=0202a99644785f0bd9de611bb3141fbf579d707eea2dd8706165c9be8160966d
 
 subpackages="libmagick libmagick-devel"
 

From 50ad0882d68388ec9c9bcc19d83c9104c809c023 Mon Sep 17 00:00:00 2001
From: Gerardo Di iorio <arete74@gmail.com>
Date: Thu, 8 Oct 2020 08:57:45 +0200
Subject: [PATCH 304/312] minio: update to 2020.10.12.

---
 srcpkgs/minio/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/minio/template b/srcpkgs/minio/template
index bdc2b7f0350..5c1f3488b11 100644
--- a/srcpkgs/minio/template
+++ b/srcpkgs/minio/template
@@ -1,8 +1,8 @@
 # Template file for 'minio'
 pkgname=minio
-version=2020.09.26
+version=2020.10.12
 revision=1
-_version="${version//./-}T03-44-56Z"
+_version="${version//./-}T21-53-21Z"
 wrksrc=${pkgname}-RELEASE.${_version}
 build_style=go
 go_import_path="github.com/minio/minio"
@@ -13,7 +13,7 @@ maintainer="Gerardo Di Iorio <arete74@gmail.com>"
 license="Apache-2.0"
 homepage="https://github.com/minio/minio"
 distfiles="${homepage}/archive/RELEASE.${_version}.tar.gz"
-checksum=8690bb968685e3d18a68b58ef77e60be24c775f92c8c50c4909dce4e2a48e6e1
+checksum=abfca74f525fe7ee6f259a42a68496b82864986ec2e2bdebac2fd8c787aa708c
 system_accounts="_minio"
 _minio_homedir="/var/lib/minio"
 _minio_descr="Minio Daemon User"

From 84a16ef7c08b808da0307d42752ce3ef42e7a87b Mon Sep 17 00:00:00 2001
From: Markus Uhlin <markus.uhlin@bredband.net>
Date: Sat, 10 Oct 2020 13:08:53 +0200
Subject: [PATCH 305/312] swirc: update to 3.2.5.

---
 srcpkgs/swirc/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/swirc/template b/srcpkgs/swirc/template
index 9b0643fc99e..9f35c447670 100644
--- a/srcpkgs/swirc/template
+++ b/srcpkgs/swirc/template
@@ -1,7 +1,7 @@
 # Template file for 'swirc'
 pkgname=swirc
-version=3.2.4
-revision=2
+version=3.2.5
+revision=1
 build_style=configure
 make_install_args="PREFIX=/usr"
 hostmakedepends="pkg-config which"
@@ -12,7 +12,7 @@ maintainer="Markus Uhlin <markus.uhlin@bredband.net>"
 license="BSD-3-Clause, ISC, MIT"
 homepage="https://www.nifty-networks.net/swirc"
 distfiles="https://www.nifty-networks.net/swirc/releases/${pkgname}-${version}.tgz"
-checksum="c8c15eeb6cc768a1b96952314420fea60c942b4dad25f6318d28dd2f00a02bc9"
+checksum="79ff8ee8e08bbbc313b9abb0f2c1641395a903b5ea114b8223cdaa71ec880ee0"
 
 post_configure() {
 	local _file="options.mk"

From 04398558f9cff65c84a2553c4cac4696cb6e327a Mon Sep 17 00:00:00 2001
From: Harrison Thorne <harrisonthorne@protonmail.com>
Date: Fri, 16 Oct 2020 13:20:41 -0600
Subject: [PATCH 306/312] spotify: update to 1.1.42

---
 srcpkgs/spotify/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/spotify/template b/srcpkgs/spotify/template
index 19fa0a45c53..1620c3dc791 100644
--- a/srcpkgs/spotify/template
+++ b/srcpkgs/spotify/template
@@ -1,8 +1,8 @@
 # Template file for 'spotify'
 pkgname=spotify
-version=1.1.26
-revision=2
-_ver="${version}.501.gbe11e53b-15_amd64"
+version=1.1.42
+revision=1
+_ver="${version}.622.gbd112320-37_amd64"
 _filename="spotify-client_${_ver}.deb"
 archs="x86_64"
 create_wrksrc=yes
@@ -14,7 +14,7 @@ maintainer="Stefan Mühlinghaus <jazzman@alphabreed.com>"
 license="custom:Proprietary"
 homepage="https://www.spotify.com"
 distfiles="http://repository.spotify.com/pool/non-free/s/spotify-client/${_filename}"
-checksum=54ba1bd91020913273c469591cedeebfa34aedc250033dde7c8b3fded94a9c71
+checksum=101a3699197659b8bc60a4fd8b579e63cc494e7abd089c45306559329af4a868
 _license_checksum=4a66993926096dd60fb03d7d82bd806f2f4b2d6ab2970aa0462e669f51f076a0
 repository=nonfree
 restricted=yes

From 13eb02341c9fdf9eb952062fccc95971b331b5bb Mon Sep 17 00:00:00 2001
From: Stefano Ragni <st3r4g@protonmail.com>
Date: Fri, 2 Oct 2020 23:54:40 +0200
Subject: [PATCH 307/312] libva: update to 2.9.0

---
 srcpkgs/libva/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/libva/template b/srcpkgs/libva/template
index 8f99983cfec..d681e84c848 100644
--- a/srcpkgs/libva/template
+++ b/srcpkgs/libva/template
@@ -1,6 +1,6 @@
 # Template file for 'libva'
 pkgname=libva
-version=2.8.0
+version=2.9.0
 revision=1
 build_style=meson
 configure_args="-Dwith_glx=no $(vopt_if wayland -Dwith_wayland=yes)"
@@ -8,12 +8,12 @@ hostmakedepends="pkg-config $(vopt_if wayland wayland-devel)"
 makedepends="libXfixes-devel libXext-devel libdrm-devel
  $(vopt_if wayland 'libffi-devel wayland-devel')"
 short_desc="Video Acceleration (VA) API"
-maintainer="Juan RP <xtraeme@gmail.com>"
+maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://01.org/linuxmedia/vaapi"
 changelog="https://raw.githubusercontent.com/intel/libva/master/NEWS"
 distfiles="https://github.com/intel/libva/archive/${version}.tar.gz"
-checksum=171bb8401930007945e87c765f22304e66e6e21c8a244a76389825dc2232671e
+checksum=f31549dd476e01504ba6ff62f69862eb78555a9809ebe737056543a189d619dc
 
 build_options="wayland"
 build_options_default="wayland"

From a56c96db71aa63ba45d7c5762627f929033b8aae Mon Sep 17 00:00:00 2001
From: Stefano Ragni <st3r4g@protonmail.com>
Date: Tue, 6 Oct 2020 11:07:33 +0200
Subject: [PATCH 308/312] libva-glx: update to 2.9.0

---
 srcpkgs/libva-glx/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/libva-glx/template b/srcpkgs/libva-glx/template
index 8867dafeb31..19ff3ba7980 100644
--- a/srcpkgs/libva-glx/template
+++ b/srcpkgs/libva-glx/template
@@ -7,7 +7,7 @@
 # KEEP THIS PACKAGE SYNCHRONIZED WITH "libva".
 #
 pkgname=libva-glx
-version=2.7.1
+version=2.9.0
 revision=1
 wrksrc="libva-${version}"
 build_style=meson
@@ -15,12 +15,12 @@ configure_args="-Dwith_glx=yes -Dwith_wayland=yes"
 hostmakedepends="pkg-config wayland-devel"
 makedepends="libva-devel libXfixes-devel MesaLib-devel wayland-devel"
 short_desc="Video Acceleration (VA) API - GLX backend"
-maintainer="Juan RP <xtraeme@gmail.com>"
+maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://01.org/linuxmedia/vaapi"
 changelog="https://raw.githubusercontent.com/intel/libva/master/NEWS"
 distfiles="https://github.com/intel/libva/archive/${version}.tar.gz"
-checksum=9a3167c9af8c0ce10c4a46791557f934457b78fcc625111dcefaa7f30b7eb289
+checksum=f31549dd476e01504ba6ff62f69862eb78555a9809ebe737056543a189d619dc
 
 post_install() {
 	# We are only interested in the glx component, remove everything else.

From 6297af6660481c463a4679705caeafbad844141c Mon Sep 17 00:00:00 2001
From: Stefano Ragni <st3r4g@protonmail.com>
Date: Tue, 6 Oct 2020 11:07:54 +0200
Subject: [PATCH 309/312] libva-utils: update to 2.9.0

---
 srcpkgs/libva-utils/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/libva-utils/template b/srcpkgs/libva-utils/template
index 6f6292e979d..b86a5c9c53a 100644
--- a/srcpkgs/libva-utils/template
+++ b/srcpkgs/libva-utils/template
@@ -1,18 +1,18 @@
 # Template file for 'libva-utils'
 pkgname=libva-utils
-version=2.7.1
+version=2.9.0
 revision=1
 build_style=meson
 configure_args="-Ddrm=true -Dx11=true -Dwayland=true"
 hostmakedepends="pkg-config wayland-devel"
 makedepends="libva-devel libXfixes-devel libXext-devel libdrm-devel wayland-devel"
 short_desc="Video Acceleration (VA) API - Utilities"
-maintainer="Juan RP <xtraeme@gmail.com>"
+maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://01.org/linuxmedia/vaapi"
 changelog="https://raw.githubusercontent.com/intel/libva-utils/master/NEWS"
 distfiles="https://github.com/intel/libva-utils/archive/${version}.tar.gz"
-checksum=9cf35b971001e7143dda14207b6891c12619a72a2ab99a9133b3da5b9c4d97dd
+checksum=d363210a42cd2667f6f7cff0e57db1d527feb067ffebe3ba233bc80b1bdcd9b4
 
 post_install() {
 	vlicense COPYING

From 36ecaf780db619950d09e6f7797c75804b59c185 Mon Sep 17 00:00:00 2001
From: Stefano Ragni <st3r4g@protonmail.com>
Date: Fri, 2 Oct 2020 23:54:49 +0200
Subject: [PATCH 310/312] libva-intel-driver: update to 2.4.1

Also drop -fcommon CFLAG.
---
 srcpkgs/libva-intel-driver/template | 12 +++++-------
 1 file changed, 5 insertions(+), 7 deletions(-)

diff --git a/srcpkgs/libva-intel-driver/template b/srcpkgs/libva-intel-driver/template
index 10003fc03f1..3cae1ab25b2 100644
--- a/srcpkgs/libva-intel-driver/template
+++ b/srcpkgs/libva-intel-driver/template
@@ -1,22 +1,20 @@
 # Template file for 'libva-intel-driver'
 pkgname=libva-intel-driver
-version=2.4.0
-revision=2
+version=2.4.1
+revision=1
+archs="i686* x86_64*"
 wrksrc="intel-vaapi-driver-${version}"
 build_style=meson
 configure_args="-Dwith_wayland=yes -Dwith_x11=yes"
 hostmakedepends="pkg-config"
 makedepends="libX11-devel libva-glx-devel libdrm-devel wayland-devel MesaLib-devel"
 short_desc="Video Acceleration (VA) API - Intel Graphics backend"
-maintainer="Juan RP <xtraeme@gmail.com>"
+maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://01.org/linuxmedia"
 changelog="https://raw.githubusercontent.com/intel/intel-vaapi-driver/master/NEWS"
 distfiles="https://github.com/intel/intel-vaapi-driver/archive/${version}.tar.gz"
-checksum=58567dac882167021f031489062cbbab76bc646214be0ee44d5f724d960b3d76
-archs="i686* x86_64*"
-
-CFLAGS="-fcommon"
+checksum=03cd7e16acc94f828b6e7f3087863d8ca06e99ffa3385588005b1984bdd56157
 
 pre_configure() {
 	# Only relevant if intel-gpu-tools is installed,

From 1978ac5b9e5d552fea7f570a413f6397d060d429 Mon Sep 17 00:00:00 2001
From: Stefano Ragni <st3r4g@protonmail.com>
Date: Fri, 2 Oct 2020 21:31:20 +0200
Subject: [PATCH 311/312] intel-gmmlib: update to 20.3.2

---
 srcpkgs/intel-gmmlib/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/intel-gmmlib/template b/srcpkgs/intel-gmmlib/template
index 992945d93b7..c3607abbd77 100644
--- a/srcpkgs/intel-gmmlib/template
+++ b/srcpkgs/intel-gmmlib/template
@@ -1,6 +1,6 @@
 # Template file for 'intel-gmmlib'
 pkgname=intel-gmmlib
-version=20.2.2
+version=20.3.2
 revision=1
 archs="i686* x86_64*"
 wrksrc=gmmlib-intel-gmmlib-${version}
@@ -11,7 +11,7 @@ maintainer="Stefano Ragni <st3r4g@protonmail.com>"
 license="MIT"
 homepage="https://github.com/intel/gmmlib"
 distfiles="https://github.com/intel/gmmlib/archive/intel-gmmlib-${version}.tar.gz"
-checksum=b3dfb193549b7385d68d959b31fa4670fef69161ca808bc9268a213bffba84f2
+checksum=1faacdd1bb2308c0528dbff25d2e9c0af6d8b807246d107f55af0cd1e7083fc7
 
 lib32disabled=yes
 

From 77e5a0f9d2a405431070c32333df4fecd71aa31c Mon Sep 17 00:00:00 2001
From: Stefano Ragni <st3r4g@protonmail.com>
Date: Fri, 2 Oct 2020 21:31:31 +0200
Subject: [PATCH 312/312] intel-media-driver: update to 20.3.0

Closes: #25288 [via git-merge-pr]
---
 srcpkgs/intel-media-driver/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/intel-media-driver/template b/srcpkgs/intel-media-driver/template
index 6fba3c474c5..6f9ff4ff8f5 100644
--- a/srcpkgs/intel-media-driver/template
+++ b/srcpkgs/intel-media-driver/template
@@ -1,6 +1,6 @@
 # Template file for 'intel-media-driver'
 pkgname=intel-media-driver
-version=20.2.0
+version=20.3.0
 revision=1
 archs="x86_64*"
 wrksrc=media-driver-intel-media-${version}
@@ -13,7 +13,7 @@ maintainer="Stefano Ragni <st3r4g@protonmail.com>"
 license="MIT, BSD-3-Clause"
 homepage="https://github.com/intel/media-driver"
 distfiles="https://github.com/intel/media-driver/archive/intel-media-${version}.tar.gz"
-checksum=1cdd40517d9fee51e3760beea23d2a19c2d5fcb1d6a9ed2bc0af7318d0d3100f
+checksum=491411d6ccdf812e4fe30b870f0623431fe9f14db16fc6b987578769925c8be0
 
 build_options="nonfree"
 desc_option_nonfree="Enable nonfree kernels"

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2020-10-17  4:21 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-10-13  1:44 [PR PATCH] bootiso: add bc depedencies hervyqa
2020-10-17  4:21 ` [PR PATCH] [Updated] " hervyqa

Github messages for voidlinux

This inbox may be cloned and mirrored by anyone:

	git clone --mirror http://inbox.vuxu.org/voidlinux-github

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V1 voidlinux-github voidlinux-github/ http://inbox.vuxu.org/voidlinux-github \
		voidlinux-github@inbox.vuxu.org
	public-inbox-index voidlinux-github

Example config snippet for mirrors.
Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.github.voidlinux


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git