Github messages for voidlinux
 help / color / mirror / Atom feed
* [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly
@ 2020-10-24 18:02 egorenar
  2020-10-24 18:04 ` minikN
                   ` (63 more replies)
  0 siblings, 64 replies; 65+ messages in thread
From: egorenar @ 2020-10-24 18:02 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1088 bytes --]

New issue by egorenar on void-packages repository

https://github.com/void-linux/void-packages/issues/25852

Description:
<!-- Don't request update of package. We have a script for that. https://alpha.de.repo.voidlinux.org/void-updates/void-updates.txt . However, a quality pull request may help. -->
### System

* xuname:  
  Void 5.8.16_1 x86_64 GenuineIntel notuptodate rrrrrmmdnFFFFFF
* package:  
  * webkit2gtk-2.30.0_1
  * gstreamer1-1.16.2_1

### Expected behavior

Playing of youtube videos with webkit2gtk works.

### Actual behavior

* Playback hangs after fast forwarding.
* Playing multiple youtube videos simultaneously is broken.

### Steps to reproduce the behavior

1. Execute `/usr/libexec/webkit2gtk-4.0/MiniBrowser`
2. Go to www.youtube.com
3. Choose any video and start playing
4. Fast forward to an arbitrary time point

### Notes

* The same behavior can also be observed with surf.
* **It might be a gstreamer issue (which is used for youtube streaming) and not an webkit2gtk one.**
* Updating webki2gtk to version 2.30.2 didn't help.

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
@ 2020-10-24 18:04 ` minikN
  2020-10-28  6:06 ` travankor
                   ` (62 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: minikN @ 2020-10-24 18:04 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 240 bytes --]

New comment by minikN on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-716032615

Comment:
Thanks @egorenar .

This seems to be related: https://github.com/atlas-engineer/nyxt/issues/1017

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
  2020-10-24 18:04 ` minikN
@ 2020-10-28  6:06 ` travankor
  2020-10-28  7:48 ` not-chicken
                   ` (61 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: travankor @ 2020-10-28  6:06 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 233 bytes --]

New comment by travankor on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-717720638

Comment:
https://github.com/void-linux/void-packages/pull/25313 might fix this

cc @not-chicken

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
  2020-10-24 18:04 ` minikN
  2020-10-28  6:06 ` travankor
@ 2020-10-28  7:48 ` not-chicken
  2020-10-28  7:51 ` not-chicken
                   ` (60 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: not-chicken @ 2020-10-28  7:48 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 245 bytes --]

New comment by not-chicken on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-717761097

Comment:
@travankor thanks for the ping. 
Unfortunately, I can still reproduce this with GStreamer 1.18 :(

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (2 preceding siblings ...)
  2020-10-28  7:48 ` not-chicken
@ 2020-10-28  7:51 ` not-chicken
  2020-11-03 20:45 ` minikN
                   ` (59 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: not-chicken @ 2020-10-28  7:51 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 297 bytes --]

New comment by not-chicken on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-717761097

Comment:
@travankor thanks for the ping. 
Unfortunately, I can still reproduce this with GStreamer 1.18 :(
Edit: Even when the sndio plugin is not installed.

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (3 preceding siblings ...)
  2020-10-28  7:51 ` not-chicken
@ 2020-11-03 20:45 ` minikN
  2020-12-26 21:22 ` notthewave
                   ` (58 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: minikN @ 2020-11-03 20:45 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1316 bytes --]

New comment by minikN on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-721365267

Comment:
I just updated to webkit2gtk 2.30.2_1 and this issue still persists.

```
003 ~ ➜ xbps-query -Rs gstreamer1-
[*] gstreamer1-1.16.2_1                Core GStreamer libraries and elements (1.x)
[*] gstreamer1-devel-1.16.2_1          Core GStreamer libraries and elements (1.x) - development files
[-] gstreamer1-pipewire-0.3.12_1       Server and user space API to deal with multimedia pipelines - gstreamer plugin
[*] gstreamer1-32bit-1.16.2_1          Core GStreamer libraries and elements (1.x) (32bit)
[-] gstreamer1-devel-32bit-1.16.2_1    Core GStreamer libraries and elements (1.x) - development files (32bit)
[-] gstreamer1-pipewire-32bit-0.3.12_1 Server and user space API to deal with multimedia pipelines - gstreamer plugin (32bit)
```

```
239 ~ ➜ xbps-query -Rs webkit2gtk
[*] webkit2gtk-2.30.2_1             GTK+3 port of the WebKit2 browser engine
[*] webkit2gtk-devel-2.30.2_1       GTK+3 port of the WebKit2 browser engine - development files
[-] webkit2gtk-32bit-2.30.2_1       GTK+3 port of the WebKit2 browser engine (32bit)
[-] webkit2gtk-devel-32bit-2.30.2_1 GTK+3 port of the WebKit2 browser engine - development files (32bit)
``` 

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (4 preceding siblings ...)
  2020-11-03 20:45 ` minikN
@ 2020-12-26 21:22 ` notthewave
  2020-12-26 21:22 ` notthewave
                   ` (57 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: notthewave @ 2020-12-26 21:22 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 213 bytes --]

New comment by notthewave on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-751397316

Comment:
Interesting that the epiphany flatpak does not have this problem...

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (5 preceding siblings ...)
  2020-12-26 21:22 ` notthewave
@ 2020-12-26 21:22 ` notthewave
  2021-01-21 17:41 ` ericonr
                   ` (56 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: notthewave @ 2020-12-26 21:22 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 218 bytes --]

New comment by notthewave on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-751397316

Comment:
Interesting that the epiphany flatpak does not have this problem... IIRC

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (6 preceding siblings ...)
  2020-12-26 21:22 ` notthewave
@ 2021-01-21 17:41 ` ericonr
  2021-01-21 20:14 ` minikN
                   ` (55 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: ericonr @ 2021-01-21 17:41 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 204 bytes --]

New comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-764819831

Comment:
Is this still an issue? We have removed sndio from gstreamer.

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (7 preceding siblings ...)
  2021-01-21 17:41 ` ericonr
@ 2021-01-21 20:14 ` minikN
  2021-01-21 21:04 ` ericonr
                   ` (54 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: minikN @ 2021-01-21 20:14 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 240 bytes --]

New comment by minikN on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-764908922

Comment:
> Is this still an issue? We have removed sndio from gstreamer.

This issue still exists for me.

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (8 preceding siblings ...)
  2021-01-21 20:14 ` minikN
@ 2021-01-21 21:04 ` ericonr
  2021-01-24 11:02 ` egorenar
                   ` (53 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: ericonr @ 2021-01-21 21:04 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 254 bytes --]

New comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-764940605

Comment:
I couldn't even get into youtube properly. I will try to update my gstreamer installation and see what happens.

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (9 preceding siblings ...)
  2021-01-21 21:04 ` ericonr
@ 2021-01-24 11:02 ` egorenar
  2021-01-24 11:29 ` travankor
                   ` (52 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: egorenar @ 2021-01-24 11:02 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 229 bytes --]

New comment by egorenar on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-766328701

Comment:
MiniBrowser still having issues with Youtube, sometimes i can't even open youtube :( 

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (10 preceding siblings ...)
  2021-01-24 11:02 ` egorenar
@ 2021-01-24 11:29 ` travankor
  2021-01-26  4:28 ` ericonr
                   ` (51 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: travankor @ 2021-01-24 11:29 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 177 bytes --]

New comment by travankor on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-766332321

Comment:
try the #27996 branch if you can

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (11 preceding siblings ...)
  2021-01-24 11:29 ` travankor
@ 2021-01-26  4:28 ` ericonr
  2021-01-26 10:09 ` travankor
                   ` (50 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: ericonr @ 2021-01-26  4:28 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 279 bytes --]

New comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-767288660

Comment:
@travankor still behaving weirdly; audio seems better, but video is extremely locked up (at points more than 10 seconds without moving).

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (12 preceding siblings ...)
  2021-01-26  4:28 ` ericonr
@ 2021-01-26 10:09 ` travankor
  2021-01-26 10:13 ` travankor
                   ` (49 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: travankor @ 2021-01-26 10:09 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 341 bytes --]

New comment by travankor on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-767440493

Comment:
The reason why video is choppy is most likely due to `gstreamer-vaapi`.
I can't get it work correctly, so I have uninstalled it. Pure software video decoding seems to work better with webkit2gtk.

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (13 preceding siblings ...)
  2021-01-26 10:09 ` travankor
@ 2021-01-26 10:13 ` travankor
  2021-01-27  7:03 ` travankor
                   ` (48 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: travankor @ 2021-01-26 10:13 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 390 bytes --]

New comment by travankor on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-767440493

Comment:
The reason why video is choppy is most likely due to `gstreamer-vaapi`.
I can't get it to work correctly (maybe a sandboxing issue with vaapi driver?), so I have uninstalled it. Pure software video decoding seems to work better with webkit2gtk.

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (14 preceding siblings ...)
  2021-01-26 10:13 ` travankor
@ 2021-01-27  7:03 ` travankor
  2021-01-27  7:10 ` travankor
                   ` (47 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: travankor @ 2021-01-27  7:03 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 921 bytes --]

New comment by travankor on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-768080613

Comment:
@egorenar Please try the above suggestions and report back. I can't reproduce this anymore after updating gstreamer and removing `gstreamer-vaapi`

```
$ xbps-query -s gst
[*] gst-libav-1.18.3_1             GStreamer libav plugin (1.x)
[*] gst-plugins-bad1-1.18.3_1      GStreamer plugins from the bad set (v1.x)
[*] gst-plugins-base1-1.18.3_1     GStreamer Base Plug-ins (v1.x)
[*] gst-plugins-good1-1.18.3_1     GStreamer set of well-maintained good plu...
[*] gst-plugins-ugly1-1.18.3_1     GStreamer plugins from the ugly set (1.x)
[*] gst1-editing-services-1.18.3_1 GStreamer 1.x Editing Services
[*] gstreamer1-1.18.3_1            Core GStreamer libraries and elements (1.x)
[*] gstreamer1-pipewire-0.3.19_1   Server and user space API to deal with mu...
```

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (15 preceding siblings ...)
  2021-01-27  7:03 ` travankor
@ 2021-01-27  7:10 ` travankor
  2021-01-27  7:11 ` travankor
                   ` (46 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: travankor @ 2021-01-27  7:10 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 921 bytes --]

New comment by travankor on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-768080613

Comment:
@egorenar Please try the above suggestions and report back. I can't reproduce this anymore after updating gstreamer and removing `gstreamer-vaapi`

```
$ xbps-query -s gst
[*] gst-libav-1.18.3_1             GStreamer libav plugin (1.x)
[*] gst-plugins-bad1-1.18.3_1      GStreamer plugins from the bad set (v1.x)
[*] gst-plugins-base1-1.18.3_1     GStreamer Base Plug-ins (v1.x)
[*] gst-plugins-good1-1.18.3_1     GStreamer set of well-maintained good plu...
[*] gst-plugins-ugly1-1.18.3_1     GStreamer plugins from the ugly set (1.x)
[*] gst1-editing-services-1.18.3_1 GStreamer 1.x Editing Services
[*] gstreamer1-1.18.3_1            Core GStreamer libraries and elements (1.x)
[*] gstreamer1-pipewire-0.3.19_1   Server and user space API to deal with mu...
```

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (16 preceding siblings ...)
  2021-01-27  7:10 ` travankor
@ 2021-01-27  7:11 ` travankor
  2021-01-27  8:09 ` egorenar
                   ` (45 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: travankor @ 2021-01-27  7:11 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 452 bytes --]

New comment by travankor on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-767440493

Comment:
The reason why video is choppy is most likely due to `gstreamer-vaapi`.
I can't get it to work correctly (maybe a sandboxing issue with vaapi driver?), so I have uninstalled it. Pure software video decoding seems to work better with webkit2gtk.

Edit: Even without `gstreamer-vaapi`, it still bugs out :/

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (17 preceding siblings ...)
  2021-01-27  7:11 ` travankor
@ 2021-01-27  8:09 ` egorenar
  2021-02-04 17:47 ` kawaiiamber
                   ` (44 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: egorenar @ 2021-01-27  8:09 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1252 bytes --]

New comment by egorenar on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-768112129

Comment:
I tried out @travankor 's  branch but still having the same issues, youtube videos just hang when i try fast forwarding.
Tested with MiniBrowser and Next.

```
➜  void-packages git:(gstreamer) xbps-query -s gst
[*] gst-libav-1.18.3_1               GStreamer libav plugin (1.x)
[*] gst-plugins-bad1-1.18.3_1        GStreamer plugins from the bad set (v1.x)
[*] gst-plugins-base1-1.18.3_1       GStreamer Base Plug-ins (v1.x)
[*] gst-plugins-base1-32bit-1.16.2_2 GStreamer Base Plug-ins (v1.x) (32bit)
[*] gst-plugins-good1-1.18.3_1       GStreamer set of well-maintained good plug-ins (1.x)
[*] gst-plugins-ugly1-1.18.3_1       GStreamer plugins from the ugly set (1.x)
[*] gst1-editing-services-1.18.3_1   GStreamer 1.x Editing Services
[*] gstreamer1-1.18.3_1              Core GStreamer libraries and elements (1.x)
[*] gstreamer1-32bit-1.16.2_2        Core GStreamer libraries and elements (1.x) (32bit)
[*] gstreamer1-pipewire-0.3.20_1     Server and user space API to deal with multimedia pipelines - gstreamer plugin
[*] gstreamermm-1.10.0_2             GStreamer API C++ bindings
```

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (18 preceding siblings ...)
  2021-01-27  8:09 ` egorenar
@ 2021-02-04 17:47 ` kawaiiamber
  2021-02-05  2:52 ` kawaiiamber
                   ` (43 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: kawaiiamber @ 2021-02-04 17:47 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 434 bytes --]

New comment by kawaiiamber on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-773490372

Comment:
The same issue can currently be reproduced with the `surf` package as well. It can play a video... kind of; it will freeze whenever one tries to pause / play, and sometimes it will just freeze altogether without any action. Video streaming is very inconsistant with `webkit2gtk` package.

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (19 preceding siblings ...)
  2021-02-04 17:47 ` kawaiiamber
@ 2021-02-05  2:52 ` kawaiiamber
  2021-02-05 18:29 ` notthewave
                   ` (42 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: kawaiiamber @ 2021-02-05  2:52 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 591 bytes --]

New comment by kawaiiamber on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-773490372

Comment:
The same issue can currently be reproduced with the `surf` package as well. It can play a video... kind of; it will freeze whenever one tries to pause / play, and sometimes it will just freeze altogether without any action. Video streaming is very inconsistant with `webkit2gtk` package.
EDIT
I have no idea if this is related, but, it might be a gstreamer issue as well. I notice that the new gtk4 video feature doesn't work on void, either.

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (20 preceding siblings ...)
  2021-02-05  2:52 ` kawaiiamber
@ 2021-02-05 18:29 ` notthewave
  2021-02-10 22:03 ` kawaiiamber
                   ` (41 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: notthewave @ 2021-02-05 18:29 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 789 bytes --]

New comment by notthewave on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-774208164

Comment:
Just checked my alpine install. This problem only seems to occur on void. Skipping in a video after installing gst-plugins-* seems to work fine on alpine.

> On 4. Feb 2021, at 18:47, KawaiiAmber <notifications@github.com> wrote:
> 
> The same issue can currently be reproduced with the surf package as well. It can play a video... kind of; it will freeze whenever one tries to pause / play, and sometimes it will just freeze altogether without any action. Video streaming is very inconsistant with webkit2gtk package.
> 
> —
> You are receiving this because you commented.
> Reply to this email directly, view it on GitHub, or unsubscribe.


^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (21 preceding siblings ...)
  2021-02-05 18:29 ` notthewave
@ 2021-02-10 22:03 ` kawaiiamber
  2021-02-11  0:02 ` kawaiiamber
                   ` (40 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: kawaiiamber @ 2021-02-10 22:03 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 460 bytes --]

New comment by kawaiiamber on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-777065922

Comment:
I now think it is most likely an issue with the `gstreamer1` package. I notice on apps that use the `qt5-multimedia` package (which uses `gstreamer1` package) suck as `nheko`, video playback is also very inconsistent in those cases as well. Video fails to play in the `gtk4-demo` package, which uses `gstreamer1`.

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (22 preceding siblings ...)
  2021-02-10 22:03 ` kawaiiamber
@ 2021-02-11  0:02 ` kawaiiamber
  2021-02-11  0:13 ` ericonr
                   ` (39 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: kawaiiamber @ 2021-02-11  0:02 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 382 bytes --]

New comment by kawaiiamber on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-777122493

Comment:
I tried messing around with different package managers and seeing how they package `gstreamer`, and thought I had something, but it didn't seem to change anything. I'm really scratching my head why the `gstreamer1` package is bugged...

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (23 preceding siblings ...)
  2021-02-11  0:02 ` kawaiiamber
@ 2021-02-11  0:13 ` ericonr
  2021-02-11  0:13 ` ericonr
                   ` (38 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: ericonr @ 2021-02-11  0:13 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 206 bytes --]

New comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-777126419

Comment:
Is it actually a bug on our side or just webkit2gtk in general?

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (24 preceding siblings ...)
  2021-02-11  0:13 ` ericonr
@ 2021-02-11  0:13 ` ericonr
  2021-03-17 19:04 ` kawaiiamber
                   ` (37 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: ericonr @ 2021-02-11  0:13 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 206 bytes --]

New comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-777126419

Comment:
Is it actually a bug on our side or just webkit2gtk in general?

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (25 preceding siblings ...)
  2021-02-11  0:13 ` ericonr
@ 2021-03-17 19:04 ` kawaiiamber
  2021-03-17 19:04 ` kawaiiamber
                   ` (36 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: kawaiiamber @ 2021-03-17 19:04 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 880 bytes --]

New comment by kawaiiamber on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-801336097

Comment:
I noticed that trying to run `gst-play-1.0 <video-file>` on either local video files or links to video files online reproduces the same inconsistant result that crashes gstreamer. I can't seem to get a good error as to why it's freezing whenever one fast forwards / rewinds. Doing `gst-play-1.0 --verbose <file/url>` also doesn't give information about why it's freezing - all of the output to the console also freezes.
In short - this is definitely an issue with the `gstreamer1` package as the `gst-play-1.0` testing tool crashes. To reproduce the bug: `gst-play-1.0 <file/url>`, then fast forward or rewind. I'm not too familiar with Linux stuff, and thus don't know a better way to see why it's freezing - e.g. memory leak, etc.

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (26 preceding siblings ...)
  2021-03-17 19:04 ` kawaiiamber
@ 2021-03-17 19:04 ` kawaiiamber
  2021-03-17 19:08 ` kawaiiamber
                   ` (35 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: kawaiiamber @ 2021-03-17 19:04 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 867 bytes --]

New comment by kawaiiamber on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-801336097

Comment:
I noticed that trying to run `gst-play-1.0 <video-file>` on either local video files or links to video files online reproduces the same result that crashes gstreamer. I can't seem to get a good error as to why it's freezing whenever one fast forwards / rewinds. Doing `gst-play-1.0 --verbose <file/url>` also doesn't give information about why it's freezing - all of the output to the console also freezes.
In short - this is definitely an issue with the `gstreamer1` package as the `gst-play-1.0` testing tool crashes. To reproduce the bug: `gst-play-1.0 <file/url>`, then fast forward or rewind. I'm not too familiar with Linux stuff, and thus don't know a better way to see why it's freezing - e.g. memory leak, etc.

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (27 preceding siblings ...)
  2021-03-17 19:04 ` kawaiiamber
@ 2021-03-17 19:08 ` kawaiiamber
  2021-03-17 19:38 ` kawaiiamber
                   ` (34 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: kawaiiamber @ 2021-03-17 19:08 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1005 bytes --]

New comment by kawaiiamber on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-801336097

Comment:
I noticed that trying to run `gst-play-1.0 <video-file>` on either local video files or links to video files online reproduces the same result that crashes gstreamer. I can't seem to get a good error as to why it's freezing whenever one fast forwards / rewinds. Doing `gst-play-1.0 --verbose <file/url>` also doesn't give information about why it's freezing - all of the output to the console also freezes.
In short - this is definitely an issue with the `gstreamer1` package as the `gst-play-1.0` testing tool crashes. To reproduce the bug: `gst-play-1.0 <file/url>`, then fast forward or rewind. I'm not too familiar with Linux stuff, and thus don't know a better way to see why it's freezing - e.g. memory leak, etc.
UPDATE:
Possibly related, I noticed that the name of the window that spawns to play `gst-play-1.0 <file/url>` is always named "broken".

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (28 preceding siblings ...)
  2021-03-17 19:08 ` kawaiiamber
@ 2021-03-17 19:38 ` kawaiiamber
  2021-03-17 19:39 ` kawaiiamber
                   ` (33 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: kawaiiamber @ 2021-03-17 19:38 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1696 bytes --]

New comment by kawaiiamber on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-801357248

Comment:
I decided to try and follow some steps from [here](https://askubuntu.com/questions/15437/why-is-my-terminal-freezing-up). I reproduced the bug with `gst-play-1.0 <file>` and tracked forward. Then, ran `ps axo pid,wchan:32,cmd`. The line that relates to the `gst-play-1.0` command crash:
```
12199 -                                gst-play-1.0 /home/amber/vids/blackbear - queen of broken hearts.mkv
```
On the column for `wchan`, it was an empty `-`. So next, I used the `strace` package/command on that PID to try and trace it with the following result:
```
[amber@otaku ~]$ doas strace -p 12199              
doas (amber@otaku) password: 
strace: Process 12199 attached
futex(0x7ffe086147c4, FUTEX_WAIT_PRIVATE, 2, NULL) = -1 EAGAIN (Resource temporarily unavailable)
futex(0x56022f252164, FUTEX_LOCK_PI_PRIVATE, NULL
```
and the command is stuck there. I noticed [this](https://stackoverflow.com/questions/39920801/resource-temporarily-unavailable-futex-while-straceing-sqoop-command), which seemed somewhat related. The output of `doas strace -f -p 12199` is [here](https://pastebin.com/YU7YEuLx) (I stopped the command with ^C signal as it was repeating over and over). These two lines seemed interesting:
```
[pid 12203] nanosleep({tv_sec=0, tv_nsec=50000000}, 0x7f713fb56880) = 0
[pid 12203] recvmsg(9, {msg_namelen=0}, 0) = -1 EAGAIN (Resource temporarily unavailable)
```
I'm not really sure if / how the pid of 12203 relates (nothing returned with `ps aux | grep -v grep | grep 12203`). That's all I'm able t get so far...

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (29 preceding siblings ...)
  2021-03-17 19:38 ` kawaiiamber
@ 2021-03-17 19:39 ` kawaiiamber
  2021-03-18  0:29 ` kawaiiamber
                   ` (32 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: kawaiiamber @ 2021-03-17 19:39 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1697 bytes --]

New comment by kawaiiamber on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-801357248

Comment:
I decided to try and follow some steps from [here](https://askubuntu.com/questions/15437/why-is-my-terminal-freezing-up). I reproduced the bug with `gst-play-1.0 <file>` and tracked forward. Then, ran `ps axo pid,wchan:32,cmd`. The line that relates to the `gst-play-1.0` command crash:
```
12199 -                                gst-play-1.0 /home/amber/vids/blackbear - queen of broken hearts.mkv
```
On the column for `wchan`, it was an empty `-`. So next, I used the `strace` package/command on that PID to try and trace it with the following result:
```
[amber@otaku ~]$ doas strace -p 12199              
doas (amber@otaku) password: 
strace: Process 12199 attached
futex(0x7ffe086147c4, FUTEX_WAIT_PRIVATE, 2, NULL) = -1 EAGAIN (Resource temporarily unavailable)
futex(0x56022f252164, FUTEX_LOCK_PI_PRIVATE, NULL
```
and the command is stuck there. I noticed [this](https://stackoverflow.com/questions/39920801/resource-temporarily-unavailable-futex-while-straceing-sqoop-command), which seemed somewhat related. The output of `doas strace -f -p 12199` is [here](https://pastebin.com/YU7YEuLx) (I stopped the command with ^C signal as it was repeating over and over). These two lines seemed interesting:
```
[pid 12203] nanosleep({tv_sec=0, tv_nsec=50000000}, 0x7f713fb56880) = 0
[pid 12203] recvmsg(9, {msg_namelen=0}, 0) = -1 EAGAIN (Resource temporarily unavailable)
```
I'm not really sure if / how the pid of 12203 relates (nothing returned with `ps aux | grep -v grep | grep 12203`). That's all I'm able to get so far...

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (30 preceding siblings ...)
  2021-03-17 19:39 ` kawaiiamber
@ 2021-03-18  0:29 ` kawaiiamber
  2021-03-18  0:30 ` kawaiiamber
                   ` (31 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: kawaiiamber @ 2021-03-18  0:29 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 631 bytes --]

New comment by kawaiiamber on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-801528228

Comment:
I've been messing around trying to build `gstreamer1` myself and changing the template locally for certain packages. I think I have something I want to test. Possibly dumb question, but, is there a way for me to have my system use my built of `gstreamer1` that was biult from the template I wrote instead of the one from the standard repo? I can't just `xbps-remove gstreamer1` to then `xbps-install --repository=./hostdir gstreamer1` as it won't let me initially remove `gstreamer1`.

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (31 preceding siblings ...)
  2021-03-18  0:29 ` kawaiiamber
@ 2021-03-18  0:30 ` kawaiiamber
  2021-03-18  0:36 ` kawaiiamber
                   ` (30 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: kawaiiamber @ 2021-03-18  0:30 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 631 bytes --]

New comment by kawaiiamber on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-801528228

Comment:
I've been messing around trying to build `gstreamer1` myself and changing the template locally for certain packages. I think I have something I want to test. Possibly dumb question, but, is there a way for me to have my system use my build of `gstreamer1` that was biult from the template I wrote instead of the one from the standard repo? I can't just `xbps-remove gstreamer1` to then `xbps-install --repository=./hostdir gstreamer1` as it won't let me initially remove `gstreamer1`.

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (32 preceding siblings ...)
  2021-03-18  0:30 ` kawaiiamber
@ 2021-03-18  0:36 ` kawaiiamber
  2021-03-18  0:38 ` ericonr
                   ` (29 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: kawaiiamber @ 2021-03-18  0:36 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 715 bytes --]

New comment by kawaiiamber on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-801528228

Comment:
I've been messing around trying to build `gstreamer1` myself and changing the template locally for certain packages. I think I have something I want to test. Possibly dumb question, but, is there a way for me to have my system use my build of `gstreamer1` that was biult from the template I wrote instead of the one from the standard repo? I can't just `xbps-remove gstreamer1` to then `xbps-install --repository=./hostdir gstreamer1` as it won't let me initially remove `gstreamer1`. (Specifically, I want to install local builds of both `gstreamer1` and `gst-libav`)

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (33 preceding siblings ...)
  2021-03-18  0:36 ` kawaiiamber
@ 2021-03-18  0:38 ` ericonr
  2021-03-18  0:38 ` ericonr
                   ` (28 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: ericonr @ 2021-03-18  0:38 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 195 bytes --]

New comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-801531346

Comment:
Install `xtools` and do `xi -f gstreamer1 gst-libav`

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (34 preceding siblings ...)
  2021-03-18  0:38 ` ericonr
@ 2021-03-18  0:38 ` ericonr
  2021-03-18  0:41 ` kawaiiamber
                   ` (27 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: ericonr @ 2021-03-18  0:38 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 250 bytes --]

New comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-801531346

Comment:
Install `xtools` and do `xi -f gstreamer1 gst-libav` (after building the packages with changes, of course).

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (35 preceding siblings ...)
  2021-03-18  0:38 ` ericonr
@ 2021-03-18  0:41 ` kawaiiamber
  2021-03-19 11:20 ` st3r4g
                   ` (26 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: kawaiiamber @ 2021-03-18  0:41 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 271 bytes --]

New comment by kawaiiamber on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-801532375

Comment:
> Install `xtools` and do `xi -f gstreamer1 gst-libav` (after building the packages with changes, of course).

Thank you ~

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (36 preceding siblings ...)
  2021-03-18  0:41 ` kawaiiamber
@ 2021-03-19 11:20 ` st3r4g
  2021-03-19 11:33 ` st3r4g
                   ` (25 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: st3r4g @ 2021-03-19 11:20 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 492 bytes --]

New comment by st3r4g on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-802760420

Comment:
> I noticed that trying to run gst-play-1.0 <video-file> on either local video files or links to video files online reproduces the same result that crashes gstreamer.

Does it happen with this [test video](https://www.freedesktop.org/software/gstreamer-sdk/data/media/sintel_trailer-480p.webm)? Playing this with `gst-play-1.0` works fine for me...

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (37 preceding siblings ...)
  2021-03-19 11:20 ` st3r4g
@ 2021-03-19 11:33 ` st3r4g
  2021-03-19 12:10 ` travankor
                   ` (24 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: st3r4g @ 2021-03-19 11:33 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 866 bytes --]

New comment by st3r4g on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-802760420

Comment:
> I noticed that trying to run gst-play-1.0 <video-file> on either local video files or links to video files online reproduces the same result that crashes gstreamer.

Does it happen with this [test video](https://www.freedesktop.org/software/gstreamer-sdk/data/media/sintel_trailer-480p.webm)? Playing this with `gst-play-1.0` works fine for me...
```
$ xbps-query -s gst
[*] gst-plugins-base1-1.18.3_1   GStreamer Base Plug-ins (v1.x)
[*] gst-plugins-good1-1.18.3_1   GStreamer set of well-maintained good plug-ins (1.x)
[*] gstreamer1-1.18.3_1          Core GStreamer libraries and elements (1.x)
[*] gstreamer1-pipewire-0.3.24_1 Server and user space API to deal with multimedia pipelines - gstreamer plugin
```

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (38 preceding siblings ...)
  2021-03-19 11:33 ` st3r4g
@ 2021-03-19 12:10 ` travankor
  2021-03-19 12:10 ` travankor
                   ` (23 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: travankor @ 2021-03-19 12:10 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 311 bytes --]

New comment by travankor on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-802788989

Comment:
>Does it happen with this test video? Playing this with gst-play-1.0 works fine for me...

Same `gst-play-1.0` works but a webkit2gtk browser freezes for this file.

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (39 preceding siblings ...)
  2021-03-19 12:10 ` travankor
@ 2021-03-19 12:10 ` travankor
  2021-03-19 12:37 ` st3r4g
                   ` (22 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: travankor @ 2021-03-19 12:10 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 312 bytes --]

New comment by travankor on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-802788989

Comment:
>Does it happen with this test video? Playing this with gst-play-1.0 works fine for me...

Same, `gst-play-1.0` works but a webkit2gtk browser freezes for this file.

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (40 preceding siblings ...)
  2021-03-19 12:10 ` travankor
@ 2021-03-19 12:37 ` st3r4g
  2021-03-19 12:50 ` st3r4g
                   ` (21 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: st3r4g @ 2021-03-19 12:37 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 315 bytes --]

New comment by st3r4g on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-802803792

Comment:
`/usr/libexec/webkit2gtk-4.0/MiniBrowser` from the `webkit2gtk` package also plays the test video fine for me. I suspect the issue arises when installing some plugin package

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (41 preceding siblings ...)
  2021-03-19 12:37 ` st3r4g
@ 2021-03-19 12:50 ` st3r4g
  2021-03-19 12:51 ` st3r4g
                   ` (20 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: st3r4g @ 2021-03-19 12:50 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 416 bytes --]

New comment by st3r4g on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-802803792

Comment:
`/usr/libexec/webkit2gtk-4.0/MiniBrowser` from the `webkit2gtk` package also plays the test video fine for me. I suspect the issue arises when installing some plugin package. If I install `gst-libav` and try to seek a youtube video, it hangs. But the test video still works.

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (42 preceding siblings ...)
  2021-03-19 12:50 ` st3r4g
@ 2021-03-19 12:51 ` st3r4g
  2021-03-19 12:51 ` st3r4g
                   ` (19 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: st3r4g @ 2021-03-19 12:51 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 412 bytes --]

New comment by st3r4g on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-802803792

Comment:
`/usr/libexec/webkit2gtk-4.0/MiniBrowser` from the `webkit2gtk` package also plays the test video fine for me. Maybe the issue arises when installing some plugin package? If I install `gst-libav` and try to seek a youtube video, it hangs. But the test video still works.

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (43 preceding siblings ...)
  2021-03-19 12:51 ` st3r4g
@ 2021-03-19 12:51 ` st3r4g
  2021-03-19 12:58 ` st3r4g
                   ` (18 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: st3r4g @ 2021-03-19 12:51 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 418 bytes --]

New comment by st3r4g on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-802803792

Comment:
`/usr/libexec/webkit2gtk-4.0/MiniBrowser` from the `webkit2gtk` package also plays the test video fine for me. Maybe the issue arises when installing some plugin package? If I install `gst-libav` and try to seek/pause a youtube video, it hangs. But the test video still works.

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (44 preceding siblings ...)
  2021-03-19 12:51 ` st3r4g
@ 2021-03-19 12:58 ` st3r4g
  2021-03-19 13:05 ` kawaiiamber
                   ` (17 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: st3r4g @ 2021-03-19 12:58 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 452 bytes --]

New comment by st3r4g on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-802803792

Comment:
`/usr/libexec/webkit2gtk-4.0/MiniBrowser` from the `webkit2gtk` package also plays the test video fine for me. Maybe the issue arises when installing some plugin package? If I install `gst-libav` (required to play youtube videos) and try to seek/pause a youtube video, it hangs. But the test video still works.

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (45 preceding siblings ...)
  2021-03-19 12:58 ` st3r4g
@ 2021-03-19 13:05 ` kawaiiamber
  2021-03-19 13:08 ` st3r4g
                   ` (16 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: kawaiiamber @ 2021-03-19 13:05 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 632 bytes --]

New comment by kawaiiamber on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-802819258

Comment:
> `/usr/libexec/webkit2gtk-4.0/MiniBrowser` from the `webkit2gtk` package also plays the test video fine for me. Maybe the issue arises when installing some plugin package? If I install `gst-libav` (required to play youtube videos) and try to seek/pause a youtube video, it hangs. But the test video still works.

I guess I should have been more specific. The video will play with `gst-play-1.0`, but will freeze upon doing any action (a list of them are available with hitting `k`).

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (46 preceding siblings ...)
  2021-03-19 13:05 ` kawaiiamber
@ 2021-03-19 13:08 ` st3r4g
  2021-03-19 13:28 ` kawaiiamber
                   ` (15 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: st3r4g @ 2021-03-19 13:08 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 287 bytes --]

New comment by st3r4g on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-802820721

Comment:
> The video will play with gst-play-1.0, but will freeze upon doing any action (a list of them are available with hitting k).

they work for me

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (47 preceding siblings ...)
  2021-03-19 13:08 ` st3r4g
@ 2021-03-19 13:28 ` kawaiiamber
  2021-03-19 13:29 ` kawaiiamber
                   ` (14 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: kawaiiamber @ 2021-03-19 13:28 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 485 bytes --]

New comment by kawaiiamber on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-802832951

Comment:
> > The video will play with gst-play-1.0, but will freeze upon doing any action (a list of them are available with hitting k).
> 
> they work for me

Interesting - they don't for me. I'm using musl and have the `gst-plugins-good1` and `gst-plugins-bad1` installed, as well. Is it only the demo video that works for you? Or any video?

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (48 preceding siblings ...)
  2021-03-19 13:28 ` kawaiiamber
@ 2021-03-19 13:29 ` kawaiiamber
  2021-03-19 14:02 ` st3r4g
                   ` (13 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: kawaiiamber @ 2021-03-19 13:29 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 506 bytes --]

New comment by kawaiiamber on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-802832951

Comment:
> > The video will play with gst-play-1.0, but will freeze upon doing any action (a list of them are available with hitting k).
> 
> they work for me

Interesting - they don't for me. I'm using musl and have the `gst-plugins-good1`, `gst-plugins-base1` and `gst-plugins-bad1` installed, as well. Is it only the demo video that works for you? Or any video?

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (49 preceding siblings ...)
  2021-03-19 13:29 ` kawaiiamber
@ 2021-03-19 14:02 ` st3r4g
  2021-03-19 14:03 ` st3r4g
                   ` (12 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: st3r4g @ 2021-03-19 14:02 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 258 bytes --]

New comment by st3r4g on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-802856186

Comment:
Then it might be a different issue, maybe musl related.

> Or any video?

Didn't test many, but any video works.

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (50 preceding siblings ...)
  2021-03-19 14:02 ` st3r4g
@ 2021-03-19 14:03 ` st3r4g
  2021-05-10 14:47 ` matheson-581
                   ` (11 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: st3r4g @ 2021-03-19 14:03 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 278 bytes --]

New comment by st3r4g on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-802856186

Comment:
Then it might be a different issue, maybe musl related. (I'm on glibc here)

> Or any video?

Didn't test many, but any video works.

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (51 preceding siblings ...)
  2021-03-19 14:03 ` st3r4g
@ 2021-05-10 14:47 ` matheson-581
  2021-05-10 14:48 ` matheson-581
                   ` (10 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: matheson-581 @ 2021-05-10 14:47 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1922 bytes --]

New comment by matheson-581 on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-836791558

Comment:
This issue is still ongoing. Every webkit2gtk-based browser I have tested (badwolf, netsurf, surf, epiphany) fails in the exact same way: skipping an ad, pausing, rewinding or fast-forwarding on YouTube, Odysee, DTube, PeerTube or Dailymotion causes the video stream to hang and the entire browser tab to freeze. 

Interestingly, playing, pausing, rewinding and fast-forwarding VP8 webm files and Ogg Theora ogv files from Wikimedia works correctly without issue - the problem only seems to affect h264/h265 streams. 

Playing, pausing, rewinding, and fast-forwarding the above-referenced VP8 test file with gst-play-1.0 locally works perfectly.  Playing, pausing, rewinding, and fast-forwarding a h264 test file with gst-play-1.0 locally works perfectly. Playing, pausing, rewinding, and fast-forwarding a direct video URI from DTube (right click the video, click "copy video link location") with gst-play-1.0 also works perfectly. Playing, pausing, rewinding, and fast-forwarding the same direct video URI in the browser also works perfectly. However, when playing the video from the DTube website (i.e., just loading the DTube URL and clicking play instead of right clicking and getting the video link location), the video hangs and the tab freezes when pausing, fast-forwarding or rewinding. Quite frustrating. This does not affect non-webkit browsers such as Firefox, Chromium, Basilisk, or Pale Moon; those browsers obviously do not use gstreamer for their backend, which seems to be the source of the problem.

My installation: kernel 5.11.18_1, gstreamer1-1.18.4_1, gstreamer-vaapi-1.18.4_1, gst-libav-1.18.4_1, gst-omx-1.18.4_1, gst-plugins-base1-1.18.4_1, gst-plugins-good1-1.18.4_1, gst-plugins-bad1-1.18.4_3, gst-plugins-ugly1-1.18.4_2, webkit2gtk-2.32.0_3

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (52 preceding siblings ...)
  2021-05-10 14:47 ` matheson-581
@ 2021-05-10 14:48 ` matheson-581
  2021-05-10 14:49 ` matheson-581
                   ` (9 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: matheson-581 @ 2021-05-10 14:48 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1929 bytes --]

New comment by matheson-581 on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-836791558

Comment:
This issue is still ongoing. Every webkit2gtk-based browser I have tested (badwolf, netsurf, surf, epiphany) fails in the exact same way: skipping an ad, pausing, rewinding or fast-forwarding on YouTube, Odysee, DTube, PeerTube or Dailymotion causes the video stream to hang and the entire browser tab to freeze. 

Interestingly, playing, pausing, rewinding and fast-forwarding VP8 webm files and Ogg Theora ogv files from Wikimedia works correctly without issue - the problem only seems to affect h264/h265 streams. 

Playing, pausing, rewinding, and fast-forwarding the above-referenced VP8 test file with gst-play-1.0 locally works perfectly.  Playing, pausing, rewinding, and fast-forwarding a h264 test file with gst-play-1.0 locally works perfectly. Playing, pausing, rewinding, and fast-forwarding a direct video URI from DTube (right click the video, click "copy video link location") with gst-play-1.0 also works perfectly. Playing, pausing, rewinding, and fast-forwarding the same direct video URI in the browser also works perfectly. However, when playing the video from the DTube website (i.e., just loading the DTube URL and clicking play instead of right clicking and getting the video link location), the video hangs and the tab freezes when pausing, fast-forwarding or rewinding. Quite frustrating. This does not affect non-webkit browsers such as Firefox, Chromium, Basilisk, or Pale Moon; those browsers obviously do not use gstreamer for their backend, which seems to be the source of the problem.

My installation: glibc, kernel 5.11.18_1, gstreamer1-1.18.4_1, gstreamer-vaapi-1.18.4_1, gst-libav-1.18.4_1, gst-omx-1.18.4_1, gst-plugins-base1-1.18.4_1, gst-plugins-good1-1.18.4_1, gst-plugins-bad1-1.18.4_3, gst-plugins-ugly1-1.18.4_2, webkit2gtk-2.32.0_3

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (53 preceding siblings ...)
  2021-05-10 14:48 ` matheson-581
@ 2021-05-10 14:49 ` matheson-581
  2021-06-05 12:17 ` egorenar
                   ` (8 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: matheson-581 @ 2021-05-10 14:49 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1936 bytes --]

New comment by matheson-581 on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-836791558

Comment:
This issue is still ongoing. Every webkit2gtk-based browser I have tested (badwolf, netsurf, surf, epiphany) fails in the exact same way: skipping an ad, pausing, rewinding or fast-forwarding on YouTube, Odysee, DTube, PeerTube or Dailymotion causes the video stream to hang and the entire browser tab to freeze. 

Interestingly, playing, pausing, rewinding and fast-forwarding VP8 webm files and Ogg Theora ogv files from Wikimedia works correctly without issue - the problem only seems to affect h264/h265 streams. 

Playing, pausing, rewinding, and fast-forwarding the above-referenced VP8 test file with gst-play-1.0 locally works perfectly.  Playing, pausing, rewinding, and fast-forwarding a h264 test file with gst-play-1.0 locally works perfectly. Playing, pausing, rewinding, and fast-forwarding a direct video URI from DTube (right click the video, click "copy video link location") with gst-play-1.0 also works perfectly. Playing, pausing, rewinding, and fast-forwarding the same direct video URI in the browser also works perfectly. However, when playing the video from the DTube website (i.e., just loading the DTube URL and clicking play instead of right clicking and getting the direct video link location), the video hangs and the tab freezes when pausing, fast-forwarding or rewinding. Quite frustrating. This does not affect non-webkit browsers such as Firefox, Chromium, Basilisk, or Pale Moon; those browsers obviously do not use gstreamer for their backend, which seems to be the source of the problem.

My installation: glibc, kernel 5.11.18_1, gstreamer1-1.18.4_1, gstreamer-vaapi-1.18.4_1, gst-libav-1.18.4_1, gst-omx-1.18.4_1, gst-plugins-base1-1.18.4_1, gst-plugins-good1-1.18.4_1, gst-plugins-bad1-1.18.4_3, gst-plugins-ugly1-1.18.4_2, webkit2gtk-2.32.0_3

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (54 preceding siblings ...)
  2021-05-10 14:49 ` matheson-581
@ 2021-06-05 12:17 ` egorenar
  2021-06-09  4:06 ` kawaiiamber
                   ` (7 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: egorenar @ 2021-06-05 12:17 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 206 bytes --]

New comment by egorenar on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-855231966

Comment:
I built nyxt 2.0.0 today and youtube works great :+1: finally.

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (55 preceding siblings ...)
  2021-06-05 12:17 ` egorenar
@ 2021-06-09  4:06 ` kawaiiamber
  2021-06-10 19:58 ` notthewave
                   ` (6 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: kawaiiamber @ 2021-06-09  4:06 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 219 bytes --]

New comment by kawaiiamber on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-857355401

Comment:
Not sure what changed recently, but video playback seems to work ok now.

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (56 preceding siblings ...)
  2021-06-09  4:06 ` kawaiiamber
@ 2021-06-10 19:58 ` notthewave
  2021-06-11 17:50 ` egorenar
                   ` (5 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: notthewave @ 2021-06-10 19:58 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 678 bytes --]

New comment by notthewave on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-858996319

Comment:
not for me...
```
~ ❱ xbps-query -s gst
[*] gst-plugins-bad1-1.18.4_3    GStreamer plugins from the bad set (v1.x)
[*] gst-plugins-base1-1.18.4_1   GStreamer Base Plug-ins (v1.x)
[*] gst-plugins-good1-1.18.4_1   GStreamer set of well-maintained good plug-ins (1.x)
[*] gst-plugins-ugly1-1.18.4_2   GStreamer plugins from the ugly set (1.x)
[*] gstreamer1-1.18.4_2          Core GStreamer libraries and elements (1.x)
[*] gstreamer1-pipewire-0.3.28_1 Server and user space API to deal with multimedia pipelines - gs...
```

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (57 preceding siblings ...)
  2021-06-10 19:58 ` notthewave
@ 2021-06-11 17:50 ` egorenar
  2021-06-11 17:51 ` egorenar
                   ` (4 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: egorenar @ 2021-06-11 17:50 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1060 bytes --]

New comment by egorenar on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-859743716

Comment:
```
$ xbps-query -s gst
[*] gst-libav-1.18.4_1               GStreamer libav plugin (1.x)
[*] gst-plugins-bad1-1.18.4_3        GStreamer plugins from the bad set (v1.x)
[*] gst-plugins-base1-1.18.4_1       GStreamer Base Plug-ins (v1.x)
[*] gst-plugins-base1-32bit-1.18.4_1 GStreamer Base Plug-ins (v1.x) (32bit)
[*] gst-plugins-good1-1.18.4_1       GStreamer set of well-maintained good plug-ins (1.x)
[*] gst-plugins-ugly1-1.18.4_2       GStreamer plugins from the ugly set (1.x)
[*] gst1-editing-services-1.18.4_1   GStreamer 1.x Editing Services
[*] gstreamer1-1.18.4_2              Core GStreamer libraries and elements (1.x)
[*] gstreamer1-32bit-1.18.4_2        Core GStreamer libraries and elements (1.x) (32bit)
[*] gstreamer1-pipewire-0.3.28_1     Server and user space API to deal with multimedia pipelines - gstreamer plugin
[*] gstreamermm-1.10.0_2             GStreamer API C++ bindings
```

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (58 preceding siblings ...)
  2021-06-11 17:50 ` egorenar
@ 2021-06-11 17:51 ` egorenar
  2021-06-12  7:53 ` kawaiiamber
                   ` (3 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: egorenar @ 2021-06-11 17:51 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1086 bytes --]

New comment by egorenar on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-859743716

Comment:
Works for me with this

```
$ xbps-query -s gst
[*] gst-libav-1.18.4_1               GStreamer libav plugin (1.x)
[*] gst-plugins-bad1-1.18.4_3        GStreamer plugins from the bad set (v1.x)
[*] gst-plugins-base1-1.18.4_1       GStreamer Base Plug-ins (v1.x)
[*] gst-plugins-base1-32bit-1.18.4_1 GStreamer Base Plug-ins (v1.x) (32bit)
[*] gst-plugins-good1-1.18.4_1       GStreamer set of well-maintained good plug-ins (1.x)
[*] gst-plugins-ugly1-1.18.4_2       GStreamer plugins from the ugly set (1.x)
[*] gst1-editing-services-1.18.4_1   GStreamer 1.x Editing Services
[*] gstreamer1-1.18.4_2              Core GStreamer libraries and elements (1.x)
[*] gstreamer1-32bit-1.18.4_2        Core GStreamer libraries and elements (1.x) (32bit)
[*] gstreamer1-pipewire-0.3.28_1     Server and user space API to deal with multimedia pipelines - gstreamer plugin
[*] gstreamermm-1.10.0_2             GStreamer API C++ bindings
```

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (59 preceding siblings ...)
  2021-06-11 17:51 ` egorenar
@ 2021-06-12  7:53 ` kawaiiamber
  2021-06-12 14:05 ` notthewave
                   ` (2 subsequent siblings)
  63 siblings, 0 replies; 65+ messages in thread
From: kawaiiamber @ 2021-06-12  7:53 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 727 bytes --]

New comment by kawaiiamber on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-860016994

Comment:
> not for me...
> 
> ```
> ~ ❱ xbps-query -s gst
> [*] gst-plugins-bad1-1.18.4_3    GStreamer plugins from the bad set (v1.x)
> [*] gst-plugins-base1-1.18.4_1   GStreamer Base Plug-ins (v1.x)
> [*] gst-plugins-good1-1.18.4_1   GStreamer set of well-maintained good plug-ins (1.x)
> [*] gst-plugins-ugly1-1.18.4_2   GStreamer plugins from the ugly set (1.x)
> [*] gstreamer1-1.18.4_2          Core GStreamer libraries and elements (1.x)
> [*] gstreamer1-pipewire-0.3.28_1 Server and user space API to deal with multimedia pipelines - gs...
> ```

You need `gst-libav`

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (60 preceding siblings ...)
  2021-06-12  7:53 ` kawaiiamber
@ 2021-06-12 14:05 ` notthewave
  2021-06-12 14:20 ` egorenar
  2021-06-14  2:55 ` ericonr
  63 siblings, 0 replies; 65+ messages in thread
From: notthewave @ 2021-06-12 14:05 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 177 bytes --]

New comment by notthewave on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-860058214

Comment:
still not working. I'm on musl.

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (61 preceding siblings ...)
  2021-06-12 14:05 ` notthewave
@ 2021-06-12 14:20 ` egorenar
  2021-06-14  2:55 ` ericonr
  63 siblings, 0 replies; 65+ messages in thread
From: egorenar @ 2021-06-12 14:20 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 196 bytes --]

New comment by egorenar on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-860060098

Comment:
It works for me also if i remove `gst-libav` package

^ permalink raw reply	[flat|nested] 65+ messages in thread

* Re: Web browsers based on webkit2gtk are not able to stream youtube videos properly
  2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
                   ` (62 preceding siblings ...)
  2021-06-12 14:20 ` egorenar
@ 2021-06-14  2:55 ` ericonr
  63 siblings, 0 replies; 65+ messages in thread
From: ericonr @ 2021-06-14  2:55 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 186 bytes --]

New comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/issues/25852#issuecomment-860331098

Comment:
This seems to be solved on my side as well.

^ permalink raw reply	[flat|nested] 65+ messages in thread

end of thread, other threads:[~2021-06-14  2:55 UTC | newest]

Thread overview: 65+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-10-24 18:02 [ISSUE] Web browsers based on webkit2gtk are not able to stream youtube videos properly egorenar
2020-10-24 18:04 ` minikN
2020-10-28  6:06 ` travankor
2020-10-28  7:48 ` not-chicken
2020-10-28  7:51 ` not-chicken
2020-11-03 20:45 ` minikN
2020-12-26 21:22 ` notthewave
2020-12-26 21:22 ` notthewave
2021-01-21 17:41 ` ericonr
2021-01-21 20:14 ` minikN
2021-01-21 21:04 ` ericonr
2021-01-24 11:02 ` egorenar
2021-01-24 11:29 ` travankor
2021-01-26  4:28 ` ericonr
2021-01-26 10:09 ` travankor
2021-01-26 10:13 ` travankor
2021-01-27  7:03 ` travankor
2021-01-27  7:10 ` travankor
2021-01-27  7:11 ` travankor
2021-01-27  8:09 ` egorenar
2021-02-04 17:47 ` kawaiiamber
2021-02-05  2:52 ` kawaiiamber
2021-02-05 18:29 ` notthewave
2021-02-10 22:03 ` kawaiiamber
2021-02-11  0:02 ` kawaiiamber
2021-02-11  0:13 ` ericonr
2021-02-11  0:13 ` ericonr
2021-03-17 19:04 ` kawaiiamber
2021-03-17 19:04 ` kawaiiamber
2021-03-17 19:08 ` kawaiiamber
2021-03-17 19:38 ` kawaiiamber
2021-03-17 19:39 ` kawaiiamber
2021-03-18  0:29 ` kawaiiamber
2021-03-18  0:30 ` kawaiiamber
2021-03-18  0:36 ` kawaiiamber
2021-03-18  0:38 ` ericonr
2021-03-18  0:38 ` ericonr
2021-03-18  0:41 ` kawaiiamber
2021-03-19 11:20 ` st3r4g
2021-03-19 11:33 ` st3r4g
2021-03-19 12:10 ` travankor
2021-03-19 12:10 ` travankor
2021-03-19 12:37 ` st3r4g
2021-03-19 12:50 ` st3r4g
2021-03-19 12:51 ` st3r4g
2021-03-19 12:51 ` st3r4g
2021-03-19 12:58 ` st3r4g
2021-03-19 13:05 ` kawaiiamber
2021-03-19 13:08 ` st3r4g
2021-03-19 13:28 ` kawaiiamber
2021-03-19 13:29 ` kawaiiamber
2021-03-19 14:02 ` st3r4g
2021-03-19 14:03 ` st3r4g
2021-05-10 14:47 ` matheson-581
2021-05-10 14:48 ` matheson-581
2021-05-10 14:49 ` matheson-581
2021-06-05 12:17 ` egorenar
2021-06-09  4:06 ` kawaiiamber
2021-06-10 19:58 ` notthewave
2021-06-11 17:50 ` egorenar
2021-06-11 17:51 ` egorenar
2021-06-12  7:53 ` kawaiiamber
2021-06-12 14:05 ` notthewave
2021-06-12 14:20 ` egorenar
2021-06-14  2:55 ` ericonr

Github messages for voidlinux

This inbox may be cloned and mirrored by anyone:

	git clone --mirror http://inbox.vuxu.org/voidlinux-github

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V1 voidlinux-github voidlinux-github/ http://inbox.vuxu.org/voidlinux-github \
		voidlinux-github@inbox.vuxu.org
	public-inbox-index voidlinux-github

Example config snippet for mirrors.
Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.github.voidlinux


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git