Github messages for voidlinux
 help / color / mirror / Atom feed
* [PR PATCH] setzer: update to 0.3.9
@ 2021-01-13 15:27 Bleznudd
  2021-01-14 12:18 ` paper42
                   ` (6 more replies)
  0 siblings, 7 replies; 8+ messages in thread
From: Bleznudd @ 2021-01-13 15:27 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 309 bytes --]

There is a new pull request by Bleznudd against master on the void-packages repository

https://github.com/Bleznudd/void-packages setzer
https://github.com/void-linux/void-packages/pull/27893

setzer: update to 0.3.9


A patch file from https://github.com/void-linux/void-packages/pull/27893.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-setzer-27893.patch --]
[-- Type: text/x-diff, Size: 1198 bytes --]

From 077fd51e6e44b0bead069f3ef25fcb1c47048e35 Mon Sep 17 00:00:00 2001
From: Bleznudd <bleznudd@pm.me>
Date: Wed, 13 Jan 2021 16:20:33 +0100
Subject: [PATCH] setzer: update to 0.3.9.

---
 srcpkgs/setzer/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/setzer/template b/srcpkgs/setzer/template
index 3d45b9be3d0..df80eaee011 100644
--- a/srcpkgs/setzer/template
+++ b/srcpkgs/setzer/template
@@ -1,14 +1,14 @@
 # Template file for 'setzer'
 pkgname=setzer
-version=0.3.7
+version=0.3.9
 revision=1
 wrksrc=Setzer-${version}
 build_style=meson
 hostmakedepends="gettext"
-depends="poppler-glib virtual?tex gspell python3-xdg python3-gobject gtksourceview4"
+depends="poppler-glib virtual?tex gspell python3-xdg python3-gobject gtksourceview4 python3-PyPDF2"
 short_desc="Simple yet full-featured LaTeX editor written in Python with Gtk"
 maintainer="Bleznudd <bleznudd@pm.me>"
 license="GPL-3.0-or-later"
 homepage="https://github.com/cvfosammmm/setzer"
 distfiles="${homepage}/archive/v${version}.tar.gz"
-checksum=04675ecb73d9fdad875665756d80587e72e06c03d85f358232e6dd1e3487b42d
+checksum=abddd4b85f41a84fc0ce18377cf955df8f9a10e0350133692e187f74f0828dad

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: setzer: update to 0.3.9
  2021-01-13 15:27 [PR PATCH] setzer: update to 0.3.9 Bleznudd
@ 2021-01-14 12:18 ` paper42
  2021-01-14 13:27 ` paper42
                   ` (5 subsequent siblings)
  6 siblings, 0 replies; 8+ messages in thread
From: paper42 @ 2021-01-14 12:18 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 345 bytes --]

New comment by paper42 on void-packages repository

https://github.com/void-linux/void-packages/pull/27893#issuecomment-760160856

Comment:
works great, thanks

I noticed some warnings in the build, what do you think about adding AppStream to hostmakedepends?
```
Program appstreamcli found: NO
Program desktop-file-validate found: NO
```

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: setzer: update to 0.3.9
  2021-01-13 15:27 [PR PATCH] setzer: update to 0.3.9 Bleznudd
  2021-01-14 12:18 ` paper42
@ 2021-01-14 13:27 ` paper42
  2021-01-20  0:49 ` ericonr
                   ` (4 subsequent siblings)
  6 siblings, 0 replies; 8+ messages in thread
From: paper42 @ 2021-01-14 13:27 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 185 bytes --]

New comment by paper42 on void-packages repository

https://github.com/void-linux/void-packages/pull/27893#issuecomment-760196325

Comment:
nevermind, the releases have it pregenerated

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: setzer: update to 0.3.9
  2021-01-13 15:27 [PR PATCH] setzer: update to 0.3.9 Bleznudd
  2021-01-14 12:18 ` paper42
  2021-01-14 13:27 ` paper42
@ 2021-01-20  0:49 ` ericonr
  2021-01-23 12:15 ` Bleznudd
                   ` (3 subsequent siblings)
  6 siblings, 0 replies; 8+ messages in thread
From: ericonr @ 2021-01-20  0:49 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 175 bytes --]

New comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/pull/27893#issuecomment-763247193

Comment:
Could you update to 0.4.1, please?

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: setzer: update to 0.3.9
  2021-01-13 15:27 [PR PATCH] setzer: update to 0.3.9 Bleznudd
                   ` (2 preceding siblings ...)
  2021-01-20  0:49 ` ericonr
@ 2021-01-23 12:15 ` Bleznudd
  2021-01-23 19:42 ` ericonr
                   ` (2 subsequent siblings)
  6 siblings, 0 replies; 8+ messages in thread
From: Bleznudd @ 2021-01-23 12:15 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 372 bytes --]

New comment by Bleznudd on void-packages repository

https://github.com/void-linux/void-packages/pull/27893#issuecomment-765935088

Comment:
I'm sorry, but 0.4.1 added [pdfminer](https://pypi.org/project/pdfminer/) as a dependency, and that module is not yet available in void repositories. I suggest to merge this version and then work on a template for python3-pdfminer

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: setzer: update to 0.3.9
  2021-01-13 15:27 [PR PATCH] setzer: update to 0.3.9 Bleznudd
                   ` (3 preceding siblings ...)
  2021-01-23 12:15 ` Bleznudd
@ 2021-01-23 19:42 ` ericonr
  2021-01-23 19:43 ` [PR PATCH] [Merged]: " ericonr
  2021-01-24 12:54 ` Bleznudd
  6 siblings, 0 replies; 8+ messages in thread
From: ericonr @ 2021-01-23 19:42 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 284 bytes --]

New comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/pull/27893#issuecomment-766168083

Comment:
@Bleznudd can you make a 0.4.1 PR later with a commit for pdfminer as a new package as well? It's ok to add new packages for existing packages.

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: [PR PATCH] [Merged]: setzer: update to 0.3.9
  2021-01-13 15:27 [PR PATCH] setzer: update to 0.3.9 Bleznudd
                   ` (4 preceding siblings ...)
  2021-01-23 19:42 ` ericonr
@ 2021-01-23 19:43 ` ericonr
  2021-01-24 12:54 ` Bleznudd
  6 siblings, 0 replies; 8+ messages in thread
From: ericonr @ 2021-01-23 19:43 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 157 bytes --]

There's a merged pull request on the void-packages repository

setzer: update to 0.3.9
https://github.com/void-linux/void-packages/pull/27893

Description:


^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: setzer: update to 0.3.9
  2021-01-13 15:27 [PR PATCH] setzer: update to 0.3.9 Bleznudd
                   ` (5 preceding siblings ...)
  2021-01-23 19:43 ` [PR PATCH] [Merged]: " ericonr
@ 2021-01-24 12:54 ` Bleznudd
  6 siblings, 0 replies; 8+ messages in thread
From: Bleznudd @ 2021-01-24 12:54 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 167 bytes --]

New comment by Bleznudd on void-packages repository

https://github.com/void-linux/void-packages/pull/27893#issuecomment-766343369

Comment:
Sure, I'll look into that

^ permalink raw reply	[flat|nested] 8+ messages in thread

end of thread, other threads:[~2021-01-24 12:54 UTC | newest]

Thread overview: 8+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-01-13 15:27 [PR PATCH] setzer: update to 0.3.9 Bleznudd
2021-01-14 12:18 ` paper42
2021-01-14 13:27 ` paper42
2021-01-20  0:49 ` ericonr
2021-01-23 12:15 ` Bleznudd
2021-01-23 19:42 ` ericonr
2021-01-23 19:43 ` [PR PATCH] [Merged]: " ericonr
2021-01-24 12:54 ` Bleznudd

Github messages for voidlinux

This inbox may be cloned and mirrored by anyone:

	git clone --mirror http://inbox.vuxu.org/voidlinux-github

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V1 voidlinux-github voidlinux-github/ http://inbox.vuxu.org/voidlinux-github \
		voidlinux-github@inbox.vuxu.org
	public-inbox-index voidlinux-github

Example config snippet for mirrors.
Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.github.voidlinux


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git