Github messages for voidlinux
 help / color / mirror / Atom feed
* [PR PATCH] New package: gajim-plugin_installer-1.3.8
@ 2021-02-22 18:59 teldra
  2021-02-24  7:42 ` [PR PATCH] [Updated] " teldra
  2021-02-24  7:45 ` teldra
  0 siblings, 2 replies; 3+ messages in thread
From: teldra @ 2021-02-22 18:59 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1093 bytes --]

There is a new pull request by teldra against master on the void-packages repository

https://github.com/teldra/void-packages new-gajim-plugin_installer
https://github.com/void-linux/void-packages/pull/28982

New package: gajim-plugin_installer-1.3.8
#### General
- [x] This is a new package and it conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements)

#### Have the results of the proposed changes been tested?
- [x] I use the packages affected by the proposed changes on a regular basis and confirm this PR works for me

#### Does it build and run successfully? 
(Please choose at least one native build and, if supported, at least one cross build. More are better.)
- [x] I built this PR locally for my native architecture, (x86_64-glibc)
- [ ] I built this PR locally for these architectures (if supported. mark crossbuilds):
  - [ ] aarch64-musl
  - [ ] armv7l
  - [ ] armv6l-musl

Please merge #28980 first.

A patch file from https://github.com/void-linux/void-packages/pull/28982.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-new-gajim-plugin_installer-28982.patch --]
[-- Type: text/x-diff, Size: 1338 bytes --]

From 492f7b20e10ab5605ea83fa3aa5bd49048fbe933 Mon Sep 17 00:00:00 2001
From: teldra <teldra@rotce.de>
Date: Mon, 22 Feb 2021 19:53:27 +0100
Subject: [PATCH] New package: gajim-plugin_installer-1.3.8

---
 srcpkgs/gajim-plugin_installer/template | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
 create mode 100644 srcpkgs/gajim-plugin_installer/template

diff --git a/srcpkgs/gajim-plugin_installer/template b/srcpkgs/gajim-plugin_installer/template
new file mode 100644
index 00000000000..2b35c0b1a93
--- /dev/null
+++ b/srcpkgs/gajim-plugin_installer/template
@@ -0,0 +1,20 @@
+# Template file for 'gajim-plugin_installer'
+pkgname=gajim-plugin_installer
+_gajim_version=1.3
+version=1.3.8
+revision=1
+wrksrc="plugin_installer"
+hostmakedepends="unzip"
+depends="python3 python3-setuptools"
+short_desc="Gajim plugin ffor installing plugins"
+maintainer="teldra <teldra@rotce.de>"
+license="GPL-3.0-or-later"
+homepage="https://dev.gajim.org/gajim/gajim-plugins/wikis/OmemoGajimPlugin"
+distfiles="https://ftp.gajim.org/plugins_${_gajim_version}_zip/${pkgname#gajim-}.zip"
+checksum=95a1722cc8df1a637a3227994c88eedf925bba50913a05a3bc94509010c00667
+
+
+do_install() {
+	install -d "${DESTDIR}/${py3_sitelib}/gajim/data/plugins/${pkgname#gajim-}"
+	cp -r * "${DESTDIR}/${py3_sitelib}/gajim/data/plugins/${pkgname#gajim-}"
+}

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PR PATCH] [Updated] New package: gajim-plugin_installer-1.3.8
  2021-02-22 18:59 [PR PATCH] New package: gajim-plugin_installer-1.3.8 teldra
@ 2021-02-24  7:42 ` teldra
  2021-02-24  7:45 ` teldra
  1 sibling, 0 replies; 3+ messages in thread
From: teldra @ 2021-02-24  7:42 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1098 bytes --]

There is an updated pull request by teldra against master on the void-packages repository

https://github.com/teldra/void-packages new-gajim-plugin_installer
https://github.com/void-linux/void-packages/pull/28982

New package: gajim-plugin_installer-1.3.8
#### General
- [x] This is a new package and it conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements)

#### Have the results of the proposed changes been tested?
- [x] I use the packages affected by the proposed changes on a regular basis and confirm this PR works for me

#### Does it build and run successfully? 
(Please choose at least one native build and, if supported, at least one cross build. More are better.)
- [x] I built this PR locally for my native architecture, (x86_64-glibc)
- [ ] I built this PR locally for these architectures (if supported. mark crossbuilds):
  - [ ] aarch64-musl
  - [ ] armv7l
  - [ ] armv6l-musl

Please merge #28980 first.

A patch file from https://github.com/void-linux/void-packages/pull/28982.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-new-gajim-plugin_installer-28982.patch --]
[-- Type: text/x-diff, Size: 1342 bytes --]

From e1bfdfee02d0df494f1f005bfd13870ba1eb91b1 Mon Sep 17 00:00:00 2001
From: teldra <teldra@rotce.de>
Date: Mon, 22 Feb 2021 19:53:27 +0100
Subject: [PATCH] New package: gajim-plugin_installer-1.3.8

---
 srcpkgs/gajim-plugin_installer/template | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
 create mode 100644 srcpkgs/gajim-plugin_installer/template

diff --git a/srcpkgs/gajim-plugin_installer/template b/srcpkgs/gajim-plugin_installer/template
new file mode 100644
index 00000000000..63f1eb92760
--- /dev/null
+++ b/srcpkgs/gajim-plugin_installer/template
@@ -0,0 +1,20 @@
+# Template file for 'gajim-plugin_installer'
+pkgname=gajim-plugin_installer
+_gajim_version=1.3
+version=1.3.8
+revision=1
+wrksrc="plugin_installer"
+hostmakedepends="unzip"
+depends="python3 python3-setuptools gajim"
+short_desc="Gajim plugin for installing plugins"
+maintainer="teldra <teldra@rotce.de>"
+license="GPL-3.0-or-only"
+homepage="https://dev.gajim.org/gajim/gajim-plugins/wikis/OmemoGajimPlugin"
+distfiles="https://ftp.gajim.org/plugins_${_gajim_version}_zip/${pkgname#gajim-}.zip"
+checksum=95a1722cc8df1a637a3227994c88eedf925bba50913a05a3bc94509010c00667
+
+
+do_install() {
+	install -d "${DESTDIR}/${py3_sitelib}/gajim/data/plugins/${pkgname#gajim-}"
+	cp -r * "${DESTDIR}/${py3_sitelib}/gajim/data/plugins/${pkgname#gajim-}"
+}

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PR PATCH] [Updated] New package: gajim-plugin_installer-1.3.8
  2021-02-22 18:59 [PR PATCH] New package: gajim-plugin_installer-1.3.8 teldra
  2021-02-24  7:42 ` [PR PATCH] [Updated] " teldra
@ 2021-02-24  7:45 ` teldra
  1 sibling, 0 replies; 3+ messages in thread
From: teldra @ 2021-02-24  7:45 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1098 bytes --]

There is an updated pull request by teldra against master on the void-packages repository

https://github.com/teldra/void-packages new-gajim-plugin_installer
https://github.com/void-linux/void-packages/pull/28982

New package: gajim-plugin_installer-1.3.8
#### General
- [x] This is a new package and it conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements)

#### Have the results of the proposed changes been tested?
- [x] I use the packages affected by the proposed changes on a regular basis and confirm this PR works for me

#### Does it build and run successfully? 
(Please choose at least one native build and, if supported, at least one cross build. More are better.)
- [x] I built this PR locally for my native architecture, (x86_64-glibc)
- [ ] I built this PR locally for these architectures (if supported. mark crossbuilds):
  - [ ] aarch64-musl
  - [ ] armv7l
  - [ ] armv6l-musl

Please merge #28980 first.

A patch file from https://github.com/void-linux/void-packages/pull/28982.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-new-gajim-plugin_installer-28982.patch --]
[-- Type: text/x-diff, Size: 1339 bytes --]

From 01b8d63d93b78492ab61cf8f7f848a04e5529cac Mon Sep 17 00:00:00 2001
From: teldra <teldra@rotce.de>
Date: Mon, 22 Feb 2021 19:53:27 +0100
Subject: [PATCH] New package: gajim-plugin_installer-1.3.8

---
 srcpkgs/gajim-plugin_installer/template | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
 create mode 100644 srcpkgs/gajim-plugin_installer/template

diff --git a/srcpkgs/gajim-plugin_installer/template b/srcpkgs/gajim-plugin_installer/template
new file mode 100644
index 00000000000..01302141059
--- /dev/null
+++ b/srcpkgs/gajim-plugin_installer/template
@@ -0,0 +1,20 @@
+# Template file for 'gajim-plugin_installer'
+pkgname=gajim-plugin_installer
+_gajim_version=1.3
+version=1.3.8
+revision=1
+wrksrc="plugin_installer"
+hostmakedepends="unzip"
+depends="python3 python3-setuptools gajim"
+short_desc="Gajim plugin for installing plugins"
+maintainer="teldra <teldra@rotce.de>"
+license="GPL-3.0-only"
+homepage="https://dev.gajim.org/gajim/gajim-plugins/wikis/OmemoGajimPlugin"
+distfiles="https://ftp.gajim.org/plugins_${_gajim_version}_zip/${pkgname#gajim-}.zip"
+checksum=95a1722cc8df1a637a3227994c88eedf925bba50913a05a3bc94509010c00667
+
+
+do_install() {
+	install -d "${DESTDIR}/${py3_sitelib}/gajim/data/plugins/${pkgname#gajim-}"
+	cp -r * "${DESTDIR}/${py3_sitelib}/gajim/data/plugins/${pkgname#gajim-}"
+}

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2021-02-24  7:46 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-02-22 18:59 [PR PATCH] New package: gajim-plugin_installer-1.3.8 teldra
2021-02-24  7:42 ` [PR PATCH] [Updated] " teldra
2021-02-24  7:45 ` teldra

Github messages for voidlinux

This inbox may be cloned and mirrored by anyone:

	git clone --mirror http://inbox.vuxu.org/voidlinux-github

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V1 voidlinux-github voidlinux-github/ http://inbox.vuxu.org/voidlinux-github \
		voidlinux-github@inbox.vuxu.org
	public-inbox-index voidlinux-github

Example config snippet for mirrors.
Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.github.voidlinux


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git