Github messages for voidlinux
 help / color / mirror / Atom feed
* [ISSUE] `jupyter-core` is not found
@ 2021-10-14  9:28 rivanfebrian123
  2021-10-14 11:58 ` dkwo
                   ` (3 more replies)
  0 siblings, 4 replies; 5+ messages in thread
From: rivanfebrian123 @ 2021-10-14  9:28 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1823 bytes --]

New issue by rivanfebrian123 on void-packages repository

https://github.com/void-linux/void-packages/issues/33536

Description:
<!-- Don't request update of package. We have a script for that. https://alpha.de.repo.voidlinux.org/void-updates/void-updates.txt . However, a quality pull request may help. -->
### System

* xuname: Void 5.13.19_1 x86_64 GenuineIntel notuptodate rrrmFFFFF
* package:  python3-jupyter_notebook-6.3.0_2

### Expected behavior

### Actual behavior
```
[rivanfebrian123@RVN ~]$ jupyter notebook
Traceback (most recent call last):
  File "/usr/bin/jupyter", line 33, in <module>
    sys.exit(load_entry_point('jupyter-core==4.7.1', 'console_scripts', 'jupyter')())
  File "/usr/bin/jupyter", line 22, in importlib_load_entry_point
    for entry_point in distribution(dist_name).entry_points
  File "/usr/lib/python3.9/importlib/metadata.py", line 524, in distribution
    return Distribution.from_name(distribution_name)
  File "/usr/lib/python3.9/importlib/metadata.py", line 187, in from_name
    raise PackageNotFoundError(name)
importlib.metadata.PackageNotFoundError: jupyter-core
```

When I try to install `jupyter-core` manually, it says:
```
[rivanfebrian123@RVN ~]$ sudo xbps-install -S python3-jupyter_core
Password: 
[*] Updating repository `https://alpha.de.repo.voidlinux.org/current/x86_64-repodata' ...
[*] Updating repository `https://alpha.de.repo.voidlinux.org/current/multilib/nonfree/x86_64-repodata' ...
[*] Updating repository `https://alpha.de.repo.voidlinux.org/current/multilib/x86_64-repodata' ...
[*] Updating repository `https://alpha.de.repo.voidlinux.org/current/nonfree/x86_64-repodata' ...
Package `python3-jupyter_core' already installed.
```

### Steps to reproduce the behavior
`sudo xbps-install -S python3-jupyter_notebook`

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: `jupyter-core` is not found
  2021-10-14  9:28 [ISSUE] `jupyter-core` is not found rivanfebrian123
@ 2021-10-14 11:58 ` dkwo
  2021-10-14 13:37 ` ahesford
                   ` (2 subsequent siblings)
  3 siblings, 0 replies; 5+ messages in thread
From: dkwo @ 2021-10-14 11:58 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 235 bytes --]

New comment by dkwo on void-packages repository

https://github.com/void-linux/void-packages/issues/33536#issuecomment-943286772

Comment:
Not a solution, but the more modern `jupyterlab` works for me, perhaps you could give it a try.

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: `jupyter-core` is not found
  2021-10-14  9:28 [ISSUE] `jupyter-core` is not found rivanfebrian123
  2021-10-14 11:58 ` dkwo
@ 2021-10-14 13:37 ` ahesford
  2021-10-15  6:40 ` rivanfebrian123
  2021-10-15  6:40 ` [ISSUE] [CLOSED] " rivanfebrian123
  3 siblings, 0 replies; 5+ messages in thread
From: ahesford @ 2021-10-14 13:37 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 305 bytes --]

New comment by ahesford on void-packages repository

https://github.com/void-linux/void-packages/issues/33536#issuecomment-943366498

Comment:
The `python3-jupyter_core` package you have is too new. You are still running Python 3.9, but we just moved Void to 3.10. You'll need to do a full system update.

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: `jupyter-core` is not found
  2021-10-14  9:28 [ISSUE] `jupyter-core` is not found rivanfebrian123
  2021-10-14 11:58 ` dkwo
  2021-10-14 13:37 ` ahesford
@ 2021-10-15  6:40 ` rivanfebrian123
  2021-10-15  6:40 ` [ISSUE] [CLOSED] " rivanfebrian123
  3 siblings, 0 replies; 5+ messages in thread
From: rivanfebrian123 @ 2021-10-15  6:40 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 236 bytes --]

New comment by rivanfebrian123 on void-packages repository

https://github.com/void-linux/void-packages/issues/33536#issuecomment-944041074

Comment:
@ahesford Yes, it works. Thanks for the hint
@dkwo Thanks for your suggestion anyway

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [ISSUE] [CLOSED] `jupyter-core` is not found
  2021-10-14  9:28 [ISSUE] `jupyter-core` is not found rivanfebrian123
                   ` (2 preceding siblings ...)
  2021-10-15  6:40 ` rivanfebrian123
@ 2021-10-15  6:40 ` rivanfebrian123
  3 siblings, 0 replies; 5+ messages in thread
From: rivanfebrian123 @ 2021-10-15  6:40 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1826 bytes --]

Closed issue by rivanfebrian123 on void-packages repository

https://github.com/void-linux/void-packages/issues/33536

Description:
<!-- Don't request update of package. We have a script for that. https://alpha.de.repo.voidlinux.org/void-updates/void-updates.txt . However, a quality pull request may help. -->
### System

* xuname: Void 5.13.19_1 x86_64 GenuineIntel notuptodate rrrmFFFFF
* package:  python3-jupyter_notebook-6.3.0_2

### Expected behavior

### Actual behavior
```
[rivanfebrian123@RVN ~]$ jupyter notebook
Traceback (most recent call last):
  File "/usr/bin/jupyter", line 33, in <module>
    sys.exit(load_entry_point('jupyter-core==4.7.1', 'console_scripts', 'jupyter')())
  File "/usr/bin/jupyter", line 22, in importlib_load_entry_point
    for entry_point in distribution(dist_name).entry_points
  File "/usr/lib/python3.9/importlib/metadata.py", line 524, in distribution
    return Distribution.from_name(distribution_name)
  File "/usr/lib/python3.9/importlib/metadata.py", line 187, in from_name
    raise PackageNotFoundError(name)
importlib.metadata.PackageNotFoundError: jupyter-core
```

When I try to install `jupyter-core` manually, it says:
```
[rivanfebrian123@RVN ~]$ sudo xbps-install -S python3-jupyter_core
Password: 
[*] Updating repository `https://alpha.de.repo.voidlinux.org/current/x86_64-repodata' ...
[*] Updating repository `https://alpha.de.repo.voidlinux.org/current/multilib/nonfree/x86_64-repodata' ...
[*] Updating repository `https://alpha.de.repo.voidlinux.org/current/multilib/x86_64-repodata' ...
[*] Updating repository `https://alpha.de.repo.voidlinux.org/current/nonfree/x86_64-repodata' ...
Package `python3-jupyter_core' already installed.
```

### Steps to reproduce the behavior
`sudo xbps-install -S python3-jupyter_notebook`

^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2021-10-15  6:40 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-10-14  9:28 [ISSUE] `jupyter-core` is not found rivanfebrian123
2021-10-14 11:58 ` dkwo
2021-10-14 13:37 ` ahesford
2021-10-15  6:40 ` rivanfebrian123
2021-10-15  6:40 ` [ISSUE] [CLOSED] " rivanfebrian123

Github messages for voidlinux

This inbox may be cloned and mirrored by anyone:

	git clone --mirror https://inbox.vuxu.org/voidlinux-github

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V1 voidlinux-github voidlinux-github/ https://inbox.vuxu.org/voidlinux-github \
		voidlinux-github@inbox.vuxu.org
	public-inbox-index voidlinux-github

Example config snippet for mirrors.
Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.github.voidlinux


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git