Github messages for voidlinux
 help / color / mirror / Atom feed
* [PR PATCH] lumina: update to 1.6.1.
@ 2021-11-26 18:57 karlgrose
  2021-11-27 23:57 ` [PR PATCH] [Updated] " karlgrose
                   ` (16 more replies)
  0 siblings, 17 replies; 18+ messages in thread
From: karlgrose @ 2021-11-26 18:57 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1073 bytes --]

There is a new pull request by karlgrose against master on the void-packages repository

https://github.com/karlgrose/void-packages master
https://github.com/void-linux/void-packages/pull/34262

lumina: update to 1.6.1.
<!-- Uncomment relevant sections and delete options which are not applicable -->

#### Testing the changes
- I tested the changes in this PR: **YES**

<!--
#### New package
- This new package conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements): **YES**|**NO**
-->

<!-- Note: If the build is likely to take more than 2 hours, please [skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration)
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->

#### Local build testing
- I built this PR locally for my native architecture, (x86_64-glibc)


A patch file from https://github.com/void-linux/void-packages/pull/34262.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-master-34262.patch --]
[-- Type: text/x-diff, Size: 3462 bytes --]

From dda2aea773fbf0414f944668d5b472483104c704 Mon Sep 17 00:00:00 2001
From: Karl R Grose <karlgrose@gromar.org>
Date: Fri, 26 Nov 2021 10:15:38 -0800
Subject: [PATCH] lumina: update to 1.6.1.

---
 srcpkgs/lumina/patches/checkpass.patch | 19 +++++++++++++++++++
 srcpkgs/lumina/patches/mandir.patch    | 11 -----------
 srcpkgs/lumina/template                |  8 ++++----
 3 files changed, 23 insertions(+), 15 deletions(-)
 create mode 100644 srcpkgs/lumina/patches/checkpass.patch
 delete mode 100644 srcpkgs/lumina/patches/mandir.patch

diff --git a/srcpkgs/lumina/patches/checkpass.patch b/srcpkgs/lumina/patches/checkpass.patch
new file mode 100644
index 000000000000..7534550b0019
--- /dev/null
+++ b/srcpkgs/lumina/patches/checkpass.patch
@@ -0,0 +1,19 @@
+--- a/src-qt5/core/lumina-checkpass/lumina-checkpass.pro
++++ b/src-qt5/core/lumina-checkpass/lumina-checkpass.pro
+@@ -6,13 +6,13 @@ QT =
+ CONFIG += console
+ 
+ TARGET = lumina-checkpass
+-target.path = $$DESTDIR$${PREFIX}/sbin
++target.path = $$DESTDIR$${PREFIX}/bin
+ 
+ LIBS     += -lpam
+ 
+ SOURCES += main.c
+ 
+-perms.path = $$DESTDIR$${PREFIX}/sbin
+-perms.extra = "chmod 4555 $$DESTDIR$${PREFIX}/sbin/lumina-checkpass"
++perms.path = $$DESTDIR$${PREFIX}/bin
++perms.extra = "chmod 4555 $(INSTALL_ROOT)$$DESTDIR$${PREFIX}/bin/lumina-checkpass"
+ 
+ INSTALLS += target perms
diff --git a/srcpkgs/lumina/patches/mandir.patch b/srcpkgs/lumina/patches/mandir.patch
deleted file mode 100644
index 9b9ce50a1e5d..000000000000
--- a/srcpkgs/lumina/patches/mandir.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src-qt5/OS-detect.pri	2017-07-05 20:02:49.727200592 +0200
-+++ b/src-qt5/OS-detect.pri	2017-07-05 20:03:10.463911159 +0200
-@@ -94,7 +94,7 @@
-   isEmpty(L_SHAREDIR){ L_SHAREDIR = $${PREFIX}/share }
-   isEmpty(L_INCLUDEDIR){ L_INCLUDEDIR = $${PREFIX}/include }
-   isEmpty(L_SESSDIR){ L_SESSDIR = $${L_SHAREDIR}/xsessions }
--  isEmpty(L_MANDIR){ L_MANDIR = $${PREFIX}/man }
-+  isEmpty(L_MANDIR){ L_MANDIR = $${PREFIX}/share/man }
-   isEmpty(LRELEASE){ LRELEASE = $$[QT_INSTALL_BINS]/lrelease }
-   isEmpty(MAN_ZIP){ MAN_ZIP = "gzip -c" }
-   !exists(LRELEASE){ NO_I18N=true } #translations unavailable
diff --git a/srcpkgs/lumina/template b/srcpkgs/lumina/template
index ed7ef97adfba..5299c6ae9c54 100644
--- a/srcpkgs/lumina/template
+++ b/srcpkgs/lumina/template
@@ -1,11 +1,11 @@
 # Template file for 'lumina'
 pkgname=lumina
-version=1.6.0
-revision=2
+version=1.6.1
+revision=1
 build_style=qmake
 configure_args="QT5LIBDIR=/usr/lib/qt5 L_ETCDIR=/etc CONFIG+=WITH_I18N"
 hostmakedepends="qt5-host-tools qt5-qmake"
-makedepends="qt5-devel qt5-x11extras-devel qt5-multimedia-devel qt5-svg-devel
+makedepends="qt5-devel qt5-x11extras-devel qt5-multimedia-devel qt5-svg-devel pam-devel
  qt5-declarative-devel libXrender-devel libXcomposite-devel libXcursor-devel libXdamage-devel
  xcb-util-devel xcb-util-wm-devel xcb-util-image-devel pulseaudio-devel poppler-qt5-devel"
 depends="fluxbox numlockx xbacklight alsa-utils acpi xscreensaver bsdtar qt5-svg qsudo"
@@ -14,7 +14,7 @@ maintainer="hipperson0 <hipperson0@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/lumina-desktop/lumina"
 distfiles="https://github.com/lumina-desktop/lumina/archive/v${version}.tar.gz"
-checksum=f3512fca4d05e3cf3a6ac106f0f16c9618bda9fa546f1d23ffb0eab9a5ce7c8a
+checksum=2bc649c95da8f997bf943cc1e64af4a61921ddc5d63dd3c46fc0ba8708e29a92
 replaces="lumina-git>=0"
 
 post_install() {

^ permalink raw reply	[flat|nested] 18+ messages in thread

* Re: [PR PATCH] [Updated] lumina: update to 1.6.1.
  2021-11-26 18:57 [PR PATCH] lumina: update to 1.6.1 karlgrose
@ 2021-11-27 23:57 ` karlgrose
  2021-11-28  0:38 ` karlgrose
                   ` (15 subsequent siblings)
  16 siblings, 0 replies; 18+ messages in thread
From: karlgrose @ 2021-11-27 23:57 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1078 bytes --]

There is an updated pull request by karlgrose against master on the void-packages repository

https://github.com/karlgrose/void-packages master
https://github.com/void-linux/void-packages/pull/34262

lumina: update to 1.6.1.
<!-- Uncomment relevant sections and delete options which are not applicable -->

#### Testing the changes
- I tested the changes in this PR: **YES**

<!--
#### New package
- This new package conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements): **YES**|**NO**
-->

<!-- Note: If the build is likely to take more than 2 hours, please [skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration)
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->

#### Local build testing
- I built this PR locally for my native architecture, (x86_64-glibc)


A patch file from https://github.com/void-linux/void-packages/pull/34262.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-master-34262.patch --]
[-- Type: text/x-diff, Size: 3462 bytes --]

From dda2aea773fbf0414f944668d5b472483104c704 Mon Sep 17 00:00:00 2001
From: Karl R Grose <karlgrose@gromar.org>
Date: Fri, 26 Nov 2021 10:15:38 -0800
Subject: [PATCH] lumina: update to 1.6.1.

---
 srcpkgs/lumina/patches/checkpass.patch | 19 +++++++++++++++++++
 srcpkgs/lumina/patches/mandir.patch    | 11 -----------
 srcpkgs/lumina/template                |  8 ++++----
 3 files changed, 23 insertions(+), 15 deletions(-)
 create mode 100644 srcpkgs/lumina/patches/checkpass.patch
 delete mode 100644 srcpkgs/lumina/patches/mandir.patch

diff --git a/srcpkgs/lumina/patches/checkpass.patch b/srcpkgs/lumina/patches/checkpass.patch
new file mode 100644
index 000000000000..7534550b0019
--- /dev/null
+++ b/srcpkgs/lumina/patches/checkpass.patch
@@ -0,0 +1,19 @@
+--- a/src-qt5/core/lumina-checkpass/lumina-checkpass.pro
++++ b/src-qt5/core/lumina-checkpass/lumina-checkpass.pro
+@@ -6,13 +6,13 @@ QT =
+ CONFIG += console
+ 
+ TARGET = lumina-checkpass
+-target.path = $$DESTDIR$${PREFIX}/sbin
++target.path = $$DESTDIR$${PREFIX}/bin
+ 
+ LIBS     += -lpam
+ 
+ SOURCES += main.c
+ 
+-perms.path = $$DESTDIR$${PREFIX}/sbin
+-perms.extra = "chmod 4555 $$DESTDIR$${PREFIX}/sbin/lumina-checkpass"
++perms.path = $$DESTDIR$${PREFIX}/bin
++perms.extra = "chmod 4555 $(INSTALL_ROOT)$$DESTDIR$${PREFIX}/bin/lumina-checkpass"
+ 
+ INSTALLS += target perms
diff --git a/srcpkgs/lumina/patches/mandir.patch b/srcpkgs/lumina/patches/mandir.patch
deleted file mode 100644
index 9b9ce50a1e5d..000000000000
--- a/srcpkgs/lumina/patches/mandir.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src-qt5/OS-detect.pri	2017-07-05 20:02:49.727200592 +0200
-+++ b/src-qt5/OS-detect.pri	2017-07-05 20:03:10.463911159 +0200
-@@ -94,7 +94,7 @@
-   isEmpty(L_SHAREDIR){ L_SHAREDIR = $${PREFIX}/share }
-   isEmpty(L_INCLUDEDIR){ L_INCLUDEDIR = $${PREFIX}/include }
-   isEmpty(L_SESSDIR){ L_SESSDIR = $${L_SHAREDIR}/xsessions }
--  isEmpty(L_MANDIR){ L_MANDIR = $${PREFIX}/man }
-+  isEmpty(L_MANDIR){ L_MANDIR = $${PREFIX}/share/man }
-   isEmpty(LRELEASE){ LRELEASE = $$[QT_INSTALL_BINS]/lrelease }
-   isEmpty(MAN_ZIP){ MAN_ZIP = "gzip -c" }
-   !exists(LRELEASE){ NO_I18N=true } #translations unavailable
diff --git a/srcpkgs/lumina/template b/srcpkgs/lumina/template
index ed7ef97adfba..5299c6ae9c54 100644
--- a/srcpkgs/lumina/template
+++ b/srcpkgs/lumina/template
@@ -1,11 +1,11 @@
 # Template file for 'lumina'
 pkgname=lumina
-version=1.6.0
-revision=2
+version=1.6.1
+revision=1
 build_style=qmake
 configure_args="QT5LIBDIR=/usr/lib/qt5 L_ETCDIR=/etc CONFIG+=WITH_I18N"
 hostmakedepends="qt5-host-tools qt5-qmake"
-makedepends="qt5-devel qt5-x11extras-devel qt5-multimedia-devel qt5-svg-devel
+makedepends="qt5-devel qt5-x11extras-devel qt5-multimedia-devel qt5-svg-devel pam-devel
  qt5-declarative-devel libXrender-devel libXcomposite-devel libXcursor-devel libXdamage-devel
  xcb-util-devel xcb-util-wm-devel xcb-util-image-devel pulseaudio-devel poppler-qt5-devel"
 depends="fluxbox numlockx xbacklight alsa-utils acpi xscreensaver bsdtar qt5-svg qsudo"
@@ -14,7 +14,7 @@ maintainer="hipperson0 <hipperson0@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/lumina-desktop/lumina"
 distfiles="https://github.com/lumina-desktop/lumina/archive/v${version}.tar.gz"
-checksum=f3512fca4d05e3cf3a6ac106f0f16c9618bda9fa546f1d23ffb0eab9a5ce7c8a
+checksum=2bc649c95da8f997bf943cc1e64af4a61921ddc5d63dd3c46fc0ba8708e29a92
 replaces="lumina-git>=0"
 
 post_install() {

^ permalink raw reply	[flat|nested] 18+ messages in thread

* Re: [PR PATCH] [Updated] lumina: update to 1.6.1.
  2021-11-26 18:57 [PR PATCH] lumina: update to 1.6.1 karlgrose
  2021-11-27 23:57 ` [PR PATCH] [Updated] " karlgrose
@ 2021-11-28  0:38 ` karlgrose
  2021-11-28 17:19 ` karlgrose
                   ` (14 subsequent siblings)
  16 siblings, 0 replies; 18+ messages in thread
From: karlgrose @ 2021-11-28  0:38 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1078 bytes --]

There is an updated pull request by karlgrose against master on the void-packages repository

https://github.com/karlgrose/void-packages master
https://github.com/void-linux/void-packages/pull/34262

lumina: update to 1.6.1.
<!-- Uncomment relevant sections and delete options which are not applicable -->

#### Testing the changes
- I tested the changes in this PR: **YES**

<!--
#### New package
- This new package conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements): **YES**|**NO**
-->

<!-- Note: If the build is likely to take more than 2 hours, please [skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration)
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->

#### Local build testing
- I built this PR locally for my native architecture, (x86_64-glibc)


A patch file from https://github.com/void-linux/void-packages/pull/34262.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-master-34262.patch --]
[-- Type: text/x-diff, Size: 6933 bytes --]

From dda2aea773fbf0414f944668d5b472483104c704 Mon Sep 17 00:00:00 2001
From: Karl R Grose <karlgrose@gromar.org>
Date: Fri, 26 Nov 2021 10:15:38 -0800
Subject: [PATCH 1/2] lumina: update to 1.6.1.

---
 srcpkgs/lumina/patches/checkpass.patch | 19 +++++++++++++++++++
 srcpkgs/lumina/patches/mandir.patch    | 11 -----------
 srcpkgs/lumina/template                |  8 ++++----
 3 files changed, 23 insertions(+), 15 deletions(-)
 create mode 100644 srcpkgs/lumina/patches/checkpass.patch
 delete mode 100644 srcpkgs/lumina/patches/mandir.patch

diff --git a/srcpkgs/lumina/patches/checkpass.patch b/srcpkgs/lumina/patches/checkpass.patch
new file mode 100644
index 000000000000..7534550b0019
--- /dev/null
+++ b/srcpkgs/lumina/patches/checkpass.patch
@@ -0,0 +1,19 @@
+--- a/src-qt5/core/lumina-checkpass/lumina-checkpass.pro
++++ b/src-qt5/core/lumina-checkpass/lumina-checkpass.pro
+@@ -6,13 +6,13 @@ QT =
+ CONFIG += console
+ 
+ TARGET = lumina-checkpass
+-target.path = $$DESTDIR$${PREFIX}/sbin
++target.path = $$DESTDIR$${PREFIX}/bin
+ 
+ LIBS     += -lpam
+ 
+ SOURCES += main.c
+ 
+-perms.path = $$DESTDIR$${PREFIX}/sbin
+-perms.extra = "chmod 4555 $$DESTDIR$${PREFIX}/sbin/lumina-checkpass"
++perms.path = $$DESTDIR$${PREFIX}/bin
++perms.extra = "chmod 4555 $(INSTALL_ROOT)$$DESTDIR$${PREFIX}/bin/lumina-checkpass"
+ 
+ INSTALLS += target perms
diff --git a/srcpkgs/lumina/patches/mandir.patch b/srcpkgs/lumina/patches/mandir.patch
deleted file mode 100644
index 9b9ce50a1e5d..000000000000
--- a/srcpkgs/lumina/patches/mandir.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src-qt5/OS-detect.pri	2017-07-05 20:02:49.727200592 +0200
-+++ b/src-qt5/OS-detect.pri	2017-07-05 20:03:10.463911159 +0200
-@@ -94,7 +94,7 @@
-   isEmpty(L_SHAREDIR){ L_SHAREDIR = $${PREFIX}/share }
-   isEmpty(L_INCLUDEDIR){ L_INCLUDEDIR = $${PREFIX}/include }
-   isEmpty(L_SESSDIR){ L_SESSDIR = $${L_SHAREDIR}/xsessions }
--  isEmpty(L_MANDIR){ L_MANDIR = $${PREFIX}/man }
-+  isEmpty(L_MANDIR){ L_MANDIR = $${PREFIX}/share/man }
-   isEmpty(LRELEASE){ LRELEASE = $$[QT_INSTALL_BINS]/lrelease }
-   isEmpty(MAN_ZIP){ MAN_ZIP = "gzip -c" }
-   !exists(LRELEASE){ NO_I18N=true } #translations unavailable
diff --git a/srcpkgs/lumina/template b/srcpkgs/lumina/template
index ed7ef97adfba..5299c6ae9c54 100644
--- a/srcpkgs/lumina/template
+++ b/srcpkgs/lumina/template
@@ -1,11 +1,11 @@
 # Template file for 'lumina'
 pkgname=lumina
-version=1.6.0
-revision=2
+version=1.6.1
+revision=1
 build_style=qmake
 configure_args="QT5LIBDIR=/usr/lib/qt5 L_ETCDIR=/etc CONFIG+=WITH_I18N"
 hostmakedepends="qt5-host-tools qt5-qmake"
-makedepends="qt5-devel qt5-x11extras-devel qt5-multimedia-devel qt5-svg-devel
+makedepends="qt5-devel qt5-x11extras-devel qt5-multimedia-devel qt5-svg-devel pam-devel
  qt5-declarative-devel libXrender-devel libXcomposite-devel libXcursor-devel libXdamage-devel
  xcb-util-devel xcb-util-wm-devel xcb-util-image-devel pulseaudio-devel poppler-qt5-devel"
 depends="fluxbox numlockx xbacklight alsa-utils acpi xscreensaver bsdtar qt5-svg qsudo"
@@ -14,7 +14,7 @@ maintainer="hipperson0 <hipperson0@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/lumina-desktop/lumina"
 distfiles="https://github.com/lumina-desktop/lumina/archive/v${version}.tar.gz"
-checksum=f3512fca4d05e3cf3a6ac106f0f16c9618bda9fa546f1d23ffb0eab9a5ce7c8a
+checksum=2bc649c95da8f997bf943cc1e64af4a61921ddc5d63dd3c46fc0ba8708e29a92
 replaces="lumina-git>=0"
 
 post_install() {

From 7fb992828c132a3277359a1584c786c19cb5b56a Mon Sep 17 00:00:00 2001
From: Karl R Grose <karlgrose@gromar.org>
Date: Fri, 26 Nov 2021 10:15:38 -0800
Subject: [PATCH 2/2] lumina: update to 1.6.1.

---
 srcpkgs/lumina/patches/checkpass.patch | 19 +++++++++++++++++++
 srcpkgs/lumina/patches/mandir.patch    | 11 -----------
 srcpkgs/lumina/template                |  8 ++++----
 3 files changed, 23 insertions(+), 15 deletions(-)
 create mode 100644 srcpkgs/lumina/patches/checkpass.patch
 delete mode 100644 srcpkgs/lumina/patches/mandir.patch

diff --git a/srcpkgs/lumina/patches/checkpass.patch b/srcpkgs/lumina/patches/checkpass.patch
new file mode 100644
index 000000000000..7534550b0019
--- /dev/null
+++ b/srcpkgs/lumina/patches/checkpass.patch
@@ -0,0 +1,19 @@
+--- a/src-qt5/core/lumina-checkpass/lumina-checkpass.pro
++++ b/src-qt5/core/lumina-checkpass/lumina-checkpass.pro
+@@ -6,13 +6,13 @@ QT =
+ CONFIG += console
+ 
+ TARGET = lumina-checkpass
+-target.path = $$DESTDIR$${PREFIX}/sbin
++target.path = $$DESTDIR$${PREFIX}/bin
+ 
+ LIBS     += -lpam
+ 
+ SOURCES += main.c
+ 
+-perms.path = $$DESTDIR$${PREFIX}/sbin
+-perms.extra = "chmod 4555 $$DESTDIR$${PREFIX}/sbin/lumina-checkpass"
++perms.path = $$DESTDIR$${PREFIX}/bin
++perms.extra = "chmod 4555 $(INSTALL_ROOT)$$DESTDIR$${PREFIX}/bin/lumina-checkpass"
+ 
+ INSTALLS += target perms
diff --git a/srcpkgs/lumina/patches/mandir.patch b/srcpkgs/lumina/patches/mandir.patch
deleted file mode 100644
index 9b9ce50a1e5d..000000000000
--- a/srcpkgs/lumina/patches/mandir.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src-qt5/OS-detect.pri	2017-07-05 20:02:49.727200592 +0200
-+++ b/src-qt5/OS-detect.pri	2017-07-05 20:03:10.463911159 +0200
-@@ -94,7 +94,7 @@
-   isEmpty(L_SHAREDIR){ L_SHAREDIR = $${PREFIX}/share }
-   isEmpty(L_INCLUDEDIR){ L_INCLUDEDIR = $${PREFIX}/include }
-   isEmpty(L_SESSDIR){ L_SESSDIR = $${L_SHAREDIR}/xsessions }
--  isEmpty(L_MANDIR){ L_MANDIR = $${PREFIX}/man }
-+  isEmpty(L_MANDIR){ L_MANDIR = $${PREFIX}/share/man }
-   isEmpty(LRELEASE){ LRELEASE = $$[QT_INSTALL_BINS]/lrelease }
-   isEmpty(MAN_ZIP){ MAN_ZIP = "gzip -c" }
-   !exists(LRELEASE){ NO_I18N=true } #translations unavailable
diff --git a/srcpkgs/lumina/template b/srcpkgs/lumina/template
index ed7ef97adfba..5299c6ae9c54 100644
--- a/srcpkgs/lumina/template
+++ b/srcpkgs/lumina/template
@@ -1,11 +1,11 @@
 # Template file for 'lumina'
 pkgname=lumina
-version=1.6.0
-revision=2
+version=1.6.1
+revision=1
 build_style=qmake
 configure_args="QT5LIBDIR=/usr/lib/qt5 L_ETCDIR=/etc CONFIG+=WITH_I18N"
 hostmakedepends="qt5-host-tools qt5-qmake"
-makedepends="qt5-devel qt5-x11extras-devel qt5-multimedia-devel qt5-svg-devel
+makedepends="qt5-devel qt5-x11extras-devel qt5-multimedia-devel qt5-svg-devel pam-devel
  qt5-declarative-devel libXrender-devel libXcomposite-devel libXcursor-devel libXdamage-devel
  xcb-util-devel xcb-util-wm-devel xcb-util-image-devel pulseaudio-devel poppler-qt5-devel"
 depends="fluxbox numlockx xbacklight alsa-utils acpi xscreensaver bsdtar qt5-svg qsudo"
@@ -14,7 +14,7 @@ maintainer="hipperson0 <hipperson0@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/lumina-desktop/lumina"
 distfiles="https://github.com/lumina-desktop/lumina/archive/v${version}.tar.gz"
-checksum=f3512fca4d05e3cf3a6ac106f0f16c9618bda9fa546f1d23ffb0eab9a5ce7c8a
+checksum=2bc649c95da8f997bf943cc1e64af4a61921ddc5d63dd3c46fc0ba8708e29a92
 replaces="lumina-git>=0"
 
 post_install() {

^ permalink raw reply	[flat|nested] 18+ messages in thread

* Re: [PR PATCH] [Updated] lumina: update to 1.6.1.
  2021-11-26 18:57 [PR PATCH] lumina: update to 1.6.1 karlgrose
  2021-11-27 23:57 ` [PR PATCH] [Updated] " karlgrose
  2021-11-28  0:38 ` karlgrose
@ 2021-11-28 17:19 ` karlgrose
  2021-12-04  1:22 ` [PR REVIEW] " ericonr
                   ` (13 subsequent siblings)
  16 siblings, 0 replies; 18+ messages in thread
From: karlgrose @ 2021-11-28 17:19 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1078 bytes --]

There is an updated pull request by karlgrose against master on the void-packages repository

https://github.com/karlgrose/void-packages master
https://github.com/void-linux/void-packages/pull/34262

lumina: update to 1.6.1.
<!-- Uncomment relevant sections and delete options which are not applicable -->

#### Testing the changes
- I tested the changes in this PR: **YES**

<!--
#### New package
- This new package conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements): **YES**|**NO**
-->

<!-- Note: If the build is likely to take more than 2 hours, please [skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration)
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->

#### Local build testing
- I built this PR locally for my native architecture, (x86_64-glibc)


A patch file from https://github.com/void-linux/void-packages/pull/34262.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-master-34262.patch --]
[-- Type: text/x-diff, Size: 3462 bytes --]

From cb2a8667ca55f498ab83d6e154b0fca6452cd340 Mon Sep 17 00:00:00 2001
From: Karl R Grose <karlgrose@gromar.org>
Date: Fri, 26 Nov 2021 10:15:38 -0800
Subject: [PATCH] lumina: update to 1.6.1.

---
 srcpkgs/lumina/patches/checkpass.patch | 19 +++++++++++++++++++
 srcpkgs/lumina/patches/mandir.patch    | 11 -----------
 srcpkgs/lumina/template                |  8 ++++----
 3 files changed, 23 insertions(+), 15 deletions(-)
 create mode 100644 srcpkgs/lumina/patches/checkpass.patch
 delete mode 100644 srcpkgs/lumina/patches/mandir.patch

diff --git a/srcpkgs/lumina/patches/checkpass.patch b/srcpkgs/lumina/patches/checkpass.patch
new file mode 100644
index 000000000000..7534550b0019
--- /dev/null
+++ b/srcpkgs/lumina/patches/checkpass.patch
@@ -0,0 +1,19 @@
+--- a/src-qt5/core/lumina-checkpass/lumina-checkpass.pro
++++ b/src-qt5/core/lumina-checkpass/lumina-checkpass.pro
+@@ -6,13 +6,13 @@ QT =
+ CONFIG += console
+ 
+ TARGET = lumina-checkpass
+-target.path = $$DESTDIR$${PREFIX}/sbin
++target.path = $$DESTDIR$${PREFIX}/bin
+ 
+ LIBS     += -lpam
+ 
+ SOURCES += main.c
+ 
+-perms.path = $$DESTDIR$${PREFIX}/sbin
+-perms.extra = "chmod 4555 $$DESTDIR$${PREFIX}/sbin/lumina-checkpass"
++perms.path = $$DESTDIR$${PREFIX}/bin
++perms.extra = "chmod 4555 $(INSTALL_ROOT)$$DESTDIR$${PREFIX}/bin/lumina-checkpass"
+ 
+ INSTALLS += target perms
diff --git a/srcpkgs/lumina/patches/mandir.patch b/srcpkgs/lumina/patches/mandir.patch
deleted file mode 100644
index 9b9ce50a1e5d..000000000000
--- a/srcpkgs/lumina/patches/mandir.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src-qt5/OS-detect.pri	2017-07-05 20:02:49.727200592 +0200
-+++ b/src-qt5/OS-detect.pri	2017-07-05 20:03:10.463911159 +0200
-@@ -94,7 +94,7 @@
-   isEmpty(L_SHAREDIR){ L_SHAREDIR = $${PREFIX}/share }
-   isEmpty(L_INCLUDEDIR){ L_INCLUDEDIR = $${PREFIX}/include }
-   isEmpty(L_SESSDIR){ L_SESSDIR = $${L_SHAREDIR}/xsessions }
--  isEmpty(L_MANDIR){ L_MANDIR = $${PREFIX}/man }
-+  isEmpty(L_MANDIR){ L_MANDIR = $${PREFIX}/share/man }
-   isEmpty(LRELEASE){ LRELEASE = $$[QT_INSTALL_BINS]/lrelease }
-   isEmpty(MAN_ZIP){ MAN_ZIP = "gzip -c" }
-   !exists(LRELEASE){ NO_I18N=true } #translations unavailable
diff --git a/srcpkgs/lumina/template b/srcpkgs/lumina/template
index ed7ef97adfba..5299c6ae9c54 100644
--- a/srcpkgs/lumina/template
+++ b/srcpkgs/lumina/template
@@ -1,11 +1,11 @@
 # Template file for 'lumina'
 pkgname=lumina
-version=1.6.0
-revision=2
+version=1.6.1
+revision=1
 build_style=qmake
 configure_args="QT5LIBDIR=/usr/lib/qt5 L_ETCDIR=/etc CONFIG+=WITH_I18N"
 hostmakedepends="qt5-host-tools qt5-qmake"
-makedepends="qt5-devel qt5-x11extras-devel qt5-multimedia-devel qt5-svg-devel
+makedepends="qt5-devel qt5-x11extras-devel qt5-multimedia-devel qt5-svg-devel pam-devel
  qt5-declarative-devel libXrender-devel libXcomposite-devel libXcursor-devel libXdamage-devel
  xcb-util-devel xcb-util-wm-devel xcb-util-image-devel pulseaudio-devel poppler-qt5-devel"
 depends="fluxbox numlockx xbacklight alsa-utils acpi xscreensaver bsdtar qt5-svg qsudo"
@@ -14,7 +14,7 @@ maintainer="hipperson0 <hipperson0@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/lumina-desktop/lumina"
 distfiles="https://github.com/lumina-desktop/lumina/archive/v${version}.tar.gz"
-checksum=f3512fca4d05e3cf3a6ac106f0f16c9618bda9fa546f1d23ffb0eab9a5ce7c8a
+checksum=2bc649c95da8f997bf943cc1e64af4a61921ddc5d63dd3c46fc0ba8708e29a92
 replaces="lumina-git>=0"
 
 post_install() {

^ permalink raw reply	[flat|nested] 18+ messages in thread

* Re: [PR REVIEW] lumina: update to 1.6.1.
  2021-11-26 18:57 [PR PATCH] lumina: update to 1.6.1 karlgrose
                   ` (2 preceding siblings ...)
  2021-11-28 17:19 ` karlgrose
@ 2021-12-04  1:22 ` ericonr
  2021-12-04 22:30 ` karlgrose
                   ` (12 subsequent siblings)
  16 siblings, 0 replies; 18+ messages in thread
From: ericonr @ 2021-12-04  1:22 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 215 bytes --]

New review comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/pull/34262#discussion_r762366026

Comment:
Please add an explanation for what the patch does on top of the file

^ permalink raw reply	[flat|nested] 18+ messages in thread

* Re: [PR REVIEW] lumina: update to 1.6.1.
  2021-11-26 18:57 [PR PATCH] lumina: update to 1.6.1 karlgrose
                   ` (3 preceding siblings ...)
  2021-12-04  1:22 ` [PR REVIEW] " ericonr
@ 2021-12-04 22:30 ` karlgrose
  2021-12-04 22:40 ` [PR PATCH] [Updated] " karlgrose
                   ` (11 subsequent siblings)
  16 siblings, 0 replies; 18+ messages in thread
From: karlgrose @ 2021-12-04 22:30 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 645 bytes --]

New review comment by karlgrose on void-packages repository

https://github.com/void-linux/void-packages/pull/34262#discussion_r762473026

Comment:
The lumina-checkpass binary, which I understand is to be disabled in release 1.6.2 according to comments on the project site (https://github.com/lumina-desktop/lumina/issues/774), was set to install to a hardwired "sbin" location, but that generates a conflict with the pkg-src sanity/lint tests. This patch just forces the build to install to a "bin" path resulting in the pkg-src checks being passed. The need for this patch should disappear with 1.6.2 if the 774 issue cited is to be believed.

^ permalink raw reply	[flat|nested] 18+ messages in thread

* Re: [PR PATCH] [Updated] lumina: update to 1.6.1.
  2021-11-26 18:57 [PR PATCH] lumina: update to 1.6.1 karlgrose
                   ` (4 preceding siblings ...)
  2021-12-04 22:30 ` karlgrose
@ 2021-12-04 22:40 ` karlgrose
  2021-12-04 22:42 ` [PR REVIEW] " karlgrose
                   ` (10 subsequent siblings)
  16 siblings, 0 replies; 18+ messages in thread
From: karlgrose @ 2021-12-04 22:40 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1078 bytes --]

There is an updated pull request by karlgrose against master on the void-packages repository

https://github.com/karlgrose/void-packages master
https://github.com/void-linux/void-packages/pull/34262

lumina: update to 1.6.1.
<!-- Uncomment relevant sections and delete options which are not applicable -->

#### Testing the changes
- I tested the changes in this PR: **YES**

<!--
#### New package
- This new package conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements): **YES**|**NO**
-->

<!-- Note: If the build is likely to take more than 2 hours, please [skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration)
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->

#### Local build testing
- I built this PR locally for my native architecture, (x86_64-glibc)


A patch file from https://github.com/void-linux/void-packages/pull/34262.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-master-34262.patch --]
[-- Type: text/x-diff, Size: 4202 bytes --]

From cb2a8667ca55f498ab83d6e154b0fca6452cd340 Mon Sep 17 00:00:00 2001
From: Karl R Grose <karlgrose@gromar.org>
Date: Fri, 26 Nov 2021 10:15:38 -0800
Subject: [PATCH 1/2] lumina: update to 1.6.1.

---
 srcpkgs/lumina/patches/checkpass.patch | 19 +++++++++++++++++++
 srcpkgs/lumina/patches/mandir.patch    | 11 -----------
 srcpkgs/lumina/template                |  8 ++++----
 3 files changed, 23 insertions(+), 15 deletions(-)
 create mode 100644 srcpkgs/lumina/patches/checkpass.patch
 delete mode 100644 srcpkgs/lumina/patches/mandir.patch

diff --git a/srcpkgs/lumina/patches/checkpass.patch b/srcpkgs/lumina/patches/checkpass.patch
new file mode 100644
index 000000000000..7534550b0019
--- /dev/null
+++ b/srcpkgs/lumina/patches/checkpass.patch
@@ -0,0 +1,19 @@
+--- a/src-qt5/core/lumina-checkpass/lumina-checkpass.pro
++++ b/src-qt5/core/lumina-checkpass/lumina-checkpass.pro
+@@ -6,13 +6,13 @@ QT =
+ CONFIG += console
+ 
+ TARGET = lumina-checkpass
+-target.path = $$DESTDIR$${PREFIX}/sbin
++target.path = $$DESTDIR$${PREFIX}/bin
+ 
+ LIBS     += -lpam
+ 
+ SOURCES += main.c
+ 
+-perms.path = $$DESTDIR$${PREFIX}/sbin
+-perms.extra = "chmod 4555 $$DESTDIR$${PREFIX}/sbin/lumina-checkpass"
++perms.path = $$DESTDIR$${PREFIX}/bin
++perms.extra = "chmod 4555 $(INSTALL_ROOT)$$DESTDIR$${PREFIX}/bin/lumina-checkpass"
+ 
+ INSTALLS += target perms
diff --git a/srcpkgs/lumina/patches/mandir.patch b/srcpkgs/lumina/patches/mandir.patch
deleted file mode 100644
index 9b9ce50a1e5d..000000000000
--- a/srcpkgs/lumina/patches/mandir.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src-qt5/OS-detect.pri	2017-07-05 20:02:49.727200592 +0200
-+++ b/src-qt5/OS-detect.pri	2017-07-05 20:03:10.463911159 +0200
-@@ -94,7 +94,7 @@
-   isEmpty(L_SHAREDIR){ L_SHAREDIR = $${PREFIX}/share }
-   isEmpty(L_INCLUDEDIR){ L_INCLUDEDIR = $${PREFIX}/include }
-   isEmpty(L_SESSDIR){ L_SESSDIR = $${L_SHAREDIR}/xsessions }
--  isEmpty(L_MANDIR){ L_MANDIR = $${PREFIX}/man }
-+  isEmpty(L_MANDIR){ L_MANDIR = $${PREFIX}/share/man }
-   isEmpty(LRELEASE){ LRELEASE = $$[QT_INSTALL_BINS]/lrelease }
-   isEmpty(MAN_ZIP){ MAN_ZIP = "gzip -c" }
-   !exists(LRELEASE){ NO_I18N=true } #translations unavailable
diff --git a/srcpkgs/lumina/template b/srcpkgs/lumina/template
index ed7ef97adfba..5299c6ae9c54 100644
--- a/srcpkgs/lumina/template
+++ b/srcpkgs/lumina/template
@@ -1,11 +1,11 @@
 # Template file for 'lumina'
 pkgname=lumina
-version=1.6.0
-revision=2
+version=1.6.1
+revision=1
 build_style=qmake
 configure_args="QT5LIBDIR=/usr/lib/qt5 L_ETCDIR=/etc CONFIG+=WITH_I18N"
 hostmakedepends="qt5-host-tools qt5-qmake"
-makedepends="qt5-devel qt5-x11extras-devel qt5-multimedia-devel qt5-svg-devel
+makedepends="qt5-devel qt5-x11extras-devel qt5-multimedia-devel qt5-svg-devel pam-devel
  qt5-declarative-devel libXrender-devel libXcomposite-devel libXcursor-devel libXdamage-devel
  xcb-util-devel xcb-util-wm-devel xcb-util-image-devel pulseaudio-devel poppler-qt5-devel"
 depends="fluxbox numlockx xbacklight alsa-utils acpi xscreensaver bsdtar qt5-svg qsudo"
@@ -14,7 +14,7 @@ maintainer="hipperson0 <hipperson0@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/lumina-desktop/lumina"
 distfiles="https://github.com/lumina-desktop/lumina/archive/v${version}.tar.gz"
-checksum=f3512fca4d05e3cf3a6ac106f0f16c9618bda9fa546f1d23ffb0eab9a5ce7c8a
+checksum=2bc649c95da8f997bf943cc1e64af4a61921ddc5d63dd3c46fc0ba8708e29a92
 replaces="lumina-git>=0"
 
 post_install() {

From 15d8444dcba577b94557dd7186046de8ef6e553e Mon Sep 17 00:00:00 2001
From: Karl Grose <karlgrose@gromar.org>
Date: Sat, 4 Dec 2021 16:40:24 -0600
Subject: [PATCH 2/2] add comment about patch purpose

---
 srcpkgs/lumina/patches/checkpass.patch | 1 +
 1 file changed, 1 insertion(+)

diff --git a/srcpkgs/lumina/patches/checkpass.patch b/srcpkgs/lumina/patches/checkpass.patch
index 7534550b0019..cb1f3c19e7ba 100644
--- a/srcpkgs/lumina/patches/checkpass.patch
+++ b/srcpkgs/lumina/patches/checkpass.patch
@@ -1,3 +1,4 @@
+Force the "bin" path to avoid conflicts with Void pkg-src lint checks
 --- a/src-qt5/core/lumina-checkpass/lumina-checkpass.pro
 +++ b/src-qt5/core/lumina-checkpass/lumina-checkpass.pro
 @@ -6,13 +6,13 @@ QT =

^ permalink raw reply	[flat|nested] 18+ messages in thread

* Re: [PR REVIEW] lumina: update to 1.6.1.
  2021-11-26 18:57 [PR PATCH] lumina: update to 1.6.1 karlgrose
                   ` (5 preceding siblings ...)
  2021-12-04 22:40 ` [PR PATCH] [Updated] " karlgrose
@ 2021-12-04 22:42 ` karlgrose
  2021-12-05  2:08 ` [PR PATCH] [Updated] " karlgrose
                   ` (9 subsequent siblings)
  16 siblings, 0 replies; 18+ messages in thread
From: karlgrose @ 2021-12-04 22:42 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 181 bytes --]

New review comment by karlgrose on void-packages repository

https://github.com/void-linux/void-packages/pull/34262#discussion_r762473964

Comment:
patch updated with brief comment

^ permalink raw reply	[flat|nested] 18+ messages in thread

* Re: [PR PATCH] [Updated] lumina: update to 1.6.1.
  2021-11-26 18:57 [PR PATCH] lumina: update to 1.6.1 karlgrose
                   ` (6 preceding siblings ...)
  2021-12-04 22:42 ` [PR REVIEW] " karlgrose
@ 2021-12-05  2:08 ` karlgrose
  2021-12-05  2:43 ` ericonr
                   ` (8 subsequent siblings)
  16 siblings, 0 replies; 18+ messages in thread
From: karlgrose @ 2021-12-05  2:08 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1078 bytes --]

There is an updated pull request by karlgrose against master on the void-packages repository

https://github.com/karlgrose/void-packages master
https://github.com/void-linux/void-packages/pull/34262

lumina: update to 1.6.1.
<!-- Uncomment relevant sections and delete options which are not applicable -->

#### Testing the changes
- I tested the changes in this PR: **YES**

<!--
#### New package
- This new package conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements): **YES**|**NO**
-->

<!-- Note: If the build is likely to take more than 2 hours, please [skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration)
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->

#### Local build testing
- I built this PR locally for my native architecture, (x86_64-glibc)


A patch file from https://github.com/void-linux/void-packages/pull/34262.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-master-34262.patch --]
[-- Type: text/x-diff, Size: 5005 bytes --]

From 55e2633d354c2567d526a627efa4396e415b2db4 Mon Sep 17 00:00:00 2001
From: Karl R Grose <karlgrose@gromar.org>
Date: Fri, 26 Nov 2021 10:15:38 -0800
Subject: [PATCH 1/3] lumina: update to 1.6.1.

---
 srcpkgs/lumina/patches/checkpass.patch | 19 +++++++++++++++++++
 srcpkgs/lumina/patches/mandir.patch    | 11 -----------
 srcpkgs/lumina/template                |  8 ++++----
 3 files changed, 23 insertions(+), 15 deletions(-)
 create mode 100644 srcpkgs/lumina/patches/checkpass.patch
 delete mode 100644 srcpkgs/lumina/patches/mandir.patch

diff --git a/srcpkgs/lumina/patches/checkpass.patch b/srcpkgs/lumina/patches/checkpass.patch
new file mode 100644
index 000000000000..7534550b0019
--- /dev/null
+++ b/srcpkgs/lumina/patches/checkpass.patch
@@ -0,0 +1,19 @@
+--- a/src-qt5/core/lumina-checkpass/lumina-checkpass.pro
++++ b/src-qt5/core/lumina-checkpass/lumina-checkpass.pro
+@@ -6,13 +6,13 @@ QT =
+ CONFIG += console
+ 
+ TARGET = lumina-checkpass
+-target.path = $$DESTDIR$${PREFIX}/sbin
++target.path = $$DESTDIR$${PREFIX}/bin
+ 
+ LIBS     += -lpam
+ 
+ SOURCES += main.c
+ 
+-perms.path = $$DESTDIR$${PREFIX}/sbin
+-perms.extra = "chmod 4555 $$DESTDIR$${PREFIX}/sbin/lumina-checkpass"
++perms.path = $$DESTDIR$${PREFIX}/bin
++perms.extra = "chmod 4555 $(INSTALL_ROOT)$$DESTDIR$${PREFIX}/bin/lumina-checkpass"
+ 
+ INSTALLS += target perms
diff --git a/srcpkgs/lumina/patches/mandir.patch b/srcpkgs/lumina/patches/mandir.patch
deleted file mode 100644
index 9b9ce50a1e5d..000000000000
--- a/srcpkgs/lumina/patches/mandir.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src-qt5/OS-detect.pri	2017-07-05 20:02:49.727200592 +0200
-+++ b/src-qt5/OS-detect.pri	2017-07-05 20:03:10.463911159 +0200
-@@ -94,7 +94,7 @@
-   isEmpty(L_SHAREDIR){ L_SHAREDIR = $${PREFIX}/share }
-   isEmpty(L_INCLUDEDIR){ L_INCLUDEDIR = $${PREFIX}/include }
-   isEmpty(L_SESSDIR){ L_SESSDIR = $${L_SHAREDIR}/xsessions }
--  isEmpty(L_MANDIR){ L_MANDIR = $${PREFIX}/man }
-+  isEmpty(L_MANDIR){ L_MANDIR = $${PREFIX}/share/man }
-   isEmpty(LRELEASE){ LRELEASE = $$[QT_INSTALL_BINS]/lrelease }
-   isEmpty(MAN_ZIP){ MAN_ZIP = "gzip -c" }
-   !exists(LRELEASE){ NO_I18N=true } #translations unavailable
diff --git a/srcpkgs/lumina/template b/srcpkgs/lumina/template
index ed7ef97adfba..5299c6ae9c54 100644
--- a/srcpkgs/lumina/template
+++ b/srcpkgs/lumina/template
@@ -1,11 +1,11 @@
 # Template file for 'lumina'
 pkgname=lumina
-version=1.6.0
-revision=2
+version=1.6.1
+revision=1
 build_style=qmake
 configure_args="QT5LIBDIR=/usr/lib/qt5 L_ETCDIR=/etc CONFIG+=WITH_I18N"
 hostmakedepends="qt5-host-tools qt5-qmake"
-makedepends="qt5-devel qt5-x11extras-devel qt5-multimedia-devel qt5-svg-devel
+makedepends="qt5-devel qt5-x11extras-devel qt5-multimedia-devel qt5-svg-devel pam-devel
  qt5-declarative-devel libXrender-devel libXcomposite-devel libXcursor-devel libXdamage-devel
  xcb-util-devel xcb-util-wm-devel xcb-util-image-devel pulseaudio-devel poppler-qt5-devel"
 depends="fluxbox numlockx xbacklight alsa-utils acpi xscreensaver bsdtar qt5-svg qsudo"
@@ -14,7 +14,7 @@ maintainer="hipperson0 <hipperson0@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/lumina-desktop/lumina"
 distfiles="https://github.com/lumina-desktop/lumina/archive/v${version}.tar.gz"
-checksum=f3512fca4d05e3cf3a6ac106f0f16c9618bda9fa546f1d23ffb0eab9a5ce7c8a
+checksum=2bc649c95da8f997bf943cc1e64af4a61921ddc5d63dd3c46fc0ba8708e29a92
 replaces="lumina-git>=0"
 
 post_install() {

From 62bfbe6e24a5bad8edc776d6758050b560d8cebc Mon Sep 17 00:00:00 2001
From: Karl Grose <karlgrose@gromar.org>
Date: Sat, 4 Dec 2021 16:36:16 -0600
Subject: [PATCH 2/3] add comment about patch purpose

---
 srcpkgs/lumina/patches/checkpass.patch | 1 +
 1 file changed, 1 insertion(+)

diff --git a/srcpkgs/lumina/patches/checkpass.patch b/srcpkgs/lumina/patches/checkpass.patch
index 7534550b0019..cb1f3c19e7ba 100644
--- a/srcpkgs/lumina/patches/checkpass.patch
+++ b/srcpkgs/lumina/patches/checkpass.patch
@@ -1,3 +1,4 @@
+Force the "bin" path to avoid conflicts with Void pkg-src lint checks
 --- a/src-qt5/core/lumina-checkpass/lumina-checkpass.pro
 +++ b/src-qt5/core/lumina-checkpass/lumina-checkpass.pro
 @@ -6,13 +6,13 @@ QT =

From 060dc47c194a511f10740a38d0a3a7ce1b94ec8f Mon Sep 17 00:00:00 2001
From: Karl R Grose <karlgrose@gromar.org>
Date: Sat, 4 Dec 2021 19:52:57 -0600
Subject: [PATCH 3/3] fix typo

---
 srcpkgs/lumina/patches/checkpass.patch | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/lumina/patches/checkpass.patch b/srcpkgs/lumina/patches/checkpass.patch
index cb1f3c19e7ba..a31d0fa8bb17 100644
--- a/srcpkgs/lumina/patches/checkpass.patch
+++ b/srcpkgs/lumina/patches/checkpass.patch
@@ -1,4 +1,4 @@
-Force the "bin" path to avoid conflicts with Void pkg-src lint checks
+Force the "bin" path to avoid conflicts with Void xbps-src lint checks
 --- a/src-qt5/core/lumina-checkpass/lumina-checkpass.pro
 +++ b/src-qt5/core/lumina-checkpass/lumina-checkpass.pro
 @@ -6,13 +6,13 @@ QT =

^ permalink raw reply	[flat|nested] 18+ messages in thread

* Re: lumina: update to 1.6.1.
  2021-11-26 18:57 [PR PATCH] lumina: update to 1.6.1 karlgrose
                   ` (7 preceding siblings ...)
  2021-12-05  2:08 ` [PR PATCH] [Updated] " karlgrose
@ 2021-12-05  2:43 ` ericonr
  2021-12-05  4:56 ` [PR PATCH] [Updated] " karlgrose
                   ` (7 subsequent siblings)
  16 siblings, 0 replies; 18+ messages in thread
From: ericonr @ 2021-12-05  2:43 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 183 bytes --]

New comment by ericonr on void-packages repository

https://github.com/void-linux/void-packages/pull/34262#issuecomment-986155667

Comment:
Please remember to squash commits as well.

^ permalink raw reply	[flat|nested] 18+ messages in thread

* Re: [PR PATCH] [Updated] lumina: update to 1.6.1.
  2021-11-26 18:57 [PR PATCH] lumina: update to 1.6.1 karlgrose
                   ` (8 preceding siblings ...)
  2021-12-05  2:43 ` ericonr
@ 2021-12-05  4:56 ` karlgrose
  2021-12-05  5:08 ` karlgrose
                   ` (6 subsequent siblings)
  16 siblings, 0 replies; 18+ messages in thread
From: karlgrose @ 2021-12-05  4:56 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1078 bytes --]

There is an updated pull request by karlgrose against master on the void-packages repository

https://github.com/karlgrose/void-packages master
https://github.com/void-linux/void-packages/pull/34262

lumina: update to 1.6.1.
<!-- Uncomment relevant sections and delete options which are not applicable -->

#### Testing the changes
- I tested the changes in this PR: **YES**

<!--
#### New package
- This new package conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements): **YES**|**NO**
-->

<!-- Note: If the build is likely to take more than 2 hours, please [skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration)
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->

#### Local build testing
- I built this PR locally for my native architecture, (x86_64-glibc)


A patch file from https://github.com/void-linux/void-packages/pull/34262.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-master-34262.patch --]
[-- Type: text/x-diff, Size: 229362 bytes --]

From cb2a8667ca55f498ab83d6e154b0fca6452cd340 Mon Sep 17 00:00:00 2001
From: Karl R Grose <karlgrose@gromar.org>
Date: Fri, 26 Nov 2021 10:15:38 -0800
Subject: [PATCH 001/143] lumina: update to 1.6.1.

---
 srcpkgs/lumina/patches/checkpass.patch | 19 +++++++++++++++++++
 srcpkgs/lumina/patches/mandir.patch    | 11 -----------
 srcpkgs/lumina/template                |  8 ++++----
 3 files changed, 23 insertions(+), 15 deletions(-)
 create mode 100644 srcpkgs/lumina/patches/checkpass.patch
 delete mode 100644 srcpkgs/lumina/patches/mandir.patch

diff --git a/srcpkgs/lumina/patches/checkpass.patch b/srcpkgs/lumina/patches/checkpass.patch
new file mode 100644
index 000000000000..7534550b0019
--- /dev/null
+++ b/srcpkgs/lumina/patches/checkpass.patch
@@ -0,0 +1,19 @@
+--- a/src-qt5/core/lumina-checkpass/lumina-checkpass.pro
++++ b/src-qt5/core/lumina-checkpass/lumina-checkpass.pro
+@@ -6,13 +6,13 @@ QT =
+ CONFIG += console
+ 
+ TARGET = lumina-checkpass
+-target.path = $$DESTDIR$${PREFIX}/sbin
++target.path = $$DESTDIR$${PREFIX}/bin
+ 
+ LIBS     += -lpam
+ 
+ SOURCES += main.c
+ 
+-perms.path = $$DESTDIR$${PREFIX}/sbin
+-perms.extra = "chmod 4555 $$DESTDIR$${PREFIX}/sbin/lumina-checkpass"
++perms.path = $$DESTDIR$${PREFIX}/bin
++perms.extra = "chmod 4555 $(INSTALL_ROOT)$$DESTDIR$${PREFIX}/bin/lumina-checkpass"
+ 
+ INSTALLS += target perms
diff --git a/srcpkgs/lumina/patches/mandir.patch b/srcpkgs/lumina/patches/mandir.patch
deleted file mode 100644
index 9b9ce50a1e5d..000000000000
--- a/srcpkgs/lumina/patches/mandir.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src-qt5/OS-detect.pri	2017-07-05 20:02:49.727200592 +0200
-+++ b/src-qt5/OS-detect.pri	2017-07-05 20:03:10.463911159 +0200
-@@ -94,7 +94,7 @@
-   isEmpty(L_SHAREDIR){ L_SHAREDIR = $${PREFIX}/share }
-   isEmpty(L_INCLUDEDIR){ L_INCLUDEDIR = $${PREFIX}/include }
-   isEmpty(L_SESSDIR){ L_SESSDIR = $${L_SHAREDIR}/xsessions }
--  isEmpty(L_MANDIR){ L_MANDIR = $${PREFIX}/man }
-+  isEmpty(L_MANDIR){ L_MANDIR = $${PREFIX}/share/man }
-   isEmpty(LRELEASE){ LRELEASE = $$[QT_INSTALL_BINS]/lrelease }
-   isEmpty(MAN_ZIP){ MAN_ZIP = "gzip -c" }
-   !exists(LRELEASE){ NO_I18N=true } #translations unavailable
diff --git a/srcpkgs/lumina/template b/srcpkgs/lumina/template
index ed7ef97adfba..5299c6ae9c54 100644
--- a/srcpkgs/lumina/template
+++ b/srcpkgs/lumina/template
@@ -1,11 +1,11 @@
 # Template file for 'lumina'
 pkgname=lumina
-version=1.6.0
-revision=2
+version=1.6.1
+revision=1
 build_style=qmake
 configure_args="QT5LIBDIR=/usr/lib/qt5 L_ETCDIR=/etc CONFIG+=WITH_I18N"
 hostmakedepends="qt5-host-tools qt5-qmake"
-makedepends="qt5-devel qt5-x11extras-devel qt5-multimedia-devel qt5-svg-devel
+makedepends="qt5-devel qt5-x11extras-devel qt5-multimedia-devel qt5-svg-devel pam-devel
  qt5-declarative-devel libXrender-devel libXcomposite-devel libXcursor-devel libXdamage-devel
  xcb-util-devel xcb-util-wm-devel xcb-util-image-devel pulseaudio-devel poppler-qt5-devel"
 depends="fluxbox numlockx xbacklight alsa-utils acpi xscreensaver bsdtar qt5-svg qsudo"
@@ -14,7 +14,7 @@ maintainer="hipperson0 <hipperson0@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/lumina-desktop/lumina"
 distfiles="https://github.com/lumina-desktop/lumina/archive/v${version}.tar.gz"
-checksum=f3512fca4d05e3cf3a6ac106f0f16c9618bda9fa546f1d23ffb0eab9a5ce7c8a
+checksum=2bc649c95da8f997bf943cc1e64af4a61921ddc5d63dd3c46fc0ba8708e29a92
 replaces="lumina-git>=0"
 
 post_install() {

From 6febece4b24b3460895b826403fa6b1d0bb39e51 Mon Sep 17 00:00:00 2001
From: Andrew Benson <abenson+void@gmail.com>
Date: Sun, 28 Nov 2021 11:16:36 -0600
Subject: [PATCH 002/143] Amass: update to 3.15.1.

---
 srcpkgs/Amass/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/Amass/template b/srcpkgs/Amass/template
index 71ee291c99e6..f78e2f70cf12 100644
--- a/srcpkgs/Amass/template
+++ b/srcpkgs/Amass/template
@@ -1,6 +1,6 @@
 # Template file for 'Amass'
 pkgname=Amass
-version=3.15.0
+version=3.15.1
 revision=1
 build_style=go
 go_import_path="github.com/OWASP/Amass/v3/..."
@@ -9,7 +9,7 @@ maintainer="Andrew Benson <abenson+void@gmail.com>"
 license="Apache-2.0"
 homepage="https://www.owasp.org/index.php/OWASP_Amass_Project"
 distfiles="https://github.com/OWASP/Amass/archive/v${version}.tar.gz"
-checksum=084ddbc8171e354abee3098458064fbcc9db059a25c4845dfc151803833df2dd
+checksum=217f5f0fed02d730543a56b58f1be3ec0fb07e57b3ace53fc673c6d0132f36a8
 
 post_install() {
 	rm ${DESTDIR}/usr/bin/examples

From 9483da0fe85267ad4ae6c0f8f5ac9c4e78c6af8d Mon Sep 17 00:00:00 2001
From: Andrew Benson <abenson+void@gmail.com>
Date: Sun, 28 Nov 2021 11:19:21 -0600
Subject: [PATCH 003/143] python3-httpx: update to 0.21.1.

---
 srcpkgs/python3-httpx/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-httpx/template b/srcpkgs/python3-httpx/template
index 5c99c9208213..55f843ed478c 100644
--- a/srcpkgs/python3-httpx/template
+++ b/srcpkgs/python3-httpx/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-httpx'
 pkgname=python3-httpx
-version=0.21.0
+version=0.21.1
 revision=1
 wrksrc="httpx-${version}"
 build_style=python3-module
@@ -14,7 +14,7 @@ license="BSD-3-Clause"
 homepage="https://www.python-httpx.org"
 changelog="https://raw.githubusercontent.com/encode/httpx/master/CHANGELOG.md"
 distfiles="${PYPI_SITE}/h/httpx/httpx-${version}.tar.gz"
-checksum=5ae1d9deb30fe074596551b3ab98f94dfd9d7efe3ecd2d08662a5c29f6fba0e4
+checksum=02af20df486b78892a614a7ccd4e4e86a5409ec4981ab0e422c579a887acad83
 # the pypi tarball doesn't contain tests
 # the tests need unpackaged dependencies trustme and uvicorn
 make_check=no

From 5a86c52881e0ce41adb3b5d8a2e88102fe07daba Mon Sep 17 00:00:00 2001
From: Andrew Benson <abenson+void@gmail.com>
Date: Sun, 28 Nov 2021 11:19:24 -0600
Subject: [PATCH 004/143] python3-youtubesearch: update to 1.5.2.

---
 srcpkgs/python3-youtubesearch/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-youtubesearch/template b/srcpkgs/python3-youtubesearch/template
index c284178a44a8..8319d620097d 100644
--- a/srcpkgs/python3-youtubesearch/template
+++ b/srcpkgs/python3-youtubesearch/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-youtubesearch'
 pkgname=python3-youtubesearch
-version=1.5.1
+version=1.5.2
 revision=1
 wrksrc="youtube-search-python-${version}"
 build_style=python3-module
@@ -11,7 +11,7 @@ maintainer="Andrew Benson <abenson+void@gmail.com>"
 license="MIT"
 homepage="https://github.com/alexmercerind/youtube-search-python"
 distfiles="${homepage}/archive/refs/tags/v${version}.tar.gz"
-checksum=485825a741ef5e7c327eaf65b27f7ffd7d10e218072a972012ff3301c2d7c488
+checksum=6094c819b195de0ef7363e76594b5c34479438a45e72c1e9f763cd9cf17a64ea
 make_check=no # no tests defined
 
 post_install() {

From 0283d5c8b27895fd16651c9cfe8d90e90c508d65 Mon Sep 17 00:00:00 2001
From: Andrew Benson <abenson+void@gmail.com>
Date: Sun, 28 Nov 2021 11:23:29 -0600
Subject: [PATCH 005/143] mongo-c-driver: update to 1.20.0.

---
 srcpkgs/mongo-c-driver/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/mongo-c-driver/template b/srcpkgs/mongo-c-driver/template
index ee79f2e3d329..b3eec27c4bab 100644
--- a/srcpkgs/mongo-c-driver/template
+++ b/srcpkgs/mongo-c-driver/template
@@ -1,6 +1,6 @@
 # Template file for 'mongo-c-driver'
 pkgname=mongo-c-driver
-version=1.19.2
+version=1.20.0
 revision=1
 build_style=cmake
 configure_args="-DENABLE_TESTS=OFF"
@@ -11,7 +11,7 @@ maintainer="Andrew Benson <abenson+void@gmail.com>"
 license="Apache-2.0"
 homepage="https://mongoc.org"
 distfiles="https://github.com/mongodb/mongo-c-driver/releases/download/${version}/mongo-c-driver-${version}.tar.gz"
-checksum=b6feb4fd65423140cdee02df392cd9db2bb459731e992a5385afa554a7515762
+checksum=a97242866212bdcf9dfb8030b31a32eef9ff83082b34e1027339c805a3c50b0d
 
 mongo-c-driver-devel_package() {
 	short_desc+=" - development files"

From 5bf69adabf8821333839571649bc165f9e9e45c9 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Sat, 27 Nov 2021 14:45:12 +0100
Subject: [PATCH 006/143] libuninameslist: update to 20211114.

---
 srcpkgs/libuninameslist/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/libuninameslist/template b/srcpkgs/libuninameslist/template
index a7e509d4b0b5..8b97662a4a31 100644
--- a/srcpkgs/libuninameslist/template
+++ b/srcpkgs/libuninameslist/template
@@ -1,6 +1,6 @@
 # Template file for 'libuninameslist'
 pkgname=libuninameslist
-version=20210917
+version=20211114
 revision=1
 build_style=gnu-configure
 hostmakedepends="automake libtool"
@@ -9,7 +9,7 @@ maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="BSD-3-Clause"
 homepage="https://github.com/fontforge/libuninameslist"
 distfiles="https://github.com/fontforge/libuninameslist/archive/${version}.tar.gz"
-checksum=7d60ea37813590c9d319d53aaac831fedf8067c980167877bc5daa351b378031
+checksum=c089c6164f2cef361c3419a07408be72d6b58d6ef224ec226724a9fa93c0d46e
 
 pre_configure() {
 	autoreconf -fi

From 60ee21e9dbb2e5044f6638ee6411c2b82c0e8686 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Sat, 27 Nov 2021 14:47:22 +0100
Subject: [PATCH 007/143] libtls: update to 3.4.2.

---
 srcpkgs/libtls/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/libtls/template b/srcpkgs/libtls/template
index 3a0922788b7e..42f33db208a6 100644
--- a/srcpkgs/libtls/template
+++ b/srcpkgs/libtls/template
@@ -1,6 +1,6 @@
 # Template file for 'libtls'
 pkgname=libtls
-version=3.4.1
+version=3.4.2
 revision=1
 wrksrc="libressl-${version}"
 build_style=gnu-configure
@@ -13,7 +13,7 @@ license="OpenSSL, ISC"
 homepage="http://www.libressl.org/"
 changelog="https://raw.githubusercontent.com/libressl-portable/portable/master/ChangeLog"
 distfiles="http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-${version}.tar.gz"
-checksum=107ceae6ca800e81cb563584c16afa36d6c7138fade94a2b3e9da65456f7c61c
+checksum=cb82ca7d547336917352fbd23db2fc483c6c44d35157b32780214ec74197b3ce
 _lssl_asm_ver="1.2.0"
 replaces="libtls20>0"
 

From 3076ca4fc7ccba59e9f97e434bf100b1b3f2f76d Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Sat, 27 Nov 2021 15:04:23 +0100
Subject: [PATCH 008/143] crash: update to 8.0.0.

---
 srcpkgs/crash/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/crash/template b/srcpkgs/crash/template
index 72a0cdd6c36a..82d9a3968c11 100644
--- a/srcpkgs/crash/template
+++ b/srcpkgs/crash/template
@@ -1,10 +1,10 @@
 # Template file for 'crash'
 pkgname=crash
-version=7.3.0
-revision=2
+version=8.0.0
+revision=1
 archs="i686 x86_64"  # broken on musl
 build_style=gnu-makefile
-hostmakedepends="flex tar wget"
+hostmakedepends="flex tar wget texinfo"
 makedepends="lzo-devel ncurses-devel zlib-devel"
 depends="binutils"
 short_desc="Kernel crash dump debugger and live inspector"
@@ -13,7 +13,7 @@ license="GPL-3.0-or-later"
 homepage="https://crash-utility.github.io/"
 changelog="https://crash-utility.github.io/crash.changelog.html"
 distfiles="https://github.com/crash-utility/crash/archive/${version}.tar.gz"
-checksum=98d4367ae0ea7d2eda547357a839f7bddee517b588b281574d58a15a418af5b9
+checksum=caab49b7b6d442f60c41360e0ec80cf852dc64e89303b41d704d7661cef43e68
 nocross=yes
 LDFLAGS=-llzo2
 

From 030428b3cb8e0321b9bb1c25f20861a2e79b962f Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Sat, 27 Nov 2021 15:04:29 +0100
Subject: [PATCH 009/143] python3-pipenv: update to 2021.11.23.

---
 srcpkgs/python3-pipenv/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-pipenv/template b/srcpkgs/python3-pipenv/template
index 01863718c2fd..1a8b586387f8 100644
--- a/srcpkgs/python3-pipenv/template
+++ b/srcpkgs/python3-pipenv/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-pipenv'
 pkgname=python3-pipenv
-version=2021.11.15
+version=2021.11.23
 revision=1
 wrksrc="pipenv-${version}"
 build_style=python3-module
@@ -11,7 +11,7 @@ maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="MIT"
 homepage="https://github.com/pypa/pipenv"
 distfiles="${PYPI_SITE}/p/pipenv/pipenv-${version}.tar.gz"
-checksum=616766b1e8dfc24b2e7c6dfbbc8276b7d7ba07e778e5eb0f1b6e59fcd4532fd1
+checksum=1bde859e8bbd1d21d503fd995bc0170048d6da7686ab885f074592c99a16e8f3
 conflicts="python-pipenv>=0"
 
 post_extract() {

From a832fda9e464c08c7c3532a47080da69bc7a84a4 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Sun, 28 Nov 2021 19:50:36 +0100
Subject: [PATCH 010/143] erlang: update to 24.1.7.

---
 srcpkgs/erlang/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/erlang/template b/srcpkgs/erlang/template
index cd7340ad4bcb..c51edbde3e10 100644
--- a/srcpkgs/erlang/template
+++ b/srcpkgs/erlang/template
@@ -1,6 +1,6 @@
 # Template file for 'erlang'
 pkgname=erlang
-version=24.1.6
+version=24.1.7
 revision=1
 create_wrksrc=yes
 build_wrksrc="otp-OTP-${version}"
@@ -14,7 +14,7 @@ license="Apache-2.0"
 homepage="http://www.erlang.org/"
 changelog="https://github.com/erlang/otp/releases"
 distfiles="https://github.com/erlang/otp/archive/OTP-${version}.tar.gz"
-checksum=1b0db74f01f0072299347b794b51d170bf1b71a8f9b6c0aac404ed2c440611ad
+checksum=a1dd1a238f1f3e79784b902f3cd00e06f35a630191eaf73324a07a26a2c93af3
 subpackages="erlang-doc"
 
 if [ -z "$CROSS_BUILD" ]; then

From 7b070452dd3fb6a401b58250bf6c216b41b060d9 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sun, 28 Nov 2021 14:30:45 -0500
Subject: [PATCH 011/143] python3-aiofiles: update to 0.8.0.

---
 srcpkgs/python3-aiofiles/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-aiofiles/template b/srcpkgs/python3-aiofiles/template
index 95660af980b3..d4c6a5445630 100644
--- a/srcpkgs/python3-aiofiles/template
+++ b/srcpkgs/python3-aiofiles/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-aiofiles'
 pkgname=python3-aiofiles
-version=0.7.0
-revision=2
+version=0.8.0
+revision=1
 wrksrc="${pkgname#*-}-${version}"
 build_style=python3-pep517
 hostmakedepends="python3-poetry-core"
@@ -13,7 +13,7 @@ license="Apache-2.0"
 homepage="https://github.com/Tinche/aiofiles"
 changelog="https://raw.githubusercontent.com/Tinche/aiofiles/master/README.rst"
 distfiles="${homepage}/archive/v${version}.tar.gz"
-checksum=2baf8e70f95618214c4910730fd625bfaa4a8b8957838b34364b0a2c7d41db9e
+checksum=1ee866ce57b47e2f5ae2c06c0372458a6eb08131a9b1d7216a234fa0d516d638
 
 do_check() {
 	PYTHONPATH=src python3 -m pytest

From f7954fa991d53e5fd8f86fcd0b52ced07206c577 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sun, 28 Nov 2021 14:37:14 -0500
Subject: [PATCH 012/143] python3-hypothesis: update to 6.28.0.

---
 srcpkgs/python3-hypothesis/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-hypothesis/template b/srcpkgs/python3-hypothesis/template
index 0c4993679d88..460af8b6cc06 100644
--- a/srcpkgs/python3-hypothesis/template
+++ b/srcpkgs/python3-hypothesis/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-hypothesis'
 pkgname=python3-hypothesis
-version=6.27.0
+version=6.28.0
 revision=1
 wrksrc="hypothesis-hypothesis-python-${version}"
 build_wrksrc=hypothesis-python
@@ -15,7 +15,7 @@ license="MPL-2.0"
 homepage="https://hypothesis.works/"
 changelog="https://hypothesis.readthedocs.io/en/latest/changes.html"
 distfiles="https://github.com/HypothesisWorks/hypothesis/archive/hypothesis-python-${version}.tar.gz"
-checksum=91912314804c37a0be3e830426d44341cbf4a751ad92e5bfdad35e434ffffd4a
+checksum=34a4e30f9a0a88bb48c2faf6d78512fb7978e03e152026e00210245b20356d70
 
 do_check() {
 	# Manually run the tests that tox considers part of the "full" suite,

From b66a57aad7eb0350fcd0039e7e36823b55945979 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sun, 28 Nov 2021 14:37:55 -0500
Subject: [PATCH 013/143] python3-prompt_toolkit: update to 3.0.23.

---
 srcpkgs/python3-prompt_toolkit/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-prompt_toolkit/template b/srcpkgs/python3-prompt_toolkit/template
index f7dbc0c33666..ca30e275d05f 100644
--- a/srcpkgs/python3-prompt_toolkit/template
+++ b/srcpkgs/python3-prompt_toolkit/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-prompt_toolkit'
 pkgname=python3-prompt_toolkit
-version=3.0.22
+version=3.0.23
 revision=1
 wrksrc="prompt_toolkit-${version}"
 build_style=python3-module
@@ -13,7 +13,7 @@ license="BSD-3-Clause"
 homepage="https://github.com/prompt-toolkit/python-prompt-toolkit"
 changelog="https://raw.githubusercontent.com/prompt-toolkit/python-prompt-toolkit/master/CHANGELOG"
 distfiles="${PYPI_SITE}/p/prompt_toolkit/prompt_toolkit-${version}.tar.gz"
-checksum=449f333dd120bd01f5d296a8ce1452114ba3a71fae7288d2f0ae2c918764fa72
+checksum=7053aba00895473cb357819358ef33f11aa97e4ac83d38efb123e5649ceeecaf
 conflicts="python3-prompt_toolkit2<=2.0.9_4"
 
 post_install() {

From ee34e3c85556556b82ed29215e563c69ee812107 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sun, 28 Nov 2021 14:39:32 -0500
Subject: [PATCH 014/143] python3-ipython: update to 7.30.0.

---
 srcpkgs/python3-ipython/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-ipython/template b/srcpkgs/python3-ipython/template
index c2a1120bcac4..85a1ae2e64c5 100644
--- a/srcpkgs/python3-ipython/template
+++ b/srcpkgs/python3-ipython/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-ipython'
 pkgname=python3-ipython
-version=7.29.0
+version=7.30.0
 revision=1
 wrksrc="ipython-${version}"
 build_style=python3-module
@@ -16,7 +16,7 @@ maintainer="Andrew J. Hesford <ajh@sideband.org>"
 license="BSD-3-Clause"
 homepage="https://ipython.org/"
 distfiles="${PYPI_SITE}/i/ipython/ipython-${version}.tar.gz"
-checksum=4f69d7423a5a1972f6347ff233e38bbf4df6a150ef20fbb00c635442ac3060aa
+checksum=d41f8e80b99690122400f9b2069b12f670246a1b4cc5d332bd6c4e2500e6d6fb
 conflicts="python-ipython<=5.8.0_2"
 
 do_check() {

From 54c944b83db42243c9e688eba21f3f4c705f44cd Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sun, 28 Nov 2021 14:39:38 -0500
Subject: [PATCH 015/143] zfs-prune-snapshots: update to 1.3.0.

---
 srcpkgs/zfs-prune-snapshots/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/zfs-prune-snapshots/template b/srcpkgs/zfs-prune-snapshots/template
index 08f538004b9e..63cf6ba63a3f 100644
--- a/srcpkgs/zfs-prune-snapshots/template
+++ b/srcpkgs/zfs-prune-snapshots/template
@@ -1,7 +1,7 @@
 # Template file for 'zfs-prune-snapshots'
 pkgname=zfs-prune-snapshots
-version=1.1.0
-revision=3
+version=1.3.0
+revision=1
 build_style=gnu-makefile
 depends="bash zfs"
 checkdepends="shellcheck"
@@ -10,7 +10,7 @@ maintainer="Andrew J. Hesford <ajh@sideband.org>"
 license="MIT"
 homepage="https://github.com/bahamas10/zfs-prune-snapshots"
 distfiles="${homepage}/archive/v${version}.tar.gz"
-checksum=a9f2fb3c5230111db7622f70318219a37aa8d6bd3d7f894fee54e1ec00cdff2f
+checksum=aacd3683f2bf615286f6c0b154162df11e29783897127a55e1fe73c6a342979f
 
 post_install() {
 	vlicense LICENSE

From 5b1909c13a188da2adf8776ef4911298531a4da6 Mon Sep 17 00:00:00 2001
From: glaulher <glaulher.developer@gmail.com>
Date: Sun, 28 Nov 2021 15:15:17 -0300
Subject: [PATCH 016/143] icewm: update to 2.9.0.

---
 srcpkgs/icewm/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/icewm/template b/srcpkgs/icewm/template
index e9ba69605326..118071556e15 100644
--- a/srcpkgs/icewm/template
+++ b/srcpkgs/icewm/template
@@ -1,6 +1,6 @@
 # Template file for 'icewm'
 pkgname=icewm
-version=2.8.0
+version=2.9.0
 revision=1
 build_style=cmake
 make_cmd=make
@@ -17,7 +17,7 @@ maintainer="Glaulher <glaulher.developer@gmail.com>"
 license="GPL-2.0-or-later"
 homepage="https://ice-wm.org/"
 distfiles="https://github.com/ice-wm/icewm/archive/${version}.tar.gz"
-checksum=f225a7e5cf225493b6ae8d427d3a08ab9d3ab6bcd2a297ec41350655ddba7be1
+checksum=eacf813ee427cf80f46aaf8d104d7d0e79937b38dff362a857ce86a091c9de5b
 # broken tests
 make_check=no
 

From 5312048944d1d11dbfa4f62a84277b0b68a27c48 Mon Sep 17 00:00:00 2001
From: Lorem <notloremipsum@protonmail.com>
Date: Sun, 28 Nov 2021 11:52:21 +0530
Subject: [PATCH 017/143] badwolf: update to 1.2.1, orphan.

---
 srcpkgs/badwolf/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/badwolf/template b/srcpkgs/badwolf/template
index 9b9f2a1fe84f..0397fe5aa59a 100644
--- a/srcpkgs/badwolf/template
+++ b/srcpkgs/badwolf/template
@@ -1,6 +1,6 @@
 # Template file for 'badwolf'
 pkgname=badwolf
-version=1.2.0
+version=1.2.1
 revision=1
 build_style=configure
 make_check_target=test
@@ -8,12 +8,12 @@ hostmakedepends="pkg-config gettext"
 makedepends="webkit2gtk-devel libsoup-devel"
 checkdepends="mdocml"
 short_desc="Minimalist and privacy-oriented WebKitGTK+ browser"
-maintainer="Lorem <notloremipsum@protonmail.com>"
+maintainer="Orphaned <orphan@voidlinux.org>"
 license="BSD-3-Clause"
 homepage="https://hacktivis.me/projects/badwolf"
 changelog="https://hacktivis.me/releases/badwolf-${version}.txt"
 distfiles="https://hacktivis.me/releases/badwolf-${version}.tar.gz"
-checksum=eaf5b99f1fc0ea94552c64f3b5e84cf9e76891882ea5e767bf633341e0265cba
+checksum=7a658908551bc0389fc43bd04a9decfef3815d28ff2097957bf6ab186a05ffd2
 
 pre_configure() {
 	export PREFIX=/usr

From 0b03833dfc71d6e4865b37bcbc5c99a48c572156 Mon Sep 17 00:00:00 2001
From: jgart <jgart@dismail.de>
Date: Sun, 28 Nov 2021 23:44:08 -0500
Subject: [PATCH 018/143] xonsh: update to 0.11.0.

---
 srcpkgs/xonsh/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/xonsh/template b/srcpkgs/xonsh/template
index 150d83d4c8f7..69caa602e442 100644
--- a/srcpkgs/xonsh/template
+++ b/srcpkgs/xonsh/template
@@ -1,7 +1,7 @@
 # Template file for 'xonsh'
 pkgname=xonsh
-version=0.10.1
-revision=2
+version=0.11.0
+revision=1
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 checkdepends="python3-pytest python3-prompt_toolkit python3-Pygments"
@@ -11,7 +11,7 @@ license="GPL-3.0-or-later"
 homepage="https://xon.sh/"
 changelog="https://raw.githubusercontent.com/xonsh/xonsh/master/CHANGELOG.rst"
 distfiles="https://github.com/xonsh/xonsh/archive/${version}.tar.gz"
-checksum=4ede94226b0cc5f429bc7605ace88137c685d24675228e9e94ec18341dd30be4
+checksum=9d73273276996297920c234c7d4267a305c695f0e9e2454dbdf0655c3a8f75cb
 register_shell="/bin/xonsh"
 # FIXME: fails with multiple AttributeErrors
 make_check=extended

From 513c764a08c0ad46a681fd2340d54f227d0df871 Mon Sep 17 00:00:00 2001
From: cinerea0 <cinerea0@disroot.org>
Date: Sun, 28 Nov 2021 23:59:11 -0500
Subject: [PATCH 019/143] sof-tools: update to 1.9.2

---
 srcpkgs/sof-tools/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/sof-tools/template b/srcpkgs/sof-tools/template
index e10c8afe210f..ecd8c553e5b1 100644
--- a/srcpkgs/sof-tools/template
+++ b/srcpkgs/sof-tools/template
@@ -1,6 +1,6 @@
 # Template file for 'sof-tools'
 pkgname=sof-tools
-version=1.9
+version=1.9.2
 revision=1
 # https://github.com/thesofproject/sof/issues/4902
 archs="x86_64"
@@ -14,7 +14,7 @@ maintainer="cinerea0 <cinerea0@protonmail.com>"
 license="BSD-3-Clause"
 homepage="https://thesofproject.github.io/latest/index.html"
 distfiles="https://github.com/thesofproject/sof/archive/refs/tags/v${version}.tar.gz"
-checksum=29b83a63720ace3a9173073f12c4dfae5ece841773483cb025623506cd02eccb
+checksum=77fc2200f96c565b18b5975fc2ac19c54a93e83502f13b4f782567e5c44f45da
 
 post_install() {
 	vlicense ../LICENCE

From 5d3326afa6d15d7f0d16bfe8d6630fe809775fdc Mon Sep 17 00:00:00 2001
From: cinerea0 <cinerea0@disroot.org>
Date: Sun, 28 Nov 2021 23:57:23 -0500
Subject: [PATCH 020/143] sof-firmware: update to 1.9.2

---
 srcpkgs/sof-firmware/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/sof-firmware/template b/srcpkgs/sof-firmware/template
index 5e866cb448f7..5e6399eca917 100644
--- a/srcpkgs/sof-firmware/template
+++ b/srcpkgs/sof-firmware/template
@@ -1,6 +1,6 @@
 # Template file for 'sof-firmware'
 pkgname=sof-firmware
-version=1.9
+version=1.9.2
 revision=1
 archs="i686* x86_64*"
 wrksrc="sof-bin-${version}"
@@ -11,13 +11,13 @@ maintainer="cinerea0 <cinerea0@protonmail.com>"
 license="BSD-3-Clause"
 homepage="https://thesofproject.github.io/latest/index.html"
 distfiles="https://github.com/thesofproject/sof-bin/archive/refs/tags/v${version}.tar.gz"
-checksum=633bff2cc1490146de66796e52e06c7a608591a328c0bfc6f3fc30114640803a
+checksum=8eac925c129d195072237dcd28f4bbe80cf63eb00fd8b23bdc0719cd1ee9b395
 
 do_install() {
 	vmkdir usr/lib/firmware/intel/sof
 	vmkdir usr/lib/firmware/intel/sof-tplg
-	rsync -a "v${version}.x/sof-v${version}/" "${DESTDIR}/usr/lib/firmware/intel/sof"
-	rsync -a "v${version}.x/sof-tplg-v${version}/" "${DESTDIR}/usr/lib/firmware/intel/sof-tplg"
+	rsync -a "v${version%.*}.x/sof-v${version}/" "${DESTDIR}/usr/lib/firmware/intel/sof"
+	rsync -a "v${version%.*}.x/sof-tplg-v${version}/" "${DESTDIR}/usr/lib/firmware/intel/sof-tplg"
 
 	vlicense LICENCE.NXP
 }

From 6eadc828e2a50a352a1db8a004038a7f2a968b18 Mon Sep 17 00:00:00 2001
From: teldra <teldra@rotce.de>
Date: Sun, 28 Nov 2021 00:46:53 +0100
Subject: [PATCH 021/143] viewnior: update to 1.8.

---
 srcpkgs/viewnior/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/viewnior/template b/srcpkgs/viewnior/template
index 8232c1eb787b..efea8ef77dfb 100644
--- a/srcpkgs/viewnior/template
+++ b/srcpkgs/viewnior/template
@@ -1,7 +1,7 @@
 # Template file for 'viewnior'
 pkgname=viewnior
-version=1.7
-revision=2
+version=1.8
+revision=1
 wrksrc="Viewnior-${pkgname}-${version}"
 build_style=meson
 hostmakedepends="pkg-config intltool gnome-common glib-devel gettext-devel"
@@ -11,4 +11,4 @@ maintainer="teldra <teldra@rotce.de>"
 license="GPL-3.0-or-later"
 homepage="http://siyanpanayotov.com/project/viewnior/"
 distfiles="https://github.com/hellosiyan/Viewnior/archive/${pkgname}-${version}.tar.gz"
-checksum=b9fad3b2909a78f65b33f4dfb47fcdfa97150275e00d5c44d0aa0f1dc499f3e6
+checksum=b9319171ebca23929e6ea8039c194b1595d92e764db5e3890836fb5c36e233b0

From 5b7cef971d694b5dc30cd6d5089914e5916c5093 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Ey=C3=9Fer?= <daniel.eysser@gmail.com>
Date: Fri, 26 Nov 2021 18:26:01 +0100
Subject: [PATCH 022/143] common/environment/build-style: add zig-build.sh

---
 common/environment/build-style/zig-build.sh | 1 +
 1 file changed, 1 insertion(+)
 create mode 100644 common/environment/build-style/zig-build.sh

diff --git a/common/environment/build-style/zig-build.sh b/common/environment/build-style/zig-build.sh
new file mode 100644
index 000000000000..049b7cd437d5
--- /dev/null
+++ b/common/environment/build-style/zig-build.sh
@@ -0,0 +1 @@
+hostmakedepends+=" zig"

From fc88cfb35e189a2a8aa4e7370760eec78472cd91 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Ey=C3=9Fer?= <daniel.eysser@gmail.com>
Date: Fri, 26 Nov 2021 18:30:51 +0100
Subject: [PATCH 023/143] rundird: zig-build now adds zig to hostmakedepends

---
 srcpkgs/rundird/template | 1 -
 1 file changed, 1 deletion(-)

diff --git a/srcpkgs/rundird/template b/srcpkgs/rundird/template
index 8fa83b5e0dcc..5ff897abd456 100644
--- a/srcpkgs/rundird/template
+++ b/srcpkgs/rundird/template
@@ -3,7 +3,6 @@ pkgname=rundird
 version=0.2.0
 revision=1
 build_style=zig-build
-hostmakedepends="zig"
 makedepends="pam-devel"
 short_desc="Simple daemon + PAM module providing an XDG_RUNTIME_DIR"
 maintainer="Isaac Freund <mail@isaacfreund.com>"

From 78f0a2419a91eac0114546a1ce8a7ccf9f0e8df2 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Ey=C3=9Fer?= <daniel.eysser@gmail.com>
Date: Fri, 26 Nov 2021 18:32:32 +0100
Subject: [PATCH 024/143] river: zig-build now adds zig to hostmakedepends

---
 srcpkgs/river/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/river/template b/srcpkgs/river/template
index d30060422419..314ed6c53146 100644
--- a/srcpkgs/river/template
+++ b/srcpkgs/river/template
@@ -4,7 +4,7 @@ version=0.1.0
 revision=1
 build_style=zig-build
 configure_args="$(vopt_if xwayland -Dxwayland)"
-hostmakedepends="zig pkg-config wayland-devel scdoc git"
+hostmakedepends="pkg-config wayland-devel scdoc git"
 makedepends="wlroots-devel"
 depends="$(vopt_if xwayland xorg-server-xwayland)"
 short_desc="Dynamic tiling Wayland compositor"

From 94f8fc4e42ab1bcb955840fe7c3af7da465024f6 Mon Sep 17 00:00:00 2001
From: Lorem <notloremipsum@protonmail.com>
Date: Sun, 28 Nov 2021 11:25:31 +0530
Subject: [PATCH 025/143] minigalaxy: update to 1.1.0, orphan.

---
 srcpkgs/minigalaxy/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/minigalaxy/template b/srcpkgs/minigalaxy/template
index 9b7d2f6dbc90..30d360cf6414 100644
--- a/srcpkgs/minigalaxy/template
+++ b/srcpkgs/minigalaxy/template
@@ -1,18 +1,18 @@
 # Template file for 'minigalaxy'
 pkgname=minigalaxy
-version=1.0.2
-revision=2
+version=1.1.0
+revision=1
 build_style=python3-module
 hostmakedepends="gettext python3-setuptools"
 depends="hicolor-icon-theme webkit2gtk python3-gobject python3-requests"
-checkdepends="$depends"
+checkdepends="$depends python3-simplejson"
 short_desc="Simple GOG client for Linux"
-maintainer="Lorem <notloremipsum@protonmail.com>"
+maintainer="Orphaned <orphan@voidlinux.org>"
 license="GPL-3.0-or-later, CC-BY-3.0"
 homepage="https://sharkwouter.github.io/minigalaxy/"
 changelog="https://github.com/sharkwouter/minigalaxy/blob/master/CHANGELOG.md"
 distfiles="https://github.com/sharkwouter/minigalaxy/archive/${version}.tar.gz"
-checksum=9cb482760c68153f2fc8b8fe229d60033634bc0c7b83a6aa43a9cfa20ab2d0e9
+checksum=581e7abfb4af0c01d795dc57a93b1305644d8bdd11ecb533bb2787f85b4bc992
 
 do_check() {
 	python -m unittest tests/*.py

From f5dfa3d20588323ab526ac96cbbb340226ff48ec Mon Sep 17 00:00:00 2001
From: oreo639 <31916379+Oreo639@users.noreply.github.com>
Date: Sat, 27 Nov 2021 01:46:21 -0800
Subject: [PATCH 026/143] pacman: update to 6.0.1

---
 srcpkgs/pacman/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/pacman/template b/srcpkgs/pacman/template
index b98560e10637..d14176f089d7 100644
--- a/srcpkgs/pacman/template
+++ b/srcpkgs/pacman/template
@@ -1,13 +1,13 @@
 # Template file for 'pacman'
 pkgname=pacman
-version=5.2.2
-revision=3
+version=6.0.1
+revision=1
 make_dirs="/var/lib/pacman 0755 root root
  /usr/var/cache/pacman/pkg 0755 root root
  /usr/share/libalpm/hooks 0755 root root"
 conf_files="/etc/pacman.conf"
 build_style=meson
-hostmakedepends="autoconf automake curl libtool gettext-devel pkg-config asciidoc"
+hostmakedepends="curl gettext-devel pkg-config asciidoc"
 makedepends="libarchive-devel gpgme-devel libcurl-devel"
 depends="gnupg>=2"
 checkdepends="fakeroot"
@@ -15,8 +15,8 @@ short_desc="Simple library-based package manager"
 maintainer="oreo639 <oreo6391@gmail.com>"
 license="GPL-2.0-or-later"
 homepage="https://www.archlinux.org/pacman/"
-distfiles="https://sources.archlinux.org/other/pacman/pacman-${version}.tar.gz"
-checksum=bb201a9f2fb53c28d011f661d50028efce6eef2c1d2a36728bdd0130189349a0
+distfiles="https://sources.archlinux.org/other/pacman/pacman-${version}.tar.xz"
+checksum=0db61456e56aa49e260e891c0b025be210319e62b15521f29d3e93b00d3bf731
 make_check=ci-skip
 
 if [ "$XBPS_TARGET_LIBC" = musl ]; then

From f98f1b87a12a425964f1dcec9188f82226e3bdea Mon Sep 17 00:00:00 2001
From: cinerea0 <cinerea0@disroot.org>
Date: Mon, 29 Nov 2021 01:08:42 -0500
Subject: [PATCH 027/143] delta: update to 0.10.2

---
 srcpkgs/delta/template | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/delta/template b/srcpkgs/delta/template
index 15481ba9a01b..bd5040d70709 100644
--- a/srcpkgs/delta/template
+++ b/srcpkgs/delta/template
@@ -1,6 +1,6 @@
 # Template file for 'delta'
 pkgname=delta
-version=0.9.2
+version=0.10.2
 revision=1
 build_style=cargo
 checkdepends="git"
@@ -9,7 +9,8 @@ maintainer="Andrew Benson <abenson+void@gmail.com>"
 license="MIT"
 homepage="https://github.com/dandavison/delta"
 distfiles="${homepage}/archive/${version}.tar.gz"
-checksum=f002a94119cd5b6fd9deede7f344667358baf5015d0051e055fec6334ee0653f
+checksum=e0f71d72eca543478941401bd96fefc5fa3f70e7860a9f858f63bfecf8fd77a5
+make_check=no  # TODO: Re-enable checks when Rust gets updated
 
 post_install() {
 	vlicense LICENSE

From 71dbddca720ba651abf7bab489ba8cf3b03b7e45 Mon Sep 17 00:00:00 2001
From: Cullen Ross <cullenrss@gmail.com>
Date: Sun, 28 Nov 2021 19:27:26 -0500
Subject: [PATCH 028/143] rxvt-unicode: update to 9.30.

---
 srcpkgs/rxvt-unicode/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/rxvt-unicode/template b/srcpkgs/rxvt-unicode/template
index 4223d2e8f789..00ebdf63c3ca 100644
--- a/srcpkgs/rxvt-unicode/template
+++ b/srcpkgs/rxvt-unicode/template
@@ -1,6 +1,6 @@
 # Template file for 'rxvt-unicode'
 pkgname=rxvt-unicode
-version=9.29
+version=9.30
 revision=1
 build_style=gnu-configure
 configure_args="
@@ -25,7 +25,7 @@ maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="GPL-3.0-or-later"
 homepage="http://software.schmorp.de/pkg/rxvt-unicode.html"
 distfiles="http://dist.schmorp.de/${pkgname}/${pkgname}-${version}.tar.bz2"
-checksum=c18bc9de0c319db1f85748ecc2f255ff9eb2be0fbe9e15fe0eabefc063c4157c
+checksum=fe1c93d12f385876457a989fc3ae05c0915d2692efc59289d0f70fabe5b44d2d
 
 # Package build options
 build_options="gdk_pixbuf perl startup_notification unicode3"

From 5c9eb9eed1c25c9f101fd7b9f7b3e9b48508fae0 Mon Sep 17 00:00:00 2001
From: Clyhtsuriva <aimeric@adjutor.xyz>
Date: Mon, 29 Nov 2021 12:46:14 +0100
Subject: [PATCH 029/143] balsa: update to 2.6.3

---
 srcpkgs/balsa/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/balsa/template b/srcpkgs/balsa/template
index 70838929c35a..af0f741d1860 100644
--- a/srcpkgs/balsa/template
+++ b/srcpkgs/balsa/template
@@ -1,6 +1,6 @@
 # Template file for 'balsa'
 pkgname=balsa
-version=2.6.2
+version=2.6.3
 revision=1
 build_style=gnu-configure
 configure_args="--without-gnome --with-libsecret --with-gpgme --with-sqlite
@@ -13,5 +13,5 @@ short_desc="Email client for GNOME"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="https://pawsa.fedorapeople.org/balsa/"
-distfiles="https://pawsa.fedorapeople.org/balsa/balsa-${version}.tar.bz2"
-checksum=51d52040577b730d7a199e97ea3687b3d0f7cf7f08f6e339e784d700621a02f0
+distfiles="https://pawsa.fedorapeople.org/balsa/balsa-${version}.tar.xz"
+checksum=d4d04576c9a5026064f7d480b34531faf59543f2e4d57c48a6fa5c76661e1dd4

From 8c7afd75652f48987a4a0f11201f996130a50747 Mon Sep 17 00:00:00 2001
From: jgart <jgart@dismail.de>
Date: Mon, 29 Nov 2021 03:05:34 -0500
Subject: [PATCH 030/143] hugo: update to 0.89.4.

---
 srcpkgs/hugo/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/hugo/template b/srcpkgs/hugo/template
index d2765c6722db..444018d45dbf 100644
--- a/srcpkgs/hugo/template
+++ b/srcpkgs/hugo/template
@@ -1,6 +1,6 @@
 # Template file for 'hugo'
 pkgname=hugo
-version=0.89.1
+version=0.89.4
 revision=1
 build_style=go
 go_import_path="github.com/gohugoio/hugo"
@@ -10,7 +10,7 @@ maintainer="Andrea Brancaleoni <abc@pompel.me>"
 license="Apache-2.0"
 homepage="https://gohugo.io"
 distfiles="https://github.com/gohugoio/hugo/archive/v${version}.tar.gz"
-checksum=c47f144291819a8d9f065f69ab290a198dfabde86a27ac2325a89f03c6e5ea3f
+checksum=9d4f61788f8d886913a1be15b3eae04fad04a4e243bd7f65c5e7367bd617856d
 
 post_install() {
 	vdoc README.md

From 4b1b908942f9d9392e672f98f8ec45871ffbb305 Mon Sep 17 00:00:00 2001
From: jgart <jgart@dismail.de>
Date: Mon, 29 Nov 2021 02:00:44 -0500
Subject: [PATCH 031/143] stagit: update to 0.9.6.

---
 srcpkgs/stagit/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/stagit/template b/srcpkgs/stagit/template
index 89c5a8cb177c..7078a4f6c946 100644
--- a/srcpkgs/stagit/template
+++ b/srcpkgs/stagit/template
@@ -1,6 +1,6 @@
 # Template file for 'stagit'
 pkgname=stagit
-version=0.9.5
+version=0.9.6
 revision=1
 build_style=gnu-makefile
 make_install_args="MANPREFIX=/usr/share/man"
@@ -10,7 +10,7 @@ maintainer="Steve Prybylski <sa.prybylx@gmail.com>"
 license="MIT"
 homepage="https://codemadness.org/git/stagit/log.html"
 distfiles="https://codemadness.org/releases/stagit/${pkgname}-${version}.tar.gz"
-checksum=025a17c7be3a4e98a2319efc4eb6329e9ea6a778b2b24b0eb97a342ece9bb039
+checksum=d072f386f3a546ed0341e20f9c2dfd7756a761fab1c40316a96690cb2b3066d0
 LDFLAGS="-lgit2"
 
 post_install() {

From 63d0068fa1cf0ea48fdf5f80391557e951cd45c6 Mon Sep 17 00:00:00 2001
From: cinerea0 <cinerea0@disroot.org>
Date: Mon, 29 Nov 2021 01:37:08 -0500
Subject: [PATCH 032/143] onefetch: update to 2.11.0

---
 srcpkgs/onefetch/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/onefetch/template b/srcpkgs/onefetch/template
index cf9832cb5459..88f21bc3b351 100644
--- a/srcpkgs/onefetch/template
+++ b/srcpkgs/onefetch/template
@@ -1,6 +1,6 @@
 # Template file for 'onefetch'
 pkgname=onefetch
-version=2.10.2
+version=2.11.0
 revision=1
 build_style=cargo
 short_desc="Git repository summary on your terminal"
@@ -8,7 +8,7 @@ maintainer="Jan Christian Grünhage <jan.christian@gruenhage.xyz>"
 license="MIT"
 homepage="https://github.com/o2sh/onefetch"
 distfiles="https://github.com/o2sh/onefetch/archive/v${version}.tar.gz"
-checksum=6e4d4effcd4fd94ce21625a5e32da5da6446c8874200e40dd791e623b7aff7bb
+checksum=ffd3cc3bd24e299ede1fada2b2da8bf066d59219da167477e1997c860650c192
 
 post_install() {
 	vlicense LICENSE.md

From 104ac0b222617bbd3fa1222989c03b2dda3a8bae Mon Sep 17 00:00:00 2001
From: cinerea0 <cinerea0@disroot.org>
Date: Mon, 29 Nov 2021 00:50:38 -0500
Subject: [PATCH 033/143] mdBook: update to 0.4.14

---
 srcpkgs/mdBook/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/mdBook/template b/srcpkgs/mdBook/template
index b9df0433334f..465ff1a1bbbc 100644
--- a/srcpkgs/mdBook/template
+++ b/srcpkgs/mdBook/template
@@ -1,6 +1,6 @@
 # Template file for 'mdBook'
 pkgname=mdBook
-version=0.4.13
+version=0.4.14
 revision=1
 build_style=cargo
 short_desc="Create book from markdown files. Like Gitbook but implemented in Rust"
@@ -9,7 +9,7 @@ license="MPL-2.0"
 homepage="https://github.com/rust-lang/mdBook"
 changelog="https://raw.githubusercontent.com/rust-lang/mdBook/master/CHANGELOG.md"
 distfiles="https://github.com/rust-lang/mdBook/archive/v${version}.tar.gz"
-checksum=12a88a08e5c5b26810cc33b4e0ebed7cc72394f9041e8b15253e3cfac1223a7b
+checksum=59fd3e417e9d09deac89e20467194dd9f93854c2f1a87e845816c5cec676765c
 
 post_install() {
 	vlicense LICENSE

From fcd9bd4dc95d61a965007430061dfd9ba628ac4d Mon Sep 17 00:00:00 2001
From: teldra <teldra@rotce.de>
Date: Sun, 28 Nov 2021 01:11:22 +0100
Subject: [PATCH 034/143] py3status: update to 3.40.

---
 srcpkgs/py3status/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/py3status/template b/srcpkgs/py3status/template
index 5267fd63fdbe..092ccfbe2bd9 100644
--- a/srcpkgs/py3status/template
+++ b/srcpkgs/py3status/template
@@ -1,7 +1,7 @@
 # Template file for 'py3status'
 pkgname=py3status
-version=3.39
-revision=2
+version=3.40
+revision=1
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-setuptools python3-pyudev"
@@ -12,7 +12,7 @@ license="BSD-3-Clause"
 homepage="https://github.com/ultrabug/py3status"
 changelog="https://raw.githubusercontent.com/ultrabug/py3status/master/CHANGELOG"
 distfiles="${homepage}/archive/${version}.tar.gz"
-checksum=d18b81e86d5a44d2fa67453c3e9f04b9285005b2a7a9455890903d0e2dfe843c
+checksum=84885ec8a43626dcd7576b9cad029406c98675ca00ba66ff124d7607290d2b66
 
 post_install() {
 	vlicense LICENSE

From 2e2f8884f7afdae768a630b8d2960c11faa7e82d Mon Sep 17 00:00:00 2001
From: teldra <teldra@rotce.de>
Date: Sun, 28 Nov 2021 01:08:24 +0100
Subject: [PATCH 035/143] openimagedenoise: update to 1.4.2.

---
 srcpkgs/openimagedenoise/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/openimagedenoise/template b/srcpkgs/openimagedenoise/template
index 7120d39bae20..8190e029a08b 100644
--- a/srcpkgs/openimagedenoise/template
+++ b/srcpkgs/openimagedenoise/template
@@ -1,6 +1,6 @@
 # Template file for 'openimagedenoise'
 pkgname=openimagedenoise
-version=1.4.1
+version=1.4.2
 revision=1
 archs="x86_64*"
 wrksrc=oidn-${version}
@@ -12,7 +12,7 @@ maintainer="teldra <teldra@rotce.de>"
 license="Apache-2.0"
 homepage="https://openimagedenoise.github.io"
 distfiles="https://github.com/OpenImageDenoise/oidn/releases/download/v${version}/oidn-${version}.src.tar.gz"
-checksum=9088966685a78adf24b8de075d66e4c0019bd7b2b9d29c6e45aaf35d294e3f6f
+checksum=e70d27ce24b41364782376c1b3b4f074f77310ccfe5f8ffec4a13a347e48a0ea
 
 do_check() {
 	build/oidnTest

From 7f5db2e188869d184a482416aa4028eaac0d99cf Mon Sep 17 00:00:00 2001
From: Firgen <filip.frgelec@disroot.org>
Date: Sun, 14 Nov 2021 15:27:49 +0100
Subject: [PATCH 036/143] i3lock-color: update to 2.13.c.4.

---
 srcpkgs/i3lock-color/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/i3lock-color/template b/srcpkgs/i3lock-color/template
index 7f5572f99d64..6ce184239bb4 100644
--- a/srcpkgs/i3lock-color/template
+++ b/srcpkgs/i3lock-color/template
@@ -1,6 +1,6 @@
 # Template file for 'i3lock-color'
 pkgname=i3lock-color
-version=2.12.c.5
+version=2.13.c.4
 revision=1
 build_style=gnu-configure
 hostmakedepends="pkg-config automake"
@@ -11,7 +11,7 @@ maintainer="jtalowell <jtalowell@protonmail.com>"
 license="MIT"
 homepage="https://github.com/Raymo111/i3lock-color"
 distfiles="https://github.com/Raymo111/i3lock-color/archive/${version}.tar.gz"
-checksum=62c9bdff2759186426b184ed45e4c1aae1dc3c582499d94da68d9b08662a96a9
+checksum=5df4cd3d515d938630ced981a7f0a6e01344d1ec51d10fd3c3d131d19283df69
 conf_files="/etc/pam.d/i3lock"
 conflicts="i3lock"
 

From 7e3f07be481c098606bbc3e45d01a0b22e888037 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Piotr=20W=C3=B3jcik?= <chocimier@tlen.pl>
Date: Mon, 29 Nov 2021 20:04:48 +0100
Subject: [PATCH 037/143] diffoscope: update to 194.

---
 srcpkgs/diffoscope/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/diffoscope/template b/srcpkgs/diffoscope/template
index 596f402323fe..31a2ca350066 100644
--- a/srcpkgs/diffoscope/template
+++ b/srcpkgs/diffoscope/template
@@ -1,6 +1,6 @@
 # Template file for 'diffoscope'
 pkgname=diffoscope
-version=193
+version=194
 revision=1
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -14,4 +14,4 @@ license="GPL-3.0-or-later"
 homepage="https://diffoscope.org/"
 changelog="https://salsa.debian.org/reproducible-builds/diffoscope/raw/master/debian/changelog"
 distfiles="${PYPI_SITE}/d/diffoscope/diffoscope-${version}.tar.gz"
-checksum=d836ddf24ccb4ffabd798ea1b7fcb66b87e55d5e8ff08286620bb7c64e1d829f
+checksum=3d28f0325e00effc6c23c50f916d153524aa393623df2fd1fc8ae0f6a12daf94

From f8cd23f19539e21b5375fbb0e263c855b7b3e1cb Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C3=89rico=20Nogueira?= <erico.erc@gmail.com>
Date: Mon, 29 Nov 2021 02:01:44 -0300
Subject: [PATCH 038/143] gnome-keyring: remove libcap-ng, adopt.

We don't set capabilities on the binary right now, so it's better to
build without libcap-ng, so it doesn't complain on start-up. This is
also done by other distros, see [1].

libcap was no longer used, and neither was libtasn1.

We already depend on gcr via shlibs, so it doesn't need to be in
depends= explicitly.

Also update changelog to canonical URL.

[1] https://gitlab.gnome.org/GNOME/gnome-keyring/-/merge_requests/41#note_1277767
---
 srcpkgs/gnome-keyring/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/gnome-keyring/template b/srcpkgs/gnome-keyring/template
index 12f1e8d2df64..f479f7f0fe5e 100644
--- a/srcpkgs/gnome-keyring/template
+++ b/srcpkgs/gnome-keyring/template
@@ -1,19 +1,19 @@
 # Template file for 'gnome-keyring'
 pkgname=gnome-keyring
 version=40.0
-revision=2
+revision=3
 build_style=gnu-configure
 configure_args="--with-pam-dir=/usr/lib/security --disable-schemas-compile"
 hostmakedepends="autoconf docbook-xsl glib-devel intltool libtasn1-tools libxslt
  openssh pkg-config"
-makedepends="gcr-devel libcap-devel libcap-ng-devel libtasn1-devel pam-devel"
-depends="dconf gcr"
+makedepends="gcr-devel pam-devel"
+depends="dconf"
 checkdepends="dbus xvfb-run"
 short_desc="GNOME password and secret manager"
-maintainer="Orphaned <orphan@voidlinux.org>"
+maintainer="Érico Nogueira <ericonr@disroot.org>"
 license="GPL-2.0-or-later, LGPL-2.1-or-later"
 homepage="https://www.gnome.org"
-changelog="https://raw.githubusercontent.com/GNOME/gnome-keyring/gnome-40/NEWS"
+changelog="https://gitlab.gnome.org/GNOME/gnome-keyring/-/raw/master/NEWS"
 distfiles="${GNOME_SITE}/$pkgname/${version%.*}/$pkgname-$version.tar.xz"
 checksum=a3d24db08ee2fdf240fbbf0971a98c8ee295aa0e1a774537f4ea938038a3b931
 make_check=ci-skip

From 23352250f33b236f725232e5996c0aca57b906cc Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C3=89rico=20Nogueira?= <erico.erc@gmail.com>
Date: Mon, 29 Nov 2021 02:10:34 -0300
Subject: [PATCH 039/143] texinfo: update to 6.8.

---
 srcpkgs/texinfo/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/texinfo/template b/srcpkgs/texinfo/template
index c183625028c5..55948fd8bab5 100644
--- a/srcpkgs/texinfo/template
+++ b/srcpkgs/texinfo/template
@@ -1,6 +1,6 @@
 # Template file for 'texinfo'
 pkgname=texinfo
-version=6.7
+version=6.8
 revision=1
 build_style=gnu-configure
 configure_args="--disable-static --disable-perl-xs"
@@ -10,9 +10,9 @@ depends="gzip perl"
 short_desc="GNU Documentation System"
 maintainer="Enno Boland <gottox@voidlinux.org>"
 license="GPL-3.0-or-later"
-homepage="http://www.gnu.org/software/texinfo/"
+homepage="https://www.gnu.org/software/texinfo/"
 distfiles="${GNU_SITE}/$pkgname/$pkgname-$version.tar.xz"
-checksum=988403c1542d15ad044600b909997ba3079b10e03224c61188117f3676b02caa
+checksum=8eb753ed28bca21f8f56c1a180362aed789229bd62fff58bf8368e9beb59fec4
 
 if [ -z "$CROSS_BUILD" ]; then
 	# XXX fails with cross compilation

From b53a02f9278ebf9c07eca2c8415d4d4795ecc345 Mon Sep 17 00:00:00 2001
From: Luke Hannan <luke@lukehannan.com>
Date: Mon, 29 Nov 2021 17:50:36 +0200
Subject: [PATCH 040/143] R: update to 4.1.2.

---
 srcpkgs/R/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/R/template b/srcpkgs/R/template
index db75515b11cd..8a7db746af46 100644
--- a/srcpkgs/R/template
+++ b/srcpkgs/R/template
@@ -1,7 +1,7 @@
 # Template file for 'R'
 pkgname=R
-version=4.1.1
-revision=2
+version=4.1.2
+revision=1
 build_style=gnu-configure
 configure_args="--docdir=/usr/share/doc/R rdocdir=/usr/share/doc/R
  --with-blas$(vopt_if openblas '=openblas') --with-lapack
@@ -22,7 +22,7 @@ license="GPL-2.0-or-later"
 homepage="https://www.r-project.org/"
 changelog="https://cran.r-project.org/doc/manuals/r-release/NEWS.html"
 distfiles="https://cran.r-project.org/src/base/R-4/${pkgname}-${version}.tar.gz"
-checksum=515e03265752257d0b7036f380f82e42b46ed8473f54f25c7b67ed25bbbdd364
+checksum=2036225e9f7207d4ce097e54972aecdaa8b40d7d9911cd26491fac5a0fab38af
 nocross=yes
 shlib_provides="libR.so"
 make_check=extended

From 4996b8b94185a079473016cfdc07dca8d69fd6e6 Mon Sep 17 00:00:00 2001
From: Lorem <notloremipsum@protonmail.com>
Date: Sun, 28 Nov 2021 11:05:58 +0530
Subject: [PATCH 041/143] New package: coeurl-0.1.0

---
 common/shlibs           |  1 +
 srcpkgs/coeurl-devel    |  1 +
 srcpkgs/coeurl/template | 28 ++++++++++++++++++++++++++++
 3 files changed, 30 insertions(+)
 create mode 120000 srcpkgs/coeurl-devel
 create mode 100644 srcpkgs/coeurl/template

diff --git a/common/shlibs b/common/shlibs
index dac22845d445..527588585aec 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -4070,3 +4070,4 @@ libbrial_groebner.so.3 brial-1.2.10_1
 libm4ri-0.0.20200125.so m4ri-20200125_1
 libm4rie-0.0.20200125.so m4rie-20200125_1
 libptytty.so.0 libptytty-2.0_1
+libcoeurl.so.0 coeurl-0.1.0_1
diff --git a/srcpkgs/coeurl-devel b/srcpkgs/coeurl-devel
new file mode 120000
index 000000000000..bdd2ff71f0cb
--- /dev/null
+++ b/srcpkgs/coeurl-devel
@@ -0,0 +1 @@
+coeurl
\ No newline at end of file
diff --git a/srcpkgs/coeurl/template b/srcpkgs/coeurl/template
new file mode 100644
index 000000000000..dd6600a89bba
--- /dev/null
+++ b/srcpkgs/coeurl/template
@@ -0,0 +1,28 @@
+# Template file for 'coeurl'
+pkgname=coeurl
+version=0.1.0
+revision=1
+wrksrc=coeurl-v${version}
+build_style=meson
+hostmakedepends="pkg-config"
+makedepends="spdlog libevent-devel libcurl-devel"
+short_desc="Simple async wrapper around CURL for C++"
+maintainer="Lorem <notloremipsum@protonmail.com>"
+license="MIT"
+homepage="https://nheko.im/nheko-reborn/coeurl"
+distfiles="https://nheko.im/nheko-reborn/coeurl/-/archive/v${version}/coeurl-v${version}.tar.gz"
+checksum=2861453317c6da359a00083e39d899dfe0fc71becadd726ef845a5fba57d3f64
+
+post_install() {
+	vlicense LICENSE
+}
+
+coeurl-devel_package() {
+	short_desc+=" - development files"
+	depends="${sourcepkg}>=${version}_${revision} ${makedepends}"
+	pkg_install() {
+		vmove usr/include
+		vmove usr/lib/pkgconfig
+		vmove "usr/lib/*.so"
+	}
+}

From a25f0df1f587857d215cbe473088adf999ae754a Mon Sep 17 00:00:00 2001
From: Lorem <notloremipsum@protonmail.com>
Date: Sun, 28 Nov 2021 11:07:15 +0530
Subject: [PATCH 042/143] mtxclient: update to 0.6.0.

---
 common/shlibs              | 2 +-
 srcpkgs/mtxclient/template | 6 +++---
 2 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index 527588585aec..ad60646030fe 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -420,7 +420,7 @@ libField3D.so.1.7 Field3D-1.7.3_1
 libMAC.so.6 libMAC-5.28_1
 libmad.so.0 libmad-0.15.1b_1
 libmatroska.so.7 libmatroska-1.6.0_1
-libmatrix_client.so.0.5.1 mtxclient-0.5.1_1
+libmatrix_client.so.0.6.0 mtxclient-0.6.0_1
 libebml.so.5 libebml-1.4.0_1
 libdvdread.so.8 libdvdread-6.1.1_1
 libdvdnav.so.4 libdvdnav-4.1.3_1
diff --git a/srcpkgs/mtxclient/template b/srcpkgs/mtxclient/template
index 35f3d4a10f42..9c8c1e3a9efe 100644
--- a/srcpkgs/mtxclient/template
+++ b/srcpkgs/mtxclient/template
@@ -1,17 +1,17 @@
 # Template file for 'mtxclient'
 pkgname=mtxclient
-version=0.5.1
+version=0.6.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_LIB_TESTS=OFF -DBUILD_LIB_EXAMPLES=OFF"
 hostmakedepends="pkg-config"
-makedepends="boost-devel json-c++ olm-devel openssl-devel"
+makedepends="json-c++ olm-devel openssl-devel coeurl-devel"
 short_desc="Client API library for the Matrix protocol"
 maintainer="Lorem <notloremipsum@protonmail.com>"
 license="MIT"
 homepage="https://github.com/Nheko-Reborn/mtxclient"
 distfiles="https://github.com/Nheko-Reborn/mtxclient/archive/v${version}.tar.gz"
-checksum=9478d870296ebe7679c90f563cb798eb3cdd3f9c4578ceea5af75b66f456baaa
+checksum=4245feb0bd4ae8e026c01f546a6bea45bc9d9d57d13430b8ba446b0aec4915c4
 
 post_install() {
 	vlicense LICENSE

From 51dfe223276ddb1daa5925cab07f66864838d699 Mon Sep 17 00:00:00 2001
From: Lorem <notloremipsum@protonmail.com>
Date: Sun, 28 Nov 2021 11:07:27 +0530
Subject: [PATCH 043/143] nheko: update to 0.9.0.

---
 srcpkgs/nheko/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/nheko/template b/srcpkgs/nheko/template
index 7b7c6bfbf6e1..deaf85713976 100644
--- a/srcpkgs/nheko/template
+++ b/srcpkgs/nheko/template
@@ -1,11 +1,11 @@
 # Template file for 'nheko'
 pkgname=nheko
-version=0.8.2
-revision=2
+version=0.9.0
+revision=1
 build_style=cmake
 hostmakedepends="qt5-host-tools qt5-qmake pkg-config qt5-declarative"
 makedepends="qt5-multimedia-devel qt5-svg-devel qt5-tools-devel fmt-devel
- spdlog mtxclient-devel boost-devel cmark-devel olm-devel json-c++ lmdb++
+ spdlog mtxclient-devel cmark-devel olm-devel json-c++ lmdb++ coeurl-devel
  qt5-declarative-devel qt5-quickcontrols2-devel qtkeychain-qt5-devel
  gst-plugins-bad1-devel gst-plugins-base1-devel xcb-util-wm-devel"
 depends="hicolor-icon-theme qt5-quickcontrols2 qt5-graphicaleffects
@@ -16,7 +16,7 @@ license="GPL-3.0-or-later"
 homepage="https://github.com/Nheko-Reborn/nheko"
 changelog="https://github.com/Nheko-Reborn/nheko/blob/master/CHANGELOG.md"
 distfiles="https://github.com/Nheko-Reborn/nheko/archive/v${version}.tar.gz"
-checksum=df4575c47daab47d418637a4637b599e3848dd749132ca1e92f981d9212eabb2
+checksum=309505f13d3b65ea23c0db19e59e469905b1ae437d2d6c7d1b496ac0921fb141
 
 case "$XBPS_TARGET_MACHINE" in
 	armv*-musl)

From 56f8cb1f0060d22b28b63d51e8308a2f521000ed Mon Sep 17 00:00:00 2001
From: Evgeny Ermakov <evgeny.v.ermakov@gmail.com>
Date: Tue, 30 Nov 2021 06:03:00 +1100
Subject: [PATCH 044/143] cglm: update to 0.8.4.

---
 srcpkgs/cglm/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/cglm/template b/srcpkgs/cglm/template
index c7dfee606c45..5b553c7c0d12 100644
--- a/srcpkgs/cglm/template
+++ b/srcpkgs/cglm/template
@@ -1,6 +1,6 @@
 # Template file for 'cglm'
 pkgname=cglm
-version=0.8.3
+version=0.8.4
 revision=1
 build_style=cmake
 short_desc="Highly Optimized Graphics Math (glm) for C"
@@ -8,7 +8,7 @@ maintainer="Nicu Borta <nicuborta123@tutanota.com>"
 license="MIT"
 homepage="https://github.com/recp/cglm"
 distfiles="https://github.com/recp/cglm/archive/v${version}.tar.gz"
-checksum=3a3f935f9f2ed5a8cb6337e421bf6f3a699a72d8cfe26fde1bbb8fde5c1c8aaf
+checksum=42f84c42c8a3e62954da77ab5c5d3264033d5802009e175db7921332a476126e
 
 post_install() {
 	vlicense LICENSE

From 4956ff3a768491659b8b6512c500b3abc3cfdaf4 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Mon, 29 Nov 2021 21:37:47 +0100
Subject: [PATCH 045/143] debootstrap: update to 1.0.126+nmu1.

---
 srcpkgs/debootstrap/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/debootstrap/template b/srcpkgs/debootstrap/template
index df67a598d286..14d0528a710c 100644
--- a/srcpkgs/debootstrap/template
+++ b/srcpkgs/debootstrap/template
@@ -1,6 +1,6 @@
 # Template file for 'debootstrap'
 pkgname=debootstrap
-version=1.0.126
+version=1.0.126+nmu1
 revision=1
 build_style=fetch
 depends="binutils gnupg gzip tar wget xz zstd"
@@ -10,7 +10,7 @@ license="MIT"
 homepage="http://packages.qa.debian.org/d/debootstrap.html"
 distfiles="${DEBIAN_SITE}/main/d/${pkgname}/${pkgname}_${version}_all.deb
  ${DEBIAN_SITE}/main/d/debian-archive-keyring/debian-archive-keyring_2021.1.1_all.deb"
-checksum="3084a2dcb4cd56a7c094c6b7cd745b6736ad78846b108275616d448fa6911f5e
+checksum="396f694346e6b401341ca07e30355faebea0ff490322cdbba804066cf4a0d048
  56beca470dcd9b6d7e6c3c9e9d702101e01e9467e62810a8c357bd7b9c26251d"
 
 case "$XBPS_TARGET_MACHINE" in

From 3dabf5e6fa3bbdf705340d525db83aea30b56f26 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Mon, 29 Nov 2021 21:37:56 +0100
Subject: [PATCH 046/143] linux: update to 5.15.

---
 srcpkgs/linux/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/linux/template b/srcpkgs/linux/template
index 50ff91aef896..f76a6a1d27e8 100644
--- a/srcpkgs/linux/template
+++ b/srcpkgs/linux/template
@@ -1,6 +1,6 @@
 # Template file for 'linux'
 pkgname=linux
-version=5.13
+version=5.15
 revision=1
 build_style=meta
 depends="linux${version} linux-base"

From b60a99346148340ea429e062dd889ba75f4a6830 Mon Sep 17 00:00:00 2001
From: Mat Boehlke <mtboehlke@gmail.com>
Date: Mon, 29 Nov 2021 10:05:29 -0600
Subject: [PATCH 047/143] font-sil-charis: update to 6.001

Remove unzip hostdepend: bsdtar works just fine
---
 srcpkgs/font-sil-charis/template | 15 +++++++--------
 1 file changed, 7 insertions(+), 8 deletions(-)

diff --git a/srcpkgs/font-sil-charis/template b/srcpkgs/font-sil-charis/template
index b8b351e36462..5d804c0e6bfe 100644
--- a/srcpkgs/font-sil-charis/template
+++ b/srcpkgs/font-sil-charis/template
@@ -1,21 +1,20 @@
 # Template file for 'font-sil-charis'
 pkgname=font-sil-charis
-version=5.000
-revision=2
+version=6.001
+revision=1
 wrksrc="CharisSIL-${version}"
-hostmakedepends="unzip"
 depends="font-util"
 short_desc="Unicode serif font, similar to Bitstream Charter"
 maintainer="Ivan Sokolov <ivan-p-sokolov@ya.ru>"
 license="OFL-1.1"
 homepage="https://software.sil.org/charis/"
 distfiles="https://software.sil.org/downloads/r/charis/CharisSIL-${version}.zip"
-checksum=5e3e5473b30363008c289cc87e2aa584a0916087a63a3f689defa8e0cee09bfd
+checksum=850df14e9024790e061a406715693ff39489dd071ea583b3258bdeba8384ebe8
 font_dirs="/usr/share/fonts/SIL"
 
 do_install() {
-	vinstall CharisSIL-B.ttf 644 ${font_dirs}
-	vinstall CharisSIL-BI.ttf 644 ${font_dirs}
-	vinstall CharisSIL-I.ttf 644 ${font_dirs}
-	vinstall CharisSIL-R.ttf 644 ${font_dirs}
+	vinstall CharisSIL-Bold.ttf 644 ${font_dirs}
+	vinstall CharisSIL-BoldItalic.ttf 644 ${font_dirs}
+	vinstall CharisSIL-Italic.ttf 644 ${font_dirs}
+	vinstall CharisSIL-Regular.ttf 644 ${font_dirs}
 }

From 9f5c349e57a390e8e1e703561f88e96aa35fb364 Mon Sep 17 00:00:00 2001
From: Gerardo Di iorio <arete74@gmail.com>
Date: Mon, 29 Nov 2021 22:06:04 +0100
Subject: [PATCH 048/143] todoist: update to 0.16.0.

---
 srcpkgs/todoist/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/todoist/template b/srcpkgs/todoist/template
index 49761d228b01..9e96ed98dc5f 100644
--- a/srcpkgs/todoist/template
+++ b/srcpkgs/todoist/template
@@ -1,6 +1,6 @@
 # Template file for 'todoist'
 pkgname=todoist
-version=0.15.0
+version=0.16.0
 revision=1
 build_style=go
 go_import_path="github.com/sachaos/todoist"
@@ -9,7 +9,7 @@ maintainer="Gerardo Di Iorio <arete74@gmail.com>"
 license="MIT"
 homepage="https://github.com/sachaos/todoist"
 distfiles="${homepage}/archive/v${version}.tar.gz"
-checksum=b7ffa14574bd241ab9e21a28f3d40c17b1a12250e89cfbc8ad708cfbfcdd84b3
+checksum=9d5a8f5c6b92d3d6df292f9ae96bec46049b4e4b7a482f7232e4e5b9708dfffa
 
 post_install() {
 	vdoc README.md

From dcde486c4a7f8b6fe489ac0575b6b7cc0b05eb1d Mon Sep 17 00:00:00 2001
From: Gerardo Di iorio <arete74@gmail.com>
Date: Mon, 29 Nov 2021 22:08:08 +0100
Subject: [PATCH 049/143] cpuid: update to 20211129.

---
 srcpkgs/cpuid/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/cpuid/template b/srcpkgs/cpuid/template
index 8f8f26c25920..0b363cdf07ff 100644
--- a/srcpkgs/cpuid/template
+++ b/srcpkgs/cpuid/template
@@ -1,6 +1,6 @@
 # Template file for 'cpuid'
 pkgname=cpuid
-version=20211121
+version=20211129
 revision=1
 archs="i686* x86_64*"
 build_style=gnu-makefile
@@ -10,4 +10,4 @@ maintainer="Gerardo Di Iorio  <arete74@gmail.com>"
 license="GPL-2.0-or-later"
 homepage="http://www.etallen.com/cpuid.html"
 distfiles="http://www.etallen.com/cpuid/cpuid-${version}.src.tar.gz"
-checksum=172f562adf31b15de177b12e6154f67179a7e5ee14d078d72319c0c074e6c01a
+checksum=230772bb88c44732e68a42d2eff43bcff46d893bf4ea6e04151d4cb6e8c88e2f

From 788126825bc8771b878615f152a8ddf9c1171f9f Mon Sep 17 00:00:00 2001
From: Piraty <piraty1@inbox.ru>
Date: Sun, 28 Nov 2021 21:06:05 +0100
Subject: [PATCH 050/143] tor: update to 0.4.6.8.

---
 srcpkgs/tor/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/tor/template b/srcpkgs/tor/template
index 39ee33963862..d6e94e369de1 100644
--- a/srcpkgs/tor/template
+++ b/srcpkgs/tor/template
@@ -1,6 +1,6 @@
 # Template file for 'tor'
 pkgname=tor
-version=0.4.6.7
+version=0.4.6.8
 revision=1
 build_style=gnu-configure
 configure_args="--enable-zstd"
@@ -14,7 +14,7 @@ license="BSD-3-Clause"
 homepage="https://www.torproject.org/"
 changelog="https://gitlab.torproject.org/tpo/core/tor/-/raw/main/ChangeLog"
 distfiles="https://dist.torproject.org/tor-${version}.tar.gz"
-checksum=ff665ce121b2952110bd98b9c8741b5593bf6c01ac09033ad848ed92c2510f9a
+checksum=15ce1a37b4cc175b07761e00acdcfa2c08f0d23d6c3ab9c97c464bd38cc5476a
 
 conf_files="/etc/tor/torrc"
 system_accounts="tor"

From 9ab7e7ac004af80a1002f1f13c2b0a7cd8f54b1e Mon Sep 17 00:00:00 2001
From: wundrweapon <whhacker.dcx@gmail.com>
Date: Mon, 29 Nov 2021 21:23:49 -0500
Subject: [PATCH 051/143] font-firacode: update to 6.

---
 srcpkgs/font-firacode/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/font-firacode/template b/srcpkgs/font-firacode/template
index 73536112a695..35d4a5630c48 100644
--- a/srcpkgs/font-firacode/template
+++ b/srcpkgs/font-firacode/template
@@ -1,7 +1,7 @@
 # Template file for 'font-firacode'
 pkgname=font-firacode
-version=5.2
-revision=2
+version=6
+revision=1
 create_wrksrc=yes
 hostmakedepends="unzip"
 short_desc="FiraCode: monospaced font with programming ligatures"
@@ -10,7 +10,7 @@ license="OFL-1.1"
 homepage="https://github.com/tonsky/FiraCode"
 changelog="https://github.com/tonsky/FiraCode/raw/master/CHANGELOG.md"
 distfiles="https://github.com/tonsky/FiraCode/releases/download/${version}/Fira_Code_v${version}.zip"
-checksum=521a72be00dd22678d248e63f817c0c79c1b6f23a4fbd377eba73d30cdca5efd
+checksum=a4997c2f905fb20a6d814baf7b9bab7df7de574a8e87d6af509685a43291caf1
 font_dirs="/usr/share/fonts/TTF"
 
 do_install() {

From 2a9b7e6b4e4e3c092b50ab3c15775fe60352620d Mon Sep 17 00:00:00 2001
From: Evgeny Ermakov <evgeny.v.ermakov@gmail.com>
Date: Tue, 30 Nov 2021 05:48:58 +1100
Subject: [PATCH 052/143] scrot: update to 1.7.

---
 srcpkgs/scrot/template | 10 ++++++++--
 1 file changed, 8 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/scrot/template b/srcpkgs/scrot/template
index 7565f4303e7e..6c1336c260ef 100644
--- a/srcpkgs/scrot/template
+++ b/srcpkgs/scrot/template
@@ -1,6 +1,6 @@
 # Template file for 'scrot'
 pkgname=scrot
-version=1.6
+version=1.7
 revision=1
 build_style=gnu-configure
 make_install_args="docsdir=/usr/share/doc/scrot"
@@ -11,7 +11,13 @@ maintainer="Frank Steinborn <steinex@nognu.de>"
 license="MIT"
 homepage="https://github.com/resurrecting-open-source-projects/scrot"
 distfiles="https://github.com/resurrecting-open-source-projects/scrot/archive/${version}.tar.gz"
-checksum=5d53df3e86220b8aca21be03a39b542905f2a8a0ccd950fdce7fc48a32c09050
+checksum=e4ff764f93ea98018d46192c35bd34eeb577040ac6e217aa0d83b2a63d88f66b
+
+if [ "$XBPS_TARGET_LIBC" = musl ]; then
+	makedepends+=" musl-legacy-compat"
+else
+	makedepends+=" libbsd-devel"
+fi
 
 pre_configure() {
 	./autogen.sh

From df83fe02223e14ef02a4eacbf85530983212ca62 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Tue, 30 Nov 2021 14:25:44 +0700
Subject: [PATCH 053/143] ca-certificates: fix busybox mktemp compat

Close: #34323
---
 .../ca-certificates/patches/busybox-flags.patch    | 14 ++++++++++++++
 srcpkgs/ca-certificates/template                   |  4 ++--
 2 files changed, 16 insertions(+), 2 deletions(-)
 create mode 100644 srcpkgs/ca-certificates/patches/busybox-flags.patch

diff --git a/srcpkgs/ca-certificates/patches/busybox-flags.patch b/srcpkgs/ca-certificates/patches/busybox-flags.patch
new file mode 100644
index 000000000000..0f109e1b0bc1
--- /dev/null
+++ b/srcpkgs/ca-certificates/patches/busybox-flags.patch
@@ -0,0 +1,14 @@
+diff --git a/sbin/update-ca-certificates b/sbin/update-ca-certificates
+--- a/work/sbin/update-ca-certificates
++++ b/work/sbin/update-ca-certificates
+@@ -81,8 +81,8 @@ trap cleanup 0
+ # Helper files.  (Some of them are not simple arrays because we spawn
+ # subshells later on.)
+ TEMPBUNDLE="${ETCCERTSDIR}/${CERTBUNDLE}.new"
+-ADDED="$(mktemp --tmpdir "ca-certificates.tmp.XXXXXX")"
+-REMOVED="$(mktemp --tmpdir "ca-certificates.tmp.XXXXXX")"
++ADDED="$(mktemp -p "${TMPDIR:-/tmp}" "ca-certificates.tmp.XXXXXX")"
++REMOVED="$(mktemp -p "${TMPDIR:-/tmp}" "ca-certificates.tmp.XXXXXX")"
+ 
+ # Adds a certificate to the list of trusted ones.  This includes a symlink
+ # in /etc/ssl/certs to the certificate file and its inclusion into the
diff --git a/srcpkgs/ca-certificates/template b/srcpkgs/ca-certificates/template
index d328fae1eb72..30b2c68d95db 100644
--- a/srcpkgs/ca-certificates/template
+++ b/srcpkgs/ca-certificates/template
@@ -1,6 +1,6 @@
 # Template file for 'ca-certificates'
 pkgname=ca-certificates
-version=20211016+3.71
+version=20211016+3.72
 revision=1
 _nss_version=${version#*+}
 bootstrap=yes
@@ -16,7 +16,7 @@ homepage="https://wiki.mozilla.org/NSS:Root_certs"
 distfiles="${DEBIAN_SITE}/main/c/${pkgname}/${pkgname}_${version%+*}.tar.xz
  ${MOZILLA_SITE}/security/nss/releases/NSS_${_nss_version//\./_}_RTM/src/nss-${_nss_version}.tar.gz"
 checksum="2ae9b6dc5f40c25d6d7fe55e07b54f12a8967d1955d3b7b2f42ee46266eeef88
- 99acd315d9af35419cda4a6960f00a7d446bd231bd407174a7b07cb3dba0c253"
+ 6ea60a9ff113e493ea2ab25f41ea75a9fbd10af7903f26f703dac8680732d02e"
 
 post_extract() {
 	cp ${FILESDIR}/* $build_wrksrc/mozilla

From c7c2a41772cb2672b143b0c58d87917389d656b5 Mon Sep 17 00:00:00 2001
From: Andrew Benson <abenson+void@gmail.com>
Date: Tue, 30 Nov 2021 07:09:02 -0600
Subject: [PATCH 054/143] python3-rich: update to 10.15.1.

---
 srcpkgs/python3-rich/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-rich/template b/srcpkgs/python3-rich/template
index 79e4226fd0c1..a11c142a2002 100644
--- a/srcpkgs/python3-rich/template
+++ b/srcpkgs/python3-rich/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-rich'
 pkgname=python3-rich
-version=10.14.0
+version=10.15.1
 revision=1
 wrksrc="rich-${version}"
 build_style=python3-module
@@ -13,7 +13,7 @@ maintainer="Andrew Benson <abenson+void@gmail.com>"
 license="MIT"
 homepage="https://github.com/willmcgugan/rich"
 distfiles="${PYPI_SITE}/r/rich/rich-${version}.tar.gz"
-checksum=8bfe4546d56b4131298d3a9e571a0742de342f1593770bd0d4707299f772a0af
+checksum=93d0ea3c35ecfd8703dbe52b76885e224ad8d68c7766c921c726b14b22a57b7d
 
 post_install() {
 	vlicense LICENSE

From aba3c7d26fe65a3b6a8d993f5cde89e3115ca81f Mon Sep 17 00:00:00 2001
From: Duncaen <duncaen@voidlinux.org>
Date: Tue, 30 Nov 2021 13:57:53 +0100
Subject: [PATCH 055/143] harfbuzz: update to 3.1.2.

---
 srcpkgs/harfbuzz/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/harfbuzz/template b/srcpkgs/harfbuzz/template
index e9924e9ed1aa..974779480058 100644
--- a/srcpkgs/harfbuzz/template
+++ b/srcpkgs/harfbuzz/template
@@ -1,6 +1,6 @@
 # Template file for 'harfbuzz'
 pkgname=harfbuzz
-version=2.9.1
+version=3.1.2
 revision=1
 build_style=meson
 build_helper=gir
@@ -14,7 +14,7 @@ license="MIT"
 homepage="http://www.freedesktop.org/wiki/Software/HarfBuzz/"
 changelog="https://github.com/harfbuzz/harfbuzz/raw/main/NEWS"
 distfiles="https://github.com/harfbuzz/harfbuzz/releases/download/${version}/harfbuzz-${version}.tar.xz"
-checksum=0edcc980f526a338452180e701d6aba6323aef457b6686976a7d17ccbddc51cf
+checksum=4056b1541dd8bbd8ec29207fe30e568805c0705515632d7fec53a94399bc7945
 
 libharfbuzz_package() {
 	short_desc+=" - runtime library"

From 8e072f8e75d54ebece8457b22657d54e5ab1ae35 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Tue, 30 Nov 2021 15:53:03 +0100
Subject: [PATCH 056/143] babashka: update to 0.6.7.

---
 srcpkgs/babashka/template | 31 ++++++++++++++++++-------------
 1 file changed, 18 insertions(+), 13 deletions(-)

diff --git a/srcpkgs/babashka/template b/srcpkgs/babashka/template
index 588d3139d6d1..aba66be44069 100644
--- a/srcpkgs/babashka/template
+++ b/srcpkgs/babashka/template
@@ -1,6 +1,6 @@
 # Template file for 'babashka'
 pkgname=babashka
-version=0.6.5
+version=0.6.7
 revision=1
 hostmakedepends="mandrel leiningen git"
 makedepends="zlib-devel"
@@ -9,14 +9,15 @@ short_desc="Native, fast starting Clojure interpreter for scripting"
 maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="EPL-1.0"
 homepage="https://babashka.org/"
-_sci_commit=7896fe1bab824e8e07b198c6eaed1ec465ae3baa
-_babashka_curl_commit=2187f908c033da45978512979c53bb53321120ce
+_sci_commit=f3d2764b8f9fc14026c89e23d94fa2071ededcea
+_babashka_curl_commit=3d3d117ea0f8a143a06e3cace92e4e8b6a5782df
 _babashka_nrepl_commit=eadb3330f0a65e781755d8b328727698f1d41fb0
 _depstar_commit=c419b8c82041855d55593c5b561fc7cea8234712
-_process_commit=4fdf33c0243ff646dfa91c4454844a33e0f025b0
+_process_commit=cb12d2eea240fc1401feb9af2606a0847edfab10
 _pods_commit=f360afa6135b8bd2d384d9ba4582c0de6fdac804
-_deps_clj_commit=422b080c64dedad37979a748377394b2d4de7e7c
-_fs_commit=21eb0654efad0ffbeedfe8319dd1194319b30d29
+_deps_clj_commit=e06a1a450625a11409be0e2e8199415e0d2e51a9
+_fs_commit=6019ec9cb09632fdf84e4bc5879fd47ed57a35eb
+_babashka_core_commit=52a6037bd4b632bffffb04394fb4efd0cdab6b1e
 distfiles="https://github.com/babashka/babashka/archive/refs/tags/v${version}.tar.gz
  https://github.com/borkdude/sci/archive/${_sci_commit}.tar.gz
  https://github.com/babashka/babashka.curl/archive/${_babashka_curl_commit}.tar.gz
@@ -25,22 +26,26 @@ distfiles="https://github.com/babashka/babashka/archive/refs/tags/v${version}.ta
  https://github.com/babashka/process/archive/${_process_commit}.tar.gz
  https://github.com/babashka/pods/archive/${_pods_commit}.tar.gz
  https://github.com/borkdude/deps.clj/archive/${_deps_clj_commit}.tar.gz
- https://github.com/babashka/fs/archive/${_fs_commit}.tar.gz"
-checksum="9053ba3582dbc94e4221eefe4e7f507d0c9e4d90aa5f941fb504f658ed3ceea2
- 9ec8e74253e1a3a5ac1fbb1b1ed2c549a4bb194ffde55829683c11d6a1c67904
- d4efe2c84512c3914d80087a43f9dc8377b4318ab63579959c4488038d6b766b
+ https://github.com/babashka/fs/archive/${_fs_commit}.tar.gz
+ https://github.com/babashka/babashka.core/archive/${_babashka_core_commit}.tar.gz"
+checksum="2ec3ab92626ec42d681bb486e06ce784732401d404dfea32dbe5be23c26b3f5e
+ 89bfee50868795b09551550b5156865623fec8435eea8b9e8f71ae0ffab362eb
+ 45abdaa5e4effd3bcfea777d02844d4634f1f80a592843eca9ec7d3544b7e16d
  916d9cc8c0a3b895a72068b95c6ac985a65d30465a9d556af8acea20aaaacc42
  9d214a10a4f5e4f15b9c80354dae85689a40e941ec3417203354c0dc3ce9457b
- dcb999043dfc807a1ebfae99027b4434e726f647aa52fbd70ed58202d907d39a
+ 510facf66f1b4404de0ab12a1093b85213cf396f5d061728315c95fc527ed96b
  4070395956fc3cb0c22bac6fb4de1ad27130d24916e1915d8a3fe9eb591f6143
- dba354c4637595ed6a24e76914497dcb6f0059b531d8cd3c8c8c23385fff605a
- 2ebe97b7fe0ad349a6a1ff567df2c372571b9a672d81f5f5f83bbf45af708d71"
+ c7ee5cfac6592885342897b3a2a2276385a3c40f0df61beee9c0e84e313b3469
+ 9bb9cb06a1a2a3cd2e9334e9e1082a510474760ed650c98b9650ceca41f4fa42
+ bad285812bcc7de7e0dd905c5df99045d7f92d6e2e191fc2768c06adbaaeb709"
 
 nocross="https://build.voidlinux.org/builders/aarch64_builder/builds/33769/steps/shell_3/logs/stdio"
 
 post_extract() {
 	rmdir -v ${wrksrc}/sci
 	mv ${wrksrc}/../sci-${_sci_commit} ${wrksrc}/sci
+	rmdir -v ${wrksrc}/babashka.core
+	mv ${wrksrc}/../babashka.core-${_babashka_core_commit} ${wrksrc}/babashka.core
 	rmdir -v ${wrksrc}/babashka.curl
 	mv ${wrksrc}/../babashka.curl-${_babashka_curl_commit} ${wrksrc}/babashka.curl
 	rmdir -v ${wrksrc}/babashka.nrepl

From b2bcf65ae92995709316b2783da4fd4c560d3229 Mon Sep 17 00:00:00 2001
From: Duncaen <duncaen@voidlinux.org>
Date: Tue, 30 Nov 2021 15:55:29 +0100
Subject: [PATCH 057/143] Revert "harfbuzz: update to 3.1.2."

This reverts commit 908b075ecb296ec246e5553abefcdb3175fb0d1b.
---
 srcpkgs/harfbuzz/template | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/harfbuzz/template b/srcpkgs/harfbuzz/template
index 974779480058..1764bc6ef8c5 100644
--- a/srcpkgs/harfbuzz/template
+++ b/srcpkgs/harfbuzz/template
@@ -1,7 +1,8 @@
 # Template file for 'harfbuzz'
 pkgname=harfbuzz
-version=3.1.2
-revision=1
+reverts="3.1.2_1"
+version=2.9.1
+revision=2
 build_style=meson
 build_helper=gir
 configure_args="-Dglib=enabled -Dfreetype=enabled -Dcairo=enabled -Dicu=enabled
@@ -14,7 +15,7 @@ license="MIT"
 homepage="http://www.freedesktop.org/wiki/Software/HarfBuzz/"
 changelog="https://github.com/harfbuzz/harfbuzz/raw/main/NEWS"
 distfiles="https://github.com/harfbuzz/harfbuzz/releases/download/${version}/harfbuzz-${version}.tar.xz"
-checksum=4056b1541dd8bbd8ec29207fe30e568805c0705515632d7fec53a94399bc7945
+checksum=0edcc980f526a338452180e701d6aba6323aef457b6686976a7d17ccbddc51cf
 
 libharfbuzz_package() {
 	short_desc+=" - runtime library"

From 3d1ca6bbdaeae6f03867619e6d0dd374f977e605 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 26 Nov 2021 12:01:25 +0700
Subject: [PATCH 058/143] gconf-editor: remove

---
 srcpkgs/gconf-editor/template     | 27 ---------------------------
 srcpkgs/removed-packages/template |  1 +
 2 files changed, 1 insertion(+), 27 deletions(-)
 delete mode 100644 srcpkgs/gconf-editor/template

diff --git a/srcpkgs/gconf-editor/template b/srcpkgs/gconf-editor/template
deleted file mode 100644
index d4d9fa79bd25..000000000000
--- a/srcpkgs/gconf-editor/template
+++ /dev/null
@@ -1,27 +0,0 @@
-# Template file for 'gconf-editor'
-pkgname=gconf-editor
-version=3.0.1
-revision=3
-build_style=gnu-configure
-configure_args="--disable-schemas-install --disable-scrollkeeper
- --with-gconf-schema-file-dir=/usr/share/gconf/schemas"
-hostmakedepends="pkg-config intltool itstool gnome-doc-utils GConf-devel which"
-makedepends="libxml2-devel gtk+3-devel gsettings-desktop-schemas-devel
- hicolor-icon-theme desktop-file-utils gnome-doc-utils GConf-devel"
-depends="gsettings-desktop-schemas>=3.10 hicolor-icon-theme desktop-file-utils"
-short_desc="Graphical editor to maintain the Gnome registry"
-maintainer="Enno Boland <gottox@voidlinux.org>"
-license="GPL-2.0-or-later"
-homepage="http://www.gnome.org"
-distfiles="${GNOME_SITE}/$pkgname/${version%.*}/$pkgname-$version.tar.xz"
-checksum=3064e84967b4b4216f5c7e065cfec8c52019438a590e9ed81366af2770660944
-
-post_patch() {
-	vsed -i -e 's/DATADIRNAME=lib/DATADIRNAME=share/' configure
-}
-
-post_install() {
-	mv ${DESTDIR}/usr/share/gconf/schemas/*.schemas ${wrksrc}
-	gconf-merge-schema ${DESTDIR}/usr/share/gconf/schemas/${pkgname}.schemas \
-		--domain ${pkgname} ${wrksrc}/*.schemas
-}
diff --git a/srcpkgs/removed-packages/template b/srcpkgs/removed-packages/template
index 8b9aa9d8bdff..ef53eba7a92e 100644
--- a/srcpkgs/removed-packages/template
+++ b/srcpkgs/removed-packages/template
@@ -67,6 +67,7 @@ replaces="
  epstopdf<=2.27_3
  fontmatrix<=0.6.0.20171228_2
  fuse-usmb<=20130204_7
+ gconf-editor<=3.0.1_3
  gegl3<=0.3.28_2
  gens-gs<=2.16.7_2
  geoip-data<=20171002_2

From ff96967a3f2a5a6d13718c390d79c8536eeb229d Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 26 Nov 2021 12:16:56 +0700
Subject: [PATCH 059/143] gmpc: not require gnome-doc-utils for check

---
 srcpkgs/gmpc/patches/locale-dir.patch       | 20 +++++++++++++++++++
 srcpkgs/gmpc/patches/no-mallard-check.patch | 22 +++++++++++++++++++++
 srcpkgs/gmpc/template                       |  5 -----
 3 files changed, 42 insertions(+), 5 deletions(-)
 create mode 100644 srcpkgs/gmpc/patches/locale-dir.patch
 create mode 100644 srcpkgs/gmpc/patches/no-mallard-check.patch

diff --git a/srcpkgs/gmpc/patches/locale-dir.patch b/srcpkgs/gmpc/patches/locale-dir.patch
new file mode 100644
index 000000000000..8398823dd765
--- /dev/null
+++ b/srcpkgs/gmpc/patches/locale-dir.patch
@@ -0,0 +1,20 @@
+--- a/configure
++++ b/configure
+@@ -11347,7 +11347,7 @@ fi
+ 
+     ;;
+     *)
+-    DATADIRNAME=lib
++    DATADIRNAME=share
+     ;;
+     esac
+ fi
+@@ -15026,7 +15026,7 @@ fi
+ 	    ;;
+ 	    *)
+ 	    CATOBJEXT=.mo
+-            DATADIRNAME=lib
++            DATADIRNAME=share
+ 	    ;;
+ 	    esac
+ fi
diff --git a/srcpkgs/gmpc/patches/no-mallard-check.patch b/srcpkgs/gmpc/patches/no-mallard-check.patch
new file mode 100644
index 000000000000..f36891f28498
--- /dev/null
+++ b/srcpkgs/gmpc/patches/no-mallard-check.patch
@@ -0,0 +1,22 @@
+--- a/doc/Makefile.am
++++ b/doc/Makefile.am
+@@ -1,7 +1,7 @@
+ man_MANS = gmpc.1 gmpc-remote.1 gmpc-remote-stream.1
+ EXTRA_DIST = $(man_MANS)
+ 
+-SUBDIRS=Mallard
++SUBDIRS=
+ 
+ .PHONY: doc
+ doc: Manual.txt
+--- a/doc/Makefile.in
++++ b/doc/Makefile.in
+@@ -311,7 +311,7 @@ unique_CFLAGS = @unique_CFLAGS@
+ unique_LIBS = @unique_LIBS@
+ man_MANS = gmpc.1 gmpc-remote.1 gmpc-remote-stream.1
+ EXTRA_DIST = $(man_MANS)
+-SUBDIRS = Mallard
++SUBDIRS =
+ all: all-recursive
+ 
+ .SUFFIXES:
diff --git a/srcpkgs/gmpc/template b/srcpkgs/gmpc/template
index 9993e6c49dfa..ec0c03ade913 100644
--- a/srcpkgs/gmpc/template
+++ b/srcpkgs/gmpc/template
@@ -6,7 +6,6 @@ build_style=gnu-configure
 hostmakedepends="pkg-config gob2 intltool vala"
 makedepends="gtk+-devel libSM-devel libmpd-devel libunique1-devel libsoup-devel sqlite-devel"
 depends="xdg-utils hicolor-icon-theme"
-checkdepends="gnome-doc-utils"
 short_desc="Gnome Music Player Client - The true MPD client"
 maintainer="Dave Davenport <qball@gmpclient.org>"
 license="GPL-2.0-or-later"
@@ -16,10 +15,6 @@ checksum=a69414f35396846733632ca9619921d7acda537ffd6d49bd84b444945cb76b2c
 
 LDFLAGS="-lm"
 
-post_patch() {
-	vsed -i -e 's/DATADIRNAME=lib/DATADIRNAME=share/' configure
-}
-
 gmpc-devel_package() {
 	short_desc+=" - development files"
 	depends="gtk+-devel libmpd-devel"

From 76da64cb008111b1591964a864526d37b8c771e0 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 26 Nov 2021 13:03:18 +0700
Subject: [PATCH 060/143] gnac: disable old gnome-help format

---
 srcpkgs/gnac/patches/fix-debug-log.patch      | 29 +++++++++++++++++++
 srcpkgs/gnac/patches/no-gnome-doc-utils.patch | 20 +++++++++++++
 srcpkgs/gnac/patches/no-po-check.patch        |  7 +++++
 srcpkgs/gnac/template                         |  6 ++--
 4 files changed, 59 insertions(+), 3 deletions(-)
 create mode 100644 srcpkgs/gnac/patches/fix-debug-log.patch
 create mode 100644 srcpkgs/gnac/patches/no-gnome-doc-utils.patch
 create mode 100644 srcpkgs/gnac/patches/no-po-check.patch

diff --git a/srcpkgs/gnac/patches/fix-debug-log.patch b/srcpkgs/gnac/patches/fix-debug-log.patch
new file mode 100644
index 000000000000..88fd15de6a56
--- /dev/null
+++ b/srcpkgs/gnac/patches/fix-debug-log.patch
@@ -0,0 +1,29 @@
+--- a/libgnac/libgnac-debug.h
++++ b/libgnac/libgnac-debug.h
+@@ -32,7 +32,7 @@
+ 
+ #if defined(__STDC_VERSION__) && __STDC_VERSION__ >= 199901L
+ #define libgnac_debug(...) \
+-        libgnac_debug_real (__func__, __FILE__, __LINE__, TRUE, __VA_ARGS__)
++        libgnac_debug_real (__func__, __FILE__, __LINE__, __VA_ARGS__)
+ #elif defined(__GNUC__) && __GNUC__ >= 3
+ #define libgnac_debug(...) \
+         libgnac_debug_real (__FUNCTION__, __FILE__, __LINE__, __VA_ARGS__)
+@@ -42,7 +42,7 @@
+ 
+ #if defined(__STDC_VERSION__) && __STDC_VERSION__ >= 199901L
+ #define libgnac_warning(...) \
+-        libgnac_warning_real (__func__, __FILE__, __LINE__, TRUE, __VA_ARGS__)
++        libgnac_warning_real (__func__, __FILE__, __LINE__, __VA_ARGS__)
+ #elif defined(__GNUC__) && __GNUC__ >= 3
+ #define libgnac_warning(...) \
+         libgnac_warning_real (__FUNCTION__, __FILE__, __LINE__, __VA_ARGS__)
+@@ -52,7 +52,7 @@
+ 
+ #if defined(__STDC_VERSION__) && __STDC_VERSION__ >= 199901L
+ #define libgnac_critical(...) \
+-        libgnac_critical_real (__func__, __FILE__, __LINE__, TRUE, __VA_ARGS__)
++        libgnac_critical_real (__func__, __FILE__, __LINE__, __VA_ARGS__)
+ #elif defined(__GNUC__) && __GNUC__ >= 3
+ #define libgnac_critical(...) \
+         libgnac_critical_real (__FUNCTION__, __FILE__, __LINE__, __VA_ARGS__)
diff --git a/srcpkgs/gnac/patches/no-gnome-doc-utils.patch b/srcpkgs/gnac/patches/no-gnome-doc-utils.patch
new file mode 100644
index 000000000000..00f89a338dbc
--- /dev/null
+++ b/srcpkgs/gnac/patches/no-gnome-doc-utils.patch
@@ -0,0 +1,20 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -55,7 +55,7 @@ AM_GLIB_GNU_GETTEXT
+ dnl Check for GSettings macros
+ GLIB_GSETTINGS
+ 
+-GNOME_DOC_INIT([0.17.2])
++GNOME_DOC_INIT([0.17.2],[:],[:])
+ GNOME_DEBUG_CHECK
+ GNOME_COMPILE_WARNINGS([maximum])
+ GNOME_CXX_WARNINGS([yes])
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,6 +1,5 @@
+ SUBDIRS = \
+ 	data \
+-	help \
+ 	libgnac \
+ 	man \
+ 	po \
diff --git a/srcpkgs/gnac/patches/no-po-check.patch b/srcpkgs/gnac/patches/no-po-check.patch
new file mode 100644
index 000000000000..bf1ddb4a9e7d
--- /dev/null
+++ b/srcpkgs/gnac/patches/no-po-check.patch
@@ -0,0 +1,7 @@
+--- a/po/POTFILES.skip
++++ b/po/POTFILES.skip
+@@ -1,3 +1,4 @@
+ # List of source files that should NOT be translated.
+ # Please keep this file sorted alphabetically.
+ data/gnac.desktop.in
++intl/plural.c
diff --git a/srcpkgs/gnac/template b/srcpkgs/gnac/template
index ad01a1e97f91..9fea6a370e87 100644
--- a/srcpkgs/gnac/template
+++ b/srcpkgs/gnac/template
@@ -1,15 +1,15 @@
 # Template file for 'gnac'
 pkgname=gnac
 version=0.2.4.1
-revision=3
+revision=4
 build_style=gnu-configure
 configure_args="--disable-scrollkeeper --disable-schemas-compile"
 hostmakedepends="gnome-common gettext-devel pkg-config intltool libtool
- gnome-doc-utils glib-devel gtk+3-devel gst-plugins-base1-devel
+ glib-devel gtk+3-devel gst-plugins-base1-devel
  autoconf-archive which"
 makedepends="libxml2-devel gtk+3-devel gst-plugins-base1-devel libunique-devel
  libnotify-devel gst-plugins-good1 gst-plugins-bad1 gst-plugins-ugly1
- desktop-file-utils hicolor-icon-theme gnome-doc-utils"
+ desktop-file-utils hicolor-icon-theme"
 depends="gst-plugins-good1 gst-plugins-bad1 gst-plugins-ugly1
  desktop-file-utils hicolor-icon-theme"
 short_desc="Audio conversion program for the Gnome desktop"

From bc710f8842cb677b43dd11b2a9d2c60b17859ab8 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 26 Nov 2021 13:05:33 +0700
Subject: [PATCH 061/143] gnome-doc-utils: remove

---
 srcpkgs/gnome-doc-utils/patches/python3.patch | 521 ------------------
 srcpkgs/gnome-doc-utils/template              |  21 -
 srcpkgs/removed-packages/template             |   1 +
 3 files changed, 1 insertion(+), 542 deletions(-)
 delete mode 100644 srcpkgs/gnome-doc-utils/patches/python3.patch
 delete mode 100644 srcpkgs/gnome-doc-utils/template

diff --git a/srcpkgs/gnome-doc-utils/patches/python3.patch b/srcpkgs/gnome-doc-utils/patches/python3.patch
deleted file mode 100644
index 284e38e775de..000000000000
--- a/srcpkgs/gnome-doc-utils/patches/python3.patch
+++ /dev/null
@@ -1,521 +0,0 @@
-taken from fedora, alpine, gentoo
-diff -U3 -r gnome-doc-utils-0.20.10.orig/xml2po/xml2po/__init__.py gnome-doc-utils-0.20.10/xml2po/xml2po/__init__.py
---- gnome-doc-utils-0.20.10.orig/xml2po/xml2po/__init__.py	2011-08-04 09:36:03.000000000 -0500
-+++ gnome-doc-utils-0.20.10/xml2po/xml2po/__init__.py	2019-09-10 09:30:28.018627919 -0500
-@@ -86,14 +86,14 @@
-                 self.messages.append(t)
-                 if spacepreserve:
-                     self.nowrap[t] = True
--                if t in self.linenos.keys():
-+                if t in list(self.linenos.keys()):
-                     self.linenos[t].append((self.filename, tag, lineno))
-                 else:
-                     self.linenos[t] = [ (self.filename, tag, lineno) ]
-                 if (not self.do_translations) and comment and not t in self.comments:
-                     self.comments[t] = comment
-             else:
--                if t in self.linenos.keys():
-+                if t in list(self.linenos.keys()):
-                     self.linenos[t].append((self.filename, tag, lineno))
-                 else:
-                     self.linenos[t] = [ (self.filename, tag, lineno) ]
-@@ -166,7 +166,7 @@
-         elif node.isText():
-             if node.isBlankNode():
-                 if self.app.options.get('expand_entities') or \
--                  (not (node.prev and not node.prev.isBlankNode() and node.next and not node.next.isBlankNode()) ):
-+                  (not (node.prev and not node.prev.isBlankNode() and node.__next__ and not node.next.isBlankNode()) ):
-                     #print >>sys.stderr, "BLANK"
-                     node.setContent('')
-             else:
-@@ -176,7 +176,7 @@
-             child = node.children
-             while child:
-                 self.normalizeNode(child)
--                child = child.next
-+                child = child.__next__
- 
-     def normalizeString(self, text, spacepreserve = False):
-         """Normalizes string to be used as key for gettext lookup.
-@@ -200,7 +200,7 @@
-             tree = ctxt.doc()
-             newnode = tree.getRootElement()
-         except:
--            print >> sys.stderr, """Error while normalizing string as XML:\n"%s"\n""" % (text)
-+            print("""Error while normalizing string as XML:\n"%s"\n""" % (text), file=sys.stderr)
-             return text
- 
-         self.normalizeNode(newnode)
-@@ -209,7 +209,7 @@
-         child = newnode.children
-         while child:
-             result += child.serialize('utf-8')
--            child = child.next
-+            child = child.__next__
- 
-         result = re.sub('^ ','', result)
-         result = re.sub(' $','', result)
-@@ -235,7 +235,7 @@
-         ctxt.parseDocument()
-         tree = ctxt.doc()
-         if next:
--            newnode = tree.children.next
-+            newnode = tree.children.__next__
-         else:
-             newnode = tree.children
- 
-@@ -243,7 +243,7 @@
-         child = newnode.children
-         while child:
-             result += child.serialize('utf-8')
--            child = child.next
-+            child = child.__next__
-         tree.freeDoc()
-         return result
- 
-@@ -262,7 +262,7 @@
-                         result += child.content.decode('utf-8')
-                 else:
-                     result += self.myAttributeSerialize(child)
--                child = child.next
-+                child = child.__next__
-         else:
-             result = node.serialize('utf-8')
-         return result
-@@ -338,7 +338,7 @@
-                 pass
- 
-             if not newnode:
--                print >> sys.stderr, """Error while parsing translation as XML:\n"%s"\n""" % (text.encode('utf-8'))
-+                print("""Error while parsing translation as XML:\n"%s"\n""" % (text.encode('utf-8')), file=sys.stderr)
-                 return
- 
-             newelem = newnode.getRootElement()
-@@ -346,13 +346,13 @@
-             if newelem and newelem.children:
-                 free = node.children
-                 while free:
--                    next = free.next
-+                    next = free.__next__
-                     free.unlinkNode()
-                     free = next
- 
-                 if node:
-                     copy = newelem.copyNodeList()
--                    next = node.next
-+                    next = node.__next__
-                     node.replaceNode(newelem.copyNodeList())
-                     node.next = next
- 
-@@ -378,7 +378,7 @@
-             if child.type in ['text'] and  child.content.strip()!='':
-                 final = True
-                 break
--            child = child.next
-+            child = child.__next__
- 
-         node.__autofinal__ = final
-         return final
-@@ -457,7 +457,7 @@
-                     outtxt += '<%s>%s</%s>' % (starttag, content, endtag)
-                 else:
-                     outtxt += self.doSerialize(child)
--            child = child.next
-+            child = child.__next__
- 
-         if self.app.operation == 'merge':
-             norm_outtxt = self.normalizeString(outtxt, self.app.isSpacePreserveNode(node))
-@@ -534,7 +534,7 @@
-             outtxt = ''
-             while child:
-                 outtxt += self.doSerialize(child)
--                child = child.next
-+                child = child.__next__
-             return outtxt
- 
- def xml_error_handler(arg, ctxt):
-@@ -577,8 +577,8 @@
-                 raise IOError("Unable to read file '%s'" % xmlfile)
-             try:
-                 doc = XMLDocument(xmlfile, self)
--            except Exception, e:
--                print >> sys.stderr, "Unable to parse XML file '%s': %s" % (xmlfile, str(e))
-+            except Exception as e:
-+                print("Unable to parse XML file '%s': %s" % (xmlfile, str(e)), file=sys.stderr)
-                 sys.exit(1)
-             self.current_mode.preProcessXml(doc.doc, self.msg)
-             doc.generate_messages()
-@@ -590,14 +590,14 @@
-             raise IOError("Unable to read file '%s'" % xmlfile)
-         try:
-             doc = XMLDocument(xmlfile, self)
--        except Exception, e:
--            print >> sys.stderr, str(e)
-+        except Exception as e:
-+            print(str(e), file=sys.stderr)
-             sys.exit(1)
- 
-         try:
-             mfile = open(mofile, "rb")
-         except:
--            print >> sys.stderr, "Can't open MO file '%s'." % (mofile)
-+            print("Can't open MO file '%s'." % (mofile), file=sys.stderr)
-         self.gt = gettext.GNUTranslations(mfile)
-         self.gt.add_fallback(NoneTranslations())
-         # Has preProcessXml use cases for merge?
-@@ -619,16 +619,16 @@
-             raise IOError("Unable to read file '%s'" % xmlfile)
-         try:
-             doc = XMLDocument(xmlfile, self)
--        except Exception, e:
--            print >> sys.stderr, str(e)
-+        except Exception as e:
-+            print(str(e), file=sys.stderr)
-             sys.exit(1)
-         doc.generate_messages()
- 
-         self.msg.translationsFollow()
-         try:
-             doc = XMLDocument(origxml, self)
--        except Exception, e:
--            print >> sys.stderr, str(e)
-+        except Exception as e:
-+            print(str(e), file=sys.stderr)
-             sys.exit(1)
-         doc.generate_messages()
-         self.output_po()
-diff -U3 -r gnome-doc-utils-0.20.10.orig/xml2po/xml2po/modes/docbook.py gnome-doc-utils-0.20.10/xml2po/xml2po/modes/docbook.py
---- gnome-doc-utils-0.20.10.orig/xml2po/xml2po/modes/docbook.py	2011-01-10 10:08:10.000000000 -0600
-+++ gnome-doc-utils-0.20.10/xml2po/xml2po/modes/docbook.py	2019-09-10 09:31:15.199572286 -0500
-@@ -43,7 +43,7 @@
- except ImportError:
-     from md5 import new as md5_new
- 
--from basic import basicXmlMode
-+from .basic import basicXmlMode
- 
- class docbookXmlMode(basicXmlMode):
-     """Class for special handling of DocBook document types.
-@@ -131,7 +131,7 @@
-                     hash = self._md5_for_file(fullpath)
-                 else:
-                     hash = "THIS FILE DOESN'T EXIST"
--                    print >>sys.stderr, "Warning: image file '%s' not found." % fullpath
-+                    print("Warning: image file '%s' not found." % fullpath, file=sys.stderr)
- 
-                 msg.outputMessage("@@image: '%s'; md5=%s" % (attr, hash), node.lineNo(),
-                                   "When image changes, this message will be marked fuzzy or untranslated for you.\n"+
-@@ -198,10 +198,10 @@
- # Perform some tests when ran standalone
- if __name__ == '__main__':
-     test = docbookXmlMode()
--    print "Ignored tags       : " + repr(test.getIgnoredTags())
--    print "Final tags         : " + repr(test.getFinalTags())
--    print "Space-preserve tags: " + repr(test.getSpacePreserveTags())
-+    print("Ignored tags       : " + repr(test.getIgnoredTags()))
-+    print("Final tags         : " + repr(test.getFinalTags()))
-+    print("Space-preserve tags: " + repr(test.getSpacePreserveTags()))
- 
--    print "Credits from string: '%s'" % test.getStringForTranslators()
--    print "Explanation for credits:\n\t'%s'" % test.getCommentForTranslators()
-+    print("Credits from string: '%s'" % test.getStringForTranslators())
-+    print("Explanation for credits:\n\t'%s'" % test.getCommentForTranslators())
- 
-diff -U3 -r gnome-doc-utils-0.20.10.orig/xml2po/xml2po/modes/gs.py gnome-doc-utils-0.20.10/xml2po/xml2po/modes/gs.py
---- gnome-doc-utils-0.20.10.orig/xml2po/xml2po/modes/gs.py	2010-12-13 10:14:07.000000000 -0600
-+++ gnome-doc-utils-0.20.10/xml2po/xml2po/modes/gs.py	2019-09-10 09:31:15.201572284 -0500
-@@ -20,7 +20,7 @@
- # Special case Gnome Summary
- #
- 
--from basic import basicXmlMode
-+from .basic import basicXmlMode
- 
- class gsXmlMode(basicXmlMode):
-     """Abstract class for special handling of document types."""
-diff -U3 -r gnome-doc-utils-0.20.10.orig/xml2po/xml2po/modes/mallard.py gnome-doc-utils-0.20.10/xml2po/xml2po/modes/mallard.py
---- gnome-doc-utils-0.20.10.orig/xml2po/xml2po/modes/mallard.py	2011-01-10 10:08:50.000000000 -0600
-+++ gnome-doc-utils-0.20.10/xml2po/xml2po/modes/mallard.py	2019-09-10 09:31:15.212572271 -0500
-@@ -39,7 +39,7 @@
- except ImportError:
-     from md5 import new as md5_new
- 
--from basic import basicXmlMode
-+from .basic import basicXmlMode
- 
- class mallardXmlMode(basicXmlMode):
-     """Class for special handling of Mallard document types."""
-@@ -112,7 +112,7 @@
-                     hash = self._md5_for_file(fullpath)
-                 else:
-                     hash = "THIS FILE DOESN'T EXIST"
--                    print >>sys.stderr, "Warning: image file '%s' not found." % fullpath
-+                    print("Warning: image file '%s' not found." % fullpath, file=sys.stderr)
-                     
-                 msg.outputMessage("@@image: '%s'; md5=%s" % (attr, hash), node.lineNo(),
-                                   "When image changes, this message will be marked fuzzy or untranslated for you.\n"+
-diff -U3 -r gnome-doc-utils-0.20.10.orig/xml2po/xml2po/modes/ubuntu.py gnome-doc-utils-0.20.10/xml2po/xml2po/modes/ubuntu.py
---- gnome-doc-utils-0.20.10.orig/xml2po/xml2po/modes/ubuntu.py	2010-12-13 10:14:07.000000000 -0600
-+++ gnome-doc-utils-0.20.10/xml2po/xml2po/modes/ubuntu.py	2019-09-10 09:31:15.213572270 -0500
-@@ -2,7 +2,7 @@
- 
- import libxml2
- 
--from docbook import docbookXmlMode
-+from .docbook import docbookXmlMode
- 
- class ubuntuXmlMode (docbookXmlMode):
-     """Special-casing Ubuntu DocBook website documentation."""
-diff -U3 -r gnome-doc-utils-0.20.10.orig/xml2po/xml2po/modes/xhtml.py gnome-doc-utils-0.20.10/xml2po/xml2po/modes/xhtml.py
---- gnome-doc-utils-0.20.10.orig/xml2po/xml2po/modes/xhtml.py	2010-12-13 10:14:07.000000000 -0600
-+++ gnome-doc-utils-0.20.10/xml2po/xml2po/modes/xhtml.py	2019-09-10 09:31:15.214572269 -0500
-@@ -21,7 +21,7 @@
- # This implements special instructions for handling XHTML documents
- # in a better way, particularly to extract some attributes in HTML tags
- 
--from basic import basicXmlMode
-+from .basic import basicXmlMode
- 
- class xhtmlXmlMode(basicXmlMode):
-     """Class for special handling of XHTML document types."""
-diff -U3 -r gnome-doc-utils-0.20.10.orig/xml2po/xml2po/xml2po.py.in gnome-doc-utils-0.20.10/xml2po/xml2po/xml2po.py.in
---- gnome-doc-utils-0.20.10.orig/xml2po/xml2po/xml2po.py.in	2010-12-13 10:14:07.000000000 -0600
-+++ gnome-doc-utils-0.20.10/xml2po/xml2po/xml2po.py.in	2019-09-10 09:30:28.217627684 -0500
-@@ -41,9 +41,9 @@
- if not os.path.exists('/dev/null'): NULL_STRING = 'NUL'
- 
- def usage (with_help = False):
--    print >> sys.stderr, "Usage:  %s [OPTIONS] [XMLFILE]..." % (sys.argv[0])
-+    print("Usage:  %s [OPTIONS] [XMLFILE]..." % (sys.argv[0]), file=sys.stderr)
-     if with_help:
--        print >> sys.stderr, """
-+        print("""
- OPTIONS may be some of:
-     -a    --automatic-tags     Automatically decides if tags are to be considered
-                                  "final" or not
-@@ -72,7 +72,7 @@
-     using -p option for each XML file:
-         %(command)s -p de.po chapter1.xml > chapter1.de.xml
-         %(command)s -p de.po chapter2.xml > chapter2.de.xml
--""" % {'command': sys.argv[0]}
-+""" % {'command': sys.argv[0]}, file=sys.stderr)
- 
- 
- def main(argv):
-@@ -82,7 +82,7 @@
- 
-     name = os.path.join(os.path.dirname(__file__), '..')
-     if os.path.exists(os.path.join(name, 'tests')):
--        print >> sys.stderr, 'Running from source folder, modifying PYTHONPATH'
-+        print('Running from source folder, modifying PYTHONPATH', file=sys.stderr)
-         sys.path.insert(0, name)
- 
-     from xml2po import Main
-@@ -142,14 +142,14 @@
-         elif opt in ('-o', '--output'):
-             output = arg
-         elif opt in ('-v', '--version'):
--            print VERSION
-+            print(VERSION)
-             sys.exit(0)
-         elif opt in ('-h', '--help'):
-             usage(True)
-             sys.exit(0)
- 
-     if operation == 'update' and output != "-":
--        print >> sys.stderr, "Option '-o' is not yet supported when updating translations directly. Ignoring this option."
-+        print("Option '-o' is not yet supported when updating translations directly. Ignoring this option.", file=sys.stderr)
- 
-     # Treat remaining arguments as XML files
-     filenames = []
-@@ -159,16 +159,16 @@
-     try:
-         xml2po_main = Main(default_mode, operation, output, options)
-     except IOError:
--        print >> sys.stderr, "Error: cannot open file %s for writing." % (output)
-+        print("Error: cannot open file %s for writing." % (output), file=sys.stderr)
-         sys.exit(5)
- 
-     if operation == 'merge':
-         if len(filenames) > 1:
--            print  >> sys.stderr, "Error: You can merge translations with only one XML file at a time."
-+            print("Error: You can merge translations with only one XML file at a time.", file=sys.stderr)
-             sys.exit(2)
- 
-         if not mofile:
--            print >> sys.stderr, "Error: You must specify MO file when merging translations."
-+            print("Error: You must specify MO file when merging translations.", file=sys.stderr)
-             sys.exit(3)
- 
-         xml2po_main.merge(mofile, filenames[0])
---- gnome-doc-utils-0.20.10/xml2po/xml2po/__init__.py.orig	2019-09-10 09:34:42.110328324 -0500
-+++ gnome-doc-utils-0.20.10/xml2po/xml2po/__init__.py	2019-09-10 09:34:44.170325899 -0500
-@@ -166,7 +166,7 @@
-         elif node.isText():
-             if node.isBlankNode():
-                 if self.app.options.get('expand_entities') or \
--                  (not (node.prev and not node.prev.isBlankNode() and node.__next__ and not node.next.isBlankNode()) ):
-+                  (not (node.prev and not node.prev.isBlankNode() and node.next and not node.next.isBlankNode()) ):
-                     #print >>sys.stderr, "BLANK"
-                     node.setContent('')
-             else:
-@@ -176,7 +176,7 @@
-             child = node.children
-             while child:
-                 self.normalizeNode(child)
--                child = child.__next__
-+                child = child.next
- 
-     def normalizeString(self, text, spacepreserve = False):
-         """Normalizes string to be used as key for gettext lookup.
-@@ -209,7 +209,7 @@
-         child = newnode.children
-         while child:
-             result += child.serialize('utf-8')
--            child = child.__next__
-+            child = child.next
- 
-         result = re.sub('^ ','', result)
-         result = re.sub(' $','', result)
-@@ -235,7 +235,7 @@
-         ctxt.parseDocument()
-         tree = ctxt.doc()
-         if next:
--            newnode = tree.children.__next__
-+            newnode = tree.children.next
-         else:
-             newnode = tree.children
- 
-@@ -243,7 +243,7 @@
-         child = newnode.children
-         while child:
-             result += child.serialize('utf-8')
--            child = child.__next__
-+            child = child.next
-         tree.freeDoc()
-         return result
- 
-@@ -262,7 +262,7 @@
-                         result += child.content.decode('utf-8')
-                 else:
-                     result += self.myAttributeSerialize(child)
--                child = child.__next__
-+                child = child.next
-         else:
-             result = node.serialize('utf-8')
-         return result
-@@ -346,13 +346,13 @@
-             if newelem and newelem.children:
-                 free = node.children
-                 while free:
--                    next = free.__next__
-+                    next = free.next
-                     free.unlinkNode()
-                     free = next
- 
-                 if node:
-                     copy = newelem.copyNodeList()
--                    next = node.__next__
-+                    next = node.next
-                     node.replaceNode(newelem.copyNodeList())
-                     node.next = next
- 
-@@ -378,7 +378,7 @@
-             if child.type in ['text'] and  child.content.strip()!='':
-                 final = True
-                 break
--            child = child.__next__
-+            child = child.next
- 
-         node.__autofinal__ = final
-         return final
-@@ -457,7 +457,7 @@
-                     outtxt += '<%s>%s</%s>' % (starttag, content, endtag)
-                 else:
-                     outtxt += self.doSerialize(child)
--            child = child.__next__
-+            child = child.next
- 
-         if self.app.operation == 'merge':
-             norm_outtxt = self.normalizeString(outtxt, self.app.isSpacePreserveNode(node))
-@@ -534,7 +534,7 @@
-             outtxt = ''
-             while child:
-                 outtxt += self.doSerialize(child)
--                child = child.__next__
-+                child = child.next
-             return outtxt
- 
- def xml_error_handler(arg, ctxt):
---- gnome-doc-utils-0.20.10/xml2po/xml2po/__init__.py.orig	2019-09-10 09:39:57.733974912 -0500
-+++ gnome-doc-utils-0.20.10/xml2po/xml2po/__init__.py	2019-09-10 09:40:24.761946962 -0500
-@@ -326,7 +326,7 @@
-                 pass
- 
-             content = '<%s>%s</%s>' % (starttag, text, endtag)
--            tmp = tmp + content.encode('utf-8')
-+            tmp = tmp + content
- 
-             newnode = None
-             try:
-@@ -663,7 +663,7 @@
-         if not text or text.strip() == '':
-             return text
-         if self.gt:
--            res = self.gt.ugettext(text.decode('utf-8'))
-+            res = self.gt.gettext(text)
-             return res
- 
-         return text
---- gnome-doc-utils-0.20.10/xml2po/xml2po/__init__.py.orig	2019-09-10 09:41:23.853885851 -0500
-+++ gnome-doc-utils-0.20.10/xml2po/xml2po/__init__.py	2019-09-10 09:44:23.580699979 -0500
-@@ -352,9 +352,10 @@
- 
-                 if node:
-                     copy = newelem.copyNodeList()
--                    next = node.next
-+                    #next = node.next
-                     node.replaceNode(newelem.copyNodeList())
--                    node.next = next
-+                    #print(type(next))
-+                    #node.next = next
- 
-             else:
-                 # In practice, this happens with tags such as "<para>    </para>" (only whitespace in between)
-@@ -470,7 +471,7 @@
- 
-         worth = self.worthOutputting(node)
-         if not translation:
--            translation = outtxt.decode('utf-8')
-+            translation = outtxt
-             if worth and self.app.options.get('mark_untranslated'):
-                 node.setLang('C')
- 
---- gnome-doc-utils-0.20.10/xml2po/xml2po/modes/docbook.py.orig	2019-09-10 09:46:15.409584334 -0500
-+++ gnome-doc-utils-0.20.10/xml2po/xml2po/modes/docbook.py	2019-09-10 09:46:30.164569075 -0500
-@@ -184,7 +184,7 @@
-                     else:
-                         ai.addChild(copy)
-                     if match.group(3):
--                        copy.newChild(None, "year", match.group(3).encode('utf-8'))
-+                        copy.newChild(None, "year", match.group(3))
-                     if match.group(1) and match.group(2):
-                         holder = match.group(1)+"(%s)" % match.group(2)
-                     elif match.group(1):
-@@ -193,7 +193,7 @@
-                         holder = match.group(2)
-                     else:
-                         holder = "???"
--                    copy.newChild(None, "holder", holder.encode('utf-8'))
-+                    copy.newChild(None, "holder", holder)
- 
- # Perform some tests when ran standalone
- if __name__ == '__main__':
---- gnome-doc-utils-0.20.10/xml2po/xml2po/xml2po.py.in~	2019-09-10 09:50:34.000000000 -0500
-+++ gnome-doc-utils-0.20.10/xml2po/xml2po/xml2po.py.in	2019-09-10 09:50:45.114305443 -0500
-@@ -1,4 +1,4 @@
--#!/usr/bin/python -u
-+#!/usr/bin/python3 -u
- # -*- encoding: utf-8 -*-
- # Copyright (c) 2004, 2005, 2006 Danilo Šegan <danilo@gnome.org>.
- # Copyright (c) 2009 Claude Paroz <claude@2xlibre.net>.
diff --git a/srcpkgs/gnome-doc-utils/template b/srcpkgs/gnome-doc-utils/template
deleted file mode 100644
index f63c6106f6c1..000000000000
--- a/srcpkgs/gnome-doc-utils/template
+++ /dev/null
@@ -1,21 +0,0 @@
-# Template file for 'gnome-doc-utils'
-pkgname=gnome-doc-utils
-version=0.20.10
-revision=9
-build_style=gnu-configure
-configure_args="--disable-scrollkeeper"
-hostmakedepends="pkg-config intltool python3 libxml2-python3 libxslt
- gsettings-desktop-schemas"
-makedepends="libxslt-devel docbook-xml docbook-xsl rarian python3
- libxml2-python3 libxslt"
-depends="libxslt docbook-xml docbook-xsl rarian python3 libxml2-python3"
-short_desc="Documentation utilities for GNOME"
-maintainer="Orphaned <orphan@voidlinux.org>"
-license="GPL-2.0-or-later, LGPL-2.1-or-later"
-homepage="https://wiki.gnome.org/Projects/GnomeDocUtils"
-distfiles="${GNOME_SITE}/${pkgname}/0.20/${pkgname}-${version}.tar.xz"
-checksum=cb0639ffa9550b6ddf3b62f3b1add92fb92ab4690d351f2353cffe668be8c4a6
-
-post_patch() {
-	vsed -i -e 's/DATADIRNAME=lib/DATADIRNAME=share/' configure
-}
diff --git a/srcpkgs/removed-packages/template b/srcpkgs/removed-packages/template
index ef53eba7a92e..2b16ae44131f 100644
--- a/srcpkgs/removed-packages/template
+++ b/srcpkgs/removed-packages/template
@@ -74,6 +74,7 @@ replaces="
  gespeaker<=0.8.6_3
  gksu<=2.0.2_4
  glibmm-doc<=2.64.2_2
+ gnome-doc-utils<=0.20.10_9
  gnome-getting-started-docs<=3.38.1_1
  gnome-shell-mousewheel-zoom<=0.8.0_2
  gnome-twitch<=0.4.2_1

From 10aca3db86ce1782bd2a887a5d424dcd9a09a042 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Wed, 1 Dec 2021 15:04:30 +0100
Subject: [PATCH 062/143] linux5.15: update to 5.15.6.

---
 srcpkgs/linux5.15/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/linux5.15/template b/srcpkgs/linux5.15/template
index 02de9dab5756..484f473b5ba8 100644
--- a/srcpkgs/linux5.15/template
+++ b/srcpkgs/linux5.15/template
@@ -1,6 +1,6 @@
 # Template file for 'linux5.15'
 pkgname=linux5.15
-version=5.15.5
+version=5.15.6
 revision=1
 wrksrc="linux-${version%.*}"
 short_desc="Linux kernel and modules (${version%.*} series)"
@@ -10,7 +10,7 @@ homepage="https://www.kernel.org"
 distfiles="https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-${version%.*}.tar.xz
  https://cdn.kernel.org/pub/linux/kernel/v5.x/patch-${version}.xz"
 checksum="57b2cf6991910e3b67a1b3490022e8a0674b6965c74c12da1e99d138d1991ee8
- 8fdc0ef34a877379bcb9b617006edafba66f9213fc2c1df7451b578ae33b5496"
+ 23f5753121e2f18ef757449f94728d18ba70a20728dd217a53d4fa0a1cde621e"
 skip_extraction="patch-${version}.xz"
 python_version=3
 

From de8f201a090888d10c7c649f056cb2d92f05a894 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Wed, 1 Dec 2021 15:05:25 +0100
Subject: [PATCH 063/143] linux5.10: update to 5.10.83.

---
 srcpkgs/linux5.10/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/linux5.10/template b/srcpkgs/linux5.10/template
index 295165a43440..422c10d16ba8 100644
--- a/srcpkgs/linux5.10/template
+++ b/srcpkgs/linux5.10/template
@@ -1,6 +1,6 @@
 # Template file for 'linux5.10'
 pkgname=linux5.10
-version=5.10.82
+version=5.10.83
 revision=1
 wrksrc="linux-${version}"
 short_desc="Linux kernel and modules (${version%.*} series)"
@@ -8,7 +8,7 @@ maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="GPL-2.0-only"
 homepage="https://www.kernel.org"
 distfiles="https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-${version}.tar.xz"
-checksum=d66f7c7eed02f84ae550b3c91a26c70eea13682a6d672432f07bce66ff8ce350
+checksum=ef259a43f33ddb56001283f4f4e50af29b8a48fa066aed7371a90ebf38c29b70
 python_version=3
 
 # XXX Restrict archs until a proper <arch>-dotconfig is available in FILESDIR.

From d076f5224c107390c463d79410af2921a7c1b8e7 Mon Sep 17 00:00:00 2001
From: Duncaen <duncaen@voidlinux.org>
Date: Wed, 1 Dec 2021 17:25:33 +0100
Subject: [PATCH 064/143] yt-dlp: add missing python3 dependency

---
 srcpkgs/yt-dlp/template | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/srcpkgs/yt-dlp/template b/srcpkgs/yt-dlp/template
index b142e21ddba6..9432641a5e73 100644
--- a/srcpkgs/yt-dlp/template
+++ b/srcpkgs/yt-dlp/template
@@ -1,11 +1,12 @@
 # Template file for 'yt-dlp'
 pkgname=yt-dlp
 version=2021.11.10.1
-revision=1
+revision=2
 wrksrc="$pkgname"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 checkdepends="python3-pytest flake8 python3-nose"
+depends="python3"
 short_desc="CLI program to download videos from YouTube and other sites"
 maintainer="Michal Vasilek <michal@vasilek.cz>"
 license="Unlicense"

From 91671636c92fdf2a7b432b16b87412dc2dd6e0ae Mon Sep 17 00:00:00 2001
From: mobinmob <mobinmob@disroot.org>
Date: Tue, 30 Nov 2021 19:36:35 +0100
Subject: [PATCH 065/143] skype: update to 8.79.0.92.

---
 srcpkgs/skype/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/skype/template b/srcpkgs/skype/template
index a09223ab1b54..c018a5e5031d 100644
--- a/srcpkgs/skype/template
+++ b/srcpkgs/skype/template
@@ -1,7 +1,7 @@
 # Template file for 'skype'
 # This just repackages the rpm package.
 pkgname=skype
-version=8.78.0.161
+version=8.79.0.92
 revision=1
 archs="x86_64"
 create_wrksrc=yes
@@ -12,7 +12,7 @@ maintainer="mobinmob <mobinmob@disroot.org>"
 license="custom:skype-servicesagreement" # no vlicense
 homepage="https://www.skype.com"
 distfiles="https://repo.skype.com/rpm/stable/skypeforlinux_${version}-1.x86_64.rpm"
-checksum=db6a9aafa028c16f2f789e3d496adb465f1b6476f88c384752d95130d6af72a1
+checksum=93b3cfd8fc403fb7b4707579a2f4b068ed7077c257179b7b401612d60b41c8f7
 repository="nonfree"
 nostrip="yes"
 

From f553e311f82a605bbb14d00bd58bf5570e73fceb Mon Sep 17 00:00:00 2001
From: Andrew Benson <abenson+void@gmail.com>
Date: Wed, 1 Dec 2021 15:26:38 -0600
Subject: [PATCH 066/143] wgetpaste: update to 2.32.

---
 srcpkgs/wgetpaste/template | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/wgetpaste/template b/srcpkgs/wgetpaste/template
index 1688736a76b4..c91532415d78 100644
--- a/srcpkgs/wgetpaste/template
+++ b/srcpkgs/wgetpaste/template
@@ -1,17 +1,18 @@
 # Template file for 'wgetpaste'
 pkgname=wgetpaste
-version=2.30
+version=2.32
 revision=1
 depends="bash wget"
 short_desc="Script that automates pasting to a number of pastebin services"
 maintainer="Orphaned <orphan@voidlinux.org>"
-license="Public Domain"
+license="MIT"
 homepage="http://wgetpaste.zlin.dk/"
-distfiles="http://wgetpaste.zlin.dk/${pkgname}-${version}.tar.bz2"
-checksum=e3ec35f1ff49f2204864e3b4d784f6c032cdddb62cadf69263900c67a4896592
+distfiles="https://github.com/zlin/wgetpaste/releases/download/${version}/wgetpaste-${version}.tar.xz"
+checksum=621dbafbc7bcf5438f11447a325d8974069e3df03ef0c8bb2a2cc3de2c0cdb13
 
 do_install() {
 	vbin ${pkgname}
 	vinstall _${pkgname} 644 usr/share/zsh/site-functions
 	vsconf ${FILESDIR}/${pkgname}.example
+	vlicense LICENSE
 }

From 74e95a4d1b5cf896c472710031dfe5658f9beaad Mon Sep 17 00:00:00 2001
From: Omar Zeghouani <omarzeghouanii@gmail.com>
Date: Wed, 1 Dec 2021 23:07:30 +0000
Subject: [PATCH 067/143] i3status-rust: update to 0.20.7.

---
 srcpkgs/i3status-rust/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/i3status-rust/template b/srcpkgs/i3status-rust/template
index 36178f3938bc..d58ecb206a22 100644
--- a/srcpkgs/i3status-rust/template
+++ b/srcpkgs/i3status-rust/template
@@ -1,6 +1,6 @@
 # Template file for 'i3status-rust'
 pkgname=i3status-rust
-version=0.20.6
+version=0.20.7
 revision=1
 build_style=cargo
 make_check_args="--bins"
@@ -12,7 +12,7 @@ license="GPL-3.0-only"
 homepage="https://github.com/greshake/i3status-rust"
 changelog="https://raw.githubusercontent.com/greshake/i3status-rust/master/NEWS.md"
 distfiles="https://github.com/greshake/i3status-rust/archive/v${version}.tar.gz"
-checksum=a8b1257b09b73add3969c8bff2a4c77142164449ae3fea37a050ee95cc138b95
+checksum=995efe21ecf03e532cff9140cab1d4de9a35f91204d9e9edf0bfe3a22fedf5a0
 
 post_install() {
 	vmkdir usr/share/i3status-rust

From 2e641f575432986a90bdc782ce7ccbabf54e598f Mon Sep 17 00:00:00 2001
From: bugcrazy <39757967+bugcrazy@users.noreply.github.com>
Date: Wed, 1 Dec 2021 14:46:40 -0300
Subject: [PATCH 068/143] oil: update to 0.9.5

---
 srcpkgs/oil/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/oil/template b/srcpkgs/oil/template
index af1eb57e8d1c..9af2cc8e5435 100644
--- a/srcpkgs/oil/template
+++ b/srcpkgs/oil/template
@@ -1,6 +1,6 @@
 # Template file for 'oil'
 pkgname=oil
-version=0.9.4
+version=0.9.5
 revision=1
 build_style=configure
 configure_args="--prefix=/usr $(vopt_with readline)"
@@ -11,7 +11,7 @@ maintainer="MarcoAPC <marcoaureliopc@gmail.com>"
 license="Apache-2.0"
 homepage="https://www.oilshell.org"
 distfiles="${homepage}/download/${pkgname}-${version}.tar.xz"
-checksum=fac61bcd6b68c0bbf2e386aa84b107f26518527d4326bf473a02aadd85e53d02
+checksum=d89d8c081c8bc536dfc7b437b965a265c07e24cf5142ff26b21b4cc4a3139e32
 register_shell="/usr/bin/osh"
 nocross="Build systems gets confused with host and cross toolchains/headers"
 nostrip=yes

From 32c88a86d8abc584034dfb32a58789bb6ff923a6 Mon Sep 17 00:00:00 2001
From: Anton Afanasyev <1157248+2asoft@users.noreply.github.com>
Date: Tue, 30 Nov 2021 23:34:20 -0800
Subject: [PATCH 069/143] intellij-idea-ultimate-edition: update to 2021.3.

---
 srcpkgs/intellij-idea-ultimate-edition/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/intellij-idea-ultimate-edition/template b/srcpkgs/intellij-idea-ultimate-edition/template
index e3b32fea16d8..20f99d94125f 100644
--- a/srcpkgs/intellij-idea-ultimate-edition/template
+++ b/srcpkgs/intellij-idea-ultimate-edition/template
@@ -1,6 +1,6 @@
 # Template file for 'intellij-idea-ultimate-edition'
 pkgname=intellij-idea-ultimate-edition
-version=2021.2.3
+version=2021.3
 revision=1
 archs="i686 x86_64"
 create_wrksrc="true"
@@ -11,7 +11,7 @@ license="custom:Commercial"
 homepage="https://www.jetbrains.com/idea"
 _filename="ideaIU-${version}-no-jbr.tar.gz"
 distfiles="https://download.jetbrains.com/idea/${_filename}"
-checksum=0d879d4b16f096b81f401e0ab76a8b565d8142c632f9667cdb7fe5e6bd9813b4
+checksum=0b46ebb2381bd587bbec9d15ff78f11380bcf2654c0716c0caf747550ee73c66
 repository=nonfree
 restricted=yes
 nopie=yes

From 4c5cd387721c69f58ec17eb1b6577f7b768b0831 Mon Sep 17 00:00:00 2001
From: Anton Afanasyev <1157248+2asoft@users.noreply.github.com>
Date: Tue, 30 Nov 2021 23:28:45 -0800
Subject: [PATCH 070/143] jetbrains-jdk-bin: update to 11.0.13b1504.49.

---
 srcpkgs/jetbrains-jdk-bin/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/jetbrains-jdk-bin/template b/srcpkgs/jetbrains-jdk-bin/template
index 7114636c6562..f6b26790ad82 100644
--- a/srcpkgs/jetbrains-jdk-bin/template
+++ b/srcpkgs/jetbrains-jdk-bin/template
@@ -1,6 +1,6 @@
 # Template file for 'jetbrains-jdk-bin'
 pkgname=jetbrains-jdk-bin
-version=11.0.12b1504.40
+version=11.0.13b1504.49
 revision=1
 archs="x86_64"
 wrksrc="jbr"
@@ -11,7 +11,7 @@ homepage="https://github.com/JetBrains/JetBrainsRuntime"
 _jdk_ver=${version%b*}
 _jdk_build=${version#*b}
 distfiles="https://cache-redirector.jetbrains.com/intellij-jbr/jbr_jcef-${_jdk_ver//\./_}-linux-x64-b${_jdk_build}.tar.gz"
-checksum=56646f634eafbe85d177e40267f52d83a4bbfcb2bd359b97282bca54812e0784
+checksum=6e84df3c86adc9ec8d63f1151ffbe2081b2c10eb04ff40e1cb86d04b20c5d36e
 # This JDK appears to link to libs that do not exist, but functions well even in their absence.
 # Best guess is that they are optional. ¯\_(ツ)_/¯
 noverifyrdeps=yes

From ea78936a80e903b9c667756434514a490ef76f0f Mon Sep 17 00:00:00 2001
From: Joel Beckmeyer <joel@beckmeyer.us>
Date: Tue, 30 Nov 2021 09:52:30 -0500
Subject: [PATCH 071/143] python3-frozendict: update to 2.1.1.

---
 srcpkgs/python3-frozendict/template | 15 +++------------
 1 file changed, 3 insertions(+), 12 deletions(-)

diff --git a/srcpkgs/python3-frozendict/template b/srcpkgs/python3-frozendict/template
index cb161120a342..f6e3b6661395 100644
--- a/srcpkgs/python3-frozendict/template
+++ b/srcpkgs/python3-frozendict/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-frozendict'
 pkgname=python3-frozendict
-version=2.1.0
+version=2.1.1
 revision=1
 wrksrc="frozendict-${version}"
 build_style=python3-module
@@ -12,17 +12,8 @@ maintainer="Joel Beckmeyer <joel@beckmeyer.us>"
 license="LGPL-3.0-only"
 homepage="https://github.com/Marco-Sulla/python-frozendict"
 distfiles="${PYPI_SITE}/f/frozendict/frozendict-${version}.tar.gz"
-checksum=0189168749ddea8601afd648146c502533f93ae33840eb76cd71f694742623cd
+checksum=655b879217dd445a2023e16154cc231febef802b5c812d5c2e822280ad69e1dc
 
 do_check() {
-	# skip tests that are failing when using C
-	# extension due to difference between pure py and
-	# C extension
-	PYTHONPATH="$(cd build/lib* && pwd)" pytest3 \
-	 --deselect=test/test_coold.py::test_repr \
-	 --deselect=test/test_coold.py::test_str \
-	 --deselect=test/test_coold.py::test_format \
-	 --deselect=test/test_frozendict_c.py::test_repr \
-	 --deselect=test/test_frozendict_c.py::test_str \
-	 --deselect=test/test_frozendict_c.py::test_format
+	PYTHONPATH="$(cd build/lib* && pwd)" pytest3
 }

From e9bec51f6788f19435250246b59fb3a016dd93be Mon Sep 17 00:00:00 2001
From: Joel Beckmeyer <joel@beckmeyer.us>
Date: Tue, 30 Nov 2021 10:00:42 -0500
Subject: [PATCH 072/143] python3-phonenumbers: update to 8.12.38.

---
 srcpkgs/python3-phonenumbers/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-phonenumbers/template b/srcpkgs/python3-phonenumbers/template
index 70699dac90eb..29e82870d9a4 100644
--- a/srcpkgs/python3-phonenumbers/template
+++ b/srcpkgs/python3-phonenumbers/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-phonenumbers'
 pkgname=python3-phonenumbers
-version=8.12.37
+version=8.12.38
 revision=1
 wrksrc="phonenumbers-${version}"
 build_style=python3-module
@@ -12,4 +12,4 @@ license="Apache-2.0"
 homepage="https://github.com/daviddrysdale/python-phonenumbers"
 changelog="https://raw.githubusercontent.com/daviddrysdale/python-phonenumbers/dev/python/HISTORY.md"
 distfiles="${PYPI_SITE}/p/phonenumbers/phonenumbers-${version}.tar.gz"
-checksum=dbc560992844a059f56c7c0c6a587904e65d956740bbfb7e39589980bc9055b8
+checksum=3cda1d1cea9a6801babf825e6c0f6a9776ea6d8a68b81b256178f8e5aa813344

From b9e19f8e3fc9d70b1f595db6034644195e42d1b9 Mon Sep 17 00:00:00 2001
From: Joel Beckmeyer <joel@beckmeyer.us>
Date: Tue, 30 Nov 2021 09:55:55 -0500
Subject: [PATCH 073/143] synapse: update to 1.48.0.

---
 srcpkgs/synapse/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/synapse/template b/srcpkgs/synapse/template
index 20c4a4cc9970..bd5f529503e5 100644
--- a/srcpkgs/synapse/template
+++ b/srcpkgs/synapse/template
@@ -1,6 +1,6 @@
 # Template file for 'synapse'
 pkgname=synapse
-version=1.47.1
+version=1.48.0
 revision=1
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -19,7 +19,7 @@ license="Apache-2.0"
 homepage="https://github.com/matrix-org/synapse"
 changelog="https://raw.githubusercontent.com/matrix-org/synapse/develop/CHANGES.md"
 distfiles="https://github.com/matrix-org/synapse/archive/v${version}.tar.gz"
-checksum=cc385b6cfeba671bba800c2557ad39063bdd53f70dfb3781c85df7af6f5d064c
+checksum=182facc856f8d0c0d2d0dd4105fae4f851297167c0ee95c202a3aad9ed86c486
 
 system_accounts="synapse"
 synapse_homedir="/var/lib/synapse"

From 1b054aca214d0f927e2c9602fef574fedc2608a0 Mon Sep 17 00:00:00 2001
From: Clyhtsuriva <aimeric@adjutor.xyz>
Date: Tue, 30 Nov 2021 12:51:38 +0100
Subject: [PATCH 074/143] ddpt: update to 0.97

---
 srcpkgs/ddpt/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/ddpt/template b/srcpkgs/ddpt/template
index a647dfdc9a81..cbb5c53e0aa8 100644
--- a/srcpkgs/ddpt/template
+++ b/srcpkgs/ddpt/template
@@ -1,6 +1,6 @@
 # Template file for 'ddpt'
 pkgname=ddpt
-version=0.96
+version=0.97
 revision=1
 build_style=gnu-configure
 makedepends="sg3_utils-devel"
@@ -9,7 +9,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="BSD-3-Clause"
 homepage="http://sg.danny.cz/sg/ddpt.html"
 distfiles="http://sg.danny.cz/sg/p/${pkgname}-${version}.tgz"
-checksum=8f231342af7458fe592496d5e8ff4e9a22313b6e0bbc5be9c588ed392d75e1f4
+checksum=e340a529aeef6a107b0c24c64873da590f5284557faffdf57a0f9dc48807233d
 
 post_install() {
 	vlicense COPYING

From f1cecac8b1885102369527c343f98c0309ee4e81 Mon Sep 17 00:00:00 2001
From: Clyhtsuriva <aimeric@adjutor.xyz>
Date: Tue, 30 Nov 2021 12:25:35 +0100
Subject: [PATCH 075/143] chuck: update to 1.4.1.0

---
 srcpkgs/chuck/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/chuck/template b/srcpkgs/chuck/template
index acf5648af53b..9c6c8be9364a 100644
--- a/srcpkgs/chuck/template
+++ b/srcpkgs/chuck/template
@@ -1,6 +1,6 @@
 # Template file for 'chuck'
 pkgname=chuck
-version=1.4.0.1
+version=1.4.1.0
 revision=1
 build_wrksrc=src
 build_style=gnu-makefile
@@ -14,7 +14,7 @@ license="GPL-2.0-or-later"
 homepage="http://chuck.cs.princeton.edu"
 changelog="https://chuck.cs.princeton.edu/release/VERSIONS"
 distfiles="http://chuck.cs.princeton.edu/release/files/$pkgname-$version.tgz"
-checksum=11a20c34b385e132bf43d5ae6a562c652f631828cc6b1562a4c029bc9a850ed4
+checksum=74bf99ad515e3113c55b833152936fad02a3cf006a54105ff11777c473194928
 
 
 post_extract() {

From 706a84dcd30688bd198137e6bf14b1dedf5d01e8 Mon Sep 17 00:00:00 2001
From: jgart <jgart@dismail.de>
Date: Mon, 29 Nov 2021 23:00:26 -0500
Subject: [PATCH 076/143] chicken: update to 5.3.0.

---
 srcpkgs/chicken/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/chicken/template b/srcpkgs/chicken/template
index 7da68b4a0468..79fdc41fbfb6 100644
--- a/srcpkgs/chicken/template
+++ b/srcpkgs/chicken/template
@@ -1,6 +1,6 @@
 # Template file for 'chicken'
 pkgname=chicken
-version=5.2.0
+version=5.3.0
 revision=1
 short_desc="Practical and portable Scheme system"
 maintainer="Orphaned <orphan@voidlinux.org>"
@@ -8,7 +8,7 @@ license="BSD-3-Clause"
 homepage="http://www.call-cc.org"
 changelog="https://code.call-cc.org/releases/$version/NEWS"
 distfiles="http://code.call-cc.org/releases/$version/$pkgname-$version.tar.gz"
-checksum=819149c8ce7303a9b381d3fdc1d5765c5f9ac4dee6f627d1652f47966a8780fa
+checksum=c3ad99d8f9e17ed810912ef981ac3b0c2e2f46fb0ecc033b5c3b6dca1bdb0d76
 
 do_configure() {
 	make -B -f Makefile.linux chicken-defaults.h PREFIX=/usr

From 7554cffb83c690806cce8bfaa426ef83b83945d2 Mon Sep 17 00:00:00 2001
From: Evgeny Ermakov <evgeny.v.ermakov@gmail.com>
Date: Tue, 30 Nov 2021 06:15:55 +1100
Subject: [PATCH 077/143] fasm: update to 1.73.28.

---
 srcpkgs/fasm/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/fasm/template b/srcpkgs/fasm/template
index 020b96a5a3b8..9137a57e86e0 100644
--- a/srcpkgs/fasm/template
+++ b/srcpkgs/fasm/template
@@ -1,6 +1,6 @@
 # Template file for 'fasm'
 pkgname=fasm
-version=1.73.27
+version=1.73.28
 revision=1
 archs="i686* x86_64*"
 wrksrc=fasm
@@ -9,7 +9,7 @@ maintainer="Dmitry Bogatov <KAction@disroot.org>"
 license="BSD-2-Clause"
 homepage="https://flatassembler.net"
 distfiles="https://flatassembler.net/fasm-${version}.tgz"
-checksum=680148377fb6d3b6663852880faa03514d7326b5995742d33a87e244f48cf0b1
+checksum=9ed1ebb485fd1174111a94eb773105a234911398e05090f5e714abf62c809292
 nostrip=yes
 
 case ${XBPS_TARGET_MACHINE} in

From 17c5f25945379a4a1479612f0c5bc2571fc5b960 Mon Sep 17 00:00:00 2001
From: Evgeny Ermakov <evgeny.v.ermakov@gmail.com>
Date: Tue, 30 Nov 2021 06:22:00 +1100
Subject: [PATCH 078/143] gtkwave: update to 3.3.111.

---
 srcpkgs/gtkwave/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/gtkwave/template b/srcpkgs/gtkwave/template
index d99b80e33dbf..9370f93039b3 100644
--- a/srcpkgs/gtkwave/template
+++ b/srcpkgs/gtkwave/template
@@ -1,6 +1,6 @@
 # Template file for 'gtkwave'
 pkgname=gtkwave
-version=3.3.109
+version=3.3.111
 revision=1
 build_style=gnu-configure
 configure_args="--with-tcl=${XBPS_CROSS_BASE}/usr/lib --with-tk=${XBPS_CROSS_BASE}/usr/lib"
@@ -11,7 +11,7 @@ maintainer="allan <mail@may.mooo.com>"
 license="GPL-2.0-or-later, MIT"
 homepage="http://gtkwave.sourceforge.net/"
 distfiles="http://gtkwave.sourceforge.net/gtkwave-${version}.tar.gz"
-checksum=ca487e5e9b728086ba4de6581058d6c096a7771915163ef600f63d0e88c3c05d
+checksum=f6e6046674033e5bab6e4e2720d6bd7dba70b23f329614191b029e06c57ec296
 
 post_install() {
 	vlicense LICENSE.TXT

From 1853a012381f1b99f8698e189fd7bf58ce24364f Mon Sep 17 00:00:00 2001
From: Evgeny Ermakov <evgeny.v.ermakov@gmail.com>
Date: Tue, 30 Nov 2021 06:09:12 +1100
Subject: [PATCH 079/143] glfw: update to 3.3.5.

---
 srcpkgs/glfw/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/glfw/template b/srcpkgs/glfw/template
index 99feb63bca77..997829355280 100644
--- a/srcpkgs/glfw/template
+++ b/srcpkgs/glfw/template
@@ -1,7 +1,7 @@
 # Template file for 'glfw'
 # update together with glfw-wayland
 pkgname=glfw
-version=3.3.4
+version=3.3.5
 revision=1
 build_style=cmake
 configure_args="-DBUILD_SHARED_LIBS=ON"
@@ -12,7 +12,7 @@ maintainer="Enno Boland <gottox@voidlinux.org>"
 license="Zlib"
 homepage="http://www.glfw.org"
 distfiles="${SOURCEFORGE_SITE}/${pkgname}/${pkgname}-${version}.tar.bz2"
-checksum=035f4572d9b7967433b3256f0eaa5257532b0e18865878a162233b108b6ca1db
+checksum=7bf8d4df3436f6eac7356e47fff7eb5a3610a692bffa27ce57dd55166abed5ea
 
 glfw-devel_package() {
 	depends="glfw>=${version}_${revision} $makedepends"

From 8f13ee7b3e9905d578d322f09df6b6a73db59d0c Mon Sep 17 00:00:00 2001
From: Evgeny Ermakov <evgeny.v.ermakov@gmail.com>
Date: Tue, 30 Nov 2021 06:11:30 +1100
Subject: [PATCH 080/143] glfw-wayland: update to 3.3.5.

---
 srcpkgs/glfw-wayland/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/glfw-wayland/template b/srcpkgs/glfw-wayland/template
index 6f90d6bc7778..8991962c6af5 100644
--- a/srcpkgs/glfw-wayland/template
+++ b/srcpkgs/glfw-wayland/template
@@ -1,6 +1,6 @@
 # Template file for 'glfw-wayland'
 pkgname=glfw-wayland
-version=3.3.4
+version=3.3.5
 revision=1
 wrksrc=glfw-${version}
 build_style=cmake
@@ -13,7 +13,7 @@ maintainer="q66 <daniel@octaforge.org>"
 license="Zlib"
 homepage="http://www.glfw.org"
 distfiles="${SOURCEFORGE_SITE}/glfw/glfw-${version}.tar.bz2"
-checksum=035f4572d9b7967433b3256f0eaa5257532b0e18865878a162233b108b6ca1db
+checksum=7bf8d4df3436f6eac7356e47fff7eb5a3610a692bffa27ce57dd55166abed5ea
 provides="glfw-${version}_${revision}"
 replaces="glfw>=0"
 

From 0446d7c3dac906fd3831fb7d227980faeacaf227 Mon Sep 17 00:00:00 2001
From: Evgeny Ermakov <evgeny.v.ermakov@gmail.com>
Date: Tue, 30 Nov 2021 06:25:14 +1100
Subject: [PATCH 081/143] socat: update to 1.7.4.2.

---
 srcpkgs/socat/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/socat/template b/srcpkgs/socat/template
index d4e0f0a9bbdb..92ccc52bc08f 100644
--- a/srcpkgs/socat/template
+++ b/srcpkgs/socat/template
@@ -1,7 +1,7 @@
 # Template file for 'socat'
 pkgname=socat
-version=1.7.4.1
-revision=2
+version=1.7.4.2
+revision=1
 build_style=gnu-configure
 configure_args="--disable-libwrap --enable-fips
  ac_cv_have_z_modifier=yes"
@@ -11,7 +11,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="GPL-2.0-only"
 homepage="http://www.dest-unreach.org/socat/"
 distfiles="http://www.dest-unreach.org/socat/download/socat-${version}.tar.bz2"
-checksum=3faca25614e89123dff5045680549ecef519d02e331aaf3c4f5a8f6837c675e9
+checksum=6690a9f9990457b505097a272bbf2cbf4cc35576176f76646e3524b0e91c1763
 
 case "$XBPS_TARGET_MACHINE" in
 	*-musl) CFLAGS="-D_LINUX_IF_ETHER_H";;

From a6505fd287842c28602639f90294ce082ca26a34 Mon Sep 17 00:00:00 2001
From: jgart <jgart@dismail.de>
Date: Mon, 29 Nov 2021 00:35:59 -0500
Subject: [PATCH 082/143] tree-sitter: update to 0.20.1.

---
 srcpkgs/tree-sitter/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/tree-sitter/template b/srcpkgs/tree-sitter/template
index 25d2743934c5..0f92c4e67130 100644
--- a/srcpkgs/tree-sitter/template
+++ b/srcpkgs/tree-sitter/template
@@ -1,6 +1,6 @@
 # Template file for 'tree-sitter'
 pkgname=tree-sitter
-version=0.20.0
+version=0.20.1
 revision=1
 build_style=cargo
 make_install_args="--path=cli"
@@ -9,7 +9,7 @@ maintainer="Érico Nogueira <ericonr@disroot.org>"
 license="MIT"
 homepage="https://tree-sitter.github.io"
 distfiles="https://github.com/tree-sitter/tree-sitter/archive/v${version}.tar.gz"
-checksum=4a8070b9de17c3b8096181fe8530320ab3e8cca685d8bee6a3e8d164b5fb47da
+checksum=12a3f7206af3028dbe8a0de50d8ebd6d7010bf762db918acae76fc7585f1258d
 make_check=no # tests require generating fixtures from remote repositories
 
 post_build() {

From 749465f86a85a281a99b596e12addd94035c76d8 Mon Sep 17 00:00:00 2001
From: reedts <j.reedts@gmail.com>
Date: Wed, 1 Dec 2021 09:29:47 +0100
Subject: [PATCH 083/143] neovim: update to 0.6.0.

---
 srcpkgs/neovim/patches/python-3.10.patch | 23 -----------------------
 srcpkgs/neovim/template                  |  6 +++---
 2 files changed, 3 insertions(+), 26 deletions(-)
 delete mode 100644 srcpkgs/neovim/patches/python-3.10.patch

diff --git a/srcpkgs/neovim/patches/python-3.10.patch b/srcpkgs/neovim/patches/python-3.10.patch
deleted file mode 100644
index 7ff1b17cc24f..000000000000
--- a/srcpkgs/neovim/patches/python-3.10.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From e78fc38908dfb9f952e75026987f0db1f9ce4253 Mon Sep 17 00:00:00 2001
-From: "Tejasvi S. Tomar" <45873379+tejasvi@users.noreply.github.com>
-Date: Thu, 7 Oct 2021 11:41:52 +0530
-Subject: [PATCH] Fix python provider's minor version comparison
-
-`'3.10' < '3.3'` but v3.10 > v3.3
----
- runtime/autoload/provider/pythonx.vim | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/runtime/autoload/provider/pythonx.vim b/runtime/autoload/provider/pythonx.vim
-index c292b374b6f5..0eeb35cba8f1 100644
---- a/runtime/autoload/provider/pythonx.vim
-+++ b/runtime/autoload/provider/pythonx.vim
-@@ -96,7 +96,7 @@ function! provider#pythonx#CheckForModule(prog, module, major_version) abort
-     if prog_version !~ '^' . a:major_version
-       return [0, prog_path . ' is Python ' . prog_version . ' and cannot provide Python '
-             \ . a:major_version . '.']
--    elseif prog_version =~ '^' . a:major_version && prog_version < min_version
-+    elseif prog_version =~ '^' . a:major_version && str2nr(prog_version[2:]) < str2nr(min_version[2:])
-       return [0, prog_path . ' is Python ' . prog_version . ' and cannot provide Python >= '
-             \ . min_version . '.']
-     endif
diff --git a/srcpkgs/neovim/template b/srcpkgs/neovim/template
index bb22714097d4..ea9d0e5daa02 100644
--- a/srcpkgs/neovim/template
+++ b/srcpkgs/neovim/template
@@ -1,7 +1,7 @@
 # Template file for 'neovim'
 pkgname=neovim
-version=0.5.1
-revision=2
+version=0.6.0
+revision=1
 build_style=cmake
 build_helper="qemu"
 configure_args="-DCMAKE_BUILD_TYPE=Release"
@@ -14,7 +14,7 @@ maintainer="Steve Prybylski <sa.prybylx@gmail.com>"
 license="Apache-2.0, custom:Vim"
 homepage="https://neovim.io"
 distfiles="https://github.com/neovim/neovim/archive/v${version}.tar.gz"
-checksum=aa449795e5cc69bdd2eeed7095f20b9c086c6ecfcde0ab62ab97a9d04243ec84
+checksum=2cfd600cfa5bb57564cc22ffbbbcb2c91531053fc3de992df33656614384fa4c
 
 alternatives="
  vi:vi:/usr/bin/nvim

From 809f0e935be566a08db0562bf7987ff70deadc7f Mon Sep 17 00:00:00 2001
From: Dakota Walsh <kota@nilsu.org>
Date: Tue, 30 Nov 2021 09:42:07 +1300
Subject: [PATCH 084/143] aerc: update to 0.6.0.

The original upstream maintainer, Drew Devault, has stepped down and a
fork was created (with Drew's approval) under the same name. The fork
has patched in a large backlog of crashes and bug fixes and put out a
new version 0.6.0 recently. I think now that the aerc community has
consolidated on this fork it would be appropriate to update out package
to the new upstream.

More info about the fork and new maintainer can be found in this
discussion: https://lists.sr.ht/~sircmpwn/aerc/%3CCFBVJ3G1Y4YB.ZI6C02D0MS0S%40diabtop%3E
---
 srcpkgs/aerc/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/aerc/template b/srcpkgs/aerc/template
index 08c81ef0d4eb..989a400caa90 100644
--- a/srcpkgs/aerc/template
+++ b/srcpkgs/aerc/template
@@ -1,6 +1,6 @@
 # Template file for 'aerc'
 pkgname=aerc
-version=0.5.2
+version=0.6.0
 revision=1
 build_style=go
 hostmakedepends="scdoc git"
@@ -9,8 +9,8 @@ short_desc="Terminal email client"
 maintainer="shtayerc <david.murko@mailbox.org>"
 license="MIT"
 homepage="https://aerc-mail.org"
-distfiles="https://git.sr.ht/~sircmpwn/aerc/archive/${version}.tar.gz"
-checksum=87b922440e53b99f260d2332996537decb452c838c774e9340b633296f9f68ee
+distfiles="https://git.sr.ht/~rjarry/aerc/archive/${version}.tar.gz"
+checksum=ec4565609938b314f0343d85dfdab1cb0659c07c2845369ff7cf0132c5faed6e
 
 do_configure() {
 	:

From 8b8852bb76754608af0f8d54aede079b0ba437c7 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Thu, 2 Dec 2021 16:22:07 +0100
Subject: [PATCH 085/143] golly: update to 4.1.

---
 srcpkgs/golly/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/golly/template b/srcpkgs/golly/template
index 614c13b3be51..ee2876689ad3 100644
--- a/srcpkgs/golly/template
+++ b/srcpkgs/golly/template
@@ -1,6 +1,6 @@
 # Template file for 'golly'
 pkgname=golly
-version=4.0
+version=4.1
 revision=1
 wrksrc="${pkgname}-${version}-src"
 build_wrksrc="gui-wx"
@@ -10,13 +10,13 @@ make_build_args="-f makefile-gtk GOLLYDIR=/usr/share/golly LUALIB=-llua5.4
 make_install_args="${make_build_args}"
 hostmakedepends="python3"
 makedepends="MesaLib-devel glu-devel lua54-devel python3-devel wxWidgets-devel
- zlib-devel"
+ zlib-devel SDL2-devel"
 short_desc="Simulator for Conway's Game of Life and other cellular automata"
 maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="GPL-2.0-or-later"
 homepage="http://golly.sourceforge.net/"
 distfiles="${SOURCEFORGE_SITE}/${pkgname}/${pkgname}-${version}-src.tar.gz"
-checksum=45a8595c9f7064de029f05d339e3fca3776b5a0c36fef95712e697f154d82ae5
+checksum=6c655a6ce2fd75c6ae7289da39d084162c6ed887a01c21c3760872e3ff6d60c8
 
 CXXFLAGS="-I../gollybase"
 
@@ -27,7 +27,7 @@ post_extract() {
 
 pre_configure() {
 	if [ "$CROSS_BUILD" ]; then
-		vsed -i "s,\(PYTHON_INCLUDE\) =.*,\1=-I${XBPS_CROSS_BASE}/usr/include/python3.9,g" makefile-gtk
+		vsed -i "s,\(PYTHON_INCLUDE\) =.*,\1=-I${XBPS_CROSS_BASE}/usr/include/python3.10,g" makefile-gtk
 	fi
 }
 

From 256697963c16d48cd7fbcf28987c389b8eca4383 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Thu, 2 Dec 2021 18:16:57 +0100
Subject: [PATCH 086/143] sbcl: update to 2.1.11.

---
 srcpkgs/sbcl/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/sbcl/template b/srcpkgs/sbcl/template
index 5225f4ae682c..524d66eb8d05 100644
--- a/srcpkgs/sbcl/template
+++ b/srcpkgs/sbcl/template
@@ -1,6 +1,6 @@
 # Template file for 'sbcl'
 pkgname=sbcl
-version=2.1.10
+version=2.1.11
 revision=1
 archs="i686 x86_64* armv7l aarch64 ppc64le*"
 hostmakedepends="iana-etc"
@@ -12,7 +12,7 @@ license="custom:BSD+public_domain"
 homepage="http://www.sbcl.org/"
 changelog="http://www.sbcl.org/news.html"
 distfiles="${SOURCEFORGE_SITE}/${pkgname}/${pkgname}-${version}-source.tar.bz2"
-checksum=eb183f0f59a5cb2cbed762ec062bc34b9b6214b65402660784ef54838884b138
+checksum=bfc1481de7fdbdfaeef2ab0f0e8e84efd343433dea8d21cfbea8b0146cbdfefd
 nocross=yes
 nopie=yes
 
@@ -20,7 +20,7 @@ _bootstrap_lisp="bash ../sbcl-*-linux/run-sbcl.sh --no-sysinit --no-userinit --d
 case "$XBPS_TARGET_MACHINE" in
 x86_64)
 	distfiles+=" ${SOURCEFORGE_SITE}/${pkgname}/${pkgname}-${version}-x86-64-linux-binary.tar.bz2"
-	checksum+=" 5b23e9527d5a451bff8a78d08650122a7c4bf7d34b73fa7c8e712670fadc28ff"
+	checksum+=" e9605c843776470d8f81000b732b0a672ec355c0e3d6bbebfb900eddeb86c440"
 	;;
 i686)
 	distfiles+=" ${SOURCEFORGE_SITE}/${pkgname}/${pkgname}-1.4.3-x86-linux-binary.tar.bz2"

From ecb6a3ede244326f1635bf1832937b045d54fb32 Mon Sep 17 00:00:00 2001
From: Michal Vasilek <michal@vasilek.cz>
Date: Thu, 2 Dec 2021 16:32:37 +0100
Subject: [PATCH 087/143] python3-md2gemini: remove site-packages/tests

---
 srcpkgs/python3-md2gemini/template | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

diff --git a/srcpkgs/python3-md2gemini/template b/srcpkgs/python3-md2gemini/template
index 508f152fa939..4b4f88c7233d 100644
--- a/srcpkgs/python3-md2gemini/template
+++ b/srcpkgs/python3-md2gemini/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-md2gemini'
 pkgname=python3-md2gemini
 version=1.8.1
-revision=1
+revision=2
 wrksrc="md2gemini-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools python3-mistune2 python3-cjkwrap
@@ -14,3 +14,8 @@ license="LGPL-3.0-only"
 homepage="https://github.com/makeworld-the-better-one/md2gemini"
 distfiles="${PYPI_SITE}/m/md2gemini/md2gemini-${version}.tar.gz"
 checksum=3ef2bd2d9e2b4968a844a2858f721348429f3a0b5976bd1c324198538103ca55
+
+post_install() {
+	# remove tests directory polluting site-packages
+	rm -r $DESTDIR/usr/lib/python*/site-packages/tests
+}

From f7f7b13fd3ab8974a8aeafc0c03d010cc3a2ea54 Mon Sep 17 00:00:00 2001
From: Michal Vasilek <michal@vasilek.cz>
Date: Thu, 2 Dec 2021 16:32:42 +0100
Subject: [PATCH 088/143] python3-pykeepass: remove site-packages/tests

---
 srcpkgs/python3-pykeepass/template | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

diff --git a/srcpkgs/python3-pykeepass/template b/srcpkgs/python3-pykeepass/template
index 532f3a77a13c..5571c1a18dbe 100644
--- a/srcpkgs/python3-pykeepass/template
+++ b/srcpkgs/python3-pykeepass/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-pykeepass'
 pkgname=python3-pykeepass
 version=4.0.1
-revision=1
+revision=2
 wrksrc="pykeepass-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -15,3 +15,8 @@ homepage="https://github.com/libkeepass/pykeepass"
 changelog="https://raw.githubusercontent.com/libkeepass/pykeepass/master/CHANGELOG.rst"
 distfiles="https://github.com/libkeepass/pykeepass/archive/refs/tags/${version}.tar.gz"
 checksum=ac5966ede4fae1a0d3ea1997468a14b893a8f8dab136b1c14425b3b2763e68e3
+
+post_install() {
+	# remove tests directory polluting site-packages
+	rm -r $DESTDIR/usr/lib/python*/site-packages/tests
+}

From 57874245eb5994fd3ab0102e0fcadf889c9805cc Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Ey=C3=9Fer?= <daniel.eysser@gmail.com>
Date: Thu, 2 Dec 2021 11:41:52 +0100
Subject: [PATCH 089/143] age: set version information

---
 srcpkgs/age/template | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/srcpkgs/age/template b/srcpkgs/age/template
index a3284c8d0c69..cf7754da9b03 100644
--- a/srcpkgs/age/template
+++ b/srcpkgs/age/template
@@ -1,10 +1,11 @@
 # Template file for 'age'
 pkgname=age
 version=1.0.0
-revision=1
+revision=2
 build_style=go
 go_import_path="filippo.io/age"
 go_package="${go_import_path}/cmd/..."
+go_ldflags="-X main.Version=${version}"
 short_desc="Simple, modern and secure encryption tool"
 maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="BSD-3-Clause"

From 5922b591d003f90892e0336e3d990ddbbd702f55 Mon Sep 17 00:00:00 2001
From: Tim Sandquist <tim.sandquist@gmail.com>
Date: Thu, 2 Dec 2021 07:53:35 -0600
Subject: [PATCH 090/143] nss: update to 3.73.

critical security fix
https://www.mozilla.org/en-US/security/advisories/mfsa2021-51/
---
 srcpkgs/nss/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/nss/template b/srcpkgs/nss/template
index 968500eb758e..8f70796361e5 100644
--- a/srcpkgs/nss/template
+++ b/srcpkgs/nss/template
@@ -3,7 +3,7 @@
 _nsprver=4.32
 
 pkgname=nss
-version=3.72
+version=3.73
 revision=1
 hostmakedepends="perl"
 makedepends="nspr-devel sqlite-devel zlib-devel"
@@ -13,7 +13,7 @@ maintainer="Đoàn Trần Công Danh <congdanhqx@gmail.com>"
 license="MPL-2.0"
 homepage="https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSS"
 distfiles="${MOZILLA_SITE}/security/nss/releases/NSS_${version//\./_}_RTM/src/nss-${version}.tar.gz"
-checksum=6ea60a9ff113e493ea2ab25f41ea75a9fbd10af7903f26f703dac8680732d02e
+checksum=566d3a68da9b10d7da9ef84eb4fe182f8f04e20d85c55d1bf360bb2c0096d8e5
 
 export NS_USE_GCC=1
 export LIBRUNPATH=

From 4b78bfadf3e9ccf619c518ec8506d3e11496566e Mon Sep 17 00:00:00 2001
From: Ramdziana F Y <ramdzian@gmail.com>
Date: Thu, 2 Dec 2021 19:16:19 +0700
Subject: [PATCH 091/143] vivaldi: update to 5.0.2497.24

---
 srcpkgs/vivaldi/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/vivaldi/template b/srcpkgs/vivaldi/template
index 98a12ab05eba..1ef2335e9ebe 100644
--- a/srcpkgs/vivaldi/template
+++ b/srcpkgs/vivaldi/template
@@ -1,6 +1,6 @@
 # Template file for 'vivaldi'
 pkgname=vivaldi
-version=4.3.2439.65
+version=5.0.2497.24
 revision=1
 _release=1
 archs="x86_64"
@@ -14,7 +14,7 @@ license="custom:Proprietary"
 homepage="https://vivaldi.com"
 distfiles="https://downloads.vivaldi.com/stable/vivaldi-stable_${version}-${_release}_amd64.deb"
 _licenseUrl="https://vivaldi.com/privacy/vivaldi-end-user-license-agreement/"
-checksum=42d6a7568b7b45c3b3d5a47e0ff51c46b80eab00645a17961be32f5320df10d1
+checksum=40f1cf35e6bd0e04e6bf9360f5179c85c68af403562a46358ea306e18080b32d
 repository=nonfree
 restricted=yes
 nostrip=yes

From 40d5944f4cca94008041c618884224e1a974f82b Mon Sep 17 00:00:00 2001
From: Clyhtsuriva <aimeric@adjutor.xyz>
Date: Thu, 2 Dec 2021 13:22:19 +0100
Subject: [PATCH 092/143] gnome-robots: update to 40.0

---
 srcpkgs/gnome-robots/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/gnome-robots/template b/srcpkgs/gnome-robots/template
index 1d85efb012db..369474709a8d 100644
--- a/srcpkgs/gnome-robots/template
+++ b/srcpkgs/gnome-robots/template
@@ -1,14 +1,14 @@
 # Template file for 'gnome-robots'
 pkgname=gnome-robots
-version=3.38.0
+version=40.0
 revision=1
 build_style=meson
-hostmakedepends="gettext glib-devel itstool pkg-config"
-makedepends="gsound-devel gtk+3-devel libcanberra-devel librsvg-devel
+hostmakedepends="gettext glib-devel itstool pkg-config vala"
+makedepends="gsound-devel gtk4-devel libcanberra-devel librsvg-devel
  libglib-devel libgnome-games-support-devel"
 short_desc="GNOME classic robots game"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="https://wiki.gnome.org/Apps/Robots"
 distfiles="${GNOME_SITE}/${pkgname}/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=1fe8694aa7d4f86e77770649fcd8944b00535913cb5975bcd3adc424bdbeffe2
+checksum=6fbf2f885750f1a5110a724f8f35addd9bc61184ee31cf0c0cb89953e4f4cb11

From afae589fa62a76877a664987969b5af065b57318 Mon Sep 17 00:00:00 2001
From: John Zimmermann <me@johnnynator.dev>
Date: Wed, 1 Dec 2021 09:21:22 +0100
Subject: [PATCH 093/143] Rocket.Chat-Desktop: update to 3.7.0.

---
 srcpkgs/Rocket.Chat-Desktop/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/Rocket.Chat-Desktop/template b/srcpkgs/Rocket.Chat-Desktop/template
index a01959934521..58f2eed1d9ba 100644
--- a/srcpkgs/Rocket.Chat-Desktop/template
+++ b/srcpkgs/Rocket.Chat-Desktop/template
@@ -1,6 +1,6 @@
 # Template file for 'Rocket.Chat-Desktop'
 pkgname=Rocket.Chat-Desktop
-version=3.6.0
+version=3.7.0
 revision=1
 _electron_ver=13
 wrksrc="Rocket.Chat.Electron-${version}"
@@ -12,7 +12,7 @@ maintainer="John <me@johnnynator.dev>"
 license="MIT"
 homepage="https://rocket.chat/"
 distfiles="https://github.com/RocketChat/Rocket.Chat.Electron/archive/${version}.tar.gz"
-checksum=1b867f55c32f24124f5aaf6ce3dcd805a5aab29c63582a4b5a8730420af5cc1d
+checksum=328707d85b847214e0fe92bd3e45d757c7a27f24532c2f6d353dd045458fee80
 
 export USE_SYSTEM_APP_BUILDER=true
 

From e2f1fb668fadab171ea6275ec6e6ec89fa588254 Mon Sep 17 00:00:00 2001
From: Duncaen <duncaen@voidlinux.org>
Date: Fri, 3 Dec 2021 15:58:47 +0100
Subject: [PATCH 094/143] knot-resolver: update to 5.4.3.

---
 srcpkgs/knot-resolver/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/knot-resolver/template b/srcpkgs/knot-resolver/template
index fc56c00f9742..56fd104bc0f0 100644
--- a/srcpkgs/knot-resolver/template
+++ b/srcpkgs/knot-resolver/template
@@ -1,6 +1,6 @@
 # Template file for 'knot-resolver'
 pkgname=knot-resolver
-version=5.4.2
+version=5.4.3
 revision=1
 build_style=meson
 configure_args="
@@ -19,7 +19,7 @@ maintainer="Duncaen <duncaen@voidlinux.org>"
 license="GPL-3.0-or-later"
 homepage="https://www.knot-resolver.cz/"
 distfiles="https://secure.nic.cz/files/knot-resolver/knot-resolver-${version}.tar.xz"
-checksum=ea6a219571a752056669bae3f2c0c3ed0bec58af5ab832d505a3ec9c4063a58b
+checksum=488729eb93190336b6bca10de0d78ecb7919f77fcab105debc0a644aa7d0a506
 
 system_accounts="_knot_resolver"
 _knot_resolver_homedir="/var/cache/knot-resolver"

From 46cbf11b02f94883c018c86b84e5596599b68530 Mon Sep 17 00:00:00 2001
From: Duncaen <duncaen@voidlinux.org>
Date: Fri, 3 Dec 2021 16:00:34 +0100
Subject: [PATCH 095/143] logswan: update to 2.1.12.

---
 srcpkgs/logswan/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/logswan/template b/srcpkgs/logswan/template
index e6a18fe21159..4436b23cac97 100644
--- a/srcpkgs/logswan/template
+++ b/srcpkgs/logswan/template
@@ -1,6 +1,6 @@
 # Template file for 'logswan'
 pkgname=logswan
-version=2.1.11
+version=2.1.12
 revision=1
 build_style=cmake
 makedepends="jansson-devel libmaxminddb-devel"
@@ -10,7 +10,7 @@ license="BSD-2-clause"
 homepage="https://www.logswan.org/"
 changelog="https://github.com/fcambus/logswan/raw/master/ChangeLog"
 distfiles="https://github.com/fcambus/logswan/archive/${version}.tar.gz"
-checksum=a031b04c2dcfe8195e4225b8dd5781fc76098b9d19d0e4a9cbe1da76a4928eea
+checksum=8e954fcf5319b83f184b1a91d0af12c58bb90ab0f322f42ea6ad36fb05d57894
 
 post_install() {
 	vlicense LICENSE

From 34bda3092ce96fb6c9fcabe7fa9e624d2b435e1e Mon Sep 17 00:00:00 2001
From: Duncaen <duncaen@voidlinux.org>
Date: Fri, 3 Dec 2021 16:10:05 +0100
Subject: [PATCH 096/143] poke: update to 1.4.

---
 srcpkgs/poke/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/poke/template b/srcpkgs/poke/template
index c1876c668059..dbb3543855e8 100644
--- a/srcpkgs/poke/template
+++ b/srcpkgs/poke/template
@@ -1,6 +1,6 @@
 # Template file for 'poke'
 pkgname=poke
-version=1.3
+version=1.4
 revision=1
 build_style=gnu-configure
 hostmakedepends="pkg-config"
@@ -12,7 +12,7 @@ license="GPL-3.0-or-later"
 homepage="https://www.jemarch.net/poke.html"
 changelog="https://www.jemarch.net/poke-${version}-relnotes.html"
 distfiles="${GNU_SITE}/poke/poke-${version}.tar.gz"
-checksum=ba7863034a1b08004b0ee8f88bda94160707e9a781d5556f555b507583cf0f1b
+checksum=ce054df29560c921230132703ee449fe130b6e25ab03aa6cc796bb401506aa24
 
 poke-devel_package() {
 	depends="${sourcepkg}>=${version}_${revision}"

From 1fb5c8473e6cc7e374751430d2753b3155faca83 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Ey=C3=9Fer?= <daniel.eysser@gmail.com>
Date: Fri, 3 Dec 2021 17:50:39 +0100
Subject: [PATCH 097/143] youtube-dl: orphan package

---
 srcpkgs/youtube-dl/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/youtube-dl/template b/srcpkgs/youtube-dl/template
index 72c70a4ee4b4..b83c6c887ab0 100644
--- a/srcpkgs/youtube-dl/template
+++ b/srcpkgs/youtube-dl/template
@@ -8,7 +8,7 @@ hostmakedepends="python3-setuptools"
 depends="python3-setuptools"
 checkdepends="flake8 python3-nose"
 short_desc="CLI program to download videos from YouTube and other sites"
-maintainer="Daniel Eyßer <daniel.eysser@gmail.com>"
+maintainer="Orphaned <orphan@voidlinux.org>"
 license="Unlicense"
 homepage="https://yt-dl.org"
 changelog="https://raw.githubusercontent.com/ytdl-org/youtube-dl/master/ChangeLog"

From ad8aa389141fca6772e4cdc5fcd0bae0d41d7df3 Mon Sep 17 00:00:00 2001
From: skmpz <dem.procopiou@gmail.com>
Date: Fri, 3 Dec 2021 20:06:41 +0400
Subject: [PATCH 098/143] calibre: update to 5.33.0.

---
 srcpkgs/calibre/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/calibre/template b/srcpkgs/calibre/template
index fcf45f5bb183..f96c9329ace6 100644
--- a/srcpkgs/calibre/template
+++ b/srcpkgs/calibre/template
@@ -1,6 +1,6 @@
 # Template file for 'calibre'
 pkgname=calibre
-version=5.32.0
+version=5.33.0
 revision=1
 build_style=python3-module
 pycompile_dirs="/usr/lib/calibre/"
@@ -27,7 +27,7 @@ license="GPL-3.0-only"
 homepage="https://calibre-ebook.com"
 changelog="https://raw.githubusercontent.com/kovidgoyal/calibre/master/Changelog.txt"
 distfiles="https://download.calibre-ebook.com/${version}/calibre-${version}.tar.xz"
-checksum=3571efc1cc773e453b459096a38b141fd0c7784fb9611505a1f9a55648f47e5e
+checksum=5c32cdd9cb7feecb125131842e3f66a8c9e838d7c5be6f016367de1a1d1f78fd
 lib32disabled=yes
 nocross=yes
 

From 7ea75f80bfb600ae4597ae591dbc72d7f39996cd Mon Sep 17 00:00:00 2001
From: Anton Afanasyev <1157248+2asoft@users.noreply.github.com>
Date: Fri, 3 Dec 2021 01:11:32 -0800
Subject: [PATCH 099/143] CLion: update to 2021.3.

---
 srcpkgs/CLion/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/CLion/template b/srcpkgs/CLion/template
index a7779c295f13..76f9dd3f1e8c 100644
--- a/srcpkgs/CLion/template
+++ b/srcpkgs/CLion/template
@@ -1,6 +1,6 @@
 # Template file for 'CLion'
 pkgname=CLion
-version=2021.2.3
+version=2021.3
 revision=1
 archs="x86_64 aarch64"
 wrksrc="clion-${version}"
@@ -10,7 +10,7 @@ maintainer="Anton Afanasyev <anton@doubleasoftware.com>"
 license="custom:Commercial"
 homepage="https://www.jetbrains.com/clion"
 distfiles="https://download.jetbrains.com/cpp/CLion-${version}.tar.gz"
-checksum=25c3968c72976b2de5e3e8f39b242702c4ec25b32268022cd16590e9fbfc0b27
+checksum=4968657ad64d55da794bcf9b878fdd36ed233014152930058f761296d2047867
 repository=nonfree
 restricted=yes
 nopie=yes

From f9546df20949eaa7261e22be0a1e00bd8e8aee6d Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Benjam=C3=ADn=20Albi=C3=B1ana?= <benalb@gmail.com>
Date: Fri, 3 Dec 2021 08:46:36 +0100
Subject: [PATCH 100/143] doomretro: update to 4.4.

---
 srcpkgs/doomretro/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/doomretro/template b/srcpkgs/doomretro/template
index 2df391db530b..d0a7996ac62b 100644
--- a/srcpkgs/doomretro/template
+++ b/srcpkgs/doomretro/template
@@ -1,6 +1,6 @@
 # Template file for 'doomretro'
 pkgname=doomretro
-version=4.3
+version=4.4
 revision=1
 build_style=cmake
 hostmakedepends="pkg-config"
@@ -11,4 +11,4 @@ license="GPL-3.0-or-later"
 homepage="https://www.doomretro.com"
 changelog="https://raw.githubusercontent.com/bradharding/doomretro/master/releasenotes.md"
 distfiles="https://github.com/bradharding/doomretro/archive/v${version}.tar.gz"
-checksum=99e48dc66e8d69a806372643db3aa1ea3b1a68dcf891ec79b9c3261484e3181e
+checksum=f28e439498de97a38decafd924d06e72ec247efca82719afca17d0532170be3b

From efa07877da7e6cdb2257cfd6621182a8618043e5 Mon Sep 17 00:00:00 2001
From: Clyhtsuriva <aimeric@adjutor.xyz>
Date: Thu, 2 Dec 2021 12:13:03 +0100
Subject: [PATCH 101/143] gnome-sudoku: update to 40.2

---
 srcpkgs/gnome-sudoku/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/gnome-sudoku/template b/srcpkgs/gnome-sudoku/template
index 86c314e7f147..ed1759478ab5 100644
--- a/srcpkgs/gnome-sudoku/template
+++ b/srcpkgs/gnome-sudoku/template
@@ -1,14 +1,14 @@
 # Template file for 'gnome-sudoku'
 pkgname=gnome-sudoku
-version=3.38.0
+version=40.2
 revision=1
 build_helper="gir"
 build_style=meson
 hostmakedepends="gettext glib-devel itstool pkg-config vala"
-makedepends="gtk+3-devel libgee08-devel json-glib-devel qqwing-devel"
+makedepends="gtk4-devel libgee08-devel json-glib-devel qqwing-devel"
 short_desc="GNOME Sudoku Japanese logic game"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="GPL-3.0-or-later"
 homepage="https://wiki.gnome.org/Apps/Sudoku"
 distfiles="${GNOME_SITE}/${pkgname}/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=38731d0cc6d56a21dbdc89409cc5bb3d08e1c02cd9009f4d57f5b34887e9fd32
+checksum=36120531e3c7139581ea3800fbfe3c2b31694c440145ecc897ac34e562d754a3

From 85b03153ff0f539f15e54f0dc15823f14b334c5e Mon Sep 17 00:00:00 2001
From: Clyhtsuriva <aimeric@adjutor.xyz>
Date: Thu, 2 Dec 2021 11:50:02 +0100
Subject: [PATCH 102/143] gnome-chess: update to 41.1

---
 srcpkgs/gnome-chess/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/gnome-chess/template b/srcpkgs/gnome-chess/template
index 4ed9e8bc914e..629a10229d9d 100644
--- a/srcpkgs/gnome-chess/template
+++ b/srcpkgs/gnome-chess/template
@@ -1,14 +1,14 @@
 # Template file for 'gnome-chess'
 pkgname=gnome-chess
-version=3.38.1
+version=41.1
 revision=1
 build_style=meson
 hostmakedepends="gettext pkg-config vala glib-devel itstool librsvg-devel"
-makedepends="gtk+3-devel librsvg-devel"
+makedepends="gtk4-devel librsvg-devel"
 depends="gnuchess"
 short_desc="GNOME chess user interface"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="GPL-3.0-or-later"
 homepage="https://wiki.gnome.org/Apps/Chess"
 distfiles="${GNOME_SITE}/${pkgname}/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=1470f037c0dffe0285c121f7b6655e1245761f99a9974ab3c04dee5d6e89f5ae
+checksum=eb619886596396b4033a3f28a3c2e3004b54ebe1b38b40d6422c17b9f2cc17d0

From 6d7b4cf1c2104bebab49572c96106a6a256bed9f Mon Sep 17 00:00:00 2001
From: Clyhtsuriva <aimeric@adjutor.xyz>
Date: Thu, 2 Dec 2021 13:51:15 +0100
Subject: [PATCH 103/143] hitori: update to 3.38.3

---
 srcpkgs/hitori/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/hitori/template b/srcpkgs/hitori/template
index 8a50efea3e63..b5fc5662126e 100644
--- a/srcpkgs/hitori/template
+++ b/srcpkgs/hitori/template
@@ -1,6 +1,6 @@
 # Template file for 'hitori'
 pkgname=hitori
-version=3.38.1
+version=3.38.3
 revision=1
 build_style=meson
 hostmakedepends="gettext glib-devel intltool itstool pkg-config"
@@ -11,4 +11,4 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="GPL-3.0-or-later"
 homepage="https://wiki.gnome.org/Apps/Hitori"
 distfiles="${GNOME_SITE}/${pkgname}/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=02bd2c421d4e2180265714e854bd12efd3c6d156ddf21f79e7df60011d4e4184
+checksum=f7d7103cb0633fb013730131a98c3ae3a2162b9fb9499fc7f19512d581bf6569

From 74e9edc74d594eec59202148eaa79bc421878bf2 Mon Sep 17 00:00:00 2001
From: Joel Beckmeyer <joel@beckmeyer.us>
Date: Thu, 2 Dec 2021 08:06:48 -0500
Subject: [PATCH 104/143] borgmatic: update to 1.5.21, adopt.

---
 srcpkgs/borgmatic/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/borgmatic/template b/srcpkgs/borgmatic/template
index 523fbf23951c..047883dcc530 100644
--- a/srcpkgs/borgmatic/template
+++ b/srcpkgs/borgmatic/template
@@ -1,6 +1,6 @@
 # Template file for 'borgmatic'
 pkgname=borgmatic
-version=1.5.20
+version=1.5.21
 revision=1
 build_style=python3-module
 # runs not yet installed self
@@ -10,12 +10,12 @@ depends="borg python3-setuptools python3-ruamel.yaml python3-jsonschema
  python3-colorama python3-requests"
 checkdepends="${depends} python3-pytest-cov python3-flexmock"
 short_desc="Wrapper script for the Borg backup software"
-maintainer="Orphaned <orphan@voidlinux.org>"
+maintainer="Joel Beckmeyer <joel@beckmeyer.us>"
 license="GPL-3.0-or-later"
 homepage="https://torsion.org/borgmatic/"
 changelog="https://projects.torsion.org/borgmatic-collective/borgmatic/raw/branch/master/NEWS"
 distfiles="${PYPI_SITE}/b/borgmatic/borgmatic-${version}.tar.gz"
-checksum=0aa6705cd72c6bd8fec94ba9e5e13ba9e90e6671799af2f2f5cb91186b90b7e5
+checksum=b8aa9dbf250b95b829827310c9638a17cd52fee160a437283eed23bffcae83cf
 
 post_install() {
 	# remove tests directory polluting site-packages

From 5133dcc04d08e723ab8f0a7a8d09b11d6f18c478 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Ey=C3=9Fer?= <daniel.eysser@gmail.com>
Date: Thu, 2 Dec 2021 17:42:47 +0100
Subject: [PATCH 105/143] mpd: update to 0.23.5.

---
 srcpkgs/mpd/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/mpd/template b/srcpkgs/mpd/template
index 144dfdf9ec43..fc9c4153e284 100644
--- a/srcpkgs/mpd/template
+++ b/srcpkgs/mpd/template
@@ -1,6 +1,6 @@
 # Template file for 'mpd'
 pkgname=mpd
-version=0.23.4
+version=0.23.5
 revision=1
 build_style=meson
 configure_args="-Dopus=enabled -Dmikmod=enabled -Dneighbor=true
@@ -22,7 +22,7 @@ hostmakedepends="pkg-config python3-Sphinx"
 makedepends="avahi-glib-libs-devel boost-devel faad2-devel ffmpeg-devel
  libcurl-devel libid3tag-devel libmad-devel libmikmod-devel libmms-devel
  libmodplug-devel libmpdclient-devel libnfs-devel libsamplerate-devel
- libnpupnp-devel mpg123-devel opus-devel yajl-devel
+ libnpupnp-devel mpg123-devel opus-devel yajl-devel pcre2-devel icu-devel
  zziplib-devel libsoxr-devel audiofile-devel twolame-devel fmt-devel
  $(vopt_if io_uring 'liburing-devel') $(vopt_if pipewire 'pipewire-devel')
  $(vopt_if cdio 'libcdio-paranoia-devel') $(vopt_if shoutcast 'libshout-devel')
@@ -39,7 +39,7 @@ license="GPL-2.0-or-later"
 homepage="https://www.musicpd.org/"
 changelog="https://raw.githubusercontent.com/MusicPlayerDaemon/MPD/master/NEWS"
 distfiles="https://www.musicpd.org/download/mpd/${version%.*}/mpd-${version}.tar.xz"
-checksum=2f359d30dd980f762d2bc324d916e48b731e8a4d456d01d120c61ad657e4c754
+checksum=f22c2c25093a05f4566f9cd7207cfbcd8405af67ed29a989bcf8905f80b7a299
 LDFLAGS="-Wl,-z,stack-size=1048576"
 
 system_accounts="mpd"

From edddfd5584389cd6ac9562233a1dee6762443a23 Mon Sep 17 00:00:00 2001
From: Imran Khan <imrankhan@teknik.io>
Date: Thu, 2 Dec 2021 15:51:18 +0600
Subject: [PATCH 106/143] txr: update to 272.

---
 srcpkgs/txr/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/txr/template b/srcpkgs/txr/template
index 1136f6b7b026..68af47b7e693 100644
--- a/srcpkgs/txr/template
+++ b/srcpkgs/txr/template
@@ -1,6 +1,6 @@
 # Template file for 'txr'
 pkgname=txr
-version=270
+version=272
 revision=1
 archs="x86_64* i686* aarch64* arm* ppc64* mips*"
 build_style=configure
@@ -13,7 +13,7 @@ license="BSD-2-Clause"
 homepage="http://www.nongnu.org/txr/"
 changelog="http://www.kylheku.com/cgit/txr/tree/RELNOTES"
 distfiles="http://www.kylheku.com/cgit/txr/snapshot/${pkgname}-${version}.tar.bz2"
-checksum=6e0fe840ee91430888a08db8ef7739b1884fa43e8b2b5e173e6ae3eda3150291
+checksum=b3c2a82198dc97633aa40ced6fff6fec39c78a905b06dc08e7b74176bda03543
 nopie=yes
 
 if [ "$CROSS_BUILD" ]; then

From 5a85d9ec3c5175da9ed4a639dea691360f9edd39 Mon Sep 17 00:00:00 2001
From: notthewave <winklbauer_m@zoho.eu>
Date: Wed, 1 Dec 2021 19:30:32 +0100
Subject: [PATCH 107/143] ART: update to 1.11.

---
 srcpkgs/ART/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/ART/template b/srcpkgs/ART/template
index 31370020a225..671695939be7 100644
--- a/srcpkgs/ART/template
+++ b/srcpkgs/ART/template
@@ -1,6 +1,6 @@
 # Template file for 'ART'
 pkgname=ART
-version=1.10.1
+version=1.11
 revision=1
 build_style=cmake
 hostmakedepends="pkg-config"
@@ -12,4 +12,4 @@ maintainer="notthewave <winklbauer_m@zoho.eu>"
 license="GPL-3.0-or-later"
 homepage="https://bitbucket.org/agriggio/art/wiki/Home"
 distfiles="https://bitbucket.org/agriggio/art/downloads/${pkgname}-${version}.tar.xz"
-checksum=e20b73de6be55bbb5924d1bc194ecd7f0bf26d581bd9b8b7d8a1af70ea85483e
+checksum=6458cdb7b8aa1afdb767c3aaaf5549e8892e2d6ecf0d29029fa32f82078dd568

From 034fed02bba101f0aedfc1f9f49a36bd0dce4aeb Mon Sep 17 00:00:00 2001
From: Omar Zeghouani <omarzeghouanii@gmail.com>
Date: Wed, 1 Dec 2021 23:02:20 +0000
Subject: [PATCH 108/143] git-filter-repo: update to 2.34.0.

---
 srcpkgs/git-filter-repo/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/git-filter-repo/template b/srcpkgs/git-filter-repo/template
index 073dd6f75fe1..a81d612705a5 100644
--- a/srcpkgs/git-filter-repo/template
+++ b/srcpkgs/git-filter-repo/template
@@ -1,7 +1,7 @@
 # Template file for 'git-filter-repo'
 pkgname=git-filter-repo
-version=2.33.0
-revision=2
+version=2.34.0
+revision=1
 depends="git python3"
 checkdepends="git python3 perl rsync dos2unix"
 short_desc="Versatile tool for rewriting git history"
@@ -9,7 +9,7 @@ maintainer="Cameron Nemo <cnemo@tutanota.com>"
 license="MIT"
 homepage="https://github.com/newren/git-filter-repo/"
 distfiles="https://github.com/newren/git-filter-repo/releases/download/v${version}/git-filter-repo-${version}.tar.xz"
-checksum=7bcf11da134bbd82a4171f7fb28a3ab7bc4d478fe8ec3a3d9580e4bbdc32e6e9
+checksum=b1bf46af1e6a91a54056d0254e480803db8e40f631336c559a1a94d2a08389c4
 
 do_check() {
 	t/run_tests

From 82512798d1feaf38c65a1769f07f7baee162fca6 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Ey=C3=9Fer?= <daniel.eysser@gmail.com>
Date: Fri, 3 Dec 2021 18:15:07 +0100
Subject: [PATCH 109/143] glances: update to 3.2.4.2.

---
 srcpkgs/glances/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/glances/template b/srcpkgs/glances/template
index f7814f03d996..e329bcbf6858 100644
--- a/srcpkgs/glances/template
+++ b/srcpkgs/glances/template
@@ -1,7 +1,7 @@
 # Template file for 'glances'
 pkgname=glances
-version=3.2.2
-revision=2
+version=3.2.4.2
+revision=1
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-future python3-psutil python3-defusedxml"
@@ -11,7 +11,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="LGPL-3.0-or-later"
 homepage="https://github.com/nicolargo/glances"
 distfiles="https://github.com/nicolargo/glances/archive/v${version}.tar.gz"
-checksum=7a96f16b09e30765a7a5b0e8d02dda20ac8ff1f144e6586d1f17ff7a80f5480f
+checksum=88ac8103d777b2a55cee9418a5940269c640c3ad964ec44de0e9bb80cdbead37
 
 post_install() {
 	vsconf conf/glances.conf

From cee8c66aa79e94c3ad11b54f045a5580d42b0406 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Ey=C3=9Fer?= <daniel.eysser@gmail.com>
Date: Fri, 3 Dec 2021 11:49:02 +0100
Subject: [PATCH 110/143] zoom: update to 5.8.6.739.

---
 srcpkgs/zoom/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/zoom/template b/srcpkgs/zoom/template
index c6d57a36e361..e5ab0c169fd5 100644
--- a/srcpkgs/zoom/template
+++ b/srcpkgs/zoom/template
@@ -1,6 +1,6 @@
 # Template file for 'zoom'
 pkgname=zoom
-version=5.8.4.210
+version=5.8.6.739
 revision=1
 archs="x86_64"
 wrksrc=zoom
@@ -13,7 +13,7 @@ maintainer="Daniel Santana <daniel@santana.tech>"
 license="custom:Proprietary"
 homepage="https://zoom.us/"
 distfiles="https://cdn.zoom.us/prod/${version}/zoom_x86_64.rpm"
-checksum=b3fc9eef929d418873bdf3cc6df38297b86deaf330259e633d17459ec8718034
+checksum=a57d03456a6a92f5ab01e342443edc1824b043837f23a8d4027cd8b5831c0f11
 repository=nonfree
 noshlibprovides=yes
 noverifyrdeps=yes

From 1ff288dcb11c4aabd0d1fdc3c1f0a5b3d38e68e9 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Ey=C3=9Fer?= <daniel.eysser@gmail.com>
Date: Fri, 3 Dec 2021 18:01:09 +0100
Subject: [PATCH 111/143] yt-dlp: update to 2021.12.01.

---
 srcpkgs/yt-dlp/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/yt-dlp/template b/srcpkgs/yt-dlp/template
index 9432641a5e73..5e0e5fe9e2e0 100644
--- a/srcpkgs/yt-dlp/template
+++ b/srcpkgs/yt-dlp/template
@@ -1,19 +1,19 @@
 # Template file for 'yt-dlp'
 pkgname=yt-dlp
-version=2021.11.10.1
-revision=2
+version=2021.12.01
+revision=1
 wrksrc="$pkgname"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
-checkdepends="python3-pytest flake8 python3-nose"
 depends="python3"
+checkdepends="python3-pytest flake8 python3-nose"
 short_desc="CLI program to download videos from YouTube and other sites"
 maintainer="Michal Vasilek <michal@vasilek.cz>"
 license="Unlicense"
 homepage="https://github.com/yt-dlp/yt-dlp"
 changelog="https://raw.githubusercontent.com/yt-dlp/yt-dlp/master/Changelog.md"
 distfiles="https://github.com/yt-dlp/yt-dlp/releases/download/$version/yt-dlp.tar.gz"
-checksum=2eb1c67e095ded9d328eaa0e6e26952248b55dd1031a3751c6d60b759aefa16a
+checksum=bf0cc22d17ffbe59c0d0378026ff135a996b86c546ec9713d838f952dea61e0f
 
 do_check() {
 	PYTHON=/usr/bin/python3 make offlinetest

From 876a05a3ad0118fb1c22ca0075a1f48c746944cf Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Ey=C3=9Fer?= <daniel.eysser@gmail.com>
Date: Fri, 3 Dec 2021 11:53:08 +0100
Subject: [PATCH 112/143] scrcpy: update to 1.21.

---
 srcpkgs/scrcpy/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/scrcpy/template b/srcpkgs/scrcpy/template
index 1fe5ac7102c6..764649fafa4a 100644
--- a/srcpkgs/scrcpy/template
+++ b/srcpkgs/scrcpy/template
@@ -1,6 +1,6 @@
 # Template file for 'scrcpy'
 pkgname=scrcpy
-version=1.20
+version=1.21
 revision=1
 build_style=meson
 configure_args="-Dcompile_server=false
@@ -14,8 +14,8 @@ license="Apache-2.0"
 homepage="https://github.com/Genymobile/scrcpy"
 distfiles="${homepage}/archive/v${version}.tar.gz
  ${homepage}/releases/download/v${version}/scrcpy-server-v${version}"
-checksum="0c667e7de043a67a740be99d3f236a7aa4107ff62c408e7c462f4fe291f045a7
- b20aee4951f99b060c4a44000ba94de973f9604758ef62beb253b371aad3df34"
+checksum="76e16a894bdb483b14b7ae7dcc1be8036ec17924dfab070cf0cb3b47653a6822
+ dbcccab523ee26796e55ea33652649e4b7af498edae9aa75e4d4d7869c0ab848"
 skip_extraction="scrcpy-server-v${version}"
 
 post_install() {

From a9820bae23de592f4e814518c3be29b0d6438f85 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Ey=C3=9Fer?= <daniel.eysser@gmail.com>
Date: Fri, 3 Dec 2021 18:45:41 +0100
Subject: [PATCH 113/143] fdupes: update to 2.1.2.

---
 srcpkgs/fdupes/template | 11 +++--------
 1 file changed, 3 insertions(+), 8 deletions(-)

diff --git a/srcpkgs/fdupes/template b/srcpkgs/fdupes/template
index 4b409f902b73..1bfa0a775980 100644
--- a/srcpkgs/fdupes/template
+++ b/srcpkgs/fdupes/template
@@ -1,20 +1,15 @@
 # Template file for 'fdupes'
 pkgname=fdupes
-version=2.1.1
+version=2.1.2
 revision=1
 build_style=gnu-configure
-hostmakedepends="autoconf automake"
 makedepends="ncurses-devel pcre2-devel"
 short_desc="Identify or delete duplicate files within specified directories"
 maintainer="Steven R <dev@styez.com>"
 license="MIT"
 homepage="https://github.com/adrianlopezroche/fdupes"
-distfiles="https://github.com/adrianlopezroche/fdupes/archive/v${version}.tar.gz"
-checksum=37b1a499f6eb8b625b45641a2600be69ef591cd1e737e75afd50aa72ac215ea4
-
-pre_configure() {
-	autoreconf --install
-}
+distfiles="https://github.com/adrianlopezroche/fdupes/releases/download/v${version}/fdupes-${version}.tar.gz"
+checksum=cd5cb53b6d898cf20f19b57b81114a5b263cc1149cd0da3104578b083b2837bd
 
 post_install() {
 	vlicense README

From 684fdd212b847221929a53b7126794bdb1da41d2 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C3=89rico=20Nogueira?= <erico.erc@gmail.com>
Date: Fri, 3 Dec 2021 15:44:13 -0300
Subject: [PATCH 114/143] Rocket.Chat-Desktop: fix checksum.

---
 srcpkgs/Rocket.Chat-Desktop/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/Rocket.Chat-Desktop/template b/srcpkgs/Rocket.Chat-Desktop/template
index 58f2eed1d9ba..6d87c8b6945b 100644
--- a/srcpkgs/Rocket.Chat-Desktop/template
+++ b/srcpkgs/Rocket.Chat-Desktop/template
@@ -12,7 +12,7 @@ maintainer="John <me@johnnynator.dev>"
 license="MIT"
 homepage="https://rocket.chat/"
 distfiles="https://github.com/RocketChat/Rocket.Chat.Electron/archive/${version}.tar.gz"
-checksum=328707d85b847214e0fe92bd3e45d757c7a27f24532c2f6d353dd045458fee80
+checksum=5b37d497f1985ca74b6a7971ae54a2741e9214c4e83cf754177f2fa444824f12
 
 export USE_SYSTEM_APP_BUILDER=true
 

From 6c9fd95ef092c24ad88114d7035e96123fcab0e2 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C3=89rico=20Nogueira?= <erico.erc@gmail.com>
Date: Sat, 27 Nov 2021 14:57:04 -0300
Subject: [PATCH 115/143] libreoffice: update to 7.2.3.2.

- remove VLC entirely (deprecated by upstream)
- update vendored tarballs
- add zxing and cmis tarballs (zxing isn't packaged by void, cmis
  upstream doesn't make releases with the necessary changes, see [1])
- builds were erroring out if the translation, dictionaries and help
  tarballs weren't unpacked, so remove them from the skip_extraction
  list, but still symlink them into the external dir so the build system
  doesn't try to download them
- move most subpackages to depend on writer, since it contains some of
  the needed pieces for them. This closes #34304
- remove outdated permission fix for soffice

[1] https://github.com/tdf/libcmis/issues/42
---
 .../libreoffice/patches/fix-vlc-backend.patch | 20 -----
 srcpkgs/libreoffice/template                  | 84 ++++++++++---------
 2 files changed, 43 insertions(+), 61 deletions(-)
 delete mode 100644 srcpkgs/libreoffice/patches/fix-vlc-backend.patch

diff --git a/srcpkgs/libreoffice/patches/fix-vlc-backend.patch b/srcpkgs/libreoffice/patches/fix-vlc-backend.patch
deleted file mode 100644
index 2c121c8ad2c6..000000000000
--- a/srcpkgs/libreoffice/patches/fix-vlc-backend.patch
+++ /dev/null
@@ -1,20 +0,0 @@
- vcl: fix build with vlc backend enabled
- 
- avmedia/source/vlc/vlcplayer.cxx tries to access the aWindow member
- directly, which leads to a compilation failure, since it's private.
-
-diff --git include/vcl/sysdata.hxx include/vcl/sysdata.hxx
-index 63b7c810de3d..0cd0e037c823 100644
---- a/include/vcl/sysdata.hxx
-+++ b/include/vcl/sysdata.hxx
-@@ -73,9 +73,8 @@ struct VCL_DLLPUBLIC SystemEnvData
-     // however, the GTK3 vclplug wants to store pointers in here!
-     sal_IntPtr          aShellWindow;   // the window of the frame's shell
-     Platform            platform;       // the windowing system in use
--private:
--    sal_uIntPtr         aWindow;        // the window of the object
- public:
-+    sal_uIntPtr         aWindow;        // the window of the object
- 
-     void SetWindowHandle(sal_uIntPtr nWindow)
-     {
diff --git a/srcpkgs/libreoffice/template b/srcpkgs/libreoffice/template
index 6ea455c5c0cb..9e3208ccf364 100644
--- a/srcpkgs/libreoffice/template
+++ b/srcpkgs/libreoffice/template
@@ -1,7 +1,7 @@
 # Template file for 'libreoffice'
 pkgname=libreoffice
-version=7.1.3.2
-revision=4
+version=7.2.3.2
+revision=1
 build_style=meta
 make_build_target="build-nocheck"
 nocross="Several dependencies are nocross=yes"
@@ -12,14 +12,14 @@ hostmakedepends="automake flex git gperf hyphen icu libtool openldap which gette
 makedepends="CoinMP-devel apr-devel avahi-libs-devel clucene-devel
  frameworkintegration-devel glyphy-devel gpgmepp-devel gst-plugins-base1-devel
  gtk+-devel gtk+3-devel hunspell-devel hyphen-devel libXt-devel libabw-devel
- libatomic_ops-devel libbluetooth-devel libcdr-devel libcmis-devel libe-book-devel
+ libatomic_ops-devel libbluetooth-devel libcdr-devel libe-book-devel
  libepubgen-devel libetonyek-devel libexttextcat-devel libfbclient3-devel libfreehand-devel
  libgcrypt-devel libgltf-devel libldap-devel libmariadbclient-devel libmspub-devel
  libmwaw-devel libnumbertext-devel libodfgen-devel liborcus-devel
  libpagemaker-devel libqxp-devel librsvg-devel libvisio-devel libwpg-devel
  libwps-devel lpsolve-devel mdds mythes-devel neon-devel nss-devel
  postgresql-libs-devel python3-devel qt5-devel redland-devel sane-devel
- telepathy-glib-devel unixodbc-devel vigra-devel vlc-devel libcppunit-devel
+ telepathy-glib-devel unixodbc-devel vigra-devel libcppunit-devel
  qrcodegen-devel xmlsec1-devel poppler-cpp-devel libxml2-devel"
 depends="libreoffice-common>=${version}_${revision}"
 depends+=" libreoffice-base>=${version}_${revision}"
@@ -59,18 +59,20 @@ distfiles="
  ${_baseurl}/${pkgname}-translations-${version}.tar.xz
  ${_addurl}/798b2ffdc8bcfe7bca2cf92b62caf685-rhino1_5R5.zip
  ${_addurl}/a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.zip
- ${_addurl}/language-subtag-registry-2019-04-03.tar.bz2
+ ${_addurl}/ace6ab49184e329db254e454a010f56d-libxml-1.1.7.zip
+ ${_addurl}/language-subtag-registry-2021-03-05.tar.bz2
  ${_addurl}/17410483b5b5f267aa18b7e00b65e6e0-hsqldb_1_8_0.zip
  ${_addurl}/d8bd5eed178db6e2b18eeed243f85aa8-flute-1.1.6.zip
  ${_addurl}/ba2930200c9f019c2d93a8c88c651a0f-flow-engine-0.9.4.zip
  ${_addurl}/b63e6340a02ff1cacfeadb2c42286161-JLanguageTool-1.7.0.tar.bz2
  ${_addurl}/box2d-2.3.1.tar.gz
+ ${_addurl}/libcmis-0.5.2.tar.xz
  ${_addurl}/libstaroffice-0.0.7.tar.xz
  ${_addurl}/libzmf-0.0.2.tar.xz
- ${_addurl}/pdfium-4306.tar.bz2
+ ${_addurl}/pdfium-4500.tar.bz2
  ${_addurl}/bae83fa5dc7f081768daace6e199adc3-glm-0.9.4.6-libreoffice.zip
  ${_exturl}/8249374c274932a21846fa7629c2aa9b-officeotron-0.7.4-master.jar
- ${_exturl}/odfvalidator-1.2.0-incubating-SNAPSHOT-jar-with-dependencies-971c54fd38a968f5860014b44301872706f9e540.jar
+ ${_exturl}/odfvalidator-0.9.0-RC2-SNAPSHOT-jar-with-dependencies-2726ab578664434a545f8379a01a9faffac0ae73.jar
  ${_exturl}/185d60944ea767075d27247c3162b3bc-unowinreg.dll
  ${_addurl}/commons-logging-1.2-src.tar.gz
  ${_addurl}/dtoa-20180411.tgz
@@ -87,45 +89,48 @@ distfiles="
  ${_addurl}/f94d9870737518e3b597f9265f4e9803-libserializer-1.1.6.zip
  ${_addurl}/7239a4430efd4d0189c4f24df67f08e5-mysql-connector-c++-1.1.4.tar.gz
  ${_addurl}/39bb3fcea1514f1369fcfc87542390fd-sacjava-1.3.zip
- ${_addurl}/skia-m88-59bafeeaa7de9eb753e3778c414e01dcf013dcd8.tar.xz
+ ${_addurl}/skia-m90-45c57e116ee0ce214bdf78405a4762722e4507d9.tar.xz
  ${_addurl}/368f114c078f94214a308a74c7e991bc-crosextrafonts-20130214.tar.gz
  ${_addurl}/c74b7223abe75949b4af367942d96c7a-crosextrafonts-carlito-20130920.tar.gz
  ${_addurl}/33e1e61fab06a547851ed308b4ffef42-dejavu-fonts-ttf-2.37.zip
  ${_addurl}/1725634df4bb3dcb1b2c91a6175f8789-GentiumBasic_1102.zip
  ${_addurl}/liberation-narrow-fonts-ttf-1.07.6.tar.gz
- ${_addurl}/liberation-fonts-ttf-2.00.4.tar.gz
+ ${_addurl}/liberation-fonts-ttf-2.1.4.tar.gz
  ${_addurl}/e7a384790b13c29113e22e596ade9687-LinLibertineG-20120116.zip
  ${_addurl}/907d6e99f241876695c19ff3db0b8923-source-code-pro-2.030R-ro-1.050R-it.tar.gz
  ${_addurl}/edc4d741888bc0d38e32dbaa17149596-source-sans-pro-2.010R-ro-1.065R-it.tar.gz
  ${_addurl}/source-serif-pro-3.000R.tar.gz
  ${_addurl}/EmojiOneColor-SVGinOT-1.3.tar.gz
  ${_addurl}/noto-fonts-20171024.tar.gz
- ${_addurl}/culmus-0.131.tar.gz
+ ${_addurl}/culmus-0.133.tar.gz
  ${_addurl}/libre-hebrew-1.0.tar.gz
  ${_addurl}/alef-1.001.tar.gz
  ${_addurl}/ttf-kacst_2.01+mry.tar.gz
+ ${_addurl}/zxing-cpp-1.1.1.tar.gz
  ${_addurl}/Amiri-0.111.zip
  ${_addurl}/ReemKufi-0.7.zip
  ${_addurl}/Scheherazade-2.100.zip
 "
-checksum="35af7fd104b253704f770a205f835aee0e82ccc889ebf0949a89d9b3276229bf
- 66dc5fd4253f6b956b8fdde0d741ef7d85f12647db235642eb74f3d0a44d404e
- e0f14b4db1585506761ad2ceeb43850cb594f2ec8a20fc9ca7bcb95e77408935
- 86138935d274d46d27e4ce92a72d759e7d4491d7b227be952e05735ba5c9b327
+checksum="56c97374956d98c8efcd6d58771c0950c8a641ed84fd64db66382884c4c3b451
+ 41ca87cf71842696c9e21c6c01eb6ade5018a5e07f7cd8745c694b74ba3a185b
+ 087e1444294afe5ab49ea37a2c78c055c2a39000e8979017dd6bb2025d2cae79
+ 07f51594fcb32fb3373e94304bade1b91b6d8b5551f8e688da777e4f520448ec
  1fb458d6aab06932693cc8a9b6e4e70944ee1ff052fa63606e3131df34e21753
  75823776fb51a9c526af904f1503a7afaaab900fba83eda64f8a41073724c870
- a1d7fb901764bb8f251d4f686cdf565764f9987d0fb5d9315d54a7366a84822d
+ 7d2797fe9f79a77009721e3f14fa4a1dec17a6d706bdc93f85f1f01d124fab66
+ ce80e8face06bf2ada363e0c159e3f990c4116fdae9232ca43e6369aa82bf16a
  d30b13f4ba2e3b6a2d4f020c0dee0a9fb9fc6fbcc2d561f36b78da4bf3802370
  1b5b24f7bc543c0362b667692f78db8bab4ed6dafc6172f104d0bd3757d8a133
  233f66e8d25c5dd971716d4200203a612a407649686ef3b52075d04b4c9df0dd
  48c87e41636783bba438b65fd895821e369ed139e1465fac654323ad93c5a82d
  58ffc8475a8650aadc351345aef696937747b40501ab78d72c197c5ff5b3035c
+ d7b18d9602190e10d437f8a964a32e983afd57e2db316a07d87477a79f5000a2
  f94fb0ad8216f97127bedef163a45886b43c62deac5e5b0f5e628e234220c8db
  27051a30cb057fdb5d5de65a1f165c7153dc76e27fe62251cbb86639eb2caf22
- eca406d47ac7e2a84dcc86f93c08f96e591d409589e881477fa75e488e4851d8
+ 26a03dd60e5ed0979cdaba9cc848242895110ddfdf347d40989ce2f14020f304
  d0312c360efe04dd048b3311fe375ff36f1993b4c2e3cb58c81062990532904a
  f2443f27561af52324eee03a1892d9f569adc8db9e7bca55614898bc2a13a770
- 984f2a479df79e27e7b01a5815ac53ae64e07746b882262d8a64566494515504
+ d55495ab3a86544650587de2a72180ddf8bfc6376d14ddfa923992dbc86a06e0
  eafde646a7dbe46d20c291685b0beac2382174d78d66ee990e229a1bf6e6cec6
  49665da5a60d033e6dff40fe0a7f9173e886ae859ce6096c1afe34c48b677c81
  0082d0684f7db6f62361b76c4b7faba19e0c7ce5cb8e36c4b65fea8281e711b4
@@ -142,44 +147,44 @@ checksum="35af7fd104b253704f770a205f835aee0e82ccc889ebf0949a89d9b3276229bf
  05640a1f6805b2b2d7e2cb9c50db9a5cb084e3c52ab1a71ce015239b4a1d4343
  a25f14dad39e93a2f9cdf09166ee53981f7212dce829e4208e07a522963a8585
  085f2112c51fa8c1783fac12fbd452650596415121348393bb51f0f7e85a9045
- f293656a15342a53bb407b932fc907c6894178a162f09728bd383e24d84b1301
+ abe0b94d54edb717c58d74263f4ed3d27824d2ce9e9f2ce85a21ab38d993f94d
  c48d1c2fd613c9c06c959c34da7b8388059e2408d2bb19845dc3ed35f76e4d09
  4bd12b6cbc321c1cf16da76e2c585c925ce956a08067ae6f6c64eff6ccfdaf5a
  7576310b219e04159d35ff61dd4a4ec4cdba4f35c00e002a136f00e96a908b0a
  2f1a2c5491d7305dffd3520c6375d2f3e14931ee35c6d8ae1e8f098bf1a7b3cc
  8879d89b5ff7b506c9fc28efc31a5c0b954bbe9333e66e5283d27d20a8519ea3
- c40e95fc5e0ecb73d4be565ae2afc1114e2bc7dc5253e00ee92d8fd6cc4adf45
+ 26f85412dd0aa9d061504a1cc8aaf0aa12a70710e8d47d8b65a1251757c1a5ef
  54adcb2bc8cac0927a647fbd9362f45eff48130ce6e2379dc3867643019e08c5
  09466dce87653333f189acd8358c60c6736dcd95f042dee0b644bdcf65b6ae2f
  e7bc9a1fec787a529e49f5a26b93dcdcf41506449dfc70f92cdef6d17eb6fb61
  826a2b784d5cdb4c2bbc7830eb62871528360a61a52689c102a101623f1928e3
  d1a08f7c10589f22740231017694af0a7a270760c8dec33d8d1c038e2be0a0c7
  29acc15a4c4d6b51201ba5d60f303dfbc2e5acbfdb70413c9ae1ed34fa259994
- dcf112cfcccb76328dcfc095f4d7c7f4d2f7e48d0eed5e78b100d1d77ce2ed1b
+ c0c6873742d07544f6bacf2ad52eb9cb392974d56427938dc1dfbc8399c64d05
  f596257c1db706ce35795b18d7f66a4db99d427725f20e9384914b534142579a
  b98b67602a2c8880a1770f0b9e37c190f29a7e2ade5616784f0b89fbdb75bf52
  dca00f5e655f2f217a766faa73a81f542c5c204aa3a47017c3c2be0b31d00a56
+ e595b3fa2ec320beb0b28f6af56b1141853257c2611686685639cebb3b248c86
  1fbfccced6348b5db2c1c21d5b319cd488e14d055702fa817a0f6cb83d882166
  f60c6508d209ce4236d2d7324256c2ffddd480be7e3d6023770b93dc391a605f
  251c8817ceb87d9b661ce1d5b49e732a0116add10abc046be4b8ba5196e149b5"
 skip_extraction="
- ${pkgname}-dictionaries-${version}.tar.xz
- ${pkgname}-help-${version}.tar.xz
- ${pkgname}-translations-${version}.tar.xz
  798b2ffdc8bcfe7bca2cf92b62caf685-rhino1_5R5.zip
  a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.zip
- language-subtag-registry-2019-04-03.tar.bz2
+ ace6ab49184e329db254e454a010f56d-libxml-1.1.7.zip
+ language-subtag-registry-2021-03-05.tar.bz2
  17410483b5b5f267aa18b7e00b65e6e0-hsqldb_1_8_0.zip
  d8bd5eed178db6e2b18eeed243f85aa8-flute-1.1.6.zip
  ba2930200c9f019c2d93a8c88c651a0f-flow-engine-0.9.4.zip
  b63e6340a02ff1cacfeadb2c42286161-JLanguageTool-1.7.0.tar.bz2
  box2d-2.3.1.tar.gz
+ libcmis-0.5.2.tar.xz
  libstaroffice-0.0.7.tar.xz
  libzmf-0.0.2.tar.xz
- pdfium-4306.tar.bz2
+ pdfium-4500.tar.bz2
  bae83fa5dc7f081768daace6e199adc3-glm-0.9.4.6-libreoffice.zip
  8249374c274932a21846fa7629c2aa9b-officeotron-0.7.4-master.jar
- odfvalidator-1.2.0-incubating-SNAPSHOT-jar-with-dependencies-971c54fd38a968f5860014b44301872706f9e540.jar
+ odfvalidator-0.9.0-RC2-SNAPSHOT-jar-with-dependencies-2726ab578664434a545f8379a01a9faffac0ae73.jar
  185d60944ea767075d27247c3162b3bc-unowinreg.dll
  commons-logging-1.2-src.tar.gz
  dtoa-20180411.tgz
@@ -196,23 +201,24 @@ skip_extraction="
  f94d9870737518e3b597f9265f4e9803-libserializer-1.1.6.zip
  7239a4430efd4d0189c4f24df67f08e5-mysql-connector-c++-1.1.4.tar.gz
  39bb3fcea1514f1369fcfc87542390fd-sacjava-1.3.zip
- skia-m88-59bafeeaa7de9eb753e3778c414e01dcf013dcd8.tar.xz
+ skia-m90-45c57e116ee0ce214bdf78405a4762722e4507d9.tar.xz
  368f114c078f94214a308a74c7e991bc-crosextrafonts-20130214.tar.gz
  c74b7223abe75949b4af367942d96c7a-crosextrafonts-carlito-20130920.tar.gz
  33e1e61fab06a547851ed308b4ffef42-dejavu-fonts-ttf-2.37.zip
  1725634df4bb3dcb1b2c91a6175f8789-GentiumBasic_1102.zip
  liberation-narrow-fonts-ttf-1.07.6.tar.gz
- liberation-fonts-ttf-2.00.4.tar.gz
+ liberation-fonts-ttf-2.1.4.tar.gz
  e7a384790b13c29113e22e596ade9687-LinLibertineG-20120116.zip
  907d6e99f241876695c19ff3db0b8923-source-code-pro-2.030R-ro-1.050R-it.tar.gz
  edc4d741888bc0d38e32dbaa17149596-source-sans-pro-2.010R-ro-1.065R-it.tar.gz
  source-serif-pro-3.000R.tar.gz
  EmojiOneColor-SVGinOT-1.3.tar.gz
  noto-fonts-20171024.tar.gz
- culmus-0.131.tar.gz
+ culmus-0.133.tar.gz
  libre-hebrew-1.0.tar.gz
  alef-1.001.tar.gz
  ttf-kacst_2.01+mry.tar.gz
+ zxing-cpp-1.1.1.tar.gz
  Amiri-0.111.zip
  ReemKufi-0.7.zip
  Scheherazade-2.100.zip
@@ -394,7 +400,7 @@ _add_lang zu		"Zulu"
 post_fetch() {
 	local srcdistdir=${XBPS_SRCDISTDIR}/${pkgname}-${version} pkg
 	mkdir -p ${wrksrc}/external/tarballs
-	for pkg in ${skip_extraction}; do
+	for pkg in ${skip_extraction} libreoffice-{dictionaries,help,translations}-${version}.tar.xz ; do
 		if [ "${pkg%.dll}" != "${pkg}" ]; then
 			# The dll needs to be copied instead of symlinked
 			cp -v ${srcdistdir}/${pkg} ${wrksrc}/external/tarballs/
@@ -454,7 +460,6 @@ do_configure() {
 	opts+=" --enable-gtk3"
 	opts+=" --enable-qt5"
 	opts+=" --enable-kf5"
-	opts+=" --enable-vlc"
 	opts+=" --disable-dependency-tracking"
 	opts+=" --enable-release-build"
 	opts+=" --enable-split-app-modules"
@@ -488,12 +493,14 @@ do_configure() {
 	fi
 	opts+=" --with-tls=nss"
 	opts+=" --without-system-box2d"
+	opts+=" --without-system-libcmis"
 	opts+=" --without-system-libzmf"
 	opts+=" --without-system-libstaroffice"
 	opts+=" --without-system-libtommath"
 	opts+=" --without-system-jfreereport"
 	opts+=" --without-system-apache-commons"
 	opts+=" --without-system-beanshell"
+	opts+=" --without-system-zxing"
 	# opts+=" --without-system-glm"
 	opts+=" --with-myspell-dicts"
 	opts+=" --with-system-icu-for-build=yes"
@@ -515,11 +522,6 @@ do_configure() {
 do_build() {
 	make ${makejobs} ${make_build_target}
 	make ${makejobs} -C libreofficekit
-
-	# on some platforms (32-bit ppc at least), this single file has
-	# incorrect (non-executable) permissions, so fix it here
-	# only this file is affected and i have no idea why...
-	chmod 755 ${wrksrc}/instdir/program/soffice
 }
 
 do_install() {
@@ -540,7 +542,7 @@ libreoffice-common_package() {
 
 libreoffice-base_package() {
 	short_desc+=" - Database frontend"
-	depends="libreoffice-common>=${version}_${revision}"
+	depends="libreoffice-writer>=${version}_${revision}"
 	noverifyrdeps=yes
 	pkg_install() {
 		_split base
@@ -549,7 +551,7 @@ libreoffice-base_package() {
 
 libreoffice-calc_package() {
 	short_desc+=" - Spreadsheet"
-	depends="libreoffice-common>=${version}_${revision}"
+	depends="libreoffice-writer>=${version}_${revision}"
 	noverifyrdeps=yes
 	pkg_install() {
 		_split calc
@@ -558,7 +560,7 @@ libreoffice-calc_package() {
 
 libreoffice-draw_package() {
 	short_desc+=" - Drawing application"
-	depends="sane libreoffice-common>=${version}_${revision}"
+	depends="sane libreoffice-writer>=${version}_${revision}"
 	noverifyrdeps=yes
 	pkg_install() {
 		_split draw
@@ -585,7 +587,7 @@ libreoffice-gnome_package() {
 
 libreoffice-impress_package() {
 	short_desc+=" - Presentation application"
-	depends="libreoffice-common>=${version}_${revision}"
+	depends="libreoffice-writer>=${version}_${revision}"
 	noverifyrdeps=yes
 	pkg_install() {
 		_split impress
@@ -616,7 +618,7 @@ libreoffice-kit_package() {
 
 libreoffice-math_package() {
 	short_desc+=" - Equation editor"
-	depends="libreoffice-common>=${version}_${revision}"
+	depends="libreoffice-writer>=${version}_${revision}"
 	noverifyrdeps=yes
 	pkg_install() {
 		_split math

From e92096a7505f42d92a02dfba9d5b8868d3f5270c Mon Sep 17 00:00:00 2001
From: ologantr <mrphyber@protonmail.com>
Date: Thu, 2 Dec 2021 13:04:03 +0100
Subject: [PATCH 116/143] sqlite: update to 3.37.0

---
 srcpkgs/sqlite/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/sqlite/template b/srcpkgs/sqlite/template
index 5a2c6dfcca5f..cf993a2c88fe 100644
--- a/srcpkgs/sqlite/template
+++ b/srcpkgs/sqlite/template
@@ -1,6 +1,6 @@
 # Template file for 'sqlite'
 pkgname=sqlite
-version=3.36.0
+version=3.37.0
 revision=1
 _amalgamationver=$(printf "%d%02d%02d00\n" ${version//./ })
 wrksrc="sqlite-autoconf-${_amalgamationver}"
@@ -13,7 +13,7 @@ license="Public Domain"
 homepage="https://sqlite.org/"
 changelog="https://www.sqlite.org/releaselog/${version//./_}.html"
 distfiles="${homepage}/2021/sqlite-autoconf-${_amalgamationver}.tar.gz"
-checksum=bd90c3eb96bee996206b83be7065c9ce19aef38c3f4fb53073ada0d0b69bbce3
+checksum=731a4651d4d4b36fc7d21db586b2de4dd00af31fd54fb5a9a4b7f492057479f7
 
 CFLAGS="-DSQLITE_ENABLE_DBSTAT_VTAB -DSQLITE_ENABLE_COLUMN_METADATA \
  -DSQLITE_ENABLE_UNLOCK_NOTIFY -DSQLITE_SECURE_DELETE -DSQLITE_ENABLE_JSON1 \

From 474cbbfee8ad178ae140e09ac48cd77a47273344 Mon Sep 17 00:00:00 2001
From: ologantr <mrphyber@protonmail.com>
Date: Thu, 2 Dec 2021 13:07:51 +0100
Subject: [PATCH 117/143] fossil: update to 2.17

---
 srcpkgs/fossil/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/fossil/template b/srcpkgs/fossil/template
index 674bfc2d632e..63323b9f1f02 100644
--- a/srcpkgs/fossil/template
+++ b/srcpkgs/fossil/template
@@ -1,6 +1,6 @@
 # Template file for 'fossil'
 pkgname=fossil
-version=2.16
+version=2.17
 revision=1
 build_style=configure
 configure_args="--disable-internal-sqlite --prefix=/usr"
@@ -12,7 +12,7 @@ license="BSD-2-Clause"
 homepage="https://www.fossil-scm.org"
 changelog="https://www.fossil-scm.org/home/doc/trunk/www/changes.wiki"
 distfiles="https://fossil-scm.org/home/tarball/version-${version}/fossil-${version}.tar.gz"
-checksum=1eab740b04d98d2c35776fea65eba86007ea1441d2116943eb0a67e18a88b2fc
+checksum=21d6ee5187775113f74e55ab5ebcb1764f7226a8e59be1b2c7896cbe9dce6914
 
 post_extract() {
 	vsed -i 's/test_system_sqlite$/# &/' auto.def  # failing on cross

From 9ce4b6016022806eadb6874e4355f83cdc7cc21b Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Ey=C3=9Fer?= <daniel.eysser@gmail.com>
Date: Sat, 27 Nov 2021 13:45:35 +0100
Subject: [PATCH 118/143] fd: update to 8.3.0.

---
 srcpkgs/fd/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/fd/template b/srcpkgs/fd/template
index f7d5cfc6b0c7..7b8fe10e0a50 100644
--- a/srcpkgs/fd/template
+++ b/srcpkgs/fd/template
@@ -1,6 +1,6 @@
 # Template file for 'fd'
 pkgname=fd
-version=8.2.1
+version=8.3.0
 revision=1
 build_style=cargo
 short_desc="Simple, fast and user-friendly alternative to find"
@@ -9,7 +9,7 @@ license="Apache-2.0, MIT"
 homepage="https://github.com/sharkdp/fd"
 changelog="https://raw.githubusercontent.com/sharkdp/fd/master/CHANGELOG.md"
 distfiles="https://github.com/sharkdp/fd/archive/v${version}.tar.gz"
-checksum=429de7f04a41c5ee6579e07a251c72342cd9cf5b11e6355e861bb3fffa794157
+checksum=3c5a8a03c4f6ade73b92432ed0ba51591db19b0d136073fa3ccfa99d63403d52
 
 post_install() {
 	vman doc/fd.1

From 6f0c1a597b5a8c9a4b332cdc396e482584299a57 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Fri, 3 Dec 2021 16:53:50 +0100
Subject: [PATCH 119/143] isync: update to 1.4.4.

---
 srcpkgs/isync/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/isync/template b/srcpkgs/isync/template
index bad7086f050f..e72235d5b77e 100644
--- a/srcpkgs/isync/template
+++ b/srcpkgs/isync/template
@@ -1,6 +1,6 @@
 # Template file for 'isync'
 pkgname=isync
-version=1.4.3
+version=1.4.4
 revision=1
 build_style=gnu-configure
 hostmakedepends="perl pkg-config"
@@ -12,7 +12,7 @@ license="GPL-2.0-or-later"
 homepage="http://isync.sourceforge.net/"
 changelog="https://sourceforge.net/p/isync/isync/ci/master/tree/NEWS?format=raw"
 distfiles="${SOURCEFORGE_SITE}/${pkgname}/${pkgname}-${version}.tar.gz"
-checksum=b4c720745bda3447fbd5b9f71783b23f699a55295917ae7586ee5c22e91b9708
+checksum=7c3273894f22e98330a330051e9d942fd9ffbc02b91952c2f1896a5c37e700ff
 
 post_install() {
 	vsconf src/mbsyncrc.sample

From 01e3fcd95ce2be9c34595ecc2c8209cfd16ee477 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Fri, 3 Dec 2021 16:55:01 +0100
Subject: [PATCH 120/143] janet: update to 1.19.0.

---
 common/shlibs          | 2 +-
 srcpkgs/janet/template | 4 ++--
 2 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index ad60646030fe..abdf7b261f8a 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -3889,7 +3889,7 @@ libcaribou.so.0 libcaribou-0.4.21_3
 libtinyclipboard.so.1 tinyclipboard-16.01_1
 libcbor.so.0.9 libcbor-0.9.0_1
 libfido2.so.1 libfido2-1.6.0_2
-libjanet.so.1.18 janet-1.18.0_1
+libjanet.so.1.19 janet-1.19.0_1
 libOpenImageDenoise.so.1 openimagedenoise-1.3.0_1
 libcbang0.so cbang-1.6.0_3
 libblosc.so.1 c-blosc-1.17.1_1
diff --git a/srcpkgs/janet/template b/srcpkgs/janet/template
index 373b1475e233..c36e4a4e97ab 100644
--- a/srcpkgs/janet/template
+++ b/srcpkgs/janet/template
@@ -1,6 +1,6 @@
 # Template file for 'janet'
 pkgname=janet
-version=1.18.1
+version=1.19.0
 revision=1
 build_style=meson
 configure_args="-Db_lto=false"  # breaks jpm
@@ -10,7 +10,7 @@ license="MIT"
 homepage="https://janet-lang.org/"
 changelog="https://github.com/janet-lang/janet/blob/master/CHANGELOG.md"
 distfiles="https://github.com/janet-lang/janet/archive/v${version}.tar.gz"
-checksum=bfc29c11a070cc175666f74eb99ea992276d6e269701ba9558a72cef05ac80b4
+checksum=613f08613d524349bea9777d9f4f930252a0f035332da113c993153fe5284ef2
 
 post_install() {
 	vlicense LICENSE

From cdddcceb689640652215408ce26564775f04fc84 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Fri, 3 Dec 2021 16:55:34 +0100
Subject: [PATCH 121/143] ugrep: update to 3.3.10.

---
 srcpkgs/ugrep/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/ugrep/template b/srcpkgs/ugrep/template
index 39891a0af99f..75826fd725ac 100644
--- a/srcpkgs/ugrep/template
+++ b/srcpkgs/ugrep/template
@@ -1,6 +1,6 @@
 # Template file for 'ugrep'
 pkgname=ugrep
-version=3.3.8
+version=3.3.10
 revision=1
 build_style=gnu-configure
 makedepends="bzip2-devel liblz4-devel liblzma-devel libzstd-devel pcre2-devel
@@ -10,7 +10,7 @@ maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="BSD-3-Clause"
 homepage="https://github.com/Genivia/ugrep"
 distfiles="https://github.com/Genivia/ugrep/archive/v${version}.tar.gz"
-checksum=1bdc73ca5fc12a41c2f7949900edee0972ca3e5f39066c8d68449846df4cf1d7
+checksum=8cf74bdf254bac78c19385028bbf8678d83be35522d452b71d16105a1c4c57b8
 
 post_install() {
 	vlicense LICENSE.txt LICENSE

From 60d104184c2274384f0bc1b35c5e75c81ca1c668 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Fri, 3 Dec 2021 18:04:38 +0100
Subject: [PATCH 122/143] z3: update to 4.8.13.

---
 srcpkgs/z3/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/z3/template b/srcpkgs/z3/template
index bca042082b3f..fb8aca291c2b 100644
--- a/srcpkgs/z3/template
+++ b/srcpkgs/z3/template
@@ -1,6 +1,6 @@
 # Template file for 'z3'
 pkgname=z3
-version=4.8.12
+version=4.8.13
 revision=4
 wrksrc="${pkgname}-${pkgname}-${version}"
 build_style=configure
@@ -15,7 +15,7 @@ maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="MIT"
 homepage="https://github.com/Z3Prover/z3"
 distfiles="https://github.com/Z3Prover/z3/archive/z3-${version}.tar.gz"
-checksum=e3aaefde68b839299cbc988178529535e66048398f7d083b40c69fe0da55f8b7
+checksum=59a0b35711fa7ae48dd535116d2067a6a16955fcbf2623c516a3f630cd2832d8
 
 build_options="ocaml"
 desc_option_ocaml="Enable support for OCaml bindings"

From 3def35292e87c10131ac4a22fbbaff09632f841e Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Fri, 3 Dec 2021 23:07:07 +0100
Subject: [PATCH 123/143] pymol: update to 2.5.0.

---
 srcpkgs/pymol/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/pymol/template b/srcpkgs/pymol/template
index 75b78380572c..659dea5d368c 100644
--- a/srcpkgs/pymol/template
+++ b/srcpkgs/pymol/template
@@ -1,12 +1,12 @@
 # Template file for 'pymol'
 pkgname=pymol
-version=2.4.0
-revision=3
+version=2.5.0
+revision=1
 wrksrc=${pkgname}-open-source-${version}
 build_style="python3-module"
 build_helper="numpy"
-makedepends="msgpack-devel freetype-devel libfreeglut-devel netcdf-devel
- glew-devel glm python3-devel libxml2-devel python3-PyQt5 mmtf-cpp"
+makedepends="freetype-devel glew-devel glm libfreeglut-devel libgomp-devel
+ libxml2-devel mmtf-cpp msgpack-devel netcdf-devel python3-PyQt5 python3-devel"
 depends="python3-numpy tcsh python3-pmw python3-tkinter python3-PyQt5"
 short_desc="PyMOL molecular visualization system"
 maintainer="Brenton Horne <brentonhorne77@gmail.com>"
@@ -14,7 +14,7 @@ license="custom:PyMOL"
 homepage="https://pymol.org/"
 distfiles="https://github.com/schrodinger/pymol-open-source/archive/v${version}.tar.gz>${pkgname}-${version}.tar.gz
  https://c.fsdn.com/allura/p/${pkgname}/icon>${pkgname}.png"
-checksum="5ede4ce2e8f53713c5ee64f5905b2d29bf01e4391da7e536ce8909d6b9116581
+checksum="aa828bf5719bd9a14510118a93182a6e0cadc03a574ba1e327e1e9780a0e80b3
  0ea81faaf336becc669a193777d0dca55475d303d1236b57df25cf67ff7c2bcd"
 skip_extraction="${pkgname}.png"
 

From d534b3f8cfcf639d1dd0f595254f253ed382b7b1 Mon Sep 17 00:00:00 2001
From: oreo639 <31916379+Oreo639@users.noreply.github.com>
Date: Fri, 26 Nov 2021 23:45:32 -0800
Subject: [PATCH 124/143] New package: webp-pixbuf-loader-0.0.3

---
 srcpkgs/webp-pixbuf-loader/template | 13 +++++++++++++
 1 file changed, 13 insertions(+)
 create mode 100644 srcpkgs/webp-pixbuf-loader/template

diff --git a/srcpkgs/webp-pixbuf-loader/template b/srcpkgs/webp-pixbuf-loader/template
new file mode 100644
index 000000000000..189889b62896
--- /dev/null
+++ b/srcpkgs/webp-pixbuf-loader/template
@@ -0,0 +1,13 @@
+# Template file for 'webp-pixbuf-loader'
+pkgname=webp-pixbuf-loader
+version=0.0.3
+revision=1
+build_style=meson
+hostmakedepends="pkg-config gdk-pixbuf"
+makedepends="gdk-pixbuf-devel libwebp-devel"
+short_desc="WebP Image format loader for GdkPixbuf"
+maintainer="oreo639 <oreo6391@gmail.com>"
+license="LGPL-2.0-or-later"
+homepage="https://github.com/aruiz/webp-pixbuf-loader"
+distfiles="https://github.com/aruiz/webp-pixbuf-loader/archive/refs/tags/${version}.tar.gz"
+checksum=e2ba11afcd1272f26147214659bcf2462066a840ecb9ba2776c85abd0ec43cbe

From c115ba446c553d4a18fe838d94f8eb0a1b1a6050 Mon Sep 17 00:00:00 2001
From: Daniel Lewan <vision360.daniel@gmail.com>
Date: Fri, 3 Dec 2021 23:24:52 +0100
Subject: [PATCH 125/143] s: update to 0.6.2.

---
 srcpkgs/s/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/s/template b/srcpkgs/s/template
index e55d22e4d3d5..cb9c4fc4e4ca 100644
--- a/srcpkgs/s/template
+++ b/srcpkgs/s/template
@@ -1,6 +1,6 @@
 # Template file for 's'
 pkgname=s
-version=0.6.1
+version=0.6.2
 revision=1
 build_helper=qemu
 build_style=go
@@ -11,7 +11,7 @@ maintainer="Daniel Lewan <vision360.daniel@gmail.com>"
 license="MIT"
 homepage="https://github.com/zquestz/s"
 distfiles="https://github.com/zquestz/s/archive/v${version}.tar.gz"
-checksum=8f5f3e9503edcf9eb4792379f93c1e08806b8b9699121a72745d1d63c91a0426
+checksum=acc38953fcb21e1dd2cd761b9d2bf8272aa6aa30fed2adb657f2dba7e4df872f
 
 post_build() {
 	s_cli=$(find $GOPATH/bin -name s)

From 6cc74e6885a806b3307e7923bb092bacc61358f3 Mon Sep 17 00:00:00 2001
From: Daniel Lewan <vision360.daniel@gmail.com>
Date: Fri, 3 Dec 2021 23:26:23 +0100
Subject: [PATCH 126/143] hivemind: update to 1.1.0.

---
 srcpkgs/hivemind/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/hivemind/template b/srcpkgs/hivemind/template
index 935d852b4a5c..ad154844be35 100644
--- a/srcpkgs/hivemind/template
+++ b/srcpkgs/hivemind/template
@@ -1,6 +1,6 @@
 # Template file for 'hivemind'
 pkgname=hivemind
-version=1.0.6
+version=1.1.0
 revision=1
 build_style=go
 go_import_path="github.com/DarthSim/hivemind"
@@ -9,7 +9,7 @@ maintainer="Daniel Lewan <vision360.daniel@gmail.com>"
 license="MIT"
 homepage="https://github.com/DarthSim/hivemind"
 distfiles="https://github.com/DarthSim/hivemind/archive/v${version}.tar.gz"
-checksum=8ca7884db49268b7938d0503e7e95443cb3a56696478d5dcc2b9813705525a39
+checksum=b4f7259663ef5b99906af0d98fe4b964d8f9a4d86a8f5aff30ab8df305d3a996
 
 post_install() {
 	vlicense LICENSE

From a85013a4bbc93363790bc400f3cf825e904564e1 Mon Sep 17 00:00:00 2001
From: Daniel Lewan <vision360.daniel@gmail.com>
Date: Sat, 4 Dec 2021 00:01:44 +0100
Subject: [PATCH 127/143] go: update URLs and install VERSION file

---
 srcpkgs/go/template | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/go/template b/srcpkgs/go/template
index 9aa551c74c53..cc66dc6c7f46 100644
--- a/srcpkgs/go/template
+++ b/srcpkgs/go/template
@@ -1,16 +1,16 @@
 # Template file for 'go'
 pkgname=go
 version=1.17.2
-revision=1
+revision=2
 create_wrksrc=yes
 build_wrksrc=go
 hostmakedepends="go1.12-bootstrap"
 short_desc="Go Programming Language"
 maintainer="Michael Aldridge <maldridge@voidlinux.org>"
 license="BSD-3-Clause"
-homepage="https://golang.org/"
-changelog="https://golang.org/doc/devel/release.html"
-distfiles="https://golang.org/dl/go${version}.src.tar.gz"
+homepage="https://go.dev/"
+changelog="https://go.dev/doc/devel/release.html"
+distfiles="https://go.dev/dl/go${version}.src.tar.gz"
 checksum=2255eb3e4e824dd7d5fcdc2e7f84534371c186312e546fb1086a34c17752f431
 nostrip=yes
 noverifyrdeps=yes
@@ -63,6 +63,7 @@ do_install() {
 	cp -a pkg src lib ${DESTDIR}/usr/lib/go
 	cp -r doc misc -t ${DESTDIR}/usr/share/go
 	ln -s /usr/share/go/doc ${DESTDIR}/usr/lib/go/doc
+	cp VERSION ${DESTDIR}/usr/lib/go/VERSION
 
 	# This is to make go get code.google.com/p/go-tour/gotour and
 	# then running the gotour executable work out of the box.

From 404660c8c37cf556b7fad9cc137afeb1bc5536a3 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Ey=C3=9Fer?= <daniel.eysser@gmail.com>
Date: Fri, 3 Dec 2021 12:02:29 +0100
Subject: [PATCH 128/143] dunst: update to 1.7.2.

---
 srcpkgs/dunst/template | 11 +++++++----
 1 file changed, 7 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/dunst/template b/srcpkgs/dunst/template
index 1b80bf0d1987..3c3d9f5107bd 100644
--- a/srcpkgs/dunst/template
+++ b/srcpkgs/dunst/template
@@ -1,21 +1,24 @@
 # Template file for 'dunst'
 pkgname=dunst
-version=1.7.1
+version=1.7.2
 revision=1
 build_style=gnu-makefile
+make_check_target=test
 make_use_env=yes
-make_build_args="SYSTEMD=0 WAYLAND=$(vopt_if wayland 1 0)"
+make_build_args="SYSTEMD=0 WAYLAND=$(vopt_if wayland 1 0) SYSCONFDIR=/etc"
 make_install_args="$make_build_args"
 hostmakedepends="perl pkg-config"
-makedepends="gtk+-devel libXScrnSaver-devel libXinerama-devel libXrandr-devel
+makedepends="gdk-pixbuf-devel libXScrnSaver-devel libXinerama-devel libXrandr-devel
  libxdg-basedir-devel libnotify-devel $(vopt_if wayland 'wayland-devel wayland-protocols')"
+checkdepends="dbus"
+conf_files="/etc/dunst/dunstrc"
 short_desc="Lightweight and customizable notification daemon"
 maintainer="Daniel Santana <daniel@santana.tech>"
 license="BSD-3-Clause"
 homepage="https://dunst-project.org"
 changelog="https://raw.githubusercontent.com/dunst-project/dunst/master/CHANGELOG.md"
 distfiles="https://github.com/dunst-project/dunst/archive/v${version}.tar.gz"
-checksum=f61ed3280aee9ec2aac07c44cf3d147df8fe8a6d7b92b6e8ab04e546bff1adce
+checksum=e4fa376d327e8a4cd375d00d4c318c93cc0968d4f184ab40da94ca6b30477181
 
 build_options="wayland"
 build_options_default="wayland"

From ef8ff65951470e991e759a58ae6bd07b97dff2d3 Mon Sep 17 00:00:00 2001
From: Tomasz Kramkowski <tk@the-tk.com>
Date: Tue, 16 Nov 2021 20:26:26 +0000
Subject: [PATCH 129/143] nim: update to 1.6.0 (and fixes + cleanup)

Version bump to 1.6.0 including the following changes:

- Nim now comes with testament
- Fusion library is no longer bundled with nim
- Examples no longer come with nim
- FIX - non-x86_64/i686 nim.cfg compiler configuration
  Non-x86_64/i686 builds no longer end up with a broken nim.cfg which
  will try to use the package build time $CC to build packages for the
  package architecture as well as a bunch of others (which will simply
  not work).
- FIX - arm nim.cfg compiler configuration
  The default arm.linux.gcc.(linker)?exe variables are now commented on
  non-x86_64/i686 builds to ensure that arm packages don't end up with
  the same issue as above.
- CLEANUP - use koch to build non-x86_64/i686 tools
  The loop was unnecessary.
  - note: This means nimsuggest is now built without -d:release on all
    builds (not just x86_64/i686 builds). I am not sure if this is
    intentional or an upstream bug, should be investigated at some
    point.
- CLEANUP - use make to build the bootstrap compiler
---
 srcpkgs/nim/template | 66 ++++++++++++++------------------------------
 1 file changed, 21 insertions(+), 45 deletions(-)

diff --git a/srcpkgs/nim/template b/srcpkgs/nim/template
index 76a3452c68ab..809627066a68 100644
--- a/srcpkgs/nim/template
+++ b/srcpkgs/nim/template
@@ -1,13 +1,11 @@
 # Template file for 'nim'
 pkgname=nim
-version=1.4.8
+version=1.6.0
 revision=1
-_cversion=0.20.0
-_nimbleversion=0.12.0
-_fusionversion=e942c649892b2ae3802851fba6bc5d251326e5fb
+_c1version=561b417c65791cd8356b5f73620914ceff845d10
+_nimbleversion=0.13.1
 create_wrksrc=yes
 build_wrksrc="Nim-$version"
-hostmakedepends="ed"
 depends="gcc openssl-devel"
 short_desc="Nim programming language"
 maintainer="allan <mail@may.mooo.com>"
@@ -15,31 +13,27 @@ license="MIT"
 homepage="https://nim-lang.org/"
 _ghsite="https://github.com/nim-lang"
 distfiles="${_ghsite}/Nim/archive/v${version}.tar.gz
- ${_ghsite}/csources/archive/v${_cversion}.tar.gz>csources-${_cversion}.tar.gz
- ${_ghsite}/nimble/archive/v${_nimbleversion}.tar.gz>nimble-${_nimbleversion}.tar.gz
- ${_ghsite}/fusion/archive/${_fusionversion}.tar.gz>fusion-${_fusionversion}.tar.gz"
-checksum="8a687beb30670dc4eadcfefd1198d4238af283dc716438ac2342a7d65e07d9e9
- 5e6fd15d90df1a8cb7614c4ffc70aa8c4198cd854d7742016202b96dd0228d3c
- 0b88d91a450f31641f85379f2d76afb0a013cf783e62144a6534525b9cb1cbac
- 76d10a2f0f25ba7fb3393bdb800c75e8084758d8ce69e63d07926cd36f555084"
+ ${_ghsite}/csources_v1/archive/${_c1version}.tar.gz>csources_v1-${_c1version}.tar.gz
+ ${_ghsite}/nimble/archive/v${_nimbleversion}.tar.gz>nimble-${_nimbleversion}.tar.gz"
+checksum="c202cfd24a24480da1cf851e1265b87edb22710bb42286a57b1a99c83b6a8315
+ 71c823444c794a12da9027d19d6a717dd7759521ecbbe28190b08372142607ec
+ e6aa8d9ee4b3ed0321dca329b4a38fa546771b9729984482fb50fe73d3777f5d"
 
 post_extract() {
-	mv csources-$_cversion $build_wrksrc/csources
+	mv csources_v1-$_c1version $build_wrksrc/csources_v1
 	mkdir $build_wrksrc/dist
 	mv nimble-$_nimbleversion $build_wrksrc/dist/nimble
-	mv fusion-$_fusionversion $build_wrksrc/dist/fusion
 }
 
 do_build() {
-	cd csources
 	case "$XBPS_TARGET_MACHINE" in
 		i686*)
 			CC=cc LD=cc CFLAGS="-Os -pipe" LDFLAGS= \
-			sh build.sh --cpu i686;;
+			make -C csources_v1 ucpu=i686 ${makejobs};;
 		*)
-			CC=cc LD=cc CFLAGS="-Os -pipe" LDFLAGS= sh build.sh;;
+			CC=cc LD=cc CFLAGS="-Os -pipe" LDFLAGS= \
+			make -C csources_v1 ${makejobs};;
 	esac
-	cd ..
 
 	bin/nim c koch
 	./koch boot -d:release -d:danger
@@ -54,32 +48,15 @@ do_build() {
 
 	case "$XBPS_TARGET_MACHINE"
 	in arm*|aarch64*|ppc*)
-		ed config/nim.cfg <<-EDIT
-			,s/^arm.linux.gcc.exe .*/arm.linux.gcc.exe = "$CC"/
-			,s/^arm.linux.gcc.linkerexe .*/arm.linux.gcc.linkerexe = "$CC"/
-			a
-			arm64.linux.gcc.exe = "$CC"
-			arm64.linux.gcc.linkerexe = "$CC"
-			powerpc.linux.gcc.exe = "$CC"
-			powerpc.linux.gcc.linkerexe = "$CC"
-			powerpc64.linux.gcc.exe = "$CC"
-			powerpc64.linux.gcc.linkerexe = "$CC"
-			powerpc64el.linux.gcc.exe = "$CC"
-			powerpc64el.linux.gcc.linkerexe = "$CC"
-			.
-			w
-			q
+		vsed -i config/nim.cfg -e 's/^arm\.linux\.gcc\.\(linker\)\?exe /#&/'
+		cat >>config/nim.cfg <<-EDIT
+		# VOIDLINUX TEMP
+		$_arch.linux.gcc.exe = "$CC"
+		$_arch.linux.gcc.linkerexe = "$CC"
 		EDIT
 		bin/nim c -d:release -d:danger --os:linux --cpu:$_arch --listCmd compiler/nim
-		for _p in \
-			dist/nimble/src/nimble \
-			tools/nimgrep \
-			nimsuggest/nimsuggest \
-			nimpretty/nimpretty
-		do
-			bin/nim c -d:release --os:linux --cpu:$_arch --listCmd $_p
-			mv $_p bin
-		done
+		./koch tools --os:linux --cpu:$_arch --listCmd
+		vsed -i config/nim.cfg -e '/^# VOIDLINUX TEMP$/,$d'
 	;; *)
 		./koch tools
 	esac
@@ -95,14 +72,13 @@ do_install() {
 	vmkdir usr/bin
 	vmkdir usr/share/nim
 	ln -sf /usr/lib/nim/bin/nim ${DESTDIR}/usr/bin/nim
-	for _f in nimble nimsuggest nimgrep nimpretty; do
+	for _f in nimble nimsuggest nimgrep nimpretty testament; do
 		chmod 0755 bin/$_f
 		cp bin/$_f ${DESTDIR}/usr/lib/nim/bin
 		ln -sf /usr/lib/nim/bin/$_f ${DESTDIR}/usr/bin/$_f
 	done
-	cp -r nimsuggest nimpretty doc examples ${DESTDIR}/usr/lib/nim
+	cp -r nimsuggest nimpretty doc ${DESTDIR}/usr/lib/nim
 	ln -sf /usr/lib/nim/doc ${DESTDIR}/usr/share/nim/doc
-	ln -sf /usr/lib/nim/examples ${DESTDIR}/usr/share/nim/examples
 	ln -sf /usr/lib/nim/nimsuggest ${DESTDIR}/usr/share/nim/nimsuggest
 	ln -sf /usr/lib/nim/nimpretty ${DESTDIR}/usr/share/nim/nimpretty
 	vlicense copying.txt

From 657f164b2470f83f568ecc319bf421fd6ec4ecef Mon Sep 17 00:00:00 2001
From: Henry Naguski <henry@nilsu.org>
Date: Sat, 13 Nov 2021 23:11:21 -0700
Subject: [PATCH 130/143] dolphin-emu: update to 5.0.15445.

---
 srcpkgs/dolphin-emu/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/dolphin-emu/template b/srcpkgs/dolphin-emu/template
index c538c4b97548..35ac6a3910df 100644
--- a/srcpkgs/dolphin-emu/template
+++ b/srcpkgs/dolphin-emu/template
@@ -1,9 +1,9 @@
 # Template file for 'dolphin-emu'
 pkgname=dolphin-emu
-version=5.0.15260
+version=5.0.15445
 revision=1
-_dolphin_commit=207c931a04c8e2629a735bc2b3f36b5c89365ca7
-_mgba_commit=9cccc5197ed73ba0a54f584d3121c27dc97405f5
+_dolphin_commit=db02b50d2ecdfbbc21e19aadc57253c353069f77
+_mgba_commit=40d4c430fc36caeb7ea32fd39624947ed487d2f2
 #Version/hash pair can be found at https://dolphin-emu.org/download/
 archs="x86_64* aarch64* ppc64le* i686*"
 wrksrc="dolphin-${_dolphin_commit}"
@@ -22,8 +22,8 @@ license="GPL-2.0-or-later"
 homepage="http://dolphin-emu.org"
 distfiles="https://github.com/dolphin-emu/dolphin/archive/${_dolphin_commit}.tar.gz
  https://github.com/mgba-emu/mgba/archive/${_mgba_commit}.tar.gz"
-checksum="84b21a6a14cf999e8c2bc44175f549aedaa4bd28a79eaa65afddd72f14905a3a
- d1c9fa071aae747fe1350130a2c69ed618ad52a759b35b119dbb7292252b4a77"
+checksum="19136c7b1bce2ff444e4a611f56268b371f4fa83a3e3ff5f3d9e2dbb34385692
+ 3cabf00a97cf4fb15fe8524b3d02190acdd003f25967cdbbf8de958649b8061b"
 nopie=yes
 
 case "$XBPS_TARGET_MACHINE" in

From dacd1b6758f9b6be1c8a029a62b59c5ba3d41478 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C3=89rico=20Nogueira?= <erico.erc@gmail.com>
Date: Sat, 4 Dec 2021 01:29:26 -0300
Subject: [PATCH 131/143] ImageMagick: update to 7.1.0.15.

---
 srcpkgs/ImageMagick/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/ImageMagick/template b/srcpkgs/ImageMagick/template
index 4648abfb476c..356015153e80 100644
--- a/srcpkgs/ImageMagick/template
+++ b/srcpkgs/ImageMagick/template
@@ -1,6 +1,6 @@
 # Template file for 'ImageMagick'
 pkgname=ImageMagick
-version=7.1.0.10
+version=7.1.0.15
 revision=1
 _majorver=${version%.*}
 _patchver=${version##*.}
@@ -20,7 +20,7 @@ license="ImageMagick"
 homepage="https://www.imagemagick.org"
 changelog="https://imagemagick.org/script/changelog.php"
 distfiles="https://github.com/ImageMagick/ImageMagick/archive/${_majorver}-${_patchver}.tar.gz"
-checksum=a2139da9a7c2e97f28861dfb18986f1d03435cf72e8ee4cc720a4997b5fa8d66
+checksum=0b0272b8bbdeb31b15c06f75764b93b22198453ef7fceabbc07655e90f3c73c2
 
 subpackages="libmagick libmagick-devel"
 

From a7dd8ab18c87747cff32f837c3d10b485775f8f8 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sat, 4 Dec 2021 08:20:48 -0500
Subject: [PATCH 132/143] maturin: update to 0.12.3.

---
 srcpkgs/maturin/patches/edition2018.patch | 18 ------------------
 srcpkgs/maturin/template                  |  4 ++--
 2 files changed, 2 insertions(+), 20 deletions(-)
 delete mode 100644 srcpkgs/maturin/patches/edition2018.patch

diff --git a/srcpkgs/maturin/patches/edition2018.patch b/srcpkgs/maturin/patches/edition2018.patch
deleted file mode 100644
index 7e6b267507b4..000000000000
--- a/srcpkgs/maturin/patches/edition2018.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Void can't yet compile with edition2021 and there seems to be no reason to
-demand it, so partially revert
-
-    https://github.com/PyO3/maturin/commit/4d51112a18a331248bb36c0cb5b4c60c6fe0091a
-
-and make maturin work.
-
---- a/Cargo.toml
-+++ b/Cargo.toml
-@@ -10,7 +10,7 @@
- license = "MIT OR Apache-2.0"
- keywords = ["python", "cffi", "packaging", "pypi", "pyo3"]
- categories = ["api-bindings", "development-tools::ffi", "command-line-utilities"]
--edition = "2021"
-+edition = "2018"
- 
- [badges]
- travis-ci = { repository = "PyO3/maturin" }
diff --git a/srcpkgs/maturin/template b/srcpkgs/maturin/template
index d5eb458e50a5..1556fa8f98c2 100644
--- a/srcpkgs/maturin/template
+++ b/srcpkgs/maturin/template
@@ -1,6 +1,6 @@
 # Template file for 'maturin'
 pkgname=maturin
-version=0.12.2
+version=0.12.3
 revision=1
 build_style=cargo
 build_helper=qemu
@@ -17,7 +17,7 @@ homepage="https://github.com/PyO3/maturin"
 # bump target-lexicon version if it changes in Cargo.lock
 distfiles="${homepage}/archive/v${version}.tar.gz
  https://github.com/bytecodealliance/target-lexicon/archive/v0.12.2.tar.gz>target-lexicon-${version}.tar.gz"
-checksum="d66d21703a78d71061b279b97fb7dd15a925474da19bce9928d87f1c22550ed6
+checksum="9a6ee17bdee33aa319941ca5000016397a2d5343a17341406150c4015aa81b75
  b6c2ddab7498cf6eab8e637a5b7895f3170b2f9ef989861d1ff33af6c8459b27"
 # Tests use unstable features and fail to build
 make_check=no

From 42717b92e9633d7dedc253a44b59bcad21057aa2 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sat, 4 Dec 2021 08:20:59 -0500
Subject: [PATCH 133/143] python3-setuptools-rust: update to 1.1.1.

---
 srcpkgs/python3-setuptools-rust/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-setuptools-rust/template b/srcpkgs/python3-setuptools-rust/template
index 85c562f33602..1811ad4be88e 100644
--- a/srcpkgs/python3-setuptools-rust/template
+++ b/srcpkgs/python3-setuptools-rust/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-setuptools-rust'
 pkgname=python3-setuptools-rust
-version=1.0.0
+version=1.1.1
 revision=1
 wrksrc="${pkgname#python3-}-${version}"
 build_style=python3-module
@@ -13,7 +13,7 @@ license="MIT"
 homepage="https://github.com/PyO3/setuptools-rust"
 changelog="https://raw.githubusercontent.com/PyO3/setuptools-rust/master/CHANGELOG.md"
 distfiles="${PYPI_SITE}/s/setuptools-rust/setuptools-rust-${version}.tar.gz"
-checksum=eb6e6d41f01e63d042288e5c609684adf93426c10ea745ec324263f3fcbf27e9
+checksum=dc04afb52a70e56f5d6800a7ed9c45ad5937ba95e51a042b9096459edc038ad6
 # Tests have unpackaged dependencies
 make_check=no
 

From 6c3ca5e22c095a69c64d2f9427abb0c201c96c34 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sat, 4 Dec 2021 08:22:34 -0500
Subject: [PATCH 134/143] python3-adblock: update to 0.5.1.

---
 srcpkgs/python3-adblock/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-adblock/template b/srcpkgs/python3-adblock/template
index 0d8832be8111..f24a681be0b9 100644
--- a/srcpkgs/python3-adblock/template
+++ b/srcpkgs/python3-adblock/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-adblock'
 pkgname=python3-adblock
-version=0.5.0
-revision=2
+version=0.5.1
+revision=1
 wrksrc="${pkgname/python3/python}-${version}"
 build_style=python3-pep517
 build_helper="rust"
@@ -16,7 +16,7 @@ license="Apache-2.0, MIT"
 homepage="https://github.com/ArniDagur/python-adblock"
 changelog="https://raw.githubusercontent.com/ArniDagur/python-adblock/master/CHANGELOG.md"
 distfiles="${homepage}/archive/${version}.tar.gz"
-checksum=35ab20170bcfe447efee4d988508d99477cc23b95a901383bf606ca2960148a3
+checksum=d24ef42c8532cab2970d1c3af116ee4d0fa595e23fbeabb3ba0f5dfa0a67eae1
 
 case "$XBPS_TARGET_MACHINE" in
 	i686*) broken="compiler throws SIGABRT on the psl crate" ;;

From 8bea736c030b83ab281582bce20e46a057a19034 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sat, 4 Dec 2021 08:29:12 -0500
Subject: [PATCH 135/143] python3-hypothesis: update to 6.30.0.

---
 srcpkgs/python3-hypothesis/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-hypothesis/template b/srcpkgs/python3-hypothesis/template
index 460af8b6cc06..9c88772dc4e8 100644
--- a/srcpkgs/python3-hypothesis/template
+++ b/srcpkgs/python3-hypothesis/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-hypothesis'
 pkgname=python3-hypothesis
-version=6.28.0
+version=6.30.0
 revision=1
 wrksrc="hypothesis-hypothesis-python-${version}"
 build_wrksrc=hypothesis-python
@@ -15,7 +15,7 @@ license="MPL-2.0"
 homepage="https://hypothesis.works/"
 changelog="https://hypothesis.readthedocs.io/en/latest/changes.html"
 distfiles="https://github.com/HypothesisWorks/hypothesis/archive/hypothesis-python-${version}.tar.gz"
-checksum=34a4e30f9a0a88bb48c2faf6d78512fb7978e03e152026e00210245b20356d70
+checksum=d10473a0b5a87eadd8e978067e4e18215cc69f40c1fdcaeedcd0ef89648c8f61
 
 do_check() {
 	# Manually run the tests that tox considers part of the "full" suite,

From d3cfc549e664a03e8630fdda46b565f5bdf5bf2c Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sat, 4 Dec 2021 08:30:22 -0500
Subject: [PATCH 136/143] python3-imageio: update to 2.13.1.

---
 srcpkgs/python3-imageio/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-imageio/template b/srcpkgs/python3-imageio/template
index 21b0e0981e11..00e60a63af44 100644
--- a/srcpkgs/python3-imageio/template
+++ b/srcpkgs/python3-imageio/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-imageio'
 pkgname=python3-imageio
-version=2.12.0
+version=2.13.1
 revision=1
 wrksrc="${pkgname#python3-}-${version}"
 build_style=python3-module
@@ -16,7 +16,7 @@ maintainer="Andrew J. Hesford <ajh@sideband.org>"
 license="BSD-2-Clause"
 homepage="https://github.com/imageio/imageio"
 distfiles="${homepage}/archive/v${version}.tar.gz"
-checksum=e7d1e7b135415db608f32c2feebd139afb9b8379dd4e49c661578f999dfc2cea
+checksum=00c843712d00d075a87bc9eb37c1b6ffe2b210327d8fbaabd52759a961b5b4bd
 
 post_install() {
 	vlicense LICENSE

From 9cc5498c3b3bfe75c52c703c43d048022057405e Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sat, 4 Dec 2021 08:31:58 -0500
Subject: [PATCH 137/143] python3-ipython: update to 7.30.1.

---
 srcpkgs/python3-ipython/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-ipython/template b/srcpkgs/python3-ipython/template
index 85a1ae2e64c5..f2eed91a2d1f 100644
--- a/srcpkgs/python3-ipython/template
+++ b/srcpkgs/python3-ipython/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-ipython'
 pkgname=python3-ipython
-version=7.30.0
+version=7.30.1
 revision=1
 wrksrc="ipython-${version}"
 build_style=python3-module
@@ -16,7 +16,7 @@ maintainer="Andrew J. Hesford <ajh@sideband.org>"
 license="BSD-3-Clause"
 homepage="https://ipython.org/"
 distfiles="${PYPI_SITE}/i/ipython/ipython-${version}.tar.gz"
-checksum=d41f8e80b99690122400f9b2069b12f670246a1b4cc5d332bd6c4e2500e6d6fb
+checksum=cb6aef731bf708a7727ab6cde8df87f0281b1427d41e65d62d4b68934fa54e97
 conflicts="python-ipython<=5.8.0_2"
 
 do_check() {

From e004ba42f8e9ee8a76babbcf3b1ba9c85dca0924 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sat, 4 Dec 2021 08:46:54 -0500
Subject: [PATCH 138/143] python3-parso: update to 0.8.3.

---
 srcpkgs/python3-parso/template | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-parso/template b/srcpkgs/python3-parso/template
index 5fb79d8baaad..16b67897a9d7 100644
--- a/srcpkgs/python3-parso/template
+++ b/srcpkgs/python3-parso/template
@@ -1,9 +1,11 @@
 # Template file for 'python3-parso'
 pkgname=python3-parso
-version=0.8.2
-revision=2
+version=0.8.3
+revision=1
 wrksrc="parso-${version}"
 build_style=python3-module
+# Several error messages changed form and trigger inappropriate failures
+make_check_args="--ignore=test/test_python_errors.py"
 hostmakedepends="python3-setuptools"
 depends="python3"
 checkdepends="python3-pytest"
@@ -12,7 +14,7 @@ maintainer="Andrew J. Hesford <ajh@sideband.org>"
 license="MIT"
 homepage="https://github.com/davidhalter/parso"
 distfiles="${PYPI_SITE}/p/parso/parso-${version}.tar.gz"
-checksum=12b83492c6239ce32ff5eed6d3639d6a536170723c6f3f1506869f1ace413398
+checksum=8c07be290bb59f03588915921e29e8a50002acaf2cdc5fa0e0114f91709fafa0
 
 post_install() {
 	vlicense LICENSE.txt

From 0698dc1bd417bb8c3c85864156cba2c79ce1c530 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sat, 4 Dec 2021 09:21:39 -0500
Subject: [PATCH 139/143] python3-scikit-image: update to 0.19.0.

---
 .../patches/no-pythran.patch                  | 60 +++++++++++++++++++
 srcpkgs/python3-scikit-image/template         | 13 ++--
 2 files changed, 67 insertions(+), 6 deletions(-)
 create mode 100644 srcpkgs/python3-scikit-image/patches/no-pythran.patch

diff --git a/srcpkgs/python3-scikit-image/patches/no-pythran.patch b/srcpkgs/python3-scikit-image/patches/no-pythran.patch
new file mode 100644
index 000000000000..a2a1bf479ead
--- /dev/null
+++ b/srcpkgs/python3-scikit-image/patches/no-pythran.patch
@@ -0,0 +1,60 @@
+Disable optional Pythran support that is hard-required during build.
+
+--- a/setup.py
++++ b/setup.py
+@@ -6,7 +6,7 @@
+ import shutil
+ import builtins
+ import textwrap
+-from numpy.distutils.command.build_ext import build_ext as npy_build_ext
++from numpy.distutils.command.build_ext import build_ext
+ 
+ import setuptools
+ from setuptools.command.build_py import build_py
+@@ -17,7 +17,13 @@
+     # can remove this except case once we require setuptools>=59.0
+     from distutils.errors import CompileError, LinkError
+ 
+-from pythran.dist import PythranBuildExt as pythran_build_ext
++try:
++    from pythran.dist import PythranBuildExt as pythran_build_ext
++except ImportError:
++    pass
++else:
++    # Replace numpy extension builder with pythran version
++    build_ext = pythran_build_ext[build_ext]
+ 
+ DISTNAME = 'scikit-image'
+ DESCRIPTION = 'Image processing in Python'
+@@ -60,7 +66,7 @@
+ 
+ # Support for openmp
+ 
+-class ConditionalOpenMP(pythran_build_ext[npy_build_ext]):
++class ConditionalOpenMP(build_ext):
+ 
+     def can_compile_link(self, compile_flags, link_flags):
+ 
+--- a/skimage/feature/setup.py
++++ b/skimage/feature/setup.py
+@@ -2,7 +2,7 @@
+ 
+ import os
+ from skimage._build import cython
+-import pythran, logging
++import logging
+ 
+ base_path = os.path.abspath(os.path.dirname(__file__))
+ 
+@@ -43,6 +43,11 @@
+     config.add_extension('_sift', sources=['_sift.c'],
+                          include_dirs=[get_numpy_include_dirs(), '../_shared'])
+ 
++    try:
++        import pythran
++    except ImportError:
++        return config
++
+     # pythran submodules
+     pythran.config.logger.setLevel(logging.INFO)
+     ext = pythran.dist.PythranExtension(
diff --git a/srcpkgs/python3-scikit-image/template b/srcpkgs/python3-scikit-image/template
index 49b214c11aef..b1d87f9d2c26 100644
--- a/srcpkgs/python3-scikit-image/template
+++ b/srcpkgs/python3-scikit-image/template
@@ -1,21 +1,22 @@
 # Template file for 'python3-scikit-image'
 pkgname=python3-scikit-image
-version=0.18.3
-revision=2
+version=0.19.0
+revision=1
 _pkgname="${pkgname#python3-}"
 wrksrc="${_pkgname}-${version}"
 build_style=python3-module
 build_helper="numpy"
-hostmakedepends="python3-setuptools python3-Cython"
+hostmakedepends="python3-Cython python3-wheel python3-numpy
+ python3-packaging python3-setuptools"
 makedepends="python3-devel"
-depends="python3-scipy python3-matplotlib python3-networkx
- python3-imageio python3-tifffile python3-pywt"
+depends="python3-scipy python3-numpy python3-imageio python3-matplotlib
+ python3-networkx python3-tifffile python3-pywt python3-packaging"
 short_desc="Image processing in Python"
 maintainer="Andrew J. Hesford <ajh@sideband.org>"
 license="BSD-3-Clause, MIT"
 homepage="https://scikit-image.org/"
 distfiles="https://github.com/${_pkgname}/${_pkgname}/archive/v${version}.tar.gz"
-checksum=a8d1c7473fc9399447a4cd5718c90338fffd543622d9e6f3d9feca43f1a9cb15
+checksum=5a0d6ad80ed3a389c19a8603391bbc1dd8e81239c2ef5ca6c274886db3087ec5
 # Tests require data files and unpackaged dependencies
 make_check=no
 

From cecb92674a91f5b0b4d3e2ca04bfdfe6daeff78d Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Sat, 4 Dec 2021 18:02:09 +0100
Subject: [PATCH 140/143] alpine: update to 2.25.1.

---
 srcpkgs/alpine/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/alpine/template b/srcpkgs/alpine/template
index 6fdbf75afcaf..2ab186c938af 100644
--- a/srcpkgs/alpine/template
+++ b/srcpkgs/alpine/template
@@ -1,8 +1,8 @@
 # Template file for 'alpine'
 pkgname=alpine
-version=2.25
+version=2.25.1
 revision=1
-_githash=465e23b898e5a3393b9ae52fc7620002541b2e75
+_githash=a4717516707498544201c2e03286142c9abb2539
 _gitshort="${_githash:0:7}"
 wrksrc="${pkgname}-${_gitshort}"
 build_style=gnu-configure
@@ -17,7 +17,7 @@ maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="Apache-2.0"
 homepage="https://repo.or.cz/alpine.git"
 distfiles="https://repo.or.cz/alpine.git/snapshot/${_githash}.tar.gz"
-checksum=ba0856bcc863b70dd0c2f06cdeda720332c2d136d49154d78450932cd9e0900a
+checksum=e1855467f8dbf21879e3a6fa959998ffb68a6d5221ee7d6cc2fc3de95ee0759a
 
 post_extract() {
 	sed -i -e '/run test program/s/^/: /' \

From 699ec557ee261612f887a11b8231def9f011529a Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Sat, 4 Dec 2021 18:02:10 +0100
Subject: [PATCH 141/143] netpbm: update to 10.96.04.

---
 srcpkgs/netpbm/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/netpbm/template b/srcpkgs/netpbm/template
index a1fb5f6d9966..f49b1bb66e5f 100644
--- a/srcpkgs/netpbm/template
+++ b/srcpkgs/netpbm/template
@@ -1,10 +1,10 @@
 # Template file for 'netpbm'
 pkgname=netpbm
 # from http://svn.code.sf.net/p/netpbm/code/advanced/doc/HISTORY
-version=10.96.03
+version=10.96.04
 revision=1
-_githash=54081f1e108cb4a385f951cbc293368829e39320
-_githash_guide=54910a3304543a702b0720c3b9c6d6be4ba12100
+_githash=3c556d3931167936ef5bfb3ba1ff569049aa1b87
+_githash_guide=913c540e85e33b07c2dbc551ef4092126ab3ed55
 create_wrksrc=yes
 build_wrksrc="netpbm-mirror-${_githash}"
 hostmakedepends="pkg-config perl python flex"
@@ -16,8 +16,8 @@ license="BSD-3-Clause,GPL-2.0-only,custom:netpbm"
 homepage="http://netpbm.sourceforge.net/"
 distfiles="https://github.com/leahneukirchen/netpbm-mirror/archive/${_githash}.tar.gz
  https://github.com/leahneukirchen/netpbm-mirror/archive/${_githash_guide}.tar.gz"
-checksum="b2184c438d2e9e7a7f99123196719b8a1d1d55a7d28607afb4842ba1ab550cbc
- b966580dcf5d72fc6a3cfa6c95d46206b9b4c252ec911e14633113c45cb49626"
+checksum="c65fcad80229c8ac2999a6ee10709c8ee4f1f73995e0a4423029250c21233756
+ 74ae5c9df00f1654eea60913cd11e7347df111032afc09b315b0567b54bf0b8f"
 
 post_extract() {
 	cd $build_wrksrc

From a794642c7c01847b0631471cf4fc486153f688b6 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Sat, 4 Dec 2021 18:02:12 +0100
Subject: [PATCH 142/143] ldns: update to 1.8.1.

---
 srcpkgs/ldns/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/ldns/template b/srcpkgs/ldns/template
index 376777cfc423..4e7bcd1f2154 100644
--- a/srcpkgs/ldns/template
+++ b/srcpkgs/ldns/template
@@ -1,7 +1,7 @@
 # Template file for 'ldns'
 pkgname=ldns
-version=1.7.1
-revision=5
+version=1.8.1
+revision=1
 build_style=gnu-configure
 configure_args="--with-drill --with-examples --disable-dane-ta-usage
  --with-trust-anchor=/etc/dns/root.key
@@ -13,7 +13,7 @@ maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="BSD-3-Clause"
 homepage="http://www.nlnetlabs.nl/projects/ldns/"
 distfiles="http://www.nlnetlabs.nl/downloads/${pkgname}/${pkgname}-${version}.tar.gz"
-checksum=8ac84c16bdca60e710eea75782356f3ac3b55680d40e1530d7cea474ac208229
+checksum=958229abce4d3aaa19a75c0d127666564b17216902186e952ca4aef47c6d7fa3
 
 post_install() {
 	vsed -i -e "s|\(-specs=.*hardened-ld\)||g" -e "s|\(-specs=.*hardened-cc1\)||g" ${DESTDIR}/usr/bin/ldns-config

From 83205c83c1a9b44594b33b36b65f83ad6eeddc9e Mon Sep 17 00:00:00 2001
From: Demedim <40205709+Demedim@users.noreply.github.com>
Date: Sat, 4 Dec 2021 13:05:40 +0100
Subject: [PATCH 143/143] aircrack-ng: add libcap to enable more utilities

Closes: #34380 [via git-merge-pr]

add comment about patch purpose

fix typo
---
 srcpkgs/aircrack-ng/patches/getopt.patch | 14 ++++++++++++++
 srcpkgs/aircrack-ng/template             |  4 ++--
 srcpkgs/lumina/patches/checkpass.patch   |  1 +
 3 files changed, 17 insertions(+), 2 deletions(-)
 create mode 100644 srcpkgs/aircrack-ng/patches/getopt.patch

diff --git a/srcpkgs/aircrack-ng/patches/getopt.patch b/srcpkgs/aircrack-ng/patches/getopt.patch
new file mode 100644
index 000000000000..7f57f30e6a3c
--- /dev/null
+++ b/srcpkgs/aircrack-ng/patches/getopt.patch
@@ -0,0 +1,14 @@
+argv[1] is a file name argument, musl getopt_long will permute it
+to a later position, so skip it for argument parsing.
+
+--- aircrack-ng-1.6/src/airolib-ng/airolib-ng.c.orig
++++ aircrack-ng-1.6/src/airolib-ng/airolib-ng.c
+@@ -1309,7 +1309,7 @@
+ 	signal(SIGTERM, sighandler);
+ 
+ 	option = getopt_long(
+-		argc, argv, "bc:d:e:hi:s:t:v:", long_options, &option_index);
++		argc-1, argv+1, "bc:d:e:hi:s:t:v:", long_options, &option_index);
+ 
+ 	if (option > 0)
+ 	{
diff --git a/srcpkgs/aircrack-ng/template b/srcpkgs/aircrack-ng/template
index 604bcefb5a34..ef5d46cebac1 100644
--- a/srcpkgs/aircrack-ng/template
+++ b/srcpkgs/aircrack-ng/template
@@ -1,10 +1,10 @@
 # Template file for 'aircrack-ng'
 pkgname=aircrack-ng
 version=1.6
-revision=3
+revision=4
 build_style=gnu-configure
 hostmakedepends="automake libtool pkg-config"
-makedepends="libnl3-devel openssl-devel sqlite-devel zlib-devel"
+makedepends="libnl3-devel openssl-devel sqlite-devel zlib-devel libcap-devel"
 short_desc="Complete suite of tools to assess WiFi network security"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="GPL-2.0-or-later, BSD-3-Clause, OpenSSL"
diff --git a/srcpkgs/lumina/patches/checkpass.patch b/srcpkgs/lumina/patches/checkpass.patch
index 7534550b0019..a31d0fa8bb17 100644
--- a/srcpkgs/lumina/patches/checkpass.patch
+++ b/srcpkgs/lumina/patches/checkpass.patch
@@ -1,3 +1,4 @@
+Force the "bin" path to avoid conflicts with Void xbps-src lint checks
 --- a/src-qt5/core/lumina-checkpass/lumina-checkpass.pro
 +++ b/src-qt5/core/lumina-checkpass/lumina-checkpass.pro
 @@ -6,13 +6,13 @@ QT =

^ permalink raw reply	[flat|nested] 18+ messages in thread

* Re: [PR PATCH] [Updated] lumina: update to 1.6.1.
  2021-11-26 18:57 [PR PATCH] lumina: update to 1.6.1 karlgrose
                   ` (9 preceding siblings ...)
  2021-12-05  4:56 ` [PR PATCH] [Updated] " karlgrose
@ 2021-12-05  5:08 ` karlgrose
  2021-12-05  5:24 ` karlgrose
                   ` (5 subsequent siblings)
  16 siblings, 0 replies; 18+ messages in thread
From: karlgrose @ 2021-12-05  5:08 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1078 bytes --]

There is an updated pull request by karlgrose against master on the void-packages repository

https://github.com/karlgrose/void-packages master
https://github.com/void-linux/void-packages/pull/34262

lumina: update to 1.6.1.
<!-- Uncomment relevant sections and delete options which are not applicable -->

#### Testing the changes
- I tested the changes in this PR: **YES**

<!--
#### New package
- This new package conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements): **YES**|**NO**
-->

<!-- Note: If the build is likely to take more than 2 hours, please [skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration)
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->

#### Local build testing
- I built this PR locally for my native architecture, (x86_64-glibc)


A patch file from https://github.com/void-linux/void-packages/pull/34262.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-master-34262.patch --]
[-- Type: text/x-diff, Size: 461742 bytes --]

From cb2a8667ca55f498ab83d6e154b0fca6452cd340 Mon Sep 17 00:00:00 2001
From: Karl R Grose <karlgrose@gromar.org>
Date: Fri, 26 Nov 2021 10:15:38 -0800
Subject: [PATCH 001/288] lumina: update to 1.6.1.

---
 srcpkgs/lumina/patches/checkpass.patch | 19 +++++++++++++++++++
 srcpkgs/lumina/patches/mandir.patch    | 11 -----------
 srcpkgs/lumina/template                |  8 ++++----
 3 files changed, 23 insertions(+), 15 deletions(-)
 create mode 100644 srcpkgs/lumina/patches/checkpass.patch
 delete mode 100644 srcpkgs/lumina/patches/mandir.patch

diff --git a/srcpkgs/lumina/patches/checkpass.patch b/srcpkgs/lumina/patches/checkpass.patch
new file mode 100644
index 000000000000..7534550b0019
--- /dev/null
+++ b/srcpkgs/lumina/patches/checkpass.patch
@@ -0,0 +1,19 @@
+--- a/src-qt5/core/lumina-checkpass/lumina-checkpass.pro
++++ b/src-qt5/core/lumina-checkpass/lumina-checkpass.pro
+@@ -6,13 +6,13 @@ QT =
+ CONFIG += console
+ 
+ TARGET = lumina-checkpass
+-target.path = $$DESTDIR$${PREFIX}/sbin
++target.path = $$DESTDIR$${PREFIX}/bin
+ 
+ LIBS     += -lpam
+ 
+ SOURCES += main.c
+ 
+-perms.path = $$DESTDIR$${PREFIX}/sbin
+-perms.extra = "chmod 4555 $$DESTDIR$${PREFIX}/sbin/lumina-checkpass"
++perms.path = $$DESTDIR$${PREFIX}/bin
++perms.extra = "chmod 4555 $(INSTALL_ROOT)$$DESTDIR$${PREFIX}/bin/lumina-checkpass"
+ 
+ INSTALLS += target perms
diff --git a/srcpkgs/lumina/patches/mandir.patch b/srcpkgs/lumina/patches/mandir.patch
deleted file mode 100644
index 9b9ce50a1e5d..000000000000
--- a/srcpkgs/lumina/patches/mandir.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src-qt5/OS-detect.pri	2017-07-05 20:02:49.727200592 +0200
-+++ b/src-qt5/OS-detect.pri	2017-07-05 20:03:10.463911159 +0200
-@@ -94,7 +94,7 @@
-   isEmpty(L_SHAREDIR){ L_SHAREDIR = $${PREFIX}/share }
-   isEmpty(L_INCLUDEDIR){ L_INCLUDEDIR = $${PREFIX}/include }
-   isEmpty(L_SESSDIR){ L_SESSDIR = $${L_SHAREDIR}/xsessions }
--  isEmpty(L_MANDIR){ L_MANDIR = $${PREFIX}/man }
-+  isEmpty(L_MANDIR){ L_MANDIR = $${PREFIX}/share/man }
-   isEmpty(LRELEASE){ LRELEASE = $$[QT_INSTALL_BINS]/lrelease }
-   isEmpty(MAN_ZIP){ MAN_ZIP = "gzip -c" }
-   !exists(LRELEASE){ NO_I18N=true } #translations unavailable
diff --git a/srcpkgs/lumina/template b/srcpkgs/lumina/template
index ed7ef97adfba..5299c6ae9c54 100644
--- a/srcpkgs/lumina/template
+++ b/srcpkgs/lumina/template
@@ -1,11 +1,11 @@
 # Template file for 'lumina'
 pkgname=lumina
-version=1.6.0
-revision=2
+version=1.6.1
+revision=1
 build_style=qmake
 configure_args="QT5LIBDIR=/usr/lib/qt5 L_ETCDIR=/etc CONFIG+=WITH_I18N"
 hostmakedepends="qt5-host-tools qt5-qmake"
-makedepends="qt5-devel qt5-x11extras-devel qt5-multimedia-devel qt5-svg-devel
+makedepends="qt5-devel qt5-x11extras-devel qt5-multimedia-devel qt5-svg-devel pam-devel
  qt5-declarative-devel libXrender-devel libXcomposite-devel libXcursor-devel libXdamage-devel
  xcb-util-devel xcb-util-wm-devel xcb-util-image-devel pulseaudio-devel poppler-qt5-devel"
 depends="fluxbox numlockx xbacklight alsa-utils acpi xscreensaver bsdtar qt5-svg qsudo"
@@ -14,7 +14,7 @@ maintainer="hipperson0 <hipperson0@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/lumina-desktop/lumina"
 distfiles="https://github.com/lumina-desktop/lumina/archive/v${version}.tar.gz"
-checksum=f3512fca4d05e3cf3a6ac106f0f16c9618bda9fa546f1d23ffb0eab9a5ce7c8a
+checksum=2bc649c95da8f997bf943cc1e64af4a61921ddc5d63dd3c46fc0ba8708e29a92
 replaces="lumina-git>=0"
 
 post_install() {

From d23945cfc4d4355c79c75296554b90fb92f3eda4 Mon Sep 17 00:00:00 2001
From: Karl R Grose <karlgrose@gromar.org>
Date: Fri, 26 Nov 2021 10:15:38 -0800
Subject: [PATCH 002/288] lumina: update to 1.6.1.

add comment about patch purpose
---
 srcpkgs/lumina/patches/checkpass.patch | 20 ++++++++++++++++++++
 srcpkgs/lumina/patches/mandir.patch    | 11 -----------
 srcpkgs/lumina/template                |  8 ++++----
 3 files changed, 24 insertions(+), 15 deletions(-)
 create mode 100644 srcpkgs/lumina/patches/checkpass.patch
 delete mode 100644 srcpkgs/lumina/patches/mandir.patch

diff --git a/srcpkgs/lumina/patches/checkpass.patch b/srcpkgs/lumina/patches/checkpass.patch
new file mode 100644
index 000000000000..cb1f3c19e7ba
--- /dev/null
+++ b/srcpkgs/lumina/patches/checkpass.patch
@@ -0,0 +1,20 @@
+Force the "bin" path to avoid conflicts with Void pkg-src lint checks
+--- a/src-qt5/core/lumina-checkpass/lumina-checkpass.pro
++++ b/src-qt5/core/lumina-checkpass/lumina-checkpass.pro
+@@ -6,13 +6,13 @@ QT =
+ CONFIG += console
+ 
+ TARGET = lumina-checkpass
+-target.path = $$DESTDIR$${PREFIX}/sbin
++target.path = $$DESTDIR$${PREFIX}/bin
+ 
+ LIBS     += -lpam
+ 
+ SOURCES += main.c
+ 
+-perms.path = $$DESTDIR$${PREFIX}/sbin
+-perms.extra = "chmod 4555 $$DESTDIR$${PREFIX}/sbin/lumina-checkpass"
++perms.path = $$DESTDIR$${PREFIX}/bin
++perms.extra = "chmod 4555 $(INSTALL_ROOT)$$DESTDIR$${PREFIX}/bin/lumina-checkpass"
+ 
+ INSTALLS += target perms
diff --git a/srcpkgs/lumina/patches/mandir.patch b/srcpkgs/lumina/patches/mandir.patch
deleted file mode 100644
index 9b9ce50a1e5d..000000000000
--- a/srcpkgs/lumina/patches/mandir.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src-qt5/OS-detect.pri	2017-07-05 20:02:49.727200592 +0200
-+++ b/src-qt5/OS-detect.pri	2017-07-05 20:03:10.463911159 +0200
-@@ -94,7 +94,7 @@
-   isEmpty(L_SHAREDIR){ L_SHAREDIR = $${PREFIX}/share }
-   isEmpty(L_INCLUDEDIR){ L_INCLUDEDIR = $${PREFIX}/include }
-   isEmpty(L_SESSDIR){ L_SESSDIR = $${L_SHAREDIR}/xsessions }
--  isEmpty(L_MANDIR){ L_MANDIR = $${PREFIX}/man }
-+  isEmpty(L_MANDIR){ L_MANDIR = $${PREFIX}/share/man }
-   isEmpty(LRELEASE){ LRELEASE = $$[QT_INSTALL_BINS]/lrelease }
-   isEmpty(MAN_ZIP){ MAN_ZIP = "gzip -c" }
-   !exists(LRELEASE){ NO_I18N=true } #translations unavailable
diff --git a/srcpkgs/lumina/template b/srcpkgs/lumina/template
index ed7ef97adfba..5299c6ae9c54 100644
--- a/srcpkgs/lumina/template
+++ b/srcpkgs/lumina/template
@@ -1,11 +1,11 @@
 # Template file for 'lumina'
 pkgname=lumina
-version=1.6.0
-revision=2
+version=1.6.1
+revision=1
 build_style=qmake
 configure_args="QT5LIBDIR=/usr/lib/qt5 L_ETCDIR=/etc CONFIG+=WITH_I18N"
 hostmakedepends="qt5-host-tools qt5-qmake"
-makedepends="qt5-devel qt5-x11extras-devel qt5-multimedia-devel qt5-svg-devel
+makedepends="qt5-devel qt5-x11extras-devel qt5-multimedia-devel qt5-svg-devel pam-devel
  qt5-declarative-devel libXrender-devel libXcomposite-devel libXcursor-devel libXdamage-devel
  xcb-util-devel xcb-util-wm-devel xcb-util-image-devel pulseaudio-devel poppler-qt5-devel"
 depends="fluxbox numlockx xbacklight alsa-utils acpi xscreensaver bsdtar qt5-svg qsudo"
@@ -14,7 +14,7 @@ maintainer="hipperson0 <hipperson0@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/lumina-desktop/lumina"
 distfiles="https://github.com/lumina-desktop/lumina/archive/v${version}.tar.gz"
-checksum=f3512fca4d05e3cf3a6ac106f0f16c9618bda9fa546f1d23ffb0eab9a5ce7c8a
+checksum=2bc649c95da8f997bf943cc1e64af4a61921ddc5d63dd3c46fc0ba8708e29a92
 replaces="lumina-git>=0"
 
 post_install() {

From 7e4f65fe4b7f2ca9939fe6a6d2b22f75c09de7b7 Mon Sep 17 00:00:00 2001
From: Andrew Benson <abenson+void@gmail.com>
Date: Sun, 28 Nov 2021 11:16:36 -0600
Subject: [PATCH 003/288] Amass: update to 3.15.1.

---
 srcpkgs/Amass/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/Amass/template b/srcpkgs/Amass/template
index 71ee291c99e6..f78e2f70cf12 100644
--- a/srcpkgs/Amass/template
+++ b/srcpkgs/Amass/template
@@ -1,6 +1,6 @@
 # Template file for 'Amass'
 pkgname=Amass
-version=3.15.0
+version=3.15.1
 revision=1
 build_style=go
 go_import_path="github.com/OWASP/Amass/v3/..."
@@ -9,7 +9,7 @@ maintainer="Andrew Benson <abenson+void@gmail.com>"
 license="Apache-2.0"
 homepage="https://www.owasp.org/index.php/OWASP_Amass_Project"
 distfiles="https://github.com/OWASP/Amass/archive/v${version}.tar.gz"
-checksum=084ddbc8171e354abee3098458064fbcc9db059a25c4845dfc151803833df2dd
+checksum=217f5f0fed02d730543a56b58f1be3ec0fb07e57b3ace53fc673c6d0132f36a8
 
 post_install() {
 	rm ${DESTDIR}/usr/bin/examples

From 9aea8e7cbf49c37182e39881a5306a9a0ebf340e Mon Sep 17 00:00:00 2001
From: Andrew Benson <abenson+void@gmail.com>
Date: Sun, 28 Nov 2021 11:19:21 -0600
Subject: [PATCH 004/288] python3-httpx: update to 0.21.1.

---
 srcpkgs/python3-httpx/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-httpx/template b/srcpkgs/python3-httpx/template
index 5c99c9208213..55f843ed478c 100644
--- a/srcpkgs/python3-httpx/template
+++ b/srcpkgs/python3-httpx/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-httpx'
 pkgname=python3-httpx
-version=0.21.0
+version=0.21.1
 revision=1
 wrksrc="httpx-${version}"
 build_style=python3-module
@@ -14,7 +14,7 @@ license="BSD-3-Clause"
 homepage="https://www.python-httpx.org"
 changelog="https://raw.githubusercontent.com/encode/httpx/master/CHANGELOG.md"
 distfiles="${PYPI_SITE}/h/httpx/httpx-${version}.tar.gz"
-checksum=5ae1d9deb30fe074596551b3ab98f94dfd9d7efe3ecd2d08662a5c29f6fba0e4
+checksum=02af20df486b78892a614a7ccd4e4e86a5409ec4981ab0e422c579a887acad83
 # the pypi tarball doesn't contain tests
 # the tests need unpackaged dependencies trustme and uvicorn
 make_check=no

From 90363e8353164ebbe2dfeacccd0486288012f25b Mon Sep 17 00:00:00 2001
From: Andrew Benson <abenson+void@gmail.com>
Date: Sun, 28 Nov 2021 11:19:24 -0600
Subject: [PATCH 005/288] python3-youtubesearch: update to 1.5.2.

---
 srcpkgs/python3-youtubesearch/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-youtubesearch/template b/srcpkgs/python3-youtubesearch/template
index c284178a44a8..8319d620097d 100644
--- a/srcpkgs/python3-youtubesearch/template
+++ b/srcpkgs/python3-youtubesearch/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-youtubesearch'
 pkgname=python3-youtubesearch
-version=1.5.1
+version=1.5.2
 revision=1
 wrksrc="youtube-search-python-${version}"
 build_style=python3-module
@@ -11,7 +11,7 @@ maintainer="Andrew Benson <abenson+void@gmail.com>"
 license="MIT"
 homepage="https://github.com/alexmercerind/youtube-search-python"
 distfiles="${homepage}/archive/refs/tags/v${version}.tar.gz"
-checksum=485825a741ef5e7c327eaf65b27f7ffd7d10e218072a972012ff3301c2d7c488
+checksum=6094c819b195de0ef7363e76594b5c34479438a45e72c1e9f763cd9cf17a64ea
 make_check=no # no tests defined
 
 post_install() {

From 8c3bea7359920bb4a29f411115821fd42c40d75e Mon Sep 17 00:00:00 2001
From: Andrew Benson <abenson+void@gmail.com>
Date: Sun, 28 Nov 2021 11:23:29 -0600
Subject: [PATCH 006/288] mongo-c-driver: update to 1.20.0.

---
 srcpkgs/mongo-c-driver/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/mongo-c-driver/template b/srcpkgs/mongo-c-driver/template
index ee79f2e3d329..b3eec27c4bab 100644
--- a/srcpkgs/mongo-c-driver/template
+++ b/srcpkgs/mongo-c-driver/template
@@ -1,6 +1,6 @@
 # Template file for 'mongo-c-driver'
 pkgname=mongo-c-driver
-version=1.19.2
+version=1.20.0
 revision=1
 build_style=cmake
 configure_args="-DENABLE_TESTS=OFF"
@@ -11,7 +11,7 @@ maintainer="Andrew Benson <abenson+void@gmail.com>"
 license="Apache-2.0"
 homepage="https://mongoc.org"
 distfiles="https://github.com/mongodb/mongo-c-driver/releases/download/${version}/mongo-c-driver-${version}.tar.gz"
-checksum=b6feb4fd65423140cdee02df392cd9db2bb459731e992a5385afa554a7515762
+checksum=a97242866212bdcf9dfb8030b31a32eef9ff83082b34e1027339c805a3c50b0d
 
 mongo-c-driver-devel_package() {
 	short_desc+=" - development files"

From 7803c3bc2115152289a27625b03556d4bbad5e3a Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Sat, 27 Nov 2021 14:45:12 +0100
Subject: [PATCH 007/288] libuninameslist: update to 20211114.

---
 srcpkgs/libuninameslist/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/libuninameslist/template b/srcpkgs/libuninameslist/template
index a7e509d4b0b5..8b97662a4a31 100644
--- a/srcpkgs/libuninameslist/template
+++ b/srcpkgs/libuninameslist/template
@@ -1,6 +1,6 @@
 # Template file for 'libuninameslist'
 pkgname=libuninameslist
-version=20210917
+version=20211114
 revision=1
 build_style=gnu-configure
 hostmakedepends="automake libtool"
@@ -9,7 +9,7 @@ maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="BSD-3-Clause"
 homepage="https://github.com/fontforge/libuninameslist"
 distfiles="https://github.com/fontforge/libuninameslist/archive/${version}.tar.gz"
-checksum=7d60ea37813590c9d319d53aaac831fedf8067c980167877bc5daa351b378031
+checksum=c089c6164f2cef361c3419a07408be72d6b58d6ef224ec226724a9fa93c0d46e
 
 pre_configure() {
 	autoreconf -fi

From 044f73ae6d466159a9305193364b7e32d003087f Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Sat, 27 Nov 2021 14:47:22 +0100
Subject: [PATCH 008/288] libtls: update to 3.4.2.

---
 srcpkgs/libtls/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/libtls/template b/srcpkgs/libtls/template
index 3a0922788b7e..42f33db208a6 100644
--- a/srcpkgs/libtls/template
+++ b/srcpkgs/libtls/template
@@ -1,6 +1,6 @@
 # Template file for 'libtls'
 pkgname=libtls
-version=3.4.1
+version=3.4.2
 revision=1
 wrksrc="libressl-${version}"
 build_style=gnu-configure
@@ -13,7 +13,7 @@ license="OpenSSL, ISC"
 homepage="http://www.libressl.org/"
 changelog="https://raw.githubusercontent.com/libressl-portable/portable/master/ChangeLog"
 distfiles="http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-${version}.tar.gz"
-checksum=107ceae6ca800e81cb563584c16afa36d6c7138fade94a2b3e9da65456f7c61c
+checksum=cb82ca7d547336917352fbd23db2fc483c6c44d35157b32780214ec74197b3ce
 _lssl_asm_ver="1.2.0"
 replaces="libtls20>0"
 

From eb472e50c4cd36574146142162a3ccf4a14ec3ac Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Sat, 27 Nov 2021 15:04:23 +0100
Subject: [PATCH 009/288] crash: update to 8.0.0.

---
 srcpkgs/crash/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/crash/template b/srcpkgs/crash/template
index 72a0cdd6c36a..82d9a3968c11 100644
--- a/srcpkgs/crash/template
+++ b/srcpkgs/crash/template
@@ -1,10 +1,10 @@
 # Template file for 'crash'
 pkgname=crash
-version=7.3.0
-revision=2
+version=8.0.0
+revision=1
 archs="i686 x86_64"  # broken on musl
 build_style=gnu-makefile
-hostmakedepends="flex tar wget"
+hostmakedepends="flex tar wget texinfo"
 makedepends="lzo-devel ncurses-devel zlib-devel"
 depends="binutils"
 short_desc="Kernel crash dump debugger and live inspector"
@@ -13,7 +13,7 @@ license="GPL-3.0-or-later"
 homepage="https://crash-utility.github.io/"
 changelog="https://crash-utility.github.io/crash.changelog.html"
 distfiles="https://github.com/crash-utility/crash/archive/${version}.tar.gz"
-checksum=98d4367ae0ea7d2eda547357a839f7bddee517b588b281574d58a15a418af5b9
+checksum=caab49b7b6d442f60c41360e0ec80cf852dc64e89303b41d704d7661cef43e68
 nocross=yes
 LDFLAGS=-llzo2
 

From 70b8039a460958fdde917c54eb6a9f4cb55a67fc Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Sat, 27 Nov 2021 15:04:29 +0100
Subject: [PATCH 010/288] python3-pipenv: update to 2021.11.23.

---
 srcpkgs/python3-pipenv/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-pipenv/template b/srcpkgs/python3-pipenv/template
index 01863718c2fd..1a8b586387f8 100644
--- a/srcpkgs/python3-pipenv/template
+++ b/srcpkgs/python3-pipenv/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-pipenv'
 pkgname=python3-pipenv
-version=2021.11.15
+version=2021.11.23
 revision=1
 wrksrc="pipenv-${version}"
 build_style=python3-module
@@ -11,7 +11,7 @@ maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="MIT"
 homepage="https://github.com/pypa/pipenv"
 distfiles="${PYPI_SITE}/p/pipenv/pipenv-${version}.tar.gz"
-checksum=616766b1e8dfc24b2e7c6dfbbc8276b7d7ba07e778e5eb0f1b6e59fcd4532fd1
+checksum=1bde859e8bbd1d21d503fd995bc0170048d6da7686ab885f074592c99a16e8f3
 conflicts="python-pipenv>=0"
 
 post_extract() {

From 82d57c26821d85a96b81b42c104f4c7d3caeabf1 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Sun, 28 Nov 2021 19:50:36 +0100
Subject: [PATCH 011/288] erlang: update to 24.1.7.

---
 srcpkgs/erlang/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/erlang/template b/srcpkgs/erlang/template
index cd7340ad4bcb..c51edbde3e10 100644
--- a/srcpkgs/erlang/template
+++ b/srcpkgs/erlang/template
@@ -1,6 +1,6 @@
 # Template file for 'erlang'
 pkgname=erlang
-version=24.1.6
+version=24.1.7
 revision=1
 create_wrksrc=yes
 build_wrksrc="otp-OTP-${version}"
@@ -14,7 +14,7 @@ license="Apache-2.0"
 homepage="http://www.erlang.org/"
 changelog="https://github.com/erlang/otp/releases"
 distfiles="https://github.com/erlang/otp/archive/OTP-${version}.tar.gz"
-checksum=1b0db74f01f0072299347b794b51d170bf1b71a8f9b6c0aac404ed2c440611ad
+checksum=a1dd1a238f1f3e79784b902f3cd00e06f35a630191eaf73324a07a26a2c93af3
 subpackages="erlang-doc"
 
 if [ -z "$CROSS_BUILD" ]; then

From 48d329b367a1624051f50b7069fbfd3a3d0090f3 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sun, 28 Nov 2021 14:30:45 -0500
Subject: [PATCH 012/288] python3-aiofiles: update to 0.8.0.

---
 srcpkgs/python3-aiofiles/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-aiofiles/template b/srcpkgs/python3-aiofiles/template
index 95660af980b3..d4c6a5445630 100644
--- a/srcpkgs/python3-aiofiles/template
+++ b/srcpkgs/python3-aiofiles/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-aiofiles'
 pkgname=python3-aiofiles
-version=0.7.0
-revision=2
+version=0.8.0
+revision=1
 wrksrc="${pkgname#*-}-${version}"
 build_style=python3-pep517
 hostmakedepends="python3-poetry-core"
@@ -13,7 +13,7 @@ license="Apache-2.0"
 homepage="https://github.com/Tinche/aiofiles"
 changelog="https://raw.githubusercontent.com/Tinche/aiofiles/master/README.rst"
 distfiles="${homepage}/archive/v${version}.tar.gz"
-checksum=2baf8e70f95618214c4910730fd625bfaa4a8b8957838b34364b0a2c7d41db9e
+checksum=1ee866ce57b47e2f5ae2c06c0372458a6eb08131a9b1d7216a234fa0d516d638
 
 do_check() {
 	PYTHONPATH=src python3 -m pytest

From 5a8c0b621d69accfdfdffa7a243af0024e36dc92 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sun, 28 Nov 2021 14:37:14 -0500
Subject: [PATCH 013/288] python3-hypothesis: update to 6.28.0.

---
 srcpkgs/python3-hypothesis/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-hypothesis/template b/srcpkgs/python3-hypothesis/template
index 0c4993679d88..460af8b6cc06 100644
--- a/srcpkgs/python3-hypothesis/template
+++ b/srcpkgs/python3-hypothesis/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-hypothesis'
 pkgname=python3-hypothesis
-version=6.27.0
+version=6.28.0
 revision=1
 wrksrc="hypothesis-hypothesis-python-${version}"
 build_wrksrc=hypothesis-python
@@ -15,7 +15,7 @@ license="MPL-2.0"
 homepage="https://hypothesis.works/"
 changelog="https://hypothesis.readthedocs.io/en/latest/changes.html"
 distfiles="https://github.com/HypothesisWorks/hypothesis/archive/hypothesis-python-${version}.tar.gz"
-checksum=91912314804c37a0be3e830426d44341cbf4a751ad92e5bfdad35e434ffffd4a
+checksum=34a4e30f9a0a88bb48c2faf6d78512fb7978e03e152026e00210245b20356d70
 
 do_check() {
 	# Manually run the tests that tox considers part of the "full" suite,

From 58719ceeafb5cf5223deed2ea19e0a3d861329ac Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sun, 28 Nov 2021 14:37:55 -0500
Subject: [PATCH 014/288] python3-prompt_toolkit: update to 3.0.23.

---
 srcpkgs/python3-prompt_toolkit/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-prompt_toolkit/template b/srcpkgs/python3-prompt_toolkit/template
index f7dbc0c33666..ca30e275d05f 100644
--- a/srcpkgs/python3-prompt_toolkit/template
+++ b/srcpkgs/python3-prompt_toolkit/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-prompt_toolkit'
 pkgname=python3-prompt_toolkit
-version=3.0.22
+version=3.0.23
 revision=1
 wrksrc="prompt_toolkit-${version}"
 build_style=python3-module
@@ -13,7 +13,7 @@ license="BSD-3-Clause"
 homepage="https://github.com/prompt-toolkit/python-prompt-toolkit"
 changelog="https://raw.githubusercontent.com/prompt-toolkit/python-prompt-toolkit/master/CHANGELOG"
 distfiles="${PYPI_SITE}/p/prompt_toolkit/prompt_toolkit-${version}.tar.gz"
-checksum=449f333dd120bd01f5d296a8ce1452114ba3a71fae7288d2f0ae2c918764fa72
+checksum=7053aba00895473cb357819358ef33f11aa97e4ac83d38efb123e5649ceeecaf
 conflicts="python3-prompt_toolkit2<=2.0.9_4"
 
 post_install() {

From cc00be1e5540e74c5dfa70a071cd363d72497ea0 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sun, 28 Nov 2021 14:39:32 -0500
Subject: [PATCH 015/288] python3-ipython: update to 7.30.0.

---
 srcpkgs/python3-ipython/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-ipython/template b/srcpkgs/python3-ipython/template
index c2a1120bcac4..85a1ae2e64c5 100644
--- a/srcpkgs/python3-ipython/template
+++ b/srcpkgs/python3-ipython/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-ipython'
 pkgname=python3-ipython
-version=7.29.0
+version=7.30.0
 revision=1
 wrksrc="ipython-${version}"
 build_style=python3-module
@@ -16,7 +16,7 @@ maintainer="Andrew J. Hesford <ajh@sideband.org>"
 license="BSD-3-Clause"
 homepage="https://ipython.org/"
 distfiles="${PYPI_SITE}/i/ipython/ipython-${version}.tar.gz"
-checksum=4f69d7423a5a1972f6347ff233e38bbf4df6a150ef20fbb00c635442ac3060aa
+checksum=d41f8e80b99690122400f9b2069b12f670246a1b4cc5d332bd6c4e2500e6d6fb
 conflicts="python-ipython<=5.8.0_2"
 
 do_check() {

From 727fbcad09daa4926c16214786387299e3b0cace Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sun, 28 Nov 2021 14:39:38 -0500
Subject: [PATCH 016/288] zfs-prune-snapshots: update to 1.3.0.

---
 srcpkgs/zfs-prune-snapshots/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/zfs-prune-snapshots/template b/srcpkgs/zfs-prune-snapshots/template
index 08f538004b9e..63cf6ba63a3f 100644
--- a/srcpkgs/zfs-prune-snapshots/template
+++ b/srcpkgs/zfs-prune-snapshots/template
@@ -1,7 +1,7 @@
 # Template file for 'zfs-prune-snapshots'
 pkgname=zfs-prune-snapshots
-version=1.1.0
-revision=3
+version=1.3.0
+revision=1
 build_style=gnu-makefile
 depends="bash zfs"
 checkdepends="shellcheck"
@@ -10,7 +10,7 @@ maintainer="Andrew J. Hesford <ajh@sideband.org>"
 license="MIT"
 homepage="https://github.com/bahamas10/zfs-prune-snapshots"
 distfiles="${homepage}/archive/v${version}.tar.gz"
-checksum=a9f2fb3c5230111db7622f70318219a37aa8d6bd3d7f894fee54e1ec00cdff2f
+checksum=aacd3683f2bf615286f6c0b154162df11e29783897127a55e1fe73c6a342979f
 
 post_install() {
 	vlicense LICENSE

From 7cfe146cef22b9e7bffc772cef2e129dcf5fe358 Mon Sep 17 00:00:00 2001
From: glaulher <glaulher.developer@gmail.com>
Date: Sun, 28 Nov 2021 15:15:17 -0300
Subject: [PATCH 017/288] icewm: update to 2.9.0.

---
 srcpkgs/icewm/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/icewm/template b/srcpkgs/icewm/template
index e9ba69605326..118071556e15 100644
--- a/srcpkgs/icewm/template
+++ b/srcpkgs/icewm/template
@@ -1,6 +1,6 @@
 # Template file for 'icewm'
 pkgname=icewm
-version=2.8.0
+version=2.9.0
 revision=1
 build_style=cmake
 make_cmd=make
@@ -17,7 +17,7 @@ maintainer="Glaulher <glaulher.developer@gmail.com>"
 license="GPL-2.0-or-later"
 homepage="https://ice-wm.org/"
 distfiles="https://github.com/ice-wm/icewm/archive/${version}.tar.gz"
-checksum=f225a7e5cf225493b6ae8d427d3a08ab9d3ab6bcd2a297ec41350655ddba7be1
+checksum=eacf813ee427cf80f46aaf8d104d7d0e79937b38dff362a857ce86a091c9de5b
 # broken tests
 make_check=no
 

From 532375a5911a49c8dd2523866cbf2021c44ad4f1 Mon Sep 17 00:00:00 2001
From: Lorem <notloremipsum@protonmail.com>
Date: Sun, 28 Nov 2021 11:52:21 +0530
Subject: [PATCH 018/288] badwolf: update to 1.2.1, orphan.

---
 srcpkgs/badwolf/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/badwolf/template b/srcpkgs/badwolf/template
index 9b9f2a1fe84f..0397fe5aa59a 100644
--- a/srcpkgs/badwolf/template
+++ b/srcpkgs/badwolf/template
@@ -1,6 +1,6 @@
 # Template file for 'badwolf'
 pkgname=badwolf
-version=1.2.0
+version=1.2.1
 revision=1
 build_style=configure
 make_check_target=test
@@ -8,12 +8,12 @@ hostmakedepends="pkg-config gettext"
 makedepends="webkit2gtk-devel libsoup-devel"
 checkdepends="mdocml"
 short_desc="Minimalist and privacy-oriented WebKitGTK+ browser"
-maintainer="Lorem <notloremipsum@protonmail.com>"
+maintainer="Orphaned <orphan@voidlinux.org>"
 license="BSD-3-Clause"
 homepage="https://hacktivis.me/projects/badwolf"
 changelog="https://hacktivis.me/releases/badwolf-${version}.txt"
 distfiles="https://hacktivis.me/releases/badwolf-${version}.tar.gz"
-checksum=eaf5b99f1fc0ea94552c64f3b5e84cf9e76891882ea5e767bf633341e0265cba
+checksum=7a658908551bc0389fc43bd04a9decfef3815d28ff2097957bf6ab186a05ffd2
 
 pre_configure() {
 	export PREFIX=/usr

From f1fb28e6cd6922da1dbd1836f0a8056b0a495fd8 Mon Sep 17 00:00:00 2001
From: jgart <jgart@dismail.de>
Date: Sun, 28 Nov 2021 23:44:08 -0500
Subject: [PATCH 019/288] xonsh: update to 0.11.0.

---
 srcpkgs/xonsh/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/xonsh/template b/srcpkgs/xonsh/template
index 150d83d4c8f7..69caa602e442 100644
--- a/srcpkgs/xonsh/template
+++ b/srcpkgs/xonsh/template
@@ -1,7 +1,7 @@
 # Template file for 'xonsh'
 pkgname=xonsh
-version=0.10.1
-revision=2
+version=0.11.0
+revision=1
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 checkdepends="python3-pytest python3-prompt_toolkit python3-Pygments"
@@ -11,7 +11,7 @@ license="GPL-3.0-or-later"
 homepage="https://xon.sh/"
 changelog="https://raw.githubusercontent.com/xonsh/xonsh/master/CHANGELOG.rst"
 distfiles="https://github.com/xonsh/xonsh/archive/${version}.tar.gz"
-checksum=4ede94226b0cc5f429bc7605ace88137c685d24675228e9e94ec18341dd30be4
+checksum=9d73273276996297920c234c7d4267a305c695f0e9e2454dbdf0655c3a8f75cb
 register_shell="/bin/xonsh"
 # FIXME: fails with multiple AttributeErrors
 make_check=extended

From ba850814aaeb45c44b5edb64181468a82f22e8b4 Mon Sep 17 00:00:00 2001
From: cinerea0 <cinerea0@disroot.org>
Date: Sun, 28 Nov 2021 23:59:11 -0500
Subject: [PATCH 020/288] sof-tools: update to 1.9.2

---
 srcpkgs/sof-tools/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/sof-tools/template b/srcpkgs/sof-tools/template
index e10c8afe210f..ecd8c553e5b1 100644
--- a/srcpkgs/sof-tools/template
+++ b/srcpkgs/sof-tools/template
@@ -1,6 +1,6 @@
 # Template file for 'sof-tools'
 pkgname=sof-tools
-version=1.9
+version=1.9.2
 revision=1
 # https://github.com/thesofproject/sof/issues/4902
 archs="x86_64"
@@ -14,7 +14,7 @@ maintainer="cinerea0 <cinerea0@protonmail.com>"
 license="BSD-3-Clause"
 homepage="https://thesofproject.github.io/latest/index.html"
 distfiles="https://github.com/thesofproject/sof/archive/refs/tags/v${version}.tar.gz"
-checksum=29b83a63720ace3a9173073f12c4dfae5ece841773483cb025623506cd02eccb
+checksum=77fc2200f96c565b18b5975fc2ac19c54a93e83502f13b4f782567e5c44f45da
 
 post_install() {
 	vlicense ../LICENCE

From a3cb2e1829cbc824afbe969e41909b776b7fb63e Mon Sep 17 00:00:00 2001
From: cinerea0 <cinerea0@disroot.org>
Date: Sun, 28 Nov 2021 23:57:23 -0500
Subject: [PATCH 021/288] sof-firmware: update to 1.9.2

---
 srcpkgs/sof-firmware/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/sof-firmware/template b/srcpkgs/sof-firmware/template
index 5e866cb448f7..5e6399eca917 100644
--- a/srcpkgs/sof-firmware/template
+++ b/srcpkgs/sof-firmware/template
@@ -1,6 +1,6 @@
 # Template file for 'sof-firmware'
 pkgname=sof-firmware
-version=1.9
+version=1.9.2
 revision=1
 archs="i686* x86_64*"
 wrksrc="sof-bin-${version}"
@@ -11,13 +11,13 @@ maintainer="cinerea0 <cinerea0@protonmail.com>"
 license="BSD-3-Clause"
 homepage="https://thesofproject.github.io/latest/index.html"
 distfiles="https://github.com/thesofproject/sof-bin/archive/refs/tags/v${version}.tar.gz"
-checksum=633bff2cc1490146de66796e52e06c7a608591a328c0bfc6f3fc30114640803a
+checksum=8eac925c129d195072237dcd28f4bbe80cf63eb00fd8b23bdc0719cd1ee9b395
 
 do_install() {
 	vmkdir usr/lib/firmware/intel/sof
 	vmkdir usr/lib/firmware/intel/sof-tplg
-	rsync -a "v${version}.x/sof-v${version}/" "${DESTDIR}/usr/lib/firmware/intel/sof"
-	rsync -a "v${version}.x/sof-tplg-v${version}/" "${DESTDIR}/usr/lib/firmware/intel/sof-tplg"
+	rsync -a "v${version%.*}.x/sof-v${version}/" "${DESTDIR}/usr/lib/firmware/intel/sof"
+	rsync -a "v${version%.*}.x/sof-tplg-v${version}/" "${DESTDIR}/usr/lib/firmware/intel/sof-tplg"
 
 	vlicense LICENCE.NXP
 }

From 9489a54d65d2e08b3a37051b4d69fd566adf46fa Mon Sep 17 00:00:00 2001
From: teldra <teldra@rotce.de>
Date: Sun, 28 Nov 2021 00:46:53 +0100
Subject: [PATCH 022/288] viewnior: update to 1.8.

---
 srcpkgs/viewnior/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/viewnior/template b/srcpkgs/viewnior/template
index 8232c1eb787b..efea8ef77dfb 100644
--- a/srcpkgs/viewnior/template
+++ b/srcpkgs/viewnior/template
@@ -1,7 +1,7 @@
 # Template file for 'viewnior'
 pkgname=viewnior
-version=1.7
-revision=2
+version=1.8
+revision=1
 wrksrc="Viewnior-${pkgname}-${version}"
 build_style=meson
 hostmakedepends="pkg-config intltool gnome-common glib-devel gettext-devel"
@@ -11,4 +11,4 @@ maintainer="teldra <teldra@rotce.de>"
 license="GPL-3.0-or-later"
 homepage="http://siyanpanayotov.com/project/viewnior/"
 distfiles="https://github.com/hellosiyan/Viewnior/archive/${pkgname}-${version}.tar.gz"
-checksum=b9fad3b2909a78f65b33f4dfb47fcdfa97150275e00d5c44d0aa0f1dc499f3e6
+checksum=b9319171ebca23929e6ea8039c194b1595d92e764db5e3890836fb5c36e233b0

From 0c6cb215ba7d88ef1c9d1713cd302f889cf5efca Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Ey=C3=9Fer?= <daniel.eysser@gmail.com>
Date: Fri, 26 Nov 2021 18:26:01 +0100
Subject: [PATCH 023/288] common/environment/build-style: add zig-build.sh

---
 common/environment/build-style/zig-build.sh | 1 +
 1 file changed, 1 insertion(+)
 create mode 100644 common/environment/build-style/zig-build.sh

diff --git a/common/environment/build-style/zig-build.sh b/common/environment/build-style/zig-build.sh
new file mode 100644
index 000000000000..049b7cd437d5
--- /dev/null
+++ b/common/environment/build-style/zig-build.sh
@@ -0,0 +1 @@
+hostmakedepends+=" zig"

From 6670feb4134b736f81655aec0f63d75ef5838d17 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Ey=C3=9Fer?= <daniel.eysser@gmail.com>
Date: Fri, 26 Nov 2021 18:30:51 +0100
Subject: [PATCH 024/288] rundird: zig-build now adds zig to hostmakedepends

---
 srcpkgs/rundird/template | 1 -
 1 file changed, 1 deletion(-)

diff --git a/srcpkgs/rundird/template b/srcpkgs/rundird/template
index 8fa83b5e0dcc..5ff897abd456 100644
--- a/srcpkgs/rundird/template
+++ b/srcpkgs/rundird/template
@@ -3,7 +3,6 @@ pkgname=rundird
 version=0.2.0
 revision=1
 build_style=zig-build
-hostmakedepends="zig"
 makedepends="pam-devel"
 short_desc="Simple daemon + PAM module providing an XDG_RUNTIME_DIR"
 maintainer="Isaac Freund <mail@isaacfreund.com>"

From fdbf216cf7ae0f442b5022af5316df49c2730be0 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Ey=C3=9Fer?= <daniel.eysser@gmail.com>
Date: Fri, 26 Nov 2021 18:32:32 +0100
Subject: [PATCH 025/288] river: zig-build now adds zig to hostmakedepends

---
 srcpkgs/river/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/river/template b/srcpkgs/river/template
index d30060422419..314ed6c53146 100644
--- a/srcpkgs/river/template
+++ b/srcpkgs/river/template
@@ -4,7 +4,7 @@ version=0.1.0
 revision=1
 build_style=zig-build
 configure_args="$(vopt_if xwayland -Dxwayland)"
-hostmakedepends="zig pkg-config wayland-devel scdoc git"
+hostmakedepends="pkg-config wayland-devel scdoc git"
 makedepends="wlroots-devel"
 depends="$(vopt_if xwayland xorg-server-xwayland)"
 short_desc="Dynamic tiling Wayland compositor"

From e5f50afbc6a6639fd642b02084908769a2b8bc66 Mon Sep 17 00:00:00 2001
From: Lorem <notloremipsum@protonmail.com>
Date: Sun, 28 Nov 2021 11:25:31 +0530
Subject: [PATCH 026/288] minigalaxy: update to 1.1.0, orphan.

---
 srcpkgs/minigalaxy/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/minigalaxy/template b/srcpkgs/minigalaxy/template
index 9b7d2f6dbc90..30d360cf6414 100644
--- a/srcpkgs/minigalaxy/template
+++ b/srcpkgs/minigalaxy/template
@@ -1,18 +1,18 @@
 # Template file for 'minigalaxy'
 pkgname=minigalaxy
-version=1.0.2
-revision=2
+version=1.1.0
+revision=1
 build_style=python3-module
 hostmakedepends="gettext python3-setuptools"
 depends="hicolor-icon-theme webkit2gtk python3-gobject python3-requests"
-checkdepends="$depends"
+checkdepends="$depends python3-simplejson"
 short_desc="Simple GOG client for Linux"
-maintainer="Lorem <notloremipsum@protonmail.com>"
+maintainer="Orphaned <orphan@voidlinux.org>"
 license="GPL-3.0-or-later, CC-BY-3.0"
 homepage="https://sharkwouter.github.io/minigalaxy/"
 changelog="https://github.com/sharkwouter/minigalaxy/blob/master/CHANGELOG.md"
 distfiles="https://github.com/sharkwouter/minigalaxy/archive/${version}.tar.gz"
-checksum=9cb482760c68153f2fc8b8fe229d60033634bc0c7b83a6aa43a9cfa20ab2d0e9
+checksum=581e7abfb4af0c01d795dc57a93b1305644d8bdd11ecb533bb2787f85b4bc992
 
 do_check() {
 	python -m unittest tests/*.py

From c93325344921792f954d939115bf647f822a40b6 Mon Sep 17 00:00:00 2001
From: oreo639 <31916379+Oreo639@users.noreply.github.com>
Date: Sat, 27 Nov 2021 01:46:21 -0800
Subject: [PATCH 027/288] pacman: update to 6.0.1

---
 srcpkgs/pacman/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/pacman/template b/srcpkgs/pacman/template
index b98560e10637..d14176f089d7 100644
--- a/srcpkgs/pacman/template
+++ b/srcpkgs/pacman/template
@@ -1,13 +1,13 @@
 # Template file for 'pacman'
 pkgname=pacman
-version=5.2.2
-revision=3
+version=6.0.1
+revision=1
 make_dirs="/var/lib/pacman 0755 root root
  /usr/var/cache/pacman/pkg 0755 root root
  /usr/share/libalpm/hooks 0755 root root"
 conf_files="/etc/pacman.conf"
 build_style=meson
-hostmakedepends="autoconf automake curl libtool gettext-devel pkg-config asciidoc"
+hostmakedepends="curl gettext-devel pkg-config asciidoc"
 makedepends="libarchive-devel gpgme-devel libcurl-devel"
 depends="gnupg>=2"
 checkdepends="fakeroot"
@@ -15,8 +15,8 @@ short_desc="Simple library-based package manager"
 maintainer="oreo639 <oreo6391@gmail.com>"
 license="GPL-2.0-or-later"
 homepage="https://www.archlinux.org/pacman/"
-distfiles="https://sources.archlinux.org/other/pacman/pacman-${version}.tar.gz"
-checksum=bb201a9f2fb53c28d011f661d50028efce6eef2c1d2a36728bdd0130189349a0
+distfiles="https://sources.archlinux.org/other/pacman/pacman-${version}.tar.xz"
+checksum=0db61456e56aa49e260e891c0b025be210319e62b15521f29d3e93b00d3bf731
 make_check=ci-skip
 
 if [ "$XBPS_TARGET_LIBC" = musl ]; then

From 24834943daabca7e7e98464acef464a7081e5b1b Mon Sep 17 00:00:00 2001
From: cinerea0 <cinerea0@disroot.org>
Date: Mon, 29 Nov 2021 01:08:42 -0500
Subject: [PATCH 028/288] delta: update to 0.10.2

---
 srcpkgs/delta/template | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/delta/template b/srcpkgs/delta/template
index 15481ba9a01b..bd5040d70709 100644
--- a/srcpkgs/delta/template
+++ b/srcpkgs/delta/template
@@ -1,6 +1,6 @@
 # Template file for 'delta'
 pkgname=delta
-version=0.9.2
+version=0.10.2
 revision=1
 build_style=cargo
 checkdepends="git"
@@ -9,7 +9,8 @@ maintainer="Andrew Benson <abenson+void@gmail.com>"
 license="MIT"
 homepage="https://github.com/dandavison/delta"
 distfiles="${homepage}/archive/${version}.tar.gz"
-checksum=f002a94119cd5b6fd9deede7f344667358baf5015d0051e055fec6334ee0653f
+checksum=e0f71d72eca543478941401bd96fefc5fa3f70e7860a9f858f63bfecf8fd77a5
+make_check=no  # TODO: Re-enable checks when Rust gets updated
 
 post_install() {
 	vlicense LICENSE

From 32e32756fe8d2b6a262f09d1fe8c8b9717381883 Mon Sep 17 00:00:00 2001
From: Cullen Ross <cullenrss@gmail.com>
Date: Sun, 28 Nov 2021 19:27:26 -0500
Subject: [PATCH 029/288] rxvt-unicode: update to 9.30.

---
 srcpkgs/rxvt-unicode/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/rxvt-unicode/template b/srcpkgs/rxvt-unicode/template
index 4223d2e8f789..00ebdf63c3ca 100644
--- a/srcpkgs/rxvt-unicode/template
+++ b/srcpkgs/rxvt-unicode/template
@@ -1,6 +1,6 @@
 # Template file for 'rxvt-unicode'
 pkgname=rxvt-unicode
-version=9.29
+version=9.30
 revision=1
 build_style=gnu-configure
 configure_args="
@@ -25,7 +25,7 @@ maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="GPL-3.0-or-later"
 homepage="http://software.schmorp.de/pkg/rxvt-unicode.html"
 distfiles="http://dist.schmorp.de/${pkgname}/${pkgname}-${version}.tar.bz2"
-checksum=c18bc9de0c319db1f85748ecc2f255ff9eb2be0fbe9e15fe0eabefc063c4157c
+checksum=fe1c93d12f385876457a989fc3ae05c0915d2692efc59289d0f70fabe5b44d2d
 
 # Package build options
 build_options="gdk_pixbuf perl startup_notification unicode3"

From e47264ed1c774c4d80901eddf944c15e1b7db0b0 Mon Sep 17 00:00:00 2001
From: Clyhtsuriva <aimeric@adjutor.xyz>
Date: Mon, 29 Nov 2021 12:46:14 +0100
Subject: [PATCH 030/288] balsa: update to 2.6.3

---
 srcpkgs/balsa/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/balsa/template b/srcpkgs/balsa/template
index 70838929c35a..af0f741d1860 100644
--- a/srcpkgs/balsa/template
+++ b/srcpkgs/balsa/template
@@ -1,6 +1,6 @@
 # Template file for 'balsa'
 pkgname=balsa
-version=2.6.2
+version=2.6.3
 revision=1
 build_style=gnu-configure
 configure_args="--without-gnome --with-libsecret --with-gpgme --with-sqlite
@@ -13,5 +13,5 @@ short_desc="Email client for GNOME"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="https://pawsa.fedorapeople.org/balsa/"
-distfiles="https://pawsa.fedorapeople.org/balsa/balsa-${version}.tar.bz2"
-checksum=51d52040577b730d7a199e97ea3687b3d0f7cf7f08f6e339e784d700621a02f0
+distfiles="https://pawsa.fedorapeople.org/balsa/balsa-${version}.tar.xz"
+checksum=d4d04576c9a5026064f7d480b34531faf59543f2e4d57c48a6fa5c76661e1dd4

From 96d64fcf921640380f2f63a4d751fd9d96720b66 Mon Sep 17 00:00:00 2001
From: jgart <jgart@dismail.de>
Date: Mon, 29 Nov 2021 03:05:34 -0500
Subject: [PATCH 031/288] hugo: update to 0.89.4.

---
 srcpkgs/hugo/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/hugo/template b/srcpkgs/hugo/template
index d2765c6722db..444018d45dbf 100644
--- a/srcpkgs/hugo/template
+++ b/srcpkgs/hugo/template
@@ -1,6 +1,6 @@
 # Template file for 'hugo'
 pkgname=hugo
-version=0.89.1
+version=0.89.4
 revision=1
 build_style=go
 go_import_path="github.com/gohugoio/hugo"
@@ -10,7 +10,7 @@ maintainer="Andrea Brancaleoni <abc@pompel.me>"
 license="Apache-2.0"
 homepage="https://gohugo.io"
 distfiles="https://github.com/gohugoio/hugo/archive/v${version}.tar.gz"
-checksum=c47f144291819a8d9f065f69ab290a198dfabde86a27ac2325a89f03c6e5ea3f
+checksum=9d4f61788f8d886913a1be15b3eae04fad04a4e243bd7f65c5e7367bd617856d
 
 post_install() {
 	vdoc README.md

From c5a166baa2e984502669873323f43085f26893a9 Mon Sep 17 00:00:00 2001
From: jgart <jgart@dismail.de>
Date: Mon, 29 Nov 2021 02:00:44 -0500
Subject: [PATCH 032/288] stagit: update to 0.9.6.

---
 srcpkgs/stagit/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/stagit/template b/srcpkgs/stagit/template
index 89c5a8cb177c..7078a4f6c946 100644
--- a/srcpkgs/stagit/template
+++ b/srcpkgs/stagit/template
@@ -1,6 +1,6 @@
 # Template file for 'stagit'
 pkgname=stagit
-version=0.9.5
+version=0.9.6
 revision=1
 build_style=gnu-makefile
 make_install_args="MANPREFIX=/usr/share/man"
@@ -10,7 +10,7 @@ maintainer="Steve Prybylski <sa.prybylx@gmail.com>"
 license="MIT"
 homepage="https://codemadness.org/git/stagit/log.html"
 distfiles="https://codemadness.org/releases/stagit/${pkgname}-${version}.tar.gz"
-checksum=025a17c7be3a4e98a2319efc4eb6329e9ea6a778b2b24b0eb97a342ece9bb039
+checksum=d072f386f3a546ed0341e20f9c2dfd7756a761fab1c40316a96690cb2b3066d0
 LDFLAGS="-lgit2"
 
 post_install() {

From bb484e5bcd2934bec4c9763e6bd5e8a355120980 Mon Sep 17 00:00:00 2001
From: cinerea0 <cinerea0@disroot.org>
Date: Mon, 29 Nov 2021 01:37:08 -0500
Subject: [PATCH 033/288] onefetch: update to 2.11.0

---
 srcpkgs/onefetch/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/onefetch/template b/srcpkgs/onefetch/template
index cf9832cb5459..88f21bc3b351 100644
--- a/srcpkgs/onefetch/template
+++ b/srcpkgs/onefetch/template
@@ -1,6 +1,6 @@
 # Template file for 'onefetch'
 pkgname=onefetch
-version=2.10.2
+version=2.11.0
 revision=1
 build_style=cargo
 short_desc="Git repository summary on your terminal"
@@ -8,7 +8,7 @@ maintainer="Jan Christian Grünhage <jan.christian@gruenhage.xyz>"
 license="MIT"
 homepage="https://github.com/o2sh/onefetch"
 distfiles="https://github.com/o2sh/onefetch/archive/v${version}.tar.gz"
-checksum=6e4d4effcd4fd94ce21625a5e32da5da6446c8874200e40dd791e623b7aff7bb
+checksum=ffd3cc3bd24e299ede1fada2b2da8bf066d59219da167477e1997c860650c192
 
 post_install() {
 	vlicense LICENSE.md

From d64f2416b0187801ec0261a2d0ee6cf2e262068e Mon Sep 17 00:00:00 2001
From: cinerea0 <cinerea0@disroot.org>
Date: Mon, 29 Nov 2021 00:50:38 -0500
Subject: [PATCH 034/288] mdBook: update to 0.4.14

---
 srcpkgs/mdBook/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/mdBook/template b/srcpkgs/mdBook/template
index b9df0433334f..465ff1a1bbbc 100644
--- a/srcpkgs/mdBook/template
+++ b/srcpkgs/mdBook/template
@@ -1,6 +1,6 @@
 # Template file for 'mdBook'
 pkgname=mdBook
-version=0.4.13
+version=0.4.14
 revision=1
 build_style=cargo
 short_desc="Create book from markdown files. Like Gitbook but implemented in Rust"
@@ -9,7 +9,7 @@ license="MPL-2.0"
 homepage="https://github.com/rust-lang/mdBook"
 changelog="https://raw.githubusercontent.com/rust-lang/mdBook/master/CHANGELOG.md"
 distfiles="https://github.com/rust-lang/mdBook/archive/v${version}.tar.gz"
-checksum=12a88a08e5c5b26810cc33b4e0ebed7cc72394f9041e8b15253e3cfac1223a7b
+checksum=59fd3e417e9d09deac89e20467194dd9f93854c2f1a87e845816c5cec676765c
 
 post_install() {
 	vlicense LICENSE

From 7b6735c90bb71b5be610bda29696ca58152590e1 Mon Sep 17 00:00:00 2001
From: teldra <teldra@rotce.de>
Date: Sun, 28 Nov 2021 01:11:22 +0100
Subject: [PATCH 035/288] py3status: update to 3.40.

---
 srcpkgs/py3status/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/py3status/template b/srcpkgs/py3status/template
index 5267fd63fdbe..092ccfbe2bd9 100644
--- a/srcpkgs/py3status/template
+++ b/srcpkgs/py3status/template
@@ -1,7 +1,7 @@
 # Template file for 'py3status'
 pkgname=py3status
-version=3.39
-revision=2
+version=3.40
+revision=1
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-setuptools python3-pyudev"
@@ -12,7 +12,7 @@ license="BSD-3-Clause"
 homepage="https://github.com/ultrabug/py3status"
 changelog="https://raw.githubusercontent.com/ultrabug/py3status/master/CHANGELOG"
 distfiles="${homepage}/archive/${version}.tar.gz"
-checksum=d18b81e86d5a44d2fa67453c3e9f04b9285005b2a7a9455890903d0e2dfe843c
+checksum=84885ec8a43626dcd7576b9cad029406c98675ca00ba66ff124d7607290d2b66
 
 post_install() {
 	vlicense LICENSE

From ec13a4999421c9386ea35c4584241f6fa60e417b Mon Sep 17 00:00:00 2001
From: teldra <teldra@rotce.de>
Date: Sun, 28 Nov 2021 01:08:24 +0100
Subject: [PATCH 036/288] openimagedenoise: update to 1.4.2.

---
 srcpkgs/openimagedenoise/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/openimagedenoise/template b/srcpkgs/openimagedenoise/template
index 7120d39bae20..8190e029a08b 100644
--- a/srcpkgs/openimagedenoise/template
+++ b/srcpkgs/openimagedenoise/template
@@ -1,6 +1,6 @@
 # Template file for 'openimagedenoise'
 pkgname=openimagedenoise
-version=1.4.1
+version=1.4.2
 revision=1
 archs="x86_64*"
 wrksrc=oidn-${version}
@@ -12,7 +12,7 @@ maintainer="teldra <teldra@rotce.de>"
 license="Apache-2.0"
 homepage="https://openimagedenoise.github.io"
 distfiles="https://github.com/OpenImageDenoise/oidn/releases/download/v${version}/oidn-${version}.src.tar.gz"
-checksum=9088966685a78adf24b8de075d66e4c0019bd7b2b9d29c6e45aaf35d294e3f6f
+checksum=e70d27ce24b41364782376c1b3b4f074f77310ccfe5f8ffec4a13a347e48a0ea
 
 do_check() {
 	build/oidnTest

From 1279ad7651c76f471c08b3b7f2847d26b7acfb3a Mon Sep 17 00:00:00 2001
From: Firgen <filip.frgelec@disroot.org>
Date: Sun, 14 Nov 2021 15:27:49 +0100
Subject: [PATCH 037/288] i3lock-color: update to 2.13.c.4.

---
 srcpkgs/i3lock-color/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/i3lock-color/template b/srcpkgs/i3lock-color/template
index 7f5572f99d64..6ce184239bb4 100644
--- a/srcpkgs/i3lock-color/template
+++ b/srcpkgs/i3lock-color/template
@@ -1,6 +1,6 @@
 # Template file for 'i3lock-color'
 pkgname=i3lock-color
-version=2.12.c.5
+version=2.13.c.4
 revision=1
 build_style=gnu-configure
 hostmakedepends="pkg-config automake"
@@ -11,7 +11,7 @@ maintainer="jtalowell <jtalowell@protonmail.com>"
 license="MIT"
 homepage="https://github.com/Raymo111/i3lock-color"
 distfiles="https://github.com/Raymo111/i3lock-color/archive/${version}.tar.gz"
-checksum=62c9bdff2759186426b184ed45e4c1aae1dc3c582499d94da68d9b08662a96a9
+checksum=5df4cd3d515d938630ced981a7f0a6e01344d1ec51d10fd3c3d131d19283df69
 conf_files="/etc/pam.d/i3lock"
 conflicts="i3lock"
 

From 62e8e4c61acc5af7cfaeb6a28a07d1dc656bde45 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Piotr=20W=C3=B3jcik?= <chocimier@tlen.pl>
Date: Mon, 29 Nov 2021 20:04:48 +0100
Subject: [PATCH 038/288] diffoscope: update to 194.

---
 srcpkgs/diffoscope/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/diffoscope/template b/srcpkgs/diffoscope/template
index 596f402323fe..31a2ca350066 100644
--- a/srcpkgs/diffoscope/template
+++ b/srcpkgs/diffoscope/template
@@ -1,6 +1,6 @@
 # Template file for 'diffoscope'
 pkgname=diffoscope
-version=193
+version=194
 revision=1
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -14,4 +14,4 @@ license="GPL-3.0-or-later"
 homepage="https://diffoscope.org/"
 changelog="https://salsa.debian.org/reproducible-builds/diffoscope/raw/master/debian/changelog"
 distfiles="${PYPI_SITE}/d/diffoscope/diffoscope-${version}.tar.gz"
-checksum=d836ddf24ccb4ffabd798ea1b7fcb66b87e55d5e8ff08286620bb7c64e1d829f
+checksum=3d28f0325e00effc6c23c50f916d153524aa393623df2fd1fc8ae0f6a12daf94

From 5885f6affeb732461637037b4c9141949a4f10ab Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C3=89rico=20Nogueira?= <erico.erc@gmail.com>
Date: Mon, 29 Nov 2021 02:01:44 -0300
Subject: [PATCH 039/288] gnome-keyring: remove libcap-ng, adopt.

We don't set capabilities on the binary right now, so it's better to
build without libcap-ng, so it doesn't complain on start-up. This is
also done by other distros, see [1].

libcap was no longer used, and neither was libtasn1.

We already depend on gcr via shlibs, so it doesn't need to be in
depends= explicitly.

Also update changelog to canonical URL.

[1] https://gitlab.gnome.org/GNOME/gnome-keyring/-/merge_requests/41#note_1277767
---
 srcpkgs/gnome-keyring/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/gnome-keyring/template b/srcpkgs/gnome-keyring/template
index 12f1e8d2df64..f479f7f0fe5e 100644
--- a/srcpkgs/gnome-keyring/template
+++ b/srcpkgs/gnome-keyring/template
@@ -1,19 +1,19 @@
 # Template file for 'gnome-keyring'
 pkgname=gnome-keyring
 version=40.0
-revision=2
+revision=3
 build_style=gnu-configure
 configure_args="--with-pam-dir=/usr/lib/security --disable-schemas-compile"
 hostmakedepends="autoconf docbook-xsl glib-devel intltool libtasn1-tools libxslt
  openssh pkg-config"
-makedepends="gcr-devel libcap-devel libcap-ng-devel libtasn1-devel pam-devel"
-depends="dconf gcr"
+makedepends="gcr-devel pam-devel"
+depends="dconf"
 checkdepends="dbus xvfb-run"
 short_desc="GNOME password and secret manager"
-maintainer="Orphaned <orphan@voidlinux.org>"
+maintainer="Érico Nogueira <ericonr@disroot.org>"
 license="GPL-2.0-or-later, LGPL-2.1-or-later"
 homepage="https://www.gnome.org"
-changelog="https://raw.githubusercontent.com/GNOME/gnome-keyring/gnome-40/NEWS"
+changelog="https://gitlab.gnome.org/GNOME/gnome-keyring/-/raw/master/NEWS"
 distfiles="${GNOME_SITE}/$pkgname/${version%.*}/$pkgname-$version.tar.xz"
 checksum=a3d24db08ee2fdf240fbbf0971a98c8ee295aa0e1a774537f4ea938038a3b931
 make_check=ci-skip

From c154356bb94361d51db610720debac2d1b446c5c Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C3=89rico=20Nogueira?= <erico.erc@gmail.com>
Date: Mon, 29 Nov 2021 02:10:34 -0300
Subject: [PATCH 040/288] texinfo: update to 6.8.

---
 srcpkgs/texinfo/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/texinfo/template b/srcpkgs/texinfo/template
index c183625028c5..55948fd8bab5 100644
--- a/srcpkgs/texinfo/template
+++ b/srcpkgs/texinfo/template
@@ -1,6 +1,6 @@
 # Template file for 'texinfo'
 pkgname=texinfo
-version=6.7
+version=6.8
 revision=1
 build_style=gnu-configure
 configure_args="--disable-static --disable-perl-xs"
@@ -10,9 +10,9 @@ depends="gzip perl"
 short_desc="GNU Documentation System"
 maintainer="Enno Boland <gottox@voidlinux.org>"
 license="GPL-3.0-or-later"
-homepage="http://www.gnu.org/software/texinfo/"
+homepage="https://www.gnu.org/software/texinfo/"
 distfiles="${GNU_SITE}/$pkgname/$pkgname-$version.tar.xz"
-checksum=988403c1542d15ad044600b909997ba3079b10e03224c61188117f3676b02caa
+checksum=8eb753ed28bca21f8f56c1a180362aed789229bd62fff58bf8368e9beb59fec4
 
 if [ -z "$CROSS_BUILD" ]; then
 	# XXX fails with cross compilation

From 749a2adfceb26bca9c12eb575734ac023da3c044 Mon Sep 17 00:00:00 2001
From: Luke Hannan <luke@lukehannan.com>
Date: Mon, 29 Nov 2021 17:50:36 +0200
Subject: [PATCH 041/288] R: update to 4.1.2.

---
 srcpkgs/R/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/R/template b/srcpkgs/R/template
index db75515b11cd..8a7db746af46 100644
--- a/srcpkgs/R/template
+++ b/srcpkgs/R/template
@@ -1,7 +1,7 @@
 # Template file for 'R'
 pkgname=R
-version=4.1.1
-revision=2
+version=4.1.2
+revision=1
 build_style=gnu-configure
 configure_args="--docdir=/usr/share/doc/R rdocdir=/usr/share/doc/R
  --with-blas$(vopt_if openblas '=openblas') --with-lapack
@@ -22,7 +22,7 @@ license="GPL-2.0-or-later"
 homepage="https://www.r-project.org/"
 changelog="https://cran.r-project.org/doc/manuals/r-release/NEWS.html"
 distfiles="https://cran.r-project.org/src/base/R-4/${pkgname}-${version}.tar.gz"
-checksum=515e03265752257d0b7036f380f82e42b46ed8473f54f25c7b67ed25bbbdd364
+checksum=2036225e9f7207d4ce097e54972aecdaa8b40d7d9911cd26491fac5a0fab38af
 nocross=yes
 shlib_provides="libR.so"
 make_check=extended

From 55ecf9eed971eb3ce8ef00d0172c9ead5897e308 Mon Sep 17 00:00:00 2001
From: Lorem <notloremipsum@protonmail.com>
Date: Sun, 28 Nov 2021 11:05:58 +0530
Subject: [PATCH 042/288] New package: coeurl-0.1.0

---
 common/shlibs           |  1 +
 srcpkgs/coeurl-devel    |  1 +
 srcpkgs/coeurl/template | 28 ++++++++++++++++++++++++++++
 3 files changed, 30 insertions(+)
 create mode 120000 srcpkgs/coeurl-devel
 create mode 100644 srcpkgs/coeurl/template

diff --git a/common/shlibs b/common/shlibs
index dac22845d445..527588585aec 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -4070,3 +4070,4 @@ libbrial_groebner.so.3 brial-1.2.10_1
 libm4ri-0.0.20200125.so m4ri-20200125_1
 libm4rie-0.0.20200125.so m4rie-20200125_1
 libptytty.so.0 libptytty-2.0_1
+libcoeurl.so.0 coeurl-0.1.0_1
diff --git a/srcpkgs/coeurl-devel b/srcpkgs/coeurl-devel
new file mode 120000
index 000000000000..bdd2ff71f0cb
--- /dev/null
+++ b/srcpkgs/coeurl-devel
@@ -0,0 +1 @@
+coeurl
\ No newline at end of file
diff --git a/srcpkgs/coeurl/template b/srcpkgs/coeurl/template
new file mode 100644
index 000000000000..dd6600a89bba
--- /dev/null
+++ b/srcpkgs/coeurl/template
@@ -0,0 +1,28 @@
+# Template file for 'coeurl'
+pkgname=coeurl
+version=0.1.0
+revision=1
+wrksrc=coeurl-v${version}
+build_style=meson
+hostmakedepends="pkg-config"
+makedepends="spdlog libevent-devel libcurl-devel"
+short_desc="Simple async wrapper around CURL for C++"
+maintainer="Lorem <notloremipsum@protonmail.com>"
+license="MIT"
+homepage="https://nheko.im/nheko-reborn/coeurl"
+distfiles="https://nheko.im/nheko-reborn/coeurl/-/archive/v${version}/coeurl-v${version}.tar.gz"
+checksum=2861453317c6da359a00083e39d899dfe0fc71becadd726ef845a5fba57d3f64
+
+post_install() {
+	vlicense LICENSE
+}
+
+coeurl-devel_package() {
+	short_desc+=" - development files"
+	depends="${sourcepkg}>=${version}_${revision} ${makedepends}"
+	pkg_install() {
+		vmove usr/include
+		vmove usr/lib/pkgconfig
+		vmove "usr/lib/*.so"
+	}
+}

From 758dd9fc25d53daad28ebf02cc94b7b21d92c7ab Mon Sep 17 00:00:00 2001
From: Lorem <notloremipsum@protonmail.com>
Date: Sun, 28 Nov 2021 11:07:15 +0530
Subject: [PATCH 043/288] mtxclient: update to 0.6.0.

---
 common/shlibs              | 2 +-
 srcpkgs/mtxclient/template | 6 +++---
 2 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index 527588585aec..ad60646030fe 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -420,7 +420,7 @@ libField3D.so.1.7 Field3D-1.7.3_1
 libMAC.so.6 libMAC-5.28_1
 libmad.so.0 libmad-0.15.1b_1
 libmatroska.so.7 libmatroska-1.6.0_1
-libmatrix_client.so.0.5.1 mtxclient-0.5.1_1
+libmatrix_client.so.0.6.0 mtxclient-0.6.0_1
 libebml.so.5 libebml-1.4.0_1
 libdvdread.so.8 libdvdread-6.1.1_1
 libdvdnav.so.4 libdvdnav-4.1.3_1
diff --git a/srcpkgs/mtxclient/template b/srcpkgs/mtxclient/template
index 35f3d4a10f42..9c8c1e3a9efe 100644
--- a/srcpkgs/mtxclient/template
+++ b/srcpkgs/mtxclient/template
@@ -1,17 +1,17 @@
 # Template file for 'mtxclient'
 pkgname=mtxclient
-version=0.5.1
+version=0.6.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_LIB_TESTS=OFF -DBUILD_LIB_EXAMPLES=OFF"
 hostmakedepends="pkg-config"
-makedepends="boost-devel json-c++ olm-devel openssl-devel"
+makedepends="json-c++ olm-devel openssl-devel coeurl-devel"
 short_desc="Client API library for the Matrix protocol"
 maintainer="Lorem <notloremipsum@protonmail.com>"
 license="MIT"
 homepage="https://github.com/Nheko-Reborn/mtxclient"
 distfiles="https://github.com/Nheko-Reborn/mtxclient/archive/v${version}.tar.gz"
-checksum=9478d870296ebe7679c90f563cb798eb3cdd3f9c4578ceea5af75b66f456baaa
+checksum=4245feb0bd4ae8e026c01f546a6bea45bc9d9d57d13430b8ba446b0aec4915c4
 
 post_install() {
 	vlicense LICENSE

From 9cef86977e52a2b00755d5db95163863a129a9db Mon Sep 17 00:00:00 2001
From: Lorem <notloremipsum@protonmail.com>
Date: Sun, 28 Nov 2021 11:07:27 +0530
Subject: [PATCH 044/288] nheko: update to 0.9.0.

---
 srcpkgs/nheko/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/nheko/template b/srcpkgs/nheko/template
index 7b7c6bfbf6e1..deaf85713976 100644
--- a/srcpkgs/nheko/template
+++ b/srcpkgs/nheko/template
@@ -1,11 +1,11 @@
 # Template file for 'nheko'
 pkgname=nheko
-version=0.8.2
-revision=2
+version=0.9.0
+revision=1
 build_style=cmake
 hostmakedepends="qt5-host-tools qt5-qmake pkg-config qt5-declarative"
 makedepends="qt5-multimedia-devel qt5-svg-devel qt5-tools-devel fmt-devel
- spdlog mtxclient-devel boost-devel cmark-devel olm-devel json-c++ lmdb++
+ spdlog mtxclient-devel cmark-devel olm-devel json-c++ lmdb++ coeurl-devel
  qt5-declarative-devel qt5-quickcontrols2-devel qtkeychain-qt5-devel
  gst-plugins-bad1-devel gst-plugins-base1-devel xcb-util-wm-devel"
 depends="hicolor-icon-theme qt5-quickcontrols2 qt5-graphicaleffects
@@ -16,7 +16,7 @@ license="GPL-3.0-or-later"
 homepage="https://github.com/Nheko-Reborn/nheko"
 changelog="https://github.com/Nheko-Reborn/nheko/blob/master/CHANGELOG.md"
 distfiles="https://github.com/Nheko-Reborn/nheko/archive/v${version}.tar.gz"
-checksum=df4575c47daab47d418637a4637b599e3848dd749132ca1e92f981d9212eabb2
+checksum=309505f13d3b65ea23c0db19e59e469905b1ae437d2d6c7d1b496ac0921fb141
 
 case "$XBPS_TARGET_MACHINE" in
 	armv*-musl)

From d8cc0dc0da92b9331deb75c6874d3813d0e56edc Mon Sep 17 00:00:00 2001
From: Evgeny Ermakov <evgeny.v.ermakov@gmail.com>
Date: Tue, 30 Nov 2021 06:03:00 +1100
Subject: [PATCH 045/288] cglm: update to 0.8.4.

---
 srcpkgs/cglm/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/cglm/template b/srcpkgs/cglm/template
index c7dfee606c45..5b553c7c0d12 100644
--- a/srcpkgs/cglm/template
+++ b/srcpkgs/cglm/template
@@ -1,6 +1,6 @@
 # Template file for 'cglm'
 pkgname=cglm
-version=0.8.3
+version=0.8.4
 revision=1
 build_style=cmake
 short_desc="Highly Optimized Graphics Math (glm) for C"
@@ -8,7 +8,7 @@ maintainer="Nicu Borta <nicuborta123@tutanota.com>"
 license="MIT"
 homepage="https://github.com/recp/cglm"
 distfiles="https://github.com/recp/cglm/archive/v${version}.tar.gz"
-checksum=3a3f935f9f2ed5a8cb6337e421bf6f3a699a72d8cfe26fde1bbb8fde5c1c8aaf
+checksum=42f84c42c8a3e62954da77ab5c5d3264033d5802009e175db7921332a476126e
 
 post_install() {
 	vlicense LICENSE

From 74a76b0807223bd9a5cb35d3b506d1aa75ad5eec Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Mon, 29 Nov 2021 21:37:47 +0100
Subject: [PATCH 046/288] debootstrap: update to 1.0.126+nmu1.

---
 srcpkgs/debootstrap/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/debootstrap/template b/srcpkgs/debootstrap/template
index df67a598d286..14d0528a710c 100644
--- a/srcpkgs/debootstrap/template
+++ b/srcpkgs/debootstrap/template
@@ -1,6 +1,6 @@
 # Template file for 'debootstrap'
 pkgname=debootstrap
-version=1.0.126
+version=1.0.126+nmu1
 revision=1
 build_style=fetch
 depends="binutils gnupg gzip tar wget xz zstd"
@@ -10,7 +10,7 @@ license="MIT"
 homepage="http://packages.qa.debian.org/d/debootstrap.html"
 distfiles="${DEBIAN_SITE}/main/d/${pkgname}/${pkgname}_${version}_all.deb
  ${DEBIAN_SITE}/main/d/debian-archive-keyring/debian-archive-keyring_2021.1.1_all.deb"
-checksum="3084a2dcb4cd56a7c094c6b7cd745b6736ad78846b108275616d448fa6911f5e
+checksum="396f694346e6b401341ca07e30355faebea0ff490322cdbba804066cf4a0d048
  56beca470dcd9b6d7e6c3c9e9d702101e01e9467e62810a8c357bd7b9c26251d"
 
 case "$XBPS_TARGET_MACHINE" in

From ed83b2c9ad9b20be80ca0567038d48db8b5790b9 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Mon, 29 Nov 2021 21:37:56 +0100
Subject: [PATCH 047/288] linux: update to 5.15.

---
 srcpkgs/linux/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/linux/template b/srcpkgs/linux/template
index 50ff91aef896..f76a6a1d27e8 100644
--- a/srcpkgs/linux/template
+++ b/srcpkgs/linux/template
@@ -1,6 +1,6 @@
 # Template file for 'linux'
 pkgname=linux
-version=5.13
+version=5.15
 revision=1
 build_style=meta
 depends="linux${version} linux-base"

From a79e0214064cab712a3d636424b3121c3b4074c1 Mon Sep 17 00:00:00 2001
From: Mat Boehlke <mtboehlke@gmail.com>
Date: Mon, 29 Nov 2021 10:05:29 -0600
Subject: [PATCH 048/288] font-sil-charis: update to 6.001

Remove unzip hostdepend: bsdtar works just fine
---
 srcpkgs/font-sil-charis/template | 15 +++++++--------
 1 file changed, 7 insertions(+), 8 deletions(-)

diff --git a/srcpkgs/font-sil-charis/template b/srcpkgs/font-sil-charis/template
index b8b351e36462..5d804c0e6bfe 100644
--- a/srcpkgs/font-sil-charis/template
+++ b/srcpkgs/font-sil-charis/template
@@ -1,21 +1,20 @@
 # Template file for 'font-sil-charis'
 pkgname=font-sil-charis
-version=5.000
-revision=2
+version=6.001
+revision=1
 wrksrc="CharisSIL-${version}"
-hostmakedepends="unzip"
 depends="font-util"
 short_desc="Unicode serif font, similar to Bitstream Charter"
 maintainer="Ivan Sokolov <ivan-p-sokolov@ya.ru>"
 license="OFL-1.1"
 homepage="https://software.sil.org/charis/"
 distfiles="https://software.sil.org/downloads/r/charis/CharisSIL-${version}.zip"
-checksum=5e3e5473b30363008c289cc87e2aa584a0916087a63a3f689defa8e0cee09bfd
+checksum=850df14e9024790e061a406715693ff39489dd071ea583b3258bdeba8384ebe8
 font_dirs="/usr/share/fonts/SIL"
 
 do_install() {
-	vinstall CharisSIL-B.ttf 644 ${font_dirs}
-	vinstall CharisSIL-BI.ttf 644 ${font_dirs}
-	vinstall CharisSIL-I.ttf 644 ${font_dirs}
-	vinstall CharisSIL-R.ttf 644 ${font_dirs}
+	vinstall CharisSIL-Bold.ttf 644 ${font_dirs}
+	vinstall CharisSIL-BoldItalic.ttf 644 ${font_dirs}
+	vinstall CharisSIL-Italic.ttf 644 ${font_dirs}
+	vinstall CharisSIL-Regular.ttf 644 ${font_dirs}
 }

From 1fb16c5d18cece04f4a92e753606415e33b29438 Mon Sep 17 00:00:00 2001
From: Gerardo Di iorio <arete74@gmail.com>
Date: Mon, 29 Nov 2021 22:06:04 +0100
Subject: [PATCH 049/288] todoist: update to 0.16.0.

---
 srcpkgs/todoist/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/todoist/template b/srcpkgs/todoist/template
index 49761d228b01..9e96ed98dc5f 100644
--- a/srcpkgs/todoist/template
+++ b/srcpkgs/todoist/template
@@ -1,6 +1,6 @@
 # Template file for 'todoist'
 pkgname=todoist
-version=0.15.0
+version=0.16.0
 revision=1
 build_style=go
 go_import_path="github.com/sachaos/todoist"
@@ -9,7 +9,7 @@ maintainer="Gerardo Di Iorio <arete74@gmail.com>"
 license="MIT"
 homepage="https://github.com/sachaos/todoist"
 distfiles="${homepage}/archive/v${version}.tar.gz"
-checksum=b7ffa14574bd241ab9e21a28f3d40c17b1a12250e89cfbc8ad708cfbfcdd84b3
+checksum=9d5a8f5c6b92d3d6df292f9ae96bec46049b4e4b7a482f7232e4e5b9708dfffa
 
 post_install() {
 	vdoc README.md

From 635b93255b51aaa500cee05d3132387ac4574683 Mon Sep 17 00:00:00 2001
From: Gerardo Di iorio <arete74@gmail.com>
Date: Mon, 29 Nov 2021 22:08:08 +0100
Subject: [PATCH 050/288] cpuid: update to 20211129.

---
 srcpkgs/cpuid/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/cpuid/template b/srcpkgs/cpuid/template
index 8f8f26c25920..0b363cdf07ff 100644
--- a/srcpkgs/cpuid/template
+++ b/srcpkgs/cpuid/template
@@ -1,6 +1,6 @@
 # Template file for 'cpuid'
 pkgname=cpuid
-version=20211121
+version=20211129
 revision=1
 archs="i686* x86_64*"
 build_style=gnu-makefile
@@ -10,4 +10,4 @@ maintainer="Gerardo Di Iorio  <arete74@gmail.com>"
 license="GPL-2.0-or-later"
 homepage="http://www.etallen.com/cpuid.html"
 distfiles="http://www.etallen.com/cpuid/cpuid-${version}.src.tar.gz"
-checksum=172f562adf31b15de177b12e6154f67179a7e5ee14d078d72319c0c074e6c01a
+checksum=230772bb88c44732e68a42d2eff43bcff46d893bf4ea6e04151d4cb6e8c88e2f

From ff0f2bd9280a2cad8ee9ad2e9ffb55e032774e37 Mon Sep 17 00:00:00 2001
From: Piraty <piraty1@inbox.ru>
Date: Sun, 28 Nov 2021 21:06:05 +0100
Subject: [PATCH 051/288] tor: update to 0.4.6.8.

---
 srcpkgs/tor/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/tor/template b/srcpkgs/tor/template
index 39ee33963862..d6e94e369de1 100644
--- a/srcpkgs/tor/template
+++ b/srcpkgs/tor/template
@@ -1,6 +1,6 @@
 # Template file for 'tor'
 pkgname=tor
-version=0.4.6.7
+version=0.4.6.8
 revision=1
 build_style=gnu-configure
 configure_args="--enable-zstd"
@@ -14,7 +14,7 @@ license="BSD-3-Clause"
 homepage="https://www.torproject.org/"
 changelog="https://gitlab.torproject.org/tpo/core/tor/-/raw/main/ChangeLog"
 distfiles="https://dist.torproject.org/tor-${version}.tar.gz"
-checksum=ff665ce121b2952110bd98b9c8741b5593bf6c01ac09033ad848ed92c2510f9a
+checksum=15ce1a37b4cc175b07761e00acdcfa2c08f0d23d6c3ab9c97c464bd38cc5476a
 
 conf_files="/etc/tor/torrc"
 system_accounts="tor"

From 44cd21f72bc5fd3cd60df3e02768705529103e59 Mon Sep 17 00:00:00 2001
From: wundrweapon <whhacker.dcx@gmail.com>
Date: Mon, 29 Nov 2021 21:23:49 -0500
Subject: [PATCH 052/288] font-firacode: update to 6.

---
 srcpkgs/font-firacode/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/font-firacode/template b/srcpkgs/font-firacode/template
index 73536112a695..35d4a5630c48 100644
--- a/srcpkgs/font-firacode/template
+++ b/srcpkgs/font-firacode/template
@@ -1,7 +1,7 @@
 # Template file for 'font-firacode'
 pkgname=font-firacode
-version=5.2
-revision=2
+version=6
+revision=1
 create_wrksrc=yes
 hostmakedepends="unzip"
 short_desc="FiraCode: monospaced font with programming ligatures"
@@ -10,7 +10,7 @@ license="OFL-1.1"
 homepage="https://github.com/tonsky/FiraCode"
 changelog="https://github.com/tonsky/FiraCode/raw/master/CHANGELOG.md"
 distfiles="https://github.com/tonsky/FiraCode/releases/download/${version}/Fira_Code_v${version}.zip"
-checksum=521a72be00dd22678d248e63f817c0c79c1b6f23a4fbd377eba73d30cdca5efd
+checksum=a4997c2f905fb20a6d814baf7b9bab7df7de574a8e87d6af509685a43291caf1
 font_dirs="/usr/share/fonts/TTF"
 
 do_install() {

From 9a3f53fbabe967da9a8d747e23fda1e8b0c55e7a Mon Sep 17 00:00:00 2001
From: Evgeny Ermakov <evgeny.v.ermakov@gmail.com>
Date: Tue, 30 Nov 2021 05:48:58 +1100
Subject: [PATCH 053/288] scrot: update to 1.7.

---
 srcpkgs/scrot/template | 10 ++++++++--
 1 file changed, 8 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/scrot/template b/srcpkgs/scrot/template
index 7565f4303e7e..6c1336c260ef 100644
--- a/srcpkgs/scrot/template
+++ b/srcpkgs/scrot/template
@@ -1,6 +1,6 @@
 # Template file for 'scrot'
 pkgname=scrot
-version=1.6
+version=1.7
 revision=1
 build_style=gnu-configure
 make_install_args="docsdir=/usr/share/doc/scrot"
@@ -11,7 +11,13 @@ maintainer="Frank Steinborn <steinex@nognu.de>"
 license="MIT"
 homepage="https://github.com/resurrecting-open-source-projects/scrot"
 distfiles="https://github.com/resurrecting-open-source-projects/scrot/archive/${version}.tar.gz"
-checksum=5d53df3e86220b8aca21be03a39b542905f2a8a0ccd950fdce7fc48a32c09050
+checksum=e4ff764f93ea98018d46192c35bd34eeb577040ac6e217aa0d83b2a63d88f66b
+
+if [ "$XBPS_TARGET_LIBC" = musl ]; then
+	makedepends+=" musl-legacy-compat"
+else
+	makedepends+=" libbsd-devel"
+fi
 
 pre_configure() {
 	./autogen.sh

From c4df2cfe7e86c3683b1440fefebb1653f3295982 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Tue, 30 Nov 2021 14:25:44 +0700
Subject: [PATCH 054/288] ca-certificates: fix busybox mktemp compat

Close: #34323
---
 .../ca-certificates/patches/busybox-flags.patch    | 14 ++++++++++++++
 srcpkgs/ca-certificates/template                   |  4 ++--
 2 files changed, 16 insertions(+), 2 deletions(-)
 create mode 100644 srcpkgs/ca-certificates/patches/busybox-flags.patch

diff --git a/srcpkgs/ca-certificates/patches/busybox-flags.patch b/srcpkgs/ca-certificates/patches/busybox-flags.patch
new file mode 100644
index 000000000000..0f109e1b0bc1
--- /dev/null
+++ b/srcpkgs/ca-certificates/patches/busybox-flags.patch
@@ -0,0 +1,14 @@
+diff --git a/sbin/update-ca-certificates b/sbin/update-ca-certificates
+--- a/work/sbin/update-ca-certificates
++++ b/work/sbin/update-ca-certificates
+@@ -81,8 +81,8 @@ trap cleanup 0
+ # Helper files.  (Some of them are not simple arrays because we spawn
+ # subshells later on.)
+ TEMPBUNDLE="${ETCCERTSDIR}/${CERTBUNDLE}.new"
+-ADDED="$(mktemp --tmpdir "ca-certificates.tmp.XXXXXX")"
+-REMOVED="$(mktemp --tmpdir "ca-certificates.tmp.XXXXXX")"
++ADDED="$(mktemp -p "${TMPDIR:-/tmp}" "ca-certificates.tmp.XXXXXX")"
++REMOVED="$(mktemp -p "${TMPDIR:-/tmp}" "ca-certificates.tmp.XXXXXX")"
+ 
+ # Adds a certificate to the list of trusted ones.  This includes a symlink
+ # in /etc/ssl/certs to the certificate file and its inclusion into the
diff --git a/srcpkgs/ca-certificates/template b/srcpkgs/ca-certificates/template
index d328fae1eb72..30b2c68d95db 100644
--- a/srcpkgs/ca-certificates/template
+++ b/srcpkgs/ca-certificates/template
@@ -1,6 +1,6 @@
 # Template file for 'ca-certificates'
 pkgname=ca-certificates
-version=20211016+3.71
+version=20211016+3.72
 revision=1
 _nss_version=${version#*+}
 bootstrap=yes
@@ -16,7 +16,7 @@ homepage="https://wiki.mozilla.org/NSS:Root_certs"
 distfiles="${DEBIAN_SITE}/main/c/${pkgname}/${pkgname}_${version%+*}.tar.xz
  ${MOZILLA_SITE}/security/nss/releases/NSS_${_nss_version//\./_}_RTM/src/nss-${_nss_version}.tar.gz"
 checksum="2ae9b6dc5f40c25d6d7fe55e07b54f12a8967d1955d3b7b2f42ee46266eeef88
- 99acd315d9af35419cda4a6960f00a7d446bd231bd407174a7b07cb3dba0c253"
+ 6ea60a9ff113e493ea2ab25f41ea75a9fbd10af7903f26f703dac8680732d02e"
 
 post_extract() {
 	cp ${FILESDIR}/* $build_wrksrc/mozilla

From f8d8b49531c5ee7b036729501cc0fb3de721cb40 Mon Sep 17 00:00:00 2001
From: Andrew Benson <abenson+void@gmail.com>
Date: Tue, 30 Nov 2021 07:09:02 -0600
Subject: [PATCH 055/288] python3-rich: update to 10.15.1.

---
 srcpkgs/python3-rich/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-rich/template b/srcpkgs/python3-rich/template
index 79e4226fd0c1..a11c142a2002 100644
--- a/srcpkgs/python3-rich/template
+++ b/srcpkgs/python3-rich/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-rich'
 pkgname=python3-rich
-version=10.14.0
+version=10.15.1
 revision=1
 wrksrc="rich-${version}"
 build_style=python3-module
@@ -13,7 +13,7 @@ maintainer="Andrew Benson <abenson+void@gmail.com>"
 license="MIT"
 homepage="https://github.com/willmcgugan/rich"
 distfiles="${PYPI_SITE}/r/rich/rich-${version}.tar.gz"
-checksum=8bfe4546d56b4131298d3a9e571a0742de342f1593770bd0d4707299f772a0af
+checksum=93d0ea3c35ecfd8703dbe52b76885e224ad8d68c7766c921c726b14b22a57b7d
 
 post_install() {
 	vlicense LICENSE

From 762deaf6261194f1f1b855560f03207e3fdec3e4 Mon Sep 17 00:00:00 2001
From: Duncaen <duncaen@voidlinux.org>
Date: Tue, 30 Nov 2021 13:57:53 +0100
Subject: [PATCH 056/288] harfbuzz: update to 3.1.2.

---
 srcpkgs/harfbuzz/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/harfbuzz/template b/srcpkgs/harfbuzz/template
index e9924e9ed1aa..974779480058 100644
--- a/srcpkgs/harfbuzz/template
+++ b/srcpkgs/harfbuzz/template
@@ -1,6 +1,6 @@
 # Template file for 'harfbuzz'
 pkgname=harfbuzz
-version=2.9.1
+version=3.1.2
 revision=1
 build_style=meson
 build_helper=gir
@@ -14,7 +14,7 @@ license="MIT"
 homepage="http://www.freedesktop.org/wiki/Software/HarfBuzz/"
 changelog="https://github.com/harfbuzz/harfbuzz/raw/main/NEWS"
 distfiles="https://github.com/harfbuzz/harfbuzz/releases/download/${version}/harfbuzz-${version}.tar.xz"
-checksum=0edcc980f526a338452180e701d6aba6323aef457b6686976a7d17ccbddc51cf
+checksum=4056b1541dd8bbd8ec29207fe30e568805c0705515632d7fec53a94399bc7945
 
 libharfbuzz_package() {
 	short_desc+=" - runtime library"

From 7d5aaaa20fe8df1bcf1dfffa972719494c3f74c6 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Tue, 30 Nov 2021 15:53:03 +0100
Subject: [PATCH 057/288] babashka: update to 0.6.7.

---
 srcpkgs/babashka/template | 31 ++++++++++++++++++-------------
 1 file changed, 18 insertions(+), 13 deletions(-)

diff --git a/srcpkgs/babashka/template b/srcpkgs/babashka/template
index 588d3139d6d1..aba66be44069 100644
--- a/srcpkgs/babashka/template
+++ b/srcpkgs/babashka/template
@@ -1,6 +1,6 @@
 # Template file for 'babashka'
 pkgname=babashka
-version=0.6.5
+version=0.6.7
 revision=1
 hostmakedepends="mandrel leiningen git"
 makedepends="zlib-devel"
@@ -9,14 +9,15 @@ short_desc="Native, fast starting Clojure interpreter for scripting"
 maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="EPL-1.0"
 homepage="https://babashka.org/"
-_sci_commit=7896fe1bab824e8e07b198c6eaed1ec465ae3baa
-_babashka_curl_commit=2187f908c033da45978512979c53bb53321120ce
+_sci_commit=f3d2764b8f9fc14026c89e23d94fa2071ededcea
+_babashka_curl_commit=3d3d117ea0f8a143a06e3cace92e4e8b6a5782df
 _babashka_nrepl_commit=eadb3330f0a65e781755d8b328727698f1d41fb0
 _depstar_commit=c419b8c82041855d55593c5b561fc7cea8234712
-_process_commit=4fdf33c0243ff646dfa91c4454844a33e0f025b0
+_process_commit=cb12d2eea240fc1401feb9af2606a0847edfab10
 _pods_commit=f360afa6135b8bd2d384d9ba4582c0de6fdac804
-_deps_clj_commit=422b080c64dedad37979a748377394b2d4de7e7c
-_fs_commit=21eb0654efad0ffbeedfe8319dd1194319b30d29
+_deps_clj_commit=e06a1a450625a11409be0e2e8199415e0d2e51a9
+_fs_commit=6019ec9cb09632fdf84e4bc5879fd47ed57a35eb
+_babashka_core_commit=52a6037bd4b632bffffb04394fb4efd0cdab6b1e
 distfiles="https://github.com/babashka/babashka/archive/refs/tags/v${version}.tar.gz
  https://github.com/borkdude/sci/archive/${_sci_commit}.tar.gz
  https://github.com/babashka/babashka.curl/archive/${_babashka_curl_commit}.tar.gz
@@ -25,22 +26,26 @@ distfiles="https://github.com/babashka/babashka/archive/refs/tags/v${version}.ta
  https://github.com/babashka/process/archive/${_process_commit}.tar.gz
  https://github.com/babashka/pods/archive/${_pods_commit}.tar.gz
  https://github.com/borkdude/deps.clj/archive/${_deps_clj_commit}.tar.gz
- https://github.com/babashka/fs/archive/${_fs_commit}.tar.gz"
-checksum="9053ba3582dbc94e4221eefe4e7f507d0c9e4d90aa5f941fb504f658ed3ceea2
- 9ec8e74253e1a3a5ac1fbb1b1ed2c549a4bb194ffde55829683c11d6a1c67904
- d4efe2c84512c3914d80087a43f9dc8377b4318ab63579959c4488038d6b766b
+ https://github.com/babashka/fs/archive/${_fs_commit}.tar.gz
+ https://github.com/babashka/babashka.core/archive/${_babashka_core_commit}.tar.gz"
+checksum="2ec3ab92626ec42d681bb486e06ce784732401d404dfea32dbe5be23c26b3f5e
+ 89bfee50868795b09551550b5156865623fec8435eea8b9e8f71ae0ffab362eb
+ 45abdaa5e4effd3bcfea777d02844d4634f1f80a592843eca9ec7d3544b7e16d
  916d9cc8c0a3b895a72068b95c6ac985a65d30465a9d556af8acea20aaaacc42
  9d214a10a4f5e4f15b9c80354dae85689a40e941ec3417203354c0dc3ce9457b
- dcb999043dfc807a1ebfae99027b4434e726f647aa52fbd70ed58202d907d39a
+ 510facf66f1b4404de0ab12a1093b85213cf396f5d061728315c95fc527ed96b
  4070395956fc3cb0c22bac6fb4de1ad27130d24916e1915d8a3fe9eb591f6143
- dba354c4637595ed6a24e76914497dcb6f0059b531d8cd3c8c8c23385fff605a
- 2ebe97b7fe0ad349a6a1ff567df2c372571b9a672d81f5f5f83bbf45af708d71"
+ c7ee5cfac6592885342897b3a2a2276385a3c40f0df61beee9c0e84e313b3469
+ 9bb9cb06a1a2a3cd2e9334e9e1082a510474760ed650c98b9650ceca41f4fa42
+ bad285812bcc7de7e0dd905c5df99045d7f92d6e2e191fc2768c06adbaaeb709"
 
 nocross="https://build.voidlinux.org/builders/aarch64_builder/builds/33769/steps/shell_3/logs/stdio"
 
 post_extract() {
 	rmdir -v ${wrksrc}/sci
 	mv ${wrksrc}/../sci-${_sci_commit} ${wrksrc}/sci
+	rmdir -v ${wrksrc}/babashka.core
+	mv ${wrksrc}/../babashka.core-${_babashka_core_commit} ${wrksrc}/babashka.core
 	rmdir -v ${wrksrc}/babashka.curl
 	mv ${wrksrc}/../babashka.curl-${_babashka_curl_commit} ${wrksrc}/babashka.curl
 	rmdir -v ${wrksrc}/babashka.nrepl

From 3bb38f85f6e85ccbd276ab4701093fe284b58bc0 Mon Sep 17 00:00:00 2001
From: Duncaen <duncaen@voidlinux.org>
Date: Tue, 30 Nov 2021 15:55:29 +0100
Subject: [PATCH 058/288] Revert "harfbuzz: update to 3.1.2."

This reverts commit 908b075ecb296ec246e5553abefcdb3175fb0d1b.
---
 srcpkgs/harfbuzz/template | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/harfbuzz/template b/srcpkgs/harfbuzz/template
index 974779480058..1764bc6ef8c5 100644
--- a/srcpkgs/harfbuzz/template
+++ b/srcpkgs/harfbuzz/template
@@ -1,7 +1,8 @@
 # Template file for 'harfbuzz'
 pkgname=harfbuzz
-version=3.1.2
-revision=1
+reverts="3.1.2_1"
+version=2.9.1
+revision=2
 build_style=meson
 build_helper=gir
 configure_args="-Dglib=enabled -Dfreetype=enabled -Dcairo=enabled -Dicu=enabled
@@ -14,7 +15,7 @@ license="MIT"
 homepage="http://www.freedesktop.org/wiki/Software/HarfBuzz/"
 changelog="https://github.com/harfbuzz/harfbuzz/raw/main/NEWS"
 distfiles="https://github.com/harfbuzz/harfbuzz/releases/download/${version}/harfbuzz-${version}.tar.xz"
-checksum=4056b1541dd8bbd8ec29207fe30e568805c0705515632d7fec53a94399bc7945
+checksum=0edcc980f526a338452180e701d6aba6323aef457b6686976a7d17ccbddc51cf
 
 libharfbuzz_package() {
 	short_desc+=" - runtime library"

From b08c00ec242962f507e9585f67a37e350199b281 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 26 Nov 2021 12:01:25 +0700
Subject: [PATCH 059/288] gconf-editor: remove

---
 srcpkgs/gconf-editor/template     | 27 ---------------------------
 srcpkgs/removed-packages/template |  1 +
 2 files changed, 1 insertion(+), 27 deletions(-)
 delete mode 100644 srcpkgs/gconf-editor/template

diff --git a/srcpkgs/gconf-editor/template b/srcpkgs/gconf-editor/template
deleted file mode 100644
index d4d9fa79bd25..000000000000
--- a/srcpkgs/gconf-editor/template
+++ /dev/null
@@ -1,27 +0,0 @@
-# Template file for 'gconf-editor'
-pkgname=gconf-editor
-version=3.0.1
-revision=3
-build_style=gnu-configure
-configure_args="--disable-schemas-install --disable-scrollkeeper
- --with-gconf-schema-file-dir=/usr/share/gconf/schemas"
-hostmakedepends="pkg-config intltool itstool gnome-doc-utils GConf-devel which"
-makedepends="libxml2-devel gtk+3-devel gsettings-desktop-schemas-devel
- hicolor-icon-theme desktop-file-utils gnome-doc-utils GConf-devel"
-depends="gsettings-desktop-schemas>=3.10 hicolor-icon-theme desktop-file-utils"
-short_desc="Graphical editor to maintain the Gnome registry"
-maintainer="Enno Boland <gottox@voidlinux.org>"
-license="GPL-2.0-or-later"
-homepage="http://www.gnome.org"
-distfiles="${GNOME_SITE}/$pkgname/${version%.*}/$pkgname-$version.tar.xz"
-checksum=3064e84967b4b4216f5c7e065cfec8c52019438a590e9ed81366af2770660944
-
-post_patch() {
-	vsed -i -e 's/DATADIRNAME=lib/DATADIRNAME=share/' configure
-}
-
-post_install() {
-	mv ${DESTDIR}/usr/share/gconf/schemas/*.schemas ${wrksrc}
-	gconf-merge-schema ${DESTDIR}/usr/share/gconf/schemas/${pkgname}.schemas \
-		--domain ${pkgname} ${wrksrc}/*.schemas
-}
diff --git a/srcpkgs/removed-packages/template b/srcpkgs/removed-packages/template
index 8b9aa9d8bdff..ef53eba7a92e 100644
--- a/srcpkgs/removed-packages/template
+++ b/srcpkgs/removed-packages/template
@@ -67,6 +67,7 @@ replaces="
  epstopdf<=2.27_3
  fontmatrix<=0.6.0.20171228_2
  fuse-usmb<=20130204_7
+ gconf-editor<=3.0.1_3
  gegl3<=0.3.28_2
  gens-gs<=2.16.7_2
  geoip-data<=20171002_2

From 0599bca748f652208c4673e752823dd193cbe449 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 26 Nov 2021 12:16:56 +0700
Subject: [PATCH 060/288] gmpc: not require gnome-doc-utils for check

---
 srcpkgs/gmpc/patches/locale-dir.patch       | 20 +++++++++++++++++++
 srcpkgs/gmpc/patches/no-mallard-check.patch | 22 +++++++++++++++++++++
 srcpkgs/gmpc/template                       |  5 -----
 3 files changed, 42 insertions(+), 5 deletions(-)
 create mode 100644 srcpkgs/gmpc/patches/locale-dir.patch
 create mode 100644 srcpkgs/gmpc/patches/no-mallard-check.patch

diff --git a/srcpkgs/gmpc/patches/locale-dir.patch b/srcpkgs/gmpc/patches/locale-dir.patch
new file mode 100644
index 000000000000..8398823dd765
--- /dev/null
+++ b/srcpkgs/gmpc/patches/locale-dir.patch
@@ -0,0 +1,20 @@
+--- a/configure
++++ b/configure
+@@ -11347,7 +11347,7 @@ fi
+ 
+     ;;
+     *)
+-    DATADIRNAME=lib
++    DATADIRNAME=share
+     ;;
+     esac
+ fi
+@@ -15026,7 +15026,7 @@ fi
+ 	    ;;
+ 	    *)
+ 	    CATOBJEXT=.mo
+-            DATADIRNAME=lib
++            DATADIRNAME=share
+ 	    ;;
+ 	    esac
+ fi
diff --git a/srcpkgs/gmpc/patches/no-mallard-check.patch b/srcpkgs/gmpc/patches/no-mallard-check.patch
new file mode 100644
index 000000000000..f36891f28498
--- /dev/null
+++ b/srcpkgs/gmpc/patches/no-mallard-check.patch
@@ -0,0 +1,22 @@
+--- a/doc/Makefile.am
++++ b/doc/Makefile.am
+@@ -1,7 +1,7 @@
+ man_MANS = gmpc.1 gmpc-remote.1 gmpc-remote-stream.1
+ EXTRA_DIST = $(man_MANS)
+ 
+-SUBDIRS=Mallard
++SUBDIRS=
+ 
+ .PHONY: doc
+ doc: Manual.txt
+--- a/doc/Makefile.in
++++ b/doc/Makefile.in
+@@ -311,7 +311,7 @@ unique_CFLAGS = @unique_CFLAGS@
+ unique_LIBS = @unique_LIBS@
+ man_MANS = gmpc.1 gmpc-remote.1 gmpc-remote-stream.1
+ EXTRA_DIST = $(man_MANS)
+-SUBDIRS = Mallard
++SUBDIRS =
+ all: all-recursive
+ 
+ .SUFFIXES:
diff --git a/srcpkgs/gmpc/template b/srcpkgs/gmpc/template
index 9993e6c49dfa..ec0c03ade913 100644
--- a/srcpkgs/gmpc/template
+++ b/srcpkgs/gmpc/template
@@ -6,7 +6,6 @@ build_style=gnu-configure
 hostmakedepends="pkg-config gob2 intltool vala"
 makedepends="gtk+-devel libSM-devel libmpd-devel libunique1-devel libsoup-devel sqlite-devel"
 depends="xdg-utils hicolor-icon-theme"
-checkdepends="gnome-doc-utils"
 short_desc="Gnome Music Player Client - The true MPD client"
 maintainer="Dave Davenport <qball@gmpclient.org>"
 license="GPL-2.0-or-later"
@@ -16,10 +15,6 @@ checksum=a69414f35396846733632ca9619921d7acda537ffd6d49bd84b444945cb76b2c
 
 LDFLAGS="-lm"
 
-post_patch() {
-	vsed -i -e 's/DATADIRNAME=lib/DATADIRNAME=share/' configure
-}
-
 gmpc-devel_package() {
 	short_desc+=" - development files"
 	depends="gtk+-devel libmpd-devel"

From 1de2d26c405b1e3a474984fbd360fb76825f20f0 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 26 Nov 2021 13:03:18 +0700
Subject: [PATCH 061/288] gnac: disable old gnome-help format

---
 srcpkgs/gnac/patches/fix-debug-log.patch      | 29 +++++++++++++++++++
 srcpkgs/gnac/patches/no-gnome-doc-utils.patch | 20 +++++++++++++
 srcpkgs/gnac/patches/no-po-check.patch        |  7 +++++
 srcpkgs/gnac/template                         |  6 ++--
 4 files changed, 59 insertions(+), 3 deletions(-)
 create mode 100644 srcpkgs/gnac/patches/fix-debug-log.patch
 create mode 100644 srcpkgs/gnac/patches/no-gnome-doc-utils.patch
 create mode 100644 srcpkgs/gnac/patches/no-po-check.patch

diff --git a/srcpkgs/gnac/patches/fix-debug-log.patch b/srcpkgs/gnac/patches/fix-debug-log.patch
new file mode 100644
index 000000000000..88fd15de6a56
--- /dev/null
+++ b/srcpkgs/gnac/patches/fix-debug-log.patch
@@ -0,0 +1,29 @@
+--- a/libgnac/libgnac-debug.h
++++ b/libgnac/libgnac-debug.h
+@@ -32,7 +32,7 @@
+ 
+ #if defined(__STDC_VERSION__) && __STDC_VERSION__ >= 199901L
+ #define libgnac_debug(...) \
+-        libgnac_debug_real (__func__, __FILE__, __LINE__, TRUE, __VA_ARGS__)
++        libgnac_debug_real (__func__, __FILE__, __LINE__, __VA_ARGS__)
+ #elif defined(__GNUC__) && __GNUC__ >= 3
+ #define libgnac_debug(...) \
+         libgnac_debug_real (__FUNCTION__, __FILE__, __LINE__, __VA_ARGS__)
+@@ -42,7 +42,7 @@
+ 
+ #if defined(__STDC_VERSION__) && __STDC_VERSION__ >= 199901L
+ #define libgnac_warning(...) \
+-        libgnac_warning_real (__func__, __FILE__, __LINE__, TRUE, __VA_ARGS__)
++        libgnac_warning_real (__func__, __FILE__, __LINE__, __VA_ARGS__)
+ #elif defined(__GNUC__) && __GNUC__ >= 3
+ #define libgnac_warning(...) \
+         libgnac_warning_real (__FUNCTION__, __FILE__, __LINE__, __VA_ARGS__)
+@@ -52,7 +52,7 @@
+ 
+ #if defined(__STDC_VERSION__) && __STDC_VERSION__ >= 199901L
+ #define libgnac_critical(...) \
+-        libgnac_critical_real (__func__, __FILE__, __LINE__, TRUE, __VA_ARGS__)
++        libgnac_critical_real (__func__, __FILE__, __LINE__, __VA_ARGS__)
+ #elif defined(__GNUC__) && __GNUC__ >= 3
+ #define libgnac_critical(...) \
+         libgnac_critical_real (__FUNCTION__, __FILE__, __LINE__, __VA_ARGS__)
diff --git a/srcpkgs/gnac/patches/no-gnome-doc-utils.patch b/srcpkgs/gnac/patches/no-gnome-doc-utils.patch
new file mode 100644
index 000000000000..00f89a338dbc
--- /dev/null
+++ b/srcpkgs/gnac/patches/no-gnome-doc-utils.patch
@@ -0,0 +1,20 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -55,7 +55,7 @@ AM_GLIB_GNU_GETTEXT
+ dnl Check for GSettings macros
+ GLIB_GSETTINGS
+ 
+-GNOME_DOC_INIT([0.17.2])
++GNOME_DOC_INIT([0.17.2],[:],[:])
+ GNOME_DEBUG_CHECK
+ GNOME_COMPILE_WARNINGS([maximum])
+ GNOME_CXX_WARNINGS([yes])
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,6 +1,5 @@
+ SUBDIRS = \
+ 	data \
+-	help \
+ 	libgnac \
+ 	man \
+ 	po \
diff --git a/srcpkgs/gnac/patches/no-po-check.patch b/srcpkgs/gnac/patches/no-po-check.patch
new file mode 100644
index 000000000000..bf1ddb4a9e7d
--- /dev/null
+++ b/srcpkgs/gnac/patches/no-po-check.patch
@@ -0,0 +1,7 @@
+--- a/po/POTFILES.skip
++++ b/po/POTFILES.skip
+@@ -1,3 +1,4 @@
+ # List of source files that should NOT be translated.
+ # Please keep this file sorted alphabetically.
+ data/gnac.desktop.in
++intl/plural.c
diff --git a/srcpkgs/gnac/template b/srcpkgs/gnac/template
index ad01a1e97f91..9fea6a370e87 100644
--- a/srcpkgs/gnac/template
+++ b/srcpkgs/gnac/template
@@ -1,15 +1,15 @@
 # Template file for 'gnac'
 pkgname=gnac
 version=0.2.4.1
-revision=3
+revision=4
 build_style=gnu-configure
 configure_args="--disable-scrollkeeper --disable-schemas-compile"
 hostmakedepends="gnome-common gettext-devel pkg-config intltool libtool
- gnome-doc-utils glib-devel gtk+3-devel gst-plugins-base1-devel
+ glib-devel gtk+3-devel gst-plugins-base1-devel
  autoconf-archive which"
 makedepends="libxml2-devel gtk+3-devel gst-plugins-base1-devel libunique-devel
  libnotify-devel gst-plugins-good1 gst-plugins-bad1 gst-plugins-ugly1
- desktop-file-utils hicolor-icon-theme gnome-doc-utils"
+ desktop-file-utils hicolor-icon-theme"
 depends="gst-plugins-good1 gst-plugins-bad1 gst-plugins-ugly1
  desktop-file-utils hicolor-icon-theme"
 short_desc="Audio conversion program for the Gnome desktop"

From 60ebe5f2d7c7bcc316975921b24337c09cb1f158 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 26 Nov 2021 13:05:33 +0700
Subject: [PATCH 062/288] gnome-doc-utils: remove

---
 srcpkgs/gnome-doc-utils/patches/python3.patch | 521 ------------------
 srcpkgs/gnome-doc-utils/template              |  21 -
 srcpkgs/removed-packages/template             |   1 +
 3 files changed, 1 insertion(+), 542 deletions(-)
 delete mode 100644 srcpkgs/gnome-doc-utils/patches/python3.patch
 delete mode 100644 srcpkgs/gnome-doc-utils/template

diff --git a/srcpkgs/gnome-doc-utils/patches/python3.patch b/srcpkgs/gnome-doc-utils/patches/python3.patch
deleted file mode 100644
index 284e38e775de..000000000000
--- a/srcpkgs/gnome-doc-utils/patches/python3.patch
+++ /dev/null
@@ -1,521 +0,0 @@
-taken from fedora, alpine, gentoo
-diff -U3 -r gnome-doc-utils-0.20.10.orig/xml2po/xml2po/__init__.py gnome-doc-utils-0.20.10/xml2po/xml2po/__init__.py
---- gnome-doc-utils-0.20.10.orig/xml2po/xml2po/__init__.py	2011-08-04 09:36:03.000000000 -0500
-+++ gnome-doc-utils-0.20.10/xml2po/xml2po/__init__.py	2019-09-10 09:30:28.018627919 -0500
-@@ -86,14 +86,14 @@
-                 self.messages.append(t)
-                 if spacepreserve:
-                     self.nowrap[t] = True
--                if t in self.linenos.keys():
-+                if t in list(self.linenos.keys()):
-                     self.linenos[t].append((self.filename, tag, lineno))
-                 else:
-                     self.linenos[t] = [ (self.filename, tag, lineno) ]
-                 if (not self.do_translations) and comment and not t in self.comments:
-                     self.comments[t] = comment
-             else:
--                if t in self.linenos.keys():
-+                if t in list(self.linenos.keys()):
-                     self.linenos[t].append((self.filename, tag, lineno))
-                 else:
-                     self.linenos[t] = [ (self.filename, tag, lineno) ]
-@@ -166,7 +166,7 @@
-         elif node.isText():
-             if node.isBlankNode():
-                 if self.app.options.get('expand_entities') or \
--                  (not (node.prev and not node.prev.isBlankNode() and node.next and not node.next.isBlankNode()) ):
-+                  (not (node.prev and not node.prev.isBlankNode() and node.__next__ and not node.next.isBlankNode()) ):
-                     #print >>sys.stderr, "BLANK"
-                     node.setContent('')
-             else:
-@@ -176,7 +176,7 @@
-             child = node.children
-             while child:
-                 self.normalizeNode(child)
--                child = child.next
-+                child = child.__next__
- 
-     def normalizeString(self, text, spacepreserve = False):
-         """Normalizes string to be used as key for gettext lookup.
-@@ -200,7 +200,7 @@
-             tree = ctxt.doc()
-             newnode = tree.getRootElement()
-         except:
--            print >> sys.stderr, """Error while normalizing string as XML:\n"%s"\n""" % (text)
-+            print("""Error while normalizing string as XML:\n"%s"\n""" % (text), file=sys.stderr)
-             return text
- 
-         self.normalizeNode(newnode)
-@@ -209,7 +209,7 @@
-         child = newnode.children
-         while child:
-             result += child.serialize('utf-8')
--            child = child.next
-+            child = child.__next__
- 
-         result = re.sub('^ ','', result)
-         result = re.sub(' $','', result)
-@@ -235,7 +235,7 @@
-         ctxt.parseDocument()
-         tree = ctxt.doc()
-         if next:
--            newnode = tree.children.next
-+            newnode = tree.children.__next__
-         else:
-             newnode = tree.children
- 
-@@ -243,7 +243,7 @@
-         child = newnode.children
-         while child:
-             result += child.serialize('utf-8')
--            child = child.next
-+            child = child.__next__
-         tree.freeDoc()
-         return result
- 
-@@ -262,7 +262,7 @@
-                         result += child.content.decode('utf-8')
-                 else:
-                     result += self.myAttributeSerialize(child)
--                child = child.next
-+                child = child.__next__
-         else:
-             result = node.serialize('utf-8')
-         return result
-@@ -338,7 +338,7 @@
-                 pass
- 
-             if not newnode:
--                print >> sys.stderr, """Error while parsing translation as XML:\n"%s"\n""" % (text.encode('utf-8'))
-+                print("""Error while parsing translation as XML:\n"%s"\n""" % (text.encode('utf-8')), file=sys.stderr)
-                 return
- 
-             newelem = newnode.getRootElement()
-@@ -346,13 +346,13 @@
-             if newelem and newelem.children:
-                 free = node.children
-                 while free:
--                    next = free.next
-+                    next = free.__next__
-                     free.unlinkNode()
-                     free = next
- 
-                 if node:
-                     copy = newelem.copyNodeList()
--                    next = node.next
-+                    next = node.__next__
-                     node.replaceNode(newelem.copyNodeList())
-                     node.next = next
- 
-@@ -378,7 +378,7 @@
-             if child.type in ['text'] and  child.content.strip()!='':
-                 final = True
-                 break
--            child = child.next
-+            child = child.__next__
- 
-         node.__autofinal__ = final
-         return final
-@@ -457,7 +457,7 @@
-                     outtxt += '<%s>%s</%s>' % (starttag, content, endtag)
-                 else:
-                     outtxt += self.doSerialize(child)
--            child = child.next
-+            child = child.__next__
- 
-         if self.app.operation == 'merge':
-             norm_outtxt = self.normalizeString(outtxt, self.app.isSpacePreserveNode(node))
-@@ -534,7 +534,7 @@
-             outtxt = ''
-             while child:
-                 outtxt += self.doSerialize(child)
--                child = child.next
-+                child = child.__next__
-             return outtxt
- 
- def xml_error_handler(arg, ctxt):
-@@ -577,8 +577,8 @@
-                 raise IOError("Unable to read file '%s'" % xmlfile)
-             try:
-                 doc = XMLDocument(xmlfile, self)
--            except Exception, e:
--                print >> sys.stderr, "Unable to parse XML file '%s': %s" % (xmlfile, str(e))
-+            except Exception as e:
-+                print("Unable to parse XML file '%s': %s" % (xmlfile, str(e)), file=sys.stderr)
-                 sys.exit(1)
-             self.current_mode.preProcessXml(doc.doc, self.msg)
-             doc.generate_messages()
-@@ -590,14 +590,14 @@
-             raise IOError("Unable to read file '%s'" % xmlfile)
-         try:
-             doc = XMLDocument(xmlfile, self)
--        except Exception, e:
--            print >> sys.stderr, str(e)
-+        except Exception as e:
-+            print(str(e), file=sys.stderr)
-             sys.exit(1)
- 
-         try:
-             mfile = open(mofile, "rb")
-         except:
--            print >> sys.stderr, "Can't open MO file '%s'." % (mofile)
-+            print("Can't open MO file '%s'." % (mofile), file=sys.stderr)
-         self.gt = gettext.GNUTranslations(mfile)
-         self.gt.add_fallback(NoneTranslations())
-         # Has preProcessXml use cases for merge?
-@@ -619,16 +619,16 @@
-             raise IOError("Unable to read file '%s'" % xmlfile)
-         try:
-             doc = XMLDocument(xmlfile, self)
--        except Exception, e:
--            print >> sys.stderr, str(e)
-+        except Exception as e:
-+            print(str(e), file=sys.stderr)
-             sys.exit(1)
-         doc.generate_messages()
- 
-         self.msg.translationsFollow()
-         try:
-             doc = XMLDocument(origxml, self)
--        except Exception, e:
--            print >> sys.stderr, str(e)
-+        except Exception as e:
-+            print(str(e), file=sys.stderr)
-             sys.exit(1)
-         doc.generate_messages()
-         self.output_po()
-diff -U3 -r gnome-doc-utils-0.20.10.orig/xml2po/xml2po/modes/docbook.py gnome-doc-utils-0.20.10/xml2po/xml2po/modes/docbook.py
---- gnome-doc-utils-0.20.10.orig/xml2po/xml2po/modes/docbook.py	2011-01-10 10:08:10.000000000 -0600
-+++ gnome-doc-utils-0.20.10/xml2po/xml2po/modes/docbook.py	2019-09-10 09:31:15.199572286 -0500
-@@ -43,7 +43,7 @@
- except ImportError:
-     from md5 import new as md5_new
- 
--from basic import basicXmlMode
-+from .basic import basicXmlMode
- 
- class docbookXmlMode(basicXmlMode):
-     """Class for special handling of DocBook document types.
-@@ -131,7 +131,7 @@
-                     hash = self._md5_for_file(fullpath)
-                 else:
-                     hash = "THIS FILE DOESN'T EXIST"
--                    print >>sys.stderr, "Warning: image file '%s' not found." % fullpath
-+                    print("Warning: image file '%s' not found." % fullpath, file=sys.stderr)
- 
-                 msg.outputMessage("@@image: '%s'; md5=%s" % (attr, hash), node.lineNo(),
-                                   "When image changes, this message will be marked fuzzy or untranslated for you.\n"+
-@@ -198,10 +198,10 @@
- # Perform some tests when ran standalone
- if __name__ == '__main__':
-     test = docbookXmlMode()
--    print "Ignored tags       : " + repr(test.getIgnoredTags())
--    print "Final tags         : " + repr(test.getFinalTags())
--    print "Space-preserve tags: " + repr(test.getSpacePreserveTags())
-+    print("Ignored tags       : " + repr(test.getIgnoredTags()))
-+    print("Final tags         : " + repr(test.getFinalTags()))
-+    print("Space-preserve tags: " + repr(test.getSpacePreserveTags()))
- 
--    print "Credits from string: '%s'" % test.getStringForTranslators()
--    print "Explanation for credits:\n\t'%s'" % test.getCommentForTranslators()
-+    print("Credits from string: '%s'" % test.getStringForTranslators())
-+    print("Explanation for credits:\n\t'%s'" % test.getCommentForTranslators())
- 
-diff -U3 -r gnome-doc-utils-0.20.10.orig/xml2po/xml2po/modes/gs.py gnome-doc-utils-0.20.10/xml2po/xml2po/modes/gs.py
---- gnome-doc-utils-0.20.10.orig/xml2po/xml2po/modes/gs.py	2010-12-13 10:14:07.000000000 -0600
-+++ gnome-doc-utils-0.20.10/xml2po/xml2po/modes/gs.py	2019-09-10 09:31:15.201572284 -0500
-@@ -20,7 +20,7 @@
- # Special case Gnome Summary
- #
- 
--from basic import basicXmlMode
-+from .basic import basicXmlMode
- 
- class gsXmlMode(basicXmlMode):
-     """Abstract class for special handling of document types."""
-diff -U3 -r gnome-doc-utils-0.20.10.orig/xml2po/xml2po/modes/mallard.py gnome-doc-utils-0.20.10/xml2po/xml2po/modes/mallard.py
---- gnome-doc-utils-0.20.10.orig/xml2po/xml2po/modes/mallard.py	2011-01-10 10:08:50.000000000 -0600
-+++ gnome-doc-utils-0.20.10/xml2po/xml2po/modes/mallard.py	2019-09-10 09:31:15.212572271 -0500
-@@ -39,7 +39,7 @@
- except ImportError:
-     from md5 import new as md5_new
- 
--from basic import basicXmlMode
-+from .basic import basicXmlMode
- 
- class mallardXmlMode(basicXmlMode):
-     """Class for special handling of Mallard document types."""
-@@ -112,7 +112,7 @@
-                     hash = self._md5_for_file(fullpath)
-                 else:
-                     hash = "THIS FILE DOESN'T EXIST"
--                    print >>sys.stderr, "Warning: image file '%s' not found." % fullpath
-+                    print("Warning: image file '%s' not found." % fullpath, file=sys.stderr)
-                     
-                 msg.outputMessage("@@image: '%s'; md5=%s" % (attr, hash), node.lineNo(),
-                                   "When image changes, this message will be marked fuzzy or untranslated for you.\n"+
-diff -U3 -r gnome-doc-utils-0.20.10.orig/xml2po/xml2po/modes/ubuntu.py gnome-doc-utils-0.20.10/xml2po/xml2po/modes/ubuntu.py
---- gnome-doc-utils-0.20.10.orig/xml2po/xml2po/modes/ubuntu.py	2010-12-13 10:14:07.000000000 -0600
-+++ gnome-doc-utils-0.20.10/xml2po/xml2po/modes/ubuntu.py	2019-09-10 09:31:15.213572270 -0500
-@@ -2,7 +2,7 @@
- 
- import libxml2
- 
--from docbook import docbookXmlMode
-+from .docbook import docbookXmlMode
- 
- class ubuntuXmlMode (docbookXmlMode):
-     """Special-casing Ubuntu DocBook website documentation."""
-diff -U3 -r gnome-doc-utils-0.20.10.orig/xml2po/xml2po/modes/xhtml.py gnome-doc-utils-0.20.10/xml2po/xml2po/modes/xhtml.py
---- gnome-doc-utils-0.20.10.orig/xml2po/xml2po/modes/xhtml.py	2010-12-13 10:14:07.000000000 -0600
-+++ gnome-doc-utils-0.20.10/xml2po/xml2po/modes/xhtml.py	2019-09-10 09:31:15.214572269 -0500
-@@ -21,7 +21,7 @@
- # This implements special instructions for handling XHTML documents
- # in a better way, particularly to extract some attributes in HTML tags
- 
--from basic import basicXmlMode
-+from .basic import basicXmlMode
- 
- class xhtmlXmlMode(basicXmlMode):
-     """Class for special handling of XHTML document types."""
-diff -U3 -r gnome-doc-utils-0.20.10.orig/xml2po/xml2po/xml2po.py.in gnome-doc-utils-0.20.10/xml2po/xml2po/xml2po.py.in
---- gnome-doc-utils-0.20.10.orig/xml2po/xml2po/xml2po.py.in	2010-12-13 10:14:07.000000000 -0600
-+++ gnome-doc-utils-0.20.10/xml2po/xml2po/xml2po.py.in	2019-09-10 09:30:28.217627684 -0500
-@@ -41,9 +41,9 @@
- if not os.path.exists('/dev/null'): NULL_STRING = 'NUL'
- 
- def usage (with_help = False):
--    print >> sys.stderr, "Usage:  %s [OPTIONS] [XMLFILE]..." % (sys.argv[0])
-+    print("Usage:  %s [OPTIONS] [XMLFILE]..." % (sys.argv[0]), file=sys.stderr)
-     if with_help:
--        print >> sys.stderr, """
-+        print("""
- OPTIONS may be some of:
-     -a    --automatic-tags     Automatically decides if tags are to be considered
-                                  "final" or not
-@@ -72,7 +72,7 @@
-     using -p option for each XML file:
-         %(command)s -p de.po chapter1.xml > chapter1.de.xml
-         %(command)s -p de.po chapter2.xml > chapter2.de.xml
--""" % {'command': sys.argv[0]}
-+""" % {'command': sys.argv[0]}, file=sys.stderr)
- 
- 
- def main(argv):
-@@ -82,7 +82,7 @@
- 
-     name = os.path.join(os.path.dirname(__file__), '..')
-     if os.path.exists(os.path.join(name, 'tests')):
--        print >> sys.stderr, 'Running from source folder, modifying PYTHONPATH'
-+        print('Running from source folder, modifying PYTHONPATH', file=sys.stderr)
-         sys.path.insert(0, name)
- 
-     from xml2po import Main
-@@ -142,14 +142,14 @@
-         elif opt in ('-o', '--output'):
-             output = arg
-         elif opt in ('-v', '--version'):
--            print VERSION
-+            print(VERSION)
-             sys.exit(0)
-         elif opt in ('-h', '--help'):
-             usage(True)
-             sys.exit(0)
- 
-     if operation == 'update' and output != "-":
--        print >> sys.stderr, "Option '-o' is not yet supported when updating translations directly. Ignoring this option."
-+        print("Option '-o' is not yet supported when updating translations directly. Ignoring this option.", file=sys.stderr)
- 
-     # Treat remaining arguments as XML files
-     filenames = []
-@@ -159,16 +159,16 @@
-     try:
-         xml2po_main = Main(default_mode, operation, output, options)
-     except IOError:
--        print >> sys.stderr, "Error: cannot open file %s for writing." % (output)
-+        print("Error: cannot open file %s for writing." % (output), file=sys.stderr)
-         sys.exit(5)
- 
-     if operation == 'merge':
-         if len(filenames) > 1:
--            print  >> sys.stderr, "Error: You can merge translations with only one XML file at a time."
-+            print("Error: You can merge translations with only one XML file at a time.", file=sys.stderr)
-             sys.exit(2)
- 
-         if not mofile:
--            print >> sys.stderr, "Error: You must specify MO file when merging translations."
-+            print("Error: You must specify MO file when merging translations.", file=sys.stderr)
-             sys.exit(3)
- 
-         xml2po_main.merge(mofile, filenames[0])
---- gnome-doc-utils-0.20.10/xml2po/xml2po/__init__.py.orig	2019-09-10 09:34:42.110328324 -0500
-+++ gnome-doc-utils-0.20.10/xml2po/xml2po/__init__.py	2019-09-10 09:34:44.170325899 -0500
-@@ -166,7 +166,7 @@
-         elif node.isText():
-             if node.isBlankNode():
-                 if self.app.options.get('expand_entities') or \
--                  (not (node.prev and not node.prev.isBlankNode() and node.__next__ and not node.next.isBlankNode()) ):
-+                  (not (node.prev and not node.prev.isBlankNode() and node.next and not node.next.isBlankNode()) ):
-                     #print >>sys.stderr, "BLANK"
-                     node.setContent('')
-             else:
-@@ -176,7 +176,7 @@
-             child = node.children
-             while child:
-                 self.normalizeNode(child)
--                child = child.__next__
-+                child = child.next
- 
-     def normalizeString(self, text, spacepreserve = False):
-         """Normalizes string to be used as key for gettext lookup.
-@@ -209,7 +209,7 @@
-         child = newnode.children
-         while child:
-             result += child.serialize('utf-8')
--            child = child.__next__
-+            child = child.next
- 
-         result = re.sub('^ ','', result)
-         result = re.sub(' $','', result)
-@@ -235,7 +235,7 @@
-         ctxt.parseDocument()
-         tree = ctxt.doc()
-         if next:
--            newnode = tree.children.__next__
-+            newnode = tree.children.next
-         else:
-             newnode = tree.children
- 
-@@ -243,7 +243,7 @@
-         child = newnode.children
-         while child:
-             result += child.serialize('utf-8')
--            child = child.__next__
-+            child = child.next
-         tree.freeDoc()
-         return result
- 
-@@ -262,7 +262,7 @@
-                         result += child.content.decode('utf-8')
-                 else:
-                     result += self.myAttributeSerialize(child)
--                child = child.__next__
-+                child = child.next
-         else:
-             result = node.serialize('utf-8')
-         return result
-@@ -346,13 +346,13 @@
-             if newelem and newelem.children:
-                 free = node.children
-                 while free:
--                    next = free.__next__
-+                    next = free.next
-                     free.unlinkNode()
-                     free = next
- 
-                 if node:
-                     copy = newelem.copyNodeList()
--                    next = node.__next__
-+                    next = node.next
-                     node.replaceNode(newelem.copyNodeList())
-                     node.next = next
- 
-@@ -378,7 +378,7 @@
-             if child.type in ['text'] and  child.content.strip()!='':
-                 final = True
-                 break
--            child = child.__next__
-+            child = child.next
- 
-         node.__autofinal__ = final
-         return final
-@@ -457,7 +457,7 @@
-                     outtxt += '<%s>%s</%s>' % (starttag, content, endtag)
-                 else:
-                     outtxt += self.doSerialize(child)
--            child = child.__next__
-+            child = child.next
- 
-         if self.app.operation == 'merge':
-             norm_outtxt = self.normalizeString(outtxt, self.app.isSpacePreserveNode(node))
-@@ -534,7 +534,7 @@
-             outtxt = ''
-             while child:
-                 outtxt += self.doSerialize(child)
--                child = child.__next__
-+                child = child.next
-             return outtxt
- 
- def xml_error_handler(arg, ctxt):
---- gnome-doc-utils-0.20.10/xml2po/xml2po/__init__.py.orig	2019-09-10 09:39:57.733974912 -0500
-+++ gnome-doc-utils-0.20.10/xml2po/xml2po/__init__.py	2019-09-10 09:40:24.761946962 -0500
-@@ -326,7 +326,7 @@
-                 pass
- 
-             content = '<%s>%s</%s>' % (starttag, text, endtag)
--            tmp = tmp + content.encode('utf-8')
-+            tmp = tmp + content
- 
-             newnode = None
-             try:
-@@ -663,7 +663,7 @@
-         if not text or text.strip() == '':
-             return text
-         if self.gt:
--            res = self.gt.ugettext(text.decode('utf-8'))
-+            res = self.gt.gettext(text)
-             return res
- 
-         return text
---- gnome-doc-utils-0.20.10/xml2po/xml2po/__init__.py.orig	2019-09-10 09:41:23.853885851 -0500
-+++ gnome-doc-utils-0.20.10/xml2po/xml2po/__init__.py	2019-09-10 09:44:23.580699979 -0500
-@@ -352,9 +352,10 @@
- 
-                 if node:
-                     copy = newelem.copyNodeList()
--                    next = node.next
-+                    #next = node.next
-                     node.replaceNode(newelem.copyNodeList())
--                    node.next = next
-+                    #print(type(next))
-+                    #node.next = next
- 
-             else:
-                 # In practice, this happens with tags such as "<para>    </para>" (only whitespace in between)
-@@ -470,7 +471,7 @@
- 
-         worth = self.worthOutputting(node)
-         if not translation:
--            translation = outtxt.decode('utf-8')
-+            translation = outtxt
-             if worth and self.app.options.get('mark_untranslated'):
-                 node.setLang('C')
- 
---- gnome-doc-utils-0.20.10/xml2po/xml2po/modes/docbook.py.orig	2019-09-10 09:46:15.409584334 -0500
-+++ gnome-doc-utils-0.20.10/xml2po/xml2po/modes/docbook.py	2019-09-10 09:46:30.164569075 -0500
-@@ -184,7 +184,7 @@
-                     else:
-                         ai.addChild(copy)
-                     if match.group(3):
--                        copy.newChild(None, "year", match.group(3).encode('utf-8'))
-+                        copy.newChild(None, "year", match.group(3))
-                     if match.group(1) and match.group(2):
-                         holder = match.group(1)+"(%s)" % match.group(2)
-                     elif match.group(1):
-@@ -193,7 +193,7 @@
-                         holder = match.group(2)
-                     else:
-                         holder = "???"
--                    copy.newChild(None, "holder", holder.encode('utf-8'))
-+                    copy.newChild(None, "holder", holder)
- 
- # Perform some tests when ran standalone
- if __name__ == '__main__':
---- gnome-doc-utils-0.20.10/xml2po/xml2po/xml2po.py.in~	2019-09-10 09:50:34.000000000 -0500
-+++ gnome-doc-utils-0.20.10/xml2po/xml2po/xml2po.py.in	2019-09-10 09:50:45.114305443 -0500
-@@ -1,4 +1,4 @@
--#!/usr/bin/python -u
-+#!/usr/bin/python3 -u
- # -*- encoding: utf-8 -*-
- # Copyright (c) 2004, 2005, 2006 Danilo Šegan <danilo@gnome.org>.
- # Copyright (c) 2009 Claude Paroz <claude@2xlibre.net>.
diff --git a/srcpkgs/gnome-doc-utils/template b/srcpkgs/gnome-doc-utils/template
deleted file mode 100644
index f63c6106f6c1..000000000000
--- a/srcpkgs/gnome-doc-utils/template
+++ /dev/null
@@ -1,21 +0,0 @@
-# Template file for 'gnome-doc-utils'
-pkgname=gnome-doc-utils
-version=0.20.10
-revision=9
-build_style=gnu-configure
-configure_args="--disable-scrollkeeper"
-hostmakedepends="pkg-config intltool python3 libxml2-python3 libxslt
- gsettings-desktop-schemas"
-makedepends="libxslt-devel docbook-xml docbook-xsl rarian python3
- libxml2-python3 libxslt"
-depends="libxslt docbook-xml docbook-xsl rarian python3 libxml2-python3"
-short_desc="Documentation utilities for GNOME"
-maintainer="Orphaned <orphan@voidlinux.org>"
-license="GPL-2.0-or-later, LGPL-2.1-or-later"
-homepage="https://wiki.gnome.org/Projects/GnomeDocUtils"
-distfiles="${GNOME_SITE}/${pkgname}/0.20/${pkgname}-${version}.tar.xz"
-checksum=cb0639ffa9550b6ddf3b62f3b1add92fb92ab4690d351f2353cffe668be8c4a6
-
-post_patch() {
-	vsed -i -e 's/DATADIRNAME=lib/DATADIRNAME=share/' configure
-}
diff --git a/srcpkgs/removed-packages/template b/srcpkgs/removed-packages/template
index ef53eba7a92e..2b16ae44131f 100644
--- a/srcpkgs/removed-packages/template
+++ b/srcpkgs/removed-packages/template
@@ -74,6 +74,7 @@ replaces="
  gespeaker<=0.8.6_3
  gksu<=2.0.2_4
  glibmm-doc<=2.64.2_2
+ gnome-doc-utils<=0.20.10_9
  gnome-getting-started-docs<=3.38.1_1
  gnome-shell-mousewheel-zoom<=0.8.0_2
  gnome-twitch<=0.4.2_1

From ceabf18a0470573f7f1d1633b10b854d9e949cfb Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Wed, 1 Dec 2021 15:04:30 +0100
Subject: [PATCH 063/288] linux5.15: update to 5.15.6.

---
 srcpkgs/linux5.15/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/linux5.15/template b/srcpkgs/linux5.15/template
index 02de9dab5756..484f473b5ba8 100644
--- a/srcpkgs/linux5.15/template
+++ b/srcpkgs/linux5.15/template
@@ -1,6 +1,6 @@
 # Template file for 'linux5.15'
 pkgname=linux5.15
-version=5.15.5
+version=5.15.6
 revision=1
 wrksrc="linux-${version%.*}"
 short_desc="Linux kernel and modules (${version%.*} series)"
@@ -10,7 +10,7 @@ homepage="https://www.kernel.org"
 distfiles="https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-${version%.*}.tar.xz
  https://cdn.kernel.org/pub/linux/kernel/v5.x/patch-${version}.xz"
 checksum="57b2cf6991910e3b67a1b3490022e8a0674b6965c74c12da1e99d138d1991ee8
- 8fdc0ef34a877379bcb9b617006edafba66f9213fc2c1df7451b578ae33b5496"
+ 23f5753121e2f18ef757449f94728d18ba70a20728dd217a53d4fa0a1cde621e"
 skip_extraction="patch-${version}.xz"
 python_version=3
 

From 124ec8ae570de4a57e2efa84d71e4ccd7cb68200 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Wed, 1 Dec 2021 15:05:25 +0100
Subject: [PATCH 064/288] linux5.10: update to 5.10.83.

---
 srcpkgs/linux5.10/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/linux5.10/template b/srcpkgs/linux5.10/template
index 295165a43440..422c10d16ba8 100644
--- a/srcpkgs/linux5.10/template
+++ b/srcpkgs/linux5.10/template
@@ -1,6 +1,6 @@
 # Template file for 'linux5.10'
 pkgname=linux5.10
-version=5.10.82
+version=5.10.83
 revision=1
 wrksrc="linux-${version}"
 short_desc="Linux kernel and modules (${version%.*} series)"
@@ -8,7 +8,7 @@ maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="GPL-2.0-only"
 homepage="https://www.kernel.org"
 distfiles="https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-${version}.tar.xz"
-checksum=d66f7c7eed02f84ae550b3c91a26c70eea13682a6d672432f07bce66ff8ce350
+checksum=ef259a43f33ddb56001283f4f4e50af29b8a48fa066aed7371a90ebf38c29b70
 python_version=3
 
 # XXX Restrict archs until a proper <arch>-dotconfig is available in FILESDIR.

From a4a366a2ee8a00de148d208657b14f11e7703c97 Mon Sep 17 00:00:00 2001
From: Duncaen <duncaen@voidlinux.org>
Date: Wed, 1 Dec 2021 17:25:33 +0100
Subject: [PATCH 065/288] yt-dlp: add missing python3 dependency

---
 srcpkgs/yt-dlp/template | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/srcpkgs/yt-dlp/template b/srcpkgs/yt-dlp/template
index b142e21ddba6..9432641a5e73 100644
--- a/srcpkgs/yt-dlp/template
+++ b/srcpkgs/yt-dlp/template
@@ -1,11 +1,12 @@
 # Template file for 'yt-dlp'
 pkgname=yt-dlp
 version=2021.11.10.1
-revision=1
+revision=2
 wrksrc="$pkgname"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 checkdepends="python3-pytest flake8 python3-nose"
+depends="python3"
 short_desc="CLI program to download videos from YouTube and other sites"
 maintainer="Michal Vasilek <michal@vasilek.cz>"
 license="Unlicense"

From 6b7fe7f7c6fc34fe2824090108aea4c83e20f870 Mon Sep 17 00:00:00 2001
From: mobinmob <mobinmob@disroot.org>
Date: Tue, 30 Nov 2021 19:36:35 +0100
Subject: [PATCH 066/288] skype: update to 8.79.0.92.

---
 srcpkgs/skype/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/skype/template b/srcpkgs/skype/template
index a09223ab1b54..c018a5e5031d 100644
--- a/srcpkgs/skype/template
+++ b/srcpkgs/skype/template
@@ -1,7 +1,7 @@
 # Template file for 'skype'
 # This just repackages the rpm package.
 pkgname=skype
-version=8.78.0.161
+version=8.79.0.92
 revision=1
 archs="x86_64"
 create_wrksrc=yes
@@ -12,7 +12,7 @@ maintainer="mobinmob <mobinmob@disroot.org>"
 license="custom:skype-servicesagreement" # no vlicense
 homepage="https://www.skype.com"
 distfiles="https://repo.skype.com/rpm/stable/skypeforlinux_${version}-1.x86_64.rpm"
-checksum=db6a9aafa028c16f2f789e3d496adb465f1b6476f88c384752d95130d6af72a1
+checksum=93b3cfd8fc403fb7b4707579a2f4b068ed7077c257179b7b401612d60b41c8f7
 repository="nonfree"
 nostrip="yes"
 

From 99a62f55b16051b1b7ffa3490f7161e467a381d8 Mon Sep 17 00:00:00 2001
From: Andrew Benson <abenson+void@gmail.com>
Date: Wed, 1 Dec 2021 15:26:38 -0600
Subject: [PATCH 067/288] wgetpaste: update to 2.32.

---
 srcpkgs/wgetpaste/template | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/wgetpaste/template b/srcpkgs/wgetpaste/template
index 1688736a76b4..c91532415d78 100644
--- a/srcpkgs/wgetpaste/template
+++ b/srcpkgs/wgetpaste/template
@@ -1,17 +1,18 @@
 # Template file for 'wgetpaste'
 pkgname=wgetpaste
-version=2.30
+version=2.32
 revision=1
 depends="bash wget"
 short_desc="Script that automates pasting to a number of pastebin services"
 maintainer="Orphaned <orphan@voidlinux.org>"
-license="Public Domain"
+license="MIT"
 homepage="http://wgetpaste.zlin.dk/"
-distfiles="http://wgetpaste.zlin.dk/${pkgname}-${version}.tar.bz2"
-checksum=e3ec35f1ff49f2204864e3b4d784f6c032cdddb62cadf69263900c67a4896592
+distfiles="https://github.com/zlin/wgetpaste/releases/download/${version}/wgetpaste-${version}.tar.xz"
+checksum=621dbafbc7bcf5438f11447a325d8974069e3df03ef0c8bb2a2cc3de2c0cdb13
 
 do_install() {
 	vbin ${pkgname}
 	vinstall _${pkgname} 644 usr/share/zsh/site-functions
 	vsconf ${FILESDIR}/${pkgname}.example
+	vlicense LICENSE
 }

From 07ff238a3e080d2f452d2ef913b6796acb5aa42e Mon Sep 17 00:00:00 2001
From: Omar Zeghouani <omarzeghouanii@gmail.com>
Date: Wed, 1 Dec 2021 23:07:30 +0000
Subject: [PATCH 068/288] i3status-rust: update to 0.20.7.

---
 srcpkgs/i3status-rust/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/i3status-rust/template b/srcpkgs/i3status-rust/template
index 36178f3938bc..d58ecb206a22 100644
--- a/srcpkgs/i3status-rust/template
+++ b/srcpkgs/i3status-rust/template
@@ -1,6 +1,6 @@
 # Template file for 'i3status-rust'
 pkgname=i3status-rust
-version=0.20.6
+version=0.20.7
 revision=1
 build_style=cargo
 make_check_args="--bins"
@@ -12,7 +12,7 @@ license="GPL-3.0-only"
 homepage="https://github.com/greshake/i3status-rust"
 changelog="https://raw.githubusercontent.com/greshake/i3status-rust/master/NEWS.md"
 distfiles="https://github.com/greshake/i3status-rust/archive/v${version}.tar.gz"
-checksum=a8b1257b09b73add3969c8bff2a4c77142164449ae3fea37a050ee95cc138b95
+checksum=995efe21ecf03e532cff9140cab1d4de9a35f91204d9e9edf0bfe3a22fedf5a0
 
 post_install() {
 	vmkdir usr/share/i3status-rust

From 4d659b0b363205f62db458de19e9eb83516f249b Mon Sep 17 00:00:00 2001
From: bugcrazy <39757967+bugcrazy@users.noreply.github.com>
Date: Wed, 1 Dec 2021 14:46:40 -0300
Subject: [PATCH 069/288] oil: update to 0.9.5

---
 srcpkgs/oil/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/oil/template b/srcpkgs/oil/template
index af1eb57e8d1c..9af2cc8e5435 100644
--- a/srcpkgs/oil/template
+++ b/srcpkgs/oil/template
@@ -1,6 +1,6 @@
 # Template file for 'oil'
 pkgname=oil
-version=0.9.4
+version=0.9.5
 revision=1
 build_style=configure
 configure_args="--prefix=/usr $(vopt_with readline)"
@@ -11,7 +11,7 @@ maintainer="MarcoAPC <marcoaureliopc@gmail.com>"
 license="Apache-2.0"
 homepage="https://www.oilshell.org"
 distfiles="${homepage}/download/${pkgname}-${version}.tar.xz"
-checksum=fac61bcd6b68c0bbf2e386aa84b107f26518527d4326bf473a02aadd85e53d02
+checksum=d89d8c081c8bc536dfc7b437b965a265c07e24cf5142ff26b21b4cc4a3139e32
 register_shell="/usr/bin/osh"
 nocross="Build systems gets confused with host and cross toolchains/headers"
 nostrip=yes

From 2423b3cd1c088e97c365a3b6d03549ff562cb13a Mon Sep 17 00:00:00 2001
From: Anton Afanasyev <1157248+2asoft@users.noreply.github.com>
Date: Tue, 30 Nov 2021 23:34:20 -0800
Subject: [PATCH 070/288] intellij-idea-ultimate-edition: update to 2021.3.

---
 srcpkgs/intellij-idea-ultimate-edition/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/intellij-idea-ultimate-edition/template b/srcpkgs/intellij-idea-ultimate-edition/template
index e3b32fea16d8..20f99d94125f 100644
--- a/srcpkgs/intellij-idea-ultimate-edition/template
+++ b/srcpkgs/intellij-idea-ultimate-edition/template
@@ -1,6 +1,6 @@
 # Template file for 'intellij-idea-ultimate-edition'
 pkgname=intellij-idea-ultimate-edition
-version=2021.2.3
+version=2021.3
 revision=1
 archs="i686 x86_64"
 create_wrksrc="true"
@@ -11,7 +11,7 @@ license="custom:Commercial"
 homepage="https://www.jetbrains.com/idea"
 _filename="ideaIU-${version}-no-jbr.tar.gz"
 distfiles="https://download.jetbrains.com/idea/${_filename}"
-checksum=0d879d4b16f096b81f401e0ab76a8b565d8142c632f9667cdb7fe5e6bd9813b4
+checksum=0b46ebb2381bd587bbec9d15ff78f11380bcf2654c0716c0caf747550ee73c66
 repository=nonfree
 restricted=yes
 nopie=yes

From 0f42b24eacc375444a8576e3a352d14a397874bd Mon Sep 17 00:00:00 2001
From: Anton Afanasyev <1157248+2asoft@users.noreply.github.com>
Date: Tue, 30 Nov 2021 23:28:45 -0800
Subject: [PATCH 071/288] jetbrains-jdk-bin: update to 11.0.13b1504.49.

---
 srcpkgs/jetbrains-jdk-bin/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/jetbrains-jdk-bin/template b/srcpkgs/jetbrains-jdk-bin/template
index 7114636c6562..f6b26790ad82 100644
--- a/srcpkgs/jetbrains-jdk-bin/template
+++ b/srcpkgs/jetbrains-jdk-bin/template
@@ -1,6 +1,6 @@
 # Template file for 'jetbrains-jdk-bin'
 pkgname=jetbrains-jdk-bin
-version=11.0.12b1504.40
+version=11.0.13b1504.49
 revision=1
 archs="x86_64"
 wrksrc="jbr"
@@ -11,7 +11,7 @@ homepage="https://github.com/JetBrains/JetBrainsRuntime"
 _jdk_ver=${version%b*}
 _jdk_build=${version#*b}
 distfiles="https://cache-redirector.jetbrains.com/intellij-jbr/jbr_jcef-${_jdk_ver//\./_}-linux-x64-b${_jdk_build}.tar.gz"
-checksum=56646f634eafbe85d177e40267f52d83a4bbfcb2bd359b97282bca54812e0784
+checksum=6e84df3c86adc9ec8d63f1151ffbe2081b2c10eb04ff40e1cb86d04b20c5d36e
 # This JDK appears to link to libs that do not exist, but functions well even in their absence.
 # Best guess is that they are optional. ¯\_(ツ)_/¯
 noverifyrdeps=yes

From 101a5deeefba38e7dff80bbf2e65527457c0e85b Mon Sep 17 00:00:00 2001
From: Joel Beckmeyer <joel@beckmeyer.us>
Date: Tue, 30 Nov 2021 09:52:30 -0500
Subject: [PATCH 072/288] python3-frozendict: update to 2.1.1.

---
 srcpkgs/python3-frozendict/template | 15 +++------------
 1 file changed, 3 insertions(+), 12 deletions(-)

diff --git a/srcpkgs/python3-frozendict/template b/srcpkgs/python3-frozendict/template
index cb161120a342..f6e3b6661395 100644
--- a/srcpkgs/python3-frozendict/template
+++ b/srcpkgs/python3-frozendict/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-frozendict'
 pkgname=python3-frozendict
-version=2.1.0
+version=2.1.1
 revision=1
 wrksrc="frozendict-${version}"
 build_style=python3-module
@@ -12,17 +12,8 @@ maintainer="Joel Beckmeyer <joel@beckmeyer.us>"
 license="LGPL-3.0-only"
 homepage="https://github.com/Marco-Sulla/python-frozendict"
 distfiles="${PYPI_SITE}/f/frozendict/frozendict-${version}.tar.gz"
-checksum=0189168749ddea8601afd648146c502533f93ae33840eb76cd71f694742623cd
+checksum=655b879217dd445a2023e16154cc231febef802b5c812d5c2e822280ad69e1dc
 
 do_check() {
-	# skip tests that are failing when using C
-	# extension due to difference between pure py and
-	# C extension
-	PYTHONPATH="$(cd build/lib* && pwd)" pytest3 \
-	 --deselect=test/test_coold.py::test_repr \
-	 --deselect=test/test_coold.py::test_str \
-	 --deselect=test/test_coold.py::test_format \
-	 --deselect=test/test_frozendict_c.py::test_repr \
-	 --deselect=test/test_frozendict_c.py::test_str \
-	 --deselect=test/test_frozendict_c.py::test_format
+	PYTHONPATH="$(cd build/lib* && pwd)" pytest3
 }

From 3ffd22eea1ba14e4558fdb5a80e88ec5b80ba839 Mon Sep 17 00:00:00 2001
From: Joel Beckmeyer <joel@beckmeyer.us>
Date: Tue, 30 Nov 2021 10:00:42 -0500
Subject: [PATCH 073/288] python3-phonenumbers: update to 8.12.38.

---
 srcpkgs/python3-phonenumbers/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-phonenumbers/template b/srcpkgs/python3-phonenumbers/template
index 70699dac90eb..29e82870d9a4 100644
--- a/srcpkgs/python3-phonenumbers/template
+++ b/srcpkgs/python3-phonenumbers/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-phonenumbers'
 pkgname=python3-phonenumbers
-version=8.12.37
+version=8.12.38
 revision=1
 wrksrc="phonenumbers-${version}"
 build_style=python3-module
@@ -12,4 +12,4 @@ license="Apache-2.0"
 homepage="https://github.com/daviddrysdale/python-phonenumbers"
 changelog="https://raw.githubusercontent.com/daviddrysdale/python-phonenumbers/dev/python/HISTORY.md"
 distfiles="${PYPI_SITE}/p/phonenumbers/phonenumbers-${version}.tar.gz"
-checksum=dbc560992844a059f56c7c0c6a587904e65d956740bbfb7e39589980bc9055b8
+checksum=3cda1d1cea9a6801babf825e6c0f6a9776ea6d8a68b81b256178f8e5aa813344

From 7cac96999707e239e7ec61500da4fc1009131c92 Mon Sep 17 00:00:00 2001
From: Joel Beckmeyer <joel@beckmeyer.us>
Date: Tue, 30 Nov 2021 09:55:55 -0500
Subject: [PATCH 074/288] synapse: update to 1.48.0.

---
 srcpkgs/synapse/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/synapse/template b/srcpkgs/synapse/template
index 20c4a4cc9970..bd5f529503e5 100644
--- a/srcpkgs/synapse/template
+++ b/srcpkgs/synapse/template
@@ -1,6 +1,6 @@
 # Template file for 'synapse'
 pkgname=synapse
-version=1.47.1
+version=1.48.0
 revision=1
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -19,7 +19,7 @@ license="Apache-2.0"
 homepage="https://github.com/matrix-org/synapse"
 changelog="https://raw.githubusercontent.com/matrix-org/synapse/develop/CHANGES.md"
 distfiles="https://github.com/matrix-org/synapse/archive/v${version}.tar.gz"
-checksum=cc385b6cfeba671bba800c2557ad39063bdd53f70dfb3781c85df7af6f5d064c
+checksum=182facc856f8d0c0d2d0dd4105fae4f851297167c0ee95c202a3aad9ed86c486
 
 system_accounts="synapse"
 synapse_homedir="/var/lib/synapse"

From 957ed6a3cc272852f603312bf17e47ce750f4663 Mon Sep 17 00:00:00 2001
From: Clyhtsuriva <aimeric@adjutor.xyz>
Date: Tue, 30 Nov 2021 12:51:38 +0100
Subject: [PATCH 075/288] ddpt: update to 0.97

---
 srcpkgs/ddpt/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/ddpt/template b/srcpkgs/ddpt/template
index a647dfdc9a81..cbb5c53e0aa8 100644
--- a/srcpkgs/ddpt/template
+++ b/srcpkgs/ddpt/template
@@ -1,6 +1,6 @@
 # Template file for 'ddpt'
 pkgname=ddpt
-version=0.96
+version=0.97
 revision=1
 build_style=gnu-configure
 makedepends="sg3_utils-devel"
@@ -9,7 +9,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="BSD-3-Clause"
 homepage="http://sg.danny.cz/sg/ddpt.html"
 distfiles="http://sg.danny.cz/sg/p/${pkgname}-${version}.tgz"
-checksum=8f231342af7458fe592496d5e8ff4e9a22313b6e0bbc5be9c588ed392d75e1f4
+checksum=e340a529aeef6a107b0c24c64873da590f5284557faffdf57a0f9dc48807233d
 
 post_install() {
 	vlicense COPYING

From 83ef7a65402080feec037639a794a43a2a0308d5 Mon Sep 17 00:00:00 2001
From: Clyhtsuriva <aimeric@adjutor.xyz>
Date: Tue, 30 Nov 2021 12:25:35 +0100
Subject: [PATCH 076/288] chuck: update to 1.4.1.0

---
 srcpkgs/chuck/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/chuck/template b/srcpkgs/chuck/template
index acf5648af53b..9c6c8be9364a 100644
--- a/srcpkgs/chuck/template
+++ b/srcpkgs/chuck/template
@@ -1,6 +1,6 @@
 # Template file for 'chuck'
 pkgname=chuck
-version=1.4.0.1
+version=1.4.1.0
 revision=1
 build_wrksrc=src
 build_style=gnu-makefile
@@ -14,7 +14,7 @@ license="GPL-2.0-or-later"
 homepage="http://chuck.cs.princeton.edu"
 changelog="https://chuck.cs.princeton.edu/release/VERSIONS"
 distfiles="http://chuck.cs.princeton.edu/release/files/$pkgname-$version.tgz"
-checksum=11a20c34b385e132bf43d5ae6a562c652f631828cc6b1562a4c029bc9a850ed4
+checksum=74bf99ad515e3113c55b833152936fad02a3cf006a54105ff11777c473194928
 
 
 post_extract() {

From d2d187e665ea02505b293b43d885c4076c4ec4c4 Mon Sep 17 00:00:00 2001
From: jgart <jgart@dismail.de>
Date: Mon, 29 Nov 2021 23:00:26 -0500
Subject: [PATCH 077/288] chicken: update to 5.3.0.

---
 srcpkgs/chicken/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/chicken/template b/srcpkgs/chicken/template
index 7da68b4a0468..79fdc41fbfb6 100644
--- a/srcpkgs/chicken/template
+++ b/srcpkgs/chicken/template
@@ -1,6 +1,6 @@
 # Template file for 'chicken'
 pkgname=chicken
-version=5.2.0
+version=5.3.0
 revision=1
 short_desc="Practical and portable Scheme system"
 maintainer="Orphaned <orphan@voidlinux.org>"
@@ -8,7 +8,7 @@ license="BSD-3-Clause"
 homepage="http://www.call-cc.org"
 changelog="https://code.call-cc.org/releases/$version/NEWS"
 distfiles="http://code.call-cc.org/releases/$version/$pkgname-$version.tar.gz"
-checksum=819149c8ce7303a9b381d3fdc1d5765c5f9ac4dee6f627d1652f47966a8780fa
+checksum=c3ad99d8f9e17ed810912ef981ac3b0c2e2f46fb0ecc033b5c3b6dca1bdb0d76
 
 do_configure() {
 	make -B -f Makefile.linux chicken-defaults.h PREFIX=/usr

From 621bac7383e8b2e78f23a305f856540c0afe1acb Mon Sep 17 00:00:00 2001
From: Evgeny Ermakov <evgeny.v.ermakov@gmail.com>
Date: Tue, 30 Nov 2021 06:15:55 +1100
Subject: [PATCH 078/288] fasm: update to 1.73.28.

---
 srcpkgs/fasm/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/fasm/template b/srcpkgs/fasm/template
index 020b96a5a3b8..9137a57e86e0 100644
--- a/srcpkgs/fasm/template
+++ b/srcpkgs/fasm/template
@@ -1,6 +1,6 @@
 # Template file for 'fasm'
 pkgname=fasm
-version=1.73.27
+version=1.73.28
 revision=1
 archs="i686* x86_64*"
 wrksrc=fasm
@@ -9,7 +9,7 @@ maintainer="Dmitry Bogatov <KAction@disroot.org>"
 license="BSD-2-Clause"
 homepage="https://flatassembler.net"
 distfiles="https://flatassembler.net/fasm-${version}.tgz"
-checksum=680148377fb6d3b6663852880faa03514d7326b5995742d33a87e244f48cf0b1
+checksum=9ed1ebb485fd1174111a94eb773105a234911398e05090f5e714abf62c809292
 nostrip=yes
 
 case ${XBPS_TARGET_MACHINE} in

From 21cbc0d95a2675ac357aa8d70077f17944c67187 Mon Sep 17 00:00:00 2001
From: Evgeny Ermakov <evgeny.v.ermakov@gmail.com>
Date: Tue, 30 Nov 2021 06:22:00 +1100
Subject: [PATCH 079/288] gtkwave: update to 3.3.111.

---
 srcpkgs/gtkwave/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/gtkwave/template b/srcpkgs/gtkwave/template
index d99b80e33dbf..9370f93039b3 100644
--- a/srcpkgs/gtkwave/template
+++ b/srcpkgs/gtkwave/template
@@ -1,6 +1,6 @@
 # Template file for 'gtkwave'
 pkgname=gtkwave
-version=3.3.109
+version=3.3.111
 revision=1
 build_style=gnu-configure
 configure_args="--with-tcl=${XBPS_CROSS_BASE}/usr/lib --with-tk=${XBPS_CROSS_BASE}/usr/lib"
@@ -11,7 +11,7 @@ maintainer="allan <mail@may.mooo.com>"
 license="GPL-2.0-or-later, MIT"
 homepage="http://gtkwave.sourceforge.net/"
 distfiles="http://gtkwave.sourceforge.net/gtkwave-${version}.tar.gz"
-checksum=ca487e5e9b728086ba4de6581058d6c096a7771915163ef600f63d0e88c3c05d
+checksum=f6e6046674033e5bab6e4e2720d6bd7dba70b23f329614191b029e06c57ec296
 
 post_install() {
 	vlicense LICENSE.TXT

From 52e4e1adec8bac910d38572db681260fa1102274 Mon Sep 17 00:00:00 2001
From: Evgeny Ermakov <evgeny.v.ermakov@gmail.com>
Date: Tue, 30 Nov 2021 06:09:12 +1100
Subject: [PATCH 080/288] glfw: update to 3.3.5.

---
 srcpkgs/glfw/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/glfw/template b/srcpkgs/glfw/template
index 99feb63bca77..997829355280 100644
--- a/srcpkgs/glfw/template
+++ b/srcpkgs/glfw/template
@@ -1,7 +1,7 @@
 # Template file for 'glfw'
 # update together with glfw-wayland
 pkgname=glfw
-version=3.3.4
+version=3.3.5
 revision=1
 build_style=cmake
 configure_args="-DBUILD_SHARED_LIBS=ON"
@@ -12,7 +12,7 @@ maintainer="Enno Boland <gottox@voidlinux.org>"
 license="Zlib"
 homepage="http://www.glfw.org"
 distfiles="${SOURCEFORGE_SITE}/${pkgname}/${pkgname}-${version}.tar.bz2"
-checksum=035f4572d9b7967433b3256f0eaa5257532b0e18865878a162233b108b6ca1db
+checksum=7bf8d4df3436f6eac7356e47fff7eb5a3610a692bffa27ce57dd55166abed5ea
 
 glfw-devel_package() {
 	depends="glfw>=${version}_${revision} $makedepends"

From 4e55e54c4a283805167774ebe989697f1bfa74d1 Mon Sep 17 00:00:00 2001
From: Evgeny Ermakov <evgeny.v.ermakov@gmail.com>
Date: Tue, 30 Nov 2021 06:11:30 +1100
Subject: [PATCH 081/288] glfw-wayland: update to 3.3.5.

---
 srcpkgs/glfw-wayland/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/glfw-wayland/template b/srcpkgs/glfw-wayland/template
index 6f90d6bc7778..8991962c6af5 100644
--- a/srcpkgs/glfw-wayland/template
+++ b/srcpkgs/glfw-wayland/template
@@ -1,6 +1,6 @@
 # Template file for 'glfw-wayland'
 pkgname=glfw-wayland
-version=3.3.4
+version=3.3.5
 revision=1
 wrksrc=glfw-${version}
 build_style=cmake
@@ -13,7 +13,7 @@ maintainer="q66 <daniel@octaforge.org>"
 license="Zlib"
 homepage="http://www.glfw.org"
 distfiles="${SOURCEFORGE_SITE}/glfw/glfw-${version}.tar.bz2"
-checksum=035f4572d9b7967433b3256f0eaa5257532b0e18865878a162233b108b6ca1db
+checksum=7bf8d4df3436f6eac7356e47fff7eb5a3610a692bffa27ce57dd55166abed5ea
 provides="glfw-${version}_${revision}"
 replaces="glfw>=0"
 

From 1453004d786046b6a2038e06efe90140b84ac150 Mon Sep 17 00:00:00 2001
From: Evgeny Ermakov <evgeny.v.ermakov@gmail.com>
Date: Tue, 30 Nov 2021 06:25:14 +1100
Subject: [PATCH 082/288] socat: update to 1.7.4.2.

---
 srcpkgs/socat/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/socat/template b/srcpkgs/socat/template
index d4e0f0a9bbdb..92ccc52bc08f 100644
--- a/srcpkgs/socat/template
+++ b/srcpkgs/socat/template
@@ -1,7 +1,7 @@
 # Template file for 'socat'
 pkgname=socat
-version=1.7.4.1
-revision=2
+version=1.7.4.2
+revision=1
 build_style=gnu-configure
 configure_args="--disable-libwrap --enable-fips
  ac_cv_have_z_modifier=yes"
@@ -11,7 +11,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="GPL-2.0-only"
 homepage="http://www.dest-unreach.org/socat/"
 distfiles="http://www.dest-unreach.org/socat/download/socat-${version}.tar.bz2"
-checksum=3faca25614e89123dff5045680549ecef519d02e331aaf3c4f5a8f6837c675e9
+checksum=6690a9f9990457b505097a272bbf2cbf4cc35576176f76646e3524b0e91c1763
 
 case "$XBPS_TARGET_MACHINE" in
 	*-musl) CFLAGS="-D_LINUX_IF_ETHER_H";;

From fc94dc8f551ad753519dc86367f9e9b2e1fda3b1 Mon Sep 17 00:00:00 2001
From: jgart <jgart@dismail.de>
Date: Mon, 29 Nov 2021 00:35:59 -0500
Subject: [PATCH 083/288] tree-sitter: update to 0.20.1.

---
 srcpkgs/tree-sitter/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/tree-sitter/template b/srcpkgs/tree-sitter/template
index 25d2743934c5..0f92c4e67130 100644
--- a/srcpkgs/tree-sitter/template
+++ b/srcpkgs/tree-sitter/template
@@ -1,6 +1,6 @@
 # Template file for 'tree-sitter'
 pkgname=tree-sitter
-version=0.20.0
+version=0.20.1
 revision=1
 build_style=cargo
 make_install_args="--path=cli"
@@ -9,7 +9,7 @@ maintainer="Érico Nogueira <ericonr@disroot.org>"
 license="MIT"
 homepage="https://tree-sitter.github.io"
 distfiles="https://github.com/tree-sitter/tree-sitter/archive/v${version}.tar.gz"
-checksum=4a8070b9de17c3b8096181fe8530320ab3e8cca685d8bee6a3e8d164b5fb47da
+checksum=12a3f7206af3028dbe8a0de50d8ebd6d7010bf762db918acae76fc7585f1258d
 make_check=no # tests require generating fixtures from remote repositories
 
 post_build() {

From a30fd24ab94dbc2a926e8e17670cdc5d8b0b5082 Mon Sep 17 00:00:00 2001
From: reedts <j.reedts@gmail.com>
Date: Wed, 1 Dec 2021 09:29:47 +0100
Subject: [PATCH 084/288] neovim: update to 0.6.0.

---
 srcpkgs/neovim/patches/python-3.10.patch | 23 -----------------------
 srcpkgs/neovim/template                  |  6 +++---
 2 files changed, 3 insertions(+), 26 deletions(-)
 delete mode 100644 srcpkgs/neovim/patches/python-3.10.patch

diff --git a/srcpkgs/neovim/patches/python-3.10.patch b/srcpkgs/neovim/patches/python-3.10.patch
deleted file mode 100644
index 7ff1b17cc24f..000000000000
--- a/srcpkgs/neovim/patches/python-3.10.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From e78fc38908dfb9f952e75026987f0db1f9ce4253 Mon Sep 17 00:00:00 2001
-From: "Tejasvi S. Tomar" <45873379+tejasvi@users.noreply.github.com>
-Date: Thu, 7 Oct 2021 11:41:52 +0530
-Subject: [PATCH] Fix python provider's minor version comparison
-
-`'3.10' < '3.3'` but v3.10 > v3.3
----
- runtime/autoload/provider/pythonx.vim | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/runtime/autoload/provider/pythonx.vim b/runtime/autoload/provider/pythonx.vim
-index c292b374b6f5..0eeb35cba8f1 100644
---- a/runtime/autoload/provider/pythonx.vim
-+++ b/runtime/autoload/provider/pythonx.vim
-@@ -96,7 +96,7 @@ function! provider#pythonx#CheckForModule(prog, module, major_version) abort
-     if prog_version !~ '^' . a:major_version
-       return [0, prog_path . ' is Python ' . prog_version . ' and cannot provide Python '
-             \ . a:major_version . '.']
--    elseif prog_version =~ '^' . a:major_version && prog_version < min_version
-+    elseif prog_version =~ '^' . a:major_version && str2nr(prog_version[2:]) < str2nr(min_version[2:])
-       return [0, prog_path . ' is Python ' . prog_version . ' and cannot provide Python >= '
-             \ . min_version . '.']
-     endif
diff --git a/srcpkgs/neovim/template b/srcpkgs/neovim/template
index bb22714097d4..ea9d0e5daa02 100644
--- a/srcpkgs/neovim/template
+++ b/srcpkgs/neovim/template
@@ -1,7 +1,7 @@
 # Template file for 'neovim'
 pkgname=neovim
-version=0.5.1
-revision=2
+version=0.6.0
+revision=1
 build_style=cmake
 build_helper="qemu"
 configure_args="-DCMAKE_BUILD_TYPE=Release"
@@ -14,7 +14,7 @@ maintainer="Steve Prybylski <sa.prybylx@gmail.com>"
 license="Apache-2.0, custom:Vim"
 homepage="https://neovim.io"
 distfiles="https://github.com/neovim/neovim/archive/v${version}.tar.gz"
-checksum=aa449795e5cc69bdd2eeed7095f20b9c086c6ecfcde0ab62ab97a9d04243ec84
+checksum=2cfd600cfa5bb57564cc22ffbbbcb2c91531053fc3de992df33656614384fa4c
 
 alternatives="
  vi:vi:/usr/bin/nvim

From 3e32975a41bfb6821ec82aeed64a252482f94d01 Mon Sep 17 00:00:00 2001
From: Dakota Walsh <kota@nilsu.org>
Date: Tue, 30 Nov 2021 09:42:07 +1300
Subject: [PATCH 085/288] aerc: update to 0.6.0.

The original upstream maintainer, Drew Devault, has stepped down and a
fork was created (with Drew's approval) under the same name. The fork
has patched in a large backlog of crashes and bug fixes and put out a
new version 0.6.0 recently. I think now that the aerc community has
consolidated on this fork it would be appropriate to update out package
to the new upstream.

More info about the fork and new maintainer can be found in this
discussion: https://lists.sr.ht/~sircmpwn/aerc/%3CCFBVJ3G1Y4YB.ZI6C02D0MS0S%40diabtop%3E
---
 srcpkgs/aerc/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/aerc/template b/srcpkgs/aerc/template
index 08c81ef0d4eb..989a400caa90 100644
--- a/srcpkgs/aerc/template
+++ b/srcpkgs/aerc/template
@@ -1,6 +1,6 @@
 # Template file for 'aerc'
 pkgname=aerc
-version=0.5.2
+version=0.6.0
 revision=1
 build_style=go
 hostmakedepends="scdoc git"
@@ -9,8 +9,8 @@ short_desc="Terminal email client"
 maintainer="shtayerc <david.murko@mailbox.org>"
 license="MIT"
 homepage="https://aerc-mail.org"
-distfiles="https://git.sr.ht/~sircmpwn/aerc/archive/${version}.tar.gz"
-checksum=87b922440e53b99f260d2332996537decb452c838c774e9340b633296f9f68ee
+distfiles="https://git.sr.ht/~rjarry/aerc/archive/${version}.tar.gz"
+checksum=ec4565609938b314f0343d85dfdab1cb0659c07c2845369ff7cf0132c5faed6e
 
 do_configure() {
 	:

From 2627578632d11418075feaaeea936b9c010a4fa0 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Thu, 2 Dec 2021 16:22:07 +0100
Subject: [PATCH 086/288] golly: update to 4.1.

---
 srcpkgs/golly/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/golly/template b/srcpkgs/golly/template
index 614c13b3be51..ee2876689ad3 100644
--- a/srcpkgs/golly/template
+++ b/srcpkgs/golly/template
@@ -1,6 +1,6 @@
 # Template file for 'golly'
 pkgname=golly
-version=4.0
+version=4.1
 revision=1
 wrksrc="${pkgname}-${version}-src"
 build_wrksrc="gui-wx"
@@ -10,13 +10,13 @@ make_build_args="-f makefile-gtk GOLLYDIR=/usr/share/golly LUALIB=-llua5.4
 make_install_args="${make_build_args}"
 hostmakedepends="python3"
 makedepends="MesaLib-devel glu-devel lua54-devel python3-devel wxWidgets-devel
- zlib-devel"
+ zlib-devel SDL2-devel"
 short_desc="Simulator for Conway's Game of Life and other cellular automata"
 maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="GPL-2.0-or-later"
 homepage="http://golly.sourceforge.net/"
 distfiles="${SOURCEFORGE_SITE}/${pkgname}/${pkgname}-${version}-src.tar.gz"
-checksum=45a8595c9f7064de029f05d339e3fca3776b5a0c36fef95712e697f154d82ae5
+checksum=6c655a6ce2fd75c6ae7289da39d084162c6ed887a01c21c3760872e3ff6d60c8
 
 CXXFLAGS="-I../gollybase"
 
@@ -27,7 +27,7 @@ post_extract() {
 
 pre_configure() {
 	if [ "$CROSS_BUILD" ]; then
-		vsed -i "s,\(PYTHON_INCLUDE\) =.*,\1=-I${XBPS_CROSS_BASE}/usr/include/python3.9,g" makefile-gtk
+		vsed -i "s,\(PYTHON_INCLUDE\) =.*,\1=-I${XBPS_CROSS_BASE}/usr/include/python3.10,g" makefile-gtk
 	fi
 }
 

From 389bc5e96d854f65909db871e90d75c16b944764 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Thu, 2 Dec 2021 18:16:57 +0100
Subject: [PATCH 087/288] sbcl: update to 2.1.11.

---
 srcpkgs/sbcl/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/sbcl/template b/srcpkgs/sbcl/template
index 5225f4ae682c..524d66eb8d05 100644
--- a/srcpkgs/sbcl/template
+++ b/srcpkgs/sbcl/template
@@ -1,6 +1,6 @@
 # Template file for 'sbcl'
 pkgname=sbcl
-version=2.1.10
+version=2.1.11
 revision=1
 archs="i686 x86_64* armv7l aarch64 ppc64le*"
 hostmakedepends="iana-etc"
@@ -12,7 +12,7 @@ license="custom:BSD+public_domain"
 homepage="http://www.sbcl.org/"
 changelog="http://www.sbcl.org/news.html"
 distfiles="${SOURCEFORGE_SITE}/${pkgname}/${pkgname}-${version}-source.tar.bz2"
-checksum=eb183f0f59a5cb2cbed762ec062bc34b9b6214b65402660784ef54838884b138
+checksum=bfc1481de7fdbdfaeef2ab0f0e8e84efd343433dea8d21cfbea8b0146cbdfefd
 nocross=yes
 nopie=yes
 
@@ -20,7 +20,7 @@ _bootstrap_lisp="bash ../sbcl-*-linux/run-sbcl.sh --no-sysinit --no-userinit --d
 case "$XBPS_TARGET_MACHINE" in
 x86_64)
 	distfiles+=" ${SOURCEFORGE_SITE}/${pkgname}/${pkgname}-${version}-x86-64-linux-binary.tar.bz2"
-	checksum+=" 5b23e9527d5a451bff8a78d08650122a7c4bf7d34b73fa7c8e712670fadc28ff"
+	checksum+=" e9605c843776470d8f81000b732b0a672ec355c0e3d6bbebfb900eddeb86c440"
 	;;
 i686)
 	distfiles+=" ${SOURCEFORGE_SITE}/${pkgname}/${pkgname}-1.4.3-x86-linux-binary.tar.bz2"

From 8d40dd0f50b3dd2cb189884eaa5f20e1b9db6b63 Mon Sep 17 00:00:00 2001
From: Michal Vasilek <michal@vasilek.cz>
Date: Thu, 2 Dec 2021 16:32:37 +0100
Subject: [PATCH 088/288] python3-md2gemini: remove site-packages/tests

---
 srcpkgs/python3-md2gemini/template | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

diff --git a/srcpkgs/python3-md2gemini/template b/srcpkgs/python3-md2gemini/template
index 508f152fa939..4b4f88c7233d 100644
--- a/srcpkgs/python3-md2gemini/template
+++ b/srcpkgs/python3-md2gemini/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-md2gemini'
 pkgname=python3-md2gemini
 version=1.8.1
-revision=1
+revision=2
 wrksrc="md2gemini-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools python3-mistune2 python3-cjkwrap
@@ -14,3 +14,8 @@ license="LGPL-3.0-only"
 homepage="https://github.com/makeworld-the-better-one/md2gemini"
 distfiles="${PYPI_SITE}/m/md2gemini/md2gemini-${version}.tar.gz"
 checksum=3ef2bd2d9e2b4968a844a2858f721348429f3a0b5976bd1c324198538103ca55
+
+post_install() {
+	# remove tests directory polluting site-packages
+	rm -r $DESTDIR/usr/lib/python*/site-packages/tests
+}

From d8d9a309ba3f66fd86a5b0e01ad95042aec5f37e Mon Sep 17 00:00:00 2001
From: Michal Vasilek <michal@vasilek.cz>
Date: Thu, 2 Dec 2021 16:32:42 +0100
Subject: [PATCH 089/288] python3-pykeepass: remove site-packages/tests

---
 srcpkgs/python3-pykeepass/template | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

diff --git a/srcpkgs/python3-pykeepass/template b/srcpkgs/python3-pykeepass/template
index 532f3a77a13c..5571c1a18dbe 100644
--- a/srcpkgs/python3-pykeepass/template
+++ b/srcpkgs/python3-pykeepass/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-pykeepass'
 pkgname=python3-pykeepass
 version=4.0.1
-revision=1
+revision=2
 wrksrc="pykeepass-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -15,3 +15,8 @@ homepage="https://github.com/libkeepass/pykeepass"
 changelog="https://raw.githubusercontent.com/libkeepass/pykeepass/master/CHANGELOG.rst"
 distfiles="https://github.com/libkeepass/pykeepass/archive/refs/tags/${version}.tar.gz"
 checksum=ac5966ede4fae1a0d3ea1997468a14b893a8f8dab136b1c14425b3b2763e68e3
+
+post_install() {
+	# remove tests directory polluting site-packages
+	rm -r $DESTDIR/usr/lib/python*/site-packages/tests
+}

From 00e42ad283612625f556599e269659eb10e3a700 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Ey=C3=9Fer?= <daniel.eysser@gmail.com>
Date: Thu, 2 Dec 2021 11:41:52 +0100
Subject: [PATCH 090/288] age: set version information

---
 srcpkgs/age/template | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/srcpkgs/age/template b/srcpkgs/age/template
index a3284c8d0c69..cf7754da9b03 100644
--- a/srcpkgs/age/template
+++ b/srcpkgs/age/template
@@ -1,10 +1,11 @@
 # Template file for 'age'
 pkgname=age
 version=1.0.0
-revision=1
+revision=2
 build_style=go
 go_import_path="filippo.io/age"
 go_package="${go_import_path}/cmd/..."
+go_ldflags="-X main.Version=${version}"
 short_desc="Simple, modern and secure encryption tool"
 maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="BSD-3-Clause"

From 8a08934e503854ab567c852682cf7d706d35dcaa Mon Sep 17 00:00:00 2001
From: Tim Sandquist <tim.sandquist@gmail.com>
Date: Thu, 2 Dec 2021 07:53:35 -0600
Subject: [PATCH 091/288] nss: update to 3.73.

critical security fix
https://www.mozilla.org/en-US/security/advisories/mfsa2021-51/
---
 srcpkgs/nss/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/nss/template b/srcpkgs/nss/template
index 968500eb758e..8f70796361e5 100644
--- a/srcpkgs/nss/template
+++ b/srcpkgs/nss/template
@@ -3,7 +3,7 @@
 _nsprver=4.32
 
 pkgname=nss
-version=3.72
+version=3.73
 revision=1
 hostmakedepends="perl"
 makedepends="nspr-devel sqlite-devel zlib-devel"
@@ -13,7 +13,7 @@ maintainer="Đoàn Trần Công Danh <congdanhqx@gmail.com>"
 license="MPL-2.0"
 homepage="https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSS"
 distfiles="${MOZILLA_SITE}/security/nss/releases/NSS_${version//\./_}_RTM/src/nss-${version}.tar.gz"
-checksum=6ea60a9ff113e493ea2ab25f41ea75a9fbd10af7903f26f703dac8680732d02e
+checksum=566d3a68da9b10d7da9ef84eb4fe182f8f04e20d85c55d1bf360bb2c0096d8e5
 
 export NS_USE_GCC=1
 export LIBRUNPATH=

From 4c063616b62a213dffec89108b8637819a6e3ccb Mon Sep 17 00:00:00 2001
From: Ramdziana F Y <ramdzian@gmail.com>
Date: Thu, 2 Dec 2021 19:16:19 +0700
Subject: [PATCH 092/288] vivaldi: update to 5.0.2497.24

---
 srcpkgs/vivaldi/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/vivaldi/template b/srcpkgs/vivaldi/template
index 98a12ab05eba..1ef2335e9ebe 100644
--- a/srcpkgs/vivaldi/template
+++ b/srcpkgs/vivaldi/template
@@ -1,6 +1,6 @@
 # Template file for 'vivaldi'
 pkgname=vivaldi
-version=4.3.2439.65
+version=5.0.2497.24
 revision=1
 _release=1
 archs="x86_64"
@@ -14,7 +14,7 @@ license="custom:Proprietary"
 homepage="https://vivaldi.com"
 distfiles="https://downloads.vivaldi.com/stable/vivaldi-stable_${version}-${_release}_amd64.deb"
 _licenseUrl="https://vivaldi.com/privacy/vivaldi-end-user-license-agreement/"
-checksum=42d6a7568b7b45c3b3d5a47e0ff51c46b80eab00645a17961be32f5320df10d1
+checksum=40f1cf35e6bd0e04e6bf9360f5179c85c68af403562a46358ea306e18080b32d
 repository=nonfree
 restricted=yes
 nostrip=yes

From a9d89251f9a0643480833d37845519b6314e0c89 Mon Sep 17 00:00:00 2001
From: Clyhtsuriva <aimeric@adjutor.xyz>
Date: Thu, 2 Dec 2021 13:22:19 +0100
Subject: [PATCH 093/288] gnome-robots: update to 40.0

---
 srcpkgs/gnome-robots/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/gnome-robots/template b/srcpkgs/gnome-robots/template
index 1d85efb012db..369474709a8d 100644
--- a/srcpkgs/gnome-robots/template
+++ b/srcpkgs/gnome-robots/template
@@ -1,14 +1,14 @@
 # Template file for 'gnome-robots'
 pkgname=gnome-robots
-version=3.38.0
+version=40.0
 revision=1
 build_style=meson
-hostmakedepends="gettext glib-devel itstool pkg-config"
-makedepends="gsound-devel gtk+3-devel libcanberra-devel librsvg-devel
+hostmakedepends="gettext glib-devel itstool pkg-config vala"
+makedepends="gsound-devel gtk4-devel libcanberra-devel librsvg-devel
  libglib-devel libgnome-games-support-devel"
 short_desc="GNOME classic robots game"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="https://wiki.gnome.org/Apps/Robots"
 distfiles="${GNOME_SITE}/${pkgname}/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=1fe8694aa7d4f86e77770649fcd8944b00535913cb5975bcd3adc424bdbeffe2
+checksum=6fbf2f885750f1a5110a724f8f35addd9bc61184ee31cf0c0cb89953e4f4cb11

From 424c97ff313e158ce0bfa6006542fe6fe3f2acbb Mon Sep 17 00:00:00 2001
From: John Zimmermann <me@johnnynator.dev>
Date: Wed, 1 Dec 2021 09:21:22 +0100
Subject: [PATCH 094/288] Rocket.Chat-Desktop: update to 3.7.0.

---
 srcpkgs/Rocket.Chat-Desktop/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/Rocket.Chat-Desktop/template b/srcpkgs/Rocket.Chat-Desktop/template
index a01959934521..58f2eed1d9ba 100644
--- a/srcpkgs/Rocket.Chat-Desktop/template
+++ b/srcpkgs/Rocket.Chat-Desktop/template
@@ -1,6 +1,6 @@
 # Template file for 'Rocket.Chat-Desktop'
 pkgname=Rocket.Chat-Desktop
-version=3.6.0
+version=3.7.0
 revision=1
 _electron_ver=13
 wrksrc="Rocket.Chat.Electron-${version}"
@@ -12,7 +12,7 @@ maintainer="John <me@johnnynator.dev>"
 license="MIT"
 homepage="https://rocket.chat/"
 distfiles="https://github.com/RocketChat/Rocket.Chat.Electron/archive/${version}.tar.gz"
-checksum=1b867f55c32f24124f5aaf6ce3dcd805a5aab29c63582a4b5a8730420af5cc1d
+checksum=328707d85b847214e0fe92bd3e45d757c7a27f24532c2f6d353dd045458fee80
 
 export USE_SYSTEM_APP_BUILDER=true
 

From 09c00fa485e974357eb08fcd2ca4387aeb6f753b Mon Sep 17 00:00:00 2001
From: Duncaen <duncaen@voidlinux.org>
Date: Fri, 3 Dec 2021 15:58:47 +0100
Subject: [PATCH 095/288] knot-resolver: update to 5.4.3.

---
 srcpkgs/knot-resolver/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/knot-resolver/template b/srcpkgs/knot-resolver/template
index fc56c00f9742..56fd104bc0f0 100644
--- a/srcpkgs/knot-resolver/template
+++ b/srcpkgs/knot-resolver/template
@@ -1,6 +1,6 @@
 # Template file for 'knot-resolver'
 pkgname=knot-resolver
-version=5.4.2
+version=5.4.3
 revision=1
 build_style=meson
 configure_args="
@@ -19,7 +19,7 @@ maintainer="Duncaen <duncaen@voidlinux.org>"
 license="GPL-3.0-or-later"
 homepage="https://www.knot-resolver.cz/"
 distfiles="https://secure.nic.cz/files/knot-resolver/knot-resolver-${version}.tar.xz"
-checksum=ea6a219571a752056669bae3f2c0c3ed0bec58af5ab832d505a3ec9c4063a58b
+checksum=488729eb93190336b6bca10de0d78ecb7919f77fcab105debc0a644aa7d0a506
 
 system_accounts="_knot_resolver"
 _knot_resolver_homedir="/var/cache/knot-resolver"

From 0a3241d5bef7a40b349139655d532fc4d5372c90 Mon Sep 17 00:00:00 2001
From: Duncaen <duncaen@voidlinux.org>
Date: Fri, 3 Dec 2021 16:00:34 +0100
Subject: [PATCH 096/288] logswan: update to 2.1.12.

---
 srcpkgs/logswan/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/logswan/template b/srcpkgs/logswan/template
index e6a18fe21159..4436b23cac97 100644
--- a/srcpkgs/logswan/template
+++ b/srcpkgs/logswan/template
@@ -1,6 +1,6 @@
 # Template file for 'logswan'
 pkgname=logswan
-version=2.1.11
+version=2.1.12
 revision=1
 build_style=cmake
 makedepends="jansson-devel libmaxminddb-devel"
@@ -10,7 +10,7 @@ license="BSD-2-clause"
 homepage="https://www.logswan.org/"
 changelog="https://github.com/fcambus/logswan/raw/master/ChangeLog"
 distfiles="https://github.com/fcambus/logswan/archive/${version}.tar.gz"
-checksum=a031b04c2dcfe8195e4225b8dd5781fc76098b9d19d0e4a9cbe1da76a4928eea
+checksum=8e954fcf5319b83f184b1a91d0af12c58bb90ab0f322f42ea6ad36fb05d57894
 
 post_install() {
 	vlicense LICENSE

From e47e55efb894fc78291e4e2c8ee9ed2ebcbdd285 Mon Sep 17 00:00:00 2001
From: Duncaen <duncaen@voidlinux.org>
Date: Fri, 3 Dec 2021 16:10:05 +0100
Subject: [PATCH 097/288] poke: update to 1.4.

---
 srcpkgs/poke/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/poke/template b/srcpkgs/poke/template
index c1876c668059..dbb3543855e8 100644
--- a/srcpkgs/poke/template
+++ b/srcpkgs/poke/template
@@ -1,6 +1,6 @@
 # Template file for 'poke'
 pkgname=poke
-version=1.3
+version=1.4
 revision=1
 build_style=gnu-configure
 hostmakedepends="pkg-config"
@@ -12,7 +12,7 @@ license="GPL-3.0-or-later"
 homepage="https://www.jemarch.net/poke.html"
 changelog="https://www.jemarch.net/poke-${version}-relnotes.html"
 distfiles="${GNU_SITE}/poke/poke-${version}.tar.gz"
-checksum=ba7863034a1b08004b0ee8f88bda94160707e9a781d5556f555b507583cf0f1b
+checksum=ce054df29560c921230132703ee449fe130b6e25ab03aa6cc796bb401506aa24
 
 poke-devel_package() {
 	depends="${sourcepkg}>=${version}_${revision}"

From 67f4a940e011e3733540684018236792d9eac1eb Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Ey=C3=9Fer?= <daniel.eysser@gmail.com>
Date: Fri, 3 Dec 2021 17:50:39 +0100
Subject: [PATCH 098/288] youtube-dl: orphan package

---
 srcpkgs/youtube-dl/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/youtube-dl/template b/srcpkgs/youtube-dl/template
index 72c70a4ee4b4..b83c6c887ab0 100644
--- a/srcpkgs/youtube-dl/template
+++ b/srcpkgs/youtube-dl/template
@@ -8,7 +8,7 @@ hostmakedepends="python3-setuptools"
 depends="python3-setuptools"
 checkdepends="flake8 python3-nose"
 short_desc="CLI program to download videos from YouTube and other sites"
-maintainer="Daniel Eyßer <daniel.eysser@gmail.com>"
+maintainer="Orphaned <orphan@voidlinux.org>"
 license="Unlicense"
 homepage="https://yt-dl.org"
 changelog="https://raw.githubusercontent.com/ytdl-org/youtube-dl/master/ChangeLog"

From f39cc1210af18ec5ae3d1761c32016c8a779a798 Mon Sep 17 00:00:00 2001
From: skmpz <dem.procopiou@gmail.com>
Date: Fri, 3 Dec 2021 20:06:41 +0400
Subject: [PATCH 099/288] calibre: update to 5.33.0.

---
 srcpkgs/calibre/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/calibre/template b/srcpkgs/calibre/template
index fcf45f5bb183..f96c9329ace6 100644
--- a/srcpkgs/calibre/template
+++ b/srcpkgs/calibre/template
@@ -1,6 +1,6 @@
 # Template file for 'calibre'
 pkgname=calibre
-version=5.32.0
+version=5.33.0
 revision=1
 build_style=python3-module
 pycompile_dirs="/usr/lib/calibre/"
@@ -27,7 +27,7 @@ license="GPL-3.0-only"
 homepage="https://calibre-ebook.com"
 changelog="https://raw.githubusercontent.com/kovidgoyal/calibre/master/Changelog.txt"
 distfiles="https://download.calibre-ebook.com/${version}/calibre-${version}.tar.xz"
-checksum=3571efc1cc773e453b459096a38b141fd0c7784fb9611505a1f9a55648f47e5e
+checksum=5c32cdd9cb7feecb125131842e3f66a8c9e838d7c5be6f016367de1a1d1f78fd
 lib32disabled=yes
 nocross=yes
 

From ae6d76f555f612e4845d42bf3be299a51b8af472 Mon Sep 17 00:00:00 2001
From: Anton Afanasyev <1157248+2asoft@users.noreply.github.com>
Date: Fri, 3 Dec 2021 01:11:32 -0800
Subject: [PATCH 100/288] CLion: update to 2021.3.

---
 srcpkgs/CLion/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/CLion/template b/srcpkgs/CLion/template
index a7779c295f13..76f9dd3f1e8c 100644
--- a/srcpkgs/CLion/template
+++ b/srcpkgs/CLion/template
@@ -1,6 +1,6 @@
 # Template file for 'CLion'
 pkgname=CLion
-version=2021.2.3
+version=2021.3
 revision=1
 archs="x86_64 aarch64"
 wrksrc="clion-${version}"
@@ -10,7 +10,7 @@ maintainer="Anton Afanasyev <anton@doubleasoftware.com>"
 license="custom:Commercial"
 homepage="https://www.jetbrains.com/clion"
 distfiles="https://download.jetbrains.com/cpp/CLion-${version}.tar.gz"
-checksum=25c3968c72976b2de5e3e8f39b242702c4ec25b32268022cd16590e9fbfc0b27
+checksum=4968657ad64d55da794bcf9b878fdd36ed233014152930058f761296d2047867
 repository=nonfree
 restricted=yes
 nopie=yes

From 46d07e9484667da151e1e8db6832e9ffed68a5ba Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Benjam=C3=ADn=20Albi=C3=B1ana?= <benalb@gmail.com>
Date: Fri, 3 Dec 2021 08:46:36 +0100
Subject: [PATCH 101/288] doomretro: update to 4.4.

---
 srcpkgs/doomretro/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/doomretro/template b/srcpkgs/doomretro/template
index 2df391db530b..d0a7996ac62b 100644
--- a/srcpkgs/doomretro/template
+++ b/srcpkgs/doomretro/template
@@ -1,6 +1,6 @@
 # Template file for 'doomretro'
 pkgname=doomretro
-version=4.3
+version=4.4
 revision=1
 build_style=cmake
 hostmakedepends="pkg-config"
@@ -11,4 +11,4 @@ license="GPL-3.0-or-later"
 homepage="https://www.doomretro.com"
 changelog="https://raw.githubusercontent.com/bradharding/doomretro/master/releasenotes.md"
 distfiles="https://github.com/bradharding/doomretro/archive/v${version}.tar.gz"
-checksum=99e48dc66e8d69a806372643db3aa1ea3b1a68dcf891ec79b9c3261484e3181e
+checksum=f28e439498de97a38decafd924d06e72ec247efca82719afca17d0532170be3b

From e5fd0407f741dd6d333ba94fe1c88a36200b4226 Mon Sep 17 00:00:00 2001
From: Clyhtsuriva <aimeric@adjutor.xyz>
Date: Thu, 2 Dec 2021 12:13:03 +0100
Subject: [PATCH 102/288] gnome-sudoku: update to 40.2

---
 srcpkgs/gnome-sudoku/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/gnome-sudoku/template b/srcpkgs/gnome-sudoku/template
index 86c314e7f147..ed1759478ab5 100644
--- a/srcpkgs/gnome-sudoku/template
+++ b/srcpkgs/gnome-sudoku/template
@@ -1,14 +1,14 @@
 # Template file for 'gnome-sudoku'
 pkgname=gnome-sudoku
-version=3.38.0
+version=40.2
 revision=1
 build_helper="gir"
 build_style=meson
 hostmakedepends="gettext glib-devel itstool pkg-config vala"
-makedepends="gtk+3-devel libgee08-devel json-glib-devel qqwing-devel"
+makedepends="gtk4-devel libgee08-devel json-glib-devel qqwing-devel"
 short_desc="GNOME Sudoku Japanese logic game"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="GPL-3.0-or-later"
 homepage="https://wiki.gnome.org/Apps/Sudoku"
 distfiles="${GNOME_SITE}/${pkgname}/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=38731d0cc6d56a21dbdc89409cc5bb3d08e1c02cd9009f4d57f5b34887e9fd32
+checksum=36120531e3c7139581ea3800fbfe3c2b31694c440145ecc897ac34e562d754a3

From c113c868b3b3eb8df1ab663fb992b08e9fb13299 Mon Sep 17 00:00:00 2001
From: Clyhtsuriva <aimeric@adjutor.xyz>
Date: Thu, 2 Dec 2021 11:50:02 +0100
Subject: [PATCH 103/288] gnome-chess: update to 41.1

---
 srcpkgs/gnome-chess/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/gnome-chess/template b/srcpkgs/gnome-chess/template
index 4ed9e8bc914e..629a10229d9d 100644
--- a/srcpkgs/gnome-chess/template
+++ b/srcpkgs/gnome-chess/template
@@ -1,14 +1,14 @@
 # Template file for 'gnome-chess'
 pkgname=gnome-chess
-version=3.38.1
+version=41.1
 revision=1
 build_style=meson
 hostmakedepends="gettext pkg-config vala glib-devel itstool librsvg-devel"
-makedepends="gtk+3-devel librsvg-devel"
+makedepends="gtk4-devel librsvg-devel"
 depends="gnuchess"
 short_desc="GNOME chess user interface"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="GPL-3.0-or-later"
 homepage="https://wiki.gnome.org/Apps/Chess"
 distfiles="${GNOME_SITE}/${pkgname}/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=1470f037c0dffe0285c121f7b6655e1245761f99a9974ab3c04dee5d6e89f5ae
+checksum=eb619886596396b4033a3f28a3c2e3004b54ebe1b38b40d6422c17b9f2cc17d0

From 515bd71b0eb6050fb12b69bf91124a22dad0d5ec Mon Sep 17 00:00:00 2001
From: Clyhtsuriva <aimeric@adjutor.xyz>
Date: Thu, 2 Dec 2021 13:51:15 +0100
Subject: [PATCH 104/288] hitori: update to 3.38.3

---
 srcpkgs/hitori/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/hitori/template b/srcpkgs/hitori/template
index 8a50efea3e63..b5fc5662126e 100644
--- a/srcpkgs/hitori/template
+++ b/srcpkgs/hitori/template
@@ -1,6 +1,6 @@
 # Template file for 'hitori'
 pkgname=hitori
-version=3.38.1
+version=3.38.3
 revision=1
 build_style=meson
 hostmakedepends="gettext glib-devel intltool itstool pkg-config"
@@ -11,4 +11,4 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="GPL-3.0-or-later"
 homepage="https://wiki.gnome.org/Apps/Hitori"
 distfiles="${GNOME_SITE}/${pkgname}/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=02bd2c421d4e2180265714e854bd12efd3c6d156ddf21f79e7df60011d4e4184
+checksum=f7d7103cb0633fb013730131a98c3ae3a2162b9fb9499fc7f19512d581bf6569

From bdf33c94ef286230cfcd97121c16fcf4c038bcac Mon Sep 17 00:00:00 2001
From: Joel Beckmeyer <joel@beckmeyer.us>
Date: Thu, 2 Dec 2021 08:06:48 -0500
Subject: [PATCH 105/288] borgmatic: update to 1.5.21, adopt.

---
 srcpkgs/borgmatic/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/borgmatic/template b/srcpkgs/borgmatic/template
index 523fbf23951c..047883dcc530 100644
--- a/srcpkgs/borgmatic/template
+++ b/srcpkgs/borgmatic/template
@@ -1,6 +1,6 @@
 # Template file for 'borgmatic'
 pkgname=borgmatic
-version=1.5.20
+version=1.5.21
 revision=1
 build_style=python3-module
 # runs not yet installed self
@@ -10,12 +10,12 @@ depends="borg python3-setuptools python3-ruamel.yaml python3-jsonschema
  python3-colorama python3-requests"
 checkdepends="${depends} python3-pytest-cov python3-flexmock"
 short_desc="Wrapper script for the Borg backup software"
-maintainer="Orphaned <orphan@voidlinux.org>"
+maintainer="Joel Beckmeyer <joel@beckmeyer.us>"
 license="GPL-3.0-or-later"
 homepage="https://torsion.org/borgmatic/"
 changelog="https://projects.torsion.org/borgmatic-collective/borgmatic/raw/branch/master/NEWS"
 distfiles="${PYPI_SITE}/b/borgmatic/borgmatic-${version}.tar.gz"
-checksum=0aa6705cd72c6bd8fec94ba9e5e13ba9e90e6671799af2f2f5cb91186b90b7e5
+checksum=b8aa9dbf250b95b829827310c9638a17cd52fee160a437283eed23bffcae83cf
 
 post_install() {
 	# remove tests directory polluting site-packages

From 748f39c1aa058a1cdabcc642bea7961f351fa479 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Ey=C3=9Fer?= <daniel.eysser@gmail.com>
Date: Thu, 2 Dec 2021 17:42:47 +0100
Subject: [PATCH 106/288] mpd: update to 0.23.5.

---
 srcpkgs/mpd/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/mpd/template b/srcpkgs/mpd/template
index 144dfdf9ec43..fc9c4153e284 100644
--- a/srcpkgs/mpd/template
+++ b/srcpkgs/mpd/template
@@ -1,6 +1,6 @@
 # Template file for 'mpd'
 pkgname=mpd
-version=0.23.4
+version=0.23.5
 revision=1
 build_style=meson
 configure_args="-Dopus=enabled -Dmikmod=enabled -Dneighbor=true
@@ -22,7 +22,7 @@ hostmakedepends="pkg-config python3-Sphinx"
 makedepends="avahi-glib-libs-devel boost-devel faad2-devel ffmpeg-devel
  libcurl-devel libid3tag-devel libmad-devel libmikmod-devel libmms-devel
  libmodplug-devel libmpdclient-devel libnfs-devel libsamplerate-devel
- libnpupnp-devel mpg123-devel opus-devel yajl-devel
+ libnpupnp-devel mpg123-devel opus-devel yajl-devel pcre2-devel icu-devel
  zziplib-devel libsoxr-devel audiofile-devel twolame-devel fmt-devel
  $(vopt_if io_uring 'liburing-devel') $(vopt_if pipewire 'pipewire-devel')
  $(vopt_if cdio 'libcdio-paranoia-devel') $(vopt_if shoutcast 'libshout-devel')
@@ -39,7 +39,7 @@ license="GPL-2.0-or-later"
 homepage="https://www.musicpd.org/"
 changelog="https://raw.githubusercontent.com/MusicPlayerDaemon/MPD/master/NEWS"
 distfiles="https://www.musicpd.org/download/mpd/${version%.*}/mpd-${version}.tar.xz"
-checksum=2f359d30dd980f762d2bc324d916e48b731e8a4d456d01d120c61ad657e4c754
+checksum=f22c2c25093a05f4566f9cd7207cfbcd8405af67ed29a989bcf8905f80b7a299
 LDFLAGS="-Wl,-z,stack-size=1048576"
 
 system_accounts="mpd"

From 2a3b54ba6178020aaed1819caa7744770f6f99be Mon Sep 17 00:00:00 2001
From: Imran Khan <imrankhan@teknik.io>
Date: Thu, 2 Dec 2021 15:51:18 +0600
Subject: [PATCH 107/288] txr: update to 272.

---
 srcpkgs/txr/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/txr/template b/srcpkgs/txr/template
index 1136f6b7b026..68af47b7e693 100644
--- a/srcpkgs/txr/template
+++ b/srcpkgs/txr/template
@@ -1,6 +1,6 @@
 # Template file for 'txr'
 pkgname=txr
-version=270
+version=272
 revision=1
 archs="x86_64* i686* aarch64* arm* ppc64* mips*"
 build_style=configure
@@ -13,7 +13,7 @@ license="BSD-2-Clause"
 homepage="http://www.nongnu.org/txr/"
 changelog="http://www.kylheku.com/cgit/txr/tree/RELNOTES"
 distfiles="http://www.kylheku.com/cgit/txr/snapshot/${pkgname}-${version}.tar.bz2"
-checksum=6e0fe840ee91430888a08db8ef7739b1884fa43e8b2b5e173e6ae3eda3150291
+checksum=b3c2a82198dc97633aa40ced6fff6fec39c78a905b06dc08e7b74176bda03543
 nopie=yes
 
 if [ "$CROSS_BUILD" ]; then

From fc92231a317692cd60a328f33bba2c4f00ef81c3 Mon Sep 17 00:00:00 2001
From: notthewave <winklbauer_m@zoho.eu>
Date: Wed, 1 Dec 2021 19:30:32 +0100
Subject: [PATCH 108/288] ART: update to 1.11.

---
 srcpkgs/ART/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/ART/template b/srcpkgs/ART/template
index 31370020a225..671695939be7 100644
--- a/srcpkgs/ART/template
+++ b/srcpkgs/ART/template
@@ -1,6 +1,6 @@
 # Template file for 'ART'
 pkgname=ART
-version=1.10.1
+version=1.11
 revision=1
 build_style=cmake
 hostmakedepends="pkg-config"
@@ -12,4 +12,4 @@ maintainer="notthewave <winklbauer_m@zoho.eu>"
 license="GPL-3.0-or-later"
 homepage="https://bitbucket.org/agriggio/art/wiki/Home"
 distfiles="https://bitbucket.org/agriggio/art/downloads/${pkgname}-${version}.tar.xz"
-checksum=e20b73de6be55bbb5924d1bc194ecd7f0bf26d581bd9b8b7d8a1af70ea85483e
+checksum=6458cdb7b8aa1afdb767c3aaaf5549e8892e2d6ecf0d29029fa32f82078dd568

From c96429230bcde22c439f38967ed27de1363c38e0 Mon Sep 17 00:00:00 2001
From: Omar Zeghouani <omarzeghouanii@gmail.com>
Date: Wed, 1 Dec 2021 23:02:20 +0000
Subject: [PATCH 109/288] git-filter-repo: update to 2.34.0.

---
 srcpkgs/git-filter-repo/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/git-filter-repo/template b/srcpkgs/git-filter-repo/template
index 073dd6f75fe1..a81d612705a5 100644
--- a/srcpkgs/git-filter-repo/template
+++ b/srcpkgs/git-filter-repo/template
@@ -1,7 +1,7 @@
 # Template file for 'git-filter-repo'
 pkgname=git-filter-repo
-version=2.33.0
-revision=2
+version=2.34.0
+revision=1
 depends="git python3"
 checkdepends="git python3 perl rsync dos2unix"
 short_desc="Versatile tool for rewriting git history"
@@ -9,7 +9,7 @@ maintainer="Cameron Nemo <cnemo@tutanota.com>"
 license="MIT"
 homepage="https://github.com/newren/git-filter-repo/"
 distfiles="https://github.com/newren/git-filter-repo/releases/download/v${version}/git-filter-repo-${version}.tar.xz"
-checksum=7bcf11da134bbd82a4171f7fb28a3ab7bc4d478fe8ec3a3d9580e4bbdc32e6e9
+checksum=b1bf46af1e6a91a54056d0254e480803db8e40f631336c559a1a94d2a08389c4
 
 do_check() {
 	t/run_tests

From 65beeac4adab2f31e3ce0ebb5248dc9d9fc9f4ca Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Ey=C3=9Fer?= <daniel.eysser@gmail.com>
Date: Fri, 3 Dec 2021 18:15:07 +0100
Subject: [PATCH 110/288] glances: update to 3.2.4.2.

---
 srcpkgs/glances/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/glances/template b/srcpkgs/glances/template
index f7814f03d996..e329bcbf6858 100644
--- a/srcpkgs/glances/template
+++ b/srcpkgs/glances/template
@@ -1,7 +1,7 @@
 # Template file for 'glances'
 pkgname=glances
-version=3.2.2
-revision=2
+version=3.2.4.2
+revision=1
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-future python3-psutil python3-defusedxml"
@@ -11,7 +11,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="LGPL-3.0-or-later"
 homepage="https://github.com/nicolargo/glances"
 distfiles="https://github.com/nicolargo/glances/archive/v${version}.tar.gz"
-checksum=7a96f16b09e30765a7a5b0e8d02dda20ac8ff1f144e6586d1f17ff7a80f5480f
+checksum=88ac8103d777b2a55cee9418a5940269c640c3ad964ec44de0e9bb80cdbead37
 
 post_install() {
 	vsconf conf/glances.conf

From 070016f7376a2e822d98a53e9e80ebe9a39bd942 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Ey=C3=9Fer?= <daniel.eysser@gmail.com>
Date: Fri, 3 Dec 2021 11:49:02 +0100
Subject: [PATCH 111/288] zoom: update to 5.8.6.739.

---
 srcpkgs/zoom/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/zoom/template b/srcpkgs/zoom/template
index c6d57a36e361..e5ab0c169fd5 100644
--- a/srcpkgs/zoom/template
+++ b/srcpkgs/zoom/template
@@ -1,6 +1,6 @@
 # Template file for 'zoom'
 pkgname=zoom
-version=5.8.4.210
+version=5.8.6.739
 revision=1
 archs="x86_64"
 wrksrc=zoom
@@ -13,7 +13,7 @@ maintainer="Daniel Santana <daniel@santana.tech>"
 license="custom:Proprietary"
 homepage="https://zoom.us/"
 distfiles="https://cdn.zoom.us/prod/${version}/zoom_x86_64.rpm"
-checksum=b3fc9eef929d418873bdf3cc6df38297b86deaf330259e633d17459ec8718034
+checksum=a57d03456a6a92f5ab01e342443edc1824b043837f23a8d4027cd8b5831c0f11
 repository=nonfree
 noshlibprovides=yes
 noverifyrdeps=yes

From b884dde9e99866afea21b6e2f26ec36186c95e7c Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Ey=C3=9Fer?= <daniel.eysser@gmail.com>
Date: Fri, 3 Dec 2021 18:01:09 +0100
Subject: [PATCH 112/288] yt-dlp: update to 2021.12.01.

---
 srcpkgs/yt-dlp/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/yt-dlp/template b/srcpkgs/yt-dlp/template
index 9432641a5e73..5e0e5fe9e2e0 100644
--- a/srcpkgs/yt-dlp/template
+++ b/srcpkgs/yt-dlp/template
@@ -1,19 +1,19 @@
 # Template file for 'yt-dlp'
 pkgname=yt-dlp
-version=2021.11.10.1
-revision=2
+version=2021.12.01
+revision=1
 wrksrc="$pkgname"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
-checkdepends="python3-pytest flake8 python3-nose"
 depends="python3"
+checkdepends="python3-pytest flake8 python3-nose"
 short_desc="CLI program to download videos from YouTube and other sites"
 maintainer="Michal Vasilek <michal@vasilek.cz>"
 license="Unlicense"
 homepage="https://github.com/yt-dlp/yt-dlp"
 changelog="https://raw.githubusercontent.com/yt-dlp/yt-dlp/master/Changelog.md"
 distfiles="https://github.com/yt-dlp/yt-dlp/releases/download/$version/yt-dlp.tar.gz"
-checksum=2eb1c67e095ded9d328eaa0e6e26952248b55dd1031a3751c6d60b759aefa16a
+checksum=bf0cc22d17ffbe59c0d0378026ff135a996b86c546ec9713d838f952dea61e0f
 
 do_check() {
 	PYTHON=/usr/bin/python3 make offlinetest

From 90ae8700c0436b151a5d3602f2a8d042325ddcdf Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Ey=C3=9Fer?= <daniel.eysser@gmail.com>
Date: Fri, 3 Dec 2021 11:53:08 +0100
Subject: [PATCH 113/288] scrcpy: update to 1.21.

---
 srcpkgs/scrcpy/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/scrcpy/template b/srcpkgs/scrcpy/template
index 1fe5ac7102c6..764649fafa4a 100644
--- a/srcpkgs/scrcpy/template
+++ b/srcpkgs/scrcpy/template
@@ -1,6 +1,6 @@
 # Template file for 'scrcpy'
 pkgname=scrcpy
-version=1.20
+version=1.21
 revision=1
 build_style=meson
 configure_args="-Dcompile_server=false
@@ -14,8 +14,8 @@ license="Apache-2.0"
 homepage="https://github.com/Genymobile/scrcpy"
 distfiles="${homepage}/archive/v${version}.tar.gz
  ${homepage}/releases/download/v${version}/scrcpy-server-v${version}"
-checksum="0c667e7de043a67a740be99d3f236a7aa4107ff62c408e7c462f4fe291f045a7
- b20aee4951f99b060c4a44000ba94de973f9604758ef62beb253b371aad3df34"
+checksum="76e16a894bdb483b14b7ae7dcc1be8036ec17924dfab070cf0cb3b47653a6822
+ dbcccab523ee26796e55ea33652649e4b7af498edae9aa75e4d4d7869c0ab848"
 skip_extraction="scrcpy-server-v${version}"
 
 post_install() {

From 6977dbfbfdf5e6f0f5758f9deb1e4190ab39ae97 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Ey=C3=9Fer?= <daniel.eysser@gmail.com>
Date: Fri, 3 Dec 2021 18:45:41 +0100
Subject: [PATCH 114/288] fdupes: update to 2.1.2.

---
 srcpkgs/fdupes/template | 11 +++--------
 1 file changed, 3 insertions(+), 8 deletions(-)

diff --git a/srcpkgs/fdupes/template b/srcpkgs/fdupes/template
index 4b409f902b73..1bfa0a775980 100644
--- a/srcpkgs/fdupes/template
+++ b/srcpkgs/fdupes/template
@@ -1,20 +1,15 @@
 # Template file for 'fdupes'
 pkgname=fdupes
-version=2.1.1
+version=2.1.2
 revision=1
 build_style=gnu-configure
-hostmakedepends="autoconf automake"
 makedepends="ncurses-devel pcre2-devel"
 short_desc="Identify or delete duplicate files within specified directories"
 maintainer="Steven R <dev@styez.com>"
 license="MIT"
 homepage="https://github.com/adrianlopezroche/fdupes"
-distfiles="https://github.com/adrianlopezroche/fdupes/archive/v${version}.tar.gz"
-checksum=37b1a499f6eb8b625b45641a2600be69ef591cd1e737e75afd50aa72ac215ea4
-
-pre_configure() {
-	autoreconf --install
-}
+distfiles="https://github.com/adrianlopezroche/fdupes/releases/download/v${version}/fdupes-${version}.tar.gz"
+checksum=cd5cb53b6d898cf20f19b57b81114a5b263cc1149cd0da3104578b083b2837bd
 
 post_install() {
 	vlicense README

From 5d49705dcfb57dbac0b285c8c6e5297e333635ef Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C3=89rico=20Nogueira?= <erico.erc@gmail.com>
Date: Fri, 3 Dec 2021 15:44:13 -0300
Subject: [PATCH 115/288] Rocket.Chat-Desktop: fix checksum.

---
 srcpkgs/Rocket.Chat-Desktop/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/Rocket.Chat-Desktop/template b/srcpkgs/Rocket.Chat-Desktop/template
index 58f2eed1d9ba..6d87c8b6945b 100644
--- a/srcpkgs/Rocket.Chat-Desktop/template
+++ b/srcpkgs/Rocket.Chat-Desktop/template
@@ -12,7 +12,7 @@ maintainer="John <me@johnnynator.dev>"
 license="MIT"
 homepage="https://rocket.chat/"
 distfiles="https://github.com/RocketChat/Rocket.Chat.Electron/archive/${version}.tar.gz"
-checksum=328707d85b847214e0fe92bd3e45d757c7a27f24532c2f6d353dd045458fee80
+checksum=5b37d497f1985ca74b6a7971ae54a2741e9214c4e83cf754177f2fa444824f12
 
 export USE_SYSTEM_APP_BUILDER=true
 

From d176063fae85901058a3df19cdd0f92cf009f039 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C3=89rico=20Nogueira?= <erico.erc@gmail.com>
Date: Sat, 27 Nov 2021 14:57:04 -0300
Subject: [PATCH 116/288] libreoffice: update to 7.2.3.2.

- remove VLC entirely (deprecated by upstream)
- update vendored tarballs
- add zxing and cmis tarballs (zxing isn't packaged by void, cmis
  upstream doesn't make releases with the necessary changes, see [1])
- builds were erroring out if the translation, dictionaries and help
  tarballs weren't unpacked, so remove them from the skip_extraction
  list, but still symlink them into the external dir so the build system
  doesn't try to download them
- move most subpackages to depend on writer, since it contains some of
  the needed pieces for them. This closes #34304
- remove outdated permission fix for soffice

[1] https://github.com/tdf/libcmis/issues/42
---
 .../libreoffice/patches/fix-vlc-backend.patch | 20 -----
 srcpkgs/libreoffice/template                  | 84 ++++++++++---------
 2 files changed, 43 insertions(+), 61 deletions(-)
 delete mode 100644 srcpkgs/libreoffice/patches/fix-vlc-backend.patch

diff --git a/srcpkgs/libreoffice/patches/fix-vlc-backend.patch b/srcpkgs/libreoffice/patches/fix-vlc-backend.patch
deleted file mode 100644
index 2c121c8ad2c6..000000000000
--- a/srcpkgs/libreoffice/patches/fix-vlc-backend.patch
+++ /dev/null
@@ -1,20 +0,0 @@
- vcl: fix build with vlc backend enabled
- 
- avmedia/source/vlc/vlcplayer.cxx tries to access the aWindow member
- directly, which leads to a compilation failure, since it's private.
-
-diff --git include/vcl/sysdata.hxx include/vcl/sysdata.hxx
-index 63b7c810de3d..0cd0e037c823 100644
---- a/include/vcl/sysdata.hxx
-+++ b/include/vcl/sysdata.hxx
-@@ -73,9 +73,8 @@ struct VCL_DLLPUBLIC SystemEnvData
-     // however, the GTK3 vclplug wants to store pointers in here!
-     sal_IntPtr          aShellWindow;   // the window of the frame's shell
-     Platform            platform;       // the windowing system in use
--private:
--    sal_uIntPtr         aWindow;        // the window of the object
- public:
-+    sal_uIntPtr         aWindow;        // the window of the object
- 
-     void SetWindowHandle(sal_uIntPtr nWindow)
-     {
diff --git a/srcpkgs/libreoffice/template b/srcpkgs/libreoffice/template
index 6ea455c5c0cb..9e3208ccf364 100644
--- a/srcpkgs/libreoffice/template
+++ b/srcpkgs/libreoffice/template
@@ -1,7 +1,7 @@
 # Template file for 'libreoffice'
 pkgname=libreoffice
-version=7.1.3.2
-revision=4
+version=7.2.3.2
+revision=1
 build_style=meta
 make_build_target="build-nocheck"
 nocross="Several dependencies are nocross=yes"
@@ -12,14 +12,14 @@ hostmakedepends="automake flex git gperf hyphen icu libtool openldap which gette
 makedepends="CoinMP-devel apr-devel avahi-libs-devel clucene-devel
  frameworkintegration-devel glyphy-devel gpgmepp-devel gst-plugins-base1-devel
  gtk+-devel gtk+3-devel hunspell-devel hyphen-devel libXt-devel libabw-devel
- libatomic_ops-devel libbluetooth-devel libcdr-devel libcmis-devel libe-book-devel
+ libatomic_ops-devel libbluetooth-devel libcdr-devel libe-book-devel
  libepubgen-devel libetonyek-devel libexttextcat-devel libfbclient3-devel libfreehand-devel
  libgcrypt-devel libgltf-devel libldap-devel libmariadbclient-devel libmspub-devel
  libmwaw-devel libnumbertext-devel libodfgen-devel liborcus-devel
  libpagemaker-devel libqxp-devel librsvg-devel libvisio-devel libwpg-devel
  libwps-devel lpsolve-devel mdds mythes-devel neon-devel nss-devel
  postgresql-libs-devel python3-devel qt5-devel redland-devel sane-devel
- telepathy-glib-devel unixodbc-devel vigra-devel vlc-devel libcppunit-devel
+ telepathy-glib-devel unixodbc-devel vigra-devel libcppunit-devel
  qrcodegen-devel xmlsec1-devel poppler-cpp-devel libxml2-devel"
 depends="libreoffice-common>=${version}_${revision}"
 depends+=" libreoffice-base>=${version}_${revision}"
@@ -59,18 +59,20 @@ distfiles="
  ${_baseurl}/${pkgname}-translations-${version}.tar.xz
  ${_addurl}/798b2ffdc8bcfe7bca2cf92b62caf685-rhino1_5R5.zip
  ${_addurl}/a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.zip
- ${_addurl}/language-subtag-registry-2019-04-03.tar.bz2
+ ${_addurl}/ace6ab49184e329db254e454a010f56d-libxml-1.1.7.zip
+ ${_addurl}/language-subtag-registry-2021-03-05.tar.bz2
  ${_addurl}/17410483b5b5f267aa18b7e00b65e6e0-hsqldb_1_8_0.zip
  ${_addurl}/d8bd5eed178db6e2b18eeed243f85aa8-flute-1.1.6.zip
  ${_addurl}/ba2930200c9f019c2d93a8c88c651a0f-flow-engine-0.9.4.zip
  ${_addurl}/b63e6340a02ff1cacfeadb2c42286161-JLanguageTool-1.7.0.tar.bz2
  ${_addurl}/box2d-2.3.1.tar.gz
+ ${_addurl}/libcmis-0.5.2.tar.xz
  ${_addurl}/libstaroffice-0.0.7.tar.xz
  ${_addurl}/libzmf-0.0.2.tar.xz
- ${_addurl}/pdfium-4306.tar.bz2
+ ${_addurl}/pdfium-4500.tar.bz2
  ${_addurl}/bae83fa5dc7f081768daace6e199adc3-glm-0.9.4.6-libreoffice.zip
  ${_exturl}/8249374c274932a21846fa7629c2aa9b-officeotron-0.7.4-master.jar
- ${_exturl}/odfvalidator-1.2.0-incubating-SNAPSHOT-jar-with-dependencies-971c54fd38a968f5860014b44301872706f9e540.jar
+ ${_exturl}/odfvalidator-0.9.0-RC2-SNAPSHOT-jar-with-dependencies-2726ab578664434a545f8379a01a9faffac0ae73.jar
  ${_exturl}/185d60944ea767075d27247c3162b3bc-unowinreg.dll
  ${_addurl}/commons-logging-1.2-src.tar.gz
  ${_addurl}/dtoa-20180411.tgz
@@ -87,45 +89,48 @@ distfiles="
  ${_addurl}/f94d9870737518e3b597f9265f4e9803-libserializer-1.1.6.zip
  ${_addurl}/7239a4430efd4d0189c4f24df67f08e5-mysql-connector-c++-1.1.4.tar.gz
  ${_addurl}/39bb3fcea1514f1369fcfc87542390fd-sacjava-1.3.zip
- ${_addurl}/skia-m88-59bafeeaa7de9eb753e3778c414e01dcf013dcd8.tar.xz
+ ${_addurl}/skia-m90-45c57e116ee0ce214bdf78405a4762722e4507d9.tar.xz
  ${_addurl}/368f114c078f94214a308a74c7e991bc-crosextrafonts-20130214.tar.gz
  ${_addurl}/c74b7223abe75949b4af367942d96c7a-crosextrafonts-carlito-20130920.tar.gz
  ${_addurl}/33e1e61fab06a547851ed308b4ffef42-dejavu-fonts-ttf-2.37.zip
  ${_addurl}/1725634df4bb3dcb1b2c91a6175f8789-GentiumBasic_1102.zip
  ${_addurl}/liberation-narrow-fonts-ttf-1.07.6.tar.gz
- ${_addurl}/liberation-fonts-ttf-2.00.4.tar.gz
+ ${_addurl}/liberation-fonts-ttf-2.1.4.tar.gz
  ${_addurl}/e7a384790b13c29113e22e596ade9687-LinLibertineG-20120116.zip
  ${_addurl}/907d6e99f241876695c19ff3db0b8923-source-code-pro-2.030R-ro-1.050R-it.tar.gz
  ${_addurl}/edc4d741888bc0d38e32dbaa17149596-source-sans-pro-2.010R-ro-1.065R-it.tar.gz
  ${_addurl}/source-serif-pro-3.000R.tar.gz
  ${_addurl}/EmojiOneColor-SVGinOT-1.3.tar.gz
  ${_addurl}/noto-fonts-20171024.tar.gz
- ${_addurl}/culmus-0.131.tar.gz
+ ${_addurl}/culmus-0.133.tar.gz
  ${_addurl}/libre-hebrew-1.0.tar.gz
  ${_addurl}/alef-1.001.tar.gz
  ${_addurl}/ttf-kacst_2.01+mry.tar.gz
+ ${_addurl}/zxing-cpp-1.1.1.tar.gz
  ${_addurl}/Amiri-0.111.zip
  ${_addurl}/ReemKufi-0.7.zip
  ${_addurl}/Scheherazade-2.100.zip
 "
-checksum="35af7fd104b253704f770a205f835aee0e82ccc889ebf0949a89d9b3276229bf
- 66dc5fd4253f6b956b8fdde0d741ef7d85f12647db235642eb74f3d0a44d404e
- e0f14b4db1585506761ad2ceeb43850cb594f2ec8a20fc9ca7bcb95e77408935
- 86138935d274d46d27e4ce92a72d759e7d4491d7b227be952e05735ba5c9b327
+checksum="56c97374956d98c8efcd6d58771c0950c8a641ed84fd64db66382884c4c3b451
+ 41ca87cf71842696c9e21c6c01eb6ade5018a5e07f7cd8745c694b74ba3a185b
+ 087e1444294afe5ab49ea37a2c78c055c2a39000e8979017dd6bb2025d2cae79
+ 07f51594fcb32fb3373e94304bade1b91b6d8b5551f8e688da777e4f520448ec
  1fb458d6aab06932693cc8a9b6e4e70944ee1ff052fa63606e3131df34e21753
  75823776fb51a9c526af904f1503a7afaaab900fba83eda64f8a41073724c870
- a1d7fb901764bb8f251d4f686cdf565764f9987d0fb5d9315d54a7366a84822d
+ 7d2797fe9f79a77009721e3f14fa4a1dec17a6d706bdc93f85f1f01d124fab66
+ ce80e8face06bf2ada363e0c159e3f990c4116fdae9232ca43e6369aa82bf16a
  d30b13f4ba2e3b6a2d4f020c0dee0a9fb9fc6fbcc2d561f36b78da4bf3802370
  1b5b24f7bc543c0362b667692f78db8bab4ed6dafc6172f104d0bd3757d8a133
  233f66e8d25c5dd971716d4200203a612a407649686ef3b52075d04b4c9df0dd
  48c87e41636783bba438b65fd895821e369ed139e1465fac654323ad93c5a82d
  58ffc8475a8650aadc351345aef696937747b40501ab78d72c197c5ff5b3035c
+ d7b18d9602190e10d437f8a964a32e983afd57e2db316a07d87477a79f5000a2
  f94fb0ad8216f97127bedef163a45886b43c62deac5e5b0f5e628e234220c8db
  27051a30cb057fdb5d5de65a1f165c7153dc76e27fe62251cbb86639eb2caf22
- eca406d47ac7e2a84dcc86f93c08f96e591d409589e881477fa75e488e4851d8
+ 26a03dd60e5ed0979cdaba9cc848242895110ddfdf347d40989ce2f14020f304
  d0312c360efe04dd048b3311fe375ff36f1993b4c2e3cb58c81062990532904a
  f2443f27561af52324eee03a1892d9f569adc8db9e7bca55614898bc2a13a770
- 984f2a479df79e27e7b01a5815ac53ae64e07746b882262d8a64566494515504
+ d55495ab3a86544650587de2a72180ddf8bfc6376d14ddfa923992dbc86a06e0
  eafde646a7dbe46d20c291685b0beac2382174d78d66ee990e229a1bf6e6cec6
  49665da5a60d033e6dff40fe0a7f9173e886ae859ce6096c1afe34c48b677c81
  0082d0684f7db6f62361b76c4b7faba19e0c7ce5cb8e36c4b65fea8281e711b4
@@ -142,44 +147,44 @@ checksum="35af7fd104b253704f770a205f835aee0e82ccc889ebf0949a89d9b3276229bf
  05640a1f6805b2b2d7e2cb9c50db9a5cb084e3c52ab1a71ce015239b4a1d4343
  a25f14dad39e93a2f9cdf09166ee53981f7212dce829e4208e07a522963a8585
  085f2112c51fa8c1783fac12fbd452650596415121348393bb51f0f7e85a9045
- f293656a15342a53bb407b932fc907c6894178a162f09728bd383e24d84b1301
+ abe0b94d54edb717c58d74263f4ed3d27824d2ce9e9f2ce85a21ab38d993f94d
  c48d1c2fd613c9c06c959c34da7b8388059e2408d2bb19845dc3ed35f76e4d09
  4bd12b6cbc321c1cf16da76e2c585c925ce956a08067ae6f6c64eff6ccfdaf5a
  7576310b219e04159d35ff61dd4a4ec4cdba4f35c00e002a136f00e96a908b0a
  2f1a2c5491d7305dffd3520c6375d2f3e14931ee35c6d8ae1e8f098bf1a7b3cc
  8879d89b5ff7b506c9fc28efc31a5c0b954bbe9333e66e5283d27d20a8519ea3
- c40e95fc5e0ecb73d4be565ae2afc1114e2bc7dc5253e00ee92d8fd6cc4adf45
+ 26f85412dd0aa9d061504a1cc8aaf0aa12a70710e8d47d8b65a1251757c1a5ef
  54adcb2bc8cac0927a647fbd9362f45eff48130ce6e2379dc3867643019e08c5
  09466dce87653333f189acd8358c60c6736dcd95f042dee0b644bdcf65b6ae2f
  e7bc9a1fec787a529e49f5a26b93dcdcf41506449dfc70f92cdef6d17eb6fb61
  826a2b784d5cdb4c2bbc7830eb62871528360a61a52689c102a101623f1928e3
  d1a08f7c10589f22740231017694af0a7a270760c8dec33d8d1c038e2be0a0c7
  29acc15a4c4d6b51201ba5d60f303dfbc2e5acbfdb70413c9ae1ed34fa259994
- dcf112cfcccb76328dcfc095f4d7c7f4d2f7e48d0eed5e78b100d1d77ce2ed1b
+ c0c6873742d07544f6bacf2ad52eb9cb392974d56427938dc1dfbc8399c64d05
  f596257c1db706ce35795b18d7f66a4db99d427725f20e9384914b534142579a
  b98b67602a2c8880a1770f0b9e37c190f29a7e2ade5616784f0b89fbdb75bf52
  dca00f5e655f2f217a766faa73a81f542c5c204aa3a47017c3c2be0b31d00a56
+ e595b3fa2ec320beb0b28f6af56b1141853257c2611686685639cebb3b248c86
  1fbfccced6348b5db2c1c21d5b319cd488e14d055702fa817a0f6cb83d882166
  f60c6508d209ce4236d2d7324256c2ffddd480be7e3d6023770b93dc391a605f
  251c8817ceb87d9b661ce1d5b49e732a0116add10abc046be4b8ba5196e149b5"
 skip_extraction="
- ${pkgname}-dictionaries-${version}.tar.xz
- ${pkgname}-help-${version}.tar.xz
- ${pkgname}-translations-${version}.tar.xz
  798b2ffdc8bcfe7bca2cf92b62caf685-rhino1_5R5.zip
  a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.zip
- language-subtag-registry-2019-04-03.tar.bz2
+ ace6ab49184e329db254e454a010f56d-libxml-1.1.7.zip
+ language-subtag-registry-2021-03-05.tar.bz2
  17410483b5b5f267aa18b7e00b65e6e0-hsqldb_1_8_0.zip
  d8bd5eed178db6e2b18eeed243f85aa8-flute-1.1.6.zip
  ba2930200c9f019c2d93a8c88c651a0f-flow-engine-0.9.4.zip
  b63e6340a02ff1cacfeadb2c42286161-JLanguageTool-1.7.0.tar.bz2
  box2d-2.3.1.tar.gz
+ libcmis-0.5.2.tar.xz
  libstaroffice-0.0.7.tar.xz
  libzmf-0.0.2.tar.xz
- pdfium-4306.tar.bz2
+ pdfium-4500.tar.bz2
  bae83fa5dc7f081768daace6e199adc3-glm-0.9.4.6-libreoffice.zip
  8249374c274932a21846fa7629c2aa9b-officeotron-0.7.4-master.jar
- odfvalidator-1.2.0-incubating-SNAPSHOT-jar-with-dependencies-971c54fd38a968f5860014b44301872706f9e540.jar
+ odfvalidator-0.9.0-RC2-SNAPSHOT-jar-with-dependencies-2726ab578664434a545f8379a01a9faffac0ae73.jar
  185d60944ea767075d27247c3162b3bc-unowinreg.dll
  commons-logging-1.2-src.tar.gz
  dtoa-20180411.tgz
@@ -196,23 +201,24 @@ skip_extraction="
  f94d9870737518e3b597f9265f4e9803-libserializer-1.1.6.zip
  7239a4430efd4d0189c4f24df67f08e5-mysql-connector-c++-1.1.4.tar.gz
  39bb3fcea1514f1369fcfc87542390fd-sacjava-1.3.zip
- skia-m88-59bafeeaa7de9eb753e3778c414e01dcf013dcd8.tar.xz
+ skia-m90-45c57e116ee0ce214bdf78405a4762722e4507d9.tar.xz
  368f114c078f94214a308a74c7e991bc-crosextrafonts-20130214.tar.gz
  c74b7223abe75949b4af367942d96c7a-crosextrafonts-carlito-20130920.tar.gz
  33e1e61fab06a547851ed308b4ffef42-dejavu-fonts-ttf-2.37.zip
  1725634df4bb3dcb1b2c91a6175f8789-GentiumBasic_1102.zip
  liberation-narrow-fonts-ttf-1.07.6.tar.gz
- liberation-fonts-ttf-2.00.4.tar.gz
+ liberation-fonts-ttf-2.1.4.tar.gz
  e7a384790b13c29113e22e596ade9687-LinLibertineG-20120116.zip
  907d6e99f241876695c19ff3db0b8923-source-code-pro-2.030R-ro-1.050R-it.tar.gz
  edc4d741888bc0d38e32dbaa17149596-source-sans-pro-2.010R-ro-1.065R-it.tar.gz
  source-serif-pro-3.000R.tar.gz
  EmojiOneColor-SVGinOT-1.3.tar.gz
  noto-fonts-20171024.tar.gz
- culmus-0.131.tar.gz
+ culmus-0.133.tar.gz
  libre-hebrew-1.0.tar.gz
  alef-1.001.tar.gz
  ttf-kacst_2.01+mry.tar.gz
+ zxing-cpp-1.1.1.tar.gz
  Amiri-0.111.zip
  ReemKufi-0.7.zip
  Scheherazade-2.100.zip
@@ -394,7 +400,7 @@ _add_lang zu		"Zulu"
 post_fetch() {
 	local srcdistdir=${XBPS_SRCDISTDIR}/${pkgname}-${version} pkg
 	mkdir -p ${wrksrc}/external/tarballs
-	for pkg in ${skip_extraction}; do
+	for pkg in ${skip_extraction} libreoffice-{dictionaries,help,translations}-${version}.tar.xz ; do
 		if [ "${pkg%.dll}" != "${pkg}" ]; then
 			# The dll needs to be copied instead of symlinked
 			cp -v ${srcdistdir}/${pkg} ${wrksrc}/external/tarballs/
@@ -454,7 +460,6 @@ do_configure() {
 	opts+=" --enable-gtk3"
 	opts+=" --enable-qt5"
 	opts+=" --enable-kf5"
-	opts+=" --enable-vlc"
 	opts+=" --disable-dependency-tracking"
 	opts+=" --enable-release-build"
 	opts+=" --enable-split-app-modules"
@@ -488,12 +493,14 @@ do_configure() {
 	fi
 	opts+=" --with-tls=nss"
 	opts+=" --without-system-box2d"
+	opts+=" --without-system-libcmis"
 	opts+=" --without-system-libzmf"
 	opts+=" --without-system-libstaroffice"
 	opts+=" --without-system-libtommath"
 	opts+=" --without-system-jfreereport"
 	opts+=" --without-system-apache-commons"
 	opts+=" --without-system-beanshell"
+	opts+=" --without-system-zxing"
 	# opts+=" --without-system-glm"
 	opts+=" --with-myspell-dicts"
 	opts+=" --with-system-icu-for-build=yes"
@@ -515,11 +522,6 @@ do_configure() {
 do_build() {
 	make ${makejobs} ${make_build_target}
 	make ${makejobs} -C libreofficekit
-
-	# on some platforms (32-bit ppc at least), this single file has
-	# incorrect (non-executable) permissions, so fix it here
-	# only this file is affected and i have no idea why...
-	chmod 755 ${wrksrc}/instdir/program/soffice
 }
 
 do_install() {
@@ -540,7 +542,7 @@ libreoffice-common_package() {
 
 libreoffice-base_package() {
 	short_desc+=" - Database frontend"
-	depends="libreoffice-common>=${version}_${revision}"
+	depends="libreoffice-writer>=${version}_${revision}"
 	noverifyrdeps=yes
 	pkg_install() {
 		_split base
@@ -549,7 +551,7 @@ libreoffice-base_package() {
 
 libreoffice-calc_package() {
 	short_desc+=" - Spreadsheet"
-	depends="libreoffice-common>=${version}_${revision}"
+	depends="libreoffice-writer>=${version}_${revision}"
 	noverifyrdeps=yes
 	pkg_install() {
 		_split calc
@@ -558,7 +560,7 @@ libreoffice-calc_package() {
 
 libreoffice-draw_package() {
 	short_desc+=" - Drawing application"
-	depends="sane libreoffice-common>=${version}_${revision}"
+	depends="sane libreoffice-writer>=${version}_${revision}"
 	noverifyrdeps=yes
 	pkg_install() {
 		_split draw
@@ -585,7 +587,7 @@ libreoffice-gnome_package() {
 
 libreoffice-impress_package() {
 	short_desc+=" - Presentation application"
-	depends="libreoffice-common>=${version}_${revision}"
+	depends="libreoffice-writer>=${version}_${revision}"
 	noverifyrdeps=yes
 	pkg_install() {
 		_split impress
@@ -616,7 +618,7 @@ libreoffice-kit_package() {
 
 libreoffice-math_package() {
 	short_desc+=" - Equation editor"
-	depends="libreoffice-common>=${version}_${revision}"
+	depends="libreoffice-writer>=${version}_${revision}"
 	noverifyrdeps=yes
 	pkg_install() {
 		_split math

From 978cbda6f208d13f0e4bfa977c4e0931d221f11a Mon Sep 17 00:00:00 2001
From: ologantr <mrphyber@protonmail.com>
Date: Thu, 2 Dec 2021 13:04:03 +0100
Subject: [PATCH 117/288] sqlite: update to 3.37.0

---
 srcpkgs/sqlite/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/sqlite/template b/srcpkgs/sqlite/template
index 5a2c6dfcca5f..cf993a2c88fe 100644
--- a/srcpkgs/sqlite/template
+++ b/srcpkgs/sqlite/template
@@ -1,6 +1,6 @@
 # Template file for 'sqlite'
 pkgname=sqlite
-version=3.36.0
+version=3.37.0
 revision=1
 _amalgamationver=$(printf "%d%02d%02d00\n" ${version//./ })
 wrksrc="sqlite-autoconf-${_amalgamationver}"
@@ -13,7 +13,7 @@ license="Public Domain"
 homepage="https://sqlite.org/"
 changelog="https://www.sqlite.org/releaselog/${version//./_}.html"
 distfiles="${homepage}/2021/sqlite-autoconf-${_amalgamationver}.tar.gz"
-checksum=bd90c3eb96bee996206b83be7065c9ce19aef38c3f4fb53073ada0d0b69bbce3
+checksum=731a4651d4d4b36fc7d21db586b2de4dd00af31fd54fb5a9a4b7f492057479f7
 
 CFLAGS="-DSQLITE_ENABLE_DBSTAT_VTAB -DSQLITE_ENABLE_COLUMN_METADATA \
  -DSQLITE_ENABLE_UNLOCK_NOTIFY -DSQLITE_SECURE_DELETE -DSQLITE_ENABLE_JSON1 \

From 9de52093c0abbbeaafde9c0c92dfc36052e4d804 Mon Sep 17 00:00:00 2001
From: ologantr <mrphyber@protonmail.com>
Date: Thu, 2 Dec 2021 13:07:51 +0100
Subject: [PATCH 118/288] fossil: update to 2.17

---
 srcpkgs/fossil/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/fossil/template b/srcpkgs/fossil/template
index 674bfc2d632e..63323b9f1f02 100644
--- a/srcpkgs/fossil/template
+++ b/srcpkgs/fossil/template
@@ -1,6 +1,6 @@
 # Template file for 'fossil'
 pkgname=fossil
-version=2.16
+version=2.17
 revision=1
 build_style=configure
 configure_args="--disable-internal-sqlite --prefix=/usr"
@@ -12,7 +12,7 @@ license="BSD-2-Clause"
 homepage="https://www.fossil-scm.org"
 changelog="https://www.fossil-scm.org/home/doc/trunk/www/changes.wiki"
 distfiles="https://fossil-scm.org/home/tarball/version-${version}/fossil-${version}.tar.gz"
-checksum=1eab740b04d98d2c35776fea65eba86007ea1441d2116943eb0a67e18a88b2fc
+checksum=21d6ee5187775113f74e55ab5ebcb1764f7226a8e59be1b2c7896cbe9dce6914
 
 post_extract() {
 	vsed -i 's/test_system_sqlite$/# &/' auto.def  # failing on cross

From b9c37ae29301dae1c76c18dc1fbf63dcdc046038 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Ey=C3=9Fer?= <daniel.eysser@gmail.com>
Date: Sat, 27 Nov 2021 13:45:35 +0100
Subject: [PATCH 119/288] fd: update to 8.3.0.

---
 srcpkgs/fd/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/fd/template b/srcpkgs/fd/template
index f7d5cfc6b0c7..7b8fe10e0a50 100644
--- a/srcpkgs/fd/template
+++ b/srcpkgs/fd/template
@@ -1,6 +1,6 @@
 # Template file for 'fd'
 pkgname=fd
-version=8.2.1
+version=8.3.0
 revision=1
 build_style=cargo
 short_desc="Simple, fast and user-friendly alternative to find"
@@ -9,7 +9,7 @@ license="Apache-2.0, MIT"
 homepage="https://github.com/sharkdp/fd"
 changelog="https://raw.githubusercontent.com/sharkdp/fd/master/CHANGELOG.md"
 distfiles="https://github.com/sharkdp/fd/archive/v${version}.tar.gz"
-checksum=429de7f04a41c5ee6579e07a251c72342cd9cf5b11e6355e861bb3fffa794157
+checksum=3c5a8a03c4f6ade73b92432ed0ba51591db19b0d136073fa3ccfa99d63403d52
 
 post_install() {
 	vman doc/fd.1

From 361fc57b0b9e8dec68f302fcd549fe75151cb5a2 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Fri, 3 Dec 2021 16:53:50 +0100
Subject: [PATCH 120/288] isync: update to 1.4.4.

---
 srcpkgs/isync/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/isync/template b/srcpkgs/isync/template
index bad7086f050f..e72235d5b77e 100644
--- a/srcpkgs/isync/template
+++ b/srcpkgs/isync/template
@@ -1,6 +1,6 @@
 # Template file for 'isync'
 pkgname=isync
-version=1.4.3
+version=1.4.4
 revision=1
 build_style=gnu-configure
 hostmakedepends="perl pkg-config"
@@ -12,7 +12,7 @@ license="GPL-2.0-or-later"
 homepage="http://isync.sourceforge.net/"
 changelog="https://sourceforge.net/p/isync/isync/ci/master/tree/NEWS?format=raw"
 distfiles="${SOURCEFORGE_SITE}/${pkgname}/${pkgname}-${version}.tar.gz"
-checksum=b4c720745bda3447fbd5b9f71783b23f699a55295917ae7586ee5c22e91b9708
+checksum=7c3273894f22e98330a330051e9d942fd9ffbc02b91952c2f1896a5c37e700ff
 
 post_install() {
 	vsconf src/mbsyncrc.sample

From 402699047b1fe2eda9a5c7b96f0021ce78b2949f Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Fri, 3 Dec 2021 16:55:01 +0100
Subject: [PATCH 121/288] janet: update to 1.19.0.

---
 common/shlibs          | 2 +-
 srcpkgs/janet/template | 4 ++--
 2 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index ad60646030fe..abdf7b261f8a 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -3889,7 +3889,7 @@ libcaribou.so.0 libcaribou-0.4.21_3
 libtinyclipboard.so.1 tinyclipboard-16.01_1
 libcbor.so.0.9 libcbor-0.9.0_1
 libfido2.so.1 libfido2-1.6.0_2
-libjanet.so.1.18 janet-1.18.0_1
+libjanet.so.1.19 janet-1.19.0_1
 libOpenImageDenoise.so.1 openimagedenoise-1.3.0_1
 libcbang0.so cbang-1.6.0_3
 libblosc.so.1 c-blosc-1.17.1_1
diff --git a/srcpkgs/janet/template b/srcpkgs/janet/template
index 373b1475e233..c36e4a4e97ab 100644
--- a/srcpkgs/janet/template
+++ b/srcpkgs/janet/template
@@ -1,6 +1,6 @@
 # Template file for 'janet'
 pkgname=janet
-version=1.18.1
+version=1.19.0
 revision=1
 build_style=meson
 configure_args="-Db_lto=false"  # breaks jpm
@@ -10,7 +10,7 @@ license="MIT"
 homepage="https://janet-lang.org/"
 changelog="https://github.com/janet-lang/janet/blob/master/CHANGELOG.md"
 distfiles="https://github.com/janet-lang/janet/archive/v${version}.tar.gz"
-checksum=bfc29c11a070cc175666f74eb99ea992276d6e269701ba9558a72cef05ac80b4
+checksum=613f08613d524349bea9777d9f4f930252a0f035332da113c993153fe5284ef2
 
 post_install() {
 	vlicense LICENSE

From 7c8c25ef3ac95627abe463ce15bd025e994db78d Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Fri, 3 Dec 2021 16:55:34 +0100
Subject: [PATCH 122/288] ugrep: update to 3.3.10.

---
 srcpkgs/ugrep/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/ugrep/template b/srcpkgs/ugrep/template
index 39891a0af99f..75826fd725ac 100644
--- a/srcpkgs/ugrep/template
+++ b/srcpkgs/ugrep/template
@@ -1,6 +1,6 @@
 # Template file for 'ugrep'
 pkgname=ugrep
-version=3.3.8
+version=3.3.10
 revision=1
 build_style=gnu-configure
 makedepends="bzip2-devel liblz4-devel liblzma-devel libzstd-devel pcre2-devel
@@ -10,7 +10,7 @@ maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="BSD-3-Clause"
 homepage="https://github.com/Genivia/ugrep"
 distfiles="https://github.com/Genivia/ugrep/archive/v${version}.tar.gz"
-checksum=1bdc73ca5fc12a41c2f7949900edee0972ca3e5f39066c8d68449846df4cf1d7
+checksum=8cf74bdf254bac78c19385028bbf8678d83be35522d452b71d16105a1c4c57b8
 
 post_install() {
 	vlicense LICENSE.txt LICENSE

From 06d588f000d27df73a86a47888ba2e8d4f8599eb Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Fri, 3 Dec 2021 18:04:38 +0100
Subject: [PATCH 123/288] z3: update to 4.8.13.

---
 srcpkgs/z3/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/z3/template b/srcpkgs/z3/template
index bca042082b3f..fb8aca291c2b 100644
--- a/srcpkgs/z3/template
+++ b/srcpkgs/z3/template
@@ -1,6 +1,6 @@
 # Template file for 'z3'
 pkgname=z3
-version=4.8.12
+version=4.8.13
 revision=4
 wrksrc="${pkgname}-${pkgname}-${version}"
 build_style=configure
@@ -15,7 +15,7 @@ maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="MIT"
 homepage="https://github.com/Z3Prover/z3"
 distfiles="https://github.com/Z3Prover/z3/archive/z3-${version}.tar.gz"
-checksum=e3aaefde68b839299cbc988178529535e66048398f7d083b40c69fe0da55f8b7
+checksum=59a0b35711fa7ae48dd535116d2067a6a16955fcbf2623c516a3f630cd2832d8
 
 build_options="ocaml"
 desc_option_ocaml="Enable support for OCaml bindings"

From 686aedb71c21bdeeb8c8f01afe59db11589d3387 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Fri, 3 Dec 2021 23:07:07 +0100
Subject: [PATCH 124/288] pymol: update to 2.5.0.

---
 srcpkgs/pymol/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/pymol/template b/srcpkgs/pymol/template
index 75b78380572c..659dea5d368c 100644
--- a/srcpkgs/pymol/template
+++ b/srcpkgs/pymol/template
@@ -1,12 +1,12 @@
 # Template file for 'pymol'
 pkgname=pymol
-version=2.4.0
-revision=3
+version=2.5.0
+revision=1
 wrksrc=${pkgname}-open-source-${version}
 build_style="python3-module"
 build_helper="numpy"
-makedepends="msgpack-devel freetype-devel libfreeglut-devel netcdf-devel
- glew-devel glm python3-devel libxml2-devel python3-PyQt5 mmtf-cpp"
+makedepends="freetype-devel glew-devel glm libfreeglut-devel libgomp-devel
+ libxml2-devel mmtf-cpp msgpack-devel netcdf-devel python3-PyQt5 python3-devel"
 depends="python3-numpy tcsh python3-pmw python3-tkinter python3-PyQt5"
 short_desc="PyMOL molecular visualization system"
 maintainer="Brenton Horne <brentonhorne77@gmail.com>"
@@ -14,7 +14,7 @@ license="custom:PyMOL"
 homepage="https://pymol.org/"
 distfiles="https://github.com/schrodinger/pymol-open-source/archive/v${version}.tar.gz>${pkgname}-${version}.tar.gz
  https://c.fsdn.com/allura/p/${pkgname}/icon>${pkgname}.png"
-checksum="5ede4ce2e8f53713c5ee64f5905b2d29bf01e4391da7e536ce8909d6b9116581
+checksum="aa828bf5719bd9a14510118a93182a6e0cadc03a574ba1e327e1e9780a0e80b3
  0ea81faaf336becc669a193777d0dca55475d303d1236b57df25cf67ff7c2bcd"
 skip_extraction="${pkgname}.png"
 

From 7dc9b798894c0827ff58a7d5c9d0c9f584dc26b4 Mon Sep 17 00:00:00 2001
From: oreo639 <31916379+Oreo639@users.noreply.github.com>
Date: Fri, 26 Nov 2021 23:45:32 -0800
Subject: [PATCH 125/288] New package: webp-pixbuf-loader-0.0.3

---
 srcpkgs/webp-pixbuf-loader/template | 13 +++++++++++++
 1 file changed, 13 insertions(+)
 create mode 100644 srcpkgs/webp-pixbuf-loader/template

diff --git a/srcpkgs/webp-pixbuf-loader/template b/srcpkgs/webp-pixbuf-loader/template
new file mode 100644
index 000000000000..189889b62896
--- /dev/null
+++ b/srcpkgs/webp-pixbuf-loader/template
@@ -0,0 +1,13 @@
+# Template file for 'webp-pixbuf-loader'
+pkgname=webp-pixbuf-loader
+version=0.0.3
+revision=1
+build_style=meson
+hostmakedepends="pkg-config gdk-pixbuf"
+makedepends="gdk-pixbuf-devel libwebp-devel"
+short_desc="WebP Image format loader for GdkPixbuf"
+maintainer="oreo639 <oreo6391@gmail.com>"
+license="LGPL-2.0-or-later"
+homepage="https://github.com/aruiz/webp-pixbuf-loader"
+distfiles="https://github.com/aruiz/webp-pixbuf-loader/archive/refs/tags/${version}.tar.gz"
+checksum=e2ba11afcd1272f26147214659bcf2462066a840ecb9ba2776c85abd0ec43cbe

From cafc22bf9e67d43bf11e00fabda432590ee5e5fc Mon Sep 17 00:00:00 2001
From: Daniel Lewan <vision360.daniel@gmail.com>
Date: Fri, 3 Dec 2021 23:24:52 +0100
Subject: [PATCH 126/288] s: update to 0.6.2.

---
 srcpkgs/s/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/s/template b/srcpkgs/s/template
index e55d22e4d3d5..cb9c4fc4e4ca 100644
--- a/srcpkgs/s/template
+++ b/srcpkgs/s/template
@@ -1,6 +1,6 @@
 # Template file for 's'
 pkgname=s
-version=0.6.1
+version=0.6.2
 revision=1
 build_helper=qemu
 build_style=go
@@ -11,7 +11,7 @@ maintainer="Daniel Lewan <vision360.daniel@gmail.com>"
 license="MIT"
 homepage="https://github.com/zquestz/s"
 distfiles="https://github.com/zquestz/s/archive/v${version}.tar.gz"
-checksum=8f5f3e9503edcf9eb4792379f93c1e08806b8b9699121a72745d1d63c91a0426
+checksum=acc38953fcb21e1dd2cd761b9d2bf8272aa6aa30fed2adb657f2dba7e4df872f
 
 post_build() {
 	s_cli=$(find $GOPATH/bin -name s)

From 723aa2ea33c20c56879e55d784fa109558e0a39c Mon Sep 17 00:00:00 2001
From: Daniel Lewan <vision360.daniel@gmail.com>
Date: Fri, 3 Dec 2021 23:26:23 +0100
Subject: [PATCH 127/288] hivemind: update to 1.1.0.

---
 srcpkgs/hivemind/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/hivemind/template b/srcpkgs/hivemind/template
index 935d852b4a5c..ad154844be35 100644
--- a/srcpkgs/hivemind/template
+++ b/srcpkgs/hivemind/template
@@ -1,6 +1,6 @@
 # Template file for 'hivemind'
 pkgname=hivemind
-version=1.0.6
+version=1.1.0
 revision=1
 build_style=go
 go_import_path="github.com/DarthSim/hivemind"
@@ -9,7 +9,7 @@ maintainer="Daniel Lewan <vision360.daniel@gmail.com>"
 license="MIT"
 homepage="https://github.com/DarthSim/hivemind"
 distfiles="https://github.com/DarthSim/hivemind/archive/v${version}.tar.gz"
-checksum=8ca7884db49268b7938d0503e7e95443cb3a56696478d5dcc2b9813705525a39
+checksum=b4f7259663ef5b99906af0d98fe4b964d8f9a4d86a8f5aff30ab8df305d3a996
 
 post_install() {
 	vlicense LICENSE

From f0659dd5763e9113120aef72e729f3b5ed515067 Mon Sep 17 00:00:00 2001
From: Daniel Lewan <vision360.daniel@gmail.com>
Date: Sat, 4 Dec 2021 00:01:44 +0100
Subject: [PATCH 128/288] go: update URLs and install VERSION file

---
 srcpkgs/go/template | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/go/template b/srcpkgs/go/template
index 9aa551c74c53..cc66dc6c7f46 100644
--- a/srcpkgs/go/template
+++ b/srcpkgs/go/template
@@ -1,16 +1,16 @@
 # Template file for 'go'
 pkgname=go
 version=1.17.2
-revision=1
+revision=2
 create_wrksrc=yes
 build_wrksrc=go
 hostmakedepends="go1.12-bootstrap"
 short_desc="Go Programming Language"
 maintainer="Michael Aldridge <maldridge@voidlinux.org>"
 license="BSD-3-Clause"
-homepage="https://golang.org/"
-changelog="https://golang.org/doc/devel/release.html"
-distfiles="https://golang.org/dl/go${version}.src.tar.gz"
+homepage="https://go.dev/"
+changelog="https://go.dev/doc/devel/release.html"
+distfiles="https://go.dev/dl/go${version}.src.tar.gz"
 checksum=2255eb3e4e824dd7d5fcdc2e7f84534371c186312e546fb1086a34c17752f431
 nostrip=yes
 noverifyrdeps=yes
@@ -63,6 +63,7 @@ do_install() {
 	cp -a pkg src lib ${DESTDIR}/usr/lib/go
 	cp -r doc misc -t ${DESTDIR}/usr/share/go
 	ln -s /usr/share/go/doc ${DESTDIR}/usr/lib/go/doc
+	cp VERSION ${DESTDIR}/usr/lib/go/VERSION
 
 	# This is to make go get code.google.com/p/go-tour/gotour and
 	# then running the gotour executable work out of the box.

From 99ec3dc5726b0f18bcd550aee31c0f0578c05283 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Ey=C3=9Fer?= <daniel.eysser@gmail.com>
Date: Fri, 3 Dec 2021 12:02:29 +0100
Subject: [PATCH 129/288] dunst: update to 1.7.2.

---
 srcpkgs/dunst/template | 11 +++++++----
 1 file changed, 7 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/dunst/template b/srcpkgs/dunst/template
index 1b80bf0d1987..3c3d9f5107bd 100644
--- a/srcpkgs/dunst/template
+++ b/srcpkgs/dunst/template
@@ -1,21 +1,24 @@
 # Template file for 'dunst'
 pkgname=dunst
-version=1.7.1
+version=1.7.2
 revision=1
 build_style=gnu-makefile
+make_check_target=test
 make_use_env=yes
-make_build_args="SYSTEMD=0 WAYLAND=$(vopt_if wayland 1 0)"
+make_build_args="SYSTEMD=0 WAYLAND=$(vopt_if wayland 1 0) SYSCONFDIR=/etc"
 make_install_args="$make_build_args"
 hostmakedepends="perl pkg-config"
-makedepends="gtk+-devel libXScrnSaver-devel libXinerama-devel libXrandr-devel
+makedepends="gdk-pixbuf-devel libXScrnSaver-devel libXinerama-devel libXrandr-devel
  libxdg-basedir-devel libnotify-devel $(vopt_if wayland 'wayland-devel wayland-protocols')"
+checkdepends="dbus"
+conf_files="/etc/dunst/dunstrc"
 short_desc="Lightweight and customizable notification daemon"
 maintainer="Daniel Santana <daniel@santana.tech>"
 license="BSD-3-Clause"
 homepage="https://dunst-project.org"
 changelog="https://raw.githubusercontent.com/dunst-project/dunst/master/CHANGELOG.md"
 distfiles="https://github.com/dunst-project/dunst/archive/v${version}.tar.gz"
-checksum=f61ed3280aee9ec2aac07c44cf3d147df8fe8a6d7b92b6e8ab04e546bff1adce
+checksum=e4fa376d327e8a4cd375d00d4c318c93cc0968d4f184ab40da94ca6b30477181
 
 build_options="wayland"
 build_options_default="wayland"

From 2bfdec4fbce1821b6b9513a381692e35c0317605 Mon Sep 17 00:00:00 2001
From: Tomasz Kramkowski <tk@the-tk.com>
Date: Tue, 16 Nov 2021 20:26:26 +0000
Subject: [PATCH 130/288] nim: update to 1.6.0 (and fixes + cleanup)

Version bump to 1.6.0 including the following changes:

- Nim now comes with testament
- Fusion library is no longer bundled with nim
- Examples no longer come with nim
- FIX - non-x86_64/i686 nim.cfg compiler configuration
  Non-x86_64/i686 builds no longer end up with a broken nim.cfg which
  will try to use the package build time $CC to build packages for the
  package architecture as well as a bunch of others (which will simply
  not work).
- FIX - arm nim.cfg compiler configuration
  The default arm.linux.gcc.(linker)?exe variables are now commented on
  non-x86_64/i686 builds to ensure that arm packages don't end up with
  the same issue as above.
- CLEANUP - use koch to build non-x86_64/i686 tools
  The loop was unnecessary.
  - note: This means nimsuggest is now built without -d:release on all
    builds (not just x86_64/i686 builds). I am not sure if this is
    intentional or an upstream bug, should be investigated at some
    point.
- CLEANUP - use make to build the bootstrap compiler
---
 srcpkgs/nim/template | 66 ++++++++++++++------------------------------
 1 file changed, 21 insertions(+), 45 deletions(-)

diff --git a/srcpkgs/nim/template b/srcpkgs/nim/template
index 76a3452c68ab..809627066a68 100644
--- a/srcpkgs/nim/template
+++ b/srcpkgs/nim/template
@@ -1,13 +1,11 @@
 # Template file for 'nim'
 pkgname=nim
-version=1.4.8
+version=1.6.0
 revision=1
-_cversion=0.20.0
-_nimbleversion=0.12.0
-_fusionversion=e942c649892b2ae3802851fba6bc5d251326e5fb
+_c1version=561b417c65791cd8356b5f73620914ceff845d10
+_nimbleversion=0.13.1
 create_wrksrc=yes
 build_wrksrc="Nim-$version"
-hostmakedepends="ed"
 depends="gcc openssl-devel"
 short_desc="Nim programming language"
 maintainer="allan <mail@may.mooo.com>"
@@ -15,31 +13,27 @@ license="MIT"
 homepage="https://nim-lang.org/"
 _ghsite="https://github.com/nim-lang"
 distfiles="${_ghsite}/Nim/archive/v${version}.tar.gz
- ${_ghsite}/csources/archive/v${_cversion}.tar.gz>csources-${_cversion}.tar.gz
- ${_ghsite}/nimble/archive/v${_nimbleversion}.tar.gz>nimble-${_nimbleversion}.tar.gz
- ${_ghsite}/fusion/archive/${_fusionversion}.tar.gz>fusion-${_fusionversion}.tar.gz"
-checksum="8a687beb30670dc4eadcfefd1198d4238af283dc716438ac2342a7d65e07d9e9
- 5e6fd15d90df1a8cb7614c4ffc70aa8c4198cd854d7742016202b96dd0228d3c
- 0b88d91a450f31641f85379f2d76afb0a013cf783e62144a6534525b9cb1cbac
- 76d10a2f0f25ba7fb3393bdb800c75e8084758d8ce69e63d07926cd36f555084"
+ ${_ghsite}/csources_v1/archive/${_c1version}.tar.gz>csources_v1-${_c1version}.tar.gz
+ ${_ghsite}/nimble/archive/v${_nimbleversion}.tar.gz>nimble-${_nimbleversion}.tar.gz"
+checksum="c202cfd24a24480da1cf851e1265b87edb22710bb42286a57b1a99c83b6a8315
+ 71c823444c794a12da9027d19d6a717dd7759521ecbbe28190b08372142607ec
+ e6aa8d9ee4b3ed0321dca329b4a38fa546771b9729984482fb50fe73d3777f5d"
 
 post_extract() {
-	mv csources-$_cversion $build_wrksrc/csources
+	mv csources_v1-$_c1version $build_wrksrc/csources_v1
 	mkdir $build_wrksrc/dist
 	mv nimble-$_nimbleversion $build_wrksrc/dist/nimble
-	mv fusion-$_fusionversion $build_wrksrc/dist/fusion
 }
 
 do_build() {
-	cd csources
 	case "$XBPS_TARGET_MACHINE" in
 		i686*)
 			CC=cc LD=cc CFLAGS="-Os -pipe" LDFLAGS= \
-			sh build.sh --cpu i686;;
+			make -C csources_v1 ucpu=i686 ${makejobs};;
 		*)
-			CC=cc LD=cc CFLAGS="-Os -pipe" LDFLAGS= sh build.sh;;
+			CC=cc LD=cc CFLAGS="-Os -pipe" LDFLAGS= \
+			make -C csources_v1 ${makejobs};;
 	esac
-	cd ..
 
 	bin/nim c koch
 	./koch boot -d:release -d:danger
@@ -54,32 +48,15 @@ do_build() {
 
 	case "$XBPS_TARGET_MACHINE"
 	in arm*|aarch64*|ppc*)
-		ed config/nim.cfg <<-EDIT
-			,s/^arm.linux.gcc.exe .*/arm.linux.gcc.exe = "$CC"/
-			,s/^arm.linux.gcc.linkerexe .*/arm.linux.gcc.linkerexe = "$CC"/
-			a
-			arm64.linux.gcc.exe = "$CC"
-			arm64.linux.gcc.linkerexe = "$CC"
-			powerpc.linux.gcc.exe = "$CC"
-			powerpc.linux.gcc.linkerexe = "$CC"
-			powerpc64.linux.gcc.exe = "$CC"
-			powerpc64.linux.gcc.linkerexe = "$CC"
-			powerpc64el.linux.gcc.exe = "$CC"
-			powerpc64el.linux.gcc.linkerexe = "$CC"
-			.
-			w
-			q
+		vsed -i config/nim.cfg -e 's/^arm\.linux\.gcc\.\(linker\)\?exe /#&/'
+		cat >>config/nim.cfg <<-EDIT
+		# VOIDLINUX TEMP
+		$_arch.linux.gcc.exe = "$CC"
+		$_arch.linux.gcc.linkerexe = "$CC"
 		EDIT
 		bin/nim c -d:release -d:danger --os:linux --cpu:$_arch --listCmd compiler/nim
-		for _p in \
-			dist/nimble/src/nimble \
-			tools/nimgrep \
-			nimsuggest/nimsuggest \
-			nimpretty/nimpretty
-		do
-			bin/nim c -d:release --os:linux --cpu:$_arch --listCmd $_p
-			mv $_p bin
-		done
+		./koch tools --os:linux --cpu:$_arch --listCmd
+		vsed -i config/nim.cfg -e '/^# VOIDLINUX TEMP$/,$d'
 	;; *)
 		./koch tools
 	esac
@@ -95,14 +72,13 @@ do_install() {
 	vmkdir usr/bin
 	vmkdir usr/share/nim
 	ln -sf /usr/lib/nim/bin/nim ${DESTDIR}/usr/bin/nim
-	for _f in nimble nimsuggest nimgrep nimpretty; do
+	for _f in nimble nimsuggest nimgrep nimpretty testament; do
 		chmod 0755 bin/$_f
 		cp bin/$_f ${DESTDIR}/usr/lib/nim/bin
 		ln -sf /usr/lib/nim/bin/$_f ${DESTDIR}/usr/bin/$_f
 	done
-	cp -r nimsuggest nimpretty doc examples ${DESTDIR}/usr/lib/nim
+	cp -r nimsuggest nimpretty doc ${DESTDIR}/usr/lib/nim
 	ln -sf /usr/lib/nim/doc ${DESTDIR}/usr/share/nim/doc
-	ln -sf /usr/lib/nim/examples ${DESTDIR}/usr/share/nim/examples
 	ln -sf /usr/lib/nim/nimsuggest ${DESTDIR}/usr/share/nim/nimsuggest
 	ln -sf /usr/lib/nim/nimpretty ${DESTDIR}/usr/share/nim/nimpretty
 	vlicense copying.txt

From f5e658ea39a926d5b2a76f70036e65b9575ab364 Mon Sep 17 00:00:00 2001
From: Henry Naguski <henry@nilsu.org>
Date: Sat, 13 Nov 2021 23:11:21 -0700
Subject: [PATCH 131/288] dolphin-emu: update to 5.0.15445.

---
 srcpkgs/dolphin-emu/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/dolphin-emu/template b/srcpkgs/dolphin-emu/template
index c538c4b97548..35ac6a3910df 100644
--- a/srcpkgs/dolphin-emu/template
+++ b/srcpkgs/dolphin-emu/template
@@ -1,9 +1,9 @@
 # Template file for 'dolphin-emu'
 pkgname=dolphin-emu
-version=5.0.15260
+version=5.0.15445
 revision=1
-_dolphin_commit=207c931a04c8e2629a735bc2b3f36b5c89365ca7
-_mgba_commit=9cccc5197ed73ba0a54f584d3121c27dc97405f5
+_dolphin_commit=db02b50d2ecdfbbc21e19aadc57253c353069f77
+_mgba_commit=40d4c430fc36caeb7ea32fd39624947ed487d2f2
 #Version/hash pair can be found at https://dolphin-emu.org/download/
 archs="x86_64* aarch64* ppc64le* i686*"
 wrksrc="dolphin-${_dolphin_commit}"
@@ -22,8 +22,8 @@ license="GPL-2.0-or-later"
 homepage="http://dolphin-emu.org"
 distfiles="https://github.com/dolphin-emu/dolphin/archive/${_dolphin_commit}.tar.gz
  https://github.com/mgba-emu/mgba/archive/${_mgba_commit}.tar.gz"
-checksum="84b21a6a14cf999e8c2bc44175f549aedaa4bd28a79eaa65afddd72f14905a3a
- d1c9fa071aae747fe1350130a2c69ed618ad52a759b35b119dbb7292252b4a77"
+checksum="19136c7b1bce2ff444e4a611f56268b371f4fa83a3e3ff5f3d9e2dbb34385692
+ 3cabf00a97cf4fb15fe8524b3d02190acdd003f25967cdbbf8de958649b8061b"
 nopie=yes
 
 case "$XBPS_TARGET_MACHINE" in

From e72fbb47796f788f5f3c0c25ca86e9040e24da15 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C3=89rico=20Nogueira?= <erico.erc@gmail.com>
Date: Sat, 4 Dec 2021 01:29:26 -0300
Subject: [PATCH 132/288] ImageMagick: update to 7.1.0.15.

---
 srcpkgs/ImageMagick/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/ImageMagick/template b/srcpkgs/ImageMagick/template
index 4648abfb476c..356015153e80 100644
--- a/srcpkgs/ImageMagick/template
+++ b/srcpkgs/ImageMagick/template
@@ -1,6 +1,6 @@
 # Template file for 'ImageMagick'
 pkgname=ImageMagick
-version=7.1.0.10
+version=7.1.0.15
 revision=1
 _majorver=${version%.*}
 _patchver=${version##*.}
@@ -20,7 +20,7 @@ license="ImageMagick"
 homepage="https://www.imagemagick.org"
 changelog="https://imagemagick.org/script/changelog.php"
 distfiles="https://github.com/ImageMagick/ImageMagick/archive/${_majorver}-${_patchver}.tar.gz"
-checksum=a2139da9a7c2e97f28861dfb18986f1d03435cf72e8ee4cc720a4997b5fa8d66
+checksum=0b0272b8bbdeb31b15c06f75764b93b22198453ef7fceabbc07655e90f3c73c2
 
 subpackages="libmagick libmagick-devel"
 

From d3f54122c786c4c041d2d2d058c1e98be717a7ec Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sat, 4 Dec 2021 08:20:48 -0500
Subject: [PATCH 133/288] maturin: update to 0.12.3.

---
 srcpkgs/maturin/patches/edition2018.patch | 18 ------------------
 srcpkgs/maturin/template                  |  4 ++--
 2 files changed, 2 insertions(+), 20 deletions(-)
 delete mode 100644 srcpkgs/maturin/patches/edition2018.patch

diff --git a/srcpkgs/maturin/patches/edition2018.patch b/srcpkgs/maturin/patches/edition2018.patch
deleted file mode 100644
index 7e6b267507b4..000000000000
--- a/srcpkgs/maturin/patches/edition2018.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Void can't yet compile with edition2021 and there seems to be no reason to
-demand it, so partially revert
-
-    https://github.com/PyO3/maturin/commit/4d51112a18a331248bb36c0cb5b4c60c6fe0091a
-
-and make maturin work.
-
---- a/Cargo.toml
-+++ b/Cargo.toml
-@@ -10,7 +10,7 @@
- license = "MIT OR Apache-2.0"
- keywords = ["python", "cffi", "packaging", "pypi", "pyo3"]
- categories = ["api-bindings", "development-tools::ffi", "command-line-utilities"]
--edition = "2021"
-+edition = "2018"
- 
- [badges]
- travis-ci = { repository = "PyO3/maturin" }
diff --git a/srcpkgs/maturin/template b/srcpkgs/maturin/template
index d5eb458e50a5..1556fa8f98c2 100644
--- a/srcpkgs/maturin/template
+++ b/srcpkgs/maturin/template
@@ -1,6 +1,6 @@
 # Template file for 'maturin'
 pkgname=maturin
-version=0.12.2
+version=0.12.3
 revision=1
 build_style=cargo
 build_helper=qemu
@@ -17,7 +17,7 @@ homepage="https://github.com/PyO3/maturin"
 # bump target-lexicon version if it changes in Cargo.lock
 distfiles="${homepage}/archive/v${version}.tar.gz
  https://github.com/bytecodealliance/target-lexicon/archive/v0.12.2.tar.gz>target-lexicon-${version}.tar.gz"
-checksum="d66d21703a78d71061b279b97fb7dd15a925474da19bce9928d87f1c22550ed6
+checksum="9a6ee17bdee33aa319941ca5000016397a2d5343a17341406150c4015aa81b75
  b6c2ddab7498cf6eab8e637a5b7895f3170b2f9ef989861d1ff33af6c8459b27"
 # Tests use unstable features and fail to build
 make_check=no

From 35a162efeac1dd643b507f805504df2bda263292 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sat, 4 Dec 2021 08:20:59 -0500
Subject: [PATCH 134/288] python3-setuptools-rust: update to 1.1.1.

---
 srcpkgs/python3-setuptools-rust/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-setuptools-rust/template b/srcpkgs/python3-setuptools-rust/template
index 85c562f33602..1811ad4be88e 100644
--- a/srcpkgs/python3-setuptools-rust/template
+++ b/srcpkgs/python3-setuptools-rust/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-setuptools-rust'
 pkgname=python3-setuptools-rust
-version=1.0.0
+version=1.1.1
 revision=1
 wrksrc="${pkgname#python3-}-${version}"
 build_style=python3-module
@@ -13,7 +13,7 @@ license="MIT"
 homepage="https://github.com/PyO3/setuptools-rust"
 changelog="https://raw.githubusercontent.com/PyO3/setuptools-rust/master/CHANGELOG.md"
 distfiles="${PYPI_SITE}/s/setuptools-rust/setuptools-rust-${version}.tar.gz"
-checksum=eb6e6d41f01e63d042288e5c609684adf93426c10ea745ec324263f3fcbf27e9
+checksum=dc04afb52a70e56f5d6800a7ed9c45ad5937ba95e51a042b9096459edc038ad6
 # Tests have unpackaged dependencies
 make_check=no
 

From 63193f25bbac558ff28d61e8a6985badf034ebca Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sat, 4 Dec 2021 08:22:34 -0500
Subject: [PATCH 135/288] python3-adblock: update to 0.5.1.

---
 srcpkgs/python3-adblock/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-adblock/template b/srcpkgs/python3-adblock/template
index 0d8832be8111..f24a681be0b9 100644
--- a/srcpkgs/python3-adblock/template
+++ b/srcpkgs/python3-adblock/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-adblock'
 pkgname=python3-adblock
-version=0.5.0
-revision=2
+version=0.5.1
+revision=1
 wrksrc="${pkgname/python3/python}-${version}"
 build_style=python3-pep517
 build_helper="rust"
@@ -16,7 +16,7 @@ license="Apache-2.0, MIT"
 homepage="https://github.com/ArniDagur/python-adblock"
 changelog="https://raw.githubusercontent.com/ArniDagur/python-adblock/master/CHANGELOG.md"
 distfiles="${homepage}/archive/${version}.tar.gz"
-checksum=35ab20170bcfe447efee4d988508d99477cc23b95a901383bf606ca2960148a3
+checksum=d24ef42c8532cab2970d1c3af116ee4d0fa595e23fbeabb3ba0f5dfa0a67eae1
 
 case "$XBPS_TARGET_MACHINE" in
 	i686*) broken="compiler throws SIGABRT on the psl crate" ;;

From 550a79b0bf9d585e64bd36e17edfdaca7d5d9080 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sat, 4 Dec 2021 08:29:12 -0500
Subject: [PATCH 136/288] python3-hypothesis: update to 6.30.0.

---
 srcpkgs/python3-hypothesis/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-hypothesis/template b/srcpkgs/python3-hypothesis/template
index 460af8b6cc06..9c88772dc4e8 100644
--- a/srcpkgs/python3-hypothesis/template
+++ b/srcpkgs/python3-hypothesis/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-hypothesis'
 pkgname=python3-hypothesis
-version=6.28.0
+version=6.30.0
 revision=1
 wrksrc="hypothesis-hypothesis-python-${version}"
 build_wrksrc=hypothesis-python
@@ -15,7 +15,7 @@ license="MPL-2.0"
 homepage="https://hypothesis.works/"
 changelog="https://hypothesis.readthedocs.io/en/latest/changes.html"
 distfiles="https://github.com/HypothesisWorks/hypothesis/archive/hypothesis-python-${version}.tar.gz"
-checksum=34a4e30f9a0a88bb48c2faf6d78512fb7978e03e152026e00210245b20356d70
+checksum=d10473a0b5a87eadd8e978067e4e18215cc69f40c1fdcaeedcd0ef89648c8f61
 
 do_check() {
 	# Manually run the tests that tox considers part of the "full" suite,

From b68ade834925d9d448d29450a0931ee864764208 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sat, 4 Dec 2021 08:30:22 -0500
Subject: [PATCH 137/288] python3-imageio: update to 2.13.1.

---
 srcpkgs/python3-imageio/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-imageio/template b/srcpkgs/python3-imageio/template
index 21b0e0981e11..00e60a63af44 100644
--- a/srcpkgs/python3-imageio/template
+++ b/srcpkgs/python3-imageio/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-imageio'
 pkgname=python3-imageio
-version=2.12.0
+version=2.13.1
 revision=1
 wrksrc="${pkgname#python3-}-${version}"
 build_style=python3-module
@@ -16,7 +16,7 @@ maintainer="Andrew J. Hesford <ajh@sideband.org>"
 license="BSD-2-Clause"
 homepage="https://github.com/imageio/imageio"
 distfiles="${homepage}/archive/v${version}.tar.gz"
-checksum=e7d1e7b135415db608f32c2feebd139afb9b8379dd4e49c661578f999dfc2cea
+checksum=00c843712d00d075a87bc9eb37c1b6ffe2b210327d8fbaabd52759a961b5b4bd
 
 post_install() {
 	vlicense LICENSE

From 3d9cca6362f98f4793a8977868a9f97a81386731 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sat, 4 Dec 2021 08:31:58 -0500
Subject: [PATCH 138/288] python3-ipython: update to 7.30.1.

---
 srcpkgs/python3-ipython/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-ipython/template b/srcpkgs/python3-ipython/template
index 85a1ae2e64c5..f2eed91a2d1f 100644
--- a/srcpkgs/python3-ipython/template
+++ b/srcpkgs/python3-ipython/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-ipython'
 pkgname=python3-ipython
-version=7.30.0
+version=7.30.1
 revision=1
 wrksrc="ipython-${version}"
 build_style=python3-module
@@ -16,7 +16,7 @@ maintainer="Andrew J. Hesford <ajh@sideband.org>"
 license="BSD-3-Clause"
 homepage="https://ipython.org/"
 distfiles="${PYPI_SITE}/i/ipython/ipython-${version}.tar.gz"
-checksum=d41f8e80b99690122400f9b2069b12f670246a1b4cc5d332bd6c4e2500e6d6fb
+checksum=cb6aef731bf708a7727ab6cde8df87f0281b1427d41e65d62d4b68934fa54e97
 conflicts="python-ipython<=5.8.0_2"
 
 do_check() {

From d0d30c4e9613ec08bff842a5e28bcebd04c32560 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sat, 4 Dec 2021 08:46:54 -0500
Subject: [PATCH 139/288] python3-parso: update to 0.8.3.

---
 srcpkgs/python3-parso/template | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-parso/template b/srcpkgs/python3-parso/template
index 5fb79d8baaad..16b67897a9d7 100644
--- a/srcpkgs/python3-parso/template
+++ b/srcpkgs/python3-parso/template
@@ -1,9 +1,11 @@
 # Template file for 'python3-parso'
 pkgname=python3-parso
-version=0.8.2
-revision=2
+version=0.8.3
+revision=1
 wrksrc="parso-${version}"
 build_style=python3-module
+# Several error messages changed form and trigger inappropriate failures
+make_check_args="--ignore=test/test_python_errors.py"
 hostmakedepends="python3-setuptools"
 depends="python3"
 checkdepends="python3-pytest"
@@ -12,7 +14,7 @@ maintainer="Andrew J. Hesford <ajh@sideband.org>"
 license="MIT"
 homepage="https://github.com/davidhalter/parso"
 distfiles="${PYPI_SITE}/p/parso/parso-${version}.tar.gz"
-checksum=12b83492c6239ce32ff5eed6d3639d6a536170723c6f3f1506869f1ace413398
+checksum=8c07be290bb59f03588915921e29e8a50002acaf2cdc5fa0e0114f91709fafa0
 
 post_install() {
 	vlicense LICENSE.txt

From 7f7ceb2bb0d307555e49a7b2bf0e2d784f6a6ffb Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sat, 4 Dec 2021 09:21:39 -0500
Subject: [PATCH 140/288] python3-scikit-image: update to 0.19.0.

---
 .../patches/no-pythran.patch                  | 60 +++++++++++++++++++
 srcpkgs/python3-scikit-image/template         | 13 ++--
 2 files changed, 67 insertions(+), 6 deletions(-)
 create mode 100644 srcpkgs/python3-scikit-image/patches/no-pythran.patch

diff --git a/srcpkgs/python3-scikit-image/patches/no-pythran.patch b/srcpkgs/python3-scikit-image/patches/no-pythran.patch
new file mode 100644
index 000000000000..a2a1bf479ead
--- /dev/null
+++ b/srcpkgs/python3-scikit-image/patches/no-pythran.patch
@@ -0,0 +1,60 @@
+Disable optional Pythran support that is hard-required during build.
+
+--- a/setup.py
++++ b/setup.py
+@@ -6,7 +6,7 @@
+ import shutil
+ import builtins
+ import textwrap
+-from numpy.distutils.command.build_ext import build_ext as npy_build_ext
++from numpy.distutils.command.build_ext import build_ext
+ 
+ import setuptools
+ from setuptools.command.build_py import build_py
+@@ -17,7 +17,13 @@
+     # can remove this except case once we require setuptools>=59.0
+     from distutils.errors import CompileError, LinkError
+ 
+-from pythran.dist import PythranBuildExt as pythran_build_ext
++try:
++    from pythran.dist import PythranBuildExt as pythran_build_ext
++except ImportError:
++    pass
++else:
++    # Replace numpy extension builder with pythran version
++    build_ext = pythran_build_ext[build_ext]
+ 
+ DISTNAME = 'scikit-image'
+ DESCRIPTION = 'Image processing in Python'
+@@ -60,7 +66,7 @@
+ 
+ # Support for openmp
+ 
+-class ConditionalOpenMP(pythran_build_ext[npy_build_ext]):
++class ConditionalOpenMP(build_ext):
+ 
+     def can_compile_link(self, compile_flags, link_flags):
+ 
+--- a/skimage/feature/setup.py
++++ b/skimage/feature/setup.py
+@@ -2,7 +2,7 @@
+ 
+ import os
+ from skimage._build import cython
+-import pythran, logging
++import logging
+ 
+ base_path = os.path.abspath(os.path.dirname(__file__))
+ 
+@@ -43,6 +43,11 @@
+     config.add_extension('_sift', sources=['_sift.c'],
+                          include_dirs=[get_numpy_include_dirs(), '../_shared'])
+ 
++    try:
++        import pythran
++    except ImportError:
++        return config
++
+     # pythran submodules
+     pythran.config.logger.setLevel(logging.INFO)
+     ext = pythran.dist.PythranExtension(
diff --git a/srcpkgs/python3-scikit-image/template b/srcpkgs/python3-scikit-image/template
index 49b214c11aef..b1d87f9d2c26 100644
--- a/srcpkgs/python3-scikit-image/template
+++ b/srcpkgs/python3-scikit-image/template
@@ -1,21 +1,22 @@
 # Template file for 'python3-scikit-image'
 pkgname=python3-scikit-image
-version=0.18.3
-revision=2
+version=0.19.0
+revision=1
 _pkgname="${pkgname#python3-}"
 wrksrc="${_pkgname}-${version}"
 build_style=python3-module
 build_helper="numpy"
-hostmakedepends="python3-setuptools python3-Cython"
+hostmakedepends="python3-Cython python3-wheel python3-numpy
+ python3-packaging python3-setuptools"
 makedepends="python3-devel"
-depends="python3-scipy python3-matplotlib python3-networkx
- python3-imageio python3-tifffile python3-pywt"
+depends="python3-scipy python3-numpy python3-imageio python3-matplotlib
+ python3-networkx python3-tifffile python3-pywt python3-packaging"
 short_desc="Image processing in Python"
 maintainer="Andrew J. Hesford <ajh@sideband.org>"
 license="BSD-3-Clause, MIT"
 homepage="https://scikit-image.org/"
 distfiles="https://github.com/${_pkgname}/${_pkgname}/archive/v${version}.tar.gz"
-checksum=a8d1c7473fc9399447a4cd5718c90338fffd543622d9e6f3d9feca43f1a9cb15
+checksum=5a0d6ad80ed3a389c19a8603391bbc1dd8e81239c2ef5ca6c274886db3087ec5
 # Tests require data files and unpackaged dependencies
 make_check=no
 

From e4b99a6d0933b994a0bdc98bc41f4133e8e27adc Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Sat, 4 Dec 2021 18:02:09 +0100
Subject: [PATCH 141/288] alpine: update to 2.25.1.

---
 srcpkgs/alpine/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/alpine/template b/srcpkgs/alpine/template
index 6fdbf75afcaf..2ab186c938af 100644
--- a/srcpkgs/alpine/template
+++ b/srcpkgs/alpine/template
@@ -1,8 +1,8 @@
 # Template file for 'alpine'
 pkgname=alpine
-version=2.25
+version=2.25.1
 revision=1
-_githash=465e23b898e5a3393b9ae52fc7620002541b2e75
+_githash=a4717516707498544201c2e03286142c9abb2539
 _gitshort="${_githash:0:7}"
 wrksrc="${pkgname}-${_gitshort}"
 build_style=gnu-configure
@@ -17,7 +17,7 @@ maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="Apache-2.0"
 homepage="https://repo.or.cz/alpine.git"
 distfiles="https://repo.or.cz/alpine.git/snapshot/${_githash}.tar.gz"
-checksum=ba0856bcc863b70dd0c2f06cdeda720332c2d136d49154d78450932cd9e0900a
+checksum=e1855467f8dbf21879e3a6fa959998ffb68a6d5221ee7d6cc2fc3de95ee0759a
 
 post_extract() {
 	sed -i -e '/run test program/s/^/: /' \

From ec796952b29b3f1dffb524433b8b8ebeafa5a6bc Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Sat, 4 Dec 2021 18:02:10 +0100
Subject: [PATCH 142/288] netpbm: update to 10.96.04.

---
 srcpkgs/netpbm/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/netpbm/template b/srcpkgs/netpbm/template
index a1fb5f6d9966..f49b1bb66e5f 100644
--- a/srcpkgs/netpbm/template
+++ b/srcpkgs/netpbm/template
@@ -1,10 +1,10 @@
 # Template file for 'netpbm'
 pkgname=netpbm
 # from http://svn.code.sf.net/p/netpbm/code/advanced/doc/HISTORY
-version=10.96.03
+version=10.96.04
 revision=1
-_githash=54081f1e108cb4a385f951cbc293368829e39320
-_githash_guide=54910a3304543a702b0720c3b9c6d6be4ba12100
+_githash=3c556d3931167936ef5bfb3ba1ff569049aa1b87
+_githash_guide=913c540e85e33b07c2dbc551ef4092126ab3ed55
 create_wrksrc=yes
 build_wrksrc="netpbm-mirror-${_githash}"
 hostmakedepends="pkg-config perl python flex"
@@ -16,8 +16,8 @@ license="BSD-3-Clause,GPL-2.0-only,custom:netpbm"
 homepage="http://netpbm.sourceforge.net/"
 distfiles="https://github.com/leahneukirchen/netpbm-mirror/archive/${_githash}.tar.gz
  https://github.com/leahneukirchen/netpbm-mirror/archive/${_githash_guide}.tar.gz"
-checksum="b2184c438d2e9e7a7f99123196719b8a1d1d55a7d28607afb4842ba1ab550cbc
- b966580dcf5d72fc6a3cfa6c95d46206b9b4c252ec911e14633113c45cb49626"
+checksum="c65fcad80229c8ac2999a6ee10709c8ee4f1f73995e0a4423029250c21233756
+ 74ae5c9df00f1654eea60913cd11e7347df111032afc09b315b0567b54bf0b8f"
 
 post_extract() {
 	cd $build_wrksrc

From 8bb9c94d31707e8e7c75e18463426b4eb4f67b72 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Sat, 4 Dec 2021 18:02:12 +0100
Subject: [PATCH 143/288] ldns: update to 1.8.1.

---
 srcpkgs/ldns/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/ldns/template b/srcpkgs/ldns/template
index 376777cfc423..4e7bcd1f2154 100644
--- a/srcpkgs/ldns/template
+++ b/srcpkgs/ldns/template
@@ -1,7 +1,7 @@
 # Template file for 'ldns'
 pkgname=ldns
-version=1.7.1
-revision=5
+version=1.8.1
+revision=1
 build_style=gnu-configure
 configure_args="--with-drill --with-examples --disable-dane-ta-usage
  --with-trust-anchor=/etc/dns/root.key
@@ -13,7 +13,7 @@ maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="BSD-3-Clause"
 homepage="http://www.nlnetlabs.nl/projects/ldns/"
 distfiles="http://www.nlnetlabs.nl/downloads/${pkgname}/${pkgname}-${version}.tar.gz"
-checksum=8ac84c16bdca60e710eea75782356f3ac3b55680d40e1530d7cea474ac208229
+checksum=958229abce4d3aaa19a75c0d127666564b17216902186e952ca4aef47c6d7fa3
 
 post_install() {
 	vsed -i -e "s|\(-specs=.*hardened-ld\)||g" -e "s|\(-specs=.*hardened-cc1\)||g" ${DESTDIR}/usr/bin/ldns-config

From a1b741eab3282bc949ba92fc53523f5516af8e9b Mon Sep 17 00:00:00 2001
From: Demedim <40205709+Demedim@users.noreply.github.com>
Date: Sat, 4 Dec 2021 13:05:40 +0100
Subject: [PATCH 144/288] aircrack-ng: add libcap to enable more utilities

Closes: #34380 [via git-merge-pr]
---
 srcpkgs/aircrack-ng/patches/getopt.patch | 14 ++++++++++++++
 srcpkgs/aircrack-ng/template             |  4 ++--
 2 files changed, 16 insertions(+), 2 deletions(-)
 create mode 100644 srcpkgs/aircrack-ng/patches/getopt.patch

diff --git a/srcpkgs/aircrack-ng/patches/getopt.patch b/srcpkgs/aircrack-ng/patches/getopt.patch
new file mode 100644
index 000000000000..7f57f30e6a3c
--- /dev/null
+++ b/srcpkgs/aircrack-ng/patches/getopt.patch
@@ -0,0 +1,14 @@
+argv[1] is a file name argument, musl getopt_long will permute it
+to a later position, so skip it for argument parsing.
+
+--- aircrack-ng-1.6/src/airolib-ng/airolib-ng.c.orig
++++ aircrack-ng-1.6/src/airolib-ng/airolib-ng.c
+@@ -1309,7 +1309,7 @@
+ 	signal(SIGTERM, sighandler);
+ 
+ 	option = getopt_long(
+-		argc, argv, "bc:d:e:hi:s:t:v:", long_options, &option_index);
++		argc-1, argv+1, "bc:d:e:hi:s:t:v:", long_options, &option_index);
+ 
+ 	if (option > 0)
+ 	{
diff --git a/srcpkgs/aircrack-ng/template b/srcpkgs/aircrack-ng/template
index 604bcefb5a34..ef5d46cebac1 100644
--- a/srcpkgs/aircrack-ng/template
+++ b/srcpkgs/aircrack-ng/template
@@ -1,10 +1,10 @@
 # Template file for 'aircrack-ng'
 pkgname=aircrack-ng
 version=1.6
-revision=3
+revision=4
 build_style=gnu-configure
 hostmakedepends="automake libtool pkg-config"
-makedepends="libnl3-devel openssl-devel sqlite-devel zlib-devel"
+makedepends="libnl3-devel openssl-devel sqlite-devel zlib-devel libcap-devel"
 short_desc="Complete suite of tools to assess WiFi network security"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="GPL-2.0-or-later, BSD-3-Clause, OpenSSL"

From bc275dfa7a39d52cc3cca7fe7855d629cf72fd48 Mon Sep 17 00:00:00 2001
From: UsernameRandomlyGenerated <overtwist_wt@aleeas.com>
Date: Sat, 4 Dec 2021 12:01:57 +0100
Subject: [PATCH 145/288] foot: update to 1.10.2.

---
 srcpkgs/foot/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/foot/template b/srcpkgs/foot/template
index b3cc9af397a9..3e5a04bfc7bb 100644
--- a/srcpkgs/foot/template
+++ b/srcpkgs/foot/template
@@ -1,6 +1,6 @@
 # Template file for 'foot'
 pkgname=foot
-version=1.10.1
+version=1.10.2
 revision=1
 wrksrc=$pkgname
 build_style=meson
@@ -15,7 +15,7 @@ license="MIT"
 homepage="https://codeberg.org/dnkl/foot"
 changelog="https://codeberg.org/dnkl/foot/src/branch/master/CHANGELOG.md"
 distfiles="${homepage}/archive/${version}.tar.gz"
-checksum=40aaf4ba96aa0cc977b7c3916b79fd5455cefea76c5c07cad43ff7aaf06fc1bd
+checksum=49ad179d5815bf76f8ccdd869b28ce56e3cb5aab8e73e45b09c7510d4a5086d7
 
 post_install() {
 	rm -f ${DESTDIR}/usr/share/doc/foot/LICENSE

From 7442167e5b17eda6a9e5550c81a0ba0eb146d5af Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Sat, 4 Dec 2021 21:13:54 +0100
Subject: [PATCH 146/288] New package: cmark-gfm-0.29.0.gfm.2

add comment about patch purpose

fix typo
---
 srcpkgs/cmark-gfm-devel                |  1 +
 srcpkgs/cmark-gfm/template             | 34 ++++++++++++++++++++++++++
 srcpkgs/lumina/patches/checkpass.patch |  2 +-
 3 files changed, 36 insertions(+), 1 deletion(-)
 create mode 120000 srcpkgs/cmark-gfm-devel
 create mode 100644 srcpkgs/cmark-gfm/template

diff --git a/srcpkgs/cmark-gfm-devel b/srcpkgs/cmark-gfm-devel
new file mode 120000
index 000000000000..bad5a89ab151
--- /dev/null
+++ b/srcpkgs/cmark-gfm-devel
@@ -0,0 +1 @@
+cmark-gfm
\ No newline at end of file
diff --git a/srcpkgs/cmark-gfm/template b/srcpkgs/cmark-gfm/template
new file mode 100644
index 000000000000..ebd19864cedc
--- /dev/null
+++ b/srcpkgs/cmark-gfm/template
@@ -0,0 +1,34 @@
+# Template file for 'cmark-gfm'
+pkgname=cmark-gfm
+version=0.29.0.gfm.2
+revision=1
+build_style=cmake
+short_desc="GitHub's fork of cmark, a CommonMark markdown renderer"
+maintainer="Leah Neukirchen <leah@vuxu.org>"
+license="MIT"
+homepage="https://github.com/github/cmark-gfm"
+distfiles="https://github.com/github/cmark-gfm/archive/${version}.tar.gz"
+checksum=66d92c8bef533744674c5b64d8744227584b12704bcfebbe16dab69f81e62029
+
+pre_configure() {
+	# Fix the SONAME version to use just the major number
+	vsed -i -e 's;\(SOVERSION ${PROJECT_VERSION_MAJOR}\).*;\1;' \
+		 src/CMakeLists.txt extensions/CMakeLists.txt
+}
+
+post_install() {
+	vlicense COPYING
+}
+
+cmark-gfm-devel_package() {
+	depends="${sourcepkg}>=${version}_${revision}"
+	short_desc+=" - development files"
+	pkg_install() {
+		vmove usr/include
+		vmove "usr/lib/*.so"
+		vmove "usr/lib/*.a"
+		vmove usr/lib/pkgconfig
+		vmove usr/lib/cmake
+		vmove usr/share/man/man3
+	}
+}
diff --git a/srcpkgs/lumina/patches/checkpass.patch b/srcpkgs/lumina/patches/checkpass.patch
index cb1f3c19e7ba..a31d0fa8bb17 100644
--- a/srcpkgs/lumina/patches/checkpass.patch
+++ b/srcpkgs/lumina/patches/checkpass.patch
@@ -1,4 +1,4 @@
-Force the "bin" path to avoid conflicts with Void pkg-src lint checks
+Force the "bin" path to avoid conflicts with Void xbps-src lint checks
 --- a/src-qt5/core/lumina-checkpass/lumina-checkpass.pro
 +++ b/src-qt5/core/lumina-checkpass/lumina-checkpass.pro
 @@ -6,13 +6,13 @@ QT =

From 6febece4b24b3460895b826403fa6b1d0bb39e51 Mon Sep 17 00:00:00 2001
From: Andrew Benson <abenson+void@gmail.com>
Date: Sun, 28 Nov 2021 11:16:36 -0600
Subject: [PATCH 147/288] Amass: update to 3.15.1.

---
 srcpkgs/Amass/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/Amass/template b/srcpkgs/Amass/template
index 71ee291c99e6..f78e2f70cf12 100644
--- a/srcpkgs/Amass/template
+++ b/srcpkgs/Amass/template
@@ -1,6 +1,6 @@
 # Template file for 'Amass'
 pkgname=Amass
-version=3.15.0
+version=3.15.1
 revision=1
 build_style=go
 go_import_path="github.com/OWASP/Amass/v3/..."
@@ -9,7 +9,7 @@ maintainer="Andrew Benson <abenson+void@gmail.com>"
 license="Apache-2.0"
 homepage="https://www.owasp.org/index.php/OWASP_Amass_Project"
 distfiles="https://github.com/OWASP/Amass/archive/v${version}.tar.gz"
-checksum=084ddbc8171e354abee3098458064fbcc9db059a25c4845dfc151803833df2dd
+checksum=217f5f0fed02d730543a56b58f1be3ec0fb07e57b3ace53fc673c6d0132f36a8
 
 post_install() {
 	rm ${DESTDIR}/usr/bin/examples

From 9483da0fe85267ad4ae6c0f8f5ac9c4e78c6af8d Mon Sep 17 00:00:00 2001
From: Andrew Benson <abenson+void@gmail.com>
Date: Sun, 28 Nov 2021 11:19:21 -0600
Subject: [PATCH 148/288] python3-httpx: update to 0.21.1.

---
 srcpkgs/python3-httpx/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-httpx/template b/srcpkgs/python3-httpx/template
index 5c99c9208213..55f843ed478c 100644
--- a/srcpkgs/python3-httpx/template
+++ b/srcpkgs/python3-httpx/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-httpx'
 pkgname=python3-httpx
-version=0.21.0
+version=0.21.1
 revision=1
 wrksrc="httpx-${version}"
 build_style=python3-module
@@ -14,7 +14,7 @@ license="BSD-3-Clause"
 homepage="https://www.python-httpx.org"
 changelog="https://raw.githubusercontent.com/encode/httpx/master/CHANGELOG.md"
 distfiles="${PYPI_SITE}/h/httpx/httpx-${version}.tar.gz"
-checksum=5ae1d9deb30fe074596551b3ab98f94dfd9d7efe3ecd2d08662a5c29f6fba0e4
+checksum=02af20df486b78892a614a7ccd4e4e86a5409ec4981ab0e422c579a887acad83
 # the pypi tarball doesn't contain tests
 # the tests need unpackaged dependencies trustme and uvicorn
 make_check=no

From 5a86c52881e0ce41adb3b5d8a2e88102fe07daba Mon Sep 17 00:00:00 2001
From: Andrew Benson <abenson+void@gmail.com>
Date: Sun, 28 Nov 2021 11:19:24 -0600
Subject: [PATCH 149/288] python3-youtubesearch: update to 1.5.2.

---
 srcpkgs/python3-youtubesearch/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-youtubesearch/template b/srcpkgs/python3-youtubesearch/template
index c284178a44a8..8319d620097d 100644
--- a/srcpkgs/python3-youtubesearch/template
+++ b/srcpkgs/python3-youtubesearch/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-youtubesearch'
 pkgname=python3-youtubesearch
-version=1.5.1
+version=1.5.2
 revision=1
 wrksrc="youtube-search-python-${version}"
 build_style=python3-module
@@ -11,7 +11,7 @@ maintainer="Andrew Benson <abenson+void@gmail.com>"
 license="MIT"
 homepage="https://github.com/alexmercerind/youtube-search-python"
 distfiles="${homepage}/archive/refs/tags/v${version}.tar.gz"
-checksum=485825a741ef5e7c327eaf65b27f7ffd7d10e218072a972012ff3301c2d7c488
+checksum=6094c819b195de0ef7363e76594b5c34479438a45e72c1e9f763cd9cf17a64ea
 make_check=no # no tests defined
 
 post_install() {

From 0283d5c8b27895fd16651c9cfe8d90e90c508d65 Mon Sep 17 00:00:00 2001
From: Andrew Benson <abenson+void@gmail.com>
Date: Sun, 28 Nov 2021 11:23:29 -0600
Subject: [PATCH 150/288] mongo-c-driver: update to 1.20.0.

---
 srcpkgs/mongo-c-driver/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/mongo-c-driver/template b/srcpkgs/mongo-c-driver/template
index ee79f2e3d329..b3eec27c4bab 100644
--- a/srcpkgs/mongo-c-driver/template
+++ b/srcpkgs/mongo-c-driver/template
@@ -1,6 +1,6 @@
 # Template file for 'mongo-c-driver'
 pkgname=mongo-c-driver
-version=1.19.2
+version=1.20.0
 revision=1
 build_style=cmake
 configure_args="-DENABLE_TESTS=OFF"
@@ -11,7 +11,7 @@ maintainer="Andrew Benson <abenson+void@gmail.com>"
 license="Apache-2.0"
 homepage="https://mongoc.org"
 distfiles="https://github.com/mongodb/mongo-c-driver/releases/download/${version}/mongo-c-driver-${version}.tar.gz"
-checksum=b6feb4fd65423140cdee02df392cd9db2bb459731e992a5385afa554a7515762
+checksum=a97242866212bdcf9dfb8030b31a32eef9ff83082b34e1027339c805a3c50b0d
 
 mongo-c-driver-devel_package() {
 	short_desc+=" - development files"

From 5bf69adabf8821333839571649bc165f9e9e45c9 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Sat, 27 Nov 2021 14:45:12 +0100
Subject: [PATCH 151/288] libuninameslist: update to 20211114.

---
 srcpkgs/libuninameslist/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/libuninameslist/template b/srcpkgs/libuninameslist/template
index a7e509d4b0b5..8b97662a4a31 100644
--- a/srcpkgs/libuninameslist/template
+++ b/srcpkgs/libuninameslist/template
@@ -1,6 +1,6 @@
 # Template file for 'libuninameslist'
 pkgname=libuninameslist
-version=20210917
+version=20211114
 revision=1
 build_style=gnu-configure
 hostmakedepends="automake libtool"
@@ -9,7 +9,7 @@ maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="BSD-3-Clause"
 homepage="https://github.com/fontforge/libuninameslist"
 distfiles="https://github.com/fontforge/libuninameslist/archive/${version}.tar.gz"
-checksum=7d60ea37813590c9d319d53aaac831fedf8067c980167877bc5daa351b378031
+checksum=c089c6164f2cef361c3419a07408be72d6b58d6ef224ec226724a9fa93c0d46e
 
 pre_configure() {
 	autoreconf -fi

From 60ee21e9dbb2e5044f6638ee6411c2b82c0e8686 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Sat, 27 Nov 2021 14:47:22 +0100
Subject: [PATCH 152/288] libtls: update to 3.4.2.

---
 srcpkgs/libtls/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/libtls/template b/srcpkgs/libtls/template
index 3a0922788b7e..42f33db208a6 100644
--- a/srcpkgs/libtls/template
+++ b/srcpkgs/libtls/template
@@ -1,6 +1,6 @@
 # Template file for 'libtls'
 pkgname=libtls
-version=3.4.1
+version=3.4.2
 revision=1
 wrksrc="libressl-${version}"
 build_style=gnu-configure
@@ -13,7 +13,7 @@ license="OpenSSL, ISC"
 homepage="http://www.libressl.org/"
 changelog="https://raw.githubusercontent.com/libressl-portable/portable/master/ChangeLog"
 distfiles="http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-${version}.tar.gz"
-checksum=107ceae6ca800e81cb563584c16afa36d6c7138fade94a2b3e9da65456f7c61c
+checksum=cb82ca7d547336917352fbd23db2fc483c6c44d35157b32780214ec74197b3ce
 _lssl_asm_ver="1.2.0"
 replaces="libtls20>0"
 

From 3076ca4fc7ccba59e9f97e434bf100b1b3f2f76d Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Sat, 27 Nov 2021 15:04:23 +0100
Subject: [PATCH 153/288] crash: update to 8.0.0.

---
 srcpkgs/crash/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/crash/template b/srcpkgs/crash/template
index 72a0cdd6c36a..82d9a3968c11 100644
--- a/srcpkgs/crash/template
+++ b/srcpkgs/crash/template
@@ -1,10 +1,10 @@
 # Template file for 'crash'
 pkgname=crash
-version=7.3.0
-revision=2
+version=8.0.0
+revision=1
 archs="i686 x86_64"  # broken on musl
 build_style=gnu-makefile
-hostmakedepends="flex tar wget"
+hostmakedepends="flex tar wget texinfo"
 makedepends="lzo-devel ncurses-devel zlib-devel"
 depends="binutils"
 short_desc="Kernel crash dump debugger and live inspector"
@@ -13,7 +13,7 @@ license="GPL-3.0-or-later"
 homepage="https://crash-utility.github.io/"
 changelog="https://crash-utility.github.io/crash.changelog.html"
 distfiles="https://github.com/crash-utility/crash/archive/${version}.tar.gz"
-checksum=98d4367ae0ea7d2eda547357a839f7bddee517b588b281574d58a15a418af5b9
+checksum=caab49b7b6d442f60c41360e0ec80cf852dc64e89303b41d704d7661cef43e68
 nocross=yes
 LDFLAGS=-llzo2
 

From 030428b3cb8e0321b9bb1c25f20861a2e79b962f Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Sat, 27 Nov 2021 15:04:29 +0100
Subject: [PATCH 154/288] python3-pipenv: update to 2021.11.23.

---
 srcpkgs/python3-pipenv/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-pipenv/template b/srcpkgs/python3-pipenv/template
index 01863718c2fd..1a8b586387f8 100644
--- a/srcpkgs/python3-pipenv/template
+++ b/srcpkgs/python3-pipenv/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-pipenv'
 pkgname=python3-pipenv
-version=2021.11.15
+version=2021.11.23
 revision=1
 wrksrc="pipenv-${version}"
 build_style=python3-module
@@ -11,7 +11,7 @@ maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="MIT"
 homepage="https://github.com/pypa/pipenv"
 distfiles="${PYPI_SITE}/p/pipenv/pipenv-${version}.tar.gz"
-checksum=616766b1e8dfc24b2e7c6dfbbc8276b7d7ba07e778e5eb0f1b6e59fcd4532fd1
+checksum=1bde859e8bbd1d21d503fd995bc0170048d6da7686ab885f074592c99a16e8f3
 conflicts="python-pipenv>=0"
 
 post_extract() {

From a832fda9e464c08c7c3532a47080da69bc7a84a4 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Sun, 28 Nov 2021 19:50:36 +0100
Subject: [PATCH 155/288] erlang: update to 24.1.7.

---
 srcpkgs/erlang/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/erlang/template b/srcpkgs/erlang/template
index cd7340ad4bcb..c51edbde3e10 100644
--- a/srcpkgs/erlang/template
+++ b/srcpkgs/erlang/template
@@ -1,6 +1,6 @@
 # Template file for 'erlang'
 pkgname=erlang
-version=24.1.6
+version=24.1.7
 revision=1
 create_wrksrc=yes
 build_wrksrc="otp-OTP-${version}"
@@ -14,7 +14,7 @@ license="Apache-2.0"
 homepage="http://www.erlang.org/"
 changelog="https://github.com/erlang/otp/releases"
 distfiles="https://github.com/erlang/otp/archive/OTP-${version}.tar.gz"
-checksum=1b0db74f01f0072299347b794b51d170bf1b71a8f9b6c0aac404ed2c440611ad
+checksum=a1dd1a238f1f3e79784b902f3cd00e06f35a630191eaf73324a07a26a2c93af3
 subpackages="erlang-doc"
 
 if [ -z "$CROSS_BUILD" ]; then

From 7b070452dd3fb6a401b58250bf6c216b41b060d9 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sun, 28 Nov 2021 14:30:45 -0500
Subject: [PATCH 156/288] python3-aiofiles: update to 0.8.0.

---
 srcpkgs/python3-aiofiles/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-aiofiles/template b/srcpkgs/python3-aiofiles/template
index 95660af980b3..d4c6a5445630 100644
--- a/srcpkgs/python3-aiofiles/template
+++ b/srcpkgs/python3-aiofiles/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-aiofiles'
 pkgname=python3-aiofiles
-version=0.7.0
-revision=2
+version=0.8.0
+revision=1
 wrksrc="${pkgname#*-}-${version}"
 build_style=python3-pep517
 hostmakedepends="python3-poetry-core"
@@ -13,7 +13,7 @@ license="Apache-2.0"
 homepage="https://github.com/Tinche/aiofiles"
 changelog="https://raw.githubusercontent.com/Tinche/aiofiles/master/README.rst"
 distfiles="${homepage}/archive/v${version}.tar.gz"
-checksum=2baf8e70f95618214c4910730fd625bfaa4a8b8957838b34364b0a2c7d41db9e
+checksum=1ee866ce57b47e2f5ae2c06c0372458a6eb08131a9b1d7216a234fa0d516d638
 
 do_check() {
 	PYTHONPATH=src python3 -m pytest

From f7954fa991d53e5fd8f86fcd0b52ced07206c577 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sun, 28 Nov 2021 14:37:14 -0500
Subject: [PATCH 157/288] python3-hypothesis: update to 6.28.0.

---
 srcpkgs/python3-hypothesis/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-hypothesis/template b/srcpkgs/python3-hypothesis/template
index 0c4993679d88..460af8b6cc06 100644
--- a/srcpkgs/python3-hypothesis/template
+++ b/srcpkgs/python3-hypothesis/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-hypothesis'
 pkgname=python3-hypothesis
-version=6.27.0
+version=6.28.0
 revision=1
 wrksrc="hypothesis-hypothesis-python-${version}"
 build_wrksrc=hypothesis-python
@@ -15,7 +15,7 @@ license="MPL-2.0"
 homepage="https://hypothesis.works/"
 changelog="https://hypothesis.readthedocs.io/en/latest/changes.html"
 distfiles="https://github.com/HypothesisWorks/hypothesis/archive/hypothesis-python-${version}.tar.gz"
-checksum=91912314804c37a0be3e830426d44341cbf4a751ad92e5bfdad35e434ffffd4a
+checksum=34a4e30f9a0a88bb48c2faf6d78512fb7978e03e152026e00210245b20356d70
 
 do_check() {
 	# Manually run the tests that tox considers part of the "full" suite,

From b66a57aad7eb0350fcd0039e7e36823b55945979 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sun, 28 Nov 2021 14:37:55 -0500
Subject: [PATCH 158/288] python3-prompt_toolkit: update to 3.0.23.

---
 srcpkgs/python3-prompt_toolkit/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-prompt_toolkit/template b/srcpkgs/python3-prompt_toolkit/template
index f7dbc0c33666..ca30e275d05f 100644
--- a/srcpkgs/python3-prompt_toolkit/template
+++ b/srcpkgs/python3-prompt_toolkit/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-prompt_toolkit'
 pkgname=python3-prompt_toolkit
-version=3.0.22
+version=3.0.23
 revision=1
 wrksrc="prompt_toolkit-${version}"
 build_style=python3-module
@@ -13,7 +13,7 @@ license="BSD-3-Clause"
 homepage="https://github.com/prompt-toolkit/python-prompt-toolkit"
 changelog="https://raw.githubusercontent.com/prompt-toolkit/python-prompt-toolkit/master/CHANGELOG"
 distfiles="${PYPI_SITE}/p/prompt_toolkit/prompt_toolkit-${version}.tar.gz"
-checksum=449f333dd120bd01f5d296a8ce1452114ba3a71fae7288d2f0ae2c918764fa72
+checksum=7053aba00895473cb357819358ef33f11aa97e4ac83d38efb123e5649ceeecaf
 conflicts="python3-prompt_toolkit2<=2.0.9_4"
 
 post_install() {

From ee34e3c85556556b82ed29215e563c69ee812107 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sun, 28 Nov 2021 14:39:32 -0500
Subject: [PATCH 159/288] python3-ipython: update to 7.30.0.

---
 srcpkgs/python3-ipython/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-ipython/template b/srcpkgs/python3-ipython/template
index c2a1120bcac4..85a1ae2e64c5 100644
--- a/srcpkgs/python3-ipython/template
+++ b/srcpkgs/python3-ipython/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-ipython'
 pkgname=python3-ipython
-version=7.29.0
+version=7.30.0
 revision=1
 wrksrc="ipython-${version}"
 build_style=python3-module
@@ -16,7 +16,7 @@ maintainer="Andrew J. Hesford <ajh@sideband.org>"
 license="BSD-3-Clause"
 homepage="https://ipython.org/"
 distfiles="${PYPI_SITE}/i/ipython/ipython-${version}.tar.gz"
-checksum=4f69d7423a5a1972f6347ff233e38bbf4df6a150ef20fbb00c635442ac3060aa
+checksum=d41f8e80b99690122400f9b2069b12f670246a1b4cc5d332bd6c4e2500e6d6fb
 conflicts="python-ipython<=5.8.0_2"
 
 do_check() {

From 54c944b83db42243c9e688eba21f3f4c705f44cd Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sun, 28 Nov 2021 14:39:38 -0500
Subject: [PATCH 160/288] zfs-prune-snapshots: update to 1.3.0.

---
 srcpkgs/zfs-prune-snapshots/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/zfs-prune-snapshots/template b/srcpkgs/zfs-prune-snapshots/template
index 08f538004b9e..63cf6ba63a3f 100644
--- a/srcpkgs/zfs-prune-snapshots/template
+++ b/srcpkgs/zfs-prune-snapshots/template
@@ -1,7 +1,7 @@
 # Template file for 'zfs-prune-snapshots'
 pkgname=zfs-prune-snapshots
-version=1.1.0
-revision=3
+version=1.3.0
+revision=1
 build_style=gnu-makefile
 depends="bash zfs"
 checkdepends="shellcheck"
@@ -10,7 +10,7 @@ maintainer="Andrew J. Hesford <ajh@sideband.org>"
 license="MIT"
 homepage="https://github.com/bahamas10/zfs-prune-snapshots"
 distfiles="${homepage}/archive/v${version}.tar.gz"
-checksum=a9f2fb3c5230111db7622f70318219a37aa8d6bd3d7f894fee54e1ec00cdff2f
+checksum=aacd3683f2bf615286f6c0b154162df11e29783897127a55e1fe73c6a342979f
 
 post_install() {
 	vlicense LICENSE

From 5b1909c13a188da2adf8776ef4911298531a4da6 Mon Sep 17 00:00:00 2001
From: glaulher <glaulher.developer@gmail.com>
Date: Sun, 28 Nov 2021 15:15:17 -0300
Subject: [PATCH 161/288] icewm: update to 2.9.0.

---
 srcpkgs/icewm/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/icewm/template b/srcpkgs/icewm/template
index e9ba69605326..118071556e15 100644
--- a/srcpkgs/icewm/template
+++ b/srcpkgs/icewm/template
@@ -1,6 +1,6 @@
 # Template file for 'icewm'
 pkgname=icewm
-version=2.8.0
+version=2.9.0
 revision=1
 build_style=cmake
 make_cmd=make
@@ -17,7 +17,7 @@ maintainer="Glaulher <glaulher.developer@gmail.com>"
 license="GPL-2.0-or-later"
 homepage="https://ice-wm.org/"
 distfiles="https://github.com/ice-wm/icewm/archive/${version}.tar.gz"
-checksum=f225a7e5cf225493b6ae8d427d3a08ab9d3ab6bcd2a297ec41350655ddba7be1
+checksum=eacf813ee427cf80f46aaf8d104d7d0e79937b38dff362a857ce86a091c9de5b
 # broken tests
 make_check=no
 

From 5312048944d1d11dbfa4f62a84277b0b68a27c48 Mon Sep 17 00:00:00 2001
From: Lorem <notloremipsum@protonmail.com>
Date: Sun, 28 Nov 2021 11:52:21 +0530
Subject: [PATCH 162/288] badwolf: update to 1.2.1, orphan.

---
 srcpkgs/badwolf/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/badwolf/template b/srcpkgs/badwolf/template
index 9b9f2a1fe84f..0397fe5aa59a 100644
--- a/srcpkgs/badwolf/template
+++ b/srcpkgs/badwolf/template
@@ -1,6 +1,6 @@
 # Template file for 'badwolf'
 pkgname=badwolf
-version=1.2.0
+version=1.2.1
 revision=1
 build_style=configure
 make_check_target=test
@@ -8,12 +8,12 @@ hostmakedepends="pkg-config gettext"
 makedepends="webkit2gtk-devel libsoup-devel"
 checkdepends="mdocml"
 short_desc="Minimalist and privacy-oriented WebKitGTK+ browser"
-maintainer="Lorem <notloremipsum@protonmail.com>"
+maintainer="Orphaned <orphan@voidlinux.org>"
 license="BSD-3-Clause"
 homepage="https://hacktivis.me/projects/badwolf"
 changelog="https://hacktivis.me/releases/badwolf-${version}.txt"
 distfiles="https://hacktivis.me/releases/badwolf-${version}.tar.gz"
-checksum=eaf5b99f1fc0ea94552c64f3b5e84cf9e76891882ea5e767bf633341e0265cba
+checksum=7a658908551bc0389fc43bd04a9decfef3815d28ff2097957bf6ab186a05ffd2
 
 pre_configure() {
 	export PREFIX=/usr

From 0b03833dfc71d6e4865b37bcbc5c99a48c572156 Mon Sep 17 00:00:00 2001
From: jgart <jgart@dismail.de>
Date: Sun, 28 Nov 2021 23:44:08 -0500
Subject: [PATCH 163/288] xonsh: update to 0.11.0.

---
 srcpkgs/xonsh/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/xonsh/template b/srcpkgs/xonsh/template
index 150d83d4c8f7..69caa602e442 100644
--- a/srcpkgs/xonsh/template
+++ b/srcpkgs/xonsh/template
@@ -1,7 +1,7 @@
 # Template file for 'xonsh'
 pkgname=xonsh
-version=0.10.1
-revision=2
+version=0.11.0
+revision=1
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 checkdepends="python3-pytest python3-prompt_toolkit python3-Pygments"
@@ -11,7 +11,7 @@ license="GPL-3.0-or-later"
 homepage="https://xon.sh/"
 changelog="https://raw.githubusercontent.com/xonsh/xonsh/master/CHANGELOG.rst"
 distfiles="https://github.com/xonsh/xonsh/archive/${version}.tar.gz"
-checksum=4ede94226b0cc5f429bc7605ace88137c685d24675228e9e94ec18341dd30be4
+checksum=9d73273276996297920c234c7d4267a305c695f0e9e2454dbdf0655c3a8f75cb
 register_shell="/bin/xonsh"
 # FIXME: fails with multiple AttributeErrors
 make_check=extended

From 513c764a08c0ad46a681fd2340d54f227d0df871 Mon Sep 17 00:00:00 2001
From: cinerea0 <cinerea0@disroot.org>
Date: Sun, 28 Nov 2021 23:59:11 -0500
Subject: [PATCH 164/288] sof-tools: update to 1.9.2

---
 srcpkgs/sof-tools/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/sof-tools/template b/srcpkgs/sof-tools/template
index e10c8afe210f..ecd8c553e5b1 100644
--- a/srcpkgs/sof-tools/template
+++ b/srcpkgs/sof-tools/template
@@ -1,6 +1,6 @@
 # Template file for 'sof-tools'
 pkgname=sof-tools
-version=1.9
+version=1.9.2
 revision=1
 # https://github.com/thesofproject/sof/issues/4902
 archs="x86_64"
@@ -14,7 +14,7 @@ maintainer="cinerea0 <cinerea0@protonmail.com>"
 license="BSD-3-Clause"
 homepage="https://thesofproject.github.io/latest/index.html"
 distfiles="https://github.com/thesofproject/sof/archive/refs/tags/v${version}.tar.gz"
-checksum=29b83a63720ace3a9173073f12c4dfae5ece841773483cb025623506cd02eccb
+checksum=77fc2200f96c565b18b5975fc2ac19c54a93e83502f13b4f782567e5c44f45da
 
 post_install() {
 	vlicense ../LICENCE

From 5d3326afa6d15d7f0d16bfe8d6630fe809775fdc Mon Sep 17 00:00:00 2001
From: cinerea0 <cinerea0@disroot.org>
Date: Sun, 28 Nov 2021 23:57:23 -0500
Subject: [PATCH 165/288] sof-firmware: update to 1.9.2

---
 srcpkgs/sof-firmware/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/sof-firmware/template b/srcpkgs/sof-firmware/template
index 5e866cb448f7..5e6399eca917 100644
--- a/srcpkgs/sof-firmware/template
+++ b/srcpkgs/sof-firmware/template
@@ -1,6 +1,6 @@
 # Template file for 'sof-firmware'
 pkgname=sof-firmware
-version=1.9
+version=1.9.2
 revision=1
 archs="i686* x86_64*"
 wrksrc="sof-bin-${version}"
@@ -11,13 +11,13 @@ maintainer="cinerea0 <cinerea0@protonmail.com>"
 license="BSD-3-Clause"
 homepage="https://thesofproject.github.io/latest/index.html"
 distfiles="https://github.com/thesofproject/sof-bin/archive/refs/tags/v${version}.tar.gz"
-checksum=633bff2cc1490146de66796e52e06c7a608591a328c0bfc6f3fc30114640803a
+checksum=8eac925c129d195072237dcd28f4bbe80cf63eb00fd8b23bdc0719cd1ee9b395
 
 do_install() {
 	vmkdir usr/lib/firmware/intel/sof
 	vmkdir usr/lib/firmware/intel/sof-tplg
-	rsync -a "v${version}.x/sof-v${version}/" "${DESTDIR}/usr/lib/firmware/intel/sof"
-	rsync -a "v${version}.x/sof-tplg-v${version}/" "${DESTDIR}/usr/lib/firmware/intel/sof-tplg"
+	rsync -a "v${version%.*}.x/sof-v${version}/" "${DESTDIR}/usr/lib/firmware/intel/sof"
+	rsync -a "v${version%.*}.x/sof-tplg-v${version}/" "${DESTDIR}/usr/lib/firmware/intel/sof-tplg"
 
 	vlicense LICENCE.NXP
 }

From 6eadc828e2a50a352a1db8a004038a7f2a968b18 Mon Sep 17 00:00:00 2001
From: teldra <teldra@rotce.de>
Date: Sun, 28 Nov 2021 00:46:53 +0100
Subject: [PATCH 166/288] viewnior: update to 1.8.

---
 srcpkgs/viewnior/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/viewnior/template b/srcpkgs/viewnior/template
index 8232c1eb787b..efea8ef77dfb 100644
--- a/srcpkgs/viewnior/template
+++ b/srcpkgs/viewnior/template
@@ -1,7 +1,7 @@
 # Template file for 'viewnior'
 pkgname=viewnior
-version=1.7
-revision=2
+version=1.8
+revision=1
 wrksrc="Viewnior-${pkgname}-${version}"
 build_style=meson
 hostmakedepends="pkg-config intltool gnome-common glib-devel gettext-devel"
@@ -11,4 +11,4 @@ maintainer="teldra <teldra@rotce.de>"
 license="GPL-3.0-or-later"
 homepage="http://siyanpanayotov.com/project/viewnior/"
 distfiles="https://github.com/hellosiyan/Viewnior/archive/${pkgname}-${version}.tar.gz"
-checksum=b9fad3b2909a78f65b33f4dfb47fcdfa97150275e00d5c44d0aa0f1dc499f3e6
+checksum=b9319171ebca23929e6ea8039c194b1595d92e764db5e3890836fb5c36e233b0

From 5b7cef971d694b5dc30cd6d5089914e5916c5093 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Ey=C3=9Fer?= <daniel.eysser@gmail.com>
Date: Fri, 26 Nov 2021 18:26:01 +0100
Subject: [PATCH 167/288] common/environment/build-style: add zig-build.sh

---
 common/environment/build-style/zig-build.sh | 1 +
 1 file changed, 1 insertion(+)
 create mode 100644 common/environment/build-style/zig-build.sh

diff --git a/common/environment/build-style/zig-build.sh b/common/environment/build-style/zig-build.sh
new file mode 100644
index 000000000000..049b7cd437d5
--- /dev/null
+++ b/common/environment/build-style/zig-build.sh
@@ -0,0 +1 @@
+hostmakedepends+=" zig"

From fc88cfb35e189a2a8aa4e7370760eec78472cd91 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Ey=C3=9Fer?= <daniel.eysser@gmail.com>
Date: Fri, 26 Nov 2021 18:30:51 +0100
Subject: [PATCH 168/288] rundird: zig-build now adds zig to hostmakedepends

---
 srcpkgs/rundird/template | 1 -
 1 file changed, 1 deletion(-)

diff --git a/srcpkgs/rundird/template b/srcpkgs/rundird/template
index 8fa83b5e0dcc..5ff897abd456 100644
--- a/srcpkgs/rundird/template
+++ b/srcpkgs/rundird/template
@@ -3,7 +3,6 @@ pkgname=rundird
 version=0.2.0
 revision=1
 build_style=zig-build
-hostmakedepends="zig"
 makedepends="pam-devel"
 short_desc="Simple daemon + PAM module providing an XDG_RUNTIME_DIR"
 maintainer="Isaac Freund <mail@isaacfreund.com>"

From 78f0a2419a91eac0114546a1ce8a7ccf9f0e8df2 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Ey=C3=9Fer?= <daniel.eysser@gmail.com>
Date: Fri, 26 Nov 2021 18:32:32 +0100
Subject: [PATCH 169/288] river: zig-build now adds zig to hostmakedepends

---
 srcpkgs/river/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/river/template b/srcpkgs/river/template
index d30060422419..314ed6c53146 100644
--- a/srcpkgs/river/template
+++ b/srcpkgs/river/template
@@ -4,7 +4,7 @@ version=0.1.0
 revision=1
 build_style=zig-build
 configure_args="$(vopt_if xwayland -Dxwayland)"
-hostmakedepends="zig pkg-config wayland-devel scdoc git"
+hostmakedepends="pkg-config wayland-devel scdoc git"
 makedepends="wlroots-devel"
 depends="$(vopt_if xwayland xorg-server-xwayland)"
 short_desc="Dynamic tiling Wayland compositor"

From 94f8fc4e42ab1bcb955840fe7c3af7da465024f6 Mon Sep 17 00:00:00 2001
From: Lorem <notloremipsum@protonmail.com>
Date: Sun, 28 Nov 2021 11:25:31 +0530
Subject: [PATCH 170/288] minigalaxy: update to 1.1.0, orphan.

---
 srcpkgs/minigalaxy/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/minigalaxy/template b/srcpkgs/minigalaxy/template
index 9b7d2f6dbc90..30d360cf6414 100644
--- a/srcpkgs/minigalaxy/template
+++ b/srcpkgs/minigalaxy/template
@@ -1,18 +1,18 @@
 # Template file for 'minigalaxy'
 pkgname=minigalaxy
-version=1.0.2
-revision=2
+version=1.1.0
+revision=1
 build_style=python3-module
 hostmakedepends="gettext python3-setuptools"
 depends="hicolor-icon-theme webkit2gtk python3-gobject python3-requests"
-checkdepends="$depends"
+checkdepends="$depends python3-simplejson"
 short_desc="Simple GOG client for Linux"
-maintainer="Lorem <notloremipsum@protonmail.com>"
+maintainer="Orphaned <orphan@voidlinux.org>"
 license="GPL-3.0-or-later, CC-BY-3.0"
 homepage="https://sharkwouter.github.io/minigalaxy/"
 changelog="https://github.com/sharkwouter/minigalaxy/blob/master/CHANGELOG.md"
 distfiles="https://github.com/sharkwouter/minigalaxy/archive/${version}.tar.gz"
-checksum=9cb482760c68153f2fc8b8fe229d60033634bc0c7b83a6aa43a9cfa20ab2d0e9
+checksum=581e7abfb4af0c01d795dc57a93b1305644d8bdd11ecb533bb2787f85b4bc992
 
 do_check() {
 	python -m unittest tests/*.py

From f5dfa3d20588323ab526ac96cbbb340226ff48ec Mon Sep 17 00:00:00 2001
From: oreo639 <31916379+Oreo639@users.noreply.github.com>
Date: Sat, 27 Nov 2021 01:46:21 -0800
Subject: [PATCH 171/288] pacman: update to 6.0.1

---
 srcpkgs/pacman/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/pacman/template b/srcpkgs/pacman/template
index b98560e10637..d14176f089d7 100644
--- a/srcpkgs/pacman/template
+++ b/srcpkgs/pacman/template
@@ -1,13 +1,13 @@
 # Template file for 'pacman'
 pkgname=pacman
-version=5.2.2
-revision=3
+version=6.0.1
+revision=1
 make_dirs="/var/lib/pacman 0755 root root
  /usr/var/cache/pacman/pkg 0755 root root
  /usr/share/libalpm/hooks 0755 root root"
 conf_files="/etc/pacman.conf"
 build_style=meson
-hostmakedepends="autoconf automake curl libtool gettext-devel pkg-config asciidoc"
+hostmakedepends="curl gettext-devel pkg-config asciidoc"
 makedepends="libarchive-devel gpgme-devel libcurl-devel"
 depends="gnupg>=2"
 checkdepends="fakeroot"
@@ -15,8 +15,8 @@ short_desc="Simple library-based package manager"
 maintainer="oreo639 <oreo6391@gmail.com>"
 license="GPL-2.0-or-later"
 homepage="https://www.archlinux.org/pacman/"
-distfiles="https://sources.archlinux.org/other/pacman/pacman-${version}.tar.gz"
-checksum=bb201a9f2fb53c28d011f661d50028efce6eef2c1d2a36728bdd0130189349a0
+distfiles="https://sources.archlinux.org/other/pacman/pacman-${version}.tar.xz"
+checksum=0db61456e56aa49e260e891c0b025be210319e62b15521f29d3e93b00d3bf731
 make_check=ci-skip
 
 if [ "$XBPS_TARGET_LIBC" = musl ]; then

From f98f1b87a12a425964f1dcec9188f82226e3bdea Mon Sep 17 00:00:00 2001
From: cinerea0 <cinerea0@disroot.org>
Date: Mon, 29 Nov 2021 01:08:42 -0500
Subject: [PATCH 172/288] delta: update to 0.10.2

---
 srcpkgs/delta/template | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/delta/template b/srcpkgs/delta/template
index 15481ba9a01b..bd5040d70709 100644
--- a/srcpkgs/delta/template
+++ b/srcpkgs/delta/template
@@ -1,6 +1,6 @@
 # Template file for 'delta'
 pkgname=delta
-version=0.9.2
+version=0.10.2
 revision=1
 build_style=cargo
 checkdepends="git"
@@ -9,7 +9,8 @@ maintainer="Andrew Benson <abenson+void@gmail.com>"
 license="MIT"
 homepage="https://github.com/dandavison/delta"
 distfiles="${homepage}/archive/${version}.tar.gz"
-checksum=f002a94119cd5b6fd9deede7f344667358baf5015d0051e055fec6334ee0653f
+checksum=e0f71d72eca543478941401bd96fefc5fa3f70e7860a9f858f63bfecf8fd77a5
+make_check=no  # TODO: Re-enable checks when Rust gets updated
 
 post_install() {
 	vlicense LICENSE

From 71dbddca720ba651abf7bab489ba8cf3b03b7e45 Mon Sep 17 00:00:00 2001
From: Cullen Ross <cullenrss@gmail.com>
Date: Sun, 28 Nov 2021 19:27:26 -0500
Subject: [PATCH 173/288] rxvt-unicode: update to 9.30.

---
 srcpkgs/rxvt-unicode/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/rxvt-unicode/template b/srcpkgs/rxvt-unicode/template
index 4223d2e8f789..00ebdf63c3ca 100644
--- a/srcpkgs/rxvt-unicode/template
+++ b/srcpkgs/rxvt-unicode/template
@@ -1,6 +1,6 @@
 # Template file for 'rxvt-unicode'
 pkgname=rxvt-unicode
-version=9.29
+version=9.30
 revision=1
 build_style=gnu-configure
 configure_args="
@@ -25,7 +25,7 @@ maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="GPL-3.0-or-later"
 homepage="http://software.schmorp.de/pkg/rxvt-unicode.html"
 distfiles="http://dist.schmorp.de/${pkgname}/${pkgname}-${version}.tar.bz2"
-checksum=c18bc9de0c319db1f85748ecc2f255ff9eb2be0fbe9e15fe0eabefc063c4157c
+checksum=fe1c93d12f385876457a989fc3ae05c0915d2692efc59289d0f70fabe5b44d2d
 
 # Package build options
 build_options="gdk_pixbuf perl startup_notification unicode3"

From 5c9eb9eed1c25c9f101fd7b9f7b3e9b48508fae0 Mon Sep 17 00:00:00 2001
From: Clyhtsuriva <aimeric@adjutor.xyz>
Date: Mon, 29 Nov 2021 12:46:14 +0100
Subject: [PATCH 174/288] balsa: update to 2.6.3

---
 srcpkgs/balsa/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/balsa/template b/srcpkgs/balsa/template
index 70838929c35a..af0f741d1860 100644
--- a/srcpkgs/balsa/template
+++ b/srcpkgs/balsa/template
@@ -1,6 +1,6 @@
 # Template file for 'balsa'
 pkgname=balsa
-version=2.6.2
+version=2.6.3
 revision=1
 build_style=gnu-configure
 configure_args="--without-gnome --with-libsecret --with-gpgme --with-sqlite
@@ -13,5 +13,5 @@ short_desc="Email client for GNOME"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="https://pawsa.fedorapeople.org/balsa/"
-distfiles="https://pawsa.fedorapeople.org/balsa/balsa-${version}.tar.bz2"
-checksum=51d52040577b730d7a199e97ea3687b3d0f7cf7f08f6e339e784d700621a02f0
+distfiles="https://pawsa.fedorapeople.org/balsa/balsa-${version}.tar.xz"
+checksum=d4d04576c9a5026064f7d480b34531faf59543f2e4d57c48a6fa5c76661e1dd4

From 8c7afd75652f48987a4a0f11201f996130a50747 Mon Sep 17 00:00:00 2001
From: jgart <jgart@dismail.de>
Date: Mon, 29 Nov 2021 03:05:34 -0500
Subject: [PATCH 175/288] hugo: update to 0.89.4.

---
 srcpkgs/hugo/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/hugo/template b/srcpkgs/hugo/template
index d2765c6722db..444018d45dbf 100644
--- a/srcpkgs/hugo/template
+++ b/srcpkgs/hugo/template
@@ -1,6 +1,6 @@
 # Template file for 'hugo'
 pkgname=hugo
-version=0.89.1
+version=0.89.4
 revision=1
 build_style=go
 go_import_path="github.com/gohugoio/hugo"
@@ -10,7 +10,7 @@ maintainer="Andrea Brancaleoni <abc@pompel.me>"
 license="Apache-2.0"
 homepage="https://gohugo.io"
 distfiles="https://github.com/gohugoio/hugo/archive/v${version}.tar.gz"
-checksum=c47f144291819a8d9f065f69ab290a198dfabde86a27ac2325a89f03c6e5ea3f
+checksum=9d4f61788f8d886913a1be15b3eae04fad04a4e243bd7f65c5e7367bd617856d
 
 post_install() {
 	vdoc README.md

From 4b1b908942f9d9392e672f98f8ec45871ffbb305 Mon Sep 17 00:00:00 2001
From: jgart <jgart@dismail.de>
Date: Mon, 29 Nov 2021 02:00:44 -0500
Subject: [PATCH 176/288] stagit: update to 0.9.6.

---
 srcpkgs/stagit/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/stagit/template b/srcpkgs/stagit/template
index 89c5a8cb177c..7078a4f6c946 100644
--- a/srcpkgs/stagit/template
+++ b/srcpkgs/stagit/template
@@ -1,6 +1,6 @@
 # Template file for 'stagit'
 pkgname=stagit
-version=0.9.5
+version=0.9.6
 revision=1
 build_style=gnu-makefile
 make_install_args="MANPREFIX=/usr/share/man"
@@ -10,7 +10,7 @@ maintainer="Steve Prybylski <sa.prybylx@gmail.com>"
 license="MIT"
 homepage="https://codemadness.org/git/stagit/log.html"
 distfiles="https://codemadness.org/releases/stagit/${pkgname}-${version}.tar.gz"
-checksum=025a17c7be3a4e98a2319efc4eb6329e9ea6a778b2b24b0eb97a342ece9bb039
+checksum=d072f386f3a546ed0341e20f9c2dfd7756a761fab1c40316a96690cb2b3066d0
 LDFLAGS="-lgit2"
 
 post_install() {

From 63d0068fa1cf0ea48fdf5f80391557e951cd45c6 Mon Sep 17 00:00:00 2001
From: cinerea0 <cinerea0@disroot.org>
Date: Mon, 29 Nov 2021 01:37:08 -0500
Subject: [PATCH 177/288] onefetch: update to 2.11.0

---
 srcpkgs/onefetch/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/onefetch/template b/srcpkgs/onefetch/template
index cf9832cb5459..88f21bc3b351 100644
--- a/srcpkgs/onefetch/template
+++ b/srcpkgs/onefetch/template
@@ -1,6 +1,6 @@
 # Template file for 'onefetch'
 pkgname=onefetch
-version=2.10.2
+version=2.11.0
 revision=1
 build_style=cargo
 short_desc="Git repository summary on your terminal"
@@ -8,7 +8,7 @@ maintainer="Jan Christian Grünhage <jan.christian@gruenhage.xyz>"
 license="MIT"
 homepage="https://github.com/o2sh/onefetch"
 distfiles="https://github.com/o2sh/onefetch/archive/v${version}.tar.gz"
-checksum=6e4d4effcd4fd94ce21625a5e32da5da6446c8874200e40dd791e623b7aff7bb
+checksum=ffd3cc3bd24e299ede1fada2b2da8bf066d59219da167477e1997c860650c192
 
 post_install() {
 	vlicense LICENSE.md

From 104ac0b222617bbd3fa1222989c03b2dda3a8bae Mon Sep 17 00:00:00 2001
From: cinerea0 <cinerea0@disroot.org>
Date: Mon, 29 Nov 2021 00:50:38 -0500
Subject: [PATCH 178/288] mdBook: update to 0.4.14

---
 srcpkgs/mdBook/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/mdBook/template b/srcpkgs/mdBook/template
index b9df0433334f..465ff1a1bbbc 100644
--- a/srcpkgs/mdBook/template
+++ b/srcpkgs/mdBook/template
@@ -1,6 +1,6 @@
 # Template file for 'mdBook'
 pkgname=mdBook
-version=0.4.13
+version=0.4.14
 revision=1
 build_style=cargo
 short_desc="Create book from markdown files. Like Gitbook but implemented in Rust"
@@ -9,7 +9,7 @@ license="MPL-2.0"
 homepage="https://github.com/rust-lang/mdBook"
 changelog="https://raw.githubusercontent.com/rust-lang/mdBook/master/CHANGELOG.md"
 distfiles="https://github.com/rust-lang/mdBook/archive/v${version}.tar.gz"
-checksum=12a88a08e5c5b26810cc33b4e0ebed7cc72394f9041e8b15253e3cfac1223a7b
+checksum=59fd3e417e9d09deac89e20467194dd9f93854c2f1a87e845816c5cec676765c
 
 post_install() {
 	vlicense LICENSE

From fcd9bd4dc95d61a965007430061dfd9ba628ac4d Mon Sep 17 00:00:00 2001
From: teldra <teldra@rotce.de>
Date: Sun, 28 Nov 2021 01:11:22 +0100
Subject: [PATCH 179/288] py3status: update to 3.40.

---
 srcpkgs/py3status/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/py3status/template b/srcpkgs/py3status/template
index 5267fd63fdbe..092ccfbe2bd9 100644
--- a/srcpkgs/py3status/template
+++ b/srcpkgs/py3status/template
@@ -1,7 +1,7 @@
 # Template file for 'py3status'
 pkgname=py3status
-version=3.39
-revision=2
+version=3.40
+revision=1
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-setuptools python3-pyudev"
@@ -12,7 +12,7 @@ license="BSD-3-Clause"
 homepage="https://github.com/ultrabug/py3status"
 changelog="https://raw.githubusercontent.com/ultrabug/py3status/master/CHANGELOG"
 distfiles="${homepage}/archive/${version}.tar.gz"
-checksum=d18b81e86d5a44d2fa67453c3e9f04b9285005b2a7a9455890903d0e2dfe843c
+checksum=84885ec8a43626dcd7576b9cad029406c98675ca00ba66ff124d7607290d2b66
 
 post_install() {
 	vlicense LICENSE

From 2e2f8884f7afdae768a630b8d2960c11faa7e82d Mon Sep 17 00:00:00 2001
From: teldra <teldra@rotce.de>
Date: Sun, 28 Nov 2021 01:08:24 +0100
Subject: [PATCH 180/288] openimagedenoise: update to 1.4.2.

---
 srcpkgs/openimagedenoise/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/openimagedenoise/template b/srcpkgs/openimagedenoise/template
index 7120d39bae20..8190e029a08b 100644
--- a/srcpkgs/openimagedenoise/template
+++ b/srcpkgs/openimagedenoise/template
@@ -1,6 +1,6 @@
 # Template file for 'openimagedenoise'
 pkgname=openimagedenoise
-version=1.4.1
+version=1.4.2
 revision=1
 archs="x86_64*"
 wrksrc=oidn-${version}
@@ -12,7 +12,7 @@ maintainer="teldra <teldra@rotce.de>"
 license="Apache-2.0"
 homepage="https://openimagedenoise.github.io"
 distfiles="https://github.com/OpenImageDenoise/oidn/releases/download/v${version}/oidn-${version}.src.tar.gz"
-checksum=9088966685a78adf24b8de075d66e4c0019bd7b2b9d29c6e45aaf35d294e3f6f
+checksum=e70d27ce24b41364782376c1b3b4f074f77310ccfe5f8ffec4a13a347e48a0ea
 
 do_check() {
 	build/oidnTest

From 7f5db2e188869d184a482416aa4028eaac0d99cf Mon Sep 17 00:00:00 2001
From: Firgen <filip.frgelec@disroot.org>
Date: Sun, 14 Nov 2021 15:27:49 +0100
Subject: [PATCH 181/288] i3lock-color: update to 2.13.c.4.

---
 srcpkgs/i3lock-color/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/i3lock-color/template b/srcpkgs/i3lock-color/template
index 7f5572f99d64..6ce184239bb4 100644
--- a/srcpkgs/i3lock-color/template
+++ b/srcpkgs/i3lock-color/template
@@ -1,6 +1,6 @@
 # Template file for 'i3lock-color'
 pkgname=i3lock-color
-version=2.12.c.5
+version=2.13.c.4
 revision=1
 build_style=gnu-configure
 hostmakedepends="pkg-config automake"
@@ -11,7 +11,7 @@ maintainer="jtalowell <jtalowell@protonmail.com>"
 license="MIT"
 homepage="https://github.com/Raymo111/i3lock-color"
 distfiles="https://github.com/Raymo111/i3lock-color/archive/${version}.tar.gz"
-checksum=62c9bdff2759186426b184ed45e4c1aae1dc3c582499d94da68d9b08662a96a9
+checksum=5df4cd3d515d938630ced981a7f0a6e01344d1ec51d10fd3c3d131d19283df69
 conf_files="/etc/pam.d/i3lock"
 conflicts="i3lock"
 

From 7e3f07be481c098606bbc3e45d01a0b22e888037 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Piotr=20W=C3=B3jcik?= <chocimier@tlen.pl>
Date: Mon, 29 Nov 2021 20:04:48 +0100
Subject: [PATCH 182/288] diffoscope: update to 194.

---
 srcpkgs/diffoscope/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/diffoscope/template b/srcpkgs/diffoscope/template
index 596f402323fe..31a2ca350066 100644
--- a/srcpkgs/diffoscope/template
+++ b/srcpkgs/diffoscope/template
@@ -1,6 +1,6 @@
 # Template file for 'diffoscope'
 pkgname=diffoscope
-version=193
+version=194
 revision=1
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -14,4 +14,4 @@ license="GPL-3.0-or-later"
 homepage="https://diffoscope.org/"
 changelog="https://salsa.debian.org/reproducible-builds/diffoscope/raw/master/debian/changelog"
 distfiles="${PYPI_SITE}/d/diffoscope/diffoscope-${version}.tar.gz"
-checksum=d836ddf24ccb4ffabd798ea1b7fcb66b87e55d5e8ff08286620bb7c64e1d829f
+checksum=3d28f0325e00effc6c23c50f916d153524aa393623df2fd1fc8ae0f6a12daf94

From f8cd23f19539e21b5375fbb0e263c855b7b3e1cb Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C3=89rico=20Nogueira?= <erico.erc@gmail.com>
Date: Mon, 29 Nov 2021 02:01:44 -0300
Subject: [PATCH 183/288] gnome-keyring: remove libcap-ng, adopt.

We don't set capabilities on the binary right now, so it's better to
build without libcap-ng, so it doesn't complain on start-up. This is
also done by other distros, see [1].

libcap was no longer used, and neither was libtasn1.

We already depend on gcr via shlibs, so it doesn't need to be in
depends= explicitly.

Also update changelog to canonical URL.

[1] https://gitlab.gnome.org/GNOME/gnome-keyring/-/merge_requests/41#note_1277767
---
 srcpkgs/gnome-keyring/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/gnome-keyring/template b/srcpkgs/gnome-keyring/template
index 12f1e8d2df64..f479f7f0fe5e 100644
--- a/srcpkgs/gnome-keyring/template
+++ b/srcpkgs/gnome-keyring/template
@@ -1,19 +1,19 @@
 # Template file for 'gnome-keyring'
 pkgname=gnome-keyring
 version=40.0
-revision=2
+revision=3
 build_style=gnu-configure
 configure_args="--with-pam-dir=/usr/lib/security --disable-schemas-compile"
 hostmakedepends="autoconf docbook-xsl glib-devel intltool libtasn1-tools libxslt
  openssh pkg-config"
-makedepends="gcr-devel libcap-devel libcap-ng-devel libtasn1-devel pam-devel"
-depends="dconf gcr"
+makedepends="gcr-devel pam-devel"
+depends="dconf"
 checkdepends="dbus xvfb-run"
 short_desc="GNOME password and secret manager"
-maintainer="Orphaned <orphan@voidlinux.org>"
+maintainer="Érico Nogueira <ericonr@disroot.org>"
 license="GPL-2.0-or-later, LGPL-2.1-or-later"
 homepage="https://www.gnome.org"
-changelog="https://raw.githubusercontent.com/GNOME/gnome-keyring/gnome-40/NEWS"
+changelog="https://gitlab.gnome.org/GNOME/gnome-keyring/-/raw/master/NEWS"
 distfiles="${GNOME_SITE}/$pkgname/${version%.*}/$pkgname-$version.tar.xz"
 checksum=a3d24db08ee2fdf240fbbf0971a98c8ee295aa0e1a774537f4ea938038a3b931
 make_check=ci-skip

From 23352250f33b236f725232e5996c0aca57b906cc Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C3=89rico=20Nogueira?= <erico.erc@gmail.com>
Date: Mon, 29 Nov 2021 02:10:34 -0300
Subject: [PATCH 184/288] texinfo: update to 6.8.

---
 srcpkgs/texinfo/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/texinfo/template b/srcpkgs/texinfo/template
index c183625028c5..55948fd8bab5 100644
--- a/srcpkgs/texinfo/template
+++ b/srcpkgs/texinfo/template
@@ -1,6 +1,6 @@
 # Template file for 'texinfo'
 pkgname=texinfo
-version=6.7
+version=6.8
 revision=1
 build_style=gnu-configure
 configure_args="--disable-static --disable-perl-xs"
@@ -10,9 +10,9 @@ depends="gzip perl"
 short_desc="GNU Documentation System"
 maintainer="Enno Boland <gottox@voidlinux.org>"
 license="GPL-3.0-or-later"
-homepage="http://www.gnu.org/software/texinfo/"
+homepage="https://www.gnu.org/software/texinfo/"
 distfiles="${GNU_SITE}/$pkgname/$pkgname-$version.tar.xz"
-checksum=988403c1542d15ad044600b909997ba3079b10e03224c61188117f3676b02caa
+checksum=8eb753ed28bca21f8f56c1a180362aed789229bd62fff58bf8368e9beb59fec4
 
 if [ -z "$CROSS_BUILD" ]; then
 	# XXX fails with cross compilation

From b53a02f9278ebf9c07eca2c8415d4d4795ecc345 Mon Sep 17 00:00:00 2001
From: Luke Hannan <luke@lukehannan.com>
Date: Mon, 29 Nov 2021 17:50:36 +0200
Subject: [PATCH 185/288] R: update to 4.1.2.

---
 srcpkgs/R/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/R/template b/srcpkgs/R/template
index db75515b11cd..8a7db746af46 100644
--- a/srcpkgs/R/template
+++ b/srcpkgs/R/template
@@ -1,7 +1,7 @@
 # Template file for 'R'
 pkgname=R
-version=4.1.1
-revision=2
+version=4.1.2
+revision=1
 build_style=gnu-configure
 configure_args="--docdir=/usr/share/doc/R rdocdir=/usr/share/doc/R
  --with-blas$(vopt_if openblas '=openblas') --with-lapack
@@ -22,7 +22,7 @@ license="GPL-2.0-or-later"
 homepage="https://www.r-project.org/"
 changelog="https://cran.r-project.org/doc/manuals/r-release/NEWS.html"
 distfiles="https://cran.r-project.org/src/base/R-4/${pkgname}-${version}.tar.gz"
-checksum=515e03265752257d0b7036f380f82e42b46ed8473f54f25c7b67ed25bbbdd364
+checksum=2036225e9f7207d4ce097e54972aecdaa8b40d7d9911cd26491fac5a0fab38af
 nocross=yes
 shlib_provides="libR.so"
 make_check=extended

From 4996b8b94185a079473016cfdc07dca8d69fd6e6 Mon Sep 17 00:00:00 2001
From: Lorem <notloremipsum@protonmail.com>
Date: Sun, 28 Nov 2021 11:05:58 +0530
Subject: [PATCH 186/288] New package: coeurl-0.1.0

---
 common/shlibs           |  1 +
 srcpkgs/coeurl-devel    |  1 +
 srcpkgs/coeurl/template | 28 ++++++++++++++++++++++++++++
 3 files changed, 30 insertions(+)
 create mode 120000 srcpkgs/coeurl-devel
 create mode 100644 srcpkgs/coeurl/template

diff --git a/common/shlibs b/common/shlibs
index dac22845d445..527588585aec 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -4070,3 +4070,4 @@ libbrial_groebner.so.3 brial-1.2.10_1
 libm4ri-0.0.20200125.so m4ri-20200125_1
 libm4rie-0.0.20200125.so m4rie-20200125_1
 libptytty.so.0 libptytty-2.0_1
+libcoeurl.so.0 coeurl-0.1.0_1
diff --git a/srcpkgs/coeurl-devel b/srcpkgs/coeurl-devel
new file mode 120000
index 000000000000..bdd2ff71f0cb
--- /dev/null
+++ b/srcpkgs/coeurl-devel
@@ -0,0 +1 @@
+coeurl
\ No newline at end of file
diff --git a/srcpkgs/coeurl/template b/srcpkgs/coeurl/template
new file mode 100644
index 000000000000..dd6600a89bba
--- /dev/null
+++ b/srcpkgs/coeurl/template
@@ -0,0 +1,28 @@
+# Template file for 'coeurl'
+pkgname=coeurl
+version=0.1.0
+revision=1
+wrksrc=coeurl-v${version}
+build_style=meson
+hostmakedepends="pkg-config"
+makedepends="spdlog libevent-devel libcurl-devel"
+short_desc="Simple async wrapper around CURL for C++"
+maintainer="Lorem <notloremipsum@protonmail.com>"
+license="MIT"
+homepage="https://nheko.im/nheko-reborn/coeurl"
+distfiles="https://nheko.im/nheko-reborn/coeurl/-/archive/v${version}/coeurl-v${version}.tar.gz"
+checksum=2861453317c6da359a00083e39d899dfe0fc71becadd726ef845a5fba57d3f64
+
+post_install() {
+	vlicense LICENSE
+}
+
+coeurl-devel_package() {
+	short_desc+=" - development files"
+	depends="${sourcepkg}>=${version}_${revision} ${makedepends}"
+	pkg_install() {
+		vmove usr/include
+		vmove usr/lib/pkgconfig
+		vmove "usr/lib/*.so"
+	}
+}

From a25f0df1f587857d215cbe473088adf999ae754a Mon Sep 17 00:00:00 2001
From: Lorem <notloremipsum@protonmail.com>
Date: Sun, 28 Nov 2021 11:07:15 +0530
Subject: [PATCH 187/288] mtxclient: update to 0.6.0.

---
 common/shlibs              | 2 +-
 srcpkgs/mtxclient/template | 6 +++---
 2 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index 527588585aec..ad60646030fe 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -420,7 +420,7 @@ libField3D.so.1.7 Field3D-1.7.3_1
 libMAC.so.6 libMAC-5.28_1
 libmad.so.0 libmad-0.15.1b_1
 libmatroska.so.7 libmatroska-1.6.0_1
-libmatrix_client.so.0.5.1 mtxclient-0.5.1_1
+libmatrix_client.so.0.6.0 mtxclient-0.6.0_1
 libebml.so.5 libebml-1.4.0_1
 libdvdread.so.8 libdvdread-6.1.1_1
 libdvdnav.so.4 libdvdnav-4.1.3_1
diff --git a/srcpkgs/mtxclient/template b/srcpkgs/mtxclient/template
index 35f3d4a10f42..9c8c1e3a9efe 100644
--- a/srcpkgs/mtxclient/template
+++ b/srcpkgs/mtxclient/template
@@ -1,17 +1,17 @@
 # Template file for 'mtxclient'
 pkgname=mtxclient
-version=0.5.1
+version=0.6.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_LIB_TESTS=OFF -DBUILD_LIB_EXAMPLES=OFF"
 hostmakedepends="pkg-config"
-makedepends="boost-devel json-c++ olm-devel openssl-devel"
+makedepends="json-c++ olm-devel openssl-devel coeurl-devel"
 short_desc="Client API library for the Matrix protocol"
 maintainer="Lorem <notloremipsum@protonmail.com>"
 license="MIT"
 homepage="https://github.com/Nheko-Reborn/mtxclient"
 distfiles="https://github.com/Nheko-Reborn/mtxclient/archive/v${version}.tar.gz"
-checksum=9478d870296ebe7679c90f563cb798eb3cdd3f9c4578ceea5af75b66f456baaa
+checksum=4245feb0bd4ae8e026c01f546a6bea45bc9d9d57d13430b8ba446b0aec4915c4
 
 post_install() {
 	vlicense LICENSE

From 51dfe223276ddb1daa5925cab07f66864838d699 Mon Sep 17 00:00:00 2001
From: Lorem <notloremipsum@protonmail.com>
Date: Sun, 28 Nov 2021 11:07:27 +0530
Subject: [PATCH 188/288] nheko: update to 0.9.0.

---
 srcpkgs/nheko/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/nheko/template b/srcpkgs/nheko/template
index 7b7c6bfbf6e1..deaf85713976 100644
--- a/srcpkgs/nheko/template
+++ b/srcpkgs/nheko/template
@@ -1,11 +1,11 @@
 # Template file for 'nheko'
 pkgname=nheko
-version=0.8.2
-revision=2
+version=0.9.0
+revision=1
 build_style=cmake
 hostmakedepends="qt5-host-tools qt5-qmake pkg-config qt5-declarative"
 makedepends="qt5-multimedia-devel qt5-svg-devel qt5-tools-devel fmt-devel
- spdlog mtxclient-devel boost-devel cmark-devel olm-devel json-c++ lmdb++
+ spdlog mtxclient-devel cmark-devel olm-devel json-c++ lmdb++ coeurl-devel
  qt5-declarative-devel qt5-quickcontrols2-devel qtkeychain-qt5-devel
  gst-plugins-bad1-devel gst-plugins-base1-devel xcb-util-wm-devel"
 depends="hicolor-icon-theme qt5-quickcontrols2 qt5-graphicaleffects
@@ -16,7 +16,7 @@ license="GPL-3.0-or-later"
 homepage="https://github.com/Nheko-Reborn/nheko"
 changelog="https://github.com/Nheko-Reborn/nheko/blob/master/CHANGELOG.md"
 distfiles="https://github.com/Nheko-Reborn/nheko/archive/v${version}.tar.gz"
-checksum=df4575c47daab47d418637a4637b599e3848dd749132ca1e92f981d9212eabb2
+checksum=309505f13d3b65ea23c0db19e59e469905b1ae437d2d6c7d1b496ac0921fb141
 
 case "$XBPS_TARGET_MACHINE" in
 	armv*-musl)

From 56f8cb1f0060d22b28b63d51e8308a2f521000ed Mon Sep 17 00:00:00 2001
From: Evgeny Ermakov <evgeny.v.ermakov@gmail.com>
Date: Tue, 30 Nov 2021 06:03:00 +1100
Subject: [PATCH 189/288] cglm: update to 0.8.4.

---
 srcpkgs/cglm/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/cglm/template b/srcpkgs/cglm/template
index c7dfee606c45..5b553c7c0d12 100644
--- a/srcpkgs/cglm/template
+++ b/srcpkgs/cglm/template
@@ -1,6 +1,6 @@
 # Template file for 'cglm'
 pkgname=cglm
-version=0.8.3
+version=0.8.4
 revision=1
 build_style=cmake
 short_desc="Highly Optimized Graphics Math (glm) for C"
@@ -8,7 +8,7 @@ maintainer="Nicu Borta <nicuborta123@tutanota.com>"
 license="MIT"
 homepage="https://github.com/recp/cglm"
 distfiles="https://github.com/recp/cglm/archive/v${version}.tar.gz"
-checksum=3a3f935f9f2ed5a8cb6337e421bf6f3a699a72d8cfe26fde1bbb8fde5c1c8aaf
+checksum=42f84c42c8a3e62954da77ab5c5d3264033d5802009e175db7921332a476126e
 
 post_install() {
 	vlicense LICENSE

From 4956ff3a768491659b8b6512c500b3abc3cfdaf4 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Mon, 29 Nov 2021 21:37:47 +0100
Subject: [PATCH 190/288] debootstrap: update to 1.0.126+nmu1.

---
 srcpkgs/debootstrap/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/debootstrap/template b/srcpkgs/debootstrap/template
index df67a598d286..14d0528a710c 100644
--- a/srcpkgs/debootstrap/template
+++ b/srcpkgs/debootstrap/template
@@ -1,6 +1,6 @@
 # Template file for 'debootstrap'
 pkgname=debootstrap
-version=1.0.126
+version=1.0.126+nmu1
 revision=1
 build_style=fetch
 depends="binutils gnupg gzip tar wget xz zstd"
@@ -10,7 +10,7 @@ license="MIT"
 homepage="http://packages.qa.debian.org/d/debootstrap.html"
 distfiles="${DEBIAN_SITE}/main/d/${pkgname}/${pkgname}_${version}_all.deb
  ${DEBIAN_SITE}/main/d/debian-archive-keyring/debian-archive-keyring_2021.1.1_all.deb"
-checksum="3084a2dcb4cd56a7c094c6b7cd745b6736ad78846b108275616d448fa6911f5e
+checksum="396f694346e6b401341ca07e30355faebea0ff490322cdbba804066cf4a0d048
  56beca470dcd9b6d7e6c3c9e9d702101e01e9467e62810a8c357bd7b9c26251d"
 
 case "$XBPS_TARGET_MACHINE" in

From 3dabf5e6fa3bbdf705340d525db83aea30b56f26 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Mon, 29 Nov 2021 21:37:56 +0100
Subject: [PATCH 191/288] linux: update to 5.15.

---
 srcpkgs/linux/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/linux/template b/srcpkgs/linux/template
index 50ff91aef896..f76a6a1d27e8 100644
--- a/srcpkgs/linux/template
+++ b/srcpkgs/linux/template
@@ -1,6 +1,6 @@
 # Template file for 'linux'
 pkgname=linux
-version=5.13
+version=5.15
 revision=1
 build_style=meta
 depends="linux${version} linux-base"

From b60a99346148340ea429e062dd889ba75f4a6830 Mon Sep 17 00:00:00 2001
From: Mat Boehlke <mtboehlke@gmail.com>
Date: Mon, 29 Nov 2021 10:05:29 -0600
Subject: [PATCH 192/288] font-sil-charis: update to 6.001

Remove unzip hostdepend: bsdtar works just fine
---
 srcpkgs/font-sil-charis/template | 15 +++++++--------
 1 file changed, 7 insertions(+), 8 deletions(-)

diff --git a/srcpkgs/font-sil-charis/template b/srcpkgs/font-sil-charis/template
index b8b351e36462..5d804c0e6bfe 100644
--- a/srcpkgs/font-sil-charis/template
+++ b/srcpkgs/font-sil-charis/template
@@ -1,21 +1,20 @@
 # Template file for 'font-sil-charis'
 pkgname=font-sil-charis
-version=5.000
-revision=2
+version=6.001
+revision=1
 wrksrc="CharisSIL-${version}"
-hostmakedepends="unzip"
 depends="font-util"
 short_desc="Unicode serif font, similar to Bitstream Charter"
 maintainer="Ivan Sokolov <ivan-p-sokolov@ya.ru>"
 license="OFL-1.1"
 homepage="https://software.sil.org/charis/"
 distfiles="https://software.sil.org/downloads/r/charis/CharisSIL-${version}.zip"
-checksum=5e3e5473b30363008c289cc87e2aa584a0916087a63a3f689defa8e0cee09bfd
+checksum=850df14e9024790e061a406715693ff39489dd071ea583b3258bdeba8384ebe8
 font_dirs="/usr/share/fonts/SIL"
 
 do_install() {
-	vinstall CharisSIL-B.ttf 644 ${font_dirs}
-	vinstall CharisSIL-BI.ttf 644 ${font_dirs}
-	vinstall CharisSIL-I.ttf 644 ${font_dirs}
-	vinstall CharisSIL-R.ttf 644 ${font_dirs}
+	vinstall CharisSIL-Bold.ttf 644 ${font_dirs}
+	vinstall CharisSIL-BoldItalic.ttf 644 ${font_dirs}
+	vinstall CharisSIL-Italic.ttf 644 ${font_dirs}
+	vinstall CharisSIL-Regular.ttf 644 ${font_dirs}
 }

From 9f5c349e57a390e8e1e703561f88e96aa35fb364 Mon Sep 17 00:00:00 2001
From: Gerardo Di iorio <arete74@gmail.com>
Date: Mon, 29 Nov 2021 22:06:04 +0100
Subject: [PATCH 193/288] todoist: update to 0.16.0.

---
 srcpkgs/todoist/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/todoist/template b/srcpkgs/todoist/template
index 49761d228b01..9e96ed98dc5f 100644
--- a/srcpkgs/todoist/template
+++ b/srcpkgs/todoist/template
@@ -1,6 +1,6 @@
 # Template file for 'todoist'
 pkgname=todoist
-version=0.15.0
+version=0.16.0
 revision=1
 build_style=go
 go_import_path="github.com/sachaos/todoist"
@@ -9,7 +9,7 @@ maintainer="Gerardo Di Iorio <arete74@gmail.com>"
 license="MIT"
 homepage="https://github.com/sachaos/todoist"
 distfiles="${homepage}/archive/v${version}.tar.gz"
-checksum=b7ffa14574bd241ab9e21a28f3d40c17b1a12250e89cfbc8ad708cfbfcdd84b3
+checksum=9d5a8f5c6b92d3d6df292f9ae96bec46049b4e4b7a482f7232e4e5b9708dfffa
 
 post_install() {
 	vdoc README.md

From dcde486c4a7f8b6fe489ac0575b6b7cc0b05eb1d Mon Sep 17 00:00:00 2001
From: Gerardo Di iorio <arete74@gmail.com>
Date: Mon, 29 Nov 2021 22:08:08 +0100
Subject: [PATCH 194/288] cpuid: update to 20211129.

---
 srcpkgs/cpuid/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/cpuid/template b/srcpkgs/cpuid/template
index 8f8f26c25920..0b363cdf07ff 100644
--- a/srcpkgs/cpuid/template
+++ b/srcpkgs/cpuid/template
@@ -1,6 +1,6 @@
 # Template file for 'cpuid'
 pkgname=cpuid
-version=20211121
+version=20211129
 revision=1
 archs="i686* x86_64*"
 build_style=gnu-makefile
@@ -10,4 +10,4 @@ maintainer="Gerardo Di Iorio  <arete74@gmail.com>"
 license="GPL-2.0-or-later"
 homepage="http://www.etallen.com/cpuid.html"
 distfiles="http://www.etallen.com/cpuid/cpuid-${version}.src.tar.gz"
-checksum=172f562adf31b15de177b12e6154f67179a7e5ee14d078d72319c0c074e6c01a
+checksum=230772bb88c44732e68a42d2eff43bcff46d893bf4ea6e04151d4cb6e8c88e2f

From 788126825bc8771b878615f152a8ddf9c1171f9f Mon Sep 17 00:00:00 2001
From: Piraty <piraty1@inbox.ru>
Date: Sun, 28 Nov 2021 21:06:05 +0100
Subject: [PATCH 195/288] tor: update to 0.4.6.8.

---
 srcpkgs/tor/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/tor/template b/srcpkgs/tor/template
index 39ee33963862..d6e94e369de1 100644
--- a/srcpkgs/tor/template
+++ b/srcpkgs/tor/template
@@ -1,6 +1,6 @@
 # Template file for 'tor'
 pkgname=tor
-version=0.4.6.7
+version=0.4.6.8
 revision=1
 build_style=gnu-configure
 configure_args="--enable-zstd"
@@ -14,7 +14,7 @@ license="BSD-3-Clause"
 homepage="https://www.torproject.org/"
 changelog="https://gitlab.torproject.org/tpo/core/tor/-/raw/main/ChangeLog"
 distfiles="https://dist.torproject.org/tor-${version}.tar.gz"
-checksum=ff665ce121b2952110bd98b9c8741b5593bf6c01ac09033ad848ed92c2510f9a
+checksum=15ce1a37b4cc175b07761e00acdcfa2c08f0d23d6c3ab9c97c464bd38cc5476a
 
 conf_files="/etc/tor/torrc"
 system_accounts="tor"

From 9ab7e7ac004af80a1002f1f13c2b0a7cd8f54b1e Mon Sep 17 00:00:00 2001
From: wundrweapon <whhacker.dcx@gmail.com>
Date: Mon, 29 Nov 2021 21:23:49 -0500
Subject: [PATCH 196/288] font-firacode: update to 6.

---
 srcpkgs/font-firacode/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/font-firacode/template b/srcpkgs/font-firacode/template
index 73536112a695..35d4a5630c48 100644
--- a/srcpkgs/font-firacode/template
+++ b/srcpkgs/font-firacode/template
@@ -1,7 +1,7 @@
 # Template file for 'font-firacode'
 pkgname=font-firacode
-version=5.2
-revision=2
+version=6
+revision=1
 create_wrksrc=yes
 hostmakedepends="unzip"
 short_desc="FiraCode: monospaced font with programming ligatures"
@@ -10,7 +10,7 @@ license="OFL-1.1"
 homepage="https://github.com/tonsky/FiraCode"
 changelog="https://github.com/tonsky/FiraCode/raw/master/CHANGELOG.md"
 distfiles="https://github.com/tonsky/FiraCode/releases/download/${version}/Fira_Code_v${version}.zip"
-checksum=521a72be00dd22678d248e63f817c0c79c1b6f23a4fbd377eba73d30cdca5efd
+checksum=a4997c2f905fb20a6d814baf7b9bab7df7de574a8e87d6af509685a43291caf1
 font_dirs="/usr/share/fonts/TTF"
 
 do_install() {

From 2a9b7e6b4e4e3c092b50ab3c15775fe60352620d Mon Sep 17 00:00:00 2001
From: Evgeny Ermakov <evgeny.v.ermakov@gmail.com>
Date: Tue, 30 Nov 2021 05:48:58 +1100
Subject: [PATCH 197/288] scrot: update to 1.7.

---
 srcpkgs/scrot/template | 10 ++++++++--
 1 file changed, 8 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/scrot/template b/srcpkgs/scrot/template
index 7565f4303e7e..6c1336c260ef 100644
--- a/srcpkgs/scrot/template
+++ b/srcpkgs/scrot/template
@@ -1,6 +1,6 @@
 # Template file for 'scrot'
 pkgname=scrot
-version=1.6
+version=1.7
 revision=1
 build_style=gnu-configure
 make_install_args="docsdir=/usr/share/doc/scrot"
@@ -11,7 +11,13 @@ maintainer="Frank Steinborn <steinex@nognu.de>"
 license="MIT"
 homepage="https://github.com/resurrecting-open-source-projects/scrot"
 distfiles="https://github.com/resurrecting-open-source-projects/scrot/archive/${version}.tar.gz"
-checksum=5d53df3e86220b8aca21be03a39b542905f2a8a0ccd950fdce7fc48a32c09050
+checksum=e4ff764f93ea98018d46192c35bd34eeb577040ac6e217aa0d83b2a63d88f66b
+
+if [ "$XBPS_TARGET_LIBC" = musl ]; then
+	makedepends+=" musl-legacy-compat"
+else
+	makedepends+=" libbsd-devel"
+fi
 
 pre_configure() {
 	./autogen.sh

From df83fe02223e14ef02a4eacbf85530983212ca62 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Tue, 30 Nov 2021 14:25:44 +0700
Subject: [PATCH 198/288] ca-certificates: fix busybox mktemp compat

Close: #34323
---
 .../ca-certificates/patches/busybox-flags.patch    | 14 ++++++++++++++
 srcpkgs/ca-certificates/template                   |  4 ++--
 2 files changed, 16 insertions(+), 2 deletions(-)
 create mode 100644 srcpkgs/ca-certificates/patches/busybox-flags.patch

diff --git a/srcpkgs/ca-certificates/patches/busybox-flags.patch b/srcpkgs/ca-certificates/patches/busybox-flags.patch
new file mode 100644
index 000000000000..0f109e1b0bc1
--- /dev/null
+++ b/srcpkgs/ca-certificates/patches/busybox-flags.patch
@@ -0,0 +1,14 @@
+diff --git a/sbin/update-ca-certificates b/sbin/update-ca-certificates
+--- a/work/sbin/update-ca-certificates
++++ b/work/sbin/update-ca-certificates
+@@ -81,8 +81,8 @@ trap cleanup 0
+ # Helper files.  (Some of them are not simple arrays because we spawn
+ # subshells later on.)
+ TEMPBUNDLE="${ETCCERTSDIR}/${CERTBUNDLE}.new"
+-ADDED="$(mktemp --tmpdir "ca-certificates.tmp.XXXXXX")"
+-REMOVED="$(mktemp --tmpdir "ca-certificates.tmp.XXXXXX")"
++ADDED="$(mktemp -p "${TMPDIR:-/tmp}" "ca-certificates.tmp.XXXXXX")"
++REMOVED="$(mktemp -p "${TMPDIR:-/tmp}" "ca-certificates.tmp.XXXXXX")"
+ 
+ # Adds a certificate to the list of trusted ones.  This includes a symlink
+ # in /etc/ssl/certs to the certificate file and its inclusion into the
diff --git a/srcpkgs/ca-certificates/template b/srcpkgs/ca-certificates/template
index d328fae1eb72..30b2c68d95db 100644
--- a/srcpkgs/ca-certificates/template
+++ b/srcpkgs/ca-certificates/template
@@ -1,6 +1,6 @@
 # Template file for 'ca-certificates'
 pkgname=ca-certificates
-version=20211016+3.71
+version=20211016+3.72
 revision=1
 _nss_version=${version#*+}
 bootstrap=yes
@@ -16,7 +16,7 @@ homepage="https://wiki.mozilla.org/NSS:Root_certs"
 distfiles="${DEBIAN_SITE}/main/c/${pkgname}/${pkgname}_${version%+*}.tar.xz
  ${MOZILLA_SITE}/security/nss/releases/NSS_${_nss_version//\./_}_RTM/src/nss-${_nss_version}.tar.gz"
 checksum="2ae9b6dc5f40c25d6d7fe55e07b54f12a8967d1955d3b7b2f42ee46266eeef88
- 99acd315d9af35419cda4a6960f00a7d446bd231bd407174a7b07cb3dba0c253"
+ 6ea60a9ff113e493ea2ab25f41ea75a9fbd10af7903f26f703dac8680732d02e"
 
 post_extract() {
 	cp ${FILESDIR}/* $build_wrksrc/mozilla

From c7c2a41772cb2672b143b0c58d87917389d656b5 Mon Sep 17 00:00:00 2001
From: Andrew Benson <abenson+void@gmail.com>
Date: Tue, 30 Nov 2021 07:09:02 -0600
Subject: [PATCH 199/288] python3-rich: update to 10.15.1.

---
 srcpkgs/python3-rich/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-rich/template b/srcpkgs/python3-rich/template
index 79e4226fd0c1..a11c142a2002 100644
--- a/srcpkgs/python3-rich/template
+++ b/srcpkgs/python3-rich/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-rich'
 pkgname=python3-rich
-version=10.14.0
+version=10.15.1
 revision=1
 wrksrc="rich-${version}"
 build_style=python3-module
@@ -13,7 +13,7 @@ maintainer="Andrew Benson <abenson+void@gmail.com>"
 license="MIT"
 homepage="https://github.com/willmcgugan/rich"
 distfiles="${PYPI_SITE}/r/rich/rich-${version}.tar.gz"
-checksum=8bfe4546d56b4131298d3a9e571a0742de342f1593770bd0d4707299f772a0af
+checksum=93d0ea3c35ecfd8703dbe52b76885e224ad8d68c7766c921c726b14b22a57b7d
 
 post_install() {
 	vlicense LICENSE

From aba3c7d26fe65a3b6a8d993f5cde89e3115ca81f Mon Sep 17 00:00:00 2001
From: Duncaen <duncaen@voidlinux.org>
Date: Tue, 30 Nov 2021 13:57:53 +0100
Subject: [PATCH 200/288] harfbuzz: update to 3.1.2.

---
 srcpkgs/harfbuzz/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/harfbuzz/template b/srcpkgs/harfbuzz/template
index e9924e9ed1aa..974779480058 100644
--- a/srcpkgs/harfbuzz/template
+++ b/srcpkgs/harfbuzz/template
@@ -1,6 +1,6 @@
 # Template file for 'harfbuzz'
 pkgname=harfbuzz
-version=2.9.1
+version=3.1.2
 revision=1
 build_style=meson
 build_helper=gir
@@ -14,7 +14,7 @@ license="MIT"
 homepage="http://www.freedesktop.org/wiki/Software/HarfBuzz/"
 changelog="https://github.com/harfbuzz/harfbuzz/raw/main/NEWS"
 distfiles="https://github.com/harfbuzz/harfbuzz/releases/download/${version}/harfbuzz-${version}.tar.xz"
-checksum=0edcc980f526a338452180e701d6aba6323aef457b6686976a7d17ccbddc51cf
+checksum=4056b1541dd8bbd8ec29207fe30e568805c0705515632d7fec53a94399bc7945
 
 libharfbuzz_package() {
 	short_desc+=" - runtime library"

From 8e072f8e75d54ebece8457b22657d54e5ab1ae35 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Tue, 30 Nov 2021 15:53:03 +0100
Subject: [PATCH 201/288] babashka: update to 0.6.7.

---
 srcpkgs/babashka/template | 31 ++++++++++++++++++-------------
 1 file changed, 18 insertions(+), 13 deletions(-)

diff --git a/srcpkgs/babashka/template b/srcpkgs/babashka/template
index 588d3139d6d1..aba66be44069 100644
--- a/srcpkgs/babashka/template
+++ b/srcpkgs/babashka/template
@@ -1,6 +1,6 @@
 # Template file for 'babashka'
 pkgname=babashka
-version=0.6.5
+version=0.6.7
 revision=1
 hostmakedepends="mandrel leiningen git"
 makedepends="zlib-devel"
@@ -9,14 +9,15 @@ short_desc="Native, fast starting Clojure interpreter for scripting"
 maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="EPL-1.0"
 homepage="https://babashka.org/"
-_sci_commit=7896fe1bab824e8e07b198c6eaed1ec465ae3baa
-_babashka_curl_commit=2187f908c033da45978512979c53bb53321120ce
+_sci_commit=f3d2764b8f9fc14026c89e23d94fa2071ededcea
+_babashka_curl_commit=3d3d117ea0f8a143a06e3cace92e4e8b6a5782df
 _babashka_nrepl_commit=eadb3330f0a65e781755d8b328727698f1d41fb0
 _depstar_commit=c419b8c82041855d55593c5b561fc7cea8234712
-_process_commit=4fdf33c0243ff646dfa91c4454844a33e0f025b0
+_process_commit=cb12d2eea240fc1401feb9af2606a0847edfab10
 _pods_commit=f360afa6135b8bd2d384d9ba4582c0de6fdac804
-_deps_clj_commit=422b080c64dedad37979a748377394b2d4de7e7c
-_fs_commit=21eb0654efad0ffbeedfe8319dd1194319b30d29
+_deps_clj_commit=e06a1a450625a11409be0e2e8199415e0d2e51a9
+_fs_commit=6019ec9cb09632fdf84e4bc5879fd47ed57a35eb
+_babashka_core_commit=52a6037bd4b632bffffb04394fb4efd0cdab6b1e
 distfiles="https://github.com/babashka/babashka/archive/refs/tags/v${version}.tar.gz
  https://github.com/borkdude/sci/archive/${_sci_commit}.tar.gz
  https://github.com/babashka/babashka.curl/archive/${_babashka_curl_commit}.tar.gz
@@ -25,22 +26,26 @@ distfiles="https://github.com/babashka/babashka/archive/refs/tags/v${version}.ta
  https://github.com/babashka/process/archive/${_process_commit}.tar.gz
  https://github.com/babashka/pods/archive/${_pods_commit}.tar.gz
  https://github.com/borkdude/deps.clj/archive/${_deps_clj_commit}.tar.gz
- https://github.com/babashka/fs/archive/${_fs_commit}.tar.gz"
-checksum="9053ba3582dbc94e4221eefe4e7f507d0c9e4d90aa5f941fb504f658ed3ceea2
- 9ec8e74253e1a3a5ac1fbb1b1ed2c549a4bb194ffde55829683c11d6a1c67904
- d4efe2c84512c3914d80087a43f9dc8377b4318ab63579959c4488038d6b766b
+ https://github.com/babashka/fs/archive/${_fs_commit}.tar.gz
+ https://github.com/babashka/babashka.core/archive/${_babashka_core_commit}.tar.gz"
+checksum="2ec3ab92626ec42d681bb486e06ce784732401d404dfea32dbe5be23c26b3f5e
+ 89bfee50868795b09551550b5156865623fec8435eea8b9e8f71ae0ffab362eb
+ 45abdaa5e4effd3bcfea777d02844d4634f1f80a592843eca9ec7d3544b7e16d
  916d9cc8c0a3b895a72068b95c6ac985a65d30465a9d556af8acea20aaaacc42
  9d214a10a4f5e4f15b9c80354dae85689a40e941ec3417203354c0dc3ce9457b
- dcb999043dfc807a1ebfae99027b4434e726f647aa52fbd70ed58202d907d39a
+ 510facf66f1b4404de0ab12a1093b85213cf396f5d061728315c95fc527ed96b
  4070395956fc3cb0c22bac6fb4de1ad27130d24916e1915d8a3fe9eb591f6143
- dba354c4637595ed6a24e76914497dcb6f0059b531d8cd3c8c8c23385fff605a
- 2ebe97b7fe0ad349a6a1ff567df2c372571b9a672d81f5f5f83bbf45af708d71"
+ c7ee5cfac6592885342897b3a2a2276385a3c40f0df61beee9c0e84e313b3469
+ 9bb9cb06a1a2a3cd2e9334e9e1082a510474760ed650c98b9650ceca41f4fa42
+ bad285812bcc7de7e0dd905c5df99045d7f92d6e2e191fc2768c06adbaaeb709"
 
 nocross="https://build.voidlinux.org/builders/aarch64_builder/builds/33769/steps/shell_3/logs/stdio"
 
 post_extract() {
 	rmdir -v ${wrksrc}/sci
 	mv ${wrksrc}/../sci-${_sci_commit} ${wrksrc}/sci
+	rmdir -v ${wrksrc}/babashka.core
+	mv ${wrksrc}/../babashka.core-${_babashka_core_commit} ${wrksrc}/babashka.core
 	rmdir -v ${wrksrc}/babashka.curl
 	mv ${wrksrc}/../babashka.curl-${_babashka_curl_commit} ${wrksrc}/babashka.curl
 	rmdir -v ${wrksrc}/babashka.nrepl

From b2bcf65ae92995709316b2783da4fd4c560d3229 Mon Sep 17 00:00:00 2001
From: Duncaen <duncaen@voidlinux.org>
Date: Tue, 30 Nov 2021 15:55:29 +0100
Subject: [PATCH 202/288] Revert "harfbuzz: update to 3.1.2."

This reverts commit 908b075ecb296ec246e5553abefcdb3175fb0d1b.
---
 srcpkgs/harfbuzz/template | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/harfbuzz/template b/srcpkgs/harfbuzz/template
index 974779480058..1764bc6ef8c5 100644
--- a/srcpkgs/harfbuzz/template
+++ b/srcpkgs/harfbuzz/template
@@ -1,7 +1,8 @@
 # Template file for 'harfbuzz'
 pkgname=harfbuzz
-version=3.1.2
-revision=1
+reverts="3.1.2_1"
+version=2.9.1
+revision=2
 build_style=meson
 build_helper=gir
 configure_args="-Dglib=enabled -Dfreetype=enabled -Dcairo=enabled -Dicu=enabled
@@ -14,7 +15,7 @@ license="MIT"
 homepage="http://www.freedesktop.org/wiki/Software/HarfBuzz/"
 changelog="https://github.com/harfbuzz/harfbuzz/raw/main/NEWS"
 distfiles="https://github.com/harfbuzz/harfbuzz/releases/download/${version}/harfbuzz-${version}.tar.xz"
-checksum=4056b1541dd8bbd8ec29207fe30e568805c0705515632d7fec53a94399bc7945
+checksum=0edcc980f526a338452180e701d6aba6323aef457b6686976a7d17ccbddc51cf
 
 libharfbuzz_package() {
 	short_desc+=" - runtime library"

From 3d1ca6bbdaeae6f03867619e6d0dd374f977e605 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 26 Nov 2021 12:01:25 +0700
Subject: [PATCH 203/288] gconf-editor: remove

---
 srcpkgs/gconf-editor/template     | 27 ---------------------------
 srcpkgs/removed-packages/template |  1 +
 2 files changed, 1 insertion(+), 27 deletions(-)
 delete mode 100644 srcpkgs/gconf-editor/template

diff --git a/srcpkgs/gconf-editor/template b/srcpkgs/gconf-editor/template
deleted file mode 100644
index d4d9fa79bd25..000000000000
--- a/srcpkgs/gconf-editor/template
+++ /dev/null
@@ -1,27 +0,0 @@
-# Template file for 'gconf-editor'
-pkgname=gconf-editor
-version=3.0.1
-revision=3
-build_style=gnu-configure
-configure_args="--disable-schemas-install --disable-scrollkeeper
- --with-gconf-schema-file-dir=/usr/share/gconf/schemas"
-hostmakedepends="pkg-config intltool itstool gnome-doc-utils GConf-devel which"
-makedepends="libxml2-devel gtk+3-devel gsettings-desktop-schemas-devel
- hicolor-icon-theme desktop-file-utils gnome-doc-utils GConf-devel"
-depends="gsettings-desktop-schemas>=3.10 hicolor-icon-theme desktop-file-utils"
-short_desc="Graphical editor to maintain the Gnome registry"
-maintainer="Enno Boland <gottox@voidlinux.org>"
-license="GPL-2.0-or-later"
-homepage="http://www.gnome.org"
-distfiles="${GNOME_SITE}/$pkgname/${version%.*}/$pkgname-$version.tar.xz"
-checksum=3064e84967b4b4216f5c7e065cfec8c52019438a590e9ed81366af2770660944
-
-post_patch() {
-	vsed -i -e 's/DATADIRNAME=lib/DATADIRNAME=share/' configure
-}
-
-post_install() {
-	mv ${DESTDIR}/usr/share/gconf/schemas/*.schemas ${wrksrc}
-	gconf-merge-schema ${DESTDIR}/usr/share/gconf/schemas/${pkgname}.schemas \
-		--domain ${pkgname} ${wrksrc}/*.schemas
-}
diff --git a/srcpkgs/removed-packages/template b/srcpkgs/removed-packages/template
index 8b9aa9d8bdff..ef53eba7a92e 100644
--- a/srcpkgs/removed-packages/template
+++ b/srcpkgs/removed-packages/template
@@ -67,6 +67,7 @@ replaces="
  epstopdf<=2.27_3
  fontmatrix<=0.6.0.20171228_2
  fuse-usmb<=20130204_7
+ gconf-editor<=3.0.1_3
  gegl3<=0.3.28_2
  gens-gs<=2.16.7_2
  geoip-data<=20171002_2

From ff96967a3f2a5a6d13718c390d79c8536eeb229d Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 26 Nov 2021 12:16:56 +0700
Subject: [PATCH 204/288] gmpc: not require gnome-doc-utils for check

---
 srcpkgs/gmpc/patches/locale-dir.patch       | 20 +++++++++++++++++++
 srcpkgs/gmpc/patches/no-mallard-check.patch | 22 +++++++++++++++++++++
 srcpkgs/gmpc/template                       |  5 -----
 3 files changed, 42 insertions(+), 5 deletions(-)
 create mode 100644 srcpkgs/gmpc/patches/locale-dir.patch
 create mode 100644 srcpkgs/gmpc/patches/no-mallard-check.patch

diff --git a/srcpkgs/gmpc/patches/locale-dir.patch b/srcpkgs/gmpc/patches/locale-dir.patch
new file mode 100644
index 000000000000..8398823dd765
--- /dev/null
+++ b/srcpkgs/gmpc/patches/locale-dir.patch
@@ -0,0 +1,20 @@
+--- a/configure
++++ b/configure
+@@ -11347,7 +11347,7 @@ fi
+ 
+     ;;
+     *)
+-    DATADIRNAME=lib
++    DATADIRNAME=share
+     ;;
+     esac
+ fi
+@@ -15026,7 +15026,7 @@ fi
+ 	    ;;
+ 	    *)
+ 	    CATOBJEXT=.mo
+-            DATADIRNAME=lib
++            DATADIRNAME=share
+ 	    ;;
+ 	    esac
+ fi
diff --git a/srcpkgs/gmpc/patches/no-mallard-check.patch b/srcpkgs/gmpc/patches/no-mallard-check.patch
new file mode 100644
index 000000000000..f36891f28498
--- /dev/null
+++ b/srcpkgs/gmpc/patches/no-mallard-check.patch
@@ -0,0 +1,22 @@
+--- a/doc/Makefile.am
++++ b/doc/Makefile.am
+@@ -1,7 +1,7 @@
+ man_MANS = gmpc.1 gmpc-remote.1 gmpc-remote-stream.1
+ EXTRA_DIST = $(man_MANS)
+ 
+-SUBDIRS=Mallard
++SUBDIRS=
+ 
+ .PHONY: doc
+ doc: Manual.txt
+--- a/doc/Makefile.in
++++ b/doc/Makefile.in
+@@ -311,7 +311,7 @@ unique_CFLAGS = @unique_CFLAGS@
+ unique_LIBS = @unique_LIBS@
+ man_MANS = gmpc.1 gmpc-remote.1 gmpc-remote-stream.1
+ EXTRA_DIST = $(man_MANS)
+-SUBDIRS = Mallard
++SUBDIRS =
+ all: all-recursive
+ 
+ .SUFFIXES:
diff --git a/srcpkgs/gmpc/template b/srcpkgs/gmpc/template
index 9993e6c49dfa..ec0c03ade913 100644
--- a/srcpkgs/gmpc/template
+++ b/srcpkgs/gmpc/template
@@ -6,7 +6,6 @@ build_style=gnu-configure
 hostmakedepends="pkg-config gob2 intltool vala"
 makedepends="gtk+-devel libSM-devel libmpd-devel libunique1-devel libsoup-devel sqlite-devel"
 depends="xdg-utils hicolor-icon-theme"
-checkdepends="gnome-doc-utils"
 short_desc="Gnome Music Player Client - The true MPD client"
 maintainer="Dave Davenport <qball@gmpclient.org>"
 license="GPL-2.0-or-later"
@@ -16,10 +15,6 @@ checksum=a69414f35396846733632ca9619921d7acda537ffd6d49bd84b444945cb76b2c
 
 LDFLAGS="-lm"
 
-post_patch() {
-	vsed -i -e 's/DATADIRNAME=lib/DATADIRNAME=share/' configure
-}
-
 gmpc-devel_package() {
 	short_desc+=" - development files"
 	depends="gtk+-devel libmpd-devel"

From 76da64cb008111b1591964a864526d37b8c771e0 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 26 Nov 2021 13:03:18 +0700
Subject: [PATCH 205/288] gnac: disable old gnome-help format

---
 srcpkgs/gnac/patches/fix-debug-log.patch      | 29 +++++++++++++++++++
 srcpkgs/gnac/patches/no-gnome-doc-utils.patch | 20 +++++++++++++
 srcpkgs/gnac/patches/no-po-check.patch        |  7 +++++
 srcpkgs/gnac/template                         |  6 ++--
 4 files changed, 59 insertions(+), 3 deletions(-)
 create mode 100644 srcpkgs/gnac/patches/fix-debug-log.patch
 create mode 100644 srcpkgs/gnac/patches/no-gnome-doc-utils.patch
 create mode 100644 srcpkgs/gnac/patches/no-po-check.patch

diff --git a/srcpkgs/gnac/patches/fix-debug-log.patch b/srcpkgs/gnac/patches/fix-debug-log.patch
new file mode 100644
index 000000000000..88fd15de6a56
--- /dev/null
+++ b/srcpkgs/gnac/patches/fix-debug-log.patch
@@ -0,0 +1,29 @@
+--- a/libgnac/libgnac-debug.h
++++ b/libgnac/libgnac-debug.h
+@@ -32,7 +32,7 @@
+ 
+ #if defined(__STDC_VERSION__) && __STDC_VERSION__ >= 199901L
+ #define libgnac_debug(...) \
+-        libgnac_debug_real (__func__, __FILE__, __LINE__, TRUE, __VA_ARGS__)
++        libgnac_debug_real (__func__, __FILE__, __LINE__, __VA_ARGS__)
+ #elif defined(__GNUC__) && __GNUC__ >= 3
+ #define libgnac_debug(...) \
+         libgnac_debug_real (__FUNCTION__, __FILE__, __LINE__, __VA_ARGS__)
+@@ -42,7 +42,7 @@
+ 
+ #if defined(__STDC_VERSION__) && __STDC_VERSION__ >= 199901L
+ #define libgnac_warning(...) \
+-        libgnac_warning_real (__func__, __FILE__, __LINE__, TRUE, __VA_ARGS__)
++        libgnac_warning_real (__func__, __FILE__, __LINE__, __VA_ARGS__)
+ #elif defined(__GNUC__) && __GNUC__ >= 3
+ #define libgnac_warning(...) \
+         libgnac_warning_real (__FUNCTION__, __FILE__, __LINE__, __VA_ARGS__)
+@@ -52,7 +52,7 @@
+ 
+ #if defined(__STDC_VERSION__) && __STDC_VERSION__ >= 199901L
+ #define libgnac_critical(...) \
+-        libgnac_critical_real (__func__, __FILE__, __LINE__, TRUE, __VA_ARGS__)
++        libgnac_critical_real (__func__, __FILE__, __LINE__, __VA_ARGS__)
+ #elif defined(__GNUC__) && __GNUC__ >= 3
+ #define libgnac_critical(...) \
+         libgnac_critical_real (__FUNCTION__, __FILE__, __LINE__, __VA_ARGS__)
diff --git a/srcpkgs/gnac/patches/no-gnome-doc-utils.patch b/srcpkgs/gnac/patches/no-gnome-doc-utils.patch
new file mode 100644
index 000000000000..00f89a338dbc
--- /dev/null
+++ b/srcpkgs/gnac/patches/no-gnome-doc-utils.patch
@@ -0,0 +1,20 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -55,7 +55,7 @@ AM_GLIB_GNU_GETTEXT
+ dnl Check for GSettings macros
+ GLIB_GSETTINGS
+ 
+-GNOME_DOC_INIT([0.17.2])
++GNOME_DOC_INIT([0.17.2],[:],[:])
+ GNOME_DEBUG_CHECK
+ GNOME_COMPILE_WARNINGS([maximum])
+ GNOME_CXX_WARNINGS([yes])
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,6 +1,5 @@
+ SUBDIRS = \
+ 	data \
+-	help \
+ 	libgnac \
+ 	man \
+ 	po \
diff --git a/srcpkgs/gnac/patches/no-po-check.patch b/srcpkgs/gnac/patches/no-po-check.patch
new file mode 100644
index 000000000000..bf1ddb4a9e7d
--- /dev/null
+++ b/srcpkgs/gnac/patches/no-po-check.patch
@@ -0,0 +1,7 @@
+--- a/po/POTFILES.skip
++++ b/po/POTFILES.skip
+@@ -1,3 +1,4 @@
+ # List of source files that should NOT be translated.
+ # Please keep this file sorted alphabetically.
+ data/gnac.desktop.in
++intl/plural.c
diff --git a/srcpkgs/gnac/template b/srcpkgs/gnac/template
index ad01a1e97f91..9fea6a370e87 100644
--- a/srcpkgs/gnac/template
+++ b/srcpkgs/gnac/template
@@ -1,15 +1,15 @@
 # Template file for 'gnac'
 pkgname=gnac
 version=0.2.4.1
-revision=3
+revision=4
 build_style=gnu-configure
 configure_args="--disable-scrollkeeper --disable-schemas-compile"
 hostmakedepends="gnome-common gettext-devel pkg-config intltool libtool
- gnome-doc-utils glib-devel gtk+3-devel gst-plugins-base1-devel
+ glib-devel gtk+3-devel gst-plugins-base1-devel
  autoconf-archive which"
 makedepends="libxml2-devel gtk+3-devel gst-plugins-base1-devel libunique-devel
  libnotify-devel gst-plugins-good1 gst-plugins-bad1 gst-plugins-ugly1
- desktop-file-utils hicolor-icon-theme gnome-doc-utils"
+ desktop-file-utils hicolor-icon-theme"
 depends="gst-plugins-good1 gst-plugins-bad1 gst-plugins-ugly1
  desktop-file-utils hicolor-icon-theme"
 short_desc="Audio conversion program for the Gnome desktop"

From bc710f8842cb677b43dd11b2a9d2c60b17859ab8 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
 <congdanhqx@gmail.com>
Date: Fri, 26 Nov 2021 13:05:33 +0700
Subject: [PATCH 206/288] gnome-doc-utils: remove

---
 srcpkgs/gnome-doc-utils/patches/python3.patch | 521 ------------------
 srcpkgs/gnome-doc-utils/template              |  21 -
 srcpkgs/removed-packages/template             |   1 +
 3 files changed, 1 insertion(+), 542 deletions(-)
 delete mode 100644 srcpkgs/gnome-doc-utils/patches/python3.patch
 delete mode 100644 srcpkgs/gnome-doc-utils/template

diff --git a/srcpkgs/gnome-doc-utils/patches/python3.patch b/srcpkgs/gnome-doc-utils/patches/python3.patch
deleted file mode 100644
index 284e38e775de..000000000000
--- a/srcpkgs/gnome-doc-utils/patches/python3.patch
+++ /dev/null
@@ -1,521 +0,0 @@
-taken from fedora, alpine, gentoo
-diff -U3 -r gnome-doc-utils-0.20.10.orig/xml2po/xml2po/__init__.py gnome-doc-utils-0.20.10/xml2po/xml2po/__init__.py
---- gnome-doc-utils-0.20.10.orig/xml2po/xml2po/__init__.py	2011-08-04 09:36:03.000000000 -0500
-+++ gnome-doc-utils-0.20.10/xml2po/xml2po/__init__.py	2019-09-10 09:30:28.018627919 -0500
-@@ -86,14 +86,14 @@
-                 self.messages.append(t)
-                 if spacepreserve:
-                     self.nowrap[t] = True
--                if t in self.linenos.keys():
-+                if t in list(self.linenos.keys()):
-                     self.linenos[t].append((self.filename, tag, lineno))
-                 else:
-                     self.linenos[t] = [ (self.filename, tag, lineno) ]
-                 if (not self.do_translations) and comment and not t in self.comments:
-                     self.comments[t] = comment
-             else:
--                if t in self.linenos.keys():
-+                if t in list(self.linenos.keys()):
-                     self.linenos[t].append((self.filename, tag, lineno))
-                 else:
-                     self.linenos[t] = [ (self.filename, tag, lineno) ]
-@@ -166,7 +166,7 @@
-         elif node.isText():
-             if node.isBlankNode():
-                 if self.app.options.get('expand_entities') or \
--                  (not (node.prev and not node.prev.isBlankNode() and node.next and not node.next.isBlankNode()) ):
-+                  (not (node.prev and not node.prev.isBlankNode() and node.__next__ and not node.next.isBlankNode()) ):
-                     #print >>sys.stderr, "BLANK"
-                     node.setContent('')
-             else:
-@@ -176,7 +176,7 @@
-             child = node.children
-             while child:
-                 self.normalizeNode(child)
--                child = child.next
-+                child = child.__next__
- 
-     def normalizeString(self, text, spacepreserve = False):
-         """Normalizes string to be used as key for gettext lookup.
-@@ -200,7 +200,7 @@
-             tree = ctxt.doc()
-             newnode = tree.getRootElement()
-         except:
--            print >> sys.stderr, """Error while normalizing string as XML:\n"%s"\n""" % (text)
-+            print("""Error while normalizing string as XML:\n"%s"\n""" % (text), file=sys.stderr)
-             return text
- 
-         self.normalizeNode(newnode)
-@@ -209,7 +209,7 @@
-         child = newnode.children
-         while child:
-             result += child.serialize('utf-8')
--            child = child.next
-+            child = child.__next__
- 
-         result = re.sub('^ ','', result)
-         result = re.sub(' $','', result)
-@@ -235,7 +235,7 @@
-         ctxt.parseDocument()
-         tree = ctxt.doc()
-         if next:
--            newnode = tree.children.next
-+            newnode = tree.children.__next__
-         else:
-             newnode = tree.children
- 
-@@ -243,7 +243,7 @@
-         child = newnode.children
-         while child:
-             result += child.serialize('utf-8')
--            child = child.next
-+            child = child.__next__
-         tree.freeDoc()
-         return result
- 
-@@ -262,7 +262,7 @@
-                         result += child.content.decode('utf-8')
-                 else:
-                     result += self.myAttributeSerialize(child)
--                child = child.next
-+                child = child.__next__
-         else:
-             result = node.serialize('utf-8')
-         return result
-@@ -338,7 +338,7 @@
-                 pass
- 
-             if not newnode:
--                print >> sys.stderr, """Error while parsing translation as XML:\n"%s"\n""" % (text.encode('utf-8'))
-+                print("""Error while parsing translation as XML:\n"%s"\n""" % (text.encode('utf-8')), file=sys.stderr)
-                 return
- 
-             newelem = newnode.getRootElement()
-@@ -346,13 +346,13 @@
-             if newelem and newelem.children:
-                 free = node.children
-                 while free:
--                    next = free.next
-+                    next = free.__next__
-                     free.unlinkNode()
-                     free = next
- 
-                 if node:
-                     copy = newelem.copyNodeList()
--                    next = node.next
-+                    next = node.__next__
-                     node.replaceNode(newelem.copyNodeList())
-                     node.next = next
- 
-@@ -378,7 +378,7 @@
-             if child.type in ['text'] and  child.content.strip()!='':
-                 final = True
-                 break
--            child = child.next
-+            child = child.__next__
- 
-         node.__autofinal__ = final
-         return final
-@@ -457,7 +457,7 @@
-                     outtxt += '<%s>%s</%s>' % (starttag, content, endtag)
-                 else:
-                     outtxt += self.doSerialize(child)
--            child = child.next
-+            child = child.__next__
- 
-         if self.app.operation == 'merge':
-             norm_outtxt = self.normalizeString(outtxt, self.app.isSpacePreserveNode(node))
-@@ -534,7 +534,7 @@
-             outtxt = ''
-             while child:
-                 outtxt += self.doSerialize(child)
--                child = child.next
-+                child = child.__next__
-             return outtxt
- 
- def xml_error_handler(arg, ctxt):
-@@ -577,8 +577,8 @@
-                 raise IOError("Unable to read file '%s'" % xmlfile)
-             try:
-                 doc = XMLDocument(xmlfile, self)
--            except Exception, e:
--                print >> sys.stderr, "Unable to parse XML file '%s': %s" % (xmlfile, str(e))
-+            except Exception as e:
-+                print("Unable to parse XML file '%s': %s" % (xmlfile, str(e)), file=sys.stderr)
-                 sys.exit(1)
-             self.current_mode.preProcessXml(doc.doc, self.msg)
-             doc.generate_messages()
-@@ -590,14 +590,14 @@
-             raise IOError("Unable to read file '%s'" % xmlfile)
-         try:
-             doc = XMLDocument(xmlfile, self)
--        except Exception, e:
--            print >> sys.stderr, str(e)
-+        except Exception as e:
-+            print(str(e), file=sys.stderr)
-             sys.exit(1)
- 
-         try:
-             mfile = open(mofile, "rb")
-         except:
--            print >> sys.stderr, "Can't open MO file '%s'." % (mofile)
-+            print("Can't open MO file '%s'." % (mofile), file=sys.stderr)
-         self.gt = gettext.GNUTranslations(mfile)
-         self.gt.add_fallback(NoneTranslations())
-         # Has preProcessXml use cases for merge?
-@@ -619,16 +619,16 @@
-             raise IOError("Unable to read file '%s'" % xmlfile)
-         try:
-             doc = XMLDocument(xmlfile, self)
--        except Exception, e:
--            print >> sys.stderr, str(e)
-+        except Exception as e:
-+            print(str(e), file=sys.stderr)
-             sys.exit(1)
-         doc.generate_messages()
- 
-         self.msg.translationsFollow()
-         try:
-             doc = XMLDocument(origxml, self)
--        except Exception, e:
--            print >> sys.stderr, str(e)
-+        except Exception as e:
-+            print(str(e), file=sys.stderr)
-             sys.exit(1)
-         doc.generate_messages()
-         self.output_po()
-diff -U3 -r gnome-doc-utils-0.20.10.orig/xml2po/xml2po/modes/docbook.py gnome-doc-utils-0.20.10/xml2po/xml2po/modes/docbook.py
---- gnome-doc-utils-0.20.10.orig/xml2po/xml2po/modes/docbook.py	2011-01-10 10:08:10.000000000 -0600
-+++ gnome-doc-utils-0.20.10/xml2po/xml2po/modes/docbook.py	2019-09-10 09:31:15.199572286 -0500
-@@ -43,7 +43,7 @@
- except ImportError:
-     from md5 import new as md5_new
- 
--from basic import basicXmlMode
-+from .basic import basicXmlMode
- 
- class docbookXmlMode(basicXmlMode):
-     """Class for special handling of DocBook document types.
-@@ -131,7 +131,7 @@
-                     hash = self._md5_for_file(fullpath)
-                 else:
-                     hash = "THIS FILE DOESN'T EXIST"
--                    print >>sys.stderr, "Warning: image file '%s' not found." % fullpath
-+                    print("Warning: image file '%s' not found." % fullpath, file=sys.stderr)
- 
-                 msg.outputMessage("@@image: '%s'; md5=%s" % (attr, hash), node.lineNo(),
-                                   "When image changes, this message will be marked fuzzy or untranslated for you.\n"+
-@@ -198,10 +198,10 @@
- # Perform some tests when ran standalone
- if __name__ == '__main__':
-     test = docbookXmlMode()
--    print "Ignored tags       : " + repr(test.getIgnoredTags())
--    print "Final tags         : " + repr(test.getFinalTags())
--    print "Space-preserve tags: " + repr(test.getSpacePreserveTags())
-+    print("Ignored tags       : " + repr(test.getIgnoredTags()))
-+    print("Final tags         : " + repr(test.getFinalTags()))
-+    print("Space-preserve tags: " + repr(test.getSpacePreserveTags()))
- 
--    print "Credits from string: '%s'" % test.getStringForTranslators()
--    print "Explanation for credits:\n\t'%s'" % test.getCommentForTranslators()
-+    print("Credits from string: '%s'" % test.getStringForTranslators())
-+    print("Explanation for credits:\n\t'%s'" % test.getCommentForTranslators())
- 
-diff -U3 -r gnome-doc-utils-0.20.10.orig/xml2po/xml2po/modes/gs.py gnome-doc-utils-0.20.10/xml2po/xml2po/modes/gs.py
---- gnome-doc-utils-0.20.10.orig/xml2po/xml2po/modes/gs.py	2010-12-13 10:14:07.000000000 -0600
-+++ gnome-doc-utils-0.20.10/xml2po/xml2po/modes/gs.py	2019-09-10 09:31:15.201572284 -0500
-@@ -20,7 +20,7 @@
- # Special case Gnome Summary
- #
- 
--from basic import basicXmlMode
-+from .basic import basicXmlMode
- 
- class gsXmlMode(basicXmlMode):
-     """Abstract class for special handling of document types."""
-diff -U3 -r gnome-doc-utils-0.20.10.orig/xml2po/xml2po/modes/mallard.py gnome-doc-utils-0.20.10/xml2po/xml2po/modes/mallard.py
---- gnome-doc-utils-0.20.10.orig/xml2po/xml2po/modes/mallard.py	2011-01-10 10:08:50.000000000 -0600
-+++ gnome-doc-utils-0.20.10/xml2po/xml2po/modes/mallard.py	2019-09-10 09:31:15.212572271 -0500
-@@ -39,7 +39,7 @@
- except ImportError:
-     from md5 import new as md5_new
- 
--from basic import basicXmlMode
-+from .basic import basicXmlMode
- 
- class mallardXmlMode(basicXmlMode):
-     """Class for special handling of Mallard document types."""
-@@ -112,7 +112,7 @@
-                     hash = self._md5_for_file(fullpath)
-                 else:
-                     hash = "THIS FILE DOESN'T EXIST"
--                    print >>sys.stderr, "Warning: image file '%s' not found." % fullpath
-+                    print("Warning: image file '%s' not found." % fullpath, file=sys.stderr)
-                     
-                 msg.outputMessage("@@image: '%s'; md5=%s" % (attr, hash), node.lineNo(),
-                                   "When image changes, this message will be marked fuzzy or untranslated for you.\n"+
-diff -U3 -r gnome-doc-utils-0.20.10.orig/xml2po/xml2po/modes/ubuntu.py gnome-doc-utils-0.20.10/xml2po/xml2po/modes/ubuntu.py
---- gnome-doc-utils-0.20.10.orig/xml2po/xml2po/modes/ubuntu.py	2010-12-13 10:14:07.000000000 -0600
-+++ gnome-doc-utils-0.20.10/xml2po/xml2po/modes/ubuntu.py	2019-09-10 09:31:15.213572270 -0500
-@@ -2,7 +2,7 @@
- 
- import libxml2
- 
--from docbook import docbookXmlMode
-+from .docbook import docbookXmlMode
- 
- class ubuntuXmlMode (docbookXmlMode):
-     """Special-casing Ubuntu DocBook website documentation."""
-diff -U3 -r gnome-doc-utils-0.20.10.orig/xml2po/xml2po/modes/xhtml.py gnome-doc-utils-0.20.10/xml2po/xml2po/modes/xhtml.py
---- gnome-doc-utils-0.20.10.orig/xml2po/xml2po/modes/xhtml.py	2010-12-13 10:14:07.000000000 -0600
-+++ gnome-doc-utils-0.20.10/xml2po/xml2po/modes/xhtml.py	2019-09-10 09:31:15.214572269 -0500
-@@ -21,7 +21,7 @@
- # This implements special instructions for handling XHTML documents
- # in a better way, particularly to extract some attributes in HTML tags
- 
--from basic import basicXmlMode
-+from .basic import basicXmlMode
- 
- class xhtmlXmlMode(basicXmlMode):
-     """Class for special handling of XHTML document types."""
-diff -U3 -r gnome-doc-utils-0.20.10.orig/xml2po/xml2po/xml2po.py.in gnome-doc-utils-0.20.10/xml2po/xml2po/xml2po.py.in
---- gnome-doc-utils-0.20.10.orig/xml2po/xml2po/xml2po.py.in	2010-12-13 10:14:07.000000000 -0600
-+++ gnome-doc-utils-0.20.10/xml2po/xml2po/xml2po.py.in	2019-09-10 09:30:28.217627684 -0500
-@@ -41,9 +41,9 @@
- if not os.path.exists('/dev/null'): NULL_STRING = 'NUL'
- 
- def usage (with_help = False):
--    print >> sys.stderr, "Usage:  %s [OPTIONS] [XMLFILE]..." % (sys.argv[0])
-+    print("Usage:  %s [OPTIONS] [XMLFILE]..." % (sys.argv[0]), file=sys.stderr)
-     if with_help:
--        print >> sys.stderr, """
-+        print("""
- OPTIONS may be some of:
-     -a    --automatic-tags     Automatically decides if tags are to be considered
-                                  "final" or not
-@@ -72,7 +72,7 @@
-     using -p option for each XML file:
-         %(command)s -p de.po chapter1.xml > chapter1.de.xml
-         %(command)s -p de.po chapter2.xml > chapter2.de.xml
--""" % {'command': sys.argv[0]}
-+""" % {'command': sys.argv[0]}, file=sys.stderr)
- 
- 
- def main(argv):
-@@ -82,7 +82,7 @@
- 
-     name = os.path.join(os.path.dirname(__file__), '..')
-     if os.path.exists(os.path.join(name, 'tests')):
--        print >> sys.stderr, 'Running from source folder, modifying PYTHONPATH'
-+        print('Running from source folder, modifying PYTHONPATH', file=sys.stderr)
-         sys.path.insert(0, name)
- 
-     from xml2po import Main
-@@ -142,14 +142,14 @@
-         elif opt in ('-o', '--output'):
-             output = arg
-         elif opt in ('-v', '--version'):
--            print VERSION
-+            print(VERSION)
-             sys.exit(0)
-         elif opt in ('-h', '--help'):
-             usage(True)
-             sys.exit(0)
- 
-     if operation == 'update' and output != "-":
--        print >> sys.stderr, "Option '-o' is not yet supported when updating translations directly. Ignoring this option."
-+        print("Option '-o' is not yet supported when updating translations directly. Ignoring this option.", file=sys.stderr)
- 
-     # Treat remaining arguments as XML files
-     filenames = []
-@@ -159,16 +159,16 @@
-     try:
-         xml2po_main = Main(default_mode, operation, output, options)
-     except IOError:
--        print >> sys.stderr, "Error: cannot open file %s for writing." % (output)
-+        print("Error: cannot open file %s for writing." % (output), file=sys.stderr)
-         sys.exit(5)
- 
-     if operation == 'merge':
-         if len(filenames) > 1:
--            print  >> sys.stderr, "Error: You can merge translations with only one XML file at a time."
-+            print("Error: You can merge translations with only one XML file at a time.", file=sys.stderr)
-             sys.exit(2)
- 
-         if not mofile:
--            print >> sys.stderr, "Error: You must specify MO file when merging translations."
-+            print("Error: You must specify MO file when merging translations.", file=sys.stderr)
-             sys.exit(3)
- 
-         xml2po_main.merge(mofile, filenames[0])
---- gnome-doc-utils-0.20.10/xml2po/xml2po/__init__.py.orig	2019-09-10 09:34:42.110328324 -0500
-+++ gnome-doc-utils-0.20.10/xml2po/xml2po/__init__.py	2019-09-10 09:34:44.170325899 -0500
-@@ -166,7 +166,7 @@
-         elif node.isText():
-             if node.isBlankNode():
-                 if self.app.options.get('expand_entities') or \
--                  (not (node.prev and not node.prev.isBlankNode() and node.__next__ and not node.next.isBlankNode()) ):
-+                  (not (node.prev and not node.prev.isBlankNode() and node.next and not node.next.isBlankNode()) ):
-                     #print >>sys.stderr, "BLANK"
-                     node.setContent('')
-             else:
-@@ -176,7 +176,7 @@
-             child = node.children
-             while child:
-                 self.normalizeNode(child)
--                child = child.__next__
-+                child = child.next
- 
-     def normalizeString(self, text, spacepreserve = False):
-         """Normalizes string to be used as key for gettext lookup.
-@@ -209,7 +209,7 @@
-         child = newnode.children
-         while child:
-             result += child.serialize('utf-8')
--            child = child.__next__
-+            child = child.next
- 
-         result = re.sub('^ ','', result)
-         result = re.sub(' $','', result)
-@@ -235,7 +235,7 @@
-         ctxt.parseDocument()
-         tree = ctxt.doc()
-         if next:
--            newnode = tree.children.__next__
-+            newnode = tree.children.next
-         else:
-             newnode = tree.children
- 
-@@ -243,7 +243,7 @@
-         child = newnode.children
-         while child:
-             result += child.serialize('utf-8')
--            child = child.__next__
-+            child = child.next
-         tree.freeDoc()
-         return result
- 
-@@ -262,7 +262,7 @@
-                         result += child.content.decode('utf-8')
-                 else:
-                     result += self.myAttributeSerialize(child)
--                child = child.__next__
-+                child = child.next
-         else:
-             result = node.serialize('utf-8')
-         return result
-@@ -346,13 +346,13 @@
-             if newelem and newelem.children:
-                 free = node.children
-                 while free:
--                    next = free.__next__
-+                    next = free.next
-                     free.unlinkNode()
-                     free = next
- 
-                 if node:
-                     copy = newelem.copyNodeList()
--                    next = node.__next__
-+                    next = node.next
-                     node.replaceNode(newelem.copyNodeList())
-                     node.next = next
- 
-@@ -378,7 +378,7 @@
-             if child.type in ['text'] and  child.content.strip()!='':
-                 final = True
-                 break
--            child = child.__next__
-+            child = child.next
- 
-         node.__autofinal__ = final
-         return final
-@@ -457,7 +457,7 @@
-                     outtxt += '<%s>%s</%s>' % (starttag, content, endtag)
-                 else:
-                     outtxt += self.doSerialize(child)
--            child = child.__next__
-+            child = child.next
- 
-         if self.app.operation == 'merge':
-             norm_outtxt = self.normalizeString(outtxt, self.app.isSpacePreserveNode(node))
-@@ -534,7 +534,7 @@
-             outtxt = ''
-             while child:
-                 outtxt += self.doSerialize(child)
--                child = child.__next__
-+                child = child.next
-             return outtxt
- 
- def xml_error_handler(arg, ctxt):
---- gnome-doc-utils-0.20.10/xml2po/xml2po/__init__.py.orig	2019-09-10 09:39:57.733974912 -0500
-+++ gnome-doc-utils-0.20.10/xml2po/xml2po/__init__.py	2019-09-10 09:40:24.761946962 -0500
-@@ -326,7 +326,7 @@
-                 pass
- 
-             content = '<%s>%s</%s>' % (starttag, text, endtag)
--            tmp = tmp + content.encode('utf-8')
-+            tmp = tmp + content
- 
-             newnode = None
-             try:
-@@ -663,7 +663,7 @@
-         if not text or text.strip() == '':
-             return text
-         if self.gt:
--            res = self.gt.ugettext(text.decode('utf-8'))
-+            res = self.gt.gettext(text)
-             return res
- 
-         return text
---- gnome-doc-utils-0.20.10/xml2po/xml2po/__init__.py.orig	2019-09-10 09:41:23.853885851 -0500
-+++ gnome-doc-utils-0.20.10/xml2po/xml2po/__init__.py	2019-09-10 09:44:23.580699979 -0500
-@@ -352,9 +352,10 @@
- 
-                 if node:
-                     copy = newelem.copyNodeList()
--                    next = node.next
-+                    #next = node.next
-                     node.replaceNode(newelem.copyNodeList())
--                    node.next = next
-+                    #print(type(next))
-+                    #node.next = next
- 
-             else:
-                 # In practice, this happens with tags such as "<para>    </para>" (only whitespace in between)
-@@ -470,7 +471,7 @@
- 
-         worth = self.worthOutputting(node)
-         if not translation:
--            translation = outtxt.decode('utf-8')
-+            translation = outtxt
-             if worth and self.app.options.get('mark_untranslated'):
-                 node.setLang('C')
- 
---- gnome-doc-utils-0.20.10/xml2po/xml2po/modes/docbook.py.orig	2019-09-10 09:46:15.409584334 -0500
-+++ gnome-doc-utils-0.20.10/xml2po/xml2po/modes/docbook.py	2019-09-10 09:46:30.164569075 -0500
-@@ -184,7 +184,7 @@
-                     else:
-                         ai.addChild(copy)
-                     if match.group(3):
--                        copy.newChild(None, "year", match.group(3).encode('utf-8'))
-+                        copy.newChild(None, "year", match.group(3))
-                     if match.group(1) and match.group(2):
-                         holder = match.group(1)+"(%s)" % match.group(2)
-                     elif match.group(1):
-@@ -193,7 +193,7 @@
-                         holder = match.group(2)
-                     else:
-                         holder = "???"
--                    copy.newChild(None, "holder", holder.encode('utf-8'))
-+                    copy.newChild(None, "holder", holder)
- 
- # Perform some tests when ran standalone
- if __name__ == '__main__':
---- gnome-doc-utils-0.20.10/xml2po/xml2po/xml2po.py.in~	2019-09-10 09:50:34.000000000 -0500
-+++ gnome-doc-utils-0.20.10/xml2po/xml2po/xml2po.py.in	2019-09-10 09:50:45.114305443 -0500
-@@ -1,4 +1,4 @@
--#!/usr/bin/python -u
-+#!/usr/bin/python3 -u
- # -*- encoding: utf-8 -*-
- # Copyright (c) 2004, 2005, 2006 Danilo Šegan <danilo@gnome.org>.
- # Copyright (c) 2009 Claude Paroz <claude@2xlibre.net>.
diff --git a/srcpkgs/gnome-doc-utils/template b/srcpkgs/gnome-doc-utils/template
deleted file mode 100644
index f63c6106f6c1..000000000000
--- a/srcpkgs/gnome-doc-utils/template
+++ /dev/null
@@ -1,21 +0,0 @@
-# Template file for 'gnome-doc-utils'
-pkgname=gnome-doc-utils
-version=0.20.10
-revision=9
-build_style=gnu-configure
-configure_args="--disable-scrollkeeper"
-hostmakedepends="pkg-config intltool python3 libxml2-python3 libxslt
- gsettings-desktop-schemas"
-makedepends="libxslt-devel docbook-xml docbook-xsl rarian python3
- libxml2-python3 libxslt"
-depends="libxslt docbook-xml docbook-xsl rarian python3 libxml2-python3"
-short_desc="Documentation utilities for GNOME"
-maintainer="Orphaned <orphan@voidlinux.org>"
-license="GPL-2.0-or-later, LGPL-2.1-or-later"
-homepage="https://wiki.gnome.org/Projects/GnomeDocUtils"
-distfiles="${GNOME_SITE}/${pkgname}/0.20/${pkgname}-${version}.tar.xz"
-checksum=cb0639ffa9550b6ddf3b62f3b1add92fb92ab4690d351f2353cffe668be8c4a6
-
-post_patch() {
-	vsed -i -e 's/DATADIRNAME=lib/DATADIRNAME=share/' configure
-}
diff --git a/srcpkgs/removed-packages/template b/srcpkgs/removed-packages/template
index ef53eba7a92e..2b16ae44131f 100644
--- a/srcpkgs/removed-packages/template
+++ b/srcpkgs/removed-packages/template
@@ -74,6 +74,7 @@ replaces="
  gespeaker<=0.8.6_3
  gksu<=2.0.2_4
  glibmm-doc<=2.64.2_2
+ gnome-doc-utils<=0.20.10_9
  gnome-getting-started-docs<=3.38.1_1
  gnome-shell-mousewheel-zoom<=0.8.0_2
  gnome-twitch<=0.4.2_1

From 10aca3db86ce1782bd2a887a5d424dcd9a09a042 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Wed, 1 Dec 2021 15:04:30 +0100
Subject: [PATCH 207/288] linux5.15: update to 5.15.6.

---
 srcpkgs/linux5.15/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/linux5.15/template b/srcpkgs/linux5.15/template
index 02de9dab5756..484f473b5ba8 100644
--- a/srcpkgs/linux5.15/template
+++ b/srcpkgs/linux5.15/template
@@ -1,6 +1,6 @@
 # Template file for 'linux5.15'
 pkgname=linux5.15
-version=5.15.5
+version=5.15.6
 revision=1
 wrksrc="linux-${version%.*}"
 short_desc="Linux kernel and modules (${version%.*} series)"
@@ -10,7 +10,7 @@ homepage="https://www.kernel.org"
 distfiles="https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-${version%.*}.tar.xz
  https://cdn.kernel.org/pub/linux/kernel/v5.x/patch-${version}.xz"
 checksum="57b2cf6991910e3b67a1b3490022e8a0674b6965c74c12da1e99d138d1991ee8
- 8fdc0ef34a877379bcb9b617006edafba66f9213fc2c1df7451b578ae33b5496"
+ 23f5753121e2f18ef757449f94728d18ba70a20728dd217a53d4fa0a1cde621e"
 skip_extraction="patch-${version}.xz"
 python_version=3
 

From de8f201a090888d10c7c649f056cb2d92f05a894 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Wed, 1 Dec 2021 15:05:25 +0100
Subject: [PATCH 208/288] linux5.10: update to 5.10.83.

---
 srcpkgs/linux5.10/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/linux5.10/template b/srcpkgs/linux5.10/template
index 295165a43440..422c10d16ba8 100644
--- a/srcpkgs/linux5.10/template
+++ b/srcpkgs/linux5.10/template
@@ -1,6 +1,6 @@
 # Template file for 'linux5.10'
 pkgname=linux5.10
-version=5.10.82
+version=5.10.83
 revision=1
 wrksrc="linux-${version}"
 short_desc="Linux kernel and modules (${version%.*} series)"
@@ -8,7 +8,7 @@ maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="GPL-2.0-only"
 homepage="https://www.kernel.org"
 distfiles="https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-${version}.tar.xz"
-checksum=d66f7c7eed02f84ae550b3c91a26c70eea13682a6d672432f07bce66ff8ce350
+checksum=ef259a43f33ddb56001283f4f4e50af29b8a48fa066aed7371a90ebf38c29b70
 python_version=3
 
 # XXX Restrict archs until a proper <arch>-dotconfig is available in FILESDIR.

From d076f5224c107390c463d79410af2921a7c1b8e7 Mon Sep 17 00:00:00 2001
From: Duncaen <duncaen@voidlinux.org>
Date: Wed, 1 Dec 2021 17:25:33 +0100
Subject: [PATCH 209/288] yt-dlp: add missing python3 dependency

---
 srcpkgs/yt-dlp/template | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/srcpkgs/yt-dlp/template b/srcpkgs/yt-dlp/template
index b142e21ddba6..9432641a5e73 100644
--- a/srcpkgs/yt-dlp/template
+++ b/srcpkgs/yt-dlp/template
@@ -1,11 +1,12 @@
 # Template file for 'yt-dlp'
 pkgname=yt-dlp
 version=2021.11.10.1
-revision=1
+revision=2
 wrksrc="$pkgname"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 checkdepends="python3-pytest flake8 python3-nose"
+depends="python3"
 short_desc="CLI program to download videos from YouTube and other sites"
 maintainer="Michal Vasilek <michal@vasilek.cz>"
 license="Unlicense"

From 91671636c92fdf2a7b432b16b87412dc2dd6e0ae Mon Sep 17 00:00:00 2001
From: mobinmob <mobinmob@disroot.org>
Date: Tue, 30 Nov 2021 19:36:35 +0100
Subject: [PATCH 210/288] skype: update to 8.79.0.92.

---
 srcpkgs/skype/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/skype/template b/srcpkgs/skype/template
index a09223ab1b54..c018a5e5031d 100644
--- a/srcpkgs/skype/template
+++ b/srcpkgs/skype/template
@@ -1,7 +1,7 @@
 # Template file for 'skype'
 # This just repackages the rpm package.
 pkgname=skype
-version=8.78.0.161
+version=8.79.0.92
 revision=1
 archs="x86_64"
 create_wrksrc=yes
@@ -12,7 +12,7 @@ maintainer="mobinmob <mobinmob@disroot.org>"
 license="custom:skype-servicesagreement" # no vlicense
 homepage="https://www.skype.com"
 distfiles="https://repo.skype.com/rpm/stable/skypeforlinux_${version}-1.x86_64.rpm"
-checksum=db6a9aafa028c16f2f789e3d496adb465f1b6476f88c384752d95130d6af72a1
+checksum=93b3cfd8fc403fb7b4707579a2f4b068ed7077c257179b7b401612d60b41c8f7
 repository="nonfree"
 nostrip="yes"
 

From f553e311f82a605bbb14d00bd58bf5570e73fceb Mon Sep 17 00:00:00 2001
From: Andrew Benson <abenson+void@gmail.com>
Date: Wed, 1 Dec 2021 15:26:38 -0600
Subject: [PATCH 211/288] wgetpaste: update to 2.32.

---
 srcpkgs/wgetpaste/template | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/wgetpaste/template b/srcpkgs/wgetpaste/template
index 1688736a76b4..c91532415d78 100644
--- a/srcpkgs/wgetpaste/template
+++ b/srcpkgs/wgetpaste/template
@@ -1,17 +1,18 @@
 # Template file for 'wgetpaste'
 pkgname=wgetpaste
-version=2.30
+version=2.32
 revision=1
 depends="bash wget"
 short_desc="Script that automates pasting to a number of pastebin services"
 maintainer="Orphaned <orphan@voidlinux.org>"
-license="Public Domain"
+license="MIT"
 homepage="http://wgetpaste.zlin.dk/"
-distfiles="http://wgetpaste.zlin.dk/${pkgname}-${version}.tar.bz2"
-checksum=e3ec35f1ff49f2204864e3b4d784f6c032cdddb62cadf69263900c67a4896592
+distfiles="https://github.com/zlin/wgetpaste/releases/download/${version}/wgetpaste-${version}.tar.xz"
+checksum=621dbafbc7bcf5438f11447a325d8974069e3df03ef0c8bb2a2cc3de2c0cdb13
 
 do_install() {
 	vbin ${pkgname}
 	vinstall _${pkgname} 644 usr/share/zsh/site-functions
 	vsconf ${FILESDIR}/${pkgname}.example
+	vlicense LICENSE
 }

From 74e95a4d1b5cf896c472710031dfe5658f9beaad Mon Sep 17 00:00:00 2001
From: Omar Zeghouani <omarzeghouanii@gmail.com>
Date: Wed, 1 Dec 2021 23:07:30 +0000
Subject: [PATCH 212/288] i3status-rust: update to 0.20.7.

---
 srcpkgs/i3status-rust/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/i3status-rust/template b/srcpkgs/i3status-rust/template
index 36178f3938bc..d58ecb206a22 100644
--- a/srcpkgs/i3status-rust/template
+++ b/srcpkgs/i3status-rust/template
@@ -1,6 +1,6 @@
 # Template file for 'i3status-rust'
 pkgname=i3status-rust
-version=0.20.6
+version=0.20.7
 revision=1
 build_style=cargo
 make_check_args="--bins"
@@ -12,7 +12,7 @@ license="GPL-3.0-only"
 homepage="https://github.com/greshake/i3status-rust"
 changelog="https://raw.githubusercontent.com/greshake/i3status-rust/master/NEWS.md"
 distfiles="https://github.com/greshake/i3status-rust/archive/v${version}.tar.gz"
-checksum=a8b1257b09b73add3969c8bff2a4c77142164449ae3fea37a050ee95cc138b95
+checksum=995efe21ecf03e532cff9140cab1d4de9a35f91204d9e9edf0bfe3a22fedf5a0
 
 post_install() {
 	vmkdir usr/share/i3status-rust

From 2e641f575432986a90bdc782ce7ccbabf54e598f Mon Sep 17 00:00:00 2001
From: bugcrazy <39757967+bugcrazy@users.noreply.github.com>
Date: Wed, 1 Dec 2021 14:46:40 -0300
Subject: [PATCH 213/288] oil: update to 0.9.5

---
 srcpkgs/oil/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/oil/template b/srcpkgs/oil/template
index af1eb57e8d1c..9af2cc8e5435 100644
--- a/srcpkgs/oil/template
+++ b/srcpkgs/oil/template
@@ -1,6 +1,6 @@
 # Template file for 'oil'
 pkgname=oil
-version=0.9.4
+version=0.9.5
 revision=1
 build_style=configure
 configure_args="--prefix=/usr $(vopt_with readline)"
@@ -11,7 +11,7 @@ maintainer="MarcoAPC <marcoaureliopc@gmail.com>"
 license="Apache-2.0"
 homepage="https://www.oilshell.org"
 distfiles="${homepage}/download/${pkgname}-${version}.tar.xz"
-checksum=fac61bcd6b68c0bbf2e386aa84b107f26518527d4326bf473a02aadd85e53d02
+checksum=d89d8c081c8bc536dfc7b437b965a265c07e24cf5142ff26b21b4cc4a3139e32
 register_shell="/usr/bin/osh"
 nocross="Build systems gets confused with host and cross toolchains/headers"
 nostrip=yes

From 32c88a86d8abc584034dfb32a58789bb6ff923a6 Mon Sep 17 00:00:00 2001
From: Anton Afanasyev <1157248+2asoft@users.noreply.github.com>
Date: Tue, 30 Nov 2021 23:34:20 -0800
Subject: [PATCH 214/288] intellij-idea-ultimate-edition: update to 2021.3.

---
 srcpkgs/intellij-idea-ultimate-edition/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/intellij-idea-ultimate-edition/template b/srcpkgs/intellij-idea-ultimate-edition/template
index e3b32fea16d8..20f99d94125f 100644
--- a/srcpkgs/intellij-idea-ultimate-edition/template
+++ b/srcpkgs/intellij-idea-ultimate-edition/template
@@ -1,6 +1,6 @@
 # Template file for 'intellij-idea-ultimate-edition'
 pkgname=intellij-idea-ultimate-edition
-version=2021.2.3
+version=2021.3
 revision=1
 archs="i686 x86_64"
 create_wrksrc="true"
@@ -11,7 +11,7 @@ license="custom:Commercial"
 homepage="https://www.jetbrains.com/idea"
 _filename="ideaIU-${version}-no-jbr.tar.gz"
 distfiles="https://download.jetbrains.com/idea/${_filename}"
-checksum=0d879d4b16f096b81f401e0ab76a8b565d8142c632f9667cdb7fe5e6bd9813b4
+checksum=0b46ebb2381bd587bbec9d15ff78f11380bcf2654c0716c0caf747550ee73c66
 repository=nonfree
 restricted=yes
 nopie=yes

From 4c5cd387721c69f58ec17eb1b6577f7b768b0831 Mon Sep 17 00:00:00 2001
From: Anton Afanasyev <1157248+2asoft@users.noreply.github.com>
Date: Tue, 30 Nov 2021 23:28:45 -0800
Subject: [PATCH 215/288] jetbrains-jdk-bin: update to 11.0.13b1504.49.

---
 srcpkgs/jetbrains-jdk-bin/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/jetbrains-jdk-bin/template b/srcpkgs/jetbrains-jdk-bin/template
index 7114636c6562..f6b26790ad82 100644
--- a/srcpkgs/jetbrains-jdk-bin/template
+++ b/srcpkgs/jetbrains-jdk-bin/template
@@ -1,6 +1,6 @@
 # Template file for 'jetbrains-jdk-bin'
 pkgname=jetbrains-jdk-bin
-version=11.0.12b1504.40
+version=11.0.13b1504.49
 revision=1
 archs="x86_64"
 wrksrc="jbr"
@@ -11,7 +11,7 @@ homepage="https://github.com/JetBrains/JetBrainsRuntime"
 _jdk_ver=${version%b*}
 _jdk_build=${version#*b}
 distfiles="https://cache-redirector.jetbrains.com/intellij-jbr/jbr_jcef-${_jdk_ver//\./_}-linux-x64-b${_jdk_build}.tar.gz"
-checksum=56646f634eafbe85d177e40267f52d83a4bbfcb2bd359b97282bca54812e0784
+checksum=6e84df3c86adc9ec8d63f1151ffbe2081b2c10eb04ff40e1cb86d04b20c5d36e
 # This JDK appears to link to libs that do not exist, but functions well even in their absence.
 # Best guess is that they are optional. ¯\_(ツ)_/¯
 noverifyrdeps=yes

From ea78936a80e903b9c667756434514a490ef76f0f Mon Sep 17 00:00:00 2001
From: Joel Beckmeyer <joel@beckmeyer.us>
Date: Tue, 30 Nov 2021 09:52:30 -0500
Subject: [PATCH 216/288] python3-frozendict: update to 2.1.1.

---
 srcpkgs/python3-frozendict/template | 15 +++------------
 1 file changed, 3 insertions(+), 12 deletions(-)

diff --git a/srcpkgs/python3-frozendict/template b/srcpkgs/python3-frozendict/template
index cb161120a342..f6e3b6661395 100644
--- a/srcpkgs/python3-frozendict/template
+++ b/srcpkgs/python3-frozendict/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-frozendict'
 pkgname=python3-frozendict
-version=2.1.0
+version=2.1.1
 revision=1
 wrksrc="frozendict-${version}"
 build_style=python3-module
@@ -12,17 +12,8 @@ maintainer="Joel Beckmeyer <joel@beckmeyer.us>"
 license="LGPL-3.0-only"
 homepage="https://github.com/Marco-Sulla/python-frozendict"
 distfiles="${PYPI_SITE}/f/frozendict/frozendict-${version}.tar.gz"
-checksum=0189168749ddea8601afd648146c502533f93ae33840eb76cd71f694742623cd
+checksum=655b879217dd445a2023e16154cc231febef802b5c812d5c2e822280ad69e1dc
 
 do_check() {
-	# skip tests that are failing when using C
-	# extension due to difference between pure py and
-	# C extension
-	PYTHONPATH="$(cd build/lib* && pwd)" pytest3 \
-	 --deselect=test/test_coold.py::test_repr \
-	 --deselect=test/test_coold.py::test_str \
-	 --deselect=test/test_coold.py::test_format \
-	 --deselect=test/test_frozendict_c.py::test_repr \
-	 --deselect=test/test_frozendict_c.py::test_str \
-	 --deselect=test/test_frozendict_c.py::test_format
+	PYTHONPATH="$(cd build/lib* && pwd)" pytest3
 }

From e9bec51f6788f19435250246b59fb3a016dd93be Mon Sep 17 00:00:00 2001
From: Joel Beckmeyer <joel@beckmeyer.us>
Date: Tue, 30 Nov 2021 10:00:42 -0500
Subject: [PATCH 217/288] python3-phonenumbers: update to 8.12.38.

---
 srcpkgs/python3-phonenumbers/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-phonenumbers/template b/srcpkgs/python3-phonenumbers/template
index 70699dac90eb..29e82870d9a4 100644
--- a/srcpkgs/python3-phonenumbers/template
+++ b/srcpkgs/python3-phonenumbers/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-phonenumbers'
 pkgname=python3-phonenumbers
-version=8.12.37
+version=8.12.38
 revision=1
 wrksrc="phonenumbers-${version}"
 build_style=python3-module
@@ -12,4 +12,4 @@ license="Apache-2.0"
 homepage="https://github.com/daviddrysdale/python-phonenumbers"
 changelog="https://raw.githubusercontent.com/daviddrysdale/python-phonenumbers/dev/python/HISTORY.md"
 distfiles="${PYPI_SITE}/p/phonenumbers/phonenumbers-${version}.tar.gz"
-checksum=dbc560992844a059f56c7c0c6a587904e65d956740bbfb7e39589980bc9055b8
+checksum=3cda1d1cea9a6801babf825e6c0f6a9776ea6d8a68b81b256178f8e5aa813344

From b9e19f8e3fc9d70b1f595db6034644195e42d1b9 Mon Sep 17 00:00:00 2001
From: Joel Beckmeyer <joel@beckmeyer.us>
Date: Tue, 30 Nov 2021 09:55:55 -0500
Subject: [PATCH 218/288] synapse: update to 1.48.0.

---
 srcpkgs/synapse/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/synapse/template b/srcpkgs/synapse/template
index 20c4a4cc9970..bd5f529503e5 100644
--- a/srcpkgs/synapse/template
+++ b/srcpkgs/synapse/template
@@ -1,6 +1,6 @@
 # Template file for 'synapse'
 pkgname=synapse
-version=1.47.1
+version=1.48.0
 revision=1
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -19,7 +19,7 @@ license="Apache-2.0"
 homepage="https://github.com/matrix-org/synapse"
 changelog="https://raw.githubusercontent.com/matrix-org/synapse/develop/CHANGES.md"
 distfiles="https://github.com/matrix-org/synapse/archive/v${version}.tar.gz"
-checksum=cc385b6cfeba671bba800c2557ad39063bdd53f70dfb3781c85df7af6f5d064c
+checksum=182facc856f8d0c0d2d0dd4105fae4f851297167c0ee95c202a3aad9ed86c486
 
 system_accounts="synapse"
 synapse_homedir="/var/lib/synapse"

From 1b054aca214d0f927e2c9602fef574fedc2608a0 Mon Sep 17 00:00:00 2001
From: Clyhtsuriva <aimeric@adjutor.xyz>
Date: Tue, 30 Nov 2021 12:51:38 +0100
Subject: [PATCH 219/288] ddpt: update to 0.97

---
 srcpkgs/ddpt/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/ddpt/template b/srcpkgs/ddpt/template
index a647dfdc9a81..cbb5c53e0aa8 100644
--- a/srcpkgs/ddpt/template
+++ b/srcpkgs/ddpt/template
@@ -1,6 +1,6 @@
 # Template file for 'ddpt'
 pkgname=ddpt
-version=0.96
+version=0.97
 revision=1
 build_style=gnu-configure
 makedepends="sg3_utils-devel"
@@ -9,7 +9,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="BSD-3-Clause"
 homepage="http://sg.danny.cz/sg/ddpt.html"
 distfiles="http://sg.danny.cz/sg/p/${pkgname}-${version}.tgz"
-checksum=8f231342af7458fe592496d5e8ff4e9a22313b6e0bbc5be9c588ed392d75e1f4
+checksum=e340a529aeef6a107b0c24c64873da590f5284557faffdf57a0f9dc48807233d
 
 post_install() {
 	vlicense COPYING

From f1cecac8b1885102369527c343f98c0309ee4e81 Mon Sep 17 00:00:00 2001
From: Clyhtsuriva <aimeric@adjutor.xyz>
Date: Tue, 30 Nov 2021 12:25:35 +0100
Subject: [PATCH 220/288] chuck: update to 1.4.1.0

---
 srcpkgs/chuck/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/chuck/template b/srcpkgs/chuck/template
index acf5648af53b..9c6c8be9364a 100644
--- a/srcpkgs/chuck/template
+++ b/srcpkgs/chuck/template
@@ -1,6 +1,6 @@
 # Template file for 'chuck'
 pkgname=chuck
-version=1.4.0.1
+version=1.4.1.0
 revision=1
 build_wrksrc=src
 build_style=gnu-makefile
@@ -14,7 +14,7 @@ license="GPL-2.0-or-later"
 homepage="http://chuck.cs.princeton.edu"
 changelog="https://chuck.cs.princeton.edu/release/VERSIONS"
 distfiles="http://chuck.cs.princeton.edu/release/files/$pkgname-$version.tgz"
-checksum=11a20c34b385e132bf43d5ae6a562c652f631828cc6b1562a4c029bc9a850ed4
+checksum=74bf99ad515e3113c55b833152936fad02a3cf006a54105ff11777c473194928
 
 
 post_extract() {

From 706a84dcd30688bd198137e6bf14b1dedf5d01e8 Mon Sep 17 00:00:00 2001
From: jgart <jgart@dismail.de>
Date: Mon, 29 Nov 2021 23:00:26 -0500
Subject: [PATCH 221/288] chicken: update to 5.3.0.

---
 srcpkgs/chicken/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/chicken/template b/srcpkgs/chicken/template
index 7da68b4a0468..79fdc41fbfb6 100644
--- a/srcpkgs/chicken/template
+++ b/srcpkgs/chicken/template
@@ -1,6 +1,6 @@
 # Template file for 'chicken'
 pkgname=chicken
-version=5.2.0
+version=5.3.0
 revision=1
 short_desc="Practical and portable Scheme system"
 maintainer="Orphaned <orphan@voidlinux.org>"
@@ -8,7 +8,7 @@ license="BSD-3-Clause"
 homepage="http://www.call-cc.org"
 changelog="https://code.call-cc.org/releases/$version/NEWS"
 distfiles="http://code.call-cc.org/releases/$version/$pkgname-$version.tar.gz"
-checksum=819149c8ce7303a9b381d3fdc1d5765c5f9ac4dee6f627d1652f47966a8780fa
+checksum=c3ad99d8f9e17ed810912ef981ac3b0c2e2f46fb0ecc033b5c3b6dca1bdb0d76
 
 do_configure() {
 	make -B -f Makefile.linux chicken-defaults.h PREFIX=/usr

From 7554cffb83c690806cce8bfaa426ef83b83945d2 Mon Sep 17 00:00:00 2001
From: Evgeny Ermakov <evgeny.v.ermakov@gmail.com>
Date: Tue, 30 Nov 2021 06:15:55 +1100
Subject: [PATCH 222/288] fasm: update to 1.73.28.

---
 srcpkgs/fasm/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/fasm/template b/srcpkgs/fasm/template
index 020b96a5a3b8..9137a57e86e0 100644
--- a/srcpkgs/fasm/template
+++ b/srcpkgs/fasm/template
@@ -1,6 +1,6 @@
 # Template file for 'fasm'
 pkgname=fasm
-version=1.73.27
+version=1.73.28
 revision=1
 archs="i686* x86_64*"
 wrksrc=fasm
@@ -9,7 +9,7 @@ maintainer="Dmitry Bogatov <KAction@disroot.org>"
 license="BSD-2-Clause"
 homepage="https://flatassembler.net"
 distfiles="https://flatassembler.net/fasm-${version}.tgz"
-checksum=680148377fb6d3b6663852880faa03514d7326b5995742d33a87e244f48cf0b1
+checksum=9ed1ebb485fd1174111a94eb773105a234911398e05090f5e714abf62c809292
 nostrip=yes
 
 case ${XBPS_TARGET_MACHINE} in

From 17c5f25945379a4a1479612f0c5bc2571fc5b960 Mon Sep 17 00:00:00 2001
From: Evgeny Ermakov <evgeny.v.ermakov@gmail.com>
Date: Tue, 30 Nov 2021 06:22:00 +1100
Subject: [PATCH 223/288] gtkwave: update to 3.3.111.

---
 srcpkgs/gtkwave/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/gtkwave/template b/srcpkgs/gtkwave/template
index d99b80e33dbf..9370f93039b3 100644
--- a/srcpkgs/gtkwave/template
+++ b/srcpkgs/gtkwave/template
@@ -1,6 +1,6 @@
 # Template file for 'gtkwave'
 pkgname=gtkwave
-version=3.3.109
+version=3.3.111
 revision=1
 build_style=gnu-configure
 configure_args="--with-tcl=${XBPS_CROSS_BASE}/usr/lib --with-tk=${XBPS_CROSS_BASE}/usr/lib"
@@ -11,7 +11,7 @@ maintainer="allan <mail@may.mooo.com>"
 license="GPL-2.0-or-later, MIT"
 homepage="http://gtkwave.sourceforge.net/"
 distfiles="http://gtkwave.sourceforge.net/gtkwave-${version}.tar.gz"
-checksum=ca487e5e9b728086ba4de6581058d6c096a7771915163ef600f63d0e88c3c05d
+checksum=f6e6046674033e5bab6e4e2720d6bd7dba70b23f329614191b029e06c57ec296
 
 post_install() {
 	vlicense LICENSE.TXT

From 1853a012381f1b99f8698e189fd7bf58ce24364f Mon Sep 17 00:00:00 2001
From: Evgeny Ermakov <evgeny.v.ermakov@gmail.com>
Date: Tue, 30 Nov 2021 06:09:12 +1100
Subject: [PATCH 224/288] glfw: update to 3.3.5.

---
 srcpkgs/glfw/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/glfw/template b/srcpkgs/glfw/template
index 99feb63bca77..997829355280 100644
--- a/srcpkgs/glfw/template
+++ b/srcpkgs/glfw/template
@@ -1,7 +1,7 @@
 # Template file for 'glfw'
 # update together with glfw-wayland
 pkgname=glfw
-version=3.3.4
+version=3.3.5
 revision=1
 build_style=cmake
 configure_args="-DBUILD_SHARED_LIBS=ON"
@@ -12,7 +12,7 @@ maintainer="Enno Boland <gottox@voidlinux.org>"
 license="Zlib"
 homepage="http://www.glfw.org"
 distfiles="${SOURCEFORGE_SITE}/${pkgname}/${pkgname}-${version}.tar.bz2"
-checksum=035f4572d9b7967433b3256f0eaa5257532b0e18865878a162233b108b6ca1db
+checksum=7bf8d4df3436f6eac7356e47fff7eb5a3610a692bffa27ce57dd55166abed5ea
 
 glfw-devel_package() {
 	depends="glfw>=${version}_${revision} $makedepends"

From 8f13ee7b3e9905d578d322f09df6b6a73db59d0c Mon Sep 17 00:00:00 2001
From: Evgeny Ermakov <evgeny.v.ermakov@gmail.com>
Date: Tue, 30 Nov 2021 06:11:30 +1100
Subject: [PATCH 225/288] glfw-wayland: update to 3.3.5.

---
 srcpkgs/glfw-wayland/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/glfw-wayland/template b/srcpkgs/glfw-wayland/template
index 6f90d6bc7778..8991962c6af5 100644
--- a/srcpkgs/glfw-wayland/template
+++ b/srcpkgs/glfw-wayland/template
@@ -1,6 +1,6 @@
 # Template file for 'glfw-wayland'
 pkgname=glfw-wayland
-version=3.3.4
+version=3.3.5
 revision=1
 wrksrc=glfw-${version}
 build_style=cmake
@@ -13,7 +13,7 @@ maintainer="q66 <daniel@octaforge.org>"
 license="Zlib"
 homepage="http://www.glfw.org"
 distfiles="${SOURCEFORGE_SITE}/glfw/glfw-${version}.tar.bz2"
-checksum=035f4572d9b7967433b3256f0eaa5257532b0e18865878a162233b108b6ca1db
+checksum=7bf8d4df3436f6eac7356e47fff7eb5a3610a692bffa27ce57dd55166abed5ea
 provides="glfw-${version}_${revision}"
 replaces="glfw>=0"
 

From 0446d7c3dac906fd3831fb7d227980faeacaf227 Mon Sep 17 00:00:00 2001
From: Evgeny Ermakov <evgeny.v.ermakov@gmail.com>
Date: Tue, 30 Nov 2021 06:25:14 +1100
Subject: [PATCH 226/288] socat: update to 1.7.4.2.

---
 srcpkgs/socat/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/socat/template b/srcpkgs/socat/template
index d4e0f0a9bbdb..92ccc52bc08f 100644
--- a/srcpkgs/socat/template
+++ b/srcpkgs/socat/template
@@ -1,7 +1,7 @@
 # Template file for 'socat'
 pkgname=socat
-version=1.7.4.1
-revision=2
+version=1.7.4.2
+revision=1
 build_style=gnu-configure
 configure_args="--disable-libwrap --enable-fips
  ac_cv_have_z_modifier=yes"
@@ -11,7 +11,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="GPL-2.0-only"
 homepage="http://www.dest-unreach.org/socat/"
 distfiles="http://www.dest-unreach.org/socat/download/socat-${version}.tar.bz2"
-checksum=3faca25614e89123dff5045680549ecef519d02e331aaf3c4f5a8f6837c675e9
+checksum=6690a9f9990457b505097a272bbf2cbf4cc35576176f76646e3524b0e91c1763
 
 case "$XBPS_TARGET_MACHINE" in
 	*-musl) CFLAGS="-D_LINUX_IF_ETHER_H";;

From a6505fd287842c28602639f90294ce082ca26a34 Mon Sep 17 00:00:00 2001
From: jgart <jgart@dismail.de>
Date: Mon, 29 Nov 2021 00:35:59 -0500
Subject: [PATCH 227/288] tree-sitter: update to 0.20.1.

---
 srcpkgs/tree-sitter/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/tree-sitter/template b/srcpkgs/tree-sitter/template
index 25d2743934c5..0f92c4e67130 100644
--- a/srcpkgs/tree-sitter/template
+++ b/srcpkgs/tree-sitter/template
@@ -1,6 +1,6 @@
 # Template file for 'tree-sitter'
 pkgname=tree-sitter
-version=0.20.0
+version=0.20.1
 revision=1
 build_style=cargo
 make_install_args="--path=cli"
@@ -9,7 +9,7 @@ maintainer="Érico Nogueira <ericonr@disroot.org>"
 license="MIT"
 homepage="https://tree-sitter.github.io"
 distfiles="https://github.com/tree-sitter/tree-sitter/archive/v${version}.tar.gz"
-checksum=4a8070b9de17c3b8096181fe8530320ab3e8cca685d8bee6a3e8d164b5fb47da
+checksum=12a3f7206af3028dbe8a0de50d8ebd6d7010bf762db918acae76fc7585f1258d
 make_check=no # tests require generating fixtures from remote repositories
 
 post_build() {

From 749465f86a85a281a99b596e12addd94035c76d8 Mon Sep 17 00:00:00 2001
From: reedts <j.reedts@gmail.com>
Date: Wed, 1 Dec 2021 09:29:47 +0100
Subject: [PATCH 228/288] neovim: update to 0.6.0.

---
 srcpkgs/neovim/patches/python-3.10.patch | 23 -----------------------
 srcpkgs/neovim/template                  |  6 +++---
 2 files changed, 3 insertions(+), 26 deletions(-)
 delete mode 100644 srcpkgs/neovim/patches/python-3.10.patch

diff --git a/srcpkgs/neovim/patches/python-3.10.patch b/srcpkgs/neovim/patches/python-3.10.patch
deleted file mode 100644
index 7ff1b17cc24f..000000000000
--- a/srcpkgs/neovim/patches/python-3.10.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From e78fc38908dfb9f952e75026987f0db1f9ce4253 Mon Sep 17 00:00:00 2001
-From: "Tejasvi S. Tomar" <45873379+tejasvi@users.noreply.github.com>
-Date: Thu, 7 Oct 2021 11:41:52 +0530
-Subject: [PATCH] Fix python provider's minor version comparison
-
-`'3.10' < '3.3'` but v3.10 > v3.3
----
- runtime/autoload/provider/pythonx.vim | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/runtime/autoload/provider/pythonx.vim b/runtime/autoload/provider/pythonx.vim
-index c292b374b6f5..0eeb35cba8f1 100644
---- a/runtime/autoload/provider/pythonx.vim
-+++ b/runtime/autoload/provider/pythonx.vim
-@@ -96,7 +96,7 @@ function! provider#pythonx#CheckForModule(prog, module, major_version) abort
-     if prog_version !~ '^' . a:major_version
-       return [0, prog_path . ' is Python ' . prog_version . ' and cannot provide Python '
-             \ . a:major_version . '.']
--    elseif prog_version =~ '^' . a:major_version && prog_version < min_version
-+    elseif prog_version =~ '^' . a:major_version && str2nr(prog_version[2:]) < str2nr(min_version[2:])
-       return [0, prog_path . ' is Python ' . prog_version . ' and cannot provide Python >= '
-             \ . min_version . '.']
-     endif
diff --git a/srcpkgs/neovim/template b/srcpkgs/neovim/template
index bb22714097d4..ea9d0e5daa02 100644
--- a/srcpkgs/neovim/template
+++ b/srcpkgs/neovim/template
@@ -1,7 +1,7 @@
 # Template file for 'neovim'
 pkgname=neovim
-version=0.5.1
-revision=2
+version=0.6.0
+revision=1
 build_style=cmake
 build_helper="qemu"
 configure_args="-DCMAKE_BUILD_TYPE=Release"
@@ -14,7 +14,7 @@ maintainer="Steve Prybylski <sa.prybylx@gmail.com>"
 license="Apache-2.0, custom:Vim"
 homepage="https://neovim.io"
 distfiles="https://github.com/neovim/neovim/archive/v${version}.tar.gz"
-checksum=aa449795e5cc69bdd2eeed7095f20b9c086c6ecfcde0ab62ab97a9d04243ec84
+checksum=2cfd600cfa5bb57564cc22ffbbbcb2c91531053fc3de992df33656614384fa4c
 
 alternatives="
  vi:vi:/usr/bin/nvim

From 809f0e935be566a08db0562bf7987ff70deadc7f Mon Sep 17 00:00:00 2001
From: Dakota Walsh <kota@nilsu.org>
Date: Tue, 30 Nov 2021 09:42:07 +1300
Subject: [PATCH 229/288] aerc: update to 0.6.0.

The original upstream maintainer, Drew Devault, has stepped down and a
fork was created (with Drew's approval) under the same name. The fork
has patched in a large backlog of crashes and bug fixes and put out a
new version 0.6.0 recently. I think now that the aerc community has
consolidated on this fork it would be appropriate to update out package
to the new upstream.

More info about the fork and new maintainer can be found in this
discussion: https://lists.sr.ht/~sircmpwn/aerc/%3CCFBVJ3G1Y4YB.ZI6C02D0MS0S%40diabtop%3E
---
 srcpkgs/aerc/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/aerc/template b/srcpkgs/aerc/template
index 08c81ef0d4eb..989a400caa90 100644
--- a/srcpkgs/aerc/template
+++ b/srcpkgs/aerc/template
@@ -1,6 +1,6 @@
 # Template file for 'aerc'
 pkgname=aerc
-version=0.5.2
+version=0.6.0
 revision=1
 build_style=go
 hostmakedepends="scdoc git"
@@ -9,8 +9,8 @@ short_desc="Terminal email client"
 maintainer="shtayerc <david.murko@mailbox.org>"
 license="MIT"
 homepage="https://aerc-mail.org"
-distfiles="https://git.sr.ht/~sircmpwn/aerc/archive/${version}.tar.gz"
-checksum=87b922440e53b99f260d2332996537decb452c838c774e9340b633296f9f68ee
+distfiles="https://git.sr.ht/~rjarry/aerc/archive/${version}.tar.gz"
+checksum=ec4565609938b314f0343d85dfdab1cb0659c07c2845369ff7cf0132c5faed6e
 
 do_configure() {
 	:

From 8b8852bb76754608af0f8d54aede079b0ba437c7 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Thu, 2 Dec 2021 16:22:07 +0100
Subject: [PATCH 230/288] golly: update to 4.1.

---
 srcpkgs/golly/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/golly/template b/srcpkgs/golly/template
index 614c13b3be51..ee2876689ad3 100644
--- a/srcpkgs/golly/template
+++ b/srcpkgs/golly/template
@@ -1,6 +1,6 @@
 # Template file for 'golly'
 pkgname=golly
-version=4.0
+version=4.1
 revision=1
 wrksrc="${pkgname}-${version}-src"
 build_wrksrc="gui-wx"
@@ -10,13 +10,13 @@ make_build_args="-f makefile-gtk GOLLYDIR=/usr/share/golly LUALIB=-llua5.4
 make_install_args="${make_build_args}"
 hostmakedepends="python3"
 makedepends="MesaLib-devel glu-devel lua54-devel python3-devel wxWidgets-devel
- zlib-devel"
+ zlib-devel SDL2-devel"
 short_desc="Simulator for Conway's Game of Life and other cellular automata"
 maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="GPL-2.0-or-later"
 homepage="http://golly.sourceforge.net/"
 distfiles="${SOURCEFORGE_SITE}/${pkgname}/${pkgname}-${version}-src.tar.gz"
-checksum=45a8595c9f7064de029f05d339e3fca3776b5a0c36fef95712e697f154d82ae5
+checksum=6c655a6ce2fd75c6ae7289da39d084162c6ed887a01c21c3760872e3ff6d60c8
 
 CXXFLAGS="-I../gollybase"
 
@@ -27,7 +27,7 @@ post_extract() {
 
 pre_configure() {
 	if [ "$CROSS_BUILD" ]; then
-		vsed -i "s,\(PYTHON_INCLUDE\) =.*,\1=-I${XBPS_CROSS_BASE}/usr/include/python3.9,g" makefile-gtk
+		vsed -i "s,\(PYTHON_INCLUDE\) =.*,\1=-I${XBPS_CROSS_BASE}/usr/include/python3.10,g" makefile-gtk
 	fi
 }
 

From 256697963c16d48cd7fbcf28987c389b8eca4383 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Thu, 2 Dec 2021 18:16:57 +0100
Subject: [PATCH 231/288] sbcl: update to 2.1.11.

---
 srcpkgs/sbcl/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/sbcl/template b/srcpkgs/sbcl/template
index 5225f4ae682c..524d66eb8d05 100644
--- a/srcpkgs/sbcl/template
+++ b/srcpkgs/sbcl/template
@@ -1,6 +1,6 @@
 # Template file for 'sbcl'
 pkgname=sbcl
-version=2.1.10
+version=2.1.11
 revision=1
 archs="i686 x86_64* armv7l aarch64 ppc64le*"
 hostmakedepends="iana-etc"
@@ -12,7 +12,7 @@ license="custom:BSD+public_domain"
 homepage="http://www.sbcl.org/"
 changelog="http://www.sbcl.org/news.html"
 distfiles="${SOURCEFORGE_SITE}/${pkgname}/${pkgname}-${version}-source.tar.bz2"
-checksum=eb183f0f59a5cb2cbed762ec062bc34b9b6214b65402660784ef54838884b138
+checksum=bfc1481de7fdbdfaeef2ab0f0e8e84efd343433dea8d21cfbea8b0146cbdfefd
 nocross=yes
 nopie=yes
 
@@ -20,7 +20,7 @@ _bootstrap_lisp="bash ../sbcl-*-linux/run-sbcl.sh --no-sysinit --no-userinit --d
 case "$XBPS_TARGET_MACHINE" in
 x86_64)
 	distfiles+=" ${SOURCEFORGE_SITE}/${pkgname}/${pkgname}-${version}-x86-64-linux-binary.tar.bz2"
-	checksum+=" 5b23e9527d5a451bff8a78d08650122a7c4bf7d34b73fa7c8e712670fadc28ff"
+	checksum+=" e9605c843776470d8f81000b732b0a672ec355c0e3d6bbebfb900eddeb86c440"
 	;;
 i686)
 	distfiles+=" ${SOURCEFORGE_SITE}/${pkgname}/${pkgname}-1.4.3-x86-linux-binary.tar.bz2"

From ecb6a3ede244326f1635bf1832937b045d54fb32 Mon Sep 17 00:00:00 2001
From: Michal Vasilek <michal@vasilek.cz>
Date: Thu, 2 Dec 2021 16:32:37 +0100
Subject: [PATCH 232/288] python3-md2gemini: remove site-packages/tests

---
 srcpkgs/python3-md2gemini/template | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

diff --git a/srcpkgs/python3-md2gemini/template b/srcpkgs/python3-md2gemini/template
index 508f152fa939..4b4f88c7233d 100644
--- a/srcpkgs/python3-md2gemini/template
+++ b/srcpkgs/python3-md2gemini/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-md2gemini'
 pkgname=python3-md2gemini
 version=1.8.1
-revision=1
+revision=2
 wrksrc="md2gemini-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools python3-mistune2 python3-cjkwrap
@@ -14,3 +14,8 @@ license="LGPL-3.0-only"
 homepage="https://github.com/makeworld-the-better-one/md2gemini"
 distfiles="${PYPI_SITE}/m/md2gemini/md2gemini-${version}.tar.gz"
 checksum=3ef2bd2d9e2b4968a844a2858f721348429f3a0b5976bd1c324198538103ca55
+
+post_install() {
+	# remove tests directory polluting site-packages
+	rm -r $DESTDIR/usr/lib/python*/site-packages/tests
+}

From f7f7b13fd3ab8974a8aeafc0c03d010cc3a2ea54 Mon Sep 17 00:00:00 2001
From: Michal Vasilek <michal@vasilek.cz>
Date: Thu, 2 Dec 2021 16:32:42 +0100
Subject: [PATCH 233/288] python3-pykeepass: remove site-packages/tests

---
 srcpkgs/python3-pykeepass/template | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

diff --git a/srcpkgs/python3-pykeepass/template b/srcpkgs/python3-pykeepass/template
index 532f3a77a13c..5571c1a18dbe 100644
--- a/srcpkgs/python3-pykeepass/template
+++ b/srcpkgs/python3-pykeepass/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-pykeepass'
 pkgname=python3-pykeepass
 version=4.0.1
-revision=1
+revision=2
 wrksrc="pykeepass-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -15,3 +15,8 @@ homepage="https://github.com/libkeepass/pykeepass"
 changelog="https://raw.githubusercontent.com/libkeepass/pykeepass/master/CHANGELOG.rst"
 distfiles="https://github.com/libkeepass/pykeepass/archive/refs/tags/${version}.tar.gz"
 checksum=ac5966ede4fae1a0d3ea1997468a14b893a8f8dab136b1c14425b3b2763e68e3
+
+post_install() {
+	# remove tests directory polluting site-packages
+	rm -r $DESTDIR/usr/lib/python*/site-packages/tests
+}

From 57874245eb5994fd3ab0102e0fcadf889c9805cc Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Ey=C3=9Fer?= <daniel.eysser@gmail.com>
Date: Thu, 2 Dec 2021 11:41:52 +0100
Subject: [PATCH 234/288] age: set version information

---
 srcpkgs/age/template | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/srcpkgs/age/template b/srcpkgs/age/template
index a3284c8d0c69..cf7754da9b03 100644
--- a/srcpkgs/age/template
+++ b/srcpkgs/age/template
@@ -1,10 +1,11 @@
 # Template file for 'age'
 pkgname=age
 version=1.0.0
-revision=1
+revision=2
 build_style=go
 go_import_path="filippo.io/age"
 go_package="${go_import_path}/cmd/..."
+go_ldflags="-X main.Version=${version}"
 short_desc="Simple, modern and secure encryption tool"
 maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="BSD-3-Clause"

From 5922b591d003f90892e0336e3d990ddbbd702f55 Mon Sep 17 00:00:00 2001
From: Tim Sandquist <tim.sandquist@gmail.com>
Date: Thu, 2 Dec 2021 07:53:35 -0600
Subject: [PATCH 235/288] nss: update to 3.73.

critical security fix
https://www.mozilla.org/en-US/security/advisories/mfsa2021-51/
---
 srcpkgs/nss/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/nss/template b/srcpkgs/nss/template
index 968500eb758e..8f70796361e5 100644
--- a/srcpkgs/nss/template
+++ b/srcpkgs/nss/template
@@ -3,7 +3,7 @@
 _nsprver=4.32
 
 pkgname=nss
-version=3.72
+version=3.73
 revision=1
 hostmakedepends="perl"
 makedepends="nspr-devel sqlite-devel zlib-devel"
@@ -13,7 +13,7 @@ maintainer="Đoàn Trần Công Danh <congdanhqx@gmail.com>"
 license="MPL-2.0"
 homepage="https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSS"
 distfiles="${MOZILLA_SITE}/security/nss/releases/NSS_${version//\./_}_RTM/src/nss-${version}.tar.gz"
-checksum=6ea60a9ff113e493ea2ab25f41ea75a9fbd10af7903f26f703dac8680732d02e
+checksum=566d3a68da9b10d7da9ef84eb4fe182f8f04e20d85c55d1bf360bb2c0096d8e5
 
 export NS_USE_GCC=1
 export LIBRUNPATH=

From 4b78bfadf3e9ccf619c518ec8506d3e11496566e Mon Sep 17 00:00:00 2001
From: Ramdziana F Y <ramdzian@gmail.com>
Date: Thu, 2 Dec 2021 19:16:19 +0700
Subject: [PATCH 236/288] vivaldi: update to 5.0.2497.24

---
 srcpkgs/vivaldi/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/vivaldi/template b/srcpkgs/vivaldi/template
index 98a12ab05eba..1ef2335e9ebe 100644
--- a/srcpkgs/vivaldi/template
+++ b/srcpkgs/vivaldi/template
@@ -1,6 +1,6 @@
 # Template file for 'vivaldi'
 pkgname=vivaldi
-version=4.3.2439.65
+version=5.0.2497.24
 revision=1
 _release=1
 archs="x86_64"
@@ -14,7 +14,7 @@ license="custom:Proprietary"
 homepage="https://vivaldi.com"
 distfiles="https://downloads.vivaldi.com/stable/vivaldi-stable_${version}-${_release}_amd64.deb"
 _licenseUrl="https://vivaldi.com/privacy/vivaldi-end-user-license-agreement/"
-checksum=42d6a7568b7b45c3b3d5a47e0ff51c46b80eab00645a17961be32f5320df10d1
+checksum=40f1cf35e6bd0e04e6bf9360f5179c85c68af403562a46358ea306e18080b32d
 repository=nonfree
 restricted=yes
 nostrip=yes

From 40d5944f4cca94008041c618884224e1a974f82b Mon Sep 17 00:00:00 2001
From: Clyhtsuriva <aimeric@adjutor.xyz>
Date: Thu, 2 Dec 2021 13:22:19 +0100
Subject: [PATCH 237/288] gnome-robots: update to 40.0

---
 srcpkgs/gnome-robots/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/gnome-robots/template b/srcpkgs/gnome-robots/template
index 1d85efb012db..369474709a8d 100644
--- a/srcpkgs/gnome-robots/template
+++ b/srcpkgs/gnome-robots/template
@@ -1,14 +1,14 @@
 # Template file for 'gnome-robots'
 pkgname=gnome-robots
-version=3.38.0
+version=40.0
 revision=1
 build_style=meson
-hostmakedepends="gettext glib-devel itstool pkg-config"
-makedepends="gsound-devel gtk+3-devel libcanberra-devel librsvg-devel
+hostmakedepends="gettext glib-devel itstool pkg-config vala"
+makedepends="gsound-devel gtk4-devel libcanberra-devel librsvg-devel
  libglib-devel libgnome-games-support-devel"
 short_desc="GNOME classic robots game"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="https://wiki.gnome.org/Apps/Robots"
 distfiles="${GNOME_SITE}/${pkgname}/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=1fe8694aa7d4f86e77770649fcd8944b00535913cb5975bcd3adc424bdbeffe2
+checksum=6fbf2f885750f1a5110a724f8f35addd9bc61184ee31cf0c0cb89953e4f4cb11

From afae589fa62a76877a664987969b5af065b57318 Mon Sep 17 00:00:00 2001
From: John Zimmermann <me@johnnynator.dev>
Date: Wed, 1 Dec 2021 09:21:22 +0100
Subject: [PATCH 238/288] Rocket.Chat-Desktop: update to 3.7.0.

---
 srcpkgs/Rocket.Chat-Desktop/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/Rocket.Chat-Desktop/template b/srcpkgs/Rocket.Chat-Desktop/template
index a01959934521..58f2eed1d9ba 100644
--- a/srcpkgs/Rocket.Chat-Desktop/template
+++ b/srcpkgs/Rocket.Chat-Desktop/template
@@ -1,6 +1,6 @@
 # Template file for 'Rocket.Chat-Desktop'
 pkgname=Rocket.Chat-Desktop
-version=3.6.0
+version=3.7.0
 revision=1
 _electron_ver=13
 wrksrc="Rocket.Chat.Electron-${version}"
@@ -12,7 +12,7 @@ maintainer="John <me@johnnynator.dev>"
 license="MIT"
 homepage="https://rocket.chat/"
 distfiles="https://github.com/RocketChat/Rocket.Chat.Electron/archive/${version}.tar.gz"
-checksum=1b867f55c32f24124f5aaf6ce3dcd805a5aab29c63582a4b5a8730420af5cc1d
+checksum=328707d85b847214e0fe92bd3e45d757c7a27f24532c2f6d353dd045458fee80
 
 export USE_SYSTEM_APP_BUILDER=true
 

From e2f1fb668fadab171ea6275ec6e6ec89fa588254 Mon Sep 17 00:00:00 2001
From: Duncaen <duncaen@voidlinux.org>
Date: Fri, 3 Dec 2021 15:58:47 +0100
Subject: [PATCH 239/288] knot-resolver: update to 5.4.3.

---
 srcpkgs/knot-resolver/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/knot-resolver/template b/srcpkgs/knot-resolver/template
index fc56c00f9742..56fd104bc0f0 100644
--- a/srcpkgs/knot-resolver/template
+++ b/srcpkgs/knot-resolver/template
@@ -1,6 +1,6 @@
 # Template file for 'knot-resolver'
 pkgname=knot-resolver
-version=5.4.2
+version=5.4.3
 revision=1
 build_style=meson
 configure_args="
@@ -19,7 +19,7 @@ maintainer="Duncaen <duncaen@voidlinux.org>"
 license="GPL-3.0-or-later"
 homepage="https://www.knot-resolver.cz/"
 distfiles="https://secure.nic.cz/files/knot-resolver/knot-resolver-${version}.tar.xz"
-checksum=ea6a219571a752056669bae3f2c0c3ed0bec58af5ab832d505a3ec9c4063a58b
+checksum=488729eb93190336b6bca10de0d78ecb7919f77fcab105debc0a644aa7d0a506
 
 system_accounts="_knot_resolver"
 _knot_resolver_homedir="/var/cache/knot-resolver"

From 46cbf11b02f94883c018c86b84e5596599b68530 Mon Sep 17 00:00:00 2001
From: Duncaen <duncaen@voidlinux.org>
Date: Fri, 3 Dec 2021 16:00:34 +0100
Subject: [PATCH 240/288] logswan: update to 2.1.12.

---
 srcpkgs/logswan/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/logswan/template b/srcpkgs/logswan/template
index e6a18fe21159..4436b23cac97 100644
--- a/srcpkgs/logswan/template
+++ b/srcpkgs/logswan/template
@@ -1,6 +1,6 @@
 # Template file for 'logswan'
 pkgname=logswan
-version=2.1.11
+version=2.1.12
 revision=1
 build_style=cmake
 makedepends="jansson-devel libmaxminddb-devel"
@@ -10,7 +10,7 @@ license="BSD-2-clause"
 homepage="https://www.logswan.org/"
 changelog="https://github.com/fcambus/logswan/raw/master/ChangeLog"
 distfiles="https://github.com/fcambus/logswan/archive/${version}.tar.gz"
-checksum=a031b04c2dcfe8195e4225b8dd5781fc76098b9d19d0e4a9cbe1da76a4928eea
+checksum=8e954fcf5319b83f184b1a91d0af12c58bb90ab0f322f42ea6ad36fb05d57894
 
 post_install() {
 	vlicense LICENSE

From 34bda3092ce96fb6c9fcabe7fa9e624d2b435e1e Mon Sep 17 00:00:00 2001
From: Duncaen <duncaen@voidlinux.org>
Date: Fri, 3 Dec 2021 16:10:05 +0100
Subject: [PATCH 241/288] poke: update to 1.4.

---
 srcpkgs/poke/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/poke/template b/srcpkgs/poke/template
index c1876c668059..dbb3543855e8 100644
--- a/srcpkgs/poke/template
+++ b/srcpkgs/poke/template
@@ -1,6 +1,6 @@
 # Template file for 'poke'
 pkgname=poke
-version=1.3
+version=1.4
 revision=1
 build_style=gnu-configure
 hostmakedepends="pkg-config"
@@ -12,7 +12,7 @@ license="GPL-3.0-or-later"
 homepage="https://www.jemarch.net/poke.html"
 changelog="https://www.jemarch.net/poke-${version}-relnotes.html"
 distfiles="${GNU_SITE}/poke/poke-${version}.tar.gz"
-checksum=ba7863034a1b08004b0ee8f88bda94160707e9a781d5556f555b507583cf0f1b
+checksum=ce054df29560c921230132703ee449fe130b6e25ab03aa6cc796bb401506aa24
 
 poke-devel_package() {
 	depends="${sourcepkg}>=${version}_${revision}"

From 1fb5c8473e6cc7e374751430d2753b3155faca83 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Ey=C3=9Fer?= <daniel.eysser@gmail.com>
Date: Fri, 3 Dec 2021 17:50:39 +0100
Subject: [PATCH 242/288] youtube-dl: orphan package

---
 srcpkgs/youtube-dl/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/youtube-dl/template b/srcpkgs/youtube-dl/template
index 72c70a4ee4b4..b83c6c887ab0 100644
--- a/srcpkgs/youtube-dl/template
+++ b/srcpkgs/youtube-dl/template
@@ -8,7 +8,7 @@ hostmakedepends="python3-setuptools"
 depends="python3-setuptools"
 checkdepends="flake8 python3-nose"
 short_desc="CLI program to download videos from YouTube and other sites"
-maintainer="Daniel Eyßer <daniel.eysser@gmail.com>"
+maintainer="Orphaned <orphan@voidlinux.org>"
 license="Unlicense"
 homepage="https://yt-dl.org"
 changelog="https://raw.githubusercontent.com/ytdl-org/youtube-dl/master/ChangeLog"

From ad8aa389141fca6772e4cdc5fcd0bae0d41d7df3 Mon Sep 17 00:00:00 2001
From: skmpz <dem.procopiou@gmail.com>
Date: Fri, 3 Dec 2021 20:06:41 +0400
Subject: [PATCH 243/288] calibre: update to 5.33.0.

---
 srcpkgs/calibre/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/calibre/template b/srcpkgs/calibre/template
index fcf45f5bb183..f96c9329ace6 100644
--- a/srcpkgs/calibre/template
+++ b/srcpkgs/calibre/template
@@ -1,6 +1,6 @@
 # Template file for 'calibre'
 pkgname=calibre
-version=5.32.0
+version=5.33.0
 revision=1
 build_style=python3-module
 pycompile_dirs="/usr/lib/calibre/"
@@ -27,7 +27,7 @@ license="GPL-3.0-only"
 homepage="https://calibre-ebook.com"
 changelog="https://raw.githubusercontent.com/kovidgoyal/calibre/master/Changelog.txt"
 distfiles="https://download.calibre-ebook.com/${version}/calibre-${version}.tar.xz"
-checksum=3571efc1cc773e453b459096a38b141fd0c7784fb9611505a1f9a55648f47e5e
+checksum=5c32cdd9cb7feecb125131842e3f66a8c9e838d7c5be6f016367de1a1d1f78fd
 lib32disabled=yes
 nocross=yes
 

From 7ea75f80bfb600ae4597ae591dbc72d7f39996cd Mon Sep 17 00:00:00 2001
From: Anton Afanasyev <1157248+2asoft@users.noreply.github.com>
Date: Fri, 3 Dec 2021 01:11:32 -0800
Subject: [PATCH 244/288] CLion: update to 2021.3.

---
 srcpkgs/CLion/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/CLion/template b/srcpkgs/CLion/template
index a7779c295f13..76f9dd3f1e8c 100644
--- a/srcpkgs/CLion/template
+++ b/srcpkgs/CLion/template
@@ -1,6 +1,6 @@
 # Template file for 'CLion'
 pkgname=CLion
-version=2021.2.3
+version=2021.3
 revision=1
 archs="x86_64 aarch64"
 wrksrc="clion-${version}"
@@ -10,7 +10,7 @@ maintainer="Anton Afanasyev <anton@doubleasoftware.com>"
 license="custom:Commercial"
 homepage="https://www.jetbrains.com/clion"
 distfiles="https://download.jetbrains.com/cpp/CLion-${version}.tar.gz"
-checksum=25c3968c72976b2de5e3e8f39b242702c4ec25b32268022cd16590e9fbfc0b27
+checksum=4968657ad64d55da794bcf9b878fdd36ed233014152930058f761296d2047867
 repository=nonfree
 restricted=yes
 nopie=yes

From f9546df20949eaa7261e22be0a1e00bd8e8aee6d Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Benjam=C3=ADn=20Albi=C3=B1ana?= <benalb@gmail.com>
Date: Fri, 3 Dec 2021 08:46:36 +0100
Subject: [PATCH 245/288] doomretro: update to 4.4.

---
 srcpkgs/doomretro/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/doomretro/template b/srcpkgs/doomretro/template
index 2df391db530b..d0a7996ac62b 100644
--- a/srcpkgs/doomretro/template
+++ b/srcpkgs/doomretro/template
@@ -1,6 +1,6 @@
 # Template file for 'doomretro'
 pkgname=doomretro
-version=4.3
+version=4.4
 revision=1
 build_style=cmake
 hostmakedepends="pkg-config"
@@ -11,4 +11,4 @@ license="GPL-3.0-or-later"
 homepage="https://www.doomretro.com"
 changelog="https://raw.githubusercontent.com/bradharding/doomretro/master/releasenotes.md"
 distfiles="https://github.com/bradharding/doomretro/archive/v${version}.tar.gz"
-checksum=99e48dc66e8d69a806372643db3aa1ea3b1a68dcf891ec79b9c3261484e3181e
+checksum=f28e439498de97a38decafd924d06e72ec247efca82719afca17d0532170be3b

From efa07877da7e6cdb2257cfd6621182a8618043e5 Mon Sep 17 00:00:00 2001
From: Clyhtsuriva <aimeric@adjutor.xyz>
Date: Thu, 2 Dec 2021 12:13:03 +0100
Subject: [PATCH 246/288] gnome-sudoku: update to 40.2

---
 srcpkgs/gnome-sudoku/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/gnome-sudoku/template b/srcpkgs/gnome-sudoku/template
index 86c314e7f147..ed1759478ab5 100644
--- a/srcpkgs/gnome-sudoku/template
+++ b/srcpkgs/gnome-sudoku/template
@@ -1,14 +1,14 @@
 # Template file for 'gnome-sudoku'
 pkgname=gnome-sudoku
-version=3.38.0
+version=40.2
 revision=1
 build_helper="gir"
 build_style=meson
 hostmakedepends="gettext glib-devel itstool pkg-config vala"
-makedepends="gtk+3-devel libgee08-devel json-glib-devel qqwing-devel"
+makedepends="gtk4-devel libgee08-devel json-glib-devel qqwing-devel"
 short_desc="GNOME Sudoku Japanese logic game"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="GPL-3.0-or-later"
 homepage="https://wiki.gnome.org/Apps/Sudoku"
 distfiles="${GNOME_SITE}/${pkgname}/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=38731d0cc6d56a21dbdc89409cc5bb3d08e1c02cd9009f4d57f5b34887e9fd32
+checksum=36120531e3c7139581ea3800fbfe3c2b31694c440145ecc897ac34e562d754a3

From 85b03153ff0f539f15e54f0dc15823f14b334c5e Mon Sep 17 00:00:00 2001
From: Clyhtsuriva <aimeric@adjutor.xyz>
Date: Thu, 2 Dec 2021 11:50:02 +0100
Subject: [PATCH 247/288] gnome-chess: update to 41.1

---
 srcpkgs/gnome-chess/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/gnome-chess/template b/srcpkgs/gnome-chess/template
index 4ed9e8bc914e..629a10229d9d 100644
--- a/srcpkgs/gnome-chess/template
+++ b/srcpkgs/gnome-chess/template
@@ -1,14 +1,14 @@
 # Template file for 'gnome-chess'
 pkgname=gnome-chess
-version=3.38.1
+version=41.1
 revision=1
 build_style=meson
 hostmakedepends="gettext pkg-config vala glib-devel itstool librsvg-devel"
-makedepends="gtk+3-devel librsvg-devel"
+makedepends="gtk4-devel librsvg-devel"
 depends="gnuchess"
 short_desc="GNOME chess user interface"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="GPL-3.0-or-later"
 homepage="https://wiki.gnome.org/Apps/Chess"
 distfiles="${GNOME_SITE}/${pkgname}/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=1470f037c0dffe0285c121f7b6655e1245761f99a9974ab3c04dee5d6e89f5ae
+checksum=eb619886596396b4033a3f28a3c2e3004b54ebe1b38b40d6422c17b9f2cc17d0

From 6d7b4cf1c2104bebab49572c96106a6a256bed9f Mon Sep 17 00:00:00 2001
From: Clyhtsuriva <aimeric@adjutor.xyz>
Date: Thu, 2 Dec 2021 13:51:15 +0100
Subject: [PATCH 248/288] hitori: update to 3.38.3

---
 srcpkgs/hitori/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/hitori/template b/srcpkgs/hitori/template
index 8a50efea3e63..b5fc5662126e 100644
--- a/srcpkgs/hitori/template
+++ b/srcpkgs/hitori/template
@@ -1,6 +1,6 @@
 # Template file for 'hitori'
 pkgname=hitori
-version=3.38.1
+version=3.38.3
 revision=1
 build_style=meson
 hostmakedepends="gettext glib-devel intltool itstool pkg-config"
@@ -11,4 +11,4 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="GPL-3.0-or-later"
 homepage="https://wiki.gnome.org/Apps/Hitori"
 distfiles="${GNOME_SITE}/${pkgname}/${version%.*}/${pkgname}-${version}.tar.xz"
-checksum=02bd2c421d4e2180265714e854bd12efd3c6d156ddf21f79e7df60011d4e4184
+checksum=f7d7103cb0633fb013730131a98c3ae3a2162b9fb9499fc7f19512d581bf6569

From 74e9edc74d594eec59202148eaa79bc421878bf2 Mon Sep 17 00:00:00 2001
From: Joel Beckmeyer <joel@beckmeyer.us>
Date: Thu, 2 Dec 2021 08:06:48 -0500
Subject: [PATCH 249/288] borgmatic: update to 1.5.21, adopt.

---
 srcpkgs/borgmatic/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/borgmatic/template b/srcpkgs/borgmatic/template
index 523fbf23951c..047883dcc530 100644
--- a/srcpkgs/borgmatic/template
+++ b/srcpkgs/borgmatic/template
@@ -1,6 +1,6 @@
 # Template file for 'borgmatic'
 pkgname=borgmatic
-version=1.5.20
+version=1.5.21
 revision=1
 build_style=python3-module
 # runs not yet installed self
@@ -10,12 +10,12 @@ depends="borg python3-setuptools python3-ruamel.yaml python3-jsonschema
  python3-colorama python3-requests"
 checkdepends="${depends} python3-pytest-cov python3-flexmock"
 short_desc="Wrapper script for the Borg backup software"
-maintainer="Orphaned <orphan@voidlinux.org>"
+maintainer="Joel Beckmeyer <joel@beckmeyer.us>"
 license="GPL-3.0-or-later"
 homepage="https://torsion.org/borgmatic/"
 changelog="https://projects.torsion.org/borgmatic-collective/borgmatic/raw/branch/master/NEWS"
 distfiles="${PYPI_SITE}/b/borgmatic/borgmatic-${version}.tar.gz"
-checksum=0aa6705cd72c6bd8fec94ba9e5e13ba9e90e6671799af2f2f5cb91186b90b7e5
+checksum=b8aa9dbf250b95b829827310c9638a17cd52fee160a437283eed23bffcae83cf
 
 post_install() {
 	# remove tests directory polluting site-packages

From 5133dcc04d08e723ab8f0a7a8d09b11d6f18c478 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Ey=C3=9Fer?= <daniel.eysser@gmail.com>
Date: Thu, 2 Dec 2021 17:42:47 +0100
Subject: [PATCH 250/288] mpd: update to 0.23.5.

---
 srcpkgs/mpd/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/mpd/template b/srcpkgs/mpd/template
index 144dfdf9ec43..fc9c4153e284 100644
--- a/srcpkgs/mpd/template
+++ b/srcpkgs/mpd/template
@@ -1,6 +1,6 @@
 # Template file for 'mpd'
 pkgname=mpd
-version=0.23.4
+version=0.23.5
 revision=1
 build_style=meson
 configure_args="-Dopus=enabled -Dmikmod=enabled -Dneighbor=true
@@ -22,7 +22,7 @@ hostmakedepends="pkg-config python3-Sphinx"
 makedepends="avahi-glib-libs-devel boost-devel faad2-devel ffmpeg-devel
  libcurl-devel libid3tag-devel libmad-devel libmikmod-devel libmms-devel
  libmodplug-devel libmpdclient-devel libnfs-devel libsamplerate-devel
- libnpupnp-devel mpg123-devel opus-devel yajl-devel
+ libnpupnp-devel mpg123-devel opus-devel yajl-devel pcre2-devel icu-devel
  zziplib-devel libsoxr-devel audiofile-devel twolame-devel fmt-devel
  $(vopt_if io_uring 'liburing-devel') $(vopt_if pipewire 'pipewire-devel')
  $(vopt_if cdio 'libcdio-paranoia-devel') $(vopt_if shoutcast 'libshout-devel')
@@ -39,7 +39,7 @@ license="GPL-2.0-or-later"
 homepage="https://www.musicpd.org/"
 changelog="https://raw.githubusercontent.com/MusicPlayerDaemon/MPD/master/NEWS"
 distfiles="https://www.musicpd.org/download/mpd/${version%.*}/mpd-${version}.tar.xz"
-checksum=2f359d30dd980f762d2bc324d916e48b731e8a4d456d01d120c61ad657e4c754
+checksum=f22c2c25093a05f4566f9cd7207cfbcd8405af67ed29a989bcf8905f80b7a299
 LDFLAGS="-Wl,-z,stack-size=1048576"
 
 system_accounts="mpd"

From edddfd5584389cd6ac9562233a1dee6762443a23 Mon Sep 17 00:00:00 2001
From: Imran Khan <imrankhan@teknik.io>
Date: Thu, 2 Dec 2021 15:51:18 +0600
Subject: [PATCH 251/288] txr: update to 272.

---
 srcpkgs/txr/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/txr/template b/srcpkgs/txr/template
index 1136f6b7b026..68af47b7e693 100644
--- a/srcpkgs/txr/template
+++ b/srcpkgs/txr/template
@@ -1,6 +1,6 @@
 # Template file for 'txr'
 pkgname=txr
-version=270
+version=272
 revision=1
 archs="x86_64* i686* aarch64* arm* ppc64* mips*"
 build_style=configure
@@ -13,7 +13,7 @@ license="BSD-2-Clause"
 homepage="http://www.nongnu.org/txr/"
 changelog="http://www.kylheku.com/cgit/txr/tree/RELNOTES"
 distfiles="http://www.kylheku.com/cgit/txr/snapshot/${pkgname}-${version}.tar.bz2"
-checksum=6e0fe840ee91430888a08db8ef7739b1884fa43e8b2b5e173e6ae3eda3150291
+checksum=b3c2a82198dc97633aa40ced6fff6fec39c78a905b06dc08e7b74176bda03543
 nopie=yes
 
 if [ "$CROSS_BUILD" ]; then

From 5a85d9ec3c5175da9ed4a639dea691360f9edd39 Mon Sep 17 00:00:00 2001
From: notthewave <winklbauer_m@zoho.eu>
Date: Wed, 1 Dec 2021 19:30:32 +0100
Subject: [PATCH 252/288] ART: update to 1.11.

---
 srcpkgs/ART/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/ART/template b/srcpkgs/ART/template
index 31370020a225..671695939be7 100644
--- a/srcpkgs/ART/template
+++ b/srcpkgs/ART/template
@@ -1,6 +1,6 @@
 # Template file for 'ART'
 pkgname=ART
-version=1.10.1
+version=1.11
 revision=1
 build_style=cmake
 hostmakedepends="pkg-config"
@@ -12,4 +12,4 @@ maintainer="notthewave <winklbauer_m@zoho.eu>"
 license="GPL-3.0-or-later"
 homepage="https://bitbucket.org/agriggio/art/wiki/Home"
 distfiles="https://bitbucket.org/agriggio/art/downloads/${pkgname}-${version}.tar.xz"
-checksum=e20b73de6be55bbb5924d1bc194ecd7f0bf26d581bd9b8b7d8a1af70ea85483e
+checksum=6458cdb7b8aa1afdb767c3aaaf5549e8892e2d6ecf0d29029fa32f82078dd568

From 034fed02bba101f0aedfc1f9f49a36bd0dce4aeb Mon Sep 17 00:00:00 2001
From: Omar Zeghouani <omarzeghouanii@gmail.com>
Date: Wed, 1 Dec 2021 23:02:20 +0000
Subject: [PATCH 253/288] git-filter-repo: update to 2.34.0.

---
 srcpkgs/git-filter-repo/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/git-filter-repo/template b/srcpkgs/git-filter-repo/template
index 073dd6f75fe1..a81d612705a5 100644
--- a/srcpkgs/git-filter-repo/template
+++ b/srcpkgs/git-filter-repo/template
@@ -1,7 +1,7 @@
 # Template file for 'git-filter-repo'
 pkgname=git-filter-repo
-version=2.33.0
-revision=2
+version=2.34.0
+revision=1
 depends="git python3"
 checkdepends="git python3 perl rsync dos2unix"
 short_desc="Versatile tool for rewriting git history"
@@ -9,7 +9,7 @@ maintainer="Cameron Nemo <cnemo@tutanota.com>"
 license="MIT"
 homepage="https://github.com/newren/git-filter-repo/"
 distfiles="https://github.com/newren/git-filter-repo/releases/download/v${version}/git-filter-repo-${version}.tar.xz"
-checksum=7bcf11da134bbd82a4171f7fb28a3ab7bc4d478fe8ec3a3d9580e4bbdc32e6e9
+checksum=b1bf46af1e6a91a54056d0254e480803db8e40f631336c559a1a94d2a08389c4
 
 do_check() {
 	t/run_tests

From 82512798d1feaf38c65a1769f07f7baee162fca6 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Ey=C3=9Fer?= <daniel.eysser@gmail.com>
Date: Fri, 3 Dec 2021 18:15:07 +0100
Subject: [PATCH 254/288] glances: update to 3.2.4.2.

---
 srcpkgs/glances/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/glances/template b/srcpkgs/glances/template
index f7814f03d996..e329bcbf6858 100644
--- a/srcpkgs/glances/template
+++ b/srcpkgs/glances/template
@@ -1,7 +1,7 @@
 # Template file for 'glances'
 pkgname=glances
-version=3.2.2
-revision=2
+version=3.2.4.2
+revision=1
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-future python3-psutil python3-defusedxml"
@@ -11,7 +11,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="LGPL-3.0-or-later"
 homepage="https://github.com/nicolargo/glances"
 distfiles="https://github.com/nicolargo/glances/archive/v${version}.tar.gz"
-checksum=7a96f16b09e30765a7a5b0e8d02dda20ac8ff1f144e6586d1f17ff7a80f5480f
+checksum=88ac8103d777b2a55cee9418a5940269c640c3ad964ec44de0e9bb80cdbead37
 
 post_install() {
 	vsconf conf/glances.conf

From cee8c66aa79e94c3ad11b54f045a5580d42b0406 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Ey=C3=9Fer?= <daniel.eysser@gmail.com>
Date: Fri, 3 Dec 2021 11:49:02 +0100
Subject: [PATCH 255/288] zoom: update to 5.8.6.739.

---
 srcpkgs/zoom/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/zoom/template b/srcpkgs/zoom/template
index c6d57a36e361..e5ab0c169fd5 100644
--- a/srcpkgs/zoom/template
+++ b/srcpkgs/zoom/template
@@ -1,6 +1,6 @@
 # Template file for 'zoom'
 pkgname=zoom
-version=5.8.4.210
+version=5.8.6.739
 revision=1
 archs="x86_64"
 wrksrc=zoom
@@ -13,7 +13,7 @@ maintainer="Daniel Santana <daniel@santana.tech>"
 license="custom:Proprietary"
 homepage="https://zoom.us/"
 distfiles="https://cdn.zoom.us/prod/${version}/zoom_x86_64.rpm"
-checksum=b3fc9eef929d418873bdf3cc6df38297b86deaf330259e633d17459ec8718034
+checksum=a57d03456a6a92f5ab01e342443edc1824b043837f23a8d4027cd8b5831c0f11
 repository=nonfree
 noshlibprovides=yes
 noverifyrdeps=yes

From 1ff288dcb11c4aabd0d1fdc3c1f0a5b3d38e68e9 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Ey=C3=9Fer?= <daniel.eysser@gmail.com>
Date: Fri, 3 Dec 2021 18:01:09 +0100
Subject: [PATCH 256/288] yt-dlp: update to 2021.12.01.

---
 srcpkgs/yt-dlp/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/yt-dlp/template b/srcpkgs/yt-dlp/template
index 9432641a5e73..5e0e5fe9e2e0 100644
--- a/srcpkgs/yt-dlp/template
+++ b/srcpkgs/yt-dlp/template
@@ -1,19 +1,19 @@
 # Template file for 'yt-dlp'
 pkgname=yt-dlp
-version=2021.11.10.1
-revision=2
+version=2021.12.01
+revision=1
 wrksrc="$pkgname"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
-checkdepends="python3-pytest flake8 python3-nose"
 depends="python3"
+checkdepends="python3-pytest flake8 python3-nose"
 short_desc="CLI program to download videos from YouTube and other sites"
 maintainer="Michal Vasilek <michal@vasilek.cz>"
 license="Unlicense"
 homepage="https://github.com/yt-dlp/yt-dlp"
 changelog="https://raw.githubusercontent.com/yt-dlp/yt-dlp/master/Changelog.md"
 distfiles="https://github.com/yt-dlp/yt-dlp/releases/download/$version/yt-dlp.tar.gz"
-checksum=2eb1c67e095ded9d328eaa0e6e26952248b55dd1031a3751c6d60b759aefa16a
+checksum=bf0cc22d17ffbe59c0d0378026ff135a996b86c546ec9713d838f952dea61e0f
 
 do_check() {
 	PYTHON=/usr/bin/python3 make offlinetest

From 876a05a3ad0118fb1c22ca0075a1f48c746944cf Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Ey=C3=9Fer?= <daniel.eysser@gmail.com>
Date: Fri, 3 Dec 2021 11:53:08 +0100
Subject: [PATCH 257/288] scrcpy: update to 1.21.

---
 srcpkgs/scrcpy/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/scrcpy/template b/srcpkgs/scrcpy/template
index 1fe5ac7102c6..764649fafa4a 100644
--- a/srcpkgs/scrcpy/template
+++ b/srcpkgs/scrcpy/template
@@ -1,6 +1,6 @@
 # Template file for 'scrcpy'
 pkgname=scrcpy
-version=1.20
+version=1.21
 revision=1
 build_style=meson
 configure_args="-Dcompile_server=false
@@ -14,8 +14,8 @@ license="Apache-2.0"
 homepage="https://github.com/Genymobile/scrcpy"
 distfiles="${homepage}/archive/v${version}.tar.gz
  ${homepage}/releases/download/v${version}/scrcpy-server-v${version}"
-checksum="0c667e7de043a67a740be99d3f236a7aa4107ff62c408e7c462f4fe291f045a7
- b20aee4951f99b060c4a44000ba94de973f9604758ef62beb253b371aad3df34"
+checksum="76e16a894bdb483b14b7ae7dcc1be8036ec17924dfab070cf0cb3b47653a6822
+ dbcccab523ee26796e55ea33652649e4b7af498edae9aa75e4d4d7869c0ab848"
 skip_extraction="scrcpy-server-v${version}"
 
 post_install() {

From a9820bae23de592f4e814518c3be29b0d6438f85 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Ey=C3=9Fer?= <daniel.eysser@gmail.com>
Date: Fri, 3 Dec 2021 18:45:41 +0100
Subject: [PATCH 258/288] fdupes: update to 2.1.2.

---
 srcpkgs/fdupes/template | 11 +++--------
 1 file changed, 3 insertions(+), 8 deletions(-)

diff --git a/srcpkgs/fdupes/template b/srcpkgs/fdupes/template
index 4b409f902b73..1bfa0a775980 100644
--- a/srcpkgs/fdupes/template
+++ b/srcpkgs/fdupes/template
@@ -1,20 +1,15 @@
 # Template file for 'fdupes'
 pkgname=fdupes
-version=2.1.1
+version=2.1.2
 revision=1
 build_style=gnu-configure
-hostmakedepends="autoconf automake"
 makedepends="ncurses-devel pcre2-devel"
 short_desc="Identify or delete duplicate files within specified directories"
 maintainer="Steven R <dev@styez.com>"
 license="MIT"
 homepage="https://github.com/adrianlopezroche/fdupes"
-distfiles="https://github.com/adrianlopezroche/fdupes/archive/v${version}.tar.gz"
-checksum=37b1a499f6eb8b625b45641a2600be69ef591cd1e737e75afd50aa72ac215ea4
-
-pre_configure() {
-	autoreconf --install
-}
+distfiles="https://github.com/adrianlopezroche/fdupes/releases/download/v${version}/fdupes-${version}.tar.gz"
+checksum=cd5cb53b6d898cf20f19b57b81114a5b263cc1149cd0da3104578b083b2837bd
 
 post_install() {
 	vlicense README

From 684fdd212b847221929a53b7126794bdb1da41d2 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C3=89rico=20Nogueira?= <erico.erc@gmail.com>
Date: Fri, 3 Dec 2021 15:44:13 -0300
Subject: [PATCH 259/288] Rocket.Chat-Desktop: fix checksum.

---
 srcpkgs/Rocket.Chat-Desktop/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/Rocket.Chat-Desktop/template b/srcpkgs/Rocket.Chat-Desktop/template
index 58f2eed1d9ba..6d87c8b6945b 100644
--- a/srcpkgs/Rocket.Chat-Desktop/template
+++ b/srcpkgs/Rocket.Chat-Desktop/template
@@ -12,7 +12,7 @@ maintainer="John <me@johnnynator.dev>"
 license="MIT"
 homepage="https://rocket.chat/"
 distfiles="https://github.com/RocketChat/Rocket.Chat.Electron/archive/${version}.tar.gz"
-checksum=328707d85b847214e0fe92bd3e45d757c7a27f24532c2f6d353dd045458fee80
+checksum=5b37d497f1985ca74b6a7971ae54a2741e9214c4e83cf754177f2fa444824f12
 
 export USE_SYSTEM_APP_BUILDER=true
 

From 6c9fd95ef092c24ad88114d7035e96123fcab0e2 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C3=89rico=20Nogueira?= <erico.erc@gmail.com>
Date: Sat, 27 Nov 2021 14:57:04 -0300
Subject: [PATCH 260/288] libreoffice: update to 7.2.3.2.

- remove VLC entirely (deprecated by upstream)
- update vendored tarballs
- add zxing and cmis tarballs (zxing isn't packaged by void, cmis
  upstream doesn't make releases with the necessary changes, see [1])
- builds were erroring out if the translation, dictionaries and help
  tarballs weren't unpacked, so remove them from the skip_extraction
  list, but still symlink them into the external dir so the build system
  doesn't try to download them
- move most subpackages to depend on writer, since it contains some of
  the needed pieces for them. This closes #34304
- remove outdated permission fix for soffice

[1] https://github.com/tdf/libcmis/issues/42
---
 .../libreoffice/patches/fix-vlc-backend.patch | 20 -----
 srcpkgs/libreoffice/template                  | 84 ++++++++++---------
 2 files changed, 43 insertions(+), 61 deletions(-)
 delete mode 100644 srcpkgs/libreoffice/patches/fix-vlc-backend.patch

diff --git a/srcpkgs/libreoffice/patches/fix-vlc-backend.patch b/srcpkgs/libreoffice/patches/fix-vlc-backend.patch
deleted file mode 100644
index 2c121c8ad2c6..000000000000
--- a/srcpkgs/libreoffice/patches/fix-vlc-backend.patch
+++ /dev/null
@@ -1,20 +0,0 @@
- vcl: fix build with vlc backend enabled
- 
- avmedia/source/vlc/vlcplayer.cxx tries to access the aWindow member
- directly, which leads to a compilation failure, since it's private.
-
-diff --git include/vcl/sysdata.hxx include/vcl/sysdata.hxx
-index 63b7c810de3d..0cd0e037c823 100644
---- a/include/vcl/sysdata.hxx
-+++ b/include/vcl/sysdata.hxx
-@@ -73,9 +73,8 @@ struct VCL_DLLPUBLIC SystemEnvData
-     // however, the GTK3 vclplug wants to store pointers in here!
-     sal_IntPtr          aShellWindow;   // the window of the frame's shell
-     Platform            platform;       // the windowing system in use
--private:
--    sal_uIntPtr         aWindow;        // the window of the object
- public:
-+    sal_uIntPtr         aWindow;        // the window of the object
- 
-     void SetWindowHandle(sal_uIntPtr nWindow)
-     {
diff --git a/srcpkgs/libreoffice/template b/srcpkgs/libreoffice/template
index 6ea455c5c0cb..9e3208ccf364 100644
--- a/srcpkgs/libreoffice/template
+++ b/srcpkgs/libreoffice/template
@@ -1,7 +1,7 @@
 # Template file for 'libreoffice'
 pkgname=libreoffice
-version=7.1.3.2
-revision=4
+version=7.2.3.2
+revision=1
 build_style=meta
 make_build_target="build-nocheck"
 nocross="Several dependencies are nocross=yes"
@@ -12,14 +12,14 @@ hostmakedepends="automake flex git gperf hyphen icu libtool openldap which gette
 makedepends="CoinMP-devel apr-devel avahi-libs-devel clucene-devel
  frameworkintegration-devel glyphy-devel gpgmepp-devel gst-plugins-base1-devel
  gtk+-devel gtk+3-devel hunspell-devel hyphen-devel libXt-devel libabw-devel
- libatomic_ops-devel libbluetooth-devel libcdr-devel libcmis-devel libe-book-devel
+ libatomic_ops-devel libbluetooth-devel libcdr-devel libe-book-devel
  libepubgen-devel libetonyek-devel libexttextcat-devel libfbclient3-devel libfreehand-devel
  libgcrypt-devel libgltf-devel libldap-devel libmariadbclient-devel libmspub-devel
  libmwaw-devel libnumbertext-devel libodfgen-devel liborcus-devel
  libpagemaker-devel libqxp-devel librsvg-devel libvisio-devel libwpg-devel
  libwps-devel lpsolve-devel mdds mythes-devel neon-devel nss-devel
  postgresql-libs-devel python3-devel qt5-devel redland-devel sane-devel
- telepathy-glib-devel unixodbc-devel vigra-devel vlc-devel libcppunit-devel
+ telepathy-glib-devel unixodbc-devel vigra-devel libcppunit-devel
  qrcodegen-devel xmlsec1-devel poppler-cpp-devel libxml2-devel"
 depends="libreoffice-common>=${version}_${revision}"
 depends+=" libreoffice-base>=${version}_${revision}"
@@ -59,18 +59,20 @@ distfiles="
  ${_baseurl}/${pkgname}-translations-${version}.tar.xz
  ${_addurl}/798b2ffdc8bcfe7bca2cf92b62caf685-rhino1_5R5.zip
  ${_addurl}/a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.zip
- ${_addurl}/language-subtag-registry-2019-04-03.tar.bz2
+ ${_addurl}/ace6ab49184e329db254e454a010f56d-libxml-1.1.7.zip
+ ${_addurl}/language-subtag-registry-2021-03-05.tar.bz2
  ${_addurl}/17410483b5b5f267aa18b7e00b65e6e0-hsqldb_1_8_0.zip
  ${_addurl}/d8bd5eed178db6e2b18eeed243f85aa8-flute-1.1.6.zip
  ${_addurl}/ba2930200c9f019c2d93a8c88c651a0f-flow-engine-0.9.4.zip
  ${_addurl}/b63e6340a02ff1cacfeadb2c42286161-JLanguageTool-1.7.0.tar.bz2
  ${_addurl}/box2d-2.3.1.tar.gz
+ ${_addurl}/libcmis-0.5.2.tar.xz
  ${_addurl}/libstaroffice-0.0.7.tar.xz
  ${_addurl}/libzmf-0.0.2.tar.xz
- ${_addurl}/pdfium-4306.tar.bz2
+ ${_addurl}/pdfium-4500.tar.bz2
  ${_addurl}/bae83fa5dc7f081768daace6e199adc3-glm-0.9.4.6-libreoffice.zip
  ${_exturl}/8249374c274932a21846fa7629c2aa9b-officeotron-0.7.4-master.jar
- ${_exturl}/odfvalidator-1.2.0-incubating-SNAPSHOT-jar-with-dependencies-971c54fd38a968f5860014b44301872706f9e540.jar
+ ${_exturl}/odfvalidator-0.9.0-RC2-SNAPSHOT-jar-with-dependencies-2726ab578664434a545f8379a01a9faffac0ae73.jar
  ${_exturl}/185d60944ea767075d27247c3162b3bc-unowinreg.dll
  ${_addurl}/commons-logging-1.2-src.tar.gz
  ${_addurl}/dtoa-20180411.tgz
@@ -87,45 +89,48 @@ distfiles="
  ${_addurl}/f94d9870737518e3b597f9265f4e9803-libserializer-1.1.6.zip
  ${_addurl}/7239a4430efd4d0189c4f24df67f08e5-mysql-connector-c++-1.1.4.tar.gz
  ${_addurl}/39bb3fcea1514f1369fcfc87542390fd-sacjava-1.3.zip
- ${_addurl}/skia-m88-59bafeeaa7de9eb753e3778c414e01dcf013dcd8.tar.xz
+ ${_addurl}/skia-m90-45c57e116ee0ce214bdf78405a4762722e4507d9.tar.xz
  ${_addurl}/368f114c078f94214a308a74c7e991bc-crosextrafonts-20130214.tar.gz
  ${_addurl}/c74b7223abe75949b4af367942d96c7a-crosextrafonts-carlito-20130920.tar.gz
  ${_addurl}/33e1e61fab06a547851ed308b4ffef42-dejavu-fonts-ttf-2.37.zip
  ${_addurl}/1725634df4bb3dcb1b2c91a6175f8789-GentiumBasic_1102.zip
  ${_addurl}/liberation-narrow-fonts-ttf-1.07.6.tar.gz
- ${_addurl}/liberation-fonts-ttf-2.00.4.tar.gz
+ ${_addurl}/liberation-fonts-ttf-2.1.4.tar.gz
  ${_addurl}/e7a384790b13c29113e22e596ade9687-LinLibertineG-20120116.zip
  ${_addurl}/907d6e99f241876695c19ff3db0b8923-source-code-pro-2.030R-ro-1.050R-it.tar.gz
  ${_addurl}/edc4d741888bc0d38e32dbaa17149596-source-sans-pro-2.010R-ro-1.065R-it.tar.gz
  ${_addurl}/source-serif-pro-3.000R.tar.gz
  ${_addurl}/EmojiOneColor-SVGinOT-1.3.tar.gz
  ${_addurl}/noto-fonts-20171024.tar.gz
- ${_addurl}/culmus-0.131.tar.gz
+ ${_addurl}/culmus-0.133.tar.gz
  ${_addurl}/libre-hebrew-1.0.tar.gz
  ${_addurl}/alef-1.001.tar.gz
  ${_addurl}/ttf-kacst_2.01+mry.tar.gz
+ ${_addurl}/zxing-cpp-1.1.1.tar.gz
  ${_addurl}/Amiri-0.111.zip
  ${_addurl}/ReemKufi-0.7.zip
  ${_addurl}/Scheherazade-2.100.zip
 "
-checksum="35af7fd104b253704f770a205f835aee0e82ccc889ebf0949a89d9b3276229bf
- 66dc5fd4253f6b956b8fdde0d741ef7d85f12647db235642eb74f3d0a44d404e
- e0f14b4db1585506761ad2ceeb43850cb594f2ec8a20fc9ca7bcb95e77408935
- 86138935d274d46d27e4ce92a72d759e7d4491d7b227be952e05735ba5c9b327
+checksum="56c97374956d98c8efcd6d58771c0950c8a641ed84fd64db66382884c4c3b451
+ 41ca87cf71842696c9e21c6c01eb6ade5018a5e07f7cd8745c694b74ba3a185b
+ 087e1444294afe5ab49ea37a2c78c055c2a39000e8979017dd6bb2025d2cae79
+ 07f51594fcb32fb3373e94304bade1b91b6d8b5551f8e688da777e4f520448ec
  1fb458d6aab06932693cc8a9b6e4e70944ee1ff052fa63606e3131df34e21753
  75823776fb51a9c526af904f1503a7afaaab900fba83eda64f8a41073724c870
- a1d7fb901764bb8f251d4f686cdf565764f9987d0fb5d9315d54a7366a84822d
+ 7d2797fe9f79a77009721e3f14fa4a1dec17a6d706bdc93f85f1f01d124fab66
+ ce80e8face06bf2ada363e0c159e3f990c4116fdae9232ca43e6369aa82bf16a
  d30b13f4ba2e3b6a2d4f020c0dee0a9fb9fc6fbcc2d561f36b78da4bf3802370
  1b5b24f7bc543c0362b667692f78db8bab4ed6dafc6172f104d0bd3757d8a133
  233f66e8d25c5dd971716d4200203a612a407649686ef3b52075d04b4c9df0dd
  48c87e41636783bba438b65fd895821e369ed139e1465fac654323ad93c5a82d
  58ffc8475a8650aadc351345aef696937747b40501ab78d72c197c5ff5b3035c
+ d7b18d9602190e10d437f8a964a32e983afd57e2db316a07d87477a79f5000a2
  f94fb0ad8216f97127bedef163a45886b43c62deac5e5b0f5e628e234220c8db
  27051a30cb057fdb5d5de65a1f165c7153dc76e27fe62251cbb86639eb2caf22
- eca406d47ac7e2a84dcc86f93c08f96e591d409589e881477fa75e488e4851d8
+ 26a03dd60e5ed0979cdaba9cc848242895110ddfdf347d40989ce2f14020f304
  d0312c360efe04dd048b3311fe375ff36f1993b4c2e3cb58c81062990532904a
  f2443f27561af52324eee03a1892d9f569adc8db9e7bca55614898bc2a13a770
- 984f2a479df79e27e7b01a5815ac53ae64e07746b882262d8a64566494515504
+ d55495ab3a86544650587de2a72180ddf8bfc6376d14ddfa923992dbc86a06e0
  eafde646a7dbe46d20c291685b0beac2382174d78d66ee990e229a1bf6e6cec6
  49665da5a60d033e6dff40fe0a7f9173e886ae859ce6096c1afe34c48b677c81
  0082d0684f7db6f62361b76c4b7faba19e0c7ce5cb8e36c4b65fea8281e711b4
@@ -142,44 +147,44 @@ checksum="35af7fd104b253704f770a205f835aee0e82ccc889ebf0949a89d9b3276229bf
  05640a1f6805b2b2d7e2cb9c50db9a5cb084e3c52ab1a71ce015239b4a1d4343
  a25f14dad39e93a2f9cdf09166ee53981f7212dce829e4208e07a522963a8585
  085f2112c51fa8c1783fac12fbd452650596415121348393bb51f0f7e85a9045
- f293656a15342a53bb407b932fc907c6894178a162f09728bd383e24d84b1301
+ abe0b94d54edb717c58d74263f4ed3d27824d2ce9e9f2ce85a21ab38d993f94d
  c48d1c2fd613c9c06c959c34da7b8388059e2408d2bb19845dc3ed35f76e4d09
  4bd12b6cbc321c1cf16da76e2c585c925ce956a08067ae6f6c64eff6ccfdaf5a
  7576310b219e04159d35ff61dd4a4ec4cdba4f35c00e002a136f00e96a908b0a
  2f1a2c5491d7305dffd3520c6375d2f3e14931ee35c6d8ae1e8f098bf1a7b3cc
  8879d89b5ff7b506c9fc28efc31a5c0b954bbe9333e66e5283d27d20a8519ea3
- c40e95fc5e0ecb73d4be565ae2afc1114e2bc7dc5253e00ee92d8fd6cc4adf45
+ 26f85412dd0aa9d061504a1cc8aaf0aa12a70710e8d47d8b65a1251757c1a5ef
  54adcb2bc8cac0927a647fbd9362f45eff48130ce6e2379dc3867643019e08c5
  09466dce87653333f189acd8358c60c6736dcd95f042dee0b644bdcf65b6ae2f
  e7bc9a1fec787a529e49f5a26b93dcdcf41506449dfc70f92cdef6d17eb6fb61
  826a2b784d5cdb4c2bbc7830eb62871528360a61a52689c102a101623f1928e3
  d1a08f7c10589f22740231017694af0a7a270760c8dec33d8d1c038e2be0a0c7
  29acc15a4c4d6b51201ba5d60f303dfbc2e5acbfdb70413c9ae1ed34fa259994
- dcf112cfcccb76328dcfc095f4d7c7f4d2f7e48d0eed5e78b100d1d77ce2ed1b
+ c0c6873742d07544f6bacf2ad52eb9cb392974d56427938dc1dfbc8399c64d05
  f596257c1db706ce35795b18d7f66a4db99d427725f20e9384914b534142579a
  b98b67602a2c8880a1770f0b9e37c190f29a7e2ade5616784f0b89fbdb75bf52
  dca00f5e655f2f217a766faa73a81f542c5c204aa3a47017c3c2be0b31d00a56
+ e595b3fa2ec320beb0b28f6af56b1141853257c2611686685639cebb3b248c86
  1fbfccced6348b5db2c1c21d5b319cd488e14d055702fa817a0f6cb83d882166
  f60c6508d209ce4236d2d7324256c2ffddd480be7e3d6023770b93dc391a605f
  251c8817ceb87d9b661ce1d5b49e732a0116add10abc046be4b8ba5196e149b5"
 skip_extraction="
- ${pkgname}-dictionaries-${version}.tar.xz
- ${pkgname}-help-${version}.tar.xz
- ${pkgname}-translations-${version}.tar.xz
  798b2ffdc8bcfe7bca2cf92b62caf685-rhino1_5R5.zip
  a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.zip
- language-subtag-registry-2019-04-03.tar.bz2
+ ace6ab49184e329db254e454a010f56d-libxml-1.1.7.zip
+ language-subtag-registry-2021-03-05.tar.bz2
  17410483b5b5f267aa18b7e00b65e6e0-hsqldb_1_8_0.zip
  d8bd5eed178db6e2b18eeed243f85aa8-flute-1.1.6.zip
  ba2930200c9f019c2d93a8c88c651a0f-flow-engine-0.9.4.zip
  b63e6340a02ff1cacfeadb2c42286161-JLanguageTool-1.7.0.tar.bz2
  box2d-2.3.1.tar.gz
+ libcmis-0.5.2.tar.xz
  libstaroffice-0.0.7.tar.xz
  libzmf-0.0.2.tar.xz
- pdfium-4306.tar.bz2
+ pdfium-4500.tar.bz2
  bae83fa5dc7f081768daace6e199adc3-glm-0.9.4.6-libreoffice.zip
  8249374c274932a21846fa7629c2aa9b-officeotron-0.7.4-master.jar
- odfvalidator-1.2.0-incubating-SNAPSHOT-jar-with-dependencies-971c54fd38a968f5860014b44301872706f9e540.jar
+ odfvalidator-0.9.0-RC2-SNAPSHOT-jar-with-dependencies-2726ab578664434a545f8379a01a9faffac0ae73.jar
  185d60944ea767075d27247c3162b3bc-unowinreg.dll
  commons-logging-1.2-src.tar.gz
  dtoa-20180411.tgz
@@ -196,23 +201,24 @@ skip_extraction="
  f94d9870737518e3b597f9265f4e9803-libserializer-1.1.6.zip
  7239a4430efd4d0189c4f24df67f08e5-mysql-connector-c++-1.1.4.tar.gz
  39bb3fcea1514f1369fcfc87542390fd-sacjava-1.3.zip
- skia-m88-59bafeeaa7de9eb753e3778c414e01dcf013dcd8.tar.xz
+ skia-m90-45c57e116ee0ce214bdf78405a4762722e4507d9.tar.xz
  368f114c078f94214a308a74c7e991bc-crosextrafonts-20130214.tar.gz
  c74b7223abe75949b4af367942d96c7a-crosextrafonts-carlito-20130920.tar.gz
  33e1e61fab06a547851ed308b4ffef42-dejavu-fonts-ttf-2.37.zip
  1725634df4bb3dcb1b2c91a6175f8789-GentiumBasic_1102.zip
  liberation-narrow-fonts-ttf-1.07.6.tar.gz
- liberation-fonts-ttf-2.00.4.tar.gz
+ liberation-fonts-ttf-2.1.4.tar.gz
  e7a384790b13c29113e22e596ade9687-LinLibertineG-20120116.zip
  907d6e99f241876695c19ff3db0b8923-source-code-pro-2.030R-ro-1.050R-it.tar.gz
  edc4d741888bc0d38e32dbaa17149596-source-sans-pro-2.010R-ro-1.065R-it.tar.gz
  source-serif-pro-3.000R.tar.gz
  EmojiOneColor-SVGinOT-1.3.tar.gz
  noto-fonts-20171024.tar.gz
- culmus-0.131.tar.gz
+ culmus-0.133.tar.gz
  libre-hebrew-1.0.tar.gz
  alef-1.001.tar.gz
  ttf-kacst_2.01+mry.tar.gz
+ zxing-cpp-1.1.1.tar.gz
  Amiri-0.111.zip
  ReemKufi-0.7.zip
  Scheherazade-2.100.zip
@@ -394,7 +400,7 @@ _add_lang zu		"Zulu"
 post_fetch() {
 	local srcdistdir=${XBPS_SRCDISTDIR}/${pkgname}-${version} pkg
 	mkdir -p ${wrksrc}/external/tarballs
-	for pkg in ${skip_extraction}; do
+	for pkg in ${skip_extraction} libreoffice-{dictionaries,help,translations}-${version}.tar.xz ; do
 		if [ "${pkg%.dll}" != "${pkg}" ]; then
 			# The dll needs to be copied instead of symlinked
 			cp -v ${srcdistdir}/${pkg} ${wrksrc}/external/tarballs/
@@ -454,7 +460,6 @@ do_configure() {
 	opts+=" --enable-gtk3"
 	opts+=" --enable-qt5"
 	opts+=" --enable-kf5"
-	opts+=" --enable-vlc"
 	opts+=" --disable-dependency-tracking"
 	opts+=" --enable-release-build"
 	opts+=" --enable-split-app-modules"
@@ -488,12 +493,14 @@ do_configure() {
 	fi
 	opts+=" --with-tls=nss"
 	opts+=" --without-system-box2d"
+	opts+=" --without-system-libcmis"
 	opts+=" --without-system-libzmf"
 	opts+=" --without-system-libstaroffice"
 	opts+=" --without-system-libtommath"
 	opts+=" --without-system-jfreereport"
 	opts+=" --without-system-apache-commons"
 	opts+=" --without-system-beanshell"
+	opts+=" --without-system-zxing"
 	# opts+=" --without-system-glm"
 	opts+=" --with-myspell-dicts"
 	opts+=" --with-system-icu-for-build=yes"
@@ -515,11 +522,6 @@ do_configure() {
 do_build() {
 	make ${makejobs} ${make_build_target}
 	make ${makejobs} -C libreofficekit
-
-	# on some platforms (32-bit ppc at least), this single file has
-	# incorrect (non-executable) permissions, so fix it here
-	# only this file is affected and i have no idea why...
-	chmod 755 ${wrksrc}/instdir/program/soffice
 }
 
 do_install() {
@@ -540,7 +542,7 @@ libreoffice-common_package() {
 
 libreoffice-base_package() {
 	short_desc+=" - Database frontend"
-	depends="libreoffice-common>=${version}_${revision}"
+	depends="libreoffice-writer>=${version}_${revision}"
 	noverifyrdeps=yes
 	pkg_install() {
 		_split base
@@ -549,7 +551,7 @@ libreoffice-base_package() {
 
 libreoffice-calc_package() {
 	short_desc+=" - Spreadsheet"
-	depends="libreoffice-common>=${version}_${revision}"
+	depends="libreoffice-writer>=${version}_${revision}"
 	noverifyrdeps=yes
 	pkg_install() {
 		_split calc
@@ -558,7 +560,7 @@ libreoffice-calc_package() {
 
 libreoffice-draw_package() {
 	short_desc+=" - Drawing application"
-	depends="sane libreoffice-common>=${version}_${revision}"
+	depends="sane libreoffice-writer>=${version}_${revision}"
 	noverifyrdeps=yes
 	pkg_install() {
 		_split draw
@@ -585,7 +587,7 @@ libreoffice-gnome_package() {
 
 libreoffice-impress_package() {
 	short_desc+=" - Presentation application"
-	depends="libreoffice-common>=${version}_${revision}"
+	depends="libreoffice-writer>=${version}_${revision}"
 	noverifyrdeps=yes
 	pkg_install() {
 		_split impress
@@ -616,7 +618,7 @@ libreoffice-kit_package() {
 
 libreoffice-math_package() {
 	short_desc+=" - Equation editor"
-	depends="libreoffice-common>=${version}_${revision}"
+	depends="libreoffice-writer>=${version}_${revision}"
 	noverifyrdeps=yes
 	pkg_install() {
 		_split math

From e92096a7505f42d92a02dfba9d5b8868d3f5270c Mon Sep 17 00:00:00 2001
From: ologantr <mrphyber@protonmail.com>
Date: Thu, 2 Dec 2021 13:04:03 +0100
Subject: [PATCH 261/288] sqlite: update to 3.37.0

---
 srcpkgs/sqlite/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/sqlite/template b/srcpkgs/sqlite/template
index 5a2c6dfcca5f..cf993a2c88fe 100644
--- a/srcpkgs/sqlite/template
+++ b/srcpkgs/sqlite/template
@@ -1,6 +1,6 @@
 # Template file for 'sqlite'
 pkgname=sqlite
-version=3.36.0
+version=3.37.0
 revision=1
 _amalgamationver=$(printf "%d%02d%02d00\n" ${version//./ })
 wrksrc="sqlite-autoconf-${_amalgamationver}"
@@ -13,7 +13,7 @@ license="Public Domain"
 homepage="https://sqlite.org/"
 changelog="https://www.sqlite.org/releaselog/${version//./_}.html"
 distfiles="${homepage}/2021/sqlite-autoconf-${_amalgamationver}.tar.gz"
-checksum=bd90c3eb96bee996206b83be7065c9ce19aef38c3f4fb53073ada0d0b69bbce3
+checksum=731a4651d4d4b36fc7d21db586b2de4dd00af31fd54fb5a9a4b7f492057479f7
 
 CFLAGS="-DSQLITE_ENABLE_DBSTAT_VTAB -DSQLITE_ENABLE_COLUMN_METADATA \
  -DSQLITE_ENABLE_UNLOCK_NOTIFY -DSQLITE_SECURE_DELETE -DSQLITE_ENABLE_JSON1 \

From 474cbbfee8ad178ae140e09ac48cd77a47273344 Mon Sep 17 00:00:00 2001
From: ologantr <mrphyber@protonmail.com>
Date: Thu, 2 Dec 2021 13:07:51 +0100
Subject: [PATCH 262/288] fossil: update to 2.17

---
 srcpkgs/fossil/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/fossil/template b/srcpkgs/fossil/template
index 674bfc2d632e..63323b9f1f02 100644
--- a/srcpkgs/fossil/template
+++ b/srcpkgs/fossil/template
@@ -1,6 +1,6 @@
 # Template file for 'fossil'
 pkgname=fossil
-version=2.16
+version=2.17
 revision=1
 build_style=configure
 configure_args="--disable-internal-sqlite --prefix=/usr"
@@ -12,7 +12,7 @@ license="BSD-2-Clause"
 homepage="https://www.fossil-scm.org"
 changelog="https://www.fossil-scm.org/home/doc/trunk/www/changes.wiki"
 distfiles="https://fossil-scm.org/home/tarball/version-${version}/fossil-${version}.tar.gz"
-checksum=1eab740b04d98d2c35776fea65eba86007ea1441d2116943eb0a67e18a88b2fc
+checksum=21d6ee5187775113f74e55ab5ebcb1764f7226a8e59be1b2c7896cbe9dce6914
 
 post_extract() {
 	vsed -i 's/test_system_sqlite$/# &/' auto.def  # failing on cross

From 9ce4b6016022806eadb6874e4355f83cdc7cc21b Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Ey=C3=9Fer?= <daniel.eysser@gmail.com>
Date: Sat, 27 Nov 2021 13:45:35 +0100
Subject: [PATCH 263/288] fd: update to 8.3.0.

---
 srcpkgs/fd/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/fd/template b/srcpkgs/fd/template
index f7d5cfc6b0c7..7b8fe10e0a50 100644
--- a/srcpkgs/fd/template
+++ b/srcpkgs/fd/template
@@ -1,6 +1,6 @@
 # Template file for 'fd'
 pkgname=fd
-version=8.2.1
+version=8.3.0
 revision=1
 build_style=cargo
 short_desc="Simple, fast and user-friendly alternative to find"
@@ -9,7 +9,7 @@ license="Apache-2.0, MIT"
 homepage="https://github.com/sharkdp/fd"
 changelog="https://raw.githubusercontent.com/sharkdp/fd/master/CHANGELOG.md"
 distfiles="https://github.com/sharkdp/fd/archive/v${version}.tar.gz"
-checksum=429de7f04a41c5ee6579e07a251c72342cd9cf5b11e6355e861bb3fffa794157
+checksum=3c5a8a03c4f6ade73b92432ed0ba51591db19b0d136073fa3ccfa99d63403d52
 
 post_install() {
 	vman doc/fd.1

From 6f0c1a597b5a8c9a4b332cdc396e482584299a57 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Fri, 3 Dec 2021 16:53:50 +0100
Subject: [PATCH 264/288] isync: update to 1.4.4.

---
 srcpkgs/isync/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/isync/template b/srcpkgs/isync/template
index bad7086f050f..e72235d5b77e 100644
--- a/srcpkgs/isync/template
+++ b/srcpkgs/isync/template
@@ -1,6 +1,6 @@
 # Template file for 'isync'
 pkgname=isync
-version=1.4.3
+version=1.4.4
 revision=1
 build_style=gnu-configure
 hostmakedepends="perl pkg-config"
@@ -12,7 +12,7 @@ license="GPL-2.0-or-later"
 homepage="http://isync.sourceforge.net/"
 changelog="https://sourceforge.net/p/isync/isync/ci/master/tree/NEWS?format=raw"
 distfiles="${SOURCEFORGE_SITE}/${pkgname}/${pkgname}-${version}.tar.gz"
-checksum=b4c720745bda3447fbd5b9f71783b23f699a55295917ae7586ee5c22e91b9708
+checksum=7c3273894f22e98330a330051e9d942fd9ffbc02b91952c2f1896a5c37e700ff
 
 post_install() {
 	vsconf src/mbsyncrc.sample

From 01e3fcd95ce2be9c34595ecc2c8209cfd16ee477 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Fri, 3 Dec 2021 16:55:01 +0100
Subject: [PATCH 265/288] janet: update to 1.19.0.

---
 common/shlibs          | 2 +-
 srcpkgs/janet/template | 4 ++--
 2 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index ad60646030fe..abdf7b261f8a 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -3889,7 +3889,7 @@ libcaribou.so.0 libcaribou-0.4.21_3
 libtinyclipboard.so.1 tinyclipboard-16.01_1
 libcbor.so.0.9 libcbor-0.9.0_1
 libfido2.so.1 libfido2-1.6.0_2
-libjanet.so.1.18 janet-1.18.0_1
+libjanet.so.1.19 janet-1.19.0_1
 libOpenImageDenoise.so.1 openimagedenoise-1.3.0_1
 libcbang0.so cbang-1.6.0_3
 libblosc.so.1 c-blosc-1.17.1_1
diff --git a/srcpkgs/janet/template b/srcpkgs/janet/template
index 373b1475e233..c36e4a4e97ab 100644
--- a/srcpkgs/janet/template
+++ b/srcpkgs/janet/template
@@ -1,6 +1,6 @@
 # Template file for 'janet'
 pkgname=janet
-version=1.18.1
+version=1.19.0
 revision=1
 build_style=meson
 configure_args="-Db_lto=false"  # breaks jpm
@@ -10,7 +10,7 @@ license="MIT"
 homepage="https://janet-lang.org/"
 changelog="https://github.com/janet-lang/janet/blob/master/CHANGELOG.md"
 distfiles="https://github.com/janet-lang/janet/archive/v${version}.tar.gz"
-checksum=bfc29c11a070cc175666f74eb99ea992276d6e269701ba9558a72cef05ac80b4
+checksum=613f08613d524349bea9777d9f4f930252a0f035332da113c993153fe5284ef2
 
 post_install() {
 	vlicense LICENSE

From cdddcceb689640652215408ce26564775f04fc84 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Fri, 3 Dec 2021 16:55:34 +0100
Subject: [PATCH 266/288] ugrep: update to 3.3.10.

---
 srcpkgs/ugrep/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/ugrep/template b/srcpkgs/ugrep/template
index 39891a0af99f..75826fd725ac 100644
--- a/srcpkgs/ugrep/template
+++ b/srcpkgs/ugrep/template
@@ -1,6 +1,6 @@
 # Template file for 'ugrep'
 pkgname=ugrep
-version=3.3.8
+version=3.3.10
 revision=1
 build_style=gnu-configure
 makedepends="bzip2-devel liblz4-devel liblzma-devel libzstd-devel pcre2-devel
@@ -10,7 +10,7 @@ maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="BSD-3-Clause"
 homepage="https://github.com/Genivia/ugrep"
 distfiles="https://github.com/Genivia/ugrep/archive/v${version}.tar.gz"
-checksum=1bdc73ca5fc12a41c2f7949900edee0972ca3e5f39066c8d68449846df4cf1d7
+checksum=8cf74bdf254bac78c19385028bbf8678d83be35522d452b71d16105a1c4c57b8
 
 post_install() {
 	vlicense LICENSE.txt LICENSE

From 60d104184c2274384f0bc1b35c5e75c81ca1c668 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Fri, 3 Dec 2021 18:04:38 +0100
Subject: [PATCH 267/288] z3: update to 4.8.13.

---
 srcpkgs/z3/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/z3/template b/srcpkgs/z3/template
index bca042082b3f..fb8aca291c2b 100644
--- a/srcpkgs/z3/template
+++ b/srcpkgs/z3/template
@@ -1,6 +1,6 @@
 # Template file for 'z3'
 pkgname=z3
-version=4.8.12
+version=4.8.13
 revision=4
 wrksrc="${pkgname}-${pkgname}-${version}"
 build_style=configure
@@ -15,7 +15,7 @@ maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="MIT"
 homepage="https://github.com/Z3Prover/z3"
 distfiles="https://github.com/Z3Prover/z3/archive/z3-${version}.tar.gz"
-checksum=e3aaefde68b839299cbc988178529535e66048398f7d083b40c69fe0da55f8b7
+checksum=59a0b35711fa7ae48dd535116d2067a6a16955fcbf2623c516a3f630cd2832d8
 
 build_options="ocaml"
 desc_option_ocaml="Enable support for OCaml bindings"

From 3def35292e87c10131ac4a22fbbaff09632f841e Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Fri, 3 Dec 2021 23:07:07 +0100
Subject: [PATCH 268/288] pymol: update to 2.5.0.

---
 srcpkgs/pymol/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/pymol/template b/srcpkgs/pymol/template
index 75b78380572c..659dea5d368c 100644
--- a/srcpkgs/pymol/template
+++ b/srcpkgs/pymol/template
@@ -1,12 +1,12 @@
 # Template file for 'pymol'
 pkgname=pymol
-version=2.4.0
-revision=3
+version=2.5.0
+revision=1
 wrksrc=${pkgname}-open-source-${version}
 build_style="python3-module"
 build_helper="numpy"
-makedepends="msgpack-devel freetype-devel libfreeglut-devel netcdf-devel
- glew-devel glm python3-devel libxml2-devel python3-PyQt5 mmtf-cpp"
+makedepends="freetype-devel glew-devel glm libfreeglut-devel libgomp-devel
+ libxml2-devel mmtf-cpp msgpack-devel netcdf-devel python3-PyQt5 python3-devel"
 depends="python3-numpy tcsh python3-pmw python3-tkinter python3-PyQt5"
 short_desc="PyMOL molecular visualization system"
 maintainer="Brenton Horne <brentonhorne77@gmail.com>"
@@ -14,7 +14,7 @@ license="custom:PyMOL"
 homepage="https://pymol.org/"
 distfiles="https://github.com/schrodinger/pymol-open-source/archive/v${version}.tar.gz>${pkgname}-${version}.tar.gz
  https://c.fsdn.com/allura/p/${pkgname}/icon>${pkgname}.png"
-checksum="5ede4ce2e8f53713c5ee64f5905b2d29bf01e4391da7e536ce8909d6b9116581
+checksum="aa828bf5719bd9a14510118a93182a6e0cadc03a574ba1e327e1e9780a0e80b3
  0ea81faaf336becc669a193777d0dca55475d303d1236b57df25cf67ff7c2bcd"
 skip_extraction="${pkgname}.png"
 

From d534b3f8cfcf639d1dd0f595254f253ed382b7b1 Mon Sep 17 00:00:00 2001
From: oreo639 <31916379+Oreo639@users.noreply.github.com>
Date: Fri, 26 Nov 2021 23:45:32 -0800
Subject: [PATCH 269/288] New package: webp-pixbuf-loader-0.0.3

---
 srcpkgs/webp-pixbuf-loader/template | 13 +++++++++++++
 1 file changed, 13 insertions(+)
 create mode 100644 srcpkgs/webp-pixbuf-loader/template

diff --git a/srcpkgs/webp-pixbuf-loader/template b/srcpkgs/webp-pixbuf-loader/template
new file mode 100644
index 000000000000..189889b62896
--- /dev/null
+++ b/srcpkgs/webp-pixbuf-loader/template
@@ -0,0 +1,13 @@
+# Template file for 'webp-pixbuf-loader'
+pkgname=webp-pixbuf-loader
+version=0.0.3
+revision=1
+build_style=meson
+hostmakedepends="pkg-config gdk-pixbuf"
+makedepends="gdk-pixbuf-devel libwebp-devel"
+short_desc="WebP Image format loader for GdkPixbuf"
+maintainer="oreo639 <oreo6391@gmail.com>"
+license="LGPL-2.0-or-later"
+homepage="https://github.com/aruiz/webp-pixbuf-loader"
+distfiles="https://github.com/aruiz/webp-pixbuf-loader/archive/refs/tags/${version}.tar.gz"
+checksum=e2ba11afcd1272f26147214659bcf2462066a840ecb9ba2776c85abd0ec43cbe

From c115ba446c553d4a18fe838d94f8eb0a1b1a6050 Mon Sep 17 00:00:00 2001
From: Daniel Lewan <vision360.daniel@gmail.com>
Date: Fri, 3 Dec 2021 23:24:52 +0100
Subject: [PATCH 270/288] s: update to 0.6.2.

---
 srcpkgs/s/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/s/template b/srcpkgs/s/template
index e55d22e4d3d5..cb9c4fc4e4ca 100644
--- a/srcpkgs/s/template
+++ b/srcpkgs/s/template
@@ -1,6 +1,6 @@
 # Template file for 's'
 pkgname=s
-version=0.6.1
+version=0.6.2
 revision=1
 build_helper=qemu
 build_style=go
@@ -11,7 +11,7 @@ maintainer="Daniel Lewan <vision360.daniel@gmail.com>"
 license="MIT"
 homepage="https://github.com/zquestz/s"
 distfiles="https://github.com/zquestz/s/archive/v${version}.tar.gz"
-checksum=8f5f3e9503edcf9eb4792379f93c1e08806b8b9699121a72745d1d63c91a0426
+checksum=acc38953fcb21e1dd2cd761b9d2bf8272aa6aa30fed2adb657f2dba7e4df872f
 
 post_build() {
 	s_cli=$(find $GOPATH/bin -name s)

From 6cc74e6885a806b3307e7923bb092bacc61358f3 Mon Sep 17 00:00:00 2001
From: Daniel Lewan <vision360.daniel@gmail.com>
Date: Fri, 3 Dec 2021 23:26:23 +0100
Subject: [PATCH 271/288] hivemind: update to 1.1.0.

---
 srcpkgs/hivemind/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/hivemind/template b/srcpkgs/hivemind/template
index 935d852b4a5c..ad154844be35 100644
--- a/srcpkgs/hivemind/template
+++ b/srcpkgs/hivemind/template
@@ -1,6 +1,6 @@
 # Template file for 'hivemind'
 pkgname=hivemind
-version=1.0.6
+version=1.1.0
 revision=1
 build_style=go
 go_import_path="github.com/DarthSim/hivemind"
@@ -9,7 +9,7 @@ maintainer="Daniel Lewan <vision360.daniel@gmail.com>"
 license="MIT"
 homepage="https://github.com/DarthSim/hivemind"
 distfiles="https://github.com/DarthSim/hivemind/archive/v${version}.tar.gz"
-checksum=8ca7884db49268b7938d0503e7e95443cb3a56696478d5dcc2b9813705525a39
+checksum=b4f7259663ef5b99906af0d98fe4b964d8f9a4d86a8f5aff30ab8df305d3a996
 
 post_install() {
 	vlicense LICENSE

From a85013a4bbc93363790bc400f3cf825e904564e1 Mon Sep 17 00:00:00 2001
From: Daniel Lewan <vision360.daniel@gmail.com>
Date: Sat, 4 Dec 2021 00:01:44 +0100
Subject: [PATCH 272/288] go: update URLs and install VERSION file

---
 srcpkgs/go/template | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/go/template b/srcpkgs/go/template
index 9aa551c74c53..cc66dc6c7f46 100644
--- a/srcpkgs/go/template
+++ b/srcpkgs/go/template
@@ -1,16 +1,16 @@
 # Template file for 'go'
 pkgname=go
 version=1.17.2
-revision=1
+revision=2
 create_wrksrc=yes
 build_wrksrc=go
 hostmakedepends="go1.12-bootstrap"
 short_desc="Go Programming Language"
 maintainer="Michael Aldridge <maldridge@voidlinux.org>"
 license="BSD-3-Clause"
-homepage="https://golang.org/"
-changelog="https://golang.org/doc/devel/release.html"
-distfiles="https://golang.org/dl/go${version}.src.tar.gz"
+homepage="https://go.dev/"
+changelog="https://go.dev/doc/devel/release.html"
+distfiles="https://go.dev/dl/go${version}.src.tar.gz"
 checksum=2255eb3e4e824dd7d5fcdc2e7f84534371c186312e546fb1086a34c17752f431
 nostrip=yes
 noverifyrdeps=yes
@@ -63,6 +63,7 @@ do_install() {
 	cp -a pkg src lib ${DESTDIR}/usr/lib/go
 	cp -r doc misc -t ${DESTDIR}/usr/share/go
 	ln -s /usr/share/go/doc ${DESTDIR}/usr/lib/go/doc
+	cp VERSION ${DESTDIR}/usr/lib/go/VERSION
 
 	# This is to make go get code.google.com/p/go-tour/gotour and
 	# then running the gotour executable work out of the box.

From 404660c8c37cf556b7fad9cc137afeb1bc5536a3 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Ey=C3=9Fer?= <daniel.eysser@gmail.com>
Date: Fri, 3 Dec 2021 12:02:29 +0100
Subject: [PATCH 273/288] dunst: update to 1.7.2.

---
 srcpkgs/dunst/template | 11 +++++++----
 1 file changed, 7 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/dunst/template b/srcpkgs/dunst/template
index 1b80bf0d1987..3c3d9f5107bd 100644
--- a/srcpkgs/dunst/template
+++ b/srcpkgs/dunst/template
@@ -1,21 +1,24 @@
 # Template file for 'dunst'
 pkgname=dunst
-version=1.7.1
+version=1.7.2
 revision=1
 build_style=gnu-makefile
+make_check_target=test
 make_use_env=yes
-make_build_args="SYSTEMD=0 WAYLAND=$(vopt_if wayland 1 0)"
+make_build_args="SYSTEMD=0 WAYLAND=$(vopt_if wayland 1 0) SYSCONFDIR=/etc"
 make_install_args="$make_build_args"
 hostmakedepends="perl pkg-config"
-makedepends="gtk+-devel libXScrnSaver-devel libXinerama-devel libXrandr-devel
+makedepends="gdk-pixbuf-devel libXScrnSaver-devel libXinerama-devel libXrandr-devel
  libxdg-basedir-devel libnotify-devel $(vopt_if wayland 'wayland-devel wayland-protocols')"
+checkdepends="dbus"
+conf_files="/etc/dunst/dunstrc"
 short_desc="Lightweight and customizable notification daemon"
 maintainer="Daniel Santana <daniel@santana.tech>"
 license="BSD-3-Clause"
 homepage="https://dunst-project.org"
 changelog="https://raw.githubusercontent.com/dunst-project/dunst/master/CHANGELOG.md"
 distfiles="https://github.com/dunst-project/dunst/archive/v${version}.tar.gz"
-checksum=f61ed3280aee9ec2aac07c44cf3d147df8fe8a6d7b92b6e8ab04e546bff1adce
+checksum=e4fa376d327e8a4cd375d00d4c318c93cc0968d4f184ab40da94ca6b30477181
 
 build_options="wayland"
 build_options_default="wayland"

From ef8ff65951470e991e759a58ae6bd07b97dff2d3 Mon Sep 17 00:00:00 2001
From: Tomasz Kramkowski <tk@the-tk.com>
Date: Tue, 16 Nov 2021 20:26:26 +0000
Subject: [PATCH 274/288] nim: update to 1.6.0 (and fixes + cleanup)

Version bump to 1.6.0 including the following changes:

- Nim now comes with testament
- Fusion library is no longer bundled with nim
- Examples no longer come with nim
- FIX - non-x86_64/i686 nim.cfg compiler configuration
  Non-x86_64/i686 builds no longer end up with a broken nim.cfg which
  will try to use the package build time $CC to build packages for the
  package architecture as well as a bunch of others (which will simply
  not work).
- FIX - arm nim.cfg compiler configuration
  The default arm.linux.gcc.(linker)?exe variables are now commented on
  non-x86_64/i686 builds to ensure that arm packages don't end up with
  the same issue as above.
- CLEANUP - use koch to build non-x86_64/i686 tools
  The loop was unnecessary.
  - note: This means nimsuggest is now built without -d:release on all
    builds (not just x86_64/i686 builds). I am not sure if this is
    intentional or an upstream bug, should be investigated at some
    point.
- CLEANUP - use make to build the bootstrap compiler
---
 srcpkgs/nim/template | 66 ++++++++++++++------------------------------
 1 file changed, 21 insertions(+), 45 deletions(-)

diff --git a/srcpkgs/nim/template b/srcpkgs/nim/template
index 76a3452c68ab..809627066a68 100644
--- a/srcpkgs/nim/template
+++ b/srcpkgs/nim/template
@@ -1,13 +1,11 @@
 # Template file for 'nim'
 pkgname=nim
-version=1.4.8
+version=1.6.0
 revision=1
-_cversion=0.20.0
-_nimbleversion=0.12.0
-_fusionversion=e942c649892b2ae3802851fba6bc5d251326e5fb
+_c1version=561b417c65791cd8356b5f73620914ceff845d10
+_nimbleversion=0.13.1
 create_wrksrc=yes
 build_wrksrc="Nim-$version"
-hostmakedepends="ed"
 depends="gcc openssl-devel"
 short_desc="Nim programming language"
 maintainer="allan <mail@may.mooo.com>"
@@ -15,31 +13,27 @@ license="MIT"
 homepage="https://nim-lang.org/"
 _ghsite="https://github.com/nim-lang"
 distfiles="${_ghsite}/Nim/archive/v${version}.tar.gz
- ${_ghsite}/csources/archive/v${_cversion}.tar.gz>csources-${_cversion}.tar.gz
- ${_ghsite}/nimble/archive/v${_nimbleversion}.tar.gz>nimble-${_nimbleversion}.tar.gz
- ${_ghsite}/fusion/archive/${_fusionversion}.tar.gz>fusion-${_fusionversion}.tar.gz"
-checksum="8a687beb30670dc4eadcfefd1198d4238af283dc716438ac2342a7d65e07d9e9
- 5e6fd15d90df1a8cb7614c4ffc70aa8c4198cd854d7742016202b96dd0228d3c
- 0b88d91a450f31641f85379f2d76afb0a013cf783e62144a6534525b9cb1cbac
- 76d10a2f0f25ba7fb3393bdb800c75e8084758d8ce69e63d07926cd36f555084"
+ ${_ghsite}/csources_v1/archive/${_c1version}.tar.gz>csources_v1-${_c1version}.tar.gz
+ ${_ghsite}/nimble/archive/v${_nimbleversion}.tar.gz>nimble-${_nimbleversion}.tar.gz"
+checksum="c202cfd24a24480da1cf851e1265b87edb22710bb42286a57b1a99c83b6a8315
+ 71c823444c794a12da9027d19d6a717dd7759521ecbbe28190b08372142607ec
+ e6aa8d9ee4b3ed0321dca329b4a38fa546771b9729984482fb50fe73d3777f5d"
 
 post_extract() {
-	mv csources-$_cversion $build_wrksrc/csources
+	mv csources_v1-$_c1version $build_wrksrc/csources_v1
 	mkdir $build_wrksrc/dist
 	mv nimble-$_nimbleversion $build_wrksrc/dist/nimble
-	mv fusion-$_fusionversion $build_wrksrc/dist/fusion
 }
 
 do_build() {
-	cd csources
 	case "$XBPS_TARGET_MACHINE" in
 		i686*)
 			CC=cc LD=cc CFLAGS="-Os -pipe" LDFLAGS= \
-			sh build.sh --cpu i686;;
+			make -C csources_v1 ucpu=i686 ${makejobs};;
 		*)
-			CC=cc LD=cc CFLAGS="-Os -pipe" LDFLAGS= sh build.sh;;
+			CC=cc LD=cc CFLAGS="-Os -pipe" LDFLAGS= \
+			make -C csources_v1 ${makejobs};;
 	esac
-	cd ..
 
 	bin/nim c koch
 	./koch boot -d:release -d:danger
@@ -54,32 +48,15 @@ do_build() {
 
 	case "$XBPS_TARGET_MACHINE"
 	in arm*|aarch64*|ppc*)
-		ed config/nim.cfg <<-EDIT
-			,s/^arm.linux.gcc.exe .*/arm.linux.gcc.exe = "$CC"/
-			,s/^arm.linux.gcc.linkerexe .*/arm.linux.gcc.linkerexe = "$CC"/
-			a
-			arm64.linux.gcc.exe = "$CC"
-			arm64.linux.gcc.linkerexe = "$CC"
-			powerpc.linux.gcc.exe = "$CC"
-			powerpc.linux.gcc.linkerexe = "$CC"
-			powerpc64.linux.gcc.exe = "$CC"
-			powerpc64.linux.gcc.linkerexe = "$CC"
-			powerpc64el.linux.gcc.exe = "$CC"
-			powerpc64el.linux.gcc.linkerexe = "$CC"
-			.
-			w
-			q
+		vsed -i config/nim.cfg -e 's/^arm\.linux\.gcc\.\(linker\)\?exe /#&/'
+		cat >>config/nim.cfg <<-EDIT
+		# VOIDLINUX TEMP
+		$_arch.linux.gcc.exe = "$CC"
+		$_arch.linux.gcc.linkerexe = "$CC"
 		EDIT
 		bin/nim c -d:release -d:danger --os:linux --cpu:$_arch --listCmd compiler/nim
-		for _p in \
-			dist/nimble/src/nimble \
-			tools/nimgrep \
-			nimsuggest/nimsuggest \
-			nimpretty/nimpretty
-		do
-			bin/nim c -d:release --os:linux --cpu:$_arch --listCmd $_p
-			mv $_p bin
-		done
+		./koch tools --os:linux --cpu:$_arch --listCmd
+		vsed -i config/nim.cfg -e '/^# VOIDLINUX TEMP$/,$d'
 	;; *)
 		./koch tools
 	esac
@@ -95,14 +72,13 @@ do_install() {
 	vmkdir usr/bin
 	vmkdir usr/share/nim
 	ln -sf /usr/lib/nim/bin/nim ${DESTDIR}/usr/bin/nim
-	for _f in nimble nimsuggest nimgrep nimpretty; do
+	for _f in nimble nimsuggest nimgrep nimpretty testament; do
 		chmod 0755 bin/$_f
 		cp bin/$_f ${DESTDIR}/usr/lib/nim/bin
 		ln -sf /usr/lib/nim/bin/$_f ${DESTDIR}/usr/bin/$_f
 	done
-	cp -r nimsuggest nimpretty doc examples ${DESTDIR}/usr/lib/nim
+	cp -r nimsuggest nimpretty doc ${DESTDIR}/usr/lib/nim
 	ln -sf /usr/lib/nim/doc ${DESTDIR}/usr/share/nim/doc
-	ln -sf /usr/lib/nim/examples ${DESTDIR}/usr/share/nim/examples
 	ln -sf /usr/lib/nim/nimsuggest ${DESTDIR}/usr/share/nim/nimsuggest
 	ln -sf /usr/lib/nim/nimpretty ${DESTDIR}/usr/share/nim/nimpretty
 	vlicense copying.txt

From 657f164b2470f83f568ecc319bf421fd6ec4ecef Mon Sep 17 00:00:00 2001
From: Henry Naguski <henry@nilsu.org>
Date: Sat, 13 Nov 2021 23:11:21 -0700
Subject: [PATCH 275/288] dolphin-emu: update to 5.0.15445.

---
 srcpkgs/dolphin-emu/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/dolphin-emu/template b/srcpkgs/dolphin-emu/template
index c538c4b97548..35ac6a3910df 100644
--- a/srcpkgs/dolphin-emu/template
+++ b/srcpkgs/dolphin-emu/template
@@ -1,9 +1,9 @@
 # Template file for 'dolphin-emu'
 pkgname=dolphin-emu
-version=5.0.15260
+version=5.0.15445
 revision=1
-_dolphin_commit=207c931a04c8e2629a735bc2b3f36b5c89365ca7
-_mgba_commit=9cccc5197ed73ba0a54f584d3121c27dc97405f5
+_dolphin_commit=db02b50d2ecdfbbc21e19aadc57253c353069f77
+_mgba_commit=40d4c430fc36caeb7ea32fd39624947ed487d2f2
 #Version/hash pair can be found at https://dolphin-emu.org/download/
 archs="x86_64* aarch64* ppc64le* i686*"
 wrksrc="dolphin-${_dolphin_commit}"
@@ -22,8 +22,8 @@ license="GPL-2.0-or-later"
 homepage="http://dolphin-emu.org"
 distfiles="https://github.com/dolphin-emu/dolphin/archive/${_dolphin_commit}.tar.gz
  https://github.com/mgba-emu/mgba/archive/${_mgba_commit}.tar.gz"
-checksum="84b21a6a14cf999e8c2bc44175f549aedaa4bd28a79eaa65afddd72f14905a3a
- d1c9fa071aae747fe1350130a2c69ed618ad52a759b35b119dbb7292252b4a77"
+checksum="19136c7b1bce2ff444e4a611f56268b371f4fa83a3e3ff5f3d9e2dbb34385692
+ 3cabf00a97cf4fb15fe8524b3d02190acdd003f25967cdbbf8de958649b8061b"
 nopie=yes
 
 case "$XBPS_TARGET_MACHINE" in

From dacd1b6758f9b6be1c8a029a62b59c5ba3d41478 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C3=89rico=20Nogueira?= <erico.erc@gmail.com>
Date: Sat, 4 Dec 2021 01:29:26 -0300
Subject: [PATCH 276/288] ImageMagick: update to 7.1.0.15.

---
 srcpkgs/ImageMagick/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/ImageMagick/template b/srcpkgs/ImageMagick/template
index 4648abfb476c..356015153e80 100644
--- a/srcpkgs/ImageMagick/template
+++ b/srcpkgs/ImageMagick/template
@@ -1,6 +1,6 @@
 # Template file for 'ImageMagick'
 pkgname=ImageMagick
-version=7.1.0.10
+version=7.1.0.15
 revision=1
 _majorver=${version%.*}
 _patchver=${version##*.}
@@ -20,7 +20,7 @@ license="ImageMagick"
 homepage="https://www.imagemagick.org"
 changelog="https://imagemagick.org/script/changelog.php"
 distfiles="https://github.com/ImageMagick/ImageMagick/archive/${_majorver}-${_patchver}.tar.gz"
-checksum=a2139da9a7c2e97f28861dfb18986f1d03435cf72e8ee4cc720a4997b5fa8d66
+checksum=0b0272b8bbdeb31b15c06f75764b93b22198453ef7fceabbc07655e90f3c73c2
 
 subpackages="libmagick libmagick-devel"
 

From a7dd8ab18c87747cff32f837c3d10b485775f8f8 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sat, 4 Dec 2021 08:20:48 -0500
Subject: [PATCH 277/288] maturin: update to 0.12.3.

---
 srcpkgs/maturin/patches/edition2018.patch | 18 ------------------
 srcpkgs/maturin/template                  |  4 ++--
 2 files changed, 2 insertions(+), 20 deletions(-)
 delete mode 100644 srcpkgs/maturin/patches/edition2018.patch

diff --git a/srcpkgs/maturin/patches/edition2018.patch b/srcpkgs/maturin/patches/edition2018.patch
deleted file mode 100644
index 7e6b267507b4..000000000000
--- a/srcpkgs/maturin/patches/edition2018.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Void can't yet compile with edition2021 and there seems to be no reason to
-demand it, so partially revert
-
-    https://github.com/PyO3/maturin/commit/4d51112a18a331248bb36c0cb5b4c60c6fe0091a
-
-and make maturin work.
-
---- a/Cargo.toml
-+++ b/Cargo.toml
-@@ -10,7 +10,7 @@
- license = "MIT OR Apache-2.0"
- keywords = ["python", "cffi", "packaging", "pypi", "pyo3"]
- categories = ["api-bindings", "development-tools::ffi", "command-line-utilities"]
--edition = "2021"
-+edition = "2018"
- 
- [badges]
- travis-ci = { repository = "PyO3/maturin" }
diff --git a/srcpkgs/maturin/template b/srcpkgs/maturin/template
index d5eb458e50a5..1556fa8f98c2 100644
--- a/srcpkgs/maturin/template
+++ b/srcpkgs/maturin/template
@@ -1,6 +1,6 @@
 # Template file for 'maturin'
 pkgname=maturin
-version=0.12.2
+version=0.12.3
 revision=1
 build_style=cargo
 build_helper=qemu
@@ -17,7 +17,7 @@ homepage="https://github.com/PyO3/maturin"
 # bump target-lexicon version if it changes in Cargo.lock
 distfiles="${homepage}/archive/v${version}.tar.gz
  https://github.com/bytecodealliance/target-lexicon/archive/v0.12.2.tar.gz>target-lexicon-${version}.tar.gz"
-checksum="d66d21703a78d71061b279b97fb7dd15a925474da19bce9928d87f1c22550ed6
+checksum="9a6ee17bdee33aa319941ca5000016397a2d5343a17341406150c4015aa81b75
  b6c2ddab7498cf6eab8e637a5b7895f3170b2f9ef989861d1ff33af6c8459b27"
 # Tests use unstable features and fail to build
 make_check=no

From 42717b92e9633d7dedc253a44b59bcad21057aa2 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sat, 4 Dec 2021 08:20:59 -0500
Subject: [PATCH 278/288] python3-setuptools-rust: update to 1.1.1.

---
 srcpkgs/python3-setuptools-rust/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-setuptools-rust/template b/srcpkgs/python3-setuptools-rust/template
index 85c562f33602..1811ad4be88e 100644
--- a/srcpkgs/python3-setuptools-rust/template
+++ b/srcpkgs/python3-setuptools-rust/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-setuptools-rust'
 pkgname=python3-setuptools-rust
-version=1.0.0
+version=1.1.1
 revision=1
 wrksrc="${pkgname#python3-}-${version}"
 build_style=python3-module
@@ -13,7 +13,7 @@ license="MIT"
 homepage="https://github.com/PyO3/setuptools-rust"
 changelog="https://raw.githubusercontent.com/PyO3/setuptools-rust/master/CHANGELOG.md"
 distfiles="${PYPI_SITE}/s/setuptools-rust/setuptools-rust-${version}.tar.gz"
-checksum=eb6e6d41f01e63d042288e5c609684adf93426c10ea745ec324263f3fcbf27e9
+checksum=dc04afb52a70e56f5d6800a7ed9c45ad5937ba95e51a042b9096459edc038ad6
 # Tests have unpackaged dependencies
 make_check=no
 

From 6c3ca5e22c095a69c64d2f9427abb0c201c96c34 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sat, 4 Dec 2021 08:22:34 -0500
Subject: [PATCH 279/288] python3-adblock: update to 0.5.1.

---
 srcpkgs/python3-adblock/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-adblock/template b/srcpkgs/python3-adblock/template
index 0d8832be8111..f24a681be0b9 100644
--- a/srcpkgs/python3-adblock/template
+++ b/srcpkgs/python3-adblock/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-adblock'
 pkgname=python3-adblock
-version=0.5.0
-revision=2
+version=0.5.1
+revision=1
 wrksrc="${pkgname/python3/python}-${version}"
 build_style=python3-pep517
 build_helper="rust"
@@ -16,7 +16,7 @@ license="Apache-2.0, MIT"
 homepage="https://github.com/ArniDagur/python-adblock"
 changelog="https://raw.githubusercontent.com/ArniDagur/python-adblock/master/CHANGELOG.md"
 distfiles="${homepage}/archive/${version}.tar.gz"
-checksum=35ab20170bcfe447efee4d988508d99477cc23b95a901383bf606ca2960148a3
+checksum=d24ef42c8532cab2970d1c3af116ee4d0fa595e23fbeabb3ba0f5dfa0a67eae1
 
 case "$XBPS_TARGET_MACHINE" in
 	i686*) broken="compiler throws SIGABRT on the psl crate" ;;

From 8bea736c030b83ab281582bce20e46a057a19034 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sat, 4 Dec 2021 08:29:12 -0500
Subject: [PATCH 280/288] python3-hypothesis: update to 6.30.0.

---
 srcpkgs/python3-hypothesis/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-hypothesis/template b/srcpkgs/python3-hypothesis/template
index 460af8b6cc06..9c88772dc4e8 100644
--- a/srcpkgs/python3-hypothesis/template
+++ b/srcpkgs/python3-hypothesis/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-hypothesis'
 pkgname=python3-hypothesis
-version=6.28.0
+version=6.30.0
 revision=1
 wrksrc="hypothesis-hypothesis-python-${version}"
 build_wrksrc=hypothesis-python
@@ -15,7 +15,7 @@ license="MPL-2.0"
 homepage="https://hypothesis.works/"
 changelog="https://hypothesis.readthedocs.io/en/latest/changes.html"
 distfiles="https://github.com/HypothesisWorks/hypothesis/archive/hypothesis-python-${version}.tar.gz"
-checksum=34a4e30f9a0a88bb48c2faf6d78512fb7978e03e152026e00210245b20356d70
+checksum=d10473a0b5a87eadd8e978067e4e18215cc69f40c1fdcaeedcd0ef89648c8f61
 
 do_check() {
 	# Manually run the tests that tox considers part of the "full" suite,

From d3cfc549e664a03e8630fdda46b565f5bdf5bf2c Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sat, 4 Dec 2021 08:30:22 -0500
Subject: [PATCH 281/288] python3-imageio: update to 2.13.1.

---
 srcpkgs/python3-imageio/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-imageio/template b/srcpkgs/python3-imageio/template
index 21b0e0981e11..00e60a63af44 100644
--- a/srcpkgs/python3-imageio/template
+++ b/srcpkgs/python3-imageio/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-imageio'
 pkgname=python3-imageio
-version=2.12.0
+version=2.13.1
 revision=1
 wrksrc="${pkgname#python3-}-${version}"
 build_style=python3-module
@@ -16,7 +16,7 @@ maintainer="Andrew J. Hesford <ajh@sideband.org>"
 license="BSD-2-Clause"
 homepage="https://github.com/imageio/imageio"
 distfiles="${homepage}/archive/v${version}.tar.gz"
-checksum=e7d1e7b135415db608f32c2feebd139afb9b8379dd4e49c661578f999dfc2cea
+checksum=00c843712d00d075a87bc9eb37c1b6ffe2b210327d8fbaabd52759a961b5b4bd
 
 post_install() {
 	vlicense LICENSE

From 9cc5498c3b3bfe75c52c703c43d048022057405e Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sat, 4 Dec 2021 08:31:58 -0500
Subject: [PATCH 282/288] python3-ipython: update to 7.30.1.

---
 srcpkgs/python3-ipython/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-ipython/template b/srcpkgs/python3-ipython/template
index 85a1ae2e64c5..f2eed91a2d1f 100644
--- a/srcpkgs/python3-ipython/template
+++ b/srcpkgs/python3-ipython/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-ipython'
 pkgname=python3-ipython
-version=7.30.0
+version=7.30.1
 revision=1
 wrksrc="ipython-${version}"
 build_style=python3-module
@@ -16,7 +16,7 @@ maintainer="Andrew J. Hesford <ajh@sideband.org>"
 license="BSD-3-Clause"
 homepage="https://ipython.org/"
 distfiles="${PYPI_SITE}/i/ipython/ipython-${version}.tar.gz"
-checksum=d41f8e80b99690122400f9b2069b12f670246a1b4cc5d332bd6c4e2500e6d6fb
+checksum=cb6aef731bf708a7727ab6cde8df87f0281b1427d41e65d62d4b68934fa54e97
 conflicts="python-ipython<=5.8.0_2"
 
 do_check() {

From e004ba42f8e9ee8a76babbcf3b1ba9c85dca0924 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sat, 4 Dec 2021 08:46:54 -0500
Subject: [PATCH 283/288] python3-parso: update to 0.8.3.

---
 srcpkgs/python3-parso/template | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-parso/template b/srcpkgs/python3-parso/template
index 5fb79d8baaad..16b67897a9d7 100644
--- a/srcpkgs/python3-parso/template
+++ b/srcpkgs/python3-parso/template
@@ -1,9 +1,11 @@
 # Template file for 'python3-parso'
 pkgname=python3-parso
-version=0.8.2
-revision=2
+version=0.8.3
+revision=1
 wrksrc="parso-${version}"
 build_style=python3-module
+# Several error messages changed form and trigger inappropriate failures
+make_check_args="--ignore=test/test_python_errors.py"
 hostmakedepends="python3-setuptools"
 depends="python3"
 checkdepends="python3-pytest"
@@ -12,7 +14,7 @@ maintainer="Andrew J. Hesford <ajh@sideband.org>"
 license="MIT"
 homepage="https://github.com/davidhalter/parso"
 distfiles="${PYPI_SITE}/p/parso/parso-${version}.tar.gz"
-checksum=12b83492c6239ce32ff5eed6d3639d6a536170723c6f3f1506869f1ace413398
+checksum=8c07be290bb59f03588915921e29e8a50002acaf2cdc5fa0e0114f91709fafa0
 
 post_install() {
 	vlicense LICENSE.txt

From 0698dc1bd417bb8c3c85864156cba2c79ce1c530 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sat, 4 Dec 2021 09:21:39 -0500
Subject: [PATCH 284/288] python3-scikit-image: update to 0.19.0.

---
 .../patches/no-pythran.patch                  | 60 +++++++++++++++++++
 srcpkgs/python3-scikit-image/template         | 13 ++--
 2 files changed, 67 insertions(+), 6 deletions(-)
 create mode 100644 srcpkgs/python3-scikit-image/patches/no-pythran.patch

diff --git a/srcpkgs/python3-scikit-image/patches/no-pythran.patch b/srcpkgs/python3-scikit-image/patches/no-pythran.patch
new file mode 100644
index 000000000000..a2a1bf479ead
--- /dev/null
+++ b/srcpkgs/python3-scikit-image/patches/no-pythran.patch
@@ -0,0 +1,60 @@
+Disable optional Pythran support that is hard-required during build.
+
+--- a/setup.py
++++ b/setup.py
+@@ -6,7 +6,7 @@
+ import shutil
+ import builtins
+ import textwrap
+-from numpy.distutils.command.build_ext import build_ext as npy_build_ext
++from numpy.distutils.command.build_ext import build_ext
+ 
+ import setuptools
+ from setuptools.command.build_py import build_py
+@@ -17,7 +17,13 @@
+     # can remove this except case once we require setuptools>=59.0
+     from distutils.errors import CompileError, LinkError
+ 
+-from pythran.dist import PythranBuildExt as pythran_build_ext
++try:
++    from pythran.dist import PythranBuildExt as pythran_build_ext
++except ImportError:
++    pass
++else:
++    # Replace numpy extension builder with pythran version
++    build_ext = pythran_build_ext[build_ext]
+ 
+ DISTNAME = 'scikit-image'
+ DESCRIPTION = 'Image processing in Python'
+@@ -60,7 +66,7 @@
+ 
+ # Support for openmp
+ 
+-class ConditionalOpenMP(pythran_build_ext[npy_build_ext]):
++class ConditionalOpenMP(build_ext):
+ 
+     def can_compile_link(self, compile_flags, link_flags):
+ 
+--- a/skimage/feature/setup.py
++++ b/skimage/feature/setup.py
+@@ -2,7 +2,7 @@
+ 
+ import os
+ from skimage._build import cython
+-import pythran, logging
++import logging
+ 
+ base_path = os.path.abspath(os.path.dirname(__file__))
+ 
+@@ -43,6 +43,11 @@
+     config.add_extension('_sift', sources=['_sift.c'],
+                          include_dirs=[get_numpy_include_dirs(), '../_shared'])
+ 
++    try:
++        import pythran
++    except ImportError:
++        return config
++
+     # pythran submodules
+     pythran.config.logger.setLevel(logging.INFO)
+     ext = pythran.dist.PythranExtension(
diff --git a/srcpkgs/python3-scikit-image/template b/srcpkgs/python3-scikit-image/template
index 49b214c11aef..b1d87f9d2c26 100644
--- a/srcpkgs/python3-scikit-image/template
+++ b/srcpkgs/python3-scikit-image/template
@@ -1,21 +1,22 @@
 # Template file for 'python3-scikit-image'
 pkgname=python3-scikit-image
-version=0.18.3
-revision=2
+version=0.19.0
+revision=1
 _pkgname="${pkgname#python3-}"
 wrksrc="${_pkgname}-${version}"
 build_style=python3-module
 build_helper="numpy"
-hostmakedepends="python3-setuptools python3-Cython"
+hostmakedepends="python3-Cython python3-wheel python3-numpy
+ python3-packaging python3-setuptools"
 makedepends="python3-devel"
-depends="python3-scipy python3-matplotlib python3-networkx
- python3-imageio python3-tifffile python3-pywt"
+depends="python3-scipy python3-numpy python3-imageio python3-matplotlib
+ python3-networkx python3-tifffile python3-pywt python3-packaging"
 short_desc="Image processing in Python"
 maintainer="Andrew J. Hesford <ajh@sideband.org>"
 license="BSD-3-Clause, MIT"
 homepage="https://scikit-image.org/"
 distfiles="https://github.com/${_pkgname}/${_pkgname}/archive/v${version}.tar.gz"
-checksum=a8d1c7473fc9399447a4cd5718c90338fffd543622d9e6f3d9feca43f1a9cb15
+checksum=5a0d6ad80ed3a389c19a8603391bbc1dd8e81239c2ef5ca6c274886db3087ec5
 # Tests require data files and unpackaged dependencies
 make_check=no
 

From cecb92674a91f5b0b4d3e2ca04bfdfe6daeff78d Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Sat, 4 Dec 2021 18:02:09 +0100
Subject: [PATCH 285/288] alpine: update to 2.25.1.

---
 srcpkgs/alpine/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/alpine/template b/srcpkgs/alpine/template
index 6fdbf75afcaf..2ab186c938af 100644
--- a/srcpkgs/alpine/template
+++ b/srcpkgs/alpine/template
@@ -1,8 +1,8 @@
 # Template file for 'alpine'
 pkgname=alpine
-version=2.25
+version=2.25.1
 revision=1
-_githash=465e23b898e5a3393b9ae52fc7620002541b2e75
+_githash=a4717516707498544201c2e03286142c9abb2539
 _gitshort="${_githash:0:7}"
 wrksrc="${pkgname}-${_gitshort}"
 build_style=gnu-configure
@@ -17,7 +17,7 @@ maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="Apache-2.0"
 homepage="https://repo.or.cz/alpine.git"
 distfiles="https://repo.or.cz/alpine.git/snapshot/${_githash}.tar.gz"
-checksum=ba0856bcc863b70dd0c2f06cdeda720332c2d136d49154d78450932cd9e0900a
+checksum=e1855467f8dbf21879e3a6fa959998ffb68a6d5221ee7d6cc2fc3de95ee0759a
 
 post_extract() {
 	sed -i -e '/run test program/s/^/: /' \

From 699ec557ee261612f887a11b8231def9f011529a Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Sat, 4 Dec 2021 18:02:10 +0100
Subject: [PATCH 286/288] netpbm: update to 10.96.04.

---
 srcpkgs/netpbm/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/netpbm/template b/srcpkgs/netpbm/template
index a1fb5f6d9966..f49b1bb66e5f 100644
--- a/srcpkgs/netpbm/template
+++ b/srcpkgs/netpbm/template
@@ -1,10 +1,10 @@
 # Template file for 'netpbm'
 pkgname=netpbm
 # from http://svn.code.sf.net/p/netpbm/code/advanced/doc/HISTORY
-version=10.96.03
+version=10.96.04
 revision=1
-_githash=54081f1e108cb4a385f951cbc293368829e39320
-_githash_guide=54910a3304543a702b0720c3b9c6d6be4ba12100
+_githash=3c556d3931167936ef5bfb3ba1ff569049aa1b87
+_githash_guide=913c540e85e33b07c2dbc551ef4092126ab3ed55
 create_wrksrc=yes
 build_wrksrc="netpbm-mirror-${_githash}"
 hostmakedepends="pkg-config perl python flex"
@@ -16,8 +16,8 @@ license="BSD-3-Clause,GPL-2.0-only,custom:netpbm"
 homepage="http://netpbm.sourceforge.net/"
 distfiles="https://github.com/leahneukirchen/netpbm-mirror/archive/${_githash}.tar.gz
  https://github.com/leahneukirchen/netpbm-mirror/archive/${_githash_guide}.tar.gz"
-checksum="b2184c438d2e9e7a7f99123196719b8a1d1d55a7d28607afb4842ba1ab550cbc
- b966580dcf5d72fc6a3cfa6c95d46206b9b4c252ec911e14633113c45cb49626"
+checksum="c65fcad80229c8ac2999a6ee10709c8ee4f1f73995e0a4423029250c21233756
+ 74ae5c9df00f1654eea60913cd11e7347df111032afc09b315b0567b54bf0b8f"
 
 post_extract() {
 	cd $build_wrksrc

From a794642c7c01847b0631471cf4fc486153f688b6 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Sat, 4 Dec 2021 18:02:12 +0100
Subject: [PATCH 287/288] ldns: update to 1.8.1.

---
 srcpkgs/ldns/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/ldns/template b/srcpkgs/ldns/template
index 376777cfc423..4e7bcd1f2154 100644
--- a/srcpkgs/ldns/template
+++ b/srcpkgs/ldns/template
@@ -1,7 +1,7 @@
 # Template file for 'ldns'
 pkgname=ldns
-version=1.7.1
-revision=5
+version=1.8.1
+revision=1
 build_style=gnu-configure
 configure_args="--with-drill --with-examples --disable-dane-ta-usage
  --with-trust-anchor=/etc/dns/root.key
@@ -13,7 +13,7 @@ maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="BSD-3-Clause"
 homepage="http://www.nlnetlabs.nl/projects/ldns/"
 distfiles="http://www.nlnetlabs.nl/downloads/${pkgname}/${pkgname}-${version}.tar.gz"
-checksum=8ac84c16bdca60e710eea75782356f3ac3b55680d40e1530d7cea474ac208229
+checksum=958229abce4d3aaa19a75c0d127666564b17216902186e952ca4aef47c6d7fa3
 
 post_install() {
 	vsed -i -e "s|\(-specs=.*hardened-ld\)||g" -e "s|\(-specs=.*hardened-cc1\)||g" ${DESTDIR}/usr/bin/ldns-config

From 83205c83c1a9b44594b33b36b65f83ad6eeddc9e Mon Sep 17 00:00:00 2001
From: Demedim <40205709+Demedim@users.noreply.github.com>
Date: Sat, 4 Dec 2021 13:05:40 +0100
Subject: [PATCH 288/288] aircrack-ng: add libcap to enable more utilities

Closes: #34380 [via git-merge-pr]

add comment about patch purpose

fix typo
---
 srcpkgs/aircrack-ng/patches/getopt.patch | 14 ++++++++++++++
 srcpkgs/aircrack-ng/template             |  4 ++--
 srcpkgs/lumina/patches/checkpass.patch   |  1 +
 3 files changed, 17 insertions(+), 2 deletions(-)
 create mode 100644 srcpkgs/aircrack-ng/patches/getopt.patch

diff --git a/srcpkgs/aircrack-ng/patches/getopt.patch b/srcpkgs/aircrack-ng/patches/getopt.patch
new file mode 100644
index 000000000000..7f57f30e6a3c
--- /dev/null
+++ b/srcpkgs/aircrack-ng/patches/getopt.patch
@@ -0,0 +1,14 @@
+argv[1] is a file name argument, musl getopt_long will permute it
+to a later position, so skip it for argument parsing.
+
+--- aircrack-ng-1.6/src/airolib-ng/airolib-ng.c.orig
++++ aircrack-ng-1.6/src/airolib-ng/airolib-ng.c
+@@ -1309,7 +1309,7 @@
+ 	signal(SIGTERM, sighandler);
+ 
+ 	option = getopt_long(
+-		argc, argv, "bc:d:e:hi:s:t:v:", long_options, &option_index);
++		argc-1, argv+1, "bc:d:e:hi:s:t:v:", long_options, &option_index);
+ 
+ 	if (option > 0)
+ 	{
diff --git a/srcpkgs/aircrack-ng/template b/srcpkgs/aircrack-ng/template
index 604bcefb5a34..ef5d46cebac1 100644
--- a/srcpkgs/aircrack-ng/template
+++ b/srcpkgs/aircrack-ng/template
@@ -1,10 +1,10 @@
 # Template file for 'aircrack-ng'
 pkgname=aircrack-ng
 version=1.6
-revision=3
+revision=4
 build_style=gnu-configure
 hostmakedepends="automake libtool pkg-config"
-makedepends="libnl3-devel openssl-devel sqlite-devel zlib-devel"
+makedepends="libnl3-devel openssl-devel sqlite-devel zlib-devel libcap-devel"
 short_desc="Complete suite of tools to assess WiFi network security"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="GPL-2.0-or-later, BSD-3-Clause, OpenSSL"
diff --git a/srcpkgs/lumina/patches/checkpass.patch b/srcpkgs/lumina/patches/checkpass.patch
index 7534550b0019..a31d0fa8bb17 100644
--- a/srcpkgs/lumina/patches/checkpass.patch
+++ b/srcpkgs/lumina/patches/checkpass.patch
@@ -1,3 +1,4 @@
+Force the "bin" path to avoid conflicts with Void xbps-src lint checks
 --- a/src-qt5/core/lumina-checkpass/lumina-checkpass.pro
 +++ b/src-qt5/core/lumina-checkpass/lumina-checkpass.pro
 @@ -6,13 +6,13 @@ QT =

^ permalink raw reply	[flat|nested] 18+ messages in thread

* Re: [PR PATCH] [Updated] lumina: update to 1.6.1.
  2021-11-26 18:57 [PR PATCH] lumina: update to 1.6.1 karlgrose
                   ` (10 preceding siblings ...)
  2021-12-05  5:08 ` karlgrose
@ 2021-12-05  5:24 ` karlgrose
  2021-12-05  5:36 ` [PR PATCH] [Closed]: " karlgrose
                   ` (4 subsequent siblings)
  16 siblings, 0 replies; 18+ messages in thread
From: karlgrose @ 2021-12-05  5:24 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1078 bytes --]

There is an updated pull request by karlgrose against master on the void-packages repository

https://github.com/karlgrose/void-packages master
https://github.com/void-linux/void-packages/pull/34262

lumina: update to 1.6.1.
<!-- Uncomment relevant sections and delete options which are not applicable -->

#### Testing the changes
- I tested the changes in this PR: **YES**

<!--
#### New package
- This new package conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements): **YES**|**NO**
-->

<!-- Note: If the build is likely to take more than 2 hours, please [skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration)
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->

#### Local build testing
- I built this PR locally for my native architecture, (x86_64-glibc)


A patch file from https://github.com/void-linux/void-packages/pull/34262.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-master-34262.patch --]
[-- Type: text/x-diff, Size: 463039 bytes --]

From cb2a8667ca55f498ab83d6e154b0fca6452cd340 Mon Sep 17 00:00:00 2001
From: Karl R Grose <karlgrose@gromar.org>
Date: Fri, 26 Nov 2021 10:15:38 -0800
Subject: [PATCH 001/289] lumina: update to 1.6.1.

---
 srcpkgs/lumina/patches/checkpass.patch | 19 +++++++++++++++++++
 srcpkgs/lumina/patches/mandir.patch    | 11 -----------
 srcpkgs/lumina/template                |  8 ++++----
 3 files changed, 23 insertions(+), 15 deletions(-)
 create mode 100644 srcpkgs/lumina/patches/checkpass.patch
 delete mode 100644 srcpkgs/lumina/patches/mandir.patch

diff --git a/srcpkgs/lumina/patches/checkpass.patch b/srcpkgs/lumina/patches/checkpass.patch
new file mode 100644
index 000000000000..7534550b0019
--- /dev/null
+++ b/srcpkgs/lumina/patches/checkpass.patch
@@ -0,0 +1,19 @@
+--- a/src-qt5/core/lumina-checkpass/lumina-checkpass.pro
++++ b/src-qt5/core/lumina-checkpass/lumina-checkpass.pro
+@@ -6,13 +6,13 @@ QT =
+ CONFIG += console
+ 
+ TARGET = lumina-checkpass
+-target.path = $$DESTDIR$${PREFIX}/sbin
++target.path = $$DESTDIR$${PREFIX}/bin
+ 
+ LIBS     += -lpam
+ 
+ SOURCES += main.c
+ 
+-perms.path = $$DESTDIR$${PREFIX}/sbin
+-perms.extra = "chmod 4555 $$DESTDIR$${PREFIX}/sbin/lumina-checkpass"
++perms.path = $$DESTDIR$${PREFIX}/bin
++perms.extra = "chmod 4555 $(INSTALL_ROOT)$$DESTDIR$${PREFIX}/bin/lumina-checkpass"
+ 
+ INSTALLS += target perms
diff --git a/srcpkgs/lumina/patches/mandir.patch b/srcpkgs/lumina/patches/mandir.patch
deleted file mode 100644
index 9b9ce50a1e5d..000000000000
--- a/srcpkgs/lumina/patches/mandir.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src-qt5/OS-detect.pri	2017-07-05 20:02:49.727200592 +0200
-+++ b/src-qt5/OS-detect.pri	2017-07-05 20:03:10.463911159 +0200
-@@ -94,7 +94,7 @@
-   isEmpty(L_SHAREDIR){ L_SHAREDIR = $${PREFIX}/share }
-   isEmpty(L_INCLUDEDIR){ L_INCLUDEDIR = $${PREFIX}/include }
-   isEmpty(L_SESSDIR){ L_SESSDIR = $${L_SHAREDIR}/xsessions }
--  isEmpty(L_MANDIR){ L_MANDIR = $${PREFIX}/man }
-+  isEmpty(L_MANDIR){ L_MANDIR = $${PREFIX}/share/man }
-   isEmpty(LRELEASE){ LRELEASE = $$[QT_INSTALL_BINS]/lrelease }
-   isEmpty(MAN_ZIP){ MAN_ZIP = "gzip -c" }
-   !exists(LRELEASE){ NO_I18N=true } #translations unavailable
diff --git a/srcpkgs/lumina/template b/srcpkgs/lumina/template
index ed7ef97adfba..5299c6ae9c54 100644
--- a/srcpkgs/lumina/template
+++ b/srcpkgs/lumina/template
@@ -1,11 +1,11 @@
 # Template file for 'lumina'
 pkgname=lumina
-version=1.6.0
-revision=2
+version=1.6.1
+revision=1
 build_style=qmake
 configure_args="QT5LIBDIR=/usr/lib/qt5 L_ETCDIR=/etc CONFIG+=WITH_I18N"
 hostmakedepends="qt5-host-tools qt5-qmake"
-makedepends="qt5-devel qt5-x11extras-devel qt5-multimedia-devel qt5-svg-devel
+makedepends="qt5-devel qt5-x11extras-devel qt5-multimedia-devel qt5-svg-devel pam-devel
  qt5-declarative-devel libXrender-devel libXcomposite-devel libXcursor-devel libXdamage-devel
  xcb-util-devel xcb-util-wm-devel xcb-util-image-devel pulseaudio-devel poppler-qt5-devel"
 depends="fluxbox numlockx xbacklight alsa-utils acpi xscreensaver bsdtar qt5-svg qsudo"
@@ -14,7 +14,7 @@ maintainer="hipperson0 <hipperson0@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/lumina-desktop/lumina"
 distfiles="https://github.com/lumina-desktop/lumina/archive/v${version}.tar.gz"
-checksum=f3512fca4d05e3cf3a6ac106f0f16c9618bda9fa546f1d23ffb0eab9a5ce7c8a
+checksum=2bc649c95da8f997bf943cc1e64af4a61921ddc5d63dd3c46fc0ba8708e29a92
 replaces="lumina-git>=0"
 
 post_install() {

From d23945cfc4d4355c79c75296554b90fb92f3eda4 Mon Sep 17 00:00:00 2001
From: Karl R Grose <karlgrose@gromar.org>
Date: Fri, 26 Nov 2021 10:15:38 -0800
Subject: [PATCH 002/289] lumina: update to 1.6.1.

add comment about patch purpose
---
 srcpkgs/lumina/patches/checkpass.patch | 20 ++++++++++++++++++++
 srcpkgs/lumina/patches/mandir.patch    | 11 -----------
 srcpkgs/lumina/template                |  8 ++++----
 3 files changed, 24 insertions(+), 15 deletions(-)
 create mode 100644 srcpkgs/lumina/patches/checkpass.patch
 delete mode 100644 srcpkgs/lumina/patches/mandir.patch

diff --git a/srcpkgs/lumina/patches/checkpass.patch b/srcpkgs/lumina/patches/checkpass.patch
new file mode 100644
index 000000000000..cb1f3c19e7ba
--- /dev/null
+++ b/srcpkgs/lumina/patches/checkpass.patch
@@ -0,0 +1,20 @@
+Force the "bin" path to avoid conflicts with Void pkg-src lint checks
+--- a/src-qt5/core/lumina-checkpass/lumina-checkpass.pro
++++ b/src-qt5/core/lumina-checkpass/lumina-checkpass.pro
+@@ -6,13 +6,13 @@ QT =
+ CONFIG += console
+ 
+ TARGET = lumina-checkpass
+-target.path = $$DESTDIR$${PREFIX}/sbin
++target.path = $$DESTDIR$${PREFIX}/bin
+ 
+ LIBS     += -lpam
+ 
+ SOURCES += main.c
+ 
+-perms.path = $$DESTDIR$${PREFIX}/sbin
+-perms.extra = "chmod 4555 $$DESTDIR$${PREFIX}/sbin/lumina-checkpass"
++perms.path = $$DESTDIR$${PREFIX}/bin
++perms.extra = "chmod 4555 $(INSTALL_ROOT)$$DESTDIR$${PREFIX}/bin/lumina-checkpass"
+ 
+ INSTALLS += target perms
diff --git a/srcpkgs/lumina/patches/mandir.patch b/srcpkgs/lumina/patches/mandir.patch
deleted file mode 100644
index 9b9ce50a1e5d..000000000000
--- a/srcpkgs/lumina/patches/mandir.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src-qt5/OS-detect.pri	2017-07-05 20:02:49.727200592 +0200
-+++ b/src-qt5/OS-detect.pri	2017-07-05 20:03:10.463911159 +0200
-@@ -94,7 +94,7 @@
-   isEmpty(L_SHAREDIR){ L_SHAREDIR = $${PREFIX}/share }
-   isEmpty(L_INCLUDEDIR){ L_INCLUDEDIR = $${PREFIX}/include }
-   isEmpty(L_SESSDIR){ L_SESSDIR = $${L_SHAREDIR}/xsessions }
--  isEmpty(L_MANDIR){ L_MANDIR = $${PREFIX}/man }
-+  isEmpty(L_MANDIR){ L_MANDIR = $${PREFIX}/share/man }
-   isEmpty(LRELEASE){ LRELEASE = $$[QT_INSTALL_BINS]/lrelease }
-   isEmpty(MAN_ZIP){ MAN_ZIP = "gzip -c" }
-   !exists(LRELEASE){ NO_I18N=true } #translations unavailable
diff --git a/srcpkgs/lumina/template b/srcpkgs/lumina/template
index ed7ef97adfba..5299c6ae9c54 100644
--- a/srcpkgs/lumina/template
+++ b/srcpkgs/lumina/template
@@ -1,11 +1,11 @@
 # Template file for 'lumina'
 pkgname=lumina
-version=1.6.0
-revision=2
+version=1.6.1
+revision=1
 build_style=qmake
 configure_args="QT5LIBDIR=/usr/lib/qt5 L_ETCDIR=/etc CONFIG+=WITH_I18N"
 hostmakedepends="qt5-host-tools qt5-qmake"
-makedepends="qt5-devel qt5-x11extras-devel qt5-multimedia-devel qt5-svg-devel
+makedepends="qt5-devel qt5-x11extras-devel qt5-multimedia-devel qt5-svg-devel pam-devel
  qt5-declarative-devel libXrender-devel libXcomposite-devel libXcursor-devel libXdamage-devel
  xcb-util-devel xcb-util-wm-devel xcb-util-image-devel pulseaudio-devel poppler-qt5-devel"
 depends="fluxbox numlockx xbacklight alsa-utils acpi xscreensaver bsdtar qt5-svg qsudo"
@@ -14,7 +14,7 @@ maintainer="hipperson0 <hipperson0@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/lumina-desktop/lumina"
 distfiles="https://github.com/lumina-desktop/lumina/archive/v${version}.tar.gz"
-checksum=f3512fca4d05e3cf3a6ac106f0f16c9618bda9fa546f1d23ffb0eab9a5ce7c8a
+checksum=2bc649c95da8f997bf943cc1e64af4a61921ddc5d63dd3c46fc0ba8708e29a92
 replaces="lumina-git>=0"
 
 post_install() {

From 7e4f65fe4b7f2ca9939fe6a6d2b22f75c09de7b7 Mon Sep 17 00:00:00 2001
From: Andrew Benson <abenson+void@gmail.com>
Date: Sun, 28 Nov 2021 11:16:36 -0600
Subject: [PATCH 003/289] Amass: update to 3.15.1.

---
 srcpkgs/Amass/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/Amass/template b/srcpkgs/Amass/template
index 71ee291c99e6..f78e2f70cf12 100644
--- a/srcpkgs/Amass/template
+++ b/srcpkgs/Amass/template
@@ -1,6 +1,6 @@
 # Template file for 'Amass'
 pkgname=Amass
-version=3.15.0
+version=3.15.1
 revision=1
 build_style=go
 go_import_path="github.com/OWASP/Amass/v3/..."
@@ -9,7 +9,7 @@ maintainer="Andrew Benson <abenson+void@gmail.com>"
 license="Apache-2.0"
 homepage="https://www.owasp.org/index.php/OWASP_Amass_Project"
 distfiles="https://github.com/OWASP/Amass/archive/v${version}.tar.gz"
-checksum=084ddbc8171e354abee3098458064fbcc9db059a25c4845dfc151803833df2dd
+checksum=217f5f0fed02d730543a56b58f1be3ec0fb07e57b3ace53fc673c6d0132f36a8
 
 post_install() {
 	rm ${DESTDIR}/usr/bin/examples

From 9aea8e7cbf49c37182e39881a5306a9a0ebf340e Mon Sep 17 00:00:00 2001
From: Andrew Benson <abenson+void@gmail.com>
Date: Sun, 28 Nov 2021 11:19:21 -0600
Subject: [PATCH 004/289] python3-httpx: update to 0.21.1.

---
 srcpkgs/python3-httpx/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-httpx/template b/srcpkgs/python3-httpx/template
index 5c99c9208213..55f843ed478c 100644
--- a/srcpkgs/python3-httpx/template
+++ b/srcpkgs/python3-httpx/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-httpx'
 pkgname=python3-httpx
-version=0.21.0
+version=0.21.1
 revision=1
 wrksrc="httpx-${version}"
 build_style=python3-module
@@ -14,7 +14,7 @@ license="BSD-3-Clause"
 homepage="https://www.python-httpx.org"
 changelog="https://raw.githubusercontent.com/encode/httpx/master/CHANGELOG.md"
 distfiles="${PYPI_SITE}/h/httpx/httpx-${version}.tar.gz"
-checksum=5ae1d9deb30fe074596551b3ab98f94dfd9d7efe3ecd2d08662a5c29f6fba0e4
+checksum=02af20df486b78892a614a7ccd4e4e86a5409ec4981ab0e422c579a887acad83
 # the pypi tarball doesn't contain tests
 # the tests need unpackaged dependencies trustme and uvicorn
 make_check=no

From 90363e8353164ebbe2dfeacccd0486288012f25b Mon Sep 17 00:00:00 2001
From: Andrew Benson <abenson+void@gmail.com>
Date: Sun, 28 Nov 2021 11:19:24 -0600
Subject: [PATCH 005/289] python3-youtubesearch: update to 1.5.2.

---
 srcpkgs/python3-youtubesearch/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-youtubesearch/template b/srcpkgs/python3-youtubesearch/template
index c284178a44a8..8319d620097d 100644
--- a/srcpkgs/python3-youtubesearch/template
+++ b/srcpkgs/python3-youtubesearch/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-youtubesearch'
 pkgname=python3-youtubesearch
-version=1.5.1
+version=1.5.2
 revision=1
 wrksrc="youtube-search-python-${version}"
 build_style=python3-module
@@ -11,7 +11,7 @@ maintainer="Andrew Benson <abenson+void@gmail.com>"
 license="MIT"
 homepage="https://github.com/alexmercerind/youtube-search-python"
 distfiles="${homepage}/archive/refs/tags/v${version}.tar.gz"
-checksum=485825a741ef5e7c327eaf65b27f7ffd7d10e218072a972012ff3301c2d7c488
+checksum=6094c819b195de0ef7363e76594b5c34479438a45e72c1e9f763cd9cf17a64ea
 make_check=no # no tests defined
 
 post_install() {

From 8c3bea7359920bb4a29f411115821fd42c40d75e Mon Sep 17 00:00:00 2001
From: Andrew Benson <abenson+void@gmail.com>
Date: Sun, 28 Nov 2021 11:23:29 -0600
Subject: [PATCH 006/289] mongo-c-driver: update to 1.20.0.

---
 srcpkgs/mongo-c-driver/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/mongo-c-driver/template b/srcpkgs/mongo-c-driver/template
index ee79f2e3d329..b3eec27c4bab 100644
--- a/srcpkgs/mongo-c-driver/template
+++ b/srcpkgs/mongo-c-driver/template
@@ -1,6 +1,6 @@
 # Template file for 'mongo-c-driver'
 pkgname=mongo-c-driver
-version=1.19.2
+version=1.20.0
 revision=1
 build_style=cmake
 configure_args="-DENABLE_TESTS=OFF"
@@ -11,7 +11,7 @@ maintainer="Andrew Benson <abenson+void@gmail.com>"
 license="Apache-2.0"
 homepage="https://mongoc.org"
 distfiles="https://github.com/mongodb/mongo-c-driver/releases/download/${version}/mongo-c-driver-${version}.tar.gz"
-checksum=b6feb4fd65423140cdee02df392cd9db2bb459731e992a5385afa554a7515762
+checksum=a97242866212bdcf9dfb8030b31a32eef9ff83082b34e1027339c805a3c50b0d
 
 mongo-c-driver-devel_package() {
 	short_desc+=" - development files"

From 7803c3bc2115152289a27625b03556d4bbad5e3a Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Sat, 27 Nov 2021 14:45:12 +0100
Subject: [PATCH 007/289] libuninameslist: update to 20211114.

---
 srcpkgs/libuninameslist/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/libuninameslist/template b/srcpkgs/libuninameslist/template
index a7e509d4b0b5..8b97662a4a31 100644
--- a/srcpkgs/libuninameslist/template
+++ b/srcpkgs/libuninameslist/template
@@ -1,6 +1,6 @@
 # Template file for 'libuninameslist'
 pkgname=libuninameslist
-version=20210917
+version=20211114
 revision=1
 build_style=gnu-configure
 hostmakedepends="automake libtool"
@@ -9,7 +9,7 @@ maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="BSD-3-Clause"
 homepage="https://github.com/fontforge/libuninameslist"
 distfiles="https://github.com/fontforge/libuninameslist/archive/${version}.tar.gz"
-checksum=7d60ea37813590c9d319d53aaac831fedf8067c980167877bc5daa351b378031
+checksum=c089c6164f2cef361c3419a07408be72d6b58d6ef224ec226724a9fa93c0d46e
 
 pre_configure() {
 	autoreconf -fi

From 044f73ae6d466159a9305193364b7e32d003087f Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Sat, 27 Nov 2021 14:47:22 +0100
Subject: [PATCH 008/289] libtls: update to 3.4.2.

---
 srcpkgs/libtls/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/libtls/template b/srcpkgs/libtls/template
index 3a0922788b7e..42f33db208a6 100644
--- a/srcpkgs/libtls/template
+++ b/srcpkgs/libtls/template
@@ -1,6 +1,6 @@
 # Template file for 'libtls'
 pkgname=libtls
-version=3.4.1
+version=3.4.2
 revision=1
 wrksrc="libressl-${version}"
 build_style=gnu-configure
@@ -13,7 +13,7 @@ license="OpenSSL, ISC"
 homepage="http://www.libressl.org/"
 changelog="https://raw.githubusercontent.com/libressl-portable/portable/master/ChangeLog"
 distfiles="http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-${version}.tar.gz"
-checksum=107ceae6ca800e81cb563584c16afa36d6c7138fade94a2b3e9da65456f7c61c
+checksum=cb82ca7d547336917352fbd23db2fc483c6c44d35157b32780214ec74197b3ce
 _lssl_asm_ver="1.2.0"
 replaces="libtls20>0"
 

From eb472e50c4cd36574146142162a3ccf4a14ec3ac Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Sat, 27 Nov 2021 15:04:23 +0100
Subject: [PATCH 009/289] crash: update to 8.0.0.

---
 srcpkgs/crash/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/crash/template b/srcpkgs/crash/template
index 72a0cdd6c36a..82d9a3968c11 100644
--- a/srcpkgs/crash/template
+++ b/srcpkgs/crash/template
@@ -1,10 +1,10 @@
 # Template file for 'crash'
 pkgname=crash
-version=7.3.0
-revision=2
+version=8.0.0
+revision=1
 archs="i686 x86_64"  # broken on musl
 build_style=gnu-makefile
-hostmakedepends="flex tar wget"
+hostmakedepends="flex tar wget texinfo"
 makedepends="lzo-devel ncurses-devel zlib-devel"
 depends="binutils"
 short_desc="Kernel crash dump debugger and live inspector"
@@ -13,7 +13,7 @@ license="GPL-3.0-or-later"
 homepage="https://crash-utility.github.io/"
 changelog="https://crash-utility.github.io/crash.changelog.html"
 distfiles="https://github.com/crash-utility/crash/archive/${version}.tar.gz"
-checksum=98d4367ae0ea7d2eda547357a839f7bddee517b588b281574d58a15a418af5b9
+checksum=caab49b7b6d442f60c41360e0ec80cf852dc64e89303b41d704d7661cef43e68
 nocross=yes
 LDFLAGS=-llzo2
 

From 70b8039a460958fdde917c54eb6a9f4cb55a67fc Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Sat, 27 Nov 2021 15:04:29 +0100
Subject: [PATCH 010/289] python3-pipenv: update to 2021.11.23.

---
 srcpkgs/python3-pipenv/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-pipenv/template b/srcpkgs/python3-pipenv/template
index 01863718c2fd..1a8b586387f8 100644
--- a/srcpkgs/python3-pipenv/template
+++ b/srcpkgs/python3-pipenv/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-pipenv'
 pkgname=python3-pipenv
-version=2021.11.15
+version=2021.11.23
 revision=1
 wrksrc="pipenv-${version}"
 build_style=python3-module
@@ -11,7 +11,7 @@ maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="MIT"
 homepage="https://github.com/pypa/pipenv"
 distfiles="${PYPI_SITE}/p/pipenv/pipenv-${version}.tar.gz"
-checksum=616766b1e8dfc24b2e7c6dfbbc8276b7d7ba07e778e5eb0f1b6e59fcd4532fd1
+checksum=1bde859e8bbd1d21d503fd995bc0170048d6da7686ab885f074592c99a16e8f3
 conflicts="python-pipenv>=0"
 
 post_extract() {

From 82d57c26821d85a96b81b42c104f4c7d3caeabf1 Mon Sep 17 00:00:00 2001
From: Leah Neukirchen <leah@vuxu.org>
Date: Sun, 28 Nov 2021 19:50:36 +0100
Subject: [PATCH 011/289] erlang: update to 24.1.7.

---
 srcpkgs/erlang/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/erlang/template b/srcpkgs/erlang/template
index cd7340ad4bcb..c51edbde3e10 100644
--- a/srcpkgs/erlang/template
+++ b/srcpkgs/erlang/template
@@ -1,6 +1,6 @@
 # Template file for 'erlang'
 pkgname=erlang
-version=24.1.6
+version=24.1.7
 revision=1
 create_wrksrc=yes
 build_wrksrc="otp-OTP-${version}"
@@ -14,7 +14,7 @@ license="Apache-2.0"
 homepage="http://www.erlang.org/"
 changelog="https://github.com/erlang/otp/releases"
 distfiles="https://github.com/erlang/otp/archive/OTP-${version}.tar.gz"
-checksum=1b0db74f01f0072299347b794b51d170bf1b71a8f9b6c0aac404ed2c440611ad
+checksum=a1dd1a238f1f3e79784b902f3cd00e06f35a630191eaf73324a07a26a2c93af3
 subpackages="erlang-doc"
 
 if [ -z "$CROSS_BUILD" ]; then

From 48d329b367a1624051f50b7069fbfd3a3d0090f3 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sun, 28 Nov 2021 14:30:45 -0500
Subject: [PATCH 012/289] python3-aiofiles: update to 0.8.0.

---
 srcpkgs/python3-aiofiles/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-aiofiles/template b/srcpkgs/python3-aiofiles/template
index 95660af980b3..d4c6a5445630 100644
--- a/srcpkgs/python3-aiofiles/template
+++ b/srcpkgs/python3-aiofiles/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-aiofiles'
 pkgname=python3-aiofiles
-version=0.7.0
-revision=2
+version=0.8.0
+revision=1
 wrksrc="${pkgname#*-}-${version}"
 build_style=python3-pep517
 hostmakedepends="python3-poetry-core"
@@ -13,7 +13,7 @@ license="Apache-2.0"
 homepage="https://github.com/Tinche/aiofiles"
 changelog="https://raw.githubusercontent.com/Tinche/aiofiles/master/README.rst"
 distfiles="${homepage}/archive/v${version}.tar.gz"
-checksum=2baf8e70f95618214c4910730fd625bfaa4a8b8957838b34364b0a2c7d41db9e
+checksum=1ee866ce57b47e2f5ae2c06c0372458a6eb08131a9b1d7216a234fa0d516d638
 
 do_check() {
 	PYTHONPATH=src python3 -m pytest

From 5a8c0b621d69accfdfdffa7a243af0024e36dc92 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sun, 28 Nov 2021 14:37:14 -0500
Subject: [PATCH 013/289] python3-hypothesis: update to 6.28.0.

---
 srcpkgs/python3-hypothesis/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-hypothesis/template b/srcpkgs/python3-hypothesis/template
index 0c4993679d88..460af8b6cc06 100644
--- a/srcpkgs/python3-hypothesis/template
+++ b/srcpkgs/python3-hypothesis/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-hypothesis'
 pkgname=python3-hypothesis
-version=6.27.0
+version=6.28.0
 revision=1
 wrksrc="hypothesis-hypothesis-python-${version}"
 build_wrksrc=hypothesis-python
@@ -15,7 +15,7 @@ license="MPL-2.0"
 homepage="https://hypothesis.works/"
 changelog="https://hypothesis.readthedocs.io/en/latest/changes.html"
 distfiles="https://github.com/HypothesisWorks/hypothesis/archive/hypothesis-python-${version}.tar.gz"
-checksum=91912314804c37a0be3e830426d44341cbf4a751ad92e5bfdad35e434ffffd4a
+checksum=34a4e30f9a0a88bb48c2faf6d78512fb7978e03e152026e00210245b20356d70
 
 do_check() {
 	# Manually run the tests that tox considers part of the "full" suite,

From 58719ceeafb5cf5223deed2ea19e0a3d861329ac Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sun, 28 Nov 2021 14:37:55 -0500
Subject: [PATCH 014/289] python3-prompt_toolkit: update to 3.0.23.

---
 srcpkgs/python3-prompt_toolkit/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-prompt_toolkit/template b/srcpkgs/python3-prompt_toolkit/template
index f7dbc0c33666..ca30e275d05f 100644
--- a/srcpkgs/python3-prompt_toolkit/template
+++ b/srcpkgs/python3-prompt_toolkit/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-prompt_toolkit'
 pkgname=python3-prompt_toolkit
-version=3.0.22
+version=3.0.23
 revision=1
 wrksrc="prompt_toolkit-${version}"
 build_style=python3-module
@@ -13,7 +13,7 @@ license="BSD-3-Clause"
 homepage="https://github.com/prompt-toolkit/python-prompt-toolkit"
 changelog="https://raw.githubusercontent.com/prompt-toolkit/python-prompt-toolkit/master/CHANGELOG"
 distfiles="${PYPI_SITE}/p/prompt_toolkit/prompt_toolkit-${version}.tar.gz"
-checksum=449f333dd120bd01f5d296a8ce1452114ba3a71fae7288d2f0ae2c918764fa72
+checksum=7053aba00895473cb357819358ef33f11aa97e4ac83d38efb123e5649ceeecaf
 conflicts="python3-prompt_toolkit2<=2.0.9_4"
 
 post_install() {

From cc00be1e5540e74c5dfa70a071cd363d72497ea0 Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sun, 28 Nov 2021 14:39:32 -0500
Subject: [PATCH 015/289] python3-ipython: update to 7.30.0.

---
 srcpkgs/python3-ipython/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-ipython/template b/srcpkgs/python3-ipython/template
index c2a1120bcac4..85a1ae2e64c5 100644
--- a/srcpkgs/python3-ipython/template
+++ b/srcpkgs/python3-ipython/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-ipython'
 pkgname=python3-ipython
-version=7.29.0
+version=7.30.0
 revision=1
 wrksrc="ipython-${version}"
 build_style=python3-module
@@ -16,7 +16,7 @@ maintainer="Andrew J. Hesford <ajh@sideband.org>"
 license="BSD-3-Clause"
 homepage="https://ipython.org/"
 distfiles="${PYPI_SITE}/i/ipython/ipython-${version}.tar.gz"
-checksum=4f69d7423a5a1972f6347ff233e38bbf4df6a150ef20fbb00c635442ac3060aa
+checksum=d41f8e80b99690122400f9b2069b12f670246a1b4cc5d332bd6c4e2500e6d6fb
 conflicts="python-ipython<=5.8.0_2"
 
 do_check() {

From 727fbcad09daa4926c16214786387299e3b0cace Mon Sep 17 00:00:00 2001
From: "Andrew J. Hesford" <ajh@sideband.org>
Date: Sun, 28 Nov 2021 14:39:38 -0500
Subject: [PATCH 016/289] zfs-prune-snapshots: update to 1.3.0.

---
 srcpkgs/zfs-prune-snapshots/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/zfs-prune-snapshots/template b/srcpkgs/zfs-prune-snapshots/template
index 08f538004b9e..63cf6ba63a3f 100644
--- a/srcpkgs/zfs-prune-snapshots/template
+++ b/srcpkgs/zfs-prune-snapshots/template
@@ -1,7 +1,7 @@
 # Template file for 'zfs-prune-snapshots'
 pkgname=zfs-prune-snapshots
-version=1.1.0
-revision=3
+version=1.3.0
+revision=1
 build_style=gnu-makefile
 depends="bash zfs"
 checkdepends="shellcheck"
@@ -10,7 +10,7 @@ maintainer="Andrew J. Hesford <ajh@sideband.org>"
 license="MIT"
 homepage="https://github.com/bahamas10/zfs-prune-snapshots"
 distfiles="${homepage}/archive/v${version}.tar.gz"
-checksum=a9f2fb3c5230111db7622f70318219a37aa8d6bd3d7f894fee54e1ec00cdff2f
+checksum=aacd3683f2bf615286f6c0b154162df11e29783897127a55e1fe73c6a342979f
 
 post_install() {
 	vlicense LICENSE

From 7cfe146cef22b9e7bffc772cef2e129dcf5fe358 Mon Sep 17 00:00:00 2001
From: glaulher <glaulher.developer@gmail.com>
Date: Sun, 28 Nov 2021 15:15:17 -0300
Subject: [PATCH 017/289] icewm: update to 2.9.0.

---
 srcpkgs/icewm/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/icewm/template b/srcpkgs/icewm/template
index e9ba69605326..118071556e15 100644
--- a/srcpkgs/icewm/template
+++ b/srcpkgs/icewm/template
@@ -1,6 +1,6 @@
 # Template file for 'icewm'
 pkgname=icewm
-version=2.8.0
+version=2.9.0
 revision=1
 build_style=cmake
 make_cmd=make
@@ -17,7 +17,7 @@ maintainer="Glaulher <glaulher.developer@gmail.com>"
 license="GPL-2.0-or-later"
 homepage="https://ice-wm.org/"
 distfiles="https://github.com/ice-wm/icewm/archive/${version}.tar.gz"
-checksum=f225a7e5cf225493b6ae8d427d3a08ab9d3ab6bcd2a297ec41350655ddba7be1
+checksum=eacf813ee427cf80f46aaf8d104d7d0e79937b38dff362a857ce86a091c9de5b
 # broken tests
 make_check=no
 

From 532375a5911a49c8dd2523866cbf2021c44ad4f1 Mon Sep 17 00:00:00 2001
From: Lorem <notloremipsum@protonmail.com>
Date: Sun, 28 Nov 2021 11:52:21 +0530
Subject: [PATCH 018/289] badwolf: update to 1.2.1, orphan.

---
 srcpkgs/badwolf/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/badwolf/template b/srcpkgs/badwolf/template
index 9b9f2a1fe84f..0397fe5aa59a 100644
--- a/srcpkgs/badwolf/template
+++ b/srcpkgs/badwolf/template
@@ -1,6 +1,6 @@
 # Template file for 'badwolf'
 pkgname=badwolf
-version=1.2.0
+version=1.2.1
 revision=1
 build_style=configure
 make_check_target=test
@@ -8,12 +8,12 @@ hostmakedepends="pkg-config gettext"
 makedepends="webkit2gtk-devel libsoup-devel"
 checkdepends="mdocml"
 short_desc="Minimalist and privacy-oriented WebKitGTK+ browser"
-maintainer="Lorem <notloremipsum@protonmail.com>"
+maintainer="Orphaned <orphan@voidlinux.org>"
 license="BSD-3-Clause"
 homepage="https://hacktivis.me/projects/badwolf"
 changelog="https://hacktivis.me/releases/badwolf-${version}.txt"
 distfiles="https://hacktivis.me/releases/badwolf-${version}.tar.gz"
-checksum=eaf5b99f1fc0ea94552c64f3b5e84cf9e76891882ea5e767bf633341e0265cba
+checksum=7a658908551bc0389fc43bd04a9decfef3815d28ff2097957bf6ab186a05ffd2
 
 pre_configure() {
 	export PREFIX=/usr

From f1fb28e6cd6922da1dbd1836f0a8056b0a495fd8 Mon Sep 17 00:00:00 2001
From: jgart <jgart@dismail.de>
Date: Sun, 28 Nov 2021 23:44:08 -0500
Subject: [PATCH 019/289] xonsh: update to 0.11.0.

---
 srcpkgs/xonsh/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/xonsh/template b/srcpkgs/xonsh/template
index 150d83d4c8f7..69caa602e442 100644
--- a/srcpkgs/xonsh/template
+++ b/srcpkgs/xonsh/template
@@ -1,7 +1,7 @@
 # Template file for 'xonsh'
 pkgname=xonsh
-version=0.10.1
-revision=2
+version=0.11.0
+revision=1
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 checkdepends="python3-pytest python3-prompt_toolkit python3-Pygments"
@@ -11,7 +11,7 @@ license="GPL-3.0-or-later"
 homepage="https://xon.sh/"
 changelog="https://raw.githubusercontent.com/xonsh/xonsh/master/CHANGELOG.rst"
 distfiles="https://github.com/xonsh/xonsh/archive/${version}.tar.gz"
-checksum=4ede94226b0cc5f429bc7605ace88137c685d24675228e9e94ec18341dd30be4
+checksum=9d73273276996297920c234c7d4267a305c695f0e9e2454dbdf0655c3a8f75cb
 register_shell="/bin/xonsh"
 # FIXME: fails with multiple AttributeErrors
 make_check=extended

From ba850814aaeb45c44b5edb64181468a82f22e8b4 Mon Sep 17 00:00:00 2001
From: cinerea0 <cinerea0@disroot.org>
Date: Sun, 28 Nov 2021 23:59:11 -0500
Subject: [PATCH 020/289] sof-tools: update to 1.9.2

---
 srcpkgs/sof-tools/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/sof-tools/template b/srcpkgs/sof-tools/template
index e10c8afe210f..ecd8c553e5b1 100644
--- a/srcpkgs/sof-tools/template
+++ b/srcpkgs/sof-tools/template
@@ -1,6 +1,6 @@
 # Template file for 'sof-tools'
 pkgname=sof-tools
-version=1.9
+version=1.9.2
 revision=1
 # https://github.com/thesofproject/sof/issues/4902
 archs="x86_64"
@@ -14,7 +14,7 @@ maintainer="cinerea0 <cinerea0@protonmail.com>"
 license="BSD-3-Clause"
 homepage="https://thesofproject.github.io/latest/index.html"
 distfiles="https://github.com/thesofproject/sof/archive/refs/tags/v${version}.tar.gz"
-checksum=29b83a63720ace3a9173073f12c4dfae5ece841773483cb025623506cd02eccb
+checksum=77fc2200f96c565b18b5975fc2ac19c54a93e83502f13b4f782567e5c44f45da
 
 post_install() {
 	vlicense ../LICENCE

From a3cb2e1829cbc824afbe969e41909b776b7fb63e Mon Sep 17 00:00:00 2001
From: cinerea0 <cinerea0@disroot.org>
Date: Sun, 28 Nov 2021 23:57:23 -0500
Subject: [PATCH 021/289] sof-firmware: update to 1.9.2

---
 srcpkgs/sof-firmware/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/sof-firmware/template b/srcpkgs/sof-firmware/template
index 5e866cb448f7..5e6399eca917 100644
--- a/srcpkgs/sof-firmware/template
+++ b/srcpkgs/sof-firmware/template
@@ -1,6 +1,6 @@
 # Template file for 'sof-firmware'
 pkgname=sof-firmware
-version=1.9
+version=1.9.2
 revision=1
 archs="i686* x86_64*"
 wrksrc="sof-bin-${version}"
@@ -11,13 +11,13 @@ maintainer="cinerea0 <cinerea0@protonmail.com>"
 license="BSD-3-Clause"
 homepage="https://thesofproject.github.io/latest/index.html"
 distfiles="https://github.com/thesofproject/sof-bin/archive/refs/tags/v${version}.tar.gz"
-checksum=633bff2cc1490146de66796e52e06c7a608591a328c0bfc6f3fc30114640803a
+checksum=8eac925c129d195072237dcd28f4bbe80cf63eb00fd8b23bdc0719cd1ee9b395
 
 do_install() {
 	vmkdir usr/lib/firmware/intel/sof
 	vmkdir usr/lib/firmware/intel/sof-tplg
-	rsync -a "v${version}.x/sof-v${version}/" "${DESTDIR}/usr/lib/firmware/intel/sof"
-	rsync -a "v${version}.x/sof-tplg-v${version}/" "${DESTDIR}/usr/lib/firmware/intel/sof-tplg"
+	rsync -a "v${version%.*}.x/sof-v${version}/" "${DESTDIR}/usr/lib/firmware/intel/sof"
+	rsync -a "v${version%.*}.x/sof-tplg-v${version}/" "${DESTDIR}/usr/lib/firmware/intel/sof-tplg"
 
 	vlicense LICENCE.NXP
 }

From 9489a54d65d2e08b3a37051b4d69fd566adf46fa Mon Sep 17 00:00:00 2001
From: teldra <teldra@rotce.de>
Date: Sun, 28 Nov 2021 00:46:53 +0100
Subject: [PATCH 022/289] viewnior: update to 1.8.

---
 srcpkgs/viewnior/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/viewnior/template b/srcpkgs/viewnior/template
index 8232c1eb787b..efea8ef77dfb 100644
--- a/srcpkgs/viewnior/template
+++ b/srcpkgs/viewnior/template
@@ -1,7 +1,7 @@
 # Template file for 'viewnior'
 pkgname=viewnior
-version=1.7
-revision=2
+version=1.8
+revision=1
 wrksrc="Viewnior-${pkgname}-${version}"
 build_style=meson
 hostmakedepends="pkg-config intltool gnome-common glib-devel gettext-devel"
@@ -11,4 +11,4 @@ maintainer="teldra <teldra@rotce.de>"
 license="GPL-3.0-or-later"
 homepage="http://siyanpanayotov.com/project/viewnior/"
 distfiles="https://github.com/hellosiyan/Viewnior/archive/${pkgname}-${version}.tar.gz"
-checksum=b9fad3b2909a78f65b33f4dfb47fcdfa97150275e00d5c44d0aa0f1dc499f3e6
+checksum=b9319171ebca23929e6ea8039c194b1595d92e764db5e3890836fb5c36e233b0

From 0c6cb215ba7d88ef1c9d1713cd302f889cf5efca Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Ey=C3=9Fer?= <daniel.eysser@gmail.com>
Date: Fri, 26 Nov 2021 18:26:01 +0100
Subject: [PATCH 023/289] common/environment/build-style: add zig-build.sh

---
 common/environment/build-style/zig-build.sh | 1 +
 1 file changed, 1 insertion(+)
 create mode 100644 common/environment/build-style/zig-build.sh

diff --git a/common/environment/build-style/zig-build.sh b/common/environment/build-style/zig-build.sh
new file mode 100644
index 000000000000..049b7cd437d5
--- /dev/null
+++ b/common/environment/build-style/zig-build.sh
@@ -0,0 +1 @@
+hostmakedepends+=" zig"

From 6670feb4134b736f81655aec0f63d75ef5838d17 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Ey=C3=9Fer?= <daniel.eysser@gmail.com>
Date: Fri, 26 Nov 2021 18:30:51 +0100
Subject: [PATCH 024/289] rundird: zig-build now adds zig to hostmakedepends

---
 srcpkgs/rundird/template | 1 -
 1 file changed, 1 deletion(-)

diff --git a/srcpkgs/rundird/template b/srcpkgs/rundird/template
index 8fa83b5e0dcc..5ff897abd456 100644
--- a/srcpkgs/rundird/template
+++ b/srcpkgs/rundird/template
@@ -3,7 +3,6 @@ pkgname=rundird
 version=0.2.0
 revision=1
 build_style=zig-build
-hostmakedepends="zig"
 makedepends="pam-devel"
 short_desc="Simple daemon + PAM module providing an XDG_RUNTIME_DIR"
 maintainer="Isaac Freund <mail@isaacfreund.com>"

From fdbf216cf7ae0f442b5022af5316df49c2730be0 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Ey=C3=9Fer?= <daniel.eysser@gmail.com>
Date: Fri, 26 Nov 2021 18:32:32 +0100
Subject: [PATCH 025/289] river: zig-build now adds zig to hostmakedepends

---
 srcpkgs/river/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/river/template b/srcpkgs/river/template
index d30060422419..314ed6c53146 100644
--- a/srcpkgs/river/template
+++ b/srcpkgs/river/template
@@ -4,7 +4,7 @@ version=0.1.0
 revision=1
 build_style=zig-build
 configure_args="$(vopt_if xwayland -Dxwayland)"
-hostmakedepends="zig pkg-config wayland-devel scdoc git"
+hostmakedepends="pkg-config wayland-devel scdoc git"
 makedepends="wlroots-devel"
 depends="$(vopt_if xwayland xorg-server-xwayland)"
 short_desc="Dynamic tiling Wayland compositor"

From e5f50afbc6a6639fd642b02084908769a2b8bc66 Mon Sep 17 00:00:00 2001
From: Lorem <notloremipsum@protonmail.com>
Date: Sun, 28 Nov 2021 11:25:31 +0530
Subject: [PATCH 026/289] minigalaxy: update to 1.1.0, orphan.

---
 srcpkgs/minigalaxy/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/minigalaxy/template b/srcpkgs/minigalaxy/template
index 9b7d2f6dbc90..30d360cf6414 100644
--- a/srcpkgs/minigalaxy/template
+++ b/srcpkgs/minigalaxy/template
@@ -1,18 +1,18 @@
 # Template file for 'minigalaxy'
 pkgname=minigalaxy
-version=1.0.2
-revision=2
+version=1.1.0
+revision=1
 build_style=python3-module
 hostmakedepends="gettext python3-setuptools"
 depends="hicolor-icon-theme webkit2gtk python3-gobject python3-requests"
-checkdepends="$depends"
+checkdepends="$depends python3-simplejson"
 short_desc="Simple GOG client for Linux"
-maintainer="Lorem <notloremipsum@protonmail.com>"
+maintainer="Orphaned <orphan@voidlinux.org>"
 license="GPL-3.0-or-later, CC-BY-3.0"
 homepage="https://sharkwouter.github.io/minigalaxy/"
 changelog="https://github.com/sharkwouter/minigalaxy/blob/master/CHANGELOG.md"
 distfiles="https://github.com/sharkwouter/minigalaxy/archive/${version}.tar.gz"
-checksum=9cb482760c68153f2fc8b8fe229d60033634bc0c7b83a6aa43a9cfa20ab2d0e9
+checksum=581e7abfb4af0c01d795dc57a93b1305644d8bdd11ecb533bb2787f85b4bc992
 
 do_check() {
 	python -m unittest tests/*.py

From c93325344921792f954d939115bf647f822a40b6 Mon Sep 17 00:00:00 2001
From: oreo639 <31916379+Oreo639@users.noreply.github.com>
Date: Sat, 27 Nov 2021 01:46:21 -0800
Subject: [PATCH 027/289] pacman: update to 6.0.1

---
 srcpkgs/pacman/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/pacman/template b/srcpkgs/pacman/template
index b98560e10637..d14176f089d7 100644
--- a/srcpkgs/pacman/template
+++ b/srcpkgs/pacman/template
@@ -1,13 +1,13 @@
 # Template file for 'pacman'
 pkgname=pacman
-version=5.2.2
-revision=3
+version=6.0.1
+revision=1
 make_dirs="/var/lib/pacman 0755 root root
  /usr/var/cache/pacman/pkg 0755 root root
  /usr/share/libalpm/hooks 0755 root root"
 conf_files="/etc/pacman.conf"
 build_style=meson
-hostmakedepends="autoconf automake curl libtool gettext-devel pkg-config asciidoc"
+hostmakedepends="curl gettext-devel pkg-config asciidoc"
 makedepends="libarchive-devel gpgme-devel libcurl-devel"
 depends="gnupg>=2"
 checkdepends="fakeroot"
@@ -15,8 +15,8 @@ short_desc="Simple library-based package manager"
 maintainer="oreo639 <oreo6391@gmail.com>"
 license="GPL-2.0-or-later"
 homepage="https://www.archlinux.org/pacman/"
-distfiles="https://sources.archlinux.org/other/pacman/pacman-${version}.tar.gz"
-checksum=bb201a9f2fb53c28d011f661d50028efce6eef2c1d2a36728bdd0130189349a0
+distfiles="https://sources.archlinux.org/other/pacman/pacman-${version}.tar.xz"
+checksum=0db61456e56aa49e260e891c0b025be210319e62b15521f29d3e93b00d3bf731
 make_check=ci-skip
 
 if [ "$XBPS_TARGET_LIBC" = musl ]; then

From 24834943daabca7e7e98464acef464a7081e5b1b Mon Sep 17 00:00:00 2001
From: cinerea0 <cinerea0@disroot.org>
Date: Mon, 29 Nov 2021 01:08:42 -0500
Subject: [PATCH 028/289] delta: update to 0.10.2

---
 srcpkgs/delta/template | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/delta/template b/srcpkgs/delta/template
index 15481ba9a01b..bd5040d70709 100644
--- a/srcpkgs/delta/template
+++ b/srcpkgs/delta/template
@@ -1,6 +1,6 @@
 # Template file for 'delta'
 pkgname=delta
-version=0.9.2
+version=0.10.2
 revision=1
 build_style=cargo
 checkdepends="git"
@@ -9,7 +9,8 @@ maintainer="Andrew Benson <abenson+void@gmail.com>"
 license="MIT"
 homepage="https://github.com/dandavison/delta"
 distfiles="${homepage}/archive/${version}.tar.gz"
-checksum=f002a94119cd5b6fd9deede7f344667358baf5015d0051e055fec6334ee0653f
+checksum=e0f71d72eca543478941401bd96fefc5fa3f70e7860a9f858f63bfecf8fd77a5
+make_check=no  # TODO: Re-enable checks when Rust gets updated
 
 post_install() {
 	vlicense LICENSE

From 32e32756fe8d2b6a262f09d1fe8c8b9717381883 Mon Sep 17 00:00:00 2001
From: Cullen Ross <cullenrss@gmail.com>
Date: Sun, 28 Nov 2021 19:27:26 -0500
Subject: [PATCH 029/289] rxvt-unicode: update to 9.30.

---
 srcpkgs/rxvt-unicode/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/rxvt-unicode/template b/srcpkgs/rxvt-unicode/template
index 4223d2e8f789..00ebdf63c3ca 100644
--- a/srcpkgs/rxvt-unicode/template
+++ b/srcpkgs/rxvt-unicode/template
@@ -1,6 +1,6 @@
 # Template file for 'rxvt-unicode'
 pkgname=rxvt-unicode
-version=9.29
+version=9.30
 revision=1
 build_style=gnu-configure
 configure_args="
@@ -25,7 +25,7 @@ maintainer="Leah Neukirchen <leah@vuxu.org>"
 license="GPL-3.0-or-later"
 homepage="http://software.schmorp.de/pkg/rxvt-unicode.html"
 distfiles="http://dist.schmorp.de/${pkgname}/${pkgname}-${version}.tar.bz2"
-checksum=c18bc9de0c319db1f85748ecc2f255ff9eb2be0fbe9e15fe0eabefc063c4157c
+checksum=fe1c93d12f385876457a989fc3ae05c0915d2692efc59289d0f70fabe5b44d2d
 
 # Package build options
 build_options="gdk_pixbuf perl startup_notification unicode3"

From e47264ed1c774c4d80901eddf944c15e1b7db0b0 Mon Sep 17 00:00:00 2001
From: Clyhtsuriva <aimeric@adjutor.xyz>
Date: Mon, 29 Nov 2021 12:46:14 +0100
Subject: [PATCH 030/289] balsa: update to 2.6.3

---
 srcpkgs/balsa/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/balsa/template b/srcpkgs/balsa/template
index 70838929c35a..af0f741d1860 100644
--- a/srcpkgs/balsa/template
+++ b/srcpkgs/balsa/template
@@ -1,6 +1,6 @@
 # Template file for 'balsa'
 pkgname=balsa
-version=2.6.2
+version=2.6.3
 revision=1
 build_style=gnu-configure
 configure_args="--without-gnome --with-libsecret --with-gpgme --with-sqlite
@@ -13,5 +13,5 @@ short_desc="Email client for GNOME"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="GPL-2.0-or-later"
 homepage="https://pawsa.fedorapeople.org/balsa/"
-distfiles="https://pawsa.fedorapeople.org/balsa/balsa-${version}.tar.bz2"
-checksum=51d52040577b730d7a199e97ea3687b3d0f7cf7f08f6e339e784d700621a02f0
+distfiles="https://pawsa.fedorapeople.org/balsa/balsa-${version}.tar.xz"
+checksum=d4d04576c9a5026064f7d480b34531faf59543f2e4d57c48a6fa5c76661e1dd4

From 96d64fcf921640380f2f63a4d751fd9d96720b66 Mon Sep 17 00:00:00 2001
From: jgart <jgart@dismail.de>
Date: Mon, 29 Nov 2021 03:05:34 -0500
Subject: [PATCH 031/289] hugo: update to 0.89.4.

---
 srcpkgs/hugo/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/hugo/template b/srcpkgs/hugo/template
index d2765c6722db..444018d45dbf 100644
--- a/srcpkgs/hugo/template
+++ b/srcpkgs/hugo/template
@@ -1,6 +1,6 @@
 # Template file for 'hugo'
 pkgname=hugo
-version=0.89.1
+version=0.89.4
 revision=1
 build_style=go
 go_import_path="github.com/gohugoio/hugo"
@@ -10,7 +10,7 @@ maintainer="Andrea Brancaleoni <abc@pompel.me>"
 license="Apache-2.0"
 homepage="https://gohugo.io"
 distfiles="https://github.com/gohugoio/hugo/archive/v${version}.tar.gz"
-checksum=c47f144291819a8d9f065f69ab290a198dfabde86a27ac2325a89f03c6e5ea3f
+checksum=9d4f61788f8d886913a1be15b3eae04fad04a4e243bd7f65c5e7367bd617856d
 
 post_install() {
 	vdoc README.md

From c5a166baa2e984502669873323f43085f26893a9 Mon Sep 17 00:00:00 2001
From: jgart <jgart@dismail.de>
Date: Mon, 29 Nov 2021 02:00:44 -0500
Subject: [PATCH 032/289] stagit: update to 0.9.6.

---
 srcpkgs/stagit/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/stagit/template b/srcpkgs/stagit/template
index 89c5a8cb177c..7078a4f6c946 100644
--- a/srcpkgs/stagit/template
+++ b/srcpkgs/stagit/template
@@ -1,6 +1,6 @@
 # Template file for 'stagit'
 pkgname=stagit
-version=0.9.5
+version=0.9.6
 revision=1
 build_style=gnu-makefile
 make_install_args="MANPREFIX=/usr/share/man"
@@ -10,7 +10,7 @@ maintainer="Steve Prybylski <sa.prybylx@gmail.com>"
 license="MIT"
 homepage="https://codemadness.org/git/stagit/log.html"
 distfiles="https://codemadness.org/releases/stagit/${pkgname}-${version}.tar.gz"
-checksum=025a17c7be3a4e98a2319efc4eb6329e9ea6a778b2b24b0eb97a342ece9bb039
+checksum=d072f386f3a546ed0341e20f9c2dfd7756a761fab1c40316a96690cb2b3066d0
 LDFLAGS="-lgit2"
 
 post_install() {

From bb484e5bcd2934bec4c9763e6bd5e8a355120980 Mon Sep 17 00:00:00 2001
From: cinerea0 <cinerea0@disroot.org>
Date: Mon, 29 Nov 2021 01:37:08 -0500
Subject: [PATCH 033/289] onefetch: update to 2.11.0

---
 srcpkgs/onefetch/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/onefetch/template b/srcpkgs/onefetch/template
index cf9832cb5459..88f21bc3b351 100644
--- a/srcpkgs/onefetch/template
+++ b/srcpkgs/onefetch/template
@@ -1,6 +1,6 @@
 # Template file for 'onefetch'
 pkgname=onefetch
-version=2.10.2
+version=2.11.0
 revision=1
 build_style=cargo
 short_desc="Git repository summary on your terminal"
@@ -8,7 +8,7 @@ maintainer="Jan Christian Grünhage <jan.christian@gruenhage.xyz>"
 license="MIT"
 homepage="https://github.com/o2sh/onefetch"
 distfiles="https://github.com/o2sh/onefetch/archive/v${version}.tar.gz"
-checksum=6e4d4effcd4fd94ce21625a5e32da5da6446c8874200e40dd791e623b7aff7bb
+checksum=ffd3cc3bd24e299ede1fada2b2da8bf066d59219da167477e1997c860650c192
 
 post_install() {
 	vlicense LICENSE.md

From d64f2416b0187801ec0261a2d0ee6cf2e262068e Mon Sep 17 00:00:00 2001
From: cinerea0 <cinerea0@disroot.org>
Date: Mon, 29 Nov 2021 00:50:38 -0500
Subject: [PATCH 034/289] mdBook: update to 0.4.14

---
 srcpkgs/mdBook/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/mdBook/template b/srcpkgs/mdBook/template
index b9df0433334f..465ff1a1bbbc 100644
--- a/srcpkgs/mdBook/template
+++ b/srcpkgs/mdBook/template
@@ -1,6 +1,6 @@
 # Template file for 'mdBook'
 pkgname=mdBook
-version=0.4.13
+version=0.4.14
 revision=1
 build_style=cargo
 short_desc="Create book from markdown files. Like Gitbook but implemented in Rust"
@@ -9,7 +9,7 @@ license="MPL-2.0"
 homepage="https://github.com/rust-lang/mdBook"
 changelog="https://raw.githubusercontent.com/rust-lang/mdBook/master/CHANGELOG.md"
 distfiles="https://github.com/rust-lang/mdBook/archive/v${version}.tar.gz"
-checksum=12a88a08e5c5b26810cc33b4e0ebed7cc72394f9041e8b15253e3cfac1223a7b
+checksum=59fd3e417e9d09deac89e20467194dd9f93854c2f1a87e845816c5cec676765c
 
 post_install() {
 	vlicense LICENSE

From 7b6735c90bb71b5be610bda29696ca58152590e1 Mon Sep 17 00:00:00 2001
From: teldra <teldra@rotce.de>
Date: Sun, 28 Nov 2021 01:11:22 +0100
Subject: [PATCH 035/289] py3status: update to 3.40.

---
 srcpkgs/py3status/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/py3status/template b/srcpkgs/py3status/template
index 5267fd63fdbe..092ccfbe2bd9 100644
--- a/srcpkgs/py3status/template
+++ b/srcpkgs/py3status/template
@@ -1,7 +1,7 @@
 # Template file for 'py3status'
 pkgname=py3status
-version=3.39
-revision=2
+version=3.40
+revision=1
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-setuptools python3-pyudev"
@@ -12,7 +12,7 @@ license="BSD-3-Clause"
 homepage="https://github.com/ultrabug/py3status"
 changelog="https://raw.githubusercontent.com/ultrabug/py3status/master/CHANGELOG"
 distfiles="${homepage}/archive/${version}.tar.gz"
-checksum=d18b81e86d5a44d2fa67453c3e9f04b9285005b2a7a9455890903d0e2dfe843c
+checksum=84885ec8a43626dcd7576b9cad029406c98675ca00ba66ff124d7607290d2b66
 
 post_install() {
 	vlicense LICENSE

From ec13a4999421c9386ea35c4584241f6fa60e417b Mon Sep 17 00:00:00 2001
From: teldra <teldra@rotce.de>
Date: Sun, 28 Nov 2021 01:08:24 +0100
Subject: [PATCH 036/289] openimagedenoise: update to 1.4.2.

---
 srcpkgs/openimagedenoise/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/openimagedenoise/template b/srcpkgs/openimagedenoise/template
index 7120d39bae20..8190e029a08b 100644
--- a/srcpkgs/openimagedenoise/template
+++ b/srcpkgs/openimagedenoise/template
@@ -1,6 +1,6 @@
 # Template file for 'openimagedenoise'
 pkgname=openimagedenoise
-version=1.4.1
+version=1.4.2
 revision=1
 archs="x86_64*"
 wrksrc=oidn-${version}
@@ -12,7 +12,7 @@ maintainer="teldra <teldra@rotce.de>"
 license="Apache-2.0"
 homepage="https://openimagedenoise.github.io"
 distfiles="https://github.com/OpenImageDenoise/oidn/releases/download/v${version}/oidn-${version}.src.tar.gz"
-checksum=9088966685a78adf24b8de075d66e4c0019bd7b2b9d29c6e45aaf35d294e3f6f
+checksum=e70d27ce24b41364782376c1b3b4f074f77310ccfe5f8ffec4a13a347e48a0ea
 
 do_check() {
 	build/oidnTest

From 1279ad7651c76f471c08b3b7f2847d26b7acfb3a Mon Sep 17 00:00:00 2001
From: Firgen <filip.frgelec@disroot.org>
Date: Sun, 14 Nov 2021 15:27:49 +0100
Subject: [PATCH 037/289] i3lock-color: update to 2.13.c.4.

---
 srcpkgs/i3lock-color/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/i3lock-color/template b/srcpkgs/i3lock-color/template
index 7f5572f99d64..6ce184239bb4 100644
--- a/srcpkgs/i3lock-color/template
+++ b/srcpkgs/i3lock-color/template
@@ -1,6 +1,6 @@
 # Template file for 'i3lock-color'
 pkgname=i3lock-color
-version=2.12.c.5
+version=2.13.c.4
 revision=1
 build_style=gnu-configure
 hostmakedepends="pkg-config automake"
@@ -11,7 +11,7 @@ maintainer="jtalowell <jtalowell@protonmail.com>"
 license="MIT"
 homepage="https://github.com/Raymo111/i3lock-color"
 distfiles="https://github.com/Raymo111/i3lock-color/archive/${version}.tar.gz"
-checksum=62c9bdff2759186426b184ed45e4c1aae1dc3c582499d94da68d9b08662a96a9
+checksum=5df4cd3d515d938630ced981a7f0a6e01344d1ec51d10fd3c3d131d19283df69
 conf_files="/etc/pam.d/i3lock"
 conflicts="i3lock"
 

From 62e8e4c61acc5af7cfaeb6a28a07d1dc656bde45 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Piotr=20W=C3=B3jcik?= <chocimier@tlen.pl>
Date: Mon, 29 Nov 2021 20:04:48 +0100
Subject: [PATCH 038/289] diffoscope: update to 194.

---
 srcpkgs/diffoscope/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/diffoscope/template b/srcpkgs/diffoscope/template
index 596f402323fe..31a2ca350066 100644
--- a/srcpkgs/diffoscope/template
+++ b/srcpkgs/diffoscope/template
@@ -1,6 +1,6 @@
 # Template file for 'diffoscope'
 pkgname=diffoscope
-version=193
+version=194
 revision=1
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -14,4 +14,4 @@ license="GPL-3.0-or-later"
 homepage="https://diffoscope.org/"
 changelog="https://salsa.debian.org/reproducible-builds/diffoscope/raw/master/debian/changelog"
 distfiles="${PYPI_SITE}/d/diffoscope/diffoscope-${version}.tar.gz"
-checksum=d836ddf24ccb4ffabd798ea1b7fcb66b87e55d5e8ff08286620bb7c64e1d829f
+checksum=3d28f0325e00effc6c23c50f916d153524aa393623df2fd1fc8ae0f6a12daf94

From 5885f6affeb732461637037b4c9141949a4f10ab Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C3=89rico=20Nogueira?= <erico.erc@gmail.com>
Date: Mon, 29 Nov 2021 02:01:44 -0300
Subject: [PATCH 039/289] gnome-keyring: remove libcap-ng, adopt.

We don't set capabilities on the binary right now, so it's better to
build without libcap-ng, so it doesn't complain on start-up. This is
also done by other distros, see [1].

libcap was no longer used, and neither was libtasn1.

We already depend on gcr via shlibs, so it doesn't need to be in
depends= explicitly.

Also update changelog to canonical URL.

[1] https://gitlab.gnome.org/GNOME/gnome-keyring/-/merge_requests/41#note_1277767
---
 srcpkgs/gnome-keyring/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/gnome-keyring/template b/srcpkgs/gnome-keyring/template
index 12f1e8d2df64..f479f7f0fe5e 100644
--- a/srcpkgs/gnome-keyring/template
+++ b/srcpkgs/gnome-keyring/template
@@ -1,19 +1,19 @@
 # Template file for 'gnome-keyring'
 pkgname=gnome-keyring
 version=40.0
-revision=2
+revision=3
 build_style=gnu-configure
 configure_args="--with-pam-dir=/usr/lib/security --disable-schemas-compile"
 hostmakedepends="autoconf docbook-xsl glib-devel intltool libtasn1-tools libxslt
  openssh pkg-config"
-makedepends="gcr-devel libcap-devel libcap-ng-devel libtasn1-devel pam-devel"
-depends="dconf gcr"
+makedepends="gcr-devel pam-devel"
+depends="dconf"
 checkdepends="dbus xvfb-run"
 short_desc="GNOME password and secret manager"
-maintainer="Orphaned <orphan@voidlinux.org>"
+maintainer="Érico Nogueira <ericonr@disroot.org>"
 license="GPL-2.0-or-later, LGPL-2.1-or-later"
 homepage="https://www.gnome.org"
-changelog="https://raw.githubusercontent.com/GNOME/gnome-keyring/gnome-40/NEWS"
+changelog="https://gitlab.gnome.org/GNOME/gnome-keyring/-/raw/master/NEWS"
 distfiles="${GNOME_SITE}/$pkgname/${version%.*}/$pkgname-$version.tar.xz"
 checksum=a3d24db08ee2fdf240fbbf0971a98c8ee295aa0e1a774537f4ea938038a3b931
 make_check=ci-skip

From c154356bb94361d51db610720debac2d1b446c5c Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C3=89rico=20Nogueira?= <erico.erc@gmail.com>
Date: Mon, 29 Nov 2021 02:10:34 -0300
Subject: [PATCH 040/289] texinfo: update to 6.8.

---
 srcpkgs/texinfo/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/texinfo/template b/srcpkgs/texinfo/template
index c183625028c5..55948fd8bab5 100644
--- a/srcpkgs/texinfo/template
+++ b/srcpkgs/texinfo/template
@@ -1,6 +1,6 @@
 # Template file for 'texinfo'
 pkgname=texinfo
-version=6.7
+version=6.8
 revision=1
 build_style=gnu-configure
 configure_args="--disable-static --disable-perl-xs"
@@ -10,9 +10,9 @@ depends="gzip perl"
 short_desc="GNU Documentation System"
 maintainer="Enno Boland <gottox@voidlinux.org>"
 license="GPL-3.0-or-later"
-homepage="http://www.gnu.org/software/texinfo/"
+homepage="https://www.gnu.org/software/texinfo/"
 distfiles="${GNU_SITE}/$pkgname/$pkgname-$version.tar.xz"
-checksum=988403c1542d15ad044600b909997ba3079b10e03224c61188117f3676b02caa
+checksum=8eb753ed28bca21f8f56c1a180362aed789229bd62fff58bf8368e9beb59fec4
 
 if [ -z "$CROSS_BUILD" ]; then
 	# XXX fails with cross compilation

From 749a2adfceb26bca9c12eb575734ac023da3c044 Mon Sep 17 00:00:00 2001
From: Luke Hannan <luke@lukehannan.com>
Date: Mon, 29 Nov 2021 17:50:36 +0200
Subject: [PATCH 041/289] R: update to 4.1.2.

---
 srcpkgs/R/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/R/template b/srcpkgs/R/template
index db75515b11cd..8a7db746af46 100644
--- a/srcpkgs/R/template
+++ b/srcpkgs/R/template
@@ -1,7 +1,7 @@
 # Template file for 'R'
 pkgname=R
-version=4.1.1
-revision=2
+version=4.1.2
+revision=1
 build_style=gnu-configure
 configure_args="--docdir=/usr/share/doc/R rdocdir=/usr/share/doc/R
  --with-blas$(vopt_if openblas '=openblas') --with-lapack
@@ -22,7 +22,7 @@ license="GPL-2.0-or-later"
 homepage="https://www.r-project.org/"
 changelog="https://cran.r-project.org/doc/manuals/r-release/NEWS.html"
 distfiles="https://cran.r-project.org/src/base/R-4/${pkgname}-${version}.tar.gz"
-checksum=515e03265752257d0b7036f380f82e42b46ed8473f54f25c7b67ed25bbbdd364
+checksum=2036225e9f7207d4ce097e54972aecdaa8b40d7d9911cd26491fac5a0fab38af
 nocross=yes
 shlib_provides="libR.so"
 make_check=extended

From 55ecf9eed971eb3ce8ef00d0172c9ead5897e308 Mon Sep 17 00:00:00 2001
From: Lorem <notloremipsum@protonmail.com>
Date: Sun, 28 Nov 2021 11:05:58 +0530
Subject: [PATCH 042/289] New package: coeurl-0.1.0

---
 common/shlibs           |  1 +
 srcpkgs/coeurl-devel    |  1 +
 srcpkgs/coeurl/template | 28 ++++++++++++++++++++++++++++
 3 files changed, 30 insertions(+)
 create mode 120000 srcpkgs/coeurl-devel
 create mode 100644 srcpkgs/coeurl/template

diff --git a/common/shlibs b/common/shlibs
index dac22845d445..527588585aec 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -4070,3 +4070,4 @@ libbrial_groebner.so.3 brial-1.2.10_1
 libm4ri-0.0.20200125.so m4ri-20200125_1
 libm4rie-0.0.20200125.so m4rie-20200125_1
 libptytty.so.0 libptytty-2.0_1
+libcoeurl.so.0 coeurl-0.1.0_1
diff --git a/srcpkgs/coeurl-devel b/srcpkgs/coeurl-devel
new file mode 120000
index 000000000000..bdd2ff71f0cb
--- /dev/null
+++ b/srcpkgs/coeurl-devel
@@ -0,0 +1 @@
+coeurl
\ No newline at end of file
diff --git a/srcpkgs/coeurl/template b/srcpkgs/coeurl/template
new file mode 100644
index 000000000000..dd6600a89bba
--- /dev/null
+++ b/srcpkgs/coeurl/template
@@ -0,0 +1,28 @@
+# Template file for 'coeurl'
+pkgname=coeurl
+version=0.1.0
+revision=1
+wrksrc=coeurl-v${version}
+build_style=meson
+hostmakedepends="pkg-config"
+makedepends="spdlog libevent-devel libcurl-devel"
+short_desc="Simple async wrapper around CURL for C++"
+maintainer="Lorem <notloremipsum@protonmail.com>"
+license="MIT"
+homepage="https://nheko.im/nheko-reborn/coeurl"
+distfiles="https://nheko.im/nheko-reborn/coeurl/-/archive/v${version}/coeurl-v${version}.tar.gz"
+checksum=2861453317c6da359a00083e39d899dfe0fc71becadd726ef845a5fba57d3f64
+
+post_install() {
+	vlicense LICENSE
+}
+
+coeurl-devel_package() {
+	short_desc+=" - development files"
+	depends="${sourcepkg}>=${version}_${revision} ${makedepends}"
+	pkg_install() {
+		vmove usr/include
+		vmove usr/lib/pkgconfig
+		vmove "usr/lib/*.so"
+	}
+}

From 758dd9fc25d53daad28ebf02cc94b7b21d92c7ab Mon Sep 17 00:00:00 2001
From: Lorem <notloremipsum@protonmail.com>
Date: Sun, 28 Nov 2021 11:07:15 +0530
Subject: [PATCH 043/289] mtxclient: update to 0.6.0.

---
 common/shlibs              | 2 +-
 srcpkgs/mtxclient/template | 6 +++---
 2 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/common/shlibs b/common/shlibs
index 527588585aec..ad60646030fe 100644
--- a/common/shlibs
+++ b/common/shlibs
@@ -420,7 +420,7 @@ libField3D.so.1.7 Field3D-1.7.3_1
 libMAC.so.6 libMAC-5.28_1
 libmad.so.0 libmad-0.15.1b_1
 libmatroska.so.7 libmatroska-1.6.0_1
-libmatrix_client.so.0.5.1 mtxclient-0.5.1_1
+libmatrix_client.so.0.6.0 mtxclient-0.6.0_1
 libebml.so.5 libebml-1.4.0_1
 libdvdread.so.8 libdvdread-6.1.1_1
 libdvdnav.so.4 libdvdnav-4.1.3_1
diff --git a/srcpkgs/mtxclient/template b/srcpkgs/mtxclient/template
index 35f3d4a10f42..9c8c1e3a9efe 100644
--- a/srcpkgs/mtxclient/template
+++ b/srcpkgs/mtxclient/template
@@ -1,17 +1,17 @@
 # Template file for 'mtxclient'
 pkgname=mtxclient
-version=0.5.1
+version=0.6.0
 revision=1
 build_style=cmake
 configure_args="-DBUILD_LIB_TESTS=OFF -DBUILD_LIB_EXAMPLES=OFF"
 hostmakedepends="pkg-config"
-makedepends="boost-devel json-c++ olm-devel openssl-devel"
+makedepends="json-c++ olm-devel openssl-devel coeurl-devel"
 short_desc="Client API library for the Matrix protocol"
 maintainer="Lorem <notloremipsum@protonmail.com>"
 license="MIT"
 homepage="https://github.com/Nheko-Reborn/mtxclient"
 distfiles="https://github.com/Nheko-Reborn/mtxclient/archive/v${version}.tar.gz"
-checksum=9478d870296ebe7679c90f563cb798eb3cdd3f9c4578ceea5af75b66f456baaa
+checksum=4245feb0bd4ae8e026c01f546a6bea45bc9d9d57d13430b8ba446b0aec4915c4
 
 post_install() {
 	vlicense LICENSE

From 9cef86977e52a2b00755d5db95163863a129a9db Mon Sep 17 00:00:00 2001
From: Lorem <notloremipsum@protonmail.com>
Date: Sun, 28 Nov 2021 11:07:27 +0530
Subject: [PATCH 044/289] nheko: update to 0.9.0.

---
 srcpkgs/nheko/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/nheko/template b/srcpkgs/nheko/template
index 7b7c6bfbf6e1..deaf85713976 100644
--- a/srcpkgs/nheko/template
+++ b/srcpkgs/nheko/template
@@ -1,11 +1,11 @@
 # Template file for 'nheko'
 pkgname=nheko
-version=0.8.2
-revision=2
+version=0.9.0
+revision=1
 build_style=cmake
 hostmakedepends="qt5-host-tools qt5-qmake pkg-config qt5-declarative"
 makedepends="qt5-multimedia-devel qt5-svg-devel qt5-tools-devel fmt-devel
- spdlog mtxclient-devel boost-devel cmark-devel olm-devel json-c++ lmdb++
+ spdlog mtxclient-devel cmark-devel olm-devel json-c++ lmdb++ coeurl-devel
  qt5-declarative-devel qt5-quickcontrols2-devel qtkeychain-qt5-devel
  gst-plugins-bad1-devel gst-plugins-base1-devel xcb-util-wm-devel"
 depends="hicolor-icon-theme qt5-quickcontrols2 qt5-graphicaleffects
@@ -16,7 +16,7 @@ license="GPL-3.0-or-later"
 homepage="https://github.com/Nheko-Reborn/nheko"
 changelog="https://github.com/Nheko-Reborn/nheko/blob/master/CHANGELOG.md"
 distfiles="https://github.com/Nheko-Reborn/nheko/archive/v${version}.tar.gz"
-checksum=df4575c47daab47d418637a4637b599e3848dd749132ca1e92f981d9212eabb2
+checksum=309505f13d3b65ea23c0db19e59e469905b1ae437d2d6c7d1b496ac0921fb141
 
 case "$XBPS_TARGET_MACHINE" in
 	armv*-musl)

From d8cc0dc0da92b9331deb75c6874d3813d0e56edc Mon Sep 17 00:00:00 2001
From: Evgeny Ermakov <evgeny.v.ermakov@gmail.com>
Date: Tue, 30 Nov 2021 06:03:00 +1100
Subject: [PATCH 045/289] cglm: update to 0.8.4.

---
 srcpkgs/cglm/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/cglm/template b/srcpkgs/cglm/template
index c7dfee606c45..5b553c7c0d12 100644
--- a/srcpkgs/cglm/template
+++ b/srcpkgs/cglm/template
@@ -1,6 +1,6 @@
 # Template file for 'cglm'
 pkgname=cglm
-version=0.8.3
+version=0.8.4
 revision=1
 build_style=cmake
 short_desc="Highly Optimized Graphics Math (glm) for C"
@@ -8,7 +8,7 @@ maintainer="Nicu Borta <nicuborta123@tutanota.com>"
 license="MIT"
 homepage="https://github.com/recp/cglm"
 distfiles="https://github.com/recp/cglm/archive/v${version}.tar.gz"
-checksum=3a3f935f9f2ed5a8cb6337e421bf6f3a699a72d8cfe26fde1bbb8fde5c1c8aaf
+checksum=42f84c42c8a3e62954da77ab5c5d3264033d5802009e175db7921332a