Github messages for voidlinux
 help / color / mirror / Atom feed
* [ISSUE] dbeaver: version of the JVM is not suitable for this product
@ 2022-01-04 22:34 jchook
  2022-01-09 20:45 ` leahneukirchen
                   ` (5 more replies)
  0 siblings, 6 replies; 7+ messages in thread
From: jchook @ 2022-01-04 22:34 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 831 bytes --]

New issue by jchook on void-packages repository

https://github.com/void-linux/void-packages/issues/34857

Description:
<!-- Don't request update of package. We have a script for that. https://alpha.de.repo.voidlinux.org/void-updates/void-updates.txt . However, a quality pull request may help. -->
### System

* xuname:  
  Void 5.15.8_1 x86_64 GenuineIntel notuptodate rrFFF
* package:  
  dbeaver-21.3.2_1

### Expected behavior

Able to launch after installing

### Actual behavior

Getting this error:

> Version 1.8.0_272 of the JVM is not suitable for this product. Version 11 or greater is required.

![image](https://user-images.githubusercontent.com/193530/148132901-04435810-a414-4e2d-a8e8-8b17117d4026.png)


### Steps to reproduce the behavior

```
sudo xbps-install -y dbeaver
dbeaver
```


^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: dbeaver: version of the JVM is not suitable for this product
  2022-01-04 22:34 [ISSUE] dbeaver: version of the JVM is not suitable for this product jchook
@ 2022-01-09 20:45 ` leahneukirchen
  2022-01-09 20:46 ` leahneukirchen
                   ` (4 subsequent siblings)
  5 siblings, 0 replies; 7+ messages in thread
From: leahneukirchen @ 2022-01-09 20:45 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 169 bytes --]

New comment by leahneukirchen on void-packages repository

https://github.com/void-linux/void-packages/issues/34857#issuecomment-1008398510

Comment:
Install openjdk11?

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: dbeaver: version of the JVM is not suitable for this product
  2022-01-04 22:34 [ISSUE] dbeaver: version of the JVM is not suitable for this product jchook
  2022-01-09 20:45 ` leahneukirchen
@ 2022-01-09 20:46 ` leahneukirchen
  2022-01-09 23:22 ` jchook
                   ` (3 subsequent siblings)
  5 siblings, 0 replies; 7+ messages in thread
From: leahneukirchen @ 2022-01-09 20:46 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 210 bytes --]

New comment by leahneukirchen on void-packages repository

https://github.com/void-linux/void-packages/issues/34857#issuecomment-1008398510

Comment:
Install openjdk11?
It has `depends="openjdk11"` already.


^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: dbeaver: version of the JVM is not suitable for this product
  2022-01-04 22:34 [ISSUE] dbeaver: version of the JVM is not suitable for this product jchook
  2022-01-09 20:45 ` leahneukirchen
  2022-01-09 20:46 ` leahneukirchen
@ 2022-01-09 23:22 ` jchook
  2022-01-09 23:57 ` jchook
                   ` (2 subsequent siblings)
  5 siblings, 0 replies; 7+ messages in thread
From: jchook @ 2022-01-09 23:22 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 280 bytes --]

New comment by jchook on void-packages repository

https://github.com/void-linux/void-packages/issues/34857#issuecomment-1008445279

Comment:
It can't seem to find the JDK. 

I had `openjdk8` installed via the `openjdk` meta package already, but uninstalling that did not help.

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: dbeaver: version of the JVM is not suitable for this product
  2022-01-04 22:34 [ISSUE] dbeaver: version of the JVM is not suitable for this product jchook
                   ` (2 preceding siblings ...)
  2022-01-09 23:22 ` jchook
@ 2022-01-09 23:57 ` jchook
  2022-01-09 23:58 ` jchook
  2022-01-15  5:34 ` hiljusti
  5 siblings, 0 replies; 7+ messages in thread
From: jchook @ 2022-01-09 23:57 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 302 bytes --]

New comment by jchook on void-packages repository

https://github.com/void-linux/void-packages/issues/34857#issuecomment-1008450003

Comment:
This fixes the issue:

Add the following to the *top* of `/usr/lib/dbeaver/dbeaver.ini`

```
--launcher.appendVmargs
-vm
/usr/lib/jvm/openjdk11/bin
```

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: dbeaver: version of the JVM is not suitable for this product
  2022-01-04 22:34 [ISSUE] dbeaver: version of the JVM is not suitable for this product jchook
                   ` (3 preceding siblings ...)
  2022-01-09 23:57 ` jchook
@ 2022-01-09 23:58 ` jchook
  2022-01-15  5:34 ` hiljusti
  5 siblings, 0 replies; 7+ messages in thread
From: jchook @ 2022-01-09 23:58 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 344 bytes --]

New comment by jchook on void-packages repository

https://github.com/void-linux/void-packages/issues/34857#issuecomment-1008450003

Comment:
[This](https://superuser.com/a/1603887/177388) fixes the issue:

Add the following to the *top* of `/usr/lib/dbeaver/dbeaver.ini`

```
--launcher.appendVmargs
-vm
/usr/lib/jvm/openjdk11/bin
```

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: dbeaver: version of the JVM is not suitable for this product
  2022-01-04 22:34 [ISSUE] dbeaver: version of the JVM is not suitable for this product jchook
                   ` (4 preceding siblings ...)
  2022-01-09 23:58 ` jchook
@ 2022-01-15  5:34 ` hiljusti
  5 siblings, 0 replies; 7+ messages in thread
From: hiljusti @ 2022-01-15  5:34 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 813 bytes --]

New comment by hiljusti on void-packages repository

https://github.com/void-linux/void-packages/issues/34857#issuecomment-1013617010

Comment:
Took me a while to find some steps to reproduce it, but tl;dr this would do it:

```
sudo xbps-install dbeaver
sudo xbps-install openjdk8
sudo xbps-alternatives --set openjdk8
dbeaver # fails with the error message
```

Maybe there are other ways to get to this state.

A quick fix is to do:

```
sudo xbps-alternatives --set openjdk11
```

But... I think there are reasons someone might want JDK 8 as a default, and still be able to use this app I guess. It's still an LTS version of Java, and some software still requires it for one reason or another. (Usually to run java bytecode compiled with some version <= JDK 7 that isn't supported by JDK 11)

^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2022-01-15  5:34 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-01-04 22:34 [ISSUE] dbeaver: version of the JVM is not suitable for this product jchook
2022-01-09 20:45 ` leahneukirchen
2022-01-09 20:46 ` leahneukirchen
2022-01-09 23:22 ` jchook
2022-01-09 23:57 ` jchook
2022-01-09 23:58 ` jchook
2022-01-15  5:34 ` hiljusti

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).