Github messages for voidlinux
 help / color / mirror / Atom feed
* [PR PATCH] libproxy: update to 0.4.17.
@ 2022-02-10 20:02 tibequadorian
  2022-02-10 20:04 ` [PR PATCH] [Updated] " tibequadorian
  2022-06-23  2:15 ` github-actions
  0 siblings, 2 replies; 3+ messages in thread
From: tibequadorian @ 2022-02-10 20:02 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1451 bytes --]

There is a new pull request by tibequadorian against master on the void-packages repository

https://github.com/tibequadorian/void-packages libproxy
https://github.com/void-linux/void-packages/pull/35515

libproxy: update to 0.4.17.
<!-- Uncomment relevant sections and delete options which are not applicable -->

#### Testing the changes
- I tested the changes in this PR: **NO**

I don't know how to test this since there is almost no documentation on how to use `/usr/bin/proxy` but given there's no soname bump it should probably work fine.

Automated tests fail with same output on the old version.

<!--
#### New package
- This new package conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements): **YES**|**NO**
-->

<!-- Note: If the build is likely to take more than 2 hours, please [skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration)
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->
<!-- 
#### Local build testing
- I built this PR locally for my native architecture, (ARCH-LIBC)
- I built this PR locally for these architectures (if supported. mark crossbuilds):
  - aarch64-musl
  - armv7l
  - armv6l-musl
-->


A patch file from https://github.com/void-linux/void-packages/pull/35515.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-libproxy-35515.patch --]
[-- Type: text/x-diff, Size: 1125 bytes --]

From 2372a401d8f830eee330d9c66b83b10ee2b9edc8 Mon Sep 17 00:00:00 2001
From: tibequadorian <tibequadorian@posteo.de>
Date: Thu, 10 Feb 2022 18:40:40 +0100
Subject: [PATCH] libproxy: update to 0.4.17.

---
 srcpkgs/libproxy/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/libproxy/template b/srcpkgs/libproxy/template
index d6103007032e..f3a638c0279a 100644
--- a/srcpkgs/libproxy/template
+++ b/srcpkgs/libproxy/template
@@ -1,6 +1,6 @@
 # Template file for 'libproxy'
 pkgname=libproxy
-version=0.4.15
+version=0.4.17
 revision=1
 build_style=cmake
 configure_args="-DWITH_GNOME=0 -DWITH_KDE4=0 -DWITH_MOZJS=0 -DWITH_NM=0
@@ -12,7 +12,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 homepage="http://github.com/libproxy/libproxy"
 license="LGPL-2.1"
 distfiles="https://github.com/libproxy/libproxy/archive/${version}.tar.gz>${pkgname}-${version}.tar.gz"
-checksum=18f58b0a0043b6881774187427ead158d310127fc46a1c668ad6d207fb28b4e0
+checksum=88c624711412665515e2800a7e564aabb5b3ee781b9820eca9168035b0de60a9
 
 libproxy-devel_package() {
 	depends="libproxy>=${version}_${revision}"

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PR PATCH] [Updated] libproxy: update to 0.4.17.
  2022-02-10 20:02 [PR PATCH] libproxy: update to 0.4.17 tibequadorian
@ 2022-02-10 20:04 ` tibequadorian
  2022-06-23  2:15 ` github-actions
  1 sibling, 0 replies; 3+ messages in thread
From: tibequadorian @ 2022-02-10 20:04 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1456 bytes --]

There is an updated pull request by tibequadorian against master on the void-packages repository

https://github.com/tibequadorian/void-packages libproxy
https://github.com/void-linux/void-packages/pull/35515

libproxy: update to 0.4.17.
<!-- Uncomment relevant sections and delete options which are not applicable -->

#### Testing the changes
- I tested the changes in this PR: **NO**

I don't know how to test this since there is almost no documentation on how to use `/usr/bin/proxy` but given there's no soname bump it should probably work fine.

Automated tests fail with same output on the old version.

<!--
#### New package
- This new package conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements): **YES**|**NO**
-->

<!-- Note: If the build is likely to take more than 2 hours, please [skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration)
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->
<!-- 
#### Local build testing
- I built this PR locally for my native architecture, (ARCH-LIBC)
- I built this PR locally for these architectures (if supported. mark crossbuilds):
  - aarch64-musl
  - armv7l
  - armv6l-musl
-->


A patch file from https://github.com/void-linux/void-packages/pull/35515.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-libproxy-35515.patch --]
[-- Type: text/x-diff, Size: 1397 bytes --]

From 5a8e74589406cdf6a5c3fbf3dde4b67371c959c7 Mon Sep 17 00:00:00 2001
From: tibequadorian <tibequadorian@posteo.de>
Date: Thu, 10 Feb 2022 18:40:40 +0100
Subject: [PATCH] libproxy: update to 0.4.17.

---
 srcpkgs/libproxy/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/libproxy/template b/srcpkgs/libproxy/template
index d6103007032e..52b050bb9bbc 100644
--- a/srcpkgs/libproxy/template
+++ b/srcpkgs/libproxy/template
@@ -1,18 +1,18 @@
 # Template file for 'libproxy'
 pkgname=libproxy
-version=0.4.15
+version=0.4.17
 revision=1
 build_style=cmake
 configure_args="-DWITH_GNOME=0 -DWITH_KDE4=0 -DWITH_MOZJS=0 -DWITH_NM=0
  -DWITH_PERL=0 -DWITH_PYTHON=1 -DWITH_WEBKIT=0"
 hostmakedepends="pkg-config python"
 makedepends="zlib-devel"
-short_desc="A library handling all the details of proxy configuration"
+short_desc="Library handling all the details of proxy configuration"
 maintainer="Orphaned <orphan@voidlinux.org>"
+license="LGPL-2.1-or-later"
 homepage="http://github.com/libproxy/libproxy"
-license="LGPL-2.1"
 distfiles="https://github.com/libproxy/libproxy/archive/${version}.tar.gz>${pkgname}-${version}.tar.gz"
-checksum=18f58b0a0043b6881774187427ead158d310127fc46a1c668ad6d207fb28b4e0
+checksum=88c624711412665515e2800a7e564aabb5b3ee781b9820eca9168035b0de60a9
 
 libproxy-devel_package() {
 	depends="libproxy>=${version}_${revision}"

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: libproxy: update to 0.4.17.
  2022-02-10 20:02 [PR PATCH] libproxy: update to 0.4.17 tibequadorian
  2022-02-10 20:04 ` [PR PATCH] [Updated] " tibequadorian
@ 2022-06-23  2:15 ` github-actions
  1 sibling, 0 replies; 3+ messages in thread
From: github-actions @ 2022-06-23  2:15 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 305 bytes --]

New comment by github-actions[bot] on void-packages repository

https://github.com/void-linux/void-packages/pull/35515#issuecomment-1163847377

Comment:
Pull Requests become stale 90 days after last activity and are closed 14 days after that.  If this pull request is still relevant bump it or assign it.

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2022-06-23  2:15 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-02-10 20:02 [PR PATCH] libproxy: update to 0.4.17 tibequadorian
2022-02-10 20:04 ` [PR PATCH] [Updated] " tibequadorian
2022-06-23  2:15 ` github-actions

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).