Development discussion of WireGuard
 help / color / mirror / Atom feed
* Re: Error when connecting from windows client
@ 2021-05-22 18:41 Hank Bao
  0 siblings, 0 replies; 3+ messages in thread
From: Hank Bao @ 2021-05-22 18:41 UTC (permalink / raw)
  To: wireguard

Hello Everyone.

I believe I've encountered the same issue. My Wintun interface failed
to boot up, and I found a warning sign on the Wintun adapter in the
device manager.

After digging into the setupapi.dev.log, I found that it's the same
error message as Johnathan's.

!    dvi: Device pending start: Device has problem: 0x38
(CM_PROB_NEED_CLASS_CONFIG), problem status: 0x00000000.

I noticed that the Cisco AnyConnect secure mobility client got a
virtual adapter installed in the system, which instance id is also
'ROOT\NET\0000'.
Hopefully, this will be helpful.

Regards,
Hank Bao

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: Error when connecting from windows client
  2021-04-27  9:54   ` Simon Rozman
@ 2021-04-28 21:29     ` Johnathan Clarke
  0 siblings, 0 replies; 3+ messages in thread
From: Johnathan Clarke @ 2021-04-28 21:29 UTC (permalink / raw)
  To: Simon Rozman; +Cc: wireguard

Hi Simon

the setupapi.dev.log

>>>  [Delete Device - ROOT\NET\0000]
>>>  Section start 2021/04/28 15:52:49.399
      cmd: "C:\Program Files\WireGuard\wireguard.exe" /tunnelservice
"C:\Program Files\WireGuard\Data\Configurations\Home.conf.dpapi"
     dvi: Query-and-Remove succeeded
<<<  Section end 2021/04/28 15:52:49.531
<<<  [Exit status: SUCCESS]


>>>  [Configure Driver Package - c:\windows\system32\driverstore\filerepository\wintun.inf_amd64_65b8959a2d220b06\wintun.inf]
>>>  Section start 2021/04/29 07:27:04.869
      cmd: "C:\Program Files\WireGuard\wireguard.exe" /tunnelservice
"C:\Program Files\WireGuard\Data\Configurations\Home.conf.dpapi"
     sto: Source Filter  = Wintun.Install
     sto: Target Filter  = ROOT\NET\0000
     inf: Class GUID     = {4d36e972-e325-11ce-bfc1-08002be10318}
     inf: Class Options  = Configurable
     inf: {Configure Driver: Wintun Userspace Tunnel}
     inf:      Section Name = Wintun.Install
     inf:      {Configure Device: ROOT\NET\0000}
     inf:      {Configure Device: exit(0x00000000)}
     inf: {Configure Driver: exit(0x00000000)}
<<<  Section end 2021/04/29 07:27:04.917
<<<  [Exit status: SUCCESS]


>>>  [Restart Device - ROOT\NET\0000]
>>>  Section start 2021/04/29 07:27:04.926
      cmd: "C:\Program Files\WireGuard\wireguard.exe" /tunnelservice
"C:\Program Files\WireGuard\Data\Configurations\Home.conf.dpapi"
     dvi: Device Status: 0x01802001
     dvi: Install Device: Starting device 'ROOT\NET\0000'. 07:27:04.932
     dvi: Install Device: Starting device completed. 07:27:04.946
!    dvi: Device pending start: Device has problem: 0x38
(CM_PROB_NEED_CLASS_CONFIG), problem status: 0x00000000.
<<<  Section end 2021/04/29 07:27:04.959
<<<  [Exit status: SUCCESS]


>>>  [Delete Device - ROOT\NET\0000]
>>>  Section start 2021/04/29 07:27:05.018
      cmd: "C:\Program Files\WireGuard\wireguard.exe" /tunnelservice
"C:\Program Files\WireGuard\Data\Configurations\Home.conf.dpapi"
     dvi: Query-and-Remove succeeded
<<<  Section end 2021/04/29 07:27:05.093
<<<  [Exit status: SUCCESS]

On Tue, Apr 27, 2021 at 7:54 PM Simon Rozman <simon@rozman.si> wrote:
>
> Hi,
>
> > 2021-04-26 14:45:33.382398: [TUN] [Home] Creating Wintun interface
> > 2021-04-26 14:45:33.519928: [TUN] [Home] [Wintun] CreateAdapter:
> > Creating adapter
> > 2021-04-26 14:45:33.828328: [TUN] [Home] [Wintun] SelectDriver: Using
> > existing driver 0.10
> > 2021-04-26 14:45:34.289159: [TUN] [Home] [Wintun] CreateAdapter:
> > Failed to setup adapter (status: 0x0): The operation completed
> > successfully. (Code 0x00000000)
>
> Your log indicates that the adapter device was created, but has a problem code with a STATUS_SUCCESS problem status. I have reintroduced the problem code check in https://git.zx2c4.com/wintun/commit/?id=2881164bff0e819f6b0b6d5fc5d3a185ecb47457. This should evaluate the Wintun adapter state with better precision.
>
> Meanwhile, can you please examine your C:\Windows\INF\setupapi.dev.log file for clues. (Note that a 0x1f/0xc0000495 problem code/status is normal when Wintun adapter is created early at boot. Hence the STATUS_PNP_DEVICE_CONFIGURATION_PENDING check in the code.)
>
> Regards, Simon



-- 
--Johnathan Clarke
--  --

Please consider something when reading this message. It was handwritten and
sent from a black computer. No iPhone. No iTypos. No iApologize.

DISCLAIMER: This email could contain confidential information, is for
the intended recipient only and blah blah blah.. If you are not the
intended recipient, sorry. Email transmissions cannot be error-free or
guaranteed to be delivered (correctly) and are constantly intercepted,
corrupted, destroyed, arrive late or incomplete and often contain
viruses. The sender does not accept any liability for damage as a
result of the transmission of this e-mail. Any views or opinions
expressed in this email are solely those of someone else and do not
represent anyone else's. Void where prohibited by law or Common Sense.
WARNING: Not following instructions as laid out in this disclaimer is
unlikely to result in legal action or otherwise. Thankyou Olger

^ permalink raw reply	[flat|nested] 3+ messages in thread

* RE: Error when connecting from windows client
  2021-04-26  5:34 ` Fwd: " Johnathan Clarke
@ 2021-04-27  9:54   ` Simon Rozman
  2021-04-28 21:29     ` Johnathan Clarke
  0 siblings, 1 reply; 3+ messages in thread
From: Simon Rozman @ 2021-04-27  9:54 UTC (permalink / raw)
  To: Johnathan Clarke, wireguard

Hi,

> 2021-04-26 14:45:33.382398: [TUN] [Home] Creating Wintun interface
> 2021-04-26 14:45:33.519928: [TUN] [Home] [Wintun] CreateAdapter:
> Creating adapter
> 2021-04-26 14:45:33.828328: [TUN] [Home] [Wintun] SelectDriver: Using
> existing driver 0.10
> 2021-04-26 14:45:34.289159: [TUN] [Home] [Wintun] CreateAdapter:
> Failed to setup adapter (status: 0x0): The operation completed
> successfully. (Code 0x00000000)

Your log indicates that the adapter device was created, but has a problem code with a STATUS_SUCCESS problem status. I have reintroduced the problem code check in https://git.zx2c4.com/wintun/commit/?id=2881164bff0e819f6b0b6d5fc5d3a185ecb47457. This should evaluate the Wintun adapter state with better precision.

Meanwhile, can you please examine your C:\Windows\INF\setupapi.dev.log file for clues. (Note that a 0x1f/0xc0000495 problem code/status is normal when Wintun adapter is created early at boot. Hence the STATUS_PNP_DEVICE_CONFIGURATION_PENDING check in the code.)

Regards, Simon

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2021-05-23  8:18 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-05-22 18:41 Error when connecting from windows client Hank Bao
     [not found] <CAOSAzkKgZS_-tRkbo10gZ3CrTfNPfBUuBUwY4bMY+W0Ynj_pNg@mail.gmail.com>
2021-04-26  5:34 ` Fwd: " Johnathan Clarke
2021-04-27  9:54   ` Simon Rozman
2021-04-28 21:29     ` Johnathan Clarke

Development discussion of WireGuard

This inbox may be cloned and mirrored by anyone:

	git clone --mirror http://inbox.vuxu.org/wireguard/0 wireguard/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 wireguard wireguard/ http://inbox.vuxu.org/wireguard \
		wireguard@lists.zx2c4.com
	public-inbox-index wireguard

Example config snippet for mirrors.
Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.archive.wireguard


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git