zsh-users
 help / color / mirror / Atom feed
* Receiving SIGWINCH while waiting for user input
@ 2019-12-24 22:20 zsugabubus
  0 siblings, 0 replies; only message in thread
From: zsugabubus @ 2019-12-24 22:20 UTC (permalink / raw)
  To: zsh-users

Hi,

I'm writing an interactive script using `zcurses`, but I got stuck
receiving SIGWINCH while waiting for user input. I tried `read`,
`zcurses input`, `sysread` and `zselect` (waiting for stdin then read)
but all blocks SIGWINCH. I also tried `vared`, but couldn't read just
one character at a time.

Is there a way I can achieve it? Handling resize only after a command
has been entered doesn't seem a nice solution.

Thanks,
zsugabubus

^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2019-12-24 22:21 UTC | newest]

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-12-24 22:20 Receiving SIGWINCH while waiting for user input zsugabubus

zsh-users

This inbox may be cloned and mirrored by anyone:

	git clone --mirror http://inbox.vuxu.org/zsh-users

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V1 zsh-users zsh-users/ http://inbox.vuxu.org/zsh-users \
		zsh-users@zsh.org
	public-inbox-index zsh-users

Example config snippet for mirrors.
Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.archive.zsh.users


code repositories for the project(s) associated with this inbox:

	https://git.vuxu.org/mirror/zsh/

AGPL code for this site: git clone https://public-inbox.org/public-inbox.git