help / color / mirror / code / Atom feed
* Sed error
@ 2022-08-03  0:12 Aki Hoji
  2022-08-03  0:40 ` Bart Schaefer
  0 siblings, 1 reply; 3+ messages in thread
From: Aki Hoji @ 2022-08-03  0:12 UTC (permalink / raw)
  To: zsh-users


I get the error message (sed: -e expression #1, char 2: invalid usage of line address 0) when I run a following;

parallel -a temp3.fq  -k --block 50M --pipe-part 'sed -e  "$!N;/\nXQ@A00165/!P;D"' > temp4.fq

When I run this one liner in bash, it works just fine but under zsh. Apprently, zsh does not like “!”.   Isn’t  “!” in the script not compatible with zsh and is there any work around for this ? 

I am using my institution’s cluster;

 x86_64 x86_64 x86_64 GNU/Linu


^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2022-08-03  0:43 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-08-03  0:12 Sed error Aki Hoji
2022-08-03  0:40 ` Bart Schaefer
2022-08-03  0:41   ` Bart Schaefer

Code repositories for project(s) associated with this public inbox


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).