zsh-workers
 help / color / Atom feed
From: Aggu Sern <agguser@gmail.com>
To: zsh-workers@zsh.org
Subject: Process substitution within parameter expansion
Date: Sun, 2 Feb 2020 11:50:08 +0700
Message-ID: <CA+gg2UbTwc0=jR--GYrbONTQDX+9A12g3jHTuGJmTjWViceEmQ@mail.gmail.com> (raw)

[-- Attachment #1: Type: text/plain, Size: 317 bytes --]

$ cat =(echo 'abc' | sed 's/^a/A/; s/c$/C/')
AbC

$ cat ${:-=(echo 'abc' | sed 's/^a/A/; s/c$/C/')}
zsh: no matches found: s/^a/A/

How to fix the error? Is this a bug?

My intention is to "embed" `=(...)` (e.g. `mpv --playlist=${:-=(...)}`)
without using anonymous function (e.g. `() { mpv --playlist=$1 } =(...)`).

                 reply index

Thread overview: [no followups] expand[flat|nested]  mbox.gz  Atom feed

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CA+gg2UbTwc0=jR--GYrbONTQDX+9A12g3jHTuGJmTjWViceEmQ@mail.gmail.com' \
    --to=agguser@gmail.com \
    --cc=zsh-workers@zsh.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

zsh-workers

Archives are clonable: git clone --mirror http://inbox.vuxu.org/zsh-workers

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.archive.zsh.workers


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git