zsh-workers
 help / color / mirror / code / Atom feed
* PATCH: OpenBSD sys{clean,merge,patch,upgrade} completion
@ 2022-02-01  4:11 Matthew Martin
  0 siblings, 0 replies; only message in thread
From: Matthew Martin @ 2022-02-01  4:11 UTC (permalink / raw)
  To: zsh-workers

OpenBSD has a number of small sys* commands that lack completion (though
sysclean is in ports).


diff --git a/Completion/BSD/Command/_sysclean b/Completion/BSD/Command/_sysclean
new file mode 100644
index 000000000..755861644
--- /dev/null
+++ b/Completion/BSD/Command/_sysclean
@@ -0,0 +1,6 @@
+#compdef sysclean
+
+_arguments -s : \
+  '(-p)-a[include filenames used by installed packages]' \
+  '-i[include ignored filenames]' \
+  '(-a)-p[output package names that are using obsolete files]'
diff --git a/Completion/BSD/Command/_sysmerge b/Completion/BSD/Command/_sysmerge
new file mode 100644
index 000000000..00ee18299
--- /dev/null
+++ b/Completion/BSD/Command/_sysmerge
@@ -0,0 +1,6 @@
+#compdef sysmerge
+
+_arguments -s : \
+  '-b[run non-interactively]' \
+  '-d[do not take any automatic action]' \
+  '-p[only compare configuration of packages]'
diff --git a/Completion/BSD/Command/_syspatch b/Completion/BSD/Command/_syspatch
new file mode 100644
index 000000000..850636d09
--- /dev/null
+++ b/Completion/BSD/Command/_syspatch
@@ -0,0 +1,7 @@
+#compdef syspatch
+
+_arguments \
+  '(   -l -R -r)-c[list available patches]' \
+  '(-c    -R -r)-l[list installed patches]' \
+  '(-c -l    -r)-R[revert all patches]' \
+  '(-c -l -R   )-r[revert the most recently installed patch]'
diff --git a/Completion/BSD/Command/_sysupgrade b/Completion/BSD/Command/_sysupgrade
new file mode 100644
index 000000000..b1144b0d5
--- /dev/null
+++ b/Completion/BSD/Command/_sysupgrade
@@ -0,0 +1,9 @@
+#compdef sysupgrade
+
+_arguments -s -S -A '-*' : \
+  '-f[force an already applied upgrade]' \
+  '-k[keep the downloaded files]' \
+  '-n[do not reboot]' \
+  '(-s)-r[upgrade to the next release]' \
+  '(-r)-s[upgrade to a snapshot]' \
+  ':installurl:'


^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2022-02-01  4:11 UTC | newest]

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-02-01  4:11 PATCH: OpenBSD sys{clean,merge,patch,upgrade} completion Matthew Martin

Code repositories for project(s) associated with this public inbox

	https://git.vuxu.org/mirror/zsh/

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).