9fans - fans of the OS Plan 9 from Bell Labs
 help / color / mirror / Atom feed
From: "yakkuliste via 9fans" <9fans@9fans.net>
To: 9fans <9fans@9fans.net>
Subject: Re: [9fans] Problems installing 9legacy on bare metal (Thinkpad X60)
Date: Thu, 27 Jan 2022 07:47:28 -0500	[thread overview]
Message-ID: <16432876480.0e2BEb0.274549@composer.9fans.topicbox.com> (raw)
In-Reply-To: <CAJQ9t7g6b6z-JuEgNEDUVQNUi28-9chuGEy+7hHGTTeDzfoTxQ@mail.gmail.com>

[-- Attachment #1: Type: text/plain, Size: 2145 bytes --]

Richard has been very forthcoming off-list in trying to get 9legacy working on my machines. But there are still a few things that aren't quite working, so let's bring this thread up to speed.

On the X60s, Plan 9 now runs on bare metal but I can't establish an ethernet connection. Even when I run ipconfig and ndb/dns manually after boot, it doesn't solve the issue, because there is an issue with the mp table.

cat /dev/kmesg
#l0: i82573: 1Gbps port 0xEE000000 irq 11: 0016d3b8c206
mpintrenable: multiple botch irq11, tbdf 5000000, lo 00000049, n 00000049
mpintrenable: out of choices eisa -1 isa 22 tbdf 0xc030000 irq 11
intrenable: couldn't enable irq 11, tbdf 0xC030000 for ether1
wpi: [...]
#l1: [...]
mpintrenable: multiple botch irq11, tbdf 5000000, lo 00000049, n 00000049
mpintrenable: out of choices eisa -1 isa 22 tbdf 0xc00ef00 irq 11
intrenable: couldn't enable irq 11, tbdf 0xC0EF000 for usbehci
init: starting /bin/rc
ipconfig: no success with DHCP
ndb/dns: can't read my ip address

It takes ages to start rc due to the latter two entries.

I've tried the BIOS in AHCI, but that returns only more errors, so I have it run in IDE compatibility mode again. The hardware works fine together under OpenBSD, so it can't be an incompatibility issue there. I understand that the MP table may be broken, so I'm wondering whether there is a way of fixing it or whether I would just need to update the BIOS 2.14>2.19 (which would mean buying an X6 Ultrabase with optical drive) and the problem would be solved.

On the X60, I can't partition the disk during installation. [partdisk] keeps failing.  Again, mpintrenable has not been very kind to me. As above, it cannot enable irq 11 for usbuhci and iahci and can't seem to recognise the hard drive (sdE0): 

sdE0: retry blk 0
sdE0: retry blk 0
sdE0: retry blk 0
sdE0: retry blk 0
sdE0: retry blk 0
sdE0: bad disk

9fans: 9fans
Permalink: https://9fans.topicbox.com/groups/9fans/Tb5aaf646618a421a-M26b0929a71ed3df775db1000
Delivery options: https://9fans.topicbox.com/groups/9fans/subscription

[-- Attachment #2: Type: text/html, Size: 3330 bytes --]

  reply	other threads:[~2022-01-27 12:47 UTC|newest]

Thread overview: 20+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-01-20 15:31 yakkuliste
2022-01-21  5:52 ` Lucio De Re
2022-01-21 10:34 ` Richard Miller
2022-01-21 11:34   ` yakkuliste via 9fans
2022-01-21 13:20     ` Richard Miller
2022-01-21 13:33     ` yakkuliste via 9fans
2022-01-21 14:01       ` Richard Miller
2022-01-21 16:47         ` Richard Miller
2022-01-21 14:01       ` Thaddeus Woskowiak
2022-01-22 15:31         ` yakkuliste via 9fans
2022-01-22 16:07           ` Thaddeus Woskowiak
2022-01-23  2:17             ` Conor Williams
2022-01-23  8:27             ` Iruatã Souza
2022-01-23 10:43               ` Richard Miller
2022-01-23 14:37                 ` Conor Williams
2022-01-24  3:23                   ` Lucio De Re
2022-01-24  5:46                     ` adr
2022-01-24 10:31                       ` Lucio De Re
2022-01-27 12:47                         ` yakkuliste via 9fans [this message]
2022-01-24  0:59                 ` Thaddeus Woskowiak

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=16432876480.0e2BEb0.274549@composer.9fans.topicbox.com \
    --to=9fans@9fans.net \


* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).