discuss@mandoc.bsd.lv
 help / color / mirror / Atom feed
* Help with setting up man.cgi with nginx
@ 2020-12-10  0:06 Aisha Tammy
  2020-12-10 13:46 ` Ingo Schwarze
  0 siblings, 1 reply; 8+ messages in thread
From: Aisha Tammy @ 2020-12-10  0:06 UTC (permalink / raw)
  To: discuss

[-- Attachment #1: Type: text/plain, Size: 3215 bytes --]

Hi,
I was trying to set up man.cgi to view my manual pages online and
haven't been able to find a lot of documentation for setting it up.
I managed to get the main page to load but its not able to show any
man pages, only the front page.

I am on Gentoo and am using the nginx webserver.

I am  using the fcgiwrap for passing to man.cgi.
As man.cgi wants the /man folder to be present and nginx doesnt have chroot
I had to symlink my /var/www/man to /man (as a temporary work around).

the folder /man contains a single file - manpath.conf with just a single line - system

the /man/system directory contains man1/ man2/ ... folders with the man pages in them.

But when I go to http://localhost , while I can see the main page, clicking on
any of the links man.cgi(8) or apropos(1) just shows the same page.

Can anyone point out what I am missing.

nginx.conf:

user nginx nginx;
worker_processes 1;

error_log /var/log/nginx/error_log info;

events {
	worker_connections 1024;
	use epoll;
}

http {
	include /etc/nginx/mime.types;
	default_type application/octet-stream;

	log_format main
		'$remote_addr - $remote_user [$time_local] '
		'"$request" $status $bytes_sent '
		'"$http_referer" "$http_user_agent" '
		'"$gzip_ratio"';

	client_header_timeout 10m;
	client_body_timeout 10m;
	send_timeout 10m;

	connection_pool_size 256;
	client_header_buffer_size 1k;
	large_client_header_buffers 4 2k;
	request_pool_size 4k;

	gzip off;

	output_buffers 1 32k;
	postpone_output 1460;

	sendfile on;
	tcp_nopush on;
	tcp_nodelay on;

	keepalive_timeout 75 20;

	ignore_invalid_headers on;

        server {
		server_name localhost;
		listen 127.0.0.1;

		location / {
			include fastcgi_params;
			fastcgi_pass 127.0.0.1:12345;
			fastcgi_param  SCRIPT_FILENAME /var/www/cgi-bin/man.cgi;
		}
	}
}



fcgiwrap init script:

#!/sbin/openrc-run

ip="0.0.0.0"
port="12345"

start() {
	ebegin "Starting fcgiwrap process..."
	/usr/sbin/fcgiwrap -s tcp:$ip:$port &
	tcp_sock=`netstat -tulpn | grep fcgiwrap`
	eend $? "Errors were encountered while starting fcgiwrap process"
}

stop() {
	ebegin "Stopping fcgiwrap process..."
	pid=`ps a | grep fcgiwrap | grep tcp | cut -d" " -f1`
	kill -s 1 $pid
	tcp_sock=`netstat -tulpn | grep fcgiwrap`
	if test $tcp_sock =  2> /dev/null ; then
		echo "Fcgiwrap process successfully stoped"
		tcp_sock=`netstat -atulpn | grep $port`
		if test $tcp_sock =  2> /dev/null ; then
			echo "No open fcgiwrap connection found..."
		else
			echo "Wait to close fcgiwrap open connections...please verify with 'status'"
			echo -e "Socket details: \n$tcp_sock"
		fi
	else
		echo "Fcgiwarp process is still running!"
		echo "Socket details: $tcp_sock"
        fi
	eend $? "Errors were encountered while stopping fcgiwrap process..."
}

status() {
	ebegin "Status fcgiwrap process..."
	tcp_sock=`netstat -atulpn | grep $port`
	if test $tcp_sock =  2> /dev/null ; then
		echo "Fcgiwrap process not running"
	else
		echo "Fcgiwarp process is running!"
		echo -e "Socket details: \n$tcp_sock"
	fi
	eend $? "Errors were encountered while stopping fcgiwrap process..."
}




[-- Attachment #2: Type: text/html, Size: 3552 bytes --]

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: Help with setting up man.cgi with nginx
  2020-12-10  0:06 Help with setting up man.cgi with nginx Aisha Tammy
@ 2020-12-10 13:46 ` Ingo Schwarze
  2020-12-10 14:26   ` Aisha Tammy
  0 siblings, 1 reply; 8+ messages in thread
From: Ingo Schwarze @ 2020-12-10 13:46 UTC (permalink / raw)
  To: Aisha Tammy; +Cc: discuss

Hi Aisha,

Aisha Tammy wrote on Wed, Dec 09, 2020 at 07:06:46PM -0500:

> I was trying to set up man.cgi to view my manual pages online and
> haven't been able to find a lot of documentation for setting it up.

Did you look at

  https://man.openbsd.org/man.cgi.8

?

> I managed to get the main page to load but its not able to show any
> man pages, only the front page.

I suggest that you inspect the web server logs.  That is the usual
method for debugging non-working web server setups.

> I am on Gentoo and am using the nginx webserver.

This sounds as if your question might be more related to how nginx
works than to man.cgi(8).  I have very little experience with nginx,
so i fear i won't be able to provide much help for that program.

> I am  using the fcgiwrap for passing to man.cgi.
> As man.cgi wants the /man folder to be present and nginx doesnt have chroot

???

To be honest, running a webserver without chroot in 2020 sounds
rather crazy.

In the design of man.cgi, Kristaps and myself did not even consider
supporting non-chroot setups.  It may or may not work, but i don't
feel like spending time on considering whether it might work, or how.

Just use a chroot, as everybody else does, and be done with it,
i would say...

> I had to symlink my /var/www/man to /man (as a temporary work around).
> 
> the folder /man contains a single file - manpath.conf with just a
> single line - system
> 
> the /man/system directory contains man1/ man2/ ... folders with the
> man pages in them.

That sounds good as far as it goes.

Did you remember to do

  # cd /var/www/man/
  # makewhatis system

after copying the manual pages into the system/man1/ system/man2/ ...
directories?

> But when I go to http://localhost , while I can see the main page, clicking on
> any of the links man.cgi(8) or apropos(1) just shows the same page.
> 
> Can anyone point out what I am missing.
> 
> nginx.conf:

I fear i can't reasonably comment on nginx or fcgiwrap.

Yours,
  Ingo
--
 To unsubscribe send an email to discuss+unsubscribe@mandoc.bsd.lv


^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: Help with setting up man.cgi with nginx
  2020-12-10 13:46 ` Ingo Schwarze
@ 2020-12-10 14:26   ` Aisha Tammy
  2020-12-10 15:01     ` Ingo Schwarze
  0 siblings, 1 reply; 8+ messages in thread
From: Aisha Tammy @ 2020-12-10 14:26 UTC (permalink / raw)
  To: discuss

[-- Attachment #1: Type: text/plain, Size: 1728 bytes --]

I finally got it working *cries in lost sanity*...

Turns out I (or nginx or whatever) was not passing the PATH_INFO fastcgi parameter.
Obscure chases through the internet led me to the final nginx.conf
configuration which finally made it work...
Please don't ask me on how this works, it's dangerous forbidden dark arts
of nginx magic. This was my first ever use of nginx, all my other thingies
are on obsd httpd.

Now to see how to work a chroot with nginx and fcgiwrap. #nginx irc users told me that this
is stupid and that this is an OS thing and not an application thing -.- , so that was fun.

Aisha

user nginx nginx;
worker_processes 1;

error_log /var/log/nginx/error_log info;

events {
	worker_connections 1024;
	use epoll;
}

http {
	include /etc/nginx/mime.types;
	default_type application/octet-stream;

	log_format main
		'$remote_addr - $remote_user [$time_local] '
		'"$request" $status $bytes_sent '
		'"$http_referer" "$http_user_agent" '
		'"$gzip_ratio"';

	client_header_timeout 10m;
	client_body_timeout 10m;
	send_timeout 10m;

	connection_pool_size 256;
	client_header_buffer_size 1k;
	large_client_header_buffers 4 2k;
	request_pool_size 4k;

	gzip off;

	output_buffers 1 32k;
	postpone_output 1460;

	sendfile on;
	tcp_nopush on;
	tcp_nodelay on;

	keepalive_timeout 75 20;

	ignore_invalid_headers on;

        server {
		server_name localhost;
		listen 0.0.0.0;
		listen [::];

		location ~ / {
			fastcgi_split_path_info ^(/cgi\-bin/man\.cgi/)(.+)$;
			include fastcgi_params;
			fastcgi_pass 127.0.0.1:12345;
			fastcgi_param SCRIPT_FILENAME /var/www/cgi-bin/man.cgi;
			fastcgi_param PATH_INFO $fastcgi_path_info;
		}
	}
}


[-- Attachment #2: Type: text/html, Size: 1929 bytes --]

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: Help with setting up man.cgi with nginx
  2020-12-10 14:26   ` Aisha Tammy
@ 2020-12-10 15:01     ` Ingo Schwarze
  2020-12-10 15:26       ` Aisha Tammy
                         ` (2 more replies)
  0 siblings, 3 replies; 8+ messages in thread
From: Ingo Schwarze @ 2020-12-10 15:01 UTC (permalink / raw)
  To: Aisha Tammy; +Cc: discuss

Hi Aisha,

Aisha Tammy wrote on Thu, Dec 10, 2020 at 09:26:36AM -0500:

> I finally got it working *cries in lost sanity*...
> 
> Turns out I (or nginx or whatever) was not passing the PATH_INFO
> fastcgi parameter.

Oh, that does indeed explain why you always got the start page and
the two links on the start page only brought you back to the start
page.

So, are you saying that with your new configuration,

  http://localhost/ls.1

and the like now work as expected?

If so, does

  http://localhost/?query=ls

work, too?  If not, i suspect you may need to pass QUERY_STRING
in the same way as you pass PATH_INFO, see

  https://man.openbsd.org/man.cgi.8#ENVIRONMENT

for details.  If it already works right now, then maybe nginx passes
QUERY_STRING by default - though i don't quite see why it would
pass QUERY_STRING by default but not PATH_INFO.  That would feel
like an odd choice of defaults to me.

> Obscure chases through the internet led me to the final nginx.conf
> configuration which finally made it work...
> Please don't ask me on how this works, it's dangerous forbidden dark arts
> of nginx magic.

Don't worry, i won't ask.  :-)

(But do consider that running a webserver on the Internet with a
 configuration you don't understand is seriously dangerous.
 So you should ask yourself how your server works, until you
 understand it, or use something else that you do understand.)

> This was my first ever use of nginx, all my other thingies
> are on obsd httpd.
> 
> Now to see how to work a chroot with nginx and fcgiwrap.
> #nginx irc users told me that this is stupid

What is stupid?  Running man.cgi(8) at all?  Or running it on Linux?
or running it on nginx?  Or ...?

> and that this is an OS thing and not an application thing -.-

Which aspect of all this is an OS thing, and what does "an application
thing" mean?  I don't think i understand what you are tryong to say
with this sentence.

> , so that was fun.

In that case, enjoy!  ;-/
  Ingo
--
 To unsubscribe send an email to discuss+unsubscribe@mandoc.bsd.lv


^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: Help with setting up man.cgi with nginx
  2020-12-10 15:01     ` Ingo Schwarze
@ 2020-12-10 15:26       ` Aisha Tammy
  2020-12-10 15:26       ` Aisha Tammy
  2020-12-16  3:28       ` Stephen Gregoratto
  2 siblings, 0 replies; 8+ messages in thread
From: Aisha Tammy @ 2020-12-10 15:26 UTC (permalink / raw)
  To: discuss



On 12/10/20 10:01 AM, Ingo Schwarze wrote:
> Hi Aisha,
> 
> Aisha Tammy wrote on Thu, Dec 10, 2020 at 09:26:36AM -0500:
> 
>> I finally got it working *cries in lost sanity*...
>>
>> Turns out I (or nginx or whatever) was not passing the PATH_INFO
>> fastcgi parameter.
> 
> Oh, that does indeed explain why you always got the start page and
> the two links on the start page only brought you back to the start
> page.
> 
> So, are you saying that with your new configuration,
> 
>   http://localhost/ls.1
> 
> and the like now work as expected?
> 
> If so, does
> 
>   http://localhost/?query=ls
> 
> work, too?  If not, i suspect you may need to pass QUERY_STRING
> in the same way as you pass PATH_INFO, see
> 
>   https://man.openbsd.org/man.cgi.8#ENVIRONMENT
> 
> for details.  If it already works right now, then maybe nginx passes
> QUERY_STRING by default - though i don't quite see why it would
> pass QUERY_STRING by default but not PATH_INFO.  That would feel
> like an odd choice of defaults to me.

The default 'fastcgi_params' file, used in 'include fastcgi_params;' 
contains QUERY_STRING but no PATH_INFO :-\ ...
Which explains this behaviour (indeed odd choice of defaults).

> 
>> Obscure chases through the internet led me to the final nginx.conf
>> configuration which finally made it work...
>> Please don't ask me on how this works, it's dangerous forbidden dark arts
>> of nginx magic.
> 
> Don't worry, i won't ask.  :-)
> 
> (But do consider that running a webserver on the Internet with a
>  configuration you don't understand is seriously dangerous.
>  So you should ask yourself how your server works, until you
>  understand it, or use something else that you do understand.)
> 
Ah, now worries on that front, this is for my local benefit.
I don't like spending all my time in the terminal :)

>> This was my first ever use of nginx, all my other thingies
>> are on obsd httpd.
>>
>> Now to see how to work a chroot with nginx and fcgiwrap.
>> #nginx irc users told me that this is stupid
> 
> What is stupid?  Running man.cgi(8) at all?  Or running it on Linux?
> or running it on nginx?  Or ...?

That having nginx do chroot is stupid... Apparently it should
be done by the sysadmin, before running nginx. 

> 
>> and that this is an OS thing and not an application thing -.-
> 
> Which aspect of all this is an OS thing, and what does "an application
> thing" mean?  I don't think i understand what you are tryong to say
> with this sentence.
As above, in their opinion chroot should be an os thing, it is not 
supposed to be done by nginx, which sounds very weird considering
that (i think) openbsd  had patched nginx (at some point in history) 
to support chroot. Not to mention that lighttpd, httpd, uwsgi (and
a lot of other web service things) support changing chroot....

Well, user opinions on IRC are not to be counted, no matter how popularly

held that belief is.



So my current plan is to shift to lighttpd + uwsgi (for fcgiwrap), as
both support chroot options (maybe useful for others who read this thread
in the future).

> 
>> , so that was fun.
> 
> In that case, enjoy!  ;-/
>   Ingo
> --
>  To unsubscribe send an email to discuss+unsubscribe@mandoc.bsd.lv
> 
--
 To unsubscribe send an email to discuss+unsubscribe@mandoc.bsd.lv


^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: Help with setting up man.cgi with nginx
  2020-12-10 15:01     ` Ingo Schwarze
  2020-12-10 15:26       ` Aisha Tammy
@ 2020-12-10 15:26       ` Aisha Tammy
  2020-12-16  3:28       ` Stephen Gregoratto
  2 siblings, 0 replies; 8+ messages in thread
From: Aisha Tammy @ 2020-12-10 15:26 UTC (permalink / raw)
  To: discuss



On 12/10/20 10:01 AM, Ingo Schwarze wrote:
> Hi Aisha,
> 
> Aisha Tammy wrote on Thu, Dec 10, 2020 at 09:26:36AM -0500:
> 
>> I finally got it working *cries in lost sanity*...
>>
>> Turns out I (or nginx or whatever) was not passing the PATH_INFO
>> fastcgi parameter.
> 
> Oh, that does indeed explain why you always got the start page and
> the two links on the start page only brought you back to the start
> page.
> 
> So, are you saying that with your new configuration,
> 
>   http://localhost/ls.1
> 
> and the like now work as expected?
> 
> If so, does
> 
>   http://localhost/?query=ls
> 
> work, too?  If not, i suspect you may need to pass QUERY_STRING
> in the same way as you pass PATH_INFO, see
> 
>   https://man.openbsd.org/man.cgi.8#ENVIRONMENT
> 
> for details.  If it already works right now, then maybe nginx passes
> QUERY_STRING by default - though i don't quite see why it would
> pass QUERY_STRING by default but not PATH_INFO.  That would feel
> like an odd choice of defaults to me.

The default 'fastcgi_params' file, used in 'include fastcgi_params;' 
contains QUERY_STRING but no PATH_INFO :-\ ...
Which explains this behaviour (indeed odd choice of defaults).

> 
>> Obscure chases through the internet led me to the final nginx.conf
>> configuration which finally made it work...
>> Please don't ask me on how this works, it's dangerous forbidden dark arts
>> of nginx magic.
> 
> Don't worry, i won't ask.  :-)
> 
> (But do consider that running a webserver on the Internet with a
>  configuration you don't understand is seriously dangerous.
>  So you should ask yourself how your server works, until you
>  understand it, or use something else that you do understand.)
> 
Ah, now worries on that front, this is for my local benefit.
I don't like spending all my time in the terminal :)

>> This was my first ever use of nginx, all my other thingies
>> are on obsd httpd.
>>
>> Now to see how to work a chroot with nginx and fcgiwrap.
>> #nginx irc users told me that this is stupid
> 
> What is stupid?  Running man.cgi(8) at all?  Or running it on Linux?
> or running it on nginx?  Or ...?

That having nginx do chroot is stupid... Apparently it should
be done by the sysadmin, before running nginx. 

> 
>> and that this is an OS thing and not an application thing -.-
> 
> Which aspect of all this is an OS thing, and what does "an application
> thing" mean?  I don't think i understand what you are tryong to say
> with this sentence.
As above, in their opinion chroot should be an os thing, it is not 
supposed to be done by nginx, which sounds very weird considering
that (i think) openbsd  had patched nginx (at some point in history) 
to support chroot. Not to mention that lighttpd, httpd, uwsgi (and
a lot of other web service things) support changing chroot....

Well, user opinions on IRC are not to be counted, no matter how popularly

held that belief is.



So my current plan is to shift to lighttpd + uwsgi (for fcgiwrap), as
both support chroot options (maybe useful for others who read this thread
in the future).

Cheers,
Aisha

> 
>> , so that was fun.
> 
> In that case, enjoy!  ;-/
>   Ingo
> --
>  To unsubscribe send an email to discuss+unsubscribe@mandoc.bsd.lv
> 
--
 To unsubscribe send an email to discuss+unsubscribe@mandoc.bsd.lv


^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: Help with setting up man.cgi with nginx
  2020-12-10 15:01     ` Ingo Schwarze
  2020-12-10 15:26       ` Aisha Tammy
  2020-12-10 15:26       ` Aisha Tammy
@ 2020-12-16  3:28       ` Stephen Gregoratto
  2020-12-16  4:51         ` Aisha Tammy
  2 siblings, 1 reply; 8+ messages in thread
From: Stephen Gregoratto @ 2020-12-16  3:28 UTC (permalink / raw)
  To: discuss; +Cc: Aisha Tammy

Hi Aisha,

Here is what I use for man.sgregoratto.me, which I cribbed from the Void
Linux Project:

  server {
    listen 80;
    listen [::]:80;
    server_name man.sgregoratto.me;
    include /etc/nginx/templates/acme-client.tmpl;
    return 302 https://$host$request_uri;
  }

  server {
    listen 443 ssl http2;
    listen [::]:443 ssl http2;
    server_name man.sgregoratto.me;

    location = /mandoc.css {
	root /var/www/htdocs;
    }
    location /  {
      gzip off;
      fastcgi_split_path_info ^(/)(.*)$;

      fastcgi_param 	QUERY_STRING	$query_string;
      fastcgi_param	REQUEST_METHOD	$request_method;
      fastcgi_param	PATH_INFO	$fastcgi_path_info;
      fastcgi_param	SCRIPT_FILENAME	/cgi-bin/man.cgi;
      fastcgi_pass	unix:/run/slowcgi.sock;
    }

    ssl_certificate /etc/ssl/man.sgregoratto.me.pem;
    ssl_certificate_key /etc/ssl/private/man.sgregoratto.me.key;
    ssl_stapling_file /etc/ssl/man.sgregoratto.me.der;
    include /etc/nginx/templates/*.tmpl;
  }

The templates are things like setting headers, OCSP stapling and ACME
challenge stuff. This setup allows all requests to go to the root of the
domain, similar to man.openbsd.org. Speaking of, here's a similar config
for httpd that I got from Ingo a while back:

  server "man.sgregoratto.me" {
    listen on * port 80
    location "/.well-known/acme-challenge/*" {
      root "/acme"
      request strip 2
    }
    location * {
      block return 302 "https://$SERVER_NAME$REQUEST_URI"
    }
  }
  server "man.sgregoratto.me" {
    listen on * tls port 443
    hsts max-age 31536000
    root "/htdocs"

    tls {
      certificate "/etc/ssl/man.sgregoratto.me.pem"
      key "/etc/ssl/private/man.sgregoratto.me.key"
      ocsp "/etc/ssl/man.sgregoratto.me.der"
    }
    location "/.well-known/acme-challenge/*" {
      root "/acme"
      request strip 2
      pass
    }
    location "/mandoc.css" {
      root "/htdocs"
    }
    location "*" {
      fastcgi
      root "/cgi-bin/man.cgi"
    }
  }
-- 
Stephen Gregoratto
--
 To unsubscribe send an email to discuss+unsubscribe@mandoc.bsd.lv


^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: Help with setting up man.cgi with nginx
  2020-12-16  3:28       ` Stephen Gregoratto
@ 2020-12-16  4:51         ` Aisha Tammy
  0 siblings, 0 replies; 8+ messages in thread
From: Aisha Tammy @ 2020-12-16  4:51 UTC (permalink / raw)
  To: discuss


On 12/15/20 10:28 PM, Stephen Gregoratto wrote:
> Hi Aisha,
> 
> Here is what I use for man.sgregoratto.me, which I cribbed from the Void
> Linux Project:
> 
>   server {
>     listen 80;
>     listen [::]:80;
>     server_name man.sgregoratto.me;
>     include /etc/nginx/templates/acme-client.tmpl;
>     return 302 https://$host$request_uri;
>   }
> 
>   server {
>     listen 443 ssl http2;
>     listen [::]:443 ssl http2;
>     server_name man.sgregoratto.me;
> 
>     location = /mandoc.css {
> 	root /var/www/htdocs;
>     }
>     location /  {
>       gzip off;
>       fastcgi_split_path_info ^(/)(.*)$;
> 
>       fastcgi_param 	QUERY_STRING	$query_string;
>       fastcgi_param	REQUEST_METHOD	$request_method;
>       fastcgi_param	PATH_INFO	$fastcgi_path_info;
>       fastcgi_param	SCRIPT_FILENAME	/cgi-bin/man.cgi;
>       fastcgi_pass	unix:/run/slowcgi.sock;
>     }
> 
>     ssl_certificate /etc/ssl/man.sgregoratto.me.pem;
>     ssl_certificate_key /etc/ssl/private/man.sgregoratto.me.key;
>     ssl_stapling_file /etc/ssl/man.sgregoratto.me.der;
>     include /etc/nginx/templates/*.tmpl;
>   }
> 
> The templates are things like setting headers, OCSP stapling and ACME
> challenge stuff. This setup allows all requests to go to the root of the
> domain, similar to man.openbsd.org. Speaking of, here's a similar config
> for httpd that I got from Ingo a while back:
> 
>   server "man.sgregoratto.me" {
>     listen on * port 80
>     location "/.well-known/acme-challenge/*" {
>       root "/acme"
>       request strip 2
>     }
>     location * {
>       block return 302 "https://$SERVER_NAME$REQUEST_URI"
>     }
>   }
>   server "man.sgregoratto.me" {
>     listen on * tls port 443
>     hsts max-age 31536000
>     root "/htdocs"
> 
>     tls {
>       certificate "/etc/ssl/man.sgregoratto.me.pem"
>       key "/etc/ssl/private/man.sgregoratto.me.key"
>       ocsp "/etc/ssl/man.sgregoratto.me.der"
>     }
>     location "/.well-known/acme-challenge/*" {
>       root "/acme"
>       request strip 2
>       pass
>     }
>     location "/mandoc.css" {
>       root "/htdocs"
>     }
>     location "*" {
>       fastcgi
>       root "/cgi-bin/man.cgi"
>     }
>   }
> 


!!!! Thanks a lot, I really appreciate it :D

Cheers,
Aisha
--
 To unsubscribe send an email to discuss+unsubscribe@mandoc.bsd.lv


^ permalink raw reply	[flat|nested] 8+ messages in thread

end of thread, other threads:[~2020-12-16  4:51 UTC | newest]

Thread overview: 8+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-12-10  0:06 Help with setting up man.cgi with nginx Aisha Tammy
2020-12-10 13:46 ` Ingo Schwarze
2020-12-10 14:26   ` Aisha Tammy
2020-12-10 15:01     ` Ingo Schwarze
2020-12-10 15:26       ` Aisha Tammy
2020-12-10 15:26       ` Aisha Tammy
2020-12-16  3:28       ` Stephen Gregoratto
2020-12-16  4:51         ` Aisha Tammy

discuss@mandoc.bsd.lv

This inbox may be cloned and mirrored by anyone:

	git clone --mirror http://inbox.vuxu.org/mandoc-discuss

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V1 mandoc-discuss mandoc-discuss/ http://inbox.vuxu.org/mandoc-discuss \
		discuss@mandoc.bsd.lv
	public-inbox-index mandoc-discuss

Example config snippet for mirrors.
Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.archive.mandoc.discuss


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git