Github messages for voidlinux
 help / color / Atom feed
* [PR PATCH] [NOMERGE] libGL: update to 19.2.0
@ 2019-10-09 12:34 voidlinux-github
  2019-10-09 20:27 ` [PR PATCH] [Updated] " voidlinux-github
                   ` (4 more replies)
  0 siblings, 5 replies; 6+ messages in thread
From: voidlinux-github @ 2019-10-09 12:34 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 615 bytes --]

There is a new pull request by st3r4g against master on the void-packages repository

https://github.com/st3r4g/void-packages mesa-19.2
https://github.com/void-linux/void-packages/pull/15276

[NOMERGE] libGL: update to 19.2.0
In preparation of the stable release (Mesa 19.2.1)
Upstream changes that required modifications in the patches:

- `GLX_USE_TLS` was renamed into `USE_ELF_TLS`
- `3fd21a6b776e0f874e0e14d9943ac2b06bcc4aad` was merged
- `__GNU_LIBRARY__` checks were removed from `nine_debug.c` and `u_thread.c`

A patch file from https://github.com/void-linux/void-packages/pull/15276.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-mesa-19.2-15276.patch --]
[-- Type: text/x-diff, Size: 8247 bytes --]

From a279a685e9a27d38d36135befbfcb6b2f13e43d4 Mon Sep 17 00:00:00 2001
From: Stefano Ragni <st3r4g@protonmail.com>
Date: Wed, 9 Oct 2019 14:16:00 +0200
Subject: [PATCH] libGL: update to 19.2.0

---
 ...1a6b776e0f874e0e14d9943ac2b06bcc4aad.patch | 26 ----------
 srcpkgs/libGL/patches/add-glx-use-tls.patch   | 47 -------------------
 srcpkgs/libGL/patches/add-use-elf-tls.patch   | 28 +++++++++++
 srcpkgs/libGL/patches/musl.patch              | 40 +---------------
 srcpkgs/libGL/template                        |  8 ++--
 5 files changed, 33 insertions(+), 116 deletions(-)
 delete mode 100644 srcpkgs/libGL/patches/3fd21a6b776e0f874e0e14d9943ac2b06bcc4aad.patch
 delete mode 100644 srcpkgs/libGL/patches/add-glx-use-tls.patch
 create mode 100644 srcpkgs/libGL/patches/add-use-elf-tls.patch

diff --git a/srcpkgs/libGL/patches/3fd21a6b776e0f874e0e14d9943ac2b06bcc4aad.patch b/srcpkgs/libGL/patches/3fd21a6b776e0f874e0e14d9943ac2b06bcc4aad.patch
deleted file mode 100644
index d0db64c76e0..00000000000
--- a/srcpkgs/libGL/patches/3fd21a6b776e0f874e0e14d9943ac2b06bcc4aad.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 3fd21a6b776e0f874e0e14d9943ac2b06bcc4aad Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Michel=20D=C3=A4nzer?= <michel.daenzer@amd.com>
-Date: Fri, 28 Jun 2019 11:07:39 +0200
-Subject: [PATCH] targets/opencl: Add clangASTMatchers library as dependency
-
-Fixes link failure since clang r364424 "[clang/DIVar] Emit the flag for
-params that have unmodified value", clangCodeGen depends on
-clangASTMatchers now.
-
-Reviewed-by: Dylan Baker <dylan@pnwbakers.com>
----
- src/gallium/targets/opencl/meson.build | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/gallium/targets/opencl/meson.build b/src/gallium/targets/opencl/meson.build
-index 317ad8dab4a..650a2054cfb 100644
---- src/gallium/targets/opencl/meson.build
-+++ src/gallium/targets/opencl/meson.build
-@@ -51,6 +51,7 @@ libopencl = shared_library(
-     cpp.find_library('clangSema', dirs : llvm_libdir),
-     cpp.find_library('clangAnalysis', dirs : llvm_libdir),
-     cpp.find_library('clangAST', dirs : llvm_libdir),
-+    cpp.find_library('clangASTMatchers', dirs : llvm_libdir),
-     cpp.find_library('clangEdit', dirs : llvm_libdir),
-     cpp.find_library('clangLex', dirs : llvm_libdir),
-     cpp.find_library('clangBasic', dirs : llvm_libdir),
diff --git a/srcpkgs/libGL/patches/add-glx-use-tls.patch b/srcpkgs/libGL/patches/add-glx-use-tls.patch
deleted file mode 100644
index 7ded1a1b2ee..00000000000
--- a/srcpkgs/libGL/patches/add-glx-use-tls.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-From f895a39b7437381a86383dd97250aa2cc7393bff Mon Sep 17 00:00:00 2001
-From: maxice8 <thinkabit.ukim@gmail.com>
-Date: Thu, 9 Aug 2018 18:37:30 -0300
-Subject: [PATCH] meson: add glx-use-tls option.
-
----
- meson.build       | 6 +++++-
- meson_options.txt | 6 ++++++
- 2 files changed, 11 insertions(+), 1 deletion(-)
-
-diff --git a/meson.build b/meson.build
-index 5dbb786..1ab3092 100644
---- meson.build
-+++ meson.build
-@@ -340,7 +340,11 @@ if with_egl and not (with_platform_drm or with_platform_surfaceless)
-   endif
- endif
- 
--pre_args += '-DGLX_USE_TLS'
-+with_glx_use_tls = get_option('glx-use-tls')
-+if with_glx_use_tls
-+  pre_args += '-DGLX_USE_TLS'
-+endif
-+
- if with_glx != 'disabled'
-   if not (with_platform_x11 and with_any_opengl)
-     if with_glx == 'auto'
-diff --git a/meson_options.txt b/meson_options.txt
-index 496fe38..12981dd 100644
---- meson_options.txt
-+++ meson_options.txt
-@@ -195,6 +195,12 @@ option(
-   choices : ['auto', 'disabled', 'dri', 'xlib', 'gallium-xlib'],
-   description : 'Build support for GLX platform'
- )
-+option(
-+  'glx-use-tls',
-+  type : 'boolean',
-+  value : true,
-+  description : 'Build support for initial-exec TLS model on GLX platform'
-+)
- option(
-   'egl',
-   type : 'combo',
--- 
-2.18.0
-
diff --git a/srcpkgs/libGL/patches/add-use-elf-tls.patch b/srcpkgs/libGL/patches/add-use-elf-tls.patch
new file mode 100644
index 00000000000..b922d8601e7
--- /dev/null
+++ b/srcpkgs/libGL/patches/add-use-elf-tls.patch
@@ -0,0 +1,28 @@
+diff --git meson.build meson.build
+index 4afd8ca..ab9b365 100644
+--- meson.build
++++ meson.build
+@@ -378,7 +378,8 @@ if with_egl and not (with_platform_drm or with_platform_surfaceless or with_plat
+ endif
+ 
+ # Android uses emutls for versions <= P/28. For USE_ELF_TLS we need ELF TLS.
+-if not with_platform_android or get_option('platform-sdk-version') >= 29
++with_use_elf_tls = get_option('use-elf-tls')
++if with_use_elf_tls and not with_platform_android or get_option('platform-sdk-version') >= 29
+   pre_args += '-DUSE_ELF_TLS'
+ endif
+ 
+diff --git meson_options.txt meson_options.txt
+index b768c15..2533220 100644
+--- meson_options.txt
++++ meson_options.txt
+@@ -358,3 +358,9 @@ option(
+   value : 25,
+   description : 'Android Platform SDK version. Default: Nougat version.'
+ )
++option(
++  'use-elf-tls',
++  type : 'boolean',
++  value : true,
++  description : 'Build support for initial-exec TLS model'
++)
diff --git a/srcpkgs/libGL/patches/musl.patch b/srcpkgs/libGL/patches/musl.patch
index dc71d18c3d8..92a37bd577c 100644
--- a/srcpkgs/libGL/patches/musl.patch
+++ b/srcpkgs/libGL/patches/musl.patch
@@ -32,44 +32,6 @@
  #include <unistd.h>
  #include <fcntl.h>
  #else
---- src/gallium/state_trackers/nine/nine_debug.c
-+++ src/gallium/state_trackers/nine/nine_debug.c
-@@ -73,8 +73,8 @@
-     }
- 
- #if defined(HAVE_PTHREAD)
--#  if defined(__GNU_LIBRARY__) && defined(__GLIBC__) && defined(__GLIBC_MINOR__) && \
--      (__GLIBC__ >= 3 || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 12))
-+#  if defined(__linux__) && !(defined(__GLIBC__) || \
-+      (__GLIBC__ < 3 || (__GLIBC__ == 2 && __GLIBC_MINOR__ < 12)))
-     if (dbg_flags & DBG_TID)
-         tid = pthread_self();
- #  endif
---- src/util/u_thread.h
-+++ src/util/u_thread.h
-@@ -61,9 +61,8 @@
- static inline void u_thread_setname( const char *name )
- {
- #if defined(HAVE_PTHREAD)
--#  if defined(__GNU_LIBRARY__) && defined(__GLIBC__) && defined(__GLIBC_MINOR__) && \
--      (__GLIBC__ >= 3 || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 12)) && \
--      defined(__linux__)
-+#  if defined(__linux__) && !(defined(__GLIBC__) || \
-+      (__GLIBC__ < 3 || (__GLIBC__ == 2 && __GLIBC_MINOR__ < 12)))
-    pthread_setname_np(pthread_self(), name);
- #  endif
- #endif
-@@ -93,8 +92,8 @@
- static inline bool u_thread_is_self(thrd_t thread)
- {
- #if defined(HAVE_PTHREAD)
--#  if defined(__GNU_LIBRARY__) && defined(__GLIBC__) && defined(__GLIBC_MINOR__) && \
--      (__GLIBC__ >= 3 || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 12))
-+#  if defined(__linux__) && !(defined(__GLIBC__) || \
-+      (__GLIBC__ < 3 || (__GLIBC__ == 2 && __GLIBC_MINOR__ < 12)))
-    return pthread_equal(pthread_self(), thread);
- #  endif
- #endif
 --- src/amd/vulkan/winsys/amdgpu/radv_amdgpu_winsys.h
 +++ src/amd/vulkan/winsys/amdgpu/radv_amdgpu_winsys.h
 @@ -28,6 +28,8 @@
@@ -80,4 +42,4 @@
 +
  #include "radv_radeon_winsys.h"
  #include "ac_gpu_info.h"
- #include "addrlib/addrinterface.h"<Paste>
+ #include "addrlib/addrinterface.h"
diff --git a/srcpkgs/libGL/template b/srcpkgs/libGL/template
index e1a20f31347..65e1791292b 100644
--- a/srcpkgs/libGL/template
+++ b/srcpkgs/libGL/template
@@ -1,7 +1,7 @@
 # Template file for 'libGL'
 pkgname=libGL
-version=19.1.7
-revision=3
+version=19.2.0
+revision=1
 wrksrc="mesa-${version}"
 build_style=meson
 configure_args="-Dshared-glapi=true -Dgbm=true -Degl=true
@@ -21,7 +21,7 @@ license="MIT, LGPL-2.1-or-later"
 homepage="https://www.mesa3d.org/"
 changelog="https://www.mesa3d.org/relnotes/${version}.html"
 distfiles="https://mesa.freedesktop.org/archive/mesa-${version}.tar.xz"
-checksum=e287920fdb38712a9fed448dc90b3ca95048c7face5db52e58361f8b6e0f3cd5
+checksum=b060caa2a00f856431160ff7377d0e8f58f2aa48c16ee5a9e265ebdccb10852a
 
 # Set subpackages manually to set proper rdeps in 32bit pkgs.
 subpackages="libglapi libgbm libEGL libGLES libOSMesa"
@@ -95,7 +95,7 @@ esac
 
 case "$XBPS_TARGET_MACHINE" in
 	# Disable TLS with musl: https://bugs.freedesktop.org/show_bug.cgi?id=35268
-	*-musl) configure_args+=" -Dglx-use-tls=false";;
+	*-musl) configure_args+=" -Duse-elf-tls=false";;
 	*) configure_args+=" -Dglx=dri";;
 esac
 

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PR PATCH] [Updated] [NOMERGE] libGL: update to 19.2.0
  2019-10-09 12:34 [PR PATCH] [NOMERGE] libGL: update to 19.2.0 voidlinux-github
  2019-10-09 20:27 ` [PR PATCH] [Updated] " voidlinux-github
@ 2019-10-09 20:27 ` voidlinux-github
  2019-10-09 20:32 ` libGL: update to 19.2.1 voidlinux-github
                   ` (2 subsequent siblings)
  4 siblings, 0 replies; 6+ messages in thread
From: voidlinux-github @ 2019-10-09 20:27 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 621 bytes --]

There is an updated pull request by st3r4g against master on the void-packages repository

https://github.com/st3r4g/void-packages mesa-19.2
https://github.com/void-linux/void-packages/pull/15276

[NOMERGE] libGL: update to 19.2.0
In preparation for the stable release (Mesa 19.2.1)
Upstream changes that required modifications in the patches:

- `GLX_USE_TLS` was renamed into `USE_ELF_TLS`
- `3fd21a6b776e0f874e0e14d9943ac2b06bcc4aad` was merged
- `__GNU_LIBRARY__` checks were removed from `nine_debug.c` and `u_thread.c`

A patch file from https://github.com/void-linux/void-packages/pull/15276.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-mesa-19.2-15276.patch --]
[-- Type: text/x-diff, Size: 8247 bytes --]

From 52c3c81fb2c2fe9dc665ab586c8988af038fc7c6 Mon Sep 17 00:00:00 2001
From: Stefano Ragni <st3r4g@protonmail.com>
Date: Wed, 9 Oct 2019 14:16:00 +0200
Subject: [PATCH] libGL: update to 19.2.1

---
 ...1a6b776e0f874e0e14d9943ac2b06bcc4aad.patch | 26 ----------
 srcpkgs/libGL/patches/add-glx-use-tls.patch   | 47 -------------------
 srcpkgs/libGL/patches/add-use-elf-tls.patch   | 28 +++++++++++
 srcpkgs/libGL/patches/musl.patch              | 40 +---------------
 srcpkgs/libGL/template                        |  8 ++--
 5 files changed, 33 insertions(+), 116 deletions(-)
 delete mode 100644 srcpkgs/libGL/patches/3fd21a6b776e0f874e0e14d9943ac2b06bcc4aad.patch
 delete mode 100644 srcpkgs/libGL/patches/add-glx-use-tls.patch
 create mode 100644 srcpkgs/libGL/patches/add-use-elf-tls.patch

diff --git a/srcpkgs/libGL/patches/3fd21a6b776e0f874e0e14d9943ac2b06bcc4aad.patch b/srcpkgs/libGL/patches/3fd21a6b776e0f874e0e14d9943ac2b06bcc4aad.patch
deleted file mode 100644
index d0db64c76e0..00000000000
--- a/srcpkgs/libGL/patches/3fd21a6b776e0f874e0e14d9943ac2b06bcc4aad.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 3fd21a6b776e0f874e0e14d9943ac2b06bcc4aad Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Michel=20D=C3=A4nzer?= <michel.daenzer@amd.com>
-Date: Fri, 28 Jun 2019 11:07:39 +0200
-Subject: [PATCH] targets/opencl: Add clangASTMatchers library as dependency
-
-Fixes link failure since clang r364424 "[clang/DIVar] Emit the flag for
-params that have unmodified value", clangCodeGen depends on
-clangASTMatchers now.
-
-Reviewed-by: Dylan Baker <dylan@pnwbakers.com>
----
- src/gallium/targets/opencl/meson.build | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/gallium/targets/opencl/meson.build b/src/gallium/targets/opencl/meson.build
-index 317ad8dab4a..650a2054cfb 100644
---- src/gallium/targets/opencl/meson.build
-+++ src/gallium/targets/opencl/meson.build
-@@ -51,6 +51,7 @@ libopencl = shared_library(
-     cpp.find_library('clangSema', dirs : llvm_libdir),
-     cpp.find_library('clangAnalysis', dirs : llvm_libdir),
-     cpp.find_library('clangAST', dirs : llvm_libdir),
-+    cpp.find_library('clangASTMatchers', dirs : llvm_libdir),
-     cpp.find_library('clangEdit', dirs : llvm_libdir),
-     cpp.find_library('clangLex', dirs : llvm_libdir),
-     cpp.find_library('clangBasic', dirs : llvm_libdir),
diff --git a/srcpkgs/libGL/patches/add-glx-use-tls.patch b/srcpkgs/libGL/patches/add-glx-use-tls.patch
deleted file mode 100644
index 7ded1a1b2ee..00000000000
--- a/srcpkgs/libGL/patches/add-glx-use-tls.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-From f895a39b7437381a86383dd97250aa2cc7393bff Mon Sep 17 00:00:00 2001
-From: maxice8 <thinkabit.ukim@gmail.com>
-Date: Thu, 9 Aug 2018 18:37:30 -0300
-Subject: [PATCH] meson: add glx-use-tls option.
-
----
- meson.build       | 6 +++++-
- meson_options.txt | 6 ++++++
- 2 files changed, 11 insertions(+), 1 deletion(-)
-
-diff --git a/meson.build b/meson.build
-index 5dbb786..1ab3092 100644
---- meson.build
-+++ meson.build
-@@ -340,7 +340,11 @@ if with_egl and not (with_platform_drm or with_platform_surfaceless)
-   endif
- endif
- 
--pre_args += '-DGLX_USE_TLS'
-+with_glx_use_tls = get_option('glx-use-tls')
-+if with_glx_use_tls
-+  pre_args += '-DGLX_USE_TLS'
-+endif
-+
- if with_glx != 'disabled'
-   if not (with_platform_x11 and with_any_opengl)
-     if with_glx == 'auto'
-diff --git a/meson_options.txt b/meson_options.txt
-index 496fe38..12981dd 100644
---- meson_options.txt
-+++ meson_options.txt
-@@ -195,6 +195,12 @@ option(
-   choices : ['auto', 'disabled', 'dri', 'xlib', 'gallium-xlib'],
-   description : 'Build support for GLX platform'
- )
-+option(
-+  'glx-use-tls',
-+  type : 'boolean',
-+  value : true,
-+  description : 'Build support for initial-exec TLS model on GLX platform'
-+)
- option(
-   'egl',
-   type : 'combo',
--- 
-2.18.0
-
diff --git a/srcpkgs/libGL/patches/add-use-elf-tls.patch b/srcpkgs/libGL/patches/add-use-elf-tls.patch
new file mode 100644
index 00000000000..b922d8601e7
--- /dev/null
+++ b/srcpkgs/libGL/patches/add-use-elf-tls.patch
@@ -0,0 +1,28 @@
+diff --git meson.build meson.build
+index 4afd8ca..ab9b365 100644
+--- meson.build
++++ meson.build
+@@ -378,7 +378,8 @@ if with_egl and not (with_platform_drm or with_platform_surfaceless or with_plat
+ endif
+ 
+ # Android uses emutls for versions <= P/28. For USE_ELF_TLS we need ELF TLS.
+-if not with_platform_android or get_option('platform-sdk-version') >= 29
++with_use_elf_tls = get_option('use-elf-tls')
++if with_use_elf_tls and not with_platform_android or get_option('platform-sdk-version') >= 29
+   pre_args += '-DUSE_ELF_TLS'
+ endif
+ 
+diff --git meson_options.txt meson_options.txt
+index b768c15..2533220 100644
+--- meson_options.txt
++++ meson_options.txt
+@@ -358,3 +358,9 @@ option(
+   value : 25,
+   description : 'Android Platform SDK version. Default: Nougat version.'
+ )
++option(
++  'use-elf-tls',
++  type : 'boolean',
++  value : true,
++  description : 'Build support for initial-exec TLS model'
++)
diff --git a/srcpkgs/libGL/patches/musl.patch b/srcpkgs/libGL/patches/musl.patch
index dc71d18c3d8..92a37bd577c 100644
--- a/srcpkgs/libGL/patches/musl.patch
+++ b/srcpkgs/libGL/patches/musl.patch
@@ -32,44 +32,6 @@
  #include <unistd.h>
  #include <fcntl.h>
  #else
---- src/gallium/state_trackers/nine/nine_debug.c
-+++ src/gallium/state_trackers/nine/nine_debug.c
-@@ -73,8 +73,8 @@
-     }
- 
- #if defined(HAVE_PTHREAD)
--#  if defined(__GNU_LIBRARY__) && defined(__GLIBC__) && defined(__GLIBC_MINOR__) && \
--      (__GLIBC__ >= 3 || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 12))
-+#  if defined(__linux__) && !(defined(__GLIBC__) || \
-+      (__GLIBC__ < 3 || (__GLIBC__ == 2 && __GLIBC_MINOR__ < 12)))
-     if (dbg_flags & DBG_TID)
-         tid = pthread_self();
- #  endif
---- src/util/u_thread.h
-+++ src/util/u_thread.h
-@@ -61,9 +61,8 @@
- static inline void u_thread_setname( const char *name )
- {
- #if defined(HAVE_PTHREAD)
--#  if defined(__GNU_LIBRARY__) && defined(__GLIBC__) && defined(__GLIBC_MINOR__) && \
--      (__GLIBC__ >= 3 || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 12)) && \
--      defined(__linux__)
-+#  if defined(__linux__) && !(defined(__GLIBC__) || \
-+      (__GLIBC__ < 3 || (__GLIBC__ == 2 && __GLIBC_MINOR__ < 12)))
-    pthread_setname_np(pthread_self(), name);
- #  endif
- #endif
-@@ -93,8 +92,8 @@
- static inline bool u_thread_is_self(thrd_t thread)
- {
- #if defined(HAVE_PTHREAD)
--#  if defined(__GNU_LIBRARY__) && defined(__GLIBC__) && defined(__GLIBC_MINOR__) && \
--      (__GLIBC__ >= 3 || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 12))
-+#  if defined(__linux__) && !(defined(__GLIBC__) || \
-+      (__GLIBC__ < 3 || (__GLIBC__ == 2 && __GLIBC_MINOR__ < 12)))
-    return pthread_equal(pthread_self(), thread);
- #  endif
- #endif
 --- src/amd/vulkan/winsys/amdgpu/radv_amdgpu_winsys.h
 +++ src/amd/vulkan/winsys/amdgpu/radv_amdgpu_winsys.h
 @@ -28,6 +28,8 @@
@@ -80,4 +42,4 @@
 +
  #include "radv_radeon_winsys.h"
  #include "ac_gpu_info.h"
- #include "addrlib/addrinterface.h"<Paste>
+ #include "addrlib/addrinterface.h"
diff --git a/srcpkgs/libGL/template b/srcpkgs/libGL/template
index e1a20f31347..78f81d3ddcf 100644
--- a/srcpkgs/libGL/template
+++ b/srcpkgs/libGL/template
@@ -1,7 +1,7 @@
 # Template file for 'libGL'
 pkgname=libGL
-version=19.1.7
-revision=3
+version=19.2.1
+revision=1
 wrksrc="mesa-${version}"
 build_style=meson
 configure_args="-Dshared-glapi=true -Dgbm=true -Degl=true
@@ -21,7 +21,7 @@ license="MIT, LGPL-2.1-or-later"
 homepage="https://www.mesa3d.org/"
 changelog="https://www.mesa3d.org/relnotes/${version}.html"
 distfiles="https://mesa.freedesktop.org/archive/mesa-${version}.tar.xz"
-checksum=e287920fdb38712a9fed448dc90b3ca95048c7face5db52e58361f8b6e0f3cd5
+checksum=4cc53ca1a8d12c6ff0e5ea44a5213c05c88447ab50d7e28bb350cd29199f01e9
 
 # Set subpackages manually to set proper rdeps in 32bit pkgs.
 subpackages="libglapi libgbm libEGL libGLES libOSMesa"
@@ -95,7 +95,7 @@ esac
 
 case "$XBPS_TARGET_MACHINE" in
 	# Disable TLS with musl: https://bugs.freedesktop.org/show_bug.cgi?id=35268
-	*-musl) configure_args+=" -Dglx-use-tls=false";;
+	*-musl) configure_args+=" -Duse-elf-tls=false";;
 	*) configure_args+=" -Dglx=dri";;
 esac
 

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PR PATCH] [Updated] [NOMERGE] libGL: update to 19.2.0
  2019-10-09 12:34 [PR PATCH] [NOMERGE] libGL: update to 19.2.0 voidlinux-github
@ 2019-10-09 20:27 ` voidlinux-github
  2019-10-09 20:27 ` voidlinux-github
                   ` (3 subsequent siblings)
  4 siblings, 0 replies; 6+ messages in thread
From: voidlinux-github @ 2019-10-09 20:27 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 621 bytes --]

There is an updated pull request by st3r4g against master on the void-packages repository

https://github.com/st3r4g/void-packages mesa-19.2
https://github.com/void-linux/void-packages/pull/15276

[NOMERGE] libGL: update to 19.2.0
In preparation for the stable release (Mesa 19.2.1)
Upstream changes that required modifications in the patches:

- `GLX_USE_TLS` was renamed into `USE_ELF_TLS`
- `3fd21a6b776e0f874e0e14d9943ac2b06bcc4aad` was merged
- `__GNU_LIBRARY__` checks were removed from `nine_debug.c` and `u_thread.c`

A patch file from https://github.com/void-linux/void-packages/pull/15276.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-mesa-19.2-15276.patch --]
[-- Type: text/x-diff, Size: 8247 bytes --]

From 52c3c81fb2c2fe9dc665ab586c8988af038fc7c6 Mon Sep 17 00:00:00 2001
From: Stefano Ragni <st3r4g@protonmail.com>
Date: Wed, 9 Oct 2019 14:16:00 +0200
Subject: [PATCH] libGL: update to 19.2.1

---
 ...1a6b776e0f874e0e14d9943ac2b06bcc4aad.patch | 26 ----------
 srcpkgs/libGL/patches/add-glx-use-tls.patch   | 47 -------------------
 srcpkgs/libGL/patches/add-use-elf-tls.patch   | 28 +++++++++++
 srcpkgs/libGL/patches/musl.patch              | 40 +---------------
 srcpkgs/libGL/template                        |  8 ++--
 5 files changed, 33 insertions(+), 116 deletions(-)
 delete mode 100644 srcpkgs/libGL/patches/3fd21a6b776e0f874e0e14d9943ac2b06bcc4aad.patch
 delete mode 100644 srcpkgs/libGL/patches/add-glx-use-tls.patch
 create mode 100644 srcpkgs/libGL/patches/add-use-elf-tls.patch

diff --git a/srcpkgs/libGL/patches/3fd21a6b776e0f874e0e14d9943ac2b06bcc4aad.patch b/srcpkgs/libGL/patches/3fd21a6b776e0f874e0e14d9943ac2b06bcc4aad.patch
deleted file mode 100644
index d0db64c76e0..00000000000
--- a/srcpkgs/libGL/patches/3fd21a6b776e0f874e0e14d9943ac2b06bcc4aad.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 3fd21a6b776e0f874e0e14d9943ac2b06bcc4aad Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Michel=20D=C3=A4nzer?= <michel.daenzer@amd.com>
-Date: Fri, 28 Jun 2019 11:07:39 +0200
-Subject: [PATCH] targets/opencl: Add clangASTMatchers library as dependency
-
-Fixes link failure since clang r364424 "[clang/DIVar] Emit the flag for
-params that have unmodified value", clangCodeGen depends on
-clangASTMatchers now.
-
-Reviewed-by: Dylan Baker <dylan@pnwbakers.com>
----
- src/gallium/targets/opencl/meson.build | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/gallium/targets/opencl/meson.build b/src/gallium/targets/opencl/meson.build
-index 317ad8dab4a..650a2054cfb 100644
---- src/gallium/targets/opencl/meson.build
-+++ src/gallium/targets/opencl/meson.build
-@@ -51,6 +51,7 @@ libopencl = shared_library(
-     cpp.find_library('clangSema', dirs : llvm_libdir),
-     cpp.find_library('clangAnalysis', dirs : llvm_libdir),
-     cpp.find_library('clangAST', dirs : llvm_libdir),
-+    cpp.find_library('clangASTMatchers', dirs : llvm_libdir),
-     cpp.find_library('clangEdit', dirs : llvm_libdir),
-     cpp.find_library('clangLex', dirs : llvm_libdir),
-     cpp.find_library('clangBasic', dirs : llvm_libdir),
diff --git a/srcpkgs/libGL/patches/add-glx-use-tls.patch b/srcpkgs/libGL/patches/add-glx-use-tls.patch
deleted file mode 100644
index 7ded1a1b2ee..00000000000
--- a/srcpkgs/libGL/patches/add-glx-use-tls.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-From f895a39b7437381a86383dd97250aa2cc7393bff Mon Sep 17 00:00:00 2001
-From: maxice8 <thinkabit.ukim@gmail.com>
-Date: Thu, 9 Aug 2018 18:37:30 -0300
-Subject: [PATCH] meson: add glx-use-tls option.
-
----
- meson.build       | 6 +++++-
- meson_options.txt | 6 ++++++
- 2 files changed, 11 insertions(+), 1 deletion(-)
-
-diff --git a/meson.build b/meson.build
-index 5dbb786..1ab3092 100644
---- meson.build
-+++ meson.build
-@@ -340,7 +340,11 @@ if with_egl and not (with_platform_drm or with_platform_surfaceless)
-   endif
- endif
- 
--pre_args += '-DGLX_USE_TLS'
-+with_glx_use_tls = get_option('glx-use-tls')
-+if with_glx_use_tls
-+  pre_args += '-DGLX_USE_TLS'
-+endif
-+
- if with_glx != 'disabled'
-   if not (with_platform_x11 and with_any_opengl)
-     if with_glx == 'auto'
-diff --git a/meson_options.txt b/meson_options.txt
-index 496fe38..12981dd 100644
---- meson_options.txt
-+++ meson_options.txt
-@@ -195,6 +195,12 @@ option(
-   choices : ['auto', 'disabled', 'dri', 'xlib', 'gallium-xlib'],
-   description : 'Build support for GLX platform'
- )
-+option(
-+  'glx-use-tls',
-+  type : 'boolean',
-+  value : true,
-+  description : 'Build support for initial-exec TLS model on GLX platform'
-+)
- option(
-   'egl',
-   type : 'combo',
--- 
-2.18.0
-
diff --git a/srcpkgs/libGL/patches/add-use-elf-tls.patch b/srcpkgs/libGL/patches/add-use-elf-tls.patch
new file mode 100644
index 00000000000..b922d8601e7
--- /dev/null
+++ b/srcpkgs/libGL/patches/add-use-elf-tls.patch
@@ -0,0 +1,28 @@
+diff --git meson.build meson.build
+index 4afd8ca..ab9b365 100644
+--- meson.build
++++ meson.build
+@@ -378,7 +378,8 @@ if with_egl and not (with_platform_drm or with_platform_surfaceless or with_plat
+ endif
+ 
+ # Android uses emutls for versions <= P/28. For USE_ELF_TLS we need ELF TLS.
+-if not with_platform_android or get_option('platform-sdk-version') >= 29
++with_use_elf_tls = get_option('use-elf-tls')
++if with_use_elf_tls and not with_platform_android or get_option('platform-sdk-version') >= 29
+   pre_args += '-DUSE_ELF_TLS'
+ endif
+ 
+diff --git meson_options.txt meson_options.txt
+index b768c15..2533220 100644
+--- meson_options.txt
++++ meson_options.txt
+@@ -358,3 +358,9 @@ option(
+   value : 25,
+   description : 'Android Platform SDK version. Default: Nougat version.'
+ )
++option(
++  'use-elf-tls',
++  type : 'boolean',
++  value : true,
++  description : 'Build support for initial-exec TLS model'
++)
diff --git a/srcpkgs/libGL/patches/musl.patch b/srcpkgs/libGL/patches/musl.patch
index dc71d18c3d8..92a37bd577c 100644
--- a/srcpkgs/libGL/patches/musl.patch
+++ b/srcpkgs/libGL/patches/musl.patch
@@ -32,44 +32,6 @@
  #include <unistd.h>
  #include <fcntl.h>
  #else
---- src/gallium/state_trackers/nine/nine_debug.c
-+++ src/gallium/state_trackers/nine/nine_debug.c
-@@ -73,8 +73,8 @@
-     }
- 
- #if defined(HAVE_PTHREAD)
--#  if defined(__GNU_LIBRARY__) && defined(__GLIBC__) && defined(__GLIBC_MINOR__) && \
--      (__GLIBC__ >= 3 || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 12))
-+#  if defined(__linux__) && !(defined(__GLIBC__) || \
-+      (__GLIBC__ < 3 || (__GLIBC__ == 2 && __GLIBC_MINOR__ < 12)))
-     if (dbg_flags & DBG_TID)
-         tid = pthread_self();
- #  endif
---- src/util/u_thread.h
-+++ src/util/u_thread.h
-@@ -61,9 +61,8 @@
- static inline void u_thread_setname( const char *name )
- {
- #if defined(HAVE_PTHREAD)
--#  if defined(__GNU_LIBRARY__) && defined(__GLIBC__) && defined(__GLIBC_MINOR__) && \
--      (__GLIBC__ >= 3 || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 12)) && \
--      defined(__linux__)
-+#  if defined(__linux__) && !(defined(__GLIBC__) || \
-+      (__GLIBC__ < 3 || (__GLIBC__ == 2 && __GLIBC_MINOR__ < 12)))
-    pthread_setname_np(pthread_self(), name);
- #  endif
- #endif
-@@ -93,8 +92,8 @@
- static inline bool u_thread_is_self(thrd_t thread)
- {
- #if defined(HAVE_PTHREAD)
--#  if defined(__GNU_LIBRARY__) && defined(__GLIBC__) && defined(__GLIBC_MINOR__) && \
--      (__GLIBC__ >= 3 || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 12))
-+#  if defined(__linux__) && !(defined(__GLIBC__) || \
-+      (__GLIBC__ < 3 || (__GLIBC__ == 2 && __GLIBC_MINOR__ < 12)))
-    return pthread_equal(pthread_self(), thread);
- #  endif
- #endif
 --- src/amd/vulkan/winsys/amdgpu/radv_amdgpu_winsys.h
 +++ src/amd/vulkan/winsys/amdgpu/radv_amdgpu_winsys.h
 @@ -28,6 +28,8 @@
@@ -80,4 +42,4 @@
 +
  #include "radv_radeon_winsys.h"
  #include "ac_gpu_info.h"
- #include "addrlib/addrinterface.h"<Paste>
+ #include "addrlib/addrinterface.h"
diff --git a/srcpkgs/libGL/template b/srcpkgs/libGL/template
index e1a20f31347..78f81d3ddcf 100644
--- a/srcpkgs/libGL/template
+++ b/srcpkgs/libGL/template
@@ -1,7 +1,7 @@
 # Template file for 'libGL'
 pkgname=libGL
-version=19.1.7
-revision=3
+version=19.2.1
+revision=1
 wrksrc="mesa-${version}"
 build_style=meson
 configure_args="-Dshared-glapi=true -Dgbm=true -Degl=true
@@ -21,7 +21,7 @@ license="MIT, LGPL-2.1-or-later"
 homepage="https://www.mesa3d.org/"
 changelog="https://www.mesa3d.org/relnotes/${version}.html"
 distfiles="https://mesa.freedesktop.org/archive/mesa-${version}.tar.xz"
-checksum=e287920fdb38712a9fed448dc90b3ca95048c7face5db52e58361f8b6e0f3cd5
+checksum=4cc53ca1a8d12c6ff0e5ea44a5213c05c88447ab50d7e28bb350cd29199f01e9
 
 # Set subpackages manually to set proper rdeps in 32bit pkgs.
 subpackages="libglapi libgbm libEGL libGLES libOSMesa"
@@ -95,7 +95,7 @@ esac
 
 case "$XBPS_TARGET_MACHINE" in
 	# Disable TLS with musl: https://bugs.freedesktop.org/show_bug.cgi?id=35268
-	*-musl) configure_args+=" -Dglx-use-tls=false";;
+	*-musl) configure_args+=" -Duse-elf-tls=false";;
 	*) configure_args+=" -Dglx=dri";;
 esac
 

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: libGL: update to 19.2.1
  2019-10-09 12:34 [PR PATCH] [NOMERGE] libGL: update to 19.2.0 voidlinux-github
  2019-10-09 20:27 ` [PR PATCH] [Updated] " voidlinux-github
  2019-10-09 20:27 ` voidlinux-github
@ 2019-10-09 20:32 ` voidlinux-github
  2019-10-14 18:09 ` voidlinux-github
  2019-10-15 19:42 ` [PR PATCH] [Merged]: " voidlinux-github
  4 siblings, 0 replies; 6+ messages in thread
From: voidlinux-github @ 2019-10-09 20:32 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 236 bytes --]

New comment by st3r4g on void-packages repository

https://github.com/void-linux/void-packages/pull/15276#issuecomment-540180037

Comment:
Mesa 19.2.1 is released. Needs some testing. I'm testing the core libs and vulkan_intel on musl.

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: libGL: update to 19.2.1
  2019-10-09 12:34 [PR PATCH] [NOMERGE] libGL: update to 19.2.0 voidlinux-github
                   ` (2 preceding siblings ...)
  2019-10-09 20:32 ` libGL: update to 19.2.1 voidlinux-github
@ 2019-10-14 18:09 ` voidlinux-github
  2019-10-15 19:42 ` [PR PATCH] [Merged]: " voidlinux-github
  4 siblings, 0 replies; 6+ messages in thread
From: voidlinux-github @ 2019-10-14 18:09 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 233 bytes --]

New comment by Wychmire on void-packages repository

https://github.com/void-linux/void-packages/pull/15276#issuecomment-541832296

Comment:
Built successfully on x86_64, I'm now running on mesa 19.2.1 with a vega 56. Working great!

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PR PATCH] [Merged]: libGL: update to 19.2.1
  2019-10-09 12:34 [PR PATCH] [NOMERGE] libGL: update to 19.2.0 voidlinux-github
                   ` (3 preceding siblings ...)
  2019-10-14 18:09 ` voidlinux-github
@ 2019-10-15 19:42 ` voidlinux-github
  4 siblings, 0 replies; 6+ messages in thread
From: voidlinux-github @ 2019-10-15 19:42 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 455 bytes --]

There's a merged pull request on the void-packages repository

libGL: update to 19.2.1
https://github.com/void-linux/void-packages/pull/15276

Description:
In preparation for the stable release (Mesa 19.2.1)
Upstream changes that required modifications in the patches:

- `GLX_USE_TLS` was renamed into `USE_ELF_TLS`
- `3fd21a6b776e0f874e0e14d9943ac2b06bcc4aad` was merged
- `__GNU_LIBRARY__` checks were removed from `nine_debug.c` and `u_thread.c`

^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, back to index

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-10-09 12:34 [PR PATCH] [NOMERGE] libGL: update to 19.2.0 voidlinux-github
2019-10-09 20:27 ` [PR PATCH] [Updated] " voidlinux-github
2019-10-09 20:27 ` voidlinux-github
2019-10-09 20:32 ` libGL: update to 19.2.1 voidlinux-github
2019-10-14 18:09 ` voidlinux-github
2019-10-15 19:42 ` [PR PATCH] [Merged]: " voidlinux-github

Github messages for voidlinux

Archives are clonable: git clone --mirror http://inbox.vuxu.org/voidlinux-github

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.github.voidlinux


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git