Github messages for voidlinux
 help / color / Atom feed
* [ISSUE] qbittorent-nox is dependent on qt5
@ 2019-07-10 11:07 voidlinux-github
  2019-07-10 14:01 ` voidlinux-github
                   ` (12 more replies)
  0 siblings, 13 replies; 14+ messages in thread
From: voidlinux-github @ 2019-07-10 11:07 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 839 bytes --]

New issue by innerspacepilot on void-packages repository

https://github.com/void-linux/void-packages/issues/12964
Description: > $ xbps-query -R qbittorrent-nox
architecture: armv7l-musl
build-date: 2019-05-11 18:14 CDT
filename-sha256: 97e174b195dfbc4c86a2c46ff1690b77d92c383c6d6ce9bce5b628264f0bf8b2
filename-size: 4773KB
homepage: http://www.qbittorrent.org/
installed_size: 6367KB
license: GPL-2.0-or-later
maintainer: Jürgen Buchmüller <pullmoll@t-online.de>
pkgver: qbittorrent-nox-4.1.6_1
repository: https://alpha.de.repo.voidlinux.org/current/musl
shlib-requires:
	libz.so.1
	libtorrent-rasterbar.so.9
	libQt5Network.so.5
	libQt5Xml.so.5
	libQt5Core.so.5
	libstdc++.so.6
	libgcc_s.so.1
	libc.so
short_desc: Free software alternative to µtorrent - no X11
source-revisions: qbittorrent:9dc56b9edc



^ permalink raw reply	[flat|nested] 14+ messages in thread

* Re: qbittorent-nox is dependent on qt5
  2019-07-10 11:07 [ISSUE] qbittorent-nox is dependent on qt5 voidlinux-github
@ 2019-07-10 14:01 ` voidlinux-github
  2019-07-10 15:52 ` voidlinux-github
                   ` (11 subsequent siblings)
  12 siblings, 0 replies; 14+ messages in thread
From: voidlinux-github @ 2019-07-10 14:01 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 209 bytes --]

New comment by Hoshpak on void-packages repository

https://github.com/void-linux/void-packages/issues/12964#issuecomment-510074088
Comment:
A software implemented with qt depends on qt, so where's the issue?

^ permalink raw reply	[flat|nested] 14+ messages in thread

* Re: qbittorent-nox is dependent on qt5
  2019-07-10 11:07 [ISSUE] qbittorent-nox is dependent on qt5 voidlinux-github
  2019-07-10 14:01 ` voidlinux-github
@ 2019-07-10 15:52 ` voidlinux-github
  2019-07-10 15:58 ` voidlinux-github
                   ` (10 subsequent siblings)
  12 siblings, 0 replies; 14+ messages in thread
From: voidlinux-github @ 2019-07-10 15:52 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 290 bytes --]

New comment by innerspacepilot on void-packages repository

https://github.com/void-linux/void-packages/issues/12964#issuecomment-510120148
Comment:
this is a special subpackage (qbittorrent-nox), which represents special build option when no gui is built, only daemon and web interface.


^ permalink raw reply	[flat|nested] 14+ messages in thread

* Re: qbittorent-nox is dependent on qt5
  2019-07-10 11:07 [ISSUE] qbittorent-nox is dependent on qt5 voidlinux-github
  2019-07-10 14:01 ` voidlinux-github
  2019-07-10 15:52 ` voidlinux-github
@ 2019-07-10 15:58 ` voidlinux-github
  2019-07-10 16:14 ` voidlinux-github
                   ` (9 subsequent siblings)
  12 siblings, 0 replies; 14+ messages in thread
From: voidlinux-github @ 2019-07-10 15:58 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 234 bytes --]

New comment by Hoshpak on void-packages repository

https://github.com/void-linux/void-packages/issues/12964#issuecomment-510122730
Comment:
Yes, but it's still a qt-based application so I see no reason why it shouldn't depend on qt.

^ permalink raw reply	[flat|nested] 14+ messages in thread

* Re: qbittorent-nox is dependent on qt5
  2019-07-10 11:07 [ISSUE] qbittorent-nox is dependent on qt5 voidlinux-github
                   ` (2 preceding siblings ...)
  2019-07-10 15:58 ` voidlinux-github
@ 2019-07-10 16:14 ` voidlinux-github
  2019-07-10 16:15 ` voidlinux-github
                   ` (8 subsequent siblings)
  12 siblings, 0 replies; 14+ messages in thread
From: voidlinux-github @ 2019-07-10 16:14 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 459 bytes --]

New comment by pullmoll on void-packages repository

https://github.com/void-linux/void-packages/issues/12964#issuecomment-510128849
Comment:
I think the problem is we have no `qt5-core` or `qt5-libs` package with only the `libQt5Core.so.*` files. Depending on `qt5` through `libQt5Core.so.*` means the whole shebang of dependencies is installed. I guess we could fix that for `qt5-5.13.0` by adding a separate `qt5-core` package and moving the libs into it.

^ permalink raw reply	[flat|nested] 14+ messages in thread

* Re: qbittorent-nox is dependent on qt5
  2019-07-10 11:07 [ISSUE] qbittorent-nox is dependent on qt5 voidlinux-github
                   ` (3 preceding siblings ...)
  2019-07-10 16:14 ` voidlinux-github
@ 2019-07-10 16:15 ` voidlinux-github
  2019-07-10 16:15 ` voidlinux-github
                   ` (7 subsequent siblings)
  12 siblings, 0 replies; 14+ messages in thread
From: voidlinux-github @ 2019-07-10 16:15 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 566 bytes --]

New comment by pullmoll on void-packages repository

https://github.com/void-linux/void-packages/issues/12964#issuecomment-510128849
Comment:
I think the problem is we have no `qt5-core` or `qt5-libs` package with only the `libQt5Core.so.*` files. Depending on `qt5` through `libQt5Core.so.*` means the whole shebang of dependencies is installed. I guess we could fix that for `qt5-5.13.0` by adding a separate `qt5-core` package and moving the libs into it.

Edit: Or even better `qt5-base` as this is how other distributions (with split builds) usually call it.

^ permalink raw reply	[flat|nested] 14+ messages in thread

* Re: qbittorent-nox is dependent on qt5
  2019-07-10 11:07 [ISSUE] qbittorent-nox is dependent on qt5 voidlinux-github
                   ` (4 preceding siblings ...)
  2019-07-10 16:15 ` voidlinux-github
@ 2019-07-10 16:15 ` voidlinux-github
  2019-07-10 16:18 ` qbittorent-nox is dependent on X voidlinux-github
                   ` (6 subsequent siblings)
  12 siblings, 0 replies; 14+ messages in thread
From: voidlinux-github @ 2019-07-10 16:15 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 286 bytes --]

New comment by innerspacepilot on void-packages repository

https://github.com/void-linux/void-packages/issues/12964#issuecomment-510129339
Comment:
Oh, well...
My misunderstanding.
Yes problem with qt.
I am making a docker image with qbittorent-nox, and it install whole X system


^ permalink raw reply	[flat|nested] 14+ messages in thread

* Re: qbittorent-nox is dependent on X
  2019-07-10 11:07 [ISSUE] qbittorent-nox is dependent on qt5 voidlinux-github
                   ` (5 preceding siblings ...)
  2019-07-10 16:15 ` voidlinux-github
@ 2019-07-10 16:18 ` voidlinux-github
  2019-07-10 16:20 ` voidlinux-github
                   ` (5 subsequent siblings)
  12 siblings, 0 replies; 14+ messages in thread
From: voidlinux-github @ 2019-07-10 16:18 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 287 bytes --]

New comment by innerspacepilot on void-packages repository

https://github.com/void-linux/void-packages/issues/12964#issuecomment-510129339
Comment:
Oh, well...
My misunderstanding.
Yes problem with qt.
I am making a docker image with qbittorent-nox, and it installs whole X system


^ permalink raw reply	[flat|nested] 14+ messages in thread

* Re: qbittorent-nox is dependent on X
  2019-07-10 11:07 [ISSUE] qbittorent-nox is dependent on qt5 voidlinux-github
                   ` (6 preceding siblings ...)
  2019-07-10 16:18 ` qbittorent-nox is dependent on X voidlinux-github
@ 2019-07-10 16:20 ` voidlinux-github
  2019-07-10 16:20 ` voidlinux-github
                   ` (4 subsequent siblings)
  12 siblings, 0 replies; 14+ messages in thread
From: voidlinux-github @ 2019-07-10 16:20 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 686 bytes --]

New comment by pullmoll on void-packages repository

https://github.com/void-linux/void-packages/issues/12964#issuecomment-510128849
Comment:
I think the problem is we have no `qt5-core` or `qt5-libs` package with only the `libQt5Core.so.*` files. Depending on `qt5` through `libQt5Core.so.*` means the whole shebang of dependencies is installed. I guess we could fix that for `qt5-5.13.0` by adding a separate `qt5-core` package and moving the libs into it.

Edit: Or even better `qt5-base` as this is how other distributions (with split builds) usually call it. Of course `qt5` must depend on `qt5-base` and other modules probably as well depending on if the utilize the UI or not.

^ permalink raw reply	[flat|nested] 14+ messages in thread

* Re: qbittorent-nox is dependent on X
  2019-07-10 11:07 [ISSUE] qbittorent-nox is dependent on qt5 voidlinux-github
                   ` (7 preceding siblings ...)
  2019-07-10 16:20 ` voidlinux-github
@ 2019-07-10 16:20 ` voidlinux-github
  2019-11-07 17:05 ` voidlinux-github
                   ` (3 subsequent siblings)
  12 siblings, 0 replies; 14+ messages in thread
From: voidlinux-github @ 2019-07-10 16:20 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 687 bytes --]

New comment by pullmoll on void-packages repository

https://github.com/void-linux/void-packages/issues/12964#issuecomment-510128849
Comment:
I think the problem is we have no `qt5-core` or `qt5-libs` package with only the `libQt5Core.so.*` files. Depending on `qt5` through `libQt5Core.so.*` means the whole shebang of dependencies is installed. I guess we could fix that for `qt5-5.13.0` by adding a separate `qt5-core` package and moving the libs into it.

Edit: Or even better `qt5-base` as this is how other distributions (with split builds) usually call it. Of course `qt5` must depend on `qt5-base` and other modules probably as well depending on if they utilize the UI or not.

^ permalink raw reply	[flat|nested] 14+ messages in thread

* Re: qbittorent-nox is dependent on X
  2019-07-10 11:07 [ISSUE] qbittorent-nox is dependent on qt5 voidlinux-github
                   ` (8 preceding siblings ...)
  2019-07-10 16:20 ` voidlinux-github
@ 2019-11-07 17:05 ` voidlinux-github
  2019-11-07 18:49 ` voidlinux-github
                   ` (2 subsequent siblings)
  12 siblings, 0 replies; 14+ messages in thread
From: voidlinux-github @ 2019-11-07 17:05 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 198 bytes --]

New comment by innerspacepilot on void-packages repository

https://github.com/void-linux/void-packages/issues/12964#issuecomment-551171996

Comment:
@pullmoll  are there any updates on this issue?

^ permalink raw reply	[flat|nested] 14+ messages in thread

* Re: qbittorent-nox is dependent on X
  2019-07-10 11:07 [ISSUE] qbittorent-nox is dependent on qt5 voidlinux-github
                   ` (9 preceding siblings ...)
  2019-11-07 17:05 ` voidlinux-github
@ 2019-11-07 18:49 ` voidlinux-github
  2019-11-07 18:54 ` voidlinux-github
  2019-11-07 19:09 ` voidlinux-github
  12 siblings, 0 replies; 14+ messages in thread
From: voidlinux-github @ 2019-11-07 18:49 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 465 bytes --]

New comment by pullmoll on void-packages repository

https://github.com/void-linux/void-packages/issues/12964#issuecomment-551212669

Comment:
@innerspacepilot I didn't find time since qt5 was upgraded to 5.13.x to take a look at if or how it would be possible to split out qt5-base from qt5. In any case it would require every package depending on qt5 to be rebuilt which is by no means easy and would hit the builders hard, perhaps harder than they can handle.


^ permalink raw reply	[flat|nested] 14+ messages in thread

* Re: qbittorent-nox is dependent on X
  2019-07-10 11:07 [ISSUE] qbittorent-nox is dependent on qt5 voidlinux-github
                   ` (10 preceding siblings ...)
  2019-11-07 18:49 ` voidlinux-github
@ 2019-11-07 18:54 ` voidlinux-github
  2019-11-07 19:09 ` voidlinux-github
  12 siblings, 0 replies; 14+ messages in thread
From: voidlinux-github @ 2019-11-07 18:54 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 690 bytes --]

New comment by pullmoll on void-packages repository

https://github.com/void-linux/void-packages/issues/12964#issuecomment-551212669

Comment:
@innerspacepilot I didn't find time since qt5 was upgraded to 5.13.x to take a look at if or how it would be possible to split out qt5-base from qt5. In any case it would require every package depending on qt5 to be rebuilt which is by no means easy and would hit the builders hard, perhaps harder than they can handle.

Or do you @void-linux/pkg-committers think it would be possible to avoid rebuilding all dependencies by making qt5 depend on a (new) qt5-base and only step by step reduce dependencies to qt5-base where this is sufficient?


^ permalink raw reply	[flat|nested] 14+ messages in thread

* Re: qbittorent-nox is dependent on X
  2019-07-10 11:07 [ISSUE] qbittorent-nox is dependent on qt5 voidlinux-github
                   ` (11 preceding siblings ...)
  2019-11-07 18:54 ` voidlinux-github
@ 2019-11-07 19:09 ` voidlinux-github
  12 siblings, 0 replies; 14+ messages in thread
From: voidlinux-github @ 2019-11-07 19:09 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 213 bytes --]

New comment by Piraty on void-packages repository

https://github.com/void-linux/void-packages/issues/12964#issuecomment-551220386

Comment:
+1 for the lib split, as it affects packages like quassel-core as well.

^ permalink raw reply	[flat|nested] 14+ messages in thread

end of thread, back to index

Thread overview: 14+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-07-10 11:07 [ISSUE] qbittorent-nox is dependent on qt5 voidlinux-github
2019-07-10 14:01 ` voidlinux-github
2019-07-10 15:52 ` voidlinux-github
2019-07-10 15:58 ` voidlinux-github
2019-07-10 16:14 ` voidlinux-github
2019-07-10 16:15 ` voidlinux-github
2019-07-10 16:15 ` voidlinux-github
2019-07-10 16:18 ` qbittorent-nox is dependent on X voidlinux-github
2019-07-10 16:20 ` voidlinux-github
2019-07-10 16:20 ` voidlinux-github
2019-11-07 17:05 ` voidlinux-github
2019-11-07 18:49 ` voidlinux-github
2019-11-07 18:54 ` voidlinux-github
2019-11-07 19:09 ` voidlinux-github

Github messages for voidlinux

Archives are clonable: git clone --mirror http://inbox.vuxu.org/voidlinux-github

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.github.voidlinux


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git