Github messages for voidlinux
 help / color / Atom feed
* [ISSUE] Wireguard DKMS module fails to build for kernel 5.7.10_1
@ 2020-07-24  0:26 cinerea0
  2020-07-24  1:02 ` luhann
                   ` (3 more replies)
  0 siblings, 4 replies; 5+ messages in thread
From: cinerea0 @ 2020-07-24  0:26 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 1856 bytes --]

New issue by cinerea0 on void-packages repository

https://github.com/void-linux/void-packages/issues/23790

Description:
### System

* xuname:  
  *Void 5.7.10_1 x86_64 GenuineIntel notuptodate rFFFFFFFFF*
* package:  
  *wireguard-dkms-1.0.20200712_1*:

### Expected behavior
The wireguard DMS module builds successfully.

### Actual behavior
The wireguard DKMS module does not build successfully. The following is the output from the configuration step after running `xbps-install -S wireguard`:
```
wireguard-tools-1.0.20200513_2: configuring ...
wireguard-tools-1.0.20200513_2: installed successfully.
wireguard-dkms-1.0.20200712_1: configuring ...
Added DKMS module 'wireguard-1.0.20200712'.
Skipping kernel-5.4.51_1. kernel-headers package not installed...
Skipping kernel-5.5.18_1. kernel-headers package not installed...
Skipping kernel-5.6.0_2. kernel-headers package not installed...
Skipping kernel-5.6.19_1. kernel-headers package not installed...
Building DKMS module 'wireguard-1.0.20200712' for kernel-5.7.10_1... FAILED!
DKMS module 'wireguard-1.0.20200712' failed to build, please check /var/lib/dkms
for errors in the log file.
Building DKMS module 'wireguard-1.0.20200712' for kernel-5.7.9_1... FAILED!
DKMS module 'wireguard-1.0.20200712' failed to build, please check /var/lib/dkms
for errors in the log file.
wireguard-dkms-1.0.20200712_1: installed successfully.
wireguard-0.0.20191226_1: configuring ...
wireguard-0.0.20191226_1: installed successfully.
```
A couple things are weird about this. One, it lists kernels (5.4.51, 5.5.18, 5.6.0, 5.6.19) that I have removed with `xbps-remove` and `vkpurge`. Two, there are no logs in the directory it tells me to check.

### Steps to reproduce the behavior
Attempt to install wireguard-dkms while either running or having installed kernel 5.7.10_1.


^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: Wireguard DKMS module fails to build for kernel 5.7.10_1
  2020-07-24  0:26 [ISSUE] Wireguard DKMS module fails to build for kernel 5.7.10_1 cinerea0
@ 2020-07-24  1:02 ` luhann
  2020-07-24  2:00 ` cinerea0
                   ` (2 subsequent siblings)
  3 siblings, 0 replies; 5+ messages in thread
From: luhann @ 2020-07-24  1:02 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 312 bytes --]

New comment by luhann on void-packages repository

https://github.com/void-linux/void-packages/issues/23790#issuecomment-663303922

Comment:
On kernels later than 5.6 wireguard is included with the kernel and it is not necessary to install wireguard, only wireguard-tools should be needed to get up and running.

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: Wireguard DKMS module fails to build for kernel 5.7.10_1
  2020-07-24  0:26 [ISSUE] Wireguard DKMS module fails to build for kernel 5.7.10_1 cinerea0
  2020-07-24  1:02 ` luhann
@ 2020-07-24  2:00 ` cinerea0
  2020-07-30  2:32 ` cinerea0
  2020-07-30  2:32 ` [ISSUE] [CLOSED] " cinerea0
  3 siblings, 0 replies; 5+ messages in thread
From: cinerea0 @ 2020-07-24  2:00 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 411 bytes --]

New comment by cinerea0 on void-packages repository

https://github.com/void-linux/void-packages/issues/23790#issuecomment-663315390

Comment:
You're right, I was able to get my VPN working without wireguard-dkms. Would it be a good idea to include a post-install message alerting users of this, or enforce it only being able to be installed on kernels 5.6 or earlier using the `depends` field in the template?

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: Wireguard DKMS module fails to build for kernel 5.7.10_1
  2020-07-24  0:26 [ISSUE] Wireguard DKMS module fails to build for kernel 5.7.10_1 cinerea0
  2020-07-24  1:02 ` luhann
  2020-07-24  2:00 ` cinerea0
@ 2020-07-30  2:32 ` cinerea0
  2020-07-30  2:32 ` [ISSUE] [CLOSED] " cinerea0
  3 siblings, 0 replies; 5+ messages in thread
From: cinerea0 @ 2020-07-30  2:32 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 388 bytes --]

New comment by cinerea0 on void-packages repository

https://github.com/void-linux/void-packages/issues/23790#issuecomment-666048654

Comment:
After discussion in the PR linked above, we reached a decision that it was best to leave everything how it is and the the short package description inform people where `wireguard-dkms` is needed. Closing because there's nothing more to be done.

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [ISSUE] [CLOSED] Wireguard DKMS module fails to build for kernel 5.7.10_1
  2020-07-24  0:26 [ISSUE] Wireguard DKMS module fails to build for kernel 5.7.10_1 cinerea0
                   ` (2 preceding siblings ...)
  2020-07-30  2:32 ` cinerea0
@ 2020-07-30  2:32 ` cinerea0
  3 siblings, 0 replies; 5+ messages in thread
From: cinerea0 @ 2020-07-30  2:32 UTC (permalink / raw)
  To: ml


[-- Attachment #1: Type: text/plain, Size: 1859 bytes --]

Closed issue by cinerea0 on void-packages repository

https://github.com/void-linux/void-packages/issues/23790

Description:
### System

* xuname:  
  *Void 5.7.10_1 x86_64 GenuineIntel notuptodate rFFFFFFFFF*
* package:  
  *wireguard-dkms-1.0.20200712_1*:

### Expected behavior
The wireguard DMS module builds successfully.

### Actual behavior
The wireguard DKMS module does not build successfully. The following is the output from the configuration step after running `xbps-install -S wireguard`:
```
wireguard-tools-1.0.20200513_2: configuring ...
wireguard-tools-1.0.20200513_2: installed successfully.
wireguard-dkms-1.0.20200712_1: configuring ...
Added DKMS module 'wireguard-1.0.20200712'.
Skipping kernel-5.4.51_1. kernel-headers package not installed...
Skipping kernel-5.5.18_1. kernel-headers package not installed...
Skipping kernel-5.6.0_2. kernel-headers package not installed...
Skipping kernel-5.6.19_1. kernel-headers package not installed...
Building DKMS module 'wireguard-1.0.20200712' for kernel-5.7.10_1... FAILED!
DKMS module 'wireguard-1.0.20200712' failed to build, please check /var/lib/dkms
for errors in the log file.
Building DKMS module 'wireguard-1.0.20200712' for kernel-5.7.9_1... FAILED!
DKMS module 'wireguard-1.0.20200712' failed to build, please check /var/lib/dkms
for errors in the log file.
wireguard-dkms-1.0.20200712_1: installed successfully.
wireguard-0.0.20191226_1: configuring ...
wireguard-0.0.20191226_1: installed successfully.
```
A couple things are weird about this. One, it lists kernels (5.4.51, 5.5.18, 5.6.0, 5.6.19) that I have removed with `xbps-remove` and `vkpurge`. Two, there are no logs in the directory it tells me to check.

### Steps to reproduce the behavior
Attempt to install wireguard-dkms while either running or having installed kernel 5.7.10_1.


^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, back to index

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-07-24  0:26 [ISSUE] Wireguard DKMS module fails to build for kernel 5.7.10_1 cinerea0
2020-07-24  1:02 ` luhann
2020-07-24  2:00 ` cinerea0
2020-07-30  2:32 ` cinerea0
2020-07-30  2:32 ` [ISSUE] [CLOSED] " cinerea0

Github messages for voidlinux

Archives are clonable: git clone --mirror http://inbox.vuxu.org/voidlinux-github

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.github.voidlinux


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git