Github messages for voidlinux
 help / color / Atom feed
* [PR PATCH] pyside-tools: remove package
@ 2019-07-30 21:10 voidlinux-github
  2019-07-30 21:29 ` [PR PATCH] [Merged]: " voidlinux-github
  0 siblings, 1 reply; 2+ messages in thread
From: voidlinux-github @ 2019-07-30 21:10 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 571 bytes --]

There is a new pull request by knusbaum against master on the void-packages repository

https://github.com/knusbaum/void-packages REMOVE_PYSIDE-TOOLS
https://github.com/void-linux/void-packages/pull/13423

pyside-tools: remove package
Resolves #12844 
pyside-tools was broken when python-pyside was removed here: https://github.com/void-linux/void-packages/pull/11064

It looks like we do not intend to support these bindings, so removing this package is the correct solution.

A patch file from https://github.com/void-linux/void-packages/pull/13423.patch is attached

[-- Warning: decoded text below may be mangled --]
[-- Attachment #2: github-pr-REMOVE_PYSIDE-TOOLS-13423.patch --]
[-- Type: text/x-diff, Size: 1782 bytes --]

From 06c8aeb9746ba318584b8eeb9ca5490bbff65445 Mon Sep 17 00:00:00 2001
From: Kyle Nusbaum <kylenusbaum@granular.ag>
Date: Tue, 30 Jul 2019 16:05:19 -0500
Subject: [PATCH] pyside-tools: remove package

---
 srcpkgs/pyside-tools/INSTALL.msg |  1 +
 srcpkgs/pyside-tools/template    | 19 +++++--------------
 2 files changed, 6 insertions(+), 14 deletions(-)
 create mode 100644 srcpkgs/pyside-tools/INSTALL.msg

diff --git a/srcpkgs/pyside-tools/INSTALL.msg b/srcpkgs/pyside-tools/INSTALL.msg
new file mode 100644
index 00000000000..fdb45eb0f42
--- /dev/null
+++ b/srcpkgs/pyside-tools/INSTALL.msg
@@ -0,0 +1 @@
+pyside-tools is no longer provided by Void Linux, and will be fully removed from the repos on 2019-10-30
diff --git a/srcpkgs/pyside-tools/template b/srcpkgs/pyside-tools/template
index d5dee735df1..27cfc18eea4 100644
--- a/srcpkgs/pyside-tools/template
+++ b/srcpkgs/pyside-tools/template
@@ -1,18 +1,9 @@
 # Template file for 'pyside-tools'
 pkgname=pyside-tools
 version=0.2.15
-revision=1
-wrksrc="Tools-${version}"
-build_style=cmake
-
-# libshiboken-python-devel libpyside-python-devel has distinct conventions
-configure_args="-DPYTHON_SUFFIX=-python2.7 -DPYTHON_BASENAME=-python2.7"
-makedepends="libshiboken-python-devel libpyside-python-devel qt-devel"
-depends="python"
-pycompile_module="pysideuic"
-short_desc="LGPL-licensed Python2 bindings for the Qt4 toolkit"
-maintainer="yopito <pierre.bourgin@free.fr>"
-license="LGPL-2.1"
+revision=2
+archs=noarch
+build_style=meta
+short_desc="LGPL-licensed Python2 bindings for the Qt4 toolkit (removed package)"
+license="BSD-2-Clause"
 homepage="https://wiki.qt.io/"
-distfiles="https://github.com/PySide/Tools/archive/${version}.tar.gz"
-checksum=8a7fe786b19c5b2b4380aff0a9590b3129fad4a0f6f3df1f39593d79b01a9f74

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: [PR PATCH] [Merged]: pyside-tools: remove package
  2019-07-30 21:10 [PR PATCH] pyside-tools: remove package voidlinux-github
@ 2019-07-30 21:29 ` " voidlinux-github
  0 siblings, 0 replies; 2+ messages in thread
From: voidlinux-github @ 2019-07-30 21:29 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 405 bytes --]

There's a merged pull request on the void-packages repository

pyside-tools: remove package
https://github.com/void-linux/void-packages/pull/13423
Description: Resolves #12844 
pyside-tools was broken when python-pyside was removed here: https://github.com/void-linux/void-packages/pull/11064

It looks like we do not intend to support these bindings, so removing this package is the correct solution.

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, back to index

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-07-30 21:10 [PR PATCH] pyside-tools: remove package voidlinux-github
2019-07-30 21:29 ` [PR PATCH] [Merged]: " voidlinux-github

Github messages for voidlinux

Archives are clonable: git clone --mirror http://inbox.vuxu.org/voidlinux-github

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.github.voidlinux


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git