Github messages for voidlinux
 help / color / mirror / Atom feed
* [ISSUE] python3-pyinfra: dependencies are broken
@ 2021-01-13 12:32 hazayan
  2021-01-13 17:14 ` UsernameRandomlyGenerated
                   ` (2 more replies)
  0 siblings, 3 replies; 4+ messages in thread
From: hazayan @ 2021-01-13 12:32 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 2765 bytes --]

New issue by hazayan on void-packages repository

https://github.com/void-linux/void-packages/issues/27885

Description:
<!-- Don't request update of package. We have a script for that. https://alpha.de.repo.voidlinux.org/void-updates/void-updates.txt . However, a quality pull request may help. -->
### System

* xuname:  
  *Void 5.9.16_1 x86_64 GenuineIntel uptodate rFFFF*
* package:  
  *affected package(s) including the version*: python3-pyinfra-1.3.1_1

### Expected behavior

Running pyinfra would run without dependency errors

### Actual behavior

Running the command below result in  the subsequent trace:

```
.... truncated for brevity ....

File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 3222, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 3251, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 567, in _build_master
    ws.require(__requires__)
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 884, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 770, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'distro==1.5.0' distribution was not found and is required by pyinfra
```

Upon fixing this by manually installing `python3-distro`, running the cli results in the subsequent trace:

```
.... truncated for brevity ....

File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 3222, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 3251, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 569, in _build_master
    return cls._build_from_requirements(__requires__)
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 582, in _build_from_requirements
    dists = ws.resolve(reqs, Environment())
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 770, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'gevent>=1.5' distribution was not found and is required by pyinfra
```

`python3-gevent` version currently is `1.4.0`. Working around that by locally updating the package template to the latest upstream version, then building and installing it, fixes the issue.

### Steps to reproduce the behavior

```
$ pyinfra @local exec -- echo "hello world"
```

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: python3-pyinfra: dependencies are broken
  2021-01-13 12:32 [ISSUE] python3-pyinfra: dependencies are broken hazayan
@ 2021-01-13 17:14 ` UsernameRandomlyGenerated
  2021-01-19 22:15 ` leahneukirchen
  2021-01-19 22:15 ` [ISSUE] [CLOSED] " leahneukirchen
  2 siblings, 0 replies; 4+ messages in thread
From: UsernameRandomlyGenerated @ 2021-01-13 17:14 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 238 bytes --]

New comment by UsernameRandomlyGenerated on void-packages repository

https://github.com/void-linux/void-packages/issues/27885#issuecomment-759593463

Comment:
https://github.com/void-linux/void-packages/pull/27040 would fix that I guess

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: python3-pyinfra: dependencies are broken
  2021-01-13 12:32 [ISSUE] python3-pyinfra: dependencies are broken hazayan
  2021-01-13 17:14 ` UsernameRandomlyGenerated
@ 2021-01-19 22:15 ` leahneukirchen
  2021-01-19 22:15 ` [ISSUE] [CLOSED] " leahneukirchen
  2 siblings, 0 replies; 4+ messages in thread
From: leahneukirchen @ 2021-01-19 22:15 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 170 bytes --]

New comment by leahneukirchen on void-packages repository

https://github.com/void-linux/void-packages/issues/27885#issuecomment-763176291

Comment:
Fixed in 751648b779.

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [ISSUE] [CLOSED] python3-pyinfra: dependencies are broken
  2021-01-13 12:32 [ISSUE] python3-pyinfra: dependencies are broken hazayan
  2021-01-13 17:14 ` UsernameRandomlyGenerated
  2021-01-19 22:15 ` leahneukirchen
@ 2021-01-19 22:15 ` leahneukirchen
  2 siblings, 0 replies; 4+ messages in thread
From: leahneukirchen @ 2021-01-19 22:15 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 2795 bytes --]

Closed issue by hazayan on void-packages repository

https://github.com/void-linux/void-packages/issues/27885

Description:
<!-- Don't request update of package. We have a script for that. https://alpha.de.repo.voidlinux.org/void-updates/void-updates.txt . However, a quality pull request may help. -->
### System

* xuname:  
  **Void 5.9.16_1 x86_64 GenuineIntel uptodate rFFFF**
* package:  
  *affected package(s) including the version*: **python3-pyinfra-1.3.1_1**

### Expected behavior

Invoking pyinfra on the command line would run without dependency errors

### Actual behavior

Running the command below result in  the subsequent trace:

```
.... truncated for brevity ....

File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 3222, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 3251, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 567, in _build_master
    ws.require(__requires__)
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 884, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 770, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'distro==1.5.0' distribution was not found and is required by pyinfra
```

Upon fixing this by manually installing `python3-distro`, running the cli results in the subsequent trace:

```
.... truncated for brevity ....

File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 3222, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 3251, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 569, in _build_master
    return cls._build_from_requirements(__requires__)
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 582, in _build_from_requirements
    dists = ws.resolve(reqs, Environment())
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 770, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'gevent>=1.5' distribution was not found and is required by pyinfra
```

`python3-gevent` version currently is `1.4.0`. Working around that by locally updating the package template to the latest upstream version, then building and installing it, fixes the issue.

### Steps to reproduce the behavior

```
$ pyinfra @local exec -- echo "hello world"
```

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2021-01-19 22:15 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-01-13 12:32 [ISSUE] python3-pyinfra: dependencies are broken hazayan
2021-01-13 17:14 ` UsernameRandomlyGenerated
2021-01-19 22:15 ` leahneukirchen
2021-01-19 22:15 ` [ISSUE] [CLOSED] " leahneukirchen

Github messages for voidlinux

This inbox may be cloned and mirrored by anyone:

	git clone --mirror http://inbox.vuxu.org/voidlinux-github

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V1 voidlinux-github voidlinux-github/ http://inbox.vuxu.org/voidlinux-github \
		voidlinux-github@inbox.vuxu.org
	public-inbox-index voidlinux-github

Example config snippet for mirrors.
Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.github.voidlinux


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git