Github messages for voidlinux
 help / color / mirror / Atom feed
* [PR PATCH] New package: lswt
@ 2022-01-09 20:41 user18130814200115-2
  2022-01-10 18:58 ` [PR PATCH] [Updated] " user18130814200115-2
                   ` (6 more replies)
  0 siblings, 7 replies; 8+ messages in thread
From: user18130814200115-2 @ 2022-01-09 20:41 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1073 bytes --]

There is a new pull request by user18130814200115-2 against master on the void-packages repository

https://github.com/user18130814200115-2/void-packages lswt
https://github.com/void-linux/void-packages/pull/34969

New package: lswt
<!-- Uncomment relevant sections and delete options which are not applicable -->

#### Testing the changes
- I tested the changes in this PR: **YES**


#### New package
- This new package conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements): **YES**


<!-- Note: If the build is likely to take more than 2 hours, please [skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration)
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->
 
#### Local build testing
- I built this PR locally for my native architecture, (aarch64-musl)


A patch file from https://github.com/void-linux/void-packages/pull/34969.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-lswt-34969.patch --]
[-- Type: text/x-diff, Size: 3167 bytes --]

From 28323cd3ce6d71644b070d0aaa20f280d3ef8394 Mon Sep 17 00:00:00 2001
From: user18130814200115-2
 <66143190+user18130814200115-2@users.noreply.github.com>
Date: Sun, 9 Jan 2022 20:27:13 +0000
Subject: [PATCH 1/2] Added lswt template

New template for lswt, a program that allows one to list wayland toplevels using the foreign-toplevel-management-unstable-v1 protocol
---
 srcpkgs/lswt/template | 13 +++++++++++++
 1 file changed, 13 insertions(+)
 create mode 100644 srcpkgs/lswt/template

diff --git a/srcpkgs/lswt/template b/srcpkgs/lswt/template
new file mode 100644
index 000000000000..eaf0f46b0704
--- /dev/null
+++ b/srcpkgs/lswt/template
@@ -0,0 +1,13 @@
+# Template file for 'lswt'
+pkgname=lswt
+version=v1.0.2
+revision=1
+build_style=gnu-makefile
+makedepends="wayland-devel"
+short_desc="List wayland toplevels using foreign-toplevel-management-unstable-v1"
+maintainer="Thijs Wester <void@wester.digital>"
+license="GPL-3.0-only"
+homepage="https://git.sr.ht/~leon_plickat/lswt"
+changelog="https://git.sr.ht/~leon_plickat/lswt/refs/${version}"
+distfiles="https://git.sr.ht/~leon_plickat/lswt/archive/${version}.tar.gz"
+checksum="28810c124c0d017ffe41e4b91461a07692aa12a3cd49261c3297dfb0dcf2f4cf"

From 74c952132602fe5a000c99dcd21d4582777cb313 Mon Sep 17 00:00:00 2001
From: user18130814200115-2
 <66143190+user18130814200115-2@users.noreply.github.com>
Date: Sun, 9 Jan 2022 20:30:29 +0000
Subject: [PATCH 2/2] lswt: PATCH disable execinfo.h

Only include execinfo.h when GLIBC is used.
This patch is from the upstream repository but is not present in any release yet
---
 srcpkgs/lswt/patches/execinfo.patch | 43 +++++++++++++++++++++++++++++
 1 file changed, 43 insertions(+)
 create mode 100644 srcpkgs/lswt/patches/execinfo.patch

diff --git a/srcpkgs/lswt/patches/execinfo.patch b/srcpkgs/lswt/patches/execinfo.patch
new file mode 100644
index 000000000000..292d6900256d
--- /dev/null
+++ b/srcpkgs/lswt/patches/execinfo.patch
@@ -0,0 +1,43 @@
+From 389b2578b27b1f3dc65952bf0d3f98e12410a8b8 Mon Sep 17 00:00:00 2001
+From: Leon Henrik Plickat <leonhenrik.plickat@stud.uni-goettingen.de>
+Date: Fri, 26 Nov 2021 13:45:06 +0100
+Subject: [PATCH] Only include execinfo.h when GLIBC is used
+
+---
+ lswt.c | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/lswt.c b/lswt.c
+index b61463d..f5fe78a 100644
+--- a/lswt.c
++++ b/lswt.c
+@@ -27,8 +27,11 @@
+ #include <wayland-client.h>
+ 
+ #ifdef __linux__
++#include <features.h>
++#ifdef __GLIBC__
+ #include<execinfo.h>
+ #endif
++#endif
+ 
+ #include "xdg-output-unstable-v1.h"
+ #include "wlr-foreign-toplevel-management-unstable-v1.h"
+@@ -642,6 +645,7 @@ static void handle_error (int signum)
+ 	fputs(msg, stderr);
+ 
+ #ifdef __linux__
++#ifdef __GLIBC__
+ 	fputs("Attempting to get backtrace:\n", stderr);
+ 
+ 	/* In some rare cases, getting a backtrace can also cause a segfault.
+@@ -652,6 +656,7 @@ static void handle_error (int signum)
+ 	const int calls = backtrace(buffer, sizeof(buffer) / sizeof(void *));
+ 	backtrace_symbols_fd(buffer, calls, fileno(stderr));
+ 	fputs("\n", stderr);
++#endif
+ #endif
+ 
+ 	/* Let the default handlers deal with the rest. */
+-- 
+2.32.0

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: [PR PATCH] [Updated] New package: lswt
  2022-01-09 20:41 [PR PATCH] New package: lswt user18130814200115-2
@ 2022-01-10 18:58 ` user18130814200115-2
  2022-01-10 19:22 ` user18130814200115-2
                   ` (5 subsequent siblings)
  6 siblings, 0 replies; 8+ messages in thread
From: user18130814200115-2 @ 2022-01-10 18:58 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1332 bytes --]

There is an updated pull request by user18130814200115-2 against master on the void-packages repository

https://github.com/user18130814200115-2/void-packages lswt
https://github.com/void-linux/void-packages/pull/34969

New package: lswt
Lswt allows one to list wayland toplevels using the foreign-toplevel-management-unstable-v1 protocol
There is one patch to only include execinfo.h when GLIBC is used.
This patch is from the upstream repository but is not present in any release yet.

<!-- Uncomment relevant sections and delete options which are not applicable -->

#### Testing the changes
- I tested the changes in this PR: **YES**


#### New package
- This new package conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements): **YES**


<!-- Note: If the build is likely to take more than 2 hours, please [skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration)
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->
 
#### Local build testing
- I built this PR locally for my native architecture, (aarch64-musl)


A patch file from https://github.com/void-linux/void-packages/pull/34969.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-lswt-34969.patch --]
[-- Type: text/x-diff, Size: 4008 bytes --]

From 28323cd3ce6d71644b070d0aaa20f280d3ef8394 Mon Sep 17 00:00:00 2001
From: user18130814200115-2
 <66143190+user18130814200115-2@users.noreply.github.com>
Date: Sun, 9 Jan 2022 20:27:13 +0000
Subject: [PATCH 1/3] Added lswt template

New template for lswt, a program that allows one to list wayland toplevels using the foreign-toplevel-management-unstable-v1 protocol
---
 srcpkgs/lswt/template | 13 +++++++++++++
 1 file changed, 13 insertions(+)
 create mode 100644 srcpkgs/lswt/template

diff --git a/srcpkgs/lswt/template b/srcpkgs/lswt/template
new file mode 100644
index 000000000000..eaf0f46b0704
--- /dev/null
+++ b/srcpkgs/lswt/template
@@ -0,0 +1,13 @@
+# Template file for 'lswt'
+pkgname=lswt
+version=v1.0.2
+revision=1
+build_style=gnu-makefile
+makedepends="wayland-devel"
+short_desc="List wayland toplevels using foreign-toplevel-management-unstable-v1"
+maintainer="Thijs Wester <void@wester.digital>"
+license="GPL-3.0-only"
+homepage="https://git.sr.ht/~leon_plickat/lswt"
+changelog="https://git.sr.ht/~leon_plickat/lswt/refs/${version}"
+distfiles="https://git.sr.ht/~leon_plickat/lswt/archive/${version}.tar.gz"
+checksum="28810c124c0d017ffe41e4b91461a07692aa12a3cd49261c3297dfb0dcf2f4cf"

From 74c952132602fe5a000c99dcd21d4582777cb313 Mon Sep 17 00:00:00 2001
From: user18130814200115-2
 <66143190+user18130814200115-2@users.noreply.github.com>
Date: Sun, 9 Jan 2022 20:30:29 +0000
Subject: [PATCH 2/3] lswt: PATCH disable execinfo.h

Only include execinfo.h when GLIBC is used.
This patch is from the upstream repository but is not present in any release yet
---
 srcpkgs/lswt/patches/execinfo.patch | 43 +++++++++++++++++++++++++++++
 1 file changed, 43 insertions(+)
 create mode 100644 srcpkgs/lswt/patches/execinfo.patch

diff --git a/srcpkgs/lswt/patches/execinfo.patch b/srcpkgs/lswt/patches/execinfo.patch
new file mode 100644
index 000000000000..292d6900256d
--- /dev/null
+++ b/srcpkgs/lswt/patches/execinfo.patch
@@ -0,0 +1,43 @@
+From 389b2578b27b1f3dc65952bf0d3f98e12410a8b8 Mon Sep 17 00:00:00 2001
+From: Leon Henrik Plickat <leonhenrik.plickat@stud.uni-goettingen.de>
+Date: Fri, 26 Nov 2021 13:45:06 +0100
+Subject: [PATCH] Only include execinfo.h when GLIBC is used
+
+---
+ lswt.c | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/lswt.c b/lswt.c
+index b61463d..f5fe78a 100644
+--- a/lswt.c
++++ b/lswt.c
+@@ -27,8 +27,11 @@
+ #include <wayland-client.h>
+ 
+ #ifdef __linux__
++#include <features.h>
++#ifdef __GLIBC__
+ #include<execinfo.h>
+ #endif
++#endif
+ 
+ #include "xdg-output-unstable-v1.h"
+ #include "wlr-foreign-toplevel-management-unstable-v1.h"
+@@ -642,6 +645,7 @@ static void handle_error (int signum)
+ 	fputs(msg, stderr);
+ 
+ #ifdef __linux__
++#ifdef __GLIBC__
+ 	fputs("Attempting to get backtrace:\n", stderr);
+ 
+ 	/* In some rare cases, getting a backtrace can also cause a segfault.
+@@ -652,6 +656,7 @@ static void handle_error (int signum)
+ 	const int calls = backtrace(buffer, sizeof(buffer) / sizeof(void *));
+ 	backtrace_symbols_fd(buffer, calls, fileno(stderr));
+ 	fputs("\n", stderr);
++#endif
+ #endif
+ 
+ 	/* Let the default handlers deal with the rest. */
+-- 
+2.32.0

From d272c44b4fc70e1faa487def814cdf56dc4b46bc Mon Sep 17 00:00:00 2001
From: user18130814200115-2
 <66143190+user18130814200115-2@users.noreply.github.com>
Date: Mon, 10 Jan 2022 18:58:04 +0000
Subject: [PATCH 3/3] Fix lswt template

The package was cross-compiling,
I believe this should now be fixed
---
 srcpkgs/lswt/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/lswt/template b/srcpkgs/lswt/template
index eaf0f46b0704..261e0e9349ff 100644
--- a/srcpkgs/lswt/template
+++ b/srcpkgs/lswt/template
@@ -3,7 +3,7 @@ pkgname=lswt
 version=v1.0.2
 revision=1
 build_style=gnu-makefile
-makedepends="wayland-devel"
+hostmakedepends="wayland-devel"
 short_desc="List wayland toplevels using foreign-toplevel-management-unstable-v1"
 maintainer="Thijs Wester <void@wester.digital>"
 license="GPL-3.0-only"

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: [PR PATCH] [Updated] New package: lswt
  2022-01-09 20:41 [PR PATCH] New package: lswt user18130814200115-2
  2022-01-10 18:58 ` [PR PATCH] [Updated] " user18130814200115-2
@ 2022-01-10 19:22 ` user18130814200115-2
  2022-01-12 19:54 ` [PR REVIEW] " ifreund
                   ` (4 subsequent siblings)
  6 siblings, 0 replies; 8+ messages in thread
From: user18130814200115-2 @ 2022-01-10 19:22 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1332 bytes --]

There is an updated pull request by user18130814200115-2 against master on the void-packages repository

https://github.com/user18130814200115-2/void-packages lswt
https://github.com/void-linux/void-packages/pull/34969

New package: lswt
Lswt allows one to list wayland toplevels using the foreign-toplevel-management-unstable-v1 protocol
There is one patch to only include execinfo.h when GLIBC is used.
This patch is from the upstream repository but is not present in any release yet.

<!-- Uncomment relevant sections and delete options which are not applicable -->

#### Testing the changes
- I tested the changes in this PR: **YES**


#### New package
- This new package conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements): **YES**


<!-- Note: If the build is likely to take more than 2 hours, please [skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration)
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->
 
#### Local build testing
- I built this PR locally for my native architecture, (aarch64-musl)


A patch file from https://github.com/void-linux/void-packages/pull/34969.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-lswt-34969.patch --]
[-- Type: text/x-diff, Size: 4058 bytes --]

From 28323cd3ce6d71644b070d0aaa20f280d3ef8394 Mon Sep 17 00:00:00 2001
From: user18130814200115-2
 <66143190+user18130814200115-2@users.noreply.github.com>
Date: Sun, 9 Jan 2022 20:27:13 +0000
Subject: [PATCH 1/3] Added lswt template

New template for lswt, a program that allows one to list wayland toplevels using the foreign-toplevel-management-unstable-v1 protocol
---
 srcpkgs/lswt/template | 13 +++++++++++++
 1 file changed, 13 insertions(+)
 create mode 100644 srcpkgs/lswt/template

diff --git a/srcpkgs/lswt/template b/srcpkgs/lswt/template
new file mode 100644
index 000000000000..eaf0f46b0704
--- /dev/null
+++ b/srcpkgs/lswt/template
@@ -0,0 +1,13 @@
+# Template file for 'lswt'
+pkgname=lswt
+version=v1.0.2
+revision=1
+build_style=gnu-makefile
+makedepends="wayland-devel"
+short_desc="List wayland toplevels using foreign-toplevel-management-unstable-v1"
+maintainer="Thijs Wester <void@wester.digital>"
+license="GPL-3.0-only"
+homepage="https://git.sr.ht/~leon_plickat/lswt"
+changelog="https://git.sr.ht/~leon_plickat/lswt/refs/${version}"
+distfiles="https://git.sr.ht/~leon_plickat/lswt/archive/${version}.tar.gz"
+checksum="28810c124c0d017ffe41e4b91461a07692aa12a3cd49261c3297dfb0dcf2f4cf"

From 74c952132602fe5a000c99dcd21d4582777cb313 Mon Sep 17 00:00:00 2001
From: user18130814200115-2
 <66143190+user18130814200115-2@users.noreply.github.com>
Date: Sun, 9 Jan 2022 20:30:29 +0000
Subject: [PATCH 2/3] lswt: PATCH disable execinfo.h

Only include execinfo.h when GLIBC is used.
This patch is from the upstream repository but is not present in any release yet
---
 srcpkgs/lswt/patches/execinfo.patch | 43 +++++++++++++++++++++++++++++
 1 file changed, 43 insertions(+)
 create mode 100644 srcpkgs/lswt/patches/execinfo.patch

diff --git a/srcpkgs/lswt/patches/execinfo.patch b/srcpkgs/lswt/patches/execinfo.patch
new file mode 100644
index 000000000000..292d6900256d
--- /dev/null
+++ b/srcpkgs/lswt/patches/execinfo.patch
@@ -0,0 +1,43 @@
+From 389b2578b27b1f3dc65952bf0d3f98e12410a8b8 Mon Sep 17 00:00:00 2001
+From: Leon Henrik Plickat <leonhenrik.plickat@stud.uni-goettingen.de>
+Date: Fri, 26 Nov 2021 13:45:06 +0100
+Subject: [PATCH] Only include execinfo.h when GLIBC is used
+
+---
+ lswt.c | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/lswt.c b/lswt.c
+index b61463d..f5fe78a 100644
+--- a/lswt.c
++++ b/lswt.c
+@@ -27,8 +27,11 @@
+ #include <wayland-client.h>
+ 
+ #ifdef __linux__
++#include <features.h>
++#ifdef __GLIBC__
+ #include<execinfo.h>
+ #endif
++#endif
+ 
+ #include "xdg-output-unstable-v1.h"
+ #include "wlr-foreign-toplevel-management-unstable-v1.h"
+@@ -642,6 +645,7 @@ static void handle_error (int signum)
+ 	fputs(msg, stderr);
+ 
+ #ifdef __linux__
++#ifdef __GLIBC__
+ 	fputs("Attempting to get backtrace:\n", stderr);
+ 
+ 	/* In some rare cases, getting a backtrace can also cause a segfault.
+@@ -652,6 +656,7 @@ static void handle_error (int signum)
+ 	const int calls = backtrace(buffer, sizeof(buffer) / sizeof(void *));
+ 	backtrace_symbols_fd(buffer, calls, fileno(stderr));
+ 	fputs("\n", stderr);
++#endif
+ #endif
+ 
+ 	/* Let the default handlers deal with the rest. */
+-- 
+2.32.0

From 493f5cdd78a92225c75818dea873a4c38d2b2ac0 Mon Sep 17 00:00:00 2001
From: user18130814200115-2
 <66143190+user18130814200115-2@users.noreply.github.com>
Date: Mon, 10 Jan 2022 18:58:04 +0000
Subject: [PATCH 3/3] New Package: lswt

 Author:    user18130814200115-2 <wester.t@github.com>

The package was not cross compiling,
this should now be fixed
---
 srcpkgs/lswt/template | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/srcpkgs/lswt/template b/srcpkgs/lswt/template
index eaf0f46b0704..261e0e9349ff 100644
--- a/srcpkgs/lswt/template
+++ b/srcpkgs/lswt/template
@@ -3,7 +3,7 @@ pkgname=lswt
 version=v1.0.2
 revision=1
 build_style=gnu-makefile
-makedepends="wayland-devel"
+hostmakedepends="wayland-devel"
 short_desc="List wayland toplevels using foreign-toplevel-management-unstable-v1"
 maintainer="Thijs Wester <void@wester.digital>"
 license="GPL-3.0-only"

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: [PR REVIEW] New package: lswt
  2022-01-09 20:41 [PR PATCH] New package: lswt user18130814200115-2
  2022-01-10 18:58 ` [PR PATCH] [Updated] " user18130814200115-2
  2022-01-10 19:22 ` user18130814200115-2
@ 2022-01-12 19:54 ` ifreund
  2022-01-12 21:48 ` [PR PATCH] [Updated] " user18130814200115-2
                   ` (3 subsequent siblings)
  6 siblings, 0 replies; 8+ messages in thread
From: ifreund @ 2022-01-12 19:54 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 189 bytes --]

New review comment by ifreund on void-packages repository

https://github.com/void-linux/void-packages/pull/34969#discussion_r783311757

Comment:
you'll need this in `makedepends` as well.

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: [PR PATCH] [Updated] New package: lswt
  2022-01-09 20:41 [PR PATCH] New package: lswt user18130814200115-2
                   ` (2 preceding siblings ...)
  2022-01-12 19:54 ` [PR REVIEW] " ifreund
@ 2022-01-12 21:48 ` user18130814200115-2
  2022-01-12 21:48 ` [PR REVIEW] " user18130814200115-2
                   ` (2 subsequent siblings)
  6 siblings, 0 replies; 8+ messages in thread
From: user18130814200115-2 @ 2022-01-12 21:48 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1332 bytes --]

There is an updated pull request by user18130814200115-2 against master on the void-packages repository

https://github.com/user18130814200115-2/void-packages lswt
https://github.com/void-linux/void-packages/pull/34969

New package: lswt
Lswt allows one to list wayland toplevels using the foreign-toplevel-management-unstable-v1 protocol
There is one patch to only include execinfo.h when GLIBC is used.
This patch is from the upstream repository but is not present in any release yet.

<!-- Uncomment relevant sections and delete options which are not applicable -->

#### Testing the changes
- I tested the changes in this PR: **YES**


#### New package
- This new package conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements): **YES**


<!-- Note: If the build is likely to take more than 2 hours, please [skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration)
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->
 
#### Local build testing
- I built this PR locally for my native architecture, (aarch64-musl)


A patch file from https://github.com/void-linux/void-packages/pull/34969.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-lswt-34969.patch --]
[-- Type: text/x-diff, Size: 3974 bytes --]

From 28323cd3ce6d71644b070d0aaa20f280d3ef8394 Mon Sep 17 00:00:00 2001
From: user18130814200115-2
 <66143190+user18130814200115-2@users.noreply.github.com>
Date: Sun, 9 Jan 2022 20:27:13 +0000
Subject: [PATCH 1/3] Added lswt template

New template for lswt, a program that allows one to list wayland toplevels using the foreign-toplevel-management-unstable-v1 protocol
---
 srcpkgs/lswt/template | 13 +++++++++++++
 1 file changed, 13 insertions(+)
 create mode 100644 srcpkgs/lswt/template

diff --git a/srcpkgs/lswt/template b/srcpkgs/lswt/template
new file mode 100644
index 000000000000..eaf0f46b0704
--- /dev/null
+++ b/srcpkgs/lswt/template
@@ -0,0 +1,13 @@
+# Template file for 'lswt'
+pkgname=lswt
+version=v1.0.2
+revision=1
+build_style=gnu-makefile
+makedepends="wayland-devel"
+short_desc="List wayland toplevels using foreign-toplevel-management-unstable-v1"
+maintainer="Thijs Wester <void@wester.digital>"
+license="GPL-3.0-only"
+homepage="https://git.sr.ht/~leon_plickat/lswt"
+changelog="https://git.sr.ht/~leon_plickat/lswt/refs/${version}"
+distfiles="https://git.sr.ht/~leon_plickat/lswt/archive/${version}.tar.gz"
+checksum="28810c124c0d017ffe41e4b91461a07692aa12a3cd49261c3297dfb0dcf2f4cf"

From 74c952132602fe5a000c99dcd21d4582777cb313 Mon Sep 17 00:00:00 2001
From: user18130814200115-2
 <66143190+user18130814200115-2@users.noreply.github.com>
Date: Sun, 9 Jan 2022 20:30:29 +0000
Subject: [PATCH 2/3] lswt: PATCH disable execinfo.h

Only include execinfo.h when GLIBC is used.
This patch is from the upstream repository but is not present in any release yet
---
 srcpkgs/lswt/patches/execinfo.patch | 43 +++++++++++++++++++++++++++++
 1 file changed, 43 insertions(+)
 create mode 100644 srcpkgs/lswt/patches/execinfo.patch

diff --git a/srcpkgs/lswt/patches/execinfo.patch b/srcpkgs/lswt/patches/execinfo.patch
new file mode 100644
index 000000000000..292d6900256d
--- /dev/null
+++ b/srcpkgs/lswt/patches/execinfo.patch
@@ -0,0 +1,43 @@
+From 389b2578b27b1f3dc65952bf0d3f98e12410a8b8 Mon Sep 17 00:00:00 2001
+From: Leon Henrik Plickat <leonhenrik.plickat@stud.uni-goettingen.de>
+Date: Fri, 26 Nov 2021 13:45:06 +0100
+Subject: [PATCH] Only include execinfo.h when GLIBC is used
+
+---
+ lswt.c | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/lswt.c b/lswt.c
+index b61463d..f5fe78a 100644
+--- a/lswt.c
++++ b/lswt.c
+@@ -27,8 +27,11 @@
+ #include <wayland-client.h>
+ 
+ #ifdef __linux__
++#include <features.h>
++#ifdef __GLIBC__
+ #include<execinfo.h>
+ #endif
++#endif
+ 
+ #include "xdg-output-unstable-v1.h"
+ #include "wlr-foreign-toplevel-management-unstable-v1.h"
+@@ -642,6 +645,7 @@ static void handle_error (int signum)
+ 	fputs(msg, stderr);
+ 
+ #ifdef __linux__
++#ifdef __GLIBC__
+ 	fputs("Attempting to get backtrace:\n", stderr);
+ 
+ 	/* In some rare cases, getting a backtrace can also cause a segfault.
+@@ -652,6 +656,7 @@ static void handle_error (int signum)
+ 	const int calls = backtrace(buffer, sizeof(buffer) / sizeof(void *));
+ 	backtrace_symbols_fd(buffer, calls, fileno(stderr));
+ 	fputs("\n", stderr);
++#endif
+ #endif
+ 
+ 	/* Let the default handlers deal with the rest. */
+-- 
+2.32.0

From 9344de8588dd71960d540679588999ac5d7f978b Mon Sep 17 00:00:00 2001
From: user18130814200115-2
 <66143190+user18130814200115-2@users.noreply.github.com>
Date: Mon, 10 Jan 2022 18:58:04 +0000
Subject: [PATCH 3/3] New Package: lswt

 Author:    user18130814200115-2 <wester.t@github.com>

fixed makedepends
---
 srcpkgs/lswt/template | 1 +
 1 file changed, 1 insertion(+)

diff --git a/srcpkgs/lswt/template b/srcpkgs/lswt/template
index eaf0f46b0704..c720ae982eb4 100644
--- a/srcpkgs/lswt/template
+++ b/srcpkgs/lswt/template
@@ -3,6 +3,7 @@ pkgname=lswt
 version=v1.0.2
 revision=1
 build_style=gnu-makefile
+hostmakedepends="wayland-devel"
 makedepends="wayland-devel"
 short_desc="List wayland toplevels using foreign-toplevel-management-unstable-v1"
 maintainer="Thijs Wester <void@wester.digital>"

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: [PR REVIEW] New package: lswt
  2022-01-09 20:41 [PR PATCH] New package: lswt user18130814200115-2
                   ` (3 preceding siblings ...)
  2022-01-12 21:48 ` [PR PATCH] [Updated] " user18130814200115-2
@ 2022-01-12 21:48 ` user18130814200115-2
  2022-01-12 21:49 ` user18130814200115-2
  2022-01-13  9:30 ` [PR PATCH] [Updated] " user18130814200115-2
  6 siblings, 0 replies; 8+ messages in thread
From: user18130814200115-2 @ 2022-01-12 21:48 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 194 bytes --]

New review comment by user18130814200115-2 on void-packages repository

https://github.com/void-linux/void-packages/pull/34969#discussion_r783468558

Comment:
Thanks a lot! Added on latest push

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: New package: lswt
  2022-01-09 20:41 [PR PATCH] New package: lswt user18130814200115-2
                   ` (4 preceding siblings ...)
  2022-01-12 21:48 ` [PR REVIEW] " user18130814200115-2
@ 2022-01-12 21:49 ` user18130814200115-2
  2022-01-13  9:30 ` [PR PATCH] [Updated] " user18130814200115-2
  6 siblings, 0 replies; 8+ messages in thread
From: user18130814200115-2 @ 2022-01-12 21:49 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 242 bytes --]

New comment by user18130814200115-2 on void-packages repository

https://github.com/void-linux/void-packages/pull/34969#issuecomment-1011483129

Comment:
Great, once Wayland 1.20.0 gets merged, I will update the template and remove the patch

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: [PR PATCH] [Updated] New package: lswt
  2022-01-09 20:41 [PR PATCH] New package: lswt user18130814200115-2
                   ` (5 preceding siblings ...)
  2022-01-12 21:49 ` user18130814200115-2
@ 2022-01-13  9:30 ` user18130814200115-2
  6 siblings, 0 replies; 8+ messages in thread
From: user18130814200115-2 @ 2022-01-13  9:30 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1332 bytes --]

There is an updated pull request by user18130814200115-2 against master on the void-packages repository

https://github.com/user18130814200115-2/void-packages lswt
https://github.com/void-linux/void-packages/pull/34969

New package: lswt
Lswt allows one to list wayland toplevels using the foreign-toplevel-management-unstable-v1 protocol
There is one patch to only include execinfo.h when GLIBC is used.
This patch is from the upstream repository but is not present in any release yet.

<!-- Uncomment relevant sections and delete options which are not applicable -->

#### Testing the changes
- I tested the changes in this PR: **YES**


#### New package
- This new package conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements): **YES**


<!-- Note: If the build is likely to take more than 2 hours, please [skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration)
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->
 
#### Local build testing
- I built this PR locally for my native architecture, (aarch64-musl)


A patch file from https://github.com/void-linux/void-packages/pull/34969.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-lswt-34969.patch --]
[-- Type: text/x-diff, Size: 2668 bytes --]

From 48dacc6c1e2ada032192a8242343a018e9ce7ea3 Mon Sep 17 00:00:00 2001
From: user18130814200115-2
 <66143190+user18130814200115-2@users.noreply.github.com>
Date: Sun, 9 Jan 2022 20:27:13 +0000
Subject: [PATCH] New package: lswt-v1.0.2

---
 srcpkgs/lswt/patches/execinfo.patch | 43 +++++++++++++++++++++++++++++
 srcpkgs/lswt/template               | 14 ++++++++++
 2 files changed, 57 insertions(+)
 create mode 100644 srcpkgs/lswt/patches/execinfo.patch
 create mode 100644 srcpkgs/lswt/template

diff --git a/srcpkgs/lswt/patches/execinfo.patch b/srcpkgs/lswt/patches/execinfo.patch
new file mode 100644
index 000000000000..292d6900256d
--- /dev/null
+++ b/srcpkgs/lswt/patches/execinfo.patch
@@ -0,0 +1,43 @@
+From 389b2578b27b1f3dc65952bf0d3f98e12410a8b8 Mon Sep 17 00:00:00 2001
+From: Leon Henrik Plickat <leonhenrik.plickat@stud.uni-goettingen.de>
+Date: Fri, 26 Nov 2021 13:45:06 +0100
+Subject: [PATCH] Only include execinfo.h when GLIBC is used
+
+---
+ lswt.c | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/lswt.c b/lswt.c
+index b61463d..f5fe78a 100644
+--- a/lswt.c
++++ b/lswt.c
+@@ -27,8 +27,11 @@
+ #include <wayland-client.h>
+ 
+ #ifdef __linux__
++#include <features.h>
++#ifdef __GLIBC__
+ #include<execinfo.h>
+ #endif
++#endif
+ 
+ #include "xdg-output-unstable-v1.h"
+ #include "wlr-foreign-toplevel-management-unstable-v1.h"
+@@ -642,6 +645,7 @@ static void handle_error (int signum)
+ 	fputs(msg, stderr);
+ 
+ #ifdef __linux__
++#ifdef __GLIBC__
+ 	fputs("Attempting to get backtrace:\n", stderr);
+ 
+ 	/* In some rare cases, getting a backtrace can also cause a segfault.
+@@ -652,6 +656,7 @@ static void handle_error (int signum)
+ 	const int calls = backtrace(buffer, sizeof(buffer) / sizeof(void *));
+ 	backtrace_symbols_fd(buffer, calls, fileno(stderr));
+ 	fputs("\n", stderr);
++#endif
+ #endif
+ 
+ 	/* Let the default handlers deal with the rest. */
+-- 
+2.32.0
diff --git a/srcpkgs/lswt/template b/srcpkgs/lswt/template
new file mode 100644
index 000000000000..c720ae982eb4
--- /dev/null
+++ b/srcpkgs/lswt/template
@@ -0,0 +1,14 @@
+# Template file for 'lswt'
+pkgname=lswt
+version=v1.0.2
+revision=1
+build_style=gnu-makefile
+hostmakedepends="wayland-devel"
+makedepends="wayland-devel"
+short_desc="List wayland toplevels using foreign-toplevel-management-unstable-v1"
+maintainer="Thijs Wester <void@wester.digital>"
+license="GPL-3.0-only"
+homepage="https://git.sr.ht/~leon_plickat/lswt"
+changelog="https://git.sr.ht/~leon_plickat/lswt/refs/${version}"
+distfiles="https://git.sr.ht/~leon_plickat/lswt/archive/${version}.tar.gz"
+checksum="28810c124c0d017ffe41e4b91461a07692aa12a3cd49261c3297dfb0dcf2f4cf"

^ permalink raw reply	[flat|nested] 8+ messages in thread

end of thread, other threads:[~2022-01-13  9:30 UTC | newest]

Thread overview: 8+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-01-09 20:41 [PR PATCH] New package: lswt user18130814200115-2
2022-01-10 18:58 ` [PR PATCH] [Updated] " user18130814200115-2
2022-01-10 19:22 ` user18130814200115-2
2022-01-12 19:54 ` [PR REVIEW] " ifreund
2022-01-12 21:48 ` [PR PATCH] [Updated] " user18130814200115-2
2022-01-12 21:48 ` [PR REVIEW] " user18130814200115-2
2022-01-12 21:49 ` user18130814200115-2
2022-01-13  9:30 ` [PR PATCH] [Updated] " user18130814200115-2

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).