Github messages for voidlinux
 help / color / mirror / Atom feed
* [PR PATCH] kitty: update to 0.24.2
@ 2022-02-03  8:25 zen0bit
  2022-02-10  3:08 ` cinerea0
                   ` (2 more replies)
  0 siblings, 3 replies; 8+ messages in thread
From: zen0bit @ 2022-02-03  8:25 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 562 bytes --]

There is a new pull request by zen0bit against master on the void-packages repository

https://github.com/oSoWoSo/void-packages kitty
https://github.com/void-linux/void-packages/pull/35374

kitty: update to 0.24.2
<!-- Uncomment relevant sections and delete options which are not applicable -->

#### Testing the changes
- I tested the changes in this PR: briefly

<!-- 
#### Local build testing
- I built this PR locally for my native architecture, X86_64 libc


A patch file from https://github.com/void-linux/void-packages/pull/35374.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-kitty-35374.patch --]
[-- Type: text/x-diff, Size: 1121 bytes --]

From 6344666a1d5d7c3e94d2bbb6ca01086082f206ad Mon Sep 17 00:00:00 2001
From: zenobit <6384793+zen0bit@users.noreply.github.com>
Date: Thu, 3 Feb 2022 08:36:12 +0100
Subject: [PATCH] kitty: update to 0.24.2

---
 srcpkgs/kitty/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/kitty/template b/srcpkgs/kitty/template
index e7eb190c3f90..e545d3e8c309 100644
--- a/srcpkgs/kitty/template
+++ b/srcpkgs/kitty/template
@@ -1,6 +1,6 @@
 # Template file for 'kitty'
 pkgname=kitty
-version=0.24.1
+version=0.24.2
 revision=1
 pycompile_dirs="usr/lib/kitty"
 hostmakedepends="pkg-config python3 wayland-devel wayland-protocols"
@@ -12,7 +12,7 @@ license="GPL-3.0-or-later"
 homepage="https://sw.kovidgoyal.net/kitty/"
 changelog="https://sw.kovidgoyal.net/kitty/changelog.html"
 distfiles="https://github.com/kovidgoyal/kitty/releases/download/v${version}/kitty-${version}.tar.xz"
-checksum=cbe9724730077c3c0ca52e431ff115c317b198dbf609c843be4aa9f34c2d5412
+checksum=66a99fcfeae481db65b94b0bc5fdb4bb28b099fe4fa94b9c0fb0284f34c7b9c7
 python_version=3
 LDFLAGS+=" -Wl,-z,stack-size=2097152"
 

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: kitty: update to 0.24.2
  2022-02-03  8:25 [PR PATCH] kitty: update to 0.24.2 zen0bit
@ 2022-02-10  3:08 ` cinerea0
  2022-02-20 12:01 ` [PR PATCH] [Closed]: " paper42
  2022-02-20 12:01 ` paper42
  2 siblings, 0 replies; 8+ messages in thread
From: cinerea0 @ 2022-02-10  3:08 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 372 bytes --]

New comment by cinerea0 on void-packages repository

https://github.com/void-linux/void-packages/pull/35374#issuecomment-1034446194

Comment:
@hechos Because you keep asking what the above comment means, you're being asked to make it so that the `makedepends` line ends at 80 characters or fewer by splitting it into two lines, with the second line starting with a space.

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: kitty: update to 0.24.2
  2022-02-03  8:25 [PR PATCH] kitty: update to 0.24.2 zen0bit
  2022-02-10  3:08 ` cinerea0
  2022-02-20 12:01 ` [PR PATCH] [Closed]: " paper42
@ 2022-02-20 12:01 ` paper42
  2 siblings, 0 replies; 8+ messages in thread
From: paper42 @ 2022-02-20 12:01 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 182 bytes --]

New comment by paper42 on void-packages repository

https://github.com/void-linux/void-packages/pull/35374#issuecomment-1046222167

Comment:
39362cf6a420a8f4220d5d81a382d94d38792979

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: [PR PATCH] [Closed]: kitty: update to 0.24.2
  2022-02-03  8:25 [PR PATCH] kitty: update to 0.24.2 zen0bit
  2022-02-10  3:08 ` cinerea0
@ 2022-02-20 12:01 ` paper42
  2022-02-20 12:01 ` paper42
  2 siblings, 0 replies; 8+ messages in thread
From: paper42 @ 2022-02-20 12:01 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 413 bytes --]

There's a closed pull request on the void-packages repository

kitty: update to 0.24.2
https://github.com/void-linux/void-packages/pull/35374

Description:
<!-- Uncomment relevant sections and delete options which are not applicable -->

#### Testing the changes
- I tested the changes in this PR: briefly

<!-- 
#### Local build testing
- I built this PR locally for my native architecture, X86_64 libc


^ permalink raw reply	[flat|nested] 8+ messages in thread

* [PR PATCH] kitty: update to 0.24.2
@ 2022-02-13 18:02 hechos
  0 siblings, 0 replies; 8+ messages in thread
From: hechos @ 2022-02-13 18:02 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1198 bytes --]

There is a new pull request by hechos against master on the void-packages repository

https://github.com/hechos/void-packages kitty
https://github.com/void-linux/void-packages/pull/35589

kitty: update to 0.24.2
<!-- Uncomment relevant sections and delete options which are not applicable -->

#### Testing the changes
- I tested the changes in this PR: YES
<!--
#### New package
- This new package conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements): **YES**|**NO**
-->

<!-- Note: If the build is likely to take more than 2 hours, please [skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration)
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->
<!-- 
#### Local build testing
- I built this PR locally for my native architecture, (ARCH-LIBC)
- I built this PR locally for these architectures (if supported. mark crossbuilds):
  - aarch64-musl
  - armv7l
  - armv6l-musl
-->


A patch file from https://github.com/void-linux/void-packages/pull/35589.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-kitty-35589.patch --]
[-- Type: text/x-diff, Size: 1599 bytes --]

From 0ed5e17a141b1cc48d9f7e9e84d4a6ae3a84c965 Mon Sep 17 00:00:00 2001
From: hechos <martin.damian.fernandez@gmail.com>
Date: Sun, 13 Feb 2022 14:32:01 -0300
Subject: [PATCH] kitty: update to 0.24.2

---
 srcpkgs/kitty/template | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/kitty/template b/srcpkgs/kitty/template
index e7eb190c3f90..6c812182e2b2 100644
--- a/srcpkgs/kitty/template
+++ b/srcpkgs/kitty/template
@@ -1,10 +1,11 @@
 # Template file for 'kitty'
 pkgname=kitty
-version=0.24.1
+version=0.24.2
 revision=1
 pycompile_dirs="usr/lib/kitty"
 hostmakedepends="pkg-config python3 wayland-devel wayland-protocols"
-makedepends="gettext-devel glfw-devel harfbuzz-devel libxkbcommon-devel python3-devel wayland-devel wayland-protocols librsync-devel libcanberra-devel"
+makedepends="gettext-devel glfw-devel harfbuzz-devel libxkbcommon-devel 
+python3-devel wayland-devel wayland-protocols librsync-devel libcanberra-devel"
 depends="kitty-terminfo-${version}_${revision}"
 short_desc="Modern, hackable, featureful, OpenGL based terminal emulator"
 maintainer="Benjamin Slade <slade@jnanam.net>"
@@ -12,7 +13,7 @@ license="GPL-3.0-or-later"
 homepage="https://sw.kovidgoyal.net/kitty/"
 changelog="https://sw.kovidgoyal.net/kitty/changelog.html"
 distfiles="https://github.com/kovidgoyal/kitty/releases/download/v${version}/kitty-${version}.tar.xz"
-checksum=cbe9724730077c3c0ca52e431ff115c317b198dbf609c843be4aa9f34c2d5412
+checksum=66a99fcfeae481db65b94b0bc5fdb4bb28b099fe4fa94b9c0fb0284f34c7b9c7
 python_version=3
 LDFLAGS+=" -Wl,-z,stack-size=2097152"
 

^ permalink raw reply	[flat|nested] 8+ messages in thread

* [PR PATCH] kitty: update to 0.24.2
@ 2022-02-13 16:00 hechos
  0 siblings, 0 replies; 8+ messages in thread
From: hechos @ 2022-02-13 16:00 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1200 bytes --]

There is a new pull request by hechos against master on the void-packages repository

https://github.com/hechos/void-packages kitty
https://github.com/void-linux/void-packages/pull/35585

kitty: update to 0.24.2
<!-- Uncomment relevant sections and delete options which are not applicable -->

#### Testing the changes
- I tested the changes in this PR: YES

<!--
#### New package
- This new package conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements): **YES**|**NO**
-->

<!-- Note: If the build is likely to take more than 2 hours, please [skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration)
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->
<!-- 
#### Local build testing
- I built this PR locally for my native architecture, (ARCH-LIBC)
- I built this PR locally for these architectures (if supported. mark crossbuilds):
  - aarch64-musl
  - armv7l
  - armv6l-musl
-->


A patch file from https://github.com/void-linux/void-packages/pull/35585.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-kitty-35585.patch --]
[-- Type: text/x-diff, Size: 1599 bytes --]

From 5be1fe4bb03332d04e484e06e1ea6b48a146b44a Mon Sep 17 00:00:00 2001
From: hechos <martin.damian.fernandez@gmail.com>
Date: Sun, 13 Feb 2022 12:59:06 -0300
Subject: [PATCH] kitty: update to 0.24.2

---
 srcpkgs/kitty/template | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/kitty/template b/srcpkgs/kitty/template
index e7eb190c3f90..5a5f4316f23c 100644
--- a/srcpkgs/kitty/template
+++ b/srcpkgs/kitty/template
@@ -1,10 +1,11 @@
 # Template file for 'kitty'
 pkgname=kitty
-version=0.24.1
+version=0.24.2
 revision=1
 pycompile_dirs="usr/lib/kitty"
 hostmakedepends="pkg-config python3 wayland-devel wayland-protocols"
-makedepends="gettext-devel glfw-devel harfbuzz-devel libxkbcommon-devel python3-devel wayland-devel wayland-protocols librsync-devel libcanberra-devel"
+makedepends="gettext-devel glfw-devel harfbuzz-devel libxkbcommon-devel python3
+-devel wayland-devel wayland-protocols librsync-devel libcanberra-devel"
 depends="kitty-terminfo-${version}_${revision}"
 short_desc="Modern, hackable, featureful, OpenGL based terminal emulator"
 maintainer="Benjamin Slade <slade@jnanam.net>"
@@ -12,7 +13,7 @@ license="GPL-3.0-or-later"
 homepage="https://sw.kovidgoyal.net/kitty/"
 changelog="https://sw.kovidgoyal.net/kitty/changelog.html"
 distfiles="https://github.com/kovidgoyal/kitty/releases/download/v${version}/kitty-${version}.tar.xz"
-checksum=cbe9724730077c3c0ca52e431ff115c317b198dbf609c843be4aa9f34c2d5412
+checksum=66a99fcfeae481db65b94b0bc5fdb4bb28b099fe4fa94b9c0fb0284f34c7b9c7
 python_version=3
 LDFLAGS+=" -Wl,-z,stack-size=2097152"
 

^ permalink raw reply	[flat|nested] 8+ messages in thread

* [PR PATCH] kitty: update to 0.24.2
@ 2022-02-13 15:11 hechos
  0 siblings, 0 replies; 8+ messages in thread
From: hechos @ 2022-02-13 15:11 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1200 bytes --]

There is a new pull request by hechos against master on the void-packages repository

https://github.com/hechos/void-packages kitty
https://github.com/void-linux/void-packages/pull/35584

kitty: update to 0.24.2
<!-- Uncomment relevant sections and delete options which are not applicable -->

#### Testing the changes
- I tested the changes in this PR: YES

<!--
#### New package
- This new package conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements): **YES**|**NO**
-->

<!-- Note: If the build is likely to take more than 2 hours, please [skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration)
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->
<!-- 
#### Local build testing
- I built this PR locally for my native architecture, (ARCH-LIBC)
- I built this PR locally for these architectures (if supported. mark crossbuilds):
  - aarch64-musl
  - armv7l
  - armv6l-musl
-->


A patch file from https://github.com/void-linux/void-packages/pull/35584.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-kitty-35584.patch --]
[-- Type: text/x-diff, Size: 1599 bytes --]

From fcfcd735b9c6a41cfb427e268f06635617933428 Mon Sep 17 00:00:00 2001
From: hechos <martin.damian.fernandez@gmail.com>
Date: Sun, 13 Feb 2022 12:09:32 -0300
Subject: [PATCH] kitty: update to 0.24.2

---
 srcpkgs/kitty/template | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/kitty/template b/srcpkgs/kitty/template
index e7eb190c3f90..090cc27962d4 100644
--- a/srcpkgs/kitty/template
+++ b/srcpkgs/kitty/template
@@ -1,10 +1,11 @@
 # Template file for 'kitty'
 pkgname=kitty
-version=0.24.1
+version=0.24.2
 revision=1
 pycompile_dirs="usr/lib/kitty"
 hostmakedepends="pkg-config python3 wayland-devel wayland-protocols"
-makedepends="gettext-devel glfw-devel harfbuzz-devel libxkbcommon-devel python3-devel wayland-devel wayland-protocols librsync-devel libcanberra-devel"
+makedepends="gettext-devel glfw-devel harfbuzz-devel libxkbcommon-devel python3-devel wayland-devel 
+wayland-protocols librsync-devel libcanberra-devel"
 depends="kitty-terminfo-${version}_${revision}"
 short_desc="Modern, hackable, featureful, OpenGL based terminal emulator"
 maintainer="Benjamin Slade <slade@jnanam.net>"
@@ -12,7 +13,7 @@ license="GPL-3.0-or-later"
 homepage="https://sw.kovidgoyal.net/kitty/"
 changelog="https://sw.kovidgoyal.net/kitty/changelog.html"
 distfiles="https://github.com/kovidgoyal/kitty/releases/download/v${version}/kitty-${version}.tar.xz"
-checksum=cbe9724730077c3c0ca52e431ff115c317b198dbf609c843be4aa9f34c2d5412
+checksum=66a99fcfeae481db65b94b0bc5fdb4bb28b099fe4fa94b9c0fb0284f34c7b9c7
 python_version=3
 LDFLAGS+=" -Wl,-z,stack-size=2097152"
 

^ permalink raw reply	[flat|nested] 8+ messages in thread

* [PR PATCH] kitty: update to 0.24.2
@ 2022-02-10 13:22 hechos
  0 siblings, 0 replies; 8+ messages in thread
From: hechos @ 2022-02-10 13:22 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1226 bytes --]

There is a new pull request by hechos against master on the void-packages repository

https://github.com/hechos/void-packages kitty
https://github.com/void-linux/void-packages/pull/35505

kitty: update to 0.24.2
<!-- Uncomment relevant sections and delete options which are not applicable -->

#### Testing the changes
- I tested the changes in this PR: **YES**|**briefly**|**NO**
Yes
<!--
#### New package
- This new package conforms to the [quality requirements](https://github.com/void-linux/void-packages/blob/master/Manual.md#quality-requirements): **YES**|**NO**
-->

<!-- Note: If the build is likely to take more than 2 hours, please [skip CI](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration)
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->
<!-- 
#### Local build testing
- I built this PR locally for my native architecture, (ARCH-LIBC)
- I built this PR locally for these architectures (if supported. mark crossbuilds):
  - aarch64-musl
  - armv7l
  - armv6l-musl
-->


A patch file from https://github.com/void-linux/void-packages/pull/35505.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-kitty-35505.patch --]
[-- Type: text/x-diff, Size: 1601 bytes --]

From fdbdd5c4da7d661446c9df41a6cdff9eef86c883 Mon Sep 17 00:00:00 2001
From: hechos <martin.damian.fernandez@gmail.com>
Date: Thu, 10 Feb 2022 10:21:45 -0300
Subject: [PATCH] kitty: update to 0.24.2

---
 srcpkgs/kitty/template | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/kitty/template b/srcpkgs/kitty/template
index e7eb190c3f90..1f5491bf3756 100644
--- a/srcpkgs/kitty/template
+++ b/srcpkgs/kitty/template
@@ -1,10 +1,11 @@
 # Template file for 'kitty'
 pkgname=kitty
-version=0.24.1
+version=0.24.2
 revision=1
 pycompile_dirs="usr/lib/kitty"
 hostmakedepends="pkg-config python3 wayland-devel wayland-protocols"
-makedepends="gettext-devel glfw-devel harfbuzz-devel libxkbcommon-devel python3-devel wayland-devel wayland-protocols librsync-devel libcanberra-devel"
+makedepends="gettext-devel glfw-devel harfbuzz-devel libxkbcommon-devel python3-devel  wayland-devel 
+ wayland-protocols librsync-devel libcanberra-devel"
 depends="kitty-terminfo-${version}_${revision}"
 short_desc="Modern, hackable, featureful, OpenGL based terminal emulator"
 maintainer="Benjamin Slade <slade@jnanam.net>"
@@ -12,7 +13,7 @@ license="GPL-3.0-or-later"
 homepage="https://sw.kovidgoyal.net/kitty/"
 changelog="https://sw.kovidgoyal.net/kitty/changelog.html"
 distfiles="https://github.com/kovidgoyal/kitty/releases/download/v${version}/kitty-${version}.tar.xz"
-checksum=cbe9724730077c3c0ca52e431ff115c317b198dbf609c843be4aa9f34c2d5412
+checksum=66a99fcfeae481db65b94b0bc5fdb4bb28b099fe4fa94b9c0fb0284f34c7b9c7
 python_version=3
 LDFLAGS+=" -Wl,-z,stack-size=2097152"
 

^ permalink raw reply	[flat|nested] 8+ messages in thread

end of thread, other threads:[~2022-02-20 12:01 UTC | newest]

Thread overview: 8+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-02-03  8:25 [PR PATCH] kitty: update to 0.24.2 zen0bit
2022-02-10  3:08 ` cinerea0
2022-02-20 12:01 ` [PR PATCH] [Closed]: " paper42
2022-02-20 12:01 ` paper42
2022-02-10 13:22 [PR PATCH] " hechos
2022-02-13 15:11 hechos
2022-02-13 16:00 hechos
2022-02-13 18:02 hechos

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).